Structure Principles of the MSRSYS DTD

MSR Engineering Documentation (MEDOC)

Structure Principles of the MSRSYS DTD
Scope: Systems and Hardware
[ MSRSYS-SP-EN]
Revision: 2.4
This document describes the principles for the structure of the MSR development documentation MEDOC for systems and hardware. The description can also be used as a guideline for preparing structured development documentation.


I. The role of MSR

Structure Principles of the MSRSYS DTD
I. The role of MSR

It is pointed out here that MSR does not conduct any standardization of the systems or their features that are described with MEDOC. MEDOC supports the use of (inter)national standards and in-house norms, as well as non-standardized norms, for the description of systems of data relevant to the documentation of development processes.


II. How to read this document

Structure Principles of the MSRSYS DTD
II. How to read this document

The general concepts of the MSR SGML application profile are not replicated in this document. Details can be seen in Structure principles of the MSR application profile
The following conventions apply
This document is written using MSRREP DTD. The following conventions apply to this document:
<msrsw> SGML elements are noted as technical term [type]=SGMLTAG.

[type] SGML attributes are noted as technical term [type]=SGML-attribute.

sgml-attribute Values of SGML attributes or discrete values for elements are noted as technical term [type]=code

ASAP2 The considered languages resp. DTDs are marked as technical term [type]=product.

ASAP The committees are noted as [type]=organization

ECU Objects in general are marked as technical terms [type]=other. This might be automotive equipments general objects such as variables etc.

Examples for SGML instances (fragments)
Examples for SGML instances use natural addressing only. For details see Structure principles of the MSR application profile .
Graphical conventions used in DTD diagrams
The structure of DTDs is shown in the MSR document as DTD diagrams (see convention in DTD diagrams).
Figure 1: convention in DTD diagrams
The meaning of the symbols is:
PCDATA | Processable Character Data (PCDATA) Data that consists of zero or more characters of both text and markup. PCDATA is a declared content keyword. PCDATA is used to indicate that all markup delimiters defined in the SGML declaration will be recognized by the parser as markup in the given element rather than data characters.
RCDATA | Replaceable Character Data (RCDATA) is data that consists of zero or more characters, in which references to substitutions are not recognized (i.e. RCDATA may contain text and entity references, but no sub-elements). See also: CDATA PCDATA.
CDATA | Character Data (CDATA) consists of zero or more text characters, where no markup of any kind is recognized. CDATA is an SGML term. Note that character references are allowed in a CDATA entity (substitution) but not in CDATA content.
ANY | a terminal type indicating that the object may contain text or any element defined in the model.
EMPTY | a terminal type keyword used to indicate that there is no data (i.e. no content, sub-elements or end-tags) for the object allowed in the document instance. This keyword is often used to describe elements that are placeholders or are pointers to external or system-generated data.
One | indicates that the element or the element group occurs exactly once
ZERO-OR-ONE | indicates that the element or the element group is optional
ONE-OR-MORE | indicates that the element or the element group occurs multiple times but at least once
ZERO-OR-MORE | indicates that the element or the element group occurs multiple times but also can be missed (optional)
ORDERED | a connector used to specify that the sibling objects must appear in the document in the order shown in the model
UNORDERED | a connector used to specify that the sibling objects can appear in any order in the document.
SELECTION | a connector used to specify that only one of the sibling objects can appear in the document.
ELEMENT | indicates a single SGML structure element
COLLAPSED | indicates, that the content of the element is not displayed here


III. Credits

Structure Principles of the MSRSYS DTD
III. Credits

The working group thanks for the contributions to the MSRSYS DTD given by: Thomas Riegraf (Vector informatik), Detlef Aufdermauer (Volkswagen), Martin Krause (Price Waterhouse Coopers)


IV. Document management

Structure Principles of the MSRSYS DTD
IV. Document management

team members
Name | Company |
Dipl.-Ing. U. Vogel | BMW AG | Phone: +49-89-382 34117 ulrich.vogel@bmw.de
Dipl.-Ing. P. Rauleder | Daimler Chrysler AG | Phone: +49-711-17 41133
Dipl.-Ing. (FH) U. Bless | Daimler Chrysler AG | Phone: +49-711-17 41723 uwe.bless@daimlerchrysler.com
Dipl.-Ing. Adams | Dr.Ing.h.c.F. Porsche AG | Phone: +49-7044-35 2084 winfried.adams@porsche.de
Dipl.-Ing. O. Marcks | Volkswagen AG | Phone: +49-5351-9 73795 oliver.marcks@volkswagen.de
M. Epping | Hella KG Hueck & Co | Phone: +49-2941-38 8572 eppimi1@hella.de
Dipl.-Ing. B. Weichel | Robert Bosch GmbH | Phone: +49-711-811 8322 bernhard.weichel@de.bosch.com
Dipl.-Inf. H. Gengenbach | Robert Bosch GmbH | Phone: +49-711-811 20521 helmut.gengenbach@de.bosch.com
Dipl.-Ing. E. Jakobi | Siemens AG | Phone: +49-941-790 4931 eckard.jakobi@at.siemens.de
Dipl.-Ing. (FH) H. Klein | XI-Works | Phone: +49-711-4609917 herbert.klein@tzkom.de
Dipl.-Ing. R.Reimer | XI-Works |
version overview
Date | Publisher
2002-02-07 | Dipl.-Ing. (FH) H. Klein
23.10.2000 | Dipl.-Ing. (FH) H. Klein
18.02.99 | Dipl.-Ing. (FH) H. Klein
26.11.98 | Dipl.-Ing. (FH) H. Klein
01.10.98 | Dipl.-Ing. (FH) H. Klein
modifications
Change | Related to
Create index, technical terms and reference. Convert to MSRREP V210 XML. Reason: | Content
New graphics and structure of the DTD Reason: Document Review | Content
New structure graphics Reason: document review | Document
several changes Reason: AG-DTD, document review | Content
- Reason: - | Content
modifications included
Date | Chapter | Change | Related to
2002-02-07 | Gesamt | Create index, technical terms and reference. Convert to MSRREP V210 XML. Reason: | Content
23.10.2000 | Gesamt | New graphics and structure of the DTD Reason: Document Review | Content
18.02.99 | Gesamt | New structure graphics Reason: document review | Document
26.11.98 | Gesamt | several changes Reason: AG-DTD, document review | Content
01.10.98 | Gesamt | - Reason: - | Content


1. Introduction

Structure Principles of the MSRSYS DTD
1. Introduction

This document describes the structural fundamentals of the MSR development documentation of the MSRSYS DTD. This description can also be used as an instruction for the preparation of a structured development documentation.
The requirements for every chapter, or every test, are documented in the form of a description, a structural definition and an example for content and layout.


2. Component Structure

Structure Principles of the MSRSYS DTD
2. Component Structure

The requirements and the product specifications for a system are described in separate instances containing only one component. For example, a system can be an ABS system, cruise control, a control unit or even just a sensor. A system can be assigned a part number (not mandatory).
A system is described as a part type. The specifications for a part type roughly encompass the following areas:
General Product Data 1
Introduction
Product Description
Function Overview
Key Data
Product Demarcation
Similar Products
General Hardware Description
General Software Description
General Interfaces
Failure Management
Resource Allocation
Calibration
Safety
Quality
Maintenance
General Conditions
Additional Design Documentation
Development Process Specifications
Additional specifications
General Test Specification
Behaviour
Architecture
Scheme Diagrams
Interface Specification
Signal Specification
Connection Components Specification
Connection Specification
Network Specifications
Additional Specifications
Electrical Characteristics
Environmental Characteristics
Other Physical Characteristics
Construction
Human Machine Interface
Additional Specifications
Parts in Part Type
The structure of a system (hierarchical component structure) is described indirectly. To understand this better, there are three terms with which one should be familiar:
Part Type
A part type is a library element which can be used ("instantiated") in a system or higher ranking part type through mounting. A part type has no description of use-related information.
Examples: a control unit, a sensor, an actuator
Part
A part is a mounted part type or a part type in use. It is mounted or employed in a higher ranking system or part type. A part inherits all characteristics of the respective part type. The part itself has a description of use-related information.
Examples: the control unit in an ABS system, the sensor on the left front wheel in the ABS system, the sensor on the right rear wheel in the ABS system
Part Definition
A part definition is a part type with all accessory parts (instances).
Example:
ABS system (part type)
Control unit (part)
Actuator (part)
Sensor front left in ABS system (part)
Sensor front right in ABS system (part)
Sensor rear left in ABS system (part)
Sensor rear right in ABS system (part)
In this way, a hierarchical component structure is created through successive mounting of part types in the higher ranking system or in higher ranking part types.
The following areas for use-related description are provided for each part of a component. All parameters deviating from the part type (naturally lower requirements than for the part type) can be defined here:
General Hardware
Operating Environment
Useful Life
Reliability
Electrical Characteristics
Environmental Characteristics
Other Physical Characteristics
An ABS system consisting of a control unit, a sensor and an actuator (which itself consists of a cylinder and a valve) would be described by means of a part type ABS, possibly with use-related requirements for the sensor and actuator. Additionally, the sensor and actuator are also specified as part types. This example is illustrated in the following figure:
Figure 2: An example of a component structure


3. Part Type

Structure Principles of the MSRSYS DTD
3. Part Type

The detailed specification of a part type takes place within 4. Parts.
General product data
Requirements for operating environment, useful life, reliability, hardware and software, information about applications, etc. The requirements can be documented with the help of text, figures and tables.
General test specification
Information on general test specifications (standard test voltage, standard test temperature, standard test configurations, etc.) with the help of text, figures, tables and parameters.
Behaviour
The behaviour of the system can be described here. For more detailed explanations, see 7. Behaviour.
Architecture

Block / Schematic diagrams | Block diagrams and/or basic circuit diagrams of a part type can be documented here.
Interfaces (<interface>) | For a basic explanation, see 8. Architecture. An interface can be hydraulic, pneumatic, mechanical, optical or electrical. It can have any number of ports. Mechanical, climatic and electrical characteristics of individual interfaces and ports can be described here.
Signals | For a basic explanation, see 8.2. Signals. A signal can be hydraulic, pneumatic, mechanical, optical or electrical. In addition, the type (analogue or digital) should also be defined. Characteristics of individual signals (particularly electrical characteristics) can also be described here.
Connection components | In this chapter any kind of connection component can be specified.
Connections | For a basic explanation, see 8.4. Connections. Each signal described under <signals> can be assigned a port. A connection component can also be assigned for each assigned port.
Electrical Characteristics

Electrical Test Specification | Information on test sequences and function states of the entire system For a detailed description of the contents, see 9.1. General electrical testing specifications.
Power supply | Information on voltage, current and power characteristics of the entire system. For a detailed description of the contents, see 9.2. Power supply
Electrical immunity | Requirements for reverse polarity protection, overvoltage resistance, short-circuit resistance, overload resistance, insulance, dielectric strength and voltage mismatch can be specified here. For a detailed description of the contents, see 9.3. Electrical immunity.
EMC | Requirements / Specifications regarding interference by conduction, interference by radiation, radio interference suppression, electrostatic discharge and EMC design can be documented here. For a detailed description of the contents, see 9.4. Electromagnetic compatibility (EMC).
Environmental Characteristics
Mechanical characteristics
Requirements for mechanical robustness (shock and jolt requirements, immunity, etc.) can be documented here.
Climatic characteristics
Information on temperature, air pressure, moisture, heat, thermal shock, etc. can be documented here.
Chemical characteristics
Information on corrosion, resistance to acidic and alkali solutions, etc. can be documented here.
Other physical characteristics
Optical, magnetic, acoustic and other physical characteristics can be documented here.
Construction

Housing | Information on the housing material, labelling, size and weight etc. can be entered here.
Optical design | Information on shapes and colors.
Ergonomics | Requirements for ergonomics.
Recycling | Information pertaining to the recovery / recycling of component units for the construction of the components.


4. Parts

Structure Principles of the MSRSYS DTD
4. Parts

<part-type-class>
This chapter documents the use-related requirements. Since the part type of a component can be used (instantiated) several times, the use-related descriptions (i.e. specifications that deviate from part type) are documented for each part. If two or more parts of the same part type have identical use-specific definitions, then they only need to be documented once. These definitions can then be referenced for the other parts.
General product data Concrete specifications for the operating environment, useful life, and reliability for this part are described.

General test specification
Behaviour
Architecture
Electrical characteristics
Electrical Test Specification | Information on test sequences and function states that deviate from part type.
Power supply | Definitions regarding power supply that deviate from part type.
Electrical immunity | Definitions regarding electrical immunity that deviate from part type.
EMC | Definitions regarding EMC that deviate from part type.
Environmental characteristics
Mechanical characteristics | Definitions regarding mechanical requirements that deviate from part type.
Climatic characteristics | Definitions regarding climatic requirements that deviate from part type.
Chemical characteristics | Definitions regarding chemical characteristics that deviate from part type.
Other physical characteristics Definitions regarding other physical characteristics that deviate from part type.


5. General Product Data

Structure Principles of the MSRSYS DTD
5. General Product Data

General product data can be described in <general-product-data-1>. This topic covers the following items:
General product description (<product-desc>) |
Function Overview (<function-overview>) | An overview of the functions of the part type
<key-data> | A brief overview of the key data of the part type
Product demarcation<product-demarcation> | Description of the demarcating charcateristics to similar products
Similar Products<similar-products> | Description of the products similar to this part type
<general-hardware> | General definitions about hardware requirements
<general-software> | General definitions about software requirements
<general-interfaces> | General definitions about the product interfaces
<failure-management> | Description of failure-save concept (<fail-save-concept>), <fmea> and <self-diagnosis> of the part type.
<resource-allocation> | Specification of the resource allocation
<calibration> | Genaral specification of the calibrations of characteristics of the part type.
<safety> | Informations about the saftey measures for the operation of the part type.
<quality> | General specification of the quality of the part type.
<maintenance> | Information about the maintenance of the part type.
General conditions (<general-cond>) |
Additional design documentations (<add-design-doc>) |
Development process specifications (<development-process-spec>) |
Additional specifications (<add-spec>) | Siehe auch Concepts of the MSR application profile V1.x.x
Figure 3: Structure of general product data


6. General Test Specification

Structure Principles of the MSRSYS DTD
6. General Test Specification

The general test specification of the part type can be described under the item <general-test-spec>.
The description includes general test parameters (<general-test-spec-prms>), test configurations (<std-test-conf>) and test equipment (<test-equipment-desc>).
Figure 4: Structure of general test specification


7. Behaviour

Structure Principles of the MSRSYS DTD
7. Behaviour

System behaviour can be described under the item <behaviour> for the part type. Behaviour itself can be described in various ways:
  • Description in a CASE-Tool
    Describing behaviour in a CASE-Tool entails making a reference to the CASE-Tool description under the point <behaviour>. A context diagram can also be included (see SA Method .
  • Description in the current SGML document
    For a description of behaviour in the document itself, the following outline should be used:
    1. Description of system behaviour
    2. Description of system environment
      Here, the external systems and the input/output sizes are described. A context diagram can also be included.
    3. Operating modes
      All the relevant operating modes of the system within this project version must be defined here. Referencing of the states defined here is carried out at the appropriate place.
    4. Functions
      All functions are listed here. The input/output, connections and flow of information, assigned operating states, assigned components and tests appropriate for the function are described for each function. It is possible to build a function hierarchy like these example:
      4.1 Function 1
      4.1.1 Function 1.1
      4.2 Function 2
      ...


8. Architecture

Structure Principles of the MSRSYS DTD
8. Architecture

Contents of this chapter:
  • 8.1. Interfaces
  • 8.2. Signals
  • 8.3. Connection Components
  • 8.4. Connections
  • 8.5. Network Specification
  • 8.6. Additional Specifications


8.1. Interfaces

Interfaces(plug-type connectors) can be described for a system on the one hand and for part types of components on the other. They are described in the item <Interfaces> by part type. Interfaces can not be described for parts, because a part inherits the interfaces from the respective part type (Part and part type belong to the same part definition in this case.).
Interfaces and ports can be identified by a <drawing-number> and a <part-number> or a reference(<part-type-ref>) to a interface <part-type>. The interface can be classified with <interface-class>. The class values can be defined company specific. Further the <seal>, a short description(<desc>) and a extented description (<ncoi-3>) can be defined for a interface.
<interface>s can contain modules and one or more ports which can be grouped together with<port-group>s . The <ports> within a <port-group> can be defined as electrical, pneumatic, hydraulic or optical ports with the attribute [kind]. The default value is "electric". One interface can, for example, contain electrical ports and also pneumatic ports. Each <port> has an attribute [direction] which can be set to the values in, out, bi, ground, power-supply or other. Generally all ports exist in each variant The reference <variant-def-ref> is only used to exclude <port>s from specific variants.
The following figure illustrates the situation:
Figure 5: An example of interfaces
In the ABS system, there are the parts (employed part types) control unit and hydraulic aggregate. The system has two interfaces; these are described by ABS part type under the item <architecture>/<interfaces>. The interfaces on the parts are inherited from the respective part types and are therefore described in the part type specifications under the item <architecture>/<interfaces>(for the part type, not for the part!) as well.
Interfaces can be connected to other <part-types> either with or without harness. This can be defined in the attribute [connection-type] with the values "harness" or "no-harness". The default value is "harness" which mean that a separate <part-type> exists and the <port-number>s of the interface are the port-numbers of the interface itself. If the value "no-harness" is set, no <part-type> "harness" exists and the <port-number>s are the port-numbers of the connector at the harness.
If a part-type has a interface that is visible from the outside of the part-type but isn't mounted physically on itself, the real interface can be linked with <interface-ref>. That is there is a temporary interface on the surrounding <part-type> that references to the interface which is mounted on the integrated <part-type>.


8.2. Signals

<signal-spec>
The definition of a signal between two parts of the same level or between a part and a part type is always contingent upon the signal in the higher ranking part type. As a rule, signals do not have a direction. This is determined by the respective port definition (in, out, bi).
Caution
Strictly speaking, no signals can be fed extraneously to systems and part types. This only becomes possible when a system or a part type is mounted and employed ( "instantiated" )in a higher ranking system or in a higher ranking part type and therefore becomes a part.
The following figure illustrates the situation:
Figure 6: An example of interfaces and signals
The signal at "1" connects the control unit part to itself. The signals at "2" connect the parts control unit and hydraulic aggregate to one another. The signal at "3" connects the hydraulic aggregate part to the ABS system, while the signal at "4" is fed to the ABS system extraneously, and therefore can only be specified if the system is instantiated.
The signals at "1", "2" and "3" in the last figure are described according to part type ABS under the point <architecture>/<signals>.
The signal at "5" is an internal signal of the control unit. This signal has to be specified within the part type of the control unit.


8.3. Connection Components

Connection components of a part type, e.g. electric cables or glass fibre cables, can be described in <connection-comp-spec>. Another possibility is to regard connection components as independent components, consisting of part types and parts. In this case, a connection component is described with its interfaces and characteristics as its own part type. Then it is also part of the component structure.
Figure 7: Structure of Connection Components


8.4. Connections

<connection-spec>
<connections> can be defined within part types. Here, the signal defined for this part type is assigned to a port of an interface. In addition, a connection component.
connection components such as a cable or a bundle of cables can be assigned here.
In the example [An example of interfaces and signals] of a connection, signal "3" is assigned a port of the ABS system. In addition, a 0,75mm2 copper wire was assigned as connecting component.


8.5. Network Specification

The network interconnection of a part type can be described in<network-spec> . This topic concentrates all items that are referenced in the MSR NET DTD. The network specification consists of one or more <network>s (e.g. a CAN Bus for Motor Control ) which respectively consists of one or more <port>s with net lines (e.g. CAN_LOW, CAN_HIGH, CAN_SHIELD).
The following example shows the interconnection of a part type in the MSR SYS DTD with the network (specified in MSR NET DTD).
Figure 8: Example for Network Specification
Figure 9: Structure of Network Specification
Figure 10: Structure of Network Port


8.6. Additional Specifications

Additional specifactions of the architecture of the part type which cannot be classified in any of the above listed subclassescan be described here


9. Electrical Characteristics

Structure Principles of the MSRSYS DTD
9. Electrical Characteristics

Contents of this chapter:
  • 9.1. General electrical testing specifications
  • 9.2. Power supply
  • 9.3. Electrical immunity
  • 9.4. Electromagnetic compatibility (EMC)
  • 9.5. Interferences by radiation
  • 9.6. Interference suppression
  • 9.7. ESD
  • 9.8. EMC design
  • 9.9. Further properties


9.1. General electrical testing specifications

<elec-test-spec>
Figure 11: Structure of electrical testing


9.1.1. Test sequence

<test-sequence>
Here the test sequence of electrical tests can be defined.


9.1.2. Function states

<function-states>
The <function-state> describes the effect upon a system during and after the exposure to an interference. Function states have initially been defined in order to evaluate electromagnetic compatibility and electrical immunity.
A function state is expressed by a capital letter (key) and a description of the state.
Figure 12: Functions State Description
Example for content:
Function states in compliance with standard DIN 40839 part 3
Function states | Description
A | Device works within the given tolerances
B | Device works, but not within the given tolerances, and returns after decay of the interference to function state A
C | Device does not work or works defectively, but returns after decay of the interference automatically to function state A
D | Device does not work or works defectively and stays after decay of the interference outside the given tolerances
E | Device does not accomplish one ore more functions during and after the exposure to the interference and has to be repaired or substituted after the exposure to the interference


9.2. Power supply

<power-supply>
Figure 13: Structure of power supply


9.2.1. Voltages

<volt-char>
Concerning voltages, various nominal voltages (<nominal-volt>) can be specified. It is possible to reference to supply connections with the reference mechanism. In the description of the supply connections, any number of voltage ranges with respective operating states can be given to each nominal voltage. Various operating states can be assigned to a voltage range.
Figure 14: Structure of voltages
Example for content:
Representation example for voltage ranges
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit |
Nominal voltage | UN |  |  |  | 12 |  | V | 1


9.2.2. Currents

<current-char>
Concerning currents, various nominal currents (<nominal-current>) can be specified. It is possible to reference to supply connections with the reference mechanism. In the description of the supply connections, any number of current ranges with respective operating states can be given to each nominal current. Various operating states can be assigned to a current range.
Figure 15: Structure of currents
Example for content:
Representation example for current ranges
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit |
<nominal-current> | IN |  |  |  | 2 |  | A | 1


9.2.3. Powers

<power-char>
Concerning powers, various nominal powers (<nominal-power>) can be specified. It is possible to reference to supply connections with the reference mechanism. In the description of the supply connections, any number of power ranges with respective operating states can be given to each nominal power. Various operating states can be assigned to a power range.
Figure 16: Structure of powers
Example for content:
Representation example for power ranges
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit |
Nominal power | PN |  |  |  | 10 |  | W | 1


9.2.4. Further properties

<add-spec>
In the topic further properties properties are described, which ought to be described in the topic range of <power-supply> but which cannot be expressed thematically in any of the subdivision points mentioned above (see Concepts of the MSR application profile V1.x.x)


9.3. Electrical immunity

<elec-immunity>
Figure 17: Structure of Electrical Immunity


9.3.1. Reverse polarity protection

<reverse-polarity-prot>
Reverse polarity protection describes the behaviour (function state and admissible fault descriptions) of the system in case of permanent reverse polarity of the battery connection. The reverse polarity is defined by the reverse polarity voltage (<test-volt>), reverse polarity time (<test-duration>) and testing temperature (<test-temp>). Furthermore, the general design of the system or component interfaces is defined, e.g. the treatment of the interfaces which have a connection to ground or to the supply voltage outside the system, the protection of the connected components, the state of the outputs during reverse polarity, etc.
The description of the reverse polarity protection is valid for all electrical connections (there is no reference to any electrical connection). If there are different descriptions for some electrical connections, a further description of the reverse polarity protection is defined for each difference (with reference to the concerned connection).
In addition to the a.m. statements there can always be given additional specifications, e.g. the test set-up.
Figure 18: Structure of reverse polarity protection test
Example for content:
Representation example for reverse polarity protection
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
Test voltage | UP |  |  |  | 15,0 |  | V
Test duration | tP | 19 | 20 | 21 |  |  | s
Test temperature | T | 17 | 22 | 27 |  |  | C
Operating state : switched off
Function state: B
Fault description: Output C2 activated


9.3.2. Overvoltage strength

<overvoltage-res>
The overvoltage strength describes the behaviour of the system in case of overvoltage regarding supply connections, which can be created by a jump start, e.g. The voltage wave form (<overvoltage-res-prms>, in the most simple way defined by corresponding voltage and time specifications), the operating state (<oper-mode-refs>), the function state (<fuction-state-ref>), and the fault description (<failure-desc>) can be defined. By defining various overvoltage strength tests, a number of different requirements, e.g. static overvoltage, jump start, boost charge etc. can be defined.
The description of the overvoltage strength is valid for all electrical connections (there is no reference to any electrical connection). If there are different descriptions for some electrical connections, a further description of the overvoltage strength is defined for each difference (with reference to the concerned connection).
In addition to the a.m. statements there can always be given additional specifications, e.g. the test set-up.
Figure 19: Structure of overvoltage strength test
Example for content:
Representation example of overvoltage strength
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit |
Overvoltage | U |  | 30 |  |  |  | V | 1
Test duration | tP | 19 | 20 | 21 |  |  | s |
Test voltage | UP |  | 15,0 |  |  |  | V |
Test temperature | T | 17 | 22 | 27 |  |  | °C |
Number of tests | n |  | 5 |  |  |  |  |
Interval between tests | t |  | 10 |  |  |  | s |
Figure 20: Voltage characteristics
Operating state : starting phase
Function state: B
Fault description: Output C2 activated


9.3.3. Short-circuit strength

<short-circuit-res>
The short-circuit strength describes the function state of the system in case of a clamp being held to ground or supply voltage thus producing a short-circuit. The short-circuit strength will be defined generally for all interfaces. Furthermore, depart from this specification the short-circuit strength can be defined for each connection regarding the description of interfaces.
The description of the short-circuit strength is valid for all electrical connections (there is no reference to any electrical connection). If there are different descriptions for some electrical connections, a further description of the short-circuit strength is defined for each difference (with reference to the concerned connection).
The MSR group defined the following description of the short-circuit strength:
Figure 21: Structure of short-circuit strength
Example for content:
Representation example for short circuit strength
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
Test voltage | UP |  | 15,0 |  |  |  | V
Test temperature | T | 17 | 22 | 27 |  |  | °C
Test duration | tP | 19 | 20 | 21 |  |  | s
Short circuit current | IKS |  | 10 |  |  |  | A
Short circuit resistance | RKS |  | 0.01 |  |  |  | W
Short circuit inductivity | LKS |  | 0.01 |  |  |  | µH
Number of tests | n |  | 5 |  |  |  |
Interval between tests | t |  | 10 |  |  |  | s
Operating state : starting phase
Function state: B
Fault description: fuse cuts out
In addition to the a.m. statements there can always be given additional specifications, e.g. the test set-up.


9.3.4. Overload strength

<overload-res>
The overload strength is an overload of the outputs (consumers use more than nominal current). Overload strength is defined generally for all interfaces. Furthermore, depart from this specification the overload strength can be defined for each connection regarding the description of interfaces.
The description of the overload strength is valid for all electrical connections (there is no reference to any electrical connection). If there are different descriptions for some electrical connections, a further description of the overload strength is defined for each difference (with reference to the concerned connection).
The MSR group defined the following description of the overload strength:
Figure 22: Structure of overload strength
Example for content:
Representation example for overload strength
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
Overload | Ü |  | 5 | 15 |  |  | A
Test duration | tP | 19 | 20 | 21 |  |  | s
Test voltage | UP |  |  |  | 15,0 |  | V
Test temperature | T | 17 | 22 | 27 |  |  | °C
Number of tests | n |  |  |  | 5 |  |
Interval between tests | t |  |  |  | 10 |  | s
Operating state : starting phase
Function state: B
Fault description: fuse cuts out
In addition to the a.m. statements there can always be given additional specifications, e.g. the test set-up.


9.3.5. Insulating resistance

<insulance>
The insulating resistance is determined between two electrically separated connections or between the casing and the electrically separated connections. The determination of the resistance is realized with an unconnected device under test (DUT) by a relatively high direct current. Furthermore, relevant quantities for the determination of the insulating resistance can be given, e.g. temperature (<test-temp>), <test-duration>, relative humidity (<relative-hum>).
The description of the insulating resistance is valid for all electrical connections (there is no reference to any electrical connection). If there are different descriptions for some electrical connections, a further description of the insulating resistance is defined for each difference (with reference to the concerned connection).
Figure 23: Structure of insulating resistance
Example for content:
Representation example for insulating resistance
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
Voltage | US | 450 | 500 | 550 |  |  | V
Test duration | tP | 0,95 | 1 | 1,05 |  |  | min
Temperature | TP | 1,9 | 2 | 2,1 |  |  | °C
Resistance | R |  | 1 |  |  |  | MW
rel. humidity | hum | 67,5 | 75 | 82,5 |  |  | %
Besides the measuring voltage and the resistance, there can always be given additional specifications for each test, e.g. the test set-up.


9.3.6. Dielectric strength

<die-strength>
The dielectric strength is determined between two electrically separated connections or between the casing and the electrically separated connections, by applying an alternating voltage.
The description of the dielectric strength is valid for all electrical connections (there is no reference to any electrical connection). If there are different descriptions for some electrical connections, a further description of the dielectric strength is defined for each difference (with reference to the concerned connection).
Figure 24: Structure of dielectric strength
Example for content:
Representation example for dielectric strength
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
Voltage | US | 450 | 500 | 550 |  |  | V
Temperature | TP | 17 | 22 | 27 |  |  | °C
Test duration | tP | 0,95 | 1 | 1,05 |  |  | min
Frequency | f |  | 50 |  |  |  | Hz
rel. humidity | hum | 67,5 | 75 | 82,5 |  |  | %
Besides the measuring voltage and the frequency, there can always be given additional specifications for each test, e.g. the test set-up.


9.3.7. Voltage mismatch

<volt-mismatch>
The voltage mismatch describes the ability of a component, or a system, to accomplish its specified function in case of a voltage mismatch in the ground conduction or power supply. The voltage mismatch can be caused by an external connection of sensors or actuators to the ground conduction or to the power supply (e.g. use of the car body as ground conduction). A max. admissible voltage mismatch can be defined, for the ground connection as well as for the power supply, with the aid of the reference point.
The description of the voltage mismatch is valid for all electrical connections (there is no reference to any electrical connection). If there are different descriptions for some electrical connections, a further description of the voltage mismatch is defined for each difference (with reference to the concerned connection).
Besides the measuring voltage and the test duration, there can always be given additional specifications for each test, e.g. the test set-up.
Figure 25: Structure of voltage mismatch
Example for content:
Representation example for voltage mismatch
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
pos. voltage mismatch | dU | 0,8 | 1 | 1,2 | V |  |
neg. voltage mismatch | dU | 0,8 | 1 | 1,2 | V |  |
Test duration | tP | 0,95 | 1 | 1,05 | min |  |
Operating state : switched on
Function state: A
Fault description: no fault


9.3.8. Further properties

In the subdivision point <add-spec> properties are described which ought to be mentioned in the topic area of Electrical immunity (<elec-immunity>) but which cannot be expressed thematically in any of the subdivision points mentioned above.
Figure 26: Structure of further properties


9.4. Electromagnetic compatibility (EMC)

<emc>
Figure 27: Structure of electromagnetic compatibility
Electromagnetic compatibility is the ability of an equipment or system to function satisfactorily within its electromagnetic environment without introducing intolerable electromagnetic disturbance to anything in that environment. ( [DIN 40 839-1;DIN 40 839-1;;2.1;]).


9.4.1. Interferences by conduction

<inter-con>
Figure 28: Structure of interferences by conduction


9.4.1.1. Interference strength

<inter-immunity>
Figure 29: Structure of interference strength
Within the interference strength, interferences by conduction in power supply conductions (<inter-supply-con>), coupled-in interferences on transmission and sensor conductions (<inter-signal-con>) as well as vehicle network ripple (<waved-nominal-volt>) are considered. The standard [DIN 40 839-1;DIN 40 839-1;;3;]forms the basis for interference strength (not including vehicle network ripple).


9.4.1.1.1. Interferences by conduction in power supply conductions

Structure Principles of the MSRSYS DTD
9. Electrical Characteristics
9.4. Electromagnetic compatibility (EMC)
9.4.1. Interferences by conduction
9.4.1.1. Interference strength
9.4.1.1.1. Interferences by conduction in power supply conductions

<inter-supply-con>
Figure 30: Structure of interference via power supply


9.4.1.1.1.1. Laboratory tests

Structure Principles of the MSRSYS DTD
9. Electrical Characteristics
9.4. Electromagnetic compatibility (EMC)
9.4.1. Interferences by conduction
9.4.1.1. Interference strength
9.4.1.1.1. Interferences by conduction in power supply conductions
9.4.1.1.1.1. Laboratory tests

<inter-supply-con-lab-test>
The requirements on interferences by conduction in power supply conductions (<inter-supply-con>) are described for one (or possibly more) vehicle network voltage(s) by means of interference strength tests.
During an interference strength test, the behaviour of a DUT is tested by submitting the sample to a test pulse. Regarding interference strength test, the following specifications can be made.
  • Test pulse
    The test pulse can be defined including all corresponding parameter values (...t1 to ... td). (as given in the definition,Representation example for test pulses for a 12 V vehicle network (according to DIN 40839 part 1).).
  • Severity level and correlated peak voltage for the test pulse
    Severity levels, defined in Determination of severity levels for test pulses by means of pulse amplitudes according to DIN 40839 part 1 can be chosen. The specification of the severity level will only be required in case of standardized test pulses.
  • Test voltage
    Vehicle network voltage applied during the test. Only defined if it deviates from the standard test voltage.
  • Internal resistance of the generator Ri
    Internal resistance of the interference source
  • Minimum test amount
    The minimum test amount is defined by the number of test pulses or by the duration of the test.
  • Intervals between test pulses
    The intervals between test pulses have to be defined only for those test pulses for which there are not given any specifications in the standard. This is especially true for test pulse 5.
  • Interference source
    The test device which generates the test pulse.
  • Operating state
    The operating state defines the state of the system at which the test is performed. If the test is to be performed with various operating states, they can be grouped.
  • Function state
    The assignment of a function state to the test is accomplished by a code letter (A...E).
  • Fault description
    The failure mode of the system will be described in textual form, in addition to the function state (if it is not equal to A).
  • Additional specifications
    Apart from the a.m. specifications, it is always possible to give additional specifications for a test. These include, e.g., a test temperature which differs from general specifications, the test set-up and further specifications which have not been defined yet.
The content of interference strength tests is not established in an (inter-)national standard. Apart from the test pulses 1 to 5, descriptions concerning interferences by conduction in power supply conductions (<inter-supply-con>) can be filed either in a user-defined way or according to in-house standards.
This includes, e.g., the test of the central load-dump protection with a characteristic that differs from test pulse 5, or the definition of the behaviour in case of a determined voltage characteristic in the power supply conductions.
The voltage characteristic describes the robustness of the system/the component against defined voltage changes, which may arise due to the failure of a generator or a defective vehicle battery. The voltage characteristic can be defined in form of a text or a graphic.
Figure 31: Structure of laboratory test
Example for content:
Representation example for interference strength requirements: concerning interferences by conduction in power supply conductions, test pulse 1
Denomination | Abbreviation <short-name> | Min <min> | Type <typ> | Max <max> | Abs <abs> | Tolerance <tol> | Unit <unit>
Severity level |  |  |  |  | 4 |  |
Peak voltage | Us |  |  |  | -100 |  | V
Test- spg. | Up |  |  |  | 13.5 |  | V
Internal resistance of generator | Ri |  |  |  | 10 |  | Ohm
Minimum test amount |  |  |  |  | 30000 |  |
Intervals between test pulses |  |  |  |  |  |  |
Interference source: test pulse generator NSG 500C
Operating state : switched on
Function state: A
Fault description: no fault
Additional specifications: Pulse generated by switching off inductive charges.
Definition test pulse 1
Denomination | Abbreviation <short-name> | Min <min> | Type <typ> | Max <max> | Abs <abs> | Tolerance <tol> | Unit <unit>
Intervals between pulses | t1 | 0.5 |  | 5 |  |  | s
Duration of individual interference | t2 |  |  |  | 200 |  | ms
Recovery time, duration between interference end and interference start | t3 |  |  |  | 100 |  | µs
Pulse rise time | tr |  |  |  | 1 |  | ms
Pulse duration | td |  |  |  | 2 |  | ms
Test pulse: 2
...(Description as for test pulse 1)
Definition of the test pulse
A test pulse is described by a curve which is characterized by specific parameters. The shape of the curve depends on the vehicle network voltage.
According to [DIN 40 839-1;DIN 40 839-1;;all;]5 different test pulses (test pulse forms) are described with the help of corresponding parameter values which additionally depend on the vehicle network voltage:
  1. Pulse generated by disconnecting inductive loads.
  2. Pulse generated by direct current motors when disconnecting.
  3. Pulse generated by switching. There is a difference between 3a (negative peak voltage) and 3b (positive peak voltage)
  4. Pulse generated by closing the starter circuit in combustion engines. The ripple produced by the revolutions of the starter is not considered.
  5. Pulse generated, among other facts, by disconnecting the battery when the generator produces charge current (battery charge current disconnection pulse).
Representation example for test pulses for a 12 V vehicle network (according to DIN 40839 part 1)
test pulse | Ua | t1 | t2 | t3 | t4 | t5 | t6 | t7 | t8 | tf | tr | td
 | V | s | ms | µs | ms | ms | ms | ms | s | ms | ms | ms
1 |  | 0,5-5 | 200 | µ100 |  |  |  |  |  |  | 1µs | 2
2 |  | 0,5-5 | 200 |  |  |  |  |  |  |  | 1µs | 0.05
3a |  | 100µs |  |  | 10 | 90 |  |  |  |  | 5ns | 0.1µs
3b |  | 100µs |  |  | 10 | 90 |  |  |  |  | 5ns | 0.1µs
4 | -2.5 |  |  |  |  |  | 15 | 50 | 0.5-20 | 100 | 5 |
5 |  |  |  |  |  |  |  |  |  |  | 0.1-10 | 40-400
Significance of parameters:
t1: Interval between pulses
t2: Duration of single interference
t3: Recovery time, duration between end of interference and beginning of interference
t4: Duration of switching burst
t5: Recovery time
t6: Duration of peak voltage drop Us
t7: Rise time from Us to Ua
t8: Duration of Ua
tf: Rise time operation voltage
tr: Pulse rise time
td: Duration of pulse
Ua: Voltage drop after transient state with reference to test voltage Up
Not all given parameters are used for the description of a test pulse.
Further user-defined or in-house standard specific test pulses can be given.
Definition of the severity level
The severity level determines the peak voltage Us of the test pulse.
According to DIN 40 839-1the following severity levels are defined:
Determination of severity levels for test pulses by means of pulse amplitudes according to DIN 40839 part 1
Test pulse | Pulse amplitude U s in volts at severity level (for vehicle network voltage of 12/24V)
 | I | II | III | IV
1 | -25/-50 | - 50/-100 | - 75/-150 | -100/-200
2 | + 25 | + 50 | + 75 | + 100
3a | -25/-35 | -50/-70 | -100/-140 | -150/-200
3b | +25/35 | +50/70 | +75/140 | +100/200
4 | -4/-5 | -5/-10 | -6/-14 | -7/-16
5 | +26,5/70 | +46,5/113 | +66,5/156 | +86,5/200
The peak voltage depends on the severity level and on the vehicle network voltage. Further user-defined or in-house standard specific severity levels with corresponding voltages U s can be defined for given test pulses.


9.4.1.1.1.2. Test in vehicle

Structure Principles of the MSRSYS DTD
9. Electrical Characteristics
9.4. Electromagnetic compatibility (EMC)
9.4.1. Interferences by conduction
9.4.1.1. Interference strength
9.4.1.1.1. Interferences by conduction in power supply conductions
9.4.1.1.1.2. Test in vehicle

<inter-supply-con-vehicle-test>
During the test in vehicle the built-in component is exposed to interferences which are originated by switching known interference sources in the wiring harness. Following specifications can be made for the description of the test:
  • Test pulse
    Contrary to the laboratory tests (<inter-supply-con-lab-test>), here pulses generated by known interference sources in the vehicle are coupled into. These are characteristic pulses which correspond the pulses 1 to 5 (see table Representation example for interference strength requirements: concerning interferences by conduction in power supply conductions, test pulse 1). If the test pulse is described by detailed parameters, an adaptation of the parameter values corresponding to the test pulse, to the pulses actually existing in the vehicle is possible.
  • Severity level and corresponding peak voltage for the test pulse.
    Severity levels defined in [Determination of severity levels for test pulses by means of pulse amplitudes according to DIN 40839 part 1] can be chosen. The specification of the severity level is only required in case of standard pulses.
  • Test voltage
    Vehicle network voltage applied during the test. It will only be defined if it deviates from the standard test voltage.
  • Minimum test amount
    The minimum test amount is defined by the number of test pulses or by the duration of the test.
  • Interference source
    The known component which generates the test pulse.
  • Operating state
    The operating state defines the state of the system at which the test is performed. If the test is to be performed with various operating states, these can be grouped.
  • Function state
    The assignment of a function state to the test is accomplished by a code letter (A...E).
  • Fault description
    The failure mode of the system will be described in textual form, in addition to the function state (if it is not equal to A).
  • Additional specifications
    Apart from the a.m. specifications, it is always possible to give additional specifications for a test. These include, e.g., a test temperature which differs from general specifications, the test set-up and further specifications which have not been defined yet.
Figure 32: Structure of vehicle test
Example for content:
See example in chapter 9.4.1.1.1.1. Laboratory tests.


9.4.1.1.2. Coupled-in interferences on transmission and sensor conductions

Structure Principles of the MSRSYS DTD
9. Electrical Characteristics
9.4. Electromagnetic compatibility (EMC)
9.4.1. Interferences by conduction
9.4.1.1. Interference strength
9.4.1.1.2. Coupled-in interferences on transmission and sensor conductions

<inter-signal-con>
Figure 33: Structure of coupled-in interferences


9.4.1.1.3. Laboratory tests

Structure Principles of the MSRSYS DTD
9. Electrical Characteristics
9.4. Electromagnetic compatibility (EMC)
9.4.1. Interferences by conduction
9.4.1.1. Interference strength
9.4.1.1.3. Laboratory tests

<inter-signal-con-lab-test>
The requirements to capacitively coupled-in interferences are described in an analogue way to the requirements to interferences by conduction in power supply conductions (<inter-supply-con>). The pulses used within that correspond, concerning their characteristics, to the pulses used in Interferences by conduction in power supply conductions (<inter-supply-con>). Although, because of the origin of these pulses, they are not the same pulses. In order to realize a capacitive coupling of an interference into the interference sink, the coupling clamp is used.
Apart from the test pulses defined by standards, it is possible to define further test pulses (e.g. company-specific test pulses).
The requirements to interferences which can be coupled into signal input conductions, data conductions, and control conductions, as well as into output conductions, are described to one or various corresponding vehicle network voltage(s) by means of interference strength tests. During an interference strength test, the behaviour of a DUT is tested by exposing the sample to a test pulse. For an interference strength test, following specifications can be made.
  • Test pulse
    Characteristic test pulses, which are described in Representation example for test pulses for coupled-in interferences on transmission and sensor conductions and a 12 volts vehicle network, can be chosen. If the test pulse is described by detailed parameters, an adaptation of the parameter values corresponding to the test pulse, to the pulses actually existing in the vehicle is possible.
  • Severity level and corresponding peak voltage for the test pulse
    Severity levels defined in Determination of severity levels for coupled-in interferences on transmission and sensor conductions according to DIN 40839 part 3., can be chosen. The specification of the severity level is only required in case of standard pulses.
  • Test voltage
    Vehicle network voltage applied during the test. It will only be defined if it deviates from the standard test voltage.
  • Internal resistance of the generator Ri
    Internal resistance of the interference source
  • Minimum test amount
    The minimum test amount is defined by the number of test pulses or by the duration of the test.
  • Interference source
    The known component which generates the test pulse.
  • Operating state
    The operating state defines the state of the system at which the test is performed. If the test is to be performed with various operating states, these can be grouped.
  • Function state
    The assignment of a function state to the test is accomplished by a code letter (A...E).
  • Fault description
    The failure mode of the system will be described in textual form, in addition to the function state (if it is not equal to A).
  • Additional specifications
    Apart from the a.m. specifications, it is always possible to give additional specifications for a test. These include, e.g., a test temperature which differs from general specifications, the test set-up, the description of the coupling clamp and further specifications which have not been defined yet.
Figure 34: Structure of laboratory testing
Example for content:
See example in chapter 9.4.1.1.1.1. Laboratory tests.
Definition of the test pulse:
Representation example for test pulses for coupled-in interferences on transmission and sensor conductions and a 12 volts vehicle network
Test pulse | t1 | t2 | t3 | tr | td
Unit | s | ms | ms | µs | ms
1 | 0,5 -5 |  |  | 1 | 2
2 | 0,5 -5 |  |  | 1 |
3a | 0,0001 | 10 | 90 | 0,005 | 0,0001
3b | 0,0001 | 10 | 90 | 0,005 | 0,0001
new |  |  |  |  |
Determination of severity levels for coupled-in interferences on transmission and sensor conductions according to DIN 40839 part 3.
Test pulse | Pulse amplitude U s in volts at severity level (for 12/24V vehicle network voltage) |  |  |
 | I | II | III | IV
1 | -7.5/-15 | -15/-30 | -22.5/-45 | -30/-60
2 | 7.5/15 | 15/30 | 22.5/45 | 30/60
3a | -15/-14 | -30/-28 | -45/-56 | -60/-80
3b | 10/14 | 20/28 | 30/56 | 40/80
The peak voltage depends on the severity level and on the vehicle network voltage. Further user-defined or in-house standard specific severity levels with corresponding voltages U s can be defined to given test pulses.


9.4.1.1.4. Test in vehicle

Structure Principles of the MSRSYS DTD
9. Electrical Characteristics
9.4. Electromagnetic compatibility (EMC)
9.4.1. Interferences by conduction
9.4.1.1. Interference strength
9.4.1.1.4. Test in vehicle

<inter-signal-con-vehicle-test>
During the test in vehicle the built-in component is exposed to interferences which are originated by switching known interference sources in the wiring harness. Following specifications can be made for the description of the test:
  • Minimum test amount
    The minimum test amount is defined by the duration of the test.
  • Operating state (<oper-mode-refs>)
    The operating state defines the state of the system at which the test is performed. If the test is to be performed with various operating states, these can be grouped.
  • Function state (<function-state-ref>)
    The assignment of a function state to the test is accomplished by a code letter (A...E).
  • Fault description (<failure desc>)
    The failure mode of the system will be described in textual form, in addition to the function state (if it is not equal to A).
  • Additional specifications (<add-info>)
    Apart from the a.m. specifications, it is always possible to give additional specifications for a test. These include, e.g., a test temperature which differs from general specifications, the test set-up and further specifications which have not been defined yet.
Figure 35: Structure of a vehicle test
Example for content:
See example in chapter 9.4.1.1.1.1. Laboratory tests.


9.4.1.2. Vehicle network ripple

<waved-nominal-volt>
Requirements concerning the vehicle network ripple define the robustness of a DUT with respect to the vehicle network ripple originated by the generator. It is assumed that the interference originated by the generator, which interferes the supply voltage, is sinusoidal. Since the generator, which is coupled to the vehicle engine, works within a wide range of revolutions, the interference strength is defined for a frequency range and for a frequency response curve. The frequency response curve determines the form of the frequency changes, e.g., ramp, sawtooth etc., within the specified test duration. This requirement can be described by the following parameters.
Figure 36: Structure of vehicle network ripple
Example for content:
Figure 37: Frequency response curve
Representation example for vehicle network ripple
Denomination | Abbreviation | Min | Type | Max | Abs | Tolerance | Unit
 | <short-name> | <min> | <typ> | <max> | <abs> | <tol> | <unit>
Interference voltage | US | 1,9 | 2 | 2,1 | V |  |
Internal resistance | RI |  | 0.2 |  | W |  |
Test duration | t | 9 | 10 | 11 | min |  |
Operating state : Switched on
Function state: A
Fault description: no fault
Additional specifications:
Apart from the a.m. specifications, it is always possible to give additional specifications for a test. These include, e.g., a test temperature which differs from general specifications, the test set-up etc.


9.4.2. Interference emission

<inter-emi>
Within the interference emission, interferences by conduction in power supply conductions (<inter-supply-con>), which are emitted from the devices, are measured. The base forms the standard DIN 40 839-1.
Figure 38: Structure of interference emission


9.4.2.1. Laboratory tests

<inter-emi-lab-test>
An interference emission is an interference emitted by the DUT onto the artificial network. In order to evaluate the emission of interferences by equipment in the laboratory, the DUT is connected to an artificial network, and put into operation. The following specifications can be given for an interference emission test.
  • Test pulse
    Characteristic test pulses as defined in table [Test pulses for the description of the interference emission according to DIN 40839 part 1] can be chosen. If the test pulse is described by detailed parameters, an adaptation of the parameter values corresponding to the test pulse to the pulses actually existing in the vehicle is possible.
  • Severity level and corresponding peak voltage for the test pulse
    Severity levels defined in [Determination of interferences emission grades for characteristic pulses via admissible pulse amplitudes according to DIN 40839 part 1] can be chosen. The specification of the severity level is only required in case of standard pulses.
  • Test voltage (<test-volt>)
    Vehicle network voltage applied during the test. It will only be defined if it deviates from the standard test voltage.
  • Equivalent resistance RS (<substitute-res>)
    The compensating resistance simulates the direct current resistance of consumers which cannot be switched off in the vehicle network.
  • Operating state (<oper-mode-refs>)
    The operating state defines the state of the system at which the test is performed. If the test is to be performed with various operating states, these can be grouped.
  • Additional specifications (<add-info>)
    Apart from the a.m. specifications, it is always possible to give additional specifications for a test. These include, e.g., a test temperature which differs from general specifications, the test set-up and further specifications which have not been defined yet.
Figure 39: Structure of a laboratory test
Example for content:
Test pulse: 1
Requirement examples for interference emissions
Denomination | Abbreviation | Min | Type | Max | Abs | Tolerance | Unit
 | <short-name> | <min> | <typ> | <max> | <abs> | <0tol> | <unit>
Severity level |  |  |  |  | 4 |  |
Peak voltage | Us |  |  |  | -30 |  | V
Test voltage | UP |  |  |  | 12 |  | V
Equivalent resistance | RS |  |  |  | 40 |  | W
Operating state : Switched on
Additional specifications:
Pulse which rises when switching off inductive loads.
Definition test pulse 1
Denomination | Abbreviation | Min | Type | Max | Abs | Tolerance | Unit
 | <short-name> | <min> | <typ> | <max> | <abs> | <0tol> | <unit>
Pulse rise time | tr |  |  |  | 1 |  | ms
Pulse duration | td |  |  |  | 2 |  | ms
Definition of test pulses
Test pulses for the description of the interference emission according to DIN 40839 part 1
Test pulse | tr | td
Unit | µs | ms
E1 | 1 | 2
E2 | 1 | 0.2
E3 | 0,05 | -
E4 |  |
E5 |  | 400
new |  |
Apart from the pulses E1 to E5, not standardized pulses can be defined, too. Since for these pulse forms no parameters can be defined yet, the description of theses pulses can be given in textual or in graphical form.
The characteristic test pulses are subdivided into interference emission grades via the pulse amplitude Us.
Determination of interferences emission grades for characteristic pulses via admissible pulse amplitudes according to DIN 40839 part 1
Characteristic pulses | Admissible pulse amplitude U s in volts at interference emission grade (for 12/24V vehicle network voltage)
 | IV | III | II | I
Pulse E1 | -100 /-200 | -75/-150 | -50/-100 | -25/-50
Pulse E2 | +100 | + 75 | + 50 | + 25
Pulse E3 (a) | -150/-200 | -110/-140 | -75/-70 | -40/-35
Pulse E3 (b) | + 100 | + 75 | + 50 | +25
Pulse E5 | +120/200 | +80/150 | +50/100 | +35/70
The severity levels depend on the vehicle network voltage. Further user-defined or in-house standard specific severity levels with corresponding voltages U s can be defined to given test pulses.
Apart from the pulse-shaped interference emission, a continuous interference emission can be defined, too. Generator ripple counts among these emissions. The interference emission of the generator ripple defines the max. admissible disturbance of the vehicle network by the generator. This is only required in case of the generators. In order to obtain reproducible results, the test installation should be described by the conduction lengths, the conduction cross sections, the generator revolutions, the generator outputs, the load resistance, the charge current, the battery type and the state of the battery. Within this test, the parameters load, range of revolutions, generator output etc. are submitted to complex interaction. Thus at present it is not possible to define parameters for this test with simple means. The description for this requirement will be given in a textual or in a graphical way.


9.4.2.2. Test in vehicle

<inter-emi-vehicle-test>
An interference emission is an interference emitted by the DUT onto the vehicle network. When performing tests in vehicle, the built-in component is investigated. The interferences in the wiring harness will be observed. The following specifications can be given for an interference emission test.
  • Test pulse
    Characteristic test pulses defined in [Test pulses for the description of the interference emission according to DIN 40839 part 1] can be chosen. If the test pulse is described by detailed parameters, an adaptation of the parameter values corresponding to the test pulse is possible, just as during the laboratory tests.
  • Severity level and corresponding peak voltage for the test pulse
    Severity levels defined in [Determination of interferences emission grades for characteristic pulses via admissible pulse amplitudes according to DIN 40839 part 1] can be chosen. The specification of the severity level is only required in case of standard pulses.
  • Test voltage (<test-volt>)
    Vehicle network voltage applied during the test. It will only be defined if it deviates from the standard test voltage.
  • Operating state (<oper-mode-refs>)
    The operating state defines the state of the system at which the test is performed. If the test is to be performed with various operating states, these can be grouped.
  • Additional specifications (<add-info>)
    Apart from the a.m. specifications, it is always possible to give additional specifications for a test. These include, e.g., a test temperature which differs from general specifications, the test set-up and further specifications which have not been defined yet (see Concepts of the MSR application profile V1.x.x).
Figure 40: Structure of a vehicle test
Example for content:
See example in chapter 9.4.1.1.1.1. Laboratory tests.


9.5. Interferences by radiation

<inter-rad>
The description of the requirements for interferences by radiation is performed in compliance with [DIN 40 839-4;DIN 40 839-4;;all;]. It includes requirements and tests in order to guarantee electromagnetic compatibility (EMC) of electronic components with respect to interferences which can couple into power supply conductions and signal conductions and/or into electronic vehicle units.
The a.m. standard describes the measurement of electromagnetic fields, the test set-up; furthermore it gives advice concerning limit values (frequency range and field strength).
Figure 41: Structure of interferences by radiation


9.5.1. Measuring methods

<mea-methods>
The measuring method describes the test devices with which the DUT is tested regarding EMC. A measuring method is described by a denomination and the description of the method.
Figure 42: Structure of the measuring method
Example for content:
Measuring method: TEM cell
Measuring equipment: TEM cell
Additional specifications to the measuring equipment:
Figure 43: Measuring set-up for interference radiation in the TEM cell
Additionally, further user-defined and in-house standard specific measuring methods can be specified.


9.5.2. Interference strength level

<inter-immunity-level>
The interference strength level is specified (as defined in the definition, see [Interference strength levels during the measurement in the stripline or in the TEM cell .]). The corresponding field strength can be taken from the respective standard.
Figure 44: Structure of interference strength level
During the measurements in the stripline and in the TEM cell the given function states have to be observed up to the following limit values for field strength, which are determined according to frequency band, DUT and measuring method. The limit values are effective values of the unmodulated carrier.
Example for content:
Interference strength level 1 Measuring method: TEM cell. [(Assignment);DIN 40839-4;;all;])
Interference strength levels during the measurement in the stripline or in the TEM cell .
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
Field strength | E |  |  |  | 25 |  | V/m
Interference strength level 2 Measuring method: TEM cell
Interference strength levels during the measurement in the stripline or in the TEM cell (assignment
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
Field strength | E |  |  |  | 50 |  | V/m
Interference strength level 3 Measuring method: TEM cell
Interference strength levels during the measurement in the stripline or in the TEM cell (assignment
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
Field strength | E |  |  |  | 100 |  | V/m
During the measurements with current supply, the given function states have to be observed up to the following limit values for power on the wiring harness, which are determined according to frequency band and DUT. The limit values are valid for the unmodulated carrier.
Example for content:
Interference strength level 1 Measuring method: Current supply
Interference strength levels during the measurement in the stripline or in the TEM cell (assignment DIN 40839, part 4).
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
Power CW signal | P |  |  |  | 20 |  | dBm
Interference strength level 2 Measuring method: Current supply
Interference strength levels during the measurement in the stripline or in the TEM cell (assignment
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
Power CW signal | P |  |  |  | 25 |  | dBm
Interference strength 3 Measuring method: Current supply
Interference strength levels during the measurement in the stripline or in the TEM cell (assignment
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
Power CW signal | P |  |  |  | 30 |  | dBm
Additionally, further user-defined or in-house standard specific interference strength levels can be specified.


9.5.3. Frequency band, step width and dwell time

<frequency-bands>
A frequency band is a frequency range with a denomination.
Statements concerning step width and dwell time can optionally be specified ( see also DIN 40 839-4).
The DUT can be tested in different frequency ranges with corresponding requirements. The frequency bands can be specified including the relative or the absolute step width Df and the dwell time during the test (as given in the definition Representation example for frequency bands (I)).
Figure 45: Structure of a frequency band
Example for content:
Frequency band: I
Representation example for frequency bands (I)
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
Frequency range | f | 1 |  | 10 |  |  | MHz
Step width | s |  |  |  | 1 |  | MHz
Dwell time | t |  |  |  | 2 |  | sec
Frequency band: II
Representation example for Frequency bands (II)
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
Frequency range | f | 10 |  | 30 |  |  | MHz
Step width | s |  |  |  | 1 |  | MHz
Dwell time | t |  |  |  | 2 |  | sec
Frequency band: III
Representation example for frequency bands (III)
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
Frequency range | f | 30 |  | 80 |  |  | MHz
Step width | s |  |  |  | 1 |  | MHz
Dwell time | t |  |  |  | 2 |  | sec
Additionally, further user-defined or in-house standard specific frequency bands can be created.


9.5.4. Modulation

<modulations>
The modulation is defined in DIN 40 839-4. The following data are necessary for a complete description:
Figure 46: Structure of modulation
Example for content:
Modulation: 80% 1kHz Modulations type: AM
Description example for amplitude modulation
Denomination | Abbreviation | Min | Type | Max | Abs | Tol | Unit
Modulation level | m |  |  |  | 80 |  | %
Modulation frequency | f |  |  |  | 1 |  | kHz


9.5.5. Laboratory tests

<inter-rad-lab-test>
Within the test in laboratory, the interference strength of the DUT with respect to interferences by radiation is tested. In case of an interference strength test, the behaviour of the DUT is tested by submitting it to different field strengths. The following specifications can be made for an interference strength test:
  • measuring method (<mea-method-ref>)
  • Interference strength level (<inter-immunity-level-ref>)
  • frequency bands (<frequency-band-refs>)
  • modulation (<modulation-ref>)
Apart from AM, also sampling and FM can be defined.
  • Operating state (<oper-mode-refs>)
    The operating state defines the state of the system at which the test is performed. If the test is to be performed with various operating states, these can be grouped.
  • Function state (<function-state-ref>)
    The assignment of a function state to the test is accomplished by a code letter (A...E).
  • Fault description (<failure-desc>)
    The failure mode of the system will be described in textual form, in addition to the function state (if it is not equal to A).
  • Additional specifications (<add-info>)
    Apart from the a.m. specifications, it is always possible to give additional specifications for a test. These include, e.g., a test temperature which differs from general specifications, the test set-up, the description of the coupling clamp and further specifications which have not been defined yet.
Figure 47: Structure of a laboratory test
Example for content:
Description example for interference by radiation, test in laboratory
Measuring method | Interference strength level | Frequency band | Modulation | Operating states | Function state | Fault description
TEM cell | 5 | I | 80% 1kHz | Idle running Full load | A |
TEM cell | 4 | II III | 80% 1kHz | Idle running Full load | A |
TEM cell | 3 | IV V | 80% 1kHz | Idle running Full load | A |
Here, for every measuring method, the test set-up and the settings of measuring instruments can be described by means of text, tables and graphics.


9.5.6. Test in vehicle

<inter-rad-vehicle-test>
When performing tests in vehicle the built-in component will be exposed to interferences by radiation. Following specifications can be made to describe the test:
  • Measuring method (<mea-method-ref>)
  • Interference strength level (<inter-immunity-level-ref>)
  • Frequency band (<frequency-band-refs>)
  • Modulation (<modulation-ref>)
  • Operating state (<oper-mode-refs>)
  • Function state (<function-state-ref>)
  • Fault description (<failure-desc>)
    The failure mode of the system will be described in textual form, in addition to the function state (if it is not equal to A).
  • Additional specifications (<add-info>)
    Apart from the a.m. specifications, it is always possible to give additional specifications for a test. These include, e.g., a test temperature which differs from general specifications, the test set-up, the description of the coupling clamp and further specifications which have not been defined yet.
Figure 48: Structure of a vehicle test
Example for content:
See chapter 9.5. Interferences by radiation.


9.5.7. Additional measurements

<add-mea>
For technical reasons, not all types of influence can be covered, neither in laboratory nor in the absorber lined chamber. For acceptance investigations, additional vehicle tests can be necessary, e.g.:
  • Measurements in front of medium wave transmitter radio stations (e.g. Europawelle Saar Hausweiler)
  • Measurements in front of short-wave high-power transmitter radio stations
  • Measurements with portable radio sets
Since the requirements differ a lot from each other and depend on the utilization possibilities of the respective type of vehicle, here the description of this requirement is not specified in more detail.
The following specifications, e.g., could be included in additional measurements:
  • Frequency range, step width, power, modulation,...
  • Test installations for mobile telephones (C-network, D-network, E-network),...
  • Operating state, function state, fault description,...
  • etc.
Structure:
Figure 49: Structure of additional measurements


9.6. Interference suppression

<radio-inter-supp>
The reason for interference suppression is the possible occurrence of electrical interferences in vehicle networks originated by various consumers, which may interfere onto radio devices in a conduction-guided way or by radiation. A distinction is made between long-distance and short-distance interferences.
Long-distance interferences (<remote-radio-inter>) are interferences (coming from the vehicle) of radio devices outside the vehicle.
Short-distance interferences (<short-inter-supp>) are interferences which affect radio devices mounted and operated inside the vehicle.
The requirements to interference suppression are described according to [DIN VDE 0879-1;DIN VDE 0879-1;;3;] and [DIN 57879-1;DIN 57879-1;;3;].
Figure 50: Structure of interference supression


9.6.1. Short-distance interference suppression

<short-inter-supp>
Short-distance interference is a high-frequent interference of the radio reception; it occurs, when undesirable electromagnetic oscillations in the high-frequent reception channel of a radio reception antenna system or of a radio receiver, are received together with the useful signal via the antenna, or, the antenna input at the device, and affect the reproduction of the useful signal in a perceptible way.
Short-distance interferences can be conduction-guided or received by the vehicle's own antenna. For the conduction-guided interferences, a degree of suppression concerning the frequency ranges long wave, medium wave, short wave and ultra short wave is required. For interferences received via antenna, the admissible interference voltage levels are given regarding the reception ranges (long wave - ultra-short wave and portable radio sets). A difference is made between wide-band interference sources and narrow-band interference sources.
Figure 51: Structure of short-distance interference suppression


9.6.1.1. Laboratory tests

<short-inter-supp-lab-test>
When performing short-distance interference tests in laboratories, the output interferences of a component are investigated.
The following specifications can be made for laboratory tests.
  • Measuring method
    The measuring method describes the measuring equipment applied to the DUT regarding its interference emission. There are two typical measuring methods:
    1. Measurements of conduction-guided interference voltages on the artificial network
      This measuring method is applied at those vehicle components which emit the major part of the interference energy via the power supply conductions (e.g., radiator fan, interior ventilation, fuel pumps and vehicle generators).
    2. Measurement of interferences by radiation in the TEM cell
  • Measuring equipment
    At this place, the used measuring equipment can be described. Typical measuring equipment are, e.g., measuring receiver and spectrum analyser. The exact documentation of the setting of the measuring equipment should be made after the test set-up.
  • Measuring band width
    1. Wide-band interference
      A wide-band interference is a band width of an interference signal which is equal to or bigger than the chosen measuring band width of the interference measuring receiver.
    2. Narrow-band interference
      A narrow-band interference is a band width of an interference signal which is smaller than the chosen measuring band width of the interference measuring receiver.
  • Frequency band
    The frequency band can be designated here (e.g. long wave, medium wave, short wave, L, M, ...)
  • Frequency range
    Specification of the frequency range.
  • Interference suppression level
    The interference suppression level defines a value for the maximum interference voltage (see (Interference suppression levels)).
  • Operating state
    The operating state defines the state of the system at which the test is performed. If the test is to be performed with various operating states, these can be grouped.
  • Additional specifications
    Apart from the a.m. specifications, it is always possible to give additional specifications for a test.
Figure 52: Structure of a laboratory test
Example for content:
The following table shows an example for the description of the narrow-band interference. The values have partially been taken from [(Interference suppression levels);DIN 57 879;;Part 3;].
Examples for interference suppression levels for measurements on the artificial vehicle network
Measuring method | Measuring bandwidth | Radio frequency band | Interference suppression level | Operating states
Artificial network | Broadband | LW | 5 | Idle running Full load
Artificial network | Broadband | MW KW | 4 | Idle running Full load
Artificial network | Broadband | UKW | 3 | Idle running Full load
Structure of the measuring method
See [9.5.5. Laboratory tests]
Example for content:
Measuring method: Artificial network
Measuring device: Artificial network
Additional specifications for the measuring device:
Assembly and ground arrangement in the vehicle have to be simulated.
The maximum interference voltage has to be identified by modifying load and the number of revolutions.
Figure 53: Measuring set-up for measuring a consumer
1. Voltage supply
2. Artificial network; casing electrically connected to part 5
3. Interference measuring receiver; 50 W - Direct impedance
4. Measuring object in mounting position
5. Sheet metal plate; minimum dimensions (width*height in mm): 1000*400
Thickness (in mm): 1.0 (+/- 0.2)


9.6.1.2. test in vehicle

<short-inter-supp-vehicle-test>
For the vehicle test, the vehicle will be positioned in a shielded room (nevertheless, measurements at open air are possible, too). The connection of the measuring receiver is made at the artificial radio at the radio mounting place.
For measurements inside the vehicle, the antennas and mounting places which are used in the production series, should be utilized. Regarding an interference-free radio reception inside the vehicle, the distance between useful signal and interference signal should be sufficiently high at the end of the antenna cable.
During the vehicle test, a maximum interference voltage will be given, which should not be exceeded at the end of the antenna cable which is closed with a resistance.
Voltage characteristics represents possible requirements. The valid values can be gathered from the respective standard, or can be determined in concordance with the EMC department.
  • Measuring methods
    The measuring method describes the test equipment with which the DUT is tested regarding its interference emission. There are two typical measuring methods:
    1. Absorber lined chamber
    2. Open air
    Measuring device
    Here, the used measuring equipment can be described. Typical measuring equipment are, e.g., measuring receiver and spectrum analyser. The exact description of the setting of the measuring equipment should be documented after the test set-up.
  • Measuring band width
    1. Wide-band interference
      A wide-band interference is a band width of an interference signal which is equal to or bigger than the chosen measuring band width of the interference measuring receiver.
    2. Narrow-band interference
      A narrow-band interference is a band width of an interference signal which is smaller than the chosen measuring band width of the interference measuring receiver.
  • Frequency band
    The frequency band can be designated here (e.g. long wave, medium wave, short wave, L, M, ...)
  • Frequency range
    Specification of the frequency range.
  • Interference suppression level
    The interference suppression level defines a value for the maximum interference voltage (see (Interference suppression levels)).
  • Operating state
    The operating state defines the state of the system at which the test is performed. If the test is to be performed with various operating states, these can be grouped.
  • Additional specifications
    Apart from the a.m. specifications, it is always possible to give additional specifications for a test.
Structure of a vehicle test:
See Structure of a laboratory test
Example for content:
Examples for interference suppression levels for measurings on the artificial vehicle network
Measuring method | Measuring band width | Radio frequency band | Interference suppression level | Operating states |
Artificial network | Broadband | LW | 5 | Idle running Full load | 2
Artificial network | Broadband | MW KW | 4 | Idle running Full load | 2
Artificial network | Broadband | UKW | 3 | Idle running Full load | 1
  1. Concluding subjective assessment of the interference suppression of ultra-high frequency range in open-air:
    The interference should not be heard in the entire frequency range, station finding should not lock.
  2. Concluding subjective assessment of the interference suppression of long wave, medium wave and short wave range in open-air:
    Radio stations which can be received well should be free of interferences.
Structure of the device description "Open air":
See [9.6.1. Short-distance interference suppression].


9.6.2. Long-distance interference suppression

<remote-radio-inter>
A long-distance interference is an interference of a radio device outside the vehicle generated by a vehicle. This is always a high-frequent interference energy radiated by the vehicle.
The standards [ECE 10;ECE 10;;all;] or [VDE 879-1;VDE 879-1;;all;] determine limit values for the maximum admissible radio interference field strength. Furthermore, they define all other specifications, such as antenna, measuring equipment, operation modes, test amount etc.
The requirements in the performance specification should be described by means of text, tables and graphics; existing standards should be mentioned.
Figure 54: Structure of long-distance interference suppression


9.7. ESD

<electrostatic-discharge>
Electrostatic discharge (ESD) is based upon the charge of two insulating materials by friction. If the charged object comes near to a conducting object, the potential discharges by a spark that goes over to that conductor. The very fast compensating currents and the electromagnetic fields which are generated by this, are able to permanently damage electronic components.
The "human-body model" is used for testing the ESD strength of electronic components. It simulates the discharge of a human being with the capacitance C via his skin with the resistance R. For the area of vehicle electronics, the standard [ISO/CD 10605;ISO/CD 10605;;all;] can be applied. ESD requirements can be defined with the following specifications:
Test plan, Test set-up, Operating states, fault criteria, fault description, laboratory tests, and inside or outside the vehicle.
Figure 55: Structure of ESD


9.8. EMC design

<emc-design>
Design requirements and constructive measures in order to guarantee electromagnetic compatibility of electrical and electronic components early in time are discussed in the EMC design.
Figure 56: Structure of EMC design


9.8.1. Conduction types and conduction arrangements

<kind-wire-arrangement-wiring>
During the design of the wiring network, the electrical leads and the connection techniques can be given, or defined, according to their function in the vehicle.
Figure 57: Structure of conduction types and conduction arrangements
Example for content:
  • Conductions without EMC functions: Unshielded single conductions and multiple conductions, flat ribbon conductions, ground plug-in connections.
  • Conductions with EMC functions (e.g. signal conductions): twisted conductions, shielded conductions, twisted and shielded conductions, coaxial conductions, screwed ground connections.
Furthermore, specifications concerning conduction arrangements can be made, in order to avoid electromagnetic radiation and coupling-in of interferences, e.g.:
  • Arrangement near ground surfaces
  • Extra ground wires
  • Parallel arrangement of inward and outward conductors
  • Separate conduction of signal conductors and power supply conductors


9.8.2. Signal waves on vehicle network

<signal-form-vehicle-electronic>
Within the transmission of data and electrical power via the vehicle network, these signals often are in a pulsed, periodic form. In order to reduce the radiation originated by these signals, general marginal conditions concerning their rise and drop times can be defined.
The signal characteristics will be defined generally for all interfaces. Furthermore, they can be defined contrary to this specification in the description of the interfaces for every connection. The signal characteristics can be defined by the parameters maximum voltage alteration and/or maximum current alteration.
Figure 58: Structure of signal waves on vehicle network
Example for content:
Examples for limit values for signal waves on vehicle network
Denomination | Abbreviation <short-name> | Min <min> | Type <typ> | Max <max> | Abs <abs> | Tolerance <tol> | Unit <unit>
Voltage change | dU/dt |  |  | 100 |  |  | V/ms
Current change | dI/dt |  |  | 10 |  |  | A/ms


9.8.3. Ground concept

<ground-concept>
The ground concept describes EMC measures with respect to ground conductions, ground layout, ground connection points in the system and inside the vehicle. The description of the requirements can be given in textual or in graphical form.
Figure 59: Structure of the ground concept


9.8.4. Vehicle antennas

<vehicle-antenna>
Here, descriptions concerning broadcast receiving antennas and mobile radio antennas can be inserted.
The description of the requirements can be given in textual or in graphical form.
Figure 60: Structure of vehicle antennas


9.8.5. EMC hardware measures

<emc-hardware-design>
The hardware measures describe means to improve EMC which can be realized with the use of hardware. Among these are, e.g.:
  • Filtration and protection wiring of inputs and outputs and supply conductions
  • Shielding measures
  • Printed circuit board layout
  • Integration of anti-interference capacitors
  • Influence of the different modes of operation (e.g. 2-wire-CAN)
  • Selection of quartzes
  • others
For the selection of quartzes, the requirements can be defined as shown in Representation example for forbidden frequency ranges for the use as oscillating circuit frequency, data transmission frequency or working frequency.
Figure 61: Structure of EMC hardware measures
Example for content:
Representation example for forbidden frequency ranges for the use as oscillating circuit frequency, data transmission frequency or working frequency
Frequency | Distance | Function
4.6 MHz | 50 kHz | Duplex distance in the 2m band
5.0 MHz | + 50 kHz | Duplex distance in the 70 cm band
5.5 MHz | + 50 kHz | TV-picture-sound carrier distance
9.8 MHz | + 50 kHz | Duplex distance in the 4m band
10.0 MHz | + 50 kHz | Duplex distance in the 2m band
10.7 MHz | + 50 kHz | Intermediate frequencies in case of wireless equipments, radio sets
21.4 MHz | + 50 kHz | Intermediate frequencies in case of wireless equipments
45.0 MHz | + 50 kHz | Duplex
auto-defined | auto-defined | auto-definable frequencies
The description of the requirements can be given in textual or in graphical form.


9.8.6. EMC software measures

<emc-software-design>
Here, EMC software measures are represented (e.g. filtration of signals realized in software, temporary deactivation of single circuit components). The description of the requirements can be given in textual or in graphical form.
Figure 62: Structure of EMC software measures


9.9. Further properties

<add-spec>
Further properties are properties which ought to be mentioned in the topic Electrical compatibility, but which cannot be expressed thematically in any of the subdivision points mentioned above.
Figure 63: Structure of additional specifications


10. Environmental Characteristics

Structure Principles of the MSRSYS DTD
10. Environmental Characteristics

Contents of this chapter:
  • 10.1. Mechanical properties
  • 10.2. Climatic characteristics
  • 10.3. Chemical characteristics


10.1. Mechanical properties


10.1.1. Static strength


10.1.1.1. Torsional strength

<torsional-strength>
Torsional strength is tested, for example, for infrared emitters, for detachable radio front plates and for keys. The test simulates a single maximum torsional stress. The test is defined either by a maximum torque or by a maximum angle.
Figure 64: Structure of torsional strength
Example for content:


10.1.1.2. Compression and tensile strength

<compr-tensile-strength>
The compression and tensile strength defines the maximum compression or tensile load for the device under test (DUT). The test is defined either by a maximum power or by a maximum displacement. DUTs can be, for example, switches or steering levers.
Figure 65: Structure of compression and tensile strength
Example for content:


10.1.1.3. Additional tests

<add-tests>
Further tests can be described here.
Figure 66: Structure of additional tests


10.1.2. Dynamic strength


10.1.2.1. Vibration

<vibration>
Basis: [ Environmental Testings Part 2: Testing;Test Fc; Vibration Sine;IEC 60068-2-6;;all;]
The test shall simulate the fatigue load of the DUT in X-, Y- and Z-axes. In general, the test is carried out in vehicle mounting position with the provided fixing elements.
Currently, different forms of description are used:
  1. The controlled variable is the displacement amplitude
    Specification of frequency range, sweep rate and vibration amplitude (in [mm], fixed over the entire frequency range; acceleration in [g], is then a function of these parameters).
  2. The controlled variable is the velocity amplitude
  3. The controlled variable is the acceleration amplitude
    Specification of frequency range, sweep rate and acceleration value. The vibration amplitude (in [mm]) is then a function of these parameters. Thus, selective vehicle-specific critical frequencies can be tested (not possible with 1).
  4. Mixed controlled variables
    The frequency range is divided into intervals. For each interval, the controlled variable can be defined according to 1., 2. or 3.
Figure 67: Structure of vibration
Example for content:
Type of vibration:
Sine-shaped vibration
Test axes:
...
Sweep rate:
df / dt Sweep rate
ABS = 1 octave/min
Number of cycles:
...
Controlled variable
Complex controlled variable:
10 - 100 Hz: 2g (fmin) - 5g (fmax)
100 - 350 Hz: 5g
operating states:
2.1
evaluation criteria
input criteria:
Before the beginning of tests the DUTs should approve the intermediate tests and not show any mechanical damages.
output criteria:
The test has been successful if the DUTs show a plausible behaviour defined according to the drawing. After the test, the parameters of the intermediate test must be within the specified limits. The DUTs have to be visually inspected after testing. Mechanical damages are not admissible.
Additional specifications:
Visual inspection before testing.
The DUTs have to be mounted at their original connection points.
Continuous supervision of the DUTs during the test.
Begin of test at ambient temperature.
Repetition of the test in the other two geometrical axes.


10.1.2.2. Wide band random vibration

<vibration-random-wide-band>
[IEC 60068-2-34;IEC 60068-2-34;;all;], [IEC 60068-2-37;IEC 60068-2-37;;all;] [DIN 40046;DIN 40046;;Part 22 - 25;].
The test shall simulate the fatigue load of the DUT in the X-, Y- and Z-axes. In general, the test is carried out in vehicle mounting position with the provided fixing elements.
The crest factor is the quotient of the maximum acceleration and the effective value of the acceleration.
Figure 68: structure of wide band random vibration test
Example for content:
Type of vibration:
Wide band random vibration
Test axes:
...
Frequency range:
f Frequency range
MIN = 10 Hz
MAX = 1000 Hz
Load duration:
t Load duration
ABS = 8 h per axis
Effective value of acceleration:
aeff Effective value of acceleration
ABS = 38,1 m/s2
Crest factor:
CF crest factor
ABS = 3,0
Form of the spectrums:
10 - 50 Hz: G(f)=0,2 g2 / Hz constant
50 - 66,7 Hz: G(f)=0,2 to 0,02 g2 / Hz decreasing by -24 dB / octave.
66,7 - 100 Hz: G(f)=0,02 g2 / Hz constant
100 - 1000 Hz: G(f)=0,02 to 0,002 g2 / Hz decreasing by -3 dB / octave.
Ambient conditions
Test temperature profile:
...
Operating states:
2.2
Evaluation criteria
Input criteria:
The previous function test is regarded as an electrical evaluation. The cases have to be examined for hair cracks and deformations.
Pass-through criteria:
No interference may arise during the test.
Output criteria:
The test is approved if the device parameters which correspond to the function of the DUT are within the specified limits after the application of load. The visual inspection includes control with respect to cracks and other mechanical damages.
Additional specifications:
When passing the lower stress temperature, the DUTs have to be disconnected.


10.1.2.3. Shock

<shock>
Basis: [IEC 60068-2-27;IEC 60068-2-27;;all;]
Serves for testing components which are mounted in hoods, doors, steering knuckles or, generally, are located near lockings.
Figure 69: Structure of a shock
Example for content:
Form of excitation:
Half-sine
Acceleration amplitude:
a Acceleration amplitude
ABS = 100 g
Load duration:
t Load duration
ABS = 6 ms
Number of loads:
3
Ambient conditions
Other conditions:
Test temperatures are -40 °C, ambient temperature and 90 °C.
Operating states:
1.2
Evaluation criteria
Input criteria:
The approval of the previous function test is regarded as an electrical evaluation. Furthermore, the device is examined with respect to mechanical changes.
Output criteria:
The test is approved if the device parameters corresponding to the function of the DUT are within the specified limits after shock testing.
Cracks and other mechanical damages are not admissible.
Additional specifications:
Loads are applied per direction and per temperature.
Visual inspection of the DUT.
Pre-heating of the devices until reaching test temperature. The minimum dwell time at this temperature is one hour before beginning the shock test. The shock test has to be terminated at the latest 2 minutes after taking the DUT out of the conditioning temperature.
Repetition of this process at the other two test temperatures.
Visual inspection of the DUTs after the test end.


10.1.2.4. Continuous bump

<bump>
Basis: [Environmental Testing; Part 2: Tests; Test Eb and Guideline Continuous Bump;DIN IEC 60068-2-29;;all;]
Serves, in most cases, for testing components which are mounted in hoods, doors, steering knuckles or, generally, are located near locking devices.
Figure 70: Structure of continuous bump
Example for content:
Form of excitation:
Half-sine
Acceleration amplitude:
a Acceleration amplitude
ABS = 25 g
Load duration:
t Load duration
ABS = 6 ms
Number of loads:
330
Ambient conditions
Other conditions:
Test temperatures are -40 °C, ambient temperature and 90 °C.
Operating states:
1.2
Evaluation criteria
Input criteria:
The approval of the previous function test is regarded as an electrical evaluation. Furthermore, the device is examined with respect to mechanical changes.
Output criteria:
The test is approved if the device parameters corresponding to the function of the DUT are within the specified limits after the shock test.
Cracks and other mechanical damages are not admissible.
Additional specifications:
Loads are applied per direction and per temperature.
Visual inspection of the DUT.
Pre-heating of the devices until reaching the test temperature. The minimum dwell time at this temperature is one hour before the begin of the shock test. The shock test has to be terminated at the latest 2 minutes after taking the DUT out of the conditioning temperature.
Repetition of this process at the other two test temperatures.
Visual inspection of the DUTs after the test end.


10.1.2.5. Cyclic torsional strength

<cyclic-torsional-strength>
The cyclic torsional strength is tested, for example, for infrared emitters, for detachable radio front plates and for keys. The test simulates the load for the whole service life of the DUT. The test is defined either by a maximum torque or by a maximum angle.
Figure 71: Structure of cyclic torsional strength
Example for content:


10.1.2.6. Additional tests

<add-tests>
Further tests can be described here.
Figure 72: Structure of additional tests


10.1.3. Free fall

Basis: [Evironmental Testing Part 2: Tests; Test Ed; Free Fall;IEC 60068-2-32;;all;]
The test <free-fall> is a simple method to simulate the effect of an impact due to rough handling.
In the course of the test, for each DUT the test axes with their corresponding directions are defined.
Figure 73: Structure of free fall
Example for content:
Fall height:
h Fall height
ABS = 1,0 m
Soil:
Concrete
Number of DUTs:
3
Test course:
The DUTs have to be marked clearly before testing. At the first cycle, every DUT has to be loaded in a different main axis.
At the second cycle, the other side of the same axis has to be chosen.
Representation example for a free fall test
DUT | Load |
 | 1 | 2
1 | X-axis | -X-axis
2 | Y-axis | -Y-axis
3 | Z-axis | -Z-axis
Ambient conditions
Other conditions:
Ambient temperature
Operating states:
1.1
Evaluation criteria
Input criteria:
The previous function test is regarded as an electrical evaluation. The cases have to be examined with respect to hair cracks and deformations.
Output criteria:
The test is approved if the device parameters corresponding to the function of the DUT are within the specified limits.
Furthermore, an evaluation of the mechanical structure has to be carried out. Cracks, hair cracks, deformations or broken-off case parts are not admissible. The regular mounting into the vehicle should not be hampered.


10.1.4. Surface strength


10.1.4.1. Scratch resistance

<scratch-res>
This test serves to prove the scratch resistance of visible front surfaces of cases, keys, displays, letterings, stickers, etc. The test can be carried out with the Erichsen hardness test bar.
Figure 74: Structure of scratch resistance
Example for content:
Type of test bar:
Type 318
Diameter of penetrator:
d diameter of penetrator
ABS = 0,75 mm
Load:
F load
ABS = 5 N
Test temperature:
TP Test temperature
ABS = 23 °C -/+ 5 K
Evaluation criteria
Output criteria:
After the test, there should not be any visible surface damage.


10.1.4.2. Abrasion resistance


10.1.4.2.1. Stickers, common surfaces

Structure Principles of the MSRSYS DTD
10. Environmental Characteristics
10.1. Mechanical properties
10.1.4. Surface strength
10.1.4.2. Abrasion resistance
10.1.4.2.1. Stickers, common surfaces

<stickers-common-surfaces>
This test serves to prove the abrasion resistance of stickers and common surfaces. This test can be carried out with the crockmeter according to [DIN 54021;DIN 54021;;all;].
Figure 75: Structure of stickers and common surfaces
Example for content:
Number of strokes:
...
Number of DUTs:
...
Test temperature:
TP Test temperature
ABS = 23 °C -/+ 5 K
Pre-treatment:
Roll on sticker with 5kg steel roll onto grease-free surface. Move roll in 5s once forward and once backward over the conglutination. Cure DUT for 2 hours at normal atmosphere according to DIN 50 014.
Evaluation criteria
Output criteria:
Comparison table according to DIN 54021 for colour changes at the probe.


10.1.4.2.2. Buttons, resistance to synthetical sweat solution with abrasion

Structure Principles of the MSRSYS DTD
10. Environmental Characteristics
10.1. Mechanical properties
10.1.4. Surface strength
10.1.4.2. Abrasion resistance
10.1.4.2.2. Buttons, resistance to synthetical sweat solution with abrasion

<buttons-switches-displays>
This test serves to prove the abrasion resistance of hand-operated buttons, switches, touch-displays and of interior parts with inscriptions. The test can be carried out with a testing device similar to [DIN 40046-59;DIN 40046-59;;all;].
Figure 76: Structure buttons,switches, displays
Example for content:
Stroke frequency:
...
Stroke length:
...
Contact force:
...
Number of strokes:
10.000
Friction medium:
Felt according to [DIN 61200;DIN 61200;;all;], hardness H1, diameter and thickness = 10mm
Test medium:
Synthetical sweat solution according to [DIN 53160;DIN 53160;;all;].
Number of DUTs:
...
Test temperature:
TP Test temperature
ABS = 23 °C -/+ 5 K
Pre-treatment:
Not applicable.
Evaluation criteria
Output criteria:
No visible abrasion.


10.1.5. Strength of interfaces

<interface-strength>
The requirements to the forces of plugging on and pulling off of all plug-in connections, with and without joining device, and of contact pairs are defined here.
The requirements to forces of plugging on and pulling off of are defined here.
Figure 77: Structure of interface strength


10.1.6. Further properties

<add-spec>
Further tests can be described here.
Figure 78: Structure of additional specifications


10.2. Climatic characteristics


10.2.1. Temperature


10.2.1.1. Operating temperature

<oper-temp-spec>
Description of the temperature range for operation. Limitations of functions can be described in the marginal conditions to the parameters.
The relation range designates the measuring point/measuring range for the temperature.
Figure 79: Structure of operating temperature specification
Example for content:
Operating temperature:
TB Operating temperature
MIN = -40 °C -0+2 K
MAX = 130 °C -2+0 K
Reference range:
Operating temperature measured as ambient temperature of control device.


10.2.1.2. Storage temperature

<store-temp-spec>
Description of the temperature range for storage.
Figure 80: Structure of storage temperature specification
Example for content:
Storage temperature
constant:
TLd constant storage temperature
MIN = -40 °C -0+2 K
MAX = 80 °C -2+0 K
short-time:
TLk short-time storage temperature
MAX = 90 °C -2+0 K
tLk Dwell time
ABS = 1 h


10.2.2. IP-Protection class/protection against foreign bodies, touch and water

<prot-class-char>
Basis: [IP-Protection;IEC 60529;;all;],DIN 40050-9
The IP protection class describes the penetration protection against foreign bodies, contact and water, and implicitly determines tests to be carried out. If necessary, deviations from the standard can be documented in the structural part <temp> or in the section 10.2.3.1. Temperature storage, designated for this purpose.
Figure 81: Structure of protection class test
Example for content:
IP protection class:
IP34K
[DIN 40050-9;DIN 40050-9;;all;].


10.2.3. climatic characteristics tests


10.2.3.1. Temperature storage


10.2.3.1.1. Low temperature storage

Structure Principles of the MSRSYS DTD
10. Environmental Characteristics
10.2. Climatic characteristics
10.2.3. climatic characteristics tests
10.2.3.1. Temperature storage
10.2.3.1.1. Low temperature storage

<low-temp-store>
[(Dry coldness);IEC 60068-2-1;;all;]
A test according to the standard is described and performed.
Figure 82: Structure of low temperature storage
Example for content:
Test temperature:
TP Test temperature
ABS = -40 °C -0+2 K
Test duration:
tP Test duration
ABS = 48 h
Operating states:
2.1
Evaluation criteria:
...


10.2.3.1.2. High temperature storage

Structure Principles of the MSRSYS DTD
10. Environmental Characteristics
10.2. Climatic characteristics
10.2.3. climatic characteristics tests
10.2.3.1. Temperature storage
10.2.3.1.2. High temperature storage

<high-temp-store>
[(Dry heat);IEC 60068-2-2;;all;]
A test according to the standard is described and performed.
Figure 83: Structure of high temperature storage
Example for content:
Test temperature:
TP Test temperature
ABS = 130 °C -2+0 K
Test duration:
tP Test duration
ABS = 48 h
Operating states:
2.1
Evaluation criteria:
...


10.2.3.2. Long-time temperature test


10.2.3.2.1. Long-time low temperature test

Structure Principles of the MSRSYS DTD
10. Environmental Characteristics
10.2. Climatic characteristics
10.2.3. climatic characteristics tests
10.2.3.2. Long-time temperature test
10.2.3.2.1. Long-time low temperature test

<long-time-low-temp>
(Dry coldness)
The long-time low temperature test is performed at climatic conditions which are described in the standard.
Complex relations between operating states and dwell times can be documented as additional specifications. The dwell time here describes the duration for which an operating state is maintained.
Figure 84: Structure of long-time low temperature test
Example for content:
Test temperature:
TP Test temperature
ABS = -30 °C -0+2 K
Test duration:
tP Test duration
ABS = 24 h
Operating states:
3.1 tV Dwell time ABS = 1 h
3.3 tV Dwell time ABS = 1 h
Evaluation criteria:
...


10.2.3.2.2. Long-time high temperature test

Structure Principles of the MSRSYS DTD
10. Environmental Characteristics
10.2. Climatic characteristics
10.2.3. climatic characteristics tests
10.2.3.2. Long-time temperature test
10.2.3.2.2. Long-time high temperature test

<long-time-high-temp>
(Dry heat)
The long-time high temperature test is performed at climatic conditions which are described in the standard. This test is equivalent to a time-compressed service life test.
Complex relations between operating states and dwell times can be documented as additional specifications. The dwell time here describes the duration for which an operating state is maintained.
Figure 85: Structure of long-time high temperature test
Example for content:
Test temperature:
TP Test temperature
ABS = 80 °C -2+0 K
Test duration:
tP Test duration
ABS = 1000 h
Operating states:
3.1 tV Dwell time ABS = 1 h
3.3 tV Dwell time ABS = 1 h
Evaluation criteria:
...


10.2.3.3. Rapid temperature change with determined transfer duration (temperature shock)

<temp-shock>
[Environmental Testing, Rapid temperature change with determined transfer duration (temperature shock);IEC 60068-2-14;;Test Na;]
This test is described according to the standard.
Complex relations between operating states and dwell times can be documented as additional specifications.
Figure 86: Structure of temperature shock test
Example for content:
Transfer duration:
tÜ Transfer duration
ABS <= 5 s
Upper test temperature:
TPO Upper test temperature
ABS = 85 °C -2+0 K
Lower test temperature:
TPU Lower test temperature
ABS = -40 °C -0+2 K
Dwell time at upper temperature:
tPO Dwell time at upper temperature
ABS = 30 min +/- 1 min
Dwell time at lower temperature:
tPU Dwell time at lower temperature
ABS = 30 min +/- 1 min
Number of cycles:
100
Operating states:
2.0 tV Dwell time = entire test duration
3.3 tV Dwell time = test duration for dynamic function test
Evaluation criteria:
...
Additional specifications:
The function test is performed after 50% and after 100% of the test duration.


10.2.3.4. Temperature change with determined rate of change

<temp-cycle>
[Environmental Testing Part2: Test Nb; Temperature change with determined rate of change;IEC 60068-2-14;;all;]
This test is described according to the standard.
Complex relations between operating states and dwell times can be documented as additional specifications.
Figure 87: Structure of temperature change test
Example for content:
Rate of change:
vT Rate of change
ABS = 4.167 K/min
Upper test temperature:
TPO Upper test temperature
ABS = 85 °C -2+0 K
Lower test temperature:
TPU Lower test temperature
ABS = -40 °C -0+2 K
Dwell time at upper temperature:
tPO Dwell time at upper temperature
ABS = 30 min +/- 1 min
Dwell time at lower temperature:
tPU Dwell time at lower temperature
ABS = 30 min +/- 1 min
Number of cycles:
500
Operating states:
2.1 tV Dwell time ABS = 1 h
3.3 tV Dwell time ABS = 1 h
Evaluation criteria:
...
Additional specifications
Figure 88: Example for temperature change test


10.2.3.5. Temperature function test

<temp-function>
The objective is to find possible malfunctions in a temperature window determined by the pattern. In every temperature window all functions are tested. The temperature function test is started at ambient temperature.
Figure 89: Structure of temperature function
Example for content:
Pattern:
DT pattern
MAX = 5 K
Upper test temperature:
TPO Upper test temperature
ABS = 80 °C -2+0 K
Lower test temperature:
TPU Lower test temperature
ABS = -25 °C -0+2 K
Evaluation criteria:
...
Additional specifications
Figure 90: Example for temperature function test


10.2.3.6. Rapid temperature change by splash water

<splash-water>
A situation like driving through water in winter shall be simulated.
Figure 91: structure of splash water test
Example for content:
Temperature of DUT:
TP Temperature of DUT
ABS = 85 °C
Dwell time at temperature of DUT:
tV Dwell time at temperature of DUT
ABS = 30 min
Temperature of splashing liquid:
TS Temperature of splashing liquid
MIN = 0 °C MAX = 4 °C
Transfer duration:
tÜ Transfer duration
MIN = 5 s MAX = 20 s
Number of cycles:
100
Operating states:
0.0 tV Dwell time MIN = 13 s MAX = 43 s 2 x tU + TS
2.1 tV Dwell time ABS = 15 min starting from storage at temperature of DUT
3.2 tV Dwell time ABS = 15 min before the begin of the rearrangement
Splashing duration:
tS Splashing duration
ABS = 3 s
Splashing quantity:
QS Splashing quantity
ABS = 5 l/min
Splashing liquid:
Water with 3 % of arizona dust
Evaluation criteria:
...
Additional specifications:
After heating the DUT to the required test temperature and after elapsed dwell time (including electrical operation) the device is transferred to ambient temperature conditions and afterwards submitted to the splash liquid.


10.2.3.7. Rapid temperature change by immersion

<immersion>
Increased thermal shock test.
Figure 92: Structure of immersion
Example for content:
Temperature of DUT:
TP Temperature of DUT
ABS = 85 °C
Dwell time at temperature of DUT:
tV Dwell time at TP
ABS = 1 h
Temperature of liquid:
TF Temperature of liquid
ABS = 0 °C
Immersion fluid:
5 % salt water
Transfer duration:
tU Repositioning duration
ABS = 5 s
Immersion duration:
tT Immersion duration
ABS = 5 min
Number of cycles:
20
Operating state:
2.1
Evaluation criteria:
...
Additional specifications:
After heating the DUT to the required test temperature and after elapsed dwell time (including electrical operation) the device is repositioned into ambient temperature conditions and afterwards immersed.


10.2.3.8. Condensation water containing sulphur in alternating climate

<condens-water-sulphur>
[DIN 50 018 KFW;DIN 50 018 KFW;;all;]
This test serves to prove corrosion resistance against condensation water containing sulphur. The sulphur content may vary (admissible values: 0,067%, 0,33% and 0,67%). Test temperatures, relative humidities, dwell times and transfer duration are specified in the standard.
Figure 93: Structure of condensation water test
Example for content:
State 1
Upper test temperature:
TPO Upper test temperature
ABS = 40 °C
Relative humidity:
FPO Humidity above
ABS = 100 %
Operating state:
1.2
State 2
Lower test temperature:
TPU Lower test temperature
MIN = 18 °C
MAX = 28 °C
Relative humidity:
FPU Humidity below
ABS < 75 %
Operating state:
1.2
Sulphur content:
k SO2 volume concentration
ABS = 0,2 l per cycle
Number of cycles:
6
Evaluation criteria:
...


10.2.3.9. Condensing water in alternating climate

<condens-water>
[DIN 50 017;DIN 50 017;;all;]
Generally, one of the three following tests is described.


10.2.3.9.1. Condensing water and constant humidity KK

Structure Principles of the MSRSYS DTD
10. Environmental Characteristics
10.2. Climatic characteristics
10.2.3. climatic characteristics tests
10.2.3.9. Condensing water in alternating climate
10.2.3.9.1. Condensing water and constant humidity KK

<condens-constant-hum>
Test temperature and relative humidity are determined in the standard.
Figure 94: Structure of condensing water and constant humidity
Example for content:


10.2.3.9.2. Condensing water with temperature change; constant humidity KTW

Structure Principles of the MSRSYS DTD
10. Environmental Characteristics
10.2. Climatic characteristics
10.2.3. climatic characteristics tests
10.2.3.9. Condensing water in alternating climate
10.2.3.9.2. Condensing water with temperature change; constant humidity KTW

<condens-cycle-temp>
The test temperatures, the dwell times, the relative humidity and the transfer duration are specified in the standard.
Figure 95: Structure of condensing water with temperature change
Example for content:


10.2.3.9.3. Condensing water with humidity and temperature changes KFW

Structure Principles of the MSRSYS DTD
10. Environmental Characteristics
10.2. Climatic characteristics
10.2.3. climatic characteristics tests
10.2.3.9. Condensing water in alternating climate
10.2.3.9.3. Condensing water with humidity and temperature changes KFW

<condens-cycle-temp-hum>
The test temperatures, the dwell times, the relative humidity and the transfer duration are specified in the standard.
Figure 96: Structure of condensing water with humidity and temperature changes
Example for content:


10.2.3.10. Constant humidity and heat

<constant-hum-heat>
Basis: [Environmental Testings Part 2: Testing;Test Ca;IEC 60068-2-3;;all;]
This test serves to prove the functioning of the device in a constant high humidity. Test temperature and relative humidity are determined by the standard.
Figure 97: Structure of constant humidity and heat
Example for content:
Test temperature:
TP Test temperature
ABS = 40 °C
Relative humidity:
FP Relative humidity
ABS = 93 %
Operating state:
1.2
Test duration:
tP Test duration
ABS = 21 days
Evaluation criteria:
...


10.2.3.11. Cycles of humidity and heat

<cycled-hum-heat>
Basis: [Environmental Testings Part 2: Testing; Test Db;IEC 60068-2-30;; all;]
This test serves to prove the functioning of the device in changing humidity. Test temperatures, relative humidity and cycle duration are determined by the standard.
Figure 98: Structure of cycles of humidity and heat
Example for content:
Upper test temperature:
TPO Upper test temperature
ABS = 55 °C
Operating state above:
...
Lower test temperature:
TPU Lower test temperature
ABS = 25 °C
Operating state below:
...
Relative humidity:
FP Humidity below
ABS > 90 %
Cycle duration:
tZ Cycle duration
ABS = 24 h (12 h + 12 h)
Number of cycles:
9
Evaluation criteria:
...
Additional specifications
Figure 99: Example for cycles of humidity and heat


10.2.3.12. Saline fog (salt spraying fog)

<saline-fog>
Basis: [Environmental Testings Part 2:;IEC 60068-2-11;;all;] [DIN 50021;DIN 50021;;SS;]
This test serves to prove the resistance against corrosion due to saline fog.
Figure 100: Structure of saline fog
Example for content:
Test temperature:
TP Test temperature
ABS = 35 °C
pH-value of the spraying liquid:
pH-value pH-value of the spraying liquid
MIN = 6,5 content of sodium chloride: 50 g/l
MAX = 7,2
Spraying duration:
tS Spraying duration
ABS = 8 h
Operating state:
1.2
Cycle duration:
tZ Cycle duration
ABS = 24 h, 16 of these as rest-time in the closed saline fog spraying chamber
Number of cycles:
6
Evaluation criteria:
...


10.2.3.13. Noxious gas test (multicomponent climate)

<noxious-gas>
This test is not described in any national or international standard. It is required by individual automobile manufacturers and is included in in-house standards (e.g. BMW N600.13 part 1 or SN29065.8). It serves for testing of environmental effects as they occur in road traffic.
Figure 101: Structure of noxious gas
Example for content:
Test temperature:
TP Test temperature
ABS = 25 °C -2+2 K
Relative humidity:
FP Relative humidity
ABS = 75 -/+5 %
Noxious gases:
SO2 k concentration ABS = 0,2 cm3/m3
H2 k concentration ABS = 0,01 cm3/m3
NO2 k concentration ABS = 0,2 cm3/m3
Cl2 k concentration ABS = 0,01 cm3/m3
Operating state:
1.2
Test duration:
tP Test duration
ABS = 10 days
Evaluation criteria:
...


10.2.3.14. Additional tests

<add-tests>
Further tests can be described here.
Figure 102: Structure of additional tests


10.3. Chemical characteristics

<chemical-char>
These tests serve to prove the resistance against media as supergrade petrol, diesel fuel, oils, radiator antifreezing compounds, battery acid, cleaning liquids for lights and windscreen, brake fluid, cold cleaners, alcohol, refreshment beverages, etc..
Figure 103: Structure of chemical characteristics
Example for content:
Tests
Test medium:
Cold cleaner
Test temperature:
TP Test temperature
ABS = 70 °C
Spraying duration:
tBS Spraying duration
ABS = 20 s
Duration of action:
tEW Duration of action
ABS = 24 h
Operating state:
1.2
Evaluation criteria:
...
Test medium:
Gear lubricant oil
Test temperature:
TP Test temperature
ABS = 70 °C
Spraying duration:
tBS Spraying duration
ABS = 20 s
Duration of action:
tEW Duration of action
ABS = 24 h
Operating state:
1.2
Evaluation criteria:
...


11. Other Physical Characteristics

Structure Principles of the MSRSYS DTD
11. Other Physical Characteristics

Other physical characteristics of a part type can be described in <other-physical-char>. This includes optical characteristics (<optical-char>), magnetical characteristics (<magnetical-char>) and acoustical characteristics (<acoustical-char>).
Figure 104: Structure of other physical characteristics


12. Construction

Structure Principles of the MSRSYS DTD
12. Construction

Informations about the Construction of a part type can be described in<construction>. This topic covers the following items:
<housing> | Description of material, pressure compensation, labelling and dimensions and weights of the part type.
<optical-design> | Description of shapes and colours of the part type
<ergonomic> | Requirements for ergonomics.
<mounting> | Description of the mounting requirements
<recycling> | For detailed description see 12.1. Recycling.
Additional specifications (<add-spec>) |
Figure 105: Structure of Construction


12.1. Recycling

<recycling>
Figure 106: Structure of recycling


12.1.1. General

In the phase of product planning and product development, highest efficiency in reduction of environmental pollution is obtained. It is an ecological and economical necessity to save resources during production, not to environmentally stress the utilization phase nor the disposal by hazardous material, as well as to facilitate the utilization/disposal by easy dismantling, thus minimizing disposal costs.
The concept of <recycling> implies, according to VDI 2243 re-utilization as well as reprocessing and exploitation.


12.1.2. Concept

<recycling-concepts>
Concepts for recycling and disposal are described.
Manuals of automobile manufacturers contain dismantling recommendations. It is also possible to document recommendations of part suppliers, considering the value added of metals or components. In appropriate instances, information regarding the dismantling of specific components containing hazardous materials must be given.
Furthermore, short information about reprocessing techniques (shredder, dump, energetic utilization) can be given.
Figure 107: Structure of recycling concepts


12.1.3. Design meeting requirements of dismantling

<disassembling>
Base: [VDI 2243;VDI 2243;;-;], [Checklist VDI 2232;Checklist VDI 2232;;-;], [DIN ISO 9001;DIN ISO 9001;;-;], various in-house and customer standards.
Design principles also have to consider the reprocessing and disposal techniques, which are becoming more and more complex due to legal regulations (Information, for example, with the help of the representatives for environmental protection).
An easy dismantling out of the vehicle and the re-utilization and further utilization of components/component groups, as well as an easy separation into the single parts have to be aspired. If reprocessing is possible and if there is a market for reprocessed products, components/component groups must be removable without being damaged. Accessibility for dismantling tools should be provided; dismantling should be possible with standard tools. The obtention of pure material fractions for reprocessing can be attained by simple dismantling, or by processing techniques, into pure recyclable material fractions. If possible, components/components groups have to be included in recycling circuits already installed.
Regarding connecting techniques the following factors have to be taken into account: Reduction of the number of connection points, utilization of detachable mechanical connections in the form of snap-in or screwed connections, preference of riveted or welded connections instead of glued connections, standardized screw heads (e.g. hexagon, slotted or cross recess types), location of unavoidable signs on a basic part which is as small as possible, utilization of standardized connecting techniques and tools.
Concerning the dismantling techniques, the following has to be observed: All maintenance and mounting criteria can be applied as well; predetermined breaking and separation points should be easily recognizable and accessible for the respective tools. Within the scope of dismantling techniques, the dismantling manual is also documented.
Figure 108: Structure of disassembling


12.1.4. Material selection

<material-selection>
After its service life, the component should not cause high disposal costs; the used materials should render a high value addes for re-utilization.
On principle, a low number of components by limitation (of the quantity) of car types (offer of models) has to be aimed at, in order to increase re-utilization and reprocessing of components. Cases for control devices should possibly consist of one material only.
Especially, for plastic materials, the possibilities of type separation are limited. Material compatibilities and the use of duroplastics have to be checked because of bad recyclability. Plastic materials containing halogens as flame protection agents should not be used.
Surface aspects have to be documented within <material-selection>, too. In case of surfaces, it has to be considered that composite materials should not be used, and that material recycling is made much more difficult or even impossible when materials are refined or painted. Furthermore, surfaces containing cadmium are forbidden.
In the section <labelling> the designation of materials can be characterized by referencing to respective standards (e.g. plastic materials according to [DIN 54840;DIN 54840;;all;], [VDA 260;VDA 260;;all;] and metals according to DIN ISO).
In the section <fogging> limiting values and standard values are documented.
In the section <part-material-list> a listing of the manufacturer concerning the material composition (physical) of the component can be documented. A pattern for a corresponding table can be gathered from Pinnacles Component Information Standard Draft Version 1.0 March 1994 . The listing serves, among other things, for the determination of useful ways of reprocessing considering economical features, the design which meets requirements of recycling (minimization of dismantling and separation time, suitability for automatic dismantling) and for the reduction of the diversity of materials (e.g. standardization of case materials).
In the section <chemical-elements-list> a listing of the manufacturer concerning the chemical composition of the component produced by him can be documented. A pattern for a corresponding table can be gathered from Pinnacles Component Information Standard Draft Version 1.0 March 1994. The materials, which are significant due to their characteristics in the dump as well as within thermal reprocessing/disposal techniques (partially regulated by legal regulations) are registered. This listing supports the decision if the component is to be dismantled, especially when an option for limiting values for contaminants is considered: The component has to be dismantled or can remain in its location, if there are not any other aspects in favour of dismantling. It has to be the objective to reduce the addition of hazardous materials into the shredding of light waste (SLW) by previous dismantling. After dismantling of the components, a reprocessing/disposal has to be managed using the existing infrastructure for electronic scrap. The existing information are the base, among other things, for substitute material strategies, for dismantling recommendations for reprocessing industry and for answering questions directed to automobile manufacturers concerning problematic and hazardous materials in automobiles.
In the section <problem-material-list> prohibition lists and avoidance lists (ingredient materials, processed materials, regulations concerning the prohibition of chemicals, customer specifications ) as well as preference lists can be documented. Ingredient materials can be evaluated using prohibition and avoidance lists.
Figure 109: Structure of material selection


12.1.5. Product packaging

<product-packaging>
The recycling and the disposal of product packagings are described. Legal regulations concerning packaging and, if existing, customer specifications have to be considered.
Note: Product packaging has to be described in the MSRSYS DTD under <general-product-data-1> as an additonal specification(<add-spec>).
Figure 110: Structure of product packaging


13. Human Machine Interface

Structure Principles of the MSRSYS DTD
13. Human Machine Interface

The operation interface of the part type is described in the section Human-Machine-Interface (<hmi>). The interface, e.g. buttons, switches or displays of the part type is specified in the section <hmi-spec>. The testing of the operability of the part type is described in the section <hmi-test>. Further specifications which do not fit in one of the topics mentioned above are given in the section <add-spec>.
Figure 111: Structure of the human machine interface


14. Glossary

Structure Principles of the MSRSYS DTD
14. Glossary

alphanumeric parameters
An alphanumeric parameter allows a structured acquisition of an alphanumeric value. It is described by:
Name alphanumeric [Function state, fault criteria,..]
Value alphanumeric [A, no loss of information ...]
Note alphanumeric [Text]
Operating state
Within the description of the electrical characteristics, it is often necessary to reference to the operating state. The operating state defines the supposed state of the system at a certain requirement. The definition of these states is necessary for a verification of the requirements and for the reproducibility of the tests.
Vehicle network voltage
The vehicle network voltage U B designates the voltage which is applied to the component at a given point of time (e.g. UB = 13 V). In [DIN 40 839;DIN 40 839;;-;], the denomination of vehicle network voltage is used on one hand for nominal voltage and on the other hand for test voltage.
Wide-band interference
A wide-band interference is a band width of an interference signal which is equal to or bigger than the chosen measuring band width of the interference measuring receiver.
Fault description
A fault description serves for an exact description of the function status in case of malfunctions (function state not equal to A). For example, it allows a more exact definition of the effects of a malfunction onto the fault storage (store, not store, loss of data), onto the outputs (triggered, switched off) and how the fault is being treated concerning the display.
The fault description has to be performed in textual form, and is not pre-defined, since a fault generally causes different effects in different systems. Examples for fault descriptions:
1: No fault release
2: Information loss of fault storage
3: Inadmissible input in fault storage
4: Inadmissible triggering of warning lamp
5: Interruption of triggering of output XX
6: Inadmissible triggering of output XX
Function voltage range
The function voltage range U FB is the voltage range within which the vehicle network voltage has to be in order to comply with the specified function (e.g. UFB = 6...16 V).
Additional specifications
The description structure of single data elements (parameters, text, graphics, subject, field) has to be specified such that it is possible to assign a comment (text or graphics) to each data element. All marginal conditions, comments and optional specifications described in the performance specifications, can be realized by means of this supplementary data.
Nominal voltage
The nominal voltage U N is the voltage according to which the electrical system of a car is denominated. The voltage-dependent electrical consumers are generally marked with the nominal voltage (according to [DIN 72 251;DIN 72 251;;-;])
Numerical parameters
A numerical parameter serves for the structured acquisition of a numerical value. It is described by:
Name alphanumeric [Nominal voltage, rise time,..]
Abbreviation alphanumeric [Un, Tr, ... ]
Operator alphanumeric [=, >=, ...]
Value numerical [12 , 0.01, ...]
Unit alphanumeric [V, ms, ...]
Tolerance alphanumeric [ -, 5%, 12 ms]
Note alphanumeric [text]
Test voltage
The test voltage U P is the vehicle network direct current state applied to the DUT if this is not submitted to any interference. In most cases, the test voltage is defined by the battery voltage with the motor at rest (UP = 12 V) or with the generator voltage with the motor running (UP = 13.5 V).
Standard test voltage
The standard test voltage U SP is a general test condition determined by General test conditions (e.g. USP = 13.5 V). When there are no specifications for U P then U P = U SP is valid.
Narrow-band interference
A narrow-band interference is a band width of an interference signal which is smaller than the chosen measuring band width of the interference measuring receiver.
Interference voltage
The interference voltage is the voltage which is measured according to [VDE 0876;VDE 0876;;-;] in dBµV at the vehicle antenna or the artificial network with an interference measuring receiver.
(Central) load-dump protection
Load-dump protection is the limitation of the generator pulse. This protection is central when it is limited to the generator itself. If this is not the case, the protection takes place in the respective components.
Description of the test pulses
The test pulses can be defined by parameters or as well by parameters and graphics, since only a graphic definition of a multitude of parameters makes sense.
Those pulse parameters for which an access by data processing makes sense, are defined as parameters. Further pulse parameters can be defined and set with values in the graphic.


15. Basic Structures of the MSR Application Profile

Structure Principles of the MSRSYS DTD
15. Basic Structures of the MSR Application Profile

All MSR DTDs are using some common data structures. These operating models are described in this chapter.


15.1. Not Content Orientated Information (ncoi)

<ncoi-1> contains all basic descriptive elements. There are also elements like <chapter> or <fail-save-concept> in the MSRSYS DTD which have the same content model as <ncoi-1>.
The figure below illustrates the structure of <ncoi-1>.
Figure 112: Structure of <ncoi-1>
There also are two weaker ncoi models ( ncoi-2 and ncoi-3) with lesser elements than <ncoi-1>. ncoi-2 has no <chapters>. ncoi-3 has also no chapters and futhermore another "topic" model without <prms>.
The components of ncoi [image] are interchangeable between all MSR DTDs [image] without any changes.

DTDs with the same version of the MSR application profile
not content orientated information


15.1.1. Chapter

<chapter> is a sequence of paragraph level elements mixed with <chapter>. <chapter>s can be nested as deeply as required. It is up to the author to make sure, that the nesting of the chapters can be handled by the processing system [image] .
Figure 113: chapter content model
One advantage of using <chapter> for all levels [image] is the option to move a chapter using cut & paste to any place in the document at any level.

the other option would be to have an extra element for each chapter level
In that respect, it is recommended to nest not more than four levels.


15.1.2. Topic

Use <topic-1> or <topic-2> to create bridge titles instead of one line paragraphs with entirely emphasized contents. Note that these elements can be referenced by <xref>. In difference to <topic-1>, <topic-2> has no <prms>.
Figure 114: Structure of <topic-1>


15.1.3. Paragraph Level Elements

"Paragraph level elements" are elements which occur on the same level as <p>.
The user should first look for an appropriate one among the available elements before trying to simulate things by using inadequate elements. In that respect the following hints are given:
<p> | Paragraph
<verbatim> | Preformatted text which is usually set in monospaced font. Tabs, line spaces and carrige returns are considered. Use <verbatim> to print program listings etc. It can even be used to show simple diagrams.
<figure> | See chapter 15.1.3.2. Figure.
<formula> | See chapter 15.1.3.3. Formula.
<list> | A ordered or unordered list of items. For an unordered set of items, use <list type="unnumbered">. For a ordered list of items use <list type="numbered"> [image] .
<def-list> | Use <def-list> to create definition lists which might be collected into an overall definition list or a glossary. In this case <labeled-list> might lead to the same rendition but has no information about the fact that terms are defined [image] .
<labeled-list> | Use<labeled-list> to create explanations or even bridge titles for very short topics instead of bulleted lists with emphasized initial words. See also 15.1.3.1. Labeled List Use <labeled-list> instead of two column tables if the first column cells almost contain one word.
<note> | See chapter 15.1.3.4. Note

it is not really easy to distinguish between these two elements. As a rule of thumb, one might say that the semantics of def-list is stronger than the one of labeled-list which is more layout oriented. The items of def-list can be referenced by xref which is not possible with the items of a labeled-list.
Actually it is up to the rendition system if the sequence is expressed as numbers or as letters.


15.1.3.1. Labeled List

Structure Principles of the MSRSYS DTD
15. Basic Structures of the MSR Application Profile
15.1. Not Content Orientated Information (ncoi)
15.1.3. Paragraph Level Elements
15.1.3.1. Labeled List

Figure 115: Structure of <labeled list>
<labeled-list> is one of the most powerful elements. If possible it is rendered as a label followed by the item body:
XX      XXXXXXXXXXXXXX
        XXXXXXXXXXXXXX

XXXXXX  XXXXXXXXXXXXXX
        XXXXXXXXXXXXXX

XXXXX   XXXXXXXXXXXXXX
        XXXXXXXXXXXXXX
The indentation is determined by the rendition system which should take into account the biggest <item-label>.
Sometimes the author wants some influence to the indentation. For this respect <indent-sample> can receive any content which is used by the rendition system as a sample which must be rendered and measured to determine the indentation.
The attribute [item-label-pos] defines how the <item-label> should be handled. The default value of the attribute is [item-label-pos]="no-newline". If an <item-label> is wider than <ident-sample> the most general case is to start the item body in a new line if necessary([item-label-pos]="newline-if-necessary"):
XXXXXXXXXX

        XXXXXXXXXXXXXX
        XXXXXXXXXXXXXX

XXXXXX  XXXXXXXXXXXXXX
        XXXXXXXXXXXXXX

XXXXXX  XXXXXXXXXXXXXX
        XXXXXXXXXXXXXX
If the attribute has the value [item-label-pos]="newline" the item-body starts generally in a new line.
Note that <indent-sample> can be used to adjust the indentation if there are multiple <labeled-list>s which should have the same indentation.


15.1.3.2. Figure

Structure Principles of the MSRSYS DTD
15. Basic Structures of the MSR Application Profile
15.1. Not Content Orientated Information (ncoi)
15.1.3. Paragraph Level Elements
15.1.3.2. Figure

<figure> is used to insert graphics into the document. A figure can be defined in three different ways.
  1. as a real <graphic>
  2. as an ASCII graphic (<verbatim>)
  3. as a pure textual description (<desc>) of the graphic
The treatment of the graphic is determined by the attributes of <graphic>:
Do not enter annotating text to <long-name>in<figure> or <table>(like Figure 1: ...). This embellishment is the task of the processing system, not of the author. If the author adds these things, they will be there twice since the rendition system will add it again.
[category]
Denotes the category of the graphic. This information can be used to generate more specific list of figures
[filename]
Denotes the system filename where the rendition system can find the graphic. This is not necessarily the final format. It is up to the rendition system to locate the graphic in the company specific environment, to change the file extension to get the appropriate graphic representation.
The type of this attribute can be turned from SDATA toENTITY in the DTD file in order to allow SGML tools access to the file using its entity manager. In this case, the entity name should be chosen in the style of a filename (e.g. crpctmt.wmf) [image] .
[fit]

0 | figure is placed in original size. If it does not fit on the page or the available space, it is scaled down.
1 | the figure is scaled up or down to fit the page as possible. This value will be ignored if [width] or [height] is specified in addition.
2 | the figure is rotated counterclockwise by 90o if it is landscape and is wider than the actual text area. It is scaled down to the page size if it does not fit otherwise. This value will be ignored if [width] or [height] is specified in addition.
3 | the figure is always rotated counterclockwise by 90o. If it does not fit on the page it will be scaled down. If [width] or [height] is specified in addition, the figure will be rotated and then scaled to the specified values.
4 | the figure is always rotated counterclockwise by 90o and scaled up or down for best fit on the page. This value will be ignored if [width] or [height] is specified in addition.
[height]
If this attribute has a value, the figure will be scaled to the defined height which is a real value with dimensions (e.g. "10cm", "150mm", "12.5in"). If also [width]is specified the figure will be distorted. This value always specifies the width of the "figure box" on the page after possible scaling/rotating.
[notation]
This attribute specifies the format of the graphic file if used by an SGML Application supporting notations.
[scale]
If this attribute receives a value, the figure will be scaled by the given factor which must be a signed real number. Numbers greater 1 increase the size of the figure, values less than 1 make the figure smaller. For example with scale="0.5" the a figure of the size 10x10 cm will appear as 5*5cm.
[width]
If this attribute has a value, the figure will be scaled to the defined width which is a real value with dimensions (e.g. "10cm", "150mm", "12.5in"). If also [height]is specified the figure will be distorted. This value always specifies the width of the "figure box" on the page after possible scaling/rotating.
The scaling attribute precedence is:
  • [scale] has precedence over all
  • [fit]has precedence over [width]and/or [height]

This is the way how this document is prepared. It is visible in the sgml source.
This can be used for systems which can't display graphics.


15.1.3.3. Formula

Structure Principles of the MSRSYS DTD
15. Basic Structures of the MSR Application Profile
15.1. Not Content Orientated Information (ncoi)
15.1.3. Paragraph Level Elements
15.1.3.3. Formula

Figure 116: Structure of <figure>
A formula can be described in five different ways which can exist parallel. These are:
<graphic> | A formula prerendered as a figure.
<verbatim> | A simple ASCII formula.
<tex-math> | A TeX math formula which can be processed by a TeX or LaTeX processor.
<c-code> | A formula which is defined as c-code.
<generic-math> | This element is intended for the definition of semantic math descriptions which can be processed by math processors. Actually there is no recommentation for the language of the formula specification or usage of a special rendering system.
It is up to the rendering system which of the available representations is used.


15.1.3.4. Note

Structure Principles of the MSRSYS DTD
15. Basic Structures of the MSR Application Profile
15.1. Not Content Orientated Information (ncoi)
15.1.3. Paragraph Level Elements
15.1.3.4. Note

A note is an object to express a combination of an icon with descriptive text and an additional label. This is useful for things like cautions, hints etc..
The attribute [notetype] defines the note category. The following values are available:
  • caution
  • hint
  • tip
  • instruction
  • exercise
  • other
If the attribute [notetype] has a value of "other" the user has to specify a own type within the attribute [user-defined-type].
A formatter has to place the right icon before the descriptive text according to the value of [notetype] or [user-defined-type]. The optional <label > can be used to define a title of the note.


15.1.4. Character Level Elements

Character level elements can occur within element like <p>, <item-label>. There are rendition oriented elements like <e> (emphasis), <sub> as well as semantically oriented Elements as <tt> (technical term) or <std>(referring to an external standard). It is highly recommended to use rather semantically oriented elements than rendition oriented ones.


15.1.4.1. Rendition Oriented Character Level Elements

Structure Principles of the MSRSYS DTD
15. Basic Structures of the MSR Application Profile
15.1. Not Content Orientated Information (ncoi)
15.1.4. Character Level Elements
15.1.4.1. Rendition Oriented Character Level Elements

The rendition oriented character level elements are:
<e> | Emphasizes the text. The attribute [type]determines the rendition style.
<sub> | Subscript - places the contents with smaller font below the base line.
<sup>
Superscript - places the contents with smaller font above the base line.


15.1.4.2. Semantically Oriented Character Level Elements

Structure Principles of the MSRSYS DTD
15. Basic Structures of the MSR Application Profile
15.1. Not Content Orientated Information (ncoi)
15.1.4. Character Level Elements
15.1.4.2. Semantically Oriented Character Level Elements

semantically oriented character level elements
Element | use for | example
<tt> | Use for any technical term. The type of that term is determined by the attribute [type] [image] . This element could be treated as a back-door to markup information which is not totally semantic. The SGML processing system can generate list of technical terms which makes it easier to find misspellings and other errors. | This is an SGML tag <tt type=sgmltag> we can collect all <tt>s
<xref> | Used to create links in the document. The role of the target is determined by the attribute [id-class] receiving the value of the target's fixed attribute [f-id-class]. The attributes of <xref> should be maintained by the authoring system. |
<xdoc> | Used to refer to an external document which usually is not available electronically. <xdoc> receives a set of elements characterizing the external document | Details to architectural forms can be found in .
<ft> | Is used to create footnotes | Footnotes seem to be small and unimportant [image] .
<ie> | creates index entries | It is not necessary to put SGML tags into the Index, since the processing for MSRREP.DTD recommends to create a list of SGML tags automatically.
<xfile> | Is used to create pointers to external files which are not to be processed by the native SGML processing system. The contents of <xfile> can be used to connect to appropriate systems in later steps of the processing chain. | The schematic is found in [MOTRONIC wiring diagram;motronic.asc;concept-ascii-format;concept;2.7;]
<std> | Is used to refer to a standard. | SGML is defined in [Information Processing - Text and Office Information Systems;ISO 8879;Standard Generalized Markup Language;standard;1986;;entire document;]
usage of technical terms
type | use for | example
<tt type=sgmltag> | Used to describe SGML tags including attributes | To describe SGML tags use <tt type=sgmltag>.
<tt type=sgml-attribute> | Used to describe SGML attributes outside of tags | The sgmltag is denoted by the attribute [type]
<tt type=tool> | Used to mention tools used for example in a process. This can be software, as well as mechanical tools. The tool should be specified by its nature not by the specific product name. | SGML files are processed using an SGML processing system.
<tt type=product> | Used to mention specific products. | This document is processed using MetaMorphosis.
<tt type=variable> | Used to mention a variable informally. This is used to control the rendition as well as for generating variable lists. This is mainly for informal reports [image] . It is also possible to use this to mention a variable in the ECU software if no <sw-data-dictionary> is part of the document. In a later process step, this can be turned over to a formal <xref> | The initialization is controlled by the environment variable MMRC. The initial advanced angle is calculated based on NandTL.
<tt type=state> | Used to mention a state for example of a process. | The documents must at least be revised if they are submitted to the customer.
<tt type=prm> | Used to mention a state for example of a process. It is also possible to use this to mention a calibration parameter in the ECU software if no <sw-data-dictionary> is part of the document. In a later process step, this can be turned over to a formal <xref> | The initial advanced angle is calculated using a lookup table KFZW.
<tt type=material> | Used to mention material. | Furniture is usually made of wood and plastic
<tt type=control-element> | Used to mention control elements of tools like push-buttons, menu items, switches etc. as well as keyboard keys. | To finish the dialog push the OK button.
<tt type=code> | Used to markup program in line code sequences | MetaMorphosis is invoked with mm crp.sgm
<tt type=organisation> | Used to markup the name of an organization. | SGML is standardized by ISO
<tt type=other> | Used to mention a special term which does not fit to the other types. This is a back-door for the definition of user defined types. They have to be specified within the attribute [user-defined-type]. A formatter uses this user defined type only if [type=other]. | This is a thing not covered by <tt>.
sub-elements for xdoc and xfile
Element | use for | example
<number> | Used to markup the document ISBN resp. the standard number | ISBN 0-7923-9432-1
<state> | Used to markup the state of the referred document resp. standard. | released
<date> | Used to markup the release date of the referred document resp. standard. This could be expressed as year only, if the exact date is not known. | 1994
<publisher> | Markup the publisher of the document or the standard. This can be the author as well as the publishing organization. | Steven J. DeRose and David G. Durand / Kluwer Academic Publishers
<position> | Markup the relevant position in the referenced document resp. standard. | Chapter 5.2 - Architectural forms
<subtitle> | Used to markup the subtitle of the referenced document or standard if there is one. | HyTime
<short-name> | Used to markup the document identifier | SGML
<long-name> | Used to markup the main title of the referenced object. | Making Hypermedia work
<file> | Used to markup the file access information. This is intended to be processed by external systems. | [MOTRONIC wiring diagram;motronic.asc;concept-ascii-format;concept;2.7;]

Note that in MSRDOC.DTD there are means to formally describe variables to be used if the system software of an ECU is specified.
But many people read footnotes first - so put the interesting stuff in footnotes
it is recommended to enter the term always in singular and create plurals outside of the element (see second example).


15.1.5. Table

<table> is implemented as CALS table (see CALS table spec at www.oasis.org). Capturing these kind of tables must be supported by the SGML editor, so only some hints are given here:
  • CALS tables consist of mainly three parts within <tgroup>: <thead>, <tbody>, <tfoot>.
  • Each part is made of <row>s of <entry>s. Each of these elements have attributes to control the layout of the table.
  • <tgroup> also receives a set of <colspec>s having information about the table columns.
  • One of the major problems if CALS tables do not work is, that the amount of <colspec> elements and <entry> does not match the value of the attribute [columns] in <tgroup>.
  • Within <entry> most of the paragraph level elements are allowed.
Note
It is highly recommended to insert <thead>. This creates a table heading which is repeated on each page, if a pagebreak falls into the table.


15.1.6. Parameter tables

User Definable Parameters
For structured documentation of individual numerical and/or alpha-numerical requirements, so-called parameters are available. They have the following structure:
Figure 117: Structure of prms
* parameter
* long-name
* short-name
* description
* parameter characteristics
* condition
((* absolute value and tolerance [image] or
* minimum, typical, maximum value [image] )
* unit) or
* text
The following representation example can be drawn from this structure:
<short-name> UB
Parameter structure
 |  | <prm-char>
Element: <long-name> | Element: <short-name> | Element: <min> | Element: <typ> | Element: <max> | Element: <abs> | Element: <unit> | Element: <tol>
Operating voltage | UB | 10,8 |  | 14,2 |  | V |
 |  |  |  |  | 13,5 | V | 5 %
Colour of housing |  | red, green and blue
Function state |  | active
  • Defined Parameters
    There are many pre-defined parameters in the MSR DOC DTD. The only difference between them and user defined parameters is that the designation (long-name element) of the parameter is pre-defined.

For definition of an alpha-numerical value.
For definition of a typical value or value range.
For definition of an exact setting or measurement value.


15.2. Predefined Document Structure

The automotive systems to be described with the help of this DTD possess very different specifications. Because of this, the specification of a particular topic, e.g. "acoustic characteristics" might not make sense or might only become necessary later on, depending on the project.
This situation was also taken into account in the DTD through the elements "<na>" (not applicable), "<tbd>" (to be defined) and "<tbr>" (to be resolved) as shown in Principles of information acquisition. This is a mechanism is located at each element on chapter level and works like a check list. A user has to make a statement for each topic.
Figure 118: Principles of information acquisition
If a certain topic is not applicable it has to be marked with <na>. If it is applicable it can be marked with either with <tbd> which indicates that someone has to do a job, or it can be marked with <tbr> which indicates that a specification already exists but it hasn't yet been included, or a detail specification can be defined.
The elements <na>and<tbr> can be described with a short description. Within the element <tbd> the persons responsible for the definitions that have to been made can be specified with <team-member-ref>s. The schedule for the definitions can be defined within <schedule>.


15.3. Project Data

Registering and documenting development of a MSR system is project-oriented, whereby there may be several versions of the product data of a project. The projects can be combined with the help of main projects. This can be defined within <overall-project> by a <label> an a short description in <desc>. Each project is assigned to a maximum of one main project.
The documentation and continuation of project phases occurs in versions. We differentiate between active versions, the data of which can still be modified, and fixed versions, the data of which can no longer be modified. New versions can be designed on the basis of a fixed version. New versions can reuse complete fixed versions of a document or even parts of such a document. This is illustrated by the following figure:
Figure 119: Structure of <project-data>
Project data can be described by a PDM system in an integrated SGML-Editor and PDM environment. This is information on the current project and possibly the main project. Company-specific details about the project can be specified in <general-project-data> on the following items:
System overview <system-overview> | This chapter can be used to define information about a global system, e.g. a certain car model.
Order justification <reason-order> | This may be used to specify information about the reasons for the order of the described component resp. for making the specification of such a component.
Objectives <objectives> | This chapter can be used to specify information about the project objectives. E.g. "Development and system release of the engine-managment-system for the model NEW-BEETLE"
Models <sample-spec> | This structure is used to define development samples like A-,B-,C-,D-sample. These samples represent the results of the different development phases.
Variant specification <variant-spec> | This section is used to specify all variant definitions and their corresponding variant characteristics. See also 15.5. Variant Concept.
Limits to other projects <demarcation-other-projects> | This chapter is used to describe the demarcation to other projects.
Parallel developments <parallel-design> | This can be used to give an overview of the work in parallel projects.
Integration capability <integration-capability> | In this chapter requirements on the capabilities of integration in other systems can be described.
Acceptance conditions<acceptance-cond> | This chapter is used to define the general conditions for the acceptance of the described components.
Schedule and plans <project-schedule> | This chapter is used to define the project-schedule, e.g. project milestones, dates, time limits etc.
Purchasing conditions <purchasing-cond> | This is used to define purchasing conditions like amount of devices per year, delivery times, storage quantities, etc. .
Protocols, minutes of meeting <protocols> | This is the place where project minutes and other arrangements can be mentioned.
Handed over documents and data<dir-hand-over-doc-data> | This is the directory of the handed over documents and data.
Additional project specifications<add-spec> | Any kind of additional project description which can't be described with the chapters mentioned above.


15.4. Administrative Data

Since the respective companies explode the interchange DTD into fragments and use it for the respective acquisition DTDs (perhaps in different departments), the administrative dataappears in many places in the DTD. Each of these places can be used as such a fragment(see below).
Figure 120: Support of DTD fragmentation through administrative data
The operating model is
  • The document respectively the fragment is written in a certain language which can be defined in the element <language>. This element can be used to control a SGML system, e.g. to set the correct prefix strings for elements.
  • The DTD can be configured for the multilingual operation. In this case <language> contains the language of the origin document. All languages used in a document have to be defined within <used-languages>, that is each language is defined with a <l-10>-element which contains the full language name and in the Attribute [l] the short language name (see 15.6. Multilinguality).
  • The document (or the fragment) is handled in all companies participating in the project.
  • The data management in the various companies is different. For that reason, each participant can enter information about their document management facilities in <company-doc-info>:
    <doc-label>
    this is the label under which the document is managed in the company denoted by <company-ref>
    <private-code>
    allows to transport company specific information in a private notation. This is the place, where for example PDMS (Product Data Management Systems) can place pointers and document ids required to resynchronize after a document exchange.
    <entity-name>
    It might be the case that each participating company uses a different fragmentation strategy. In order to support this, <entity-name> can receive information useable by a split utility which creates the desired fragments out of the entire document.
  • If a new release of the document or the fragment is given, each participating site may use a specific scheme for revision numbers. For that reason, each <doc-revision> can receive <company-revision-info> which holds the participant specific information for the actual document revision.
    It is up to a semantical check utility to keep sure that there is only one entry per company.
  • nevertheless, the actual revision is initiated by one individual denoted by <team-member-ref> at one certain point of time denoted by <date>.
  • Finally the modifications made in that revision are stored in <modifcations> where the actual <change> as well as the <reason> for that change is notified. If possible, the change can be located by <xref>.
  • For each <modifcation> the attribute [type] determines, if the change is made to the document only (doc-related) or to the subject of the document (content-related).


15.5. Variant Concept

Especially in the automotive sector there is a multiplicity of different variants of a part type. Normally there is not only one variant documented in the system requirements respectively the product specification of such part types.
To understand the implementation of the variant concept in the MSR DTDs, first some definitions have to be made:
Variant Characteristic
Characteristics that lead to a new variant e.g. engine, product line, country, etc. Characteristics are defined in <variant-char>. The characteristics have to be subdivided in three classes. These are:
  • characteristics which lead to a new subject number(<variant-char [type="new-part-number"]>). For this only the existence of such a characteristic is enough to establish a new subject number for this variant!
  • characteristics which don't lead to a new subject number (<variant-char [type="no-new-part-number"]>).
  • characteristics which lead to a new subject number according to shaping.
Variant Definition:
Definition of several variants with their variant characteristics for a part type.
Variant:
A variant of a part type is defined through the values of it's variant characteristics.
Variant Coding:
Allocation of all variant definitions to their corresponding subject- and drawing- numbers and the respective development versions.


15.6. Multilinguality

The MSR DTDs can be configured for multilingual operation. To use the multilingual DTD configuration the DTD switch "multilinguality : YES or NO" have to be set.
The description of multilingual texts is made through multiple terminal elements that is multiple elements with content of #PCDATA. Multilingual elements get one of the additional language elements <l1>,<l2>, <l3>,<l4>,<l10> to build an aggregate of terminal elements. These language elements provide an attribute [l] where the language of this element can be specified. The content of the attribute [l] have to be defined as two-letter lower-case symbols according to the [Code for the representation of names of languages;ISO639::1988((E/F));;Part1;]
Figure 121: Multilingual Paragraph


Technical Terms

Structure Principles of the MSRSYS DTD
Technical Terms


Code

code | II.
content-related | 15.4.
crpctmt.wmf | 15.1.3.2.
doc-related | 15.4.
ENTITY | 15.1.3.2.
mm crp.sgm | 15.1.4.2.
organization | II.
other | II.
product | II.
scale="0.5" | 15.1.3.2.
SDATA | 15.1.3.2.
SGML-attribute | II.
SGMLTAG | II.


Control elements

OK
15.1.4.2.


Material

plastic | 15.1.4.2.
wood | 15.1.4.2.


Organisations

ASAP
II.


OTHER

CALS table | 15.1.5.
CALS table | 15.1.5.
ECU | II.
ISO | 15.1.4.2.
ncoi-2 | 15.1.
ncoi-3 | 15.1.
thing | 15.1.4.2.


Parameter

KFZW
15.1.4.2.


Products

ASAP2 | II.
MetaMorphosis | 15.1.4.2.
MSR NET DTD | 8.5.
MSRREP DTD | II.
MSRREP.DTD | 15.1.4.2.
MSRSYS DTD | III. 1. 15.1.
systems and hardware |


SGML Attributes

category | 15.1.3.2.
columns | 15.1.5.
connection-type | 8.1.
direction | 8.1.
f-id-class | 15.1.4.2.
filename | 15.1.3.2.
fit | 15.1.3.2.
height | 15.1.3.2.
id-class | 15.1.4.2.
item-label-pos | 15.1.3.1.
kind | 8.1.
l | 15.4. 15.6.
notation | 15.1.3.2.
notetype | 15.1.3.4.
scale | 15.1.3.2.
type | II. 15.1.4.1. 15.1.4.2. 15.4.
type="new-part-number" | 15.5.
type="no-new-part-number" | 15.5.
type=other | 15.1.4.2.
user-defined-type | 15.1.3.4. 15.1.4.2.
width | 15.1.3.2.


SGML Elements

0tol | 9.4.2.1.
abrasion-res | 10.1.4.2.
abs | 9.4.1.1.1.1. 9.4.1.2. 9.4.2.1. 9.8.2. 15.1.6.
acceptance-cond | 15.3.
acoustical-char | 11.
add-design-doc | 5.
add-info | 9.4.1.1.4. 9.4.2.1. 9.4.2.2. 9.5.5. 9.5.6.
add-mea | 9.5.7.
add-spec | 5. 9.2.4. 9.3.8. 9.9. 10.1.6. 12. 12.1.5. 13. 15.3.
add-tests | 10.1.1.3. 10.1.2.6. 10.2.3.14.
architecture | 8.1. 8.2.
behaviour | 7.
bump | 10.1.2.4.
buttons-switches-displays | 10.1.4.2.2.
c-code | 15.1.3.3.
calibration | 5.
change | 15.4.
chapter | 15.1. 15.1.1.
chapters | 15.1.
chemical-char | 10.3.
chemical-elements-list | 12.1.4.
climatic-char | 10.2.
climatic-char-tests | 10.2.3.
colspec | 15.1.5.
company-doc-info | 15.4.
company-ref | 15.4.
company-revision-info | 15.4.
compr-tensile-strength | 10.1.1.2.
condens-constant-hum | 10.2.3.9.1.
condens-cycle-temp | 10.2.3.9.2.
condens-cycle-temp-hum | 10.2.3.9.3.
condens-water | 10.2.3.9.
condens-water-sulphur | 10.2.3.8.
connection-comp-spec | 8.3.
connection-spec | 8.4.
connections | 8.4.
constant-hum-heat | 10.2.3.10.
construction | 12.
current-char | 9.2.2.
cycled-hum-heat | 10.2.3.11.
cyclic-torsional-strength | 10.1.2.5.
date | 15.1.4.2. 15.4.
def-list | 15.1.3.
demarcation-other-projects | 15.3.
desc | 8.1. 15.1.3.2. 15.3.
development-process-spec | 5.
die-strength | 9.3.6.
dir-hand-over-doc-data | 15.3.
disassembling | 12.1.3.
doc-label | 15.4.
doc-revision | 15.4.
drawing-number | 8.1.
dynamic-strength | 10.1.2.
e | 15.1.4. 15.1.4.1.
elec-immunity | 9.3. 9.3.8.
elec-test-spec | 9.1.
electrostatic-discharge | 9.7.
emc | 9.4.
emc-design | 9.8.
emc-hardware-design | 9.8.5.
emc-software-design | 9.8.6.
entity-name | 15.4.
entry | 15.1.5.
ergonomic | 12.
fail-save-concept | 5. 15.1.
failure desc | 9.4.1.1.4.
failure-desc | 9.3.2. 9.5.5. 9.5.6.
failure-management | 5.
figure | 15.1.3. 15.1.3.2.
file | 15.1.4.2.
fmea | 5.
fogging | 12.1.4.
formula | 15.1.3.
free-fall | 10.1.3.
frequency-band-refs | 9.5.5. 9.5.6.
frequency-bands | 9.5.3.
ft | 15.1.4.2.
fuction-state-ref | 9.3.2.
function-overview | 5.
function-state | 9.1.2.
function-state-ref | 9.4.1.1.4. 9.5.5. 9.5.6.
function-states | 9.1.2.
general-cond | 5.
general-hardware | 5.
general-interfaces | 5.
general-product-data-1 | 5. 12.1.5.
general-project-data | 15.3.
general-software | 5.
general-test-spec | 6.
general-test-spec-prms | 6.
generic-math | 15.1.3.3.
graphic | 15.1.3.2. 15.1.3.3.
ground-concept | 9.8.3.
high-temp-store | 10.2.3.1.2.
hmi | 13.
hmi-spec | 13.
hmi-test | 13.
housing | 12.
ident-sample | 15.1.3.1.
ie | 15.1.4.2.
immersion | 10.2.3.7.
indent-sample | 15.1.3.1.
insulance | 9.3.5.
integration-capability | 15.3.
inter-con | 9.4.1.
inter-emi | 9.4.2.
inter-emi-lab-test | 9.4.2.1.
inter-emi-vehicle-test | 9.4.2.2.
inter-immunity | 9.4.1.1.
inter-immunity-level | 9.5.2.
inter-immunity-level-ref | 9.5.5. 9.5.6.
inter-rad | 9.5.
inter-rad-lab-test | 9.5.5.
inter-rad-vehicle-test | 9.5.6.
inter-signal-con | 9.4.1.1. 9.4.1.1.2.
inter-signal-con-lab-test | 9.4.1.1.3.
inter-signal-con-vehicle-test | 9.4.1.1.4.
inter-supply-con | 9.4.1.1. 9.4.1.1.1. 9.4.1.1.1.1. 9.4.1.1.3. 9.4.2.
inter-supply-con-lab-test | 9.4.1.1.1.1. 9.4.1.1.1.2.
inter-supply-con-vehicle-test | 9.4.1.1.1.2.
interface | 3. 8.1.
interface-class | 8.1.
interface-ref | 8.1.
interface-strength | 10.1.5.
Interfaces | 8.1.
item-label | 15.1.3.1. 15.1.4.
key-data | 5.
kind-wire-arrangement-wiring | 9.8.1.
l-10 | 15.4.
l1 | 15.6.
l10 | 15.6.
l2 | 15.6.
l3 | 15.6.
l4 | 15.6.
label | 15.3.
label | 15.1.3.4.
labeled-list | 15.1.3. 15.1.3.1.
labelling | 12.1.4.
language | 15.4.
list | 15.1.3.
list type="unnumbered" | 15.1.3.
list type="numbered" | 15.1.3.
long-name | 15.1.3.2. 15.1.4.2. 15.1.6.
long-time-high-temp | 10.2.3.2.2.
long-time-low-temp | 10.2.3.2.1.
long-time-temp-tests | 10.2.3.2.
low-temp-store | 10.2.3.1.1.
magnetical-char | 11.
maintenance | 5.
material-selection | 12.1.4.
max | 9.4.1.1.1.1. 9.4.1.2. 9.4.2.1. 9.8.2. 15.1.6.
mea-method-ref | 9.5.5. 9.5.6.
mea-methods | 9.5.1.
mech-char | 10.1.
min | 9.4.1.1.1.1. 9.4.1.2. 9.4.2.1. 9.8.2. 15.1.6.
modifcation | 15.4.
modifcations | 15.4.
modulation-ref | 9.5.5. 9.5.6.
modulations | 9.5.4.
mounting | 12.
msrsw | II.
na | 15.2.
ncoi-1 | 15.1.
ncoi-3 | 8.1.
network | 8.5.
network-spec | 8.5.
nominal-current | 9.2.2.
nominal-power | 9.2.3.
nominal-volt | 9.2.1.
note | 15.1.3.
noxious-gas | 10.2.3.13.
number | 15.1.4.2.
objectives | 15.3.
oper-mode-refs | 9.3.2. 9.4.1.1.4. 9.4.2.1. 9.4.2.2. 9.5.5. 9.5.6.
oper-temp-spec | 10.2.1.1.
optical-char | 11.
optical-design | 12.
other-physical-char | 11.
overall-project | 15.3.
overload-res | 9.3.4.
overvoltage-res | 9.3.2.
overvoltage-res-prms | 9.3.2.
p | 15.1.3. 15.1.4.
parallel-design | 15.3.
part-material-list | 12.1.4.
part-number | 8.1.
part-type | 8.1.
part-type-class | 4.
part-type-ref | 8.1.
part-types | 8.1.
port | 8.1. 8.5.
port-group | 8.1.
port-number | 8.1.
ports | 8.1.
position | 15.1.4.2.
power-char | 9.2.3.
power-supply | 9.2. 9.2.4.
private-code | 15.4.
prm-char | 15.1.6.
prms | 15.1. 15.1.2.
problem-material-list | 12.1.4.
product-demarcation | 5.
product-desc | 5.
product-packaging | 12.1.5.
project-schedule | 15.3.
prot-class-char | 10.2.2.
protocols | 15.3.
publisher | 15.1.4.2.
purchasing-cond | 15.3.
quality | 5.
radio-inter-supp | 9.6.
reason | 15.4.
reason-order | 15.3.
recycling | 12. 12.1. 12.1.1.
recycling-concepts | 12.1.2.
relative-hum | 9.3.5.
remote-radio-inter | 9.6. 9.6.2.
resource-allocation | 5.
reverse-polarity-prot | 9.3.1.
row | 15.1.5.
safety | 5.
saline-fog | 10.2.3.12.
sample-spec | 15.3.
schedule | 15.2.
scratch-res | 10.1.4.1.
seal | 8.1.
self-diagnosis | 5.
shock | 10.1.2.3.
short-circuit-res | 9.3.3.
short-inter-supp | 9.6. 9.6.1.
short-inter-supp-lab-test | 9.6.1.1.
short-inter-supp-vehicle-test | 9.6.1.2.
short-name | 9.4.1.1.1.1. 9.4.1.2. 9.4.2.1. 9.8.2. 15.1.4.2. 15.1.6.
signal-form-vehicle-electronic | 9.8.2.
signal-spec | 8.2.
signals | 3. 8.2.
similar-products | 5.
splash-water | 10.2.3.6.
state | 15.1.4.2.
static-strength | 10.1.1.
std | 15.1.4. 15.1.4.2.
std-test-conf | 6.
stickers-common-surfaces | 10.1.4.2.1.
store-temp-spec | 10.2.1.2.
sub | 15.1.4. 15.1.4.1.
substitute-res | 9.4.2.1.
subtitle | 15.1.4.2.
sup | 15.1.4.1.
surface-char | 10.1.4.
sw-data-dictionary | 15.1.4.2.
system-overview | 15.3.
table | 15.1.3.2. 15.1.5.
tbd | 15.2.
tbody | 15.1.5.
tbr | 15.2.
team-member-ref | 15.2. 15.4.
temp | 10.2.1. 10.2.2.
temp-cycle | 10.2.3.4.
temp-function | 10.2.3.5.
temp-shock | 10.2.3.3.
temp-store | 10.2.3.1.
test-duration | 9.3.1. 9.3.5.
test-equipment-desc | 6.
test-sequence | 9.1.1.
test-temp | 9.3.1. 9.3.5.
test-volt | 9.3.1. 9.4.2.1. 9.4.2.2.
tex-math | 15.1.3.3.
tfoot | 15.1.5.
tgroup | 15.1.5.
thead | 15.1.5.
tol | 9.4.1.1.1.1. 9.4.1.2. 9.8.2. 15.1.6.
topic-1 | 15.1.2.
topic-2 | 15.1.2.
torsional-strength | 10.1.1.1.
tt | 15.1.4. 15.1.4.2.
tt type=material | 15.1.4.2.
tt type=other | 15.1.4.2.
tt type=prm | 15.1.4.2.
tt type=sgml-attribute | 15.1.4.2.
tt type=sgmltag | 15.1.4.2.
tt type=state | 15.1.4.2.
tt type=code | 15.1.4.2.
tt type=control-element | 15.1.4.2.
tt type=organisation | 15.1.4.2.
tt type=product | 15.1.4.2.
tt type=sgmltag | 15.1.4.2.
tt type=tool | 15.1.4.2.
tt type=variable | 15.1.4.2.
typ | 9.4.1.1.1.1. 9.4.1.2. 9.4.2.1. 9.8.2. 15.1.6.
unit | 9.4.1.1.1.1. 9.4.1.2. 9.4.2.1. 9.8.2. 15.1.6.
used-languages | 15.4.
variant-char | 15.5.
variant-def-ref | 8.1.
variant-spec | 15.3.
vehicle-antenna | 9.8.4.
verbatim | 15.1.3. 15.1.3.2. 15.1.3.3.
vibration | 10.1.2.1.
vibration-random-wide-band | 10.1.2.2.
volt-char | 9.2.1.
volt-mismatch | 9.3.7.
waved-nominal-volt | 9.4.1.1. 9.4.1.2.
xdoc | 15.1.4.2.
xfile | 15.1.4.2.
xref |


State

revised
15.1.4.2.


Tools

authoring system | 15.1.4.2.
cut & paste | 15.1.1.
entity manager | 15.1.3.2.
LaTeX | 15.1.3.3.
PDMS | 15.4.
Product Data Management System | 15.4.
rendition system | 15.1.3.2.
rendition system | 15.1.3.1. 15.1.3.2.
semantical check utility | 15.4.
SGML Application | 15.1.3.2.
SGML editor | 15.1.5.
SGML processing system | 15.1.4.2.
SGML processing system | 15.1.4.2.
SGML tool | 15.1.3.2.
split utility | 15.4.
TeX | 15.1.3.3.


Variables

MMRC | 15.1.4.2.
N | 15.1.4.2.
TL | 15.1.4.2.


Untitled

Actually it is up to the rendition system if the sequence is expressed as numbers or as letters.


Untitled

This is the way how this document is prepared. It is visible in the sgml source.


Untitled

it is recommended to enter the term always in singular and create plurals outside of the element (see second example).


Untitled

But many people read footnotes first - so put the interesting stuff in footnotes


Untitled

For definition of an exact setting or measurement value.


Untitled

For definition of a typical value or value range.


Untitled

DTDs with the same version of the MSR application profile


Untitled

the other option would be to have an extra element for each chapter level


Untitled

it is not really easy to distinguish between these two elements. As a rule of thumb, one might say that the semantics of def-list is stronger than the one of labeled-list which is more layout oriented. The items of def-list can be referenced by xref which is not possible with the items of a labeled-list.


Untitled

In that respect, it is recommended to nest not more than four levels.


Untitled

This can be used for systems which can't display graphics.


Untitled

Note that in MSRDOC.DTD there are means to formally describe variables to be used if the system software of an ECU is specified.