Element Attribute Documentation
MSRSW V2.3.0 (single language)
[MSRSW-eadoc]
Revision: 1.1
This document describes MSRSW-230 including the extensions for the architecture driven design of engine control units.
It is intended to serve as a DTD reference and a global description of semantics. This document will be accompanied by a explicit use case description which specifies the particular usage of the elements and the domain specific aspects of the semantics in greater detail.


I. About this document

Element Attribute Documentation
I. About this document

Contents of this chapter:
  • I.1. Purpose of this document
  • I.2. Intended audience


I.1. Purpose of this document

This document describes MSRSW-230 including the extensions for the architecture driven design of engine control units.
It is intended to serve as a DTD reference and a global description of semantics. This document will be accompanied by a explicit use case description which specifies the particular usage of the elements and the domain specific aspects of the semantics in greater detail.
It is a working document which is delivered as is and which is constantly updated and enhanced. Not all elements are described up to now. But the overall structure can be recognized.


I.2. Intended audience

This document is intended for process developers and tool developers.


II. Document management

Element Attribute Documentation
II. Document management

Team members
Name | Company | {CONTACT}
Bernhard Weichel | MSR MEDOC | Department: Robert Bosch GmbH, GS-EC/EMT4
Mikael Berling | MSR MEDOC | Department: Robert Bosch GmbH, GS-EC/EMT4
Gottfried Frenzen | MSR MEDOC | Department: Robert Bosch GmbH, GS-EC/EMT4
Herbert Klein | MSR MEDOC | Department: XI-Works
Version overview
Version | Date | Editor | State
1.1 | 2005-05-31 | Herbert Klein | Release
1.0 | 2005-02-16 | Gottfried Frenzen | Draft
Modifications
Version | Change | Related to
1.1 | Adapt document to MSRSW V2.3.0 | Content
Modifications included
Date | Chapter | Change | Related to
2005-05-31 | Gesamt | Adapt document to MSRSW V2.3.0 | Content


1. Standard Attributes

Element Attribute Documentation
1. Standard Attributes
See Also Description Example Formal Description

Description
These attribute are so called Standard Attributes since they occur on every element within the DTD. They will only be described here to save document space.
Example
Formal Description
Name | Type | Values / Default | Notes
[S] (implied) | cdata |  | Signature under which the calculated signature belonging to the contents of an element, can be stored, e.g. CRC.
[SI] (implied) | cdata |  | Description of the semantic meaning of an element.
[SYSCOND] (implied) | cdata |  | Makes it possible to differ between a view on a instance and a content switch based on a system constant. For more details how this attribute ist to be filled, please refer to 2.630. SW-SYSCOND
[T] (implied) | cdata |  | Time stamp specification
[VIEW] (implied) | cdata |  | Arbitrary term for realization of a conceptual view. In this way, text components can be inserted or masked out in editor, or when a document is generated.


2. Elemente der MSRSW DTD

Element Attribute Documentation
2. Elemente der MSRSW DTD


2.1. ABS
See Also Description Example Formal Description

Description
Use <ABS> to enter the absolute values of a parameter in a parameter table.
Example
<ABS>5</ABS>
Formal Description
Within context of: | PRM-CHAR
Is context for: | Text, SUP, SUB


2.2. ACCEPTANCE-COND

Description
Use <ACCEPTANCE-COND>, to enter the conditions of approval . The condtitions can be entered in report style in the element <NCOI-1>.
Example
This sample uses has an introduction which is followed by a <NCOI-1> containing descriptive chapters.
<ACCEPTANCE-COND>
                  <INTRODUCTION>
                    <P>Introduction to the conditions...</P>
                  </INTRODUCTION>
                  <NCOI-1>
                    <CHAPTER>
                      <LONG-NAME>Overview</LONG-NAME>
                      <P>Text ...</P>
                    </CHAPTER>
                    <CHAPTER>
                      <LONG-NAME>Deliveries</LONG-NAME>
                      <P>Text ...</P>
                    </CHAPTER>
                  </NCOI-1>
                </ACCEPTANCE-COND>
Formal Description
Within context of: | GENERAL-PROJECT-DATA
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.3. ADD-DESIGN-DOC

Description
The opportunity to describe and reference additional development documents in the form of continuous text.
Use <ADD-DESIGN-DOC>, to insert additional development documents .
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.4. ADD-INFO

Description
<ADD-INFO> gives the opportunity to provide additional information to a structure in the form of continuous text. The element is a subset of a <CHAPTER> element which enables a several ways of expressions.
Example
This sample shows a typedefinition with an <ADD-INFO> at the end showing the desired definition in C syntax.
<SW-CLASS>
                  <LONG-NAME>type of pointer of pointer to a constant object of one_level_t</LONG-NAME>
                  <SHORT-NAME>pointer_pointer_t</SHORT-NAME>
                  <CATEGORY>SIMPLE_TYPEDEF</CATEGORY>
                  <SW-DATA-DEF-PROPS>
                    <SW-POINTER>
                      <SW-DATA-DEF-PROPS>
                        <SW-POINTER>
                          <SW-DATA-DEF-PROPS>
                            <SW-CLASS-REF>one_level_t</SW-CLASS-REF>
                            <SW-IMPL-POLICY>STANDARD_CONST</SW-IMPL-POLICY>
                          </SW-DATA-DEF-PROPS>
                        </SW-POINTER>
                      </SW-DATA-DEF-PROPS>
                    </SW-POINTER>
                  </SW-DATA-DEF-PROPS>
                  <ADD-INFO>
                    <VERBATIM>typedef const one_level_t ** pointer_pointer_t;</VERBATIM>
                  </ADD-INFO>
                </SW-CLASS>
Formal Description
Within context of: | REQUIREMENT, SW-CALIBRATION-METHOD, SW-CALIBRATION-METHOD-SPEC, SW-CALPRM, SW-CALPRM-PROTOTYPE, SW-CLASS, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-COLLECTION-SPEC, SW-COMPONENT-SPEC, SW-CPU-SPEC, SW-DATA-DEF-PROPS, SW-DATA-DICTIONARY-SPEC, SW-FEATURE, SW-INSTANCE-SPEC, SW-OPER-MODE, SW-SCHEDULING-SPEC, SW-SERVICE, SW-SERVICE-PROTOTYPE, SW-TASK, SW-TASK-SPEC, SW-UNIT, SW-USER-RIGHT-SPEC, SW-VARIABLE, SW-VARIABLE-PROTOTYPE, SW-VCD-SPEC
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, SYN-SYNOPSIS, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.5. ADD-INFO-5

Description
<ADD-INFO-5> has the same purpose as the <ADD-INFO> element and gives the opportunity to provide additional information to a structure in the form of continuous text. The only difference is that <ADD-INFO-5> has a limited set of elements. The information can only be entered in one level since no subchapters or topics are available.
Example
This sample show how some information has been added to describe a Service Argument.
<SW-SERVICE-ARG>
                                 <LONG-NAME>Temp Input Value</LONG-NAME>
                   <SHORT-NAME>gTemp</SHORT-NAME>
                                 <SW-DATA-DEF-PROPS>
                                          <SW-BASE-TYPE-REF>real32</SW-BASE-TYPE-REF>
                                 </SW-DATA-DEF-PROPS>
                   <ADD-INFO-5>
                     <P>It might seem unnecessary to take the gTemp into account, but....</P>
                   </ADD-INFO-5>
                </SW-SERVICE-ARG>
Formal Description
Within context of: | CONF-ITEM, CONF-PRO-VALUE, SW-SERVICE-ARG, SW-SERVICE-RETURN, SYN-ARGUMENT, SYN-EXAMPLE, SYN-RETURN-VALUE, SYN-SEMANTICS
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, SYN-SYNOPSIS, TABLE, MSR-QUERY-P-1


2.6. ADD-SPEC

Description
This element provides you with the opportunity to add additional specifications. The specification can have an introduction and a arbitrary amount of underlying chapters. The chapters are wrapped by the <NCOI-1> element.
Example
<ADD-SPEC>
                  <INTRODUCTION>
                    <P>This component must provide....</P>
                  </INTRODUCION>
                  <NCOI-1>
                    <CHAPTER>
                      <LONG-NAME>Overview</LONG-NAME>
                      <P>.......</P>
                    </CHAPTER>
                  </NCOI-1>
                <ADD-SPEC>
Formal Description
Within context of: | CONTRACT-ASPECTS, DATA-REQUIREMENTS, DESIGN-REQUIREMENTS, FAILURE-MANAGEMENT, FUNCTIONAL-REQUIREMENTS, GENERAL-HARDWARE, GENERAL-INTERFACES, GENERAL-PRODUCT-DATA-1, GENERAL-PROJECT-DATA, GENERAL-REQUIREMENTS, GENERAL-SOFTWARE, SW-ARCHITECTURE, SW-SYSTEM
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.7. ADDRESS

Description
Use <ADDRESS> , to enter the street name of the company address, e.g. where a project participant is located. One line can be entered since all carriage returns typically are ignored.
Example
<ADDRESS>Quilt Steet 43</ADDRESS>
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text


2.8. ADMIN-DATA

Description
<ADMIN-DATA> can be used to set administrative information for an element. This administration information is to be treated as metadata such as revision id or state of the file. There are basically four kinds of metadata
  • The language and/or used laguages.
  • Revision information covering e.g. revision number, state, release date, changes. Note that this information can be given in general as well as related to a particular company.
  • Document metadata specific for a company
  • Formatting controls that can affect layouts for example.
  • Revision information for the element.
Example
This sample shows how the language and some revision information has been defined for an element.
  <ADMIN-DATA>
                   <LANGUAGE>en</LANGUAGE>
                   <DOC-REVISIONS>
                      <DOC-REVISION>
                         <REVISION-LABEL>2</REVISION-LABEL>
                             <STATE>review-candiate</STATE>
                         <TEAM-MEMBER-REF ID-REF="wl">Wl</TEAM-MEMBER-REF>
                         <DATE>15.8.2001</DATE>
                         <MODIFICATIONS>
                            <MODIFICATION>
                               <CHANGE>fixed typos</CHANGE>
                               <REASON>typos were found in the internal review</REASON>
                            </MODIFICATION>
                         </MODIFICATIONS>
                      </DOC-REVISION>
                      <DOC-REVISION>
                         <REVISION-LABEL>1</REVISION-LABEL>
                         <STATE>initial draft</STATE>
                         <TEAM-MEMBER-REF ID-REF="wl">Wl</TEAM-MEMBER-REF>
                         <DATE>12.8.2001</DATE>
                         <MODIFICATIONS>
                            <MODIFICATION>
                               <CHANGE>Created the document</CHANGE>
                               <REASON>According to video-conference held at Jul2001</REASON>
                            </MODIFICATION>
                         </MODIFICATIONS>
                      </DOC-REVISION>
                   </DOC-REVISIONS>
                </ADMIN-DATA>
Formal Description
Within context of:
CHAPTER, CONF-ITEMS, CONF-RULE, CONF-RULES, FUNCTIONAL-REQUIREMENTS, GENERAL-PRODUCT-DATA-1, GENERAL-PROJECT-DATA, GENERAL-REQUIREMENTS, MSRSW, REQUIREMENT, REQUIREMENT-SPEC, SW-ADDR-METHOD, SW-ADDR-METHODS, SW-ARCHITECTURE, SW-AXIS-TYPE, SW-AXIS-TYPES, SW-BASE-TYPE, SW-BASE-TYPES, SW-CALIBRATION-METHOD, SW-CALIBRATION-METHOD-SPEC, SW-CALPRM, SW-CALPRM-PROTOTYPE, SW-CALPRMS, SW-CLASS, SW-CLASS-ATTR-IMPL, SW-CLASS-INSTANCE, SW-CLASS-INSTANCES, SW-CLASS-PROTOTYPE, SW-CLASSES, SW-CODE-SYNTAX, SW-CODE-SYNTAXES, SW-COLLECTION, SW-COLLECTION-SPEC, SW-COMPONENT-SPEC, SW-COMPU-METHOD, SW-COMPU-METHODS, SW-CPU-MEM-SEG, SW-CPU-SPEC, SW-DATA-CONSTR, SW-DATA-CONSTRS, SW-DATA-DICTIONARY-SPEC, SW-EVENT-SPEC, SW-FEATURE, SW-FEATURE-INTERFACE, SW-GENERIC-AXIS-PARAM-TYPE, SW-GLOSSARY, SW-INSTANCE, SW-INSTANCE-PROPS-VARIANT, SW-INSTANCE-SPEC, SW-INSTANCE-TREE, SW-MC-BASE-TYPE, SW-MC-COMMUNICATION-SPEC, SW-MC-FRAME, SW-MC-INTERFACE, SW-MC-INTERFACE-IMPL, SW-MC-INTERFACE-SOURCE, SW-MC-INTERFACE-SPEC, SW-OPER-MODE-SPEC, SW-RECORD-LAYOUT, SW-RECORD-LAYOUTS, SW-SCHEDULING-SPEC, SW-SERVICE, SW-SERVICE-PROTOTYPE, SW-SERVICES, SW-SYSTEM, SW-SYSTEMCONST, SW-SYSTEMCONSTS, SW-TASK, SW-TASK-SPEC, SW-TEMPLATE, SW-TEMPLATES, SW-UNIT, SW-UNITS, SW-USER-ACCESS-CASE, SW-USER-GROUP, SW-USER-RIGHT-SPEC, SW-VARIABLE, SW-VARIABLE-PROTOTYPE, SW-VARIABLES, SW-VCD-CRITERION, SW-VCD-SPEC
Is context for:
LANGUAGE, USED-LANGUAGES, COMPANY-DOC-INFOS, FORMATTER-CTRLS, DOC-REVISIONS


2.9. ANNOTATION

Description
Textual comments are stored in this element, which refer to the object that is to be described. These are intended for use during the development process, to transfer information from one stage to the next. In this way, a specific note can be passed on from the function development, for instance, to the calibration phase.
A comment consists of:
  • Heading ( <LABEL> ), clearly indicating the comments
  • Origin of the comment: e.g. a tool or a process phase ( <ANNOTATION-ORIGIN> )
  • the comment itself (text) ( <ANNOTATION-TEXT> )
Example
<ANNOTATION>
                  <LABEL>Todo</LABEL>
                  <ANNOTATION-ORIGIN>Brainstorming</ANNOTATION-ORIGIN>
                  <ANNOTATION-TEXT>
                    <P>Check this with the developer.</P>
                  </ANNOTATION-TEXT>
                </ANNOTATION>
Formal Description
Within context of: | ANNOTATIONS, SW-COLLECTION
Is context for: | LABEL, ANNOTATION-ORIGIN, ANNOTATION-TEXT


2.10. ANNOTATION-ORIGIN

Description
This element identifies the origin of a comment, which may be passed on through various process phases for instance.
Example
<ANNOTATION>
                   <LABEL>Do not change this</LABEL>
                   <ANNOTATION-ORIGIN>funcdev</ANNOTATION-ORIGIN>
                   <ANNOTATION-TEXT>
                      <P>This feature should not be changed, even if the custormer
                      requests it. You should tell him that it risks serious trouble.</P>
                   </ANNOTATION-TEXT>
                </ANNOTATION>
Formal Description
Within context of: | ANNOTATION
Is context for: | Text


2.11. ANNOTATION-TEXT

Description
This element contains paragraphs <P> or <VERBATIM> for specifying a textual comment in an <ANNOTATION> .
Example
Please refer to ANNOTATION for a sample.
Formal Description
Within context of: | ANNOTATION
Is context for: | P, VERBATIM


2.12. ANNOTATIONS

Description
Container-Element for <ANNOTATION> , please refer to ANNOTATION for more information.
Example
Please refer to ANNOTATION for samples.
Formal Description
Within context of: | SW-CALPRM, SW-CALPRM-PROTOTYPE, SW-CLASS, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-DATA-DEF-PROPS, SW-FEATURE, SW-INSTANCE-PROPS-VARIANT, SW-SERVICE-PROTOTYPE, SW-VARIABLE, SW-VARIABLE-PROTOTYPE
Is context for: | ANNOTATION


2.13. AREA

Description
This element specifies a region in an image map. Image maps enable authors to specify regions in an object (e.g. a graphic) and to assign a specific activity to each region (e.g. load a document, launch a program etc.).
Example
  <AREA SHAPE="RECT" COORDS="63,28,99,46" HREF="msrrep-id:EADOC-SUP"/>
Formal Description
Within context of: | MAP
Has no contents. |
Name
Type
Values / Default
Notes
[SHAPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • RECT
  • CIRCLE
  • POLY
  • DEFAULT
The interpretation of the coordinates [COORDS] is controlled by the value of [SHAPE] .
[ACCESSKEY]
optional
String (CDATA)
This attribute assigns an access key to an element. An access key is an individual character (e.g. "B") within the document character range. If an access key with an element assigned to it is pressed, the element comes into focus. The activity performed when an element comes into focus, is dependent on the element itself.
[ALT]
optional
String (CDATA)
This attribute specifies the text to be inserted as an alternative to illustrations, shapes or applets, where these cannot be displayed by user agents.
[CLASS]
optional
String (CDATA)
Blank separated list of classes
[COORDS]
optional
String (CDATA)
This attribute specifies the position and shape on the screen. The number of values and their order depend on the geometrical figure defined. Possible combinations are:
[HREF]
optional
String (CDATA)
This attribute specifies the memory location of a web resource. It is therefore able to specify a link between the current element and the target element.
[ID]
optional
ID (ID)
Unambiguous identifier of the element within the document.
[NOHREF]
optional
Value selection (NAMEDTOKENGROUP)
  • NOHREF
If this attribute is set, <AREA> has no associated link.
[ONBLUR]
optional
String (CDATA)
The ONBLUR-Event occurs, when focus is switched away from an element. A script can be stored in this attribute to be performed in the Event.
[ONCLICK]
optional
String (CDATA)
The ONCLICK-Event occurs, if the current element is clicked-on. A script can be stored in this attribute to be performed in the Event.
[ONDBLCLICK]
optional
String (CDATA)
The ONDBLCLICK-Event occurs, if the current Event is clicked-on. A script can be stored in this attribute to be performed in the Event.
[ONFOCUS]
optional
String (CDATA)
The ONFOCUS-Event occurs, if an element comes into focus (e.g. through navigation using the tab button). A script can be stored in this attribute to be performed in the Event.
[ONKEYDOWN]
optional
String (CDATA)
The ONKEYDOWN-Event occurs, if a button on the current element is pressed down. A script can be stored in this attribute to be performed in the Event.
[ONKEYPRESS]
optional
String (CDATA)
The ONKEYPRESS-Event occurs, if a button on the current element is pressed down and released. A script can be stored in this attribute to be performed in the Event.
[ONKEYUP]
optional
String (CDATA)
The ONKEYUP-Event occurs, if a button on the current element is released. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEDOWN]
optional
String (CDATA)
The ONMOUSEDOWN-Event occurs, if the mouse button used for clicking is held down on the current element. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEMOVE]
optional
String (CDATA)
The ONMOUSEMOVE-Event occurs, if the mouse pointer is moved on the current element (i.e. it is located on the current element). A script can be stored in this attribute to be performed in the Event.
[ONMOUSEOUT]
optional
String (CDATA)
The ONMOUSEOUT-Event occurs, if the mouse pointer is moved from the current element. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEOVER]
optional
String (CDATA)
The ONMOUSEOVER-Event occurs, if the mouse pointer is moved to the current element from another location outside it. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEUP]
optional
String (CDATA)
The ONMOUSEUP-Event occurs if the mouse button used for clicking is released on the current element. A script can be stored in this attribute to be performed in the Event.
[STYLE]
optional
String (CDATA)
Information on the associated style
[TABINDEX]
optional
String (CDATA)
This attribute specifies the position of the current element in tabbing-order for the corresponding document. The value must lie between 0 and 32767. The Tabbing Order defines the sequence in which elements are focused on, when the user navigates using the keyboard.
[TITLE]
optional
String (CDATA)
Title information of the <AREA> -element


2.14. AVAILABILITY

Description
Use <AVAILABILITY>, to enter availability .
Example
Formal Description
Within context of: | USEFUL-LIFE-PRMS
Is context for: | LONG-NAME, SHORT-NAME, DESC, PRM-CHAR
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | PRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.15. BINARY-COMPATIBILITY

Description
Use <BINARY-COMPATIBILITY>, to enter binary compatibility .
Example
Formal Description
Within context of: | GENERAL-SOFTWARE
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.16. BIT-POSITION

Description
This element is used by a Variable that actually is a part of an other Variable called Host Variable. The BIT-POSITION points out the starting point of the Variable in the Host Variable.
Example
<BIT-POSITION>4</BIT-POSITION>
Formal Description
Within context of: | SW-BIT-REPRESENTATION
Is context for: | Text


2.17. BR

Description
This element is the same as function here as in a HTML document i.e. it forces a line break.
Example
<P>The first row<BR/>the second row</P>
Formal Description
Within context of: | P, TBR, VERBATIM
Has no contents. |


2.18. BYTE-ORDER

Description
This element specifies the byte order of the parent element. The byte order is defined with the attribute [TYPE]. Possible values are:
  • MOST-SIGNIFICANT-BYTE-FIRST
  • MOST-SIGNIFICANT-BYTE-LAST
Example
<BYTE-ORDER TYPE="MOST-SIGNIFICANT-BYTE-FIRST"/>
Formal Description
Within context of: | SW-BASE-TYPE, SW-CPU-SPEC, SW-MC-BASE-TYPE
Is context for: | Text
Name
Type
Values / Default
Notes
[TYPE]
required
Value selection (NAMEDTOKENGROUP)
  • MOST-SIGNIFICANT-BYTE-FIRST
  • MOST-SIGNIFICANT-BYTE-LAST


2.19. C-CODE

Description
Use <C-CODE> to insert a formula defined as C-Code.
Example
Formal Description
Within context of: | FORMULA
Is context for: | Text


2.20. C-IDENTIFIER

Description
This element enables the insertion of a conversion formula identifier in tabular form, in accordance with the programming language, C. This means that the mapping of conversion formulae in C-enumerators can be supported.
Example
Formal Description
Within context of: | SW-COMPU-SCALE
Is context for: | Text


2.21. CALIBRATION

Description
Use <CALIBRATION>, to insert commands for calibration .
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.22. CATEGORY

Description
This element assigns a category to the parent element. The category can be used by a semantic checker in post-processes to ensure that the parent object is defined correctly i.e. has the right number of elements for example.
Example
This example shows how <CATEGORY> is used to qualify a calibration parameter as a map. Further processing could now establish whether two axes also has to be specified.
<SW-CALPRM>
                   <SHORT-NAME>KF_XYZ</SHORT-NAME>
                   <CATEGORY>MAP</CATEGORY>
                   ...
                <SW-CALPRM>
Formal Description
Within context of: | CONF-ITEM, CONF-RULE, MSRSW, REQUIREMENT, SW-ADDR-METHOD, SW-AXIS-TYPE, SW-BASE-TYPE, SW-CALIBRATION-METHOD, SW-CALPRM, SW-CALPRM-PROTOTYPE, SW-CLASS, SW-CLASS-ATTR-IMPL, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-CODE-SYNTAX, SW-COLLECTION, SW-COMPU-METHOD, SW-CPU-MEM-SEG, SW-DATA-CONSTR, SW-EVENT, SW-EVENT-SOURCE, SW-FEATURE, SW-FEATURE-INTERFACE, SW-FEATURE-VARIANT, SW-GENERIC-AXIS-PARAM-TYPE, SW-INSTANCE, SW-INSTANCE-TREE, SW-MC-BASE-TYPE, SW-MC-FRAME, SW-MC-INTERFACE, SW-MC-INTERFACE-SOURCE, SW-OPER-MODE, SW-RECORD-LAYOUT, SW-SERVICE, SW-SERVICE-ARG, SW-SERVICE-PROTOTYPE, SW-SERVICE-RETURN, SW-SYSTEM, SW-SYSTEMCONST, SW-TASK, SW-TEMPLATE, SW-UNIT, SW-USER-ACCESS-CASE, SW-USER-GROUP, SW-VARIABLE, SW-VARIABLE-PROTOTYPE, SW-VCD-CRITERION, SYN-CAPTION
Is context for: | Text


2.23. CHANGE

Description
<CHANGE> is used to enter a modification text for a <MODIFICATION> element. The element has the same contents and features as a normal Pararagraf element <P>.
Example
<CHANGE>This code is now optimized for <TT TYPE="PRODUCT">C#</TT>.</CHANGE>
Formal Description
Within context of: | MODIFICATION
Is context for: | Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, MSR-QUERY-TEXT


2.24. CHAPTER

Description
Use <CHAPTER> , to create a chapter structure.
Example
Formal Description
Within context of: | ADD-INFO, CHAPTER, CONF-RULE-DOC, CRITICAL-ASPECTS, FREE-INFO, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-CHAPTER, NCOI-1, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-COMPONENTS, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS
Is context for: | LONG-NAME, SHORT-NAME, ADMIN-DATA, INTRODUCTION, P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, SYN-SYNOPSIS, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name
Type
Values / Default
Notes
[BREAK]
optional
Value selection (NAMEDTOKENGROUP)
  • BREAK
  • NO-BREAK
Select BREAK to insert a page break ahead of the chapter title.
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the parent element. The syntax has its origins in the help system utilized. This is often used to calculate an object ID or a widget name hierarchy from a window system, which is then correlated with the help entries.
[ID]
optional
ID (ID)
Unambiguous identifier of the element within the document.
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[F-ID-CLASS]
fixed value
SGML string (NMTOKEN)
CHAPTER
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.25. CITY

Description
Use <CITY> to enter the city in the company address where a project participant is located.
Example
<CITY>London</CITY>
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text


2.26. CODE

Description
Use CODE, to enter the code .
A variant definition requires a variant code, variant characteristics, or values for variant characteristics. The code can be a number or a name.
Example
Formal Description
Within context of: | VARIANT-CHAR, VARIANT-CHAR-VALUE, VARIANT-DEF
Is context for: | Text


2.27. COLSPEC

Description
Use <COLSPEC> , to insert and specify a column in a table.
Example
<COLSPEC COLNAME="col1" COLNUM="1" COLWIDTH="1.00*"/>
Formal Description
Within context of: | TFOOT, TGROUP, THEAD
Has no contents. |
Name
Type
Values / Default
Notes
[ALIGN]
optional
Value selection (NAMEDTOKENGROUP)
  • LEFT
  • RIGHT
  • CENTER
  • JUSTIFY
  • CHAR
LEFT - The table contents is justified left. RIGHT - The table contents is justified right. CENTER - The table contents is centered horizontally. JUSTIFY - The table contents is displayed with justified typesetting. There is an equal distance from the left and right-hand edges of the cell. CHAR - The alignment of the table contents is set by [CHAR] .
[CHAR]
optional
String (CDATA)
If [ALIGN]="CHAR", this one-character value of [CHAR] specifies the alignment sign e.g. "bzlw", as a decimal point separator. The sign cannot be a SDATA entity.
[CHAROFF]
optional
SGML string (NMTOKEN)
If [ALIGN]="CHAROFF", this value indicates the percentage of the current column width to the left edge of the alignment sign in the [CHAR]-attribute. If there is no alignment sign in the element <COLSPEC>, alignment is always horizontal right. The default value is taken from <TGROUP> .
[COLNAME]
optional
SGML string (NMTOKEN)
Now, specify an identification name for the column that has been modified, e.g. column1 for the first one.
[COLNUM]
optional
SGML string (NMTOKEN)
At this point you should specify the placement of the modified column within the table, e.g. 1 for the first column.
[COLSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the column guides are to be visible. You should enter 0, if no column guides are to be displayed. You should enter 1 , if the column guides are to be displayed.
[COLWIDTH]
optional
String (CDATA)
Next, specify the width of the modified column in the table. You can enter absolute values such as 4 cm, or relative values marked with *, e.g. 2* for column widths double those of other columns.
[ROWSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the column guides are to be visible. You should enter 0, if no row guides are to be displayed. You should enter 1 , if the row guides are to be displayed.


2.28. COMMENT

Description
This element contains a commentary in text form.
Example
<COMMENT>This section is maintained by John.</COMMENT>
Formal Description
Within context of: | MSR-QUERY-PROPS
Is context for: | Text


2.29. COMMUNICATION

Description
This element contains the functional requirements concerning communication, in text form.
Example
Formal Description
Within context of: | FUNCTIONAL-REQUIREMENTS
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.30. COMMUNICATION-INTERFACE

Description
Use COMMUNICATION-INTERFACE, to enter the communication interfaces .
Example
Formal Description
Within context of: | GENERAL-INTERFACES
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.31. COMPANIES

Description
<COMPANIES> can be used to describe the companies involved in the project. The company responsible for the generation or maintenance of the file or some parts of the file is determined by a <TEAM-MEMBER-REF> within <ADMIN-DATA> . In simple cases there is only one company.
Example
Formal Description
Within context of: | PROJECT
Is context for: | COMPANY


2.32. COMPANY

Description
Use <COMPANY> , to describe the company, its role and its members.
Example
Formal Description
Within context of: | COMPANIES
Is context for: | LONG-NAME, SHORT-NAME, ROLES, TEAM-MEMBERS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[ROLE] optional | SGML string (NMTOKEN) |  | Select MANUFACTURER, if the company participating in the project is a manufacturer/partner. Select SUPPLIER, if this is the function of the company participating in the project.
[F-CHILD-TYPE] fixed value | String (CDATA) | LONG-NAME:SELECTION | Fixed Child Type. Warning: This attribute is included in the DTD for compatibility with older versions and should not be used for any new implementations. It may be removed in future versions of the DTD. The attribute contains information stating which child elements of the element carrying this attribute, should be checked by an semantic checker.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | COMPANY | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | TEAM-MEMBER | Fixed Namespace. This attribute is assigned to elements which define a namespace for linkable objects. The attribute contains a list of elements, where the element carrying the attribute serves as a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names including the namespaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')


2.33. COMPANY-DOC-INFO

Description
Use <COMPANY-DOC-INFO> , to generate document information on the companies participating in the project.
Example
Formal Description
Within context of: | COMPANY-DOC-INFOS
Is context for: | COMPANY-REF, DOC-LABEL, TEAM-MEMBER-REF, PRIVATE-CODES, ENTITY-NAME, SDGS


2.34. COMPANY-DOC-INFOS

Description
Use <COMPANY-DOC-INFOS> , to generate a summary of the document information on the companies participating in the project.
Example
Formal Description
Within context of: | ADMIN-DATA
Is context for: | COMPANY-DOC-INFO


2.35. COMPANY-REF

Description
Use <COMPANY-REF> , to refer to the company for which you wish to generate corporate-specific document information.
Example
Formal Description
Within context of: | COMPANY-DOC-INFO, COMPANY-REVISION-INFO
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | COMPANY | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF) used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.36. COMPANY-REVISION-INFO

Description
Use <COMPANY-REVISION-INFO> , to generate information on document version within the respective company.
Example
Formal Description
Within context of: | COMPANY-REVISION-INFOS
Is context for: | COMPANY-REF, REVISION-LABEL, REVISION-LABEL-P1, REVISION-LABEL-P2, STATE


2.37. COMPANY-REVISION-INFOS

Description
Use <COMPANY-REVISION-INFOS> , to generate a summary of the information on document version within a company.
Example
Formal Description
Within context of: | DOC-REVISION
Is context for: | COMPANY-REVISION-INFO


2.38. COMPATIBILITY

Description
Use <COMPATIBILITY>, to describe the similarity to other systems / compatibility .
Example
Formal Description
Within context of: | GENERAL-SOFTWARE
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.39. COND

Description
Use <COND> , to enter marginal conditions for which parameter values are valid.
Example
Formal Description
Within context of: | PRM-CHAR
Is context for: | P


2.40. CONF-DEFAULT-VALUE

Description
Example
Formal Description
Within context of: | CONF-VALUE-PROPS
Is context for: | VF, VT, V, SW-INSTANCE-REF


2.41. CONF-FORWARDING

Description
Example
Formal Description
Within context of: | CONF-RULE
Is context for: | CONF-RULE-REFS


2.42. CONF-ITEM

Description
Example
Formal Description
Within context of: | CONF-ITEMS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, SW-SYSCOND, CONF-RULES-EDITION, VF, VT, V, SW-INSTANCE-REF, ADD-INFO-5, CONF-PRO-VALUES, CONF-ITEMS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | CONF-ITEM |


2.43. CONF-ITEM-CODED-REF

Description
Example
Formal Description
Within context of: | LOWER-LIMIT, MAX-TEXT-LENGTH, MIN-INCR-SIZE, MIN-TEXT-LENGTH, SW-CALPRM-MAX-TEXT-SIZE, SW-COMPU-GENERIC-MATH, SW-DATA-DEPENDENCY-ARGS, SW-MAX-AXIS-POINTS, SW-MIN-AXIS-POINTS, SW-NUMBER-OF-AXIS-POINTS, SW-SYSCOND, UPPER-LIMIT, VF
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | CONF-ITEM |
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF |
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK |


2.44. CONF-ITEM-PHYS-REF

Description
Example
Formal Description
Within context of: | LOWER-LIMIT, MAX-TEXT-LENGTH, MIN-INCR-SIZE, MIN-TEXT-LENGTH, SW-CALPRM-MAX-TEXT-SIZE, SW-COMPU-GENERIC-MATH, SW-DATA-DEPENDENCY-ARGS, SW-MAX-AXIS-POINTS, SW-MIN-AXIS-POINTS, SW-NUMBER-OF-AXIS-POINTS, SW-SYSCOND, UPPER-LIMIT, VF
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | CONF-ITEM |
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF |
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK |


2.45. CONF-ITEMS

Description
Example
Formal Description
Within context of: | CONF-ITEM, CONF-SPEC
Is context for: | ADMIN-DATA, CONF-SOURCE, CONF-ITEM


2.46. CONF-KEY-COUNT

Description
Example
Formal Description
Within context of: | CONF-KEY-SPEC
Is context for: | LOWER-LIMIT, UPPER-LIMIT


2.47. CONF-KEY-ITEM

Description
Example
Formal Description
Within context of: | CONF-KEY-SPEC
Is context for: | CONF-RULE-REF


2.48. CONF-KEY-LOOKUP

Description
Example
Formal Description
Within context of: | CONF-VALUE-PROPS
Is context for: | CONF-RULE-REF


2.49. CONF-KEY-SPEC

Description
Example
Formal Description
Within context of: | CONF-RULE
Is context for: | CONF-KEY-ITEM, CONF-KEY-COUNT


2.50. CONF-PRO-VALUE

Description
Example
Formal Description
Within context of: | CONF-PRO-VALUES
Is context for: | CONF-SOURCE, VF, VT, V, SW-INSTANCE-REF, ADD-INFO-5


2.51. CONF-PRO-VALUES

Description
Example
Formal Description
Within context of: | CONF-ITEM
Is context for: | CONF-PRO-VALUE


2.52. CONF-RULE

Description
Example
Formal Description
Within context of: | CONF-RULES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-SYSCOND, CONF-RULES-EDITION, CONF-FORWARDING, CONF-RULE-DOC, CONF-SOURCES, CONF-KEY-SPEC, CONF-VALUE-PROPS, CONF-RULES
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | CONF-RULE |


2.53. CONF-RULE-DOC

Description
Example
Formal Description
Within context of: | CONF-RULE
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.54. CONF-RULE-REF

Description
Example
Formal Description
Within context of: | CONF-KEY-ITEM, CONF-KEY-LOOKUP, CONF-RULE-REF-SYSCOND, CONF-RULE-REFS
Is context for: | Text
Name | Type | Values / Default | Notes
[F-ID-CLASS] has default value | String (CDATA) | CONF-RULE |
[ID-REF] optional | ID reference (IDREF) |  |
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF |
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK |


2.55. CONF-RULE-REF-SYSCOND

Description
Example
Formal Description
Within context of: | CONF-RULE-REFS
Is context for: | CONF-RULE-REF, SW-SYSCOND


2.56. CONF-RULE-REFS

Description
Example
Formal Description
Within context of: | CONF-FORWARDING, SW-FEATURE-ELEMENTS
Is context for: | CONF-RULE-REF, CONF-RULE-REF-SYSCOND


2.57. CONF-RULES

Description
Example
Formal Description
Within context of: | CONF-RULE, CONF-SPEC
Is context for: | ADMIN-DATA, CONF-RULE


2.58. CONF-RULES-EDITION

Description
Example
Formal Description
Within context of: | CONF-ITEM, CONF-RULE
Is context for: | Text


2.59. CONF-SOURCE

Description
Example
Formal Description
Within context of: | CONF-ITEMS, CONF-PRO-VALUE
Is context for: | SW-FEATURE-REF


2.60. CONF-SOURCE-COUNT

Description
Example
Formal Description
Within context of: | CONF-SOURCES
Is context for: | LOWER-LIMIT, UPPER-LIMIT


2.61. CONF-SOURCES

Description
Example
Formal Description
Within context of: | CONF-RULE
Is context for: | CONF-SOURCES-REQUIRED, CONF-SOURCES-OPTIONAL, CONF-SOURCES-PROHIBITED, CONF-SOURCE-COUNT


2.62. CONF-SOURCES-OPTIONAL

Description
Example
Formal Description
Within context of: | CONF-SOURCES
Is context for: | SW-INTERFACE-EXPORT-SCOPE


2.63. CONF-SOURCES-PROHIBITED

Description
Example
Formal Description
Within context of: | CONF-SOURCES
Is context for: | SW-INTERFACE-EXPORT-SCOPE


2.64. CONF-SOURCES-REQUIRED

Description
Example
Formal Description
Within context of: | CONF-SOURCES
Is context for: | SW-INTERFACE-EXPORT-SCOPE


2.65. CONF-SPEC

Description
Example
Formal Description
Within context of: | SW-SYSTEM
Is context for: | CONF-RULES, CONF-ITEMS


2.66. CONF-VALUE-CONSTR

Description
Example
Formal Description
Within context of: | CONF-VALUE-CONSTRS
Is context for: | SW-SYSCOND, LOWER-LIMIT, UPPER-LIMIT, MIN-INCR-SIZE, MIN-TEXT-LENGTH, MAX-TEXT-LENGTH, DCI-TEXT-TYPE, XSD-PATTERN, DCI-ENUM


2.67. CONF-VALUE-CONSTRS

Description
Example
Formal Description
Within context of: | CONF-VALUE-PROPS
Is context for: | CONF-VALUE-CONSTR


2.68. CONF-VALUE-PROPS

Description
Example
Formal Description
Within context of: | CONF-RULE
Is context for: | CONF-DEFAULT-VALUE, CONF-KEY-LOOKUP, CONF-VALUE-CONSTRS, SW-CODE-SYNTAX-REF, SW-COMPU-METHOD-REF, SW-DISPLAY-FORMAT, SW-POINTER, SW-UNIT-REF, XSD-WHITE-SPACE


2.69. CONTRACT-ASPECTS

Description
Use <CONTRACT-ASPECTS>, to enter the contractual aspects .
Example
Formal Description
Within context of: | GENERAL-PROJECT-DATA
Is context for: | NA, TBD, TBR, INTRODUCTION, RIGHTS, GUARANTEE, MAINTENANCE, ADD-SPEC


2.70. CRITICAL-ASPECTS

Description
Use CRITICAL-ASPECTS , to specify critical aspects in text form within a requirement.
Example
Formal Description
Within context of: | REQUIREMENT
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.71. DATA-DESC

Description
<DATA-DESC> is used to describe data in text form. <DATA-DESC> is basically a root for a document which can contain several chapters.
Example
Formal Description
Within context of: | DATA-REQUIREMENTS
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.72. DATA-REQUIREMENTS

Description
Use <DATA-REQUIREMENTS>, to enter the data-orientated requirements .
Example
Formal Description
Within context of: | GENERAL-SOFTWARE
Is context for: | NA, TBD, TBR, INTRODUCTION, DATA-STRUCTURES, DATA-DESC, ADD-SPEC


2.73. DATA-STRUCTURES

Description
Use DATA-STRUCTURES, to describe the data structures in text form.
Example
Formal Description
Within context of: | DATA-REQUIREMENTS
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.74. DATE

Description
<DATE> is used to capture a time stamp. It must match to one of the following syntaxes based on [Representation of dates and times;ISO-8601;]. In multilingual DTDs <DATE> is also multilingual.
<YYYY>-<MM>-<DD>[T<hh>:<mm>:<ss>]

<YYYY>.<MM>.<DD>[T<hh>:<mm>:<ss>]

<YYYY>/<MM>/<DD>[T<hh>:<mm>:<ss>]
The last pattern is the most preferred one, since it reflects a common use in US.
Example
<DATE>2001-03-20T09:00:00</DATE>
Formal Description
Within context of: | DOC-REVISION, SCHEDULE, SW-CS-ENTRY
Is context for: | Text


2.75. DATE-1

Description
Use <DATE-1> , to enter the validity date of a standard document, or the creation date of an external document.
The element is like <DATE> but is never handled multilingual.
<DATE> is used to capture a time stamp. It must match to one of the following syntaxes based on [Representation of dates and times;ISO-8601;]:
<YYYY>-<MM>-<DD>[T<hh>:<mm>:<ss>]

<YYYY>.<MM>.<DD>[T<hh>:<mm>:<ss>]

<YYYY>/<MM>/<DD>[T<hh>:<mm>:<ss>]
The last pattern is the most preferred one, since it reflects a common use in US.
Example
Formal Description
Within context of: | STD, XDOC
Is context for: | Text


2.76. DCI-ENUM

Description
A <dci-enum> represents an enumeration type. Each enumeration value is entered in a <DCI-ENUM-ENTRY>.
Example
<DCI-ENUM>
                  <DCI-ENUM-ENTRY>
                    <V>Audi</V>
                  </DCI-ENUM-ENTRY>
                  <DCI-ENUM-ENTRY>
                    <V>Porsche</V>
                  </DCI-ENUM-ENTRY>
                  <DCI-ENUM-ENTRY>
                   <V>Volvo</V>
                  </DCI-ENUM-ENTRY>
                  <DCI-ENUM-ENTRY>
                   <V>Saab</V>
                  </DCI-ENUM-ENTRY>
                </DCI-ENUM>
Formal Description
Within context of: | CONF-VALUE-CONSTR
Is context for: | DCI-ENUM-ENTRY
Name
Type
Values / Default
Notes
[CASE-SENSITIVE]
optional
Value selection (NAMEDTOKENGROUP)
  • CASE-SENSITIVE
  • NO-CASE-SENSITIVE


2.77. DCI-ENUM-ENTRY

Description
<DCI-ENUM-ENTRY> represents a single enumeration value in an enumeration type.
Example
  <DCI-ENUM-ENTRY>
                    <V>Audi</V>
                  </DCI-ENUM-ENTRY>
Formal Description
Within context of: | DCI-ENUM
Is context for: | VT, DESC


2.78. DCI-TEXT-TYPE

Description
This element, defines a set of text constraints which could also be expressed by the other available constraints but is provided for convenience and consistency reasons. If any of the other dedicated constraints is defined, they silently override the defaults given by the <DCI-TEXT-TYPE>.
Currently, only one <DCI-TEXT-TYPE> setting is available:
IDENTIFIER_C:
Text settings having this text type must obey the rules for valid identifiers in the C programming language:
  • They must consist only of uppercase or lowercase ASCII characters or numbers (this also exludes e.g. umlauts or spaces)
  • They must not start with a number
  • Some keywords are reserved and therefore forbidden: auto, bool, break, case, char, const, continue, default, do, double, else, enum, extern, float, for, goto, if, inline, int, long, main, register, return, short, signed, sizeof, static, struct, switch, typedef, union, unsigned, void, volatile, while
  • Length is restricted to 1...31 characters
Example
Formal Description
Within context of: | CONF-VALUE-CONSTR
Is context for: | Text


2.79. DEF

Description
Use <DEF> , to enter a paragraph within the definition list for describing the title.
Example
Formal Description
Within context of: | DEF-ITEM
Is context for: | P


2.80. DEF-ITEM

Description
Use <DEF-ITEM> , to enter the title of an enumeration element in the definition list.
Example
Formal Description
Within context of: | DEF-LIST
Is context for: | LONG-NAME, SHORT-NAME, DEF
Name
Type
Values / Default
Notes
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[ID]
optional
ID (ID)
Unambiguous identifier of the element within the document.
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[F-ID-CLASS]
fixed value
SGML string (NMTOKEN)
DEF-ITEM
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.81. DEF-LIST

Description
Use <DEF-LIST> , to create a definition list, where the marginal notes can be referenced.
Example
Formal Description
Within context of: | ADD-INFO, ADD-INFO-5, CHAPTER, CONF-RULE-DOC, CRITICAL-ASPECTS, ENTRY, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Is context for: | DEF-ITEM
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.


2.82. DEMARCATION-OTHER-PROJECTS

Description
Use DEMARCATION-OTHER-PROJECTS, to enter the factor distinguishing this project from others .
Example
Formal Description
Within context of: | GENERAL-PROJECT-DATA
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.83. DEPARTMENT

Description
Use <DEPARTMENT> , to enter the department of a project participant.
Example
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text


2.84. DESC

Description
<DESC> represents a general but brief description of the object in question.
Example
<DESC> This calibration is a gain
                                                that is used for the transition period between crank to run. It should be set
                                                between 1000 and 1500.
                </DESC>
Formal Description
Within context of:
AVAILABILITY, CONF-ITEM, CONF-RULE, DCI-ENUM-ENTRY, FIGURE, LIFE-TIME, MTBF, OPERATING-TIME, OVERALL-PROJECT, PPM, PRM, PROJECT, REQUIREMENT, SDG-CAPTION, SW-ADDR-METHOD, SW-AR-RELATION, SW-AXIS-TYPE, SW-BASE-TYPE, SW-CALIBRATION-METHOD, SW-CALPRM, SW-CALPRM-PROTOTYPE, SW-CLASS, SW-CLASS-ATTR-IMPL, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-CODE-SYNTAX, SW-COLLECTION, SW-COMPU-METHOD, SW-COMPU-SCALE, SW-CPU-MEM-SEG, SW-DATA-CONSTR, SW-DATA-DEPENDENCY, SW-DATA-DICTIONARY-SPEC, SW-EVENT, SW-EVENT-SOURCE, SW-FEATURE, SW-FEATURE-INTERFACE, SW-FEATURE-OWNED-ELEMENT-SET, SW-FEATURE-VARIANT, SW-GENERIC-AXIS-PARAM-TYPE, SW-INSTANCE, SW-INSTANCE-PROPS-VARIANT, SW-INSTANCE-TREE, SW-INTERFACE-ACCESSED-ELEMENT-SET, SW-INTERFACE-EXPORT, SW-INTERFACE-IMPORT, SW-MC-BASE-TYPE, SW-MC-FRAME, SW-MC-GENERIC-INTERFACE, SW-MC-INTERFACE, SW-MC-INTERFACE-SOURCE, SW-OPER-MODE, SW-POINTER, SW-PROCESS, SW-PROCESS-LIST, SW-RECORD-LAYOUT, SW-RECORD-LAYOUT-GROUP, SW-RECORD-LAYOUT-V, SW-SERVICE, SW-SERVICE-ACCESSED-ELEMENT-SET, SW-SERVICE-ARG, SW-SERVICE-PROTOTYPE, SW-SERVICE-RETURN, SW-SYSTEM, SW-SYSTEMCONST, SW-TASK, SW-TEMPLATE, SW-UNIT, SW-USER-ACCESS-CASE, SW-USER-GROUP, SW-VARIABLE, SW-VARIABLE-PROTOTYPE, SW-VCD-CRITERION, SYN-ARGUMENT, SYN-CAPTION, SYN-EXAMPLE, SYN-RETURN-VALUE, SYN-SEMANTICS, TBD
Is context for:
Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, MSR-QUERY-TEXT


2.85. DESIGN-REQUIREMENTS

Description
Use DESIGN-REQUIREMENTS, to enter requirements regarding software design .
Example
Formal Description
Within context of: | GENERAL-SOFTWARE
Is context for: | NA, TBD, TBR, INTRODUCTION, NORMATIVE-REFERENCE, RESTRICTIONS-BY-HARDWARE, STANDARD-SW-MODULES, ADD-SPEC


2.86. DEVELOPMENT-PROCESS-SPEC

Description
Use DEVELOPMENT-PROCESS-SPEC, to enter the definition of the development process .
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.87. DIAGNOSIS

Description
This element contains the functional requirements affecting the scope of diagnosis, in text form.
Example
Formal Description
Within context of: | FUNCTIONAL-REQUIREMENTS
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.88. DIR-HAND-OVER-DOC-DATA

Description
Use DIR-HAND-OVER-DOC-DATA, to enter the directory of transferred documents . The directory location is entered in text form.
Example
Formal Description
Within context of: | GENERAL-PROJECT-DATA
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.89. DOC-LABEL

Description
Use <DOC-LABEL> , to enter the title of the document, or a label for the part of the document for which you wish to generate administrative data.
Example
Formal Description
Within context of: | COMPANY-DOC-INFO
Is context for: | Text


2.90. DOC-REVISION

Description
Use <DOC-REVISION> , to generate information on the corresponding document version.
Example
Formal Description
Within context of: | DOC-REVISIONS
Is context for: | COMPANY-REVISION-INFOS, REVISION-LABEL, REVISION-LABEL-P1, REVISION-LABEL-P2, STATE, ISSUED-BY, TEAM-MEMBER-REF, DATE, MODIFICATIONS


2.91. DOC-REVISIONS

Description
<DOC-REVISIONS> is a container for the entire change-history for an object containing <ADMIN-DATA> and <DOC-REVISIONS>. Although the sequence of changes can be determined by sorting <DOC-REVISIONS> according to <DOC-REVISION>/ <DATE>, it is recommended that the most recent <DOC-REVISION> is the first child of <DOC-REVISIONS> .
Example
For an example, see 2.8. ADMIN-DATA .
Formal Description
Within context of: | ADMIN-DATA
Is context for: | DOC-REVISION


2.92. E

Description
Use <E> , to highlight sections of text within a paragraph element.
Example
Formal Description
Within context of: | CHANGE, DESC, FT, INDENT-SAMPLE, ITEM-LABEL, LABEL, LONG-NAME, LONG-NAME-1, MSR-QUERY-RESULT-TEXT, P, REASON, TBR, VERBATIM
Is context for: | Text
Name
Type
Values / Default
Notes
[TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • BOLD
  • ITALIC
  • BOLDITALIC
  • PLAIN
You can highlight text using BOLD or ITALIC to alter its appearance.
[COLOR]
optional
String (CDATA)
Color value, specified in SRBG A Color value can either be a hexadecimal value (prefixed with #) or one of the predefined color names, e.g "black", "dodgerblue" or "indianred". The color names are case-insensitive.
[FONT]
optional
Value selection (NAMEDTOKENGROUP)
  • MONO
  • DEFAULT


2.93. EMAIL

Description
Use <EMAIL> , to enter the email address of a project participant.
Example
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text


2.94. ENTITY-NAME

Description
Use <ENTITY-NAME> , to create a company-specific file name for the document or document part.
Example
Formal Description
Within context of: | COMPANY-DOC-INFO
Is context for: | Text


2.95. ENTRY

Description
Use <ENTRY> , that contains a paragraph element to display the contents of a table cell.
Example
Formal Description
Within context of: | ROW
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE
Name
Type
Values / Default
Notes
[MOREROWS]
has default value
SGML string (NMTOKEN)
0
Modify the attribute to merge the appropriate <ENTRY> cell with the cells belonging to the subsequent rows. Enter 0 if you do not wish to merge any cells. Enter 1 to merge a cell with a cell in the next row. Enter a numeric value n to merge a cell with cells in n subsequent rows.
[ROTATE]
has default value
SGML string (NMTOKEN)
0
Enter the angle by which the contents of a cell should be rotated.
[VALIGN]
has default value
Value selection (NAMEDTOKENGROUP)
  • TOP
  • BOTTOM
  • MIDDLE
TOP - The contents of the table is aligned to the upper edge of the cell. BOTTOM - The contents of the table is aligned to the lower edge of the cell. MIDDLE - The contents of the table is centered to the vertical.
[ALIGN]
optional
Value selection (NAMEDTOKENGROUP)
  • LEFT
  • RIGHT
  • CENTER
  • JUSTIFY
  • CHAR
LEFT - The table contents is justified left. RIGHT - The table contents is justified right. CENTER - The table contents is centered horizontally. JUSTIFY - The table contents is displayed with justified typesetting. There is an equal distance from the left and right-hand edges of the cell. CHAR - The alignment of the table contents is set by [CHAR] .
[CHAR]
optional
String (CDATA)
If [ALIGN]="CHAR", this specifies the alignment sign e.g. "bzlw", as a decimal point separator from an existing value of [CHAR] . The sign cannot be a SDATA entity.
[CHAROFF]
optional
SGML string (NMTOKEN)
If [ALIGN]="CHAR", this value indicates the percentage of the current column width to the left edge of the alignment sign in the [CHAR]-attribute. If there is no alignment sign in the element <ENTRY>, alignment is always horizontal right. The default value is taken from <COLSPEC> or <SPANSPEC> .
[COLNAME]
optional
SGML string (NMTOKEN)
Now, specify an identification name for the column that has been modified, e.g. column1 for the first one.
[COLSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the column guides of a cell are to be visible. You should enter 0, if no column guides are to be displayed. You should enter 1 , if the column guides are to be displayed.
[NAMEEND]
optional
SGML string (NMTOKEN)
Identification number of the final column included in the merge.
[NAMEST]
optional
SGML string (NMTOKEN)
Identification number of the first column to be merged.
[ROWSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the row guides of a cell are to be visible. You should enter 0, if no row guides are to be displayed. You should enter 1 , if the row guides are to be displayed.
[SPANNAME]
optional
SGML string (NMTOKEN)
Identification name of a specified column merge.


2.96. EXTENSIBILITY

Description
Use <EXTENSIBILITY>, to enter the expandability .
Example
Formal Description
Within context of: | GENERAL-SOFTWARE
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.97. FAIL-SAVE-CONCEPT

Description
Use <FAIL-SAVE-CONCEPT>, to enter the emergency run concept .
Example
Formal Description
Within context of: | FAILURE-MANAGEMENT
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.98. FAILURE-MANAGEMENT

Description
Use <FAILURE-MANAGEMENT>, to enter the failure procedure .
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, FMEA, FAIL-SAVE-CONCEPT, REPLACEMENT-VALUES, FAILURE-MEM, SELF-DIAGNOSIS, ADD-SPEC


2.99. FAILURE-MEM

Description
Use <FAILURE-MEM>, to enter the fault memory .
Example
Formal Description
Within context of: | FAILURE-MANAGEMENT
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.100. FAX

Description
Use <FAX> , to enter the fax number of a project participant.
Example
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text


2.101. FIGURE

Description
Use <FIGURE> , to integrate graphics into a document.
Example
Formal Description
Within context of: | ADD-INFO, ADD-INFO-5, CHAPTER, CONF-RULE-DOC, CRITICAL-ASPECTS, ENTRY, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Is context for: | FIGURE-CAPTION, GRAPHIC, MAP, VERBATIM, DESC
Name
Type
Values / Default
Notes
[FLOAT]
optional
Value selection (NAMEDTOKENGROUP)
  • FLOAT
  • NO-FLOAT
Permits a check, in the case of a <FIGURE> that cannot be broken up, to determine whether the <FIGURE> can be shifted elsewhere, so that the page can be used to a greater advantage (compare to flat at TeX).
[FRAME]
optional
Value selection (NAMEDTOKENGROUP)
  • TOP
  • BOTTOM
  • TOPBOT
  • ALL
  • SIDES
  • NONE
TOP - Border at the top of the picture
BOTTOM - Border at the bottom of the figure
TOPBOT - Borders at the top and bottom of the figure
ALL - Borders all around the figure
SIDES - Borders at the sides of the figure
NONE - No borders around the figure
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
KEEP: ensures that the graphic and the element preceding it are not separated. NO-KEEP separates the two elements.
[PGWIDE]
optional
Value selection (NAMEDTOKENGROUP)
  • PGWIDE
  • NO-PGWIDE
PGWIDE: enables the expansion of the diagram to fit across the entire page. NO-PGWIDIE suppresses expansion across the page if, for example, a fixed margin has been given.


2.102. FIGURE-CAPTION

Description
This element specifies the title of an illustration.
Example
Formal Description
Within context of: | FIGURE
Is context for: | LONG-NAME, SHORT-NAME
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | FIGURE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.103. FLASH-PROGRAMMING

Description
Use <FLASH-PROGRAMMING>, to enter the flash-programming .
Example
Formal Description
Within context of: | GENERAL-INTERFACES
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.104. FMEA

Description
Use <FMEA>, to enter the FMEA (Failure Mode Effects Analysis).
Example
Formal Description
Within context of: | FAILURE-MANAGEMENT
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.105. FORMATTER-CTRL

Description
This element contains instructions to be formatted that can be freely specified, such as the scope of the context in which <FORMATTER-CTRL> is located. Here, the attribute [SI] can carry on further useful information obtained through the formatting process.
Example
Formal Description
Within context of: | FORMATTER-CTRLS
Is context for: | Text
Name | Type | Notes
[TARGET-SYSTEM] optional | String (CDATA) | This attribute can specify a target system which is valid for the current setting. If the attribute is absent, it is valid for all target systems. The target systems determine how this attribute should be interpreted. For example, the view control on creation of a help file could proceede in the following way: if there is a formatter-ctrl, si="view" target-system="htmlhelp", this will be used. If there is no specific view, but a formatter-ctrl si="view", without a target system specification, then this is used.


2.106. FORMATTER-CTRLS

Description
Container-Element for <FORMATTER-CTRL> .
Example
Formal Description
Within context of: | ADMIN-DATA
Is context for: | FORMATTER-CTRL


2.107. FORMULA

Description
Use <FORMULA> , to enter a formula in a document.
Example
Formal Description
Within context of: | ADD-INFO, ADD-INFO-5, CHAPTER, CONF-RULE-DOC, CRITICAL-ASPECTS, ENTRY, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Is context for: | FORMULA-CAPTION, GRAPHIC, MAP, VERBATIM, TEX-MATH, C-CODE, GENERIC-MATH
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
KEEP: ensures that the formula and the element preceding it are not separated. NO-KEEP separates the two elements.


2.108. FORMULA-CAPTION

Description
This element specifies the identification or heading of a formula.
Example
Formal Description
Within context of: | FORMULA
Is context for: | LONG-NAME, SHORT-NAME
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | FORMULA | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.109. FR-FEATURE-REF

Description
<FR-FEAUTURE-REF> is used to reference a <FR-FEATURE> describing a specific charachteristic of the system. The <FR-FEATURE> is normally handled with the MSRFR DTD.
Example
<FR-FEATURE-REF>Cruise Control</FR-FEATURE-REF>
Formal Description
Within context of: | SW-SYSCOND
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | FR-FEATURE |
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF |
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK |


2.110. FREE-INFO

Description
Use <FREE-INFO>, to enter the details in the form of continuous text.
Example
Formal Description
Within context of: | KEY-DATA
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.111. FT

Description
Use <FT> , to create a footnote.
Example
<FT>This text appears as a footnote</FT>
Formal Description
Within context of: | CHANGE, DESC, INDENT-SAMPLE, ITEM-LABEL, MSR-QUERY-RESULT-TEXT, P, REASON, TBR
Is context for: | Text, TT, E


2.112. FUNCTION-OVERVIEW

Description
Use <FUNCTION-OVERVIEW>, to enter the functional overview .
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.113. FUNCTION-REF

Description
This is an external reference to a <FUNCTION> within an instance of MSRSYS DTD.
Example
<MSRSW>
                   <SW-SYSTEMS>
                      <SW-SYSTEM ID="IDB7C9BC9rad7F9FF">
                         <LONG-NAME>Demonstrator System</LONG-NAME>
                         <SHORT-NAME>Demosys</SHORT-NAME>
                         <SW-COMPONENT-SPEC>
                            <SW-COMPONENTS>
                               <SW-FEATURE ID="IDB7C9BC9radFEF65">
                                  <SHORT-NAME>Demofeature</SHORT-NAME>
                                  <SW-FULFILS>
                                     <FUNCTION-REF ID-REF="id-demofeature">sysdemo</FUNCTION-REF>
                                  </SW-FULFILS>
                               </SW-FEATURE>
                             </SW-COMPONENTS>
                          </SW-COMPONENT-SPEC>
                      </SW-SYSTEM>
                   </SW-SYSTEMS>
                   <LOCS>
                      <NAMELOC ID="id-demofeature">
                         <LONG-NAME>Demonstratorfunktion</LONG-NAME>
                         <SHORT-NAME>Demofeature aus MSRSYS</SHORT-NAME>
                         <NMLIST DOCORSUB="&msrsys-instance;">sysdemo</NMLIST>
                      </NAMELOC>
                   </LOCS>
                </MSRSW>
Formal Description
Within context of: | SW-FULFILS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-EXT-ID-CLASS] fixed value | SGML string (NMTOKEN) | FUNCTION | Fixed External ID Class. The value of this attribute classifies links and external link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an external object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | EXTERNAL | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF, used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.114. FUNCTIONAL-REQUIREMENTS

Description
This element is the actual root element of an MSRSW instance sub-tree in which requirements are stored. In addition to administrative ( <ADMIN-DATA>, <ADD-SPEC>) and introductory ( <INTRODUCTION>) elements they may also contain the requirement specifications (<REQUIREMENT-SPEC>) .
Example
Formal Description
Within context of: | GENERAL-REQUIREMENTS
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, REQUIREMENT-SPEC, MONITORING, DIAGNOSIS, COMMUNICATION, OPERATIONAL-REQUIREMENTS, ADD-SPEC


2.115. GENERAL-COND

Description
Use <GENERAL-COND>, to enter the general marginal conditions .
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.116. GENERAL-HARDWARE

Description
Use <GENERAL-HARDWARE>, to enter the general hardware conditions .
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, OPERATING-ENV, USEFUL-LIFE, RELIABILITY, ADD-SPEC


2.117. GENERAL-INTERFACES

Description
Use <GENERAL-INTERFACES>, to enter the interface requirements .
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, USER-INTERFACE, HARDWARE-INTERFACE, INTERNAL-INTERFACES, COMMUNICATION-INTERFACE, FLASH-PROGRAMMING, ADD-SPEC


2.118. GENERAL-PRODUCT-DATA-1

Description
Use <GENERAL-PRODUCT-DATA-1>, to specify the general requirements regarding the software.
Example
Formal Description
Within context of: | GENERAL-REQUIREMENTS
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, PRODUCT-DESC, FUNCTION-OVERVIEW, KEY-DATA, PRODUCT-DEMARCATION, SIMILAR-PRODUCTS, GENERAL-HARDWARE, GENERAL-SOFTWARE, GENERAL-INTERFACES, FAILURE-MANAGEMENT, RESOURCE-ALLOCATION, CALIBRATION, SAFETY, QUALITY, MAINTENANCE, GENERAL-COND, ADD-DESIGN-DOC, DEVELOPMENT-PROCESS-SPEC, ADD-SPEC


2.119. GENERAL-PROJECT-DATA

Description
Use <GENERAL-PROJECT-DATA>, to enter the general project data .
Example
Formal Description
Within context of: | PROJECT
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SYSTEM-OVERVIEW, REASON-ORDER, OBJECTIVES, CONTRACT-ASPECTS, SAMPLE-SPEC, VARIANT-SPEC, DEMARCATION-OTHER-PROJECTS, PARALLEL-DESIGNS, INTEGRATION-CAPABILITY, ACCEPTANCE-COND, PROJECT-SCHEDULE, PURCHASING-COND, PROTOCOLS, DIR-HAND-OVER-DOC-DATA, ADD-SPEC


2.120. GENERAL-REQUIREMENTS

Description
This element specifies general requirements which for example can be defined in the requirement management.
Example
Formal Description
Within context of: | MSRSW
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, GENERAL-PRODUCT-DATA-1, FUNCTIONAL-REQUIREMENTS, ADD-SPEC


2.121. GENERAL-SOFTWARE

Description
Use <GENERAL-SOFTWARE> to enter the general software requirements .
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, DESIGN-REQUIREMENTS, DATA-REQUIREMENTS, BINARY-COMPATIBILITY, EXTENSIBILITY, COMPATIBILITY, ADD-SPEC


2.122. GENERIC-MATH

Description
Use <GENERIC-MATH> to insert semantic and mathematical descriptions which are processed by a math-processor.
Example
Formal Description
Within context of: | FORMULA
Is context for: | Text


2.123. GRAPHIC

Description
Use <GRAPHIC> , to integrate an already existing graphic in the context elements.
Example
Formal Description
Within context of: | FIGURE, FORMULA
Is context for: | Text
Name
Type
Values / Default
Notes
[EDITFIT]
has default value
Value selection (NAMEDTOKENGROUP)
  • AS-IS
  • ROTATE-90-CW
  • ROTATE-90-CCW
  • ROTATE-180
  • FIT-TO-TEXT
  • FIT-TO-PAGE
  • LIMIT-TO-TEXT
  • LIMIT-TO-PAGE
  • ROTATE-90-CW-FIT-TO-TEXT
  • ROTATE-90-CCW-FIT-TO-TEXT
  • ROTATE-180-LIMIT-TO-TEXT
  • ROTATE-90-CW-LIMIT-TO-PAGE
  • ROTATE-90-CCW-LIMIT-TO-PAGE
  • ROTATE-180-LIMIT-TO-PAGE
  • 0
  • 1
  • 2
  • 3
FIT properties of the graphic in edit mode.
[FIT]
has default value
Value selection (NAMEDTOKENGROUP)
  • AS-IS
  • ROTATE-90-CW
  • ROTATE-90-CCW
  • ROTATE-180
  • FIT-TO-TEXT
  • FIT-TO-PAGE
  • LIMIT-TO-TEXT
  • LIMIT-TO-PAGE
  • ROTATE-90-CW-FIT-TO-TEXT
  • ROTATE-90-CCW-FIT-TO-TEXT
  • ROTATE-180-LIMIT-TO-TEXT
  • ROTATE-90-CW-LIMIT-TO-PAGE
  • ROTATE-90-CCW-LIMIT-TO-PAGE
  • ROTATE-180-LIMIT-TO-PAGE
  • 0
  • 1
  • 2
  • 3
Modify the attribute [FIT], to determine the way in which the graphic should be inserted. Enter the attribute value 0 , to insert a graphic in its original dimensions. The graphic is adapted, if it is too big for the space for which it was intended.
[HTML-FIT]
has default value
Value selection (NAMEDTOKENGROUP)
  • AS-IS
  • ROTATE-90-CW
  • ROTATE-90-CCW
  • ROTATE-180
  • FIT-TO-TEXT
  • FIT-TO-PAGE
  • LIMIT-TO-TEXT
  • LIMIT-TO-PAGE
  • ROTATE-90-CW-FIT-TO-TEXT
  • ROTATE-90-CCW-FIT-TO-TEXT
  • ROTATE-180-LIMIT-TO-TEXT
  • ROTATE-90-CW-LIMIT-TO-PAGE
  • ROTATE-90-CCW-LIMIT-TO-PAGE
  • ROTATE-180-LIMIT-TO-PAGE
  • 0
  • 1
  • 2
  • 3
Determines whether the graphic should be adapted to fit the dimensions of the window.
[CATEGORY]
optional
Value selection (NAMEDTOKENGROUP)
  • BARCODE
  • CONCEPTUAL
  • ENGINEERING
  • FLOWCHART
  • GRAPH
  • LOGO
  • SCHEMATIC
  • WAVEFORM
Here, you can enter the category of the graphic. This can be used to generate a list of graphics from specific categories.
[EDIT-HEIGHT]
optional
String (CDATA)
Height of the graphic in editor
[EDIT-WIDTH]
optional
String (CDATA)
Width of the graphic in editor
[EDITSCALE]
optional
String (CDATA)
Scale of the graphic in edit mode.
[FILENAME]
optional
String (CDATA)
Here, you should enter the file name under which the system for reproduction can call the graphic.
[HEIGHT]
optional
String (CDATA)
In this attribute, the height of the graphic can be altered.
[HTML-HEIGHT]
optional
String (CDATA)
Height of the graphic displayed online in html and htmlhelp.
[HTML-SCALE]
optional
String (CDATA)
Scale of the graphic when displayed in html and htmlhelp.
[HTML-WIDTH]
optional
String (CDATA)
Width of the graphic displayed online in html and htmlhelp.
[NOTATION]
optional
String (CDATA)
Now the format of the graphic file must be specified, e.g. EPS.
[SCALE]
optional
String (CDATA)
In this element the dimensions of the graphic can be altered proportionally.
[WIDTH]
optional
String (CDATA)
In this attribute, the width of the graphic can be altered.


2.124. GUARANTEE

Description
Use <GUARANTEE>, to enter the guarantee .
Example
Formal Description
Within context of: | CONTRACT-ASPECTS
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.125. HARDWARE-INTERFACE

Description
Use <HARDWARE-INTERFACE> to enter the interfaces to hardware .
Example
Formal Description
Within context of: | GENERAL-INTERFACES
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.126. HOMEPAGE

Description
Use <HOMEPAGE> , to enter the company email address of a project participant.
Example
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text


2.127. IE

Description
Use <IE> to create an index that is to appear in the index directory.
Example
Formal Description
Within context of: | CHANGE, DESC, INDENT-SAMPLE, ITEM-LABEL, LABEL, LONG-NAME, LONG-NAME-1, MSR-QUERY-RESULT-TEXT, P, REASON, TBR
Is context for: | Text, SUP, SUB
Name | Type | Notes
[TYPE] optional | String (CDATA) | Indicates a type of the respective element.


2.128. INDENT-SAMPLE

Description
Use <INDENT-SAMPLE> to set the amount of indentation for the parent object.
Example
The following example sets an indentation of one unit.
<INDENT-SAMPLE>X</INDENT-SAMLPE>
Formal Description
Within context of: | LABELED-LIST
Is context for: | Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, MSR-QUERY-TEXT
Name
Type
Values / Default
Notes
[ITEM-LABEL-POS]
has default value
Value selection (NAMEDTOKENGROUP)
  • NO-NEWLINE
  • NEWLINE
  • NEWLINE-IF-NECESSARY
NO-NEWLINE - line break inside the first column. NEWLINE - no line break inside the first column. The description regarding designation begins in the second row. NEWLINE-IF-NECESSARY - no line break inside the first column. If the marginal notes designation is longer than in the <INDENT-SAMPLE> , the description begins in the second row. Otherwise it begins in the first.


2.129. INTEGRATION-CAPABILITY

Description
Use <INTEGRATION-CAPABILITY>, to enter the integration capacity .
Example
Formal Description
Within context of: | GENERAL-PROJECT-DATA
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.130. INTERNAL-INTERFACES

Description
Use <INTERNAL-INTERFACES> to enter the internal interfaces .
Example
Formal Description
Within context of: | GENERAL-INTERFACES
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.131. INTERRUPT-SPEC

Description
This container describes the architecture of the program interrupts in verbal form. A more formal specification is possible through the assignment of data to the [SI] attributes in the <NCOI-1> sub-tree.
Example
<INTERRUPT-SPEC>
                   <INTRODUCTION>
                      <P>This chapter describes the general architecture of external events.</P>
                   </INTRODUCTION>
                   <NCOI-1>
                      <P>The software utilizes the following interrupts:</P>
                      <TABLE>
                         <TABLE-CAPTION>
                            <LONG-NAME>Interrupt table</LONG-NAME>
                         </TABLE-CAPTION>
                         <TGROUP COLS="4">
                            <COLSPEC COLNUM="1" COLNAME="col1" COLWIDTH="1.00*">
                            <COLSPEC COLNUM="2" COLNAME="col2" COLWIDTH="4.90*">
                            <COLSPEC COLNUM="3" COLNAME="col3" COLWIDTH="2.97*">
                            <COLSPEC COLNUM="4" COLNAME="col4" COLWIDTH="2.97*">
                            <THEAD>
                               <ROW>
                                  <ENTRY SI="LABEL" COLNAME="col1">
                                     <P>Label</P>
                                  </ENTRY>
                                  <ENTRY COLNAME="col2">
                                     <P>Description</P></ENTRY>
                                  <ENTRY COLNAME="col3">
                                     <P>Priority</P>
                                  </ENTRY>
                                  <ENTRY SI="SERVICE-ROUTINE" COLNAME="col4">
                                     <P>Service routine</P>
                                  </ENTRY>
                               </ROW>
                            </THEAD>
                            <TBODY>
                               <ROW>
                                  <ENTRY COLNAME="col1"><P>IRQ1</P></ENTRY>
                                  <ENTRY COLNAME="col2"><P>Timer</P></ENTRY>
                                  <ENTRY COLNAME="col3"><P>medium</P></ENTRY>
                                  <ENTRY COLNAME="col4"><P>0x1000</P></ENTRY>
                               </ROW>
                               <ROW>
                                  <ENTRY COLNAME="col1"><P>IRQ2</P></ENTRY>
                                  <ENTRY COLNAME="col2"><P>Angle interrupt</P></ENTRY>
                                  <ENTRY COLNAME="col3"><P>high</P></ENTRY>
                                  <ENTRY COLNAME="col4"><P>0x1004</P></ENTRY>
                               </ROW>
                            </TBODY>
                         </TGROUP>
                      </TABLE>
                   </NCOI-1>
                </INTERRUPT-SPEC>
Formal Description
Within context of: | SW-ARCHITECTURE
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.132. INTRODUCTION

Description
<INTRODUCTION> provides a general introduction to the object in question.
  • Use <P> to enable the processing systems to perform a word wrapping.
  • Use <VERBATIM> if white-spaces are significant.
Example
 <INTRODUCTION>
                   <P>This File is used to illustrate, how CDF can be implentend according
                      to ASAM-MCD-2MC 2.0 resp. MSRSW.DTD 2.2.0 </P>
                </INTRODUCTION>
Formal Description
Within context of:
ACCEPTANCE-COND, ADD-DESIGN-DOC, ADD-SPEC, BINARY-COMPATIBILITY, CALIBRATION, CHAPTER, COMMUNICATION, COMMUNICATION-INTERFACE, COMPATIBILITY, CONTRACT-ASPECTS, DATA-DESC, DATA-REQUIREMENTS, DATA-STRUCTURES, DEMARCATION-OTHER-PROJECTS, DESIGN-REQUIREMENTS, DEVELOPMENT-PROCESS-SPEC, DIAGNOSIS, DIR-HAND-OVER-DOC-DATA, EXTENSIBILITY, FAIL-SAVE-CONCEPT, FAILURE-MANAGEMENT, FAILURE-MEM, FLASH-PROGRAMMING, FMEA, FUNCTION-OVERVIEW, FUNCTIONAL-REQUIREMENTS, GENERAL-COND, GENERAL-HARDWARE, GENERAL-INTERFACES, GENERAL-PRODUCT-DATA-1, GENERAL-PROJECT-DATA, GENERAL-REQUIREMENTS, GENERAL-SOFTWARE, GUARANTEE, HARDWARE-INTERFACE, INTEGRATION-CAPABILITY, INTERNAL-INTERFACES, INTERRUPT-SPEC, KEY-DATA, MAINTENANCE, MONITORING, MSRSW, NORMATIVE-REFERENCE, OBJECTIVES, OPERATING-ENV, OPERATIONAL-REQUIREMENTS, OVERVIEW, PARALLEL-DESIGNS, PRODUCT-DEMARCATION, PRODUCT-DESC, PROJECT-SCHEDULE, PROTOCOLS, PURCHASING-COND, QUALITY, REASON-ORDER, RELIABILITY, REPLACEMENT-VALUES, REQUIREMENT-SPEC, RESOURCE-ALLOCATION, RESTRICTIONS-BY-HARDWARE, RIGHTS, SAFETY, SAMPLE-SPEC, SELF-DIAGNOSIS, SIMILAR-PRODUCTS, STANDARD-SW-MODULES, SW-ARCHITECTURE, SW-CALIBRATION-METHOD-SPEC, SW-COLLECTION-SPEC, SW-COMPONENT-SPEC, SW-CPU-SPEC, SW-DATA-DICTIONARY-SPEC, SW-EVENT-SPEC, SW-GLOSSARY, SW-INSTANCE-SPEC, SW-MC-COMMUNICATION-SPEC, SW-OPER-MODE-SPEC, SW-SCHEDULING-SPEC, SW-SYSTEM, SW-TASK-SPEC, SW-TEST-SPEC, SW-USER-RIGHT-SPEC, SW-VCD-SPEC, SYSTEM-OVERVIEW, TIME-DEPENDENCY, USEFUL-LIFE, USER-INTERFACE, VARIANT-SPEC
Is context for:
P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, MSR-QUERY-P-2, TOPIC-2, MSR-QUERY-TOPIC-2


2.133. ISSUED-BY

Description
This element contains the name of the person who initiated the document revision. If the initiator cannot be referenced as <TEAM-MEMBER> in the current document his name can be given in this element.
Example
Formal Description
Within context of: | DOC-REVISION
Is context for: | Text


2.134. ITEM

Description
Use <ITEM> to create entries in a <LIST>.
Example
Formal Description
Within context of: | LIST
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.


2.135. ITEM-LABEL

Description
Use <ITEM-LABEL> to enter the label for the parent object.
Example
Formal Description
Within context of: | LABELED-ITEM, SYN-ARGUMENT, SYN-OBJECT
Is context for: | Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, MSR-QUERY-TEXT


2.136. KEY-DATA

Description
Use <KEY-DATA>, to enter the characteristic parameters .
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, FREE-INFO, PRM-REFS


2.137. LABEL

Description
<LABEL> is used as a long designator (similar to <LONG-NAME> ) for objects which cannot be referenced. In this case it is the name of the corresponding project.
Example
Refer to 2.208. PROJECT-DATA for an example, where <LABEL> is the name of the corresponding project.
Formal Description
Within context of: | ANNOTATION, MATCHING-DCI, NOTE, OVERALL-PROJECT, PRMS, PROJECT, SW-CALIBRATION-METHOD-VERSION, SW-CALPRM-VALUE-AXIS-LABELS, SW-MC-GENERIC-INTERFACE, SW-PROCESS, SW-SERVICE-ARG, SW-SERVICE-RETURN, VG
Is context for: | Text, TT, E, SUP, SUB, IE


2.138. LABELED-ITEM

Description
Use <LABELED-ITEM> to create an entry in a labeled list. The list can be nested by creating a new <LABELED-LIST> within the <LABELED-ITEM> .
Example
Formal Description
Within context of: | LABELED-LIST
Is context for: | ITEM-LABEL, P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE
Name
Type
Values / Default
Notes
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.


2.139. LABELED-LIST

Description
Use <LABELED-LIST> to create a list with labels that can be nested.
Example
Formal Description
Within context of: | ADD-INFO, ADD-INFO-5, CHAPTER, CONF-RULE-DOC, CRITICAL-ASPECTS, ENTRY, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Is context for: | INDENT-SAMPLE, LABELED-ITEM
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.


2.140. LANGUAGE

Description
<LANGUAGE> represents the human language used within the file. Its primary use is to prompt the tools to switch to an appropriate language.
This element is in accordance with the ISO 639-1 two letter language codes ( Codes for the Representation of Names of Languages ). The most frequently used codes are given in Most common language codes (alphabetical) :
Most common language codes (alphabetical)
Code | Language
de | German
en | English
es | Spanish
fr | French
it | Italian
jp | Japanese
Example
Formal Description
Within context of: | ADMIN-DATA
Is context for: | Text


2.141. LIFE-TIME

Description
Use <LIFE-TIME> to enter the operation life-time .
Example
Formal Description
Within context of: | USEFUL-LIFE-PRMS
Is context for: | LONG-NAME, SHORT-NAME, DESC, PRM-CHAR
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | PRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.142. LIST

Description
Use <LIST> , to create a numbered or unnumbered list. The list can be nested by adding a new list inside the <ITEM> element.
Example
Formal Description
Within context of: | ADD-INFO, ADD-INFO-5, CHAPTER, CONF-RULE-DOC, CRITICAL-ASPECTS, ENTRY, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Is context for: | ITEM
Name
Type
Values / Default
Notes
[TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • UNNUMBER
  • NUMBER
UNNUMBER - enumeration without numbering NUMBER - numbered enumeration
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.


2.143. LOCS

Description
Use <LOCS> to generate references to external documents.
Example
Formal Description
Within context of: | MSRSW
Is context for: | NAMELOC


2.144. LONG-NAME

Description
Use <LONG-NAME> to create a comprehensive name for the context element.
Example
<LONG-NAME>Variable 1 that keeps the cabin preassure</LONG-NAME>
Formal Description
Within context of: | AVAILABILITY, CHAPTER, COMPANY, CONF-ITEM, CONF-RULE, DEF-ITEM, FIGURE-CAPTION, FORMULA-CAPTION, LIFE-TIME, MTBF, NAMELOC, OPERATING-TIME, PPM, PRM, REQUIREMENT, SAMPLE, SDG-CAPTION, SW-ADDR-METHOD, SW-AXIS-TYPE, SW-BASE-TYPE, SW-CALIBRATION-METHOD, SW-CALPRM, SW-CALPRM-PROTOTYPE, SW-CLASS, SW-CLASS-ATTR-IMPL, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-CODE-SYNTAX, SW-COLLECTION, SW-COMPU-METHOD, SW-CPU-MEM-SEG, SW-DATA-CONSTR, SW-EVENT, SW-EVENT-SOURCE, SW-FEATURE, SW-FEATURE-INTERFACE, SW-FEATURE-VARIANT, SW-GENERIC-AXIS-PARAM-TYPE, SW-INSTANCE, SW-INSTANCE-TREE, SW-MC-BASE-TYPE, SW-MC-FRAME, SW-MC-INTERFACE, SW-MC-INTERFACE-SOURCE, SW-OPER-MODE, SW-RECORD-LAYOUT, SW-SERVICE, SW-SERVICE-ARG, SW-SERVICE-PROTOTYPE, SW-SERVICE-RETURN, SW-SYSTEM, SW-SYSTEMCONST, SW-TASK, SW-TEMPLATE, SW-UNIT, SW-USER-ACCESS-CASE, SW-USER-GROUP, SW-VARIABLE, SW-VARIABLE-PROTOTYPE, SW-VCD-CRITERION, SYN-CAPTION, TABLE-CAPTION, TEAM-MEMBER, TOPIC-1, TOPIC-2, VARIANT-CHAR, VARIANT-DEF
Is context for: | Text, TT, E, SUP, SUB, IE


2.145. LONG-NAME-1

Description
Use <LONG-NAME-1> to create a comprehensive name for the context element
Example
Formal Description
Within context of: | STD, XDOC, XFILE, XREF-TARGET
Is context for: | Text, TT, E, SUP, SUB, IE


2.146. LOWER-LIMIT

Description
This element specifies the lower limit of a closed, half-open or open interval. It can also be set to infinity by setting the attribute INTERVAL-TYPE to INFINITE. No value has to be set in the case of an infinite interval.
Example
Formal Description
Within context of: | CONF-KEY-COUNT, CONF-SOURCE-COUNT, CONF-VALUE-CONSTR, SW-COMPU-SCALE, SW-INTERNAL-CONSTRS, SW-PHYS-CONSTRS, SW-SCALE-CONSTR
Is context for: | Text, CONF-ITEM-CODED-REF, CONF-ITEM-PHYS-REF, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF
Name
Type
Values / Default
Notes
[INTERVAL-TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • OPEN
  • CLOSED
  • INFINITE
OPEN: open interval
CLOSED: closed interval
INFINITE: infinite interval


2.147. MAINTENANCE

Description
Use <MAINTENANCE> to enter the maintenance .
Example
Formal Description
Within context of: | CONTRACT-ASPECTS, GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.148. MAP

Description
Image maps enable authors to specify regions of an image or object and assign a specific action to each region (e.g., retrieve a document, run a program, etc.) When the region is activated by the user, the action is executed.
Example
Formal Description
Within context of: | FIGURE, FORMULA
Is context for: | AREA
Name | Type | Notes
[CLASS] optional | String (CDATA) | Blank separated list of classes
[ID] optional | ID (ID) | Unambiguous identifier of the element within the document.
[NAME] optional | SGML string (NMTOKEN) | This attribute assigns a name to the image map in the MAP element. This name can be used to be referenced in an HTML image through the attribute USEMAP. Although this is not actually necessary in the MSR model, it was inserted in order to support the MAPs which were created for HTML.
[ONCLICK] optional | String (CDATA) | The ONCLICK-Event occurs, if the current element is clicked-on. A script can be stored in this attribute to be performed in the Event.
[ONDBLCLICK] optional | String (CDATA) | The ONDBLCLICK-Event occurs, if the current Event is clicked-on. A script can be stored in this attribute to be performed in the Event.
[ONKEYDOWN] optional | String (CDATA) | The ONKEYDOWN-Event occurs, if a button on the current element is pressed down. A script can be stored in this attribute to be performed in the Event.
[ONKEYPRESS] optional | String (CDATA) | The ONKEYPRESS-Event occurs, if a button on the current element is pressed down and released. A script can be stored in this attribute to be performed in the Event.
[ONKEYUP] optional | String (CDATA) | The ONKEYUP-Event occurs, if a button on the current element is released. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEDOWN] optional | String (CDATA) | The ONMOUSEDOWN-Event occurs, if the mouse button used for clicking is held down on the current element. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEMOVE] optional | String (CDATA) | The ONMOUSEMOVE-Event occurs, if the mouse pointer is moved on the current element (i.e. it is located on the current element). A script can be stored in this attribute to be performed in the Event.
[ONMOUSEOUT] optional | String (CDATA) | The ONMOUSEOUT-Event occurs, if the mouse pointer is moved from the current element. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEOVER] optional | String (CDATA) | The ONMOUSEOVER-Event occurs, if the mouse pointer is moved to the current element from another location outside it. A script can be stored in this attribute to be performed in the Event.
[ONMOUSEUP] optional | String (CDATA) | The ONMOUSEUP-Event occurs if the mouse button used for clicking is released on the current element. A script can be stored in this attribute to be performed in the Event.
[STYLE] optional | String (CDATA) | Information on the associated style
[TITLE] optional | String (CDATA) | Title information of the <MAP> -element


2.149. MATCHING-DCI

Description
<MATCHING-DCI> represents a reference to a DCI instance (Document Content Information) to which the current file should match. The official identification of the DCI is denoted by <URL> which points to the DCI file. The other elements are given to provide information.
Example
Formal Description
Within context of: | MATCHING-DCIS
Is context for: | LABEL, SHORT-LABEL, URL, REMARK


2.150. MATCHING-DCIS

Description
<MATCHING-DCIS> represents all Document Content Information specifications to which the current file should comply. As there may be multiple DCI instances, the current file should match all of them. Nevertheless, the check is only requested according to the case currently in use.
Especially in the case of the CDF, a CDF processor is obliged to check if the CDF-DCI is mentioned in <MATCHING-DCIS> .
Example
In the following example, the current file would match CDF as well as PACO which would support more of the features in MSRSW.DTD .
<MATCHING-DCIS>
                   <MATCHING-DCI>
                      <LABEL>Parameter Contents File</LABEL>
                      <SHORT-LABEL>PACO2.0</SHORT-LABEL>
                      <URL>http://www.msr-wg.de/dcis/paco.dci.xml</URL>
                   </MATCHING-DCI>
                   <MATCHING-DCI>
                      <LABEL>Calibration Data File Specification</LABEL>
                      <SHORT-LABEL>CDF</SHORT-LABEL>
                      <URL>http://www.asam.net/dcis/cdf.dci.xml</URL>
                   </MATCHING-DCI>
                </MATCHING-DCIS>
Formal Description
Within context of: | MSRSW
Is context for: | MATCHING-DCI


2.151. MAX

Description
Use <MAX> to enter the maximum values of a parameter in a table of parameters.
Example
Formal Description
Within context of: | PRM-CHAR
Is context for: | Text, SUP, SUB


2.152. MAX-TEXT-LENGTH

Description
Use <MAX-TEXT-LENGTH> to enter the maximum allowed text length. The value can be set directly or be assiged by expressions containing constants.
Example
<MAX-TEXT-LENGTH>
                  7 + <SW-SYSTEMCONST-PHYS-REF>myConst</SW-SYSTEMCONST-PHYS-REF>
                </MAX-TEXT-LENGTH>
Formal Description
Within context of: | CONF-VALUE-CONSTR
Is context for: | Text, CONF-ITEM-CODED-REF, CONF-ITEM-PHYS-REF, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF


2.153. MIN

Description
Use <MIN> to enter the minimum values of a parameter in a table of parameters.
Example
Formal Description
Within context of: | PRM-CHAR
Is context for: | Text, SUP, SUB


2.154. MIN-INCR-SIZE

Description
Example
Formal Description
Within context of: | CONF-VALUE-CONSTR
Is context for: | Text, CONF-ITEM-CODED-REF, CONF-ITEM-PHYS-REF, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF


2.155. MIN-TEXT-LENGTH

Description
Example
Formal Description
Within context of: | CONF-VALUE-CONSTR
Is context for: | Text, CONF-ITEM-CODED-REF, CONF-ITEM-PHYS-REF, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF


2.156. MODIFICATION

Description
Use <MODIFICATION> to record what has changed in a document in comparison to its predecessor.
Example
Formal Description
Within context of: | MODIFICATIONS
Is context for: | CHANGE, REASON
Name
Type
Values / Default
Notes
[TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • CONTENT-RELATED
  • DOC-RELATED
DOC-RELATED - document-specific changes have necessitated a new document version. CONTENT-RELATED - product-specific changes have necessitated a new document version.


2.157. MODIFICATIONS

Description
<MODIFICATIONS> contains the changes in a document in comparison to its predecessor.
Example
Formal Description
Within context of: | DOC-REVISION
Is context for: | MODIFICATION


2.158. MONITORING

Description
This element provides a verbal description containing the requirements for system monitoring that is to be implemented in the ECU.
Example
<MONITORING>
                   <NCOI-1>
                      <P>The system shall implement an hardware based
                      watchdog to ensure that the software is working. </P>
                   </NCOI-1>
                </MONITORING>
Formal Description
Within context of: | FUNCTIONAL-REQUIREMENTS
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.159. MSR-PROCESSING-LOG

Description
This element is a placeholder in which tools responsible for the automatic processing of the instance can store processing execution information (log information). It is advisable to create an individual chapter ( <CHAPTER> ) for every process executed. The most recent chapter should come first (sorting according to date).
Example
<MSR-PROCESSING-LOG>
                   <CHAPTER>
                      <LONG-NAME>MSR-Query 2.10.2001</LONG-NAME>
                      <SHORT-NAME>msrquery.2001.10.02-1</SHORT-NAME>
                      <VERBATIM>MSR-Query processor Version 0.99 run at 2.10.2001 reading file
                                c:\examples\myexample.sgm warning: duplicate ID found ("hugo") error: query
                                "replacechapters" not implemented 20 queries processed 1 warning 1
                                error
                      </VERBATIM>
                   </CHAPTER>
                   <CHAPTER>
                      <LONG-NAME>MSR-Query 1.10.2001</LONG-NAME>
                      <SHORT-NAME>msrquery.2001.10.01-1</SHORT-NAME>
                      <VERBATIM>MSR-Query processor Version 0.99 run at 1.10.2001 reading file
                                c:\examples\myexample.sgm warning: duplicate ID found ("hugo") error: query
                                "replacechapters" not implemented 20 queries processed 1 warning 1
                   error
                      </VERBATIM>
                   </CHAPTER>
                </MSR-PROCESSING-LOG>
Formal Description
Within context of: | MSRSW
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.160. MSR-QUERY-ARG

Description
This element specifies an argument within a so-called MSR-QUERY which is named in the sister element <MSR-QUERY-NAME> .
Example
Formal Description
Within context of: | MSR-QUERY-PROPS
Is context for: | Text, XREF


2.161. MSR-QUERY-CHAPTER

Description
This element contains a chapter generated through an external query or a chapter generated in an external program (in <MSR-QUERY-RESULT-CHAPTER>), as well as the data necessary to enable a conclusion to be drawn as to the origins of a chapter (in <MSR-QUERY-PROPS> ).
Example
Formal Description
Within context of: | ADD-INFO, CHAPTER, CONF-RULE-DOC, CRITICAL-ASPECTS, FREE-INFO, MSR-PROCESSING-LOG, NCOI-1, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS
Is context for: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-CHAPTER
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.


2.162. MSR-QUERY-NAME

Description
This element specifies the name of the MSR-QUERY triggered.
Example
Formal Description
Within context of: | MSR-QUERY-PROPS
Is context for: | Text


2.163. MSR-QUERY-P-1

Description
This element contains the arguments <MSR-QUERY-PROPS>. In addition, it may also contain result elements in text form, embedded in <MSR-QUERY-RESULT-P-1>, which correspond to a MSR-QUERY , generated either by an external program or an external query, for the purpose of integrating the element into an MSRSW instance.
Example
Formal Description
Within context of: | ADD-INFO, ADD-INFO-5, CHAPTER, CONF-RULE-DOC, CRITICAL-ASPECTS, FREE-INFO, MSR-PROCESSING-LOG, NCOI-1, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1
Is context for: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-P-1
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.


2.164. MSR-QUERY-P-2

Description
This element contains the arguments <MSR-QUERY-PROPS>. In addition, it may also contain result elements in text form, embedded in <MSR-QUERY-RESULT-P-2>, which correspond to a MSR-QUERY , generated either by an external program or an external query, for the purpose of integrating the element into an MSRSW instance.
Example
Formal Description
Within context of: | INTRODUCTION, NCOI-3, TOPIC-2
Is context for: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-P-2
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.


2.165. MSR-QUERY-PROPS

Description
This element specifies the characteristics and arguments of a MSR-QUERY, that is, the name <MSR-QUERY-NAME>, the arguments <MSR-QUERY-ARG> and if required, the comment <COMMENT> .
Example
Formal Description
Within context of: | MSR-QUERY-CHAPTER, MSR-QUERY-P-1, MSR-QUERY-P-2, MSR-QUERY-TEXT, MSR-QUERY-TOPIC-1, MSR-QUERY-TOPIC-2
Is context for: | MSR-QUERY-NAME, MSR-QUERY-ARG, COMMENT


2.166. MSR-QUERY-RESULT-CHAPTER

Description
This element contains the result chapter of a MSR-QUERY , which was generated by an external program or an external query, so that it could be integrated into an MSRSW instance.
Example
Formal Description
Within context of: | MSR-QUERY-CHAPTER
Is context for: | CHAPTER


2.167. MSR-QUERY-RESULT-P-1

Description
This element contains the result element of a MSR-QUERY in text form, which was generated by an external program or an external query, so that it could be integrated into an MSRSW instance. Unlike <MSR-QUERY-RESULT-P-2>, <MSR-QUERY-RESULT-P-1> may still contain <PRMS> elements.
Example
Formal Description
Within context of: | MSR-QUERY-P-1
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, SYN-SYNOPSIS, TABLE, PRMS


2.168. MSR-QUERY-RESULT-P-2

Description
This element contains the result element of a MSR-QUERY in text form, which was generated by an external program or an external query, so that it could be integrated into an MSRSW instance. Unlike <MSR-QUERY-RESULT-P-1>, <MSR-QUERY-RESULT-P-2> may contain no <PRMS> elements.
Example
Formal Description
Within context of: | MSR-QUERY-P-2
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE


2.169. MSR-QUERY-RESULT-TEXT

Description
This element contains the textual description within <MSR-QUERY-TEXT>, generated by a MSR-QUERY , which encompasses no further sub-paragraphs.
Example
Formal Description
Within context of: | MSR-QUERY-TEXT
Is context for: | Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, MSR-QUERY-TEXT


2.170. MSR-QUERY-RESULT-TOPIC-1

Description
This element contains the result of a <TOPIC-1> element generated from an external MSR-QUERY .
Example
Formal Description
Within context of: | MSR-QUERY-TOPIC-1
Is context for: | TOPIC-1


2.171. MSR-QUERY-RESULT-TOPIC-2

Description
This element contains the result of a <TOPIC-2> element generated from an external MSR-QUERY .
Example
Formal Description
Within context of: | MSR-QUERY-TOPIC-2
Is context for: | TOPIC-2


2.172. MSR-QUERY-TEXT

Description
This element contains a MSR-QUERY specified more accurately in the subelement <MSR-QUERY-PROPS>, as well as the textual description generated as a result of it within the subelement <MSR-QUERY-TEXT> , which contains no further subparagraphs.
Example
Formal Description
Within context of: | CHANGE, DESC, INDENT-SAMPLE, ITEM-LABEL, MSR-QUERY-RESULT-TEXT, P, REASON, TBR
Is context for: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-TEXT


2.173. MSR-QUERY-TOPIC-1

Description
This element contains a generated TOPIC-1 element with a result in <MSR-QUERY-RESULT-TOPIC-1>. This is from an external MSR-QUERY which is defined more accurately in <MSR-QUERY-PROPS> .
Example
Formal Description
Within context of: | ADD-INFO, CHAPTER, CONF-RULE-DOC, CRITICAL-ASPECTS, FREE-INFO, MSR-PROCESSING-LOG, NCOI-1, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS
Is context for: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-TOPIC-1
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.


2.174. MSR-QUERY-TOPIC-2

Description
This element contains a generated TOPIC-2 element with a result in <MSR-QUERY-RESULT-TOPIC-2>. This is from an external MSR-QUERY which is defined more accurately in <MSR-QUERY-PROPS> .
Example
Formal Description
Within context of: | INTRODUCTION, NCOI-3
Is context for: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-TOPIC-2
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.


2.175. MSRSW

Description
This element is the root element of an MSRSW instance. Hence the entire sub-tree of the MSRSW instance is located under the element MSRSW which otherwise, is never used. All elements below <MSRSW> are optional, to enable the results of various process phases (which can run in sequence or parallel) to be integrated into an MSRSW instance.
In <SHORT-NAME> you can assign your own identifier to the instance, which can be evaluated by external applications. In <CATEGORY> a specific, in some parts process/application-dependent category of the MSRSW instance can be given, which can then be evaluated by the semantic checker in post processes, e.g. in connection with <MATCHING-DCI> .
In <PROJECT-DATA> project-specific details can be given, where the current MSRSW instance is included in their scope of validity.
<ADMIN-DATA> describes administrative data for the current MSRSW instance, e.g. languages used, version information, formatting instructions, companies participating in the generating of the instance etc.).
<INTRODUCTION> is intended for a concise, textual description of the MSRSW instance, which can incorporate several paragraphs, but no chapter structures.
The main contents of an MSRSW instance is located beneath <SW-SYSTEMS> . This enables the support of several ECU systems, as well as of a system with more than one CPU.
In the sub-tree of the element <GENERAL-REQUIREMENTS> , information is stored which concerns the requirement management phase.
The A2ML BLOB definitions are stored in <SW-MC-COMMUNICATION-SPEC> .
A glossary can be created in <SW-GLOSSARY> .
Non-SGML/XML data can be referenced or checked-in the sub-tree of <SPECIAL-DATA> .
The validity of the semantics can be checked using so-called Document Control Instances. These can be specified in the sub-tree of <MATCHING-DCIS> .
<MSR-PROCESSING-LOG>
It is possible to reference in external documents through the assignment of data to <LOCS> .
Example
<MSRSW>
                   <SHORT-NAME>DEMO</SHORT-NAME>
                   <ADMIN-DATA>
                      <LANGUAGE>en</LANGUAGE>
                   </ADMIN-DATA>
                   <INTRODUCTION>
                      <P>This is a demonstration file to illustrate, how CDF could be
                      implemented in ASAM-MCD-2MC 2.0</P>
                   </INTRODUCTION>
                   <SW-SYSTEMS>
                      <SW-SYSTEM>
                         <SHORT-NAME>DEMO</SHORT-NAME>
                         <SW-INSTANCE-SPEC>
                            <SW-INSTANCE-TREE>
                               <SHORT-NAME>DEMODATA</SHORT-NAME>
                               <SW-INSTANCE>
                                  <SHORT-NAME>FBAM</SHORT-NAME>
                                  <SW-INSTANCE-PROPS-VARIANTS>
                                     <SW-INSTANCE-PROPS-VARIANT>
                                        <SW-AXIS-CONTS>
                                           <SW-AXIS-CONT> </SW-AXIS-CONT>
                                        </SW-AXIS-CONTS>
                                     </SW-INSTANCE-PROPS-VARIANT>
                                  </SW-INSTANCE-PROPS-VARIANTS>
                               </SW-INSTANCE>
                            </SW-INSTANCE-TREE>
                            <SW-INSTANCE-TREE>
                               <SHORT-NAME>Testdata</SHORT-NAME>
                                  <SW-INSTANCE>
                                     <SHORT-NAME>FBAM</SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <SW-AXIS-CONTS>
                                              <SW-AXIS-CONT> </SW-AXIS-CONT>
                                           </SW-AXIS-CONTS>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>
                            </SW-INSTANCE-TREE>
                         </SW-INSTANCE-SPEC>
                      </SW-SYSTEM>
                   </SW-SYSTEMS>
                   <MATCHING-DCIS>
                      <MATCHING-DCI>
                         <URL>http://www.asam.net/dci/cdf.dci.xml</URL>
                      </MATCHING-DCI>
                   </MATCHING-DCIS>
                </MSRSW>
Formal Description
Within context of: | Root
Is context for: | SHORT-NAME, CATEGORY, PROJECT-DATA, ADMIN-DATA, INTRODUCTION, GENERAL-REQUIREMENTS, SW-SYSTEMS, SW-MC-COMMUNICATION-SPEC, SW-GLOSSARY, SPECIAL-DATA, MSR-PROCESSING-LOG, MATCHING-DCIS, LOCS
Name | Type | Values / Default | Notes
[F-BUILD] has default value | String (CDATA) | 1022 |
[F-CM-TOOL-ID] has default value | String (CDATA) | $Id: msrsw_v2_2_2_rb17_v1_7_p3.sl-eadoc.xml,v 1.1 2005/02/16 12:36:09 FGO2SI Exp $ |
[F-REVISION-ID] has default value | String (CDATA) | 1.7 p3 |
[PUBID] has default value | String (CDATA) | -//MSR//DTD MSR SOFTWARE DTD:V2.2.2:RB17:LAI:IAI:XML:MSRSW.DTD//EN | Public Identifier. Unlike [F-PUBID] , this can be modified by means of an application.
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | CHAPTER COMPANY DEF-ITEM EXTERNAL FIGURE FORMULA PRM REQUIREMENT SAMPLE SDG STD SW-MC-BASE-TYPE SW-MC-FRAME SW-MC-INTERFACE SW-MC-INTERFACE-SOURCE SYNOPSIS TABLE TEAM-MEMBER TOPIC VARIANT-DEF VARIANT-CHAR XDOC XFILE XREF-TARGET | Fixed Namespace. This attribute is assigned to elements which define a namespace for linkable objects. The attribute contains a list of elements, where the element carrying the attribute serves as a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names including the namespaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')
[F-PUBID] fixed value | String (CDATA) | -//MSR//DTD MSR SOFTWARE DTD:V2.2.2:RB17:LAI:IAI:XML:MSRSW.DTD//EN | Fixed Public ID. Unlike [PUBID] this cannot be modified and contains the public identifier of the current MSRSW.DTD.
[HYTIME] fixed value | SGML string (NMTOKEN) | HYDOC | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.176. MTBF

Description
Use <MTBF>, to enter the MTBF (Mean Time Between Failures) .
Example
Formal Description
Within context of: | RELIABILITY-PRMS
Is context for: | LONG-NAME, SHORT-NAME, DESC, PRM-CHAR
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | PRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.177. NA

Description
Use <NA> to designate something as Not Applicable and to give a explanation if required.
Example
Formal Description
Within context of:
ACCEPTANCE-COND, ADD-DESIGN-DOC, ADD-SPEC, BINARY-COMPATIBILITY, CALIBRATION, COMMUNICATION, COMMUNICATION-INTERFACE, COMPATIBILITY, CONTRACT-ASPECTS, DATA-DESC, DATA-REQUIREMENTS, DATA-STRUCTURES, DEMARCATION-OTHER-PROJECTS, DESIGN-REQUIREMENTS, DEVELOPMENT-PROCESS-SPEC, DIAGNOSIS, DIR-HAND-OVER-DOC-DATA, EXTENSIBILITY, FAIL-SAVE-CONCEPT, FAILURE-MANAGEMENT, FAILURE-MEM, FLASH-PROGRAMMING, FMEA, FUNCTION-OVERVIEW, FUNCTIONAL-REQUIREMENTS, GENERAL-COND, GENERAL-HARDWARE, GENERAL-INTERFACES, GENERAL-PRODUCT-DATA-1, GENERAL-PROJECT-DATA, GENERAL-REQUIREMENTS, GENERAL-SOFTWARE, GUARANTEE, HARDWARE-INTERFACE, INTEGRATION-CAPABILITY, INTERNAL-INTERFACES, INTERRUPT-SPEC, KEY-DATA, MAINTENANCE, MONITORING, NORMATIVE-REFERENCE, OBJECTIVES, OPERATING-ENV, OPERATIONAL-REQUIREMENTS, OVERVIEW, PARALLEL-DESIGNS, PRODUCT-DEMARCATION, PRODUCT-DESC, PROJECT-SCHEDULE, PROTOCOLS, PURCHASING-COND, QUALITY, REASON-ORDER, RELIABILITY, REPLACEMENT-VALUES, REQUIREMENT-SPEC, RESOURCE-ALLOCATION, RESTRICTIONS-BY-HARDWARE, RIGHTS, SAFETY, SAMPLE-SPEC, SELF-DIAGNOSIS, SIMILAR-PRODUCTS, STANDARD-SW-MODULES, SW-ARCHITECTURE, SW-CALIBRATION-METHOD-SPEC, SW-COLLECTION-SPEC, SW-COMPONENT-SPEC, SW-CPU-SPEC, SW-DATA-DICTIONARY-SPEC, SW-EVENT-SPEC, SW-GLOSSARY, SW-INSTANCE-SPEC, SW-MC-COMMUNICATION-SPEC, SW-OPER-MODE-SPEC, SW-SCHEDULING-SPEC, SW-SYSTEM, SW-TASK-SPEC, SW-TEST-SPEC, SW-USER-RIGHT-SPEC, SW-VCD-SPEC, SYSTEM-OVERVIEW, TIME-DEPENDENCY, USEFUL-LIFE, USER-INTERFACE, VARIANT-SPEC
Is context for:
Text


2.178. NAMELOC

Description
Use <NAMELOC> to identify the external document of a cross-reference spanning more than one document, that is to be referenced.
Example
See 2.113. FUNCTION-REF .
Formal Description
Within context of: | LOCS
Is context for: | LONG-NAME, SHORT-NAME, NMLIST
Name | Type | Values / Default | Notes
[EXT-ID-CLASS] optional | SGML string (NMTOKEN) |  | External ID Class. The value of this attribute classifies links and external link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an external object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | EXTERNAL | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYTIME] fixed value | SGML string (NMTOKEN) | NAMELOC | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables the use of a generic architectural form processor for link processing and transition.


2.179. NCOI-1

Description
Use <NCOI-1> to generate information that is not content-orientated. This information is known as general document contents.
Example
Formal Description
Within context of: | ACCEPTANCE-COND, ADD-DESIGN-DOC, ADD-SPEC, BINARY-COMPATIBILITY, CALIBRATION, COMMUNICATION, COMMUNICATION-INTERFACE, COMPATIBILITY, DATA-DESC, DATA-STRUCTURES, DEMARCATION-OTHER-PROJECTS, DEVELOPMENT-PROCESS-SPEC, DIAGNOSIS, DIR-HAND-OVER-DOC-DATA, EXTENSIBILITY, FAIL-SAVE-CONCEPT, FAILURE-MEM, FLASH-PROGRAMMING, FMEA, FUNCTION-OVERVIEW, GENERAL-COND, GUARANTEE, HARDWARE-INTERFACE, INTEGRATION-CAPABILITY, INTERNAL-INTERFACES, INTERRUPT-SPEC, MAINTENANCE, MONITORING, NORMATIVE-REFERENCE, OBJECTIVES, OPERATING-ENV, OPERATIONAL-REQUIREMENTS, OVERVIEW, PARALLEL-DESIGNS, PRODUCT-DEMARCATION, PRODUCT-DESC, PROJECT-SCHEDULE, PROTOCOLS, PURCHASING-COND, QUALITY, REASON-ORDER, REPLACEMENT-VALUES, RESOURCE-ALLOCATION, RESTRICTIONS-BY-HARDWARE, RIGHTS, SAFETY, SAMPLE, SELF-DIAGNOSIS, SIMILAR-PRODUCTS, STANDARD-SW-MODULES, SW-GLOSSARY, SW-TEST-SPEC, SYSTEM-OVERVIEW, TIME-DEPENDENCY, USER-INTERFACE
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.180. NCOI-3

Description
Use <NCOI-3> to enter the details. See also NCOI-1 .
Example
Formal Description
Within context of: | RELIABILITY, USEFUL-LIFE
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, MSR-QUERY-P-2, TOPIC-2, MSR-QUERY-TOPIC-2


2.181. NMLIST

Description
Use <NMLIST> to enter the name of an entity or element, to be referenced in an external document.
Example
Formal Description
Within context of: | NAMELOC
Is context for: | Text
Name
Type
Values / Default
Notes
[NAMETYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • ENTITY
  • ELEMENT
ENTITY - reference to an entity in an external document. ELEMENT - reference to an element in an external document.
[DOCORSUB]
optional
Entity (ENTITY)
SGML/XML document or sub-document, the prologue of which declares entities or elements that occur in NMLIST. Refer to [FUNCTION-REF] for an example.
[HYTIME]
fixed value
SGML string (NMTOKEN)
NMLIST
HYTIME is the standard attribute use to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.182. NORMATIVE-REFERENCE

Description
Use <NORMATIVE-REFERENCE> to enter the compliance to standards .
Example
Formal Description
Within context of: | DESIGN-REQUIREMENTS
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.183. NOTATION

Description
This element indicates the data format of the external file in which the superordinated XFILE is located. The identifier itself must be arranged amongst the project participants. The contents of <NOTATION> are treated in a similar way to an SGML notation format.
Possible values are for example:
Notation | Meaning
EPS | Encapsulated Postscript
PDF | Portable Document Format
PaCo | Parameter Contents File in MSRSW2.2 structure
... | ...
Example
<P>Please refer to
                   <XFILE>
                      <LONG-NAME-1>Parameter Contents file</LONG-NAME-1>
                      <SHORT-NAME>0711paco</SHORT-NAME>
                      <URL>../pacos/0711paco.xml</URL>
                      <NOTATION>PaCo</NOTATION>
                      <TOOL>DDCL</TOOL>
                      <TOOL-VERSION>1.3</TOOL-VERSION>
                   </XFILE>
                </P>
Formal Description
Within context of: | XFILE
Is context for: | Text


2.184. NOTE

Description
Use <NOTE> to highlight particular safety or usage notes.
Example
Formal Description
Within context of: | ADD-INFO, ADD-INFO-5, CHAPTER, CONF-RULE-DOC, CRITICAL-ASPECTS, ENTRY, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Is context for: | LABEL, P
Name
Type
Values / Default
Notes
[NOTE-TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • CAUTION
  • HINT
  • TIP
  • INSTRUCTION
  • EXERCISE
  • OTHER
CAUTION - dangers involving instruments and personnel during operation. HINT - special operation features
TIP - measures to improve efficiency
INSTRUCTION - important instructions
EXERCISE - practical examples
OTHER - additional notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[USER-DEFINED-TYPE]
optional
String (CDATA)
Allows user-specific notes to be introduced.


2.185. NUMBER

Description
Use <NUMBER> to enter the version number of an external document that is referenced.
Example
Formal Description
Within context of: | XDOC
Is context for: | Text


2.186. NUMBER-OF-BITS

Description
Number of bits of a bit variable (described by <SW-BIT-REPRESENTATION>), calculation based on the position specified by the parallel element <BIT-POSITION> .
Example
See 2.305. SW-BIT-REPRESENTATION
Formal Description
Within context of: | SW-BIT-REPRESENTATION
Is context for: | Text


2.187. OBJECTIVES

Description
Use <OBJECTIVES>, to enter the objectives for the system. The objectives are entered in text form.
Example
Formal Description
Within context of: | GENERAL-PROJECT-DATA
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.188. OPERATING-ENV

Description
This element verbally describes the operation environment in which the system is to be applied with the software. This is part of the general requirements <GENERAL-REQUIREMENTS>. Unlike <OPERATIONAL-REQUIREMENTS>, which specifies operation requirements to be fulfilled internally through the software, <OPERATING-ENV> describes the operation environment which is influenced by external factors.
Example
Formal Description
Within context of: | GENERAL-HARDWARE
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.189. OPERATING-TIME

Description
This element verbally describes requirements concerning operation duration, on the system with the software. This is part of the general requirements <GENERAL-REQUIREMENTS> .
Example
Formal Description
Within context of: | USEFUL-LIFE-PRMS
Is context for: | LONG-NAME, SHORT-NAME, DESC, PRM-CHAR
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | PRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.190. OPERATIONAL-REQUIREMENTS

Description
This element describes operation requirements to be fulfilled by the system. For example requirements regarding performance. Unlike <OPERATING-ENV> which specifies the operation environment influenced by external factors <OPERATIONAL-REQUIREMENTS> describes the operation requirements that are to be fulfilled internally through the software.
Example
Formal Description
Within context of: | FUNCTIONAL-REQUIREMENTS
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.191. OVERALL-PROJECT

Description
Use <OVERALL-PROJECT> to enter the name of the overall project. It is also possible to supply a short description as information.
Example
Formal Description
Within context of: | PROJECT-DATA
Is context for: | LABEL, DESC


2.192. OVERVIEW

Description
In this element can an overview of the SW architecture for the current <SW-SYSTEM> be given.
Example
Formal Description
Within context of: | SW-ARCHITECTURE
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.193. P

Description
Use <P> to create a paragraph for continuous texts.
Example
Formal Description
Within context of: | ADD-INFO, ADD-INFO-5, ANNOTATION-TEXT, CHAPTER, COND, CONF-RULE-DOC, CRITICAL-ASPECTS, DEF, ENTRY, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, NOTE, REALTIME-REQUIREMENTS, REMARK, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, SYN-FORMAT, SYN-INCLUDE, SYN-OBJECT, SYN-SEE-ALSO, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Is context for: | Text, TT, BR, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, STD, XDOC, XFILE, MSR-QUERY-TEXT
Name
Type
Values / Default
Notes
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.


2.194. PARALLEL-DESIGNS

Description
Use <PARALLEL-DESIGNS> to enter the parallel developments .
Example
Formal Description
Within context of: | GENERAL-PROJECT-DATA
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.195. PHONE

Description
Use <PHONE> to enter the telephone number of a project participant.
Example
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text


2.196. POSITION

Description
Use <POSITION> to enter references to the relevant positions of a standard.
Example
Formal Description
Within context of: | STD, XDOC
Is context for: | Text


2.197. PPM

Description
Use <PPM> to enter the PPM (Parts Per Million) .
Example
Formal Description
Within context of: | RELIABILITY-PRMS
Is context for: | LONG-NAME, SHORT-NAME, DESC, PRM-CHAR
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | PRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.198. PRIVATE-CODE

Description
Use <PRIVATE-CODE> to generate data for specially adapted systems or for processes.
Example
Formal Description
Within context of: | PRIVATE-CODES
Is context for: | Text
Name | Type | Notes
[TYPE] optional | String (CDATA) | Indicates a type of the respective element.


2.199. PRIVATE-CODES

Description
Use <PRIVATE-CODES> to create a summary of the data for specially adapted systems or for processes.
Example
Formal Description
Within context of: | COMPANY-DOC-INFO
Is context for: | PRIVATE-CODE


2.200. PRM

Description
Use <PRM> to create a parameter table
Example
Formal Description
Within context of: | PRMS, RELIABILITY-PRMS, USEFUL-LIFE-PRMS
Is context for: | LONG-NAME, SHORT-NAME, DESC, PRM-CHAR
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | PRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.201. PRM-CHAR

Description
Use <PRM-CHAR> to generate parameter values.
Example
Formal Description
Within context of: | AVAILABILITY, LIFE-TIME, MTBF, OPERATING-TIME, PPM, PRM
Is context for: | COND, ABS, TOL, MIN, TYP, MAX, UNIT, TEXT, REMARK


2.202. PRM-REF

Description
Use <PRM-REF>, to enter a reference to a parameter table.
Example
Formal Description
Within context of: | PRM-REFS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | PRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.203. PRM-REFS

Description
Use <PRM-REFS> to enter parameter references .
Example
Formal Description
Within context of: | KEY-DATA
Is context for: | PRM-REF


2.204. PRMS

Description
Use <PRMS> to create a parameter table for a number of parameters.
Example
Formal Description
Within context of: | ADD-INFO, CHAPTER, CONF-RULE-DOC, CRITICAL-ASPECTS, FREE-INFO, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, NCOI-1, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1
Is context for: | LABEL, PRM
Name
Type
Values / Default
Notes
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.


2.205. PRODUCT-DEMARCATION

Description
Use <PRODUCT-DEMARCATION> to enter the product limitation .
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.206. PRODUCT-DESC

Description
Use <PRODUCT-DESC> to enter a short product description.
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.207. PROJECT

Description
Use <PROJECT> to enter the corresponding project .
Example
Formal Description
Within context of: | PROJECT-DATA
Is context for: | LABEL, DESC, COMPANIES, GENERAL-PROJECT-DATA


2.208. PROJECT-DATA

Description
Use <PROJECT-DATA> to gather information on the project to which the file belongs. Although this wrapper element seems to be superfluous in CDF, it exists because it is possible to have more project related information in MSRSW.DTD .
Example
 <PROJECT-DATA>
                            <PROJECT>
                               <LABEL>demo project for CDF file format with MSRSW.DTD</LABEL>
                               <DESC> this project is used to illustrate how CDF format can be defined by
                                      following the structures of ASAM-MCD-2MC 2.0 resp. MSRSW.DTD 2.2.0
                               </DESC>
                               <COMPANIES>
                                  <COMPANY ROLE="SUPPLIER" ID="rb">
                                     <LONG-NAME>Robert Bosch GmbH</LONG-NAME>
                                     <SHORT-NAME>Bosch</SHORT-NAME>
                                     <TEAM-MEMBERS>
                                        <TEAM-MEMBER ID="wl">
                                        <LONG-NAME>Bernhard Weichel</LONG-NAME>
                                        <SHORT-NAME>Wl</SHORT-NAME>
                                           <ROLES>
                                              <ROLE>Author</ROLE>
                                           </ROLES>
                                           <DEPARTMENT>GS/EMW4</DEPARTMENT>
                                        </TEAM-MEMBER>
                                     </TEAM-MEMBERS>
                                  </COMPANY>
                               </COMPANIES>
                            </PROJECT>
                </PROJECT-DATA>
Formal Description
Within context of: | MSRSW
Is context for: | OVERALL-PROJECT, PROJECT


2.209. PROJECT-SCHEDULE

Description
Use <PROJECT-SCHEDULE> to enter the project schedule .
Example
Formal Description
Within context of: | GENERAL-PROJECT-DATA
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.210. PROTOCOLS

Description
Use <PROTOCOLS> to enter the protocol/consultation notes .
Example
Formal Description
Within context of: | GENERAL-PROJECT-DATA
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.211. PUBLISHER

Description
Use <PUBLISHER> to enter the publisher of an external document that is being referenced.
Example
Formal Description
Within context of: | XDOC
Is context for: | Text


2.212. PURCHASING-COND

Description
Use <PURCHASING-COND> to enter the purchasing conditions.
Example
Formal Description
Within context of: | GENERAL-PROJECT-DATA
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.213. QUALITY

Description
Use <QUALITY> to enter the quality model .
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.214. REALTIME-REQUIREMENTS

Description
This element specifies the textual requirements for real-time operation.
Example
Formal Description
Within context of: | REQUIREMENT
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.215. REASON

Description
Use <REASON> to cite the reason for changes to the document version.
Example
Formal Description
Within context of: | MODIFICATION
Is context for: | Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, MSR-QUERY-TEXT


2.216. REASON-ORDER

Description
Use <REASON-ORDER> to enter an order explanation .
Example
Formal Description
Within context of: | GENERAL-PROJECT-DATA
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.217. RELIABILITY

Description
Use <RELIABILITY> to enter reliability .
Example
Formal Description
Within context of: | GENERAL-HARDWARE
Is context for: | NA, TBD, TBR, INTRODUCTION, RELIABILITY-PRMS, NCOI-3


2.218. RELIABILITY-PRMS

Description
Use <RELIABILITY-PRMS> to enter the parameters .
Example
Formal Description
Within context of: | RELIABILITY
Is context for: | MTBF, PPM, PRM


2.219. REMARK

Description
<REMARK> is used for comments e.g. on the specific calibration state. There are two options:
  • Use <P> to enable the processing systems to perform a word wrapping.
  • Use <VERBATIM> if a white-space is significant.
Example
Formal Description
Within context of: | MATCHING-DCI, PRM-CHAR, SW-CS-ENTRY
Is context for: | P, VERBATIM


2.220. REPLACEMENT-VALUES

Description
Use <REPLACEMENT-VALUES>, to enter the replacement values .
Example
Formal Description
Within context of: | FAILURE-MANAGEMENT
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.221. REQUIREMENT

Description
This element contains a requirement with a short, paragraph-long description <DESC>, administrative data <ADMIN-DATA>, the complete description of the requirement <REQUIREMENT-BODY>, critical aspects that must be observed <CRITICAL-ASPECTS>, technical aspects <TECHNICAL-ASPECTS>, real-time requirements <REALTIME-REQUIREMENTS>, risks <RISKS>, requirement dependencies <REQUIREMENTS-DEPENDENCY> and additional information <ADD-INFO>. A requirement <REQUIREMENT> may in turn contain requirements <REQUIREMENT> .
Example
Formal Description
Within context of: | REQUIREMENT, REQUIREMENTS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, REQUIREMENT-BODY, CRITICAL-ASPECTS, TECHNICAL-ASPECTS, REALTIME-REQUIREMENTS, RISKS, REQUIREMENTS-DEPENDENCY, ADD-INFO, REQUIREMENT
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | REQUIREMENT | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.222. REQUIREMENT-BODY

Description
This element contains the textual description of a requirement, which can be distributed over chapter structures.
Example
Formal Description
Within context of: | REQUIREMENT
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.223. REQUIREMENT-REF

Description
This element describes a reference to a requirement <REQUIREMENT>. The reference is established using the [ID-REF]-attribute contents of the <REQUIREMENT-REF>-element which points to an <REQUIREMENT>-element with an [ID]-attribute of the same value. The reference can also occur via the contents of the <REQUIREMENT-REF>-element, which then has the same contents as the <SHORT-NAME> of a <REQUIREMENT> .
Example
Formal Description
Within context of: | SW-FULFILS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | REQUIREMENT | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF) used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute use to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.224. REQUIREMENT-SPEC

Description
This element contains the specification of functional requirements. If given, explanations for these can be found in <INTRODUCTION> .
Example
Formal Description
Within context of: | FUNCTIONAL-REQUIREMENTS
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, REQUIREMENTS


2.225. REQUIREMENTS

Description
Container-Element for <REQUIREMENT> .
Example
Formal Description
Within context of: | REQUIREMENT-SPEC
Is context for: | REQUIREMENT


2.226. REQUIREMENTS-DEPENDENCY

Description
This element describes the cross-references from one requirement to another, in text form. A formal dependency is not specified here, although this is possible if <XREF> is used.
Example
<REQUIREMENTS>
                   <REQUIREMENT ID="IDMUSTHAVELAMP">
                      <LONG-NAME>The system shall have warning lamp</LONG-NAME>
                   </REQUIREMENT>
                   <REQUIREMENT ID="IDDETECTDANGER">
                      <LONG-NAME>The system shall detect dangerous situations</LONG-NAME>
                   </REQUIREMENT>
                   <REQUIREMENT ID="ID72DE4BF3rad10F26">
                      <LONG-NAME>The warning lamp shall flash on danger</LONG-NAME>
                      <REQUIREMENTS-DEPENDENCY>
                         <TOPIC-1 ID="ID72DE4BF3rad98328">
                            <LONG-NAME>Prerequisites</LONG-NAME>
                            <P><XREF ID-CLASS="REQUIREMENT" ID-REF="IDMUSTHAVELAMP"></XREF></P>
                            <P><XREF ID-CLASS="REQUIREMENT" ID-REF="IDDETECTDANGER"></XREF></P>
                         </TOPIC-1>
                      </REQUIREMENTS-DEPENDENCY>
                   </REQUIREMENT>
                </REQUIREMENTS>
Formal Description
Within context of: | REQUIREMENT
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.227. RESOURCE-ALLOCATION

Description
Use <RESOURCE-ALLOCATION>, to insert commands regarding exploitation of resources .
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.228. RESTRICTIONS-BY-HARDWARE

Description
Use <RESTRICTIONS-BY-HARDWARE>, to enter limitations caused by the hardware .
Example
Formal Description
Within context of: | DESIGN-REQUIREMENTS
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.229. REVISION-LABEL

Description
Use <REVISION-LABEL>, to enter the version number of the document, or the document section to which administrative is applied.. The syntax is free and refers to the configuration management plan respectively the version management tool being used.
Example
Formal Description
Within context of: | COMPANY-REVISION-INFO, DOC-REVISION
Is context for: | Text


2.230. REVISION-LABEL-P1

Description
Use <REVISION-LABEL-P1>, to enter the version number of the first predecessor of the document, or the document section to which administrative is applied.. The syntax is free and refers to the configuration management plan respectively the version management tool being used. This element is used, if the document or document section is the result of a merge process in which two branches are merged in to one new revision.
Example
<REVISION-LABEL>1.4</REVISION-LABEL>
                <REVISION-LABEL-P1>1.2.1.3</REVISION-LABEL-P1>
                <REVISION-LABEL-P2>1.3.1.4</REViSION-LABEL-P2>
This example shows a scenario where the current revision 1.4 is produced by merging 1.3.1.4 into 1.2.1.3
Formal Description
Within context of: | COMPANY-REVISION-INFO, DOC-REVISION
Is context for: | Text


2.231. REVISION-LABEL-P2

Description
Use <REVISION-LABEL-P1>, to enter the version number of the second predecessor of the document, or the document section to which administrative is applied.. The syntax is free and refers to the configuration management plan respectively the version management tool being used. This element is used, if the document or document section is the result of a merge process in which two branches are merged in to one new revision.
Example
<REVISION-LABEL>1.4</REVISION-LABEL>
                <REVISION-LABEL-P1>1.2.1.3</REVISION-LABEL-P1>
                <REVISION-LABEL-P2>1.3.1.4</REViSION-LABEL-P2>
This example shows a scenario where current revision 1.4 is produced by merging 1.3.1.4 into 1.2.1.3
Formal Description
Within context of: | COMPANY-REVISION-INFO, DOC-REVISION
Is context for: | Text


2.232. RIGHTS

Description
Use <RIGHTS>, to enter the licensing rights .
Example
Formal Description
Within context of: | CONTRACT-ASPECTS
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.233. RISKS

Description
In this element, textual descriptions of risks concerning a functional requirement can be indicated.
Example
Formal Description
Within context of: | REQUIREMENT
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.234. ROLE

Description
<ROLE> denotes one particular role adopted by the team member within the current project. Roles include "Author", "Calibration engineer", "Supporter", "Quality assurance".
Example
Formal Description
Within context of: | ROLES
Is context for: | Text


2.235. ROLES

Description
<ROLES> is a wrapper containing all the roles attributed to one particular team member involved in the project.
Example
for an example, see 2.208. PROJECT-DATA
Formal Description
Within context of: | COMPANY, TEAM-MEMBER
Is context for: | ROLE
Name | Type | Values / Default | Notes
[F-CHILD-TYPE] fixed value | String (CDATA) | ROLE:SELECTION | Fixed Child Type. Warning: This attribute is included in the DTD for compatibility with older versions and should not be used for any new implementations. It may be removed in future versions of the DTD. The attribute contains information stating which child elements of the element carrying this attribute, should be checked by an semantic checker.


2.236. ROW

Description
Use <ROW> , to create a row in a table.
Example
Formal Description
Within context of: | TBODY, TFOOT, THEAD
Is context for: | ENTRY
Name
Type
Values / Default
Notes
[VALIGN]
has default value
Value selection (NAMEDTOKENGROUP)
  • TOP
  • BOTTOM
  • MIDDLE
TOP - The contents of the row is aligned to the upper edge of the cell. BOTTOM - The contents of the row is aligned to the lower edge of the cell. MIDDLE - The contents of the row is centered to the vertical.
[ROWSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the row guides of a cell are to be visible. You should enter 0, if no row guides are to be displayed. You should enter 1 , if the row guides are to be displayed.


2.237. SAFETY

Description
Use <SAFETY>, to determine confidentiality .
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.238. SAMPLE

Description
Use <SAMPLE>, to enter the prototype .
Example
Formal Description
Within context of: | SAMPLES
Is context for: | LONG-NAME, SHORT-NAME, NCOI-1
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-CHILD-TYPE] fixed value | String (CDATA) | LONG-NAME:SELECTION | Fixed Child Type. Warning: This attribute is included in the DTD for compatibility with older versions and should not be used for any new implementations. It may be removed in future versions of the DTD. The attribute contains information stating which child elements of the element carrying this attribute, should be checked by an semantic checker.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SAMPLE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.239. SAMPLE-REF

Description
Use <SAMPLE-REF>, to enter the prototype reference .
Example
Formal Description
Within context of: | SCHEDULE
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SAMPLE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.240. SAMPLE-SPEC

Description
Use <SAMPLE-SPEC>, to enter the prototype definitions .
Example
Formal Description
Within context of: | GENERAL-PROJECT-DATA
Is context for: | NA, TBD, TBR, INTRODUCTION, SAMPLES


2.241. SAMPLES

Description
Use <SAMPLES>, to enter the prototype .
Example
Formal Description
Within context of: | SAMPLE-SPEC
Is context for: | SAMPLE


2.242. SCHEDULE

Description
Use <SCHEDULE> to enter the schedule .
Example
Formal Description
Within context of: | TBD
Is context for: | SAMPLE-REF, DATE


2.243. SD

Description
This element is a "Special Data" element. By using this element it is possible to extend the dtd with a "new" element tag.
Example
If the element:
<BIG-NUMBER>1000</BIG-NUMBER>
is required but doesn't exist in the dtd it can be created with a <SD> element. It would then look like this:
<SD GID="BIG-NUMBER">1000</SD>
Formal Description
Within context of: | SDG
Is context for: | Text
Name | Type | Notes
[GID] required | String (CDATA) | Identification name of the new element
[ID-CLASS] optional | SGML string (NMTOKEN) |
[ID-REF] optional | ID reference (IDREF) |


2.244. SDG

Description
SDG ( Special Data Group) is a backdoor used to handle elements that has not yet been defined in a DTD. The <SDG> is a containder for one or several <SD> that defines new elements and carries the information. Special Data should only be used moderately since all elements should be defined in the dtd. Thereby should SDG be considered as a temporary sollution when elements are missing. If a <SDG-CAPTION> element is created along with a <SHORT-NAME> it is possible to reference the <SDG> structure via a <XREF>.
Example
If the element structure:
<MY-NUMBERS>
                  <BIG-NUMBER>1000</BIG-NUMBER>
                  <SMALL-NUMBER>1</SMALL-NUMBER>
                <MY-NUMBERS>
is required but doesn't exist in the dtd it can be created with a <SDG> and some <SD> elements. It would then look like this:
<SDG GID="MY-NUMBERS">
                  <SD GID="BIG-NUMBER">1000</SD>
                  <SD GID="SMALL-NUMBER">1</SD>
                </SDG>
Formal Description
Within context of: | SDG, SDGS, SPECIAL-DATA
Is context for: | SDG-CAPTION, SD, SDG
Name | Type | Notes
[GID] required | String (CDATA) | Identification name of the element group


2.245. SDG-CAPTION

Description
This enables a <SHORT-NAME> to be assigned to [ID] and enables a <LONG-NAME> to be assigned to a special data group <SDG> .
Example
Formal Description
Within context of: | SDG
Is context for: | LONG-NAME, SHORT-NAME, DESC
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SDG | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.246. SDGS

Description
This is a container for one or several <SDG> (Special Data Group) elements.
Special data groups (SDGs) are a standard extension mechanism for harmonized objects; they are used to store data for that no other element exists of the data model in a structured way. It could be considerd as a "well formed island" which allows to carry specific data even if the DTD itself does not expllicitly supports it. this prevents a process designer or a user to entirely switch to another technology if information musst be transferred whichis not explicitly supported.
Example
Examples for the usage of SDGs within harmonized objects are the company specific documentation in COMPANY DOC INFO.This document defines the structure of SDGs but not their content.
The following example is taken from [ASAM MCD 2 Harmonized Data Objects, Version 1.0-RC2 ;]
<SDGS>
                  <SDG>
                     <SDG-CAPTION ID="SDGC_ValidPL" TI="G">
                        <SHORT-NAME>ValidPL</SHORT-NAME>
                        <LONG-NAME>Validity production line</LONG-NAME>
                        <DESC>establishes the relation between ECU and production line</DESC>
                     </SDG-CAPTION>
                     <SD SI="prodline">E46-M3</SD>
                     <SD SI="prodline">E39-M3</SD>
                     <SD SI="prodline">E39-M5</SD>
                  </SDG>
                  <SDG>
                    <SDG-CAPTION ID="SDGC_DiagInd" TI="D">
                       <SHORT-NAME>DiagInd</SHORT-NAME>
                       <LONG-NAME>Diagnosisindex</LONG-NAME>
                    </SDG-CAPTION>
                    <SD>0.7</SD>
                  </SDG>
                </SDGS>
Formal Description
Within context of: | COMPANY-DOC-INFO
Is context for: | SDG


2.247. SELF-DIAGNOSIS

Description
Use <SELF-DIAGNOSIS> to enter the self-diagnosis .
Example
Formal Description
Within context of: | FAILURE-MANAGEMENT
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.248. SHORT-LABEL

Description
This element specifies a short name for the context element. This label cannot be referenced in the same way as a <SHORT-NAME> in connection with MSRSW (queries, external applications etc.).
Example
See 2.150. MATCHING-DCIS 2.150. MATCHING-DCIS .
Formal Description
Within context of: | MATCHING-DCI, SW-MC-GENERIC-INTERFACE, SW-PROCESS, SW-PROCESS-LIST, SW-SERVICE-ARG, SW-SERVICE-RETURN
Is context for: | Text


2.249. SHORT-NAME

Description
Use <SHORT-NAME> to generate a short name for the context element, which enables it to be referenced .
Example
Formal Description
Within context of:
AVAILABILITY, CHAPTER, COMPANY, CONF-ITEM, CONF-RULE, DEF-ITEM, FIGURE-CAPTION, FORMULA-CAPTION, LIFE-TIME, MSRSW, MTBF, NAMELOC, OPERATING-TIME, PPM, PRM, REQUIREMENT, SAMPLE, SDG-CAPTION, STD, SW-ADDR-METHOD, SW-AXIS-TYPE, SW-BASE-TYPE, SW-CALIBRATION-METHOD, SW-CALPRM, SW-CALPRM-PROTOTYPE, SW-CLASS, SW-CLASS-ATTR-IMPL, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-CODE-SYNTAX, SW-COLLECTION, SW-COMPU-METHOD, SW-CPU-MEM-SEG, SW-DATA-CONSTR, SW-EVENT, SW-EVENT-SOURCE, SW-FEATURE, SW-FEATURE-INTERFACE, SW-FEATURE-VARIANT, SW-GENERIC-AXIS-PARAM-TYPE, SW-INSTANCE, SW-INSTANCE-TREE, SW-MC-BASE-TYPE, SW-MC-FRAME, SW-MC-INTERFACE, SW-MC-INTERFACE-SOURCE, SW-OPER-MODE, SW-RECORD-LAYOUT, SW-SERVICE, SW-SERVICE-ARG, SW-SERVICE-PROTOTYPE, SW-SERVICE-RETURN, SW-SYSTEM, SW-SYSTEMCONST, SW-TASK, SW-TEMPLATE, SW-UNIT, SW-USER-ACCESS-CASE, SW-USER-GROUP, SW-VARIABLE, SW-VARIABLE-PROTOTYPE, SW-VCD-CRITERION, SYN-CAPTION, TABLE-CAPTION, TEAM-MEMBER, TOPIC-1, TOPIC-2, VARIANT-CHAR, VARIANT-DEF, XDOC, XFILE, XREF-TARGET
Is context for:
Text


2.250. SI-UNIT

Description
Describes a standardized unit of measurement, which can be used to convert other units of measurement. The following belong to this:
  • Amount of substance
  • Electric current
  • Length
  • Mass
  • Luminous intensity
  • Temperature
  • Time
The measuring unit exponents are determined using the specific attributes.
The definition of a <SW-UNIT> can be based both on a <SI-UNIT> and on any other unit of measurement, using the reference <SW-UNIT-REF> . Here the following must be observed:
  • When using referenced units of measurement, the chain of references must end at a SI-UNIT.
  • The conversion of the current unit of measurement into the unit of measurement referenced is specified through <SW-UNIT-CONVERSION-METHOD> . Here the following is valid:
    Conversion of measuring units
    SW-UNIT = SW-UNIT-GRADIENT * SW-UNIT-REF + SW-UNIT-OFFSET
Example
<SW-UNIT ID="HERTZ">
                   <LONG-NAME>HERTZ</LONG-NAME>
                   <SHORT-NAME>Hz</SHORT-NAME>
                   <SW-UNIT-DISPLAY>Hz</SW-UNIT-DISPLAY>
                   <SI-UNIT TIME-EXPO="-1"></SI-UNIT>
                </SW-UNIT>
                <SW-UNIT ID="UPM">
                   <LONG-NAME>ROTATES PER MINUTE</LONG-NAME>
                   <SHORT-NAME>UPM</SHORT-NAME>
                   <SW-UNIT-DISPLAY>UPM</SW-UNIT-DISPLAY>
                   <SW-UNIT-CONVERSION-METHOD>
                      <SW-UNIT-GRADIENT>0.0166</SW-UNIT-GRADIENT>
                      <SW-UNIT-OFFSET>0</SW-UNIT-OFFSET>
                   </SW-UNIT-CONVERSION-METHOD>
                   <SW-UNIT-REF ID-REF="HERTZ">HERTZ</SW-UNIT-REF>
                </SW-UNIT>
UPM = 0.0166 * Hz + 0
Formal Description
Within context of: | SW-UNIT
Is context for: | Text
Name | Type | Notes
[AMOUNT-OF-SUBSTANCE-EXPO] optional | String (CDATA) | Exponent of substance amount unit
[ELECTRIC-CURRENT-EXPO] optional | String (CDATA) | Exponent of electricity unit
[LENGTH-EXPO] optional | String (CDATA) | Exponent of unit of length
[LUMINOUS-INTENSITY-EXPO] optional | String (CDATA) | Exponent of unit of luminous intensity
[MASS-EXPO] optional | String (CDATA) | Exponent of unit of mass
[THERMODYNAMIC-TEMPERATURE-EXPO] optional | String (CDATA) | Exponent of unit of temperature
[TIME-EXPO] optional | String (CDATA) | Exponent of unit of time


2.251. SIGNAL-REF

Description
Use <SIGNAL-REF> to reference a Hardware signal. It is e.g. used within MSRSW to associate events with a signal in the hardware system.
Example
<SW-EVENT-SOURCE >
                   <LONG-NAME>Kickdown pressed</LONG-NAME>
                   <SHORT-NAME>ev_kickdown</SHORT-NAME>
                   <SIGNAL-REF>/body/kickdown</SIGNAL-REF>
                </SW-EVENT-SOURCE>
This example illustrates an event source which is connected to the signal kickdown within a hardware system named body. It is implemented as a reference which is resolved according to the regular MSR linking mechanism.
Formal Description
Within context of: | SW-EVENT-SOURCE
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  |
[EXT-ID-CLASS] fixed value | SGML string (NMTOKEN) | SIGNAL |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | EXTERNAL |
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF |
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK |


2.252. SIMILAR-PRODUCTS

Description
Use <SIMILAR-PRODUCTS> to enter a reference to similar products .
Example
Formal Description
Within context of: | GENERAL-PRODUCT-DATA-1
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.253. SPANSPEC

Description
Use <SPANSPEC> to determine the identification data for a merging of columns.
Example
Formal Description
Within context of: | TGROUP
Has no contents. |
Name
Type
Values / Default
Notes
[NAMEEND]
required
SGML string (NMTOKEN)
Identification number of the final column to be merged.
[NAMEST]
required
SGML string (NMTOKEN)
Identification number of the first column to be merged.
[SPANNAME]
required
SGML string (NMTOKEN)
Identification name for the column merging specified
[ALIGN]
has default value
Value selection (NAMEDTOKENGROUP)
  • LEFT
  • RIGHT
  • CENTER
  • JUSTIFY
  • CHAR
LEFT - The table contents is justified left. RIGHT - The table contents is justified right. CENTER - The table contents is centered horizontally. JUSTIFY - The table contents is displayed with justified typesetting. There is an equal distance from the left and right-hand edges of the cell. CHAR - The alignment of the table contents is set by [CHAR] .
[CHAR]
optional
String (CDATA)
If [ALIGN]="CHAR", this specifies the alignment sign e.g. "bzlw", as a decimal point separator from an existing value of [CHAR] . The sign cannot be a SDATA entity.
[CHAROFF]
optional
SGML string (NMTOKEN)
If [ALIGN]="CHAR", this value indicates the percentage of the current column width to the left edge of the alignment sign in the [CHAR]-attribute. If there is no alignment sign in the element <ENTRY>, alignment is always horizontal right. The default value is taken from the <COLSPEC> element, which is located in the attribute [NAMEST] .
[COLSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the column guides of a cell are to be visible. You should enter 0, if no column guides are to be displayed. You should enter 1 , if the column guides are to be displayed.
[ROWSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the row guides of a cell are to be visible. You should enter 0, if no row guides are to be displayed. You should enter 1 , if the row guides are to be displayed.


2.254. SPECIAL-DATA

Description
Container element for <SDG> .
Example
Formal Description
Within context of: | MSRSW
Is context for: | SDG


2.255. STANDARD-SW-MODULES

Description
Use <STANDARD-SW-MODULES> to enter the standardized SW module .
Example
Formal Description
Within context of: | DESIGN-REQUIREMENTS
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.256. STATE

Description
<STATE> represents the current state of the current file according to the configuration management plan.
Example
<STATE>reviewed</STATE>
Formal Description
Within context of: | COMPANY-REVISION-INFO, DOC-REVISION
Is context for: | Text


2.257. STATE-1

Description
Use <STATE-1> to enter the version and state of a standard or an external document.
Example
Formal Description
Within context of: | STD, XDOC
Is context for: | Text


2.258. STD

Description
Use <STD> to reference external standards within a paragraph element.
Example
Formal Description
Within context of: | P, TBR
Is context for: | LONG-NAME-1, SHORT-NAME, SUBTITLE, STATE-1, DATE-1, URL, POSITION
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | STD | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.259. SUB

Description
Use <SUB> to display sections of text within a paragraph element, in a smaller font beneath the base line.
Example
Formal Description
Within context of: | ABS, CHANGE, DESC, IE, INDENT-SAMPLE, ITEM-LABEL, LABEL, LONG-NAME, LONG-NAME-1, MAX, MIN, MSR-QUERY-RESULT-TEXT, P, REASON, SW-UNIT-DISPLAY, TBR, TEXT, TOL, TYP, UNIT
Is context for: | Text


2.260. SUBTITLE

Description
Use <SUBTITLE> to enter a sub-heading of an external standard.
Example
Formal Description
Within context of: | STD
Is context for: | Text


2.261. SUP

Description
Use <SUP> to display sections of text within a paragraph element, in a smaller font above the base line.
Example
Formal Description
Within context of: | ABS, CHANGE, DESC, IE, INDENT-SAMPLE, ITEM-LABEL, LABEL, LONG-NAME, LONG-NAME-1, MAX, MIN, MSR-QUERY-RESULT-TEXT, P, REASON, SW-UNIT-DISPLAY, TBR, TEXT, TOL, TYP, UNIT
Is context for: | Text


2.262. SW-ACCESS-DEF

Description
This element describes a specific entry into the "access authorization table". This means it indicates which users ( <SW-USER-GROUP-REF>)that are permitted to execute different types of access operations ( <SW-USER-ACCESS-CASE-REF>) on which objects ( <SW-COLLECTION-REF> ).
This following notes apply:
  • If no <SW-COLLECTION> is referenced, the access authorization applies to all objects.
  • The access semantics must be controlled through the allocation of an arranged <SHORT-NAME> within <SW-USER-ACCESS-CASE>. For this purpose, a verbal description can be given in <DESC> under <SW-USER-ACCESS-CASE> . This refers to necessary priorities among the access operations.
  • The concept of the access authorization as being an open system (anything is permitted), or as a closed system (nothing is permitted), must be carried out by allocating the semantics of the <SW-USER-ACCESS-CASES> appropriately.
  • It is logical that the access system is regarded first as a closed system.
Example
Example of a closed system:
<SW-USER-RIGHT-SPEC>
                   <SW-USER-GROUPS>
                      <SW-USER-GROUP ID="ALL-USERS">
                         <DESC>If no user is referred to, all users belong to this group </DESC>
                      </SW-USER-GROUP>
                      <SW-USER-GROUP ID="THE-BOSSES">
                         <LONG-NAME>The bosses of this world</LONG-NAME>
                         <SHORT-NAME>the-bosses</SHORT-NAME>
                         <SYSTEM-USERS>
                            <SYSTEM-USER>bigates</SYSTEM-USER>
                            <SYSTEM-USER>gebush</SYSTEM-USER>
                            <SYSTEM-USER>vlputin</SYSTEM-USER>
                            <SYSTEM-USER>frbeckenbauer</SYSTEM-USER>
                         </SYSTEM-USERS>
                      </SW-USER-GROUP>
                   </SW-USER-GROUPS>
                   <SW-USER-ACCESS-CASES>
                      <SW-USER-ACCESS-CASE ID="READ-ACCESS">
                         <LONG-NAME>Read access</LONG-NAME>
                         <SHORT-NAME>Read</SHORT-NAME>
                      </SW-USER-ACCESS-CASE>
                      <SW-USER-ACCESS-CASE ID="NO-ACCESS">
                         <LONG-NAME>No access</LONG-NAME>
                         <SHORT-NAME>No-Access</SHORT-NAME>
                         <DESC>"No-Access" establishes a closed system. Access can be grantet explicitly by another Access Case.</DESC>
                      </SW-USER-ACCESS-CASE>
                   </SW-USER-ACCESS-CASES>
                   <SW-USER-ACCESS-DEFINTIONS>
                      <SW-ACCESS-DEF>
                         <SW-USER-GROUP-REF ID-REF="THE-BOSSES">the-bosses</SW-USER-GROUP-REF>
                         <SW-USER-ACCESS-CASE-REF ID-REF="READ-ACCESS">Read</SW-USER-ACCESS-CASE-REF>
                      </SW-ACCESS-DEF>
                      <SW-ACCESS-DEF>
                         <SW-USER-GROUP-REF ID-REF="ALL-USERS">ALL-USERS</SW-USER-GROUP-REF>
                         <SW-USER-ACCESS-CASE-REF ID-REF="NO-ACCESS">No-Access</SW-USER-ACCESS-CASE-REF>
                      </SW-ACCESS-DEF>
                   </SW-USER-ACCESS-DEFINTIONS>
                </SW-USER-RIGHT-SPEC>
Formal Description
Within context of: | SW-USER-ACCESS-DEFINTIONS
Is context for: | SW-USER-GROUP-REF, SW-USER-ACCESS-CASE-REF, SW-COLLECTION-REF


2.263. SW-ACCESS-DURATION

Description
Use <SW-ACCESS-DURATION> to define the period of time that an object is being accessed. The object can for example be a variable. The duration is set with a CSE code and a CSE code factor.
Example
<SW-ACCESS-DURATION>
                  <SW-CSE-CODE>4</SW-CSE-CODE>
                  <SW-CSE-CODE-FACTOR>1</SW-CSE-CODE-FACTOR>
                </SW-ACCESS-DURATION>
Formal Description
Within context of: | SW-ACCESSED-VARIABLE
Is context for: | SW-CSE-CODE, SW-CSE-CODE-FACTOR


2.264. SW-ACCESSED-CALPRMS

Description
Use <SW-ACCESSED-CALPRMS> to list all calibration parameters that will be accessed by the parent object. It can for example list all parameters that a <SW-SERVICE> is accessing. All parameters that only will be accessed under certain conditions can be entered under the <SW-CALPRM-REF-SYSCOND> structure, e.g. when a system constant has a specific value.
Example
The parameter Calprm1 is always accessed and Calprm3 is only accessed when LINA_Gear > 0.
<SW-ACCESSED-CALPRMS>
                  <SW-CALPRM-REF>Calprm1</SW-CALPRM-REF>
                  <SW-CALPRM-REF-SYSCOND>
                    <SW-CALPRM-REF>Calprm3</SW-CALPRM-REF>
                    <SW-SYSCOND>
                      <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&gt;0
                    </SW-SYSCOND>
                  <SW-CALPRM-REF-SYSCOND>
                </SW-ACCESSED-CALPRMS>
Formal Description
Within context of: | SW-INTERFACE-ACCESSED-ELEMENT-SET, SW-SERVICE, SW-SERVICE-ACCESSED-ELEMENT-SET, SW-SERVICE-IMPL
Is context for: | SW-CALPRM-REF, SW-CALPRM-REF-SYSCOND


2.265. SW-ACCESSED-CLASS-INSTANCES

Description
Use <SW-ACCESSED-CLASS-INSTANCES> to list all class instances that will be accessed by the parent object. It can for example list all class instances that a <SW-SERVICE> is accessing. All instances that only will be accessed under certain conditions can be entered under the <SW-CLASS-INSTANCE-REF-SYSCOND> structure, e.g. when a system constant has a specific value.
Example
<SW-ACCESSED-CLASS-INSTANCES>
                  <SW-CLASS-INSTANCE-REF>ClassIn1</SW-CLASS-INSTANCE-REF>
                  <SW-CLASS-INSTANCE-REF-SYSCOND>
                    <SW-CLASS-INSTANCE-REF>ClassIn3</SW-CLASS-INSTANCE-REF>
                    <SW-SYSCOND>
                      <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&gt;0
                    </SW-SYSCOND>
                  <SW-CLASS-INSTANCE-REF-SYSCOND>
                </SW-ACCESSED-CLASS-INSTANCES>
Formal Description
Within context of: | SW-INTERFACE-ACCESSED-ELEMENT-SET, SW-SERVICE, SW-SERVICE-ACCESSED-ELEMENT-SET, SW-SERVICE-IMPL
Is context for: | SW-CLASS-INSTANCE-REF, SW-CLASS-INSTANCE-REF-SYSCOND


2.266. SW-ACCESSED-SERVICE

Description
Use <SW-ACCESSED-SERVICE> to list all services that will be accessed by the parent object (actually it is the parent of the container <SW-ACCESSED-SERVICES>). It can for example list all services that a <SW-SERVICE> is accessing. All services that only will be accessed under certain conditions can be defined with the <SW-SYSCOND> structure, e.g. when a system constant has a specific value. The service will only be included when the <SW-SYSCOND> is evaluated to true.
Example
<SW-ACCESSED-SERVICE>
                  <SW-SERVICE-REF>Serv1</SW-SERVICE-REF>
                  <SW-SYSCOND>
                    <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&gt;0
                  </SW-SYSCOND>
                </SW-ACCESSED-SERVICE>
Formal Description
Within context of: | SW-ACCESSED-SERVICES
Is context for: | SW-SERVICE-REF, SW-SYSCOND, SW-OPER-MODE-REF, SW-TASK-REF


2.267. SW-ACCESSED-SERVICES

Description
This is a container for all services that are being accessed by the parent to this element.
Example
Formal Description
Within context of: | SW-INTERFACE-ACCESSED-ELEMENT-SET, SW-SERVICE, SW-SERVICE-ACCESSED-ELEMENT-SET, SW-SERVICE-IMPL
Is context for: | SW-ACCESSED-SERVICE


2.268. SW-ACCESSED-VARIABLE

Description
<SW-ACCESSED-VARIABLE> defines a variable that is being accessed from for example a service. The variable reference can either be entered directly or it can be made dependent of a system condition. There are also some additional properties such as:
  • <SW-VARIABLE-USAGE>
    to set READ, WRITE or READWRITE for example.
  • <SW-VARIABLE-ACCESS-SEQUENCE>
  • <SW-VARABLE-ACCESS-IMPL>
    to set the implementation e.g OPTIMISED
  • <SW-ACCESS-DURATION>
    to set the access duration.
Example
<SW-VARIABLE-REF>TST_varSimple_mp</SW-VARIABLE-REF>
                  <SW-VARIABLE-USAGE>READ</SW-VARIABLE-USAGE>
                  <SW-VARIABLE-ACCESS-IMPL>OPTIMISED</SW-VARIABLE-ACCESS-IMPL>
                </SW-ACCESSED-VARIABLE>
Formal Description
Within context of: | SW-ACCESSED-VARIABLES
Is context for: | SW-VARIABLE-REF, SW-VARIABLE-REF-SYSCOND, SW-VARIABLE-USAGE, SW-VARIABLE-ACCESS-SEQUENCE, SW-VARIABLE-ACCESS-IMPL, SW-ACCESS-DURATION


2.269. SW-ACCESSED-VARIABLES

Description
Example
Formal Description
Within context of: | SW-INTERFACE-ACCESSED-ELEMENT-SET, SW-SERVICE, SW-SERVICE-ACCESSED-ELEMENT-SET, SW-SERVICE-IMPL
Is context for: | SW-ACCESSED-VARIABLE


2.270. SW-ADDR-INFO

Description
This element provides the information required to address a memory object. For this purpose, the following must be input:
  • The memory segment (referenced through <SW-CPU-MEM-SEG-REF> ) in which the memory object is to be stored (e.g. RAM, ROM).
  • The base address, given by <SW-BASE-ADDR>
  • The offset, specified using <SW-ADDR-OFFSET>
  • The size of the memory object in bytes, indicated by <SW-SIZEOF-INSTANCE> . This is required for the recalculation of the individual component addresses, on temporary storage of the structures.
Example
<SW-ADDR-INFO>
                   <SW-CPU-MEM-SEG-REF>RAM</SW-CPU-MEM-SEG-REF>
                   <SW-ADDR-OFFSET>0x100</SW-ADDR-OFFSET>
                   <SW-SIZEOF-INSTANCE>25</SW-SIZEOF-INSTANCE>
                </SW-ADDR-INFO>
Formal Description
Within context of: | SW-ADDR-INFOS, SW-CPU-ADDR-EPK
Is context for: | SW-CPU-MEM-SEG-REF, SW-BASE-ADDR, SW-ADDR-OFFSET, SW-SIZEOF-INSTANCE


2.271. SW-ADDR-INFOS

Description
Container-Element for <SW-ADDR-INFOS> .
Example
Formal Description
Within context of: | SW-INSTANCE-PROPS-VARIANT
Is context for: | SW-ADDR-INFO


2.272. SW-ADDR-METHOD

Description
An address schematic <SW-ADDR-METHOD> describes how variables or parameters are addressed in the ECU. Address methods can take the form of direct addressing or indirect addressing using a vector.
The principle role of this element is the declaration of keywords (in the subelement <SHORT-NAME>) for the address calculation process. The process itself is given a verbal description (in <SW-ADDR-METHOD-DESC>) rather than a formal one. However, a formal reference <SW-CPU-MEM-SEG-REF> to the memory segment concerned is issued. . This approach was adopted as the number of possible address schematics is relatively small. A complete formal description would create unnecessary work.
Example
<SW-ADDR-METHODS>
                   <SW-ADDR-METHOD ID="IDBIT">
                      <LONG-NAME>This is Addr-Method Bit</LONG-NAME>
                      <SHORT-NAME>Bit</SHORT-NAME>
                      <SW-CPU-MEM-SEG-REF></SW-CPU-MEM-SEG-REF>
                      <SW-ADDR-METHOD-DESC>
                         <VERBATIM>Adressierschema: Bit Kopfzeile: BitHeader Fusszeile: BitFooter Adressierart: Bit Datentyp des Vektors: aw </VERBATIM>
                      </SW-ADDR-METHOD-DESC>
                   </SW-ADDR-METHOD>
                </SW-ADDR-METHODS>
Formal Description
Within context of: | SW-ADDR-METHODS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-CPU-MEM-SEG-REF, SW-ADDR-METHOD-DESC
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-ADDR-METHOD | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.

In future versions further formal components may be added to this, if required.


2.273. SW-ADDR-METHOD-DESC

Description
Verbal description of the method for addressing variables or parameters.
Example
Formal Description
Within context of: | SW-ADDR-METHOD
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.274. SW-ADDR-METHOD-REF

Description
This element refers to an addressing method <SW-ADDR-METHOD>. The reference is established using the [ID-REF]-attribute contents of the <SW-ADDR-METHOD-REF>-element which indicates an <SW-ADDR-METHOD>-element with an [ID]-attribute of the same value. The reference can also emerge via the <SHORT-NAME> of the <SW-ADDR-METHOD-REF>-element, which then has the same contents as the <SHORT-NAME> of a <SW-ADDR-METHOD> .
Example
Formal Description
Within context of: | SW-ADDR-METHOD-REF-SYSCOND, SW-ADDR-METHOD-REFS, SW-DATA-DEF-PROPS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-ADDR-METHOD | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.275. SW-ADDR-METHOD-REF-SYSCOND

Description
Use <SW-ADDR-METHOD-REF-SYSCOND> to create a <SW-ADDR-METHOD-REF> that will be valid only when the corresponding <SW-SYSCOND> expression evaluates to true. This is useful when a <SW-ADDR-METHOD-REF> shall be used when system constant has a certain value.
Example
This addressing method reference is used when LINA_Gear is less or equal to 4.
<SW-ADDR-METHOD-REF-SYSCOND>
                  <SW-ADDR-METHOD-REF>Addr_Ref</SW-ADDR-METHOD-REF>
                  <SW-SYSCOND>
                    <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&lt;=4
                  </SW-SYSCOND>
                </SW-ADDR-METHOD-REF-SYSCOND>
Formal Description
Within context of: | SW-ADDR-METHOD-REFS
Is context for: | SW-ADDR-METHOD-REF, SW-SYSCOND


2.276. SW-ADDR-METHOD-REFS

Description
Container element for <SW-ADDR-METHOD-REF> .
Example
Formal Description
Within context of: | SW-COLLECTION-CONT, SW-FEATURE-ELEMENTS
Is context for: | SW-ADDR-METHOD-REF, SW-ADDR-METHOD-REF-SYSCOND


2.277. SW-ADDR-METHODS

Description
Container element for <SW-ADDR-METHOD> .
Example
Formal Description
Within context of: | SW-DATA-DICTIONARY-SPEC
Is context for: | ADMIN-DATA, SW-ADDR-METHOD


2.278. SW-ADDR-OFFSET

Description
This element specifies the offset of a memory object.
Example
See 2.270. SW-ADDR-INFO
Formal Description
Within context of: | SW-ADDR-INFO
Is context for: | Text


2.279. SW-ALIAS-NAME

Description
This element describes an alias name which can be used for compatibility to other naming conventions.
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | Text


2.280. SW-APPLICATION-NOTES

Description
In this element are application instructions specified in text form.
Example
Formal Description
Within context of: | SW-CLASS, SW-FEATURE
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.281. SW-AR-RELATION

Description
This element contains information about releations between SW-Components except from relations within a component such as Part-of or Variant-of relations. The element <SW-AR-RELATION-TYPE> defines the type of relation. The elements SW-FEATURE-VARIANT-REF, SW-FEATURE-REF and/or SW-CLASS-REF defines the SW-Component to which this SW-Component relates to.
Example
Formal Description
Within context of: | SW-AR-RELATIONS
Is context for: | DESC, SW-SYSCOND, SW-AR-RELATION-TYPE, SW-FEATURE-VARIANT-REF, SW-FEATURE-REF, SW-CLASS-REF


2.282. SW-AR-RELATION-TYPE

Description
Please look at the description for <SW-AR-RELATION>.
Example
Formal Description
Within context of: | SW-AR-RELATION
Is context for: | Text


2.283. SW-AR-RELATIONS

Description
SW-AR-RELATIONS can contain 0..n <SW-AR-RELATION> elements.
Example
Formal Description
Within context of: | SW-FEATURE
Is context for: | SW-AR-RELATION


2.284. SW-ARCHITECTURE

Description
This element provides a verbal description of the existing software system architecture. The verbal description still follows a predefined structuring pattern, however:
  • Overview <OVERVIEW>
  • Task specification and process structure <SW-TASK-SPEC>
  • Interrupt specification <INTERRUPT-SPEC>
  • Temporal dependencies <TIME-DEPENDENCY>
  • Other dependencies <ADD-SPEC>
Example
Formal Description
Within context of: | SW-SYSTEM
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, OVERVIEW, SW-TASK-SPEC, INTERRUPT-SPEC, TIME-DEPENDENCY, ADD-SPEC


2.285. SW-ARRAY-INDEX

Description
Specifies the field index for exactly one coordinate of a characteristic variable array in an instance <SW-INSTANCE>. The instance corresponds either with a structure, a class attribute or a field index.
The array index begins at 0.
Example
<SW-INSTANCE ID="IDTEST">
                   <LONG-NAME>Kenngröen-Array</LONG-NAME>
                   <SHORT-NAME>kgr_a</SHORT-NAME>
                   <SW-INSTANCE ID="IDB6433D7radB380B">
                      <SW-ARRAY-INDEX>0</SW-ARRAY-INDEX>
                      <SW-FEATURE-REF>test_AG</SW-FEATURE-REF>
                      <CATEGORY>curve_individual</CATEGORY>
                      <SW-INSTANCE-PROPS-VARIANTS>
                         <SW-INSTANCE-PROPS-VARIANT>
                            <SW-AXIS-CONTS>
                               <SW-AXIS-CONT>
                                  <SW-UNIT-REF>Grad-C</SW-UNIT-REF>
                                  <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
                                  <SW-VALUES-PHYS>
                                     <V>-49.3</V>
                                     <V>-48.6</V>
                                     <V>-47.8</V>
                                     <V>-47.1</V>
                                     <V>-46.4</V>
                                     <V>-45.7</V>
                                  </SW-VALUES-PHYS>
                               </SW-AXIS-CONT>
                               <SW-AXIS-CONT>
                                  <SW-UNIT-REF>dez</SW-UNIT-REF>
                                  <SW-AXIS-INDEX>0</SW-AXIS-INDEX>
                                  <SW-VALUES-PHYS>
                                     <V>1.0</V>
                                        <V>2.0</V>
                                     <V>3.0</V>
                                        <V>4.0</V>
                                     <V>5.0</V>
                                     <V>6.0</V>
                                  </SW-VALUES-PHYS>
                               </SW-AXIS-CONT>
                            </SW-AXIS-CONTS>
                         </SW-INSTANCE-PROPS-VARIANT>
                      </SW-INSTANCE-PROPS-VARIANTS>
                   </SW-INSTANCE>
                   <SW-INSTANCE ID="IDB6433D7radBBD87">
                      <SW-ARRAY-INDEX>1</SW-ARRAY-INDEX>
                      <SW-FEATURE-REF>test_AG</SW-FEATURE-REF>
                      <CATEGORY>curve_individual</CATEGORY>
                      <SW-INSTANCE-PROPS-VARIANTS>
                            <SW-INSTANCE-PROPS-VARIANT>
                               <SW-AXIS-CONTS>
                                  <SW-AXIS-CONT>
                                  <SW-UNIT-REF>Grad-C</SW-UNIT-REF>
                                  <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
                                  <SW-VALUES-PHYS>
                                     <V>-49.3</V>
                                     <V>-48.6</V>
                                     <V>-47.8</V>
                                     <V>-47.1</V>
                                     <V>-46.4</V>
                                     <V>-45.7</V>
                                  </SW-VALUES-PHYS>
                               </SW-AXIS-CONT>
                               <SW-AXIS-CONT>
                                  <SW-UNIT-REF>dez</SW-UNIT-REF>
                                  <SW-AXIS-INDEX>0</SW-AXIS-INDEX>
                                  <SW-VALUES-PHYS>
                                     <V>1.0</V>
                                     <V>2.0</V>
                                     <V>3.0</V>
                                     <V>4.0</V>
                                     <V>5.0</V>
                                     <V>6.0</V>
                                  </SW-VALUES-PHYS>
                               </SW-AXIS-CONT>
                            </SW-AXIS-CONTS>
                         </SW-INSTANCE-PROPS-VARIANT>
                      </SW-INSTANCE-PROPS-VARIANTS>
                   </SW-INSTANCE>
                   <SW-INSTANCE ID="IDB6433D7rad2B10B">
                      <SW-ARRAY-INDEX>2</SW-ARRAY-INDEX>
                      <SW-FEATURE-REF>test_AG</SW-FEATURE-REF>
                      <CATEGORY>curve_individual</CATEGORY>
                      <SW-INSTANCE-PROPS-VARIANTS>
                         <SW-INSTANCE-PROPS-VARIANT>
                            <SW-AXIS-CONTS>
                               <SW-AXIS-CONT>
                                  <SW-UNIT-REF>Grad-C</SW-UNIT-REF>
                                  <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
                                  <SW-VALUES-PHYS>
                                     <V>-49.3</V>
                                     <V>-48.6</V>
                                     <V>-47.8</V>
                                     <V>-47.1</V>
                                     <V>-46.4</V>
                                     <V>-45.7</V>
                                  </SW-VALUES-PHYS>
                               </SW-AXIS-CONT>
                               <SW-AXIS-CONT>
                                  <SW-UNIT-REF>dez</SW-UNIT-REF>
                                  <SW-AXIS-INDEX>0</SW-AXIS-INDEX>
                                  <SW-VALUES-PHYS>
                                     <V>1.0</V>
                                     <V>2.0</V>
                                     <V>3.0</V>
                                     <V>4.0</V>
                                     <V>5.0</V>
                                     <V>6.0</V>
                                  </SW-VALUES-PHYS>
                               </SW-AXIS-CONT>
                            </SW-AXIS-CONTS>
                         </SW-INSTANCE-PROPS-VARIANT>
                      </SW-INSTANCE-PROPS-VARIANTS>
                   </SW-INSTANCE>
                </SW-INSTANCE>
Formal Description
Within context of: | SW-INSTANCE
Is context for: | Text


2.286. SW-ARRAYSIZE

Description
The existence of <SW-ARRAYSIZE> turns the parent element into a multidimensional object. It is then possible to create arrays of variables, parameters etc. <SW-ARRAYSIZE> should not be used to imitate stereotypes such as curves or maps since these structures are stored in the DTD itself as own elements, refer to <SW-CALPRM-AXIS-SET> for a <SW-CALPRM>. Apart from that any array can be created.
Example
<SW-VARIABLE>
                   <LONG-NAME>This is Array1</LONG-NAME>
                   <SHORT-NAME>Array1</SHORT-NAME>
                   <SW-ARRAYSIZE>
                      <VF>3</VF>
                   </SW-ARRAYSIZE>
                   <SW-DATA-DEF-PROPS>
                      <SW-ADDR-METHOD-REF>OffsetAdS1</SW-ADDR-METHOD-REF>
                      <SW-BASE-TYPE-REF>UWORD</SW-BASE-TYPE-REF>
                      <SW-CALIBRATION-ACCESS>CALIBRATION</SW-CALIBRATION-ACCESS>
                      <SW-CODE-SYNTAX-REF>Bit</SW-CODE-SYNTAX-REF>
                      <SW-COMPU-METHOD-REF>default</SW-COMPU-METHOD-REF>
                   </SW-DATA-DEF-PROPS>
                </SW-VARIABLE>
Formal Description
Within context of: | SW-CALPRM, SW-CALPRM-PROTOTYPE, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-SERVICE-ARG, SW-SERVICE-RETURN, SW-VARIABLE, SW-VARIABLE-PROTOTYPE
Is context for: | VF


2.287. SW-AXIS-CONT

Description
Description of the contents of a characteristic variable axis, specified in the subelement <SW-AXIS-INDEX>, as well as the optional data assignment of the corresponding values e.g. physical and integer values to the subelements <SW-VALUES-PHYS>, <SW-VALUES-CODED> etc. If there is more than one axis, the axis with index 1 is incremented first. This means that the values are given in the following order:
v(1,1) | ... | v(n,1)
v(1,2) | ... | v(n,2)
... |  |
v(1,m) | ... | v(n, m)
The element <SW-AXIS-CONT> appears as long as the corresponding instantiated variable or parameter has an axis. The axis currently relevant is specified in the subelement <SW-AXIS-INDEX> .
The contents of the axis can be specified on different levels:
  • Physical ( <SW-VALUES-PHYS> )
  • Decimal-coded ( <SW-VALUES-CODED> )
  • Hexadecimal-coded ( <SW-VALUES-CODED-HEX> )
  • Any other representations ( <SW-VALUES-GENERIC> in connection to attribute [TYPE] )
Since the MSRSW.DTD should also be used to transport purely physical data independently of the details in the data dictionary, it is important that measuring units can be specified. These are referenced using <SW-UNIT-REF> .
Example
For an example, see 2.285. SW-ARRAY-INDEX 2.501. SW-INSTANCE .
Formal Description
Within context of: | SW-AXIS-CONTS
Is context for: | SW-SYSCOND, SW-UNIT-REF, SW-AXIS-INDEX, SW-VALUES-PHYS, SW-VALUES-CODED, SW-VALUES-CODED-HEX, SW-VALUES-GENERIC


2.288. SW-AXIS-CONTS

Description
<SW-AXIS-CONTS> describes the contents of all axes belonging to a certain characteristic variable.
Example
See 2.285. SW-ARRAY-INDEX 2.501. SW-INSTANCE .
Formal Description
Within context of: | SW-INSTANCE-PROPS-VARIANT
Is context for: | SW-AXIS-CONT


2.289. SW-AXIS-GENERIC

Description
This element defines an axis for the base points calculated in the ECU. The ECU is equipped with a fixed calculation algorithm. Parameters for the algorithm can be stored in the data component of the ECU. The following is valid:
  • The algorithm to be used is specified as <SW-AXIS-TYPE> in the data dictionary semi-formal (reservation of keyword and specification of parameters). Thus when forming an axis, the algorithm is given through the appropriate reference ( <SW-AXIS-TYPE-REF> ).
  • The number of base points to be calculated is defined in <SW-NUMER-OF-AXIS-POINTS>. This element exists to enable the number of axis points to be stored explicitly, although it could also be described as <SW-GENERIC-AXIS-PARAM> .
  • The calculated base points can be stored on a physical level in the element <SW-VALUES-PHYS> , which means that it is not necessary for the required calculation algorithm to be implemented in every MCD system.
  • The calculated base points can be stored on a standardized level in the element <SW-VALUES-CODED> , which means that it is not necessary for the required calculation algorithm to be implemented in every MCD system.
Example
<SW-AXIS-TYPE ID="ID72ED69DFrad6E82E">
                   <SHORT-NAME>shiftOffset</SHORT-NAME>
                   <SW-GENERIC-AXIS-DESC>
                      <P>This is an axis with shift and offset.</P>
                   </SW-GENERIC-AXIS-DESC>

                   <SW-GENERIC-AXIS-PARAM-TYPES>
                      <SW-GENERIC-AXIS-PARAM-TYPE>
                         <SHORT-NAME>shift</SHORT-NAME>
                      </SW-GENERIC-AXIS-PARAM-TYPE>

                      <SW-GENERIC-AXIS-PARAM-TYPE>
                         <SHORT-NAME>offset</SHORT-NAME>
                      </SW-GENERIC-AXIS-PARAM-TYPE>
                   </SW-GENERIC-AXIS-PARAM-TYPES>
                </SW-AXIS-TYPE>
                <SW-CALPRM>
                   <SHORT-NAME>Festkl</SHORT-NAME>
                   <SW-DATA-DEF-PROPS>
                      <SW-CALPRM-AXIS-SET>
                         <SW-CALPRM-AXIS>
                            <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
                            <SW-AXIS-INDIVIDUAL>
                               <SW-AXIS-GENERIC>
                                  <SW-AXIS-TYPE-REF>ShiftOffset</SW-AXIS-TYPE-REF>
                               </SW-AXIS-GENERIC>
                            </SW-AXIS-INDIVIDUAL>
                         </SW-CALPRM-AXIS>
                      </SW-CALPRM-AXIS-SET>
                   </SW-DATA-DEF-PROPS>
                </SW-CALPRM>

                <SW-CALPRM>
                   <SHORT-NAME>Festkl</SHORT-NAME>
                   <SW-DATA-DEF-PROPS>
                      <SW-CALPRM-AXIS-SET>
                         <SW-CALPRM-AXIS>
                            <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
                            <SW-AXIS-INDIVIDUAL>
                               <SW-AXIS-GENERIC>
                                  <SW-AXIS-TYPE-REF>ShiftOffset</SW-AXIS-TYPE-REF>
                               </SW-AXIS-GENERIC>
                            </SW-AXIS-INDIVIDUAL>
                         </SW-CALPRM-AXIS>
                      </SW-CALPRM-AXIS-SET>
                   </SW-DATA-DEF-PROPS>
                </SW-CALPRM>
Formal Description
Within context of: | SW-AXIS-INDIVIDUAL
Is context for: | SW-AXIS-TYPE-REF, SW-NUMBER-OF-AXIS-POINTS, SW-GENERIC-AXIS-PARAMS, SW-VALUES-PHYS, SW-VALUES-CODED


2.290. SW-AXIS-GROUPED

Description
A group axis is described in <SW-AXIS-GROUPED>, as an alternative to <SW-AXIS-INDIVIDUAL> . A group axis is specified using
  • the reference ( <SW-CALPRM-REF> ) to the parameter from which an axis should be imported, which is then to serve as a group axis
  • the index of the axis to be used ( <SW-AXIS-INDEX>). This index should only be specified if the parameter under <SW-CALPRM-REF> contains more than one axis. It is standard practise for the axis index of parameters with more than one axis, to be set to 1, if data has not been assigned to <SW-AXIS-INDEX> .
  • If SW-AXIS-INDEX is equal to 0, the interpolation result of the referenced parameter is used as a base point index. This means that the keyword CURVE_AXIS_REF can be supported.
Example
Formal Description
Within context of: | SW-CALPRM-AXIS
Is context for: | SW-AXIS-INDEX, SW-CALPRM-REF


2.291. SW-AXIS-INDEX

Description
<SW-AXIS-INDEX> describes the index referring to the axis currently described, for which the contents is specified. The index satisfies the following convention:
0: | This is the value-axis of a curve or a map.
1: | This is the X-axis of a curve or a map.
2: | This is the Y-axis of a map.
3: | This is the Z-axis of a cuboid.
Example
See 2.291. SW-AXIS-INDEX 2.501. SW-INSTANCE .
Formal Description
Within context of: | SW-AXIS-CONT, SW-AXIS-GROUPED, SW-CALPRM-AXIS
Is context for: | Text


2.292. SW-AXIS-INDIVIDUAL

Description
This element describes an axis integrated into a parameter (field etc.). The integration makes this individual to each parameter. The so-called group axis represents the counterpart to this. It is conceived as an independent parameter and is referenced by the respective parameters used ( <SW-CALPRM-REF> within <SW-AXIS-GROUPED> ).
The specification of this axis incorporates:
  • Possible input variables for the axis ( <SW-VARIABLE-REFS> ).
    It is possible to specify more than one variable. Here the following is valid:
    • The variable with the highest priority must be given first. It is used in the generation of the code and is also displayed first in the application system.
    • All variables referenced must be of the same physical nature. This is usually detected in that the conversion formulae affected refer back to the same ( <SI-UNIT> s).
    • This multiple referencing allows a base point distribution for more than one input variable to be used. One example of this are the temperature curves, which can depend both on the induction air temperature and the engine temperature.
      These variables can be displayed simultaneously by MCD systems (adjustment systems), enabling operating points to be shown in the curves.
  • a conversion formula ( <SW-COMPU-METHOD-REF> )
  • a measuring unit ( <SW-UNIT-REF> )
  • a bit representation ( <SW-BIT-REPRESENTATION> )
  • Maximum and minimum number of axis base points ( <SW-MAX-AXIS-POINTS>, <SW-MIN-AXIS-POINTS> )
  • Plausibility checks ( <SW-DATA-CONSTR-REF> )
  • Generic axis characteristics ( <SW-AXIS-GENERIC> ), in the event that such an axis is involved.
The specifications <SW-VARIABLE-REFS>, <SW-COMPU-METHOD-REF>, <SW-UNIT-REF> can exist in parallel, although physically speaking, only one is practical. This parallelism introduces flexibility into the development process, as axes can be described purely physically, without a conversion formula being available.
The following priority exists:
  1. <SW-VARIABLE-REFS>
  2. <SW-COMPU-METHOD-REF>
  3. <SW-UNIT-REF>
Example
Formal Description
Within context of: | SW-CALPRM-AXIS
Is context for: | SW-VARIABLE-REFS, SW-COMPU-METHOD-REF, SW-UNIT-REF, SW-BIT-REPRESENTATION, SW-MAX-AXIS-POINTS, SW-MIN-AXIS-POINTS, SW-DATA-CONSTR-REF, SW-AXIS-GENERIC


2.293. SW-AXIS-TYPE

Description
Reserves names for specific axis calculation strategies. No formal specification is given, due to the fact that it is possible to use arbitrary algorithms for calculating axis-points. Instead, the algorithm is described verbally; the parameters ( <SW-GENERIC-AXIS-PARAM-TYPES>) are specified formally with respect to their names and constraints. As a result, <SW-AXIS-TYPE> mainly reserves appropriate keywords.
Example
<SW-AXIS-TYPES>
                   <SW-AXIS-TYPE>
                      <LONG-NAME>ACHENSTYP FR KENNWERTEBLOCK, UM ANZAHL DARSTELLEN ZU KNNEN</LONG-NAME>
                      <SHORT-NAME>KWB</SHORT-NAME>
                   </SW-AXIS-TYPE>
                </SW-AXIS-TYPES>
Formal Description
Within context of: | SW-AXIS-TYPES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-GENERIC-AXIS-DESC, SW-GENERIC-AXIS-PARAM-TYPES
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-AXIS-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | SW-GENERIC-AXIS-PARAM-TYPE |


2.294. SW-AXIS-TYPE-REF

Description
This element references an element <SW-AXIS-TYPE> .
Example
Formal Description
Within context of: | SW-AXIS-GENERIC, SW-AXIS-TYPE-REF-SYSCOND, SW-AXIS-TYPE-REFS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-AXIS-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.295. SW-AXIS-TYPE-REF-SYSCOND

Description
Use <SW-AXIS-TYPE-REF-SYSCOND> to create a <SW-AXIS-TYPE-REF> that will be valid only when the corresponding <SW-SYSCOND> expression evaluates to true. This is useful when a <SW-AXIS-TYPE-REF> shall be used when system constant has a certain value.
Example
This Axis Type reference is used when LINA_Gear is less or equal to 4.
<SW-AXIS-TYPE-REF-SYSCOND>
                  <SW-AXIS-TYPE-REF>Axis_type_Ref</SW-AXIS-TYPE-REF>
                  <SW-SYSCOND>
                    <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&lt;=4
                  </SW-SYSCOND>
                </SW-AXIS-TYPE-REF-SYSCOND>
Formal Description
Within context of: | SW-AXIS-TYPE-REFS
Is context for: | SW-AXIS-TYPE-REF, SW-SYSCOND


2.296. SW-AXIS-TYPE-REFS

Description
Container element for <SW-AXIS-TYPE-REF> .
Example
Formal Description
Within context of: | SW-COLLECTION-CONT, SW-FEATURE-ELEMENTS
Is context for: | SW-AXIS-TYPE-REF, SW-AXIS-TYPE-REF-SYSCOND


2.297. SW-AXIS-TYPES

Description
Container to describe all generic axes in the system.
Example
Formal Description
Within context of: | SW-DATA-DICTIONARY-SPEC
Is context for: | ADMIN-DATA, SW-AXIS-TYPE


2.298. SW-BASE-ADDR

Description
This element specifies the base address of a memory object.
Example
See 2.270. SW-ADDR-INFO
Formal Description
Within context of: | SW-ADDR-INFO
Is context for: | Text


2.299. SW-BASE-TYPE

Description
A <SW-BASE-TYPE> is used by variables, parameters and record layouts. In <SW-RECORD-LAYOUT>, a <SW-BASE-TYPE> can be referenced/used through the element <SW-BASE-TYPE-REF>. This specifies how the object in question, denoted by the container ( <SW-VARIABLE> or <SW-CALPRM> ) of <SW-DATA-DEF-PROPS> , is to be stored in the ECU memory.
Example
Formal Description
Within context of: | SW-BASE-TYPES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-BASE-TYPE-SIZE, SW-CODED-TYPE, SW-MEM-ALIGNMENT, BYTE-ORDER, SW-BASE-TYPE-REF
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-BASE-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.300. SW-BASE-TYPE-REF

Description
This element references the element <SW-BASE-TYPE> .
Example
Formal Description
Within context of: | SW-BASE-TYPE, SW-BASE-TYPE-REF-SYSCOND, SW-BASE-TYPE-REFS, SW-CALPRM-AXIS, SW-CALPRM-TEXT, SW-DATA-DEF-PROPS, SW-MC-BASE-TYPE, SW-RECORD-LAYOUT-V
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-BASE-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.301. SW-BASE-TYPE-REF-SYSCOND

Description
Use <SW-BASE-TYPE-REF-SYSCOND> to create a <SW-BASE-TYPE-REF> that will be valid only when the corresponding <SW-SYSCOND> expression evaluates to true. This is useful when a <SW-BASE-TYPE-REF> shall be used when system constant has a certain value.
Example
This Base Type reference is used when LINA_Gear is less or equal to 4.
<SW-BASE-TYPE-REF-SYSCOND>
                  <SW-BASE-TYPE-REF>base_type_Ref</SW-BASE-TYPE-REF>
                  <SW-SYSCOND>
                    <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&lt;=4
                  </SW-SYSCOND>
                </SW-BASE-TYPE-REF-SYSCOND>
Formal Description
Within context of: | SW-BASE-TYPE-REFS
Is context for: | SW-BASE-TYPE-REF, SW-SYSCOND


2.302. SW-BASE-TYPE-REFS

Description
Container element for <SW-BASE-TYPE-REF> .
Example
Formal Description
Within context of: | SW-COLLECTION-CONT, SW-FEATURE-ELEMENTS
Is context for: | SW-BASE-TYPE-REF, SW-BASE-TYPE-REF-SYSCOND


2.303. SW-BASE-TYPE-SIZE

Description
Describes the length of the data type specified in the container ( <SW-BASE-TYPE> or <SW-MC-BASE-TYPE>) in bits. When used within <SW-CPU-SPEC> , this specification denotes the data word size of the CPU.
Example
<SW-BASE-TYPE>
                   <SHORT-NAME>LONG<SHORT-NAME>
                         <SW-BASE-TYPE-SIZE>32</SW-BASE-TYPE-SIZE>
                      </SHORT-NAME></SHORT-NAME>
                </SW-BASE-TYPE>
Formal Description
Within context of: | SW-BASE-TYPE, SW-CPU-SPEC, SW-MC-BASE-TYPE
Is context for: | Text


2.304. SW-BASE-TYPES

Description
Container element for <SW-BASE-TYPE>. In addition, administrative data can be specified in <ADMIN-DATA> .
Example
Formal Description
Within context of: | SW-DATA-DICTIONARY-SPEC
Is context for: | ADMIN-DATA, SW-BASE-TYPE


2.305. SW-BIT-REPRESENTATION

Description
Description of the structure of a bit variable: comprises of the <BIT-POSITION> in a memory object (e.g. <SW-HOST-VARIABLE>, which stands parallel to <SW-BIT-REPRESENTATION>) and the <NUMBER-OF-BITS> . In this way, interrelated memory areas can be described. Non-related memory areas are not supported.
Example
<SW-VARIABLE ID="ID01">
                   <LONG-NAME>Variable_01</LONG-NAME>
                   <SHORT-NAME>Variable_01</SHORT-NAME>
                   <SW-DATA-DEF-PROPS>
                      <SW-ADDR-METHOD-REF>defaultAdrS</SW-ADDR-METHOD-REF>
                      <SW-BASE-TYPE-REF ID-REF="UWORD">UWORD</SW-BASE-TYPE-REF>
                      <SW-COMPU-METHOD-REF ID-REF="B-TRUE">B-TRUE</SW-COMPU-METHOD-REF>
                      <SW-DISPLAY-FORMAT>%13.11</SW-DISPLAY-FORMAT>
                   </SW-DATA-DEF-PROPS>
                </SW-VARIABLE>

                <SW-VARIABLE ID="ID02">
                   <LONG-NAME></LONG-NAME>
                   <SHORT-NAME>Variable_02</SHORT-NAME>
                   <SW-DATA-DEF-PROPS>
                      <SW-ADDR-METHOD-REF>defaultAdrS</SW-ADDR-METHOD-REF>
                      <SW-BASE-TYPE-REF ID-REF="UBIT">UBIT</SW-BASE-TYPE-REF>
                      <SW-BIT-REPRESENTATION>
                         <BIT-POSITION>5</BIT-POSITION>
                         <NUMBER-OF-BITS>1</NUMBER-OF-BITS>
                      </SW-BIT-REPRESENTATION>
                      <SW-CALIBRATION-ACCESS>CALIBRATION</SW-CALIBRATION-ACCESS>
                      <SW-CODE-SYNTAX-REF>Bit</SW-CODE-SYNTAX-REF>
                      <SW-COMPU-METHOD-REF>B_TRUE</SW-COMPU-METHOD-REF>
                      <SW-HOST-VARIABLE>
                         <SW-VARIABLE-REF>Variable_01</SW-VARIABLE-REF>
                      </SW-HOST-VARIABLE>
                   </SW-DATA-DEF-PROPS>
                </SW-VARIABLE>
Formal Description
Within context of: | SW-AXIS-INDIVIDUAL, SW-DATA-DEF-PROPS
Is context for: | BIT-POSITION, NUMBER-OF-BITS


2.306. SW-CALIBRATION-ACCESS

Description
Describes the applicability of parameters and variables. Valid values are:
  • CALIBRATION : applicable
  • NO-CALIBRATION : not applicable
  • NOT-IN-MEMORY : not in the EPROM (not for variables)
  • ADAPTIVE : adaptive characteristic variables (not for variables)
  • NOT-ACCESSIBLE : The element will not appear in an ASAP file.
  • READ-ONLY : The element will only appear as read-only in an ASAP file.
  • READ-WRITE : Both read and write access.
Example
Formal Description
Within context of: | SW-CALPRM-AXIS, SW-DATA-DEF-PROPS
Is context for: | Text


2.307. SW-CALIBRATION-HANDLE

Description
This element describes specific parameters, for the calibration method given in the container. The contents of the element depends on this method and cannot be defined in general terms.
Example
<SW-CALIBRATION-METHOD>
                   <SHORT-NAME>InCircuit</SHORT-NAME>
                   <SW-CALIBRATION-METHOD-VERSIONS>
                      <SW-CALIBRATION-METHOD-VERSION>
                         <LABEL>V2</LABEL>
                         <SW-CALIBRATION-HANDLE>
                            <VF>0x10000</VF>
                            <VF>0x200</VF>
                            <VF>0x4</VF>
                            <VF>0x30000</VF>
                            <VF>0x20000</VF>
                         </SW-CALIBRATION-HANDLE>
                      </SW-CALIBRATION-METHOD-VERSION>
                   </SW-CALIBRATION-METHOD-VERSIONS>
                </SW-CALIBRATION-METHOD>
Formal Description
Within context of: | SW-CALIBRATION-METHOD-VERSION
Is context for: | VF


2.308. SW-CALIBRATION-METHOD

Description
This element is used to indicate the different access methods implemented in the ECU, which can be used regardless of the actual ECU interface.
The <SHORT-NAME> labels the calibration method to be used. A convention regarding the meaning of the calibration methods must be agreed upon between the parties involved. The following strings are already in use: "InCircuit", "SERAM", "DSERAP", "BSERAP"
The actual parameters for the calibration method are specified in <SW-CALIBRATION-HANDLE> .
Example
See 2.307. SW-CALIBRATION-HANDLE
Formal Description
Within context of: | SW-CALIBRATION-METHODS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-CALIBRATION-METHOD-VERSIONS, ADD-INFO
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | String (CDATA) | SW-CALIBRATION-METHOD | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.309. SW-CALIBRATION-METHOD-SPEC

Description
This element describes the methods via which the various application systems can access the ECU. Several methods can be implemented simultaneously, which for their part can exist in several versions ( <SW-CALIBRATION-METHOD-VERSION> ).
Example
Formal Description
Within context of: | SW-SYSTEM
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-CALIBRATION-METHODS, ADD-INFO


2.310. SW-CALIBRATION-METHOD-VERSION

Description
This element describes a specific version of an application method. The version number is given in <LABEL> .
Example
Formal Description
Within context of: | SW-CALIBRATION-METHOD-VERSIONS
Is context for: | LABEL, SW-CALIBRATION-HANDLE


2.311. SW-CALIBRATION-METHOD-VERSIONS

Description
Container element for <SW-CALIBRATION-METHOD-VERSION> .
Example
Formal Description
Within context of: | SW-CALIBRATION-METHOD
Is context for: | SW-CALIBRATION-METHOD-VERSION


2.312. SW-CALIBRATION-METHODS

Description
Container element for <SW-CALIBRATION-METHOD> .
Example
Formal Description
Within context of: | SW-CALIBRATION-METHOD-SPEC
Is context for: | SW-CALIBRATION-METHOD


2.313. SW-CALPRM

Description
This element specifies the characteristics of calibration parameters in the ECU. Calibration parameters are objects that are not adapted to the run time of the vehicle. Instead, they calibrated to a greater extent in the application phase. Variables are quite the opposite ( <SW-VARIABLE> s), being objects that are manipulated during the run time of the software.
For the most part, calibration parameters consist of:
  • Long and short names ( <LONG-NAME>, <SHORT-NAME> )
  • Short description ( <DESC> )
  • Category ( <CATEGORY> ), describing the basic structure of the parameter
  • Field parameter ( <SW-ARRAYSIZE> ), in case the parameter an array
  • The technical characteristics ( <SW-DATA-DEF-PROPS>)
  • Sub-structures simulated through the integration of <SW-CALPRMS> .
  • Comments ( <ANNOTATIONS> ), enabling notes to be passed on from one stage to the next, throughout the development process.
  • Additional information ( <ADD-INFO>) in verbal form. Here, formal components can also be accommodated when [SI] -attributes are used.
Allocation of <CATEGORY>
Value | Meaning | Remark
VALUE | Characteristic value | This represents a single value.
CURVE_INDIVIDUAL | Characteristic | This represents a curve with an embedded axis.
MAP_INDIVIDUAL | Map | This represents a map with embedded axes.
CURVE_FIXED | Fixed characteristic | This indicates a curve where the axes are calculated by the ECU program. The algorithm is fixed and therefore the axis-points can not be calibrated. The parameters of the algorithm may in some cases be specified by applying <SW-AXIS-GENERIC> .
MAP_FIXED | Fixed map | This indicates a map where the axes are calculated by the ECU program. The algorithm is fixed and therefore the axis-points can not be calibrated. The parameters of the algorithm may in some cases be specified by applying <SW-AXIS-GENERIC> .
CURVE_GROUPED | Group characteristic | This indicates a curve which uses the axis-points of another calibration parameter which is then referred to by <SW-CALPRM-REF> in <SW-AXIS-GROUPED> .
MAP_GROUPED | Group map | This indicates a map which uses the axis-points of another calibration parameter which is then referred to by <SW-CALPRM-REF> in <SW-AXIS-GROUPED> .
ASCII | Characteristic text | This indicates a parameter in text form (e.g. a message).
STRUCTURE | Parameter structure | This indicates a structure of calibration parameters. In this case, an embedded <SW-CALPRM> should exist.
VALUE_BLOCK | Characteristic values block | This indicates a homogeneous parameter set which is handled as a block. Unlike structures or arrays, the components of a value block appear in the instance tree within one <SW-INSTANCE> .
AXIS_VALUES | Group datapoints | This indicates the axis points of a calibration parameter, which are referenced in <SW-AXIS-GROUP> by a calibration parameter of the category MAP_GROUPED or CURVE_GROUPED .
Example
The next example illustrates a single value.
 <sw-calprm id="ABGMSIGH"> <long-name>threshold for exh. temp. for wiring-interruption with Ri-diagnosis downstr. ca</long-name> <short-name>ABGMSIGH</short-name> <category>VALUE</category> <sw-data-def-props> <sw-compu-method-ref id-ref="TEMP-UB-Q5-O50">temp_ub_q5_o50</sw-compu-method-ref> <sw-data-constr-ref id-ref="DC-ABGMSIGH">DC-ABGMSIGH</sw-data-constr-ref> <sw-display-format>%5.0</sw-display-format> <sw-record-layout-ref id-ref="KWUB">KWUB</sw-record-layout-ref> </sw-data-def-props> </sw-calprm>
The next example illustrates a map.
 <SW-CALPRM ID="FKKVS">
                   <LONG-NAME>factor to correct fuel delivary system</LONG-NAME>
                   <SHORT-NAME>FKKVS</SHORT-NAME>
                   <DESC></DESC>
                   <CATEGORY>MAP</CATEGORY>
                   <SW-DATA-DEF-PROPS>
                      <SW-CALIBRATION-ACCESS>CALIBRATION</SW-CALIBRATION-ACCESS>
                      <SW-CALPRM-AXIS-SET>
                         <SW-CALPRM-AXIS>
                            <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
                            <SW-AXIS-INDIVIDUAL>
                               <SW-VARIABLE-REFS>
                                  <SW-VARIABLE-REF ID-REF="NMOT">NMOT</SW-VARIABLE-REF>
                               </SW-VARIABLE-REFS>
                               <SW-MAX-AXIS-POINTS>16</SW-MAX-AXIS-POINTS>
                            </SW-AXIS-INDIVIDUAL>
                         </SW-CALPRM-AXIS>
                         <SW-CALPRM-AXIS>
                            <SW-AXIS-INDEX>2</SW-AXIS-INDEX>
                            <SW-AXIS-INDIVIDUAL>
                               <SW-VARIABLE-REFS>
                                  <SW-VARIABLE-REF ID-REF="TEVFA-W-KGE">TEVFA-W-KGE</SW-VARIABLE-REF>
                               </SW-VARIABLE-REFS>
                               <SW-MAX-AXIS-POINTS>16</SW-MAX-AXIS-POINTS>
                            </SW-AXIS-INDIVIDUAL>
                         </SW-CALPRM-AXIS>
                      </SW-CALPRM-AXIS-SET>
                      <SW-COMPU-METHOD-REF ID-REF="FAK-UW-B2">FAK-UW-B2</SW-COMPU-METHOD-REF>
                      <SW-DATA-CONSTR-REF ID-REF="DC-FKKVS">DC-FKKVS</SW-DATA-CONSTR-REF>
                      <SW-DISPLAY-FORMAT>%8.6</SW-DISPLAY-FORMAT>
                      <SW-INTERPOLATION-METHOD>linear</SW-INTERPOLATION-METHOD>
                      <SW-RECORD-LAYOUT-REF ID-REF="SIMPLE-MAP">SIMPLE-MAP</SW-RECORD-LAYOUT-REF>
                   </SW-DATA-DEF-PROPS>
                </SW-CALPRM>
Formal Description
Within context of: | SW-CALPRMS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-ARRAYSIZE, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS, SW-CALPRMS, ANNOTATIONS, ADD-INFO
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-CALPRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] fixed value | SGML string (NMTOKEN) | SW-CALPRM | Fixed Namespace. This attribute is assigned to elements which define a namespace for linkable objects. The attribute contains a list of elements, where the element carrying the attribute serves as a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names including the namespaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')

Conforms to ASAP
These are identical to the technical characteristics of variables


2.314. SW-CALPRM-AXIS

Description
This element specifies an individual input parameter axis (abscissa). The following belongs to this:
  • Which axis is involved ( <SW-AXIS-INDEX> )
  • Whether the axis is integrated ( <SW-AXIS-INDIVIDUAL>) or whether it is adopted from another parameter ( <SW-AXIS-GROUPED> ).
  • Whether the axis can be applicated ( <SW-CALIBRATION-ACCESS> ).
  • Which display format should be used for the axis ( <SW-DISPLAY-FORMAT> ).
  • Which base type should be used for the axis ( <SW-BASE-TYPE-REF> ).
Example
Formal Description
Within context of: | SW-CALPRM-AXIS-SET
Is context for: | SW-AXIS-INDEX, SW-AXIS-INDIVIDUAL, SW-AXIS-GROUPED, SW-CALIBRATION-ACCESS, SW-DISPLAY-FORMAT, SW-BASE-TYPE-REF


2.315. SW-CALPRM-AXIS-SET

Description
This element specifies the input parameter axes (abscissas) of parameters (and variables, if these are used adaptively).
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | SW-CALPRM-AXIS


2.316. SW-CALPRM-IMPL

Description
This element describes the implementation details of a class attribute which manifests itself as a calibration parameter.
Example
See 2.331. SW-CLASS
Formal Description
Within context of: | SW-CALPRM-IMPLS
Is context for: | SW-CALPRM-PROTOTYPE-REF, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS


2.317. SW-CALPRM-IMPLS

Description
Container element for <SW-CALPRM-IMPL> .
Example
Formal Description
Within context of: | SW-CLASS-ATTR-IMPL, SW-CLASS-ATTR-INSTANCE-IMPL
Is context for: | SW-CALPRM-IMPL


2.318. SW-CALPRM-MAX-TEXT-SIZE

Description
Maximum length of a text parameter, the length is equivalent with the number of characters.
Example
See 2.327. SW-CALPRM-TEXT
Formal Description
Within context of: | SW-CALPRM-TEXT
Is context for: | Text, CONF-ITEM-CODED-REF, CONF-ITEM-PHYS-REF, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF


2.319. SW-CALPRM-NO-EFFECT-VALUE

Description
This element describes the value to which the parameter must be set, so that it remains without a consequence.
It is for example used if new parameters are introduced to the ECU that cannot yet be applicated. Settings to the <SW-CALPRM-NO-EFFECT-VALUE> ensures software compatibility to an earlier version.
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | Text


2.320. SW-CALPRM-PROTOTYPE

Description
This element describes the prototype declaration of a class attribute, which is used as a calibration parameter.
Example
See 2.331. SW-CLASS
Formal Description
Within context of: | SW-CALPRM-PROTOTYPES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-ARRAYSIZE, SW-SYSCOND, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS, ANNOTATIONS, ADD-INFO
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | String (CDATA) | SW-CALPRM-PROTOTYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.321. SW-CALPRM-PROTOTYPE-REF

Description
Through this element, a <SW-CALPRM-PROTOTYPE> is referenced.
Example
Formal Description
Within context of: | SW-CALPRM-IMPL
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-CALPRM-PROTOTYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.322. SW-CALPRM-PROTOTYPES

Description
Container element for <SW-CALPRM-PROTOTYPE> .
Example
Formal Description
Within context of: | SW-CLASS-ATTR
Is context for: | SW-CALPRM-PROTOTYPE


2.323. SW-CALPRM-REF

Description
Through this element, a <SW-CALPRM> is referenced.
Example
Formal Description
Within context of: | SW-ACCESSED-CALPRMS, SW-AXIS-GROUPED, SW-CALPRM-REF-SYSCOND, SW-CALPRM-REFS, SW-CONSTR-OBJECTS, SW-DATA-DEPENDENCY-ARGS, SW-FEATURE-EXPORT-CALPRMS, SW-FEATURE-IMPORT-CALPRMS, SW-FEATURE-LOCAL-PARAMS, SW-VCD-CRITERION
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-CALPRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.324. SW-CALPRM-REF-SYSCOND

Description
This element is a conditional reference to a calibration parameter. It is used to ensure that the assignment of calibration parameters to functions is dependent on the settings of system constants. For this reason, the element exists in parallel to <SW-CALPRM-REF> .
Example
Formal Description
Within context of: | SW-ACCESSED-CALPRMS, SW-CALPRM-REFS, SW-FEATURE-EXPORT-CALPRMS, SW-FEATURE-IMPORT-CALPRMS, SW-FEATURE-LOCAL-PARAMS
Is context for: | SW-CALPRM-REF, SW-SYSCOND


2.325. SW-CALPRM-REFS

Description
Container element for <SW-CALPRM-REF> .
Example
Formal Description
Within context of: | SW-COLLECTION-CONT, SW-FEATURE-ELEMENTS
Is context for: | SW-CALPRM-REF, SW-CALPRM-REF-SYSCOND


2.326. SW-CALPRM-TARGET

Description
In some systems, the result of a base point search (group axis) or an interpolation, is temporarily stored using a parameter, in the form of variables. For this purpose, the <SW-CALPRM-TARGET> contains a reference to a variable performing the role of intermediate storage.
The element establishes a 1:1 relationship between the variable referenced and the superordinated <SW-DATA-DEF-PROPS>, or its father element. In this respect, it would be superfluous as this could be addressed directly. However SW-CALPRM-TARGET serves to explicitly express the semantics of the reference.
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | SW-VARIABLE-REF


2.327. SW-CALPRM-TEXT

Description
SW-CALPRM-TEXT specifies textual parameters in the ECU. For this purpose, the following must be defined:
  • The maximum length of the text
  • The filler character for texts which are shorter than the maximum permitted text length.
  • The base type for every character in the text string <SW-BASE-TYPE-REF> , is used to describe the string coding.
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | SW-CALPRM-MAX-TEXT-SIZE, SW-BASE-TYPE-REF, SW-FILL-CHARACTER


2.328. SW-CALPRM-VALUE-AXIS-LABELS

Description
This element is used to record textual descriptions of axis values and is contained in ASAP1.4, for reasons of backward compatibility.
In new systems, the application should be implemented via conversion formulae.
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | LABEL


2.329. SW-CALPRMS

Description
Container element for <SW-CALPRM> .
Example
Formal Description
Within context of: | SW-CALPRM, SW-DATA-DICTIONARY-SPEC
Is context for: | ADMIN-DATA, SW-CALPRM


2.330. SW-CARB-DOC

Description
This element records the documentation, specifically requested by CARB .
Example
Formal Description
Within context of: | SW-CLASS, SW-FEATURE
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.331. SW-CLASS

Description
A <SW-CLASS> enables the object-oriented programming model. A class may provide multiple implementations. In MSRSW.DTD, this primarily covers the implementation of variables and parameters originating in the instantiation of this class. Therefore, a <SW-CLASS> can optionally contain 1 to n <SW-CLASS-ATTR-IMPLS>, with each representing a particular class implementation. A <SW-CLASS> contains 0 to n <SW-CLASS-ATTR>s attributes. This is merely the list of variables, parameters and objects to be established by the instantiation of the class. This is one of the reasons why a <SW-INSTANCE-TREE> is necessary. A <SW-CLASS> contains 0 to n <SW-CLASS-METHOD> s, each of which representing a particular class method. The methods are described informally. This branch is connected to future extensions.
Classes are instantiated within the data dictionaries, either globally or within a feature. Therefore a <SW-CLASS-INSTANCE> in a Data Dictionary contains a reference to a . This represents a particular instance of a . The contents of this element replace the contents of the referenced <SW-CLASS> , thus defining the particular implementation.
Example
The following example illustrates a small system comprising of one class with three instances utilizing different implementations. The class has a component which a class in itself and as such, is an example of an embedded class. The example is complete in the sense that all referenced objects are present.
<MSRSW PUBID      ="-//MSR//DTD MSR SOFTWARE DTD:V2.2.2:MSRSW.DTD//EN"
                       F-PUBID    ="-//MSR//DTD MSR SOFTWARE DTD:V2.2.2:MSRSW.DTD//EN"
                       F-NAMESPACE="CHAPTER COMPANY DEF-ITEM EXTERNAL FIGURE FORMULA PRM REQUIREMENT SAMPLE
                                    STD SW-ADDR-METHOD SW-AXIS-TYPE SW-BASE-TYPE SW-CALPRM SW-CALPRM-PROTOTYPE
                                    SW-CLASS-PROTOTYPE SW-CLASS-ATTR-IMPL SW-CLASS-INSTANCE SW-CLASS SW-CODE-SYNTAX
                                    SW-COLLECTION SW-COMPU-METHOD SW-CPU-MEM-SEG SW-DATA-CONSTR SW-FEATURE
                                    SW-GENERIC-AXIS-PARAM-TYPE SW-INSTANCE-TREE SW-INSTANCE SW-MC-BASE-TYPE
                                    SW-MC-INTERFACE-SOURCE SW-MC-INTERFACE SW-RECORD-LAYOUT SW-SYSTEMCONST SW-SYSTEM
                                    SW-TASK SW-TEMPLATE SW-UNIT SW-USER-ACCESS-CASE SW-USER-GROUP SW-VARIABLE-PROTOTYPE
                                    SW-VARIABLE SW-VCD-CRITERION TABLE TEAM-MEMBER TOPIC VARIANT-DEF VARIANT-CHAR XDOC XFILE"
                       HYTIME     ="HYDOC">

                   <SW-SYSTEMS>
                      <SW-SYSTEM ID         ="ID49163FEDRADCE418"
                                 F-ID-CLASS ="SW-SYSTEM"
                                 F-NAMESPACE="SW-ADDR-METHOD SW-AXIS-TYPE SW-BASE-TYPE SW-CALPRM SW-CALPRM-PROTOTYPE
                                              SW-CLASS-PROTOTYPE SW-CLASS-ATTR-IMPL SW-CLASS-INSTANCE SW-CLASS SW-CODE-SYNTAX
                                              SW-COLLECTION SW-COMPU-METHOD SW-CPU-MEM-SEG SW-DATA-CONSTR SW-FEATURE
                                              SW-GENERIC-AXIS-PARAM-TYPE SW-INSTANCE-TREE SW-INSTANCE SW-RECORD-LAYOUT
                                              SW-SYSTEMCONST SW-TASK SW-TEMPLATE SW-UNIT SW-USER-ACCESS-CASE SW-USER-GROUP
                                              SW-VARIABLE-PROTOTYPE SW-VARIABLE SW-VCD-CRITERION">
                         <LONG-NAME>
                            <L-4 L="">Demonstrator für Klassen</L-4>
                         </LONG-NAME>
                         <SHORT-NAME>ClassDemo</SHORT-NAME>
                         <SW-DATA-DICTIONARY-SPEC></SW-DATA-DICTIONARY-SPEC>
                      </SW-SYSTEM>
                   </SW-SYSTEMS>
                </MSRSW>
Here we define the required measurement units:
 <SW-UNITS>
                   <SW-UNIT ID        ="ID4F1ADF2DRAD46366"
                            F-ID-CLASS="SW-UNIT">
                      <SHORT-NAME>rpm</SHORT-NAME>
                      <SI-UNIT><?xm-replace_text {SI-UNIT}></SI-UNIT>
                   </SW-UNIT>

                   <SW-UNIT ID        ="ID4F1ADF2DRADC299F"
                            F-ID-CLASS="SW-UNIT">
                      <SHORT-NAME>gradkw</SHORT-NAME>
                      <SI-UNIT><?xm-replace_text {SI-UNIT}></SI-UNIT>
                   </SW-UNIT>

                   <SW-UNIT ID        ="ID4F1AE136RAD07900"
                            F-ID-CLASS="SW-UNIT">
                      <SHORT-NAME>ms</SHORT-NAME>
                      <SW-UNIT-CONVERSION-METHOD>
                         <SW-UNIT-GRADIENT>1000</SW-UNIT-GRADIENT>
                         <SW-UNIT-OFFSET>0</SW-UNIT-OFFSET>
                      </SW-UNIT-CONVERSION-METHOD>
                      <SI-UNIT TIME-EXPO="1"><?xm-replace_text {SI-UNIT}></SI-UNIT>
                   </SW-UNIT>
                </SW-UNITS>
Here we have global class instances. Note that the class itself is specified later.
 <SW-CLASS-INSTANCES>
                   <SW-CLASS-INSTANCE ID        ="ID49163FECRADA984D"
                                      F-ID-CLASS="SW-CLASS-INSTANCE">
                      <SHORT-NAME>no-fun</SHORT-NAME>
                      <DESC>Das ist die Instantiierung eines globalen objektes der Klasse nonsense. Es wird die Highend-Implementierung verwendet.</DESC>
                      <SW-CLASS-REF ID-REF="NONSENSE">nonsense</SW-CLASS-REF>
                      <SW-CLASS-ATTR-IMPL-REF ID-REF    ="ID49163FECRAD4BFD7"
                                              HYTIME    ="CLINK"
                                              HYNAMES   ="LINKEND ID-REF"
                                              F-ID-CLASS="SW-CLASS-ATTR-IMPL">highend</SW-CLASS-ATTR-IMPL-REF>
                   </SW-CLASS-INSTANCE>

                   <SW-CLASS-INSTANCE ID        ="ID49163FECRAD51C6A"
                                      F-ID-CLASS="SW-CLASS-INSTANCE">
                      <SHORT-NAME>no-sports </SHORT-NAME>
                      <DESC>Das ist eine weitere Instantiierung eines globalen objektes der Klasse nonsense. Es wird die Lowend-Implementierung verwendet.</DESC>
                      <SW-CLASS-REF ID-REF="NONSENSE">nonsense</SW-CLASS-REF>
                      <SW-CLASS-ATTR-IMPL-REF ID-REF    ="ID49163FECRAD4BFD7-1"
                                              HYTIME    ="CLINK"
                                              HYNAMES   ="LINKEND ID-REF"
                                              F-ID-CLASS="SW-CLASS-ATTR-IMPL">lowend</SW-CLASS-ATTR-IMPL-REF>
                   </SW-CLASS-INSTANCE>

                   <SW-CLASS-INSTANCE ID        ="ID49163FECRAD353DD"
                                      F-ID-CLASS="SW-CLASS-INSTANCE">
                      <SHORT-NAME>no-life </SHORT-NAME>
                      <DESC>Das ist eine weitere Instantiierung eines globalen objektes der Klasse nonsense. Es wird die Highend-Implementierung verwendet.</DESC>
                      <SW-CLASS-REF ID-REF    ="NONSENSE"
                                    HYTIME    ="CLINK"
                                    HYNAMES   ="LINKEND ID-REF"
                                    F-ID-CLASS="SW-CLASS">nonsense</SW-CLASS-REF>
                      <SW-CLASS-ATTR-IMPL-REF ID-REF    ="ID49163FECRAD4BFD7"
                                              HYTIME    ="CLINK"
                                              HYNAMES   ="LINKEND ID-REF"
                                              F-ID-CLASS="SW-CLASS-ATTR-IMPL">highend</SW-CLASS-ATTR-IMPL-REF>
                   </SW-CLASS-INSTANCE>
                </SW-CLASS-INSTANCES>
Here we specify the required code syntaxes.
 <SW-CODE-SYNTAXES>
                   <SW-CODE-SYNTAX ID        ="ID4F1ADF2DRADE6B70"
                                   F-ID-CLASS="SW-CODE-SYNTAX">
                      <SHORT-NAME>kf-8</SHORT-NAME>
                   </SW-CODE-SYNTAX>

                   <SW-CODE-SYNTAX ID        ="ID4F1ADF2DRAD41815"
                                   F-ID-CLASS="SW-CODE-SYNTAX">
                      <SHORT-NAME>kf-32</SHORT-NAME>
                   </SW-CODE-SYNTAX>

                   <SW-CODE-SYNTAX ID        ="ID4F1ADF2DRADA3D4F"
                                   F-ID-CLASS="SW-CODE-SYNTAX">
                      <SHORT-NAME>kl-8</SHORT-NAME>
                   </SW-CODE-SYNTAX>

                   <SW-CODE-SYNTAX ID        ="ID4F1ADF2DRADA8D81"
                                   F-ID-CLASS="SW-CODE-SYNTAX">
                      <SHORT-NAME>kl-32</SHORT-NAME>
                   </SW-CODE-SYNTAX>
                </SW-CODE-SYNTAXES>
Here we define the required base types.
 <SW-BASE-TYPES>
                   <SW-BASE-TYPE ID        ="ID4F1ADF2DRAD66771"
                                 F-ID-CLASS="SW-BASE-TYPE">
                      <SHORT-NAME>byte</SHORT-NAME>
                      <SW-BASE-TYPE-SIZE>8</SW-BASE-TYPE-SIZE>
                      <SW-CODED-TYPE>integer</SW-CODED-TYPE>
                   </SW-BASE-TYPE>

                   <SW-BASE-TYPE ID        ="ID4F1ADF2DRAD2A264"
                                 F-ID-CLASS="SW-BASE-TYPE">
                      <SHORT-NAME>long</SHORT-NAME>
                      <SW-BASE-TYPE-SIZE>32</SW-BASE-TYPE-SIZE>
                      <SW-CODED-TYPE>integer</SW-CODED-TYPE>
                   </SW-BASE-TYPE>
                </SW-BASE-TYPES>
Since classes are handled as software components, they are defined within <SW-COMPONENT-SPEC> . Here we define a class "nonsense" and the subclass which is instantiated as part of "nonsense".
 <SW-COMPONENT-SPEC>
                   <SW-COMPONENTS>
                      <SW-CLASS ID         ="NONSENSE"
                                F-ID-CLASS ="SW-CLASS"
                                F-NAMESPACE="SW-CALPRM-PROTOTYPE SW-CLASS-PROTOTYPE SW-VARIABLE-PROTOTYPE">
                         <SHORT-NAME>nonsense </SHORT-NAME>
                         <SW-FEATURE-DESC>
                            <P>Diese Klasse dient nur zur Demonstration der Mglichkeiten in MSRSW.</P>
                            <LIST TYPE="UNNUMBER">
                               <ITEM>
                                  <P>Klassenbeschreibung</P>
                               </ITEM>
                               <ITEM>
                                  <P>Klassenattribute</P>
                               </ITEM>
                               <ITEM>
                                  <P>Methoden</P>
                               </ITEM>
                            </LIST>
                         </SW-FEATURE-DESC>
                         <SW-CLASS-ATTR></SW-CLASS-ATTR>
                      </SW-CLASS>
                   </SW-COMPONENTS>
                </SW-COMPONENT-SPEC>
The class attributes are initially specified as prototypes. Subsequently the implementations available in the ECU are specified in <SW-CLASS-ATTR-IMPLS>. The attributes may manifest themselves as variables ( <SW-VARIABLE-PROTOTYPE>s, calibration parameters ( <SW-CALPRM-PROTOTYPE>s) or class instances ( <SW-CLASS-PROTOTYPE> s).
 <SW-VARIABLE-PROTOTYPES>
                   <SW-VARIABLE-PROTOTYPE ID        ="ID49163FEDRAD112E9"
                                          F-ID-CLASS="SW-VARIABLE-PROTOTYPE">
                      <SHORT-NAME>N</SHORT-NAME>
                      <DESC>Das ist ein Prototyp für ein Attribut der Klasse, welche sich als Variable instantiiert.</DESC>
                   </SW-VARIABLE-PROTOTYPE>

                   <SW-VARIABLE-PROTOTYPE ID        ="ID49163FEDRAD77C19"
                                          F-ID-CLASS="SW-VARIABLE-PROTOTYPE">
                      <SHORT-NAME>TL </SHORT-NAME>
                      <DESC>Das ist ein Prototyp für ein Attribut der Klasse, welche sich als Variable instantiiert.</DESC>
                   </SW-VARIABLE-PROTOTYPE>

                   <SW-VARIABLE-PROTOTYPE ID        ="ID49163FEDRAD65A29"
                                          F-ID-CLASS="SW-VARIABLE-PROTOTYPE">
                      <SHORT-NAME>TMOT </SHORT-NAME>
                      <DESC>Das ist ein Prototyp für ein Attribut der Klasse, welche sich als Variable instantiiert.</DESC>
                   </SW-VARIABLE-PROTOTYPE>
                </SW-VARIABLE-PROTOTYPES>
These are calibration parameter prototypes:
 <SW-CALPRM-PROTOTYPES>
                   <SW-CALPRM-PROTOTYPE ID        ="ID49163FECRAD0EE17"
                                        F-ID-CLASS="SW-CALPRM-PROTOTYPE">
                      <SHORT-NAME>WLN </SHORT-NAME>
                      <DESC>Das ist ein Prototyp für ein Attribut der Klasse, welche sich als Parameter instantiiert.</DESC>
                   </SW-CALPRM-PROTOTYPE>

                   <SW-CALPRM-PROTOTYPE ID        ="ID49163FECRADB7A5D"
                                        F-ID-CLASS="SW-CALPRM-PROTOTYPE">
                      <SHORT-NAME>WTL </SHORT-NAME>
                      <DESC>Das ist ein Prototyp für ein Attribut der Klasse, welche sich als Parameter instantiiert.</DESC>
                   </SW-CALPRM-PROTOTYPE>

                   <SW-CALPRM-PROTOTYPE ID        ="ID49163FECRADD360C"
                                        F-ID-CLASS="SW-CALPRM-PROTOTYPE">
                      <SHORT-NAME>WTMOT </SHORT-NAME>
                      <DESC>Das ist ein Prototyp für ein Attribut der Klasse, welche sich als Parameter instantiiert.</DESC>
                   </SW-CALPRM-PROTOTYPE>

                   <SW-CALPRM-PROTOTYPE ID        ="ID49163FECRADF9F29"
                                        F-ID-CLASS="SW-CALPRM-PROTOTYPE">
                      <SHORT-NAME>KFNTL </SHORT-NAME>
                   </SW-CALPRM-PROTOTYPE>
                </SW-CALPRM-PROTOTYPES>
These are class instance prototypes:
 <SW-CLASS-PROTOTYPES>
                   <SW-CLASS-PROTOTYPE ID        ="ID49163FECRADE0ACB"
                                       F-ID-CLASS="SW-CLASS-PROTOTYPE">
                      <SHORT-NAME>substuff </SHORT-NAME>
                      <SW-CLASS-REF ID-REF    ="ID49163FECRAD19FEB"
                                    HYTIME    ="CLINK"
                                    HYNAMES   ="LINKEND ID-REF"
                                    F-ID-CLASS="SW-CLASS">Subclass</SW-CLASS-REF>
                      <DESC>Das ist ein Prototyp für ein Attribut der Klasse, welche sich als instanz der Klasse
                      Subclass instantiiert. Durch diese Instantiierung wird es seine Attribute einbringen.</DESC>
                   </SW-CLASS-PROTOTYPE>
                </SW-CLASS-PROTOTYPES>
Here, the particular implementations of the various prototypes are specified:
 <SW-CLASS-ATTR-IMPLS>
                   <SW-CLASS-ATTR-IMPL ID        ="ID49163FECRAD4BFD7-1"
                                       F-ID-CLASS="SW-CLASS-ATTR-IMPL">
                      <LONG-NAME>Lowend-Implementierung, z.B. als 8 bit</LONG-NAME>
                      <SHORT-NAME>highend </SHORT-NAME>
                      <SW-VARIABLE-IMPLS>
                         <SW-VARIABLE-IMPL>
                            <SW-VARIABLE-PROTOTYPE-REF ID-REF    ="ID49163FEDRAD112E9"
                                                       HYTIME    ="CLINK"
                                                       HYNAMES   ="LINKEND ID-REF"
                                                       F-ID-CLASS="SW-VARIABLE-PROTOTYPE">N</SW-VARIABLE-PROTOTYPE-REF>
                            <SW-DATA-DEF-PROPS>
                               <SW-BASE-TYPE-REF ID-REF    ="ID4F1ADF2DRAD66771"
                                                 HYTIME    ="CLINK"
                                                 HYNAMES   ="LINKEND ID-REF"
                                                 F-ID-CLASS="SW-BASE-TYPE">byte</SW-BASE-TYPE-REF>
                            </SW-DATA-DEF-PROPS>
                         </SW-VARIABLE-IMPL>
                         <SW-VARIABLE-IMPL>
                            <SW-VARIABLE-PROTOTYPE-REF ID-REF    ="ID49163FEDRAD77C19"
                                                       HYTIME    ="CLINK"
                                                       HYNAMES   ="LINKEND ID-REF"
                                                       F-ID-CLASS="SW-VARIABLE-PROTOTYPE">TL</SW-VARIABLE-PROTOTYPE-REF>
                            <SW-DATA-DEF-PROPS>
                               <SW-BASE-TYPE-REF ID-REF    ="ID4F1ADF2DRAD66771"
                                                 HYTIME    ="CLINK"
                                                 HYNAMES   ="LINKEND ID-REF"
                                                 F-ID-CLASS="SW-BASE-TYPE">byte</SW-BASE-TYPE-REF>
                            </SW-DATA-DEF-PROPS>
                         </SW-VARIABLE-IMPL>
                         <SW-VARIABLE-IMPL>
                            <SW-VARIABLE-PROTOTYPE-REF ID-REF    ="ID49163FEDRAD65A29"
                                                       HYTIME    ="CLINK"
                                                       HYNAMES   ="LINKEND ID-REF"
                                                       F-ID-CLASS="SW-VARIABLE-PROTOTYPE">TMOT</SW-VARIABLE-PROTOTYPE-REF>
                            <SW-DATA-DEF-PROPS>
                               <SW-BASE-TYPE-REF ID-REF    ="ID4F1ADF2DRAD66771"
                                                 HYTIME    ="CLINK"
                                                 HYNAMES   ="LINKEND ID-REF"
                                                 F-ID-CLASS="SW-BASE-TYPE">byte</SW-BASE-TYPE-REF>
                            </SW-DATA-DEF-PROPS>
                         </SW-VARIABLE-IMPL>
                      </SW-VARIABLE-IMPLS>
                      <SW-CALPRM-IMPLS>
                         <SW-CALPRM-IMPL>
                            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRAD0EE17"
                                                     HYTIME    ="CLINK"
                                                     HYNAMES   ="LINKEND ID-REF"
                                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">WLN</SW-CALPRM-PROTOTYPE-REF>
                            <SW-DATA-DEF-PROPS>
                               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRADA3D4F"
                                                   HYTIME    ="CLINK"
                                                   HYNAMES   ="LINKEND ID-REF"
                                                   F-ID-CLASS="SW-CODE-SYNTAX">kl-8</SW-CODE-SYNTAX-REF>
                            </SW-DATA-DEF-PROPS>
                         </SW-CALPRM-IMPL>
                         <SW-CALPRM-IMPL>
                            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRADB7A5D"
                                                     HYTIME    ="CLINK"
                                                     HYNAMES   ="LINKEND ID-REF"
                                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">WTL</SW-CALPRM-PROTOTYPE-REF>
                            <SW-DATA-DEF-PROPS>
                               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRADA3D4F"
                                                   HYTIME    ="CLINK"
                                                   HYNAMES   ="LINKEND ID-REF"
                                                   F-ID-CLASS="SW-CODE-SYNTAX">kl-8</SW-CODE-SYNTAX-REF>
                            </SW-DATA-DEF-PROPS>
                         </SW-CALPRM-IMPL>
                         <SW-CALPRM-IMPL>
                            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRADD360C"
                                                     HYTIME    ="CLINK"
                                                     HYNAMES   ="LINKEND ID-REF"
                                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">WTMOT</SW-CALPRM-PROTOTYPE-REF>
                            <SW-DATA-DEF-PROPS>
                               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRADA3D4F"
                                                   HYTIME    ="CLINK"
                                                   HYNAMES   ="LINKEND ID-REF"
                                                   F-ID-CLASS="SW-CODE-SYNTAX">kl-8</SW-CODE-SYNTAX-REF>
                            </SW-DATA-DEF-PROPS>
                         </SW-CALPRM-IMPL>
                         <SW-CALPRM-IMPL>
                            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRADF9F29"
                                                     HYTIME    ="CLINK"
                                                     HYNAMES   ="LINKEND ID-REF"
                                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">KFNTL</SW-CALPRM-PROTOTYPE-REF>
                            <SW-DATA-DEF-PROPS>
                               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRADE6B70"
                                                   HYTIME    ="CLINK"
                                                   HYNAMES   ="LINKEND ID-REF"
                                                   F-ID-CLASS="SW-CODE-SYNTAX">kf-8</SW-CODE-SYNTAX-REF>
                            </SW-DATA-DEF-PROPS>
                         </SW-CALPRM-IMPL>
                      </SW-CALPRM-IMPLS>
                      <SW-CLASS-IMPLS>
                         <SW-CLASS-IMPL>
                            <SW-CLASS-PROTOTYPE-REF ID-REF    ="ID49163FECRADE0ACB"
                                                    HYTIME    ="CLINK"
                                                    HYNAMES   ="LINKEND ID-REF"
                                                    F-ID-CLASS="SW-CLASS-PROTOTYPE">substuff</SW-CLASS-PROTOTYPE-REF>
                            <SW-CLASS-ATTR-IMPL-REF ID-REF    ="ID7E9146ARADC551A"
                                                    HYTIME    ="CLINK"
                                                    HYNAMES   ="LINKEND ID-REF"
                                                    F-ID-CLASS="SW-CLASS-ATTR-IMPL">32bit</SW-CLASS-ATTR-IMPL-REF>
                         </SW-CLASS-IMPL>
                      </SW-CLASS-IMPLS>
                   </SW-CLASS-ATTR-IMPL>

                   <SW-CLASS-ATTR-IMPL ID        ="ID49163FECRAD4BFD7"
                                       F-ID-CLASS="SW-CLASS-ATTR-IMPL">
                      <LONG-NAME>Highend-Implementierung, z.B. als 32 bit</LONG-NAME>
                      <SHORT-NAME>highend </SHORT-NAME>
                      <SW-VARIABLE-IMPLS>
                         <SW-VARIABLE-IMPL>
                            <SW-VARIABLE-PROTOTYPE-REF ID-REF    ="ID49163FEDRAD112E9"
                                                       HYTIME    ="CLINK"
                                                       HYNAMES   ="LINKEND ID-REF"
                                                       F-ID-CLASS="SW-VARIABLE-PROTOTYPE">N</SW-VARIABLE-PROTOTYPE-REF>
                            <SW-DATA-DEF-PROPS>
                               <SW-BASE-TYPE-REF ID-REF    ="ID4F1ADF2DRAD2A264"
                                                 HYTIME    ="CLINK"
                                                 HYNAMES   ="LINKEND ID-REF"
                                                 F-ID-CLASS="SW-BASE-TYPE">long</SW-BASE-TYPE-REF>
                            </SW-DATA-DEF-PROPS>
                         </SW-VARIABLE-IMPL>
                         <SW-VARIABLE-IMPL>
                            <SW-VARIABLE-PROTOTYPE-REF ID-REF    ="ID49163FEDRAD77C19"
                                                       HYTIME    ="CLINK"
                                                       HYNAMES   ="LINKEND ID-REF"
                                                       F-ID-CLASS="SW-VARIABLE-PROTOTYPE">TL</SW-VARIABLE-PROTOTYPE-REF>
                            <SW-DATA-DEF-PROPS>
                               <SW-BASE-TYPE-REF ID-REF    ="ID4F1ADF2DRAD2A264"
                                                 HYTIME    ="CLINK"
                                                 HYNAMES   ="LINKEND ID-REF"
                                                 F-ID-CLASS="SW-BASE-TYPE">long</SW-BASE-TYPE-REF>
                            </SW-DATA-DEF-PROPS>
                         </SW-VARIABLE-IMPL>
                         <SW-VARIABLE-IMPL>
                            <SW-VARIABLE-PROTOTYPE-REF ID-REF    ="ID49163FEDRAD65A29"
                                                       HYTIME    ="CLINK"
                                                       HYNAMES   ="LINKEND ID-REF"
                                                       F-ID-CLASS="SW-VARIABLE-PROTOTYPE">TMOT</SW-VARIABLE-PROTOTYPE-REF>
                            <SW-DATA-DEF-PROPS>
                               <SW-BASE-TYPE-REF ID-REF    ="ID4F1ADF2DRAD2A264"
                                                 HYTIME    ="CLINK"
                                                 HYNAMES   ="LINKEND ID-REF"
                                                 F-ID-CLASS="SW-BASE-TYPE">long</SW-BASE-TYPE-REF>
                            </SW-DATA-DEF-PROPS>
                         </SW-VARIABLE-IMPL>
                      </SW-VARIABLE-IMPLS>
                      <SW-CALPRM-IMPLS>
                         <SW-CALPRM-IMPL>
                            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRAD0EE17"
                                                     HYTIME    ="CLINK"
                                                     HYNAMES   ="LINKEND ID-REF"
                                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">WLN</SW-CALPRM-PROTOTYPE-REF>
                            <SW-DATA-DEF-PROPS>
                               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRADA8D81"
                                                   HYTIME    ="CLINK"
                                                   HYNAMES   ="LINKEND ID-REF"
                                                   F-ID-CLASS="SW-CODE-SYNTAX">kl-32</SW-CODE-SYNTAX-REF>
                            </SW-DATA-DEF-PROPS>
                         </SW-CALPRM-IMPL>
                         <SW-CALPRM-IMPL>
                            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRADB7A5D"
                                                     HYTIME    ="CLINK"
                                                     HYNAMES   ="LINKEND ID-REF"
                                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">WTL</SW-CALPRM-PROTOTYPE-REF>
                            <SW-DATA-DEF-PROPS>
                               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRADA8D81"
                                                   HYTIME    ="CLINK"
                                                   HYNAMES   ="LINKEND ID-REF"
                                                   F-ID-CLASS="SW-CODE-SYNTAX">kl-32</SW-CODE-SYNTAX-REF>
                            </SW-DATA-DEF-PROPS>
                         </SW-CALPRM-IMPL>
                         <SW-CALPRM-IMPL>
                            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRADD360C"
                                                     HYTIME    ="CLINK"
                                                     HYNAMES   ="LINKEND ID-REF"
                                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">WTMOT</SW-CALPRM-PROTOTYPE-REF>
                            <SW-DATA-DEF-PROPS>
                               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRADA8D81"
                                                   HYTIME    ="CLINK"
                                                   HYNAMES   ="LINKEND ID-REF"
                                                   F-ID-CLASS="SW-CODE-SYNTAX">kl-32</SW-CODE-SYNTAX-REF>
                            </SW-DATA-DEF-PROPS>
                         </SW-CALPRM-IMPL>
                         <SW-CALPRM-IMPL>
                            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRADF9F29"
                                                     HYTIME    ="CLINK"
                                                     HYNAMES   ="LINKEND ID-REF"
                                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">KFNTL</SW-CALPRM-PROTOTYPE-REF>
                            <SW-DATA-DEF-PROPS>
                               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRAD41815"
                                                   HYTIME    ="CLINK"
                                                   HYNAMES   ="LINKEND ID-REF"
                                                   F-ID-CLASS="SW-CODE-SYNTAX">kf-32</SW-CODE-SYNTAX-REF>
                            </SW-DATA-DEF-PROPS>
                         </SW-CALPRM-IMPL>
                      </SW-CALPRM-IMPLS>
                      <SW-CLASS-IMPLS>
                         <SW-CLASS-IMPL>
                            <SW-CLASS-PROTOTYPE-REF ID-REF    ="ID49163FECRADE0ACB"
                                                    HYTIME    ="CLINK"
                                                    HYNAMES   ="LINKEND ID-REF"
                                                    F-ID-CLASS="SW-CLASS-PROTOTYPE">substuff</SW-CLASS-PROTOTYPE-REF>
                            <SW-CLASS-ATTR-IMPL-REF ID-REF    ="ID7E9146ARADC551A"
                                                    HYTIME    ="CLINK"
                                                    HYNAMES   ="LINKEND ID-REF"
                                                    F-ID-CLASS="SW-CLASS-ATTR-IMPL">32bit</SW-CLASS-ATTR-IMPL-REF>
                         </SW-CLASS-IMPL>
                      </SW-CLASS-IMPLS>
                   </SW-CLASS-ATTR-IMPL>
                </SW-CLASS-ATTR-IMPLS>
Here, the subclass called "Subclass" of "nonsense" is specified:
 <SW-CLASS ID         ="ID49163FECRAD19FEB"
                          F-ID-CLASS ="SW-CLASS"
                          F-NAMESPACE="SW-CALPRM-PROTOTYPE SW-CLASS-PROTOTYPE SW-VARIABLE-PROTOTYPE">
                   <SHORT-NAME>Subclass</SHORT-NAME>
                   <SW-CLASS-ATTR>

                      <SW-VARIABLE-PROTOTYPES>
                         <SW-VARIABLE-PROTOTYPE ID        ="ID49163FEDRADC1F7C"
                                                F-ID-CLASS="SW-VARIABLE-PROTOTYPE">
                            <SHORT-NAME>subvar </SHORT-NAME>
                         </SW-VARIABLE-PROTOTYPE>
                      </SW-VARIABLE-PROTOTYPES>

                      <SW-CALPRM-PROTOTYPES>
                         <SW-CALPRM-PROTOTYPE ID        ="ID49163FECRAD8F757"
                                              F-ID-CLASS="SW-CALPRM-PROTOTYPE">
                            <SHORT-NAME>subparam </SHORT-NAME>
                         </SW-CALPRM-PROTOTYPE>
                      </SW-CALPRM-PROTOTYPES>
                   </SW-CLASS-ATTR>

                   <SW-CLASS-ATTR-IMPLS>
                      <SW-CLASS-ATTR-IMPL ID        ="ID7E9146ARADC551A"
                                          F-ID-CLASS="SW-CLASS-ATTR-IMPL">
                         <LONG-NAME>Highend-Implementierung</LONG-NAME>
                         <SHORT-NAME>highend</SHORT-NAME>
                         <SW-VARIABLE-IMPLS>
                            <SW-VARIABLE-IMPL>
                               <SW-VARIABLE-PROTOTYPE-REF ID-REF    ="ID49163FEDRADC1F7C"
                                                          HYTIME    ="CLINK"
                                                          HYNAMES   ="LINKEND ID-REF"
                                                          F-ID-CLASS="SW-VARIABLE-PROTOTYPE">ID49163FEDRADC1F7C</SW-VARIABLE-PROTOTYPE-REF>
                            </SW-VARIABLE-IMPL>
                         </SW-VARIABLE-IMPLS>
                         <SW-CALPRM-IMPLS>
                            <SW-CALPRM-IMPL>
                               <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRAD8F757"
                                                        HYTIME    ="CLINK"
                                                        HYNAMES   ="LINKEND ID-REF"
                                                        F-ID-CLASS="SW-CALPRM-PROTOTYPE">ID49163FECRAD8F757</SW-CALPRM-PROTOTYPE-REF>
                            </SW-CALPRM-IMPL>
                         </SW-CALPRM-IMPLS>
                      </SW-CLASS-ATTR-IMPL>
                   </SW-CLASS-ATTR-IMPLS>
                </SW-CLASS>
Here, the resulting instance tree of the class "nonsense" is given.
 <MSRSW>
                   <SW-SYSTEMS>
                      <SW-SYSTEM>
                         <SW-INSTANCE-SPEC>
                            <SW-INSTANCE-TREE ID         ="ID49163FEDRADEB5E8"
                                              F-ID-CLASS ="SW-INSTANCE-TREE"
                                              F-NAMESPACE="SW-INSTANCE">
                               <SHORT-NAME>xxx</SHORT-NAME>
                               <CATEGORY>init-values</CATEGORY>
                               <SW-INSTANCE ID ="ID49163FECRAD7CCBA" F-ID-CLASS ="SW-INSTANCE" F-NAMESPACE="SW-INSTANCE">

                               <SHORT-NAME>no-fun</SHORT-NAME>
                               <SW-INSTANCE-PROPS-VARIANTS>
                                  <SW-INSTANCE-PROPS-VARIANT>
                                     <DESC>Instanz von
                                        <XREF ID-CLASS                ="SW-CLASS-INSTANCE"
                                              ID-REF                  ="ID49163FECRADA984D"
                                              HYTIME                  ="CLINK"
                                              HYNAMES                 ="LINKEND ID-REF"
                                              SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                              SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                              SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                              SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                              SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADA984D</XREF></DESC>
                                  </SW-INSTANCE-PROPS-VARIANT>
                               </SW-INSTANCE-PROPS-VARIANTS>
                               <SW-INSTANCE ID ="ID49163FECRADB8019" F-ID-CLASS ="SW-INSTANCE" F-NAMESPACE="SW-INSTANCE">
                               <SHORT-NAME>N</SHORT-NAME>
                               <SW-INSTANCE-PROPS-VARIANTS>
                                  <SW-INSTANCE-PROPS-VARIANT>
                                     <DESC>Instanz von
                                        <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                              ID-REF                  ="ID49163FEDRAD112E9"
                                              HYTIME                  ="CLINK"
                                              HYNAMES                 ="LINKEND ID-REF"
                                              SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                              SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                              SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                              SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                              SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD112E9</XREF></DESC>
                                  </SW-INSTANCE-PROPS-VARIANT>
                               </SW-INSTANCE-PROPS-VARIANTS>
                               <SW-INSTANCE ID ="ID49163FECRADA113B" F-ID-CLASS ="SW-INSTANCE" F-NAMESPACE="SW-INSTANCE">
                               <SHORT-NAME>TL </SHORT-NAME>
                               <SW-INSTANCE-PROPS-VARIANTS>
                                  <SW-INSTANCE-PROPS-VARIANT>
                                     <DESC>Instanz von
                                        <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                              ID-REF                  ="ID49163FEDRAD77C19"
                                              HYTIME                  ="CLINK"
                                              HYNAMES                 ="LINKEND ID-REF"
                                              SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                              SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                              SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                              SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                              SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD77C19</XREF></DESC>
                                  </SW-INSTANCE-PROPS-VARIANT>
                               </SW-INSTANCE-PROPS-VARIANTS>
                               <SW-INSTANCE ID ="ID49163FECRAD3588D" F-ID-CLASS ="SW-INSTANCE" F-NAMESPACE="SW-INSTANCE">
                               <SHORT-NAME>TMOT</SHORT-NAME>
                               <SW-INSTANCE-PROPS-VARIANTS>
                                  <SW-INSTANCE-PROPS-VARIANT>
                                     <DESC>Instanz von
                                        <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                              ID-REF                  ="ID49163FEDRAD65A29"
                                              HYTIME                  ="CLINK"
                                              HYNAMES                 ="LINKEND ID-REF"
                                              SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                              SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                              SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                              SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                              SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD65A29</XREF></DESC>
                                  </SW-INSTANCE-PROPS-VARIANT>
                               </SW-INSTANCE-PROPS-VARIANTS>
                               <SW-INSTANCE ID ="ID49163FECRAD2B108" F-ID-CLASS ="SW-INSTANCE" F-NAMESPACE="SW-INSTANCE">
                               <SHORT-NAME>WLN</SHORT-NAME>
                               <SW-INSTANCE-PROPS-VARIANTS>
                                  <SW-INSTANCE-PROPS-VARIANT>
                                     <DESC>Instanz von
                                        <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                              ID-REF                  ="ID49163FECRAD0EE17"
                                              HYTIME                  ="CLINK"
                                              HYNAMES                 ="LINKEND ID-REF"
                                              SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                              SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                              SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                              SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                              SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD0EE17</XREF></DESC>
                                  </SW-INSTANCE-PROPS-VARIANT>
                               </SW-INSTANCE-PROPS-VARIANTS>
                               <SW-INSTANCE ID ="ID49163FECRAD7339D" F-ID-CLASS ="SW-INSTANCE" F-NAMESPACE="SW-INSTANCE">
                               <SHORT-NAME>WTL</SHORT-NAME>
                               <SW-INSTANCE-PROPS-VARIANTS>
                                  <SW-INSTANCE-PROPS-VARIANT>
                                     <DESC>Instanz von
                                        <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                              ID-REF                  ="ID49163FECRADB7A5D"
                                              HYTIME                  ="CLINK"
                                              HYNAMES                 ="LINKEND ID-REF"
                                              SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                              SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                              SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                              SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                              SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADB7A5D</XREF></DESC>
                                  </SW-INSTANCE-PROPS-VARIANT>
                               </SW-INSTANCE-PROPS-VARIANTS>
                               <SW-INSTANCE ID         ="ID49163FECRAD7BD7C"
                                            F-ID-CLASS ="SW-INSTANCE"
                                            F-NAMESPACE="SW-INSTANCE">
                                  <SHORT-NAME>WTMOT </SHORT-NAME>
                                  <SW-INSTANCE-PROPS-VARIANTS>
                                     <SW-INSTANCE-PROPS-VARIANT>
                                        <DESC>Instanz von
                                           <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                                 ID-REF                  ="ID49163FECRADD360C"
                                                 HYTIME                  ="CLINK"
                                                 HYNAMES                 ="LINKEND ID-REF"
                                                 SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                 SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                 SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                 SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                 SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADD360C</XREF></DESC>
                                     </SW-INSTANCE-PROPS-VARIANT>
                                  </SW-INSTANCE-PROPS-VARIANTS>
                               </SW-INSTANCE>

                               <SW-INSTANCE ID         ="ID49163FECRADB0847"
                                            F-ID-CLASS ="SW-INSTANCE"
                                            F-NAMESPACE="SW-INSTANCE">
                                  <SHORT-NAME>KFNTL </SHORT-NAME>
                                  <SW-INSTANCE-PROPS-VARIANTS>
                                     <SW-INSTANCE-PROPS-VARIANT>
                                        <DESC>Instanz von
                                           <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                                 ID-REF                  ="ID49163FECRADF9F29"
                                                 HYTIME                  ="CLINK"
                                                 HYNAMES                 ="LINKEND ID-REF"
                                                 SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                 SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                 SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                 SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                 SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADF9F29</XREF></DESC>
                                     </SW-INSTANCE-PROPS-VARIANT>
                                  </SW-INSTANCE-PROPS-VARIANTS>
                               </SW-INSTANCE>

                               <SW-INSTANCE ID         ="ID49163FECRAD999EA"
                                            F-ID-CLASS ="SW-INSTANCE"
                                            F-NAMESPACE="SW-INSTANCE">
                                  <SHORT-NAME>substuff </SHORT-NAME>
                                  <SW-INSTANCE-PROPS-VARIANTS>
                                     <SW-INSTANCE-PROPS-VARIANT>
                                        <DESC>Das ist eine Instanz des Klassenattributes
                                           <XREF ID-CLASS                ="SW-CLASS-PROTOTYPE"
                                                 ID-REF                  ="ID49163FECRADE0ACB"
                                                 HYTIME                  ="CLINK"
                                                 HYNAMES                 ="LINKEND ID-REF"
                                                 SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                 SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                 SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                 SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                 SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADE0ACB</XREF></DESC>
                                     </SW-INSTANCE-PROPS-VARIANT>
                                  </SW-INSTANCE-PROPS-VARIANTS>
                                  <SW-INSTANCE ID         ="ID49163FECRADAE61E"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>subparam </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                                    ID-REF                  ="ID49163FECRAD8F757"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD8F757</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>

                                  <SW-INSTANCE ID         ="ID49163FEDRADB5D49"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>subvar </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                                    ID-REF                  ="ID49163FEDRADC1F7C"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRADC1F7C</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>
                               </SW-INSTANCE>

                               <SW-INSTANCE ID         ="ID49163FEDRADE40F7"
                                            F-ID-CLASS ="SW-INSTANCE"
                                            F-NAMESPACE="SW-INSTANCE">
                                  <SHORT-NAME>no-sports </SHORT-NAME>
                                  <SW-INSTANCE-PROPS-VARIANTS>
                                     <SW-INSTANCE-PROPS-VARIANT>
                                        <DESC>Instanz von
                                           <XREF ID-CLASS                ="SW-CLASS-INSTANCE"
                                                 ID-REF                  ="ID49163FECRAD51C6A"
                                                 HYTIME                  ="CLINK"
                                                 HYNAMES                 ="LINKEND ID-REF"
                                                 SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                 SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                 SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                 SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                 SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD51C6A</XREF></DESC>
                                     </SW-INSTANCE-PROPS-VARIANT>
                                  </SW-INSTANCE-PROPS-VARIANTS>
                                  <SW-INSTANCE ID         ="ID49163FEDRADF06C9"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>N </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                                    ID-REF                  ="ID49163FEDRAD112E9"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD112E9</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>

                                  <SW-INSTANCE ID         ="ID49163FEDRADC2B0A"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>TL </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                                    ID-REF                  ="ID49163FEDRAD77C19"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD77C19</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>

                                  <SW-INSTANCE ID         ="ID49163FEDRADC3297"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>TMOT </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                                    ID-REF                  ="ID49163FEDRAD65A29"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD65A29</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>

                                  <SW-INSTANCE ID         ="ID49163FEDRADFC198"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>WLN </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                                    ID-REF                  ="ID49163FECRAD0EE17"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD0EE17</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>

                                  <SW-INSTANCE ID         ="ID49163FEDRADF223E"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>WTL </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                                    ID-REF                  ="ID49163FECRADB7A5D"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADB7A5D</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>

                                  <SW-INSTANCE ID         ="ID49163FEDRADB4878"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>WTMOT </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                                    ID-REF                  ="ID49163FECRADD360C"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADD360C</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>

                                  <SW-INSTANCE ID         ="ID49163FEDRAD1EBBB"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>KFNTL </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                                    ID-REF                  ="ID49163FECRADF9F29"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADF9F29</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>

                                  <SW-INSTANCE ID         ="ID49163FEDRAD5CBAE"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>substuff </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-CLASS-PROTOTYPE"
                                                    ID-REF                  ="ID49163FECRADE0ACB"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADE0ACB</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                     <SW-INSTANCE ID         ="ID49163FEDRAD98DBB"
                                                  F-ID-CLASS ="SW-INSTANCE"
                                                  F-NAMESPACE="SW-INSTANCE">
                                        <SHORT-NAME>subparam </SHORT-NAME>
                                        <SW-INSTANCE-PROPS-VARIANTS>
                                           <SW-INSTANCE-PROPS-VARIANT>
                                              <DESC>Instanz von
                                                 <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                                       ID-REF                  ="ID49163FECRAD8F757"
                                                       HYTIME                  ="CLINK"
                                                       HYNAMES                 ="LINKEND ID-REF"
                                                       SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                       SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                       SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                       SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                       SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD8F757</XREF></DESC>
                                           </SW-INSTANCE-PROPS-VARIANT>
                                        </SW-INSTANCE-PROPS-VARIANTS>
                                     </SW-INSTANCE>

                                     <SW-INSTANCE ID         ="ID49163FEDRAD0DEEB"
                                                  F-ID-CLASS ="SW-INSTANCE"
                                                  F-NAMESPACE="SW-INSTANCE">
                                        <SHORT-NAME>subvar </SHORT-NAME>
                                        <SW-INSTANCE-PROPS-VARIANTS>
                                           <SW-INSTANCE-PROPS-VARIANT>
                                              <DESC>Instanz von
                                                 <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                                       ID-REF                  ="ID49163FEDRADC1F7C"
                                                       HYTIME                  ="CLINK"
                                                       HYNAMES                 ="LINKEND ID-REF"
                                                       SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                       SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                       SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                       SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                       SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRADC1F7C</XREF></DESC>
                                           </SW-INSTANCE-PROPS-VARIANT>
                                        </SW-INSTANCE-PROPS-VARIANTS>
                                     </SW-INSTANCE>
                                  </SW-INSTANCE>
                               </SW-INSTANCE>

                               <SW-INSTANCE ID         ="ID49163FEDRADC50EB"
                                            F-ID-CLASS ="SW-INSTANCE"
                                            F-NAMESPACE="SW-INSTANCE">
                                  <SHORT-NAME>no-life </SHORT-NAME>
                                  <SW-INSTANCE-PROPS-VARIANTS>
                                     <SW-INSTANCE-PROPS-VARIANT>
                                        <DESC>Instanz von
                                           <XREF ID-CLASS                ="SW-CLASS-INSTANCE"
                                                 ID-REF                  ="ID49163FECRAD353DD"
                                                 HYTIME                  ="CLINK"
                                                 HYNAMES                 ="LINKEND ID-REF"
                                                 SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                 SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                 SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                 SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                 SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD353DD</XREF></DESC>
                                     </SW-INSTANCE-PROPS-VARIANT>
                                  </SW-INSTANCE-PROPS-VARIANTS>
                                  <SW-INSTANCE ID         ="ID49163FEDRADEC698"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>N </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                                    ID-REF                  ="ID49163FEDRAD112E9"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD112E9</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>

                                  <SW-INSTANCE ID         ="ID49163FEDRAD84097"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>TL </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                                    ID-REF                  ="ID49163FEDRAD77C19"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD77C19</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>

                                  <SW-INSTANCE ID         ="ID49163FEDRADA2A67"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>TMOT </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                                    ID-REF                  ="ID49163FEDRAD65A29"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD65A29</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>

                                  <SW-INSTANCE ID         ="ID49163FEDRAD0C4EB"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>WLN </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                                    ID-REF                  ="ID49163FECRAD0EE17"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD0EE17</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>

                                  <SW-INSTANCE ID         ="ID49163FEDRADFF9EA"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>WTL </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                                    ID-REF                  ="ID49163FECRADB7A5D"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADB7A5D</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>

                                  <SW-INSTANCE ID         ="ID49163FEDRADDD319"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>WTMOT </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                                    ID-REF                  ="ID49163FECRADD360C"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADD360C</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>

                                  <SW-INSTANCE ID         ="ID49163FEDRAD9583C"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>KFNTL </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                                    ID-REF                  ="ID49163FECRADF9F29"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADF9F29</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                  </SW-INSTANCE>

                                  <SW-INSTANCE ID         ="ID49163FEDRAD7B2AA"
                                               F-ID-CLASS ="SW-INSTANCE"
                                               F-NAMESPACE="SW-INSTANCE">
                                     <SHORT-NAME>substuff </SHORT-NAME>
                                     <SW-INSTANCE-PROPS-VARIANTS>
                                        <SW-INSTANCE-PROPS-VARIANT>
                                           <DESC>Instanz von
                                              <XREF ID-CLASS                ="SW-CLASS-PROTOTYPE"
                                                    ID-REF                  ="ID49163FECRADE0ACB"
                                                    HYTIME                  ="CLINK"
                                                    HYNAMES                 ="LINKEND ID-REF"
                                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADE0ACB</XREF></DESC>
                                        </SW-INSTANCE-PROPS-VARIANT>
                                     </SW-INSTANCE-PROPS-VARIANTS>
                                     <SW-INSTANCE ID         ="ID49163FEDRADF76EE"
                                                  F-ID-CLASS ="SW-INSTANCE"
                                                  F-NAMESPACE="SW-INSTANCE">
                                        <SHORT-NAME>subparam </SHORT-NAME>
                                        <SW-INSTANCE-PROPS-VARIANTS>
                                           <SW-INSTANCE-PROPS-VARIANT>
                                              <DESC>Instanz von
                                                 <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                                       ID-REF                  ="ID49163FECRAD8F757"
                                                       HYTIME                  ="CLINK"
                                                       HYNAMES                 ="LINKEND ID-REF"
                                                       SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                       SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                       SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                       SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                       SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD8F757</XREF></DESC>
                                           </SW-INSTANCE-PROPS-VARIANT>
                                        </SW-INSTANCE-PROPS-VARIANTS>
                                     </SW-INSTANCE>

                                     <SW-INSTANCE ID         ="ID49163FEDRAD7BD9B"
                                                  F-ID-CLASS ="SW-INSTANCE"
                                                  F-NAMESPACE="SW-INSTANCE">
                                        <SHORT-NAME>subvar </SHORT-NAME>
                                        <SW-INSTANCE-PROPS-VARIANTS>
                                           <SW-INSTANCE-PROPS-VARIANT>
                                              <DESC>Instanz von
                                                 <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                                       ID-REF                  ="ID49163FEDRADC1F7C"
                                                       HYTIME                  ="CLINK"
                                                       HYNAMES                 ="LINKEND ID-REF"
                                                       SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                                       SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                                       SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                                       SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                                       SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRADC1F7C</XREF></DESC>
                                           </SW-INSTANCE-PROPS-VARIANT>
                                        </SW-INSTANCE-PROPS-VARIANTS>
                                     </SW-INSTANCE>
                                  </SW-INSTANCE>
                               </SW-INSTANCE>
                            </SW-INSTANCE-TREE>
                         </SW-INSTANCE-SPEC>
                      </SW-SYSTEM>
                   </SW-SYSTEMS>
                </MSRSW>
Formal Description
Within context of: | SW-CLASS-PROTOTYPE, SW-CLASSES, SW-COMPONENTS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-FULFILS, SW-CLASS-ATTR, SW-CLASS-ATTR-IMPLS, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS, SW-FEATURE-VARIABLES, SW-FEATURE-PARAMS, SW-FEATURE-CLASS-INSTANCES, SW-DATA-DICTIONARY-SPEC, SW-TEST-DESC, SW-APPLICATION-NOTES, SW-MAINTENANCE-NOTES, SW-CARB-DOC, SW-FEATURE-OWNED-ELEMENT-SETS, SW-FEATURE-OWNED-ELEMENTS, SW-FEATURE-INTERFACES, ANNOTATIONS, ADD-INFO
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-CLASS | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | CHAPTER DEF-ITEM FIGURE FORMULA PRM SDG STD SW-ADDR-METHOD SW-AXIS-TYPE SW-BASE-TYPE SW-CALPRM SW-CALPRM-PROTOTYPE SW-CLASS-ATTR-IMPL SW-CLASS-INSTANCE SW-CLASS-PROTOTYPE SW-CODE-SYNTAX SW-COMPU-METHOD SW-DATA-CONSTR SW-FEATURE-INTERFACE SW-GENERIC-AXIS-PARAM-TYPE SW-RECORD-LAYOUT SW-SERVICE SW-SERVICE-ARG SW-SERVICE-PROTOTYPE SW-SERVICE-RETURN SW-SYSTEMCONST SW-TEMPLATE SW-UNIT SW-VARIABLE SW-VARIABLE-PROTOTYPE SYNOPSIS TABLE TOPIC XDOC XFILE XREF-TARGET | Fixed Namespace. This attribute is assigned to elements which define a namespace for linkable objects. The attribute contains a list of elements, where the element carrying the attribute serves as a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names including the namespaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')


2.332. SW-CLASS-ATTR

Description
Defines the object-oriented class-attributes containing the prototypes: <SW-VARIABLE-PROTOTYPES> which denote attributes within the classes that are variables, <SW-CALPRM-PROTOTYPES> which denote attributes within the classes that are calibration parameters , <SW-SERVICE-PROTOTYPES> which denote attributes within the classes that are services and <SW-CLASS-PROTOTYPES> which denote attributes within the classes that are class instances themselves.
Example
Formal Description
Within context of: | SW-CLASS
Is context for: | SW-VARIABLE-PROTOTYPES, SW-CALPRM-PROTOTYPES, SW-SERVICE-PROTOTYPES, SW-CLASS-PROTOTYPES


2.333. SW-CLASS-ATTR-IMPL

Description
Defines the object-oriented class-attributes: 2.688. SW-VARIABLE-IMPLS which implement attributes that are variables, 2.317. SW-CALPRM-IMPLS which implement attributes that are calibration parameters and 2.340. SW-CLASS-IMPLS which implement attributes that are class instances themselves.
Example
Formal Description
Within context of: | SW-CLASS-ATTR-IMPLS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS, SW-VARIABLE-IMPLS, SW-SERVICE-IMPLS, SW-CALPRM-IMPLS, SW-CLASS-IMPLS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | String (CDATA) | SW-CLASS-ATTR-IMPL | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.334. SW-CLASS-ATTR-IMPL-REF

Description
This element references <SW-CLASS-ATTR-IMPL> .
Example
Formal Description
Within context of: | SW-CLASS-ATTR-IMPL-REF-SYSCOND, SW-CLASS-ATTR-IMPL-REFS, SW-CLASS-INSTANCE, SW-DATA-DEF-PROPS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-CLASS-ATTR-IMPL | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.335. SW-CLASS-ATTR-IMPL-REF-SYSCOND

Description
Example
Formal Description
Within context of: | SW-CLASS-ATTR-IMPL-REFS
Is context for: | SW-CLASS-ATTR-IMPL-REF, SW-SYSCOND


2.336. SW-CLASS-ATTR-IMPL-REFS

Description
Example
Formal Description
Within context of: | SW-FEATURE-ELEMENTS
Is context for: | SW-CLASS-ATTR-IMPL-REF, SW-CLASS-ATTR-IMPL-REF-SYSCOND


2.337. SW-CLASS-ATTR-IMPLS

Description
Container element for <SW-CLASS-ATTR-IMPL> .
Example
Formal Description
Within context of: | SW-CLASS
Is context for: | SW-CLASS-ATTR-IMPL


2.338. SW-CLASS-ATTR-INSTANCE-IMPL

Description
<SW-CLASS-ATTR-INSTANCE-IMPL> is used to create an instance from a model (Models are defined with SW-CLASS) where some specifications shall be changed / overwritten. This implementation will then be a instance specific implementation (Classes are usually only implemented under <SW-CLASS-IMPLS>).
Example
Formal Description
Within context of: | SW-CLASS-INSTANCE
Is context for: | SW-VARIABLE-IMPLS, SW-CALPRM-IMPLS, SW-CLASS-IMPLS


2.339. SW-CLASS-IMPL

Description
This element describes the implementation details of a class attribute which manifests itself as a class.
Example
Formal Description
Within context of: | SW-CLASS-IMPLS
Is context for: | SW-CLASS-PROTOTYPE-REF, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS


2.340. SW-CLASS-IMPLS

Description
Container element for <SW-CLASS-IMPL> .
Example
Formal Description
Within context of: | SW-CLASS-ATTR-IMPL, SW-CLASS-ATTR-INSTANCE-IMPL
Is context for: | SW-CLASS-IMPL


2.341. SW-CLASS-INSTANCE

Description
Defines the particular instantiation of a referenced <SW-CLASS> .
Example
Formal Description
Within context of: | SW-CLASS-INSTANCES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-ARRAYSIZE, SW-CLASS-REF, SW-CLASS-ATTR-IMPL-REF, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS, SW-CLASS-ATTR-INSTANCE-IMPL, ANNOTATIONS, ADD-INFO
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-CLASS-INSTANCE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.342. SW-CLASS-INSTANCE-REF

Description
This element refers to an <SW-CLASS-INSTANCE> .
Example
Formal Description
Within context of: | SW-ACCESSED-CLASS-INSTANCES, SW-CLASS-INSTANCE-REF-SYSCOND, SW-CLASS-INSTANCE-REFS, SW-FEATURE-EXPORT-CLASS-INSTANCES, SW-FEATURE-IMPORT-CLASS-INSTANCES, SW-FEATURE-LOCAL-CLASS-INSTANCES
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-CLASS-INSTANCE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.343. SW-CLASS-INSTANCE-REF-SYSCOND

Description
Use <SW-CLASS-INSTANCE-REF-SYSCOND> to create a <SW-CLASS-INSTANCE-REF> that will be valid only when the corresponding <SW-SYSCOND> expression evaluates to true. This is useful when a <SW-CLASS-INSTANCE-REF> shall be used when system constant has a certain value.
Example
This Class Instance reference is used when LINA_Gear is less or equal to 4.
<SW-CLASS-INSTANCE-REF-SYSCOND>
                  <SW-CLASS-INSTANCE-REF>class_i_Ref</SW-CLASS-INSTANCE-REF>
                  <SW-SYSCOND>
                    <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&lt;=4
                  </SW-SYSCOND>
                </SW-CLASS-INSTANCE-REF-SYSCOND>
Formal Description
Within context of: | SW-ACCESSED-CLASS-INSTANCES, SW-CLASS-INSTANCE-REFS
Is context for: | SW-CLASS-INSTANCE-REF, SW-SYSCOND


2.344. SW-CLASS-INSTANCE-REFS

Description
Container element for <SW-CLASS-INSTANCE-REF> .
Example
Formal Description
Within context of: | SW-COLLECTION-CONT, SW-FEATURE-ELEMENTS
Is context for: | SW-CLASS-INSTANCE-REF, SW-CLASS-INSTANCE-REF-SYSCOND


2.345. SW-CLASS-INSTANCES

Description
Container element for <SW-CLASS-INSTANCE> in a data dictionary.
Example
Formal Description
Within context of: | SW-DATA-DICTIONARY-SPEC
Is context for: | ADMIN-DATA, SW-CLASS-INSTANCE


2.346. SW-CLASS-PROTOTYPE

Description
This element describes the prototype declaration of a class attribute, which appears in the form of a class.
Example
See 2.331. SW-CLASS
Formal Description
Within context of: | SW-CLASS-PROTOTYPES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-ARRAYSIZE, SW-SYSCOND, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS, SW-CLASS, ANNOTATIONS, ADD-INFO
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | String (CDATA) | SW-CLASS-PROTOTYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.347. SW-CLASS-PROTOTYPE-REF

Description
This element points to a <SW-CLASS-PROTOTYPE> .
Example
Formal Description
Within context of: | SW-CLASS-IMPL
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-CLASS-PROTOTYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.348. SW-CLASS-PROTOTYPES

Description
Container element for <SW-CLASS-PROTOTYPE> .
Example
Formal Description
Within context of: | SW-CLASS-ATTR
Is context for: | SW-CLASS-PROTOTYPE


2.349. SW-CLASS-REF

Description
This element points to a <SW-CLASS> .
Example
Formal Description
Within context of: | SW-AR-RELATION, SW-CLASS-INSTANCE, SW-CLASS-REF-SYSCOND, SW-CLASS-REFS, SW-DATA-DEF-PROPS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-CLASS | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.350. SW-CLASS-REF-SYSCOND

Description
Use <SW-CLASS-REF-SYSCOND> to create a <SW-CLASS-REF> that will be valid only when the corresponding <SW-SYSCOND> expression evaluates to true. This is useful when a <SW-CLASS-REF> shall be used when system constant has a certain value.
Example
This Class reference is used when LINA_Gear is less or equal to 4.
<SW-CLASS-REF-SYSCOND>
                  <SW-CLASS-REF>class_Ref</SW-CLASS-REF>
                  <SW-SYSCOND>
                    <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&lt;=4
                  </SW-SYSCOND>
                </SW-CLASS-REF-SYSCOND>
Formal Description
Within context of: | SW-CLASS-REFS
Is context for: | SW-CLASS-REF, SW-SYSCOND


2.351. SW-CLASS-REFS

Description
This is a container for SW-CLASS-REFS.
Example
Formal Description
Within context of: | SW-COLLECTION-CONT, SW-FEATURE-ELEMENTS
Is context for: | SW-CLASS-REF, SW-CLASS-REF-SYSCOND


2.352. SW-CLASSES

Description
Container for classes.
Example
Formal Description
Within context of: | SW-DATA-DICTIONARY-SPEC
Is context for: | ADMIN-DATA, SW-CLASS


2.353. SW-CODE-SYNTAX

Description
Code syntax objects fix the representation of the variables and parameters in the program source file. These code syntax objects are defined centrally in <SW-CODE-SYNTAXES> and are connected to variables and parameters by means of <SW-CODE-SYNTAX-REF> .
The principle role of this element is the declaration of keywords (in the subelement <SHORT-NAME>) for the code generation procedure. The process itself is given a verbal description (in <SW-CODE-SYNTAX-DESC> ) rather than a formal one. This approach was adopted as the number of possible code syntax schematics is relatively small. A complete formal description would create unnecessary work.
It is possible however, to store a process-dependent micro syntax in <SW-CODE-SYNTAX-DESC>, for example within <VERBATIM> and to label this through a suitable data assignment to the attribute [SI] .
Example
<SW-CODE-SYNTAXES>
                   <SW-CODE-SYNTAX ID="IDCS1">
                      <LONG-NAME>CodeSyntax-Objekt für Systemkonstanten</LONG-NAME>
                      <SHORT-NAME>$cSyKgsSys</SHORT-NAME>
                      <SW-CODE-SYNTAX-DESC>
                         <VERBATIM>CodeSyntax: $cSyKgsSys CodeSyntax-Objekt für Systemkonstanten HFm: #ifndef <KGR> #define <KGR>
                                  <IWERTE> #elif (<KGR> != <IWERTE>) #error >>>> <KGR> multiple defined #endif QFm: /* #define <KGR>
                                                 <IWERTE> */ </IWERTE>
                                              </KGR></KGR></IWERTE></KGR></IWERTE>
                               </KGR></KGR></VERBATIM>
                      </SW-CODE-SYNTAX-DESC>
                   </SW-CODE-SYNTAX>

                   <SW-CODE-SYNTAX ID="IDCS2">
                      <LONG-NAME>This is Code Syntax 2</LONG-NAME>
                      <SHORT-NAME>Bit</SHORT-NAME>
                      <SW-CODE-SYNTAX-DESC>
                         <VERBATIM>CodeSyntax: Bit HFm: extern bit <RAM>; QFm: bit <RAM>
                                  <INITWERTIDEF>" = <INITWERTIDEF>;">; </INITWERTIDEF></INITWERTIDEF>
                               </RAM></RAM></VERBATIM>
                      </SW-CODE-SYNTAX-DESC>
                   </SW-CODE-SYNTAX>
                </SW-CODE-SYNTAXES>
Formal Description
Within context of: | SW-CODE-SYNTAXES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-CODE-SYNTAX-DESC
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-CODE-SYNTAX | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.354. SW-CODE-SYNTAX-DESC

Description
Verbal description of the algorithm for outputting the variables or parameters in the program source file (generation of code).
Example
Formal Description
Within context of: | SW-CODE-SYNTAX
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.355. SW-CODE-SYNTAX-REF

Description
This element refers to an <SW-CODE-SYNTAX> .
Example
Formal Description
Within context of: | CONF-VALUE-PROPS, SW-CODE-SYNTAX-REF-SYSCOND, SW-CODE-SYNTAX-REFS, SW-DATA-DEF-PROPS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-CODE-SYNTAX | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.356. SW-CODE-SYNTAX-REF-SYSCOND

Description
Use <SW-CODE-SYNTAX-REF-SYSCOND> to create a <SW-CODE-SYNTAX-REF> that will be valid only when the corresponding <SW-SYSCOND> expression evaluates to true. This is useful when a <SW-CODE-SYNTAX-REF> shall be used when system constant has a certain value.
Example
This Code Syntax reference is used when LINA_Gear is less or equal to 4.
<SW-CODE-SYNTAX-REF-SYSCOND>
                  <SW-CODE-SYNTAX-REF>code_syn_Ref</SW-CODE-SYNTAX-REF>
                  <SW-SYSCOND>
                    <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&lt;=4
                  </SW-SYSCOND>
                </SW-CODE-SYNTAX-REF-SYSCOND>
Formal Description
Within context of: | SW-CODE-SYNTAX-REFS
Is context for: | SW-CODE-SYNTAX-REF, SW-SYSCOND


2.357. SW-CODE-SYNTAX-REFS

Description
Container element for <SW-CODE-SYNTAX-REF> .
Example
Formal Description
Within context of: | SW-COLLECTION-CONT, SW-FEATURE-ELEMENTS
Is context for: | SW-CODE-SYNTAX-REF, SW-CODE-SYNTAX-REF-SYSCOND


2.358. SW-CODE-SYNTAXES

Description
Container element for <SW-CODE-SYNTAX> .
Example
Formal Description
Within context of: | SW-DATA-DICTIONARY-SPEC
Is context for: | ADMIN-DATA, SW-CODE-SYNTAX


2.359. SW-CODED-TYPE

Description
Gives a name to the coding belonging to a data object of a base type, in the memory. The name is therefore a keyword, denoting the interpretation of the bits in a base type. Possible values are:
unsigned | Refers to an unsigned integer number.
signed | Refers to a signed integer number.
bcd | Refers to a decimal number in binary code.
IEEE_floating_point | Refers to a floating point number according to IEEE standards. These standards exist for 32 and 64 bit floating point numbers.
DSP-fractional | This is a fractal data type which appears in connection with digital signal processors, e.g. Siemens Tricore databook.
Indicates whether the current data type is SIGNED or UNSIGNED. For example, for a signed data type, the contents of SW-CODED-TYPE is:
<SW-CODED-TYPE>SIGNED</SW-CODED-TYPE>
Example
Formal Description
Within context of: | SW-BASE-TYPE, SW-MC-BASE-TYPE
Is context for: | Text


2.360. SW-COLLECTION

Description
<SW-COLLECTION> describes a generic group mechanism which allows the free grouping of different objects in the DTD (especially <sw-variables>, <sw-param>s and <sw-function>s). The composition is located within <SW-COLLECTION-CONT> .
Group definition can be carried out for a number of purposes. These include:
  • application of access rights
  • building work packages for the calibration phase
  • assigning responsibilities
  • general data management
  • Selection criteria in an MCD-System .
A group can specify sub-groups. A generic collection mechanism is implemented, supporting the following requests:
  • Collections comprise of objects such as variables, calibration parameters, functions, collections, compu-methods, units etc. (thus allowing embedded collections).
  • Collections are assigned to multiple purposes which can be predefined and also freely defined.
  • The contents of a collection are defined by specifying objects which are included in the collection. To maintain clarity, it is not necessary to list the objects which are not included. This can be achieved by inverting collections on application.
  • Collections can be inverted on application for any purpose.
  • Purposes defined via collections may override properties defined elsewhere in the ASAP file. For instance, if a parameter belongs to a collection with the pupose "readonly", it cannot be manipulated in the mcd system, regardless of the value of the attribute [calibration] .
  • It is possible to define the rules dictating how a collection is established ( <sw-collection-rules> ). The objects can be selected using references, wildcards and regular expressions. In future versions, additional means may be implemented such as properties, query languages and scripting (which is already implemented as a preliminary solution in the dtd).
  • Collections can also be defined by applying previously defined collections ( <sw-collection-refs> ). Circular references are not permitted and must be detected.
  • The collections can also be specified through applying the rules to the database and resolving <sw-collection-refs> (acting as subcollections).
    If a collection is applied, only the result is taken into consideration.
    References contained within elements (e.g. the variable of a parameter axis), which make up the result, are not resolved automatically. This means that the collection comprises only of those objects mentioned explicitly.
  • Whenever a collection is applied, it can be used either inverted or in its direct form. This is specified with the attribute [invert] in <sw-collection-ref> .
  • Collections apply to only one file (strictly speaking to one parse unit).
  • The collections have no order.
Example
Formal Description
Within context of: | SW-COLLECTIONS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, ANNOTATION, SW-COLLECTION-RULES, SW-COLLECTION-REFS, SW-COLLECTION-CONT
Name
Type
Values / Default
Notes
[ROOT]
has default value
Value selection (NAMEDTOKENGROUP)
  • ROOT
  • NO-ROOT
This collection is displayed in an editing system as a possible point of entry for further navigation. This provides you with the opportunity to generate different views on the data in the ECU and also, to offer corresponding navigators. Example :
[ID]
optional
ID (ID)
Unambiguous identifier of the element within the document.
[F-ID-CLASS]
fixed value
SGML string (NMTOKEN)
SW-COLLECTION
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.361. SW-COLLECTION-CONT

Description
This element contains the composition of an <SW-COLLECTION> , which can consist of any objects included in the ECU software.
Example
Formal Description
Within context of: | SW-COLLECTION
Is context for: | SW-FEATURE-REFS, SW-SERVICE-REFS, SW-UNIT-REFS, SW-VARIABLE-REFS, SW-CALPRM-REFS, SW-INSTANCE-REFS, SW-CLASS-REFS, SW-CLASS-INSTANCE-REFS, SW-COMPU-METHOD-REFS, SW-ADDR-METHOD-REFS, SW-RECORD-LAYOUT-REFS, SW-CODE-SYNTAX-REFS, SW-BASE-TYPE-REFS, SW-SYSTEMCONST-REFS, SW-DATA-CONSTR-REFS, SW-AXIS-TYPE-REFS


2.362. SW-COLLECTION-REF

Description
This element references an <SW-COLLECTION> .
Example
Formal Description
Within context of: | SW-ACCESS-DEF, SW-COLLECTION-REFS
Is context for: | Text
Name
Type
Values / Default
Notes
[INVERT]
has default value
Value selection (NAMEDTOKENGROUP)
  • INVERT
  • NO-INVERT
INVERT can assume the values INVERT and NO-INVERT. In the case of INVERT, the collection is excluded. This means that if, in an SW-Collection, another collection with INVERT="INVERT" is referenced, the elements of the collection referenced, are extracted from the resulting total set.
[ID-REF]
optional
ID reference (IDREF)
Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS]
fixed value
SGML string (NMTOKEN)
SW-COLLECTION
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES]
fixed value
SGML strings (NMTOKENS)
LINKEND ID-REF
HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME]
fixed value
SGML string (NMTOKEN)
CLINK
HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.363. SW-COLLECTION-REFS

Description
Container element for <SW-COLLECTION-REF> .
Example
Formal Description
Within context of: | SW-COLLECTION
Is context for: | SW-COLLECTION-REF


2.364. SW-COLLECTION-REGEXP

Description
This element specifies a regular expression, e.g. a-zA-Z0-9_, which is to be executed on the set to be selected.
Example
Formal Description
Within context of: | SW-COLLECTION-REGEXPS
Is context for: | Text


2.365. SW-COLLECTION-REGEXPS

Description
Container element for <SW-COLLECTION-REGEXP> .
Example
Formal Description
Within context of: | SW-COLLECTION-RULE
Is context for: | SW-COLLECTION-REGEXP


2.366. SW-COLLECTION-RULE

Description
Describes a rule with which the objects for a compilation <SW-COLLECTION> can be selected. The selection is possible using:
  • Wildcards on the <SHORT-NAME>s objects to be selected ( <SW-COLLECTION-WILDCARDS> )
  • Regular expressions on the <SHORT-NAME>s of the objects to be selected ( <SW-COLLECTION-REGEXPS> )
  • Scripts ( <SW-COLLECTION-SCRIPTS> )
Example
Formal Description
Within context of: | SW-COLLECTION-RULES
Is context for: | SW-COLLECTION-REGEXPS, SW-COLLECTION-WILDCARDS, SW-COLLECTION-SCRIPTS
Name
Type
Values / Default
Notes
[RESOLVE-REFS]
has default value
Value selection (NAMEDTOKENGROUP)
  • RESOLVE-REFS
  • NOT-RESOLVE-REFS
Indicates whether the objects bound by the objects selected, e.g. conversion formulae, are included in the selection.
[SCOPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • SW-ADDR-METHOD
  • SW-AXIS-TYPE
  • SW-BASE-TYPE
  • SW-CALPRM
  • SW-CLASS
  • SW-CLASS-INSTANCE
  • SW-CODE-SYNTAX
  • SW-COMPU-METHOD
  • SW-DATA-CONSTR
  • SW-FEATURE
  • SW-INSTANCE
  • SW-RECORD-LAYOUT
  • SW-SERVICE
  • SW-SYSTEMCONST
  • SW-UNIT
  • SW-VARIABLE
  • ALL
Indicates the type of the object to be selected e.g. SW-VARIABLE, SW-CALPRM. The contents of this attribute must conform with the contents of the element <SW-COLLECTION-CONT> parallel to the father element <SW-COLLECTION-RULES> .


2.367. SW-COLLECTION-RULES

Description
Container element for <SW-COLLECTION-RULE> .
Example
Formal Description
Within context of: | SW-COLLECTION
Is context for: | SW-COLLECTION-RULE


2.368. SW-COLLECTION-SCRIPT

Description
This element specifies a script in the [LANGUAGE] which is used on the current set being selected.
Example
Formal Description
Within context of: | SW-COLLECTION-SCRIPTS
Is context for: | Text
Name | Type | Notes
[LANGUAGE] optional | String (CDATA) | Language to be used on the current set to be selected.


2.369. SW-COLLECTION-SCRIPTS

Description
Container element for <SW-COLLECTION-SCRIPT> .
Example
Formal Description
Within context of: | SW-COLLECTION-RULE
Is context for: | SW-COLLECTION-SCRIPT


2.370. SW-COLLECTION-SPEC

Description
Describes the contents of parameter and variable groups.
Example
Formal Description
Within context of: | SW-SYSTEM
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-COLLECTIONS, ADD-INFO


2.371. SW-COLLECTION-WILDCARD

Description
This element specifies a wildcard (e.g. ABC*), which must be applied to the current set to be selected, e.g. <SHORT-NAME> s.
Example
Formal Description
Within context of: | SW-COLLECTION-WILDCARDS
Is context for: | Text


2.372. SW-COLLECTION-WILDCARDS

Description
Container element for <SW-COLLECTION-WILDCARD> .
Example
Formal Description
Within context of: | SW-COLLECTION-RULE
Is context for: | SW-COLLECTION-WILDCARD


2.373. SW-COLLECTIONS

Description
Container element for <SW-COLLECTION> .
Example
Formal Description
Within context of: | SW-COLLECTION-SPEC
Is context for: | SW-COLLECTION


2.374. SW-COMPARISON-VARIABLES

Description
These variables can be used to display the value of a variable on the value axis of a calibration parameter (characteristic), that is currently displayed in the MCD-System. The purpose is to compare the appropriate result from the calibration parameter in question, with a value being calculated or taken from a sensor (the comparison variable).
The sole purpose of this comparison-variable is to serve the calibration process.
Figure 1: Screen representation of comparison variable
     Vs |              |
                        |              |
                        |              |
                     V _|______________|______________
                        |         /----|------
                        |  /-----/     |
                        | /            |
                        |/             |
                        |--------------|--------------
                                       tx          tmot

                        tx: akt. Temperatur
                        V:  akt. Geschwindigkeit eingeblendet im MCD-System
                            zu Vergleichszwecken: SW-COMPARISON-VARIABLE
                        Vs: Geschwindigkeitsschwelle über Temperatur
                        tmot: Motortemperatur
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | SW-VARIABLE-REF


2.375. SW-COMPONENT-SPEC

Description
Takes up descriptions of SW system components in <SW-COMPONENTS> :
  1. Functional characteristics or functions in the SW of an ECU ( <SW-FEATURE> ).
  2. Classes ( <SW-CLASS> )
  3. Other descriptions ( <CHAPTER> ) not directly occurring in the ECU software.
The structure of <SW-COMPONENT-SPEC> is related to the document, in that the sequence is chosen to correspond to the printed documentation. The structure of the components is semi-formal, i.e. to a large extent, the characteristics are described in the form of free text. There is a formal structure for these data flows ( <SW-FEATURE-VARIABLES> etc.).
The conceptual differences between <SW-FEATURE> and <SW-CLASS> can be found in the following table Correlation between classes and feature .
Correlation between classes and feature
Feature
Class
Purpose
Used for specific features of the ECU
Used as recyclable functionality (building block) to establish features
Interfaces
Messages and global variables used as inputs and outputs
A class can have methods which can be invoked.
Instantiation
The feature is instantiated implicitly. Therefore a feature can be instantiated only once within one software system.
The class must be instantiated within one or more features.
scope of variables, parameters, namespaces
The feature can have local variables/parameters as well as global ones. The communication merely uses the global ones.
a class can establish local variables/parameters for memory purposes.
If the MCD-system needs access to such variables/parameters, then they are instantiated with the instantiation of the class itself.
A class may touch global variables/parameters which are already instantiated.
Implementation
The implementation of variables/parameters may differ from instance to instance. It must therefore be possible to manipulate the implementation of the variables/parameters when the class is instantiated.
Class types
There are basically two types of class:
  • Classes which establish visible and calibratable variables/parameters. These are known as open classes.
  • Classes which do not establish visible variables/parameters. These are known as closed classes.
"Open" and "closed" reflects the view of the calibration phase.
If packages are introduced, it is not necessary to keep this distinction.
Remarks
Classes can be very large such as "exhaust-gas-control", or very small such as "delay". The large ones are instantiated only a few times while the small ones are usually instantiated rather more frequently.
In most cases, large classes appear as open classes while small classes appear as closed ones.
Documentation
The features are described in various aspects such as <sw-feature-defintion>, <sw-carb-doc> etc.
In case of "large" classes, the description of class comes close to the documentation of a feature. On the other hand "small" classes may only described as a small table, with the graphic image and the methods.
In general a specific structure for the documentation of methods is recommended.
Relevant in ASAP/MSR
features are relevant at any time, since they are responsible for establishing the system itself.
The "open" classes are most relevant for documentation purposes, as well as for the instantiation of variables/parameters.
In an MSRSW-file it is therefore the case, that only those classes which instantiate variables/parameters, must be instantiated within the features.
Example
Formal Description
Within context of: | SW-SYSTEM
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-COMPONENTS, SW-ROOT-FEATURES, ADD-INFO


2.376. SW-COMPONENTS

Description
Container element for <SW-CLASS>, <SW-FEATURE> .
Example
Formal Description
Within context of: | SW-COMPONENT-SPEC
Is context for: | CHAPTER, SW-CLASS, SW-FEATURE


2.377. SW-COMPU-CONST

Description
This element is used if a constant value is valid in a section of a conversion formula. It ensures that the constancy of the section is clearly marked.
Example
<SW-COMPU-SCALE>
                   <LOWER-LIMIT INTERVAL-TYPE="CLOSED">0</LOWER-LIMIT>
                   <UPPER-LIMIT INTERVAL-TYPE="CLOSED">10</UPPER-LIMIT>
                   <sw-compu-const>
                      <VT>FALSE</VT>
                   </sw-compu-const</E>
                </SW-COMPU-SCALE>
                <SW-COMPU-SCALE>
                   <UPPER-LIMIT INTERVAL-TYPE="CLOSED">20</UPPER-LIMIT>
                   <sw-compu-const>
                      <VT>TRUE</VT>
                   </sw-compu-const</E>
                </SW-COMPU-SCALE>
Formal Description
Within context of: | SW-COMPU-SCALE
Is context for: | VF, V, VT


2.378. SW-COMPU-DEFAULT-VALUE

Description
This element can be used to specify an output value for a conversion formula, if the value to be converted lies outside the plausibility limit. Although this is possible for all conversion formulae, it is especially valid for variables with tabular conversion formulae.
It is not advisable to set this default value in MCD-Systemen , as this could prevent defective conditions from being detected.
Example
Formal Description
Within context of: | SW-COMPU-INTERNAL-TO-PHYS, SW-COMPU-PHYS-TO-INTERNAL
Is context for: | Text


2.379. SW-COMPU-DENOMINATOR

Description
Describes the rational coefficients for the divisor, in a fractional rational conversion formula, with rational coefficients.
Example
See 2.392. SW-COMPU-RATIONAL-COEFFS
Formal Description
Within context of: | SW-COMPU-RATIONAL-COEFFS
Is context for: | VF, V


2.380. SW-COMPU-GENERIC-MATH

Description
This element describes a calculation formula as a simple arithmetical expression in which system constants, referenced by <SW-SYSTEMCONST-CODED-REF> and <SW-SYSTEMCONST-PHYS-REF> , are substituted.
Example
Formal Description
Within context of: | SW-COMPU-SCALE
Is context for: | Text, CONF-ITEM-CODED-REF, CONF-ITEM-PHYS-REF, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF
Name | Type | Notes
[LEVEL] optional | SGML string (NMTOKEN) | Placeholder to describe an indicator of a language level for the mathematics e.g. INFORMAL or MATHML2.0


2.381. SW-COMPU-IDENTITY

Description
If given, a 1:1 conversion is specified by <SW-COMPU-IDENTITY> .
Example
Formal Description
Within context of: | SW-COMPU-METHOD
Is context for: | Text


2.382. SW-COMPU-INTERNAL-TO-PHYS

Description
Describes the conversion formula which converts internal values into physical values.
Example
Formal Description
Within context of: | SW-COMPU-METHOD
Is context for: | SW-COMPU-SCALES, SW-COMPU-DEFAULT-VALUE


2.383. SW-COMPU-INVERSE-VALUE

Description
The purpose of this element is to specify a functional value for a definition section ( <SW-COMPU-SCALE> ) of a conversion formula. The specification of the inverse value causes constant functions to become unambiguously inversible, section-by-section. In this way the otherwise necessary specification of the inverse function can be omitted.
Example
Formal Description
Within context of: | SW-COMPU-SCALE
Is context for: | VF, V, VT


2.384. SW-COMPU-METHOD

Description
Describes the relationship between physical domain and the mathematical domain which then is implemented in the ECU. Thus the SW-COMPU-METHOD mainly converts a value with physical dimension to a normalized number which is a value without physical dimension. This involves the following principles:
  • The conversion can be specified in both directions. If the mapping is unambiguous, the specification in one direction can be omitted.
  • The conversion itself can be defined section by section ( <SW-COMPU-SCALES>). Here, simplification possibilities are valid if the mapping is continuous. The element <SW-COMPU-IDENTITY> is used for a 1:1 mapping, i.e. the 1:1 mapping is marked explicitly.
  • The conversion formula determines the physical characteristics. Therefore it contains units of measurement ( <SW-UNIT-REF> ).
  • The conversion formula does not determine the data-technical storage of the standardized variables. For this reason there is no reference to SW-BASE-TYPE. The data-technical storage of the standardized variables must be specified for the corresponding data objects (e.g. <SW-VARIABLE> ).
  • The conversion formula has ranges of values for its input and output variables. These can be specified both directly and indirectly, as well as on a physical level and a standardized level.
Here, conversions from physical to internal values (or vice-versa) can be specified ( <SW-COMPU-PHYS-TO-INTERNAL>, <SW-COMPU-INTERNAL-TO-PHYS>), display formats can be given ( <SW-DISPLAY-FORMAT>), measurement units can be referenced ( <SW-UNIT-REF>) and interval limits can be specified ( <SW-PHYS-CONSTRS-1>, <SW-INTERNAL-CONSTRS-1>). The element <SW-COMPU-IDENTITY> is used to designate the 1:1 conversions.
Example
<SW-COMPU-METHOD ID="B-TRUE">
                   <LONG-NAME>this is SW-COMPU-METHOD B-TRUE</LONG-NAME>
                   <SHORT-NAME>B_TRUE</SHORT-NAME>
                   <SW-DISPLAY-FORMAT>%s</SW-DISPLAY-FORMAT>
                   <SW-COMPU-INTERNAL-TO-PHYS>
                      <SW-COMPU-SCALES>
                         <SW-COMPU-SCALE>
                            <LOWER-LIMIT INTERVAL-TYPE="CLOSED">0</LOWER-LIMIT>
                            <UPPER-LIMIT INTERVAL-TYPE="CLOSED">0</UPPER-LIMIT>
                            <SW-COMPU-INVERSE-VALUE>
                               <V>0</V>
                            </SW-COMPU-INVERSE-VALUE>
                            <SW-COMPU-CONST>
                               <VT>FALSE</VT>
                            </SW-COMPU-CONST>
                         </SW-COMPU-SCALE>
                         <SW-COMPU-SCALE>
                            <LOWER-LIMIT INTERVAL-TYPE="CLOSED">1</LOWER-LIMIT>
                            <UPPER-LIMIT INTERVAL-TYPE="CLOSED">1</UPPER-LIMIT>
                            <SW-COMPU-INVERSE-VALUE>
                               <V>1</V>
                            </SW-COMPU-INVERSE-VALUE>
                            <SW-COMPU-CONST>
                               <VT>TRUE</VT>
                            </SW-COMPU-CONST>
                         </SW-COMPU-SCALE>
                         <SW-COMPU-SCALE>
                            <LOWER-LIMIT INTERVAL-TYPE="CLOSED">2</LOWER-LIMIT>
                            <UPPER-LIMIT INTERVAL-TYPE="CLOSED">2</UPPER-LIMIT>
                            <SW-COMPU-INVERSE-VALUE>
                               <V>2</V>
                            </SW-COMPU-INVERSE-VALUE>
                            <SW-COMPU-CONST>
                               <VT></VT>
                            </SW-COMPU-CONST>
                         </SW-COMPU-SCALE>
                      </SW-COMPU-SCALES>
                   </SW-COMPU-INTERNAL-TO-PHYS>
                </SW-COMPU-METHOD>
many more elaboreate examples can be found in [ASAM MCD 2 Harmonized Data Objects;2004/06/02;ASAM e.V.;Chapter 9 - compuMethods;]
Formal Description
Within context of: | SW-COMPU-METHODS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-DISPLAY-FORMAT, SW-UNIT-REF, SW-DATA-CONSTR-REF, SW-PHYS-CONSTRS-1, SW-INTERNAL-CONSTRS-1, SW-COMPU-IDENTITY, SW-COMPU-PHYS-TO-INTERNAL, SW-COMPU-INTERNAL-TO-PHYS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-COMPU-METHOD | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.385. SW-COMPU-METHOD-REF

Description
This element references an <SW-COMPU-METHOD> .
Example
Formal Description
Within context of: | CONF-VALUE-PROPS, SW-AXIS-INDIVIDUAL, SW-COMPU-METHOD-REF-SYSCOND, SW-COMPU-METHOD-REFS, SW-CONSTR-OBJECTS, SW-DATA-DEF-PROPS, SW-VCD-CRITERION
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-COMPU-METHOD | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.386. SW-COMPU-METHOD-REF-SYSCOND

Description
Use <SW-COMPU-METHOD-REF-SYSCOND> to create a <SW-COMPU-METHOD-REF> that will be valid only when the corresponding <SW-SYSCOND> expression evaluates to true. This is useful when a <SW-COMPU-METHOD-REF> shall be used when system constant has a certain value.
Example
This Computation Method reference is used when LINA_Gear is less or equal to 4.
<SW-COMPU-METHOD-REF-SYSCOND>
                  <SW-COMPU-METHOD-REF>comp_Ref</SW-COMPU-METHOD-REF>
                  <SW-SYSCOND>
                    <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&lt;=4
                  </SW-SYSCOND>
                </SW-COMPU-METHOD-REF-SYSCOND>
Formal Description
Within context of: | SW-COMPU-METHOD-REFS
Is context for: | SW-COMPU-METHOD-REF, SW-SYSCOND


2.387. SW-COMPU-METHOD-REFS

Description
Container element for <SW-COMPU-METHOD-REF> .
Example
Formal Description
Within context of: | SW-COLLECTION-CONT, SW-FEATURE-ELEMENTS
Is context for: | SW-COMPU-METHOD-REF, SW-COMPU-METHOD-REF-SYSCOND


2.388. SW-COMPU-METHODS

Description
Container element for <SW-COMPU-METHOD> .
Example
Formal Description
Within context of: | SW-DATA-DICTIONARY-SPEC
Is context for: | ADMIN-DATA, SW-COMPU-METHOD


2.389. SW-COMPU-NUMERATOR

Description
Describes the rational coefficients for the counter, in a fractional rational conversion formula, with rational coefficients.
Example
See 2.392. SW-COMPU-RATIONAL-COEFFS
Formal Description
Within context of: | SW-COMPU-RATIONAL-COEFFS
Is context for: | VF, V


2.390. SW-COMPU-PHYS-TO-INTERNAL

Description
Describes the conversion formula which converts physical values into internal values.
Internal value = sum in <SW-COMPU-NUMERATOR> over <VF> i * phys i / sum in <SW-COMPU-DENOMINATOR> over <VF> i * phys i
Example
The fractional rational conversion formula below simulates the formula:
internal = (1 * phys + 2 / 40)
<SW-COMPU-RATIONAL-COEFFS>
                   <SW-COMPU-NUMERATOR>
                      <VF>2</VF>
                      <VF>1</VF>
                   </SW-COMPU-NUMERATOR>
                   <SW-COMPU-DENOMINATOR>
                      <VF>40</VF>
                   </SW-COMPU-DENOMINATOR>
                </SW-COMPU-RATIONAL-COEFFS>
Formal Description
Within context of: | SW-COMPU-METHOD
Is context for: | SW-COMPU-SCALES, SW-COMPU-DEFAULT-VALUE


2.391. SW-COMPU-PROGRAM-CODE

Description
This element contains the description of a calculation formula, written in programming language.
Example
Formal Description
Within context of: | SW-COMPU-SCALE
Is context for: | Text
Name | Type | Notes
[LANG-SUBSET] optional | String (CDATA) | Describes the language subset to be used for the program code. E.g Ansii-C
[PROGRAM-LANG] optional | String (CDATA) | Indicates the programming language used.
[USED-LIBS] optional | String (CDATA) | Indicates the libraries used.


2.392. SW-COMPU-RATIONAL-COEFFS

Description
Describes the rational coefficients for counters ( <SW-COMPU-NUMERATOR>) and divisors ( <SW-COMPU-DENOMINATOR>) of the scaling instruction in the father element <SW-COMPU-SCALE> .
Example
Formal Description
Within context of: | SW-COMPU-SCALE
Is context for: | SW-COMPU-NUMERATOR, SW-COMPU-DENOMINATOR


2.393. SW-COMPU-SCALE

Description
Describes the conversion from internal to physical values (or vice-versa). Here, upper and lower limits ( <UPPER-LIMIT>, <LOWER-LIMIT>) can be determined, as well as the coefficients of a fractional rational conversion instruction ( <SW-COMPU-RATIONAL-COEFFS> ).
Example
In the example (see <SW-COMPU-METHOD> ) intervals of internal values are assigned to functional values using a table.
Formal Description
Within context of: | SW-COMPU-SCALES
Is context for: | C-IDENTIFIER, DESC, LOWER-LIMIT, UPPER-LIMIT, SW-COMPU-INVERSE-VALUE, SW-COMPU-CONST, SW-COMPU-RATIONAL-COEFFS, SW-COMPU-PROGRAM-CODE, SW-COMPU-GENERIC-MATH


2.394. SW-COMPU-SCALES

Description
Container element for <SW-COMPU-SCALE> .
Example
Formal Description
Within context of: | SW-COMPU-INTERNAL-TO-PHYS, SW-COMPU-PHYS-TO-INTERNAL
Is context for: | SW-COMPU-SCALE


2.395. SW-CONSTR-LEVEL

Description
This element describes the category of a constraint. One of its functions is in the area of constraint violation, where it can be used from a certain level, to produce error messages .
The contents of <SW-CONSTR-LEVEL> is a positive integer. The higher the level, the more stringent the check.
The determination of the level itself is dependent on the process and must be established by the process partners.
Example
<SW-DATA-CONSTR>
                   <SHORT-NAME>NMOT_GE0</SHORT-NAME>
                   <DESC>Drehzahl darf nicht negativ sein!</DESC>
                   <SW-DATA-CONSTR-RULE>
                      <SW-CONSTR-LEVEL>3</SW-CONSTR-LEVEL>
                      <SW-INTERNAL-CONSTRS>
                         <LOWER-LIMIT INTERVAL-TYPE="CLOSED">0</LOWER-LIMIT>
                      </SW-INTERNAL-CONSTRS>
                   </SW-DATA-CONSTR-RULE>
                </SW-DATA-CONSTR>
Formal Description
Within context of: | SW-DATA-CONSTR-RULE
Is context for: | Text


2.396. SW-CONSTR-OBJECTS

Description
Parameters or variables can reference plausibility checks. The assignment of data to <SW-CONSTR-OBJECTS> makes the reverse direction possible.
In this way for example plausibility libraries stored in external files can be latched beneath the previous element <SW-DATA-CONSTRS> -element.
Example
Formal Description
Within context of: | SW-DATA-CONSTR
Is context for: | SW-VARIABLE-REF, SW-CALPRM-REF, SW-COMPU-METHOD-REF


2.397. SW-CPU-ADDR-EPK

Description
This element specifies the address of the EPROM Identifier. It corresponds to the ASAM keyword ADDR_EPK (Eprom Kennung = EPROM Identifier).
Example
Formal Description
Within context of: | SW-CPU-SPEC
Is context for: | SW-ADDR-INFO


2.398. SW-CPU-CALIBRATION-OFFSET

Description
This element specifies a fixed address offset, which must be added when calibration parameters are accessed. This is significant for
  • Near pointers in calibration objects. Some record layouts include near pointers inside a calibration object. This is used by the calibration system to calculate the absolute values through adding the <SW-CPU-CALIBRATION-OFFSET> .
  • Variant Coding. Some ECU projects include multiple data sets for different engine or vehicle projects served by one common ECU. By using the <SW-CPU-CALIBRATION-OFFSET> , a selection of project base addresses can be made.
Example
<SW-CPU-CALIBRATION-OFFSET>0x1000</SW-CPU-CALIBRATION-OFFSET>
Formal Description
Within context of: | SW-CPU-SPEC
Is context for: | Text


2.399. SW-CPU-EPK

Description
This element specifies the EPROM identifier of the ECU, i.e. the string that should be located under the address of <SW-CPU-ADDR-EPK> in the ECU.
Example
<SW-CPU-EPK>EPROM identifier test</SW-CPU-EPK>
Formal Description
Within context of: | SW-CPU-SPEC
Is context for: | Text


2.400. SW-CPU-MEM-SEG

Description
The name of a <SW-CPU-MEM-SEG> can be used for references from Interface-Data-Blobs, as well as to provide an accurate description of the memory through memory types <SW-MEM-TYPE> and attributes <SW-MEM-ATTR> ( INTERN and EXTERN). The parameter <SW-MEM-OFFSET> is used to describe a number of mirrored segments. <SW-CPU-MEM-SEGS> with the same <SW-MEM-TYPE> and the same <SW-MEM-ATTR> must not overlap. In addition all <SW-CPU-MEM-SEG> with the <SW-MEM-PROGRAM-TYPE> CODE, DATA, OFFLINE_DATA, RESERVED may not mutually overlap to acquire linear address space for access to calibration data. However, all other <SW-CPU-MEM-SEG>s with different <SW-MEM-TYPE> or different <SW-MEM-ATTR> may overlap. This includes internal and external memory segments, for example.
The following table contains descriptions of some useful <SW-MEM-PROGRAM-TYPE> and <SW-MEM-TYPE> combinations as well as their meaning:
Useful combinations for <SW-MEM-PROGRAM-TYPE> and <SW-MEM-TYPE>
Combination | Meaning
CODE/FLASH | Executable code: has to be preserved for downloading and HEX-file generation.
DATA/FLASH or DATA/EEPROM | Calibration data: can be modified by the user via calibration systems.
RESERVED/FLASH | Specific code or data: has to be preserved for HEX-file generation but not for download.
DATA/RAM | Calibration data: will be modified by ECU and calibration systems.
OFFLINE_DATA/FLASH | Calibration data: will only be modified without ECU access, online calibration is not allowed.
VARIABLES/RAM | RAM of the ECU for variables (measurement values and others).
REGISTER/RAM | RAM of the ECU for special purpose values.
SERAM/RAM | ECU-RAM section available for serial application. For usage see also: 2.308. SW-CALIBRATION-METHOD .
Hint
FLASH has been used as a synonym for EPROM and ROM.
Example
<SW-CPU-MEM-SEGS>
                   <SW-CPU-MEM-SEG>
                      <LONG-NAME>Data internal Flash</LONG-NAME>
                      <SHORT-NAME>Data1</SHORT-NAME>
                      <DESC>This describes Data for internal Flash.</DESC>
                      <SW-MEM-PROGRAM-TYPE>DATA</SW-MEM-PROGRAM-TYPE>
                      <SW-MEM-TYPE>FLASH</SW-MEM-TYPE>
                      <SW-MEM-ATTR>INTERN</SW-MEM-ATTR>
                      <SW-MEM-BASE-ADDR>0x4000</SW-MEM-BASE-ADDR>
                      <SW-MEM-SIZE>0x200</SW-MEM-SIZE>
                      <SW-MEM-OFFSETS>0x10000</SW-MEM-OFFSETS>
                   </SW-CPU-MEM-SEG>
                </SW-CPU-MEM-SEGS>
Formal Description
Within context of: | SW-CPU-MEM-SEGS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-MEM-PROGRAM-TYPE, SW-MEM-TYPE, SW-MEM-ATTR, SW-MEM-BASE-ADDR, SW-MEM-SIZE, SW-MEM-OFFSETS, SW-MC-INSTANCE-INTERFACES
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | String (CDATA) | SW-CPU-MEM-SEG | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.401. SW-CPU-MEM-SEG-REF

Description
This element references <SW-CPU-MEM-SEG> .
Example
Formal Description
Within context of: | SW-ADDR-INFO, SW-ADDR-METHOD
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-CPU-MEM-SEG | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.402. SW-CPU-MEM-SEGS

Description
Container element for <SW-CPU-MEM-SEG> .
Example
Formal Description
Within context of: | SW-CPU-SPEC
Is context for: | SW-CPU-MEM-SEG


2.403. SW-CPU-NUMBER-OF-INTERFACES

Description
This element specifies the number of calibration interfaces made available by the CPU.
Example
<SW-CPU-NUMBER-OF-INTERFACES>2</SW-CPU-NUMBER-OF-INTERFACES>
Formal Description
Within context of: | SW-CPU-SPEC
Is context for: | Text


2.404. SW-CPU-SPEC

Description
This element is to specify the relevant details of the CPU within the control unit according to ASAM-MCD-2MC. If one ECU contains multiple CPUs then we have multiple <SW-SYSTEM> s.
Example
Formal Description
Within context of: | SW-SYSTEM
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, BYTE-ORDER, SW-BASE-TYPE-SIZE, SW-MEM-ALIGNMENT, SW-CPU-STANDARD-RECORD-LAYOUT, SW-CPU-MEM-SEGS, SW-CPU-EPK, SW-CPU-ADDR-EPK, SW-CPU-TYPE, SW-CPU-CALIBRATION-OFFSET, SW-CPU-NUMBER-OF-INTERFACES, ADD-INFO


2.405. SW-CPU-STANDARD-RECORD-LAYOUT

Description
This element specifies the default record layout, which is valid if no record layout is specified in a calibration parameter.
Example
Formal Description
Within context of: | SW-CPU-SPEC
Is context for: | SW-RECORD-LAYOUT-REF


2.406. SW-CPU-TYPE

Description
This element provides a verbal description of the type of CPU used.
Example
<SW-CPU-TYPE>Intel 4711</SW-CPU-TYPE>
Formal Description
Within context of: | SW-CPU-SPEC
Is context for: | Text


2.407. SW-CS-CONTEXT

Description
This element specifies the current work package for the current application status of an application object. A work package is a summary of complete functions.
Example
See 2.411. SW-CS-HISTORY .
Formal Description
Within context of: | SW-CS-ENTRY
Is context for: | Text


2.408. SW-CS-DATA-IDENTIFIER

Description
This element specifies the version of a data status belonging to a certain application status, which in turn relates to a characteristic variable that is to be applicated.
Example
See 2.411. SW-CS-HISTORY .
Formal Description
Within context of: | SW-CS-ENTRY
Is context for: | Text


2.409. SW-CS-ENTRY

Description
This element describes an entry into the history of all application states. Application states can be specified for the following elements:
  • Characteristic variables
  • Functions
  • Work packages (summary of functions)
  • Data status
Example
See 2.411. SW-CS-HISTORY .
Formal Description
Within context of: | SW-CS-HISTORY
Is context for: | SW-CS-STATE, SW-CS-CONTEXT, SW-CS-PROJECT-INFO, SW-CS-TARGET-VARIANT, SW-CS-TEST-OBJECT, SW-CS-PROGRAM-IDENTIFIER, SW-CS-DATA-IDENTIFIER, SW-CS-PERFORMED-BY, REMARK, DATE, SW-CS-FIELD


2.410. SW-CS-FIELD

Description
This element contains random information on application status. It is adopted to ensure compatibility to random data assignments to the MSRSW instance. The respective semantics of the data assignment of SW-CS-FIELD must be given in the attribute [SI] .
Example
<SW-CS-FIELD SI="Review-State">reviewed by Senior engineer<SW-CS-FIELD>
Formal Description
Within context of: | SW-CS-ENTRY
Is context for: | Text


2.411. SW-CS-HISTORY

Description
Container element for <SW-CS-ENTRY>, for the storage of calibration states. <SW-CS-HISTORY> allows the history of the calibration process to be tracked, for either one particular calibration item or the entire calibration list. The history therefore allows more than one history entry to be stored.
Example
 <SW-CS-HISTORY>
                   <SW-CS-ENTRY>
                      <SW-CS-STATE>calibrated</SW-CS-STATE>
                      <SW-CS-CONTEXT>development of demo version</SW-CS-CONTEXT>
                      <SW-CS-PROJECT-INFO>Demo-Project CDF / ASAM-MCD-2D</SW-CS-PROJECT-INFO>
                      <SW-CS-TARGET-VARIANT>automatic gear</SW-CS-TARGET-VARIANT>
                      <SW-CS-TEST-OBJECT>Vehicle: S-Nn-4455</SW-CS-TEST-OBJECT>
                      <SW-CS-PROGRAM-IDENTIFIER>67985</SW-CS-PROGRAM-IDENTIFIER>
                      <SW-CS-DATA-IDENTIFIER>67985:123.4</SW-CS-DATA-IDENTIFIER>
                      <SW-CS-PERFORMED-BY>Weichel</SW-CS-PERFORMED-BY>
                      <REMARK>
                         <P>Note that we did not really calibrate this. The current structure is for demonstration purposes only. </P>
                      </REMARK>
                      <DATE>18.05.2001T13.23</DATE>
                      <SW-CS-FIELD SI="feeling">We did feel good while doing this stuff.</SW-CS-FIELD>
                   </SW-CS-ENTRY>
                </SW-CS-HISTORY>
Formal Description
Within context of: | SW-INSTANCE-PROPS-VARIANT, SW-INSTANCE-TREE
Is context for: | SW-CS-ENTRY


2.412. SW-CS-PERFORMED-BY

Description
<SW-CS-PERFORMED-BY> specifies the individual responsible for assigning the current calibration state. Although this could be a reference to a <TEAM-MEMBER> , it is in actual fact simply a string. This is because data might be copied from project to project, an activity which would serve to invalidate the formal reference.
Example
For an example, see 2.411. SW-CS-HISTORY .
Formal Description
Within context of: | SW-CS-ENTRY
Is context for: | Text


2.413. SW-CS-PROGRAM-IDENTIFIER

Description
<SW-CS-PROGRAM-IDENTIFIER> denotes the identifier of the ECU program, used while calibrating the current calibration item up to the state of the current calibration history.
To some extent, this should provide a basis for determining the matching SYMBOLIC-FILE according to the CDF specification.
Example
For an example, see 2.411. SW-CS-HISTORY .
Formal Description
Within context of: | SW-CS-ENTRY
Is context for: | Text


2.414. SW-CS-PROJECT-INFO

Description
<SW-CS-PROJECT-INFO> enables the specification of a project identifier for indicating the project in which the current calibration state was achieved. This is useful since calibration items can be copied from one project to another. Therefore the information provided in the <PROJECT-DATA> does not suffice in this case.
Example
For an example, see 2.411. SW-CS-HISTORY .
Formal Description
Within context of: | SW-CS-ENTRY
Is context for: | Text


2.415. SW-CS-STATE

Description
<SW-CS-STATE> is used to denote the current state of the calibration item, depending on the context of the instantiated function. The legal values must be defined within the process.
Example
<SW-CS-STATE>fineTuned<SW-CS-STATE>
For a further example, see 2.411. SW-CS-HISTORY .
Formal Description
Within context of: | SW-CS-ENTRY
Is context for: | Text


2.416. SW-CS-TARGET-VARIANT

Description
<SW-CS-TARGET-VARIANT> is used to specify the target system variant through which the current calibration state was achieved.
Example
For an example, see 2.411. SW-CS-HISTORY .
Formal Description
Within context of: | SW-CS-ENTRY
Is context for: | Text


2.417. SW-CS-TEST-OBJECT

Description
<SW-CS-TEST-OBJECT> denotes the calibrated object within the current calibration item. This is usually a vehicle or a particular test environment.
Example
For an example, see 2.411. SW-CS-HISTORY .
Formal Description
Within context of: | SW-CS-ENTRY
Is context for: | Text


2.418. SW-CSE-CODE

Description
This element is used for parameterizing the ASAP1b-interface.
Figure 2: ASAP1b-Prinzip (tbd)
During parameterization, specifications concerning the scaling units must be made at various points. The values of these specifications (codes for scaling units, CSE) are uniformly laid down:
Scaling Units CSE
Value | Unit | Referred to | Comment
0 | 1 µsec | Time |
1 | 10 µsec | Time |
2 | 10 µsec | Time |
3 | 1 msec | Time |
4 | 10 msec | Time |
5 | 100 msec | Time |
6 | 1 sec | Time |
7 | 10 sec | Time |
8 | 1 min | Time |
9 | 1 h | Time |
10 | 1 d | Time |
100 | Angular degrees | Angle |
101 | Revolutions 360 degrees | Angle |
102 | Cycle 720 degrees | Angle | e.g. in case of IC engines
103 | Cylinder segment | Combustion | e.g. in case of IC engines
998 | When frame available | Time | Source defined in the ASAP 2 keyword, FRAME
999 | Always if there is new value |  | Calculation of a new upper range limit after receiving a new partial value, e.g. when calculating a complex trigger condition
1000 | Non deterministic |  | Without fixed scaling
Example
See 2.603. SW-REFRESH-TIMING
Formal Description
Within context of: | SW-ACCESS-DURATION, SW-EVENT-CYCLE, SW-EVENT-FREQUENCY-MAX, SW-EVENT-FREQUENCY-MIN, SW-EVENT-LAXITY, SW-EVENT-PHASE, SW-REFRESH-TIMING, SW-TASK-DEADLINE, SW-TASK-LATENCY
Is context for: | Text


2.419. SW-CSE-CODE-FACTOR

Description
This element describes the coefficient of the <SW-CSE-CODE> which is parallel to <SW-CSE-CODE-FACTOR> for a <SW-REFRESH-TIMING> .
If, for example, the value in <SW-CSE-CODE-FACTOR> is 360 and the value in <SW-CSE-CODE> is 100, this is equivalent to the value 1 in <SW-CSE-CODE-FACTOR> and the value 101 in <SW-CSE-CODE> .
Example
Formal Description
Within context of: | SW-ACCESS-DURATION, SW-EVENT-CYCLE, SW-EVENT-FREQUENCY-MAX, SW-EVENT-FREQUENCY-MIN, SW-EVENT-LAXITY, SW-EVENT-PHASE, SW-REFRESH-TIMING, SW-TASK-DEADLINE, SW-TASK-LATENCY
Is context for: | Text


2.420. SW-DATA-CONSTR

Description
A data constraint <SW-DATA-CONSTR> may be applied to data objects such as calculation methods, variables and parameters. Therefore, a <SW-DATA-CONSTR-RULE> is supplied.
Example
Formal Description
Within context of: | SW-DATA-CONSTRS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-CONSTR-OBJECTS, SW-DATA-CONSTR-RULE
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-DATA-CONSTR | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.421. SW-DATA-CONSTR-REF

Description
This element references an <SW-DATA-CONSTR> .
Example
Formal Description
Within context of: | SW-AXIS-INDIVIDUAL, SW-COMPU-METHOD, SW-DATA-CONSTR-REF-SYSCOND, SW-DATA-CONSTR-REFS, SW-DATA-DEF-PROPS, SW-GENERIC-AXIS-PARAM-TYPE
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-DATA-CONSTR | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.422. SW-DATA-CONSTR-REF-SYSCOND

Description
Use <SW-DATA-CONSTR-REF-SYSCOND> to create a <SW-DATA-CONSTR-REF> that will be valid only when the corresponding <SW-SYSCOND> expression evaluates to true. This is useful when a <SW-DATA-CONSTR-REF> shall be used when system constant has a certain value.
Example
This Data Constraint reference is used when LINA_Gear is less or equal to 4.
<SW-DATA-CONSTR-REF-SYSCOND>
                  <SW-DATA-CONSTR-REF>Axis_type_constr_Ref</SW-DATA-CONSTR-REF>
                  <SW-SYSCOND>
                    <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&lt;=4
                  </SW-SYSCOND>
                </SW-DATA-CONSTR-REF-SYSCOND>
Formal Description
Within context of: | SW-DATA-CONSTR-REFS
Is context for: | SW-DATA-CONSTR-REF, SW-SYSCOND


2.423. SW-DATA-CONSTR-REFS

Description
Container element for <SW-DATA-CONSTR-REF> .
Example
Formal Description
Within context of: | SW-COLLECTION-CONT, SW-FEATURE-ELEMENTS
Is context for: | SW-DATA-CONSTR-REF, SW-DATA-CONSTR-REF-SYSCOND


2.424. SW-DATA-CONSTR-RULE

Description
Describes the internal or physical limits for variables or parameter values in the elements <SW-PHYS-CONSTRS> or <SW-INTERNAL-CONSTRS> .
Example
Formal Description
Within context of: | SW-DATA-CONSTR
Is context for: | SW-CONSTR-LEVEL, SW-MAX-GRADIENT, SW-PHYS-CONSTRS, SW-INTERNAL-CONSTRS


2.425. SW-DATA-CONSTRS

Description
Container element for <SW-DATA-CONSTR> .
Example
Formal Description
Within context of: | SW-DATA-DICTIONARY-SPEC
Is context for: | ADMIN-DATA, SW-DATA-CONSTR


2.426. SW-DATA-DEF-PROPS

Description
This element describes all of the distinguishing characteristics of a data object (variable or parameter). <SW-DATA-DEF-PROPS> is used in every case, where characteristics of data objects must be given.
It is inevitable that not all of the inputs are useful all of the time. Hence, the process definition or the DCI has the task of implementing limitations.
The <SW-DATA-DEF-PROPS> describe the characteristics of all axes:
  • The characteristics of the argument axes (abscissas) are described in <SW-CALPRM-AXIS-SET> .
  • The characteristics of the value axis are described directly in <SW-DATA-DEF-PROPS> .
Example
Formal Description
Within context of: | SW-CALPRM, SW-CALPRM-IMPL, SW-CALPRM-PROTOTYPE, SW-CLASS, SW-CLASS-ATTR-IMPL, SW-CLASS-IMPL, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-DATA-DEF-PROPS-SYSCONDS, SW-INSTANCE-PROPS-VARIANT, SW-POINTER, SW-SERVICE-ARG, SW-SERVICE-RETURN, SW-SYSTEMCONST, SW-TEMPLATE, SW-VARIABLE, SW-VARIABLE-IMPL, SW-VARIABLE-PROTOTYPE
Is context for: | SW-SYSCOND, ANNOTATIONS, SW-ADDR-METHOD-REF, SW-ALIAS-NAME, SW-BASE-TYPE-REF, SW-BIT-REPRESENTATION, SW-CALIBRATION-ACCESS, SW-CALPRM-AXIS-SET, SW-CALPRM-NO-EFFECT-VALUE, SW-CALPRM-TARGET, SW-CALPRM-TEXT, SW-CALPRM-VALUE-AXIS-LABELS, SW-CLASS-ATTR-IMPL-REF, SW-CLASS-REF, SW-CODE-SYNTAX-REF, SW-COMPARISON-VARIABLES, SW-COMPU-METHOD-REF, SW-DATA-CONSTR-REF, SW-DATA-DEPENDENCY, SW-DISPLAY-FORMAT, SW-HOST-VARIABLE, SW-IMPL-POLICY, SW-INTENDED-RESOLUTION, SW-INTERPOLATION-METHOD, SW-IS-VIRTUAL, SW-MC-BASE-TYPE-REF, SW-POINTER, SW-RECORD-LAYOUT-REF, SW-REFRESH-TIMING, SW-SEMAPHORE, SW-SERVICE-REF, SW-TASK-REF, SW-TEMPLATE-REF, SW-UNIT-REF, SW-VAR-INIT-VALUE, SW-VAR-NOT-AVL-VALUE, SW-VARIABLE-KIND, SW-VARIABLE-ACCESS-IMPL-POLICY, SW-VCD-CRITERION-REFS, ADD-INFO


2.427. SW-DATA-DEF-PROPS-SYSCONDS

Description
Use <SW-DATA-DEF-PROPS-SYSCOND> to create a <SW-DATA-DEF-PROPS> that will be valid only when the corresponding <SW-SYSCOND> expression evaluates to true, The <SW-SYSCOND> element inside the <SW-DATA-DEF-PROPS> is used. This is useful when a <SW-DATA-DEF-PROPS> shall be used when system constant has a certain value.
Example
This <SW-DATA-DEF-PROPS> is used when LINA_Gear is less or equal to 4.
<SW-DATA-DEF-PROPS-SYSCOND>
                  <SW-DATA-DEF-PROPS>
                    <SW-SYSCOND>
                      <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&lt;=4
                    </SW-SYSCOND>
                    <SW-BASE-TYPE-REF>int</SW-BASE-TYPE-REF>
                    ...
                    ...
                  </SW-DATA-DEF-PROPS>
                </SW-DATA-DEF-PROPS-SYSCOND>
Formal Description
Within context of: | SW-CALPRM, SW-CALPRM-IMPL, SW-CALPRM-PROTOTYPE, SW-CLASS, SW-CLASS-ATTR-IMPL, SW-CLASS-IMPL, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-INSTANCE-PROPS-VARIANT, SW-POINTER, SW-SERVICE-ARG, SW-SERVICE-RETURN, SW-SYSTEMCONST, SW-TEMPLATE, SW-VARIABLE, SW-VARIABLE-IMPL, SW-VARIABLE-PROTOTYPE
Is context for: | SW-DATA-DEF-PROPS


2.428. SW-DATA-DEPENDENCY

Description
This element describes the interdependencies of variables and parameters. These can be used for example, to treat virtual parameters.
Example
The following example describes a scenario in which the adjacent leg A of a right-angled triangle is stored in the ECU with the hypotenuse of the length 1. The length of the opposite leg B (= SQRT(1-A*A)) or the area covered by the opposite leg B_AREA, is relevant for the physical understanding of the application engineer. Hence, three calibration parameters are introduced, of which two (B and B_AREA) are virtual. The example is taken from the ASAP1.3.
Figure 3: SW-DATA-DEPENDENCY
<SW-CALPRMS>
                   <SW-CALPRM>
                      <LONG-NAME>Eingangsparamenter</LONG-NAME>
                      <SHORT-NAME>A</SHORT-NAME>
                      <DESC>A ist die im Speicher abgelegte Ankathete</DESC>
                   </SW-CALPRM>

                   <SW-CALPRM>
                      <LONG-NAME>Abhängiger Parameter</LONG-NAME>
                      <SHORT-NAME>B</SHORT-NAME>
                      <DESC>Dies ist die Gegenkathete</DESC>
                      <SW-DATA-DEF-PROPS>
                         <SW-DATA-DEPENDENCY>
                            <SW-DATA-DEPENDENCY-FORMULA>sqrt(1 - X1 * X1)</SW-DATA-DEPENDENCY-FORMULA>
                            <SW-DATA-DEPENDENCY-ARGS>
                               <SW-CALPRM-REF>A</SW-CALPRM-REF>
                            </SW-DATA-DEPENDENCY-ARGS>
                         </SW-DATA-DEPENDENCY>
                         <SW-IS-VIRTUAL>yes</SW-IS-VIRTUAL>
                      </SW-DATA-DEF-PROPS>
                     </SW-CALPRM>

                   <SW-CALPRM>
                      <LONG-NAME>Fläche</LONG-NAME>
                      <SHORT-NAME>B_Area</SHORT-NAME>
                      <SW-DATA-DEF-PROPS>
                         <SW-DATA-DEPENDENCY>
                            <DESC>Dies ist die Fläche, die durch ein Quadrat aus B aufgespannt wird.</DESC>
                            <SW-DATA-DEPENDENCY-FORMULA>X1 * X1</SW-DATA-DEPENDENCY-FORMULA>
                            <SW-DATA-DEPENDENCY-ARGS>
                               <SW-CALPRM-REF>B</SW-CALPRM-REF>
                            </SW-DATA-DEPENDENCY-ARGS>
                         </SW-DATA-DEPENDENCY>
                         <SW-IS-VIRTUAL>yes</SW-IS-VIRTUAL>
                      </SW-DATA-DEF-PROPS>
                   </SW-CALPRM>
                </SW-CALPRMS>
Formal Description
Within context of: | SW-DATA-DEF-PROPS, SW-RELATED-CONSTRS
Is context for: | DESC, SW-DATA-DEPENDENCY-FORMULA, SW-DATA-DEPENDENCY-ARGS


2.429. SW-DATA-DEPENDENCY-ARGS

Description
This element specifies the elements used in a <SW-DATA-DEPENDENCY> .
Example
See 2.428. SW-DATA-DEPENDENCY
Formal Description
Within context of: | SW-DATA-DEPENDENCY
Is context for: | CONF-ITEM-CODED-REF, CONF-ITEM-PHYS-REF, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF, SW-CALPRM-REF, SW-VARIABLE-REF


2.430. SW-DATA-DEPENDENCY-FORMULA

Description
This element describes the formula with which the dependencies between the participating objects are defined. The formulae are texts which formulate first order arithmetical expressions.
The following syntax is valid:
numeric_expression ::= ( "-"expression ) | ( expression ( "+" | "-" | "*" | "/" | "^") expression )
                expression ::= ( number | variable | numeric_expression | ( "(" expression ")" ) | sinus_statement | cosinus_statement | sqrt_statement ) | expression {white-space}
                sinus_statement ::= "sin" "(" expression ")"
                cosinus_statement ::= "cos" "(" expression ")"
                sqrt_statement ::= "sqrt" "(" expression ")"
                number ::= integer_literal | float_literal
                variable ::= Any valid Object in question
                integer_literal ::= ( "1..9" { "0..9" } ) | ( "0" "x" "0..9a..f" { "0..9a..f" } )
                float_literal ::= ( decimal_digits "."  decimal_digits   exponent_part  ) | ( "." decimal_digits  exponent_part  ) | ( decimal_digits  exponent_part  )
                decimal_digits ::= "0..9" { "0..9" }
                exponent_part ::= "e"  "+" | "-"  decimal_digits
                white-space ::= tabulator | blank | newline | carriage_return | {tabulator | blank | newline | carriage_return }
                tabulator ::= \t
                blank ::= " "
                newline ::= \n
                carriage_return ::= \c
Example
See 2.428. SW-DATA-DEPENDENCY
Further examples are:
X1 + X2^2 (X1 - X2)^2
Formal Description
Within context of: | SW-DATA-DEPENDENCY
Is context for: | Text


2.431. SW-DATA-DICTIONARY-SPEC

Description
A Data-dictionary contains information on the data structures and related objects in an ECU. A Data-dictionary may appear in two locations in order to express different scopes within the ECU:
<SW-SYSTEM> | This indicates a global Data-dictionary definition, which means that all objects contained in these Data-dictionaries are known globally within the ECU.
<SW-FEATURE> | This represents a local Data-dictionary. This is local to the particular feature (sometimes called module or component) in the ECU software. The objects within this Data-dictionary are known locally within the feature. They may be addressed by prefixing by the <SHORT-NAME> of the feature.
Unless the ECU uses local data objects, all calibration parameters and variables should be placed in the global Data-dictionary.
The Data-dictionary mainly defines three kinds of objects which occur in the ECU:
<SW-VARIABLE> | These objects (often called measurements) represent all data which is variable during the runtime of the ECU.
<SW-CALPRM> | These objects (often called calibration parameters) represent data which is adjusted during the calibration process of the ECU.
<SW-CLASS-INSTANCE> | These objects (currently new to the domain of ECUs) represent instantiations of particular classes. These instantiations are specified as a reference to the class and to one of the implementations provided by the class (see 2.331. SW-CLASS ).
In addition to this, the data dictionary contains auxiliary definitions required to specify the three main items mentioned above. These auxiliary definitions are [image] :
<SW-UNIT> | Physical unit
<SW-COMPU-METHOD> | Methods to convert physical data to normalized data.
<SW-BASE-TYPE> | Definitions of basic types within the ECU such as "Unsigned Integer", "Float". These basic types may be standardized by ASAM with regards to their name and technical properties.
<SW-CODE-SYNTAX> | Containers for generator-specific definitions of how to describe the data objects (variables, calibration parameters) in the intended programming language.
<SW-RECORD-LAYOUT> | Defines how the data objects (variables, calibration parameters etc.) should be stored in the ECU memory. As an example, this definition specifies the sequence of axis points in the ECU memory.
<SW-ADDR-METHOD> | Reserves names serving as keywords for how the data objects might be addressed within the ECU-memory.
<SW-AXIS-TYPE> | Reserves names for specific axis computing strategies. For the reason that it is possible to use arbitrary algorithms to calculate axis-points, no formal specification is given. Instead, the algorithm is described verbally; the parameters are specified formally with respect to their name and constraints.
<SW-TEMPLATE> | These templates are used to predefine some properties of variables or parameters. The templates can be used to simplify the typing task. They have no architectural meaning, so they have no influence on the data model in the ECU.
Example
Formal Description
Within context of: | SW-CLASS, SW-FEATURE, SW-SYSTEM
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, DESC, SW-UNITS, SW-TEMPLATES, SW-VARIABLES, SW-CALPRMS, SW-SYSTEMCONSTS, SW-CLASS-INSTANCES, SW-COMPU-METHODS, SW-ADDR-METHODS, SW-RECORD-LAYOUTS, SW-CODE-SYNTAXES, SW-BASE-TYPES, SW-DATA-CONSTRS, SW-AXIS-TYPES, SW-SERVICES, SW-CLASSES, ADD-INFO

Each of the following elements is described in the singular form in spite of the fact that the data dictionary allows multiple instances of each of them


2.432. SW-DISPLAY-FORMAT

Description
This element describes the display format in "printf"-format of the syntax for the programming language C.
One of its uses is for conversion formulae <SW-COMPU-METHOD> .
This element may contain a format specification for the display of values of this setting. The format specification adheres to the syntax defined for printf format specification fields (e.g. "%f.2"), but due to the numerical nature of value settings, only the format types are allowed:
d: | Signed decimal integer
i: | Signed decimal integer
o: | Unsigned octal integer
u: | Unsigned decimal integer
x: | Unsigned hexadecimal integer, using "abcdef"
X: | Unsigned hexadecimal integer, using "ABCDEF"
e: | Signed value having the form [-]d.dddd e [sign]ddd where d is a single decimal digit, dddd is one or more decimal digits, ddd is exactly three decimal digits, and sign is + or -
E: | Identical to the e format except that E rather than e introduces the exponent
f: | Signed value having the form [-]dddd.dddd, where dddd is one or more decimal digits; the number of digits before the decimal point depends on the magnitude of the number, and the number of digits after the decimal point depends on the requested precision
g: | Signed value printed in f or e format, whichever is more compact for the given value and precision; trailing zeros are truncated, and the decimal point appears only if one or more digits follow it
G: | Identical to the g format, except that E, rather than e, introduces the exponent (where appropriate)
Example
Formal Description
Within context of: | CONF-VALUE-PROPS, SW-CALPRM-AXIS, SW-COMPU-METHOD, SW-DATA-DEF-PROPS
Is context for: | Text


2.433. SW-EFFECT

Description
The effect of the parent element <SW-EFFECTING-VARIABLE> is given as a keyword in <SW-EFFECT> . The values must be agreed upon by the parties involved.
Example
Formal Description
Within context of: | SW-EFFECTING-VARIABLE
Is context for: | Text
Name | Type | Notes
[ORIGIN] optional | String (CDATA) | Indicates from whom the information originates. The <SW-EFFECT> -flow is generated with Ascet and then revised manually. In this case, those from ASCET are entered as Origin=Ascet, for manual revision work, Origin=Username is entered.


2.434. SW-EFFECT-FLOW

Description
Insert <SW-EFFECT-FLOW> into <SW-FUNCTION-VARIANT> to describe how the referenced variable <SW-VARIABLE-REF> is influenced by <SW-EFFECTING-VARIABLE>. The effect is given as a keyword in the child node <SW-EFFECT> of <SW-EFFECTING-VARIABLE> . The values must be agreed upon by the partners.
Example
Formal Description
Within context of: | SW-EFFECT-FLOWS
Is context for: | SW-VARIABLE-REF, SW-EFFECTING-VARIABLE


2.435. SW-EFFECT-FLOWS

Description
Container element for <SW-EFFECT-FLOW> .
Example
Formal Description
Within context of: | SW-FEATURE
Is context for: | SW-EFFECT-FLOW


2.436. SW-EFFECTING-VARIABLE

Description
In the Element <SW-EFFECTING-VARIABLE>, the variable referenced by its sister element <SW-VARIABLE-REF> is influenced by the child element <SW-VARIABLE-REF> of <SW-EFFECTING-VARIABLE> .
Example
Formal Description
Within context of: | SW-EFFECT-FLOW
Is context for: | SW-VARIABLE-REF, SW-EFFECT


2.437. SW-EVENT

Description
Example
Formal Description
Within context of: | SW-EVENTS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, SW-EVENT-MESSAGE-RECEIVED, SW-EVENT-TASK-TERMINATED, SW-EVENT-SOURCE-REF, SW-EVENT-PHASE, SW-EVENT-CYCLE, SW-EVENT-LAXITY, SW-TASK-REFS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-EVENT |


2.438. SW-EVENT-CYCLE

Description
Example
Formal Description
Within context of: | SW-EVENT
Is context for: | SW-CSE-CODE, SW-CSE-CODE-FACTOR


2.439. SW-EVENT-FREQUENCY-MAX

Description
Example
Formal Description
Within context of: | SW-EVENT-SOURCE
Is context for: | SW-CSE-CODE, SW-CSE-CODE-FACTOR


2.440. SW-EVENT-FREQUENCY-MIN

Description
Example
Formal Description
Within context of: | SW-EVENT-SOURCE
Is context for: | SW-CSE-CODE, SW-CSE-CODE-FACTOR


2.441. SW-EVENT-LAXITY

Description
Example
Formal Description
Within context of: | SW-EVENT
Is context for: | SW-CSE-CODE, SW-CSE-CODE-FACTOR


2.442. SW-EVENT-MESSAGE-RECEIVED

Description
Example
Formal Description
Within context of: | SW-EVENT
Is context for: | SW-VARIABLE-REF


2.443. SW-EVENT-PHASE

Description
Example
Formal Description
Within context of: | SW-EVENT
Is context for: | SW-EVENT-REF, SW-CSE-CODE, SW-CSE-CODE-FACTOR


2.444. SW-EVENT-REF

Description
Example
Formal Description
Within context of: | SW-EVENT-PHASE, SW-EVENT-REF-SYSCOND, SW-EVENT-REFS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-EVENT |
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF |
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK |


2.445. SW-EVENT-REF-SYSCOND

Description
Example
Formal Description
Within context of: | SW-EVENT-REFS
Is context for: | SW-EVENT-REF, SW-SYSCOND


2.446. SW-EVENT-REFS

Description
Example
Formal Description
Within context of: | SW-OPER-MODE
Is context for: | SW-EVENT-REF, SW-EVENT-REF-SYSCOND


2.447. SW-EVENT-SOURCE

Description
Example
Formal Description
Within context of: | SW-EVENT-SOURCES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, SIGNAL-REF, SW-EVENT-FREQUENCY-MIN, SW-EVENT-FREQUENCY-MAX
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-EVENT-SOURCE |


2.448. SW-EVENT-SOURCE-REF

Description
Example
Formal Description
Within context of: | SW-EVENT
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-EVENT-SOURCE |
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF |
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK |


2.449. SW-EVENT-SOURCES

Description
Example
Formal Description
Within context of: | SW-EVENT-SPEC
Is context for: | SW-EVENT-SOURCE


2.450. SW-EVENT-SPEC

Description
Example
Formal Description
Within context of: | SW-SCHEDULING-SPEC
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-EVENTS, SW-EVENT-SOURCES


2.451. SW-EVENT-TASK-TERMINATED

Description
Example
Formal Description
Within context of: | SW-EVENT
Is context for: | SW-TASK-REF


2.452. SW-EVENTS

Description
Example
Formal Description
Within context of: | SW-EVENT-SPEC
Is context for: | SW-EVENT


2.453. SW-FEATURE

Description
A <SW-FEATURE> describes a specific ECU feature with regards to functionality, used data and processing. It may define its own 2.431. SW-DATA-DICTIONARY-SPEC and 2.486. SW-FEATURE-VARIABLES for feature-local purposes.
A <SW-FEATURE> is usually used to describe a software component. A software system is build of software components, where each component may have any number of sub components. The static view of the software system is described with <SW-FEATURE-DECOMPOSITION> .
Each <SW-FEATURE> may define its interfaces <SW-FEATURE-INTERFACES> .
The common name of the software component is defined in <SW-FEATURE> <SHORT-NAME>, while the unique name is defined in <SW-FEATURE> <SW-FEATURE-VARIANT> <SHORT-NAME> .
Example
             <SW-FEATURE>
      <LONG-NAME>Low Idle Governer</LONG-NAME>
      <SHORT-NAME>LIGov</SHORT-NAME>
                  <SW-FEATURE-OWNED-ELEMENTS>
                    <SW-FEATURE-ELEMENTS>
                         <SW-CALPRM-REFS>
                              <SW-CALPRM-REF>TST_calSimple_C</SW-CALPRM-REF>
                              <SW-CALPRM-REF>TST_calSimple2_C</SW-CALPRM-REF>
                   </SW-CALPRM-REFS>
                         <SW-CLASS-INSTANCE-REFS>
                              <SW-CLASS-INSTANCE-REF>TST_calClassInstance1</SW-CLASS-INSTANCE-REF>
                              <SW-CLASS-INSTANCE-REF>TST_calClassInstance2</SW-CLASS-INSTANCE-REF>
                         </SW-CLASS-INSTANCE-REFS>
                         <SW-CLASS-REFS>
                              <SW-CLASS-REF>TST_calClass</SW-CLASS-REF>
                         </SW-CLASS-REFS>
                         <SW-SYSTEMCONST-REFS>
                              <SW-SYSTEMCONST-REF>SYS1</SW-SYSTEMCONST-REF>
                      </SW-SYSTEMCONST-REFS>
                         <SW-VARIABLE-REFS>
                              <SW-VARIABLE-REF>TST_varStruct</SW-VARIABLE-REF>
                              <SW-VARIABLE-REF>TST_varArray</SW-VARIABLE-REF>
                      </SW-VARIABLE-REFS>
                    </SW-FEATURE-ELEMENTS>
                  </SW-FEATURE-OWNED-ELEMENTS>
                  <SW-FEATURE-INTERFACES>
                    <SW-FEATURE-INTERFACE>
          <CATEGORY>EXPORT</CATEGORY>
          <SHORT-NAME>LIGov_Ex</SHORT-NAME>
                         <SW-INTERFACE-EXPORTS>
                              <SW-INTERFACE-EXPORT>
                                <SW-INTERFACE-EXPORT-SCOPE>
                                     <SW-INTERFACE-EXPORT-LEVEL>global</SW-INTERFACE-EXPORT-LEVEL>
                                </SW-INTERFACE-EXPORT-SCOPE>
                                <SW-FEATURE-ELEMENTS>
                                     <SW-CALPRM-REFS>
                                          <SW-CALPRM-REF>TST_calSimple_C</SW-CALPRM-REF>
                                          <SW-CALPRM-REF>TST_calSimple2_C</SW-CALPRM-REF>
                                     </SW-CALPRM-REFS>
                                     <SW-CLASS-INSTANCE-REFS>
                                          <SW-CLASS-INSTANCE-REF>TST_calClassInstance1</SW-CLASS-INSTANCE-REF>
                                          <SW-CLASS-INSTANCE-REF>TST_calClassInstance2</SW-CLASS-INSTANCE-REF>
                                     </SW-CLASS-INSTANCE-REFS>
                                     <SW-CLASS-REFS>
                                          <SW-CLASS-REF>TST_calClass</SW-CLASS-REF>
                                     </SW-CLASS-REFS>
                                     <SW-SYSTEMCONST-REFS>
                                          <SW-SYSTEMCONST-REF>SYS1</SW-SYSTEMCONST-REF>
                              </SW-SYSTEMCONST-REFS>
                                   <SW-VARIABLE-REFS>
                                        <SW-VARIABLE-REF>TST_varStruct</SW-VARIABLE-REF>
                                        <SW-VARIABLE-REF>TST_varArray</SW-VARIABLE-REF>
                               </SW-VARIABLE-REFS>
                             </SW-FEATURE-ELEMENTS>
                           </SW-INTERFACE-EXPORT>
                      </SW-INTERFACE-EXPORTS>
                 </SW-FEATURE-INTERFACE>
                 <SW-FEATURE-INTERFACE>
                   <SW-INTERFACE-IMPORTS>
                           <SW-INTERFACE-IMPORT>
           <CATEGORY>EXPORT</CATEGORY>
           <SHORT-NAME>LIGov_Ex</SHORT-NAME>
                             <SW-FEATURE-ELEMENTS>
                                  <SW-CALPRM-REFS>
                                       <SW-CALPRM-REF>IMP_calImport_C</SW-CALPRM-REF>
                                  </SW-CALPRM-REFS>
                                  <SW-VARIABLE-REFS>
                                       <SW-VARIABLE-REF>IMP_varImport1</SW-VARIABLE-REF>
                                       <SW-VARIABLE-REF>IMP_varImport2N40</SW-VARIABLE-REF>
                                  </SW-VARIABLE-REFS>
                             </SW-FEATURE-ELEMENTS>
                           </SW-INTERFACE-IMPORT>
                      </SW-INTERFACE-IMPORTS>
              </SW-FEATURE-INTERFACE>
            </SW-FEATURE-INTERFACES>
    </SW-FEATURE>
Example for the software component ( <SW-FEATURE> ) Low Idle Governer with owned elements and interfaces.
Formal Description
Within context of: | SW-COMPONENTS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-SYSCOND, SW-FEATURE-VARIANT, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-FULFILS, SW-FEATURE-DESIGN-DATA, SW-EFFECT-FLOWS, SW-FEATURE-VARIABLES, SW-FEATURE-PARAMS, SW-FEATURE-CLASS-INSTANCES, SW-FEATURE-SERVICES, SW-SYSTEMCONST-REFS, SW-DATA-DICTIONARY-SPEC, SW-TEST-DESC, SW-APPLICATION-NOTES, SW-MAINTENANCE-NOTES, SW-CARB-DOC, SW-FEATURE-DECOMPOSITION, SW-FEATURE-VARIANT-OF, SW-AR-RELATIONS, SW-FEATURE-OWNED-ELEMENT-SETS, SW-FEATURE-OWNED-ELEMENTS, SW-FEATURE-INTERFACES, ANNOTATIONS, ADD-INFO
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-FEATURE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | CHAPTER DEF-ITEM FIGURE FORMULA PRM SDG STD SW-ADDR-METHOD SW-AXIS-TYPE SW-BASE-TYPE SW-CALPRM SW-CALPRM-PROTOTYPE SW-CLASS SW-CLASS-ATTR-IMPL SW-CLASS-INSTANCE SW-CLASS-PROTOTYPE SW-CODE-SYNTAX SW-COMPU-METHOD SW-DATA-CONSTR SW-FEATURE-INTERFACE SW-FEATURE-VARIANT SW-GENERIC-AXIS-PARAM-TYPE SW-RECORD-LAYOUT SW-SERVICE SW-SERVICE-ARG SW-SERVICE-PROTOTYPE SW-SERVICE-RETURN SW-SYSTEMCONST SW-TEMPLATE SW-UNIT SW-VARIABLE SW-VARIABLE-PROTOTYPE SYNOPSIS TABLE TOPIC XDOC XFILE XREF-TARGET | Fixed Namespace. This attribute is assigned to elements which define a namespace for linkable objects. The attribute contains a list of elements, where the element carrying the attribute serves as a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names including the namespaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')


2.454. SW-FEATURE-CLASS-INSTANCES

Description
Container element for <SW-FEATURE-EXPORT-CLASS-INSTANCES>, <SW-FEATURE-IMPORT-CLASS-INSTANCES>, <SW-FEATURE-LOCAL-CLASS-INSTANCES> .
Example
Formal Description
Within context of: | SW-CLASS, SW-FEATURE
Is context for: | SW-FEATURE-EXPORT-CLASS-INSTANCES, SW-FEATURE-IMPORT-CLASS-INSTANCES, SW-FEATURE-LOCAL-CLASS-INSTANCES


2.455. SW-FEATURE-DECOMPOSITION

Description
This element allows a hierarchy to be drawn from the functional description of software, in that a <SW-FEATURE> is composed through a reference to other components. A process sequence can also be specified in this composition (see <SW-SUBCOMPONENT> ).
Example
 <SW-FEATURE>
                   <SHORT-NAME>Zusammegesetztes Feature</SHORT-NAME>
                   <SW-FEATURE-DECOMPOSITION>
                      <SW-SUBCOMPONENT>
                         <SW-FEATURE-REF>SF1</SW-FEATURE-REF>
                         <SW-PROCESSES>
                            <SW-PROCESS>
                               <SHORT-LABEL>Initialisierung</SHORT-LABEL>
                               <SW-TASK-REF>init</SW-TASK-REF>
                            </SW-PROCESS>
                            <SW-PROCESS>
                               <SHORT-LABEL>Zeitscheibe 1</SHORT-LABEL>
                               <SW-TASK-REF>10msec</SW-TASK-REF>
                            </SW-PROCESS>
                         </SW-PROCESSES>
                      </SW-SUBCOMPONENT>
                   </SW-FEATURE-DECOMPOSITION>
                </SW-FEATURE>
Formal Description
Within context of: | SW-FEATURE
Is context for: | SW-SUBCOMPONENT


2.456. SW-FEATURE-DEF

Description
This element contains the textual definition of a software function <SW-FEATURE> .
Example
Formal Description
Within context of: | SW-CLASS, SW-FEATURE
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.457. SW-FEATURE-DESC

Description
This element contains the textual description of a software function <SW-FEATURE> .
Example
Formal Description
Within context of: | SW-CLASS, SW-FEATURE
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.458. SW-FEATURE-DESIGN-DATA

Description
At the time of software system development, although the variables and calibration parameters are known, the implemetation details and system distribution are not. (i.e. which characteristic variables are to be declared where, which are to be exported or imported). It is therefore possible to describe the logical information flow <SW-FEATURE-DESIGN-DATA>, without taking the distribution of declarations into account. This element is therefore intended for use in the initial software design phase, later becoming obsolte as a result of <SW-FEATURE-VARIABLES>, <SW-FEATURE-CALPRMS> and <SW-FEATURE-CLASS-INSTANCES> .
Example
Formal Description
Within context of: | SW-FEATURE
Is context for: | SW-VARIABLES-READ, SW-VARIABLES-WRITE, SW-VARIABLES-READ-WRITE, SW-FEATURE-LOCAL-PARAMS


2.459. SW-FEATURE-ELEMENTS

Description
Example
Formal Description
Within context of: | SW-FEATURE-OWNED-ELEMENT-SET, SW-FEATURE-OWNED-ELEMENTS, SW-INTERFACE-EXPORT, SW-INTERFACE-IMPORT
Is context for: | CONF-RULE-REFS, SW-ADDR-METHOD-REFS, SW-AXIS-TYPE-REFS, SW-BASE-TYPE-REFS, SW-CALPRM-REFS, SW-CLASS-ATTR-IMPL-REFS, SW-CLASS-INSTANCE-REFS, SW-CLASS-REFS, SW-CODE-SYNTAX-REFS, SW-COMPU-METHOD-REFS, SW-DATA-CONSTR-REFS, SW-FEATURE-INTERFACE-REFS, SW-INSTANCE-REFS, SW-RECORD-LAYOUT-REFS, SW-SERVICE-REFS, SW-SYSTEMCONST-REFS, SW-TASK-REFS, SW-TEMPLATE-REFS, SW-UNIT-REFS, SW-VARIABLE-REFS, SW-VCD-CRITERION-REFS


2.460. SW-FEATURE-EXPORT-CALPRMS

Description
Parameters generated by a function and also made available in other functions, if required.
Example
Formal Description
Within context of: | SW-FEATURE-PARAMS
Is context for: | SW-CALPRM-REF, SW-CALPRM-REF-SYSCOND


2.461. SW-FEATURE-EXPORT-CLASS-INSTANCES

Description
Class instances generated by a function and also made available in other functions, if required.
Example
Formal Description
Within context of: | SW-FEATURE-CLASS-INSTANCES
Is context for: | SW-CLASS-INSTANCE-REF, SW-INSTANCE-REF-SYSCOND


2.462. SW-FEATURE-EXPORT-SERVICES

Description
Example
Formal Description
Within context of: | SW-FEATURE-SERVICES
Is context for: | SW-SERVICE-REF, SW-SERVICE-REF-SYSCOND


2.463. SW-FEATURE-EXPORT-VARIABLES

Description
Output RAM variables, applied in the current function and available in other functions as input variables.
Example
Formal Description
Within context of: | SW-FEATURE-VARIABLES
Is context for: | SW-VARIABLES-READ, SW-VARIABLES-WRITE, SW-VARIABLES-READ-WRITE


2.464. SW-FEATURE-IMPORT-CALPRMS

Description
Parameters generated by a different function and used by the current function.
Example
Formal Description
Within context of: | SW-FEATURE-PARAMS
Is context for: | SW-CALPRM-REF, SW-CALPRM-REF-SYSCOND


2.465. SW-FEATURE-IMPORT-CLASS-INSTANCES

Description
Class instances generated by a different function and used by the current function.
Example
Formal Description
Within context of: | SW-FEATURE-CLASS-INSTANCES
Is context for: | SW-CLASS-INSTANCE-REF, SW-INSTANCE-REF-SYSCOND


2.466. SW-FEATURE-IMPORT-SERVICES

Description
Example
Formal Description
Within context of: | SW-FEATURE-SERVICES
Is context for: | SW-SERVICE-REF, SW-SERVICE-REF-SYSCOND


2.467. SW-FEATURE-IMPORT-VARIABLES

Description
RAM variables generated by a different function and made available as an output.
Example
Formal Description
Within context of: | SW-FEATURE-VARIABLES
Is context for: | SW-VARIABLES-READ, SW-VARIABLES-WRITE, SW-VARIABLES-READ-WRITE


2.468. SW-FEATURE-INTERFACE

Description
A <SW-FEATURE-INTERFACE> is used to describe a interface of a software component (<SW-FEATURE>). It may contain up to 3 different kinds of interfaces: An export interface <SW-INTERFACE-EXPORTS>, an import interface <SW-INTERFACE-IMPORT> and an access interface <SW-INTERFACE-ACCESSED-ELEMENT-SETS>.
Example
The following example shows two interfaces, one containing an export interface and one containing two import interfaces.
If these two interfaces belong to a software component (<SW-FEATURE>) called Emil, Emil exports a function (<SW-SERVICE>) called Emil_Func and a variable (<SW-VARIABLE>) called EMIL_Var1. These exported elements are visible in his parent component and their descendants, due to the scope level PARENT. To fullfill its task the component Emil needs (imports) the variables Max_Var1, Moritz_Var3 and Max_Var2.
<SW-FEATURE-INTERFACE>
  <SHORT-NAME>Emil_Export</SHORT-NAME>
  <CATEGORY>EXPORT</CATEGORY>
  <SW-INTERFACE-EXPORTS>
    <SW-INTERFACE-EXPORT>
      <SW-INTERFACE-EXPORT-SCOPE>
        <SW-INTERFACE-EXPORT-LEVEL>PARENT</SW-INTERFACE-EXPORT-LEVEL>
      </SW-INTERFACE-EXPORT-SCOPE>
      <SW-FEATURE-ELEMENTS>
        <SW-SERVICE-REFS>
          <SW-SERVICE-REF>Emil_Func</SW-SERVICE-REF>
        </SW-SERVICE-REFS>
        <SW-VARIABLE-REFS>
          <SW-VARIABLE-REF>Emil_Var1</SW-VARIABLE-REF>
        </SW-VARIABLE-REFS>
      </SW-FEATURE-ELEMENTS>
    </SW-INTERFACE-EXPORT>
  </SW-INTERFACE-EXPORTS>
</SW-FEATURE-INTERFACE>

<SW-FEATURE-INTERFACE>
  <SHORT-NAME>Emil_Import</SHORT-NAME>
  <CATEGORY>IMPORT</CATEGORY>
  <SW-INTERFACE-IMPORTS>
    <SW-INTERFACE-IMPORT>
      <SW-FEATURE-ELEMENTS>
        <SW-VARIABLE-REFS>
          <SW-VARIABLE-REF>Max_Var1</SW-VARIABLE-REF>
          <SW-VARIABLE-REF>Moritz_Var3</SW-VARIABLE-REF>
        </SW-VARIABLE-REFS>
      </SW-FEATURE-ELEMENTS>
    </SW-INTERFACE-IMPORT>
    <SW-INTERFACE-IMPORT>
      <SW-FEATURE-ELEMENTS>
        <SW-VARIABLE-REFS>
          <SW-VARIABLE-REF>Max_Var2</SW-VARIABLE-REF>
        </SW-VARIABLE-REFS>
      </SW-FEATURE-ELEMENTS>
    </SW-INTERFACE-IMPORT>
  </SW-INTERFACE-IMPORTS>
</SW-FEATURE-INTERFACE>
Formal Description
Within context of: | SW-FEATURE-INTERFACES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-SYSCOND, SW-INTERFACE-EXPORTS, SW-INTERFACE-IMPORTS, SW-INTERFACE-ACCESSED-ELEMENT-SETS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-FEATURE-INTERFACE |


2.469. SW-FEATURE-INTERFACE-REF

Description
Example
Formal Description
Within context of: | SW-FEATURE-INTERFACE-REF-SYSCOND, SW-FEATURE-INTERFACE-REFS, SW-INTERFACE-ACCESSED-ELEMENT-SET
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-FEATURE-INTERFACE |
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF |
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK |


2.470. SW-FEATURE-INTERFACE-REF-SYSCOND

Description
Example
Formal Description
Within context of: | SW-FEATURE-INTERFACE-REFS
Is context for: | SW-FEATURE-INTERFACE-REF, SW-SYSCOND


2.471. SW-FEATURE-INTERFACE-REFS

Description
Example
Formal Description
Within context of: | SW-FEATURE-ELEMENTS
Is context for: | SW-FEATURE-INTERFACE-REF, SW-FEATURE-INTERFACE-REF-SYSCOND


2.472. SW-FEATURE-INTERFACES

Description
Container element for <SW-FEATURE-INTERFACE> .
Example
Formal Description
Within context of: | SW-CLASS, SW-FEATURE
Is context for: | SW-FEATURE-INTERFACE


2.473. SW-FEATURE-LOCAL-CLASS-INSTANCES

Description
Class instances generated in the current function, which cannot be used in other functions.
Example
Formal Description
Within context of: | SW-FEATURE-CLASS-INSTANCES
Is context for: | SW-CLASS-INSTANCE-REF, SW-INSTANCE-REF-SYSCOND


2.474. SW-FEATURE-LOCAL-PARAMS

Description
Parameters applied in the current function, which cannot be used in other functions.
Example
Formal Description
Within context of: | SW-FEATURE-DESIGN-DATA, SW-FEATURE-PARAMS
Is context for: | SW-CALPRM-REF, SW-CALPRM-REF-SYSCOND


2.475. SW-FEATURE-LOCAL-SERVICES

Description
Example
Formal Description
Within context of: | SW-FEATURE-SERVICES
Is context for: | SW-SERVICE-REF, SW-SERVICE-REF-SYSCOND


2.476. SW-FEATURE-LOCAL-VARIABLES

Description
Variables applied in the current function, which cannot be used in other functions.
Example
Formal Description
Within context of: | SW-FEATURE-VARIABLES
Is context for: | SW-VARIABLES-READ-WRITE


2.477. SW-FEATURE-MODEL-ONLY-VARIABLES

Description
This element describes variables that only exist in simulation models and do not exist in a real ECU. This usually involves virtual variables (i.e. with <SW-IS-VIRTUAL> ).
Example
Formal Description
Within context of: | SW-FEATURE-VARIABLES
Is context for: | SW-VARIABLE-REF


2.478. SW-FEATURE-OWNED-ELEMENT-SET

Description
This element specifies a set of elenents being "owned" by a particular software component (represented as <SW-FEATURE> ). This feature is responsible e.g. for allcoation of memory (of e.g. variables) or for the definition of the computation method etc. Elements owned by a particular components are usually imported by other components in order to access resp. to use it.
There might be sets of owned elements which are dependant on <SW-SYSCOND> . Therefore within one component there might be multiple sets.
This element replaces the deprecated SW-FEATURE-OWNED-ELEMENTS which did not have the option to created sets of <SW-SYSCOND> dependant owned elements.
Example
Formal Description
Within context of: | SW-FEATURE-OWNED-ELEMENT-SETS
Is context for: | DESC, SW-SYSCOND, SW-FEATURE-ELEMENTS


2.479. SW-FEATURE-OWNED-ELEMENT-SETS

Description
Example
Formal Description
Within context of: | SW-CLASS, SW-FEATURE
Is context for: | SW-FEATURE-OWNED-ELEMENT-SET


2.480. SW-FEATURE-OWNED-ELEMENTS

Description
Example
Formal Description
Within context of: | SW-CLASS, SW-FEATURE
Is context for: | SW-FEATURE-ELEMENTS


2.481. SW-FEATURE-PARAMS

Description
This element declares parameters generated by a different function <SW-FEATURE> .
Example
Formal Description
Within context of: | SW-CLASS, SW-FEATURE
Is context for: | SW-FEATURE-EXPORT-CALPRMS, SW-FEATURE-IMPORT-CALPRMS, SW-FEATURE-LOCAL-PARAMS


2.482. SW-FEATURE-REF

Description
This element references a SW-function <SW-FEATURE> .
Example
Formal Description
Within context of: | CONF-SOURCE, SW-AR-RELATION, SW-FEATURE-REF-SYSCOND, SW-FEATURE-REFS, SW-INSTANCE, SW-INSTANCE-TREE, SW-ROOT-FEATURES, SW-SUBCOMPONENT
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-FEATURE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.483. SW-FEATURE-REF-SYSCOND

Description
Example
Formal Description
Within context of: | SW-FEATURE-REFS
Is context for: | SW-FEATURE-REF, SW-SYSCOND


2.484. SW-FEATURE-REFS

Description
Container element for <SW-FEATURE-REF> .
Example
Formal Description
Within context of: | SW-COLLECTION-CONT, SW-INTERFACE-EXPORT-SCOPE
Is context for: | SW-FEATURE-REF, SW-FEATURE-REF-SYSCOND


2.485. SW-FEATURE-SERVICES

Description
Example
Formal Description
Within context of: | SW-FEATURE
Is context for: | SW-FEATURE-EXPORT-SERVICES, SW-FEATURE-IMPORT-SERVICES, SW-FEATURE-LOCAL-SERVICES


2.486. SW-FEATURE-VARIABLES

Description
This element declares variables generated by a different function <SW-FEATURE> .
Example
Formal Description
Within context of: | SW-CLASS, SW-FEATURE
Is context for: | SW-FEATURE-EXPORT-VARIABLES, SW-FEATURE-IMPORT-VARIABLES, SW-FEATURE-LOCAL-VARIABLES, SW-FEATURE-MODEL-ONLY-VARIABLES


2.487. SW-FEATURE-VARIANT

Description
Das Tag <SW-FEATURE-VARIANT> enthält Informationen um Varianten von SW-Komponenten eindeutig zu identifizieren. Mit dem <SHORT-NAME> in diesem Tag lässt sich eine Variante einer SW-Komponente eindeutig identifizieren (unique name). Dies wird benötigt da alle Varianten einer SW-Komponente denselben <SHORT-NAME> unter <SW-FEATURE> haben (common name).
The unique name of a SW-Component is the case sensitive unique identifier of a SW-Component in the name space of the software system. If the SW-Component is not a variant, then unique name and common name of this SW-Component are identical.
Example
     <SW-FEATURE>
                <SHORT-NAME>Engine</SHORT-NAME>
                <CATEGORY>FCT</CATEGORY>
    <SW-FEATURE-VARIANT>
      <SHORT-NAME>Engine_Diesel</SHORT-NAME>
    </SW-FEATURE-VARIANT>
This example defines a sw component with a unique name Engine_Diesel which is a variant of the sw component with the common name Engine.
Formal Description
Within context of: | SW-FEATURE
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-FEATURE-VARIANT |
[F-NAMESPACE] fixed value | SGML string (NMTOKEN) | SW-FEATURE-VARIANT |


2.488. SW-FEATURE-VARIANT-OF

Description
This element serves as a reference to the unique label of a SW-Component variant, namely to the <SW-FEATURE>/<SW-FEATURE-VARIANT>/<SHORT-NAME>. More information can be found in the use case specification for ArComp.
Example
Formal Description
Within context of: | SW-FEATURE
Is context for: | SW-SYSCOND, SW-FEATURE-VARIANT-REF


2.489. SW-FEATURE-VARIANT-REF

Description
Is part of <SW-FEATURE-VARIANT-OF >. Please look at description there.
Example
Formal Description
Within context of: | SW-AR-RELATION, SW-FEATURE-VARIANT-OF, SW-SUBCOMPONENT
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-FEATURE-VARIANT |
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF |
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK |


2.490. SW-FILL-CHARACTER

Description
Filler character for text parameter to pad up to the maximum length <SW-CALPRM-MAX-TEXT-SIZE> in the parent element <SW-CALPRM-TEXT> .
Example
Formal Description
Within context of: | SW-CALPRM-TEXT
Is context for: | Text


2.491. SW-FULFILS

Description
With this element, references are specified to the requirements fulfilled with the existing feature. Here, there are two possibilities:
  • <FUNCTION-REF> on the behaviour of system functions in MSRSYS.DTD -instances
  • References to requirements via <REQUIREMENT-REF> , which occur in the same MSRSW-instance, but which can also be described in an external document.
Example
See 2.482. SW-FEATURE-REF
Formal Description
Within context of: | SW-CLASS, SW-FEATURE
Is context for: | FUNCTION-REF, REQUIREMENT-REF


2.492. SW-GENERIC-AXIS-DESC

Description
This element contains an axis description in text form for a <SW-AXIS-TYPE> .
Example
Formal Description
Within context of: | SW-AXIS-TYPE
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE


2.493. SW-GENERIC-AXIS-PARAM

Description
This element describes a specific parameter of a generic axis. For this parameter, the following must be specified:
  • The name of the parameter; implemented here through a reference ( <SW-GENERIC-AXIS-PARAM-TYPE-REF>) to a parameter defined on a corresponding axis type. This is contained in the sister element <SW-AXIS-TYPE-REF> of the corresponding <SW-GENERIC-AXIS-PARAMS> element.
    Caution
    References can only be made to axis parameters, defined within the referenced axis type.
  • The value of the parameter, specified in the element <VF> .
Example
Formal Description
Within context of: | SW-GENERIC-AXIS-PARAMS
Is context for: | SW-GENERIC-AXIS-PARAM-TYPE-REF, VF


2.494. SW-GENERIC-AXIS-PARAM-TYPE

Description
This element describes a generic axis type which contains:
  • Plausibility checks can be specified ( <SW-DATA-CONSTR-REF> ).
  • Textual description ( <DESC> ), as a formal description is not of any use, due to the large variety of possibilities.
  • If this parameter contains structures, these can be simulated through the recursive use of <SW-GENERIC-AXIS-PARAM-TYPES> .
Example
Formal Description
Within context of: | SW-GENERIC-AXIS-PARAM-TYPE, SW-GENERIC-AXIS-PARAM-TYPES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-DATA-CONSTR-REF, SW-GENERIC-AXIS-PARAM-TYPE
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-GENERIC-AXIS-PARAM-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.495. SW-GENERIC-AXIS-PARAM-TYPE-REF

Description
This element references <SW-GENERIC-AXIS-PARAM-TYPE> .
Example
Formal Description
Within context of: | SW-GENERIC-AXIS-PARAM, SW-RECORD-LAYOUT-GROUP, SW-RECORD-LAYOUT-V
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-GENERIC-AXIS-PARAM-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.496. SW-GENERIC-AXIS-PARAM-TYPES

Description
Container element for <SW-GENERIC-AXIS-PARAM-TYPE> .
Example
Formal Description
Within context of: | SW-AXIS-TYPE
Is context for: | SW-GENERIC-AXIS-PARAM-TYPE


2.497. SW-GENERIC-AXIS-PARAMS

Description
Container element for <SW-GENERIC-AXIS-PARAM> .
Example
Formal Description
Within context of: | SW-AXIS-GENERIC
Is context for: | SW-GENERIC-AXIS-PARAM


2.498. SW-GLOSSARY

Description
The function of this element is to compile a glossary. This is in the context of inputting a fixed chapter in the ECU documentation, which appears in a glossary.
Example
Formal Description
Within context of: | MSRSW
Is context for: | NA, TBD, TBR, INTRODUCTION, ADMIN-DATA, NCOI-1


2.499. SW-HOST-VARIABLE

Description
This element contains a reference <SW-VARIABLE-REF> to a variable, which serves as a host-variable for a bit variable <SW-BIT-REPRESENTATION> .
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | SW-VARIABLE-REF


2.500. SW-IMPL-POLICY

Description
<SW-IMPL-POLICY> enables the specification of an implementation strategy. In this way, the direction of the implementation to come, can be specified in advance in an earlier phase. The contents of the element comprise of a key word which is to be declared in the process. Examples of possible values are
  • MEMORY_OPTIMIZED
  • CPU-OPTIMIZED
  • INPLACE
  • SINGLE-INSTANCE
  • MULTI-INSTANCE
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS, SW-SERVICE-PROPS
Is context for: | Text


2.501. SW-INSTANCE

Description
A <SW-INSTANCE> indicates instance-specific information. If a variable or scalar parameter is specified, the subelement <SHORT-NAME> has to be populated, if a parameter array is specified, the <SW-ARRAY-INDEX> has to be populated.
<SW-INSTANCE> represents one particular calibration item and therefore corresponds to CAL-ITEM in CDF.
Example
<SW-INSTANCE>
                   <LONG-NAME>faule Bären aus München (Viktualienmarkt)</LONG-NAME>
                   <SHORT-NAME>FBAM_V</SHORT-NAME>
                   <CATEGORY>curve_individual</CATEGORY>
                   <SW-INSTANCE-PROPS-VARIANTS>
                      <SW-INSTANCE-PROPS-VARIANT>
                         <SW-AXIS-CONTS>
                            <SW-AXIS-CONT>
                               <SW-UNIT-REF>grad_040C</SW-UNIT-REF>
                               <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
                               <SW-VALUES-PHYS>
                                  <V>-35.6</V>
                                  <V>-32.0</V>
                                  <V>-24.9</V>
                                  <V>-21.3</V>
                                  <V>-18.4</V>
                                  <V>-15.5</V>
                                  <V>-14.1</V>
                                  <V>3.9</V>
                                  <V>21.8</V>
                                  <V>39.8</V>
                               </SW-VALUES-PHYS>
                            </SW-AXIS-CONT>
                            <SW-AXIS-CONT>
                               <SW-UNIT-REF>km_pro_h</SW-UNIT-REF>
                               <SW-AXIS-INDEX>0</SW-AXIS-INDEX>
                               <SW-VALUES-PHYS>
                                  <V>0.00</V>
                                  <V>3.63</V>
                                  <V>3.75</V>
                                  <V>3.88</V>
                                  <V>3.94</V>
                                  <V>4.06</V>
                                  <V>4.13</V>
                                  <V>4.25</V>
                                  <V>4.69</V>
                                  <V>5.25</V>
                               </SW-VALUES-PHYS>
                            </SW-AXIS-CONT>
                         </SW-AXIS-CONTS>
                         <SW-CS-HISTORY>
                            <SW-CS-ENTRY>
                               <SW-CS-STATE>calibrated</SW-CS-STATE>
                               <SW-CS-CONTEXT>development of demo version</SW-CS-CONTEXT>
                               <SW-CS-PROJECT-INFO>Demo-Project CDF / ASAM-MCD-2D</SW-CS-PROJECT-INFO>
                               <SW-CS-TARGET-VARIANT>automatic gear</SW-CS-TARGET-VARIANT>
                               <SW-CS-TEST-OBJECT>Vehicle: S-Nn-4455</SW-CS-TEST-OBJECT>
                               <SW-CS-PROGRAM-IDENTIFIER>67985</SW-CS-PROGRAM-IDENTIFIER>
                               <SW-CS-DATA-IDENTIFIER>67985:123.4</SW-CS-DATA-IDENTIFIER>
                               <SW-CS-PERFORMED-BY>Weichel</SW-CS-PERFORMED-BY>
                               <REMARK>
                                  <P>Note that we did not really calibrate this. The current structure is for demonstration purposes only. </P>
                               </REMARK>
                               <DATE>18.05.2001T13.23</DATE>
                               <SW-CS-FIELD SI="feeling">We did feel good while doing this stuff.</SW-CS-FIELD>
                            </SW-CS-ENTRY>
                         </SW-CS-HISTORY>
                      </SW-INSTANCE-PROPS-VARIANT>
                   </SW-INSTANCE-PROPS-VARIANTS>
                </SW-INSTANCE>
Formal Description
Within context of: | SW-INSTANCE, SW-INSTANCE-TREE
Is context for: | LONG-NAME, SHORT-NAME, SW-ARRAY-INDEX, DESC, CATEGORY, ADMIN-DATA, SW-FEATURE-REF, SW-INSTANCE-PROPS-VARIANTS, SW-INSTANCE
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | String (CDATA) | SW-INSTANCE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] fixed value | SGML string (NMTOKEN) | SW-INSTANCE | Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')


2.502. SW-INSTANCE-PROPS-VARIANT

Description
<SW-INSTANCE-PROPS-VARIANT> describes one particular variant of the current calibration item. Since CDF did not request this, there is one and only one variant per calibration item which can be specified.
Example
For an example, see 2.411. SW-CS-HISTORY 2.331. SW-CLASS .
Formal Description
Within context of: | SW-INSTANCE-PROPS-VARIANTS
Is context for: | ADMIN-DATA, DESC, SW-VCD-CRITERION-VALUES, SW-ADDR-INFOS, SW-AXIS-CONTS, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS, SW-MC-INSTANCE-INTERFACES, SW-CS-HISTORY, ANNOTATIONS


2.503. SW-INSTANCE-PROPS-VARIANTS

Description
<SW-INSTANCE-PROPS-VARIANTS> is the container which takes all variants of one particular calibration item.
Example
For an example, see 2.501. SW-INSTANCE 2.331. SW-CLASS .
Formal Description
Within context of: | SW-INSTANCE
Is context for: | SW-INSTANCE-PROPS-VARIANT


2.504. SW-INSTANCE-REF

Description
This element references <SW-INSTANCE> .
Example
Formal Description
Within context of: | CONF-DEFAULT-VALUE, CONF-ITEM, CONF-PRO-VALUE, SW-INSTANCE-REF-SYSCOND, SW-INSTANCE-REFS, SW-MC-BLOB-ECU-DEPOSIT, SW-VALUES-CODED, SW-VALUES-CODED-HEX, SW-VALUES-GENERIC, SW-VALUES-PHYS, VG
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-INSTANCE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.505. SW-INSTANCE-REF-SYSCOND

Description
This element is a conditional reference to a class instance. It is used to ensure that the assignment of class instances to functions is dependent on the settings of system constants. For this reason, the element exists parallel to <SW-INSTANCE-REF> .
Example
Formal Description
Within context of: | SW-FEATURE-EXPORT-CLASS-INSTANCES, SW-FEATURE-IMPORT-CLASS-INSTANCES, SW-FEATURE-LOCAL-CLASS-INSTANCES, SW-INSTANCE-REFS
Is context for: | SW-INSTANCE-REF, SW-SYSCOND


2.506. SW-INSTANCE-REFS

Description
Container element for <SW-INSTANCE-REF> .
Example
Formal Description
Within context of: | SW-COLLECTION-CONT, SW-FEATURE-ELEMENTS
Is context for: | SW-INSTANCE-REF, SW-INSTANCE-REF-SYSCOND


2.507. SW-INSTANCE-SPEC

Description
<SW-INSTANCE-SPEC> is the section within a <SW-SYSTEM> which gathers any information on the instances of data items within the ECU, in particular the calibration items.
As <SW-SYSTEM> does not allow a note or introduction to be placed, the <INTRODUCTION> of <SW-INSTANCE-SPEC> corresponds to NOTE in CAL-LIST specified by CDF .
Example
Formal Description
Within context of: | SW-SYSTEM
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-INSTANCE-TREE, ADD-INFO


2.508. SW-INSTANCE-TREE

Description
The instance tree contains all "real existing" instances, i.e. variables and parameters, that are part of the ECU software. The structure takes the form of a tree (in contrast to ASAM-MCD- 2MC V1.3 where only a flat list is possible) to reflect the natural (e.g. function resp. feature) structure.
<SW-INSTANCE-TREE> receives one particular set of calibration items. Therefore it corresponds to CAL-LIST within the CDF specification.
Example
<SW-INSTANCE-SPEC>
                   <INTRODUCTION>
                      <P>This is the system to demonstrate, how CDF should work.</P>
                   </INTRODUCTION>
                   <SW-INSTANCE-TREE>
                      <SHORT-NAME>Summertest</SHORT-NAME>
                      <SW-INSTANCE>
                         <LONG-NAME>faule Bären aus München (Viktualienmarkt)</LONG-NAME>
                         <SHORT-NAME>FBAM_V</SHORT-NAME> ... </SW-INSTANCE>
                   </SW-INSTANCE-TREE>

                   <SW-INSTANCE-TREE>
                      <SHORT-NAME>Wintertest</SHORT-NAME>
                      <SW-INSTANCE>
                         <LONG-NAME>faule Bären aus München (Viktualienmarkt)</LONG-NAME>
                         <SHORT-NAME>FBAM_V</SHORT-NAME> ... </SW-INSTANCE>
                   </SW-INSTANCE-TREE>
                </SW-INSTANCE-SPEC>
Formal Description
Within context of: | SW-INSTANCE-SPEC
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-CS-HISTORY, SW-VCD-CRITERION-VALUES, SW-FEATURE-REF, SW-INSTANCE
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-INSTANCE-TREE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] fixed value | SGML string (NMTOKEN) | SW-INSTANCE | Fixed Namespace. This attribute is assigned to elements which define a namespace for linkable objects. The attribute contains a list of elements, where the element carrying the attribute serves as a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names including the namespaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')


2.509. SW-INTENDED-RESOLUTION

Description
The purpose of this element is to describe the requested quantization of data objects early on in the design process. The resolution ultimately occurs via the conversion formula present ( <SW-COMPU-METHOD>), which specifies the transition from the physical world to the standardized world (and vice-versa) (here, "the slope per bit" is present implicitly in the conversion formula). In the case of a development phase without a fixed conversion formula, a pre-specification can occur through <SW-INTENDED-RESOLUTION>. If however, a conversion formula is present, this can be checked for plausibility against <SW-INTENDED-RESOLUTION> .
Example
<SW-VARIABLE>
                   <LONG-NAME>Drehzahl</LONG-NAME>
                   <SHORT-NAME>N</SHORT-NAME>
                   <SW-DATA-DEF-PROPS>
                      <SW-INTENDED-RESOLUTION>40</SW-INTENDED-RESOLUTION>
                      <SW-UNIT-REF>upm</SW-UNIT-REF>
                   </SW-DATA-DEF-PROPS>
                </SW-VARIABLE>
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | Text


2.510. SW-INTERFACE-ACCESSED-ELEMENT-SET

Description
Example
Formal Description
Within context of: | SW-INTERFACE-ACCESSED-ELEMENT-SETS
Is context for: | DESC, SW-SYSCOND, SW-ACCESSED-VARIABLES, SW-ACCESSED-CALPRMS, SW-ACCESSED-CLASS-INSTANCES, SW-ACCESSED-SERVICES, SW-FEATURE-INTERFACE-REF


2.511. SW-INTERFACE-ACCESSED-ELEMENT-SETS

Description
Example
Formal Description
Within context of: | SW-FEATURE-INTERFACE
Is context for: | SW-INTERFACE-ACCESSED-ELEMENT-SET


2.512. SW-INTERFACE-EXPORT

Description
Example
Formal Description
Within context of: | SW-INTERFACE-EXPORTS
Is context for: | DESC, SW-SYSCOND, SW-INTERFACE-EXPORT-SCOPE, SW-FEATURE-ELEMENTS


2.513. SW-INTERFACE-EXPORT-LEVEL

Description
Example
Formal Description
Within context of: | SW-INTERFACE-EXPORT-SCOPE
Is context for: | Text


2.514. SW-INTERFACE-EXPORT-SCOPE

Description
Example
Formal Description
Within context of: | CONF-SOURCES-OPTIONAL, CONF-SOURCES-PROHIBITED, CONF-SOURCES-REQUIRED, SW-INTERFACE-EXPORT
Is context for: | SW-INTERFACE-EXPORT-LEVEL, SW-FEATURE-REFS


2.515. SW-INTERFACE-EXPORTS

Description
Container element for <SW-INTERFACE-EXPORT> .
Example
Formal Description
Within context of: | SW-FEATURE-INTERFACE
Is context for: | SW-INTERFACE-EXPORT


2.516. SW-INTERFACE-IMPORT

Description
Example
Formal Description
Within context of: | SW-INTERFACE-IMPORTS
Is context for: | DESC, SW-SYSCOND, SW-FEATURE-ELEMENTS


2.517. SW-INTERFACE-IMPORTS

Description
Example
Formal Description
Within context of: | SW-FEATURE-INTERFACE
Is context for: | SW-INTERFACE-IMPORT


2.518. SW-INTERNAL-CONSTRS

Description
Describes the limitations valid for the standardized values of variables or calibration parameters (as opposed to <SW-PHYS-CONSTRS> ).
Example
Formal Description
Within context of: | SW-DATA-CONSTR-RULE
Is context for: | LOWER-LIMIT, UPPER-LIMIT, SW-SCALE-CONSTRS, SW-MAX-DIFF, SW-MONOTONY, SW-RELATED-CONSTRS


2.519. SW-INTERNAL-CONSTRS-1

Description
This element restricts <SW-INTERNAL-CONSTRS> , to such an extent that only ranges of values can be defined.
Example
Formal Description
Within context of: | SW-COMPU-METHOD
Is context for: | SW-SCALE-CONSTR


2.520. SW-INTERPOLATION-METHOD

Description
This element provides a textual description of the mathematic interpolation method that is to be used.
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | Text


2.521. SW-IS-VIRTUAL

Description
This element distinguishes virtual objects. Virtual objects do not appear in the memory, their derivation is much more dependent on other objects and hence they must have a <SW-DATA-DEPENDENCY> .
Hint
The contents of the element must always be set to the value "yes". More recent versions can also admit other values. The element is given contents to prevent the occurrance of empty elements which are problematic in SGML.
Example
See 2.428. SW-DATA-DEPENDENCY
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | Text


2.522. SW-MAINTENANCE-NOTES

Description
This element describes the absolute value which is provided by the respective function or class, for the generation of the customer service documents.
Example
Formal Description
Within context of: | SW-CLASS, SW-FEATURE
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.523. SW-MAX-AXIS-POINTS

Description
Maximum number of base points contained in the axis of a map or curve.
Example
Formal Description
Within context of: | SW-AXIS-INDIVIDUAL
Is context for: | Text, CONF-ITEM-CODED-REF, CONF-ITEM-PHYS-REF, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF


2.524. SW-MAX-DIFF

Description
Maximum difference that is permitted between two consecutive axis values. .
Hint
These can be used both for value and for input axes. However in the case of input axes, the marginal condition is only given for <SW-AXIS-INDIVIDUAL> . Where group axes are concerned, the restriction is specified at the axis itself, and not at the reference.
Example
Formal Description
Within context of: | SW-INTERNAL-CONSTRS, SW-PHYS-CONSTRS
Is context for: | Text


2.525. SW-MAX-GRADIENT

Description
This element specifies the maximum slope that may be used in maps and curves.
Example
Formal Description
Within context of: | SW-DATA-CONSTR-RULE
Is context for: | Text


2.526. SW-MC-ADDR-MAPPED-SIZE

Description
Size of a remapped address space of the ECU to an access address.
Example
See 2.527. SW-MC-ADDR-MAPPING .
Formal Description
Within context of: | SW-MC-ADDR-MAPPING
Is context for: | Text


2.527. SW-MC-ADDR-MAPPING

Description
Remapping of the address space of the ECU to an access address. This is necessary for special application methods (for example, special address calculation is needed in KWP2000, where only 24 bit addresses are available.)
Example
<SW-MC-ADDR-MAPPING>
                   <SW-MC-ORIGINAL-ADDR>0x4000</SW-MC-ORIGINAL-ADDR>
                   <SW-MC-MAPPED-ADDR>0x8000</SW-MC-MAPPED-ADDR>
                   <SW-MC-ADDR-MAPPED-SIZE>0x0200</SW-MC-ADDR-MAPPED-SIZE>
                </SW-MC-ADDR-MAPPING>
Formal Description
Within context of: | SW-MC-ADDR-MAPPINGS
Is context for: | SW-MC-ORIGINAL-ADDR, SW-MC-MAPPED-ADDR, SW-MC-ADDR-MAPPED-SIZE


2.528. SW-MC-ADDR-MAPPINGS

Description
Container element for <SW-MC-ADDR-MAPPING> .
Example
Formal Description
Within context of: | SW-MC-INSTANCE-INTERFACE
Is context for: | SW-MC-ADDR-MAPPING


2.529. SW-MC-BASE-TYPE

Description
<SW-MC-BASE-TYPE> follows the approach of <SW-BASE-TYPE> .
Example
Formal Description
Within context of: | SW-MC-BASE-TYPES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-BASE-TYPE-SIZE, SW-CODED-TYPE, SW-MEM-ALIGNMENT, BYTE-ORDER, SW-BASE-TYPE-REF
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | String (CDATA) | SW-MC-BASE-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.530. SW-MC-BASE-TYPE-REF

Description
This element references <SW-MC-BASE-TYPE> .
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-MC-BASE-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.531. SW-MC-BASE-TYPES

Description
Container element for <SW-MC-BASE-TYPE> .
Example
Formal Description
Within context of: | SW-MC-COMMUNICATION-SPEC
Is context for: | SW-MC-BASE-TYPE


2.532. SW-MC-BLOB-ECU-DEPOSIT

Description
<SW-MC-BLOB-ECU-DEPOSIT> is the alternative to <SW-MC-BLOB-VALUE> in the parent element, providing the blob is given as the instance of a calibration parameter.
Example
Formal Description
Within context of: | SW-MC-QP-BLOB-CONTS, SW-MC-TP-BLOB-CONTS
Is context for: | SW-INSTANCE-REF


2.533. SW-MC-BLOB-LAYOUTS

Description
Container element for <SW-MC-TP-BLOB-LAYOUT>, <SW-MC-QP-BLOB-LAYOUT>, <SW-MC-KP-BLOB-LAYOUT>, <SW-MC-DP-BLOB-LAYOUT>, <SW-MC-PA-BLOB-LAYOUT> .
Example
Formal Description
Within context of: | SW-MC-INTERFACE
Is context for: | SW-MC-TP-BLOB-LAYOUT, SW-MC-QP-BLOB-LAYOUT, SW-MC-KP-BLOB-LAYOUT, SW-MC-DP-BLOB-LAYOUT, SW-MC-PA-BLOB-LAYOUT


2.534. SW-MC-BLOB-VALUE

Description
<SW-MC-BLOB-VALUE> is the value of the blob given in A2L microsyntax. <SW-MC-BLOB-ECU-DEPOSIT> is the alternative in the parent element, if the blob is given as the instance of a calibration parameter.
Example
Formal Description
Within context of: | SW-MC-QP-BLOB-CONTS, SW-MC-TP-BLOB-CONTS
Is context for: | Text


2.535. SW-MC-COMMUNICATION-SPEC

Description
This corresponds to the BLOB defintion of the A2ML part. It merely comprises of a formal definition of datatypes <SW-MC-SYSTEM-BASE-TYPES> and <SW-MC-INTERFACE-SPEC> specifying BLOB layouts <SW-MC-BLOB-LAYOUTS> . This element is introduced so that the complete information on the interfaces of a module can be assigned to it. In the first step, ASAP 1b compliant MC-Interfaces are assigned. In the future however, other interfaces to the outside world could be modelled here.
Example
Formal Description
Within context of: | MSRSW
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-MC-INTERFACE-SPEC, SW-MC-BASE-TYPES, SW-MC-INTERFACE-IMPLS


2.536. SW-MC-DP-BLOB-CONTS

Description
Data parameter B lob - (BLOB: binary large ob-ject): an interface specific description for accessing a calibration parameter. Any object for which a DP-BLOB exists, can be uploaded and downloaded. It exists for each respective parameter instance. It is a runtime blob.
Example
Formal Description
Within context of: | SW-MC-GENERIC-INTERFACE, SW-MC-INSTANCE-INTERFACE
Is context for: | Text


2.537. SW-MC-DP-BLOB-LAYOUT

Description
This element provides a description in ASAP syntax, of the information relevant for an adjustment system of a data-parameter BLOB layout. This equips the adjustment system with the ability to interpret <SW-MC-DP-BLOB-VALUE> .
Example
Formal Description
Within context of: | SW-MC-BLOB-LAYOUTS
Is context for: | Text


2.538. SW-MC-FRAME

Description
This element represents message frames and associate messages. It is located in the subtree of SW-MC-INTERFACE-IMPL as it is regarded as being interface-specific.
A frame establishes a group of variable references which can be accessed in one step in the MCD system. This group is called "frame" within ASAP.
Example
Formal Description
Within context of: | SW-MC-FRAMES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-REFRESH-TIMING, SW-VARIABLE-REFS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | String (CDATA) | SW-MC-FRAME | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.539. SW-MC-FRAMES

Description
Container element for <SW-MC-FRAME> .
Example
Formal Description
Within context of: | SW-MC-INTERFACE-IMPL
Is context for: | SW-MC-FRAME


2.540. SW-MC-GENERIC-INTERFACE

Description
In ASAM-MCD 1.x a specific configuration is generated for the interfaces to the adjustment system ( <SW-MC-INSTANCE-INTERFACE>) for every variant of a variable or characteristic variable (i.e. for every <SW-INSTANCE>). Very often, information is encrypted in the resulting BLOBs, which is already present in the ASAM-MCD file. This information could perhaps be extracted directly, if more intelligent MCD-System s were to be used.
To support this approach, it is possible to specify in the <SW-MC-GENERIC-INTERFACE> rules, how the instant-specific BLOBS are to be calculated.
Hint
The project partipants must reach a consensus as to the use of this element. The presence of the element enables practical experience to be gathered. Particular outstanding factors include:
Is more than one generic interface description required per MCD interface? If so, in what way can they be distinguished from one another?
Does the generic interface description depend on the structure of the curve/variables?
What language is to be used for the specification of the expressions (e.g. Xpath, JavaScript, Perl ...)?
Example
A generic XML processor could evaluate the information in <SW-MC-GENERIC-INTERFACES> and fill out the <SW-MC-INSTANCE-INTERFACE> in the instance-tree. The Xpath expressions are used in the following example, to calculate the BLOB entries from the basis of a <SW-INSTANCE-PROPS-VARIANT> .
<SW-MC-GENERIC-INTERFACE>
                   <SW-MC-KP-BLOB-CONTS>
                      xpath(SW-ADDR-INFOS/SW-ADDR-INFO/SW-BASE-ADRESS/text()) + xpath(SW-ADDR-INFOS/SW-ADDR-INFO/SW-CPU-MEM-SEG-REF/getAdressType()) + xpath(SW-ADDR-INFOS/SW-SIZE-OF-INSTANCE/text())
                   </SW-MC-KP-BLOB-CONTS>
                   <SW-MC-DP-BLOB-CONTS>
                      xpath(SW-ADDR-INFOS/SW-ADDR-INFO/SW-BASE-ADRESS/text()) + count(SW-AXIS-CONTS1/SW-VALUES-PHYS/*)
                   </SW-MC-DP-BLOB-CONTS>
                </SW-MC-GENERIC-INTERFACE>
Formal Description
Within context of: | SW-MC-GENERIC-INTERFACES
Is context for: | LABEL, SHORT-LABEL, DESC, SW-MC-INTERFACE-DEFAULT-SOURCE, SW-MC-INTERFACE-AVL-SOURCES, SW-MC-KP-BLOB-CONTS, SW-MC-DP-BLOB-CONTS, SW-MC-PA-BLOB-CONTS


2.541. SW-MC-GENERIC-INTERFACES

Description
Container element for <SW-MC-GENERIC-INTERFACE> .
Example
Formal Description
Within context of: | SW-MC-INTERFACE-IMPL
Is context for: | SW-MC-GENERIC-INTERFACE


2.542. SW-MC-INSTANCE-INTERFACE

Description
This element describes a data record for describing the interface-specific description data used at ASAP1b device. The parameters associated with this keyword are described in the ASAP2 metalanguage (in short A2ML) by the control unit supplier or the interface module supplier.
Example
Formal Description
Within context of: | SW-MC-INSTANCE-INTERFACES
Is context for: | SW-MC-INTERFACE-REF, SW-MC-INTERFACE-DEFAULT-SOURCE, SW-MC-INTERFACE-AVL-SOURCES, SW-MC-KP-BLOB-CONTS, SW-MC-DP-BLOB-CONTS, SW-MC-PA-BLOB-CONTS, SW-MC-ADDR-MAPPINGS


2.543. SW-MC-INSTANCE-INTERFACES

Description
Container element for <SW-MC-INSTANCE-INTERFACES> .
Example
Formal Description
Within context of: | SW-CPU-MEM-SEG, SW-INSTANCE-PROPS-VARIANT
Is context for: | SW-MC-INSTANCE-INTERFACE


2.544. SW-MC-INTERFACE

Description
<SW-MC-INTERFACE> describes the structure of a specific interface between the ECU and the MCD-System. For the most part, this structure is described through the layout of the BLOBS used, i.e. through the layout of the information required for the configuration of the MCD-Systems, for the interface concerned.
Example
Formal Description
Within context of: | SW-MC-INTERFACE-SPEC
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-MC-BLOB-LAYOUTS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | String (CDATA) | SW-MC-INTERFACE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.545. SW-MC-INTERFACE-AVL-SOURCES

Description
This element provides the available sources referenced by <SW-MC-INTERFACE-SOURCE-REF> .
Example
Formal Description
Within context of: | SW-MC-GENERIC-INTERFACE, SW-MC-INSTANCE-INTERFACE
Is context for: | SW-MC-INTERFACE-SOURCE-REF


2.546. SW-MC-INTERFACE-DEFAULT-SOURCE

Description
Interfaces to variables and parameters may have a default source specified in <SW-MC-INTERFACE-DEFAULT-SOURCE>. This must be one of the available sources specified in <SW-MC-INTERFACE-AVL-SOURCES> . This supports the fact that the user of an MCD system may change the source during runtime, if the variable or the parameter is submitted in multiple source communication. If this is carried out to its full extent, a large amount of data will be generated.
Example
Formal Description
Within context of: | SW-MC-GENERIC-INTERFACE, SW-MC-INSTANCE-INTERFACE
Is context for: | SW-MC-INTERFACE-SOURCE-REF


2.547. SW-MC-INTERFACE-IMPL

Description
This element comprises of the actual blob data which represents the actual implementation of a particular interface. It consists of the driver-specific BLOB in <SW-MC-TP-BLOB-CONTS>. In addition to this, the sources provided by the interface are specified in <SW-SYSTEM-MC-INTERFACE-SOURCES> .
Example
Formal Description
Within context of: | SW-MC-INTERFACE-IMPLS
Is context for: | ADMIN-DATA, SW-MC-INTERFACE-REF, SW-MC-TP-BLOB-CONTS, SW-MC-GENERIC-INTERFACES, SW-MC-INTERFACE-SOURCES, SW-MC-FRAMES


2.548. SW-MC-INTERFACE-IMPLS

Description
Container element for <SW-MC-INTERFACE-IMPL> .
Example
Formal Description
Within context of: | SW-MC-COMMUNICATION-SPEC
Is context for: | SW-MC-INTERFACE-IMPL


2.549. SW-MC-INTERFACE-REF

Description
This element references <SW-MC-INTERFACE> and designates the MCD interface, for which the information specified in the context element is valid.
Example
Formal Description
Within context of: | SW-MC-INSTANCE-INTERFACE, SW-MC-INTERFACE-IMPL
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-MC-INTERFACE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.550. SW-MC-INTERFACE-SOURCE

Description
This source can be understood as being a channel which provides access to data within a certain time interval for that particular interface. It is possibble for different sources to exist within different interfaces. A default souce ( <SW-SYSTEM-MC-INTERFACE-DEFAULT-SOURCE>) is available, which was not present in ASAM-MCD-2MC. This makes it easier for the user to specify a source each time he wishes to access specific data. <REFRESH-TIMING> describes the maximum update rate for different interface sources.
Example
Formal Description
Within context of: | SW-MC-INTERFACE-SOURCES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-REFRESH-TIMING, SW-MC-QP-BLOB-CONTS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | String (CDATA) | SW-MC-INTERFACE-SOURCE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.551. SW-MC-INTERFACE-SOURCE-REF

Description
This element references <SW-MC-INTERFACE-SOURCE> .
Example
Formal Description
Within context of: | SW-MC-INTERFACE-AVL-SOURCES, SW-MC-INTERFACE-DEFAULT-SOURCE
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-MC-INTERFACE-SOURCE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.552. SW-MC-INTERFACE-SOURCES

Description
Container element for <SW-MC-INTERFACE-SOURCE> .
Example
Formal Description
Within context of: | SW-MC-INTERFACE-IMPL
Is context for: | SW-MC-INTERFACE-SOURCE


2.553. SW-MC-INTERFACE-SPEC

Description
This element specifies interfaces to a MCD-system (Measurement, Calibration and Diagnostic systems) mainly in terms of
  • basic data types for MCD communication ( <SW-MCD-BASE-TYPES> )
  • layout of the blobs ( <SW-MC-BLOB-LAYOUTS> )
  • data sources (SW-MC-)
Example
Formal Description
Within context of: | SW-MC-COMMUNICATION-SPEC
Is context for: | ADMIN-DATA, SW-MC-INTERFACE


2.554. SW-MC-KP-BLOB-CONTS

Description
Channel P arameter - an interface-specific description for accessing software variables. It exists for each variable instance. It is a runtime blob and is used to transfer individual channel parameters.
Example
Formal Description
Within context of: | SW-MC-GENERIC-INTERFACE, SW-MC-INSTANCE-INTERFACE
Is context for: | Text


2.555. SW-MC-KP-BLOB-LAYOUT

Description
This element provides a description in ASAP syntax, of the information relevant for an adjustment system of a channel parameter BLOB layout. This equips the editing system with the ability to interpret <SW-MC-KP-BLOB-VALUE> .
Example
Formal Description
Within context of: | SW-MC-BLOB-LAYOUTS
Is context for: | Text


2.556. SW-MC-MAPPED-ADDR

Description
This specifies the remapped address of the ECU to an access address. This is required for special application methods (for example, special address calculation is needed in KWP2000, where only 24 bit addresses are available.)
Example
See 2.527. SW-MC-ADDR-MAPPING
Formal Description
Within context of: | SW-MC-ADDR-MAPPING
Is context for: | Text


2.557. SW-MC-ORIGINAL-ADDR

Description
Original address of the ECU address space which was remapped to an access address. This is required for special application methods (for example, special address calculation is necessary in KWP2000, where only 24 bit addresses are available.)
Example
See 2.527. SW-MC-ADDR-MAPPING .
Formal Description
Within context of: | SW-MC-ADDR-MAPPING
Is context for: | Text


2.558. SW-MC-PA-BLOB-CONTS

Description
This element describes information in ASAP-Syntax for any special parameters that are required for this service. These are given in ASAP-Syntax.
Example
Formal Description
Within context of: | SW-MC-GENERIC-INTERFACE, SW-MC-INSTANCE-INTERFACE
Is context for: | Text


2.559. SW-MC-PA-BLOB-LAYOUT

Description
This element provides a description in ASAP syntax, of the information relevant for an editing system of a parameter-accessor BLOB layout. This equips the editing system with the ability to interpret <SW-MC-PA-BLOB-VALUE> .
Example
Formal Description
Within context of: | SW-MC-BLOB-LAYOUTS
Is context for: | Text


2.560. SW-MC-QP-BLOB-CONTS

Description
Source P arameter - describes the different channels for the acquisition of data such as measurements in the MCD system. It exists exactly once per interval and is used at initialization.
<SW-MC-BLOB-VALUE> is the value of the blob given in A2L microsyntax. <SW-MC-BLOB-ECU-DEPOSIT> is the alternative, if the blob is given as the instance of a calibration parameter.
Example
Formal Description
Within context of: | SW-MC-INTERFACE-SOURCE
Is context for: | SW-MC-BLOB-VALUE, SW-MC-BLOB-ECU-DEPOSIT


2.561. SW-MC-QP-BLOB-LAYOUT

Description
This element provides a description of the information relevant for an editing system of a source-parameter BLOB layout. This equips the editing system with the ability to interpret <SW-MC-QP-BLOB-VALUE> .
Example
Formal Description
Within context of: | SW-MC-BLOB-LAYOUTS
Is context for: | Text


2.562. SW-MC-TP-BLOB-CONTS

Description
Driver P arameter - specifies driver specific information in the interface. Usually a TP-BLOB is available for each interface, present for each one supported by the ECU. This is used at initialization.
<SW-MC-BLOB-VALUE> is the value of the blob given in A2L microsyntax. <SW-MC-BLOB-ECU-DEPOSIT> is the alternative, if the blob is given as the instance of a calibration parameter.
As with any other blob contents, this comprises of a sequence of blob values ( <SW-MC-BLOB-VALUE>) . The blob contents must match the <SW-MC-TP-BLOB-LAYOUT> .
This element is used to transfer specific parameterization and preparation values, the contents of which are not known to the higher-ranking coordinator and which can only be passed on by the latter. BLOBs generally originate from ASAP2 and are generated by the application.
Example
Formal Description
Within context of: | SW-MC-INTERFACE-IMPL
Is context for: | SW-MC-BLOB-VALUE, SW-MC-BLOB-ECU-DEPOSIT


2.563. SW-MC-TP-BLOB-LAYOUT

Description
This element provides a description in ASAP syntax, of the information relevant for an editing system of a driver-parameter BLOB layout. This equips the editing system with the ability to interpret <SW-MC-TP-BLOB-VALUE> .
Example
Formal Description
Within context of: | SW-MC-BLOB-LAYOUTS
Is context for: | Text


2.564. SW-MEM-ALIGNMENT

Description
This element specifies the alignment of a memory object.
Example
Formal Description
Within context of: | SW-BASE-TYPE, SW-CPU-SPEC, SW-MC-BASE-TYPE
Is context for: | Text


2.565. SW-MEM-ATTR

Description
This element describes attributes of the corresponding segment. Valid values are:
<SW-MEM-ATTR>
Type | Description
INTERN | Internal segment
EXTERN | External segment
Example
Formal Description
Within context of: | SW-CPU-MEM-SEG
Is context for: | Text


2.566. SW-MEM-BASE-ADDR

Description
This element describes the initial address of the corresponding segment.
Example
Formal Description
Within context of: | SW-CPU-MEM-SEG
Is context for: | Text


2.567. SW-MEM-OFFSET

Description
This element describes the offset address of mirrored segments.
Example
Formal Description
Within context of: | SW-MEM-OFFSETS
Is context for: | Text


2.568. SW-MEM-OFFSETS

Description
Container element for <SW-MEM-OFFSET> .
Example
Formal Description
Within context of: | SW-CPU-MEM-SEG
Is context for: | SW-MEM-OFFSET


2.569. SW-MEM-PROGRAM-TYPE

Description
This element describes the type of data stored in the memory segment.
<SW-MEM-PROGRAM-TYPE>
Type | Description
CODE | Program Code
DATA | Program data which can be used for online calibration.
OFFLINE-DATA | Program data which can only be used for offline calibration.
VARIABLES | Program variables
SERAM | Program data for serial emulation
RESERVED | Reserved segments
CALIBRATION_VARIABLES | Values which are available in the ECU but do not exist in the Hex-file. No upload is required to obtain access to the ECU data. The ECU will never be touched by the instrumentation tool with the exception of upload.
EXCLUDE_FROM_FLASH | Values existing in the ECU but not dropped down in the binary file. No upload should be needed to obtain access to the ECU data. The ECU will never be touched by the instrumentation tool, with the exception of upload.
Example
Formal Description
Within context of: | SW-CPU-MEM-SEG
Is context for: | Text


2.570. SW-MEM-SIZE

Description
This element specifies the position of the corresponding memory segment.
Example
Formal Description
Within context of: | SW-CPU-MEM-SEG
Is context for: | Text


2.571. SW-MEM-TYPE

Description
This element describes the memory type that was used, which belongs to the current memory segment. The following types are permitted:
<SW-MEM-TYPE>
Type | Description
RAM | RAM segment
EEPROM | EEPROM segment
EPROM | EPROM segment
ROM | ROM segment
REGISTER | CPU Register Segment
FLASH | FLASH segment
Example
Formal Description
Within context of: | SW-CPU-MEM-SEG
Is context for: | Text


2.572. SW-MIN-AXIS-POINTS

Description
This element specifies the minimum number of base points on the current axis of a map or curve.
Example
Formal Description
Within context of: | SW-AXIS-INDIVIDUAL
Is context for: | Text, CONF-ITEM-CODED-REF, CONF-ITEM-PHYS-REF, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF


2.573. SW-MONOTONY

Description
This element specifies the monotony characteristics of the current internal or physical limits. The following table shows the monotony characteristics which are to be filled through the corresponding values. If the element has no contents or if it is omitted, "no-monotony" is the default content.
Example
Formal Description
Within context of: | SW-INTERNAL-CONSTRS, SW-PHYS-CONSTRS
Is context for: | Text


2.574. SW-NUMBER-OF-AXIS-POINTS

Description
The number of base points to be calculated for the current axis is defined in <SW-NUMER-OF-AXIS-POINTS> .
Example
Formal Description
Within context of: | SW-AXIS-GENERIC
Is context for: | Text, CONF-ITEM-CODED-REF, CONF-ITEM-PHYS-REF, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF


2.575. SW-OPER-MODE

Description
Example
Formal Description
Within context of: | SW-OPER-MODES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, SW-EVENT-REFS, ADD-INFO
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-OPER-MODE |


2.576. SW-OPER-MODE-REF

Description
Example
Formal Description
Within context of: | SW-ACCESSED-SERVICE
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-OPER-MODE |
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF |
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK |


2.577. SW-OPER-MODE-SPEC

Description
Example
Formal Description
Within context of: | SW-SCHEDULING-SPEC
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-OPER-MODES


2.578. SW-OPER-MODES

Description
Example
Formal Description
Within context of: | SW-OPER-MODE-SPEC
Is context for: | SW-OPER-MODE


2.579. SW-PHYS-CONSTRS

Description
Describes the physical limits for variable or parameter values.
Example
Formal Description
Within context of: | SW-DATA-CONSTR-RULE
Is context for: | LOWER-LIMIT, UPPER-LIMIT, SW-SCALE-CONSTRS, SW-UNIT-REF, SW-MAX-DIFF, SW-MONOTONY, SW-RELATED-CONSTRS


2.580. SW-PHYS-CONSTRS-1

Description
This element indroduces such restrictions <SW-PHYS-CONSTRS> , that only ranges of values can be defined.
Example
Formal Description
Within context of: | SW-COMPU-METHOD
Is context for: | SW-SCALE-CONSTR


2.581. SW-POINTER

Description
This element indicates, that the data object (which is specified by the parent element) is a reference to another data object. The properties of the referred data object are described in the <SW-DATA-DEF-PROPS> contained in the <SW-POINTER> .
Example
<SW-CLASS>
                  <LONG-NAME>type of pointer of pointer
                              to a constant object of
                              one_level_t</LONG-NAME>
                  <SHORT-NAME>pointer_pointer_t</SHORT-NAME>
                  <DESC>not visible in warmduscher mode</DESC>
                  <CATEGORY>SIMPLE_TYPEDEF</CATEGORY>
                  <SW-DATA-DEF-PROPS>
                     <SW-POINTER>
                        <SW-DATA-DEF-PROPS>
                           <SW-POINTER>
                             <SW-DATA-DEF-PROPS>
                                 <SW-CLASS-REF>one_level_t</SW-CLASS-REF>
                                 <SW-IMPL-POLICY>STANDARD_CONST</SW-IMPL-POLICY>
                             </SW-DATA-DEF-PROPS>
                           </SW-POINTER>
                        </SW-DATA-DEF-PROPS>
                     </SW-POINTER>
                  </SW-DATA-DEF-PROPS>
                  <ADD-INFO>
                     <VERBATIM>typedef const one_level_t ** pointer_pointer_t;</VERBATIM>
                  </ADD-INFO>
                </SW-CLASS>
This example represents a type of pointer of pointer to a constant object of one_level_t
<SW-CLASS>
                   <LONG-NAME>Variable taking a pointer to a service</LONG-NAME>
                       <SHORT-NAME>pointer_service_t</SHORT-NAME>
                       <CATEGORY>SIMPLE_TYPEDEF</CATEGORY>
                       <SW-DATA-DEF-PROPS><SW-POINTER>
                          <SW-DATA-DEF-PROPS>
                            <SW-POINTER>
                              <SW-DATA-DEF-PROPS>
                                 <SW-SERVICE-REF>null_function</SW-SERVICE-REF>
                            </SW-DATA-DEF-PROPS>
                          </SW-POINTER>
                       </SW-DATA-DEF-PROPS>
                       <ADD-INFO>
                           <VERBATIM>typedef void (pointer_service_t *)(void);</VERBATIM>
                       </ADD-INFO>
                </SW-CLASS>
This example shows how a reference to a function can be specified.
Hint
The signature of the function is specified in the referenced function.
Formal Description
Within context of: | CONF-VALUE-PROPS, SW-DATA-DEF-PROPS
Is context for: | DESC, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS


2.582. SW-PROCESS

Description
Processes are defined within <SW-FEATURE-DECOMPOSITION>. Here, allocations to the processes are also performed in the tasks. See also 2.649. SW-TASK-SPEC for further information on tasks and processes.
Example
See 2.455. SW-FEATURE-DECOMPOSITION
Formal Description
Within context of: | SW-PROCESSES
Is context for: | LABEL, SHORT-LABEL, SW-TASK-REF, DESC


2.583. SW-PROCESS-LIST

Description
This element represents one particular segment of a process list. I contributes to the process list of a <SW-TASK> which denotes a set of process lists. The processes in the list are denoted as <SW-SERVICE-REFS>. The partial lists can also be dependant on <SW-SYSCOND> . It is depending on the development process or the particular step in the development process if the sequence of services is the intended or the actual process sequence within the task in question.
Example
Formal Description
Within context of: | SW-PROCESS-LISTS
Is context for: | SHORT-LABEL, DESC, SW-SYSCOND, SW-SERVICE-REFS


2.584. SW-PROCESS-LISTS

Description
This element represents a segmented process list for one <SW-TASK> . Depending on the use case in question, the intended sequence of processes is given by the flattened set of process lists.
Example
Formal Description
Within context of: | SW-TASK
Is context for: | SW-PROCESS-LIST


2.585. SW-PROCESSES

Description
Container element for <SW-PROCESS> .
Example
Formal Description
Within context of: | SW-SUBCOMPONENT
Is context for: | SW-PROCESS


2.586. SW-RECORD-LAYOUT

Description
Defines how the data objects (variables, calibration parameters etc.) are to be stored in the ECU memory. As an example, this definition specifies the sequence of axis points in the ECU memory. Iterations through axis values are stored within the subelements <SW-RECORD-LAYOUT-GROUP> . These subelements might be stored embedded.
Example
<SW-RECORD-LAYOUTS>
                   <SW-RECORD-LAYOUT ID="KWUB">
                      <LONG-NAME>this is SW-RECORD-LAYOUT Kennwert Unsigned Byte KWUB</LONG-NAME>
                      <SHORT-NAME>KwUb</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                         <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                         <SW-RECORD-LAYOUT-V>
                            <SW-BASE-TYPE-REF ID-REF="UBYTE">UBYTE</SW-BASE-TYPE-REF>
                            <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                         </SW-RECORD-LAYOUT-V>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="SIMPLE-CURVE">
                      <LONG-NAME>This is the record layout for a simple curve.</LONG-NAME>
                      <SHORT-NAME>rly-simple-curve</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-V>
                            <SW-BASE-TYPE-REF ID-REF="UBYTE">UBYTE</SW-BASE-TYPE-REF>
                            <SW-RECORD-LAYOUT-V-PROP>SOURCE-ADR</SW-RECORD-LAYOUT-V-PROP>
                         </SW-RECORD-LAYOUT-V>
                         <SW-RECORD-LAYOUT-V>
                            <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
                         </SW-RECORD-LAYOUT-V>
                         <SW-RECORD-LAYOUT-GROUP>
                            <DESC>Here are the values of the x axis.</DESC>
                            <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>x</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                               <SW-RECORD-LAYOUT-V-INDEX>x</SW-RECORD-LAYOUT-V-INDEX>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <DESC>Here are the values of the value axis.</DESC>
                            <SW-RECORD-LAYOUT-GROUP-AXIS>0</SW-RECORD-LAYOUT-GROUP-AXIS>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>v</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                               <SW-RECORD-LAYOUT-V-INDEX>v</SW-RECORD-LAYOUT-V-INDEX>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="ALTERNATIVE-CURVE">
                      <LONG-NAME>This is the record layout for an alternative curve.</LONG-NAME>
                      <SHORT-NAME>alternative-curve</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-V>
                            <SW-BASE-TYPE-REF ID-REF="UBYTE">UBYTE</SW-BASE-TYPE-REF>
                            <SW-RECORD-LAYOUT-V-PROP>SOURCE-ADR</SW-RECORD-LAYOUT-V-PROP>
                         </SW-RECORD-LAYOUT-V>
                         <SW-RECORD-LAYOUT-V>
                            <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
                         </SW-RECORD-LAYOUT-V>
                         <SW-RECORD-LAYOUT-GROUP>
                            <DESC>Here are the values of the x axis.</DESC>
                            <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>x</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                               <SW-RECORD-LAYOUT-V-INDEX>x</SW-RECORD-LAYOUT-V-INDEX>
                            </SW-RECORD-LAYOUT-V>
                            <SW-RECORD-LAYOUT-V>
                               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                               <SW-RECORD-LAYOUT-V-INDEX>x</SW-RECORD-LAYOUT-V-INDEX>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="SIMPLE-MAP">
                      <LONG-NAME>This is the record layout for a simple map.</LONG-NAME>
                      <SHORT-NAME>simple_map</SHORT-NAME>
                      <DESC>Appendix B in ASAP2-specification (KEBUSS).</DESC>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF ID-REF="UBYTE">UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                            <SW-RECORD-LAYOUT-V>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <DESC>Here are the values of the x axis.</DESC>
                            <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>x</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>-1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF ID-REF="UBYTE">UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                               <SW-RECORD-LAYOUT-V-INDEX>x</SW-RECORD-LAYOUT-V-INDEX>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <DESC>Here are the values of the y axis.</DESC>
                            <SW-RECORD-LAYOUT-GROUP-AXIS>2</SW-RECORD-LAYOUT-GROUP-AXIS>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>y</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>-1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF ID-REF="UWORD">UWORD</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>2</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                               <SW-RECORD-LAYOUT-V-INDEX>x</SW-RECORD-LAYOUT-V-INDEX>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-AXIS>2</SW-RECORD-LAYOUT-GROUP-AXIS>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>y</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>-1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-GROUP>
                               <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
                               <SW-RECORD-LAYOUT-GROUP-INDEX>x</SW-RECORD-LAYOUT-GROUP-INDEX>
                               <SW-RECORD-LAYOUT-GROUP-FROM>-1</SW-RECORD-LAYOUT-GROUP-FROM>
                               <SW-RECORD-LAYOUT-GROUP-TO>1</SW-RECORD-LAYOUT-GROUP-TO>
                               <SW-RECORD-LAYOUT-V>
                                  <SW-BASE-TYPE-REF ID-REF="UWORD">UWORD</SW-BASE-TYPE-REF>
                                  <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                                  <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                                  <SW-RECORD-LAYOUT-V-INDEX>x y</SW-RECORD-LAYOUT-V-INDEX>
                               </SW-RECORD-LAYOUT-V>
                            </SW-RECORD-LAYOUT-GROUP>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="COMMON-X-AXIS">
                      <LONG-NAME>This is the record layout for a common x Axis.</LONG-NAME>
                      <SHORT-NAME>common-x-axis</SHORT-NAME>
                      <DESC></DESC>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF ID-REF="UBYTE">UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <DESC>Here are the values of the x axis.</DESC>
                            <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>x</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF ID-REF="UBYTE">UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                               <SW-RECORD-LAYOUT-V-INDEX>x</SW-RECORD-LAYOUT-V-INDEX>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="IDB6433D9radCD2F5">
                      <LONG-NAME>Ablageschema Festkennfeld FKF0</LONG-NAME>
                      <SHORT-NAME>FKF0</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-AXIS>2</SW-RECORD-LAYOUT-GROUP-AXIS>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>Y</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-GROUP>
                               <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
                               <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                               <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                               <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                               <SW-RECORD-LAYOUT-V>
                                  <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                                  <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                                  <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                                  <SW-RECORD-LAYOUT-V-INDEX>Y X</SW-RECORD-LAYOUT-V-INDEX>
                               </SW-RECORD-LAYOUT-V>
                            </SW-RECORD-LAYOUT-GROUP>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="IDB6433D9rad19537">
                      <LONG-NAME>Ablageschema Festkennlinie FKL0</LONG-NAME>
                      <SHORT-NAME>FKL0</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="IDB6433D9rad4EA19">
                      <LONG-NAME>Ablageschema Gruppenkennfeld GKF0</LONG-NAME>
                      <SHORT-NAME>GKF0</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-AXIS>2</SW-RECORD-LAYOUT-GROUP-AXIS>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>Y</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-GROUP>
                               <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
                               <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                               <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                               <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                               <SW-RECORD-LAYOUT-V>
                                  <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                                  <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                                  <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                                  <SW-RECORD-LAYOUT-V-INDEX>Y X</SW-RECORD-LAYOUT-V-INDEX>
                               </SW-RECORD-LAYOUT-V>
                            </SW-RECORD-LAYOUT-GROUP>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="IDB6433D9rad921E6">
                      <LONG-NAME>Ablageschema Gruppenkennlinie GKL0</LONG-NAME>
                      <SHORT-NAME>GKL0</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="IDB6433D9radBE1E5">
                      <LONG-NAME>Ablageschema Kennfeld KF0</LONG-NAME>
                      <SHORT-NAME>KF0</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>SOURCE-ADR</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>2</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>SOURCE-ADR</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>2</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>Y</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>2</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-AXIS>2</SW-RECORD-LAYOUT-GROUP-AXIS>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>Y</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-GROUP>
                               <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
                               <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                               <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                               <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                               <SW-RECORD-LAYOUT-V>
                                  <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                                  <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                                  <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                                  <SW-RECORD-LAYOUT-V-INDEX>Y X</SW-RECORD-LAYOUT-V-INDEX>
                               </SW-RECORD-LAYOUT-V>
                            </SW-RECORD-LAYOUT-GROUP>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="IDB6433D9rad9E02A">
                      <LONG-NAME>Ablageschema Kennlinie KL0</LONG-NAME>
                      <SHORT-NAME>KL0</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>SOURCE-ADR</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="IDB6433D9rad1063C">
                      <LONG-NAME>Ablageschema Kennlinie KL1</LONG-NAME>
                      <SHORT-NAME>KL1</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>SOURCE-ADR</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="IDB6433D9rad9035C">
                      <LONG-NAME>Ablageschema Kennwert KW0</LONG-NAME>
                      <SHORT-NAME>KW0</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <DESC>IGNORE</DESC>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <DESC>IGNORE</DESC>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="IDB6433D9rad2AE47">
                      <LONG-NAME>Ablageschema Kennwert KW1</LONG-NAME>
                      <SHORT-NAME>KW1</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UWORD</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="IDB6433D9rad7A3B6">
                      <LONG-NAME>Ablageschema Kennwert KW2</LONG-NAME>
                      <SHORT-NAME>KW2</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>ULONG</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="IDB6433D9rad65958">
                      <LONG-NAME>Ablageschema Kennwertblock KWB0</LONG-NAME>
                      <SHORT-NAME>KWB0</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="IDB6433D9radDE73A">
                      <LONG-NAME>Ablageschema Einzelstützstelle SST0</LONG-NAME>
                      <SHORT-NAME>SST0</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>SOURCE-ADR</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="ID71EA062AradC6319">
                      <LONG-NAME>Gruppenkennfeld SWORD</LONG-NAME>
                      <SHORT-NAME>GkfWSw</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-AXIS>2</SW-RECORD-LAYOUT-GROUP-AXIS>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>Y</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-GROUP>
                               <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
                               <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                               <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                               <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                               <SW-RECORD-LAYOUT-V>
                                  <SW-BASE-TYPE-REF>SWORD</SW-BASE-TYPE-REF>
                                  <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                                  <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                                  <SW-RECORD-LAYOUT-V-INDEX>Y X</SW-RECORD-LAYOUT-V-INDEX>
                               </SW-RECORD-LAYOUT-V>
                            </SW-RECORD-LAYOUT-GROUP>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="ID71EA062AradC16F8">
                      <LONG-NAME>Gruppenkennfeld UWORD</LONG-NAME>
                      <SHORT-NAME>GkfWUw</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-AXIS>2</SW-RECORD-LAYOUT-GROUP-AXIS>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>Y</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-GROUP>
                               <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
                               <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                               <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                               <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                               <SW-RECORD-LAYOUT-V>
                                  <SW-BASE-TYPE-REF>UWORD</SW-BASE-TYPE-REF>
                                  <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                                  <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                                  <SW-RECORD-LAYOUT-V-INDEX>Y X</SW-RECORD-LAYOUT-V-INDEX>
                               </SW-RECORD-LAYOUT-V>
                            </SW-RECORD-LAYOUT-GROUP>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="ID71EA062AradE849A">
                      <LONG-NAME>Kenntexte mit Endekennung</LONG-NAME>
                      <SHORT-NAME>KtxC</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP> </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="ID71EA062AradC0865">
                      <LONG-NAME>Kenntexte aufgefuellt bis zur max. Laenge</LONG-NAME>
                      <SHORT-NAME>KtxF</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="ID71EA062AradCF598">
                      <LONG-NAME>Kenntexte mit Laenge am Anfang</LONG-NAME>
                      <SHORT-NAME>KtxL</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="ID71EA062Arad021C9">
                      <LONG-NAME>Kennwertblock UBYTE</LONG-NAME>
                      <SHORT-NAME>KwbUb</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="ID71EA062AradCE36D">
                      <LONG-NAME>Kennwertblock UWORD</LONG-NAME>
                      <SHORT-NAME>KwbUw</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UWORD</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="ID71EA062Arad66295">
                      <LONG-NAME>Kennwert UBYTE</LONG-NAME>
                      <SHORT-NAME>KwUb</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="ID71EA062AradB6CC6">
                      <LONG-NAME>Kennwert UWORD</LONG-NAME>

                      <SHORT-NAME>KwUw</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UWORD</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>

                   <SW-RECORD-LAYOUT ID="ID71EA062Arad32B0C">
                      <LONG-NAME>Einzelstützstelle UWORD Einzelstützstelle UWORD</LONG-NAME>
                      <SHORT-NAME>SstAUwSstUw</SHORT-NAME>
                      <SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UWORD</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                         <SW-RECORD-LAYOUT-GROUP>
                            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
                            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
                            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
                            <SW-RECORD-LAYOUT-V>
                               <SW-BASE-TYPE-REF>UWORD</SW-BASE-TYPE-REF>
                               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
                               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                            </SW-RECORD-LAYOUT-V>
                         </SW-RECORD-LAYOUT-GROUP>
                      </SW-RECORD-LAYOUT-GROUP>
                   </SW-RECORD-LAYOUT>
                </SW-RECORD-LAYOUTS>
Formal Description
Within context of: | SW-RECORD-LAYOUTS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-RECORD-LAYOUT-GROUP
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-RECORD-LAYOUT | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.587. SW-RECORD-LAYOUT-COMPONENT

Description
This element is used to denote the component to which the group in question applies. Thus, the record layout supports structured objects. This secures independence from the sequence of components, because they can be referred to via name.
Example
Formal Description
Within context of: | SW-RECORD-LAYOUT-GROUP
Is context for: | Text


2.588. SW-RECORD-LAYOUT-GROUP

Description
Specifies how a record layout is set up. Using <SW-RECORD-LAYOUT-GROUP>, it recursively models iterations through axis values. The subelement <SW-RECORD-LAYOUT-REF> may reference other <SW-RECORD-LAYOUT>s. The order of the subelements <SW-RECORD-LAYOUT-REF>, <SW-RECORD-LAYOUT-V> and <SW-RECORD-LAYOUT-GROUP> is relevant for the modeled record layout.
Example
Formal Description
Within context of: | SW-RECORD-LAYOUT, SW-RECORD-LAYOUT-GROUP
Is context for: | DESC, SW-RECORD-LAYOUT-GROUP-AXIS, SW-RECORD-LAYOUT-GROUP-INDEX, SW-GENERIC-AXIS-PARAM-TYPE-REF, SW-RECORD-LAYOUT-GROUP-FROM, SW-RECORD-LAYOUT-GROUP-TO, SW-RECORD-LAYOUT-GROUP-STEP, SW-RECORD-LAYOUT-COMPONENT, SW-RECORD-LAYOUT-REF, SW-RECORD-LAYOUT-V, SW-RECORD-LAYOUT-GROUP


2.589. SW-RECORD-LAYOUT-GROUP-AXIS

Description
The contents of this element specifies the axis number within a record layout group <SW-RECORD-LAYOUT-GROUP>. The sister elements on the right-hand side of the tree next to <SW-RECORD-LAYOUT-GROUP-AXIS> refer exactly to this axis number.
Example
Formal Description
Within context of: | SW-RECORD-LAYOUT-GROUP
Is context for: | Text


2.590. SW-RECORD-LAYOUT-GROUP-FROM

Description
This element specifies the iterator index for the point in the axis from which a record layout group <SW-RECORD-LAYOUT-GROUP> is commenced. Negative values are also possible, i.e. the value -4 counts from the fourth value from the end.
Example
Formal Description
Within context of: | SW-RECORD-LAYOUT-GROUP
Is context for: | Text


2.591. SW-RECORD-LAYOUT-GROUP-INDEX

Description
This element attributes a symbolic name to the iterator of the superimposed record layout group <SW-RECORD-LAYOUT-GROUP>. This can be referenced as a loop index beneath superimposed or subsequent <SW-RECORD-LAYOUT-V> elements.
Example
Formal Description
Within context of: | SW-RECORD-LAYOUT-GROUP
Is context for: | Text


2.592. SW-RECORD-LAYOUT-GROUP-STEP

Description
This element specifies the step width for the iterator index, which is used for a record layout group <SW-RECORD-LAYOUT-GROUP> .
Example
Formal Description
Within context of: | SW-RECORD-LAYOUT-GROUP
Is context for: | Text


2.593. SW-RECORD-LAYOUT-GROUP-TO

Description
This element specifies the iterator index for a point in the axis up to which iteration for a record layout group takes place. Negative values are also possible, i.e. the value -4 counts up to the fourth value from the end.
Example
Formal Description
Within context of: | SW-RECORD-LAYOUT-GROUP
Is context for: | Text


2.594. SW-RECORD-LAYOUT-REF

Description
This element references <SW-RECORD-LAYOUT> .
Example
Formal Description
Within context of: | SW-CPU-STANDARD-RECORD-LAYOUT, SW-DATA-DEF-PROPS, SW-RECORD-LAYOUT-GROUP, SW-RECORD-LAYOUT-REF-SYSCOND, SW-RECORD-LAYOUT-REFS, SW-RECORD-LAYOUT-V
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-RECORD-LAYOUT | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.595. SW-RECORD-LAYOUT-REF-SYSCOND

Description
Use <SW-RECORD-LAYOUT-REF-SYSCOND> to create a <SW-RECORD-LAYOUT-REF> that will be valid only when the corresponding <SW-SYSCOND> expression evaluates to true. This is useful when a <SW-RECORD-LAYOUT-REF> shall be used when system constant has a certain value.
Example
This Record Layout reference is used when LINA_Gear is less or equal to 4.
<SW-RECORD-LAYOUT-REF-SYSCOND>
                  <SW-RECORD-LAYOUT-REF>rec_lay_Ref</SW-RECORD-LAYOUT-REF>
                  <SW-SYSCOND>
                    <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&lt;=4
                  </SW-SYSCOND>
                </SW-RECORD-LAYOUT-REF>
Formal Description
Within context of: | SW-RECORD-LAYOUT-REFS
Is context for: | SW-RECORD-LAYOUT-REF, SW-SYSCOND


2.596. SW-RECORD-LAYOUT-REFS

Description
Container element for <SW-RECORD-LAYOUT-REF> .
Example
Formal Description
Within context of: | SW-COLLECTION-CONT, SW-FEATURE-ELEMENTS
Is context for: | SW-RECORD-LAYOUT-REF, SW-RECORD-LAYOUT-REF-SYSCOND


2.597. SW-RECORD-LAYOUT-V

Description
This element specifies which values are stored for the current <SW-RECORD-LAYOUT-GROUP>. If no <SW-BASE-TYPE-REF> is present, the <SW-BASE-TYPE> referenced initially in the father element <SW-RECORD-LAYOUT-GROUP> is valid. The specification of <SW-RECORD-LAYOUT-V-AXIS> gives the axis of the values to be stored in accordance with the current record layout <SW-RECORD-LAYOUT-GROUP>. In <SW-RECORD-LAYOUT-V-PROP> you are able to specify the type of values that are to be stored, e.g. number or value. Under <SW-RECORD-V-INDEX>, the symbolic values of the axes can be given, for which the value given under <SW-RECORD-LAYOUT-V-PROP> is iterated. These symbolic values relate to the values given in <SW-RECORD-LAYOUT-GROUP-INDEX> .
Example
Formal Description
Within context of: | SW-RECORD-LAYOUT-GROUP
Is context for: | DESC, SW-BASE-TYPE-REF, SW-RECORD-LAYOUT-V-AXIS, SW-RECORD-LAYOUT-V-PROP, SW-RECORD-LAYOUT-V-INDEX, SW-GENERIC-AXIS-PARAM-TYPE-REF, SW-RECORD-LAYOUT-V-FIX-VALUE, SW-RECORD-LAYOUT-REF


2.598. SW-RECORD-LAYOUT-V-AXIS

Description
This element specifies the number of axes with values that are stored in the ECU. Refer to <SW-RECORD-LAYOUT-V> for further details.
Example
Formal Description
Within context of: | SW-RECORD-LAYOUT-V
Is context for: | Text


2.599. SW-RECORD-LAYOUT-V-FIX-VALUE

Description
This element specifies the filler character for the current record layout, in the form of hex digits. The element present parallel to this <SW-RECORD-LAYOUT-V-PROP> must therefore have the contents FILL.
Example
Formal Description
Within context of: | SW-RECORD-LAYOUT-V
Is context for: | Text


2.600. SW-RECORD-LAYOUT-V-INDEX

Description
The symbolic value for iteration, or the symbolic values separated by white-spaces, refer to the symbolic values given in <SW-RECORD-LAYOUT-GROUP-INDEX> . The iterators are processed from left to right, in such a manner that they symbolize the loop index from the outside to the inside.
An error has occurred if a parameter references a record layout which contains a <SW-RECORD-LAYOUT-V-INDEX> with more components than the number of parameter axes.
Figure 4: Example of a corresponding error check in MetaMorphosis
//*******************************************************

                //übung: dieses in XPath tun  :-)

                ((*prm:=this).null,
                 \ref(child[?sw-record-layout-ref].data)
                    [
                       ?descendant[?sw-record-layout-v-index
                                     [
                                      count(data.split(" ")) ^=
                                      count(*prm.descendant[?sw-calprm-axis])
                                     ]
                                  ]
                    ]
                )
Example
See 2.586. SW-RECORD-LAYOUT
Formal Description
Within context of: | SW-RECORD-LAYOUT-V
Is context for: | Text


2.601. SW-RECORD-LAYOUT-V-PROP

Description
The contents of this element describes the type of values to be stored. The following are permitted:
VALUE | The value of the axis
COUNT | The amount of values of the axis
LEFTDIFF | The difference to the previous value
RIGHTDIFF | The difference to the next value
DIST | The <distance> value of this axis (if introduced)
SOURCE-ADR | The address of the source of this axis
RESULT-ADR | The address of the result for this axis (if introduced)
ADDRESS | The address
FILL | Fill with the hex value specified as contents of <SW-RECORD-LAYOUT-FIX-VALUE>
FIXLEFTDIFF | Difference between this and a fixed left-hand value (normally 0)
FIXRIGHTDIFF | Difference between this and a fixed right-hand value (e.g. 255)
... | Further values must be worked out.
Example
Formal Description
Within context of: | SW-RECORD-LAYOUT-V
Is context for: | Text


2.602. SW-RECORD-LAYOUTS

Description
Container element for <SW-RECORD-LAYOUT> .
Example
Formal Description
Within context of: | SW-DATA-DICTIONARY-SPEC
Is context for: | ADMIN-DATA, SW-RECORD-LAYOUT


2.603. SW-REFRESH-TIMING

Description
This element specifies the frequency in which the object involved is called or calculated.
Example
<SW-VARIABLE>
                   <LONG-NAME>Drehzahl</LONG-NAME>
                   <SHORT-NAME>N</SHORT-NAME>
                   <SW-DATA-DEF-PROPS>
                      <SW-INTENDED-RESOLUTION>40</SW-INTENDED-RESOLUTION>
                      <SW-REFRESH-TIMING>
                         <SW-CSE-CODE>101</SW-CSE-CODE>
                         <SW-CSE-CODE-FACTOR>1</SW-CSE-CODE-FACTOR>
                      </SW-REFRESH-TIMING>
                      <SW-UNIT-REF>upm</SW-UNIT-REF>
                   </SW-DATA-DEF-PROPS>
                </SW-VARIABLE>
Formal Description
Within context of: | SW-DATA-DEF-PROPS, SW-MC-FRAME, SW-MC-INTERFACE-SOURCE, SW-TASK
Is context for: | SW-CSE-CODE, SW-CSE-CODE-FACTOR


2.604. SW-RELATED-CONSTRS

Description
This element describes plausibility rules that go beyond the individual data object. E.g. the overrun shut-off engine speed must not be higher than the maximum engine speed. This plausibility rule is defined in exactly the same way as the contexts and dependencies of virtual characteristic variables and variables.
Example
Formal Description
Within context of: | SW-INTERNAL-CONSTRS, SW-PHYS-CONSTRS
Is context for: | SW-DATA-DEPENDENCY


2.605. SW-ROOT-FEATURES

Description
This element is the root element of the hierarchy, given implicity through the decomposition of the function.
Example
Formal Description
Within context of: | SW-COMPONENT-SPEC
Is context for: | SW-FEATURE-REF


2.606. SW-SCALE-CONSTR

Description
Describes the section-by-section definition of the upper and lower limits of internal and physical restrictions.
Example
Formal Description
Within context of: | SW-INTERNAL-CONSTRS-1, SW-PHYS-CONSTRS-1, SW-SCALE-CONSTRS
Is context for: | LOWER-LIMIT, UPPER-LIMIT


2.607. SW-SCALE-CONSTRS

Description
Container element for <SW-SCALE-CONSTR> .
Example
Formal Description
Within context of: | SW-INTERNAL-CONSTRS, SW-PHYS-CONSTRS
Is context for: | SW-SCALE-CONSTR


2.608. SW-SCHEDULING-SPEC

Description
Example
Formal Description
Within context of: | SW-SYSTEM
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-OPER-MODE-SPEC, SW-TASK-SPEC, SW-EVENT-SPEC, ADD-INFO


2.609. SW-SEMAPHORE

Description
This element denotes a variable which servers as a semaphore variable for a particular ressource which is specified in the surrounding <SW-DATA-DEF-PROPS>
Example
<SW-VARIABLE>
                   <LONG-NAME>Measurement Point</LONG-NAME>
                   <SHORT-NAME>TST_varSimple_mp</SHORT-NAME>
                   <CATEGORY>VALUE</CATEGORY>
                   <SW-DATA-DEF-PROPS>
                     <SW-ADDR-METHOD-REF>extRam></SW-ADDR-METHOD-REF>
                     <SW-BASE-TYPE-REF >sint16</SW-BASE-TYPE-REF>
                     <SW-CALIBRATION-ACCESS>READ-ONLY</SW-CALIBRATION-ACCESS>
                     <SW-CODE-SYNTAX-REF>Mp_s16</SW-CODE-SYNTAX-REF>
                     <SW-COMPU-METHOD-REF>Compu_1</SW-COMPU-METHOD-REF>
                     <SW-IMPL-POLICY>MEASUREMENT-POINT</SW-IMPL-POLICY>
                     <SW-SEMAPHORE>
                        <SW-VARIABLE-REF >TST_varSimple_mp_sema</SW-VARIABLE-REF><
                     </SW-SEMAPHORE>
                   </SW-DATA-DEF-PROPS>
                </SW-VARIABLE>
This example shows a variable named TST_varSimple_mp of which the access is controlled by the semaphore variable TST_varSimple_mp_sema.
Hint
The same semaphore variable can be used for mor than one ressource.
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | SW-VARIABLE-REF


2.610. SW-SERVICE

Description
Example
Formal Description
Within context of: | SW-SERVICES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-SERVICE-RETURN, SW-SERVICE-ARGS, SW-ACCESSED-SERVICES, SW-ACCESSED-CALPRMS, SW-ACCESSED-VARIABLES, SW-ACCESSED-CLASS-INSTANCES, SW-SERVICE-ACCESSED-ELEMENT-SETS, SW-SERVICE-PROPS, ADD-INFO
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-SERVICE |
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | SW-SERVICE-ARG SW-SERVICE-RETURN |


2.611. SW-SERVICE-ACCESSED-ELEMENT-SET

Description
This element is similar to <SW-INTERFACE-ACCESSED-ELEMENT-SET> but applies to <SW-SERVICE> . To some extent it is now possible to epress the access to interface elements
  • within a software component represented by ( <SW-FEATURE> ), which is the mainly a functional view
  • within a process represented by <SW-SERVICE>, which is more the dynamic view. These processes are part of compontents (represented by ownership and imports, which makes it possible to retrieve the functional view from the dynamic view (but not vice versa).
Example
Formal Description
Within context of: | SW-SERVICE-ACCESSED-ELEMENT-SETS
Is context for: | DESC, SW-SYSCOND, SW-ACCESSED-VARIABLES, SW-ACCESSED-CALPRMS, SW-ACCESSED-CLASS-INSTANCES, SW-ACCESSED-SERVICES


2.612. SW-SERVICE-ACCESSED-ELEMENT-SETS

Description
This is a wrapper for <SW-SERVICE-ACCESSED-ELEMENT-SET> .
Example
Formal Description
Within context of: | SW-SERVICE
Is context for: | SW-SERVICE-ACCESSED-ELEMENT-SET


2.613. SW-SERVICE-ARG

Description
Example
Formal Description
Within context of: | SW-SERVICE-ARGS
Is context for: | LONG-NAME, SHORT-NAME, LABEL, SHORT-LABEL, DESC, CATEGORY, SW-ARRAYSIZE, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS, ADD-INFO-5
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-SERVICE-ARG |


2.614. SW-SERVICE-ARGS

Description
Example
Formal Description
Within context of: | SW-SERVICE, SW-SERVICE-IMPL
Is context for: | SW-SERVICE-ARG


2.615. SW-SERVICE-IMPL

Description
Example
Formal Description
Within context of: | SW-SERVICE-IMPLS
Is context for: | SW-SERVICE-PROTOTYPE-REF, SW-SERVICE-RETURN, SW-SERVICE-ARGS, SW-ACCESSED-SERVICES, SW-ACCESSED-CALPRMS, SW-ACCESSED-VARIABLES, SW-ACCESSED-CLASS-INSTANCES, SW-SERVICE-PROPS


2.616. SW-SERVICE-IMPLS

Description
Example
Formal Description
Within context of: | SW-CLASS-ATTR-IMPL
Is context for: | SW-SERVICE-IMPL


2.617. SW-SERVICE-PROPS

Description
Example
Formal Description
Within context of: | SW-SERVICE, SW-SERVICE-IMPL
Is context for: | SW-SERVICE-REENTRANCE, SW-SERVICE-RECURSIVE, SW-IMPL-POLICY


2.618. SW-SERVICE-PROTOTYPE

Description
Example
Formal Description
Within context of: | SW-SERVICE-PROTOTYPES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-SYSCOND, ANNOTATIONS, ADD-INFO
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[F-ID-CLASS] fixed value | String (CDATA) | SW-SERVICE-PROTOTYPE |


2.619. SW-SERVICE-PROTOTYPE-REF

Description
Example
Formal Description
Within context of: | SW-SERVICE-IMPL
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-SERVICE-PROTOTYPE |
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF |
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK |


2.620. SW-SERVICE-PROTOTYPES

Description
Example
Formal Description
Within context of: | SW-CLASS-ATTR
Is context for: | SW-SERVICE-PROTOTYPE


2.621. SW-SERVICE-RECURSIVE

Description
Example
Formal Description
Within context of: | SW-SERVICE-PROPS
Is context for: | Text


2.622. SW-SERVICE-REENTRANCE

Description
Example
Formal Description
Within context of: | SW-SERVICE-PROPS
Is context for: | Text


2.623. SW-SERVICE-REF

Description
Example
Formal Description
Within context of: | SW-ACCESSED-SERVICE, SW-DATA-DEF-PROPS, SW-FEATURE-EXPORT-SERVICES, SW-FEATURE-IMPORT-SERVICES, SW-FEATURE-LOCAL-SERVICES, SW-SERVICE-REF-SYSCOND, SW-SERVICE-REFS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-SERVICE |
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF |
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK |


2.624. SW-SERVICE-REF-SYSCOND

Description
Example
Formal Description
Within context of: | SW-FEATURE-EXPORT-SERVICES, SW-FEATURE-IMPORT-SERVICES, SW-FEATURE-LOCAL-SERVICES, SW-SERVICE-REFS
Is context for: | SW-SERVICE-REF, SW-SYSCOND


2.625. SW-SERVICE-REFS

Description
Example
Formal Description
Within context of: | SW-COLLECTION-CONT, SW-FEATURE-ELEMENTS, SW-PROCESS-LIST, SW-TASK
Is context for: | SW-SERVICE-REF, SW-SERVICE-REF-SYSCOND


2.626. SW-SERVICE-RETURN

Description
Example
Formal Description
Within context of: | SW-SERVICE, SW-SERVICE-IMPL
Is context for: | LONG-NAME, SHORT-NAME, LABEL, SHORT-LABEL, DESC, CATEGORY, SW-ARRAYSIZE, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS, ADD-INFO-5
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-SERVICE-RETURN |


2.627. SW-SERVICES

Description
Example
Formal Description
Within context of: | SW-DATA-DICTIONARY-SPEC
Is context for: | ADMIN-DATA, SW-SERVICE


2.628. SW-SIZEOF-INSTANCE

Description
This element specifies the size of a memory object in bytes . This is required for the recalculation of the individual component addresses, on temporary storage of the structures.
Example
See 2.270. SW-ADDR-INFO
Formal Description
Within context of: | SW-ADDR-INFO
Is context for: | Text


2.629. SW-SUBCOMPONENT

Description
This element describes a sub-component within the functional decomposition of a feature. A process sequence can also be specified in this composition (see <SW-FEATURE-DECOMPOSITION> ).
Example
See 2.455. SW-FEATURE-DECOMPOSITION
Formal Description
Within context of: | SW-FEATURE-DECOMPOSITION
Is context for: | SW-SYSCOND, SW-FEATURE-REF, SW-FEATURE-VARIANT-REF, SW-PROCESSES


2.630. SW-SYSCOND

Description
This element is used to denote, that the existence of its parent element is treated to be conditional. This means, that the parent element is processed only, if the evaluation of the content of <SW-SYSCOND> evaluates to "1".
This element specifies an expression that is to be calculated, in which system constants, referenced through <SW-SYSTEMCONST-CODED-REF> and <SW-SYSTEMCONST-PHYS-REF>, are substituted.
The contents of this element is an arithmetic expression with the features as follows:
  • Zulässige Operanden: Integer-Zahlen (vorzeichenlos oder mit Vorzeichen), Gleitpunktzahlen, Verweise auf Systemkonstanten
  • Zulässige Operatoren: Operatoren in arithmetischen Ausdrücken!
  • Es dürfen Klammern (auch geschachtelt) enthalten sein.
  • Es wird zwischen Integer- und Gleitpunktarithmetik unterschieden.
  • Im Objektspeicher sind arithmetische Ausdrücke in runde Klammern eingefasst abgespeichert.
  • In der KGS-Datei bestehen keine syntaktischen Besonderheiten (keine Einfassung in Klammern etc. nötig)
  • Arithmetische Ausdrücke dürfen auch über mehrere Zeilen gehen.
Folgende Operatoren sind unterstützt. Dabei entspricht die Reihenfolge der Nennung der Berechnungsreihenfolge (Operatorenpräzedenz) - angelehnt an die Programmiersprache "C".
Instruction
Im Fehlerfall (Ausdruck falsch formuliert) muss die betreffende Anwendung eine hochpriore Fehlermeldung werfen, und das ergebnis als false (0) annehmen.
Instruction
Es hängt von der jeweiligen Prozess-Strategie ab, wie auf einen undefinierte Operanden reagiert wird. Drei Strategien sind denkbar:
konservativ - <SW-SYSCOND> wird als falsch interpretiert, d.h. das betroffene Element wird rausgelöscht. Damit wird auf jeden Fall die Verarbeitung unzutreffender Information vermieden.
iterativ - <SW-SYSCOND> wird nicht interpretiert, d.h. das betroffene Element wird inklusive seiner Systembedinung weitergereicht, um in einem nächsten Lauf wieder ausgewertet zu werden. Damit kann man eine auf mehrere Iterationen verteilte Auswertung realisiseren.
progressiv - <SW-SYSCOND> wird als wahr interpretiert, d.h. das betroffene Element wird behalten, aber <SW-SYSCOND> wird entfernt. Damit wird auf jeden Fall Informationsverlust vermieden.
Operatoren in arithmetischen Ausdrücken
Zeichen | Operator
!, ~ | Negation (bool'sch, bitweise)
** | Potenzierung
*, / | Multiplikation, Division
+, - | Addition, Subtraktion
<<, >> | bitweises Schieben (links, rechts)
<, <=, >, >= | Vergleich: kleiner, kleiner oder gleich, gröer, gröer oder gleich
==, != | Vergleich: gleich, ungleich
& | bitweises UND
^ | bitweises XOR
| | bitweises ODER
&& | bool'sches UND
|| | bool'sches ODER
Die Berechnung von Ausdrücken mit bool'schem UND oder ODER wird abgebrochen, wenn bereits aus dem ersten Operanden das Ergebnis feststeht (wie in C). Zum Tragen kommt dieses Verhalten bei einem Ausdruck wie:
defined (SY_COUNT) && SY_COUNT > 1
da hier, falls SY_COUNT nicht definiert ist, die Abprüfung auf "> 1" nicht durchgeführt wird und somit eine ungewollte Fehlermeldung vermieden wird.
Folgende mathematische Funktionen sind unterstützt:
mathematische Funktionen in arithmetischen Ausdrücken
Funktion | Anzahl Parameter | Ergebnis-Typ | Bedeutung
IROUND | 1 | integer oder unsigned integer | rundet positive und negative Zahlen auf die nächstgelegene ganze Zahl
ICEIL | 1 | integer oder unsigned integer | rundet positive und negative Zahlen auf auf die nächste darüber liegende ganze Zahl
IFLOOR | 1 | integer oder unsigned integer | rundet positive und negative Zahlen ab auf die nächste darunter liegende ganze Zahl
UROUND | 1 | unsigned integer | rundet positive und negative Zahlen auf die nächstgelegene ganze, vorzeichenlose Zahl
UCEIL | 1 | unsigned integer | rundet positive und negative Zahlen auf auf die nächste darüber liegende ganze, vorzeichenlose Zahl
UFLOOR | 1 | unsigned integer | rundet positive und negative Zahlen ab auf die nächste darunter liegende ganze, vorzeichenlose Zahl
ABS | 1 | wie Operand | Absolutbetrag
LN | 1 | float | natürlicher Logarithmus (zur Basis e)
EXP | 1 | float | Exponentialbildung (Basis e)
DEFINED | 1 | 0 oder 1 | Prüfung, ob alle zur Berechnung des Operanden notwendigen Systemkonstanten definiert sind.
MAX | 2 | abhängig von Operanden | Maximalwertbildung
MIN | 2 | abhängig von Operanden | Minimalwertbildung
Beispiele für korrekte arithmetische Ausdrücke sind:
   1
   2.0
   1.5E5
   2.0 * (1 + 2)
   SY_ZYLZA
   SY_ZYLZA + SY_TURBO
   defined (SY_ZYLZA)
   1 / SY_ZYLZA
Bei letztem Beispiel ist zu beachten, dass hier mit Integer-Arithmetik gerechnet wird (also das Ergebnis gleich 0 sein wird), wenn die Zylinderzahl SY_ZYLZA ebenfalls als Integerzahl definiert wurde.
Figure 5: Grammar for an arithmetic expression
<expression> :== (<expression>)
                | <expression> <op> <expression>
                | <value>
 <value>      :== UINTEGER | INTEGER | DOUBLE | IDENTIFIER | <function>
 <function>   :== <ufunc>(<expression>) | <bfunc>(<expression>,<expresssion>)
 <ufunc>      :== IROUND | ICEIL | IFLOOR | UROUND | UCEIL | UFLOOR | ABS | LN |
                  EXP | DEFINED
 <bfunc>      :== MAX | MIN
 <op>         :== + | - | / | * | ** | & | ^ | | | ~ | << | >> | && | || |
                  == | != | ! | < | <= | > | >=
IDENTIFIER sind Referenzen auf Systemkonstanten (<SW-SYSTEM-CONST-CODED-REF> bzw. <SW-SYSTEM-CONST-PHYS-REF>), Features aus einer MSRFR-Instanz (<FR-FEATURE-REF>) oder Konfigurationseinstellungen (<CONF-ITEM-CODED-REF> bzw. <CONF-ITEM-PHYS-REF>).
Hint
Es wird empfohlen in einem Editor folgende Ersatzdarstellungen für IDENTIFIER zu verwenden:
c( ... ) für <SW-SYSTEM-CONST-CODED-REF>
p( ... ) für <SW-SYSTEM-CONST-PHYS-REF>
fr( ... ) für <FR-FEATURE-REF>
cc( ... ) für <CONF-ITEM-CODED-REF>
cp( ... ) für <CONF-ITEM-PHYS-REF>
Diese Ersatzdarstellungen müssen auch verwendet werden, wenn die Bedingung in das Attribut [SYSCOND] eingetragen wird.
INTEGER, UINTEGER und DOUBLE sind wie in C angebbar.
Hint: Implementierungshinweis
Es wird empfohlen, im Unterschied zu C positive Integer-Zahlen als unsigned integer zu behandeln (dadurch haben boolsche Ausdrücke den Typ UINTEGER). Die explizite Kennzeichnung eines UINTEGER mit Suffix U bzw. UL ist nicht mehr zwingend, ist aber nach wie vor akzeptiert. Wird ein ganzzahliger arithmetischer Ausdruck bzw. ein Zwischenergebnis negativ, so wird automatisch von Typ UINTEGER auf INTEGER umgewandelt. Damit dürfen Zwischenergebnisse während der Auswertung eines arithmetischen Ausdrucks den üblichen Wertebereich von signed integer überschreiten, ohne dass es sofort zu einem berlauffehler käme. Damit ist man in der Lage, z.B. Adressen gröer als 0x7FFFFFFF zu behandeln, ohne dass die erzeugenden Tools sich um das Suffix kümmern müssten.
Vorrang: Es gilt die allgemein übliche Vorrang-Regel Punkt vor Strich. Am stärksten bindet der Potenz-Operator (**).

Das unäre Minus bindet stärker als alle anderen Operatoren. Bsp: -2**3 wird zu -8 = (-2)**3 ausgewertet -ln(2.718281828)**2 entspricht (-ln(2.718281828))**2 und ist somit gleich +1.
Typ: Der Typ eines arithmetischen Ausdrucks ist entweder ArithInteger (intern abgebildet durch long int), ArithUnsignedInteger (intern abgebildet durch unsigned long int) oder ArithDouble (intern abgebildet durch double). Er wird bestimmt durch den Typ seiner einzelnen Bestandteile. Es gilt:

  • der Typ von INTEGER ist ArithInteger
  • der Typ von UINTEGER ist ArithUnsignedInteger
  • der Typ von DOUBLE ist ArithDouble
  • zum Ergebnistyp einer Funktion bzw. eines Operanden s. resultierende Typen von Operatoren und Funktionen
Operator / Der Divisions-Operator angewandt auf zwei Ausdrücke vom Typ INTEGER oder UINTEGER verhält sich wie die Division in C für Integer (Ganzzahl-Division)

Funktionen IROUND, ICEIL, IFLOOR,UROUND, >UCEIL und UFLOOR Diese wirken als 'Integer-Cast' bzw. 'Unsigned Integer-Cast' mit Rundung. Man beachte, dass ab Version V1.15D positive Integer wie unsigned integer behandelt werden. Es ist somit z.B. 4 identisch mit 4UL. Im einzelnen gilt:

IROUND
rundet positive und negative Zahlen auf die nächstgelegene ganze Zahl.
         Bsp.: IROUND(4.4) = 4      IROUND(-4.4) = -4
               IROUND(4.7) = 5      IROUND(-4.7) = -5
               IROUND(4.5) = 5      IROUND(-4.5) = -5
IFLOOR
rundet positive und negative Zahlen ab auf die nächste darunter liegende ganze Zahl.
         Bsp.: IFLOOR(4.4) = 4      IFLOOR(-4.4) = -5
               IFLOOR(4.7) = 4      IFLOOR(-4.7) = -5
               IFLOOR(4.0) = 4      IFLOOR(-4.0) = -4
ICEIL
rundet positive und negative Zahlen auf auf die nächste darüber liegende ganze Zahl.
         Bsp.: ICEIL(4.4)  = 5      ICEIL(-4.4)  = -4
               ICEIL(4.7)  = 5      ICEIL(-4.7)  = -4
               ICEIL(4.0)  = 4      ICEIL(-4.0)  = -4
UROUND, UCEIL, UFLOOR
wirken wie ihre Entsprechungen IROUND, ICEIL und IFLOOR. Negative Zahlen werden immer auf 0 gerundet.
         Bsp.: UCEIL(4.4)  = 5UL      UCEIL(-4.4)  = 0UL
               UCEIL(4.7)  = 5UL      UROUND(4.7)  = 5UL
               UCEIL(4.0)  = 4UL      UROUND(4.0)  = 4UL
               UROUND(4.5) = 5UL      UROUND(4.4)  = 4UL
               UFLOOR(4.5) = 4UL      UFLOOR(4.7)  = 4UL
Funktion DEFINED DEFINED liefert 1, falls der als Parameter übergebene arithmetische Ausdruck auswertbar ist, d.h. alle darin vorkommenden Systemkonstanten definiert sind. Eine Systemkonstante ist genau dann 'definiert', falls sie als konstanter Ausdruck definiert ist oder alle in ihrem Ausdruck verwendeten Systemkonstanten wiederum 'definiert' sind.

Bsp.: es seien folgende Systemkonstanten definiert:
         ZYL_ZA = 4
         ZYLZA2 = ZYLZA+2
         TURBO  =          (undefiniert)
         TURBO2 = TURBO+2
        dann gilt:
         DEFINED(ZYL_ZA)  = 1
         DEFINED(ZYL_ZA2) = 1
         DEFINED(TURBO)   = 0
         DEFINED(TURBO2)  = 0    (TURBO2 ist mit Hilfe von TURBO definiert,
                                  das wiederum undefiniert ist)
         DEFINED(3*4-6)   = 1
         DEFINED(ZYL_ZA-TURBO2) = 0
Ein Ausdruck wie:
defined (SY_COUNT) && SY_COUNT > 1
ist zulässig, da hier, falls SY_COUNT nicht definiert ist, die Abprüfung auf "> 1" nicht durchgeführt wird und somit eine ungewollte Fehlermeldung vermieden wird.
Fehlerbehandlung Fehlermeldungen gibt es, wenn

  • der arithmetische Ausdruck ist syntaktisch nicht korrekt
  • es wird durch 0 dividiert
  • der Definitionsbereich einer Funktion wird nicht beachtet
  • der Funktionswert einer Funktion liegt auerhalb des darstellbaren Bereichs (dies ist z.B. auch für IFLOOR(10E22) der Fall)
  • einer der Operanden ist nicht definiert
Keine Fehlermeldung gibt es, wenn bei Verwendung der Grundrechenoperatoren '-', '+', '*', '/' der Darstellungsbereich überschritten wird.
resultierende Typen von Operatoren und Funktionen
Funktion / Operator
Typen der Parameter/Operanden
Ergebnistyp
Bemerkung
+, -, / ,*
INTEGER; INTEGER
Ganzzahl
Dominanz: DOUBLE vor Ganzzahl. (Für Ganzzahl ist der Ergenistyp abhängig vom Ergebniswert:
INTEGER, falls Ergebnis < 0
UINTEGER, falls Ergebnis >= 0
INTEGER, UINTEGER
UINTEGER, UINTEGER
DOUBLE, UINTEGER
DOUBLE
DOUBLE, INTEGER
DOUBLE, DOUBLE
||, &&, ==, <=, <, >, >=, !=
INTEGER, INTEGER
UINTEGER
Dominanz: der Ergebnistyp der booleschen Operatoren ist unabhängig vom Typ der Operanden immer UINTEGER
Wie in C ist das Ergebnis entweder 0 oder 1
INTEGER, UINTEGER
UINTEGER, UINTEGER
DOUBLE, UINTEGER
DOUBLE, INTEGER
DOUBLE, DOUBLE
|, &, ^, <<, >>
INTEGER, INTEGER
UINTEGER
Dominanz: der Ergebnistyp der bitweisen Operatoren ist unabhängig vom Typ der Operanden immer UINTEGER.
Die Verwendung eines Operanden vom Typ DOUBLE führt zu einem fehlerhaften arithmetischen Ausdruck mit Fehlermeldung
INTEGER, UINTEGER
UINTEGER, UINTEGER
DOUBLE, UINTEGER
Fehler
DOUBLE, INTEGER
DOUBLE, DOUBLE
MIN
INTEGER, INTEGER
INTEGER
Dominanz: DOUBLE vor INTEGER vor UINTEGER
Beachte: Die Dominanzen von MIN und MAX unterscheiden sich!
INTEGER, UINTEGER
UINTEGER, UINTEGER
UINTEGER
DOUBLE, UINTEGER
DOUBLE
DOUBLE, INTEGER
DOUBLE, DOUBLE
MAX
INTEGER, INTEGER
INTEGER
Dominanz: DOUBLE vor UINTEGER vor INTEGER
Beachte: Die Dominanzen von MIN und MAX unterscheiden sich!
INTEGER, UINTEGER
UINTEGER
UINTEGER, UINTEGER
DOUBLE, UINTEGER
DOUBLE
DOUBLE, INTEGER
DOUBLE, DOUBLE
~
INTEGER
UINTEGER
Verwendung eines Operanden vom Typ DOUBLE führt zu einem fehlerhaften arithmetischen Ausdruck mit Fehlermeldung
UINTEGER
DOUBLE
Fehler
!, DEFINED
INTEGER
UINTEGER
Dominanz: Ergebnistyp ist immer UINTEGER
Das Ergebnis ist entweder 0 oder 1
UINTEGER
DOUBLE
LN, EXP
INTEGER
DOUBLE
Dominanz: Ergebnistyp ist immer DOUBLE
UINTEGER
DOUBLE
ABS
INTEGER
UINTEGER
Für ganze Zahlen ist Ergebnistyp immer UINTEGER
UINTEGER
DOUBLE
DOUBLE
ICEIL, IFLOOR, IROUND
INTEGER
Ganzzahl
Dominanz: Ergebnistyp ist abhängig vom Ergebnis entweder INTEGER (Ergebnis < 0) oder UINTEGER (Ergebnis >= 0)
UINTEGER
DOUBLE
UCEIL, UFLOOR, UROUND
INTEGER
UINTEGER
Dominanz: Ergebnistyp ist immer UINTEGER
Für negative Parameter wird 0 zurückgegeben
UINTEGER
DOUBLE
Example
   1

   2.0

   1.5E5

   2.0 * (1 + 2)

   <SW-SYSTEMCONST-CODED-REF>SY_ZYLZA</SW-SYSTEMCONST-CODED-REF>

   <SW-SYSTEMCONST-CODED-REF>SY_ZYLZA</SW-SYSTEMCONST-CODED-REF>
         + <SW-SYSTEMCONST-CODED-REF>SY_TURBO</SW-SYSTEMCONST-CODED-REF>

   defined (<SW-SYSTEMCONST-CODED-REF>SY_ZYLZA</SW-SYSTEMCONST-CODED-REF>)

   1 / <SW-SYSTEMCONST-CODED-REF>SY_ZYLZA</SW-SYSTEMCONST-CODED-REF>
Formal Description
Within context of:
CONF-ITEM, CONF-RULE, CONF-RULE-REF-SYSCOND, CONF-VALUE-CONSTR, SW-ACCESSED-SERVICE, SW-ADDR-METHOD-REF-SYSCOND, SW-AR-RELATION, SW-AXIS-CONT, SW-AXIS-TYPE-REF-SYSCOND, SW-BASE-TYPE-REF-SYSCOND, SW-CALPRM-PROTOTYPE, SW-CALPRM-REF-SYSCOND, SW-CLASS-ATTR-IMPL-REF-SYSCOND, SW-CLASS-INSTANCE-REF-SYSCOND, SW-CLASS-PROTOTYPE, SW-CLASS-REF-SYSCOND, SW-CODE-SYNTAX-REF-SYSCOND, SW-COMPU-METHOD-REF-SYSCOND, SW-DATA-CONSTR-REF-SYSCOND, SW-DATA-DEF-PROPS, SW-EVENT-REF-SYSCOND, SW-FEATURE, SW-FEATURE-INTERFACE, SW-FEATURE-INTERFACE-REF-SYSCOND, SW-FEATURE-OWNED-ELEMENT-SET, SW-FEATURE-REF-SYSCOND, SW-FEATURE-VARIANT-OF, SW-INSTANCE-REF-SYSCOND, SW-INTERFACE-ACCESSED-ELEMENT-SET, SW-INTERFACE-EXPORT, SW-INTERFACE-IMPORT, SW-PROCESS-LIST, SW-RECORD-LAYOUT-REF-SYSCOND, SW-SERVICE-ACCESSED-ELEMENT-SET, SW-SERVICE-PROTOTYPE, SW-SERVICE-REF-SYSCOND, SW-SUBCOMPONENT, SW-SYSTEMCONST-REF-SYSCOND, SW-TASK-REF-SYSCOND, SW-TEMPLATE-REF-SYSCOND, SW-UNIT-REF-SYSCOND, SW-VARIABLE-PROTOTYPE, SW-VARIABLE-REF-SYSCOND, SW-VCD-CRITERION-REF-SYSCOND
Is context for:
Text, CONF-ITEM-CODED-REF, CONF-ITEM-PHYS-REF, FR-FEATURE-REF, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF


2.631. SW-SYSTEM

Description
<SW-SYSTEM> describes one particular system within the current file. This supports the transfer of calibration data of multi-ECU systems within one file.
Example
<SW-SYSTEM>
                   <SHORT-NAME>DEMO</SHORT-NAME>
                   <SW-INSTANCE-SPEC>
                      <INTRODUCTION>
                         <P>This is the system to demonstrate, how CDF should work.</P>
                      </INTRODUCTION>
                      <SW-INSTANCE-TREE>
                         <SHORT-NAME>Summertest</SHORT-NAME>
                         <SW-INSTANCE>
                            <LONG-NAME>faule Bären aus München (Viktualienmarkt)</LONG-NAME>
                            <SHORT-NAME>FBAM_V</SHORT-NAME> ... </SW-INSTANCE>
                      </SW-INSTANCE-TREE>
                   </SW-INSTANCE-SPEC>
                </SW-SYSTEM>
Formal Description
Within context of: | SW-SYSTEMS
Is context for: | NA, TBD, TBR, LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, INTRODUCTION, CONF-SPEC, SW-ARCHITECTURE, SW-SCHEDULING-SPEC, SW-TEST-SPEC, SW-DATA-DICTIONARY-SPEC, SW-COMPONENT-SPEC, SW-INSTANCE-SPEC, SW-COLLECTION-SPEC, SW-USER-RIGHT-SPEC, SW-CPU-SPEC, SW-CALIBRATION-METHOD-SPEC, SW-VCD-SPEC, ADD-SPEC
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-SYSTEM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | CHAPTER CONF-ITEM CONF-RULE DEF-ITEM FIGURE FORMULA PRM SDG STD SW-ADDR-METHOD SW-AXIS-TYPE SW-BASE-TYPE SW-CALIBRATION-METHOD SW-CALPRM SW-CALPRM-PROTOTYPE SW-CLASS SW-CLASS-ATTR-IMPL SW-CLASS-INSTANCE SW-CLASS-PROTOTYPE SW-CODE-SYNTAX SW-COLLECTION SW-COMPU-METHOD SW-CPU-MEM-SEG SW-DATA-CONSTR SW-EVENT SW-EVENT-SOURCE SW-FEATURE SW-FEATURE-INTERFACE SW-FEATURE-VARIANT SW-GENERIC-AXIS-PARAM-TYPE SW-INSTANCE SW-INSTANCE-TREE SW-OPER-MODE SW-RECORD-LAYOUT SW-SERVICE SW-SERVICE-ARG SW-SERVICE-PROTOTYPE SW-SERVICE-RETURN SW-SYSTEMCONST SW-TASK SW-TEMPLATE SW-UNIT SW-USER-ACCESS-CASE SW-USER-GROUP SW-VARIABLE SW-VARIABLE-PROTOTYPE SW-VCD-CRITERION SYNOPSIS TABLE TOPIC XDOC XFILE XREF-TARGET | Fixed Namespace. This attribute is assigned to elements which define a namespace for linkable objects. The attribute contains a list of elements, where the element carrying the attribute serves as a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names including the namespaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')


2.632. SW-SYSTEMCONST

Description
This element specifies a system constant. Normally, a system constant can be accessed during compilation time (not during runtime). A system constant can belong to a specific category <CATEGORY>. Physical values <SW-VALUES-PHYS> or internal values <SW-VALUES-CODED> can be specified. If the system constant is referenced in code, but has only been set physically, the converted value is applied in the place of the reference. Therefore, the references to system constants are literally replaced by the value of the referenced system constant (calculated where necessary).
Example
<MSRSW>
                   <ADMIN-DATA>
                      <LANGUAGE>EN</LANGUAGE>
                   </ADMIN-DATA>
                   <INTRODUCTION></INTRODUCTION>
                   <SW-SYSTEMS>
                      <SW-SYSTEM>
                         <LONG-NAME><?xm-replace_text {LONG-NAME}></LONG-NAME>
                         <SHORT-NAME><?xm-replace_text {SHORT-NAME}></SHORT-NAME>
                         <SW-DATA-DICTIONARY-SPEC>
                            <SW-SYSTEMCONSTS>
                               <SW-SYSTEMCONST>
                                  <LONG-NAME><?xm-replace_text{LONG-NAME}></LONG-NAME>
                                  <SHORT-NAME>sy_medium_temperature</SHORT-NAME>
                                  <CATEGORY>scaling</CATEGORY>
                                  <SW-VALUES-PHYS>
                                     <V>20</V>
                                  </SW-VALUES-PHYS>
                                  <DESC>This systemconstant describes the medium athmosphere temperature which is expected in the target market continent. It is used for clima control purposed only </DESC>
                               </SW-SYSTEMCONST>
                            </SW-SYSTEMCONSTS>
                            <SW-COMPU-METHODS>
                               <SW-COMPU-METHOD>
                                  <SHORT-NAME>TEMP</SHORT-NAME>
                                  <SW-UNIT-REF>degC</SW-UNIT-REF>
                                  <SW-COMPU-PHYS-TO-INTERNAL>
                                     <SW-COMPU-SCALES>
                                        <SW-COMPU-SCALE>
                                           <LOWER-LIMIT>-30</LOWER-LIMIT>
                                           <UPPER-LIMIT>130</UPPER-LIMIT>
                                           <SW-COMPU-RATIONAL-COEFFS>
                                              <SW-COMPU-NUMERATOR>
                                                 <V>60</V>
                                                 <V>2</V>
                                              </SW-COMPU-NUMERATOR>
                                              <SW-COMPU-DENOMINATOR>
                                                 <V>1</V>
                                              </SW-COMPU-DENOMINATOR>
                                           </SW-COMPU-RATIONAL-COEFFS>
                                        </SW-COMPU-SCALE>
                                     </SW-COMPU-SCALES>
                                  </SW-COMPU-PHYS-TO-INTERNAL>
                               </SW-COMPU-METHOD>
                            </SW-COMPU-METHODS>
                         </SW-DATA-DICTIONARY-SPEC>
                         <SW-INSTANCE-SPEC>
                            <SW-INSTANCE-TREE>
                               <SHORT-NAME>sampledata</SHORT-NAME>
                               <SW-INSTANCE>
                                  <SHORT-NAME>ClimaLimit</SHORT-NAME>
                                  <SW-INSTANCE-PROPS-VARIANTS>
                                     <SW-INSTANCE-PROPS-VARIANT>
                                        <SW-AXIS-CONTS>
                                           <SW-AXIS-CONT>
                                              <SW-VALUES-PHYS>
                                                 <VF>
                                                    <SW-SYSTEMCONST-PHYS-REF>sy_medium_temperature</SW-SYSTEMCONST-PHYS-REF> + 10</VF>
                                              </SW-VALUES-PHYS>
                                              <SW-VALUES-CODED>
                                                 <VF>
                                                    <SW-SYSTEMCONST-CODED-REF>sy_medium_temperature</SW-SYSTEMCONST-CODED-REF> + 80</VF>
                                              </SW-VALUES-CODED>
                                           </SW-AXIS-CONT>
                                        </SW-AXIS-CONTS>
                                     </SW-INSTANCE-PROPS-VARIANT>
                                  </SW-INSTANCE-PROPS-VARIANTS>
                               </SW-INSTANCE>
                            </SW-INSTANCE-TREE>
                         </SW-INSTANCE-SPEC>
                      </SW-SYSTEM>
                   </SW-SYSTEMS>
                </MSRSW>
Formal Description
Within context of: | SW-SYSTEMCONSTS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-VALUES-PHYS, SW-VALUES-CODED, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-SYSTEMCONST | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.633. SW-SYSTEMCONST-CODED-REF

Description
This element references <SW-SYSTEMCONST>, whereby in the case of <SW-SYSTEMCONST> , it concerns an internal system constant.
Example
Formal Description
Within context of: | LOWER-LIMIT, MAX-TEXT-LENGTH, MIN-INCR-SIZE, MIN-TEXT-LENGTH, SW-CALPRM-MAX-TEXT-SIZE, SW-COMPU-GENERIC-MATH, SW-DATA-DEPENDENCY-ARGS, SW-MAX-AXIS-POINTS, SW-MIN-AXIS-POINTS, SW-NUMBER-OF-AXIS-POINTS, SW-SYSCOND, UPPER-LIMIT, VF
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-SYSTEMCONST | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.634. SW-SYSTEMCONST-PHYS-REF

Description
This element references <SW-SYSTEMCONST>, whereby in the case of <SW-SYSTEMCONST> , it concerns physical system constant.
Example
Formal Description
Within context of: | LOWER-LIMIT, MAX-TEXT-LENGTH, MIN-INCR-SIZE, MIN-TEXT-LENGTH, SW-CALPRM-MAX-TEXT-SIZE, SW-COMPU-GENERIC-MATH, SW-DATA-DEPENDENCY-ARGS, SW-MAX-AXIS-POINTS, SW-MIN-AXIS-POINTS, SW-NUMBER-OF-AXIS-POINTS, SW-SYSCOND, UPPER-LIMIT, VF
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-SYSTEMCONST | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.635. SW-SYSTEMCONST-REF

Description
This element references <SW-SYSTEMCONST> .
Example
Formal Description
Within context of: | SW-SYSTEMCONST-REF-SYSCOND, SW-SYSTEMCONST-REFS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-SYSTEMCONST | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.636. SW-SYSTEMCONST-REF-SYSCOND

Description
Use <SW-SYSTEMCONST-REF-SYSCOND> to create a <SW-SYSTEMCONST-REF> that will be valid only when the corresponding <SW-SYSCOND> expression evaluates to true. This is useful when a <SW-SYSTEMCONST-REF> shall be used when system constant has a certain value
Example
This Systemconstant reference is used when LINA_Gear is less or equal to 4.
<SW-SYSTEMCONST-REF-SYSCOND>
                  <SW-SYSTEMCONST-REF>sysconst_Ref</SW-SYSTEMCONST-REF>
                  <SW-SYSCOND>
                    <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&lt;=4
                  </SW-SYSCOND>
                </SW-SYSTEMCONST-REF-SYSCOND>
Formal Description
Within context of: | SW-SYSTEMCONST-REFS
Is context for: | SW-SYSTEMCONST-REF, SW-SYSCOND


2.637. SW-SYSTEMCONST-REFS

Description
Container element for <SW-SYSTEMCONST-REF> .
Example
Formal Description
Within context of: | SW-COLLECTION-CONT, SW-FEATURE, SW-FEATURE-ELEMENTS
Is context for: | SW-SYSTEMCONST-REF, SW-SYSTEMCONST-REF-SYSCOND


2.638. SW-SYSTEMCONSTS

Description
Container element for <SW-SYSTEMCONST> .
Example
Formal Description
Within context of: | SW-DATA-DICTIONARY-SPEC
Is context for: | ADMIN-DATA, SW-SYSTEMCONST


2.639. SW-SYSTEMS

Description
Container element for <SW-SYSTEM> . The main contents of an MSRSW instance is located beneath SW-SYSTEM. This enables the support of several ECU systems, as well as of a system with more than one CPU.
Example
<SW-SYSTEMS>
                   <SW-SYSTEM>
                      <SHORT-NAME>DEMO</SHORT-NAME>
                      <SW-INSTANCE-SPEC>
                         <INTRODUCTION>
                            <P>This is the system to demonstrate, how CDF should work.</P>
                         </INTRODUCTION>
                         <SW-INSTANCE-TREE>
                            <SHORT-NAME>Summertest</SHORT-NAME>
                            <SW-INSTANCE>
                               <LONG-NAME>faule Bären aus München (Viktualienmarkt)</LONG-NAME>
                               <SHORT-NAME>FBAM_V</SHORT-NAME> ... </SW-INSTANCE>
                         </SW-INSTANCE-TREE>
                      </SW-INSTANCE-SPEC>
                   </SW-SYSTEM>
                </SW-SYSTEMS>
Formal Description
Within context of: | MSRSW
Is context for: | SW-SYSTEM


2.640. SW-TASK

Description
This element describes a specific task. For further details, see 2.649. SW-TASK-SPEC .
Example
Formal Description
Within context of: | SW-TASKS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-TASK-PREEMPTIVE-PRIO, SW-TASK-COOPERATIVE-PRIO, SW-TASK-LATENCY, SW-TASK-DEADLINE, SW-TASK-MAX-ACTIVATION, SW-PROCESS-LISTS, SW-SERVICE-REFS, SW-REFRESH-TIMING, ADD-INFO
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-TASK | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.641. SW-TASK-COOPERATIVE-PRIO

Description
Example
Formal Description
Within context of: | SW-TASK
Is context for: | Text


2.642. SW-TASK-DEADLINE

Description
This element represents the latest point (in time or in angle) when the task in question will be or shall be finished (depending on the usecase). It gives the maximum allowed amount of time til the result of the interrupt service routine is available. It is the sum of latency, worst case runtime and further interrupts.
Hint
In demarcation to <SW-TASK-DEADLINE>, <SW-TASK-LATENCY> gives the duration between the event /interrupt and the beginning of task execution.
Example
Formal Description
Within context of: | SW-TASK
Is context for: | SW-CSE-CODE, SW-CSE-CODE-FACTOR


2.643. SW-TASK-LATENCY

Description
Example
Formal Description
Within context of: | SW-TASK
Is context for: | SW-CSE-CODE, SW-CSE-CODE-FACTOR


2.644. SW-TASK-MAX-ACTIVATION

Description
Example
Formal Description
Within context of: | SW-TASK
Is context for: | Text


2.645. SW-TASK-PREEMPTIVE-PRIO

Description
Example
Formal Description
Within context of: | SW-TASK
Is context for: | Text


2.646. SW-TASK-REF

Description
This element references <SW-TASK> .
Example
Formal Description
Within context of: | SW-ACCESSED-SERVICE, SW-DATA-DEF-PROPS, SW-EVENT-TASK-TERMINATED, SW-PROCESS, SW-TASK-REF-SYSCOND, SW-TASK-REFS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-TASK | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.647. SW-TASK-REF-SYSCOND

Description
Example
Formal Description
Within context of: | SW-TASK-REFS
Is context for: | SW-TASK-REF, SW-SYSCOND


2.648. SW-TASK-REFS

Description
Example
Formal Description
Within context of: | SW-EVENT, SW-FEATURE-ELEMENTS
Is context for: | SW-TASK-REF, SW-TASK-REF-SYSCOND


2.649. SW-TASK-SPEC

Description
This element describes the task distribution in the ECU, which is provided through the operating system in the ECU. Here, tasks concering time response are specified. The general model is:
  • The operating system performs a number of tasks, e.g. an angle-synchrnous task (synchronous to current crankshaft angle) and/or several time-synchronous tasks.
  • The individual features establish processes which should run in a specific order, within the respective task.
This model is supported by:
  • Definition of tasks within <SW-TASK-SPEC>, once per system globally in <SW-ARCHITECTURE>
  • Definition of processes within <SW-FEATURE-DECOMPOSITION> . Here, allocations to the processes are also performed in the tasks.
Example
Formal Description
Within context of: | SW-ARCHITECTURE, SW-SCHEDULING-SPEC
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-TASKS, ADD-INFO


2.650. SW-TASKS

Description
Container element for <SW-TASK> .
Example
Formal Description
Within context of: | SW-TASK-SPEC
Is context for: | SW-TASK


2.651. SW-TEMPLATE

Description
This element permits the anticipated definition of <SW-DATA-DEF-PROPS>, so that this can be reapplied at <SW-VARIABLE> or <SW-CALPRM> . In their conception, templates only serve to simplify writing. It is not intended that they find expression in the ECU.
If, for example, a variable refers to a template and defines characteristics in <SW-DATA-DEF-PROPS> itself, these overwrite the "inherited" template characteristics.
Example
Formal Description
Within context of: | SW-TEMPLATES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-TEMPLATE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.652. SW-TEMPLATE-REF

Description
This element references <SW-TEMPLATE> .
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS, SW-TEMPLATE-REF-SYSCOND, SW-TEMPLATE-REFS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-TEMPLATE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.653. SW-TEMPLATE-REF-SYSCOND

Description
Use <SW-TEMPLATE-REF-SYSCOND> to create a <SW-TEMPLATE-REF> that will be valid only when the corresponding <SW-SYSCOND> expression evaluates to true. This is useful when a <SW-TEMPLATE-REF> shall be used when system constant has a certain value
Example
This Template reference is used when LINA_Gear is less or equal to 4.
<SW-TEMPLATE-REF-SYSCOND>
                  <SW-TEMPLATE-REF>template_Ref</SW-TEMPLATE-REF>
                  <SW-SYSCOND>
                    <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&lt;=4
                  </SW-SYSCOND>
                </SW-TEMPLATE-REF-SYSCOND>
Formal Description
Within context of: | SW-TEMPLATE-REFS
Is context for: | SW-TEMPLATE-REF, SW-SYSCOND


2.654. SW-TEMPLATE-REFS

Description
This is a container for <SW-TEMPLATE-REF>s.
Example
Formal Description
Within context of: | SW-FEATURE-ELEMENTS
Is context for: | SW-TEMPLATE-REF, SW-TEMPLATE-REF-SYSCOND


2.655. SW-TEMPLATES

Description
Container element for <SW-TEMPLATE> .
Example
Formal Description
Within context of: | SW-DATA-DICTIONARY-SPEC
Is context for: | ADMIN-DATA, SW-TEMPLATE


2.656. SW-TEST-DESC

Description
This element describes the scope of the test carried out on the current context, in text form.
Example
Formal Description
Within context of: | SW-CLASS, SW-FEATURE
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.657. SW-TEST-SPEC

Description
This element provides a textual definition of the test specification belonging to a software system <SW-SYSTEM> .
Example
Formal Description
Within context of: | SW-SYSTEM
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.658. SW-UNIT

Description
<SW-UNIT> describes a measurement unit. This may concern both a <SI-UNIT> and a unit of measurement, which references other <SI-UNIT> via <SW-UNIT-REF> and converts to the referenced <SI-UNIT> via <SW-UNIT-CONVERSION-METHOD> .
Example
Formal Description
Within context of: | SW-UNITS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-UNIT-DISPLAY, SW-UNIT-CONVERSION-METHOD, SI-UNIT, SW-UNIT-REF, ADD-INFO
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-UNIT | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.659. SW-UNIT-CONVERSION-METHOD

Description
Describes the linear formula used to convert <SW-UNIT> into another <SW-UNIT>, which is specified in the parent element of <SW-UNIT-CONVERSION-METHOD> by means of the subelement <SW-UNIT-REF>. Refer to 2.250. SI-UNIT for an example.
Example
Formal Description
Within context of: | SW-UNIT
Is context for: | SW-UNIT-GRADIENT, SW-UNIT-OFFSET


2.660. SW-UNIT-DISPLAY

Description
Describes the textual representation of a measuring unit, that is specified in the parent element <SW-UNIT> .
Example
Formal Description
Within context of: | SW-UNIT
Is context for: | Text, SUP, SUB


2.661. SW-UNIT-GRADIENT

Description
Describes the gradient (the slope) in the linear conversion formula of a <SW-UNIT-CONVERSION-METHOD> .
Example
Formal Description
Within context of: | SW-UNIT-CONVERSION-METHOD
Is context for: | Text


2.662. SW-UNIT-OFFSET

Description
Describes the Y-axis in the linear conversion formula of a <SW-UNIT-CONVERSION-METHOD> .
Example
Formal Description
Within context of: | SW-UNIT-CONVERSION-METHOD
Is context for: | Text


2.663. SW-UNIT-REF

Description
<SW-UNIT-REF> is a formal reference to a measurement unit. Since this was not requested by CDF , the reference is treated as a measurement unit designator.
Caution
The contents of <SW-UNIT-REF> must be in accordance with the <SHORT-NAME> restrictions. In particular, there must be no white-spaces and special characters.
Example
For an example, see 2.285. SW-ARRAY-INDEX 2.501. SW-INSTANCE .
Formal Description
Within context of: | CONF-VALUE-PROPS, SW-AXIS-CONT, SW-AXIS-INDIVIDUAL, SW-COMPU-METHOD, SW-DATA-DEF-PROPS, SW-PHYS-CONSTRS, SW-UNIT, SW-UNIT-REF-SYSCOND, SW-UNIT-REFS, SW-VARIABLE-PROTOTYPE
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-UNIT | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.664. SW-UNIT-REF-SYSCOND

Description
Use <SW-UNIT-REF-SYSCOND> to create a <SW-UNIT-REF> that will be valid only when the corresponding <SW-SYSCOND> expression evaluates to true. This is useful when a <SW-UNIT-REF> shall be used when system constant has a certain value
Example
This Unit reference is used when LINA_Gear is less or equal to 4.
<SW-UNIT-REF-SYSCOND>
                  <SW-UNIT-REF>Unit_Ref</SW-UNIT-REF>
                  <SW-SYSCOND>
                    <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&lt;=4
                  </SW-SYSCOND>
                </SW-UNIT-REF-SYSCOND>
Formal Description
Within context of: | SW-UNIT-REFS
Is context for: | SW-UNIT-REF, SW-SYSCOND


2.665. SW-UNIT-REFS

Description
Container element for <SW-UNIT-REF> .
Example
Formal Description
Within context of: | SW-COLLECTION-CONT, SW-FEATURE-ELEMENTS
Is context for: | SW-UNIT-REF, SW-UNIT-REF-SYSCOND


2.666. SW-UNITS

Description
Container element for <SW-UNIT> .
Example
Formal Description
Within context of: | SW-DATA-DICTIONARY-SPEC
Is context for: | ADMIN-DATA, SW-UNIT


2.667. SW-USER-ACCESS-CASE

Description
This element describes an access operation (e.g. read access), which is referenced in the access authorization table (in <SW-ACCESS-DEFINITIONS> ).
Example
See 2.262. SW-ACCESS-DEF .
Formal Description
Within context of: | SW-USER-ACCESS-CASES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-USER-ACCESS-CASE-REFS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | String (CDATA) | SW-USER-ACCESS-CASE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.668. SW-USER-ACCESS-CASE-REF

Description
This element references <SW-USER-ACCESS-CASE> .
Example
Formal Description
Within context of: | SW-ACCESS-DEF, SW-USER-ACCESS-CASE-REFS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-USER-ACCESS-CASE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.669. SW-USER-ACCESS-CASE-REFS

Description
Container element for <SW-USER-ACCESS-CASE-REF> .
Example
Formal Description
Within context of: | SW-USER-ACCESS-CASE
Is context for: | SW-USER-ACCESS-CASE-REF


2.670. SW-USER-ACCESS-CASES

Description
Container element for <SW-USER-ACCESS-CASE> .
Example
Formal Description
Within context of: | SW-USER-RIGHT-SPEC
Is context for: | SW-USER-ACCESS-CASE


2.671. SW-USER-ACCESS-DEFINTIONS

Description
Container element for <SW-ACCESS-DEF> .
Example
Formal Description
Within context of: | SW-USER-RIGHT-SPEC
Is context for: | SW-ACCESS-DEF


2.672. SW-USER-GROUP

Description
This element specifies a user group which can be referenced in the access authorization table ( <SW-ACCESS-DEFINITIONS>). A <SW-USER-GROUP>consists of <SYSTEM-USER>s. In turn, a <SW-USER-GROUP> can reference other user groups (through <SW-USER-GRUOP-REFS>) and <TEAM-MEMBER-REFS> .
Example
See 2.262. SW-ACCESS-DEF .
Formal Description
Within context of: | SW-USER-GROUPS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, TEAM-MEMBER-REFS, SYSTEM-USERS, SW-USER-GROUP-REFS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | String (CDATA) | SW-USER-GROUP | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.673. SW-USER-GROUP-REF

Description
This element references <SW-USER-GROUP> .
Example
Formal Description
Within context of: | SW-ACCESS-DEF, SW-USER-GROUP-REFS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-USER-GROUP | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.674. SW-USER-GROUP-REFS

Description
Container element for <SW-USER-GROUP-REF> .
Example
Formal Description
Within context of: | SW-USER-GROUP
Is context for: | SW-USER-GROUP-REF


2.675. SW-USER-GROUPS

Description
Container element for <SW-USER-GROUP> .
Example
Formal Description
Within context of: | SW-USER-RIGHT-SPEC
Is context for: | SW-USER-GROUP


2.676. SW-USER-RIGHT-SPEC

Description
This element specifies the <SW-USER-GROUPS>, the access operations ( <SW-USER-ACCESS-CASES>) and the actual access authorization table ( <SW-ACCESS-DEFINITIONS> ). Thus the following is specified in this element:
  • For which persons access authorization should be considered
  • The types of access available
  • Which person has what type of access
Example
See 2.262. SW-ACCESS-DEF
Formal Description
Within context of: | SW-SYSTEM
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-USER-GROUPS, SW-USER-ACCESS-CASES, SW-USER-ACCESS-DEFINTIONS, ADD-INFO


2.677. SW-VALUES-CODED

Description
Describes internal values.
Example
Formal Description
Within context of: | SW-AXIS-CONT, SW-AXIS-GENERIC, SW-SYSTEMCONST
Is context for: | VF, VT, V, VG, SW-INSTANCE-REF


2.678. SW-VALUES-CODED-HEX

Description
Describes internal values.
Example
Formal Description
Within context of: | SW-AXIS-CONT
Is context for: | VF, VT, V, VG, SW-INSTANCE-REF


2.679. SW-VALUES-GENERIC

Description
This element contains axis values in any format, which are specified via the attribute [TYPE] . The value of the attribute must be agreed upon amongst the process partners.
Example
<SW-VALUES-GENERIC TYPE="octal">
                   <VF>001</VF>
                   <VF>003</VF>
                   <VF>007</VF>
                   <VF>013</VF>
                   <VF>015</VF>
                </SW-VALUES-GENERIC>
Formal Description
Within context of: | SW-AXIS-CONT
Is context for: | VF, VT, V, VG, SW-INSTANCE-REF
Name | Type | Notes
[TYPE] required | SGML string (NMTOKEN) | Format in which the axis values are given.


2.680. SW-VALUES-PHYS

Description
<SW-VALUES-PHYS> receives the physical values of the calibration item. The values can either be numeric ( <V>) or textual ( <VT> ) but not mixed.
Example
For an example, see 2.285. SW-ARRAY-INDEX 2.501. SW-INSTANCE .
Formal Description
Within context of: | SW-AXIS-CONT, SW-AXIS-GENERIC, SW-SYSTEMCONST
Is context for: | VF, VT, V, VG, SW-INSTANCE-REF


2.681. SW-VAR-INIT-VALUE

Description
Describes initial values of the current variable or the current parameter.
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | Text


2.682. SW-VAR-NOT-AVL-VALUE

Description
The internal value for "variable not available" is entered in this element <SW-VAR-NOT-AVL-VALUE> (Software Variable Not Available Value). This is the value assumed by the variable, if the corresponding external value is not available (either if it has not yet been recorded, or if an error has occurred). It is not possible to have an external value for not available, for the very reason that it is not available.
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | Text


2.683. SW-VARIABLE

Description
This element specifies the characteristics of variables (measurands) in the ECU. Variables are objects that are not adapted to the run time of the vehicle. Calibration parameters are quite the opposite ( <SW-CALPRM> s), being objects that are manipulated during the run time of the software.
For the most part, variables consist of:
  • Long and short labels ( <LONG-NAME>, <SHORT-NAME> )
  • Short description ( <DESC> )
  • Category ( <CATEGORY> ), describing the basic structure of the variables
  • Field size ( <SW-ARRAYSIZE> ), in case the variable is executed as an array
  • The technical characteristics ( <SW-DATA-DEF-PROPS>)
  • Sub-structures simulated through the integration of <SW-VARIABLES> .
  • Comments ( <ANNOTATIONS> ), enabling notes to be passed on from one stage to the next, throughout the development process.
  • Additional information ( <ADD-INFO>) in verbal form. Here, formal components can also be accommodated when [SI] -attributes are used.
Example
Formal Description
Within context of: | SW-VARIABLES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-ARRAYSIZE, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS, SW-VARIABLES, ANNOTATIONS, ADD-INFO
Name
Type
Values / Default
Notes
[CALIBRATION]
has default value
Value selection (NAMEDTOKENGROUP)
  • CALIBRATION
  • NO-CALIBRATION
  • NOT-IN-MC-SYSTEM
CALIBRATION: the current variable can be applicated. NO-CALIBRATION: the current variable cannot be applicated. NOT-IN-MC-SYSTEM: the current variable is not available in the adjustment system
[ID]
optional
ID (ID)
Unambiguous identifier of the element within the document.
[F-ID-CLASS]
fixed value
SGML string (NMTOKEN)
SW-VARIABLE
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE]
fixed value
SGML strings (NMTOKENS)
SW-VARIABLE
Fixed Namespace. This attribute is assigned to elements which define a namespace for linkable objects. The attribute contains a list of elements, where the element carrying the attribute serves as a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names including the namespaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')

These are identical to the technical characteristics of parameters


2.684. SW-VARIABLE-ACCESS-IMPL

Description
Example
Formal Description
Within context of: | SW-ACCESSED-VARIABLE
Is context for: | Text


2.685. SW-VARIABLE-ACCESS-IMPL-POLICY

Description
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | Text


2.686. SW-VARIABLE-ACCESS-SEQUENCE

Description
Example
Formal Description
Within context of: | SW-ACCESSED-VARIABLE
Is context for: | Text


2.687. SW-VARIABLE-IMPL

Description
This element describes the implementation details of a class attribute which manifests itself as a variable.
Example
Formal Description
Within context of: | SW-VARIABLE-IMPLS
Is context for: | SW-VARIABLE-PROTOTYPE-REF, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS


2.688. SW-VARIABLE-IMPLS

Description
Container element for <SW-VARIABLE-IMPL> .
Example
Formal Description
Within context of: | SW-CLASS-ATTR-IMPL, SW-CLASS-ATTR-INSTANCE-IMPL
Is context for: | SW-VARIABLE-IMPL


2.689. SW-VARIABLE-KIND

Description
This element describes the use of a variable with regards to organization.
Example
<SW-VARIABLE-KIND>Control Flow</SW-VARIABLE-KIND>
Formal Description
Within context of: | SW-DATA-DEF-PROPS
Is context for: | Text


2.690. SW-VARIABLE-PROTOTYPE

Description
This element describes the prototype declaration of a class attribute, which appears in the form of a variable.
Example
See 2.331. SW-CLASS
Formal Description
Within context of: | SW-VARIABLE-PROTOTYPES
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-ARRAYSIZE, SW-UNIT-REF, SW-SYSCOND, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS-SYSCONDS, ANNOTATIONS, ADD-INFO
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | String (CDATA) | SW-VARIABLE-PROTOTYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.691. SW-VARIABLE-PROTOTYPE-REF

Description
This element references <SW-VARIABLE-PROTOTYPE> .
Example
Formal Description
Within context of: | SW-VARIABLE-IMPL
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-VARIABLE-PROTOTYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.692. SW-VARIABLE-PROTOTYPES

Description
Container element for <SW-VARIABLE-PROTOTYPE> .
Example
Formal Description
Within context of: | SW-CLASS-ATTR
Is context for: | SW-VARIABLE-PROTOTYPE


2.693. SW-VARIABLE-REF

Description
This element references <SW-VARIABLE> .
Example
Formal Description
Within context of: | SW-ACCESSED-VARIABLE, SW-CALPRM-TARGET, SW-COMPARISON-VARIABLES, SW-CONSTR-OBJECTS, SW-DATA-DEPENDENCY-ARGS, SW-EFFECT-FLOW, SW-EFFECTING-VARIABLE, SW-EVENT-MESSAGE-RECEIVED, SW-FEATURE-MODEL-ONLY-VARIABLES, SW-HOST-VARIABLE, SW-SEMAPHORE, SW-VARIABLE-REF-SYSCOND, SW-VARIABLE-REFS, SW-VARIABLES-READ, SW-VARIABLES-READ-WRITE, SW-VARIABLES-WRITE, SW-VCD-CRITERION
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-VARIABLE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.694. SW-VARIABLE-REF-SYSCOND

Description
This element is a conditional reference to a variable. It is used to ensure that the assignment of variables to functions is dependent on the settings of system constants. For this reason, the element exists parallel to <SW-VARIABLE-REF> .
Example
Formal Description
Within context of: | SW-ACCESSED-VARIABLE, SW-VARIABLE-REFS, SW-VARIABLES-READ, SW-VARIABLES-READ-WRITE, SW-VARIABLES-WRITE
Is context for: | SW-VARIABLE-REF, SW-SYSCOND


2.695. SW-VARIABLE-REFS

Description
Container element for <SW-VARIABLE-REF> .
Example
Formal Description
Within context of: | SW-AXIS-INDIVIDUAL, SW-COLLECTION-CONT, SW-FEATURE-ELEMENTS, SW-MC-FRAME
Is context for: | SW-VARIABLE-REF, SW-VARIABLE-REF-SYSCOND


2.696. SW-VARIABLE-USAGE

Description
Example
Formal Description
Within context of: | SW-ACCESSED-VARIABLE
Is context for: | Text


2.697. SW-VARIABLES

Description
Container element for <SW-VARIABLE> .
Example
Formal Description
Within context of: | SW-DATA-DICTIONARY-SPEC, SW-VARIABLE
Is context for: | ADMIN-DATA, SW-VARIABLE


2.698. SW-VARIABLES-READ

Description
This element specifies variables restricted to read access only.
Example
Formal Description
Within context of: | SW-FEATURE-DESIGN-DATA, SW-FEATURE-EXPORT-VARIABLES, SW-FEATURE-IMPORT-VARIABLES
Is context for: | SW-VARIABLE-REF, SW-VARIABLE-REF-SYSCOND


2.699. SW-VARIABLES-READ-WRITE

Description
This element specifies variables with read and write access.
Example
Formal Description
Within context of: | SW-FEATURE-DESIGN-DATA, SW-FEATURE-EXPORT-VARIABLES, SW-FEATURE-IMPORT-VARIABLES, SW-FEATURE-LOCAL-VARIABLES
Is context for: | SW-VARIABLE-REF, SW-VARIABLE-REF-SYSCOND


2.700. SW-VARIABLES-WRITE

Description
This element specifies variables restricted to write access only.
Example
Formal Description
Within context of: | SW-FEATURE-DESIGN-DATA, SW-FEATURE-EXPORT-VARIABLES, SW-FEATURE-IMPORT-VARIABLES
Is context for: | SW-VARIABLE-REF, SW-VARIABLE-REF-SYSCOND


2.701. SW-VCD-CRITERIA

Description
Container element for <SW-VCD-CRITERION> .
Example
Formal Description
Within context of: | SW-VCD-SPEC
Is context for: | SW-VCD-CRITERION


2.702. SW-VCD-CRITERION

Description
The variant criterion describes the switchover of variant encoded parameters. The value X over the SW-VARIABLE-REF referenced variable selects the criteria value. If the value X equals 0, the first criteria value is used, if it is 1, the second is used.
Example
Formal Description
Within context of: | SW-VCD-CRITERIA
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-CALPRM-REF, SW-VARIABLE-REF, SW-VCD-CRITERION-POSSIBLE-VALUES, SW-COMPU-METHOD-REF
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | String (CDATA) | SW-VCD-CRITERION | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.703. SW-VCD-CRITERION-POSSIBLE-VALUES

Description
Possible values for variant encoding.
Example
<SW-VCD-CRITERION>
                   <SHORT-NAME>GETRIEBE</SHORT-NAME>
                   <SW-VCD-POSSIBLE-VALUES>
                      <VT>HAND</VT>
                      <VT>AUTOMATIK</VT>
                   </SW-VCD-POSSIBLE-VALUES>
                </SW-VCD-CRITERION>
                <SW-VCD-CRITERION>
                   <SHORT-NAME>KAROSSERIE</SHORT-NAME>
                   <SW-VCD-POSSIBLE-VALUES>
                      <VT>CABRIO</VT>
                      <VT>KOMBI</VT>
                      <VT>LIMOUSINE</VT>
                   </SW-VCD-POSSIBLE-VALUES>
                </SW-VCD-CRITERION>
Formal Description
Within context of: | SW-VCD-CRITERION
Is context for: | VT


2.704. SW-VCD-CRITERION-REF

Description
References the variant criterion <SW-VCD-CRITERION> of the parameter, which is specified in the <SW-VCD-SPEC> . This is therefore the current variant criterion that has been set for a parameter.
Example
Formal Description
Within context of: | SW-VCD-CRITERION-REF-SYSCOND, SW-VCD-CRITERION-REFS, SW-VCD-CRITERION-VALUE
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-VCD-CRITERION | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.705. SW-VCD-CRITERION-REF-SYSCOND

Description
Use <SW-VCD-CRITERION-REF-SYSCOND> to create a <SW-VCD-CRITERION-REF> that will be valid only when the corresponding <SW-SYSCOND> expression evaluates to true. This is useful when a <SW-VCD-CRITERION-REF> shall be used when system constant has a certain value
Example
This VCD Criterion reference is used when LINA_Gear is less or equal to 4.
<SW-VCD-CRITERION-REF-SYSCOND>
                  <SW-VCD-CRITERION-REF>vcd_cr_Ref</SW-VCD-CRITERION-REF>
                  <SW-SYSCOND>
                    <SW-SYSTEMCONST-PHYS-REF>LINA_Gear</SW-SYSTEMCONST-PHYS-REF>&lt;=4
                  </SW-SYSCOND>
                </SW-VCD-CRITERION-REF>
Formal Description
Within context of: | SW-VCD-CRITERION-REFS
Is context for: | SW-VCD-CRITERION-REF, SW-SYSCOND


2.706. SW-VCD-CRITERION-REFS

Description
Container element for <SW-VCD-CRITERION-REF> .
Example
Formal Description
Within context of: | SW-DATA-DEF-PROPS, SW-FEATURE-ELEMENTS
Is context for: | SW-VCD-CRITERION-REF, SW-VCD-CRITERION-REF-SYSCOND


2.707. SW-VCD-CRITERION-VALUE

Description
Defines the values for variant criteria. All of the values that are possible (see 2.703. SW-VCD-CRITERION-POSSIBLE-VALUES ) are located in <SW-VCD-CRITERION-POSSIBLE-VALUES>. Die instantiated combinations in the instance tree, for which the variant criteria are currently valid, are formed by a combination of <SW-VCD-CRITERION-REFS> and <SW-VCD-CRITERION-VALUES>, which are both located in the sub-tree of <SW-INSTANCE-PROPS-VARIANT> .
Example
Formal Description
Within context of: | SW-VCD-CRITERION-VALUES
Is context for: | SW-VCD-CRITERION-REF, VT


2.708. SW-VCD-CRITERION-VALUES

Description
Container element for <SW-VCD-CRITERION-VALUE> .
Example
Formal Description
Within context of: | SW-INSTANCE-PROPS-VARIANT, SW-INSTANCE-TREE
Is context for: | SW-VCD-CRITERION-VALUE


2.709. SW-VCD-SPEC

Description
The existance of this object prescribes the implementation of variant coding. Furthermore, the object contains all the information relevant for the complete variant coding process.
Example
Formal Description
Within context of: | SW-SYSTEM
Is context for: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-VCD-CRITERIA, ADD-INFO


2.710. SYN-ARGUMENT

Description
This element describes one particular Argument within the current object synopsis. The name of the argument goes into <ITEM-LABEL>. The short description goes in to <DESC>. The detailed description goes into <ADD-INFO-5>.
Example
see 2.713. SYN-EXAMPLE
Formal Description
Within context of: | SYN-ARGUMENTS
Is context for: | ITEM-LABEL, DESC, ADD-INFO-5


2.711. SYN-ARGUMENTS

Description
This element taks all arguments of the objects described in the synopsis.
Example
2.713. SYN-EXAMPLE
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | SYN-ARGUMENT


2.712. SYN-CAPTION

Description
This serves to specify the caption of a particular synopsis similar to <TABLE-CAPTION>.
Example
2.713. SYN-EXAMPLE
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  |
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SYNOPSIS |
[F-NAMESPACE] fixed value | SGML string (NMTOKEN) | SYNOPSIS |


2.713. SYN-EXAMPLE

Description
This element is used to give an example how to use the object the <SYN-SYNOPSIS> is given for.
Example
2.713. SYN-EXAMPLE
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | DESC, ADD-INFO-5


2.714. SYN-FORMAT

Description
This element specifies the format how the object for which the <SYN-SYNOPSIS> is given. Note that the target name of the target-format ist described in the <P>.
Example
see 2.713. SYN-EXAMPLE
<SYN-FORMAT>
                  <P>usage in C++</P>
                  <VERBATIM>
                     x=mmx.execute("-S myfile.xml");
                  </VERBATIM>
                  <P>usage in Visual Basic</P>
                  <VERBATIM>
                     let x=mmx.execute("-S myfile.xml");
                  </VERBATIM>
                </SYN-FORMAT>
Formal Description
Within context of: | SYN-FORMATS
Is context for: | P, VERBATIM


2.715. SYN-FORMATS

Description
This element is a container for all the possible formats in which the object described in <SYN-SYNOPSIS> can be used.
Example
see 2.713. SYN-EXAMPLE
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | SYN-FORMAT


2.716. SYN-INCLUDE

Description
This element denotes the required inclusions required by the objects for which a <SYN-SYNOPSIS> is given.
Example
see Example
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | P


2.717. SYN-OBJECT

Description
This element is used to denote an object which is described in the current synopsis. The name of the object is given as <ITEM-LABEL>. The <P> are used to give a short definition of the main purpose of the object.
Example
see Example
Formal Description
Within context of: | SYN-OBJECTS
Is context for: | ITEM-LABEL, P


2.718. SYN-OBJECTS

Description
This element serves as a container to keep all <SYN-OBJECT>s in the Synopsis.
Example
Example
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | SYN-OBJECT


2.719. SYN-RETURN-VALUE

Description
This element describes the return value of the object for which the synopsis is given. <DESC> takes a short description used for overviews. <ADD-INFO-5> is used to give a full blown specification.
Example
see Example
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | DESC, ADD-INFO-5


2.720. SYN-SEE-ALSO

Description
This element is used to to give references to similar objects and additional reference material.
Example
see Example
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | P


2.721. SYN-SEMANTICS

Description
This element is used to specify the particular semantics of the objects for which a synopsis is given. <DESC> takes an quick description intended for overview tables. <ADD-INFO-5> takes a full blown specification.
Example
see Example
Formal Description
Within context of: | SYN-SYNOPSIS
Is context for: | DESC, ADD-INFO-5


2.722. SYN-SYNOPSIS

Description
This element serves as a semiformal description of the Synopsis of an application arogramming interface. This is mainly intended to be used for generating a programmer's reference manual in MSRREP. Although there is some overlap with <SW-SERVICE> in the MSRSW-Context, this Element can be useful to specifiy a required API. Therfore <SYN-SYNOPIS> is located in free text elements on a paragraph level. <SYN-SYNOPIS> is made such that it can be redered similar to a <LABELED-LIST>. In this sense, <SYN-SYNOPSIS> can be considered as a specific form of a <LABELED-LST> .
Example
This example shows the source code of a routine called forceerror which takse three arguments.

                <SYN-SYNOPSIS>
                 <SYN-CAPTION ID="SYN.PROCEDURE.FORCEERROR">
                  <LONG-NAME>forceerror</LONG-NAME>
                 </SYN-CAPTION>
                 <SYN-OBJECTS>

                  <SYN-OBJECT>
                   <ITEM-LABEL>forceerror
                    <IE>procedure;forceerror</IE>

                    <IE>forceerror</IE>
                   </ITEM-LABEL>

                   <P>force an error</P>
                  </SYN-OBJECT>
                 </SYN-OBJECTS>
                 <SYN-FORMATS>

                  <SYN-FORMAT>

                   <P>
                    <E TYPE="ITALIC">subject</E>.forceerror(
                    <E TYPE="ITALIC">type</E>,
                    <E TYPE="ITALIC">code</E>,
                    <E TYPE="ITALIC">node</E>?)
                   </P>
                  </SYN-FORMAT>
                 </SYN-FORMATS>
                 <SYN-ARGUMENTS>

                  <SYN-ARGUMENT>
                   <ITEM-LABEL>subject</ITEM-LABEL>

                   <DESC>string</DESC>
                  </SYN-ARGUMENT>

                  <SYN-ARGUMENT>
                   <ITEM-LABEL>type</ITEM-LABEL>

                   <DESC>single string</DESC>
                  </SYN-ARGUMENT>

                  <SYN-ARGUMENT>
                   <ITEM-LABEL>code</ITEM-LABEL>

                   <DESC>single string</DESC>
                  </SYN-ARGUMENT>

                  <SYN-ARGUMENT>
                   <ITEM-LABEL>node</ITEM-LABEL>

                   <DESC>tree node</DESC>
                  </SYN-ARGUMENT>
                 </SYN-ARGUMENTS>

                 <SYN-RETURN-VALUE>

                  <DESC>null</DESC>
                  <ADD-INFO-5/>
                 </SYN-RETURN-VALUE>
                 <SYN-SEMANTICS>

                  <DESC>forces a warning/error... to be issued;

                   <E TYPE="PLAIN" FONT="MONO" COLOR="blue">subject</E> (which must evaluate to a
                                                string) is used as the message text;
                   <E TYPE="PLAIN" FONT="MONO" COLOR="blue">type</E> may be any string, e.g., "warning",
                                                "error" etc.,
                   <E TYPE="PLAIN" FONT="MONO" COLOR="blue">code</E> is
                                                used as the warning/error/.... code, e.g., "illegal input" etc.;

                   <E TYPE="PLAIN" FONT="MONO" COLOR="blue">node</E> the object to which the error
                                                node will be linked (the current target node if nothing is specified).
                  </DESC>

                  <ADD-INFO-5/>
                 </SYN-SEMANTICS>
                 <SYN-EXAMPLE>
                  <ADD-INFO-5>

                   <VERBATIM>: i "Wrong.\n".forceerror("INFO","ILLEGAL INPUT");</VERBATIM>

                   <P>returns the following output on stderr:</P>

                   <VERBATIM>FORCED-INFO (ILLEGAL INPUT):
                Wrong.
                null
                :</VERBATIM>

                  </ADD-INFO-5>
                 </SYN-EXAMPLE>
                </SYN-SYNOPSIS>
Formal Description
Within context of: | ADD-INFO, ADD-INFO-5, CHAPTER, MSR-QUERY-RESULT-P-1, TOPIC-1
Is context for: | SYN-CAPTION, SYN-OBJECTS, SYN-INCLUDE, SYN-FORMATS, SYN-ARGUMENTS, SYN-RETURN-VALUE, SYN-SEMANTICS, SYN-EXAMPLE, SYN-SEE-ALSO


2.723. SYSTEM-OVERVIEW

Description
Use <SYSTEM-OVERVIEW> to enter the system overview .
Example
Formal Description
Within context of: | GENERAL-PROJECT-DATA
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.724. SYSTEM-USER

Description
This element specifies a system user that is logged-in to the operating system of the MCD system.
Example
See 2.262. SW-ACCESS-DEF
Formal Description
Within context of: | SYSTEM-USERS
Is context for: | Text


2.725. SYSTEM-USERS

Description
Container element for <SYSTEM-USER> .
Example
Formal Description
Within context of: | SW-USER-GROUP
Is context for: | SYSTEM-USER


2.726. TABLE

Description
Use <TABLE> to create a table.
Example
Formal Description
Within context of: | ADD-INFO, ADD-INFO-5, CHAPTER, CONF-RULE-DOC, CRITICAL-ASPECTS, FREE-INFO, INTRODUCTION, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Is context for: | TABLE-CAPTION, TGROUP
Name
Type
Values / Default
Notes
[TOCENTRY]
has default value
SGML string (NMTOKEN)
1
0 - no table heading <LONG-NAME> entered into the table directory. 0 - table heading <LONG-NAME> entered into the table directory.
[COLSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the column guides of a cell are to be visible. You should enter 0, if no column guides are to be displayed. You should enter 1 , if the column guides are to be displayed.
[FLOAT]
optional
Value selection (NAMEDTOKENGROUP)
  • FLOAT
  • NO-FLOAT
Permits a check, in the case of a <TABLE> that cannot be broken up, to determine whether the <TABLE> can be shifted elsewhere, so that the page can be used to a greater advantage (compare to flat at TeX).
[FRAME]
optional
Value selection (NAMEDTOKENGROUP)
  • TOP
  • BOTTOM
  • TOPBOT
  • ALL
  • SIDES
  • NONE
TOP - graphic limit at upper edge of table. BOTTOM - graphic limit at lower edge of table. TOPBOT - graphic limit at upper and lower edge of table. ALL - graphic limit of all table edges. SIDES - graphic limit of side edges of table NONE - no graphic limits in table
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[ORIENT]
optional
Value selection (NAMEDTOKENGROUP)
  • PORT
  • LAND
PORT - table contents is parallel to the paragraph elements. LAND - table contents is at orthogonal to the paragraph elements.
[PGWIDE]
optional
SGML string (NMTOKEN)
0 - table width is the sum of the widths specified for the columns. 1 - table width corresponds to page width.
[ROWSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the row guides of a cell are to be visible. You should enter 0, if no row guides are to be displayed. You should enter 1 , if the row guides are to be displayed.
[SHORTENTRY]
optional
SGML string (NMTOKEN)
0 - a <SHORT-NAME> is not taken over into the table directory 0 - table directory is assigned a <SHORT-NAME> .
[TABSTYLE]
optional
SGML string (NMTOKEN)
Identification of an external table style


2.727. TABLE-CAPTION

Description
This element specifies the table heading.
Example
Formal Description
Within context of: | TABLE
Is context for: | LONG-NAME, SHORT-NAME
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | TABLE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.728. TBD

Description
Use <TBD> to enter the instruction still to be processed! .
Example
Formal Description
Within context of:
ACCEPTANCE-COND, ADD-DESIGN-DOC, ADD-SPEC, BINARY-COMPATIBILITY, CALIBRATION, COMMUNICATION, COMMUNICATION-INTERFACE, COMPATIBILITY, CONTRACT-ASPECTS, DATA-DESC, DATA-REQUIREMENTS, DATA-STRUCTURES, DEMARCATION-OTHER-PROJECTS, DESIGN-REQUIREMENTS, DEVELOPMENT-PROCESS-SPEC, DIAGNOSIS, DIR-HAND-OVER-DOC-DATA, EXTENSIBILITY, FAIL-SAVE-CONCEPT, FAILURE-MANAGEMENT, FAILURE-MEM, FLASH-PROGRAMMING, FMEA, FUNCTION-OVERVIEW, FUNCTIONAL-REQUIREMENTS, GENERAL-COND, GENERAL-HARDWARE, GENERAL-INTERFACES, GENERAL-PRODUCT-DATA-1, GENERAL-PROJECT-DATA, GENERAL-REQUIREMENTS, GENERAL-SOFTWARE, GUARANTEE, HARDWARE-INTERFACE, INTEGRATION-CAPABILITY, INTERNAL-INTERFACES, INTERRUPT-SPEC, KEY-DATA, MAINTENANCE, MONITORING, NORMATIVE-REFERENCE, OBJECTIVES, OPERATING-ENV, OPERATIONAL-REQUIREMENTS, OVERVIEW, PARALLEL-DESIGNS, PRODUCT-DEMARCATION, PRODUCT-DESC, PROJECT-SCHEDULE, PROTOCOLS, PURCHASING-COND, QUALITY, REASON-ORDER, RELIABILITY, REPLACEMENT-VALUES, REQUIREMENT-SPEC, RESOURCE-ALLOCATION, RESTRICTIONS-BY-HARDWARE, RIGHTS, SAFETY, SAMPLE-SPEC, SELF-DIAGNOSIS, SIMILAR-PRODUCTS, STANDARD-SW-MODULES, SW-ARCHITECTURE, SW-CALIBRATION-METHOD-SPEC, SW-COLLECTION-SPEC, SW-COMPONENT-SPEC, SW-CPU-SPEC, SW-DATA-DICTIONARY-SPEC, SW-EVENT-SPEC, SW-GLOSSARY, SW-INSTANCE-SPEC, SW-MC-COMMUNICATION-SPEC, SW-OPER-MODE-SPEC, SW-SCHEDULING-SPEC, SW-SYSTEM, SW-TASK-SPEC, SW-TEST-SPEC, SW-USER-RIGHT-SPEC, SW-VCD-SPEC, SYSTEM-OVERVIEW, TIME-DEPENDENCY, USEFUL-LIFE, USER-INTERFACE, VARIANT-SPEC
Is context for:
TEAM-MEMBER-REFS, SCHEDULE, DESC


2.729. TBODY

Description
Use <TBODY> to generate all of the rows in a table.
Example
Formal Description
Within context of: | TGROUP
Is context for: | ROW
Name
Type
Values / Default
Notes
[VALIGN]
has default value
Value selection (NAMEDTOKENGROUP)
  • TOP
  • MIDDLE
  • BOTTOM
TOP - The contents of the table is aligned to the upper edge of the cell. BOTTOM - The contents of the table is aligned to the lower edge of the cell. MIDDLE - The contents of the table is centered to the vertical.


2.730. TBR

Description
Use <TBR> to enter still to be moved from other document! .
Example
Formal Description
Within context of:
ACCEPTANCE-COND, ADD-DESIGN-DOC, ADD-SPEC, BINARY-COMPATIBILITY, CALIBRATION, COMMUNICATION, COMMUNICATION-INTERFACE, COMPATIBILITY, CONTRACT-ASPECTS, DATA-DESC, DATA-REQUIREMENTS, DATA-STRUCTURES, DEMARCATION-OTHER-PROJECTS, DESIGN-REQUIREMENTS, DEVELOPMENT-PROCESS-SPEC, DIAGNOSIS, DIR-HAND-OVER-DOC-DATA, EXTENSIBILITY, FAIL-SAVE-CONCEPT, FAILURE-MANAGEMENT, FAILURE-MEM, FLASH-PROGRAMMING, FMEA, FUNCTION-OVERVIEW, FUNCTIONAL-REQUIREMENTS, GENERAL-COND, GENERAL-HARDWARE, GENERAL-INTERFACES, GENERAL-PRODUCT-DATA-1, GENERAL-PROJECT-DATA, GENERAL-REQUIREMENTS, GENERAL-SOFTWARE, GUARANTEE, HARDWARE-INTERFACE, INTEGRATION-CAPABILITY, INTERNAL-INTERFACES, INTERRUPT-SPEC, KEY-DATA, MAINTENANCE, MONITORING, NORMATIVE-REFERENCE, OBJECTIVES, OPERATING-ENV, OPERATIONAL-REQUIREMENTS, OVERVIEW, PARALLEL-DESIGNS, PRODUCT-DEMARCATION, PRODUCT-DESC, PROJECT-SCHEDULE, PROTOCOLS, PURCHASING-COND, QUALITY, REASON-ORDER, RELIABILITY, REPLACEMENT-VALUES, REQUIREMENT-SPEC, RESOURCE-ALLOCATION, RESTRICTIONS-BY-HARDWARE, RIGHTS, SAFETY, SAMPLE-SPEC, SELF-DIAGNOSIS, SIMILAR-PRODUCTS, STANDARD-SW-MODULES, SW-ARCHITECTURE, SW-CALIBRATION-METHOD-SPEC, SW-COLLECTION-SPEC, SW-COMPONENT-SPEC, SW-CPU-SPEC, SW-DATA-DICTIONARY-SPEC, SW-EVENT-SPEC, SW-GLOSSARY, SW-INSTANCE-SPEC, SW-MC-COMMUNICATION-SPEC, SW-OPER-MODE-SPEC, SW-SCHEDULING-SPEC, SW-SYSTEM, SW-TASK-SPEC, SW-TEST-SPEC, SW-USER-RIGHT-SPEC, SW-VCD-SPEC, SYSTEM-OVERVIEW, TIME-DEPENDENCY, USEFUL-LIFE, USER-INTERFACE, VARIANT-SPEC
Is context for:
Text, TT, BR, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, STD, XDOC, XFILE, MSR-QUERY-TEXT


2.731. TEAM-MEMBER

Description
Use <TEAM-MEMBER> to enter data on a project participant from a specific company.
Example
Formal Description
Within context of: | TEAM-MEMBERS
Is context for: | LONG-NAME, SHORT-NAME, ROLES, DEPARTMENT, ADDRESS, ZIP, CITY, PHONE, FAX, EMAIL, HOMEPAGE
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | TEAM-MEMBER | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.732. TEAM-MEMBER-REF

Description
<TEAM-MEMBER-REF> is the pointer to one particular team member. The content is the <SHORT-NAME> of the corresponding <TEAM-MEMBER> .
Example
For an example, see 2.8. ADMIN-DATA 2.8. ADMIN-DATA .
Formal Description
Within context of: | COMPANY-DOC-INFO, DOC-REVISION, TEAM-MEMBER-REFS
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | TEAM-MEMBER | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.733. TEAM-MEMBER-REFS

Description
Use <TEAM-MEMBER-REFS> to enter the references .
Example
Formal Description
Within context of: | SW-USER-GROUP, TBD
Is context for: | TEAM-MEMBER-REF


2.734. TEAM-MEMBERS

Description
Use <TEAM-MEMBERS> to enter data on all project participants from a specific company.
Example
Formal Description
Within context of: | COMPANY
Is context for: | TEAM-MEMBER


2.735. TECHNICAL-ASPECTS

Description
This element describes the technical aspects of a <REQUIREMENT> in text form.
Example
Formal Description
Within context of: | REQUIREMENT
Is context for: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER


2.736. TEX-MATH

Description
Use <TEX-MATH> to insert a TeX formula. A TeX formula can be processed by a TeX or a LaTeX processor.
Example
Formal Description
Within context of: | FORMULA
Is context for: | Text
Name
Type
Values / Default
Notes
[xml:space]
has default value
Value selection (NAMEDTOKENGROUP)
  • default
  • preserve


2.737. TEXT

Description
Use <TEXT> to enter descriptive text into the cell of a parameter table.
Example
Formal Description
Within context of: | PRM-CHAR
Is context for: | Text, SUP, SUB


2.738. TFOOT

Description
Use <TFOOT> to create a footnote for a table.
Example
Formal Description
Within context of: | TGROUP
Is context for: | COLSPEC, ROW
Name
Type
Values / Default
Notes
[VALIGN]
has default value
Value selection (NAMEDTOKENGROUP)
  • TOP
  • MIDDLE
  • BOTTOM
TOP - The contents of the table is aligned to the upper edge of the cell. BOTTOM - The contents of the table is aligned to the lower edge of the cell. MIDDLE - The contents of the table is centered to the vertical.


2.739. TGROUP

Description
Use <TGROUP> to create a table group within a table.
Example
Formal Description
Within context of: | TABLE
Is context for: | COLSPEC, SPANSPEC, THEAD, TFOOT, TBODY
Name
Type
Values / Default
Notes
[COLS]
required
SGML string (NMTOKEN)
Enter the number of columns in the table group.
[ALIGN]
has default value
Value selection (NAMEDTOKENGROUP)
  • LEFT
  • RIGHT
  • CENTER
  • JUSTIFY
  • CHAR
LEFT - The table contents is justified left. RIGHT - The table contents is justified right. CENTER - The table contents is centered horizontally. JUSTIFY - The table contents is displayed with justified typesetting. There is an equal distance from the left and right-hand edges of the cell. CHAR - The alignment of the table contents is set by [CHAR] .
[CHAR]
has default value
String (CDATA)
If [ALIGN]="CHAR", this specifies the alignment sign e.g. "bzlw", as a decimal point separator from an existing value of [CHAR] . The sign cannot be a SDATA entity.
[CHAROFF]
has default value
SGML string (NMTOKEN)
50
If [ALIGN]="CHAR", this value indicates the percentage of the current column width to the left edge of the alignment sign in the [CHAR]-attribute. If there is no alignment sign in the element <ENTRY> , alignment is always horizontal right.
[COLSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the column guides of a cell are to be visible. You should enter 0, if no column guides are to be displayed. You should enter 1 , if the column guides are to be displayed.
[ROWSEP]
optional
SGML string (NMTOKEN)
At this point, you should determine whether the row guides of a cell are to be visible. You should enter 0, if no row guides are to be displayed. You should enter 1 , if the row guides are to be displayed.
[TGROUPSTYLE]
optional
SGML string (NMTOKEN)
Identification of an external table group style


2.740. THEAD

Description
Use <THEAD> to create a heading for a table.
Example
Formal Description
Within context of: | TGROUP
Is context for: | COLSPEC, ROW
Name
Type
Values / Default
Notes
[VALIGN]
has default value
Value selection (NAMEDTOKENGROUP)
  • TOP
  • MIDDLE
  • BOTTOM
TOP - The contents of the table is aligned to the upper edge of the cell. BOTTOM - The contents of the table is aligned to the lower edge of the cell. MIDDLE - The contents of the table is centered to the vertical.


2.741. TIME-DEPENDENCY

Description
This element provides a verbal description of temporal dependencies within the software system, which can be defined on an architectural level.
Example
Formal Description
Within context of: | SW-ARCHITECTURE
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.742. TOL

Description
Use <TOL> to enter the tolerance values of a parameter.
Example
Formal Description
Within context of: | PRM-CHAR
Is context for: | Text, SUP, SUB


2.743. TOOL

Description
This element describes the tool which was used to generate the corresponding <XFILE> .
Example
Formal Description
Within context of: | XFILE
Is context for: | Text


2.744. TOOL-VERSION

Description
This element describes the tool version which was used to generate the corresponding <XFILE> .
Example
<XFILE ID="DC17723163279664">
                   <LONG-NAME-1>Praesentation</LONG-NAME-1>
                   <NOTATION>PowerPoint</NOTATION>
                   <TOOL>Microsoft PowerPoint</TOOL>
                   <TOOL-VERSION>2000</TOOL-VERSION>
                </XFILE>
Formal Description
Within context of: | XFILE
Is context for: | Text


2.745. TOPIC-1

Description
Use <TOPIC-1> to generate a closed sense unit within a documentation.
Example
Formal Description
Within context of: | ADD-INFO, CHAPTER, CONF-RULE-DOC, CRITICAL-ASPECTS, FREE-INFO, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-TOPIC-1, NCOI-1, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS
Is context for: | LONG-NAME, SHORT-NAME, P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, SYN-SYNOPSIS, TABLE, PRMS, MSR-QUERY-P-1
Name
Type
Values / Default
Notes
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[ID]
optional
ID (ID)
Unambiguous identifier of the element within the document.
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[F-ID-CLASS]
fixed value
SGML string (NMTOKEN)
TOPIC
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.746. TOPIC-2

Description
Use <TOPIC-2> to generate a closed sense unit within a documentation.
Example
Formal Description
Within context of: | INTRODUCTION, MSR-QUERY-RESULT-TOPIC-2, NCOI-3
Is context for: | LONG-NAME, SHORT-NAME, P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, MSR-QUERY-P-2
Name
Type
Values / Default
Notes
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[ID]
optional
ID (ID)
Unambiguous identifier of the element within the document.
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[F-ID-CLASS]
fixed value
SGML string (NMTOKEN)
TOPIC
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.747. TT

Description
Use <TT> to format technical terms within the paragraph element.
Example
Formal Description
Within context of: | CHANGE, DESC, FT, INDENT-SAMPLE, ITEM-LABEL, LABEL, LONG-NAME, LONG-NAME-1, MSR-QUERY-RESULT-TEXT, P, REASON, TBR
Is context for: | Text
Name
Type
Values / Default
Notes
[TYPE]
required
Value selection (NAMEDTOKENGROUP)
  • SGMLTAG
  • SGML-ATTRIBUTE
  • TOOL
  • PRODUCT
  • VARIABLE
  • STATE
  • PRM
  • MATERIAL
  • CONTROL-ELEMENT
  • CODE
  • ORGANISATION
  • OTHER
Indicates a type of the respective element.
[USER-DEFINED-TYPE]
optional
String (CDATA)
Allows user-specific TTs to be introduced.


2.748. TYP

Description
Use <TYP> to enter the typical values of a parameter.
Example
Formal Description
Within context of: | PRM-CHAR
Is context for: | Text, SUP, SUB


2.749. UNIT

Description
Use <UNIT> to enter the unit of a parameter.
Example
Formal Description
Within context of: | PRM-CHAR
Is context for: | Text, SUP, SUB


2.750. UPPER-LIMIT

Description
This element specifies the upper limit of a closed, half-open or open interval. It can also be set to infinity by setting the attribute INTERVAL-TYPE to INFINITE. No value has to be set in the case of an infinite interval.
Example
Formal Description
Within context of: | CONF-KEY-COUNT, CONF-SOURCE-COUNT, CONF-VALUE-CONSTR, SW-COMPU-SCALE, SW-INTERNAL-CONSTRS, SW-PHYS-CONSTRS, SW-SCALE-CONSTR
Is context for: | Text, CONF-ITEM-CODED-REF, CONF-ITEM-PHYS-REF, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF
Name
Type
Values / Default
Notes
[INTERVAL-TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • OPEN
  • CLOSED
  • INFINITE
OPEN: open interval
CLOSED: closed interval
INFINITE: infinite interval


2.751. URL

Description
This element specifies the Uniform Resource Locator (URL) of the context contained in the <URL> element.
Example
See 2.150. MATCHING-DCIS 2.149. MATCHING-DCI .
Formal Description
Within context of: | MATCHING-DCI, STD, XDOC, XFILE
Is context for: | Text
Name | Type | Notes
[MIME-TYPE] optional | String (CDATA) |


2.752. USED-LANGUAGES

Description
Use <USED-LANGUAGES> to enter all other languages, in addition to the document language, which are used an a document or a section of a document.
Example
Formal Description
Within context of: | ADMIN-DATA
Is context for: | Text


2.753. USEFUL-LIFE

Description
Use <USEFUL-LIFE> to enter the duration of use .
Example
Formal Description
Within context of: | GENERAL-HARDWARE
Is context for: | NA, TBD, TBR, INTRODUCTION, USEFUL-LIFE-PRMS, NCOI-3


2.754. USEFUL-LIFE-PRMS

Description
Use <USEFUL-LIFE-PRMS> to enter the parameters .
Example
Formal Description
Within context of: | USEFUL-LIFE
Is context for: | AVAILABILITY, LIFE-TIME, OPERATING-TIME, PRM


2.755. USER-INTERFACE

Description
Use USER-INTERFACE to enter the user interface .
Example
Formal Description
Within context of: | GENERAL-INTERFACES
Is context for: | NA, TBD, TBR, INTRODUCTION, NCOI-1


2.756. V

Description
Use <V> to enter a numerical value.
Example
See 2.285. SW-ARRAY-INDEX .
Formal Description
Within context of: | CONF-DEFAULT-VALUE, CONF-ITEM, CONF-PRO-VALUE, SW-COMPU-CONST, SW-COMPU-DENOMINATOR, SW-COMPU-INVERSE-VALUE, SW-COMPU-NUMERATOR, SW-VALUES-CODED, SW-VALUES-CODED-HEX, SW-VALUES-GENERIC, SW-VALUES-PHYS, VG
Is context for: | Text


2.757. VALUE

Description
Use <VALUE>, to enter the value .
Example
Formal Description
Within context of: | VARIANT-CHAR-VALUE
Is context for: | Text


2.758. VARIANT-CHAR

Description
Use <VARIANT-CHAR> to enter the variant characteristic .
Example
Formal Description
Within context of: | VARIANT-CHARS
Is context for: | LONG-NAME, SHORT-NAME, CODE
Name
Type
Values / Default
Notes
[TYPE]
required
Value selection (NAMEDTOKENGROUP)
  • NEW-PART-NUMBER
  • NO-NEW-PART-NUMBER
NEW-PART-NUMBER: new part number; NO-NEW-PART-NUMBER: no new part number.
[ID]
optional
ID (ID)
Unambiguous identifier of the element within the document.
[F-ID-CLASS]
fixed value
SGML string (NMTOKEN)
VARIANT-CHAR
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.759. VARIANT-CHAR-ASSIGN

Description
Use <VARIANT-CHAR-ASSIGN> to enter the assignment .
Example
Formal Description
Within context of: | VARIANT-CHAR-ASSIGNS
Is context for: | VARIANT-CHAR-REF, VARIANT-CHAR-VALUE


2.760. VARIANT-CHAR-ASSIGNS

Description
Use <VARIANT-CHAR-ASSIGNS>, to enter the assignments .
Example
Formal Description
Within context of: | VARIANT-DEF
Is context for: | VARIANT-CHAR-ASSIGN


2.761. VARIANT-CHAR-REF

Description
Use <VARIANT-CHAR-REF>, to enter the reference .
Example
Formal Description
Within context of: | VARIANT-CHAR-ASSIGN
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | Reference to an element made unambiguous through an ID attribute value within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | VARIANT-CHAR | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.762. VARIANT-CHAR-VALUE

Description
Use <VARIANT-CHAR-VALUE>, to enter the value .
Example
Formal Description
Within context of: | VARIANT-CHAR-ASSIGN
Is context for: | VALUE, CODE


2.763. VARIANT-CHARS

Description
Container for <VARIANT-CHAR>s.
Example
Fuzzy fuzzy
Formal Description
Within context of: | VARIANT-SPEC
Is context for: | VARIANT-CHAR


2.764. VARIANT-DEF

Description
Use <VARIANT-DEF>, to enter the variant identification .
Example
Formal Description
Within context of: | VARIANT-DEFS
Is context for: | LONG-NAME, SHORT-NAME, CODE, VARIANT-CHAR-ASSIGNS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | VARIANT-DEF | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.765. VARIANT-DEFS

Description
Use <VARIANT-DEFS>, to enter the variant definitions .
Example
Formal Description
Within context of: | VARIANT-SPEC
Is context for: | VARIANT-DEF


2.766. VARIANT-SPEC

Description
Use <VARIANT-SPEC>, to enter the variant specifications .
Example
Formal Description
Within context of: | GENERAL-PROJECT-DATA
Is context for: | NA, TBD, TBR, INTRODUCTION, VARIANT-CHARS, VARIANT-DEFS


2.767. VERBATIM

Description
<VERBATIM> is a paragraph in which white-space (in particular blanks and line feeds) is obeyed. This enables basic preformatting to be carried out, which can even be displayed on simple devices. Behavior is the same as PRE in HTML .
Example
<VERBATIM>
                  This is the system to demonstrate, how CDF should work.

                  I make it in three lines to demonstrate, how VERBATIM works.
                </VERBATIM>
Formal Description
Within context of: | ADD-INFO, ADD-INFO-5, ANNOTATION-TEXT, CHAPTER, CONF-RULE-DOC, CRITICAL-ASPECTS, ENTRY, FIGURE, FORMULA, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REMARK, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, SYN-FORMAT, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Is context for: | Text, E, XREF, BR
Name
Type
Values / Default
Notes
[ALLOW-BREAK]
has default value
SGML string (NMTOKEN)
1
Checks whether page breaks may be included in a <VERBATIM> . NO-ALLOW-BREAK means that the user is responsible for confining the layout to a page.
[FLOAT]
optional
Value selection (NAMEDTOKENGROUP)
  • FLOAT
  • NO-FLOAT
Permits a check, in the case of a <VERBATIM> that cannot be broken up, to determine whether the <VERBATIM> can be shifted elsewhere, so that the page can be used to a greater advantage (compare to flat at TeX).
[HELP-ENTRY]
optional
String (CDATA)
Enables the help to be called by marking the father element. The syntax has its origins in the help system utilized. This is often used to calculate a widget name hierarchy from a widow system, which is then correlated with the help entries. For example:
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[PGWIDE]
optional
Value selection (NAMEDTOKENGROUP)
  • PGWIDE
  • NO-PGWIDE
PGWIDE: enables the contents of the current element to be formatted using the entire width of the page. This for example, is beneficial in the case of code containing more than 80 characters per line.
[xml:space]
fixed value
Value selection (NAMEDTOKENGROUP)
  • preserve


2.768. VF

Description
Value calculated via a system constant. This element is included in every case, where parameters should be generated from numerical values during compile time (not runtime!). Thus for example, the influence of the cylinder number on conversion formulae, can be introduced in a repeatable manner.
Example
The example below demonstrates the influence of the cylinder number on the ignition interval:
<VF>360/ <SW-SYSTEMCONST-CODED-REF>ZYLZA<SW-SYSTEMCONST-CODED-REF> </VF>
The following example shows the influence of the demanded maximum engine speed on the 8-bit engine speed quantization that results from it:
<VF><SW-SYSTEMCONST-PHYS-REF>MAXDRZ<SW-SYSTEMCONST-PHYS-REF>/256 </VF>
Formal Description
Within context of: | CONF-DEFAULT-VALUE, CONF-ITEM, CONF-PRO-VALUE, SW-ARRAYSIZE, SW-CALIBRATION-HANDLE, SW-COMPU-CONST, SW-COMPU-DENOMINATOR, SW-COMPU-INVERSE-VALUE, SW-COMPU-NUMERATOR, SW-GENERIC-AXIS-PARAM, SW-VALUES-CODED, SW-VALUES-CODED-HEX, SW-VALUES-GENERIC, SW-VALUES-PHYS, VG
Is context for: | Text, CONF-ITEM-CODED-REF, CONF-ITEM-PHYS-REF, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF


2.769. VG

Description
This element enables value parameters to be grouped. It can be used to perform row and column-orientated groupings, so that these can be output in grouped form, for example on the screen.
Example
Formal Description
Within context of: | SW-VALUES-CODED, SW-VALUES-CODED-HEX, SW-VALUES-GENERIC, SW-VALUES-PHYS, VG
Is context for: | LABEL, VF, VT, V, VG, SW-INSTANCE-REF


2.770. VT

Description
<VT> represents one particular textual value of the calibration item.
Example
<SW-INSTANCE>
                   <LONG-NAME>Stupid Messages</LONG-NAME>
                   <SHORT-NAME>murph</SHORT-NAME>
                   <SW-INSTANCE-PROPS-VARIANTS>
                      <SW-INSTANCE-PROPS-VARIANT>
                         <SW-AXIS-CONTS>
                            <SW-AXIS-CONT>
                               <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
                               <SW-VALUES-PHYS>
                                  <V>1</V>
                                  <V>2</V>
                                  <V>3</V>
                                  <V>4</V>
                               </SW-VALUES-PHYS>
                            </SW-AXIS-CONT>
                            <SW-AXIS-CONT>
                               <SW-AXIS-INDEX>0</SW-AXIS-INDEX>
                               <SW-VALUES-PHYS>
                                  <VT>Things appear to be nearer than they are</VT>
                                  <VT>Shit happens</VT>
                                  <VT>Things will never be the same</VT>
                                  <VT>Stay tuned to see unexpected results</VT>
                               </SW-VALUES-PHYS>
                            </SW-AXIS-CONT>
                         </SW-AXIS-CONTS>
                      </SW-INSTANCE-PROPS-VARIANT>
                   </SW-INSTANCE-PROPS-VARIANTS>
                </SW-INSTANCE>
Formal Description
Within context of: | CONF-DEFAULT-VALUE, CONF-ITEM, CONF-PRO-VALUE, DCI-ENUM-ENTRY, SW-COMPU-CONST, SW-COMPU-INVERSE-VALUE, SW-VALUES-CODED, SW-VALUES-CODED-HEX, SW-VALUES-GENERIC, SW-VALUES-PHYS, SW-VCD-CRITERION-POSSIBLE-VALUES, SW-VCD-CRITERION-VALUE, VG
Is context for: | Text


2.771. XDOC

Description
Use <XDOC> , to reference an external document.
Example
Formal Description
Within context of: | P, TBR
Is context for: | LONG-NAME-1, SHORT-NAME, NUMBER, STATE-1, DATE-1, PUBLISHER, URL, POSITION
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | XDOC | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.772. XFILE

Description
Use <XFILE> , to reference an external file.
Example
<P>Please refer to
                   <XFILE>
                      <LONG-NAME-1>Parameter Contents file</LONG-NAME-1>
                      <SHORT-NAME>0711paco</SHORT-NAME>
                      <URL>../pacos/0711paco.xml</URL>
                      <NOTATION>PaCo</NOTATION>
                      <TOOL>DDCL</TOOL>
                      <TOOL-VERSION>1.3</TOOL-VERSION>
                   </XFILE>
                </P>
Formal Description
Within context of: | P, TBR
Is context for: | LONG-NAME-1, SHORT-NAME, URL, NOTATION, TOOL, TOOL-VERSION
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | XFILE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.773. XREF

Description
Use <XREF> , to generate cross-references within the document.
Example
Formal Description
Within context of: | CHANGE, DESC, INDENT-SAMPLE, ITEM-LABEL, MSR-QUERY-ARG, MSR-QUERY-RESULT-TEXT, P, REASON, TBR, VERBATIM
Is context for: | Text
Name
Type
Values / Default
Notes
[ID-CLASS]
required
SGML string (NMTOKEN)
ID-CLASS. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <XREF IDREF="ID1" ID-CLASS="TEAM-MEMBER">...</XREF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[SHOW-CONTENT]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-CONTENT
  • NO-SHOW-CONTENT
CONTENT determines whether the contents of an element should be output
[SHOW-RESOURCE-LONG-NAME]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-LONG-NAME
  • NO-SHOW-LONG-NAME
Select SHOW-LONG-NAME to display the paragraph label of the reference target.
[SHOW-RESOURCE-NUMBER]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-NUMBER
  • NO-SHOW-NUMBER
Select SHOW-NUMBER to display the paragraph number of the reference target.
[SHOW-RESOURCE-PAGE]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-PAGE
  • NO-SHOW-PAGE
Select SHOW-LONG-NAME to display the page number of the reference target.
[SHOW-RESOURCE-SHORT-NAME]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-SHORT-NAME
  • NO-SHOW-SHORT-NAME
Select SHOW-LONG-NAME to display the abbreviation of the reference target.
[SHOW-RESOURCE-TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-TYPE
  • NO-SHOW-TYPE
Select SHOW-TYPE to display the paragraph type of the reference target.
[SHOW-SEE]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-SEE
  • NO-SHOW-SEE
Determines whether the fixed text "see" should be output.
[EXT-ID-CLASS]
optional
String (CDATA)
External ID Class. The value of this attribute classifies links and external link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an external object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[ID-REF]
optional
ID reference (IDREF)
Reference to an element made unambiguous through an ID attribute value within the document.
[HYNAMES]
fixed value
SGML strings (NMTOKENS)
LINKEND ID-REF
HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). The names of the locator attributes (e.g. ID-REF), used to address the target of a hyperlink, can be mapped to names defined in the HYTIME standard, LINKEND. This enables the use of a generic architectural form processor for link processing and transition.
[HYTIME]
fixed value
SGML string (NMTOKEN)
CLINK
HYTIME is the standard attribute used to define a HYTIME architectural form. This functionality is defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). It enables the use of a generic architectural form processor for link processing and transition.


2.774. XREF-TARGET

Description
This element specifies a reference target which can be scattered throughout the text.
Example
<P>Dieses Element spezifiziert ein <XREF-TARGET ID="DC92181212673206"><LONG-NAME-1>Verweisziel</LONG-NAME-1></XREF-TARGET> Verweisziel,
                welches in den Text eingestreut werden kann. </P>
Formal Description
Within context of: | CHANGE, DESC, INDENT-SAMPLE, ITEM-LABEL, MSR-QUERY-RESULT-TEXT, P, REASON, TBR
Is context for: | LONG-NAME-1, SHORT-NAME
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | Unambiguous identifier of the element within the document.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | XREF-TARGET | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" e.g: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


2.775. XSD-PATTERN

Description
this element specifies a constraint on the value space of an element (e.ge. a <CONF-VALUE>) which is achieved by constraining the lexical spac to literals which match a specific pattern. The value of pattern must be a regular expression.
If in doubt, refer to XML Schema Part 2: Datatypes.
Example
<XSD-PATTERN>[0-9]{5}(-[0-9]{4})?</XSD-PATTERN>
Formal Description
Within context of: | CONF-VALUE-CONSTR
Is context for: | Text


2.776. XSD-WHITE-SPACE

Description
This element constrains the ·value space·a <CONF-VALUE> such that the various behaviors specified in Attribute Value Normalization in [XML 1.0 (Second Edition)] are realized. The value of <XSD-WHITE-SPACE> must be one of {preserve, replace, collapse}.
Hint
The notation #xA used here represents the Universal Character Set (UCS) code point hexadecimal A (line feed), which is denoted by U+000A. This notation is to be distinguished from, which is the XML character reference to that same UCS code point
preserve | No normalization is done, the value is not changed (this is the behavior required by [XML 1.0 (Second Edition)] for element content)
replace | All occurrences of #x9 (tab), #xA (line feed) and #xD (carriage return) are replaced with #x20 (space)
collapse | After the processing implied by replace, contiguous sequences of #x20's are collapsed to a single #x20, and leading and trailing #x20's are removed.
For more details refer to XML Schema Part 2: Datatypes
Example
<XSD-WHITE-SPACE>preserve</XSD-WHITE-SPACE>
Formal Description
Within context of: | CONF-VALUE-PROPS
Is context for: | Text


2.777. ZIP

Description
Use <ZIP> , to enter the zip code of the company address, of a project participant.
Example
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text


Technical Terms

Element Attribute Documentation
Technical Terms


A-Links

ABS | 2.1.
ACCEPTANCE-COND | 2.2.
ADD-DESIGN-DOC | 2.3.
ADD-INFO | 2.4.
ADD-INFO-5 | 2.5.
ADD-SPEC | 2.6.
ADDRESS | 2.7.
ADMIN-DATA | 2.8.
ANNOTATION | 2.9.
ANNOTATION-ORIGIN | 2.10.
ANNOTATION-TEXT | 2.11.
ANNOTATIONS | 2.12.
AREA | 2.13.
AVAILABILITY | 2.14.
BINARY-COMPATIBILITY | 2.15.
BIT-POSITION | 2.16.
BR | 2.17.
BYTE-ORDER | 2.18.
C-CODE | 2.19.
C-IDENTIFIER | 2.20.
CALIBRATION | 2.21.
CATEGORY | 2.22.
CHANGE | 2.23.
CHAPTER | 2.24.
CITY | 2.25.
CODE | 2.26.
COLSPEC | 2.27.
COMMENT | 2.28.
COMMUNICATION | 2.29.
COMMUNICATION-INTERFACE | 2.30.
COMPANIES | 2.31.
COMPANY | 2.32.
COMPANY-DOC-INFO | 2.33.
COMPANY-DOC-INFOS | 2.34.
COMPANY-REF | 2.35.
COMPANY-REVISION-INFO | 2.36.
COMPANY-REVISION-INFOS | 2.37.
COMPATIBILITY | 2.38.
COND | 2.39.
CONF-DEFAULT-VALUE | 2.40.
CONF-FORWARDING | 2.41.
CONF-ITEM | 2.42.
CONF-ITEM-CODED-REF | 2.43.
CONF-ITEM-PHYS-REF | 2.44.
CONF-ITEMS | 2.45.
CONF-KEY-COUNT | 2.46.
CONF-KEY-ITEM | 2.47.
CONF-KEY-LOOKUP | 2.48.
CONF-KEY-SPEC | 2.49.
CONF-PRO-VALUE | 2.50.
CONF-PRO-VALUES | 2.51.
CONF-RULE | 2.52.
CONF-RULE-DOC | 2.53.
CONF-RULE-REF | 2.54.
CONF-RULE-REF-SYSCOND | 2.55.
CONF-RULE-REFS | 2.56.
CONF-RULES | 2.57.
CONF-RULES-EDITION | 2.58.
CONF-SOURCE | 2.59.
CONF-SOURCE-COUNT | 2.60.
CONF-SOURCES | 2.61.
CONF-SOURCES-OPTIONAL | 2.62.
CONF-SOURCES-PROHIBITED | 2.63.
CONF-SOURCES-REQUIRED | 2.64.
CONF-SPEC | 2.65.
CONF-VALUE-CONSTR | 2.66.
CONF-VALUE-CONSTRS | 2.67.
CONF-VALUE-PROPS | 2.68.
CONTRACT-ASPECTS | 2.69.
CRITICAL-ASPECTS | 2.70.
DATA-DESC | 2.71.
DATA-REQUIREMENTS | 2.72.
DATA-STRUCTURES | 2.73.
DATE | 2.74.
DATE-1 | 2.75.
DCI-ENUM | 2.76.
DCI-ENUM-ENTRY | 2.77.
DCI-TEXT-TYPE | 2.78.
DEF | 2.79.
DEF-ITEM | 2.80.
DEF-LIST | 2.81.
DEMARCATION-OTHER-PROJECTS | 2.82.
DEPARTMENT | 2.83.
DESC | 2.84.
DESIGN-REQUIREMENTS | 2.85.
DEVELOPMENT-PROCESS-SPEC | 2.86.
DIAGNOSIS | 2.87.
DIR-HAND-OVER-DOC-DATA | 2.88.
DOC-LABEL | 2.89.
DOC-REVISION | 2.90.
DOC-REVISIONS | 2.91.
E | 2.92.
EMAIL | 2.93.
ENTITY-NAME | 2.94.
ENTRY | 2.95.
EXTENSIBILITY | 2.96.
FAIL-SAVE-CONCEPT | 2.97.
FAILURE-MANAGEMENT | 2.98.
FAILURE-MEM | 2.99.
FAX | 2.100.
FIGURE | 2.101.
FIGURE-CAPTION | 2.102.
FLASH-PROGRAMMING | 2.103.
FMEA | 2.104.
FORMATTER-CTRL | 2.105.
FORMATTER-CTRLS | 2.106.
FORMULA | 2.107.
FORMULA-CAPTION | 2.108.
FR-FEATURE-REF | 2.109.
FREE-INFO | 2.110.
FT | 2.111.
FUNCTION-OVERVIEW | 2.112.
FUNCTION-REF | 2.113.
FUNCTIONAL-REQUIREMENTS | 2.114.
GENERAL-COND | 2.115.
GENERAL-HARDWARE | 2.116.
GENERAL-INTERFACES | 2.117.
GENERAL-PRODUCT-DATA-1 | 2.118.
GENERAL-PROJECT-DATA | 2.119.
GENERAL-REQUIREMENTS | 2.120.
GENERAL-SOFTWARE | 2.121.
GENERIC-MATH | 2.122.
GRAPHIC | 2.123.
GUARANTEE | 2.124.
HARDWARE-INTERFACE | 2.125.
HOMEPAGE | 2.126.
IE | 2.127.
INDENT-SAMPLE | 2.128.
INTEGRATION-CAPABILITY | 2.129.
INTERNAL-INTERFACES | 2.130.
INTERRUPT-SPEC | 2.131.
INTRODUCTION | 2.132.
ISSUED-BY | 2.133.
ITEM | 2.134.
ITEM-LABEL | 2.135.
KEY-DATA | 2.136.
LABEL | 2.137.
LABELED-ITEM | 2.138.
LABELED-LIST | 2.139.
LANGUAGE | 2.140.
LIFE-TIME | 2.141.
LIST | 2.142.
LOCS | 2.143.
LONG-NAME | 2.144.
LONG-NAME-1 | 2.145.
LOWER-LIMIT | 2.146.
MAINTENANCE | 2.147.
MAP | 2.148.
MATCHING-DCI | 2.149.
MATCHING-DCIS | 2.150.
MAX | 2.151.
MAX-TEXT-LENGTH | 2.152.
MIN | 2.153.
MIN-INCR-SIZE | 2.154.
MIN-TEXT-LENGTH | 2.155.
MODIFICATION | 2.156.
MODIFICATIONS | 2.157.
MONITORING | 2.158.
MSR-PROCESSING-LOG | 2.159.
MSR-QUERY-ARG | 2.160.
MSR-QUERY-CHAPTER | 2.161.
MSR-QUERY-NAME | 2.162.
MSR-QUERY-P-1 | 2.163.
MSR-QUERY-P-2 | 2.164.
MSR-QUERY-PROPS | 2.165.
MSR-QUERY-RESULT-CHAPTER | 2.166.
MSR-QUERY-RESULT-P-1 | 2.167.
MSR-QUERY-RESULT-P-2 | 2.168.
MSR-QUERY-RESULT-TEXT | 2.169.
MSR-QUERY-RESULT-TOPIC-1 | 2.170.
MSR-QUERY-RESULT-TOPIC-2 | 2.171.
MSR-QUERY-TEXT | 2.172.
MSR-QUERY-TOPIC-1 | 2.173.
MSR-QUERY-TOPIC-2 | 2.174.
MSRSW | 2.175.
MTBF | 2.176.
NA | 2.177.
NAMELOC | 2.178.
NCOI-1 | 2.179. 2.180.
NCOI-3 | 2.180.
NMLIST | 2.181.
NORMATIVE-REFERENCE | 2.182.
NOTATION | 2.183.
NOTE | 2.184.
NUMBER | 2.185.
NUMBER-OF-BITS | 2.186.
OBJECTIVES | 2.187.
OPERATING-ENV | 2.188.
OPERATING-TIME | 2.189.
OPERATIONAL-REQUIREMENTS | 2.190.
OVERALL-PROJECT | 2.191.
OVERVIEW | 2.192.
P | 2.193.
PARALLEL-DESIGNS | 2.194.
PHONE | 2.195.
POSITION | 2.196.
PPM | 2.197.
PRIVATE-CODE | 2.198.
PRIVATE-CODES | 2.199.
PRM | 2.200.
PRM-CHAR | 2.201.
PRM-REF | 2.202.
PRM-REFS | 2.203.
PRMS | 2.204.
PRODUCT-DEMARCATION | 2.205.
PRODUCT-DESC | 2.206.
PROJECT | 2.207.
PROJECT-DATA | 2.208.
PROJECT-SCHEDULE | 2.209.
PROTOCOLS | 2.210.
PUBLISHER | 2.211.
PURCHASING-COND | 2.212.
QUALITY | 2.213.
REALTIME-REQUIREMENTS | 2.214.
REASON | 2.215.
REASON-ORDER | 2.216.
RELIABILITY | 2.217.
RELIABILITY-PRMS | 2.218.
REMARK | 2.219.
REPLACEMENT-VALUES | 2.220.
REQUIREMENT | 2.221.
REQUIREMENT-BODY | 2.222.
REQUIREMENT-REF | 2.223.
REQUIREMENT-SPEC | 2.224.
REQUIREMENTS | 2.225.
REQUIREMENTS-DEPENDENCY | 2.226.
RESOURCE-ALLOCATION | 2.227.
RESTRICTIONS-BY-HARDWARE | 2.228.
REVISION-LABEL | 2.229.
REVISION-LABEL-P1 | 2.230.
REVISION-LABEL-P2 | 2.231.
RIGHTS | 2.232.
RISKS | 2.233.
ROLE | 2.234.
ROLES | 2.235.
ROW | 2.236.
SAFETY | 2.237.
SAMPLE | 2.238.
SAMPLE-REF | 2.239.
SAMPLE-SPEC | 2.240.
SAMPLES | 2.241.
SCHEDULE | 2.242.
SD | 2.243.
SDG | 2.244.
SDG-CAPTION | 2.245.
SDGS | 2.246.
SELF-DIAGNOSIS | 2.247.
SHORT-LABEL | 2.248.
SHORT-NAME | 2.249.
SI-UNIT | 2.250.
SIGNAL-REF | 2.251.
SIMILAR-PRODUCTS | 2.252.
SPANSPEC | 2.253.
SPECIAL-DATA | 2.254.
Standard Attributes | 1.
STANDARD-SW-MODULES | 2.255.
STATE | 2.256.
STATE-1 | 2.257.
STD | 2.258.
SUB | 2.259.
SUBTITLE | 2.260.
SUP | 2.261.
SW-ACCESS-DEF | 2.262.
SW-ACCESS-DURATION | 2.263.
SW-ACCESSED-CALPRMS | 2.264.
SW-ACCESSED-CLASS-INSTANCES | 2.265.
SW-ACCESSED-SERVICE | 2.266.
SW-ACCESSED-SERVICES | 2.267.
SW-ACCESSED-VARIABLE | 2.268.
SW-ACCESSED-VARIABLES | 2.269.
SW-ADDR-INFO | 2.270.
SW-ADDR-INFOS | 2.271.
SW-ADDR-METHOD | 2.272.
SW-ADDR-METHOD-DESC | 2.273.
SW-ADDR-METHOD-REF | 2.274.
SW-ADDR-METHOD-REF-SYSCOND | 2.275.
SW-ADDR-METHOD-REFS | 2.276.
SW-ADDR-METHODS | 2.277.
SW-ADDR-OFFSET | 2.278.
SW-ALIAS-NAME | 2.279.
SW-APPLICATION-NOTES | 2.280.
SW-AR-RELATION | 2.281.
SW-AR-RELATION-TYPE | 2.282.
SW-AR-RELATIONS | 2.283.
SW-ARCHITECTURE | 2.284.
SW-ARRAY-INDEX | 2.285.
SW-ARRAYSIZE | 2.286.
SW-AXIS-CONT | 2.287.
SW-AXIS-CONTS | 2.288.
SW-AXIS-GENERIC | 2.289.
SW-AXIS-GROUPED | 2.290.
SW-AXIS-INDEX | 2.291.
SW-AXIS-INDIVIDUAL | 2.292.
SW-AXIS-TYPE | 2.293.
SW-AXIS-TYPE-REF | 2.294.
SW-AXIS-TYPE-REF-SYSCOND | 2.295.
SW-AXIS-TYPE-REFS | 2.296.
SW-AXIS-TYPES | 2.297.
SW-BASE-ADDR | 2.298.
SW-BASE-TYPE | 2.299.
SW-BASE-TYPE-REF | 2.300.
SW-BASE-TYPE-REF-SYSCOND | 2.301.
SW-BASE-TYPE-REFS | 2.302.
SW-BASE-TYPE-SIZE | 2.303.
SW-BASE-TYPES | 2.304.
SW-BIT-REPRESENTATION | 2.305.
SW-CALIBRATION-ACCESS | 2.306.
SW-CALIBRATION-HANDLE | 2.307.
SW-CALIBRATION-METHOD | 2.308.
SW-CALIBRATION-METHOD-SPEC | 2.309.
SW-CALIBRATION-METHOD-VERSION | 2.310.
SW-CALIBRATION-METHOD-VERSIONS | 2.311.
SW-CALIBRATION-METHODS | 2.312.
SW-CALPRM | 2.313.
SW-CALPRM-AXIS | 2.314.
SW-CALPRM-AXIS-SET | 2.315.
SW-CALPRM-IMPL | 2.316.
SW-CALPRM-IMPLS | 2.317.
SW-CALPRM-MAX-TEXT-SIZE | 2.318.
SW-CALPRM-NO-EFFECT-VALUE | 2.319.
SW-CALPRM-PROTOTYPE | 2.320.
SW-CALPRM-PROTOTYPE-REF | 2.321.
SW-CALPRM-PROTOTYPES | 2.322.
SW-CALPRM-REF | 2.323.
SW-CALPRM-REF-SYSCOND | 2.324.
SW-CALPRM-REFS | 2.325.
SW-CALPRM-TARGET | 2.326.
SW-CALPRM-TEXT | 2.327.
SW-CALPRM-VALUE-AXIS-LABELS | 2.328.
SW-CALPRMS | 2.329.
SW-CARB-DOC | 2.330.
SW-CLASS | 2.331.
SW-CLASS-ATTR | 2.332.
SW-CLASS-ATTR-IMPL | 2.333.
SW-CLASS-ATTR-IMPL-REF | 2.334.
SW-CLASS-ATTR-IMPL-REF-SYSCOND | 2.335.
SW-CLASS-ATTR-IMPL-REFS | 2.336.
SW-CLASS-ATTR-IMPLS | 2.337.
SW-CLASS-ATTR-INSTANCE-IMPL | 2.338.
SW-CLASS-IMPL | 2.339.
SW-CLASS-IMPLS | 2.340.
SW-CLASS-INSTANCE | 2.341.
SW-CLASS-INSTANCE-REF | 2.342.
SW-CLASS-INSTANCE-REF-SYSCOND | 2.343.
SW-CLASS-INSTANCE-REFS | 2.344.
SW-CLASS-INSTANCES | 2.345.
SW-CLASS-PROTOTYPE | 2.346.
SW-CLASS-PROTOTYPE-REF | 2.347.
SW-CLASS-PROTOTYPES | 2.348.
SW-CLASS-REF | 2.349.
SW-CLASS-REF-SYSCOND | 2.350.
SW-CLASS-REFS | 2.351.
SW-CLASSES | 2.352.
SW-CODE-SYNTAX | 2.353.
SW-CODE-SYNTAX-DESC | 2.354.
SW-CODE-SYNTAX-REF | 2.355.
SW-CODE-SYNTAX-REF-SYSCOND | 2.356.
SW-CODE-SYNTAX-REFS | 2.357.
SW-CODE-SYNTAXES | 2.358.
SW-CODED-TYPE | 2.359.
SW-COLLECTION | 2.360.
SW-COLLECTION-CONT | 2.361.
SW-COLLECTION-REF | 2.362.
SW-COLLECTION-REFS | 2.363.
SW-COLLECTION-REGEXP | 2.364.
SW-COLLECTION-REGEXPS | 2.365.
SW-COLLECTION-RULE | 2.366.
SW-COLLECTION-RULES | 2.367.
SW-COLLECTION-SCRIPT | 2.368.
SW-COLLECTION-SCRIPTS | 2.369.
SW-COLLECTION-SPEC | 2.370.
SW-COLLECTION-WILDCARD | 2.371.
SW-COLLECTION-WILDCARDS | 2.372.
SW-COLLECTIONS | 2.373.
SW-COMPARISON-VARIABLES | 2.374.
SW-COMPONENT-SPEC | 2.375.
SW-COMPONENTS | 2.376.
SW-COMPU-CONST | 2.377.
SW-COMPU-DEFAULT-VALUE | 2.378.
SW-COMPU-DENOMINATOR | 2.379.
SW-COMPU-GENERIC-MATH | 2.380.
SW-COMPU-IDENTITY | 2.381.
SW-COMPU-INTERNAL-TO-PHYS | 2.382.
SW-COMPU-INVERSE-VALUE | 2.383.
SW-COMPU-METHOD | 2.384.
SW-COMPU-METHOD-REF | 2.385.
SW-COMPU-METHOD-REF-SYSCOND | 2.386.
SW-COMPU-METHOD-REFS | 2.387.
SW-COMPU-METHODS | 2.388.
SW-COMPU-NUMERATOR | 2.389.
SW-COMPU-PHYS-TO-INTERNAL | 2.390.
SW-COMPU-PROGRAM-CODE | 2.391.
SW-COMPU-RATIONAL-COEFFS | 2.392.
SW-COMPU-SCALE | 2.393.
SW-COMPU-SCALES | 2.394.
SW-CONSTR-LEVEL | 2.395.
SW-CONSTR-OBJECTS | 2.396.
SW-CPU-ADDR-EPK | 2.397.
SW-CPU-CALIBRATION-OFFSET | 2.398.
SW-CPU-EPK | 2.399.
SW-CPU-MEM-SEG | 2.400.
SW-CPU-MEM-SEG-REF | 2.401.
SW-CPU-MEM-SEGS | 2.402.
SW-CPU-NUMBER-OF-INTERFACES | 2.403.
SW-CPU-SPEC | 2.404.
SW-CPU-STANDARD-RECORD-LAYOUT | 2.405.
SW-CPU-TYPE | 2.406.
SW-CS-CONTEXT | 2.407.
SW-CS-DATA-IDENTIFIER | 2.408.
SW-CS-ENTRY | 2.409.
SW-CS-FIELD | 2.410.
SW-CS-HISTORY | 2.411.
SW-CS-PERFORMED-BY | 2.412.
SW-CS-PROGRAM-IDENTIFIER | 2.413.
SW-CS-PROJECT-INFO | 2.414.
SW-CS-STATE | 2.415.
SW-CS-TARGET-VARIANT | 2.416.
SW-CS-TEST-OBJECT | 2.417.
SW-CSE-CODE | 2.418.
SW-CSE-CODE-FACTOR | 2.419.
SW-DATA-CONSTR | 2.420.
SW-DATA-CONSTR-REF | 2.421.
SW-DATA-CONSTR-REF-SYSCOND | 2.422.
SW-DATA-CONSTR-REFS | 2.423.
SW-DATA-CONSTR-RULE | 2.424.
SW-DATA-CONSTRS | 2.425.
SW-DATA-DEF-PROPS | 2.426.
SW-DATA-DEF-PROPS-SYSCONDS | 2.427.
SW-DATA-DEPENDENCY | 2.428.
SW-DATA-DEPENDENCY-ARGS | 2.429.
SW-DATA-DEPENDENCY-FORMULA | 2.430.
SW-DATA-DICTIONARY-SPEC | 2.431.
SW-DISPLAY-FORMAT | 2.432.
SW-EFFECT | 2.433.
SW-EFFECT-FLOW | 2.434.
SW-EFFECT-FLOWS | 2.435.
SW-EFFECTING-VARIABLE | 2.436.
SW-EVENT | 2.437.
SW-EVENT-CYCLE | 2.438.
SW-EVENT-FREQUENCY-MAX | 2.439.
SW-EVENT-FREQUENCY-MIN | 2.440.
SW-EVENT-LAXITY | 2.441.
SW-EVENT-MESSAGE-RECEIVED | 2.442.
SW-EVENT-PHASE | 2.443.
SW-EVENT-REF | 2.444.
SW-EVENT-REF-SYSCOND | 2.445.
SW-EVENT-REFS | 2.446.
SW-EVENT-SOURCE | 2.447.
SW-EVENT-SOURCE-REF | 2.448.
SW-EVENT-SOURCES | 2.449.
SW-EVENT-SPEC | 2.450.
SW-EVENT-TASK-TERMINATED | 2.451.
SW-EVENTS | 2.452.
SW-FEATURE | 2.453.
SW-FEATURE-CLASS-INSTANCES | 2.454.
SW-FEATURE-DECOMPOSITION | 2.455.
SW-FEATURE-DEF | 2.456.
SW-FEATURE-DESC | 2.457.
SW-FEATURE-DESIGN-DATA | 2.458.
SW-FEATURE-ELEMENTS | 2.459.
SW-FEATURE-EXPORT-CALPRMS | 2.460.
SW-FEATURE-EXPORT-CLASS-INSTANCES | 2.461.
SW-FEATURE-EXPORT-SERVICES | 2.462.
SW-FEATURE-EXPORT-VARIABLES | 2.463.
SW-FEATURE-IMPORT-CALPRMS | 2.464.
SW-FEATURE-IMPORT-CLASS-INSTANCES | 2.465.
SW-FEATURE-IMPORT-SERVICES | 2.466.
SW-FEATURE-IMPORT-VARIABLES | 2.467.
SW-FEATURE-INTERFACE | 2.468.
SW-FEATURE-INTERFACE-REF | 2.469.
SW-FEATURE-INTERFACE-REF-SYSCOND | 2.470.
SW-FEATURE-INTERFACE-REFS | 2.471.
SW-FEATURE-INTERFACES | 2.472.
SW-FEATURE-LOCAL-CLASS-INSTANCES | 2.473.
SW-FEATURE-LOCAL-PARAMS | 2.474.
SW-FEATURE-LOCAL-SERVICES | 2.475.
SW-FEATURE-LOCAL-VARIABLES | 2.476.
SW-FEATURE-MODEL-ONLY-VARIABLES | 2.477.
SW-FEATURE-OWNED-ELEMENT-SET | 2.478.
SW-FEATURE-OWNED-ELEMENT-SETS | 2.479.
SW-FEATURE-OWNED-ELEMENTS | 2.480.
SW-FEATURE-PARAMS | 2.481.
SW-FEATURE-REF | 2.482.
SW-FEATURE-REF-SYSCOND | 2.483.
SW-FEATURE-REFS | 2.484.
SW-FEATURE-SERVICES | 2.485.
SW-FEATURE-VARIABLES | 2.486.
SW-FEATURE-VARIANT | 2.487.
SW-FEATURE-VARIANT-OF | 2.488.
SW-FEATURE-VARIANT-REF | 2.489.
SW-FILL-CHARACTER | 2.490.
SW-FULFILS | 2.491.
SW-GENERIC-AXIS-DESC | 2.492.
SW-GENERIC-AXIS-PARAM | 2.493.
SW-GENERIC-AXIS-PARAM-TYPE | 2.494.
SW-GENERIC-AXIS-PARAM-TYPE-REF | 2.495.
SW-GENERIC-AXIS-PARAM-TYPES | 2.496.
SW-GENERIC-AXIS-PARAMS | 2.497.
SW-GLOSSARY | 2.498.
SW-HOST-VARIABLE | 2.499.
SW-IMPL-POLICY | 2.500.
SW-INSTANCE | 2.501.
SW-INSTANCE-PROPS-VARIANT | 2.502.
SW-INSTANCE-PROPS-VARIANTS | 2.503.
SW-INSTANCE-REF | 2.504.
SW-INSTANCE-REF-SYSCOND | 2.505.
SW-INSTANCE-REFS | 2.506.
SW-INSTANCE-SPEC | 2.507.
SW-INSTANCE-TREE | 2.508.
SW-INTENDED-RESOLUTION | 2.509.
SW-INTERFACE-ACCESSED-ELEMENT-SET | 2.510.
SW-INTERFACE-ACCESSED-ELEMENT-SETS | 2.511.
SW-INTERFACE-EXPORT | 2.512.
SW-INTERFACE-EXPORT-LEVEL | 2.513.
SW-INTERFACE-EXPORT-SCOPE | 2.514.
SW-INTERFACE-EXPORTS | 2.515.
SW-INTERFACE-IMPORT | 2.516.
SW-INTERFACE-IMPORTS | 2.517.
SW-INTERNAL-CONSTRS | 2.518.
SW-INTERNAL-CONSTRS-1 | 2.519.
SW-INTERPOLATION-METHOD | 2.520.
SW-IS-VIRTUAL | 2.521.
SW-MAINTENANCE-NOTES | 2.522.
SW-MAX-AXIS-POINTS | 2.523.
SW-MAX-DIFF | 2.524.
SW-MAX-GRADIENT | 2.525.
SW-MC-ADDR-MAPPED-SIZE | 2.526.
SW-MC-ADDR-MAPPING | 2.527.
SW-MC-ADDR-MAPPINGS | 2.528.
SW-MC-BASE-TYPE | 2.529.
SW-MC-BASE-TYPE-REF | 2.530.
SW-MC-BASE-TYPES | 2.531.
SW-MC-BLOB-ECU-DEPOSIT | 2.532.
SW-MC-BLOB-LAYOUTS | 2.533.
SW-MC-BLOB-VALUE | 2.534.
SW-MC-COMMUNICATION-SPEC | 2.535.
SW-MC-DP-BLOB-CONTS | 2.536.
SW-MC-DP-BLOB-LAYOUT | 2.537.
SW-MC-FRAME | 2.538.
SW-MC-FRAMES | 2.539.
SW-MC-GENERIC-INTERFACE | 2.540.
SW-MC-GENERIC-INTERFACES | 2.541.
SW-MC-INSTANCE-INTERFACE | 2.542.
SW-MC-INSTANCE-INTERFACES | 2.543.
SW-MC-INTERFACE | 2.544.
SW-MC-INTERFACE-AVL-SOURCES | 2.545.
SW-MC-INTERFACE-DEFAULT-SOURCE | 2.546.
SW-MC-INTERFACE-IMPL | 2.547.
SW-MC-INTERFACE-IMPLS | 2.548.
SW-MC-INTERFACE-REF | 2.549.
SW-MC-INTERFACE-SOURCE | 2.550.
SW-MC-INTERFACE-SOURCE-REF | 2.551.
SW-MC-INTERFACE-SOURCES | 2.552.
SW-MC-INTERFACE-SPEC | 2.553.
SW-MC-KP-BLOB-CONTS | 2.554.
SW-MC-KP-BLOB-LAYOUT | 2.555.
SW-MC-MAPPED-ADDR | 2.556.
SW-MC-ORIGINAL-ADDR | 2.557.
SW-MC-PA-BLOB-CONTS | 2.558.
SW-MC-PA-BLOB-LAYOUT | 2.559.
SW-MC-QP-BLOB-CONTS | 2.560.
SW-MC-QP-BLOB-LAYOUT | 2.561.
SW-MC-TP-BLOB-CONTS | 2.562.
SW-MC-TP-BLOB-LAYOUT | 2.563.
SW-MEM-ALIGNMENT | 2.564.
SW-MEM-ATTR | 2.565.
SW-MEM-BASE-ADDR | 2.566.
SW-MEM-OFFSET | 2.567.
SW-MEM-OFFSETS | 2.568.
SW-MEM-PROGRAM-TYPE | 2.569.
SW-MEM-SIZE | 2.570.
SW-MEM-TYPE | 2.571.
SW-MIN-AXIS-POINTS | 2.572.
SW-MONOTONY | 2.573.
SW-NUMBER-OF-AXIS-POINTS | 2.574.
SW-OPER-MODE | 2.575.
SW-OPER-MODE-REF | 2.576.
SW-OPER-MODE-SPEC | 2.577.
SW-OPER-MODES | 2.578.
SW-PHYS-CONSTRS | 2.579.
SW-PHYS-CONSTRS-1 | 2.580.
SW-POINTER | 2.581.
SW-PROCESS | 2.582.
SW-PROCESS-LIST | 2.583.
SW-PROCESS-LISTS | 2.584.
SW-PROCESSES | 2.585.
SW-RECORD-LAYOUT | 2.586.
SW-RECORD-LAYOUT-COMPONENT | 2.587.
SW-RECORD-LAYOUT-GROUP | 2.588.
SW-RECORD-LAYOUT-GROUP-AXIS | 2.589.
SW-RECORD-LAYOUT-GROUP-FROM | 2.590.
SW-RECORD-LAYOUT-GROUP-INDEX | 2.591.
SW-RECORD-LAYOUT-GROUP-STEP | 2.592.
SW-RECORD-LAYOUT-GROUP-TO | 2.593.
SW-RECORD-LAYOUT-REF | 2.594.
SW-RECORD-LAYOUT-REF-SYSCOND | 2.595.
SW-RECORD-LAYOUT-REFS | 2.596.
SW-RECORD-LAYOUT-V | 2.597.
SW-RECORD-LAYOUT-V-AXIS | 2.598.
SW-RECORD-LAYOUT-V-FIX-VALUE | 2.599.
SW-RECORD-LAYOUT-V-INDEX | 2.600.
SW-RECORD-LAYOUT-V-PROP | 2.601.
SW-RECORD-LAYOUTS | 2.602.
SW-REFRESH-TIMING | 2.603.
SW-RELATED-CONSTRS | 2.604.
SW-ROOT-FEATURES | 2.605.
SW-SCALE-CONSTR | 2.606.
SW-SCALE-CONSTRS | 2.607.
SW-SCHEDULING-SPEC | 2.608.
SW-SEMAPHORE | 2.609.
SW-SERVICE | 2.610.
SW-SERVICE-ACCESSED-ELEMENT-SET | 2.611.
SW-SERVICE-ACCESSED-ELEMENT-SETS | 2.612.
SW-SERVICE-ARG | 2.613.
SW-SERVICE-ARGS | 2.614.
SW-SERVICE-IMPL | 2.615.
SW-SERVICE-IMPLS | 2.616.
SW-SERVICE-PROPS | 2.617.
SW-SERVICE-PROTOTYPE | 2.618.
SW-SERVICE-PROTOTYPE-REF | 2.619.
SW-SERVICE-PROTOTYPES | 2.620.
SW-SERVICE-RECURSIVE | 2.621.
SW-SERVICE-REENTRANCE | 2.622.
SW-SERVICE-REF | 2.623.
SW-SERVICE-REF-SYSCOND | 2.624.
SW-SERVICE-REFS | 2.625.
SW-SERVICE-RETURN | 2.626.
SW-SERVICES | 2.627.
SW-SIZEOF-INSTANCE | 2.628.
SW-SUBCOMPONENT | 2.629.
SW-SYSCOND | 2.630.
SW-SYSTEM | 2.631.
SW-SYSTEMCONST | 2.632.
SW-SYSTEMCONST-CODED-REF | 2.633.
SW-SYSTEMCONST-PHYS-REF | 2.634.
SW-SYSTEMCONST-REF | 2.635.
SW-SYSTEMCONST-REF-SYSCOND | 2.636.
SW-SYSTEMCONST-REFS | 2.637.
SW-SYSTEMCONSTS | 2.638.
SW-SYSTEMS | 2.639.
SW-TASK | 2.640.
SW-TASK-COOPERATIVE-PRIO | 2.641.
SW-TASK-DEADLINE | 2.642.
SW-TASK-LATENCY | 2.643.
SW-TASK-MAX-ACTIVATION | 2.644.
SW-TASK-PREEMPTIVE-PRIO | 2.645.
SW-TASK-REF | 2.646.
SW-TASK-REF-SYSCOND | 2.647.
SW-TASK-REFS | 2.648.
SW-TASK-SPEC | 2.649.
SW-TASKS | 2.650.
SW-TEMPLATE | 2.651.
SW-TEMPLATE-REF | 2.652.
SW-TEMPLATE-REF-SYSCOND | 2.653.
SW-TEMPLATE-REFS | 2.654.
SW-TEMPLATES | 2.655.
SW-TEST-DESC | 2.656.
SW-TEST-SPEC | 2.657.
SW-UNIT | 2.658.
SW-UNIT-CONVERSION-METHOD | 2.659.
SW-UNIT-DISPLAY | 2.660.
SW-UNIT-GRADIENT | 2.661.
SW-UNIT-OFFSET | 2.662.
SW-UNIT-REF | 2.663.
SW-UNIT-REF-SYSCOND | 2.664.
SW-UNIT-REFS | 2.665.
SW-UNITS | 2.666.
SW-USER-ACCESS-CASE | 2.667.
SW-USER-ACCESS-CASE-REF | 2.668.
SW-USER-ACCESS-CASE-REFS | 2.669.
SW-USER-ACCESS-CASES | 2.670.
SW-USER-ACCESS-DEFINTIONS | 2.671.
SW-USER-GROUP | 2.672.
SW-USER-GROUP-REF | 2.673.
SW-USER-GROUP-REFS | 2.674.
SW-USER-GROUPS | 2.675.
SW-USER-RIGHT-SPEC | 2.676.
SW-VALUES-CODED | 2.677.
SW-VALUES-CODED-HEX | 2.678.
SW-VALUES-GENERIC | 2.679.
SW-VALUES-PHYS | 2.680.
SW-VAR-INIT-VALUE | 2.681.
SW-VAR-NOT-AVL-VALUE | 2.682.
SW-VARIABLE | 2.683.
SW-VARIABLE-ACCESS-IMPL | 2.684.
SW-VARIABLE-ACCESS-IMPL-POLICY | 2.685.
SW-VARIABLE-ACCESS-SEQUENCE | 2.686.
SW-VARIABLE-IMPL | 2.687.
SW-VARIABLE-IMPLS | 2.688.
SW-VARIABLE-KIND | 2.689.
SW-VARIABLE-PROTOTYPE | 2.690.
SW-VARIABLE-PROTOTYPE-REF | 2.691.
SW-VARIABLE-PROTOTYPES | 2.692.
SW-VARIABLE-REF | 2.693.
SW-VARIABLE-REF-SYSCOND | 2.694.
SW-VARIABLE-REFS | 2.695.
SW-VARIABLE-USAGE | 2.696.
SW-VARIABLES | 2.697.
SW-VARIABLES-READ | 2.698.
SW-VARIABLES-READ-WRITE | 2.699.
SW-VARIABLES-WRITE | 2.700.
SW-VCD-CRITERIA | 2.701.
SW-VCD-CRITERION | 2.702.
SW-VCD-CRITERION-POSSIBLE-VALUES | 2.703.
SW-VCD-CRITERION-REF | 2.704.
SW-VCD-CRITERION-REF-SYSCOND | 2.705.
SW-VCD-CRITERION-REFS | 2.706.
SW-VCD-CRITERION-VALUE | 2.707.
SW-VCD-CRITERION-VALUES | 2.708.
SW-VCD-SPEC | 2.709.
SYN-ARGUMENT | 2.710.
SYN-ARGUMENTS | 2.711.
SYN-CAPTION | 2.712.
SYN-EXAMPLE | 2.713.
SYN-FORMAT | 2.714.
SYN-FORMATS | 2.715.
SYN-INCLUDE | 2.716.
SYN-OBJECT | 2.717.
SYN-OBJECTS | 2.718.
SYN-RETURN-VALUE | 2.719.
SYN-SEE-ALSO | 2.720.
SYN-SEMANTICS | 2.721.
SYN-SYNOPSIS | 2.722.
SYSTEM-OVERVIEW | 2.723.
SYSTEM-USER | 2.724.
SYSTEM-USERS | 2.725.
TABLE | 2.726.
TABLE-CAPTION | 2.727.
TBD | 2.728.
TBODY | 2.729.
TBR | 2.730.
TEAM-MEMBER | 2.731.
TEAM-MEMBER-REF | 2.732.
TEAM-MEMBER-REFS | 2.733.
TEAM-MEMBERS | 2.734.
TECHNICAL-ASPECTS | 2.735.
TEX-MATH | 2.736.
TEXT | 2.737.
TFOOT | 2.738.
TGROUP | 2.739.
THEAD | 2.740.
TIME-DEPENDENCY | 2.741.
TOL | 2.742.
TOOL | 2.743.
TOOL-VERSION | 2.744.
TOPIC-1 | 2.745.
TOPIC-2 | 2.746.
TT | 2.747.
TYP | 2.748.
UNIT | 2.749.
UPPER-LIMIT | 2.750.
URL | 2.751.
USED-LANGUAGES | 2.752.
USEFUL-LIFE | 2.753.
USEFUL-LIFE-PRMS | 2.754.
USER-INTERFACE | 2.755.
V | 2.756.
VALUE | 2.757.
VARIANT-CHAR | 2.758.
VARIANT-CHAR-ASSIGN | 2.759.
VARIANT-CHAR-ASSIGNS | 2.760.
VARIANT-CHAR-REF | 2.761.
VARIANT-CHAR-VALUE | 2.762.
VARIANT-CHARS | 2.763.
VARIANT-DEF | 2.764.
VARIANT-DEFS | 2.765.
VARIANT-SPEC | 2.766.
VERBATIM | 2.767.
VF | 2.768.
VG | 2.769.
VT | 2.770.
XDOC | 2.771.
XFILE | 2.772.
XREF | 2.773.
XREF-TARGET | 2.774.
XSD-PATTERN | 2.775.
XSD-WHITE-SPACE | 2.776.
ZIP | 2.777.


Code

'-', '+', '*', '/' | 2.630.
-2**3 | 2.630.
-8 = (-2)**3 | 2.630.
(-ln(2.718281828))**2 | 2.630.
** | 2.630.
+1 | 2.630.
-ln(2.718281828)**2 | 2.630.
/ | 2.630.
0x7FFFFFFF | 2.630.
4 | 2.630.
4UL | 2.630.
> 1 | 2.630.
>UCEIL | 2.630.
ADAPTIVE | 2.306.
ADDRESS | 2.601.
ASCII | 2.313.
AXIS_VALUES | 2.313.
c( ... ) | 2.630.
CAL-ITEM | 2.501.
CAL-LIST | 2.507. 2.508.
CALIBRATION | 2.306.
cc( ... ) | 2.630.
CODE | 2.400.
COUNT | 2.601.
cp( ... ) | 2.630.
CURVE_AXIS_REF | 2.290.
CURVE_FIXED | 2.313.
CURVE_GROUPED | 2.313.
CURVE_INDIVIDUAL | 2.313.
DATA | 2.400.
DEFINED | 2.630.
DIST | 2.601.
DOUBLE | 2.630.
EEPROM | 2.571.
EPROM | 2.571.
EXTERN | 2.400. 2.565.
FILL | 2.601.
FIXLEFTDIFF | 2.601.
FIXRIGHTDIFF | 2.601.
FLASH | 2.571.
fr( ... ) | 2.630.
ICEIL | 2.630.
IDENTIFIER | 2.630.
IFLOOR | 2.630.
IFLOOR(10E22) | 2.630.
INTEGER | 2.630.
INTERN | 2.400. 2.565.
IROUND | 2.630.
LEFTDIFF | 2.601.
MAP_FIXED | 2.313.
MAP_GROUPED | 2.313.
MAP_INDIVIDUAL | 2.313.
NO-CALIBRATION | 2.306.
NOT-ACCESSIBLE | 2.306.
NOT-IN-MEMORY | 2.306.
NOTE | 2.507.
OFFLINE_DATA | 2.400.
p( ... ) | 2.630.
RAM | 2.571.
READ-ONLY | 2.306.
READ-WRITE | 2.306.
REGISTER | 2.571.
RESERVED | 2.400.
RESULT-ADR | 2.601.
RIGHTDIFF | 2.601.
ROM | 2.571.
SOURCE-ADR | 2.601.
STRUCTURE | 2.313.
SY_COUNT | 2.630.
SYMBOLIC-FILE | 2.413.
U | 2.630.
UFLOOR | 2.630.
UINTEGER | 2.630.
UL | 2.630.
UROUND | 2.630.
UROUND, UCEIL, UFLOOR | 2.630.
VALUE | 2.313. 2.601.
VALUE_BLOCK | 2.313.


Control elements

ADDR_EPK | 2.397.
collapse | 2.776.
MSR-QUERY | 2.160. 2.162. 2.163. 2.164. 2.165. 2.166. 2.167. 2.168. 2.169. 2.170. 2.171. 2.172. 2.173. 2.174.
preserve | 2.776.
replace | 2.776.


Organisations

ASAM | 2.431.
CARB | 2.330.
IEEE | 2.359.
preserve | 2.776.


OTHER

 | 2.722.
DATA-STRUCTURES | 2.73.
DEMARCATION-OTHER-PROJECTS | 2.82.
DESIGN-REQUIREMENTS | 2.85.
DEVELOPMENT-PROCESS-SPEC | 2.86.
DIR-HAND-OVER-DOC-DATA | 2.88.
Special Data Group | 2.244.
USER-INTERFACE | 2.755.


Products

A2ML | 2.175.
ASAM-MCD 1.x | 2.540.
CDF | 2.150. 2.208. 2.413. 2.502. 2.507. 2.508. 2.663.
DCI | 2.149.
HTML | 2.767.
MSRREP | 2.722.
MSRSW | 2.722.
MSRSW.DTD | 2.150. 2.208.
MSRSYS.DTD | 2.491.
PACO | 2.150.


SGML Attributes

ACCESSKEY | 2.13.
ALIGN | 2.27. 2.95. 2.253. 2.739.
ALLOW-BREAK | 2.767.
ALT | 2.13.
AMOUNT-OF-SUBSTANCE-EXPO | 2.250.
BREAK | 2.24.
calibration | 2.360.
CASE-SENSITIVE | 2.76.
CATEGORY | 2.123.
CHAR | 2.27. 2.95. 2.253. 2.739.
CHAROFF | 2.27. 2.95. 2.253. 2.739.
CLASS | 2.13. 2.148.
COLNAME | 2.27. 2.95.
COLNUM | 2.27.
COLOR | 2.92.
COLS | 2.739.
COLSEP | 2.27. 2.95. 2.253. 2.726. 2.739.
COLWIDTH | 2.27.
COORDS | 2.13.
DOCORSUB | 2.181.
EDIT-HEIGHT | 2.123.
EDIT-WIDTH | 2.123.
EDITFIT | 2.123.
EDITSCALE | 2.123.
ELECTRIC-CURRENT-EXPO | 2.250.
EXT-ID-CLASS | 2.178. 2.251. 2.773.
F-BUILD | 2.175.
F-CHILD-TYPE | 2.32. 2.235. 2.238.
F-CM-TOOL-ID | 2.175.
F-EXT-ID-CLASS | 2.113.
F-ID-CLASS | 2.14. 2.24. 2.32. 2.35. 2.42. 2.43. 2.44. 2.52. 2.54. 2.80. 2.102. 2.108. 2.109. 2.113. 2.141. 2.176. 2.178. 2.189. 2.197. 2.200. 2.202. 2.221. 2.223. 2.238. 2.239. 2.245. 2.251. 2.258. 2.272. 2.274. 2.293. 2.294. 2.299. 2.300. 2.308. 2.313. 2.320. 2.321. 2.323. 2.331. 2.333. 2.334. 2.341. 2.342. 2.346. 2.347. 2.349. 2.353. 2.355. 2.360. 2.362. 2.384. 2.385. 2.400. 2.401. 2.420. 2.421. 2.437. 2.444. 2.447. 2.448. 2.453. 2.468. 2.469. 2.482. 2.487. 2.489. 2.494. 2.495. 2.501. 2.504. 2.508. 2.529. 2.530. 2.538. 2.544. 2.549. 2.550. 2.551. 2.575. 2.576. 2.586. 2.594. 2.610. 2.613. 2.618. 2.619. 2.623. 2.626. 2.631. 2.632. 2.633. 2.634. 2.635. 2.640. 2.646. 2.651. 2.652. 2.658. 2.663. 2.667. 2.668. 2.672. 2.673. 2.683. 2.690. 2.691. 2.693. 2.702. 2.704. 2.712. 2.727. 2.731. 2.732. 2.745. 2.746. 2.758. 2.761. 2.764. 2.771. 2.772. 2.774.
F-NAMESPACE | 2.32. 2.175. 2.293. 2.313. 2.331. 2.453. 2.487. 2.501. 2.508. 2.610. 2.631. 2.683. 2.712.
F-PUBID | 2.175.
F-REVISION-ID | 2.175.
FILENAME | 2.123.
FIT | 2.123.
FLOAT | 2.101. 2.726. 2.767.
FONT | 2.92.
FRAME | 2.101. 2.726.
FUNCTION-REF | 2.181.
GID | 2.243. 2.244.
HEIGHT | 2.123.
HELP-ENTRY | 2.24. 2.80. 2.101. 2.138. 2.193. 2.726. 2.745. 2.746. 2.767.
HREF | 2.13.
HTML-FIT | 2.123.
HTML-HEIGHT | 2.123.
HTML-SCALE | 2.123.
HTML-WIDTH | 2.123.
HYNAMES | 2.35. 2.43. 2.44. 2.54. 2.109. 2.113. 2.202. 2.223. 2.239. 2.251. 2.274. 2.294. 2.300. 2.321. 2.323. 2.334. 2.342. 2.347. 2.349. 2.355. 2.362. 2.385. 2.401. 2.421. 2.444. 2.448. 2.469. 2.482. 2.489. 2.495. 2.504. 2.530. 2.549. 2.551. 2.576. 2.594. 2.619. 2.623. 2.633. 2.634. 2.635. 2.646. 2.652. 2.663. 2.668. 2.673. 2.691. 2.693. 2.704. 2.732. 2.761. 2.773.
HYTIME | 2.35. 2.43. 2.44. 2.54. 2.109. 2.113. 2.175. 2.178. 2.181. 2.202. 2.223. 2.239. 2.251. 2.274. 2.294. 2.300. 2.321. 2.323. 2.334. 2.342. 2.347. 2.349. 2.355. 2.362. 2.385. 2.401. 2.421. 2.444. 2.448. 2.469. 2.482. 2.489. 2.495. 2.504. 2.530. 2.549. 2.551. 2.576. 2.594. 2.619. 2.623. 2.633. 2.634. 2.635. 2.646. 2.652. 2.663. 2.668. 2.673. 2.691. 2.693. 2.704. 2.732. 2.761. 2.773.
ID | 2.13. 2.14. 2.24. 2.32. 2.42. 2.52. 2.80. 2.102. 2.108. 2.141. 2.148. 2.176. 2.178. 2.189. 2.197. 2.200. 2.221. 2.223. 2.238. 2.245. 2.258. 2.272. 2.274. 2.293. 2.299. 2.308. 2.313. 2.320. 2.331. 2.333. 2.341. 2.346. 2.353. 2.360. 2.384. 2.400. 2.420. 2.437. 2.447. 2.453. 2.468. 2.487. 2.494. 2.501. 2.508. 2.529. 2.538. 2.544. 2.550. 2.575. 2.586. 2.610. 2.613. 2.618. 2.626. 2.631. 2.632. 2.640. 2.651. 2.658. 2.667. 2.672. 2.683. 2.690. 2.702. 2.712. 2.727. 2.731. 2.745. 2.746. 2.758. 2.764. 2.771. 2.772. 2.774.
ID-CLASS | 2.243. 2.773.
ID-REF | 2.35. 2.43. 2.44. 2.54. 2.109. 2.113. 2.202. 2.223. 2.239. 2.243. 2.251. 2.274. 2.294. 2.300. 2.321. 2.323. 2.334. 2.342. 2.347. 2.349. 2.355. 2.362. 2.385. 2.401. 2.421. 2.444. 2.448. 2.469. 2.482. 2.489. 2.495. 2.504. 2.530. 2.549. 2.551. 2.576. 2.594. 2.619. 2.623. 2.633. 2.634. 2.635. 2.646. 2.652. 2.663. 2.668. 2.673. 2.691. 2.693. 2.704. 2.732. 2.761. 2.773.
INTERVAL-TYPE | 2.146. 2.750.
invert | 2.360.
ITEM-LABEL-POS | 2.128.
KEEP-WITH-PREVIOUS | 2.24. 2.80. 2.81. 2.101. 2.107. 2.134. 2.138. 2.139. 2.142. 2.161. 2.163. 2.164. 2.173. 2.174. 2.184. 2.193. 2.204. 2.726. 2.745. 2.746. 2.767.
LANG-SUBSET | 2.391.
LANGUAGE | 2.368.
LENGTH-EXPO | 2.250.
LEVEL | 2.380.
LUMINOUS-INTENSITY-EXPO | 2.250.
MASS-EXPO | 2.250.
MIME-TYPE | 2.751.
MOREROWS | 2.95.
NAME | 2.148.
NAMEEND | 2.95. 2.253.
NAMEST | 2.95. 2.253.
NAMETYPE | 2.181.
NOHREF | 2.13.
NOTATION | 2.123.
NOTE-TYPE | 2.184.
ONBLUR | 2.13.
ONCLICK | 2.13. 2.148.
ONDBLCLICK | 2.13. 2.148.
ONFOCUS | 2.13.
ONKEYDOWN | 2.13. 2.148.
ONKEYPRESS | 2.13. 2.148.
ONKEYUP | 2.13. 2.148.
ONMOUSEDOWN | 2.13. 2.148.
ONMOUSEMOVE | 2.13. 2.148.
ONMOUSEOUT | 2.13. 2.148.
ONMOUSEOVER | 2.13. 2.148.
ONMOUSEUP | 2.13. 2.148.
ORIENT | 2.726.
ORIGIN | 2.433.
PGWIDE | 2.101. 2.726. 2.767.
PROGRAM-LANG | 2.391.
PUBID | 2.175.
RESOLVE-REFS | 2.366.
ROLE | 2.32.
ROOT | 2.360.
ROTATE | 2.95.
ROWSEP | 2.27. 2.95. 2.236. 2.253. 2.726. 2.739.
S | 1.
SCALE | 2.123.
SCOPE | 2.366.
SHAPE | 2.13.
SHORTENTRY | 2.726.
SHOW-CONTENT | 2.773.
SHOW-RESOURCE-LONG-NAME | 2.773.
SHOW-RESOURCE-NUMBER | 2.773.
SHOW-RESOURCE-PAGE | 2.773.
SHOW-RESOURCE-SHORT-NAME | 2.773.
SHOW-RESOURCE-TYPE | 2.773.
SHOW-SEE | 2.773.
SI | 1. 2.105. 2.131. 2.313. 2.353. 2.410. 2.683.
SPANNAME | 2.95. 2.253.
STYLE | 2.13. 2.148.
SYSCOND | 1. 2.630.
T | 1.
TABINDEX | 2.13.
TABSTYLE | 2.726.
TARGET-SYSTEM | 2.105.
TGROUPSTYLE | 2.739.
THERMODYNAMIC-TEMPERATURE-EXPO | 2.250.
TIME-EXPO | 2.250.
TITLE | 2.13. 2.148.
TOCENTRY | 2.726.
TYPE | 2.18. 2.92. 2.127. 2.142. 2.156. 2.198. 2.287. 2.679. 2.747. 2.758.
USED-LIBS | 2.391.
USER-DEFINED-TYPE | 2.184. 2.747.
VALIGN | 2.95. 2.236. 2.729. 2.738. 2.740.
VIEW | 1.
WIDTH | 2.123.
xml:space |


SGML Elements

ABS | 2.1.
ACCEPTANCE-COND | 2.2.
ADD-DESIGN-DOC | 2.3.
ADD-INFO | 2.4. 2.5. 2.221. 2.313. 2.683.
ADD-INFO-5 | 2.5. 2.710. 2.719. 2.721.
ADD-SPEC | 2.114. 2.284.
ADDRESS | 2.7.
ADMIN-DATA | 2.8. 2.31. 2.91. 2.114. 2.175. 2.221. 2.304.
ANNOTATION | 2.11. 2.12.
ANNOTATION-ORIGIN | 2.9.
ANNOTATION-TEXT | 2.9.
ANNOTATIONS | 2.313. 2.683.
AREA | 2.13.
AVAILABILITY | 2.14.
BINARY-COMPATIBILITY | 2.15.
BIT-POSITION | 2.186. 2.305.
C-CODE | 2.19.
CALIBRATION | 2.21.
CATEGORY | 2.22. 2.175. 2.313. 2.632. 2.683.
CHANGE | 2.23.
CHAPTER | 2.4. 2.24. 2.159. 2.375.
CITY | 2.25.
COLSPEC | 2.27. 2.95. 2.253.
COMMENT | 2.165.
COMPANIES | 2.31.
COMPANY | 2.32.
COMPANY-DOC-INFO | 2.33.
COMPANY-DOC-INFOS | 2.34.
COMPANY-REF | 2.35.
COMPANY-REVISION-INFO | 2.36.
COMPANY-REVISION-INFOS | 2.37.
COMPATIBILITY | 2.38.
COND | 2.39.
CONF-ITEM-CODED-REF | 2.630.
CONF-ITEM-PHYS-REF | 2.630.
CONF-VALUE | 2.775. 2.776.
CONTRACT-ASPECTS | 2.69.
CRITICAL-ASPECTS | 2.221.
DATA-DESC | 2.71.
DATA-REQUIREMENTS | 2.72.
DATE | 2.74. 2.75. 2.91.
DATE-1 | 2.75.
dci-enum | 2.76.
DCI-ENUM-ENTRY | 2.76. 2.77.
DCI-TEXT-TYPE | 2.78.
DEF | 2.79.
DEF-ITEM | 2.80.
DEF-LIST | 2.81.
DEPARTMENT | 2.83.
DESC | 2.84. 2.221. 2.262. 2.313. 2.494. 2.683. 2.710. 2.719. 2.721.
distance | 2.601.
DOC-LABEL | 2.89.
DOC-REVISION | 2.90. 2.91.
DOC-REVISIONS | 2.91.
E | 2.92.
EMAIL | 2.93.
ENTITY-NAME | 2.94.
ENTRY | 2.95. 2.253. 2.739.
EXTENSIBILITY | 2.96.
FAIL-SAVE-CONCEPT | 2.97.
FAILURE-MANAGEMENT | 2.98.
FAILURE-MEM | 2.99.
FAX | 2.100.
FIGURE | 2.101.
FLASH-PROGRAMMING | 2.103.
FMEA | 2.104.
FORMATTER-CTRL | 2.105. 2.106.
FORMULA | 2.107.
FR-FEATURE | 2.109.
FR-FEATURE-REF | 2.630.
FR-FEAUTURE-REF | 2.109.
FREE-INFO | 2.110.
FT | 2.111.
FUNCTION-OVERVIEW | 2.112.
FUNCTION-REF | 2.491.
GENERAL-COND | 2.115.
GENERAL-HARDWARE | 2.116.
GENERAL-INTERFACES | 2.117.
GENERAL-PRODUCT-DATA-1 | 2.118.
GENERAL-PROJECT-DATA | 2.119.
GENERAL-REQUIREMENTS | 2.175. 2.188. 2.189.
GENERAL-SOFTWARE | 2.121.
GENERIC-MATH | 2.122.
GRAPHIC | 2.123.
GUARANTEE | 2.124.
HARDWARE-INTERFACE | 2.125.
HOMEPAGE | 2.126.
IE | 2.127.
INDENT-SAMPLE | 2.128.
INTEGRATION-CAPABILITY | 2.129.
INTERNAL-INTERFACES | 2.130.
INTERRUPT-SPEC | 2.284.
INTRODUCTION | 2.114. 2.132. 2.175. 2.224. 2.507.
ITEM | 2.134. 2.142.
ITEM-LABEL | 2.135. 2.710. 2.717.
KEY-DATA | 2.136.
LABEL | 2.9. 2.137. 2.310.
LABELED-ITEM | 2.138.
LABELED-LIST | 2.138. 2.139. 2.722.
LABELED-LST | 2.722.
LANGUAGE | 2.140.
LIFE-TIME | 2.141.
LIST | 2.134. 2.142.
LOCS | 2.143. 2.175.
LONG-NAME | 2.137. 2.144. 2.245. 2.313. 2.683. 2.726.
LONG-NAME-1 | 2.145.
LOWER-LIMIT | 2.393.
MAINTENANCE | 2.147.
MAP | 2.148.
MATCHING-DCI | 2.149. 2.175.
MATCHING-DCIS | 2.150. 2.175.
MAX | 2.151.
MAX-TEXT-LENGTH | 2.152.
MIN | 2.153.
MODIFICATION | 2.23. 2.156.
MODIFICATIONS | 2.157.
MSR-PROCESSING-LOG | 2.175.
MSR-QUERY-ARG | 2.165.
MSR-QUERY-NAME | 2.160. 2.165.
MSR-QUERY-PROPS | 2.161. 2.163. 2.164. 2.172. 2.173. 2.174.
MSR-QUERY-RESULT-CHAPTER | 2.161.
MSR-QUERY-RESULT-P-1 | 2.163. 2.167. 2.168.
MSR-QUERY-RESULT-P-2 | 2.164. 2.167. 2.168.
MSR-QUERY-RESULT-TOPIC-1 | 2.173.
MSR-QUERY-RESULT-TOPIC-2 | 2.174.
MSR-QUERY-TEXT | 2.169. 2.172.
MSRSW | 2.175.
MTBF | 2.176.
NA | 2.177.
NAMELOC | 2.178.
NCOI-1 | 2.2. 2.6. 2.131. 2.179.
NCOI-3 | 2.180.
NMLIST | 2.181.
NORMATIVE-REFERENCE | 2.182.
NOTATION | 2.183.
NOTE | 2.184.
NUMBER | 2.185.
NUMBER-OF-BITS | 2.305.
OBJECTIVES | 2.187.
OPERATING-ENV | 2.188. 2.190.
OPERATIONAL-REQUIREMENTS | 2.188. 2.190.
OVERALL-PROJECT | 2.191.
OVERVIEW | 2.284.
P | 2.11. 2.23. 2.132. 2.193. 2.219. 2.714. 2.717.
PARALLEL-DESIGNS | 2.194.
PHONE | 2.195.
POSITION | 2.196.
PPM | 2.197.
PRIVATE-CODE | 2.198.
PRIVATE-CODES | 2.199.
PRM | 2.200.
PRM-CHAR | 2.201.
PRM-REF | 2.202.
PRM-REFS | 2.203.
PRMS | 2.167. 2.168. 2.204.
PRODUCT-DEMARCATION | 2.205.
PRODUCT-DESC | 2.206.
PROJECT | 2.207.
PROJECT-DATA | 2.175. 2.208. 2.414.
PROJECT-SCHEDULE | 2.209.
PROTOCOLS | 2.210.
PUBLISHER | 2.211.
PURCHASING-COND | 2.212.
QUALITY | 2.213.
REALTIME-REQUIREMENTS | 2.221.
REASON | 2.215.
REASON-ORDER | 2.216.
REFRESH-TIMING | 2.550.
RELIABILITY | 2.217.
RELIABILITY-PRMS | 2.218.
REMARK | 2.219.
REPLACEMENT-VALUES | 2.220.
REQUIREMENT | 2.221. 2.223. 2.225. 2.735.
REQUIREMENT-BODY | 2.221.
REQUIREMENT-REF | 2.223. 2.491.
REQUIREMENT-SPEC | 2.114.
REQUIREMENTS-DEPENDENCY | 2.221.
RESOURCE-ALLOCATION | 2.227.
RESTRICTIONS-BY-HARDWARE | 2.228.
REVISION-LABEL | 2.229.
REVISION-LABEL-P1 | 2.230. 2.231.
RIGHTS | 2.232.
RISKS | 2.221.
ROLE | 2.234.
ROLES | 2.235.
ROW | 2.236.
SAFETY | 2.237.
SAMPLE | 2.238.
SAMPLE-REF | 2.239.
SAMPLE-SPEC | 2.240.
SAMPLES | 2.241.
SCHEDULE | 2.242.
SD | 2.243. 2.244.
SDG | 2.244. 2.245. 2.246. 2.254.
SDG-CAPTION | 2.244.
SELF-DIAGNOSIS | 2.247.
SHORT-NAME | 2.175. 2.223. 2.244. 2.245. 2.248. 2.249. 2.262. 2.272. 2.274. 2.308. 2.313. 2.353. 2.366. 2.371. 2.431. 2.453. 2.487. 2.488. 2.501. 2.663. 2.683. 2.726. 2.732.
SI-UNIT | 2.250. 2.292. 2.658.
SIGNAL-REF | 2.251.
SIMILAR-PRODUCTS | 2.252.
SPANSPEC | 2.95. 2.253.
SPECIAL-DATA | 2.175.
STANDARD-SW-MODULES | 2.255.
STATE | 2.256.
STATE-1 | 2.257.
STD | 2.258.
SUB | 2.259.
SUBTITLE | 2.260.
SUP | 2.261.
SW-ACCESS-DEF | 2.671.
SW-ACCESS-DEFINITIONS | 2.667. 2.672. 2.676.
SW-ACCESS-DURATION | 2.263. 2.268.
SW-ACCESSED-CALPRMS | 2.264.
SW-ACCESSED-CLASS-INSTANCES | 2.265.
SW-ACCESSED-SERVICE | 2.266.
SW-ACCESSED-SERVICES | 2.266.
SW-ACCESSED-VARIABLE | 2.268.
SW-ADDR-INFOS | 2.271.
SW-ADDR-METHOD | 2.272. 2.274. 2.277. 2.431.
SW-ADDR-METHOD-DESC | 2.272.
SW-ADDR-METHOD-REF | 2.274. 2.275. 2.276.
SW-ADDR-METHOD-REF-SYSCOND | 2.275.
SW-ADDR-OFFSET | 2.270.
SW-AR-RELATION | 2.282. 2.283.
SW-AR-RELATION-TYPE | 2.281.
SW-ARCHITECTURE | 2.649.
SW-ARRAY-INDEX | 2.501.
SW-ARRAYSIZE | 2.286. 2.313. 2.683.
SW-AXIS-CONT | 2.287.
SW-AXIS-CONTS | 2.288.
SW-AXIS-GENERIC | 2.292. 2.313.
SW-AXIS-GROUP | 2.313.
SW-AXIS-GROUPED | 2.290. 2.292. 2.313. 2.314.
SW-AXIS-INDEX | 2.287. 2.290. 2.291. 2.314.
SW-AXIS-INDIVIDUAL | 2.290. 2.314. 2.524.
SW-AXIS-TYPE | 2.289. 2.293. 2.294. 2.431. 2.492.
SW-AXIS-TYPE-REF | 2.289. 2.295. 2.296. 2.493.
SW-AXIS-TYPE-REF-SYSCOND | 2.295.
SW-BASE-ADDR | 2.270.
SW-BASE-TYPE | 2.299. 2.300. 2.303. 2.304. 2.431. 2.529. 2.597.
SW-BASE-TYPE-REF | 2.299. 2.301. 2.302. 2.314. 2.327. 2.597.
SW-BASE-TYPE-REF-SYSCOND | 2.301.
SW-BIT-REPRESENTATION | 2.186. 2.292. 2.305. 2.499.
SW-CALIBRATION-ACCESS | 2.314.
SW-CALIBRATION-HANDLE | 2.308.
SW-CALIBRATION-METHOD | 2.312.
SW-CALIBRATION-METHOD-VERSION | 2.309. 2.311.
SW-CALPRM | 2.286. 2.299. 2.313. 2.323. 2.329. 2.431. 2.651. 2.683.
SW-CALPRM-AXIS-SET | 2.286. 2.426.
SW-CALPRM-IMPL | 2.317.
SW-CALPRM-MAX-TEXT-SIZE | 2.490.
SW-CALPRM-NO-EFFECT-VALUE | 2.319.
SW-CALPRM-PROTOTYPE | 2.321. 2.322. 2.331.
SW-CALPRM-PROTOTYPES | 2.332.
SW-CALPRM-REF | 2.290. 2.292. 2.313. 2.324. 2.325.
SW-CALPRM-REF-SYSCOND | 2.264.
SW-CALPRM-TARGET | 2.326.
SW-CALPRM-TEXT | 2.490.
SW-CALPRMS | 2.313.
sw-carb-doc | 2.375.
SW-CLASS | 2.331. 2.341. 2.349. 2.375. 2.376.
SW-CLASS-ATTR | 2.331.
SW-CLASS-ATTR-IMPL | 2.334. 2.337.
SW-CLASS-ATTR-IMPLS | 2.331.
SW-CLASS-ATTR-INSTANCE-IMPL | 2.338.
SW-CLASS-IMPL | 2.340.
SW-CLASS-IMPLS | 2.338.
SW-CLASS-INSTANCE | 2.331. 2.342. 2.345. 2.431.
SW-CLASS-INSTANCE-REF | 2.343. 2.344.
SW-CLASS-INSTANCE-REF-SYSCOND | 2.265. 2.343.
SW-CLASS-METHOD | 2.331.
SW-CLASS-PROTOTYPE | 2.331. 2.347. 2.348.
SW-CLASS-PROTOTYPES | 2.332.
SW-CLASS-REF | 2.350.
SW-CLASS-REF-SYSCOND | 2.350.
SW-CODE-SYNTAX | 2.355. 2.358. 2.431.
SW-CODE-SYNTAX-DESC | 2.353.
SW-CODE-SYNTAX-REF | 2.353. 2.356. 2.357.
SW-CODE-SYNTAX-REF-SYSCOND | 2.356.
SW-CODE-SYNTAXES | 2.353.
SW-COLLECTION | 2.262. 2.360. 2.361. 2.362. 2.366. 2.373.
SW-COLLECTION-CONT | 2.360. 2.366.
SW-COLLECTION-REF | 2.262. 2.363.
sw-collection-refs | 2.360.
SW-COLLECTION-REGEXP | 2.365.
SW-COLLECTION-REGEXPS | 2.366.
SW-COLLECTION-RULE | 2.367.
sw-collection-rules | 2.360.
SW-COLLECTION-SCRIPT | 2.369.
SW-COLLECTION-SCRIPTS | 2.366.
SW-COLLECTION-WILDCARD | 2.372.
SW-COLLECTION-WILDCARDS | 2.366.
SW-COMPONENT-SPEC | 2.331. 2.375.
SW-COMPONENTS | 2.375.
SW-COMPU-DENOMINATOR | 2.390. 2.392.
SW-COMPU-IDENTITY | 2.381. 2.384.
SW-COMPU-INTERNAL-TO-PHYS | 2.384.
SW-COMPU-METHOD | 2.385. 2.388. 2.393. 2.431. 2.432. 2.509.
SW-COMPU-METHOD-REF | 2.292. 2.386. 2.387.
SW-COMPU-METHOD-REF-SYSCOND | 2.386.
SW-COMPU-NUMERATOR | 2.390. 2.392.
SW-COMPU-PHYS-TO-INTERNAL | 2.384.
SW-COMPU-RATIONAL-COEFFS | 2.393.
SW-COMPU-SCALE | 2.383. 2.392. 2.394.
SW-COMPU-SCALES | 2.384.
SW-CONSTR-LEVEL | 2.395.
SW-CONSTR-OBJECTS | 2.396.
SW-CPU-ADDR-EPK | 2.399.
SW-CPU-CALIBRATION-OFFSET | 2.398.
SW-CPU-MEM-SEG | 2.400. 2.401. 2.402.
SW-CPU-MEM-SEG-REF | 2.270. 2.272.
SW-CPU-MEM-SEGS | 2.400.
SW-CPU-SPEC | 2.303.
SW-CS-ENTRY | 2.411.
SW-CS-HISTORY | 2.411.
SW-CS-PERFORMED-BY | 2.412.
SW-CS-PROGRAM-IDENTIFIER | 2.413.
SW-CS-PROJECT-INFO | 2.414.
SW-CS-STATE | 2.415.
SW-CS-TARGET-VARIANT | 2.416.
SW-CS-TEST-OBJECT | 2.417.
SW-CSE-CODE | 2.419.
SW-CSE-CODE-FACTOR | 2.419.
SW-DATA-CONSTR | 2.420. 2.421. 2.425.
SW-DATA-CONSTR-REF | 2.292. 2.422. 2.423. 2.494.
SW-DATA-CONSTR-REF-SYSCOND | 2.422.
SW-DATA-CONSTR-RULE | 2.420.
SW-DATA-CONSTRS | 2.396.
SW-DATA-DEF-PROPS | 2.299. 2.313. 2.326. 2.426. 2.427. 2.581. 2.609. 2.651. 2.683.
SW-DATA-DEF-PROPS-SYSCOND | 2.427.
SW-DATA-DEPENDENCY | 2.429. 2.521.
SW-DISPLAY-FORMAT | 2.314. 2.384.
SW-EFFECT | 2.433. 2.434.
SW-EFFECT-FLOW | 2.434. 2.435.
SW-EFFECTING-VARIABLE | 2.433. 2.434. 2.436.
SW-FEATURE | 2.375. 2.376. 2.431. 2.453. 2.455. 2.456. 2.457. 2.468. 2.478. 2.481. 2.482. 2.486. 2.487. 2.488. 2.611.
SW-FEATURE-CALPRMS | 2.458.
SW-FEATURE-CLASS-INSTANCES | 2.458.
SW-FEATURE-DECOMPOSITION | 2.453. 2.582. 2.629. 2.649.
sw-feature-defintion | 2.375.
SW-FEATURE-DESIGN-DATA | 2.458.
SW-FEATURE-EXPORT-CLASS-INSTANCES | 2.454.
SW-FEATURE-IMPORT-CLASS-INSTANCES | 2.454.
SW-FEATURE-INTERFACE | 2.468.
SW-FEATURE-INTERFACES | 2.453.
SW-FEATURE-LOCAL-CLASS-INSTANCES | 2.454.
SW-FEATURE-REF | 2.484.
SW-FEATURE-VARIABLES | 2.375. 2.458.
SW-FEATURE-VARIANT | 2.453. 2.487. 2.488.
SW-FEATURE-VARIANT-OF | 2.489.
sw-function | 2.360.
SW-FUNCTION-VARIANT | 2.434.
SW-GENERIC-AXIS-PARAM | 2.289. 2.497.
SW-GENERIC-AXIS-PARAM-TYPE | 2.495. 2.496.
SW-GENERIC-AXIS-PARAM-TYPE-REF | 2.493.
SW-GENERIC-AXIS-PARAM-TYPES | 2.293. 2.494.
SW-GENERIC-AXIS-PARAMS | 2.493.
SW-GLOSSARY | 2.175.
SW-HOST-VARIABLE | 2.305.
SW-IMPL-POLICY | 2.500.
SW-INSTANCE | 2.285. 2.313. 2.501. 2.504. 2.540.
SW-INSTANCE-PROPS-VARIANT | 2.502. 2.540. 2.707.
SW-INSTANCE-PROPS-VARIANTS | 2.503.
SW-INSTANCE-REF | 2.505. 2.506.
SW-INSTANCE-SPEC | 2.507.
SW-INSTANCE-TREE | 2.331. 2.508.
SW-INTENDED-RESOLUTION | 2.509.
SW-INTERFACE-ACCESSED-ELEMENT-SET | 2.611.
SW-INTERFACE-ACCESSED-ELEMENT-SETS | 2.468.
SW-INTERFACE-EXPORTS | 2.468.
SW-INTERFACE-IMPORT | 2.468.
SW-INTERNAL-CONSTRS | 2.424. 2.519.
SW-INTERNAL-CONSTRS-1 | 2.384.
SW-IS-VIRTUAL | 2.477.
SW-MAX-AXIS-POINTS | 2.292.
SW-MC-ADDR-MAPPING | 2.528.
SW-MC-BASE-TYPE | 2.303. 2.529. 2.530. 2.531.
SW-MC-BLOB-ECU-DEPOSIT | 2.532. 2.534. 2.560. 2.562.
SW-MC-BLOB-LAYOUTS | 2.535. 2.553.
SW-MC-BLOB-VALUE | 2.532. 2.534. 2.560. 2.562.
SW-MC-COMMUNICATION-SPEC | 2.175.
SW-MC-DP-BLOB-LAYOUT | 2.533.
SW-MC-DP-BLOB-VALUE | 2.537.
SW-MC-FRAME | 2.539.
SW-MC-GENERIC-INTERFACE | 2.540. 2.541.
SW-MC-GENERIC-INTERFACES | 2.540.
SW-MC-INSTANCE-INTERFACE | 2.540.
SW-MC-INSTANCE-INTERFACES | 2.543.
SW-MC-INTERFACE | 2.544. 2.549.
SW-MC-INTERFACE-AVL-SOURCES | 2.546.
SW-MC-INTERFACE-DEFAULT-SOURCE | 2.546.
SW-MC-INTERFACE-IMPL | 2.548.
SW-MC-INTERFACE-SOURCE | 2.551. 2.552.
SW-MC-INTERFACE-SOURCE-REF | 2.545.
SW-MC-INTERFACE-SPEC | 2.535.
SW-MC-KP-BLOB-LAYOUT | 2.533.
SW-MC-KP-BLOB-VALUE | 2.555.
SW-MC-PA-BLOB-LAYOUT | 2.533.
SW-MC-PA-BLOB-VALUE | 2.559.
SW-MC-QP-BLOB-LAYOUT | 2.533.
SW-MC-QP-BLOB-VALUE | 2.561.
SW-MC-SYSTEM-BASE-TYPES | 2.535.
SW-MC-TP-BLOB-CONTS | 2.547.
SW-MC-TP-BLOB-LAYOUT | 2.533. 2.562.
SW-MC-TP-BLOB-VALUE | 2.563.
SW-MCD-BASE-TYPES | 2.553.
SW-MEM-ATTR | 2.400. 2.565.
SW-MEM-OFFSET | 2.400. 2.568.
SW-MEM-PROGRAM-TYPE | 2.400. 2.569.
SW-MEM-TYPE | 2.400. 2.571.
SW-MIN-AXIS-POINTS | 2.292.
SW-NUMER-OF-AXIS-POINTS | 2.289. 2.574.
sw-param | 2.360.
SW-PHYS-CONSTRS | 2.424. 2.518. 2.580.
SW-PHYS-CONSTRS-1 | 2.384.
SW-POINTER | 2.581.
SW-PROCESS | 2.585.
SW-RECORD-LAYOUT | 2.299. 2.431. 2.588. 2.594. 2.602.
SW-RECORD-LAYOUT-FIX-VALUE | 2.601.
SW-RECORD-LAYOUT-GROUP | 2.586. 2.588. 2.589. 2.590. 2.591. 2.592. 2.597.
SW-RECORD-LAYOUT-GROUP-AXIS | 2.589.
SW-RECORD-LAYOUT-GROUP-INDEX | 2.597. 2.600.
SW-RECORD-LAYOUT-REF | 2.588. 2.595. 2.596.
SW-RECORD-LAYOUT-REF-SYSCOND | 2.595.
SW-RECORD-LAYOUT-V | 2.588. 2.591. 2.598.
SW-RECORD-LAYOUT-V-AXIS | 2.597.
SW-RECORD-LAYOUT-V-INDEX | 2.600.
SW-RECORD-LAYOUT-V-PROP | 2.597. 2.599.
SW-RECORD-V-INDEX | 2.597.
SW-REFRESH-TIMING | 2.419.
SW-SCALE-CONSTR | 2.607.
SW-SERVICE | 2.264. 2.265. 2.266. 2.468. 2.611. 2.722.
SW-SERVICE-ACCESSED-ELEMENT-SET | 2.612.
SW-SERVICE-PROTOTYPES | 2.332.
SW-SERVICE-REFS | 2.583.
SW-SIZEOF-INSTANCE | 2.270.
SW-SUBCOMPONENT | 2.455.
SW-SYSCOND | 2.266. 2.275. 2.295. 2.301. 2.343. 2.350. 2.356. 2.386. 2.422. 2.427. 2.478. 2.583. 2.595. 2.630. 2.636. 2.653. 2.664. 2.705.
SW-SYSTEM | 2.192. 2.404. 2.431. 2.507. 2.631. 2.639. 2.657.
SW-SYSTEM-CONST-CODED-REF | 2.630.
SW-SYSTEM-CONST-PHYS-REF | 2.630.
SW-SYSTEM-MC-INTERFACE-DEFAULT-SOURCE | 2.550.
SW-SYSTEM-MC-INTERFACE-SOURCES | 2.547.
SW-SYSTEMCONST | 2.633. 2.634. 2.635. 2.638.
SW-SYSTEMCONST-CODED-REF | 2.380. 2.630.
SW-SYSTEMCONST-PHYS-REF | 2.380. 2.630.
SW-SYSTEMCONST-REF | 2.636. 2.637.
SW-SYSTEMCONST-REF-SYSCOND | 2.636.
SW-SYSTEMS | 2.175.
SW-TASK | 2.583. 2.584. 2.646. 2.650.
SW-TASK-DEADLINE | 2.642.
SW-TASK-LATENCY | 2.642.
SW-TASK-SPEC | 2.284. 2.649.
SW-TEMPLATE | 2.431. 2.652. 2.655.
SW-TEMPLATE-REF | 2.653. 2.654.
SW-TEMPLATE-REF-SYSCOND | 2.653.
SW-UNIT | 2.250. 2.431. 2.658. 2.659. 2.660. 2.666.
SW-UNIT-CONVERSION-METHOD | 2.250. 2.658. 2.659. 2.661. 2.662.
SW-UNIT-REF | 2.250. 2.287. 2.292. 2.384. 2.658. 2.659. 2.663. 2.664. 2.665.
SW-UNIT-REF-SYSCOND | 2.664.
SW-USER-ACCESS-CASE | 2.262. 2.668. 2.670.
SW-USER-ACCESS-CASE-REF | 2.262. 2.669.
SW-USER-ACCESS-CASES | 2.262. 2.676.
SW-USER-GROUP | 2.672. 2.673. 2.675.
SW-USER-GROUP-REF | 2.262. 2.674.
SW-USER-GROUPS | 2.676.
SW-USER-GRUOP-REFS | 2.672.
SW-VALUES-CODED | 2.287. 2.289. 2.632.
SW-VALUES-CODED-HEX | 2.287.
SW-VALUES-GENERIC | 2.287.
SW-VALUES-PHYS | 2.287. 2.289. 2.632. 2.680.
SW-VAR-NOT-AVL-VALUE | 2.682.
SW-VARABLE-ACCESS-IMPL | 2.268.
SW-VARIABLE | 2.299. 2.313. 2.384. 2.431. 2.468. 2.651. 2.693. 2.697.
SW-VARIABLE-ACCESS-SEQUENCE | 2.268.
SW-VARIABLE-IMPL | 2.688.
SW-VARIABLE-PROTOTYPE | 2.331. 2.691. 2.692.
SW-VARIABLE-PROTOTYPES | 2.332.
SW-VARIABLE-REF | 2.434. 2.436. 2.499. 2.694. 2.695.
SW-VARIABLE-REFS | 2.292.
SW-VARIABLE-USAGE | 2.268.
sw-variables | 2.360.
SW-VCD-CRITERION | 2.701. 2.704.
SW-VCD-CRITERION-POSSIBLE-VALUES | 2.707.
SW-VCD-CRITERION-REF | 2.705. 2.706.
SW-VCD-CRITERION-REF-SYSCOND | 2.705.
SW-VCD-CRITERION-REFS | 2.707.
SW-VCD-CRITERION-VALUE | 2.708.
SW-VCD-CRITERION-VALUES | 2.707.
SW-VCD-SPEC | 2.704.
SYN-OBJECT | 2.718.
SYN-SYNOPIS | 2.722.
SYN-SYNOPSIS | 2.713. 2.714. 2.715. 2.716. 2.722.
SYSTEM-OVERVIEW | 2.723.
SYSTEM-USER | 2.672. 2.725.
TABLE | 2.726.
TABLE-CAPTION | 2.712.
TBD | 2.728.
TBODY | 2.729.
TBR | 2.730.
TEAM-MEMBER | 2.133. 2.412. 2.731. 2.732.
TEAM-MEMBER-REF | 2.31. 2.732.
TEAM-MEMBER-REFS | 2.672. 2.733.
TEAM-MEMBERS | 2.734.
TECHNICAL-ASPECTS | 2.221.
TEX-MATH | 2.736.
TEXT | 2.737.
TFOOT | 2.738.
TGROUP | 2.27. 2.739.
THEAD | 2.740.
TIME-DEPENDENCY | 2.284.
TOL | 2.742.
TOPIC-1 | 2.170. 2.745.
TOPIC-2 | 2.171. 2.746.
TT | 2.747.
TYP | 2.748.
UNIT | 2.749.
UPPER-LIMIT | 2.393.
URL | 2.149. 2.751.
USED-LANGUAGES | 2.752.
USEFUL-LIFE | 2.753.
USEFUL-LIFE-PRMS | 2.754.
V | 2.680. 2.756.
VALUE | 2.757.
VARIANT-CHAR | 2.758. 2.763.
VARIANT-CHAR-ASSIGN | 2.759.
VARIANT-CHAR-ASSIGNS | 2.760.
VARIANT-CHAR-REF | 2.761.
VARIANT-CHAR-VALUE | 2.762.
VARIANT-DEF | 2.764.
VARIANT-DEFS | 2.765.
VARIANT-SPEC | 2.766.
VERBATIM | 2.11. 2.132. 2.219. 2.353. 2.767.
VF | 2.390. 2.493.
VT | 2.680. 2.770.
XDOC | 2.771.
XFILE | 2.743. 2.744. 2.772.
XREF | 2.226. 2.244. 2.773.
XSD-WHITE-SPACE | 2.776.
ZIP | 2.777.


State

false | 2.630.
PARENT | 2.468.


Tools

CDF processor | 2.150.
mcd system | 2.360.
MCD-System | 2.360. 2.540. 2.544.
MCD-Systemen | 2.378.
MCD-Systems | 2.544.


Untitled

Each of the following elements is described in the singular form in spite of the fact that the data dictionary allows multiple instances of each of them


Untitled

These are identical to the technical characteristics of parameters


Untitled

In future versions further formal components may be added to this, if required.


Untitled

These are identical to the technical characteristics of variables