Element Attribute Documentation
[msrsw_v2.2.2-eadoc]
Version: 14


1. Elemente der MSRSW DTD

Element Attribute Documentation
1. Elemente der MSRSW DTD

Alle Elemente der MSRSW DTD in alphabetischer Reihenfolge.


1.1. ABS
Siehe Auch Beschreibung Formale Beschreibung

Beschreibung
Verwenden Sie <ABS>, um die Absolutwerte eines Parameters einzugeben.
Formale Beschreibung
Hat als Kontext: | PRM-CHAR
Ist Kontext für: | Text, SUP, SUB
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.2. ACCEPTANCE-COND

Beschreibung
Verwenden Sie <ACCEPTANCE-COND>, um die Abnahmebedingungen einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PROJECT-DATA
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.3. ADD-DESIGN-DOC

Beschreibung
Die Möglichkeit, um zusätzliche Entwicklungsunterlagen in Form von Fließtext zu beschreiben und zu referenzieren.
Verwenden Sie <ADD-DESIGN-DOC>, um die zusätzlichen Entwicklungsunterlagen einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.4. ADD-INFO

Beschreibung
Die Möglichkeit, um zusätzliche Informationen, welche nicht durch die bestehende Struktur abgedeckt ist, in Form von Fließtext zu beschreiben. Im Gegensatz zu <ADD-SPEC> ergänzt <ADD-INFO> die Struktur, während <ADD-SPEC> genutzt wird, wo keine Struktur existiert.
Verwenden Sie <ADD-INFO>, um die zusätzlichen Informationen einzugeben.
Formale Beschreibung
Hat als Kontext: | REQUIREMENT, SW-CALIBRATION-METHOD, SW-CALIBRATION-METHOD-SPEC, SW-CALPRM, SW-CALPRM-PROTOTYPE, SW-CLASS, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-COLLECTION-SPEC, SW-COMPONENT-SPEC, SW-CPU-SPEC, SW-DATA-DEF-PROPS, SW-DATA-DICTIONARY-SPEC, SW-FEATURE, SW-INSTANCE-SPEC, SW-TASK-SPEC, SW-UNIT, SW-USER-RIGHT-SPEC, SW-VARIABLE, SW-VARIABLE-PROTOTYPE, SW-VCD-SPEC
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.5. ADD-SPEC

Beschreibung
Dieses Element gibt Ihnen die Möglichkeit, zusätzliche Spezifikationen, für welche es keine explizite Struktur gibt, hinzuzufügen. Zur Abgrenzung zu <ADD-INFO> siehe dort.
Formale Beschreibung
Hat als Kontext: | CONTRACT-ASPECTS, DATA-REQUIREMENTS, DESIGN-REQUIREMENTS, FAILURE-MANAGEMENT, FUNCTIONAL-REQUIREMENTS, GENERAL-HARDWARE, GENERAL-INTERFACES, GENERAL-PRODUCT-DATA-1, GENERAL-PROJECT-DATA, GENERAL-REQUIREMENTS, GENERAL-SOFTWARE, SW-ARCHITECTURE, SW-SYSTEM
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.6. ADDRESS

Beschreibung
Verwenden Sie <ADDRESS>, um die Straße der Firmenadresse eines Projektbeteiligten einzugeben.
Formale Beschreibung
Hat als Kontext: | TEAM-MEMBER
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.7. ADMIN-DATA
Siehe Auch Description Example Formale Beschreibung

Description
<ADMIN-DATA> can be used to capture all information regarding document management such as used language and versioning.
Example
  <ADMIN-DATA>
   <LANGUAGE>en</LANGUAGE>
   <DOC-REVISIONS>
      <DOC-REVISION>
         <REVISION-LABEL>2</REVISION-LABEL>
           <STATE>review-candiate</STATE>
         <TEAM-MEMBER-REF ID-REF="wl">Wl</TEAM-MEMBER-REF>
         <DATE>15.8.2001</DATE>
         <MODIFICATIONS>
            <MODIFICATION>
               <CHANGE>fixed typos</CHANGE>
               <REASON>typos were found in the internal review</REASON>
            </MODIFICATION>
         </MODIFICATIONS>
      </DOC-REVISION>
      <DOC-REVISION>
         <REVISION-LABEL>1</REVISION-LABEL>
         <STATE>initial draft</STATE>
         <TEAM-MEMBER-REF ID-REF="wl">Wl</TEAM-MEMBER-REF>
         <DATE>12.8.2001</DATE>
         <MODIFICATIONS>
            <MODIFICATION>
               <CHANGE>Created the document</CHANGE>
               <REASON>According to video-conference held at Jul2001</REASON>
            </MODIFICATION>
         </MODIFICATIONS>
      </DOC-REVISION>
   </DOC-REVISIONS>
</ADMIN-DATA>
Formale Beschreibung
Hat als Kontext:
CHAPTER, FUNCTIONAL-REQUIREMENTS, GENERAL-PRODUCT-DATA-1, GENERAL-PROJECT-DATA, GENERAL-REQUIREMENTS, MSRSW, REQUIREMENT, REQUIREMENT-SPEC, SW-ADDR-METHOD, SW-ADDR-METHODS, SW-ARCHITECTURE, SW-AXIS-TYPE, SW-AXIS-TYPES, SW-BASE-TYPE, SW-BASE-TYPES, SW-CALIBRATION-METHOD, SW-CALIBRATION-METHOD-SPEC, SW-CALPRM, SW-CALPRM-PROTOTYPE, SW-CALPRMS, SW-CLASS, SW-CLASS-ATTR-IMPL, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-CODE-SYNTAX, SW-CODE-SYNTAXES, SW-COLLECTION, SW-COLLECTION-SPEC, SW-COMPONENT-SPEC, SW-COMPU-METHOD, SW-COMPU-METHODS, SW-CPU-MEM-SEG, SW-CPU-SPEC, SW-DATA-CONSTR, SW-DATA-CONSTRS, SW-DATA-DICTIONARY-SPEC, SW-FEATURE, SW-GENERIC-AXIS-PARAM-TYPE, SW-GLOSSARY, SW-INSTANCE, SW-INSTANCE-PROPS-VARIANT, SW-INSTANCE-SPEC, SW-INSTANCE-TREE, SW-MC-BASE-TYPE, SW-MC-COMMUNICATION-SPEC, SW-MC-FRAME, SW-MC-INTERFACE, SW-MC-INTERFACE-IMPL, SW-MC-INTERFACE-SOURCE, SW-MC-INTERFACE-SPEC, SW-RECORD-LAYOUT, SW-RECORD-LAYOUTS, SW-SYSTEM, SW-SYSTEMCONST, SW-TASK, SW-TASK-SPEC, SW-TEMPLATE, SW-UNIT, SW-UNITS, SW-USER-ACCESS-CASE, SW-USER-GROUP, SW-USER-RIGHT-SPEC, SW-VARIABLE, SW-VARIABLE-PROTOTYPE, SW-VARIABLES, SW-VCD-CRITERION, SW-VCD-SPEC
Ist Kontext für:
LANGUAGE, USED-LANGUAGES, COMPANY-DOC-INFOS, FORMATTER-CTRLS, DOC-REVISIONS

Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.8. ANNOTATION

Beschreibung
In diesem Element werden textuelle Anmerkungen für das zu beschreibende Objekt gespeichert. Diese sind dafür vorgesehen, Informationen im Entwicklungsprozeß von Prozeßschritt zu Prozeßschritt weiterzureichen. Z.B. kann auf diese Weise ein besonderer Hinweis von der Funktionsentwicklung zur Calibrationsphase durchgereicht werden.
Eine Anmerkung besteht aus:
  • Überschrift (<LABEL>), die die Anmerkungen eindeutig kennzeichnet
  • Ursprung der Anmerkung: z.B. ein Werkzeug oder eine Prozeßphase (<ANNOTATION-ORIGIN>)
  • eigentlicher Text der Anmerkung (<ANNOTATION-TEXT>)
Formale Beschreibung
Hat als Kontext: | ANNOTATIONS, SW-COLLECTION
Ist Kontext für: | LABEL, ANNOTATION-ORIGIN, ANNOTATION-TEXT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.9. ANNOTATION-ORIGIN
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element kennzeichnet den Ursprung einer Anmerkung, welche z.B. durch verschiedene Prozeßphasen gereicht wird.
Example
<ANNOTATION>
   <LABEL>Do not change this</LABEL>
   <ANNOTATION-ORIGIN>funcdev</ANNOTATION-ORIGIN>
   <ANNOTATION-TEXT>
      <P>This feature should not be changed, even if the custormer
      requests it. You should tell him that it risks serious trouble.</P>
   </ANNOTATION-TEXT>
</ANNOTATION>
Formale Beschreibung
Hat als Kontext: | ANNOTATION
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.10. ANNOTATION-TEXT

Beschreibung
Dieses Element beinhaltet Paragraphen <P> bzw. <VERBATIM> zur Spezifikation einer textuellen Anmerkung relativ zu dem ihn beinhaltenden Kontext.
Formale Beschreibung
Hat als Kontext: | ANNOTATION
Ist Kontext für: | P, VERBATIM
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.11. ANNOTATIONS

Beschreibung
Container-Element für <ANNOTATION>.
Formale Beschreibung
Hat als Kontext: | SW-CALPRM, SW-CALPRM-PROTOTYPE, SW-CLASS, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-DATA-DEF-PROPS, SW-FEATURE, SW-INSTANCE-PROPS-VARIANT, SW-VARIABLE, SW-VARIABLE-PROTOTYPE
Ist Kontext für: | ANNOTATION
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.12. AREA

Beschreibung
Dieses Element spezifiziert eine Client-seitige Region in einer image map. Image maps erlauben es Autoren, Regionen in einem Objekt (z.B. einer Grafik) zu spezifizieren und eine bestimmte Aktion zu jeder Region zuzuweisen (z.B. lade ein Dokument, starte ein Programm, etc.).
Formale Beschreibung
Hat als Kontext: | MAP
Hat keinen Inhalt. |
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[SHAPE]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • RECT
  • CIRCLE
  • POLY
  • DEFAULT
Die Interpretation der Koordinaten [COORDS] wird durch den Wert von [SHAPE] kontrolliert.
[ID]
optional
Zeichenkette (CDATA)
Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[CLASS]
optional
Zeichenkette (CDATA)
Blank-separierte Liste von Klassen
[STYLE]
optional
Zeichenkette (CDATA)
Information über den assoziierten Stil
[TITLE]
optional
Zeichenkette (CDATA)
Titelinformation des <AREA>-Elementes
[ONCLICK]
optional
Zeichenkette (CDATA)
Der ONCLICK-Event tritt auf, wenn das aktuelle Element geklickt wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONDBLCLICK]
optional
Zeichenkette (CDATA)
Der ONDBLCLICK-Event tritt auf, wenn das aktuelle Element geklickt wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONMOUSEDOWN]
optional
Zeichenkette (CDATA)
Der ONMOUSEDOWN-Event tritt auf, wenn die zum klicken verwendete Maustaste auf dem aktuellen Element gedrückt gehalten wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONMOUSEUP]
optional
Zeichenkette (CDATA)
Der ONMOUSEUP-Event tritt auf, wenn die zum klicken verwendete Maustaste auf dem aktuellen Element losgelassen wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONMOUSEOVER]
optional
Zeichenkette (CDATA)
Der ONMOUSEOVER-Event tritt auf, wenn der Mauszeiger von außerhalb auf das aktuelle Element bewegt wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONMOUSEMOVE]
optional
Zeichenkette (CDATA)
Der ONMOUSEMOVE-Event tritt auf, wenn der Mauszeiger auf dem aktuellen Element bewegt wird (d.h. er befindet sich darauf). In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONMOUSEOUT]
optional
Zeichenkette (CDATA)
Der ONMOUSEOUT-Event tritt auf, wenn der Mauszeiger aus dem aktuellen Element herausbewegt wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONKEYPRESS]
optional
Zeichenkette (CDATA)
Der ONKEYPRESS-Event tritt auf, wenn eine Taste auf dem aktuellen Element gedrückt und wieder losgelassen wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONKEYDOWN]
optional
Zeichenkette (CDATA)
Der ONKEYDOWN-Event tritt auf, wenn eine Taste auf dem aktuellen Element gedrückt wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONKEYUP]
optional
Zeichenkette (CDATA)
Der ONKEYUP-Event tritt auf, wenn eine Taste auf dem aktuellen Element losgelassen wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[COORDS]
optional
Zeichenkette (CDATA)
Dieses Attribut spezifiziert die Position und die Form auf dem Bildschirm. Die Anzahl und Reihenfolge der Werte hängt von der definierten geometrischen Figur ab. Mögliche Kombinationen sind:
[HREF]
optional
Zeichenkette (CDATA)
Dieses Attribut spezifiziert den Speicherort einer Web-Resource, somit wird eine Verknüpfung (Link) zwischen dem aktuellen Element und dem Zielelement durch dieses Attribut spezifiziert.
[NOHREF]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • NOHREF
Falls dieses Attribut gesetzt ist, hat eine <AREA> keinen assoziierten Link.
[ALT]
optional
Zeichenkette (CDATA)
User Agenten, die keine Bilder, Formen oder Applets darstellen können, spezifiziert dieses Attribut den alternativ einzufügenden Text.
[TABINDEX]
optional
Zeichenkette (CDATA)
Dieses Attribut spezifiziert die Position des aktuellen Elementes in der Tabulator-Reihenfolge (Tabbing-Order) für das aktuelle Dokument. Dieser Wert muß zwischen 0 und 32767 liegen. Die Tabbing Order definiert die Reihenfolge, in welcher Elemente den Fokus erhalten, wenn Benutzer über die Tastatur navigieren.
[ACCESSKEY]
optional
Zeichenkette (CDATA)
Dieses Attribut weist einem Element einen Zugangs-Taste zu. Ein Zugangs-Taste ist ein einzelnes Zeichen (z.B. "B") innerhalb des Dokumenten-Zeichensatzes.Drückt man die Zugangs-Taste, welche einem Element zugewiesen ist, erhält das Element den Fokus. Die Aktion, welche ausgeführt wird, wenn ein Element den Fokus erhält, hängt vom Element selbst ab.
[ONFOCUS]
optional
Zeichenkette (CDATA)
Der ONFOCUS-Event tritt auf, wenn ein Element den Fokus erhält (z.B. durch Navigation durch die Tabulator-Taste). In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONBLUR]
optional
Zeichenkette (CDATA)
Der ONBLUR-Event tritt auf, wenn ein Element den Fokus verliert. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.


1.13. AVAILABILITY

Beschreibung
Verwenden Sie <AVAILABILITY>, um die Verfügbarkeit einzugeben.
Formale Beschreibung
Hat als Kontext: | USEFUL-LIFE-PRMS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, PRM-CHAR
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | PRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.14. BINARY-COMPATIBILITY

Beschreibung
Verwenden Sie <BINARY-COMPATIBILITY>, um die Binärkompatibilität einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-SOFTWARE
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.15. BIT-POSITION

Beschreibung
Anfangsposition einer Bitvariablen. Einzelheiten finden sich unter <SW-BIT-REPRESENTATION>.
Formale Beschreibung
Hat als Kontext: | SW-BIT-REPRESENTATION
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.16. BYTE-ORDER

Beschreibung
Dieses Element spezifiziert die Reihenfolge der Bytes in Speicherelementen, die mehrere Bytes umfassen, im Attribut [TYPE]. Mögliche Werte sind:
  • MOST-SIGNIFICANT-BYTE-FIRST - das höchstwertigste Byte steht zuerst
  • MOST-SIGNIFICANT-BYTE-LAST - das höchstwertigste Byte steht zuletzt
Formale Beschreibung
Hat als Kontext: | SW-BASE-TYPE, SW-CPU-SPEC, SW-MC-BASE-TYPE
Ist Kontext für: | Text
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[TYPE]
obligatorisch
Auswahlwert (NAMEDTOKENGROUP)
  • MOST-SIGNIFICANT-BYTE-FIRST
  • MOST-SIGNIFICANT-BYTE-LAST
MOST-SIGNIFICANT-BYTE-FIRST:höchstwertiges Byte zuerstMOST-SIGNIFICANT-BYTE-LAST:höchstwertiges Byte zuletzt
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.17. C-CODE

Beschreibung
Verwenden Sie <C-CODE> , um eine Formel einzufügen, die als C-Code definiert ist.
Formale Beschreibung
Hat als Kontext: | FORMULA
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.18. C-IDENTIFIER

Beschreibung
Dieses Element erlaubt es, den Einträgen einer tabellarischen Umrechnungsformel Identifier entsprechend der Programmiersprache C zuzuordnen. Damit wird eine Abbildung von Umrechnungsformeln in C-Enumeratoren unterstützbar.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-SCALE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.19. CALIBRATION

Beschreibung
Verwenden Sie <CALIBRATION>, um Anforderungen an die Kalibrierung einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.20. CATEGORY
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Spezifische, z.T. prozeß-/anwendungsabhängige Ausprägungen des Vaterelementes. Diese kann anschließend durch semantische Checker (z.B. DCI checker) in Postprozessen ausgewertet werden.
Mögliche Inhalte werden in der vorliegenden Dokumentation bei den Vaterelementen beschrieben.
Example
<SW-CALPRM>
   <SHORT-NAME>KF_XYZ</SHORT-NAME>
   <CATEGORY>MAP</CATEGORY>
<SW-CALPRM>
Dieses Beispiel zeigt, wie <CATEGORY> verwendet wird, um einen Kalibrierparameter als Kennfeld zu qualifizieren. Weitere Verarbeitung könnte daraus abprüfen, ob auch zwei Achsen spezifiziert sind.
Formale Beschreibung
Hat als Kontext: | MSRSW, REQUIREMENT, SW-ADDR-METHOD, SW-AXIS-TYPE, SW-BASE-TYPE, SW-CALIBRATION-METHOD, SW-CALPRM, SW-CALPRM-PROTOTYPE, SW-CLASS, SW-CLASS-ATTR-IMPL, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-CODE-SYNTAX, SW-COLLECTION, SW-COMPU-METHOD, SW-CPU-MEM-SEG, SW-DATA-CONSTR, SW-FEATURE, SW-GENERIC-AXIS-PARAM-TYPE, SW-INSTANCE, SW-INSTANCE-TREE, SW-MC-BASE-TYPE, SW-MC-FRAME, SW-MC-INTERFACE, SW-MC-INTERFACE-SOURCE, SW-RECORD-LAYOUT, SW-SYSTEM, SW-SYSTEMCONST, SW-TASK, SW-TEMPLATE, SW-UNIT, SW-USER-ACCESS-CASE, SW-USER-GROUP, SW-VARIABLE, SW-VARIABLE-PROTOTYPE, SW-VCD-CRITERION
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.21. CHANGE

Beschreibung
Verwenden Sie <CHANGE>, um die Änderungen der aktuellen Dokumentversion im Vergleich zur Vorgängerversion einzugeben.
Formale Beschreibung
Hat als Kontext: | MODIFICATION
Ist Kontext für: | Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, MSR-QUERY-TEXT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.22. CHAPTER

Beschreibung
Verwenden Sie <CHAPTER>, um eine Kapitelstruktur zu erstellen.
Formale Beschreibung
Hat als Kontext: | ADD-INFO, CHAPTER, CRITICAL-ASPECTS, FREE-INFO, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-CHAPTER, NCOI-1, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-COMPONENTS, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS
Ist Kontext für: | LONG-NAME, SHORT-NAME, ADMIN-DATA, INTRODUCTION, P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[ID]
obligatorisch
Identifikator (ID)
Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[BREAK]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • BREAK
  • NO-BREAK
Wählen Sie BREAK aus, um vor der Kapitelüberschrift einen Seitenumbruch einzufügen.
[HELP-ENTRY]
optional
Zeichenkette (CDATA)
Erlaubt es, das Vaterelement als ein Hilfe-Einstiegspunkt zu markieren. Die Syntax ergibt sich aus dem verwendeten Hilfesystem. Oft wird das dazu verwendet, aus einem Fenstersystem eine Objekt-Id bzw. eine Widget-Namenshierarchie zu errechnen, die dann mit den Help-Entry-Einträgen korreliert wird.Beispiel:
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS]
festgelegter Wert
SGML Zeichenkette (NMTOKEN)
CHAPTER
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.23. CITY

Beschreibung
Verwenden Sie <CITY>, um den Ort der Firmenadresse eines Projektbeteiligten einzugeben.
Formale Beschreibung
Hat als Kontext: | TEAM-MEMBER
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.24. CODE

Beschreibung
Verwenden Sie CODE, um die Kodierung einzugeben.
Die Definition von Varianten benötigt Kodierungen für Varianten, bzw. Varianteneigenschaften oder Werte für Varianteneigenschaften. Die Kodierung kann eine Nummer oder ein Name sein.
Formale Beschreibung
Hat als Kontext: | VARIANT-CHAR, VARIANT-CHAR-VALUE, VARIANT-DEF
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.25. COLSPEC

Beschreibung
Verwenden Sie <COLSPEC>, um eine Spalte innerhalb einer Tabellengruppe einzufügen und zu spezifizieren.
Formale Beschreibung
Hat als Kontext: | TFOOT, TGROUP, THEAD
Hat keinen Inhalt. |
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[COLNUM]
optional
SGML Zeichenkette (NMTOKEN)
Geben Sie an dieser Stelle die Plazierung der modifizierten Spalte innerhalb der Tabelle an, z.B. 1 für die erste Spalte.
[COLNAME]
optional
SGML Zeichenkette (NMTOKEN)
Geben Sie an dieser Stelle einen Identifikationsnamen für die modifizierte Spalte ein, z.B. Spalte1 für die erste Spalte.
[ALIGN]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • LEFT
  • RIGHT
  • CENTER
  • JUSTIFY
  • CHAR
LEFT - Der Tabelleninhalt wird linksbündig ausgerichtet.RIGHT - Der Tabelleninhalt wird rechtsbündig ausgerichtet.CENTER - Der Tabelleninhalt wird horizontal zentriert.JUSTIFY - Der Tabelleninhalt wird als Blocksatz dargestellt. Der Abstand zum linken und rechten Rand der Zelle ist gleich.CHAR - Die Ausrichtung des Tabelleninhalts wird über das Attribut [CHAR] festgelegt.
[CHAROFF]
optional
SGML Zeichenkette (NMTOKEN)
Wenn [ALIGN]="CHAR" ist, gibt dieser Wert die Prozentanzahl der aktuellen Spaltenbreite zum linken Rand des Ausrichtungszeichens im [CHAR]-Attribut an. Falls kein Ausrichtungszeichen im Element <COLSPEC> vorhanden ist, wird horizontal rechts ausgerichtet. Der Defaultwert wird von <TGROUP> geerbt.
[CHAR]
optional
Zeichenkette (CDATA)
Falls [ALIGN]="CHAR" ist, gibt dieser aus einem Zeichen bestehende Wert von [CHAR] das Ausrichtungszeichen, z.B. "," bzlw "." als Dezimalpunkttrennzeichen, an. Das Zeichen darf kein SDATA-Entity sein.
[COLWIDTH]
optional
Zeichenkette (CDATA)
Geben Sie an dieser Stelle die Breite der modifizierten Spalte innerhalb der Tabelle an. Sie können Absolutwerte wie z.B. 4 cm eingeben, oder Relativwerte, die mit * markiert werden, z.B. 2* für doppelte Spaltenbreite im Vergleich zu den anderen Spalten.
[COLSEP]
optional
SGML Zeichenkette (NMTOKEN)
Legen Sie an dieser Stelle fest, ob für Spalten Spaltenlinien angezeigt werden sollen.Geben Sie 0 ein, wenn keine Spaltenlinien angezeigt werden sollen.Geben Sie 1 ein, wenn Spaltenlinien angezeigt werden sollen.
[ROWSEP]
optional
SGML Zeichenkette (NMTOKEN)
Legen Sie an dieser Stelle fest, ob für die Spalten Reihenlinien angezeigt werden sollen.Geben Sie 0 ein, wenn keine Reihenlinien angezeigt werden sollenGeben Sie 1 ein, wenn Reihenlinien angezeigt werden sollen.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.26. COMMENT

Beschreibung
Dieses Element beinhaltet einen textuellen Kommentar.
Formale Beschreibung
Hat als Kontext: | MSR-QUERY-PROPS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.27. COMMUNICATION

Beschreibung
Dieses Element beinhaltet die Kommunikation betreffende textuelle funktionale Anforderungen.
Formale Beschreibung
Hat als Kontext: | FUNCTIONAL-REQUIREMENTS
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.28. COMMUNICATION-INTERFACE

Beschreibung
Verwenden Sie COMMUNICATION-INTERFACE, um die Kommunikationsschnittstellen einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-INTERFACES
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.29. COMPANIES
Siehe Auch Description Example Formale Beschreibung

Description
<COMPANIES> can be used to describe the companies being involved in the procject. With respect to CDF this is used mainly to specify copyright information and the involved persons. Usually there is more than one company involved in the project. The company which generated the file is determined by following <TEAM-MEMBER-REF> within <ADMIN-DATA>. In simple cases there is only one company, so this lookup is not really necessary.
Example
For an example, see COMPANIES
Formale Beschreibung
Hat als Kontext: | PROJECT
Ist Kontext für: | COMPANY
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.30. COMPANY

Beschreibung
Verwenden Sie <COMPANY>, um Unternehmensdaten und generelle Projektdaten zu beschreiben.
Formale Beschreibung
Hat als Kontext: | COMPANIES
Ist Kontext für: | LONG-NAME, SHORT-NAME, ROLES, TEAM-MEMBERS
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[ID]
obligatorisch
Identifikator (ID)
Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[ROLE]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • MANUFACTURER
  • SUPPLIER
Wählen Sie MANUFACTURER aus, wenn das projektbeiteiligte Unternehmen ein Hersteller/Partner ist.Wählen Sie SUPPLIER aus, wenn das projektbeiteiligte Unternehmen ein Lieferant ist.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS]
festgelegter Wert
SGML Zeichenkette (NMTOKEN)
COMPANY
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE]
festgelegter Wert
SGML Zeichenketten (NMTOKENS)
TEAM-MEMBER
Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')
[F-CHILD-TYPE]
festgelegter Wert
Zeichenkette (CDATA)
LONG-NAME:SELECTION
Fixed Child Type. Warning: This attribute is only in the DTD for compatibility with older versions of the DTD and should not be used for any new implementations. It might be removed in future versions of the DTD.This attribute contains the information which child elements of the element carring this attribute should be checked by an semantic checker.


1.31. COMPANY-DOC-INFO

Beschreibung
Verwenden Sie <COMPANY-DOC-INFO>, um Dokumentinformationen zu den projektbeteiligten Unternehmen zu erstellen.
Formale Beschreibung
Hat als Kontext: | COMPANY-DOC-INFOS
Ist Kontext für: | COMPANY-REF, DOC-LABEL, TEAM-MEMBER-REF, PRIVATE-CODES, ENTITY-NAME
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.32. COMPANY-DOC-INFOS

Beschreibung
Verwenden Sie <COMPANY-DOC-INFOS>, um eine Zusammenfassung der Dokumentinformationen zu projektbeteiligten Unternehmen zu erstellen.
Formale Beschreibung
Hat als Kontext: | ADMIN-DATA
Ist Kontext für: | COMPANY-DOC-INFO
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.33. COMPANY-REF

Beschreibung
Verwenden Sie <COMPANY-REF>, um auf die entsprechende Firma zu referenzieren, für die Sie unternehmensspezifische Dokumentinformationen erstellen wollen.
Formale Beschreibung
Hat als Kontext: | COMPANY-DOC-INFO, COMPANY-REVISION-INFO
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | COMPANY | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.


1.34. COMPANY-REVISION-INFO

Beschreibung
Verwenden Sie <COMPANY-REVISION-INFO>, um Informationen zum Dokumentenstand innerhalb des jeweiligen Unternehmens zu erstellen.
Formale Beschreibung
Hat als Kontext: | COMPANY-REVISION-INFOS
Ist Kontext für: | COMPANY-REF, REVISION-LABEL, STATE, REMARK
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.35. COMPANY-REVISION-INFOS

Beschreibung
Verwenden Sie <COMPANY-REVISION-INFOS>, um eine Zusammenfassung der Informationen zum Dokumentenstand innerhalb eines Unternehmens zu erstellen.
Formale Beschreibung
Hat als Kontext: | DOC-REVISION
Ist Kontext für: | COMPANY-REVISION-INFO
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.36. COMPATIBILITY

Beschreibung
Verwenden Sie COMPATIBILITY, um die Ähnlichkeit mit anderen Systemen / Kompatibilität einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-SOFTWARE
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.37. COND

Beschreibung
Verwenden Sie <COND>, um Randbedingungen, für die Parameterwerte gültig sind, einzugeben.
Formale Beschreibung
Hat als Kontext: | PRM-CHAR
Ist Kontext für: | P
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.38. CONTRACT-ASPECTS

Beschreibung
Verwenden Sie CONTRACT-ASPECTS, um die vertraglichen Aspekte einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PROJECT-DATA
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, RIGHTS, GUARANTEE, MAINTENANCE, ADD-SPEC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.39. CRITICAL-ASPECTS

Beschreibung
Verwenden Sie CRITICAL-ASPECTS, um kritische Aspekte textuell innerhalb einer Anforderung zu spezifizieren.
Formale Beschreibung
Hat als Kontext: | REQUIREMENT
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.40. DATA-DESC

Beschreibung
Verwenden Sie DATA-DESC, um die Datenbeschreibung einzugeben.
Formale Beschreibung
Hat als Kontext: | DATA-REQUIREMENTS
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.41. DATA-REQUIREMENTS

Beschreibung
Verwenden Sie DATA-REQUIREMENTS, um die Datenorientierten Anforderungen einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-SOFTWARE
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, DATA-STRUCTURES, DATA-DESC, ADD-SPEC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.42. DATA-STRUCTURES

Beschreibung
Verwenden Sie DATA-STRUCTURES, um die Datenstrukturen einzugeben.
Formale Beschreibung
Hat als Kontext: | DATA-REQUIREMENTS
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.43. DATE
Siehe Auch Description Example Formale Beschreibung

Description
<DATE> ist used to capture a time stamp. It must match to one of the following syntaxes:
<YYYY>-<MM>-<DD>[T<hh>:<mm>:<ss>]

<YYYY>.<MM>.<DD>[T<hh>:<mm>:<ss>]

<YYYY>/<MM>/<DD>[T<hh>:<mm>:<ss>]
The last pattern is the most preferred one, since it reflects a common use in US.
Example
<DATE>2001-03-20T09:00:00</DATE>
Formale Beschreibung
Hat als Kontext: | DOC-REVISION, SCHEDULE, SW-CS-ENTRY
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.44. DATE-1

Beschreibung
Verwenden Sie <DATE-1>, um das Gültigkeitsdatum eines Standards oder das Erstelldatum eines externen Dokumentes einzugeben.
Formale Beschreibung
Hat als Kontext: | STD, XDOC
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.45. DEF

Beschreibung
Verwenden Sie <DEF>, um innerhalb einer Definitionsliste einen Absatz zur Beschreibung des Titels einzugeben
Formale Beschreibung
Hat als Kontext: | DEF-ITEM
Ist Kontext für: | P
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.46. DEF-ITEM

Beschreibung
Verwenden Sie <DEF-ITEM> , um den Titel eines Aufzählungselementes der Definitionsliste einzugeben.
Formale Beschreibung
Hat als Kontext: | DEF-LIST
Ist Kontext für: | LONG-NAME, SHORT-NAME, DEF
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[ID]
obligatorisch
Identifikator (ID)
Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[HELP-ENTRY]
optional
Zeichenkette (CDATA)
Erlaubt es, das Vaterelement als ein Hilfe-Einstiegspunkt zu markieren. Die Syntax ergibt sich aus dem verwendeten Hilfesystem. Oft wird das dazu verwendet, aus einem Fenstersystem eine Objekt-Id bzw. eine Widget-Namenshierarchie zu errechnen, die dann mit den Help-Entry-Einträgen korreliert wird.Beispiel:
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS]
festgelegter Wert
SGML Zeichenkette (NMTOKEN)
DEF-ITEM
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.47. DEF-LIST

Beschreibung
Verwenden Sie <DEF-LIST>, um eine Definitionsliste anzulegen, deren Marginalie referenzierbar ist.
Formale Beschreibung
Hat als Kontext: | ADD-INFO, CHAPTER, CRITICAL-ASPECTS, ENTRY, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REMARK, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CLASS-METHOD-RETURN, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Ist Kontext für: | DEF-ITEM
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.48. DEMARCATION-OTHER-PROJECTS

Beschreibung
Verwenden Sie DEMARCATION-OTHER-PROJECTS, um die Abgrenzung gegenüber anderen Projekten einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PROJECT-DATA
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.49. DEPARTMENT

Beschreibung
Verwenden Sie <DEPARTMENT>, um die Abteilung eines Projektbeteiligten einzugeben.
Formale Beschreibung
Hat als Kontext: | TEAM-MEMBER
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.50. DESC
Siehe Auch Description Example Formale Beschreibung

Description
<DESC> represents a general but brief description of the object in question.
Example
Using <DESC> corresponding to ANNOTATION in CDF format would look like this:
<DESC> This calibration is a gain
                that is used for the tranistion period between crank to run. It should be set
                between 1000 and 1500
</DESC>
Formale Beschreibung
Hat als Kontext: | AVAILABILITY, FIGURE, LIFE-TIME, MTBF, OPERATING-TIME, OVERALL-PROJECT, PPM, PRM, PROJECT, REQUIREMENT, SDG-CAPTION, SW-ADDR-METHOD, SW-AXIS-TYPE, SW-BASE-TYPE, SW-CALIBRATION-METHOD, SW-CALPRM, SW-CALPRM-POINTER, SW-CALPRM-PROTOTYPE, SW-CLASS, SW-CLASS-ATTR-IMPL, SW-CLASS-INSTANCE, SW-CLASS-METHOD, SW-CLASS-PROTOTYPE, SW-CODE-SYNTAX, SW-COLLECTION, SW-COMPU-METHOD, SW-COMPU-SCALE, SW-CPU-MEM-SEG, SW-DATA-CONSTR, SW-DATA-DEPENDENCY, SW-DATA-DICTIONARY-SPEC, SW-FEATURE, SW-GENERIC-AXIS-PARAM-TYPE, SW-INSTANCE, SW-INSTANCE-PROPS-VARIANT, SW-INSTANCE-TREE, SW-MC-BASE-TYPE, SW-MC-FRAME, SW-MC-GENERIC-INTERFACE, SW-MC-INTERFACE, SW-MC-INTERFACE-SOURCE, SW-PROCESS, SW-RECORD-LAYOUT, SW-RECORD-LAYOUT-GROUP, SW-RECORD-LAYOUT-V, SW-SYSTEM, SW-SYSTEMCONST, SW-TASK, SW-TEMPLATE, SW-UNIT, SW-USER-ACCESS-CASE, SW-USER-GROUP, SW-VARIABLE, SW-VARIABLE-PROTOTYPE, SW-VCD-CRITERION, TBD
Ist Kontext für: | Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, MSR-QUERY-TEXT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.51. DESIGN-REQUIREMENTS

Beschreibung
Verwenden Sie DESIGN-REQUIREMENTS, um die Anforderungen an das Softwaredesign einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-SOFTWARE
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NORMATIVE-REFERENCE, RESTRICTIONS-BY-HARDWARE, STANDARD-SW-MODULES, ADD-SPEC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.52. DEVELOPMENT-PROCESS-SPEC

Beschreibung
Verwenden Sie DEVELOPMENT-PROCESS-SPEC, um die Definition des Entwicklungsprozesses einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.53. DIAGNOSIS

Beschreibung
Dieses Element beinhaltet Diagnoseumfänge betreffende textuelle funktionale Anforderungen.
Formale Beschreibung
Hat als Kontext: | FUNCTIONAL-REQUIREMENTS
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.54. DIR-HAND-OVER-DOC-DATA

Beschreibung
Verwenden Sie DIR-HAND-OVER-DOC-DATA, um das Verzeichnis der übergebenen Unterlagen einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PROJECT-DATA
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.55. DOC-LABEL

Beschreibung
Verwenden Sie <DOC-LABEL>, um den Titel des Dokumentes oder Dokumententeiles einzugeben, für das Sie administrative Daten erstellen möchten.
Formale Beschreibung
Hat als Kontext: | COMPANY-DOC-INFO
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.56. DOC-REVISION

Beschreibung
Verwenden Sie <DOC-REVISION>, um Informationen zum entsprechenden Dokumentstand zu erstellen.
Formale Beschreibung
Hat als Kontext: | DOC-REVISIONS
Ist Kontext für: | COMPANY-REVISION-INFOS, REVISION-LABEL, STATE, ISSUED-BY, TEAM-MEMBER-REF, DATE, MODIFICATIONS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.57. DOC-REVISIONS
Siehe Auch Description Example Formale Beschreibung

Description
<DOC-REVISIONS> is a container to get the entire change-history. Although the sequence of changes can be determined by sorting <DOC-REVISIONS> according to <DOC-REVISION>/<DATE>, it is recommended to put the most recent <DOC-REVISION> as the first child of <DOC-REVISIONS>.
Example
For an example, see 1.7. ADMIN-DATA ADMIN-DATA ADMIN-DATA ADMIN-DATA.
Formale Beschreibung
Hat als Kontext: | ADMIN-DATA
Ist Kontext für: | DOC-REVISION
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.58. E

Beschreibung
Verwenden Sie <E>, um innerhalb eines Absatzelementes Textteile hervorzuheben.
Formale Beschreibung
Hat als Kontext: | CHANGE, DESC, INDENT-SAMPLE, ITEM-LABEL, LABEL, LONG-NAME, LONG-NAME-1, MSR-QUERY-RESULT-TEXT, P, REASON, TBR, VERBATIM
Ist Kontext für: | Text
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[TYPE]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • BOLD
  • ITALIC
  • BOLDITALIC
  • PLAIN
Verwenden Sie BOLD, um fett hervorzuhebenVerwenden Sie ITALIC, um kursiv hervorzuheben
[COLOR]
optional
Zeichenkette (CDATA)
Farbwert, spezifiziert in SRBGEin Farbwert darf entweder ein Hhexadezimalwert (mit # als Präfix) oder eine der folgenden 16 Farbnamen sein. Die Farbnamen sind Case-Insensitive.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.59. EMAIL

Beschreibung
Verwenden Sie <EMAIL>, um die Web-Adresse der Firma eines Projektbeteiligten einzugeben.
Formale Beschreibung
Hat als Kontext: | TEAM-MEMBER
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.60. ENTITY-NAME

Beschreibung
Verwenden Sie <ENTITY-NAME>, um einen unternehmensspezifischen Dateinamen des Dokumentes oder Dokumentteils zu erstellen.
Formale Beschreibung
Hat als Kontext: | COMPANY-DOC-INFO
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.61. ENTRY

Beschreibung
Verwenden Sie <ENTRY>, um das Absatzelement zu erstellen, mit dem der Inhalt einer Tabellenzelle dargestellt werden soll.
Formale Beschreibung
Hat als Kontext: | ROW
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[MOREROWS]
mit Default-Wert
SGML Zeichenkette (NMTOKEN)
0
Modifizieren Sie das Attribut, um die entsprechende <ENTRY>-Zelle mit den Zellen der darauffolgenden Zeilen zu verschmelzen.Geben Sie 0 ein, wenn Sie keine Zeilenverschmelzung wünschen.Geben Sie 1 ein, wenn Sie die Zelle mit der Zelle der nächsten Zeile verschmelzen möchten.Geben Sie eine Zahl n ein, wenn Sie die Zelle mit Zellen der n darauffolgenden Zeilen verschmelzen möchten.
[ROTATE]
mit Default-Wert
SGML Zeichenkette (NMTOKEN)
0
Geben Sie den Winkel ein, um den der Inhalt einer Zelle gedreht werden soll.
[VALIGN]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • TOP
  • BOTTOM
  • MIDDLE
TOP - Der Tabelleninhalt wird am oberen Zellenrand ausgerichtet.BOTTOM - Der Tabelleninhalt wird am unteren Zellenrand ausgerichtet.MIDDLE - Der Tabelleninhalt wird vertikal zentriert ausgerichtet.
[COLNAME]
optional
SGML Zeichenkette (NMTOKEN)
Geben Sie an dieser Stelle einen Identifikationsnamen für die modifizierte Spalte ein, z.B. Spalte1 für die erste Spalte.
[NAMEST]
optional
SGML Zeichenkette (NMTOKEN)
Identifikationsnummer der ersten Spalte einer Spaltenverschmelzung
[NAMEEND]
optional
SGML Zeichenkette (NMTOKEN)
Identifikationsnummer der letzten Spalte einer Spaltenverschmelzung
[SPANNAME]
optional
SGML Zeichenkette (NMTOKEN)
Identifikationsname einer spezifizierte Spaltenverschmelzung
[COLSEP]
optional
SGML Zeichenkette (NMTOKEN)
Legen Sie an dieser Stelle fest, ob für die Zelle Spaltenlinien angezeigt werden sollen.Geben Sie 0 ein, wenn keine Spaltenlinien angezeigt werden sollen.Geben Sie 1 ein, wenn Spaltenlinien angezeigt werden sollen.
[ROWSEP]
optional
SGML Zeichenkette (NMTOKEN)
Legen Sie an dieser Stelle fest, ob für die Zelle Reihenlinien angezeigt werden sollen.Geben Sie 0 ein, wenn keine Reihenlinien angezeigt werden sollenGeben Sie 1 ein, wenn Reihenlinien angezeigt werden sollen.
[ALIGN]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • LEFT
  • RIGHT
  • CENTER
  • JUSTIFY
  • CHAR
LEFT - Der Tabelleninhalt wird linksbündig ausgerichtet.RIGHT - Der Tabelleninhalt wird rechtsbündig ausgerichtet.CENTER - Der Tabelleninhalt wird horizontal zentriert.JUSTIFY - Der Tabelleninhalt wird als Blocksatz dargestellt. Der Abstand zum linken und rechten Rand der Zelle ist gleich.CHAR - Die Ausrichtung des Tabelleninhalts wird über das Attribut [CHAR] festgelegt.
[CHAROFF]
optional
SGML Zeichenkette (NMTOKEN)
Wenn [ALIGN]="CHAR" ist, gibt dieser Wert die Prozentanzahl der aktuellen Spaltenbreite zum linken Rand des Ausrichtungszeichens im [CHAR]-Attribut an. Falls kein Ausrichtungszeichen im Element <ENTRY> vorhanden ist, wird horizontal rechts ausgerichtet. Der Defaultwert wird von <COLSPEC> oder <SPANSPEC> geerbt.
[CHAR]
optional
Zeichenkette (CDATA)
Falls [ALIGN]="CHAR" ist, gibt dieser aus einem Zeichen bestehende Wert von [CHAR] das Ausrichtungszeichen, z.B. "," bzlw "." als Dezimalpunkttrennzeichen, an. Das Zeichen darf kein SDATA-Entity sein.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.62. EXTENSIBILITY

Beschreibung
Verwenden Sie <EXTENSIBILITY>, um die Erweiterbarkeit einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-SOFTWARE
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.63. FAIL-SAVE-CONCEPT

Beschreibung
Verwenden Sie <FAIL-SAVE-CONCEPT>, um die Notlaufkonzept einzugeben.
Formale Beschreibung
Hat als Kontext: | FAILURE-MANAGEMENT
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.64. FAILURE-MANAGEMENT

Beschreibung
Verwenden Sie <FAILURE-MANAGEMENT>, um die Ausfallbehandlung einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, FMEA, FAIL-SAVE-CONCEPT, REPLACEMENT-VALUES, FAILURE-MEM, SELF-DIAGNOSIS, ADD-SPEC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.65. FAILURE-MEM

Beschreibung
Verwenden Sie <FAILURE-MEM>, um die Fehlerspeicher einzugeben.
Formale Beschreibung
Hat als Kontext: | FAILURE-MANAGEMENT
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.66. FAX

Beschreibung
Verwenden Sie <FAX>, um die Faxnummer eines Projektbeteiligten einzugeben.
Formale Beschreibung
Hat als Kontext: | TEAM-MEMBER
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.67. FIGURE

Beschreibung
Verwenden Sie <FIGURE>, um Grafiken in ein Dokument einzubinden.
Formale Beschreibung
Hat als Kontext: | ADD-INFO, CHAPTER, CRITICAL-ASPECTS, ENTRY, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REMARK, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CLASS-METHOD-RETURN, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Ist Kontext für: | FIGURE-CAPTION, GRAPHIC, MAP, VERBATIM, DESC
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[FLOAT]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • FLOAT
  • NO-FLOAT
Erlaubt es, bei einer nicht umbrechbaren <FIGURE> zu steuern ob die <FIGURE> woanders hin verschoben werden kann um eine bessere Seitenausnutzung zu bekommen (vergleiche flat bei TeX).
[HELP-ENTRY]
optional
Zeichenkette (CDATA)
Erlaubt es, das Vaterelement als ein Hilfe-Einstiegspunkt zu markieren. Die Syntax ergibt sich aus dem verwendeten Hilfesystem. Oft wird das dazu verwendet, aus einem Fenstersystem eine Objekt-Id bzw. eine Widget-Namenshierarchie zu errechnen, die dann mit den Help-Entry-Einträgen korreliert wird.Beispiel:
[PGWIDE]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • PGWIDE
  • NO-PGWIDE
PGWIDE: Erlaubt das Ausdehnen der Abbildung auf die gesamte Seitenbreite. NO-PGWIDIE unterdrückt die Ausdehnung auf die gesamte Seitenbreite, z.B. falls fester Sidehead vorgegeben.
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
KEEP: Erzwingt, daß die Grafik und das vorausgehende Element zusammengehalten werden. NO-KEEP trennt beide Elemente.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.68. FIGURE-CAPTION

Beschreibung
Dieses Element spezifiziert den Titel einer Abbildung.
Formale Beschreibung
Hat als Kontext: | FIGURE
Ist Kontext für: | LONG-NAME, SHORT-NAME
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | FIGURE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.69. FLASH-PROGRAMMING

Beschreibung
Verwenden Sie <FLASH-PROGRAMMING>, um die Flash-Programmierung einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-INTERFACES
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.70. FMEA

Beschreibung
Verwenden Sie <FMEA>, um die FMEA einzugeben.
Formale Beschreibung
Hat als Kontext: | FAILURE-MANAGEMENT
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.71. FORMATTER-CTRL

Beschreibung
Dieses Element beinhaltet frei spezifizierbare Anweisungen, wie der Umfang des Kontextes, in dem <FORMATTER-CTRL> steht, zu formatieren ist. Das Attribut [SI] kann hierbei von einem Formatierungsprozeß weitere zu verwendende Informationen tragen.
Formale Beschreibung
Hat als Kontext: | FORMATTER-CTRLS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[TARGET-SYSTEM] optional | Zeichenkette (CDATA) | Dieses Attribut kann ein Zielsytem angeben, für das die aktuelle Einstellung gilt. Fehlt dieses Attribut, gilt es für alle Zielsysteme. Es ist Aufgabe der Zielsysteme zu entscheiden, wie dieses Attribut interpretiert wird. So kann z.B. die Steuer der Sicht bei der Erstellung eines Hilfe-Files so vorgehen: gibt es eine formatter-ctrl si="view" target-system="htmlhelp", dann wird dies verwendet. Gibt es die spezifische Sicht nicht, aber ein formatter-ctrl si="view" ohne Angabe des Zielsystems verwendet er diese.
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.72. FORMATTER-CTRLS

Beschreibung
Container-Element für <FORMATTER-CTRL>.
Formale Beschreibung
Hat als Kontext: | ADMIN-DATA
Ist Kontext für: | FORMATTER-CTRL
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.73. FORMULA

Beschreibung
Verwenden Sie <FORMULA>, um eine Formel in eine Dokumentation einzufügen.
Formale Beschreibung
Hat als Kontext: | ADD-INFO, CHAPTER, CRITICAL-ASPECTS, ENTRY, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REMARK, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CLASS-METHOD-RETURN, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Ist Kontext für: | FORMULA-CAPTION, GRAPHIC, MAP, VERBATIM, TEX-MATH, C-CODE, GENERIC-MATH
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
KEEP: Erzwingt, daß die Formel und das vorausgehende Element zusammengehalten werden. NO-KEEP trennt beide Elemente.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.74. FORMULA-CAPTION

Beschreibung
Dieses Element spezifiziert die Beschriftung bzw. Überschrift einer Formel.
Formale Beschreibung
Hat als Kontext: | FORMULA
Ist Kontext für: | LONG-NAME, SHORT-NAME
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | FORMULA | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.75. FREE-INFO

Beschreibung
Verwenden Sie <FREE-INFO>, um die Einzelheiten als Fließtext einzugeben.
Formale Beschreibung
Hat als Kontext: | KEY-DATA
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.76. FT

Beschreibung
Verwenden Sie <FT>, um eine Fußnote zu erstellen.
Formale Beschreibung
Hat als Kontext: | CHANGE, DESC, INDENT-SAMPLE, ITEM-LABEL, MSR-QUERY-RESULT-TEXT, P, REASON, TBR
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.77. FUNCTION-OVERVIEW

Beschreibung
Verwenden Sie <FUNCTION-OVERVIEW>, um die Funktionsübersicht einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.78. FUNCTION-REF
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Die MSRSYS.DTD beschreibt die Funktionalität eines Systems unabhängig davon, ob diese in Hardware oder in Software implementiert wird. Der vorliegende Verweis erlaubt es, die Verbindung zwischen Systemfunktionalität und einer korrespondierenden Funktionalität in Software (<SW-FEATURE> bzw. <SW-CLASS>) darzustellen.
Hinweis
Da dies auf jeden Fall ein dokumentübergreifender Verweis ist, muß ein NAMELOC (d.h. HyTIME)-Verweis verwendet werden. Siehe hierzu auch LOCS
Example
<MSRSW>
   <SW-SYSTEMS>
      <SW-SYSTEM ID="IDB7C9BC9rad7F9FF">
         <LONG-NAME>Demonstrator Sytem</LONG-NAME>
         <SHORT-NAME>Demosys</SHORT-NAME>
         <SW-COMPONENT-SPEC>
            <SW-COMPONENTS>
               <SW-FEATURE ID="IDB7C9BC9radFEF65">
                  <SHORT-NAME>Demofeature</SHORT-NAME>
              <SW-FULFILS>
                 <FUNCTION-REF ID-REF="id-demofeature">sysdemo</FUNCTION-REF>
              </SW-FULFILS>
           </SW-FEATURE>
         </SW-COMPONENTS>
      </SW-COMPONENT-SPEC>
      </SW-SYSTEM>
   </SW-SYSTEMS>
   <LOCS>
      <NAMELOC ID="id-demofeature">
         <LONG-NAME>Demonstratorfunktion</LONG-NAME>
         <SHORT-NAME>Demofeature aus MSRSYS</SHORT-NAME>
         <NMLIST DOCORSUB="&msrsys-instance;">sysdemo</NMLIST>
      </NAMELOC>
   </LOCS>
</MSRSW>
Formale Beschreibung
Hat als Kontext: | SW-FULFILS
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | EXTERNAL | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-EXT-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | FUNCTION | Fixed External ID Class. The value of this attribute classifies links and external link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an external object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.79. FUNCTIONAL-REQUIREMENTS

Beschreibung
Dieses Element ist das eigentliche Wurzelelement des Teilbaumes einer MSRSW-Instanz, in dem Anforderungen abgespeichert werden. Diese können neben administrativen (<ADMIN-DATA>, <ADD-SPEC>) und einleitenden (<INTRODUCTION>) Elementen die Anforderungs-Spezifikation <REQUIREMENT-SPEC> enthalten.
Formale Beschreibung
Hat als Kontext: | GENERAL-REQUIREMENTS
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, REQUIREMENT-SPEC, MONITORING, DIAGNOSIS, COMMUNICATION, OPERATIONAL-REQUIREMENTS, ADD-SPEC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.80. GENERAL-COND

Beschreibung
Verwenden Sie <GENERAL-COND>, um die allgemeinen Randbedingungen einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.81. GENERAL-HARDWARE

Beschreibung
Verwenden Sie <GENERAL-HARDWARE>, um die allgemeinen Hardwareanforderungen einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, OPERATING-ENV, USEFUL-LIFE, RELIABILITY, ADD-SPEC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.82. GENERAL-INTERFACES

Beschreibung
Verwenden Sie <GENERAL-INTERFACES>, um die Anforderungen an Schnittstellen einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, USER-INTERFACE, HARDWARE-INTERFACE, INTERNAL-INTERFACES, COMMUNICATION-INTERFACE, FLASH-PROGRAMMING, ADD-SPEC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.83. GENERAL-PRODUCT-DATA-1

Beschreibung
Verwenden Sie <GENERAL-PRODUCT-DATA-1>, um die allgemeinen Anforderungen an die Software zu spezifizieren.
Formale Beschreibung
Hat als Kontext: | GENERAL-REQUIREMENTS
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, PRODUCT-DESC, FUNCTION-OVERVIEW, KEY-DATA, PRODUCT-DEMARCATION, SIMILAR-PRODUCTS, GENERAL-HARDWARE, GENERAL-SOFTWARE, GENERAL-INTERFACES, FAILURE-MANAGEMENT, RESOURCE-ALLOCATION, CALIBRATION, SAFETY, QUALITY, MAINTENANCE, GENERAL-COND, ADD-DESIGN-DOC, DEVELOPMENT-PROCESS-SPEC, ADD-SPEC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.84. GENERAL-PROJECT-DATA

Beschreibung
Verwenden Sie <GENERAL-PROJECT-DATA>, um die allgemeinen Projektdaten einzugeben.
Formale Beschreibung
Hat als Kontext: | PROJECT
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SYSTEM-OVERVIEW, REASON-ORDER, OBJECTIVES, CONTRACT-ASPECTS, SAMPLE-SPEC, VARIANT-SPEC, DEMARCATION-OTHER-PROJECTS, PARALLEL-DESIGNS, INTEGRATION-CAPABILITY, ACCEPTANCE-COND, PROJECT-SCHEDULE, PURCHASING-COND, PROTOCOLS, DIR-HAND-OVER-DOC-DATA, ADD-SPEC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.85. GENERAL-REQUIREMENTS

Beschreibung
Dieses Element spezifiziert allgemeine Anforderungen, welche beispielsweise während des Anforderungs-Managemements zu definieren sind.
Formale Beschreibung
Hat als Kontext: | MSRSW
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, GENERAL-PRODUCT-DATA-1, FUNCTIONAL-REQUIREMENTS, ADD-SPEC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.86. GENERAL-SOFTWARE

Beschreibung
Verwenden Sie <GENERAL-SOFTWARE>, um die allgemeinen Softwareanforderungen einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, DESIGN-REQUIREMENTS, DATA-REQUIREMENTS, BINARY-COMPATIBILITY, EXTENSIBILITY, COMPATIBILITY, ADD-SPEC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.87. GENERIC-MATH

Beschreibung
Verwenden Sie <GENERIC-MATH>, um semantische, mathematische Beschreibungen einzufügen, die von einem Math-Prozessor verarbeitet werden.
Formale Beschreibung
Hat als Kontext: | FORMULA
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.88. GRAPHIC

Beschreibung
Verwenden Sie <GRAPHIC>, um eine bereits vorhandene Grafik in die Kontext-Elemente einzubinden.
Formale Beschreibung
Hat als Kontext: | FIGURE, FORMULA
Ist Kontext für: | Text
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[FIT]
mit Default-Wert
SGML Zeichenkette (NMTOKEN)
0
Modifizieren Sie das Attribut [FIT], um festzulegen, auf welche Art die Grafik eingefügt werden soll. Geben Sie den Attributwert 0 ein, um eine Grafik in ihrer Originalgröße einzufügen. Ist sie zu groß für den vorgesehenen Freiraum, so wird sie angepaßt.
[HTML-FIT]
mit Default-Wert
SGML Zeichenkette (NMTOKEN)
0
Entscheidet, ob die Grafik der Fenstergröße angepasst werden soll.
[FILENAME]
optional
Zeichenkette (CDATA)
Geben Sie hier den Dateinamen ein, unter dem das Wiedergabesystem die Grafik aufrufen kann.
[NOTATION]
optional
Zeichenkette (CDATA)
Geben Sie hier das Format der Grafikdatei an, z.B. EPS.
[WIDTH]
optional
Zeichenkette (CDATA)
Verändern sie in diesem Attribut die Breite der Grafik.
[HEIGHT]
optional
Zeichenkette (CDATA)
Verändern Sie in diesem Attribut die Höhe der Grafik.
[SCALE]
optional
Zeichenkette (CDATA)
Verändern Sie in diesem Element die Gesamtgröße der Grafik proportional.
[EDIT-WIDTH]
optional
Zeichenkette (CDATA)
Breite der Grafik im Editor
[EDIT-HEIGHT]
optional
Zeichenkette (CDATA)
Höhe der Grafik im Editor
[HTML-WIDTH]
optional
Zeichenkette (CDATA)
Breite der Grafik bei online Darstellung in html und htmlhelp.
[HTML-HEIGHT]
optional
Zeichenkette (CDATA)
Höhe der Grafik bei online-Darstellung in html und htmlhelp
[CATEGORY]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • BARCODE
  • CONCEPTUAL
  • ENGINEERING
  • FLOWCHART
  • GRAPH
  • LOGO
  • SCHEMATIC
  • WAVEFORM
Geben Sie hier die Kategorie der Grafik ein. Dies kann dazu verwendet werden, eine Liste von Grafiken bestimmter Kategorien zu erstellen.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.89. GUARANTEE

Beschreibung
Verwenden Sie <GUARANTEE>, um die Gewährleistung einzugeben.
Formale Beschreibung
Hat als Kontext: | CONTRACT-ASPECTS
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.90. HARDWARE-INTERFACE

Beschreibung
Verwenden Sie <HARDWARE-INTERFACE>, um die Schnittstellen zur Hardware einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-INTERFACES
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.91. HOMEPAGE

Beschreibung
Verwenden Sie <HOMEPAGE>, um die Web-Adresse der Firma eines Projektbeteiligten einzugeben.
Formale Beschreibung
Hat als Kontext: | TEAM-MEMBER
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.92. IE

Beschreibung
Verwenden Sie <IE>, um einen Index zu erstellen, der im Indexverzeichnis erscheinen soll.
Formale Beschreibung
Hat als Kontext: | CHANGE, DESC, INDENT-SAMPLE, ITEM-LABEL, LABEL, LONG-NAME, LONG-NAME-1, MSR-QUERY-RESULT-TEXT, P, REASON, TBR
Ist Kontext für: | Text, SUP, SUB
Name | Typ | Anmerkung
[TYPE] optional | Zeichenkette (CDATA) | Gibt einen Typ des jeweiligen Elementes an.
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.93. INDENT-SAMPLE

Beschreibung
Verwenden Sie <INDENT-SAMPLE>, um einen Platzhalter für die Breite der ersten Spalte einer Marginalie zu erstellen.
Formale Beschreibung
Hat als Kontext: | LABELED-LIST
Ist Kontext für: | Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, MSR-QUERY-TEXT
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[ITEM-LABEL-POS]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • NO-NEWLINE
  • NEWLINE
  • NEWLINE-IF-NECESSARY
NO-NEWLINE - Zeilenumbruch innerhalb der ersten SpalteNEWLINE - keine Zeilenumbruch innerhalb der ersten Spalte. Die Beschreibung zur Benennung beginnt in der zweiten Zeile.NEWLINE-IF-NECESSARY - kein Zeilenumbruch innerhalb der ersten Spalte. Ist die Marginalienbenennung länger als unter <INDENT-SAMPLE> festgelegt, so beginnt die Beschreibung in der zweiten Zeile, andernfalls in der Ersten.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.94. INTEGRATION-CAPABILITY

Beschreibung
Verwenden Sie <INTEGRATION-CAPABILITY>, um die Integrationsfähigkeit einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PROJECT-DATA
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.95. INTERNAL-INTERFACES

Beschreibung
Verwenden Sie <INTERNAL-INTERFACES>, um die internen Schnittstellen einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-INTERFACES
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.96. INTERRUPT-SPEC
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieser Container beschreibt die Architektur der Programmunterbrechungen (Interrupts) in verbaler Form. Eine formalere Spezifikation ist durch die Bedatung von [SI]-Attributen im <NCOI-1>-Unterbaum möglich.
Example
<INTERRUPT-SPEC>
   <INTRODUCTION>
      <P>This chapter describes the general architecture of external events.</P>
   </INTRODUCTION>
   <NCOI-1>
      <P>The software utilizes the following interrupts:</P>
      <TABLE>
         <TABLE-CAPTION>
            <LONG-NAME>Interrupt table</LONG-NAME>
         </TABLE-CAPTION>
         <TGROUP COLS="4">
            <COLSPEC COLNUM="1" COLNAME="col1" COLWIDTH="1.00*">
            <COLSPEC COLNUM="2" COLNAME="col2" COLWIDTH="4.90*">
            <COLSPEC COLNUM="3" COLNAME="col3" COLWIDTH="2.97*">
            <COLSPEC COLNUM="4" COLNAME="col4" COLWIDTH="2.97*">
            <THEAD>
               <ROW>
                  <ENTRY SI="LABEL" COLNAME="col1">
                     <P>Label</P>
                  </ENTRY>
                  <ENTRY COLNAME="col2">
                     <P>Description</P></ENTRY>
                  <ENTRY COLNAME="col3">
                     <P>Priority</P>
                  </ENTRY>
                  <ENTRY SI="SERVICE-ROUTINE" COLNAME="col4">
                     <P>Service routine</P>
                  </ENTRY>
               </ROW>
            </THEAD>
            <TBODY>
               <ROW>
                  <ENTRY COLNAME="col1"><P>IRQ1</P></ENTRY>
                  <ENTRY COLNAME="col2"><P>Timer</P></ENTRY>
                  <ENTRY COLNAME="col3"><P>medium</P></ENTRY>
                  <ENTRY COLNAME="col4"><P>0x1000</P></ENTRY>
               </ROW>
               <ROW>
                  <ENTRY COLNAME="col1"><P>IRQ2</P></ENTRY>
                  <ENTRY COLNAME="col2"><P>Angle interrupt</P></ENTRY>
                  <ENTRY COLNAME="col3"><P>high</P></ENTRY>
                  <ENTRY COLNAME="col4"><P>0x1004</P></ENTRY>
               </ROW>
            </TBODY>
         </TGROUP>
      </TABLE>
   </NCOI-1>
</INTERRUPT-SPEC>
Formale Beschreibung
Hat als Kontext: | SW-ARCHITECTURE
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.97. INTRODUCTION
Siehe Auch Description Example Formale Beschreibung

Description
<INTRODUCTION> is used to provide a geneal introduction to the object in question. Although not requested by CDF, there are two options:
  • Use <P> to allow the processing systems to perform a word wrapping.
  • Use <VERBATIM> if whitespace is siginifcant.
According to the CDF a restriction to only one paragraph is allowed, even if MSRSW.DTD has a more powerful model.
Example
 <INTRODUCTION>
   <P>This File is used to illustrate, how CDF can be implentend according
      to ASAM-MCD-2MC 2.0 resp. MSRSW.DTD 2.2.0 </P>
</INTRODUCTION>
Formale Beschreibung
Hat als Kontext:
ACCEPTANCE-COND, ADD-DESIGN-DOC, ADD-SPEC, BINARY-COMPATIBILITY, CALIBRATION, CHAPTER, COMMUNICATION, COMMUNICATION-INTERFACE, COMPATIBILITY, CONTRACT-ASPECTS, DATA-DESC, DATA-REQUIREMENTS, DATA-STRUCTURES, DEMARCATION-OTHER-PROJECTS, DESIGN-REQUIREMENTS, DEVELOPMENT-PROCESS-SPEC, DIAGNOSIS, DIR-HAND-OVER-DOC-DATA, EXTENSIBILITY, FAIL-SAVE-CONCEPT, FAILURE-MANAGEMENT, FAILURE-MEM, FLASH-PROGRAMMING, FMEA, FUNCTION-OVERVIEW, FUNCTIONAL-REQUIREMENTS, GENERAL-COND, GENERAL-HARDWARE, GENERAL-INTERFACES, GENERAL-PRODUCT-DATA-1, GENERAL-PROJECT-DATA, GENERAL-REQUIREMENTS, GENERAL-SOFTWARE, GUARANTEE, HARDWARE-INTERFACE, INTEGRATION-CAPABILITY, INTERNAL-INTERFACES, INTERRUPT-SPEC, KEY-DATA, MAINTENANCE, MONITORING, MSRSW, NORMATIVE-REFERENCE, OBJECTIVES, OPERATING-ENV, OPERATIONAL-REQUIREMENTS, OVERVIEW, PARALLEL-DESIGNS, PRODUCT-DEMARCATION, PRODUCT-DESC, PROJECT-SCHEDULE, PROTOCOLS, PURCHASING-COND, QUALITY, REASON-ORDER, RELIABILITY, REPLACEMENT-VALUES, REQUIREMENT-SPEC, RESOURCE-ALLOCATION, RESTRICTIONS-BY-HARDWARE, RIGHTS, SAFETY, SAMPLE-SPEC, SELF-DIAGNOSIS, SIMILAR-PRODUCTS, STANDARD-SW-MODULES, SW-ARCHITECTURE, SW-CALIBRATION-METHOD-SPEC, SW-COLLECTION-SPEC, SW-COMPONENT-SPEC, SW-CPU-SPEC, SW-DATA-DICTIONARY-SPEC, SW-GLOSSARY, SW-INSTANCE-SPEC, SW-MC-COMMUNICATION-SPEC, SW-SYSTEM, SW-TASK-SPEC, SW-TEST-SPEC, SW-USER-RIGHT-SPEC, SW-VCD-SPEC, SYSTEM-OVERVIEW, TIME-DEPENDENCY, USEFUL-LIFE, USER-INTERFACE, VARIANT-SPEC
Ist Kontext für:
P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, MSR-QUERY-P-2, TOPIC-2, MSR-QUERY-TOPIC-2

Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.98. ISSUED-BY

Beschreibung
Dieses Element beinhaltet die Person, die eine Dokument-Revision ausgestellt hat. Falls diese nicht im aktuellen Dokument als <TEAM-MEMBER> referenzierbar ist, kann die Person in diesem Element angegeben werden.
Formale Beschreibung
Hat als Kontext: | DOC-REVISION
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.99. ITEM

Beschreibung
Verwenden Sie <ITEM>, um mehrere verschiedene Aufzählungspunkte zu erstellen.
Formale Beschreibung
Hat als Kontext: | LIST
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.100. ITEM-LABEL

Beschreibung
Verwenden Sie <ITEM-LABEL>, um die Benennung einer Marginalie einzugeben. Diese Benennung wird in der ersten Spalte der Marginalie dargestellt.
Formale Beschreibung
Hat als Kontext: | LABELED-ITEM
Ist Kontext für: | Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, MSR-QUERY-TEXT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.101. KEY-DATA

Beschreibung
Verwenden Sie <KEY-DATA>, um die charakteristischen Parameter einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, FREE-INFO, PRM-REFS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.102. LABEL
Siehe Auch Description Example Formale Beschreibung

Description
<LABEL> is used as a long designator (similar to <LONG-NAME>) for objects which cannot be referenced. In this case it is the name of the corresponding project.
Example
For an example, see 1.170. PROJECT-DATA PROJECT-DATA PROJECT-DATA, where <LABEL> is the name of the corresponding project.
Formale Beschreibung
Hat als Kontext: | ANNOTATION, MATCHING-DCI, NOTE, OVERALL-PROJECT, PRMS, PROJECT, SW-CALIBRATION-METHOD-VERSION, SW-CALPRM-VALUE-AXIS-LABELS, SW-CLASS-METHOD, SW-CLASS-METHOD-ARG, SW-MC-GENERIC-INTERFACE, SW-PROCESS, VG
Ist Kontext für: | Text, TT, E, SUP, SUB, IE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.103. LABELED-ITEM

Beschreibung
Verwenden Sie <LABELED-ITEM>, um eine Marginalie innerhalb einer Liste zu erstellen.
Formale Beschreibung
Hat als Kontext: | LABELED-LIST
Ist Kontext für: | ITEM-LABEL, P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[HELP-ENTRY]
optional
Zeichenkette (CDATA)
Erlaubt es, das Vaterelement als ein Hilfe-Einstiegspunkt zu markieren. Die Syntax ergibt sich aus dem verwendeten Hilfesystem. Oft wird das dazu verwendet, aus einem Fenstersystem eine Objekt-Id bzw. eine Widget-Namenshierarchie zu errechnen, die dann mit den Help-Entry-Einträgen korreliert wird.Beispiel:
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.104. LABELED-LIST

Beschreibung
Verwenden Sie <LABELED-LIST>, um kurze Themenabschnitte strukturiert als Marginalien darzustellen.
Formale Beschreibung
Hat als Kontext: | ADD-INFO, CHAPTER, CRITICAL-ASPECTS, ENTRY, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REMARK, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CLASS-METHOD-RETURN, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Ist Kontext für: | INDENT-SAMPLE, LABELED-ITEM
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.105. LANGUAGE
Siehe Auch Description Formale Beschreibung

Description
<LANGUAGE> represents the human language used within the file. It is mainly used to cause the tools to switch to an appropriate language.
This element follows ISO 639-1 two letter language codes ( Codes for the Representation of Names of Languages). Mostly used codes are given in Most common language codes (alphabetical):
Most common language codes (alphabetical)
Code | Language
de | German
en | English
es | Spanish
fr | French
it | Italian
jp | Japanese
Formale Beschreibung
Hat als Kontext: | ADMIN-DATA
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.106. LIFE-TIME

Beschreibung
Verwenden Sie <LIFE-TIME>, um die Lebensdauer einzugeben.
Formale Beschreibung
Hat als Kontext: | USEFUL-LIFE-PRMS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, PRM-CHAR
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | PRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.107. LIST

Beschreibung
Verwenden Sie <LIST>, um Inhalte als Aufzählung darzustellen.
Formale Beschreibung
Hat als Kontext: | ADD-INFO, CHAPTER, CRITICAL-ASPECTS, ENTRY, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REMARK, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CLASS-METHOD-RETURN, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Ist Kontext für: | ITEM
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[TYPE]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • UNNUMBER
  • NUMBER
UNNUMBER - nicht numerierte AufzählungNUMBER - numerierte Aufzählung
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.108. LOCS

Beschreibung
Verwenden Sie <LOCS>, um Referenzen in externe Dokumente zu erstellen.
Formale Beschreibung
Hat als Kontext: | MSRSW
Ist Kontext für: | NAMELOC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.109. LONG-NAME

Beschreibung
Verwenden Sie <LONG-NAME>, um eine Bezeichnung zu den Kontext-Elementen zu erstellen.
Formale Beschreibung
Hat als Kontext: | AVAILABILITY, CHAPTER, COMPANY, DEF-ITEM, FIGURE-CAPTION, FORMULA-CAPTION, LIFE-TIME, MTBF, NAMELOC, OPERATING-TIME, PPM, PRM, REQUIREMENT, SAMPLE, SDG-CAPTION, SW-ADDR-METHOD, SW-AXIS-TYPE, SW-BASE-TYPE, SW-CALIBRATION-METHOD, SW-CALPRM, SW-CALPRM-PROTOTYPE, SW-CLASS, SW-CLASS-ATTR-IMPL, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-CODE-SYNTAX, SW-COLLECTION, SW-COMPU-METHOD, SW-CPU-MEM-SEG, SW-DATA-CONSTR, SW-FEATURE, SW-GENERIC-AXIS-PARAM-TYPE, SW-INSTANCE, SW-INSTANCE-TREE, SW-MC-BASE-TYPE, SW-MC-FRAME, SW-MC-INTERFACE, SW-MC-INTERFACE-SOURCE, SW-RECORD-LAYOUT, SW-SYSTEM, SW-SYSTEMCONST, SW-TASK, SW-TEMPLATE, SW-UNIT, SW-USER-ACCESS-CASE, SW-USER-GROUP, SW-VARIABLE, SW-VARIABLE-PROTOTYPE, SW-VCD-CRITERION, TABLE-CAPTION, TEAM-MEMBER, TOPIC-1, TOPIC-2, VARIANT-CHAR, VARIANT-DEF
Ist Kontext für: | Text, TT, E, SUP, SUB, IE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.110. LONG-NAME-1

Beschreibung
Verwenden Sie <LONG-NAME-1>, um eine Bezeichnung zu den Kontext-Elementen zu erstellen.
Formale Beschreibung
Hat als Kontext: | STD, XDOC, XFILE, XREF-TARGET
Ist Kontext für: | Text, TT, E, SUP, SUB, IE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.111. LOWER-LIMIT

Beschreibung
Dieses Element spezifiziert die untere Schranke eines geschlossenen, halboffenen oder offenen Intervalles.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-SCALE, SW-INTERNAL-CONSTRS, SW-PHYS-CONSTRS, SW-SCALE-CONSTR
Ist Kontext für: | Text
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[INTERVAL-TYPE]
obligatorisch
Auswahlwert (NAMEDTOKENGROUP)
  • OPEN
  • CLOSED
OPEN: Offenes Intervall; CLOSED: geschlossenes Intervall
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.112. MAINTENANCE

Beschreibung
Verwenden Sie <MAINTENANCE>, um die Wartung einzugeben.
Formale Beschreibung
Hat als Kontext: | CONTRACT-ASPECTS, GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.113. MAP

Beschreibung
Image maps allow authors to specify regions of an image or object and assign a specific action to each region (e.g., retrieve a document, run a program, etc.) When the region is activated by the user, the action is executed.
Formale Beschreibung
Hat als Kontext: | FIGURE, FORMULA
Ist Kontext für: | AREA
Name | Typ | Anmerkung
[ID] optional | Zeichenkette (CDATA) | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[CLASS] optional | Zeichenkette (CDATA) | Blank-separierte Liste von Klassen
[STYLE] optional | Zeichenkette (CDATA) | Information über den assoziierten Stil
[TITLE] optional | Zeichenkette (CDATA) | Titelinformation des <MAP>-Elementes
[ONCLICK] optional | Zeichenkette (CDATA) | Der ONCLICK-Event tritt auf, wenn das aktuelle Element geklickt wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONDBLCLICK] optional | Zeichenkette (CDATA) | Der ONDBLCLICK-Event tritt auf, wenn das aktuelle Element geklickt wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONMOUSEDOWN] optional | Zeichenkette (CDATA) | Der ONMOUSEDOWN-Event tritt auf, wenn die zum klicken verwendete Maustaste auf dem aktuellen Element gedrückt gehalten wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONMOUSEUP] optional | Zeichenkette (CDATA) | Der ONMOUSEUP-Event tritt auf, wenn die zum klicken verwendete Maustaste auf dem aktuellen Element losgelassen wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONMOUSEOVER] optional | Zeichenkette (CDATA) | Der ONMOUSEOVER-Event tritt auf, wenn der Mauszeiger von außerhalb auf das aktuelle Element bewegt wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONMOUSEMOVE] optional | Zeichenkette (CDATA) | Der ONMOUSEMOVE-Event tritt auf, wenn der Mauszeiger auf dem aktuellen Element bewegt wird (d.h. er befindet sich darauf). In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONMOUSEOUT] optional | Zeichenkette (CDATA) | Der ONMOUSEOUT-Event tritt auf, wenn der Mauszeiger aus dem aktuellen Element herausbewegt wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONKEYPRESS] optional | Zeichenkette (CDATA) | Der ONKEYPRESS-Event tritt auf, wenn eine Taste auf dem aktuellen Element gedrückt und wieder losgelassen wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONKEYDOWN] optional | Zeichenkette (CDATA) | Der ONKEYDOWN-Event tritt auf, wenn eine Taste auf dem aktuellen Element gedrückt wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[ONKEYUP] optional | Zeichenkette (CDATA) | Der ONKEYUP-Event tritt auf, wenn eine Taste auf dem aktuellen Element losgelassen wird. In diesem Attribut kann ein Skript hinterlegt werden, was bei diesem Event ausgeführt wird.
[NAME] optional | SGML Zeichenkette (NMTOKEN) | Dieses Attribut weist einen Namen zu der Image Map im MAP-Element zu. Dieser Name kann benutzt werden, um durch das Attribut USEMAP in einem HTML-Image referenziert zu werden. Obwohl dieses Although nicht wirklich im MSR-Modell notwendig ist, wurde es eingefügt, um MAPs zu unterstützen, die für HTML erstellt wurden.


1.114. MATCHING-DCI
Siehe Auch Description Formale Beschreibung

Description
<MATCHING-DCI> represents a reference to a DCI instance (Document Content Information) tho which the current file is supposed to match to. The official identification of the DCI is denoted by <URL> which points to the DCI file. The other elements are provided for informational purposes.
Formale Beschreibung
Hat als Kontext: | MATCHING-DCIS
Ist Kontext für: | LABEL, SHORT-LABEL, URL, REMARK
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.115. MATCHING-DCIS
Siehe Auch Description Example Formale Beschreibung

Description
<MATCHING-DCIS> represents all Document Content Information specifications the current file is supposed to be compliant to. As there may be multiple DCI instances, the current file is supposed to match to all of them. Nevertheless the check is only requested according to the current use case.
In particular, in the CDF usecase, a CDF processor is obliged to check, if the CDF-DCI is mentioned within <MATCHING-DCIS>.
Example
In the following example the current file would match CDF as well as PACO which would support more of the features in MSRSW.DTD.
<MATCHING-DCIS>
   <MATCHING-DCI>
      <LABEL>Parameter Contents File</LABEL>
      <SHORT-LABEL>PACO2.0</SHORT-LABEL>
      <URL>http://www.msr-wg.de/dcis/paco.dci.xml</URL>
   </MATCHING-DCI>
   <MATCHING-DCI>
      <LABEL>Calibration Data File Specification</LABEL>
      <SHORT-LABEL>CDF</SHORT-LABEL>
      <URL>http://www.asam.net/dcis/cdf.dci.xml</URL>
   </MATCHING-DCI>
</MATCHING-DCIS>
Formale Beschreibung
Hat als Kontext: | MSRSW
Ist Kontext für: | MATCHING-DCI
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.116. MAX

Beschreibung
Verwenden Sie <MAX>, um die Maximalwerte eines Parameters in einer Parametertabelle einzugeben.
Formale Beschreibung
Hat als Kontext: | PRM-CHAR
Ist Kontext für: | Text, SUP, SUB
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.117. MIN

Beschreibung
Verwenden Sie <MIN>, um die Minimalwerte eines Parameters in einer Parametertabelle einzugeben
Formale Beschreibung
Hat als Kontext: | PRM-CHAR
Ist Kontext für: | Text, SUP, SUB
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.118. MODIFICATION

Beschreibung
Verwenden Sie <MODIFICATION>, um eine Änderung im Dokument im Vergleich zum Vorgängerdokument zu dokumentieren.
Formale Beschreibung
Hat als Kontext: | MODIFICATIONS
Ist Kontext für: | CHANGE, REASON
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[TYPE]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • CONTENT-RELATED
  • DOC-RELATED
DOC-RELATED - Dokumentspezifische Änderungen sind der Grund für eine neue Dokumentenversion .CONTENT-RELATED - Produktspezifische Änderungen sind der Grund für eine neue Dokumentenversion.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.119. MODIFICATIONS

Beschreibung
Verwenden Sie <MODIFICATION>, um Änderungen im Dokument im Vergleich zum Vorgängerdokument zusammen zu fassen.
Formale Beschreibung
Hat als Kontext: | DOC-REVISION
Ist Kontext für: | MODIFICATION
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.120. MONITORING
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt in verbaler Weise die Anforderungen an die Systemüberwachung, welche in dem Steuergerät zu implementieren ist.
Example
<MONITORING>
   <NCOI-1>
      <P>The system shall implement an hardware based
      watchdog to ensure that the software is working. </P>
   </NCOI-1>
</MONITORING>
Formale Beschreibung
Hat als Kontext: | FUNCTIONAL-REQUIREMENTS
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.121. MSR-PROCESSING-LOG
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element ist ein Platzhalter, in welchem Werkzeuge, die die Instanz automatisiert bearbeiten, Informationen über den Verarbeitungslauf (Log-Informationen) ablegen können. Es ist zu empfehlen, für jeden Lauf ein eigenes Kapitel (<CHAPTER>) anzulegen. Die neuesten Kapitel sollten oben stehen (Sortierung nach Datum).
Example
<MSR-PROCESSING-LOG>
   <CHAPTER>
      <LONG-NAME>MSR-Query 2.10.2001</LONG-NAME>
      <SHORT-NAME>msrquery.2001.10.02-1</SHORT-NAME>
      <VERBATIM>MSR-Query processor Version 0.99 run at 2.10.2001 reading file
        c:\examples\myexample.sgm warning: duplicate ID found ("hugo") error: query
        "replacechapters" not implemented 20 queries processed 1 warning 1
        error
      </VERBATIM>
   </CHAPTER>
   <CHAPTER>
      <LONG-NAME>MSR-Query 1.10.2001</LONG-NAME>
      <SHORT-NAME>msrquery.2001.10.01-1</SHORT-NAME>
      <VERBATIM>MSR-Query processor Version 0.99 run at 1.10.2001 reading file
        c:\examples\myexample.sgm warning: duplicate ID found ("hugo") error: query
        "replacechapters" not implemented 20 queries processed 1 warning 1
   error
      </VERBATIM>
   </CHAPTER>
</MSR-PROCESSING-LOG>
Formale Beschreibung
Hat als Kontext: | MSRSW
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.122. MSR-QUERY-ARG

Beschreibung
Dieses Element spezifiziert ein Argument innerhalb einer sogenannten MSR-QUERY, welche im Schwesterelement <MSR-QUERY-NAME> genannt wird.
Formale Beschreibung
Hat als Kontext: | MSR-QUERY-PROPS
Ist Kontext für: | Text, XREF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.123. MSR-QUERY-CHAPTER

Beschreibung
Dieses Element beinhaltet ein durch eine externe Abfrage oder ein externes Programm erzeugtes Kapitel (in <MSR-QUERY-RESULT-CHAPTER>) sowie die notwendigen Daten, um Rückschlüsse auf die Herkunft des Kapitels ziehen zu können (in <MSR-QUERY-PROPS>).
Formale Beschreibung
Hat als Kontext: | ADD-INFO, CHAPTER, CRITICAL-ASPECTS, FREE-INFO, MSR-PROCESSING-LOG, NCOI-1, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS
Ist Kontext für: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-CHAPTER
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.124. MSR-QUERY-NAME

Beschreibung
Dieses Element spezifiziert den Namen der abgesetzten MSR-QUERY.
Formale Beschreibung
Hat als Kontext: | MSR-QUERY-PROPS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.125. MSR-QUERY-P-1

Beschreibung
Dieses Element beinhaltet die Argumente <MSR-QUERY-PROPS> sowie optional die in <MSR-QUERY-RESULT-P-1> eingebetteten textuellen Ergebniselemente einer MSR-QUERY, welche durch ein externes Programm oder eine externe Abfrage erzeugt wurde, um dieses in eine MSRSW-Instanz einzubetten.
Formale Beschreibung
Hat als Kontext: | ADD-INFO, CHAPTER, CRITICAL-ASPECTS, FREE-INFO, MSR-PROCESSING-LOG, NCOI-1, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1
Ist Kontext für: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-P-1
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.126. MSR-QUERY-P-2

Beschreibung
Dieses Element beinhaltet die Argumente <MSR-QUERY-PROPS> sowie optional die in <MSR-QUERY-RESULT-P-2> eingebetteten textuellen Ergebniselemente einer MSR-QUERY, welche durch ein externes Programm oder eine externe Abfrage erzeugt wurde, um dieses in eine MSRSW-Instanz einzubetten.
Formale Beschreibung
Hat als Kontext: | INTRODUCTION, NCOI-3, TOPIC-2
Ist Kontext für: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-P-2
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.127. MSR-QUERY-PROPS

Beschreibung
Dieses Element spezifiziert die Eigenschaften und Argumente einer MSR-QUERY, nämlich den Namen <MSR-QUERY-NAME>, die Argumente <MSR-QUERY-ARG> sowie ggf. Kommentare <COMMENT>.
Formale Beschreibung
Hat als Kontext: | MSR-QUERY-CHAPTER, MSR-QUERY-P-1, MSR-QUERY-P-2, MSR-QUERY-TEXT, MSR-QUERY-TOPIC-1, MSR-QUERY-TOPIC-2
Ist Kontext für: | MSR-QUERY-NAME, MSR-QUERY-ARG, COMMENT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.128. MSR-QUERY-RESULT-CHAPTER

Beschreibung
Dieses Element beinhaltet das Ergebniskapitel einer MSR-QUERY, welches durch ein externes Programm oder eine externe Abfrage erzeugt wurde, um dieses in eine MSRSW-Instanz einzubetten.
Formale Beschreibung
Hat als Kontext: | MSR-QUERY-CHAPTER
Ist Kontext für: | CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.129. MSR-QUERY-RESULT-P-1

Beschreibung
Dieses Element beinhaltet die textuellen Ergebniselemente einer MSR-QUERY, welche durch ein externes Programm oder eine externe Abfrage erzeugt wurde, um dieses in eine MSRSW-Instanz einzubetten. Im Gegensatz zu <MSR-QUERY-RESULT-P-2> dürfen in <MSR-QUERY-RESULT-P-1> noch <PRMS>-Elemente enthalten sein.
Formale Beschreibung
Hat als Kontext: | MSR-QUERY-P-1
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.130. MSR-QUERY-RESULT-P-2

Beschreibung
Dieses Element beinhaltet die textuellen Ergebniselemente einer MSR-QUERY, welche durch ein externes Programm oder eine externe Abfrage erzeugt wurde, um dieses in eine MSRSW-Instanz einzubetten. Im Gegensatz zu <MSR-QUERY-RESULT-P-1> dürfen in <MSR-QUERY-RESULT-P-2> keine <PRMS>-Elemente enthalten sein.
Formale Beschreibung
Hat als Kontext: | MSR-QUERY-P-2
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.131. MSR-QUERY-RESULT-TEXT

Beschreibung
Dieses Element beinhaltet die durch eine MSR-QUERY generierte textuelle Beschreibung innerhalb <MSR-QUERY-TEXT>, welche keine weiteren Unterparagraphen umfaßt.
Formale Beschreibung
Hat als Kontext: | MSR-QUERY-TEXT
Ist Kontext für: | Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, MSR-QUERY-TEXT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.132. MSR-QUERY-RESULT-TOPIC-1

Beschreibung
Dieses Element beinhaltet das Ergebnis eines generierten <TOPIC-1>-Elementes aus einer externen MSR-QUERY.
Formale Beschreibung
Hat als Kontext: | MSR-QUERY-TOPIC-1
Ist Kontext für: | TOPIC-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.133. MSR-QUERY-RESULT-TOPIC-2

Beschreibung
Dieses Element beinhaltet das Ergebnis eines generierten <TOPIC-2>-Elementes aus einer externen MSR-QUERY.
Formale Beschreibung
Hat als Kontext: | MSR-QUERY-TOPIC-2
Ist Kontext für: | TOPIC-2
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.134. MSR-QUERY-TEXT

Beschreibung
Dieses Element beinhaltet die durch eine im Unterelement <MSR-QUERY-PROPS> näher spezifizierte MSR-QUERY sowie die durch sie generierte textuelle Beschreibung innerhalb des Unterelementes <MSR-QUERY-TEXT>, welche keine weiteren Unterparagraphen umfaßt.
Formale Beschreibung
Hat als Kontext: | CHANGE, DESC, INDENT-SAMPLE, ITEM-LABEL, MSR-QUERY-RESULT-TEXT, P, REASON, TBR
Ist Kontext für: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-TEXT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.135. MSR-QUERY-TOPIC-1

Beschreibung
Dieses Element beinhaltet ein generiertes TOPIC-1-Element mit Ergebnis in <MSR-QUERY-RESULT-TOPIC-1> aus einer externen MSR-QUERY, welche in <MSR-QUERY-PROPS> näher definiert wird.
Formale Beschreibung
Hat als Kontext: | ADD-INFO, CHAPTER, CRITICAL-ASPECTS, FREE-INFO, MSR-PROCESSING-LOG, NCOI-1, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS
Ist Kontext für: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-TOPIC-1
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.136. MSR-QUERY-TOPIC-2

Beschreibung
Dieses Element beinhaltet ein generiertes TOPIC-2-Element mit Ergebnis in <MSR-QUERY-RESULT-TOPIC-2> aus einer externen MSR-QUERY, welche in <MSR-QUERY-PROPS> näher definiert wird.
Formale Beschreibung
Hat als Kontext: | INTRODUCTION, NCOI-3
Ist Kontext für: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-TOPIC-2
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.137. MSRSW
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element ist das Wurzelelement einer MSRSW-Instanz. Der gesamte Unterbaum der MSRSW-Instanz hängt somit unter dem Element MSRSW, welches sonst nirgends verwendet wird. Damit die Ergebnisse verschiedener Prozeßphasen, die sequentiell oder parallel ablaufen können, in eine MSRSW-Instanz integriert werden können, sind unterhalb <MSRSW> alle Elemente optional.
In <SHORT-NAME> kann man einen Identifikator für die Instanz selbst vergeben, der von externen Applikationen ausgewertet werden kann. In <CATEGORY> kann eine spezifische, z.T. prozeß-/anwendungsabhängige Kategorie der MSRSW-Instanz angegeben werden, welche kann anschließend durch semantische Checker in Postprozessen , z.B. im Zusammenhang mit <MATCHING-DCI>, ausgewertet werden kann.
In <PROJECT-DATA> können projektspezifische Angaben, in deren Geltungsbereich die aktuelle MSRSW-Instanz fällt, gemacht werden.
<ADMIN-DATA> beschreibt administrative Daten für die aktuelle MSRSW-Instanz, z.B. verwendete Sprachen, Versions-Informationen, Formatierer-Anweisungen, an der Erstellung der Instanz beteiligte Firmen etc.).
<INTRODUCTION> ist für eine prägnante, kurze textuelle Beschreibung der MSRSW-Instanz gedacht, welche mehrere Paragraphen, jedoch keine Kapitelstrukturen umfassen darf.
Der Hauptinhalt einer MSRSW-Instanz steht unterhalb von <SW-SYSTEMS>. Dies ermöglicht es, mehrere ECU-Systeme zu unterstützen, als auch ein System mit mehreren CPUs.
Im Unterbaum von Element <GENERAL-REQUIREMENTS> werden die Anforderungs-Managementphase betreffende Informationen abgespeichert.
In <SW-MC-COMMUNICATION-SPEC> werden die A2ML-BLOB-Definition abgelebt.
Ein Glossar kann in <SW-GLOSSARY> angelegt werden.
Nicht-SGML/XML-Daten können im Unterbaum von <SPECIAL-DATA> referenziert bzw. eingestellt werden.
Im Unterbaum von <MATCHING-DCIS> können sogenannte Document Control Instances angegeben werden, mittels derer die Gültigkeit der Semantik abgeprüfet werden kann.
<MSR-PROCESSING-LOG>
Referenzen in externe Dokumente sind über die Bedatung von <LOCS> möglich.
Example
<MSRSW>
   <SHORT-NAME>DEMO</SHORT-NAME>
   <ADMIN-DATA>
      <LANGUAGE>en</LANGUAGE>
   </ADMIN-DATA>
   <INTRODUCTION>
      <P>This is a demonstration file to illustrate, how CDF could be
      implemented in ASAM-MCD-2MC 2.0</P>
   </INTRODUCTION>
   <SW-SYSTEMS>
      <SW-SYSTEM>
         <SHORT-NAME>DEMO</SHORT-NAME>
         <SW-INSTANCE-SPEC>
            <SW-INSTANCE-TREE>
               <SHORT-NAME>DEMODATA</SHORT-NAME>
               <SW-INSTANCE>
                  <SHORT-NAME>FBAM</SHORT-NAME>
                  <SW-INSTANCE-PROPS-VARIANTS>
                     <SW-INSTANCE-PROPS-VARIANT>
                        <SW-AXIS-CONTS>
                           <SW-AXIS-CONT> </SW-AXIS-CONT>
                        </SW-AXIS-CONTS>
                     </SW-INSTANCE-PROPS-VARIANT>
                  </SW-INSTANCE-PROPS-VARIANTS>
           </SW-INSTANCE>
        </SW-INSTANCE-TREE>
        <SW-INSTANCE-TREE>
           <SHORT-NAME>Testdata</SHORT-NAME>
              <SW-INSTANCE>
                 <SHORT-NAME>FBAM</SHORT-NAME>
                 <SW-INSTANCE-PROPS-VARIANTS>
                    <SW-INSTANCE-PROPS-VARIANT>
                       <SW-AXIS-CONTS>
                          <SW-AXIS-CONT> </SW-AXIS-CONT>
                       </SW-AXIS-CONTS>
                    </SW-INSTANCE-PROPS-VARIANT>
                 </SW-INSTANCE-PROPS-VARIANTS>
              </SW-INSTANCE>
        </SW-INSTANCE-TREE>
     </SW-INSTANCE-SPEC>
      </SW-SYSTEM>
   </SW-SYSTEMS>
   <MATCHING-DCIS>
      <MATCHING-DCI>
         <URL>http://www.asam.net/dci/cdf.dci.xml</URL>
      </MATCHING-DCI>
   </MATCHING-DCIS>
</MSRSW>
Formale Beschreibung
Hat als Kontext: | Root
Ist Kontext für: | SHORT-NAME, CATEGORY, PROJECT-DATA, ADMIN-DATA, INTRODUCTION, GENERAL-REQUIREMENTS, SW-SYSTEMS, SW-MC-COMMUNICATION-SPEC, SW-GLOSSARY, SPECIAL-DATA, MSR-PROCESSING-LOG, MATCHING-DCIS, LOCS
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[PUBID] mit Default-Wert | Zeichenkette (CDATA) | -//MSR//DTD MSR SOFTWARE DTD:V2.2.2:MSRSW.DTD//EN | Public Identifier. Dieser ist im Gegensatz zu [F-PUBID] durch eine Applikation veränderber.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-PUBID] festgelegter Wert | Zeichenkette (CDATA) | -//MSR//DTD MSR SOFTWARE DTD:V2.2.2:MSRSW.DTD//EN | Fixed Public ID. Dieser ist im Gegensatz zu [PUBID] nicht veränderbar und beinhaltet den Public Identifier der aktuellen MSRSW.DTD.
[F-NAMESPACE] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | CHAPTER COMPANY DEF-ITEM EXTERNAL FIGURE FORMULA PRM REQUIREMENT SAMPLE SDG STD SW-ADDR-METHOD SW-AXIS-TYPE SW-BASE-TYPE SW-CALPRM SW-CALPRM-PROTOTYPE SW-CLASS-PROTOTYPE SW-CLASS-ATTR-IMPL SW-CLASS-INSTANCE SW-CLASS SW-CODE-SYNTAX SW-COLLECTION SW-COMPU-METHOD SW-CPU-MEM-SEG SW-DATA-CONSTR SW-FEATURE SW-GENERIC-AXIS-PARAM-TYPE SW-INSTANCE-TREE SW-INSTANCE SW-MC-BASE-TYPE SW-MC-INTERFACE-SOURCE SW-MC-INTERFACE SW-RECORD-LAYOUT SW-SYSTEMCONST SW-SYSTEM SW-TASK SW-TEMPLATE SW-UNIT SW-USER-ACCESS-CASE SW-USER-GROUP SW-VARIABLE-PROTOTYPE SW-VARIABLE SW-VCD-CRITERION TABLE TEAM-MEMBER TOPIC VARIANT-DEF VARIANT-CHAR XDOC XFILE XREF-TARGET | Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | HYDOC | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.


1.138. MTBF

Beschreibung
Verwenden Sie <MTBF>, um die MTBF einzugeben.
Formale Beschreibung
Hat als Kontext: | RELIABILITY-PRMS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, PRM-CHAR
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | PRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.139. NA

Beschreibung
Verwenden Sie <NA>, um etwas als Nicht anwendungsrelevant zu kennzeichnen und evt. eine Begründung einzugeben.
Formale Beschreibung
Hat als Kontext:
ACCEPTANCE-COND, ADD-DESIGN-DOC, ADD-SPEC, BINARY-COMPATIBILITY, CALIBRATION, COMMUNICATION, COMMUNICATION-INTERFACE, COMPATIBILITY, CONTRACT-ASPECTS, DATA-DESC, DATA-REQUIREMENTS, DATA-STRUCTURES, DEMARCATION-OTHER-PROJECTS, DESIGN-REQUIREMENTS, DEVELOPMENT-PROCESS-SPEC, DIAGNOSIS, DIR-HAND-OVER-DOC-DATA, EXTENSIBILITY, FAIL-SAVE-CONCEPT, FAILURE-MANAGEMENT, FAILURE-MEM, FLASH-PROGRAMMING, FMEA, FUNCTION-OVERVIEW, FUNCTIONAL-REQUIREMENTS, GENERAL-COND, GENERAL-HARDWARE, GENERAL-INTERFACES, GENERAL-PRODUCT-DATA-1, GENERAL-PROJECT-DATA, GENERAL-REQUIREMENTS, GENERAL-SOFTWARE, GUARANTEE, HARDWARE-INTERFACE, INTEGRATION-CAPABILITY, INTERNAL-INTERFACES, INTERRUPT-SPEC, KEY-DATA, MAINTENANCE, MONITORING, NORMATIVE-REFERENCE, OBJECTIVES, OPERATING-ENV, OPERATIONAL-REQUIREMENTS, OVERVIEW, PARALLEL-DESIGNS, PRODUCT-DEMARCATION, PRODUCT-DESC, PROJECT-SCHEDULE, PROTOCOLS, PURCHASING-COND, QUALITY, REASON-ORDER, RELIABILITY, REPLACEMENT-VALUES, REQUIREMENT-SPEC, RESOURCE-ALLOCATION, RESTRICTIONS-BY-HARDWARE, RIGHTS, SAFETY, SAMPLE-SPEC, SELF-DIAGNOSIS, SIMILAR-PRODUCTS, STANDARD-SW-MODULES, SW-ARCHITECTURE, SW-CALIBRATION-METHOD-SPEC, SW-COLLECTION-SPEC, SW-COMPONENT-SPEC, SW-CPU-SPEC, SW-DATA-DICTIONARY-SPEC, SW-GLOSSARY, SW-INSTANCE-SPEC, SW-MC-COMMUNICATION-SPEC, SW-SYSTEM, SW-TASK-SPEC, SW-TEST-SPEC, SW-USER-RIGHT-SPEC, SW-VCD-SPEC, SYSTEM-OVERVIEW, TIME-DEPENDENCY, USEFUL-LIFE, USER-INTERFACE, VARIANT-SPEC
Ist Kontext für:
Text

Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.140. NAMELOC
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Verwenden Sie <NAMELOC>, um das externe Dokument eines dokumentübergreifenden Querverweises zu identifizieren, auf das verwiesen werden soll.
Example
Siehe FUNCTION-REF.
Formale Beschreibung
Hat als Kontext: | LOCS
Ist Kontext für: | LONG-NAME, SHORT-NAME, NMLIST
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[EXT-ID-CLASS] optional | SGML Zeichenkette (NMTOKEN) |  | External ID Class. The value of this attribute classifies links and external link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an external object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | EXTERNAL | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | NAMELOC | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.


1.141. NCOI-1

Beschreibung
Verwenden Sie <NCOI-1>, um nicht inhaltsorientierte Informationen, sog. allgemeine Dokumentinhalte, zu erstellen.
Formale Beschreibung
Hat als Kontext: | ACCEPTANCE-COND, ADD-DESIGN-DOC, ADD-SPEC, BINARY-COMPATIBILITY, CALIBRATION, COMMUNICATION, COMMUNICATION-INTERFACE, COMPATIBILITY, DATA-DESC, DATA-STRUCTURES, DEMARCATION-OTHER-PROJECTS, DEVELOPMENT-PROCESS-SPEC, DIAGNOSIS, DIR-HAND-OVER-DOC-DATA, EXTENSIBILITY, FAIL-SAVE-CONCEPT, FAILURE-MEM, FLASH-PROGRAMMING, FMEA, FUNCTION-OVERVIEW, GENERAL-COND, GUARANTEE, HARDWARE-INTERFACE, INTEGRATION-CAPABILITY, INTERNAL-INTERFACES, INTERRUPT-SPEC, MAINTENANCE, MONITORING, NORMATIVE-REFERENCE, OBJECTIVES, OPERATING-ENV, OPERATIONAL-REQUIREMENTS, OVERVIEW, PARALLEL-DESIGNS, PRODUCT-DEMARCATION, PRODUCT-DESC, PROJECT-SCHEDULE, PROTOCOLS, PURCHASING-COND, QUALITY, REASON-ORDER, REPLACEMENT-VALUES, RESOURCE-ALLOCATION, RESTRICTIONS-BY-HARDWARE, RIGHTS, SAFETY, SAMPLE, SDG, SELF-DIAGNOSIS, SIMILAR-PRODUCTS, STANDARD-SW-MODULES, SW-GLOSSARY, SW-TEST-SPEC, SYSTEM-OVERVIEW, TIME-DEPENDENCY, USER-INTERFACE
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.142. NCOI-3

Beschreibung
Verwenden Sie <NCOI-3>, um die Einzelheiten einzugeben. Siehe dazu auch NCOI-1.
Formale Beschreibung
Hat als Kontext: | RELIABILITY, USEFUL-LIFE
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, MSR-QUERY-P-2, TOPIC-2, MSR-QUERY-TOPIC-2
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.143. NMLIST

Beschreibung
Verwenden Sie <NMLIST>, um die Bezeichnung der Entity oder des Elements einzugeben, worauf in einem externen Dokument verwiesen werden soll.
Formale Beschreibung
Hat als Kontext: | NAMELOC
Ist Kontext für: | Text
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[NAMETYPE]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • ENTITY
  • ELEMENT
ENTITY - Verweis auf eine Entity im externen DokumentELEMENT - Verweis auf ein Element im externen Dokument
[DOCORSUB]
optional
Entity (ENTITY)
SGML/XML-Dokument oder Subdokument, dessen Prolog Entities oder Elemente deklariert, die in NMLIST vorkommen. Beispiel: siehe [FUNCTION-REF].
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME]
festgelegter Wert
SGML Zeichenkette (NMTOKEN)
NMLIST
HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.


1.144. NORMATIVE-REFERENCE

Beschreibung
Verwenden Sie <NORMATIVE-REFERENCE>, um die Erfüllung von Standards einzugeben.
Formale Beschreibung
Hat als Kontext: | DESIGN-REQUIREMENTS
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.145. NOTATION
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element bezeichnet das Datenformat der externen Datei, in welcher das übergeordnete XFILE vorliegt. Der Bezeichner selber ist zwischen den projektbeteiligten Partnern zu vereinbaren. Der Inhalt von <NOTATION> wird ähnlich wie eine SGML-Notation-Format behandelt.
Mögliche Werte sind z.B.:
Notation | Bedeutung
EPS | Encapsulated Postscript
PDF | Portable Document Format
PaCo | Parameter Contents File in MSRSW2.2-Struktur
... | ...
Example
<P>Please refer to
   <XFILE>
      <LONG-NAME-1>Parameter Contents file</LONG-NAME-1>
      <SHORT-NAME>0711paco</SHORT-NAME>
      <URL>../pacos/0711paco.xml</URL>
      <NOTATION>PaCo</NOTATION>
      <TOOL>DDCL</TOOL>
      <TOOL-VERSION>1.3</TOOL-VERSION>
   </XFILE>
</P>
Formale Beschreibung
Hat als Kontext: | XFILE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.146. NOTE

Beschreibung
Verwenden Sie <NOTE>, um Sicherheits- oder Bedienhinweise besonders hervorzuheben.
Formale Beschreibung
Hat als Kontext: | ADD-INFO, CHAPTER, CRITICAL-ASPECTS, ENTRY, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REMARK, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CLASS-METHOD-RETURN, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Ist Kontext für: | LABEL, P
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[NOTE-TYPE]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • CAUTION
  • HINT
  • TIP
  • INSTRUCTION
  • EXERCISE
  • OTHER
CAUTION - Gefahren für Geräte und Personen bei der BedienungHINT - Besondere BedienmerkmaleTIP - Arbeitserleichternde MaßnahmenINSTRUCTION - Notwendige AnweisungenEXERCISE - PraxisbeispieleOTHER - Zusätzliche Hinweise
[USER-DEFINED-TYPE]
optional
Zeichenkette (CDATA)
Erlaubt es, benutzerspezifische Notes einzuführen.
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.147. NUMBER

Beschreibung
Verwenden Sie <NUMBER>, um die Versionsnummer eines externen Dokumentes einzugeben, auf das verwiesen wird.
Formale Beschreibung
Hat als Kontext: | XDOC
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.148. NUMBER-OF-BITS
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Anzahl von Bits einer Bitgröße (beschrieben durch <SW-BIT-REPRESENTATION>), gerechnet ab der Position, welche durch das parallele Elementes <BIT-POSITION> spezifiziert wird.
Example
siehe SW-BIT-REPRESENTATION
Formale Beschreibung
Hat als Kontext: | SW-BIT-REPRESENTATION
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.149. OBJECTIVES

Beschreibung
Verwenden Sie <OBJECTIVES>, um die Ziele einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PROJECT-DATA
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.150. OPERATING-ENV

Beschreibung
Dieses Element beschreibt in verbaler Weise die Betriebs-Umgebung, in welcher das System mit der Software eingesetzt werden soll. Es ist Bestandteil der allgemeinen Anforderungen <GENERAL-REQUIREMENTS>. Im Gegensatz zu <OPERATIONAL-REQUIREMENTS> , welches Betriebsanforderungen spezifizert, welche die Software von innen heraus erfüllen soll, beschreibt <OPERATING-ENV> die von außen aufgeprägte Betriebsumgebung.
Formale Beschreibung
Hat als Kontext: | GENERAL-HARDWARE
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.151. OPERATING-TIME

Beschreibung
Dieses Element beschreibt in verbaler Weise die Anforderung hinsichtlich Betriebsdauer, an das System mit der Software. Es ist Bestandteil der allgemeinen Anforderungen <GENERAL-REQUIREMENTS>.
Formale Beschreibung
Hat als Kontext: | USEFUL-LIFE-PRMS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, PRM-CHAR
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | PRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.152. OPERATIONAL-REQUIREMENTS

Beschreibung
Dieses Element beschreibt die Betriebsanforderungen, die das System erfüllen muß, z.B. Anforderungen an die Performance. Im Gegensatz zu <OPERATING-ENV>, welches die von außen aufgeprägte Betriebsumgebung spezifiziert, beschreibt <OPERATIONAL-REQUIREMENTS> Betriebsanforderungen, welche die Software von innen heraus erfüllen soll.
Formale Beschreibung
Hat als Kontext: | FUNCTIONAL-REQUIREMENTS
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.153. OVERALL-PROJECT

Beschreibung
Verwenden Sie <OVERALL-PROJECT>, um die Gesamtprojekt einzugeben.
Formale Beschreibung
Hat als Kontext: | PROJECT-DATA
Ist Kontext für: | LABEL, DESC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.154. OVERVIEW

Beschreibung
In diesem Element soll eine textuelle Übersicht über die SW-Architektur des aktuellen <SW-SYSTEM>s gegeben werden.
Formale Beschreibung
Hat als Kontext: | SW-ARCHITECTURE
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.155. P

Beschreibung
Verwenden Sie <P>, um einen Absatz eines Fließtextes zu erstellen.
Formale Beschreibung
Hat als Kontext: | ADD-INFO, ANNOTATION-TEXT, CHAPTER, COND, CRITICAL-ASPECTS, DEF, ENTRY, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, NOTE, REALTIME-REQUIREMENTS, REMARK, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CLASS-METHOD-RETURN, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Ist Kontext für: | Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, STD, XDOC, XFILE, MSR-QUERY-TEXT
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[HELP-ENTRY]
optional
Zeichenkette (CDATA)
Erlaubt es, das Vaterelement als ein Hilfe-Einstiegspunkt zu markieren. Die Syntax ergibt sich aus dem verwendeten Hilfesystem. Oft wird das dazu verwendet, aus einem Fenstersystem eine Objekt-Id bzw. eine Widget-Namenshierarchie zu errechnen, die dann mit den Help-Entry-Einträgen korreliert wird.Beispiel:
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.156. PARALLEL-DESIGNS

Beschreibung
Verwenden Sie <PARALLEL-DESIGNS>, um die Parallelentwicklungen einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PROJECT-DATA
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.157. PHONE

Beschreibung
Verwenden Sie <PHONE>, um die Telefonnummer eines Projektbeteiligten einzugeben.
Formale Beschreibung
Hat als Kontext: | TEAM-MEMBER
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.158. POSITION

Beschreibung
Verwenden Sie <POSITION>, um Verweise auf die relevanten Stellen eines Standards einzugeben.
Formale Beschreibung
Hat als Kontext: | STD, XDOC
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.159. PPM

Beschreibung
Verwenden Sie <PPM>, um die PPM einzugeben.
Formale Beschreibung
Hat als Kontext: | RELIABILITY-PRMS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, PRM-CHAR
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | PRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.160. PRIVATE-CODE

Beschreibung
Verwenden Sie <PRIVATE-CODE>, um Daten für speziell angepaßte Systeme oder für Prozesse zu erzeugen.
Formale Beschreibung
Hat als Kontext: | PRIVATE-CODES
Ist Kontext für: | Text
Name | Typ | Anmerkung
[TYPE] optional | Zeichenkette (CDATA) | Gibt einen Typ des jeweiligen Elementes an.
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.161. PRIVATE-CODES

Beschreibung
Verwenden Sie <PRIVATE-CODE>, um eine Zusammenfassung der Daten für speziell angepaßte Systeme oder für Prozesse zu erzeugen.
Formale Beschreibung
Hat als Kontext: | COMPANY-DOC-INFO
Ist Kontext für: | PRIVATE-CODE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.162. PRM

Beschreibung
Verwenden Sie <PRM>, um eine Parametertabelle zu erstellen.
Formale Beschreibung
Hat als Kontext: | PRMS, RELIABILITY-PRMS, USEFUL-LIFE-PRMS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, PRM-CHAR
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | PRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.163. PRM-CHAR

Beschreibung
Verwenden Sie <PRM-CHAR>, um Parameterwerte zu erstellen.
Formale Beschreibung
Hat als Kontext: | AVAILABILITY, LIFE-TIME, MTBF, OPERATING-TIME, PPM, PRM
Ist Kontext für: | COND, ABS, TOL, MIN, TYP, MAX, UNIT, TEXT, REMARK
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.164. PRM-REF

Beschreibung
Verwenden Sie <PRM-REF>, um die Referenz einzugeben.
Formale Beschreibung
Hat als Kontext: | PRM-REFS
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | PRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.165. PRM-REFS

Beschreibung
Verwenden Sie <PRM-REFS>, um die Parameter-Referenzen einzugeben.
Formale Beschreibung
Hat als Kontext: | KEY-DATA
Ist Kontext für: | PRM-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.166. PRMS

Beschreibung
Verwenden Sie <PRMS>, um eine Parametertabelle für mehrere Parameter zu erstellen.
Formale Beschreibung
Hat als Kontext: | ADD-INFO, CHAPTER, CRITICAL-ASPECTS, FREE-INFO, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, NCOI-1, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1
Ist Kontext für: | LABEL, PRM
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.167. PRODUCT-DEMARCATION

Beschreibung
Verwenden Sie <PRODUCT-DEMARCATION>, um die Produktabgrenzung einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.168. PRODUCT-DESC

Beschreibung
Verwenden Sie <PRODUCT-DESC>, um die Produktkurzbeschreibung einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.169. PROJECT

Beschreibung
Verwenden Sie <PROJECT>, um das entsprechendeProjekt einzugeben.
Formale Beschreibung
Hat als Kontext: | PROJECT-DATA
Ist Kontext für: | LABEL, DESC, COMPANIES, GENERAL-PROJECT-DATA
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.170. PROJECT-DATA
Siehe Auch Description Example Formale Beschreibung

Description
Use <PROJECT-DATA> to capture information about the project the file belongs to. Although this wrapper elmenet seems to be superfluous in CDF, exists because more project related information is possible in MSRSW.DTD.
Example
 <PROJECT-DATA>
   <PROJECT>
      <LABEL>demo project for CDF file format with MSRSW.DTD</LABEL>
      <DESC> this project is used to illustrate how CDF format can be defined by
             following the structures of ASAM-MCD-2MC 2.0 resp. MSRSW.DTD 2.2.0
      </DESC>
      <COMPANIES>
         <COMPANY ROLE="SUPPLIER" ID="rb">
            <LONG-NAME>Robert Bosch GmbH</LONG-NAME>
            <SHORT-NAME>Bosch</SHORT-NAME>
            <TEAM-MEMBERS>
               <TEAM-MEMBER ID="wl">
               <LONG-NAME>Bernhard Weichel</LONG-NAME>
               <SHORT-NAME>Wl</SHORT-NAME>
                  <ROLES>
                     <ROLE>Author</ROLE>
                  </ROLES>
                  <DEPARTMENT>GS/EMW4</DEPARTMENT>
               </TEAM-MEMBER>
            </TEAM-MEMBERS>
         </COMPANY>
      </COMPANIES>
   </PROJECT>
</PROJECT-DATA>
Formale Beschreibung
Hat als Kontext: | MSRSW
Ist Kontext für: | OVERALL-PROJECT, PROJECT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.171. PROJECT-SCHEDULE

Beschreibung
Verwenden Sie <PROJECT-SCHEDULE>, um den Projektzeitplan einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PROJECT-DATA
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.172. PROTOCOLS

Beschreibung
Verwenden Sie <PROTOCOLS>, um die Protokolle/Besprechungsnotizen einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PROJECT-DATA
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.173. PUBLISHER

Beschreibung
Verwenden Sie <PUBLISHER>, um den Herausgeber eines externen Dokumentes einzugeben, auf das verwiesen wird.
Formale Beschreibung
Hat als Kontext: | XDOC
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.174. PURCHASING-COND

Beschreibung
Verwenden Sie <PURCHASING-COND>, um die Angebote einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PROJECT-DATA
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.175. QUALITY

Beschreibung
Verwenden Sie <QUALITY>, um das Qualitätsmodell einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.176. REALTIME-REQUIREMENTS

Beschreibung
Dieses Element spezifiziert textuelle Anforderungen für Echtzeit-Betrieb.
Formale Beschreibung
Hat als Kontext: | REQUIREMENT
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.177. REASON

Beschreibung
Verwenden Sie <REASON>, um den Grund für die Änderungen der aktuellen Dokumentversion im Vergleich zur Vorgängerversion einzugeben.
Formale Beschreibung
Hat als Kontext: | MODIFICATION
Ist Kontext für: | Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, MSR-QUERY-TEXT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.178. REASON-ORDER

Beschreibung
Verwenden Sie <REASON-ORDER>, um die Auftragsbegründung einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PROJECT-DATA
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.179. RELIABILITY

Beschreibung
Verwenden Sie <RELIABILITY>, um die Zuverlässigkeit einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-HARDWARE
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, RELIABILITY-PRMS, NCOI-3
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.180. RELIABILITY-PRMS

Beschreibung
Verwenden Sie <RELIABILITY-PRMS>, um die Parameter einzugeben.
Formale Beschreibung
Hat als Kontext: | RELIABILITY
Ist Kontext für: | MTBF, PPM, PRM
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.181. REMARK
Siehe Auch Description Formale Beschreibung

Description
<REMARK> is used to give a comment e.g. for the particular calibration state. There are two options:
  • Use <P> to allow the processing systems to perform a word wrapping.
  • Use <VERBATIM> if whitespace is siginifcant.
Formale Beschreibung
Hat als Kontext: | COMPANY-REVISION-INFO, MATCHING-DCI, PRM-CHAR, SW-CLASS-METHOD-ARG, SW-CS-ENTRY
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.182. REPLACEMENT-VALUES

Beschreibung
Verwenden Sie <REPLACEMENT-VALUES>, um die Ersatzwerte einzugeben.
Formale Beschreibung
Hat als Kontext: | FAILURE-MANAGEMENT
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.183. REQUIREMENT

Beschreibung
Dieses Element beinhaltet eine Anforderung, welche eine kurze einparagraphige Beschreibung <DESC>, Administrative Daten <ADMIN-DATA>, die gesamte Beschreibung der Anforderung <REQUIREMENT-BODY>, zu beachtende kritische Aspekte <CRITICAL-ASPECTS>, technische Aspekte <TECHNICAL-ASPECTS>, Echtzeit-Anforderungen <REALTIME-REQUIREMENTS>, Risiken <RISKS>, Abhängigkeiten von Anforderungen <REQUIREMENTS-DEPENDENCY> sowie zusätzliche Informationen <ADD-INFO>. Eine Anforderung <REQUIREMENT> darf wiederum Anforderungen <REQUIREMENT> enthalten.
Formale Beschreibung
Hat als Kontext: | REQUIREMENT, REQUIREMENTS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, REQUIREMENT-BODY, CRITICAL-ASPECTS, TECHNICAL-ASPECTS, REALTIME-REQUIREMENTS, RISKS, REQUIREMENTS-DEPENDENCY, ADD-INFO, REQUIREMENT
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | REQUIREMENT | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.184. REQUIREMENT-BODY

Beschreibung
Dieses Element beinhaltet die textuelle Beschreibung einer Anforderung, welche über Kapitelstrukturen verteilt sein kann.
Formale Beschreibung
Hat als Kontext: | REQUIREMENT
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.185. REQUIREMENT-REF

Beschreibung
Dieses Element beschreibt eine Referenz auf eine Anforderung <REQUIREMENT>. Die Referenz wird über das [ID-REF]-Attribut Inhalt des <REQUIREMENT-REF>-Elementes etabliert, welches auf ein <REQUIREMENT>-Element mit [ID]-Attribut gleichen Wertes zeigt. Der Verweis kann zusätzlich über den Inhalt des <REQUIREMENT-REF>-Elementes erfolgen, welches dann denselben Inhalt wie der <SHORT-NAME>eines <REQUIREMENT>s hat.
Formale Beschreibung
Hat als Kontext: | SW-FULFILS
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | REQUIREMENT | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.186. REQUIREMENT-SPEC

Beschreibung
Dieses Element beinhaltet die Spezifikation funktionaler Anforderungen. In <INTRODUCTION> können, falls angegeben, hierfür einige Erläuterungen stehen.
Formale Beschreibung
Hat als Kontext: | FUNCTIONAL-REQUIREMENTS
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, REQUIREMENTS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.187. REQUIREMENTS

Beschreibung
Container-Element für <REQUIREMENT>.
Formale Beschreibung
Hat als Kontext: | REQUIREMENT-SPEC
Ist Kontext für: | REQUIREMENT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.188. REQUIREMENTS-DEPENDENCY
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt in verbaler Weise die Querbeziehungen einer Anforderung zu anderen Anforderungen. Eine formale Abhängigkeit wird hier nicht spezifiziert, ist jedoch unter Verwendung von <XREF> möglich.
Example
<REQUIREMENTS>
   <REQUIREMENT ID="IDMUSTHAVELAMP">
      <LONG-NAME>The system shall have warning lamp</LONG-NAME>
   </REQUIREMENT>
   <REQUIREMENT ID="IDDETECTDANGER">
      <LONG-NAME>The system shall detect dangerous situations</LONG-NAME>
   </REQUIREMENT>
   <REQUIREMENT ID="ID72DE4BF3rad10F26">
      <LONG-NAME>The warning lamp shall flash on danger</LONG-NAME>
      <REQUIREMENTS-DEPENDENCY>
         <TOPIC-1 ID="ID72DE4BF3rad98328">
            <LONG-NAME>Prerequisites</LONG-NAME>
            <P><XREF ID-CLASS="REQUIREMENT" ID-REF="IDMUSTHAVELAMP"></XREF></P>
            <P><XREF ID-CLASS="REQUIREMENT" ID-REF="IDDETECTDANGER"></XREF></P>
         </TOPIC-1>
      </REQUIREMENTS-DEPENDENCY>
   </REQUIREMENT>
</REQUIREMENTS>
Formale Beschreibung
Hat als Kontext: | REQUIREMENT
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.189. RESOURCE-ALLOCATION

Beschreibung
Verwenden Sie <RESOURCE-ALLOCATION>, um die Anforderungen an die Ressourcennutzung einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.190. RESTRICTIONS-BY-HARDWARE

Beschreibung
Verwenden Sie <RESTRICTIONS-BY-HARDWARE>, um die Beschränkungen durch die Hardware einzugeben.
Formale Beschreibung
Hat als Kontext: | DESIGN-REQUIREMENTS
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.191. REVISION-LABEL

Beschreibung
Verwenden Sie <REVISION-LABEL>, um die Versionsnummer des Dokumentes oder Dokumententeiles einzugeben, für das administrative Daten erstellt werden sollen.
Formale Beschreibung
Hat als Kontext: | COMPANY-REVISION-INFO, DOC-REVISION
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.192. RIGHTS

Beschreibung
Verwenden Sie <RIGHTS>, um die Lizenzrechte einzugeben.
Formale Beschreibung
Hat als Kontext: | CONTRACT-ASPECTS
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.193. RISKS

Beschreibung
In diesem Element können textuelle Beschreibungen von Risiken einer funktionalen Anfordurung angegeben werden.
Formale Beschreibung
Hat als Kontext: | REQUIREMENT
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.194. ROLE
Siehe Auch Description Formale Beschreibung

Description
<ROLE> denotes one particular role taken by the team member in question within the current project. Roles are such as "Author", "Calibration engineer", "Supporter", "Quality assurance".
Formale Beschreibung
Hat als Kontext: | ROLES
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.195. ROLES
Siehe Auch Description Example Formale Beschreibung

Description
<ROLES> is a wrapper containing all roles one particular team member takes within the project.
Example
for an example, see PROJECT-DATA
Formale Beschreibung
Hat als Kontext: | COMPANY, TEAM-MEMBER
Ist Kontext für: | ROLE
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-CHILD-TYPE] festgelegter Wert | Zeichenkette (CDATA) | ROLE:SELECTION | Fixed Child Type. Warning: This attribute is only in the DTD for compatibility with older versions of the DTD and should not be used for any new implementations. It might be removed in future versions of the DTD.This attribute contains the information which child elements of the element carring this attribute should be checked by an semantic checker.


1.196. ROW

Beschreibung
Verwenden Sie <ROW>, um eine Reihe einer Tabelle zu erstellen.
Formale Beschreibung
Hat als Kontext: | TBODY, TFOOT, THEAD
Ist Kontext für: | ENTRY
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[VALIGN]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • TOP
  • BOTTOM
  • MIDDLE
TOP - Der Zeileninhalt wird am oberen Zellenrand ausgerichtet.BOTTOM - Der Zeileninhalt wird am unteren Zellenrand ausgerichtet.MIDDLE - Der Zeileninhalt wird vertikal zentriert ausgerichtet.
[ROWSEP]
optional
SGML Zeichenkette (NMTOKEN)
Legen Sie an dieser Stelle fest, ob für die Zelle Reihenlinien angezeigt werden sollen.Geben Sie 0 ein, wenn keine Reihenlinien angezeigt werden sollenGeben Sie 1 ein, wenn Reihenlinien angezeigt werden sollen.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.197. SAFETY

Beschreibung
Verwenden Sie <SAFETY>, um die Sicherheit einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.198. SAMPLE

Beschreibung
Verwenden Sie <SAMPLE>, um die Muster einzugeben.
Formale Beschreibung
Hat als Kontext: | SAMPLES
Ist Kontext für: | LONG-NAME, SHORT-NAME, NCOI-1
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SAMPLE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-CHILD-TYPE] festgelegter Wert | Zeichenkette (CDATA) | LONG-NAME:SELECTION | Fixed Child Type. Warning: This attribute is only in the DTD for compatibility with older versions of the DTD and should not be used for any new implementations. It might be removed in future versions of the DTD.This attribute contains the information which child elements of the element carring this attribute should be checked by an semantic checker.


1.199. SAMPLE-REF

Beschreibung
Verwenden Sie <SAMPLE-REF>, um die Musterreferenz einzugeben.
Formale Beschreibung
Hat als Kontext: | SCHEDULE
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SAMPLE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.


1.200. SAMPLE-SPEC

Beschreibung
Verwenden Sie <SAMPLE-SPEC>, um die Musterdefinitionen einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PROJECT-DATA
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, SAMPLES
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.201. SAMPLES

Beschreibung
Verwenden Sie <SAMPLES>, um die Muster einzugeben.
Formale Beschreibung
Hat als Kontext: | SAMPLE-SPEC
Ist Kontext für: | SAMPLE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.202. SCHEDULE

Beschreibung
Verwenden Sie <SCHEDULE>, um die einzugeben.
Formale Beschreibung
Hat als Kontext: | TBD
Ist Kontext für: | SAMPLE-REF, DATE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.203. SD

Beschreibung
Dieses Element beinhaltet nicht näher zu spezifizierende Daten, welche nicht unbedingt SGML/XML-Daten sind. Es kann auch ein neues Element einer umgebungsspezifischen DTD-Erweiterung verwendet werden.
Formale Beschreibung
Hat als Kontext: | SDG
Ist Kontext für: | Text
Name | Typ | Anmerkung
[GID] obligatorisch | Zeichenkette (CDATA) | Identifikationsname des neuen Elementes
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.204. SDG

Beschreibung
SDG (Special Data Group) is a backdoor to transmit unpretended data, which is contained in the "terminal" element <SD>. It is also very dangerous, because it may compromise the objective of standardized data exchange.It could be the case that data must be transmitted which is originally not supported in one of the DTDs. In order to avoid other file formats, the MSR-DTDs should be able to take such data. Links to other elements in the instance are possible via <XREF>.
Formale Beschreibung
Hat als Kontext: | SDG, SPECIAL-DATA
Ist Kontext für: | SDG-CAPTION, SD, SDG, NCOI-1, XREF
Name | Typ | Anmerkung
[GID] obligatorisch | Zeichenkette (CDATA) | Identifikationsname der Element-Gruppe
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.205. SDG-CAPTION

Beschreibung
This allows to assign an [ID], a <SHORT-NAME> as well as a <LONG-NAME> to a special data group <SDG>.
Formale Beschreibung
Hat als Kontext: | SDG
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SDG | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.206. SELF-DIAGNOSIS

Beschreibung
Verwenden Sie <SELF-DIAGNOSIS>, um die Selbstdiagnose einzugeben.
Formale Beschreibung
Hat als Kontext: | FAILURE-MANAGEMENT
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.207. SHORT-LABEL
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element spezifiziert einen Kurzbezeichner für das Kontext-Element, welcher jedoch nicht wie ein <SHORT-NAME> im MSRSW-Zusammenhang (Queries, externe Applikationen etc.) referenzierbar ist.
Example
Siehe MATCHING-DCIS 1.115. MATCHING-DCIS MATCHING-DCIS MATCHING-DCIS.
Formale Beschreibung
Hat als Kontext: | MATCHING-DCI, SW-CLASS-METHOD, SW-CLASS-METHOD-ARG, SW-MC-GENERIC-INTERFACE, SW-PROCESS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.208. SHORT-NAME

Beschreibung
Verwenden Sie <SHORT-NAME>, um eine Kurzbezeichnung für das Kontext-Element zu erstellen, welches hierdurchreferenzierbar ist.
Formale Beschreibung
Hat als Kontext: | AVAILABILITY, CHAPTER, COMPANY, DEF-ITEM, FIGURE-CAPTION, FORMULA-CAPTION, LIFE-TIME, MSRSW, MTBF, NAMELOC, OPERATING-TIME, PPM, PRM, REQUIREMENT, SAMPLE, SDG-CAPTION, STD, SW-ADDR-METHOD, SW-AXIS-TYPE, SW-BASE-TYPE, SW-CALIBRATION-METHOD, SW-CALPRM, SW-CALPRM-PROTOTYPE, SW-CLASS, SW-CLASS-ATTR-IMPL, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-CODE-SYNTAX, SW-COLLECTION, SW-COMPU-METHOD, SW-CPU-MEM-SEG, SW-DATA-CONSTR, SW-FEATURE, SW-GENERIC-AXIS-PARAM-TYPE, SW-INSTANCE, SW-INSTANCE-TREE, SW-MC-BASE-TYPE, SW-MC-FRAME, SW-MC-INTERFACE, SW-MC-INTERFACE-SOURCE, SW-RECORD-LAYOUT, SW-SYSTEM, SW-SYSTEMCONST, SW-TASK, SW-TEMPLATE, SW-UNIT, SW-USER-ACCESS-CASE, SW-USER-GROUP, SW-VARIABLE, SW-VARIABLE-PROTOTYPE, SW-VCD-CRITERION, TABLE-CAPTION, TEAM-MEMBER, TOPIC-1, TOPIC-2, VARIANT-CHAR, VARIANT-DEF, XDOC, XFILE, XREF-TARGET
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.209. SI-UNIT
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Beschreibt eine standardisierte Maßeinheit, welche für andere Maßeinheiten zur Umrechnung herangezogen wird. Hierzu gehören:
  • Stoffmenge
  • Strom
  • Länge
  • Masse
  • Lichtstärke
  • Temperatur
  • Zeit
Die Maßeinheiten-Exponenten werden über die entsprechenden spezifischen Attribute bestimmt.
Eine <SW-UNIT> kann sowohl auf Basis einer <SI-UNIT> als auch auf einer anderen beliebigen Maßeinheit mittels der Referenz <SW-UNIT-REF> definiert werden. Dabei ist zu beachten:
  • Bei Verwendung von referenzierten Maßeinheiten muß die Kette der Verweise bei einer SI-UNIT enden.
  • Die Umrechnung der aktuellen Maßeinheit in die referenzierte Maßeinheit wird spezifizert durch <SW-UNIT-CONVERSION-METHOD>. Dabei gilt:
    Umrechnung von Maßeinheiten
    SW-UNIT = SW-UNIT-GRADIENT * SW-UNIT-REF + SW-UNIT-OFFSET
Example
<SW-UNIT ID="HERTZ">
   <LONG-NAME>HERTZ</LONG-NAME>
   <SHORT-NAME>Hz</SHORT-NAME>
   <SW-UNIT-DISPLAY>Hz</SW-UNIT-DISPLAY>
   <SI-UNIT TIME-EXPO="-1"></SI-UNIT>
</SW-UNIT>
<SW-UNIT ID="UPM">
   <LONG-NAME>ROTATES PER MINUTE</LONG-NAME>
   <SHORT-NAME>UPM</SHORT-NAME>
   <SW-UNIT-DISPLAY>UPM</SW-UNIT-DISPLAY>
   <SW-UNIT-CONVERSION-METHOD>
      <SW-UNIT-GRADIENT>0.0166</SW-UNIT-GRADIENT>
      <SW-UNIT-OFFSET>0</SW-UNIT-OFFSET>
   </SW-UNIT-CONVERSION-METHOD>
   <SW-UNIT-REF ID-REF="HERTZ">HERTZ</SW-UNIT-REF>
</SW-UNIT>
[UPM] = 0.0166 * [Hz] + 0
Formale Beschreibung
Hat als Kontext: | SW-UNIT
Ist Kontext für: | Text
Name | Typ | Anmerkung
[LENGTH-EXPO] optional | Zeichenkette (CDATA) | Exponent der Längeneinheit
[TIME-EXPO] optional | Zeichenkette (CDATA) | Exponent der Zeiteinheit
[MASS-EXPO] optional | Zeichenkette (CDATA) | Exponent der Masseneinheit
[ELECTRIC-CURRENT-EXPO] optional | Zeichenkette (CDATA) | Exponent der Stromeinheit
[THERMODYNAMIC-TEMPERATURE-EXPO] optional | Zeichenkette (CDATA) | Exponent der Temperatureinheit
[LUMINOUS-INTENSITY-EXPO] optional | Zeichenkette (CDATA) | Exponent der Lichtstärkeneinheit
[AMOUNT-OF-SUBSTANCE-EXPO] optional | Zeichenkette (CDATA) | Exponent der Stoffmengeneinheit
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.210. SIMILAR-PRODUCTS

Beschreibung
Verwenden Sie <SIMILAR-PRODUCTS>, um die Hinweise auf ähnliche Produkte einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PRODUCT-DATA-1
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.211. SPANSPEC

Beschreibung
Verwenden Sie <SPANSPEC>, um die Identifikationdaten für eine Spaltenverschmelzung festzulegen.
Formale Beschreibung
Hat als Kontext: | TGROUP
Hat keinen Inhalt. |
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[NAMEST]
obligatorisch
SGML Zeichenkette (NMTOKEN)
Identifikationsnummer der ersten Spalte der Spaltenverschmelzung
[NAMEEND]
obligatorisch
SGML Zeichenkette (NMTOKEN)
Identifikationsnummer der letzten Spalte der Spaltenverschmelzung
[SPANNAME]
obligatorisch
SGML Zeichenkette (NMTOKEN)
Identifikationsnamen für die spezifizierte Spaltenverschmelzung
[ALIGN]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • LEFT
  • RIGHT
  • CENTER
  • JUSTIFY
  • CHAR
LEFT - Der Tabelleninhalt wird linksbündig ausgerichtet.RIGHT - Der Tabelleninhalt wird rechtsbündig ausgerichtet.CENTER - Der Tabelleninhalt wird horizontal zentriert.JUSTIFY - Der Tabelleninhalt wird als Blocksatz dargestellt. Der Abstand zum linken und rechten Rand der Zelle ist gleich.CHAR - Die Ausrichtung des Tabelleninhalts wird über das Attribut [CHAR] festgelegt.
[CHAROFF]
optional
SGML Zeichenkette (NMTOKEN)
Wenn [ALIGN]="CHAR" ist, gibt dieser Wert die Prozentanzahl der aktuellen Spaltenbreite zum linken Rand des Ausrichtungszeichens im [CHAR]-Attribut an. Falls kein Ausrichtungszeichen im Element <ENTRY> vorhanden ist, wird horizontal rechts ausgerichtet. Der Defaultwert wird von dem <COLSPEC> Element geerbt, welche im Attribut[NAMEST] steht.
[CHAR]
optional
Zeichenkette (CDATA)
Falls [ALIGN]="CHAR" ist, gibt dieser aus einem Zeichen bestehende Wert von [CHAR] das Ausrichtungszeichen, z.B. "," bzlw "." als Dezimalpunkttrennzeichen, an. Das Zeichen darf kein SDATA-Entity sein.
[COLSEP]
optional
SGML Zeichenkette (NMTOKEN)
Legen Sie an dieser Stelle fest, ob für die Zelle Spaltenlinien angezeigt werden sollen.Geben Sie 0 ein, wenn keine Spaltenlinien angezeigt werden sollen.Geben Sie 1 ein, wenn Spaltenlinien angezeigt werden sollen.
[ROWSEP]
optional
SGML Zeichenkette (NMTOKEN)
Legen Sie an dieser Stelle fest, ob für die Zelle Reihenlinien angezeigt werden sollen.Geben Sie 0 ein, wenn keine Reihenlinien angezeigt werden sollenGeben Sie 1 ein, wenn Reihenlinien angezeigt werden sollen.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.212. SPECIAL-DATA

Beschreibung
Container Element für <SDG>.
Formale Beschreibung
Hat als Kontext: | MSRSW
Ist Kontext für: | SDG
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.213. STANDARD-SW-MODULES

Beschreibung
Verwenden Sie <STANDARD-SW-MODULES>, um die standardisierten SW-Module einzugeben.
Formale Beschreibung
Hat als Kontext: | DESIGN-REQUIREMENTS
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.214. STATE
Siehe Auch Description Example Formale Beschreibung

Description
<STATE> represents the current state of the current file according to the configuration management plan.
Example
<STATE>reviewed</STATE>
Formale Beschreibung
Hat als Kontext: | COMPANY-REVISION-INFO, DOC-REVISION
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.215. STATE-1

Beschreibung
Verwenden Sie <STATE-1>, um die Version und den Zustand eines Standards oder eines externen Dokuments einzugeben.
Formale Beschreibung
Hat als Kontext: | STD, XDOC
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.216. STD

Beschreibung
Verwenden Sie <STD>, um auf externe Standards innerhalb eines Absatzelementes zu verweisen.
Formale Beschreibung
Hat als Kontext: | P, TBR
Ist Kontext für: | LONG-NAME-1, SHORT-NAME, SUBTITLE, STATE-1, DATE-1, URL, POSITION
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | STD | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.217. SUB

Beschreibung
Verwenden Sie <SUB>, um Textteile innerhalb eines Absatzelementes in kleinerer Schriftart unterhalb der Grundlinie darzustellen.
Formale Beschreibung
Hat als Kontext: | ABS, CHANGE, DESC, IE, INDENT-SAMPLE, ITEM-LABEL, LABEL, LONG-NAME, LONG-NAME-1, MAX, MIN, MSR-QUERY-RESULT-TEXT, P, REASON, SW-UNIT-DISPLAY, TBR, TEXT, TOL, TYP, UNIT
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.218. SUBTITLE

Beschreibung
Verwenden Sie <SUBTITLE>, um eine Teilüberschrift eines externen Standards einzugeben.
Formale Beschreibung
Hat als Kontext: | STD
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.219. SUP

Beschreibung
Verwenden Sie <SUP>, um Textteile innerhalb eines Absatzelementes in kleinerer Schriftart oberhalb der Grundlinie darzustellen.
Formale Beschreibung
Hat als Kontext: | ABS, CHANGE, DESC, IE, INDENT-SAMPLE, ITEM-LABEL, LABEL, LONG-NAME, LONG-NAME-1, MAX, MIN, MSR-QUERY-RESULT-TEXT, P, REASON, SW-UNIT-DISPLAY, TBR, TEXT, TOL, TYP, UNIT
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.220. SW-ACCESS-DEF
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt einen spezifischen Eintrag in der "Zugriffsrechtetabelle". Es gibt also an, welche Menge von Benutzern (<SW-USER-GROUP-REF>) welche Art von Zugriffsoperation (<SW-USER-ACCESS-CASE-REF>) an welchen Objekten (<SW-COLLECTION-REF>) durchführen darf.
Es gelten folgende Hinweise:
  • Falls keine <SW-COLLECTION> referenziert wird, gelten die Zugriffsrechte auf allen Objekten.
  • Die Semantik der Zugriffe ist durch eine vereinbarte Belegung von <SHORT-NAME> innerhalb <SW-USER-ACCESS-CASE> zu steuern. Eine verbale Beschreibung hierzu kann in <DESC> unterhalb <SW-USER-ACCESS-CASE> gestellt werden. Dies bezieht sich auch auf notwendige Prioritäten von Zugriffsoperationen.
  • Die Ausgestaltung der Zugriffsrechte als offenes (es ist alles erlaubt) bzw. als geschlossenes System (nichts ist erlaubt) muß durch geeignete Festlegung der Semantiken der <SW-USER-ACCESS-CASES> erfolgen.
  • Das Zugriffssystem ist a priori als geschlossenes System aufzufassen.
Example
Beispiel für ein geschlossenes System:
<SW-USER-RIGHT-SPEC>
   <SW-USER-GROUPS>
      <SW-USER-GROUP ID="ALL-USERS">
         <DESC>If no user is referred to, all users belong to this group </DESC>
      </SW-USER-GROUP>
      <SW-USER-GROUP ID="THE-BOSSES">
         <LONG-NAME>The bosses of this world</LONG-NAME>
         <SHORT-NAME>the-bosses</SHORT-NAME>
         <SYSTEM-USERS>
            <SYSTEM-USER>bigates</SYSTEM-USER>
            <SYSTEM-USER>gebush</SYSTEM-USER>
            <SYSTEM-USER>vlputin</SYSTEM-USER>
            <SYSTEM-USER>frbeckenbauer</SYSTEM-USER>
         </SYSTEM-USERS>
      </SW-USER-GROUP>
   </SW-USER-GROUPS>
   <SW-USER-ACCESS-CASES>
      <SW-USER-ACCESS-CASE ID="READ-ACCESS">
         <LONG-NAME>Read access</LONG-NAME>
         <SHORT-NAME>Read</SHORT-NAME>
      </SW-USER-ACCESS-CASE>
      <SW-USER-ACCESS-CASE ID="NO-ACCESS">
         <LONG-NAME>No access</LONG-NAME>
         <SHORT-NAME>No-Access</SHORT-NAME>
         <DESC>"No-Access" establishes a closed system. Access can be grantet explicitly by another Access Case.</DESC>
      </SW-USER-ACCESS-CASE>
   </SW-USER-ACCESS-CASES>
   <SW-USER-ACCESS-DEFINTIONS>
      <SW-ACCESS-DEF>
         <SW-USER-GROUP-REF ID-REF="THE-BOSSES">the-bosses</SW-USER-GROUP-REF>
         <SW-USER-ACCESS-CASE-REF ID-REF="READ-ACCESS">Read</SW-USER-ACCESS-CASE-REF>
      </SW-ACCESS-DEF>
      <SW-ACCESS-DEF>
         <SW-USER-GROUP-REF ID-REF="ALL-USERS">ALL-USERS</SW-USER-GROUP-REF>
         <SW-USER-ACCESS-CASE-REF ID-REF="NO-ACCESS">No-Access</SW-USER-ACCESS-CASE-REF>
      </SW-ACCESS-DEF>
   </SW-USER-ACCESS-DEFINTIONS>
</SW-USER-RIGHT-SPEC>
Formale Beschreibung
Hat als Kontext: | SW-USER-ACCESS-DEFINTIONS
Ist Kontext für: | SW-USER-GROUP-REF, SW-USER-ACCESS-CASE-REF, SW-COLLECTION-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.221. SW-ADDR-INFO
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element gibt die Information, die notwendig ist, um ein Speicherobjekt zu addressieren. Hierfür werden folgende Angaben gemacht:
  • Das Speichersegment (referenziert durch <SW-CPU-MEM-SEG-REF>) in dem das Speicherobjekt abgelegt wird (z.B. RAM, ROM)
  • Die Basisaddresse angegeben durch <SW-BASE-ADDR>
  • Der Offset angegeben durch <SW-ADDR-OFFSET>
  • Die Größe des Speicherobjektes in Byte, angegeben durch <SW-SIZEOF-INSTANCE>. Diese wird benötigt, um bei Ablage von Strukturen die Einzeladdressen der Komponenten nachrechnen zu können.
Example
<SW-ADDR-INFO>
   <SW-CPU-MEM-SEG-REF>RAM</SW-CPU-MEM-SEG-REF>
   <SW-ADDR-OFFSET>0x100</SW-ADDR-OFFSET>
   <SW-SIZEOF-INSTANCE>25</SW-SIZEOF-INSTANCE>
</SW-ADDR-INFO>
Formale Beschreibung
Hat als Kontext: | SW-ADDR-INFOS, SW-CPU-ADDR-EPK
Ist Kontext für: | SW-CPU-MEM-SEG-REF, SW-BASE-ADDR, SW-ADDR-OFFSET, SW-SIZEOF-INSTANCE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.222. SW-ADDR-INFOS

Beschreibung
Container-Element für <SW-ADDR-INFOS>.
Formale Beschreibung
Hat als Kontext: | SW-INSTANCE-PROPS-VARIANT
Ist Kontext für: | SW-ADDR-INFO
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.223. SW-ADDR-METHOD
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Ein Adressierschema <SW-ADDR-METHOD> beschreibt, wie Variablen bzw. Parameter im Steuergerät addressiert werden. Beispiele für unterschiedliche Addressierungsarten sind die direkte Addressierung oder die indirekte Addressierung über einen Vektor.
Dieses Element dient im wesentlichen zur Vereinbarung von Keywords (im Subelement <SHORT-NAME>) für Adressberechnungsverfahren. Das Verfahren selbst wird nur verbal (in <SW-ADDR-METHOD-DESC>), aber nicht formal beschrieben. Allerdings wird ein formaler Verweis <SW-CPU-MEM-SEG-REF> auf das betroffene Speichersegment gegeben [image] . Dieser Ansatz wurde gewählt, da die Anzahl der möglichen Adressierschemata relativ gering ist. Eine volle formale Beschreibung ist hierfür zu aufwendig.
Example
<SW-ADDR-METHODS>
   <SW-ADDR-METHOD ID="IDBIT">
      <LONG-NAME>This is Addr-Method Bit</LONG-NAME>
      <SHORT-NAME>Bit</SHORT-NAME>
      <SW-CPU-MEM-SEG-REF></SW-CPU-MEM-SEG-REF>
      <SW-ADDR-METHOD-DESC>
         <VERBATIM>Adressierschema: Bit Kopfzeile: BitHeader Fusszeile: BitFooter Adressierart: Bit Datentyp des Vektors: aw </VERBATIM>
      </SW-ADDR-METHOD-DESC>
   </SW-ADDR-METHOD>
</SW-ADDR-METHODS>
Formale Beschreibung
Hat als Kontext: | SW-ADDR-METHODS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-CPU-MEM-SEG-REF, SW-ADDR-METHOD-DESC
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-ADDR-METHOD | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.

In künftigen Versionen können bei Bedarf weitere formale Anteile hinzukommen.


1.224. SW-ADDR-METHOD-DESC

Beschreibung
Verbale Beschreibung der Addressierungsmethode für Variablen bzw. Parameter.
Formale Beschreibung
Hat als Kontext: | SW-ADDR-METHOD
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.225. SW-ADDR-METHOD-REF

Beschreibung
Dieses Element referenziert auf eine Adressierungsmethode <SW-ADDR-METHOD>. Die Referenz wird über das [ID-REF]-Attribut Inhalt des <SW-ADDR-METHOD-REF>-Elementes etabliert, welches auf ein <SW-ADDR-METHOD>-Element mit [ID]-Attribut gleichen Wertes zeigt. Der Verweis kann zusätzlich über den Inhalt des <SW-ADDR-METHOD-REF>-Elementes erfolgen, welches dann denselben Inhalt wie der <SHORT-NAME>einer <SW-ADDR-METHOD> hat.
Formale Beschreibung
Hat als Kontext: | SW-ADDR-METHOD-REFS, SW-DATA-DEF-PROPS
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-ADDR-METHOD | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.226. SW-ADDR-METHOD-REFS

Beschreibung
Container Element für <SW-ADDR-METHOD-REF>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-CONT
Ist Kontext für: | SW-ADDR-METHOD-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.227. SW-ADDR-METHODS

Beschreibung
Container Element für <SW-ADDR-METHOD>.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DICTIONARY-SPEC
Ist Kontext für: | ADMIN-DATA, SW-ADDR-METHOD
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.228. SW-ADDR-OFFSET
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element gibt den Offset eines Speicherobjektes an.
Example
Siehe SW-ADDR-INFO
Formale Beschreibung
Hat als Kontext: | SW-ADDR-INFO
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.229. SW-ALIAS-NAME

Beschreibung
Dieses Element beschreibt einen Aliasnamen, der für die Kompatibilität zu anderen Namenskonventionen herangezogen werden kann.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.230. SW-APPLICATION-NOTES

Beschreibung
IN diesem Element werden Applikationshinweise textuell spezifiziert.
Formale Beschreibung
Hat als Kontext: | SW-CLASS, SW-FEATURE
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.231. SW-ARCHITECTURE

Beschreibung
Dieses Element beschreibt in verbaler Form die Architektur des vorliegenden Software-Systems. Eine Gliederungsstruktur ist jedoch vorgegeben:
  • Übersicht <OVERVIEW>
  • Task-Spezifikation und Prozeßstruktur <SW-TASK-SPEC>
  • Interrupt-Spezifikation <INTERRUPT-SPEC>
  • Zeitliche Abhängigkeiten <TIME-DEPENDENCY>
  • sonstige Spezifikationen <ADD-SPEC>
Formale Beschreibung
Hat als Kontext: | SW-SYSTEM
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, OVERVIEW, SW-TASK-SPEC, INTERRUPT-SPEC, TIME-DEPENDENCY, ADD-SPEC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.232. SW-ARRAY-INDEX
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Spezifiziert den Feldindex für genau eine Koordinate eines Kenngrößen-Arrays in einer Instanz <SW-INSTANCE>. Diese Instanz korrespondiert mit entweder einer Struktur, einem Klassenattribut oder einem Feldindex, in diesem Fall <SW-ARRAY-INDEX>.
Der Array-Index beginnt bei 0.
Example
<SW-INSTANCE ID="IDTEST">
   <LONG-NAME>Kenngrößen-Array</LONG-NAME>
   <SHORT-NAME>kgr_a</SHORT-NAME>
   <SW-INSTANCE ID="IDB6433D7radB380B">
      <SW-ARRAY-INDEX>0</SW-ARRAY-INDEX>
      <SW-FEATURE-REF>test_AG</SW-FEATURE-REF>
      <CATEGORY>curve_individual</CATEGORY>
      <SW-INSTANCE-PROPS-VARIANTS>
         <SW-INSTANCE-PROPS-VARIANT>
            <SW-AXIS-CONTS>
               <SW-AXIS-CONT>
                  <SW-UNIT-REF>Grad-C</SW-UNIT-REF>
                  <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
                  <SW-VALUES-PHYS>
                     <V>-49.3</V>
                     <V>-48.6</V>
                     <V>-47.8</V>
                     <V>-47.1</V>
                     <V>-46.4</V>
                     <V>-45.7</V>
                  </SW-VALUES-PHYS>
               </SW-AXIS-CONT>
               <SW-AXIS-CONT>
                  <SW-UNIT-REF>dez</SW-UNIT-REF>
                  <SW-AXIS-INDEX>0</SW-AXIS-INDEX>
                  <SW-VALUES-PHYS>
                     <V>1.0</V>
                        <V>2.0</V>
                     <V>3.0</V>
                        <V>4.0</V>
                     <V>5.0</V>
                     <V>6.0</V>
                  </SW-VALUES-PHYS>
               </SW-AXIS-CONT>
            </SW-AXIS-CONTS>
         </SW-INSTANCE-PROPS-VARIANT>
      </SW-INSTANCE-PROPS-VARIANTS>
   </SW-INSTANCE>
   <SW-INSTANCE ID="IDB6433D7radBBD87">
      <SW-ARRAY-INDEX>1</SW-ARRAY-INDEX>
      <SW-FEATURE-REF>test_AG</SW-FEATURE-REF>
      <CATEGORY>curve_individual</CATEGORY>
      <SW-INSTANCE-PROPS-VARIANTS>
            <SW-INSTANCE-PROPS-VARIANT>
               <SW-AXIS-CONTS>
                  <SW-AXIS-CONT>
                  <SW-UNIT-REF>Grad-C</SW-UNIT-REF>
                  <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
                  <SW-VALUES-PHYS>
                     <V>-49.3</V>
                     <V>-48.6</V>
                     <V>-47.8</V>
                     <V>-47.1</V>
                     <V>-46.4</V>
                     <V>-45.7</V>
                  </SW-VALUES-PHYS>
               </SW-AXIS-CONT>
               <SW-AXIS-CONT>
                  <SW-UNIT-REF>dez</SW-UNIT-REF>
                  <SW-AXIS-INDEX>0</SW-AXIS-INDEX>
                  <SW-VALUES-PHYS>
                     <V>1.0</V>
                     <V>2.0</V>
                     <V>3.0</V>
                     <V>4.0</V>
                     <V>5.0</V>
                     <V>6.0</V>
                  </SW-VALUES-PHYS>
               </SW-AXIS-CONT>
            </SW-AXIS-CONTS>
         </SW-INSTANCE-PROPS-VARIANT>
      </SW-INSTANCE-PROPS-VARIANTS>
   </SW-INSTANCE>
   <SW-INSTANCE ID="IDB6433D7rad2B10B">
      <SW-ARRAY-INDEX>2</SW-ARRAY-INDEX>
      <SW-FEATURE-REF>test_AG</SW-FEATURE-REF>
      <CATEGORY>curve_individual</CATEGORY>
      <SW-INSTANCE-PROPS-VARIANTS>
         <SW-INSTANCE-PROPS-VARIANT>
            <SW-AXIS-CONTS>
               <SW-AXIS-CONT>
                  <SW-UNIT-REF>Grad-C</SW-UNIT-REF>
                  <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
                 <SW-VALUES-PHYS>
                     <V>-49.3</V>
                     <V>-48.6</V>
                     <V>-47.8</V>
                     <V>-47.1</V>
                     <V>-46.4</V>
                     <V>-45.7</V>
              </SW-VALUES-PHYS>
               </SW-AXIS-CONT>
               <SW-AXIS-CONT>
                  <SW-UNIT-REF>dez</SW-UNIT-REF>
                  <SW-AXIS-INDEX>0</SW-AXIS-INDEX>
                  <SW-VALUES-PHYS>
                     <V>1.0</V>
                     <V>2.0</V>
                     <V>3.0</V>
                     <V>4.0</V>
                     <V>5.0</V>
                     <V>6.0</V>
                  </SW-VALUES-PHYS>
               </SW-AXIS-CONT>
            </SW-AXIS-CONTS>
         </SW-INSTANCE-PROPS-VARIANT>
      </SW-INSTANCE-PROPS-VARIANTS>
   </SW-INSTANCE>
</SW-INSTANCE>
Formale Beschreibung
Hat als Kontext: | SW-INSTANCE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.233. SW-ARRAYSIZE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Die Existenz von <SW-ARRAYSIZE> macht das Vaterelement zu einem mehrdimensionalen Objekt. Hierbei handelt es sich um Arrays von Variablen oder Parametern als solches. <SW-ARRAYSIZE> sollte nicht verwendet werden, um Stereotype wie Kennlinie oder Kennfeld nachzubilden, da diese Strukturen in der DTD selbst angelegt sind.
Es ist also möglich, z.B. Arrays von Kennfeldern zu definieren.
Example
<SW-VARIABLE ID="ID71EA062Crad3494D">
   <LONG-NAME>This is Array1</LONG-NAME>
   <SHORT-NAME>Array1</SHORT-NAME>
   <SW-ARRAYSIZE>
      <VF>3</VF>
   </SW-ARRAYSIZE>
   <SW-DATA-DEF-PROPS>
      <SW-ADDR-METHOD-REF>OffsetAdS1</SW-ADDR-METHOD-REF>
      <SW-BASE-TYPE-REF>UWORD</SW-BASE-TYPE-REF>
      <SW-CALIBRATION-ACCESS>CALIBRATION</SW-CALIBRATION-ACCESS>
      <SW-CODE-SYNTAX-REF>Bit</SW-CODE-SYNTAX-REF>
      <SW-COMPU-METHOD-REF>default</SW-COMPU-METHOD-REF>
   </SW-DATA-DEF-PROPS>
</SW-VARIABLE>
Formale Beschreibung
Hat als Kontext: | SW-CALPRM, SW-CALPRM-PROTOTYPE, SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE, SW-VARIABLE, SW-VARIABLE-PROTOTYPE
Ist Kontext für: | VF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.234. SW-AXIS-CONT
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Beschreibung des Inhaltes einer Kenngrößen-Achse, welche im Unterelement <SW-AXIS-INDEX> spezifiziert wird, sowie optionale Bedatung der zugehörigen Werte, z. B. Physik- und Integerwerte in den Unterelementen <SW-VALUES-PHYS>, <SW-VALUES-CODED> etc. Falls es mehr als eine Achse gibt, so inkrementiert die Achse mit Index 1 zuerst. Dies bedeutet, daß die Werte in der folgenden Reihenfolge gegeben sind:
v(1,1) | ... | v(n,1)
v(1,2) | ... | v(n,2)
... |  |
v(1,m) | ... | v(n, m)
Das Element <SW-AXIS-CONT> tritt so oft auf, wie die korespondierende instanziierte Variable oder Parameter Achsen besitzt. Die aktuell relevante Achse wird im Subelement <SW-AXIS-INDEX> spezifiziert.
Die Inhalte der Achse können auf verschiedenen Ebenen angegeben werden:
  • Physikalisch (<SW-VALUES-PHYS>)
  • Codiert dezimal (<SW-VALUES-CODED>)
  • Codiert hexadezimal (<SW-VALUES-CODED-HEX>)
  • Beliebige andere Repräsentationen (<SW-VALUES-GENERIC> in Verbindung mit dem Attribut [TYPE])
Da die MSRSW.DTD auch dazu verwendbar sein soll, reine physikalische Daten unabhängig von den Details des Datenlexikons zu transportieren, ist es notwendig, Maßeinheiten spezifizieren zu können. Diese werden mit <SW-UNIT-REF> referenziert.
Example
For an example, see SW-ARRAY-INDEX 1.407. SW-INSTANCE SW-INSTANCE SW-INSTANCE.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-CONTS
Ist Kontext für: | SW-UNIT-REF, SW-AXIS-INDEX, SW-VALUES-PHYS, SW-VALUES-CODED, SW-VALUES-CODED-HEX, SW-VALUES-GENERIC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.235. SW-AXIS-CONTS
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
<SW-AXIS-CONTS> beschreibt den Inhalt aller Achsen einer bestimmten Kenngröße.
Example
Siehe SW-ARRAY-INDEX 1.407. SW-INSTANCE SW-INSTANCE SW-INSTANCE.
Formale Beschreibung
Hat als Kontext: | SW-INSTANCE-PROPS-VARIANT
Ist Kontext für: | SW-AXIS-CONT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.236. SW-AXIS-GENERIC
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element definiert eine Achse, für die die Stützstellen in der ECU errechnet werden. Der Algorithmus zur Berechnung ist in der ECU fest verdrahtet. Parameter für diesen Algorithmus können im Datenteil des Steuergerätes abgelegt werden. Es gilt:
  • Der zu verwendende Algorithmus wird als <SW-AXIS-TYPE> im Datenlexikon semiformal (Reservierung des Keywords und Spezifikation der Parameter) spezifiziert. Beim Aufbau einer Achse ergibt sich der Algorithmus also durch eine entsprechende Referenz (<SW-AXIS-TYPE-REF>).
  • Die Anzahl der zu berechnenden Stützstellen wird in <SW-NUMER-OF-AXIS-POINTS> definiert. Um die Anzahl der Achsenpunkte explizit zu speichern, ist dieses Element vorhanden, obwohl man es auch als <SW-GENERIC-AXIS-PARAM> beschreiben könnte.
  • Im Element <SW-VALUES-PHYS> können die berechneten Stützstellen auf physikalischer Ebene abgelegt werden, so daß nicht jedes MCD-System den erforderlichen Berechnungsalgorithmus implementiert haben muß.
  • Im Element <SW-VALUES-CODED> können die berechneten Stützstellen auf normierter Ebene abgelegt werden, so daß nicht jedes MCD-System den erforderlichen Berechnungsalgorithmus implementiert haben muß.
Example
<SW-AXIS-TYPE ID="ID72ED69DFrad6E82E">
   <SHORT-NAME>shiftOffset</SHORT-NAME>
   <SW-GENERIC-AXIS-DESC>
      <P>This is an axis with shift and offset.</P>
   </SW-GENERIC-AXIS-DESC>

   <SW-GENERIC-AXIS-PARAM-TYPES>
      <SW-GENERIC-AXIS-PARAM-TYPE ID="ID72ED69DFradCBCED">
         <SHORT-NAME>shift</SHORT-NAME>
      </SW-GENERIC-AXIS-PARAM-TYPE>

      <SW-GENERIC-AXIS-PARAM-TYPE ID="ID72ED69DFrad723A8">
         <SHORT-NAME>offset</SHORT-NAME>
      </SW-GENERIC-AXIS-PARAM-TYPE>
   </SW-GENERIC-AXIS-PARAM-TYPES>
</SW-AXIS-TYPE>
<SW-CALPRM ID="IDB7E2463rad21A0A">
   <SHORT-NAME>Festkl</SHORT-NAME>
   <SW-DATA-DEF-PROPS>
      <SW-CALPRM-AXIS-SET>
         <SW-CALPRM-AXIS>
            <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
            <SW-AXIS-INDIVIDUAL>
               <SW-AXIS-GENERIC>
                  <SW-AXIS-TYPE-REF ID-REF="ID72ED69DFrad6E82E">ShiftOffset</SW-AXIS-TYPE-REF>
               </SW-AXIS-GENERIC>
            </SW-AXIS-INDIVIDUAL>
         </SW-CALPRM-AXIS>
      </SW-CALPRM-AXIS-SET>
   </SW-DATA-DEF-PROPS>
</SW-CALPRM>

<SW-CALPRM ID="IDB7E2463rad21A0A">
   <SHORT-NAME>Festkl</SHORT-NAME>
   <SW-DATA-DEF-PROPS>
      <SW-CALPRM-AXIS-SET>
         <SW-CALPRM-AXIS>
            <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
            <SW-AXIS-INDIVIDUAL>
               <SW-AXIS-GENERIC>
                  <SW-AXIS-TYPE-REF ID-REF="ID72ED69DFrad6E82E">ShiftOffset</SW-AXIS-TYPE-REF>
               </SW-AXIS-GENERIC>
            </SW-AXIS-INDIVIDUAL>
         </SW-CALPRM-AXIS>
      </SW-CALPRM-AXIS-SET>
   </SW-DATA-DEF-PROPS>
</SW-CALPRM>
Formale Beschreibung
Hat als Kontext: | SW-AXIS-INDIVIDUAL
Ist Kontext für: | SW-AXIS-TYPE-REF, SW-NUMBER-OF-AXIS-POINTS, SW-GENERIC-AXIS-PARAMS, SW-VALUES-PHYS, SW-VALUES-CODED
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.237. SW-AXIS-GROUPED

Beschreibung
Als Alternative zu <SW-AXIS-INDIVIDUAL> wird in <SW-AXIS-GROUPED> eine Gruppenachse beschrieben. Eine Gruppenachse wird spezifiziert durch
  • den Verweis (<SW-CALPRM-REF>) auf den Parameter, von dem eine Achse importiert werden soll , welche als Gruppenachse dient
  • der Index der zu verwendenden Achse (<SW-AXIS-INDEX>). Dieser Index ist nur anzugeben, falls der unter <SW-CALPRM-REF> Parameter mehr als eine Achse enthält. Für Parameter mit mehr als einer Achse wird standardmäßig der Achsenindex auf 1 gesetzt, falls <SW-AXIS-INDEX> nicht bedatet ist.
  • Ist SW-AXIS-INDEX gleich 0, so wird das Interpolationsergebnis des referenzierten Parameters als Stützstellenindex verwendet. Damit kann das aus USA neu angeforderte Keyword CURVE_AXIS_REF unterstützt werden.
Formale Beschreibung
Hat als Kontext: | SW-CALPRM-AXIS
Ist Kontext für: | SW-AXIS-INDEX, SW-CALPRM-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.238. SW-AXIS-INDEX
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
<SW-AXIS-INDEX> beschreibt den Index der aktuell beschriebenen Achse für den der Inhalt spezifiziert wird. Der Index genügt folgeder Konvention:
0: | Dies ist die Werte-Achse einer Kennlinie oder eines Kennfeldes.
1: | Dies ist die X-Achse einer Kennlinie oder eines Kennfeldes.
2: | Dies ist die Y-Achse eines Kennfeldes.
3: | Dies ist die Z-Achse eines Kuboids
Example
Siehe SW-ARRAY-INDEX 1.407. SW-INSTANCE SW-INSTANCE SW-INSTANCE.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-CONT, SW-AXIS-GROUPED, SW-CALPRM-AXIS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.239. SW-AXIS-INDIVIDUAL

Beschreibung
Dieses Element beschreibt eine in einen Parameter (-Feld etc.) eingebettete Achse. Diese ist durch die Einbettung parameterindividuell. Das Gegenstück hierzu ist die sogenannte Gruppenachse, welche als eigenständiger Parameter angelegt ist und von den jeweiligen diese verwendenden Parametern referenziert wird (<SW-CALPRM-REF> innerhalb von <SW-AXIS-GROUPED>).
Die Spezifikation dieser Achse umfaßt:
  • Mögliche Eingangsvariablen für die Achse (<SW-VARIABLE-REFS>).
    Es ist möglich, mehr als eine Variable anzugeben. Dafür gilt:
    • Die Variable mit der höchsten Prilorität muß als erstes angegeben werden. Sie wird dann bei der Codegenerierung verwendet und auch im Applikationssystem als erstes angezeigt.
    • Alle referenzierten Variablen müssen von der gleichen physikalischen Natur sein. In der Regel wird dies daran erkannt, daß die betroffenen Umrechnungsformeln sich auf die gleichen SI-Einheiten (<SI-UNIT>s) zurückführen lassen.
    • Diese Mehrfachreferenzierung erlaubt es, eine Stützstellenverteilung für mehr als eine Eingangsgröße zu verwenden. Beispiel hierfür sind Temperaturkennlinien, die sowohl von der Ansauglufttemperatur als auch von der Motortemperatur abhängen können.
      MCD-Systeme (Verstellsysteme) können diese Variablen simultan anzeigen, um Arbeitspunkte in Kennlinien darzustellen.
  • eine Umrechnungsformel (<SW-COMPU-METHOD-REF>)
  • eine Maßeinheit (<SW-UNIT-REF>)
  • eine Bit-Repräsentation (<SW-BIT-REPRESENTATION>)
  • Anzahl maximaler und minimaler Achsenstützstellen (<SW-MAX-AXIS-POINTS>, <SW-MIN-AXIS-POINTS>)
  • Plausibilitätskontrollen (<SW-DATA-CONSTR-REF>)
  • Eigenschaften der generischen Achse (<SW-AXIS-GENERIC>), falls es sich um eine solche handelt.
Die Angaben <SW-VARIABLE-REFS>, <SW-COMPU-METHOD-REF>, <SW-UNIT-REF> können parallel bestehen, obwohl nur eine physikalisch sinnvoll ist. Diese Parallelität erlaubt eine Flexibilität im Entwicklungsprozeß, weil Achsen rein physikalisch beschrieben werden können, ohne daß schon eine Umrechnungsformel vorliegt.
Es gibt folgende Priorität:
  1. <SW-VARIABLE-REFS>
  2. <SW-COMPU-METHOD-REF>
  3. <SW-UNIT-REF>
Formale Beschreibung
Hat als Kontext: | SW-CALPRM-AXIS
Ist Kontext für: | SW-VARIABLE-REFS, SW-COMPU-METHOD-REF, SW-UNIT-REF, SW-BIT-REPRESENTATION, SW-MAX-AXIS-POINTS, SW-MIN-AXIS-POINTS, SW-DATA-CONSTR-REF, SW-AXIS-GENERIC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.240. SW-AXIS-TYPE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Reserves names for specific axis computing strategies. For the reason that arbitrary algorithms for computing axis-points are possible, no formal specification is given. Instead, the algorithm is described verbally; the parameters (<SW-GENERIC-AXIS-PARAM-TYPES>) are specified formally with respect to their name and constraints. Thus, <SW-AXIS-TYPE> mainly reserves appropriate keywords.
Example
<SW-AXIS-TYPES>
   <SW-AXIS-TYPE>
      <LONG-NAME>ACHENSTYP FÜR KENNWERTEBLOCK, UM ANZAHL DARSTELLEN ZU KÖNNEN</LONG-NAME>
      <SHORT-NAME>KWB</SHORT-NAME>
   </SW-AXIS-TYPE>
</SW-AXIS-TYPES>
Formale Beschreibung
Hat als Kontext: | SW-AXIS-TYPES
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-GENERIC-AXIS-DESC, SW-GENERIC-AXIS-PARAM-TYPES
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-AXIS-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.241. SW-AXIS-TYPE-REF

Beschreibung
Dieses Element referenziert ein Element <SW-AXIS-TYPE>.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-GENERIC, SW-AXIS-TYPE-REFS
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-AXIS-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.242. SW-AXIS-TYPE-REFS

Beschreibung
Container Element für <SW-AXIS-TYPE-REF>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-CONT
Ist Kontext für: | SW-AXIS-TYPE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.243. SW-AXIS-TYPES

Beschreibung
Container zur Beschreibung aller im System definierten generischen Achsen.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DICTIONARY-SPEC
Ist Kontext für: | ADMIN-DATA, SW-AXIS-TYPE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.244. SW-BASE-ADDR
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element gibt die Basisadresse eines Speicherobjektes an.
Example
Siehe SW-ADDR-INFO
Formale Beschreibung
Hat als Kontext: | SW-ADDR-INFO
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.245. SW-BASE-TYPE

Beschreibung
A <SW-BASE-TYPE> is used by variables, parameters and record layouts. In <SW-RECORD-LAYOUT> , a <SW-BASE-TYPE> can be referenced/used by using the element <SW-BASE-TYPE-REF>. This denotes how the object in question, denoted by the container (<SW-VARIABLE> or <SW-CALPRM> ) of <SW-DATA-DEF-PROPS>, is stored in the memory of the ECU.
Formale Beschreibung
Hat als Kontext: | SW-BASE-TYPES
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-BASE-TYPE-SIZE, SW-CODED-TYPE, SW-MEM-ALIGNMENT, BYTE-ORDER, SW-BASE-TYPE-REF
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-BASE-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.246. SW-BASE-TYPE-REF

Beschreibung
Dieses Element referenziert auf das Element <SW-BASE-TYPE>.
Formale Beschreibung
Hat als Kontext: | SW-BASE-TYPE, SW-BASE-TYPE-REFS, SW-CALPRM-AXIS, SW-CALPRM-TEXT, SW-DATA-DEF-PROPS, SW-MC-BASE-TYPE, SW-RECORD-LAYOUT-V
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-BASE-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.247. SW-BASE-TYPE-REFS

Beschreibung
Container Element für <SW-BASE-TYPE-REF>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-CONT
Ist Kontext für: | SW-BASE-TYPE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.248. SW-BASE-TYPE-SIZE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Beschreibt die Länge des im Container (<SW-BASE-TYPE> oder <SW-MC-BASE-TYPE>) spezifizierten Datentyps in Bits. Bei Verwendung innerhalb von <SW-CPU-SPEC> spezifiziert diese Angabe die Wortlänge der CPU.
Example
<SW-BASE-TYPE>
   <SHORT-NAME>LONG<SHORT-NAME>
         <SW-BASE-TYPE-SIZE>32</SW-BASE-TYPE-SIZE>
      </SHORT-NAME></SHORT-NAME>
</SW-BASE-TYPE>
Formale Beschreibung
Hat als Kontext: | SW-BASE-TYPE, SW-CPU-SPEC, SW-MC-BASE-TYPE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.249. SW-BASE-TYPES

Beschreibung
Container Elemtent für <SW-BASE-TYPE>. Zusätzlich können administrative Daten in <ADMIN-DATA> angegeben werden.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DICTIONARY-SPEC
Ist Kontext für: | ADMIN-DATA, SW-BASE-TYPE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.250. SW-BIT-REPRESENTATION
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Beschreibung des Aufbaus einer Bitgröße: setzt sich zusammen aus der Bitposition <BIT-POSITION> in einem Speicherobjekt (z.B. Hostvariable <SW-HOST-VARIABLE>, welche parallel zu <SW-BIT-REPRESENTATION> steht) und der Größe in Bits <NUMBER-OF-BITS>. Damit lassen sich zusammenhängende Speicherbereiche beschreiben. Nicht zusammenhängende Speicherbereiche werden nicht unterstützt.
Example
<SW-VARIABLE ID="ID01">
   <LONG-NAME>Variable_01</LONG-NAME>
   <SHORT-NAME>Variable_01</SHORT-NAME>
   <SW-DATA-DEF-PROPS>
      <SW-ADDR-METHOD-REF>defaultAdrS</SW-ADDR-METHOD-REF>
      <SW-BASE-TYPE-REF ID-REF="UWORD">UWORD</SW-BASE-TYPE-REF>
      <SW-COMPU-METHOD-REF ID-REF="B-TRUE">B-TRUE</SW-COMPU-METHOD-REF>
      <SW-DISPLAY-FORMAT>%13.11</SW-DISPLAY-FORMAT>
   </SW-DATA-DEF-PROPS>
</SW-VARIABLE>

<SW-VARIABLE ID="ID02">
   <LONG-NAME></LONG-NAME>
   <SHORT-NAME>Variable_02</SHORT-NAME>
   <SW-DATA-DEF-PROPS>
      <SW-ADDR-METHOD-REF>defaultAdrS</SW-ADDR-METHOD-REF>
      <SW-BASE-TYPE-REF ID-REF="UBIT">UBIT</SW-BASE-TYPE-REF>
      <SW-BIT-REPRESENTATION>
         <BIT-POSITION>5</BIT-POSITION>
         <NUMBER-OF-BITS>1</NUMBER-OF-BITS>
      </SW-BIT-REPRESENTATION>
      <SW-CALIBRATION-ACCESS>CALIBRATION</SW-CALIBRATION-ACCESS>
      <SW-CODE-SYNTAX-REF>Bit</SW-CODE-SYNTAX-REF>
      <SW-COMPU-METHOD-REF>B_TRUE</SW-COMPU-METHOD-REF>
      <SW-HOST-VARIABLE>
         <SW-VARIABLE-REF>Variable_01</SW-VARIABLE-REF>
      </SW-HOST-VARIABLE>
   </SW-DATA-DEF-PROPS>
</SW-VARIABLE>
Formale Beschreibung
Hat als Kontext: | SW-AXIS-INDIVIDUAL, SW-DATA-DEF-PROPS
Ist Kontext für: | BIT-POSITION, NUMBER-OF-BITS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.251. SW-CALIBRATION-ACCESS

Beschreibung
Beschreibt die Applizierbarkeit von Parametern und Variablen. Gültige Werte sind:
  • CALIBRATION: applizierbar
  • NO-CALIBRATION: nicht applizierber
  • NOT-IN-MEMORY: nicht im EPROM (nicht für Variablen)
  • ADAPTIVE: adaptive Kenngrößen (nicht für Variablen)
Formale Beschreibung
Hat als Kontext: | SW-CALPRM-AXIS, SW-DATA-DEF-PROPS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.252. SW-CALIBRATION-HANDLE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt spezifische Parameter für die im Container angegebene Kalibriermethode. Der Inhalt dieses Elementes ist abhängig von dieser Methode und nicht allgemein definierbar.
Example
<SW-CALIBRATION-METHOD>
   <SHORT-NAME>InCircuit</SHORT-NAME>
   <SW-CALIBRATION-METHOD-VERSIONS>
      <SW-CALIBRATION-METHOD-VERSION>
         <LABEL>V2</LABEL>
         <SW-CALIBRATION-HANDLE>
            <VF>0x10000</VF>
            <VF>0x200</VF>
            <VF>0x4</VF>
            <VF>0x30000</VF>
            <VF>0x20000</VF>
         </SW-CALIBRATION-HANDLE>
      </SW-CALIBRATION-METHOD-VERSION>
   </SW-CALIBRATION-METHOD-VERSIONS>
</SW-CALIBRATION-METHOD>
Formale Beschreibung
Hat als Kontext: | SW-CALIBRATION-METHOD-VERSION
Ist Kontext für: | VF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.253. SW-CALIBRATION-METHOD
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
This element is used to indicate the different methods of access that are implemented in the ECU and that can be used regardless of the actual interface of the ECU.
The <SHORT-NAME> identifies the calibration method to be used. A convention regarding the meaning of the calibration methods must be agreed upon between the involved parties. The following strings are already in use: "InCircuit", "SERAM", "DSERAP", "BSERAP"
The actual parameters for the calibration method are specified in <SW-CALIBRATION-HANDLE>.
Example
Siehe SW-CALIBRATION-HANDLE
Formale Beschreibung
Hat als Kontext: | SW-CALIBRATION-METHODS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-CALIBRATION-METHOD-VERSIONS, ADD-INFO
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | Zeichenkette (CDATA) | SW-CALIBRATION-METHOD | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.254. SW-CALIBRATION-METHOD-SPEC

Beschreibung
Dieses Element beschreibt die Methoden, über die die verschiedenen Applikationssysteme auf das Steuergerät zugreifen können. Es können mehrere Methoden gleichzeitig implementiert sein, welche ihrerseits in mehreren Versionen vorliegen (<SW-CALIBRATION-METHOD-VERSION>) können.
Formale Beschreibung
Hat als Kontext: | SW-SYSTEM
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-CALIBRATION-METHODS, ADD-INFO
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.255. SW-CALIBRATION-METHOD-VERSION

Beschreibung
Dieses Element beschreibt eine spezifische Version einer Applikationsmethode. Die Versionsnummer wird in <LABEL> angegeben.
Formale Beschreibung
Hat als Kontext: | SW-CALIBRATION-METHOD-VERSIONS
Ist Kontext für: | LABEL, SW-CALIBRATION-HANDLE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.256. SW-CALIBRATION-METHOD-VERSIONS

Beschreibung
Container Element für <SW-CALIBRATION-METHOD-VERSION>.
Formale Beschreibung
Hat als Kontext: | SW-CALIBRATION-METHOD
Ist Kontext für: | SW-CALIBRATION-METHOD-VERSION
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.257. SW-CALIBRATION-METHODS

Beschreibung
Container Element für <SW-CALIBRATION-METHOD>.
Formale Beschreibung
Hat als Kontext: | SW-CALIBRATION-METHOD-SPEC
Ist Kontext für: | SW-CALIBRATION-METHOD
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.258. SW-CALPRM
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element spezifiziert die Eigenschaften von Kalibrierparametern im Steuergerät. Kalibrierparameter sind Objekte die zur Laufzeit des Fahrzeugs nicht verändert werden. Sie werden vielmehr in der Applikationsphase kalibriert. Im Gegensatz dazu sind Variablen (<SW-VARIABLE>s) Objekte, die zur Laufzeit von der Software manipuliert werden.
Kalibrierparameter bestehen im wesentlichen aus:
  • Lang- und Kurzbezeichner (<LONG-NAME>, <SHORT-NAME>)
  • Kurzbeschreibung (<DESC>)
  • Kategorie (<CATEGORY>), welche die Grundstruktur des Parameters beschreibt
  • Feldgrößen (<SW-ARRAYSIZE>), falls der Parameter als Array ausgeführt ist
  • die technischen Eigenschaften (<SW-DATA-DEF-PROPS>)
  • Unterstrukturen, die durch Verschachtelung von <SW-CALPRMS> modelliert werden.
  • Anmerkungen (<ANNOTATIONS>), die es erlauben, Notizen im Entwicklungsprozeß von Schritt zu Schritt weiterzureichen
  • Zusatzinformationen (<ADD-INFO>) in verbaler Form. Dabei können unter Verwendung von [SI]-Attributen auch formale Anteile untergebracht werden.
Belegung von <CATEGORY>
Value | Meaning | Remark
VALUE | Characteristic value | This represents a single value.
CURVE_INDIVIDUAL | Characteristic | This represents a curve with an embedded axis.
MAP_INDIVIDUAL | Map | This represents a map with embedded axes.
CURVE_FIXED | Fixed characteristic | This represents a curve of which the axis are calculated by the ecu-program. The algorithm is fixed and therefore the axis-points can not be calibrated. Sometimes the parameters of the algorithm might be specified by applying <SW-AXIS-GENERIC>.
MAP_FIXED | Fixed map | This represents a map of which the axes are calculated by the ecu-program. The algorithm is fixed and therefore the axis-points can not be calibrated. Sometimes the parameters of the algorithm might be specified by applying <SW-AXIS-GENERIC>.
CURVE_GROUPED | Group characteristic | This represents a curve which uses the axis-points of another calibration parameter which is then referred to by <SW-CALPRM-REF> in <SW-AXIS-GROUPED>.
MAP_GROUPED | Group map | This represents a map which uses the axis-points of another calibration parameter which is then referred to by <SW-CALPRM-REF> in <SW-AXIS-GROUPED>.
ASCII | Characteristic text | This represents a parameter which is text (e.g. a message).
STRUCTURE | Parameter structure | This represents a structure of calibration parameters. In this case, a nested <SW-CALPRM> should exist.
VALUE_BLOCK | Characteristic values block | This represents a homogeneous set of parameters which are handled as a block. In opposite to structures or arrays, the components of a value block appear whithin one particular <SW-INSTANCE> in the instance tree.
AXIS_VALUES | Group datapoints | This represents the axis points of a calibration parameter which are referenced in <SW-AXIS-GROUP> by a calibration parameter which is of category MAP_GROUPED or CURVE_GROUPED.
Example
The next example illustrates a single value.
 <sw-calprm id="ABGMSIGH"> <long-name>threshold for exh. temp. for wiring-interruption with Ri-diagnosis downstr. ca</long-name> <short-name>ABGMSIGH</short-name> <category>VALUE</category> <sw-data-def-props> <sw-compu-method-ref id-ref="TEMP-UB-Q5-O50">temp_ub_q5_o50</sw-compu-method-ref> <sw-data-constr-ref id-ref="DC-ABGMSIGH">DC-ABGMSIGH</sw-data-constr-ref> <sw-display-format>%5.0</sw-display-format> <sw-record-layout-ref id-ref="KWUB">KWUB</sw-record-layout-ref> </sw-data-def-props> </sw-calprm>
The next example illustrates a map.
 <SW-CALPRM ID="FKKVS">
   <LONG-NAME>factor to correct fuel delivary system</LONG-NAME>
   <SHORT-NAME>FKKVS</SHORT-NAME>
   <DESC></DESC>
   <CATEGORY>MAP</CATEGORY>
   <SW-DATA-DEF-PROPS>
      <SW-CALIBRATION-ACCESS>CALIBRATION</SW-CALIBRATION-ACCESS>
      <SW-CALPRM-AXIS-SET>
         <SW-CALPRM-AXIS>
            <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
            <SW-AXIS-INDIVIDUAL>
               <SW-VARIABLE-REFS>
                  <SW-VARIABLE-REF ID-REF="NMOT">NMOT</SW-VARIABLE-REF>
               </SW-VARIABLE-REFS>
               <SW-MAX-AXIS-POINTS>16</SW-MAX-AXIS-POINTS>
            </SW-AXIS-INDIVIDUAL>
         </SW-CALPRM-AXIS>
         <SW-CALPRM-AXIS>
            <SW-AXIS-INDEX>2</SW-AXIS-INDEX>
            <SW-AXIS-INDIVIDUAL>
               <SW-VARIABLE-REFS>
                  <SW-VARIABLE-REF ID-REF="TEVFA-W-KGE">TEVFA-W-KGE</SW-VARIABLE-REF>
               </SW-VARIABLE-REFS>
               <SW-MAX-AXIS-POINTS>16</SW-MAX-AXIS-POINTS>
            </SW-AXIS-INDIVIDUAL>
         </SW-CALPRM-AXIS>
      </SW-CALPRM-AXIS-SET>
      <SW-COMPU-METHOD-REF ID-REF="FAK-UW-B2">FAK-UW-B2</SW-COMPU-METHOD-REF>
      <SW-DATA-CONSTR-REF ID-REF="DC-FKKVS">DC-FKKVS</SW-DATA-CONSTR-REF>
      <SW-DISPLAY-FORMAT>%8.6</SW-DISPLAY-FORMAT>
      <SW-INTERPOLATION-METHOD>linear</SW-INTERPOLATION-METHOD>
      <SW-RECORD-LAYOUT-REF ID-REF="SIMPLE-MAP">SIMPLE-MAP</SW-RECORD-LAYOUT-REF>
   </SW-DATA-DEF-PROPS>
</SW-CALPRM>
Formale Beschreibung
Hat als Kontext: | SW-CALPRMS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-ARRAYSIZE, SW-DATA-DEF-PROPS, SW-CALPRMS, ANNOTATIONS, ADD-INFO
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-CALPRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-CALPRM | Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')

Conforms to ASAP
Diese sind identisch mit den technischen Eigenschaften von Variablen


1.259. SW-CALPRM-AXIS

Beschreibung
Dieses Element spezifiziert eine einzelne Eingangsparameter-Achse (Abszisse). Hierzu gehört:
  • Um welche Achse es sich handelt (<SW-AXIS-INDEX>)
  • Ob die Achse eingebettet (<SW-AXIS-INDIVIDUAL>) oder von einem anderen Parameter übernommen wird (<SW-AXIS-GROUPED>).
  • Ob die Achse applizierbar ist (<SW-CALIBRATION-ACCESS>).
  • Welches Anzeigeformat für diese Achse gelten soll (<SW-DISPLAY-FORMAT>).
  • Welcher Basistyp für diese Achse gelten soll (<SW-BASE-TYPE-REF>).
Formale Beschreibung
Hat als Kontext: | SW-CALPRM-AXIS-SET
Ist Kontext für: | SW-AXIS-INDEX, SW-AXIS-INDIVIDUAL, SW-AXIS-GROUPED, SW-CALIBRATION-ACCESS, SW-DISPLAY-FORMAT, SW-BASE-TYPE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.260. SW-CALPRM-AXIS-SET

Beschreibung
Dieses Element spezifiziert die Eingangsparameter-Achsen (-Abszissen) von Parametern (und Variablen, falls diese adaptiv genutzt werden).
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | SW-CALPRM-AXIS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.261. SW-CALPRM-IMPL
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt die Implementierungsdetails eines Klassenattributes, welches sich als Kalibrierparameter manifestiert.
Example
Siehe SW-CLASS
Formale Beschreibung
Hat als Kontext: | SW-CALPRM-IMPLS
Ist Kontext für: | SW-CALPRM-PROTOTYPE-REF, SW-DATA-DEF-PROPS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.262. SW-CALPRM-IMPLS

Beschreibung
Container Element für <SW-CALPRM-IMPL>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS-ATTR-IMPL
Ist Kontext für: | SW-CALPRM-IMPL
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.263. SW-CALPRM-MAX-TEXT-SIZE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Maximale Länge eines Textparameters in Zeichen.
Example
siehe SW-CALPRM-TEXT
Formale Beschreibung
Hat als Kontext: | SW-CALPRM-TEXT
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.264. SW-CALPRM-NO-EFFECT-VALUE

Beschreibung
Dieses Element beschreibt den Wert, auf den der Parameter eingestellt werden muß, damit er ohne Wirkung bleibt.
Dies wird z.B. verwendet, wenn im Steuergerät neue Parameter eingeführt worden sind, die noch nicht appliziert werden konnten. Durch Einstellen auf den <SW-CALPRM-NO-EFFECT-VALUE> kann so die Software kompatibel zu einer Vorgängerversion betrieben werden.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.265. SW-CALPRM-POINTER

Beschreibung
<SW-CALPRM-POINTER> indiziert, dass das Datenobjekt (z.B. <SW-CALPRM>, <SW-VARIABLE>) einen Verweis auf ein anderes Datenobjekt aufnimmt. Die Art der Zielobjekte wird über einen Verweis auf ein Template bzw. auf eine Klasse bestimmt.
Example
<SW-CALPRM>
   <SHORT-NAME>Testpointer</SHORT-NAME>
   <CATEGORY>POINTER</CATEGORY>
   <SW-DATA-DEF-PROPS>
      <SW-CALPRM-POINTER>
         <SW-TEMPLATE-REF>TEMP</SW-TEMPLATE-REF>
         <DESC>Dieses Element soll Verweise auf Temperaturwerter
               aufnehmen.</DESC>
      </SW-CALPRM-POINTER>
   </SW-DATA-DEF-PROPS>
</SW-CALPRM>
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | SW-TEMPLATE-REF, SW-CLASS-ATTR-IMPL-REF, DESC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes


1.266. SW-CALPRM-PROTOTYPE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt die Prototyp-Deklaration eines Klassenattributes, welcher als Kalibrationsparameter verwendet wird.
Example
Siehe SW-CLASS
Formale Beschreibung
Hat als Kontext: | SW-CALPRM-PROTOTYPES
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-ARRAYSIZE, SW-SYSCOND, ANNOTATIONS, ADD-INFO
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | Zeichenkette (CDATA) | SW-CALPRM-PROTOTYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.267. SW-CALPRM-PROTOTYPE-REF

Beschreibung
Durch dieses Element wird ein <SW-CALPRM-PROTOTYPE> referenziert.
Formale Beschreibung
Hat als Kontext: | SW-CALPRM-IMPL
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-CALPRM-PROTOTYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.268. SW-CALPRM-PROTOTYPES

Beschreibung
Container Element für <SW-CALPRM-PROTOTYPE>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS-ATTR
Ist Kontext für: | SW-CALPRM-PROTOTYPE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.269. SW-CALPRM-REF

Beschreibung
Durch dieses Element wird ein <SW-CALPRM> referenziert.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-GROUPED, SW-CALPRM-REF-SYSCOND, SW-CALPRM-REFS, SW-CONSTR-OBJECTS, SW-DATA-DEPENDENCY-ARGS, SW-FEATURE-EXPORT-CALPRMS, SW-FEATURE-IMPORT-CALPRMS, SW-FEATURE-LOCAL-PARAMS, SW-VCD-CRITERION
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-CALPRM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.270. SW-CALPRM-REF-SYSCOND
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element ist eine bedingte Referenz auf einen Kalibrierparameter. Dieses wird verwendet, um die Zuordnung von Kalibrierparametern zu Funktionen abhängig zu machen von Systemkonstanten-Einstellungen. Deshalb existiert das Element parallel zu <SW-CALPRM-REF>.
Example
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-EXPORT-CALPRMS, SW-FEATURE-IMPORT-CALPRMS, SW-FEATURE-LOCAL-PARAMS
Ist Kontext für: | SW-CALPRM-REF, SW-SYSCOND
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.271. SW-CALPRM-REFS

Beschreibung
Container Element für <SW-CALPRM-REF>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-CONT
Ist Kontext für: | SW-CALPRM-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.272. SW-CALPRM-TARGET

Beschreibung
In manchen Systemen wird das Ergebnis einer Stützstellensuche (Gruppenachse) bzw. einer Interpolation über einen Parameter in Variablen zwischengespeichert. Dazu dient <SW-CALPRM-TARGET>, welches eine Referenz auf die als Zwischenspeicher dienende Variable enthält.
Das Element etabliert eine 1:1-Beziehung zwischen der referenzierten Variablen und den übergeordneten <SW-DATA-DEF-PROPS> bzw. dessen Vaterelement. Insoweit wäre es überflüssig, da diese direkt adressierbar wäre. Jedoch dient SW-CALPRM-TARGET dazu, die Semantik des Verweises explizit auszudrücken.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | SW-VARIABLE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.273. SW-CALPRM-TEXT

Beschreibung
SW-CALPRM-TEXT spezifiziert textuelle Parameter im Steuergerät. Hierfür muß definiert werden:
  • die maximale Länge des Textes
  • die Füllzeichen für Texte, die kürzer als die maximale zulässige Textlänge sind
  • den Basistyp für jedes Zeichen des Textstrings <SW-BASE-TYPE-REF>, wird verwendet, um die Stringcodierung zu beschreiben
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | SW-CALPRM-MAX-TEXT-SIZE, SW-BASE-TYPE-REF, SW-FILL-CHARACTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.274. SW-CALPRM-VALUE-AXIS-LABELS

Beschreibung
Dieses Element dient zur Aufnahme von textuellen Achsenwertbeschreibungen und ist aus Gründen der Rückwärtskompatibilität zu ASAP1.4 enthalten.
In neuen Systemen sollte die Verwendung über Umrechnungsformeln realisisert werden.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | LABEL
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.275. SW-CALPRMS

Beschreibung
Container Element für <SW-CALPRM>.
Formale Beschreibung
Hat als Kontext: | SW-CALPRM, SW-DATA-DICTIONARY-SPEC
Ist Kontext für: | ADMIN-DATA, SW-CALPRM
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.276. SW-CARB-DOC

Beschreibung
Dieses Element nimmt die von CARB spezifisch geforderte Dokumentation auf.
Formale Beschreibung
Hat als Kontext: | SW-CLASS, SW-FEATURE
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.277. SW-CLASS
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
A <SW-CLASS> enables the object-oriented programming paradigm. A class may provide multiple implementations. In MSRSW.DTD, this primarily covers the implementation of variables and parameters which come from the instantiation of this class. A <SW-CLASS> therefore contains optionally 1 to n <SW-CLASS-ATTR-IMPLS> each of which representing a particular implementation of a class. A <SW-CLASS> contains 0 to n <SW-CLASS-ATTR> s attributes. This is merely the list of variables, parameters and objects which will be established by the instantiation of the class. This is one of the reasons that we need an <SW-INSTANCE-TREE> . A <SW-CLASS> contains 0 to n <SW-CLASS-METHOD> s .each of which representing a particular method of a class. The methods are described informally. This branch is bound to future extensions.
Classes are instantiated within the data dictionaries, either the global one or within a feature. Therefore a <SW-CLASS-INSTANCE> in a Data Dictionary has a refer-ence to a . This represents a particular instance of a . The contents of this element superseed the contents of the referenced <SW-CLASS> thus defining the particular implementation.
Example
The following example illustrates a small system comprising of one class with three instances utilizing different implementations. The one class has a component which itself is a class thus demonstrating nested classes. The example is complete in that sense that all referenced objects are there.
<MSRSW PUBID      ="-//MSR//DTD MSR SOFTWARE DTD:V2.2.2:MSRSW.DTD//EN"
       F-PUBID    ="-//MSR//DTD MSR SOFTWARE DTD:V2.2.2:MSRSW.DTD//EN"
       F-NAMESPACE="CHAPTER COMPANY DEF-ITEM EXTERNAL FIGURE FORMULA PRM REQUIREMENT SAMPLE
                    STD SW-ADDR-METHOD SW-AXIS-TYPE SW-BASE-TYPE SW-CALPRM SW-CALPRM-PROTOTYPE
                    SW-CLASS-PROTOTYPE SW-CLASS-ATTR-IMPL SW-CLASS-INSTANCE SW-CLASS SW-CODE-SYNTAX
                    SW-COLLECTION SW-COMPU-METHOD SW-CPU-MEM-SEG SW-DATA-CONSTR SW-FEATURE
                    SW-GENERIC-AXIS-PARAM-TYPE SW-INSTANCE-TREE SW-INSTANCE SW-MC-BASE-TYPE
                    SW-MC-INTERFACE-SOURCE SW-MC-INTERFACE SW-RECORD-LAYOUT SW-SYSTEMCONST SW-SYSTEM
                    SW-TASK SW-TEMPLATE SW-UNIT SW-USER-ACCESS-CASE SW-USER-GROUP SW-VARIABLE-PROTOTYPE
                    SW-VARIABLE SW-VCD-CRITERION TABLE TEAM-MEMBER TOPIC VARIANT-DEF VARIANT-CHAR XDOC XFILE"
       HYTIME     ="HYDOC">

   <SW-SYSTEMS>
      <SW-SYSTEM ID         ="ID49163FEDRADCE418"
                 F-ID-CLASS ="SW-SYSTEM"
                 F-NAMESPACE="SW-ADDR-METHOD SW-AXIS-TYPE SW-BASE-TYPE SW-CALPRM SW-CALPRM-PROTOTYPE
                              SW-CLASS-PROTOTYPE SW-CLASS-ATTR-IMPL SW-CLASS-INSTANCE SW-CLASS SW-CODE-SYNTAX
                              SW-COLLECTION SW-COMPU-METHOD SW-CPU-MEM-SEG SW-DATA-CONSTR SW-FEATURE
                              SW-GENERIC-AXIS-PARAM-TYPE SW-INSTANCE-TREE SW-INSTANCE SW-RECORD-LAYOUT
                              SW-SYSTEMCONST SW-TASK SW-TEMPLATE SW-UNIT SW-USER-ACCESS-CASE SW-USER-GROUP
                              SW-VARIABLE-PROTOTYPE SW-VARIABLE SW-VCD-CRITERION">
         <LONG-NAME>
            <L-4 L="">Demonstrator für Klassen</L-4>
         </LONG-NAME>
         <SHORT-NAME>ClassDemo</SHORT-NAME>
         <SW-DATA-DICTIONARY-SPEC></SW-DATA-DICTIONARY-SPEC>
      </SW-SYSTEM>
   </SW-SYSTEMS>
</MSRSW>
Here we define the required measurement units:
 <SW-UNITS>
   <SW-UNIT ID        ="ID4F1ADF2DRAD46366"
            F-ID-CLASS="SW-UNIT">
      <SHORT-NAME>rpm</SHORT-NAME>
      <SI-UNIT><?xm-replace_text {SI-UNIT}></SI-UNIT>
   </SW-UNIT>

   <SW-UNIT ID        ="ID4F1ADF2DRADC299F"
            F-ID-CLASS="SW-UNIT">
      <SHORT-NAME>gradkw</SHORT-NAME>
      <SI-UNIT><?xm-replace_text {SI-UNIT}></SI-UNIT>
   </SW-UNIT>

   <SW-UNIT ID        ="ID4F1AE136RAD07900"
            F-ID-CLASS="SW-UNIT">
      <SHORT-NAME>ms</SHORT-NAME>
      <SW-UNIT-CONVERSION-METHOD>
         <SW-UNIT-GRADIENT>1000</SW-UNIT-GRADIENT>
         <SW-UNIT-OFFSET>0</SW-UNIT-OFFSET>
      </SW-UNIT-CONVERSION-METHOD>
      <SI-UNIT TIME-EXPO="1"><?xm-replace_text {SI-UNIT}></SI-UNIT>
   </SW-UNIT>
</SW-UNITS>
Here we have global class instances. Note that the class itself is specified later.
 <SW-CLASS-INSTANCES>
   <SW-CLASS-INSTANCE ID        ="ID49163FECRADA984D"
                      F-ID-CLASS="SW-CLASS-INSTANCE">
      <SHORT-NAME>no-fun</SHORT-NAME>
      <DESC>Das ist die Instantiierung eines globalen objektes der Klasse nonsense. Es wird die Highend-Implementierung verwendet.</DESC>
      <SW-CLASS-REF ID-REF="NONSENSE">nonsense</SW-CLASS-REF>
      <SW-CLASS-ATTR-IMPL-REF ID-REF    ="ID49163FECRAD4BFD7"
                              HYTIME    ="CLINK"
                              HYNAMES   ="LINKEND ID-REF"
                              F-ID-CLASS="SW-CLASS-ATTR-IMPL">highend</SW-CLASS-ATTR-IMPL-REF>
   </SW-CLASS-INSTANCE>

   <SW-CLASS-INSTANCE ID        ="ID49163FECRAD51C6A"
                      F-ID-CLASS="SW-CLASS-INSTANCE">
      <SHORT-NAME>no-sports </SHORT-NAME>
      <DESC>Das ist eine weitere Instantiierung eines globalen objektes der Klasse nonsense. Es wird die Lowend-Implementierung verwendet.</DESC>
      <SW-CLASS-REF ID-REF="NONSENSE">nonsense</SW-CLASS-REF>
      <SW-CLASS-ATTR-IMPL-REF ID-REF    ="ID49163FECRAD4BFD7-1"
                              HYTIME    ="CLINK"
                              HYNAMES   ="LINKEND ID-REF"
                              F-ID-CLASS="SW-CLASS-ATTR-IMPL">lowend</SW-CLASS-ATTR-IMPL-REF>
   </SW-CLASS-INSTANCE>

   <SW-CLASS-INSTANCE ID        ="ID49163FECRAD353DD"
                      F-ID-CLASS="SW-CLASS-INSTANCE">
      <SHORT-NAME>no-life </SHORT-NAME>
      <DESC>Das ist eine weitere Instantiierung eines globalen objektes der Klasse nonsense. Es wird die Highend-Implementierung verwendet.</DESC>
      <SW-CLASS-REF ID-REF    ="NONSENSE"
                    HYTIME    ="CLINK"
                    HYNAMES   ="LINKEND ID-REF"
                    F-ID-CLASS="SW-CLASS">nonsense</SW-CLASS-REF>
      <SW-CLASS-ATTR-IMPL-REF ID-REF    ="ID49163FECRAD4BFD7"
                              HYTIME    ="CLINK"
                              HYNAMES   ="LINKEND ID-REF"
                              F-ID-CLASS="SW-CLASS-ATTR-IMPL">highend</SW-CLASS-ATTR-IMPL-REF>
   </SW-CLASS-INSTANCE>
</SW-CLASS-INSTANCES>
Here we specify the required code syntaxes.
 <SW-CODE-SYNTAXES>
   <SW-CODE-SYNTAX ID        ="ID4F1ADF2DRADE6B70"
                   F-ID-CLASS="SW-CODE-SYNTAX">
      <SHORT-NAME>kf-8</SHORT-NAME>
   </SW-CODE-SYNTAX>

   <SW-CODE-SYNTAX ID        ="ID4F1ADF2DRAD41815"
                   F-ID-CLASS="SW-CODE-SYNTAX">
      <SHORT-NAME>kf-32</SHORT-NAME>
   </SW-CODE-SYNTAX>

   <SW-CODE-SYNTAX ID        ="ID4F1ADF2DRADA3D4F"
                   F-ID-CLASS="SW-CODE-SYNTAX">
      <SHORT-NAME>kl-8</SHORT-NAME>
   </SW-CODE-SYNTAX>

   <SW-CODE-SYNTAX ID        ="ID4F1ADF2DRADA8D81"
                   F-ID-CLASS="SW-CODE-SYNTAX">
      <SHORT-NAME>kl-32</SHORT-NAME>
   </SW-CODE-SYNTAX>
</SW-CODE-SYNTAXES>
Here we define the required base types.
 <SW-BASE-TYPES>
   <SW-BASE-TYPE ID        ="ID4F1ADF2DRAD66771"
                 F-ID-CLASS="SW-BASE-TYPE">
      <SHORT-NAME>byte</SHORT-NAME>
      <SW-BASE-TYPE-SIZE>8</SW-BASE-TYPE-SIZE>
      <SW-CODED-TYPE>integer</SW-CODED-TYPE>
   </SW-BASE-TYPE>

   <SW-BASE-TYPE ID        ="ID4F1ADF2DRAD2A264"
                 F-ID-CLASS="SW-BASE-TYPE">
      <SHORT-NAME>long</SHORT-NAME>
      <SW-BASE-TYPE-SIZE>32</SW-BASE-TYPE-SIZE>
      <SW-CODED-TYPE>integer</SW-CODED-TYPE>
   </SW-BASE-TYPE>
</SW-BASE-TYPES>
Since classes are handled as software components, they are defined within <SW-COMPONENT-SPEC>. Here we define a class "nonsense" and the subclass which is instantiated as part of "nonsense".
 <SW-COMPONENT-SPEC>
   <SW-COMPONENTS>
      <SW-CLASS ID         ="NONSENSE"
                F-ID-CLASS ="SW-CLASS"
                F-NAMESPACE="SW-CALPRM-PROTOTYPE SW-CLASS-PROTOTYPE SW-VARIABLE-PROTOTYPE">
         <SHORT-NAME>nonsense </SHORT-NAME>
         <SW-FEATURE-DESC>
            <P>Diese Klasse dient nur zur Demonstration der Mglichkeiten in MSRSW.</P>
            <LIST TYPE="UNNUMBER">
               <ITEM>
                  <P>Klassenbeschreibung</P>
               </ITEM>
               <ITEM>
                  <P>Klassenattribute</P>
               </ITEM>
               <ITEM>
                  <P>Methoden</P>
               </ITEM>
            </LIST>
         </SW-FEATURE-DESC>
         <SW-CLASS-ATTR></SW-CLASS-ATTR>
      </SW-CLASS>
   </SW-COMPONENTS>
</SW-COMPONENT-SPEC>
The class attributes are first specified as prototypes. Subsequently the implementations available in the ECU are specified in <SW-CLASS-ATTR-IMPLS>. The attributes may manifest as variables (<SW-VARIABLE-PROTOTYPE>s, calibration parameters ( <SW-CALPRM-PROTOTYPE>s) or class instances (<SW-CLASS-PROTOTYPE>s).
 <SW-VARIABLE-PROTOTYPES>
   <SW-VARIABLE-PROTOTYPE ID        ="ID49163FEDRAD112E9"
                          F-ID-CLASS="SW-VARIABLE-PROTOTYPE">
      <SHORT-NAME>N</SHORT-NAME>
      <DESC>Das ist ein Prototyp für ein Attribut der Klasse, welche sich als Variable instantiiert.</DESC>
   </SW-VARIABLE-PROTOTYPE>

   <SW-VARIABLE-PROTOTYPE ID        ="ID49163FEDRAD77C19"
                          F-ID-CLASS="SW-VARIABLE-PROTOTYPE">
      <SHORT-NAME>TL </SHORT-NAME>
      <DESC>Das ist ein Prototyp für ein Attribut der Klasse, welche sich als Variable instantiiert.</DESC>
   </SW-VARIABLE-PROTOTYPE>

   <SW-VARIABLE-PROTOTYPE ID        ="ID49163FEDRAD65A29"
                          F-ID-CLASS="SW-VARIABLE-PROTOTYPE">
      <SHORT-NAME>TMOT </SHORT-NAME>
      <DESC>Das ist ein Prototyp für ein Attribut der Klasse, welche sich als Variable instantiiert.</DESC>
   </SW-VARIABLE-PROTOTYPE>
</SW-VARIABLE-PROTOTYPES>
These are calibration parameter prototypes:
 <SW-CALPRM-PROTOTYPES>
   <SW-CALPRM-PROTOTYPE ID        ="ID49163FECRAD0EE17"
                        F-ID-CLASS="SW-CALPRM-PROTOTYPE">
      <SHORT-NAME>WLN </SHORT-NAME>
      <DESC>Das ist ein Prototyp für ein Attribut der Klasse, welche sich als Parameter instantiiert.</DESC>
   </SW-CALPRM-PROTOTYPE>

   <SW-CALPRM-PROTOTYPE ID        ="ID49163FECRADB7A5D"
                        F-ID-CLASS="SW-CALPRM-PROTOTYPE">
      <SHORT-NAME>WTL </SHORT-NAME>
      <DESC>Das ist ein Prototyp für ein Attribut der Klasse, welche sich als Parameter instantiiert.</DESC>
   </SW-CALPRM-PROTOTYPE>

   <SW-CALPRM-PROTOTYPE ID        ="ID49163FECRADD360C"
                        F-ID-CLASS="SW-CALPRM-PROTOTYPE">
      <SHORT-NAME>WTMOT </SHORT-NAME>
      <DESC>Das ist ein Prototyp für ein Attribut der Klasse, welche sich als Parameter instantiiert.</DESC>
   </SW-CALPRM-PROTOTYPE>

   <SW-CALPRM-PROTOTYPE ID        ="ID49163FECRADF9F29"
                        F-ID-CLASS="SW-CALPRM-PROTOTYPE">
      <SHORT-NAME>KFNTL </SHORT-NAME>
   </SW-CALPRM-PROTOTYPE>
</SW-CALPRM-PROTOTYPES>
These are class instance prototypes:
 <SW-CLASS-PROTOTYPES>
   <SW-CLASS-PROTOTYPE ID        ="ID49163FECRADE0ACB"
                       F-ID-CLASS="SW-CLASS-PROTOTYPE">
      <SHORT-NAME>substuff </SHORT-NAME>
      <SW-CLASS-REF ID-REF    ="ID49163FECRAD19FEB"
                    HYTIME    ="CLINK"
                    HYNAMES   ="LINKEND ID-REF"
                    F-ID-CLASS="SW-CLASS">Subclass</SW-CLASS-REF>
      <DESC>Das ist ein Prototyp für ein Attribut der Klasse, welche sich als instanz der Klasse
      Subclass instantiiert. Durch diese Instantiierung wird es seine Attribute einbringen.</DESC>
   </SW-CLASS-PROTOTYPE>
</SW-CLASS-PROTOTYPES>
Here, the particular implementations of the various prototypes are specified:
 <SW-CLASS-ATTR-IMPLS>
   <SW-CLASS-ATTR-IMPL ID        ="ID49163FECRAD4BFD7-1"
                       F-ID-CLASS="SW-CLASS-ATTR-IMPL">
      <LONG-NAME>Lowend-Implementierung, z.B. als 8 bit</LONG-NAME>
      <SHORT-NAME>highend </SHORT-NAME>
      <SW-VARIABLE-IMPLS>
         <SW-VARIABLE-IMPL>
            <SW-VARIABLE-PROTOTYPE-REF ID-REF    ="ID49163FEDRAD112E9"
                                       HYTIME    ="CLINK"
                                       HYNAMES   ="LINKEND ID-REF"
                                       F-ID-CLASS="SW-VARIABLE-PROTOTYPE">N</SW-VARIABLE-PROTOTYPE-REF>
            <SW-DATA-DEF-PROPS>
               <SW-BASE-TYPE-REF ID-REF    ="ID4F1ADF2DRAD66771"
                                 HYTIME    ="CLINK"
                                 HYNAMES   ="LINKEND ID-REF"
                                 F-ID-CLASS="SW-BASE-TYPE">byte</SW-BASE-TYPE-REF>
            </SW-DATA-DEF-PROPS>
         </SW-VARIABLE-IMPL>
         <SW-VARIABLE-IMPL>
            <SW-VARIABLE-PROTOTYPE-REF ID-REF    ="ID49163FEDRAD77C19"
                                       HYTIME    ="CLINK"
                                       HYNAMES   ="LINKEND ID-REF"
                                       F-ID-CLASS="SW-VARIABLE-PROTOTYPE">TL</SW-VARIABLE-PROTOTYPE-REF>
            <SW-DATA-DEF-PROPS>
               <SW-BASE-TYPE-REF ID-REF    ="ID4F1ADF2DRAD66771"
                                 HYTIME    ="CLINK"
                                 HYNAMES   ="LINKEND ID-REF"
                                 F-ID-CLASS="SW-BASE-TYPE">byte</SW-BASE-TYPE-REF>
            </SW-DATA-DEF-PROPS>
         </SW-VARIABLE-IMPL>
         <SW-VARIABLE-IMPL>
            <SW-VARIABLE-PROTOTYPE-REF ID-REF    ="ID49163FEDRAD65A29"
                                       HYTIME    ="CLINK"
                                       HYNAMES   ="LINKEND ID-REF"
                                       F-ID-CLASS="SW-VARIABLE-PROTOTYPE">TMOT</SW-VARIABLE-PROTOTYPE-REF>
            <SW-DATA-DEF-PROPS>
               <SW-BASE-TYPE-REF ID-REF    ="ID4F1ADF2DRAD66771"
                                 HYTIME    ="CLINK"
                                 HYNAMES   ="LINKEND ID-REF"
                                 F-ID-CLASS="SW-BASE-TYPE">byte</SW-BASE-TYPE-REF>
            </SW-DATA-DEF-PROPS>
         </SW-VARIABLE-IMPL>
      </SW-VARIABLE-IMPLS>
      <SW-CALPRM-IMPLS>
         <SW-CALPRM-IMPL>
            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRAD0EE17"
                                     HYTIME    ="CLINK"
                                     HYNAMES   ="LINKEND ID-REF"
                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">WLN</SW-CALPRM-PROTOTYPE-REF>
            <SW-DATA-DEF-PROPS>
               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRADA3D4F"
                                   HYTIME    ="CLINK"
                                   HYNAMES   ="LINKEND ID-REF"
                                   F-ID-CLASS="SW-CODE-SYNTAX">kl-8</SW-CODE-SYNTAX-REF>
            </SW-DATA-DEF-PROPS>
         </SW-CALPRM-IMPL>
         <SW-CALPRM-IMPL>
            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRADB7A5D"
                                     HYTIME    ="CLINK"
                                     HYNAMES   ="LINKEND ID-REF"
                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">WTL</SW-CALPRM-PROTOTYPE-REF>
            <SW-DATA-DEF-PROPS>
               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRADA3D4F"
                                   HYTIME    ="CLINK"
                                   HYNAMES   ="LINKEND ID-REF"
                                   F-ID-CLASS="SW-CODE-SYNTAX">kl-8</SW-CODE-SYNTAX-REF>
            </SW-DATA-DEF-PROPS>
         </SW-CALPRM-IMPL>
         <SW-CALPRM-IMPL>
            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRADD360C"
                                     HYTIME    ="CLINK"
                                     HYNAMES   ="LINKEND ID-REF"
                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">WTMOT</SW-CALPRM-PROTOTYPE-REF>
            <SW-DATA-DEF-PROPS>
               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRADA3D4F"
                                   HYTIME    ="CLINK"
                                   HYNAMES   ="LINKEND ID-REF"
                                   F-ID-CLASS="SW-CODE-SYNTAX">kl-8</SW-CODE-SYNTAX-REF>
            </SW-DATA-DEF-PROPS>
         </SW-CALPRM-IMPL>
         <SW-CALPRM-IMPL>
            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRADF9F29"
                                     HYTIME    ="CLINK"
                                     HYNAMES   ="LINKEND ID-REF"
                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">KFNTL</SW-CALPRM-PROTOTYPE-REF>
            <SW-DATA-DEF-PROPS>
               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRADE6B70"
                                   HYTIME    ="CLINK"
                                   HYNAMES   ="LINKEND ID-REF"
                                   F-ID-CLASS="SW-CODE-SYNTAX">kf-8</SW-CODE-SYNTAX-REF>
            </SW-DATA-DEF-PROPS>
         </SW-CALPRM-IMPL>
      </SW-CALPRM-IMPLS>
      <SW-CLASS-IMPLS>
         <SW-CLASS-IMPL>
            <SW-CLASS-PROTOTYPE-REF ID-REF    ="ID49163FECRADE0ACB"
                                    HYTIME    ="CLINK"
                                    HYNAMES   ="LINKEND ID-REF"
                                    F-ID-CLASS="SW-CLASS-PROTOTYPE">substuff</SW-CLASS-PROTOTYPE-REF>
            <SW-CLASS-ATTR-IMPL-REF ID-REF    ="ID7E9146ARADC551A"
                                    HYTIME    ="CLINK"
                                    HYNAMES   ="LINKEND ID-REF"
                                    F-ID-CLASS="SW-CLASS-ATTR-IMPL">32bit</SW-CLASS-ATTR-IMPL-REF>
         </SW-CLASS-IMPL>
      </SW-CLASS-IMPLS>
   </SW-CLASS-ATTR-IMPL>

   <SW-CLASS-ATTR-IMPL ID        ="ID49163FECRAD4BFD7"
                       F-ID-CLASS="SW-CLASS-ATTR-IMPL">
      <LONG-NAME>Highend-Implementierung, z.B. als 32 bit</LONG-NAME>
      <SHORT-NAME>highend </SHORT-NAME>
      <SW-VARIABLE-IMPLS>
         <SW-VARIABLE-IMPL>
            <SW-VARIABLE-PROTOTYPE-REF ID-REF    ="ID49163FEDRAD112E9"
                                       HYTIME    ="CLINK"
                                       HYNAMES   ="LINKEND ID-REF"
                                       F-ID-CLASS="SW-VARIABLE-PROTOTYPE">N</SW-VARIABLE-PROTOTYPE-REF>
            <SW-DATA-DEF-PROPS>
               <SW-BASE-TYPE-REF ID-REF    ="ID4F1ADF2DRAD2A264"
                                 HYTIME    ="CLINK"
                                 HYNAMES   ="LINKEND ID-REF"
                                 F-ID-CLASS="SW-BASE-TYPE">long</SW-BASE-TYPE-REF>
            </SW-DATA-DEF-PROPS>
         </SW-VARIABLE-IMPL>
         <SW-VARIABLE-IMPL>
            <SW-VARIABLE-PROTOTYPE-REF ID-REF    ="ID49163FEDRAD77C19"
                                       HYTIME    ="CLINK"
                                       HYNAMES   ="LINKEND ID-REF"
                                       F-ID-CLASS="SW-VARIABLE-PROTOTYPE">TL</SW-VARIABLE-PROTOTYPE-REF>
            <SW-DATA-DEF-PROPS>
               <SW-BASE-TYPE-REF ID-REF    ="ID4F1ADF2DRAD2A264"
                                 HYTIME    ="CLINK"
                                 HYNAMES   ="LINKEND ID-REF"
                                 F-ID-CLASS="SW-BASE-TYPE">long</SW-BASE-TYPE-REF>
            </SW-DATA-DEF-PROPS>
         </SW-VARIABLE-IMPL>
         <SW-VARIABLE-IMPL>
            <SW-VARIABLE-PROTOTYPE-REF ID-REF    ="ID49163FEDRAD65A29"
                                       HYTIME    ="CLINK"
                                       HYNAMES   ="LINKEND ID-REF"
                                       F-ID-CLASS="SW-VARIABLE-PROTOTYPE">TMOT</SW-VARIABLE-PROTOTYPE-REF>
            <SW-DATA-DEF-PROPS>
               <SW-BASE-TYPE-REF ID-REF    ="ID4F1ADF2DRAD2A264"
                                 HYTIME    ="CLINK"
                                 HYNAMES   ="LINKEND ID-REF"
                                 F-ID-CLASS="SW-BASE-TYPE">long</SW-BASE-TYPE-REF>
            </SW-DATA-DEF-PROPS>
         </SW-VARIABLE-IMPL>
      </SW-VARIABLE-IMPLS>
      <SW-CALPRM-IMPLS>
         <SW-CALPRM-IMPL>
            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRAD0EE17"
                                     HYTIME    ="CLINK"
                                     HYNAMES   ="LINKEND ID-REF"
                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">WLN</SW-CALPRM-PROTOTYPE-REF>
            <SW-DATA-DEF-PROPS>
               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRADA8D81"
                                   HYTIME    ="CLINK"
                                   HYNAMES   ="LINKEND ID-REF"
                                   F-ID-CLASS="SW-CODE-SYNTAX">kl-32</SW-CODE-SYNTAX-REF>
            </SW-DATA-DEF-PROPS>
         </SW-CALPRM-IMPL>
         <SW-CALPRM-IMPL>
            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRADB7A5D"
                                     HYTIME    ="CLINK"
                                     HYNAMES   ="LINKEND ID-REF"
                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">WTL</SW-CALPRM-PROTOTYPE-REF>
            <SW-DATA-DEF-PROPS>
               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRADA8D81"
                                   HYTIME    ="CLINK"
                                   HYNAMES   ="LINKEND ID-REF"
                                   F-ID-CLASS="SW-CODE-SYNTAX">kl-32</SW-CODE-SYNTAX-REF>
            </SW-DATA-DEF-PROPS>
         </SW-CALPRM-IMPL>
         <SW-CALPRM-IMPL>
            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRADD360C"
                                     HYTIME    ="CLINK"
                                     HYNAMES   ="LINKEND ID-REF"
                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">WTMOT</SW-CALPRM-PROTOTYPE-REF>
            <SW-DATA-DEF-PROPS>
               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRADA8D81"
                                   HYTIME    ="CLINK"
                                   HYNAMES   ="LINKEND ID-REF"
                                   F-ID-CLASS="SW-CODE-SYNTAX">kl-32</SW-CODE-SYNTAX-REF>
            </SW-DATA-DEF-PROPS>
         </SW-CALPRM-IMPL>
         <SW-CALPRM-IMPL>
            <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRADF9F29"
                                     HYTIME    ="CLINK"
                                     HYNAMES   ="LINKEND ID-REF"
                                     F-ID-CLASS="SW-CALPRM-PROTOTYPE">KFNTL</SW-CALPRM-PROTOTYPE-REF>
            <SW-DATA-DEF-PROPS>
               <SW-CODE-SYNTAX-REF ID-REF    ="ID4F1ADF2DRAD41815"
                                   HYTIME    ="CLINK"
                                   HYNAMES   ="LINKEND ID-REF"
                                   F-ID-CLASS="SW-CODE-SYNTAX">kf-32</SW-CODE-SYNTAX-REF>
            </SW-DATA-DEF-PROPS>
         </SW-CALPRM-IMPL>
      </SW-CALPRM-IMPLS>
      <SW-CLASS-IMPLS>
         <SW-CLASS-IMPL>
            <SW-CLASS-PROTOTYPE-REF ID-REF    ="ID49163FECRADE0ACB"
                                    HYTIME    ="CLINK"
                                    HYNAMES   ="LINKEND ID-REF"
                                    F-ID-CLASS="SW-CLASS-PROTOTYPE">substuff</SW-CLASS-PROTOTYPE-REF>
            <SW-CLASS-ATTR-IMPL-REF ID-REF    ="ID7E9146ARADC551A"
                                    HYTIME    ="CLINK"
                                    HYNAMES   ="LINKEND ID-REF"
                                    F-ID-CLASS="SW-CLASS-ATTR-IMPL">32bit</SW-CLASS-ATTR-IMPL-REF>
         </SW-CLASS-IMPL>
      </SW-CLASS-IMPLS>
   </SW-CLASS-ATTR-IMPL>
</SW-CLASS-ATTR-IMPLS>
Here, the subclass called "Subclass" of "nonsense" is specified:
 <SW-CLASS ID         ="ID49163FECRAD19FEB"
          F-ID-CLASS ="SW-CLASS"
          F-NAMESPACE="SW-CALPRM-PROTOTYPE SW-CLASS-PROTOTYPE SW-VARIABLE-PROTOTYPE">
   <SHORT-NAME>Subclass</SHORT-NAME>
   <SW-CLASS-ATTR>

      <SW-VARIABLE-PROTOTYPES>
         <SW-VARIABLE-PROTOTYPE ID        ="ID49163FEDRADC1F7C"
                                F-ID-CLASS="SW-VARIABLE-PROTOTYPE">
            <SHORT-NAME>subvar </SHORT-NAME>
         </SW-VARIABLE-PROTOTYPE>
      </SW-VARIABLE-PROTOTYPES>

      <SW-CALPRM-PROTOTYPES>
         <SW-CALPRM-PROTOTYPE ID        ="ID49163FECRAD8F757"
                              F-ID-CLASS="SW-CALPRM-PROTOTYPE">
            <SHORT-NAME>subparam </SHORT-NAME>
         </SW-CALPRM-PROTOTYPE>
      </SW-CALPRM-PROTOTYPES>
   </SW-CLASS-ATTR>

   <SW-CLASS-ATTR-IMPLS>
      <SW-CLASS-ATTR-IMPL ID        ="ID7E9146ARADC551A"
                          F-ID-CLASS="SW-CLASS-ATTR-IMPL">
         <LONG-NAME>Highend-Implementierung</LONG-NAME>
         <SHORT-NAME>highend</SHORT-NAME>
         <SW-VARIABLE-IMPLS>
            <SW-VARIABLE-IMPL>
               <SW-VARIABLE-PROTOTYPE-REF ID-REF    ="ID49163FEDRADC1F7C"
                                          HYTIME    ="CLINK"
                                          HYNAMES   ="LINKEND ID-REF"
                                          F-ID-CLASS="SW-VARIABLE-PROTOTYPE">ID49163FEDRADC1F7C</SW-VARIABLE-PROTOTYPE-REF>
            </SW-VARIABLE-IMPL>
         </SW-VARIABLE-IMPLS>
         <SW-CALPRM-IMPLS>
            <SW-CALPRM-IMPL>
               <SW-CALPRM-PROTOTYPE-REF ID-REF    ="ID49163FECRAD8F757"
                                        HYTIME    ="CLINK"
                                        HYNAMES   ="LINKEND ID-REF"
                                        F-ID-CLASS="SW-CALPRM-PROTOTYPE">ID49163FECRAD8F757</SW-CALPRM-PROTOTYPE-REF>
            </SW-CALPRM-IMPL>
         </SW-CALPRM-IMPLS>
      </SW-CLASS-ATTR-IMPL>
   </SW-CLASS-ATTR-IMPLS>
</SW-CLASS>
Here, the resulting instance tree of the class "nonsense" is given.
 <MSRSW>
   <SW-SYSTEMS>
      <SW-SYSTEM>
         <SW-INSTANCE-SPEC>
            <SW-INSTANCE-TREE ID         ="ID49163FEDRADEB5E8"
                              F-ID-CLASS ="SW-INSTANCE-TREE"
                              F-NAMESPACE="SW-INSTANCE">
               <SHORT-NAME>xxx</SHORT-NAME>
               <CATEGORY>init-values</CATEGORY>
               <SW-INSTANCE ID ="ID49163FECRAD7CCBA" F-ID-CLASS ="SW-INSTANCE" F-NAMESPACE="SW-INSTANCE">
               <SHORT-NAME>no-fun</SHORT-NAME>
               <SW-INSTANCE-PROPS-VARIANTS>
                  <SW-INSTANCE-PROPS-VARIANT>
                     <DESC>Instanz von
                        <XREF ID-CLASS                ="SW-CLASS-INSTANCE"
                              ID-REF                  ="ID49163FECRADA984D"
                              HYTIME                  ="CLINK"
                              HYNAMES                 ="LINKEND ID-REF"
                              SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                              SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                              SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                              SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                              SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADA984D</XREF></DESC>
                  </SW-INSTANCE-PROPS-VARIANT>
               </SW-INSTANCE-PROPS-VARIANTS>
               <SW-INSTANCE ID ="ID49163FECRADB8019" F-ID-CLASS ="SW-INSTANCE" F-NAMESPACE="SW-INSTANCE">
               <SHORT-NAME>N</SHORT-NAME>
               <SW-INSTANCE-PROPS-VARIANTS>
                  <SW-INSTANCE-PROPS-VARIANT>
                     <DESC>Instanz von
                        <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                              ID-REF                  ="ID49163FEDRAD112E9"
                              HYTIME                  ="CLINK"
                              HYNAMES                 ="LINKEND ID-REF"
                              SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                              SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                              SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                              SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                              SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD112E9</XREF></DESC>
                  </SW-INSTANCE-PROPS-VARIANT>
               </SW-INSTANCE-PROPS-VARIANTS>
               <SW-INSTANCE ID ="ID49163FECRADA113B" F-ID-CLASS ="SW-INSTANCE" F-NAMESPACE="SW-INSTANCE">
               <SHORT-NAME>TL </SHORT-NAME>
               <SW-INSTANCE-PROPS-VARIANTS>
                  <SW-INSTANCE-PROPS-VARIANT>
                     <DESC>Instanz von
                        <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                              ID-REF                  ="ID49163FEDRAD77C19"
                              HYTIME                  ="CLINK"
                              HYNAMES                 ="LINKEND ID-REF"
                              SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                              SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                              SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                              SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                              SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD77C19</XREF></DESC>
                  </SW-INSTANCE-PROPS-VARIANT>
               </SW-INSTANCE-PROPS-VARIANTS>
               <SW-INSTANCE ID ="ID49163FECRAD3588D" F-ID-CLASS ="SW-INSTANCE" F-NAMESPACE="SW-INSTANCE">
               <SHORT-NAME>TMOT</SHORT-NAME>
               <SW-INSTANCE-PROPS-VARIANTS>
                  <SW-INSTANCE-PROPS-VARIANT>
                     <DESC>Instanz von
                        <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                              ID-REF                  ="ID49163FEDRAD65A29"
                              HYTIME                  ="CLINK"
                              HYNAMES                 ="LINKEND ID-REF"
                              SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                              SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                              SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                              SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                              SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD65A29</XREF></DESC>
                  </SW-INSTANCE-PROPS-VARIANT>
               </SW-INSTANCE-PROPS-VARIANTS>
               <SW-INSTANCE ID ="ID49163FECRAD2B108" F-ID-CLASS ="SW-INSTANCE" F-NAMESPACE="SW-INSTANCE">
               <SHORT-NAME>WLN</SHORT-NAME>
               <SW-INSTANCE-PROPS-VARIANTS>
                  <SW-INSTANCE-PROPS-VARIANT>
                     <DESC>Instanz von
                        <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                              ID-REF                  ="ID49163FECRAD0EE17"
                              HYTIME                  ="CLINK"
                              HYNAMES                 ="LINKEND ID-REF"
                              SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                              SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                              SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                              SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                              SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD0EE17</XREF></DESC>
                  </SW-INSTANCE-PROPS-VARIANT>
               </SW-INSTANCE-PROPS-VARIANTS>
               <SW-INSTANCE ID ="ID49163FECRAD7339D" F-ID-CLASS ="SW-INSTANCE" F-NAMESPACE="SW-INSTANCE">
               <SHORT-NAME>WTL</SHORT-NAME>
               <SW-INSTANCE-PROPS-VARIANTS>
                  <SW-INSTANCE-PROPS-VARIANT>
                     <DESC>Instanz von
                        <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                              ID-REF                  ="ID49163FECRADB7A5D"
                              HYTIME                  ="CLINK"
                              HYNAMES                 ="LINKEND ID-REF"
                              SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                              SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                              SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                              SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                              SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADB7A5D</XREF></DESC>
                  </SW-INSTANCE-PROPS-VARIANT>
               </SW-INSTANCE-PROPS-VARIANTS>
               <SW-INSTANCE ID         ="ID49163FECRAD7BD7C"
                            F-ID-CLASS ="SW-INSTANCE"
                            F-NAMESPACE="SW-INSTANCE">
                  <SHORT-NAME>WTMOT </SHORT-NAME>
                  <SW-INSTANCE-PROPS-VARIANTS>
                     <SW-INSTANCE-PROPS-VARIANT>
                        <DESC>Instanz von
                           <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                 ID-REF                  ="ID49163FECRADD360C"
                                 HYTIME                  ="CLINK"
                                 HYNAMES                 ="LINKEND ID-REF"
                                 SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                 SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                 SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                 SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                 SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADD360C</XREF></DESC>
                     </SW-INSTANCE-PROPS-VARIANT>
                  </SW-INSTANCE-PROPS-VARIANTS>
               </SW-INSTANCE>

               <SW-INSTANCE ID         ="ID49163FECRADB0847"
                            F-ID-CLASS ="SW-INSTANCE"
                            F-NAMESPACE="SW-INSTANCE">
                  <SHORT-NAME>KFNTL </SHORT-NAME>
                  <SW-INSTANCE-PROPS-VARIANTS>
                     <SW-INSTANCE-PROPS-VARIANT>
                        <DESC>Instanz von
                           <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                 ID-REF                  ="ID49163FECRADF9F29"
                                 HYTIME                  ="CLINK"
                                 HYNAMES                 ="LINKEND ID-REF"
                                 SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                 SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                 SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                 SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                 SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADF9F29</XREF></DESC>
                     </SW-INSTANCE-PROPS-VARIANT>
                  </SW-INSTANCE-PROPS-VARIANTS>
               </SW-INSTANCE>

               <SW-INSTANCE ID         ="ID49163FECRAD999EA"
                            F-ID-CLASS ="SW-INSTANCE"
                            F-NAMESPACE="SW-INSTANCE">
                  <SHORT-NAME>substuff </SHORT-NAME>
                  <SW-INSTANCE-PROPS-VARIANTS>
                     <SW-INSTANCE-PROPS-VARIANT>
                        <DESC>Das ist eine Instanz des Klassenattributes
                           <XREF ID-CLASS                ="SW-CLASS-PROTOTYPE"
                                 ID-REF                  ="ID49163FECRADE0ACB"
                                 HYTIME                  ="CLINK"
                                 HYNAMES                 ="LINKEND ID-REF"
                                 SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                 SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                 SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                 SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                 SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADE0ACB</XREF></DESC>
                     </SW-INSTANCE-PROPS-VARIANT>
                  </SW-INSTANCE-PROPS-VARIANTS>
                  <SW-INSTANCE ID         ="ID49163FECRADAE61E"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>subparam </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                    ID-REF                  ="ID49163FECRAD8F757"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD8F757</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>

                  <SW-INSTANCE ID         ="ID49163FEDRADB5D49"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>subvar </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                    ID-REF                  ="ID49163FEDRADC1F7C"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRADC1F7C</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>
               </SW-INSTANCE>

               <SW-INSTANCE ID         ="ID49163FEDRADE40F7"
                            F-ID-CLASS ="SW-INSTANCE"
                            F-NAMESPACE="SW-INSTANCE">
                  <SHORT-NAME>no-sports </SHORT-NAME>
                  <SW-INSTANCE-PROPS-VARIANTS>
                     <SW-INSTANCE-PROPS-VARIANT>
                        <DESC>Instanz von
                           <XREF ID-CLASS                ="SW-CLASS-INSTANCE"
                                 ID-REF                  ="ID49163FECRAD51C6A"
                                 HYTIME                  ="CLINK"
                                 HYNAMES                 ="LINKEND ID-REF"
                                 SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                 SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                 SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                 SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                 SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD51C6A</XREF></DESC>
                     </SW-INSTANCE-PROPS-VARIANT>
                  </SW-INSTANCE-PROPS-VARIANTS>
                  <SW-INSTANCE ID         ="ID49163FEDRADF06C9"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>N </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                    ID-REF                  ="ID49163FEDRAD112E9"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD112E9</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>

                  <SW-INSTANCE ID         ="ID49163FEDRADC2B0A"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>TL </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                    ID-REF                  ="ID49163FEDRAD77C19"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD77C19</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>

                  <SW-INSTANCE ID         ="ID49163FEDRADC3297"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>TMOT </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                    ID-REF                  ="ID49163FEDRAD65A29"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD65A29</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>

                  <SW-INSTANCE ID         ="ID49163FEDRADFC198"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>WLN </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                    ID-REF                  ="ID49163FECRAD0EE17"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD0EE17</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>

                  <SW-INSTANCE ID         ="ID49163FEDRADF223E"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>WTL </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                    ID-REF                  ="ID49163FECRADB7A5D"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADB7A5D</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>

                  <SW-INSTANCE ID         ="ID49163FEDRADB4878"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>WTMOT </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                    ID-REF                  ="ID49163FECRADD360C"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADD360C</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>

                  <SW-INSTANCE ID         ="ID49163FEDRAD1EBBB"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>KFNTL </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                    ID-REF                  ="ID49163FECRADF9F29"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADF9F29</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>

                  <SW-INSTANCE ID         ="ID49163FEDRAD5CBAE"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>substuff </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-CLASS-PROTOTYPE"
                                    ID-REF                  ="ID49163FECRADE0ACB"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADE0ACB</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                     <SW-INSTANCE ID         ="ID49163FEDRAD98DBB"
                                  F-ID-CLASS ="SW-INSTANCE"
                                  F-NAMESPACE="SW-INSTANCE">
                        <SHORT-NAME>subparam </SHORT-NAME>
                        <SW-INSTANCE-PROPS-VARIANTS>
                           <SW-INSTANCE-PROPS-VARIANT>
                              <DESC>Instanz von
                                 <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                       ID-REF                  ="ID49163FECRAD8F757"
                                       HYTIME                  ="CLINK"
                                       HYNAMES                 ="LINKEND ID-REF"
                                       SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                       SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                       SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                       SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                       SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD8F757</XREF></DESC>
                           </SW-INSTANCE-PROPS-VARIANT>
                        </SW-INSTANCE-PROPS-VARIANTS>
                     </SW-INSTANCE>

                     <SW-INSTANCE ID         ="ID49163FEDRAD0DEEB"
                                  F-ID-CLASS ="SW-INSTANCE"
                                  F-NAMESPACE="SW-INSTANCE">
                        <SHORT-NAME>subvar </SHORT-NAME>
                        <SW-INSTANCE-PROPS-VARIANTS>
                           <SW-INSTANCE-PROPS-VARIANT>
                              <DESC>Instanz von
                                 <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                       ID-REF                  ="ID49163FEDRADC1F7C"
                                       HYTIME                  ="CLINK"
                                       HYNAMES                 ="LINKEND ID-REF"
                                       SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                       SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                       SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                       SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                       SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRADC1F7C</XREF></DESC>
                           </SW-INSTANCE-PROPS-VARIANT>
                        </SW-INSTANCE-PROPS-VARIANTS>
                     </SW-INSTANCE>
                  </SW-INSTANCE>
               </SW-INSTANCE>

               <SW-INSTANCE ID         ="ID49163FEDRADC50EB"
                            F-ID-CLASS ="SW-INSTANCE"
                            F-NAMESPACE="SW-INSTANCE">
                  <SHORT-NAME>no-life </SHORT-NAME>
                  <SW-INSTANCE-PROPS-VARIANTS>
                     <SW-INSTANCE-PROPS-VARIANT>
                        <DESC>Instanz von
                           <XREF ID-CLASS                ="SW-CLASS-INSTANCE"
                                 ID-REF                  ="ID49163FECRAD353DD"
                                 HYTIME                  ="CLINK"
                                 HYNAMES                 ="LINKEND ID-REF"
                                 SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                 SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                 SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                 SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                 SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD353DD</XREF></DESC>
                     </SW-INSTANCE-PROPS-VARIANT>
                  </SW-INSTANCE-PROPS-VARIANTS>
                  <SW-INSTANCE ID         ="ID49163FEDRADEC698"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>N </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                    ID-REF                  ="ID49163FEDRAD112E9"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD112E9</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>

                  <SW-INSTANCE ID         ="ID49163FEDRAD84097"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>TL </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                    ID-REF                  ="ID49163FEDRAD77C19"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD77C19</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>

                  <SW-INSTANCE ID         ="ID49163FEDRADA2A67"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>TMOT </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                    ID-REF                  ="ID49163FEDRAD65A29"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRAD65A29</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>

                  <SW-INSTANCE ID         ="ID49163FEDRAD0C4EB"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>WLN </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                    ID-REF                  ="ID49163FECRAD0EE17"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD0EE17</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>

                  <SW-INSTANCE ID         ="ID49163FEDRADFF9EA"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>WTL </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                    ID-REF                  ="ID49163FECRADB7A5D"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADB7A5D</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>

                  <SW-INSTANCE ID         ="ID49163FEDRADDD319"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>WTMOT </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                    ID-REF                  ="ID49163FECRADD360C"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADD360C</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>

                  <SW-INSTANCE ID         ="ID49163FEDRAD9583C"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>KFNTL </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                    ID-REF                  ="ID49163FECRADF9F29"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADF9F29</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                  </SW-INSTANCE>

                  <SW-INSTANCE ID         ="ID49163FEDRAD7B2AA"
                               F-ID-CLASS ="SW-INSTANCE"
                               F-NAMESPACE="SW-INSTANCE">
                     <SHORT-NAME>substuff </SHORT-NAME>
                     <SW-INSTANCE-PROPS-VARIANTS>
                        <SW-INSTANCE-PROPS-VARIANT>
                           <DESC>Instanz von
                              <XREF ID-CLASS                ="SW-CLASS-PROTOTYPE"
                                    ID-REF                  ="ID49163FECRADE0ACB"
                                    HYTIME                  ="CLINK"
                                    HYNAMES                 ="LINKEND ID-REF"
                                    SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                    SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                    SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                    SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                    SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRADE0ACB</XREF></DESC>
                        </SW-INSTANCE-PROPS-VARIANT>
                     </SW-INSTANCE-PROPS-VARIANTS>
                     <SW-INSTANCE ID         ="ID49163FEDRADF76EE"
                                  F-ID-CLASS ="SW-INSTANCE"
                                  F-NAMESPACE="SW-INSTANCE">
                        <SHORT-NAME>subparam </SHORT-NAME>
                        <SW-INSTANCE-PROPS-VARIANTS>
                           <SW-INSTANCE-PROPS-VARIANT>
                              <DESC>Instanz von
                                 <XREF ID-CLASS                ="SW-CALPRM-PROTOTYPE"
                                       ID-REF                  ="ID49163FECRAD8F757"
                                       HYTIME                  ="CLINK"
                                       HYNAMES                 ="LINKEND ID-REF"
                                       SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                       SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                       SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                       SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                       SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FECRAD8F757</XREF></DESC>
                           </SW-INSTANCE-PROPS-VARIANT>
                        </SW-INSTANCE-PROPS-VARIANTS>
                     </SW-INSTANCE>

                     <SW-INSTANCE ID         ="ID49163FEDRAD7BD9B"
                                  F-ID-CLASS ="SW-INSTANCE"
                                  F-NAMESPACE="SW-INSTANCE">
                        <SHORT-NAME>subvar </SHORT-NAME>
                        <SW-INSTANCE-PROPS-VARIANTS>
                           <SW-INSTANCE-PROPS-VARIANT>
                              <DESC>Instanz von
                                 <XREF ID-CLASS                ="SW-VARIABLE-PROTOTYPE"
                                       ID-REF                  ="ID49163FEDRADC1F7C"
                                       HYTIME                  ="CLINK"
                                       HYNAMES                 ="LINKEND ID-REF"
                                       SHOW-RESOURCE-TYPE      ="SHOW-TYPE"
                                       SHOW-RESOURCE-NUMBER    ="SHOW-NUMBER"
                                       SHOW-RESOURCE-LONG-NAME ="SHOW-LONG-NAME"
                                       SHOW-RESOURCE-SHORT-NAME="SHOW-SHORT-NAME"
                                       SHOW-RESOURCE-PAGE      ="SHOW-PAGE">ID49163FEDRADC1F7C</XREF></DESC>
                           </SW-INSTANCE-PROPS-VARIANT>
                        </SW-INSTANCE-PROPS-VARIANTS>
                     </SW-INSTANCE>
                  </SW-INSTANCE>
               </SW-INSTANCE>
            </SW-INSTANCE-TREE>
         </SW-INSTANCE-SPEC>
      </SW-SYSTEM>
   </SW-SYSTEMS>
</MSRSW>
Formale Beschreibung
Hat als Kontext: | SW-COMPONENTS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-FULFILS, SW-CLASS-METHODS, SW-CLASS-ATTR, SW-CLASS-ATTR-IMPLS, SW-DATA-DEF-PROPS, SW-FEATURE-VARIABLES, SW-FEATURE-PARAMS, SW-FEATURE-CLASS-INSTANCES, SW-TEST-DESC, SW-APPLICATION-NOTES, SW-MAINTENANCE-NOTES, SW-CARB-DOC, ANNOTATIONS, ADD-INFO
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-CLASS | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | SW-CALPRM-PROTOTYPE SW-CLASS-PROTOTYPE SW-VARIABLE-PROTOTYPE | Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')


1.278. SW-CLASS-ATTR

Beschreibung
Defines the object-oriented class-attributes, populated by the prototypes SW-VARIABLE-PROTOTYPES denoting attributes within the classes which are variables, SW-CALPRM-PROTOTYPES denoting attributes within the classes which are calibration parameters and SW-CLASS-PROTOTYPES denoting attributes within the classes which themselves are instances of classes.
Formale Beschreibung
Hat als Kontext: | SW-CLASS
Ist Kontext für: | SW-VARIABLE-PROTOTYPES, SW-CALPRM-PROTOTYPES, SW-CLASS-PROTOTYPES
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.279. SW-CLASS-ATTR-IMPL

Beschreibung
Defines the object-oriented class-attributes SW-VARIABLE-IMPLS which implement attributes which are variables, SW-CALPRM-IMPLS which implement attributes which are calibration parameters and SW-CLASS-IMPLS which implement attributes which themselves are instances of classes.
Formale Beschreibung
Hat als Kontext: | SW-CLASS-ATTR-IMPLS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-DATA-DEF-PROPS, SW-VARIABLE-IMPLS, SW-CALPRM-IMPLS, SW-CLASS-IMPLS
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | Zeichenkette (CDATA) | SW-CLASS-ATTR-IMPL | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.280. SW-CLASS-ATTR-IMPL-REF

Beschreibung
Dieses Element referenziert <SW-CLASS-ATTR-IMPL>.
Formale Beschreibung
Hat als Kontext: | SW-CALPRM-POINTER, SW-CLASS-IMPL, SW-CLASS-INSTANCE
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-CLASS-ATTR-IMPL | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.281. SW-CLASS-ATTR-IMPLS

Beschreibung
Container Element für <SW-CLASS-ATTR-IMPL>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS
Ist Kontext für: | SW-CLASS-ATTR-IMPL
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.282. SW-CLASS-IMPL

Beschreibung
Dieses Element spezifiziert durch Angabe des Klassen-Prototyps SW-CLASS-PROTOTYPE-REF, um welche sowie der optionalen Angabe von SW
Formale Beschreibung
Hat als Kontext: | SW-CLASS-IMPLS
Ist Kontext für: | SW-CLASS-PROTOTYPE-REF, SW-CLASS-ATTR-IMPL-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.283. SW-CLASS-IMPLS

Beschreibung
Container Element für <SW-CLASS-IMPL>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS-ATTR-IMPL
Ist Kontext für: | SW-CLASS-IMPL
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.284. SW-CLASS-INSTANCE

Beschreibung
Defines the particular instantiation of a referenced <SW-CLASS>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS-INSTANCES
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-ARRAYSIZE, SW-CLASS-REF, SW-CLASS-ATTR-IMPL-REF, SW-DATA-DEF-PROPS, ANNOTATIONS, ADD-INFO
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-CLASS-INSTANCE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.285. SW-CLASS-INSTANCE-REF

Beschreibung
Dieses Element referenziert auf eine <SW-CLASS-INSTANCE>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS-INSTANCE-REFS, SW-FEATURE-EXPORT-CLASS-INSTANCES, SW-FEATURE-IMPORT-CLASS-INSTANCES, SW-FEATURE-LOCAL-CLASS-INSTANCES, SW-INSTANCE-REF-SYSCOND
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-CLASS-INSTANCE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.286. SW-CLASS-INSTANCE-REFS

Beschreibung
Container Element für <SW-CLASS-INSTANCE-REF>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-CONT
Ist Kontext für: | SW-CLASS-INSTANCE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.287. SW-CLASS-INSTANCES

Beschreibung
Container Element für <SW-CLASS-INSTANCE> in einem Data Dictionary.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DICTIONARY-SPEC
Ist Kontext für: | SW-CLASS-INSTANCE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.288. SW-CLASS-METHOD

Beschreibung
Within a Class-method <SW-CLASS-METHOD> it is possible to describe methods of classes in an informal way but within a predefined structure. Note that the description of methods is very compact since it is intended to show all the methods within a table. It is up to the user to use to add more semantics. The <SW-CLASS-METHOD>s are introduced solely for documentation purposes. It allows to describe methods, which can be rendered in various layouts. It is also possible to generate message overviews. The Name of the method is stored in <SHORT-LABEL>. The return value is stored in <SW-CLASS-METHOD-RETURN>. The arguments are stored in <SW-CLASS-METHOD-ARG>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS-METHODS
Ist Kontext für: | LABEL, SHORT-LABEL, DESC, SW-CLASS-METHOD-RETURN, SW-CLASS-METHOD-ARG
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.289. SW-CLASS-METHOD-ARG

Beschreibung
Dieses Element spezifiziert ein Argument einer Klassen-Methode, welches über <SHORT-LABEL> adressierbar ist. <LABEL> gibt textuelle Beschreibung des Argumentes an. Mittels <REMARK> sind Anmerkungen zum Klassenargument möglich.
Formale Beschreibung
Hat als Kontext: | SW-CLASS-METHOD
Ist Kontext für: | LABEL, SHORT-LABEL, REMARK
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.290. SW-CLASS-METHOD-RETURN

Beschreibung
Dieses Element spezifiziert den Rückgabewert einer Klassen-Methode. Dieser wird nicht formalisiert textuell beschrieben.
Formale Beschreibung
Hat als Kontext: | SW-CLASS-METHOD
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.291. SW-CLASS-METHODS

Beschreibung
Container Element für <SW-CLASS-METHOD>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS
Ist Kontext für: | SW-CLASS-METHOD
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.292. SW-CLASS-PROTOTYPE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt die Prototyp-Deklaration eines Klassenattributes, welcher als Klasseninstanz auftritt.
Example
Siehe SW-CLASS
Formale Beschreibung
Hat als Kontext: | SW-CLASS-PROTOTYPES
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-CLASS-REF, SW-ARRAYSIZE, SW-SYSCOND, ANNOTATIONS, ADD-INFO
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | Zeichenkette (CDATA) | SW-CLASS-PROTOTYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.293. SW-CLASS-PROTOTYPE-REF

Beschreibung
Dieses Element zeigt auf einen <SW-CLASS-PROTOTYPE>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS-IMPL
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-CLASS-PROTOTYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.294. SW-CLASS-PROTOTYPES

Beschreibung
Container Element für <SW-CLASS-PROTOTYPE>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS-ATTR
Ist Kontext für: | SW-CLASS-PROTOTYPE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.295. SW-CLASS-REF

Beschreibung
Dieses Element zeigt auf eine <SW-CLASS>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS-INSTANCE, SW-CLASS-PROTOTYPE
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-CLASS | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.296. SW-CODE-SYNTAX
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Codesyntax-Objekte legen die Darstellung der Variablen und Parameter in der Programmquelldatei fest. Diese Codesyntaxobjekte werden in <SW-CODE-SYNTAXES> zentral definiert und durch <SW-CODE-SYNTAX-REF> mit Variablen und Parametern verbunden.
Dieses Element dient im wesentlichen zur Vereinbarung von Keywords (im Subelement <SHORT-NAME>) für Codegenerierungssverfahren. Das Verfahren selbst wird nur verbal (in <SW-CODE-SYNTAX-DESC>), aber nicht formal beschrieben. Dieser Ansatz wurde gewählt, da die Anzahl der möglichen Codesyntaxschemata relativ gering ist. Eine volle formale Beschreibung ist hierfür zu aufwendig.
Es ist jedoch möglich, innerhalb von z.B. <VERBATIM> in <SW-CODE-SYNTAX-DESC> eine prozeßabhängige Micro-Syntax abzulegen und diese durch angemessene Bedatung des Attributes [SI] zu kennzeichnen.
Example
<SW-CODE-SYNTAXES>
   <SW-CODE-SYNTAX ID="IDCS1">
      <LONG-NAME>CodeSyntax-Objekt für Systemkonstanten</LONG-NAME>
      <SHORT-NAME>$cSyKgsSys</SHORT-NAME>
      <SW-CODE-SYNTAX-DESC>
         <VERBATIM>CodeSyntax: $cSyKgsSys CodeSyntax-Objekt für Systemkonstanten HFm: #ifndef <KGR> #define <KGR>
                  <IWERTE> #elif (<KGR> != <IWERTE>) #error >>>> <KGR> multiple defined #endif QFm: /* #define <KGR>
                                 <IWERTE> */ </IWERTE>
                              </KGR></KGR></IWERTE></KGR></IWERTE>
               </KGR></KGR></VERBATIM>
      </SW-CODE-SYNTAX-DESC>
   </SW-CODE-SYNTAX>

   <SW-CODE-SYNTAX ID="IDCS2">
      <LONG-NAME>This is Code Syntax 2</LONG-NAME>
      <SHORT-NAME>Bit</SHORT-NAME>
      <SW-CODE-SYNTAX-DESC>
         <VERBATIM>CodeSyntax: Bit HFm: extern bit <RAM>; QFm: bit <RAM>
                  <INITWERTIDEF>" = <INITWERTIDEF>;">; </INITWERTIDEF></INITWERTIDEF>
               </RAM></RAM></VERBATIM>
      </SW-CODE-SYNTAX-DESC>
   </SW-CODE-SYNTAX>
</SW-CODE-SYNTAXES>
Formale Beschreibung
Hat als Kontext: | SW-CODE-SYNTAXES
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-CODE-SYNTAX-DESC
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-CODE-SYNTAX | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.297. SW-CODE-SYNTAX-DESC

Beschreibung
Verbale Beschreibung des Algorithmus zur Ausgabe der Variablen oder Parameter in die Programmquelldatei (Codegenerierung).
Formale Beschreibung
Hat als Kontext: | SW-CODE-SYNTAX
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.298. SW-CODE-SYNTAX-REF

Beschreibung
Dieses Element referenziert auf eine <SW-CODE-SYNTAX>.
Formale Beschreibung
Hat als Kontext: | SW-CODE-SYNTAX-REFS, SW-DATA-DEF-PROPS
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-CODE-SYNTAX | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.299. SW-CODE-SYNTAX-REFS

Beschreibung
Container Element für <SW-CODE-SYNTAX-REF>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-CONT
Ist Kontext für: | SW-CODE-SYNTAX-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.300. SW-CODE-SYNTAXES

Beschreibung
Container Element für <SW-CODE-SYNTAX>.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DICTIONARY-SPEC
Ist Kontext für: | ADMIN-DATA, SW-CODE-SYNTAX
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.301. SW-CODED-TYPE

Beschreibung
Benennt die Codierung eines Datenobjektes eines Basistypen im Speicher. Es ist daher ein Schlüsselwort, das die Interpretation der Bits in einem Basistypen spezifiziert. Mögliche Werte sind:
unsinged | Es handelt sich um eine vorzeichenlose Integer-Zahl.
signed | Es handelt sich um eine vorzeichenbehaftete Integer-Zahl.
bcd | Es handelt sich um eine binärcodierte Dezimalzahl.
IEEE_floating_point | Es handelt sich um eine Fließkommazahl nach IEEE-Standard. Diese Standards existieren für 32- und für 64 Bit Fließkommazahlen.
DSP-fractional | Dies ist an fraktaler Datentyp, er im Zusammenhang mit digitalen Signalprozessoren auftritt, z.B. Siemens Tricore databook.
Gibt an, ob der aktuelle Datentyp ein Vorzeichen hat, d.h. SIGNED oder UNSIGNED ist. Inhalt von SW-CODED-TYPE ist z.B. für einen vorzeichenbehafteten Datentyp:
<SW-CODED-TYPE>SIGNED</SW-CODED-TYPE>
Formale Beschreibung
Hat als Kontext: | SW-BASE-TYPE, SW-MC-BASE-TYPE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.302. SW-COLLECTION

Beschreibung
<SW-COLLECTION> describes a generic group mechanism which allows free grouping of different objects in the DTD (especially <sw-variables>, <sw-param>s and <sw-function>s). The composition is located within <SW-COLLECTION-CONT>.
There may be several motivations to define groups such as
  • application of access rights
  • building work packages for the calibration phase
  • assigning responsibilities
  • general data management
  • Selection criteria in an MCD-System.
A group can specify sub groups. A generic collection mechanism is implemented, supporting the following requests:
  • Collections comprise of objects such as variables, calibration parameters, functions, collections, compu-methods, units etc. (thus allowing nested collections).
  • Collections are assigned to multiple purposes which can be predefined as well as be freely defined.
  • The contents of a collection are defined denoting objects being member of the collection. For sake of clarity, exclusion is not requested. It can be achieved by inverting collections at the time they are applied.
  • Collections can be inverted when thery are applied to any purpuose.
  • Purposes defined via collections may override properties defined elsewhere in the ASAP file. For instance, if a parameter belongs to a collection with the pupose "readonly", it cannot be manipulated in the mcd system regardless of the value of the attribute [calibration].
  • It is possible to define the rules how a collection is established (<sw-collection-rules>). The objects can be selected using references, wildcards, regular expresions. In a latter version additional means may be impelemented such as properties, query languages, scripting (which is already implemented as a preliminary solution in the dtd).
  • Collections can furtheron be defined by applying previously defined collections (<sw-collection-refs>). Circular references are not allowed and must be detected.
  • The collections are also specified as the result of applying the rules to the database and resolving <sw-collection-refs> (acting as subcollections).
    If a collection is applied, only the result is considerd.
    References within elements (e.g. the variable of a parameter axis) of the result are not resolved automatically. This means that the collection comprises only of those object mentioned explicitly.
  • Whenever a collection is applied, it can be used inverted or direct. This is specified using the attribute [invert] in <sw-collection-ref>.
  • Collections apply to only one file (strictly speaking to one parse unit).
  • The collections are unordered.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTIONS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, ANNOTATION, SW-COLLECTION-RULES, SW-COLLECTION-REFS, SW-COLLECTION-CONT
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[ID]
obligatorisch
Identifikator (ID)
Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[ROOT]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • ROOT
  • NO-ROOT
Diese Collection wird in einem Verstellsystem angezeigt als möglicher Einstiegspunkt für eine weitere Navigation. DAmit hat man die möglichkeit, verschiedene Sichten auf die Daten im Steuergerät zu erzeugen, und auch entsprechende Navigatoren anzubieten. Beispiel :
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS]
festgelegter Wert
SGML Zeichenkette (NMTOKEN)
SW-COLLECTION
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.303. SW-COLLECTION-CONT

Beschreibung
Dieses Element beinhaltet die Zusammenstellung einer <SW-COLLECTION>, welche aus beliebigen Objekten einer Steuergerätesoftware bestehen kann.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION
Ist Kontext für: | SW-FEATURE-REFS, SW-UNIT-REFS, SW-VARIABLE-REFS, SW-CALPRM-REFS, SW-INSTANCE-REFS, SW-CLASS-INSTANCE-REFS, SW-COMPU-METHOD-REFS, SW-ADDR-METHOD-REFS, SW-RECORD-LAYOUT-REFS, SW-CODE-SYNTAX-REFS, SW-BASE-TYPE-REFS, SW-SYSTEMCONST-REFS, SW-DATA-CONSTR-REFS, SW-AXIS-TYPE-REFS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.304. SW-COLLECTION-REF

Beschreibung
Dieses Element referenziert eine <SW-COLLECTION>.
Formale Beschreibung
Hat als Kontext: | SW-ACCESS-DEF, SW-COLLECTION-REFS
Ist Kontext für: | Text
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[ID-REF]
obligatorisch
ID-Referenz (IDREF)
Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[INVERT]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • INVERT
  • NO-INVERT
INVERT kann die Werte INVERT und NO-INVERT annehmen. Im Falle von INVERT wird die Collection excludiert. Das heisst, wenn in einer SW-Collection eine andere referenziert ist, welche INVERT="INVERT" hat, dann werden die Elemente der referenzierten Collection aus der Gesamtergebnismenge herausgenommen.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME]
festgelegter Wert
SGML Zeichenkette (NMTOKEN)
CLINK
HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES]
festgelegter Wert
SGML Zeichenketten (NMTOKENS)
LINKEND ID-REF
HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS]
festgelegter Wert
SGML Zeichenkette (NMTOKEN)
SW-COLLECTION
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.305. SW-COLLECTION-REFS

Beschreibung
Container Element für <SW-COLLECTION-REF>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION
Ist Kontext für: | SW-COLLECTION-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.306. SW-COLLECTION-REGEXP

Beschreibung
Dieses Element spezifiziert einen regulären Ausdruck, z.B. [a-zA-Z0-9_], welcher auf der aktuell zu selektierenden Menge auszuführen ist.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-REGEXPS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.307. SW-COLLECTION-REGEXPS

Beschreibung
Container Element für <SW-COLLECTION-REGEXP>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-RULE
Ist Kontext für: | SW-COLLECTION-REGEXP
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.308. SW-COLLECTION-RULE

Beschreibung
Beschreibt eine Regel, mit der Objekte für eine Sammlung <SW-COLLECTION> ausgewählt werden können. Diese Auswahl ist möglich durch:
  • Wildcards auf <SHORT-NAME>s der auszuwählenden Objekte (<SW-COLLECTION-WILDCARDS>)
  • Reguläre Ausdrücke auf <SHORT-NAME>s der auszuwählenden Objekte (<SW-COLLECTION-REGEXPS>)
  • Scripts (<SW-COLLECTION-SCRIPTS>)
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-RULES
Ist Kontext für: | SW-COLLECTION-REGEXPS, SW-COLLECTION-WILDCARDS, SW-COLLECTION-SCRIPTS
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[SCOPE]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • SW-ADDR-METHOD
  • SW-AXIS-TYPE
  • SW-BASE-TYPE
  • SW-CALPRM
  • SW-CLASS-INSTANCE
  • SW-CODE-SYNTAX
  • SW-COMPU-METHOD
  • SW-DATA-CONSTR
  • SW-FEATURE
  • SW-INSTANCE
  • SW-RECORD-LAYOUT
  • SW-SYSTEMCONST
  • SW-UNIT
  • SW-VARIABLE
  • ALL
Gibt den Typen des Objektes an, der auszuwählen ist, z.B. SW-VARIABLE, SW-CALPRM. Der Inhalt dieses Attributes muß mit dem Inhalt des Elementes <SW-COLLECTION-CONT> parallel zum Vaterelement <SW-COLLECTION-RULES> übereinstimmen.
[RESOLVE-REFS]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • RESOLVE-REFS
  • NOT-RESOLVE-REFS
Gibt an, ob die von den ausgewählten Objekten verbundenen Objekte, z.B. Umrechnungsformeln, mit in die Auswahl übernommen werden.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.309. SW-COLLECTION-RULES

Beschreibung
Container Element für <SW-COLLECTION-RULE>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION
Ist Kontext für: | SW-COLLECTION-RULE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.310. SW-COLLECTION-SCRIPT

Beschreibung
Dieses Element spezifiziert ein Script in der Sprache [LANGUAGE], welches auf der aktuell zu selektierenden Menge auszuführen ist.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-SCRIPTS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[LANGUAGE] optional | Zeichenkette (CDATA) | Sprache, welches auf der aktuell zu selektierende Menge auszuführen ist.
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.311. SW-COLLECTION-SCRIPTS

Beschreibung
Container Element für <SW-COLLECTION-SCRIPT>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-RULE
Ist Kontext für: | SW-COLLECTION-SCRIPT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.312. SW-COLLECTION-SPEC

Beschreibung
Beschreibt Inhalten von Parameter- und Variablengruppen.
Formale Beschreibung
Hat als Kontext: | SW-SYSTEM
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-COLLECTIONS, ADD-INFO
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.313. SW-COLLECTION-WILDCARD

Beschreibung
Dieses Element spezifiziert eine Wildcard (z.B. ABC*), welche auf die aktuell zu selektierende Menge, z.B. <SHORT-NAME>s, anzuwenden ist.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-WILDCARDS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.314. SW-COLLECTION-WILDCARDS

Beschreibung
Container Element für <SW-COLLECTION-WILDCARD>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-RULE
Ist Kontext für: | SW-COLLECTION-WILDCARD
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.315. SW-COLLECTIONS

Beschreibung
Container Element für <Sw-COLLECTION>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-SPEC
Ist Kontext für: | SW-COLLECTION
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.316. SW-COMPARISON-VARIABLES

Beschreibung
These variables can be used to display the value of a variable on the value axis of a calibration parameter (characteristic) currently displayed in the MCD-System. The purpose is to compare the corresponding result value of the calibration parameter in question with some value being calculated or taken from a sensor (the comparison variable).
The only reason for the existence of this comparison-variable is for sake of the calibration process.
Abbildung 1: Darstellung von Comparison-Variable am Bildschirm
     Vs |              |
        |              |
        |              |
     V _|______________|______________
        |         /----|------
        |  /-----/     |
        | /            |
        |/             |
        |--------------|--------------
                       tx          tmot

        tx: akt. Temperatur
        V:  akt. Geschwindigkeit eingeblendet im MCD-System
            zu Vergleichszwecken: SW-COMPARISON-VARIABLE
        Vs: Geschwindigkeitsschwelle über Temperatur
        tmot: Motortemperatur
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | SW-VARIABLE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.317. SW-COMPONENT-SPEC

Beschreibung
Nimmt Beschreibungen der Komponenten des SW-Systems innerhalb von <SW-COMPONENTS> auf:
  1. Funktionalen Eigenschaften oder Funktionen in der SW eines Steuergerätes (<SW-FEATURE>).
  2. Klassen (<SW-CLASS>)
  3. sonstigen Beschreibungen (<CHAPTER>), welche nicht direkt in der Steuergerätesoftware auftauchen.
Die Struktur von <SW-COMPONENT-SPEC> ist insoweit dokumentlastig, als daß die Reihenfolge so gewählt wird, daß sie der gewünschten gedruckten Dokumentation entspricht. Die Struktur der Komponenten ist semiformal, d.h. die Eigenschaften werden im wesentlichen als Freitexte beschrieben. Eine formale Struktur liegt für Datenflüsse (<SW-FEATURE-VARIABLES> usw.) vor.
Die konzeptuellen Unterschiede zwischen <SW-FEATURE> und <SW-CLASS> finden sich in folgender Tabelle Correlation between classes and feature.
Correlation between classes and feature
Feature
Class
Purpose
Used for specific features of the ECU
Used as reusable functionality (building block) to establish features
Interfaces
Messages and global variables used as inputs and outputs
A class can have methods which can invoked.
Instantiation
The feature is instantiated implicitly. Therefore a feature can be instantiated only once within one software system.
The class must be instatiated within one or more features.
scope of Variables and parameters, namespaces
The feature can have local variables/parameters as well as global ones. The communication merely uses the global ones.
a class can establish local variables/parameters for memory purposes.
If the MCD-system needs access to such variables/parameters, then they are instantiated with the instantiation of the class itself.
A class may touch global variables/parameters which are already instantiated.
Implementation
The implementation of variables/parameters may differ from instance to instance. Therefore it must be possible to manipulate the implementation of the variables/parameters when the class is instantiated
Class types
Basically there are two kinds of classes:
  • classes which establish visible and calibratable variables/parameters. We call this open classes
  • classes which do not establish visible variables/parameters. We call this closed classes
"Open" and "closed" reflects the view of the calibration phase.
If packages are introduced, it is not necessary to keep this distinction.
Remarks
Classes can be very large such as "exhaust-gas-control" or very small such as "delay". The large ones are instantiated only a few times while the small ones tend to be instantiated pretty often.
In most cases, large classes appear as open classes while small classes appear as closed ones.
Documentation
The features are described in various aspects such as <sw-feature-defintion>, <sw-carb-doc> etc.
In case of "large" classes, the description of class comes close to the documentation of a feature. On the other hand "small" classes may only described as a small table, with the graphical image and the methods.
In general a specific structure for the documentation of methods is recommended.
Relevant in ASAP/MSR
features are relevant at any time, since they establish the system at all.
Primarily the "open" classes are relevant for documentation purposes as well as for the instantiation of variables/parameters.
Therefore it is expected that in an MSRSW-file only those classes are must be instantiated within features which instantiate variables/parameters.
Formale Beschreibung
Hat als Kontext: | SW-SYSTEM
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-COMPONENTS, SW-ROOT-FEATURES, ADD-INFO
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.318. SW-COMPONENTS

Beschreibung
Container Element für <SW-CLASS>, <SW-FEATURE>.
Formale Beschreibung
Hat als Kontext: | SW-COMPONENT-SPEC
Ist Kontext für: | CHAPTER, SW-CLASS, SW-FEATURE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.319. SW-COMPU-CONST
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element wird verwendet, wenn in einem Abschnitt einer Umrechnungsformel ein konstanter Wert gilt. Dadurch wird die Konstanz des Abschnitts eindeutig markiert.
Example
<SW-COMPU-SCALE>
   <LOWER-LIMIT INTERVAL-TYPE="CLOSED">0</LOWER-LIMIT>
   <UPPER-LIMIT INTERVAL-TYPE="CLOSED">10</UPPER-LIMIT>
   <sw-compu-const>
      <VT>FALSE</VT>
   </sw-compu-const</E>
</SW-COMPU-SCALE>
<SW-COMPU-SCALE>
   <UPPER-LIMIT INTERVAL-TYPE="CLOSED">20</UPPER-LIMIT>
   <sw-compu-const>
      <VT>TRUE</VT>
   </sw-compu-const</E>
</SW-COMPU-SCALE>
Formale Beschreibung
Hat als Kontext: | SW-COMPU-SCALE
Ist Kontext für: | VF, V, VT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.320. SW-COMPU-DEFAULT-VALUE

Beschreibung
Dieses Element kann verwendet werden, um einen Ausgabewert für eine Umrechnungsformel zu spezifizieren, falls der umzurechnende Wert außerhalb der Plausibilitätsgrenze liegt. Dies ist für alle Umrechnungsformeln möglich, besonders aber für Variablen mit tabellarischen Umrechnungsformeln.
Es wird empfohlen, daß in MCD-Systemen dieser Default-Wert nicht einstellbar ist, weil sonst fehlerhafte Bedingungen nicht erkannt werden können.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-INTERNAL-TO-PHYS, SW-COMPU-PHYS-TO-INTERNAL
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.321. SW-COMPU-DENOMINATOR
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Beschreibt die rationalen Koeffizienten für den Nenner in einer gebrochen rationalen Umrechnungsformel mit rationalen Koeffizienten.
Example
siehe SW-COMPU-RATIONAL-COEFFS
Formale Beschreibung
Hat als Kontext: | SW-COMPU-RATIONAL-COEFFS
Ist Kontext für: | VF, V
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.322. SW-COMPU-GENERIC-MATH

Beschreibung
Dieses Element beschreibt eine Berechnungs-Formel als einen einfache arithmetischen Ausdruck, in dem System-Konstanten, referenziert durch <SW-SYSTEMCONST-CODED-REF> und <SW-SYSTEMCONST-PHYS-REF>, substituiert werden.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-SCALE
Ist Kontext für: | Text, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF
Name | Typ | Anmerkung
[LEVEL] optional | SGML Zeichenkette (NMTOKEN) | Platzhalter, um einen Indikator eines Sprachlevels für die Mathematik zu beschreiben, z.B. INFORMAL oder MATHML2.0
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.323. SW-COMPU-IDENTITY

Beschreibung
Falls angegeben, wird durch <SW-COMPU-IDENTITY> eine 1:1-Umrechnung spezifiziert.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-METHOD
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.324. SW-COMPU-INTERNAL-TO-PHYS

Beschreibung
Beschreibt die Umrechnungsformel, die interne Werte in physikalische Werte umrechnet.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-METHOD
Ist Kontext für: | SW-COMPU-SCALES, SW-COMPU-DEFAULT-VALUE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.325. SW-COMPU-INVERSE-VALUE

Beschreibung
Dieses Element dient dazu, für einen Definitionsabschnitt (<SW-COMPU-SCALE>) einer Umrechnungsformel einen Funktionswert zu spezifizieren. Durch Angabe des inversen Wertes werden abschnittsweise konstante Funktionen eindeutig umkerhrbar. Hierdurch entfällt die ansonsten notwendige Spezifikation der Umkehrfunktion.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-SCALE
Ist Kontext für: | VF, V, VT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.326. SW-COMPU-METHOD
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Beschreibt die Beziehung zwischen physikalischen und normierten Größen. Dafür gelten folgende Prinzipien:
  • Die Umrechnung kann in beiden Richtungen spezifiziert werden. Bei eineindeutiger Abbildung kann die Spezifikation in eine Richtung entfallen.
  • Die Umrechnung selber wird abschnittsweise (<SW-COMPU-SCALES>) definiert. Dafür gelten Vereinfachungsmöglichkeiten bei stetigen Abbildungen. Im Falle einer 1:1-Abbildung wird das Element <SW-COMPU-IDENTITY> eingesetzt, d.h. die 1:1-Abbildung wird explizit markiert.
  • Die Umrechnungsformel bestimmt die physikalischen Eigenschaften. Daher ist sie mit Maßeinheiten behaftet (<SW-UNIT-REF>).
  • Die Umrechnungsformel bestimmt nicht die datentechnische Ablage der normierten Größen. Deshalb ist kein Verweis auf SW-BASE-TYPE vorhanden. Die datentechnische Ablage der normierten Größen ist bei den entsprechenden Datenobjekten (z.B. <SW-VARIABLE>) zu spezifizieren.
  • Die Umrechnungsformel hat Wertebereiche für Ihre Ein- und Ausgangsgrößen. Diese können sowohl direkt als auch indirekt sowie auf physikalischer Ebene und auf normierter Ebene spezifiziert werden.
Einzelheiten zu Umrechnungsformeln finden sich in
Hierfür können Umrechnungen von physikalischen nach internen Werten oder umgekehrt spezifiziert werden (<SW-COMPU-PHYS-TO-INTERNAL>, <SW-COMPU-INTERNAL-TO-PHYS>), Anzeigeformate angegeben (<SW-DISPLAY-FORMAT>), Maßeinheiten referenziert (<SW-UNIT-REF>) sowie Intervallgrenzen angegeben werden (<SW-PHYS-CONSTRS-1>, <SW-INTERNAL-CONSTRS-1>). Für die Auszeichnung von 1:1-Umrechnungen dient das Element <SW-COMPU-IDENTITY>.
Example
<SW-COMPU-METHOD ID="B-TRUE">
   <LONG-NAME>this is SW-COMPU-METHOD B-TRUE</LONG-NAME>
   <SHORT-NAME>B_TRUE</SHORT-NAME>
   <SW-DISPLAY-FORMAT>%s</SW-DISPLAY-FORMAT>
   <SW-COMPU-INTERNAL-TO-PHYS>
      <SW-COMPU-SCALES>
         <SW-COMPU-SCALE>
            <LOWER-LIMIT INTERVAL-TYPE="CLOSED">0</LOWER-LIMIT>
            <UPPER-LIMIT INTERVAL-TYPE="CLOSED">0</UPPER-LIMIT>
            <SW-COMPU-INVERSE-VALUE>
               <V>0</V>
            </SW-COMPU-INVERSE-VALUE>
            <SW-COMPU-CONST>
               <VT>FALSE</VT>
            </SW-COMPU-CONST>
         </SW-COMPU-SCALE>
         <SW-COMPU-SCALE>
            <LOWER-LIMIT INTERVAL-TYPE="CLOSED">1</LOWER-LIMIT>
            <UPPER-LIMIT INTERVAL-TYPE="CLOSED">1</UPPER-LIMIT>
            <SW-COMPU-INVERSE-VALUE>
               <V>1</V>
            </SW-COMPU-INVERSE-VALUE>
            <SW-COMPU-CONST>
               <VT>TRUE</VT>
            </SW-COMPU-CONST>
         </SW-COMPU-SCALE>
         <SW-COMPU-SCALE>
            <LOWER-LIMIT INTERVAL-TYPE="CLOSED">2</LOWER-LIMIT>
            <UPPER-LIMIT INTERVAL-TYPE="CLOSED">2</UPPER-LIMIT>
            <SW-COMPU-INVERSE-VALUE>
               <V>2</V>
            </SW-COMPU-INVERSE-VALUE>
            <SW-COMPU-CONST>
               <VT></VT>
            </SW-COMPU-CONST>
         </SW-COMPU-SCALE>
      </SW-COMPU-SCALES>
   </SW-COMPU-INTERNAL-TO-PHYS>
</SW-COMPU-METHOD>
Formale Beschreibung
Hat als Kontext: | SW-COMPU-METHODS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-DISPLAY-FORMAT, SW-UNIT-REF, SW-DATA-CONSTR-REF, SW-PHYS-CONSTRS-1, SW-INTERNAL-CONSTRS-1, SW-COMPU-IDENTITY, SW-COMPU-PHYS-TO-INTERNAL, SW-COMPU-INTERNAL-TO-PHYS
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-COMPU-METHOD | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.327. SW-COMPU-METHOD-REF

Beschreibung
Dieses Element referenziert eine <SW-COMPU-METHOD>.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-INDIVIDUAL, SW-COMPU-METHOD-REFS, SW-CONSTR-OBJECTS, SW-DATA-DEF-PROPS, SW-VCD-CRITERION
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-COMPU-METHOD | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.328. SW-COMPU-METHOD-REFS

Beschreibung
Container Element für <SW-COMPU-METHOD-REF>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-CONT
Ist Kontext für: | SW-COMPU-METHOD-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.329. SW-COMPU-METHODS

Beschreibung
Container Element für <SW-COMPU-METHOD>.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DICTIONARY-SPEC
Ist Kontext für: | ADMIN-DATA, SW-COMPU-METHOD
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.330. SW-COMPU-NUMERATOR
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Beschreibt die rationalen Koeffizienten für den Zähler in einer gebrochen rationalen Umrechnungsformel mit rationalen Koeffizienten.
Example
siehe SW-COMPU-RATIONAL-COEFFS
Formale Beschreibung
Hat als Kontext: | SW-COMPU-RATIONAL-COEFFS
Ist Kontext für: | VF, V
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.331. SW-COMPU-PHYS-TO-INTERNAL
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Beschreibt die Umrechnungsformel, die physikalische Werte in interne Werte umrechnet.
Interner Wert = Summe in <SW-COMPU-NUMERATOR> über <VF> i * physi / Summe in <SW-COMPU-DENOMINATOR> über <VF> i * physi
Example
Die folgende gebrochen rationale Umrechnungsformel modelliert die Formel:
internal = (1 * phys + 2 / 40)
<SW-COMPU-RATIONAL-COEFFS>
   <SW-COMPU-NUMERATOR>
      <VF>2</VF>
      <VF>1</VF>
   </SW-COMPU-NUMERATOR>
   <SW-COMPU-DENOMINATOR>
      <VF>40</VF>
   </SW-COMPU-DENOMINATOR>
</SW-COMPU-RATIONAL-COEFFS>
Formale Beschreibung
Hat als Kontext: | SW-COMPU-METHOD
Ist Kontext für: | SW-COMPU-SCALES, SW-COMPU-DEFAULT-VALUE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.332. SW-COMPU-PROGRAM-CODE

Beschreibung
Dieses Element beinhaltet die beschreibung einer Berechnungs-Formel in der Notation einer Programmiersprache.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-SCALE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[LANG-SUBSET] optional | Zeichenkette (CDATA) | Beschreibt das anzuwendende Sprachsubset für den Programmcode. Z.B. Ansii-C
[USED-LIBS] optional | Zeichenkette (CDATA) | Bezeichnet die verwendeten Bibliotheken.
[PROGRAM-LANG] optional | Zeichenkette (CDATA) | Bezeichnet die verwendete Programmiersprache.
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.333. SW-COMPU-RATIONAL-COEFFS

Beschreibung
Beschreibt die rationalen Koeffizienten für Zähler (<SW-COMPU-NUMERATOR>) und Nenner (<SW-COMPU-DENOMINATOR>) der Skalierungsvorschrift im Vaterelement <SW-COMPU-SCALE>.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-SCALE
Ist Kontext für: | SW-COMPU-NUMERATOR, SW-COMPU-DENOMINATOR
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.334. SW-COMPU-SCALE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Beschreibt, wie von internen nach physikalischen Werten (oder umgekehrt) umgerechnet wird. Hierbei können obere und untere Grenzen (<UPPER-LIMIT>, <LOWER-LIMIT>) sowie die Koeffizienten einer gebrochen rationalen Umrechnungsvorschrift (<SW-COMPU-RATIONAL-COEFFS>) festgelegt werden.
Example
In dem Beispiel (siehe <SW-COMPU-METHOD>) werden Intervalle von internen Werten tabellarisch auf Funktionswerte zugeordnet.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-SCALES
Ist Kontext für: | C-IDENTIFIER, DESC, LOWER-LIMIT, UPPER-LIMIT, SW-COMPU-INVERSE-VALUE, SW-COMPU-CONST, SW-COMPU-RATIONAL-COEFFS, SW-COMPU-PROGRAM-CODE, SW-COMPU-GENERIC-MATH
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.335. SW-COMPU-SCALES

Beschreibung
Container Element für <SW-COMPU-SCALE>.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-INTERNAL-TO-PHYS, SW-COMPU-PHYS-TO-INTERNAL
Ist Kontext für: | SW-COMPU-SCALE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.336. SW-CONSTR-LEVEL
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt die Kategorie einer Constraint. Diese können u.a. dahingehend verwendet werden, daß bei Verletzung von Constraints ab einem bestimmten Level Fehlermeldungen produziert werden.
Der Inhalt von <SW-CONSTR-LEVEL> ist eine positive Ganzzahl. Je höher der Level, desto schärfer ist die Prüfung.
Die Festlegung der Level selbst ist prozeßabhängig und wird den Prozeßpartnern zu vereinbaren.
Example
<SW-DATA-CONSTR>
   <SHORT-NAME>NMOT_GE0</SHORT-NAME>
   <DESC>Drehzahl darf nicht negativ sein!</DESC>
   <SW-DATA-CONSTR-RULE>
      <SW-CONSTR-LEVEL>3</SW-CONSTR-LEVEL>
      <SW-INTERNAL-CONSTRS>
         <LOWER-LIMIT INTERVAL-TYPE="CLOSED">0</LOWER-LIMIT>
      </SW-INTERNAL-CONSTRS>
   </SW-DATA-CONSTR-RULE>
</SW-DATA-CONSTR>
Formale Beschreibung
Hat als Kontext: | SW-DATA-CONSTR-RULE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.337. SW-CONSTR-OBJECTS

Beschreibung
Parameter bzw. Variablen können auf Plausibilitätskontrollen referenzieren. Durch die Bedatung von <SW-CONSTR-OBJECTS> wird die umgekehrte Richtung ermöglicht.
Hierdurch können z.B. in externen Dateien abgelegte Plausibilitäts-Bibliotheken unterhalb vom Vorfahrelement <SW-DATA-CONSTRS>-Element eingeklinkt werden.
Formale Beschreibung
Hat als Kontext: | SW-DATA-CONSTR
Ist Kontext für: | SW-VARIABLE-REF, SW-CALPRM-REF, SW-COMPU-METHOD-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.338. SW-CPU-ADDR-EPK

Beschreibung
Dieses Element gibt die Addresse des EPROM-Identifiers an. Es korrespondiert zum ASAM-Keyword ADDR_EPK.
Formale Beschreibung
Hat als Kontext: | SW-CPU-SPEC
Ist Kontext für: | SW-ADDR-INFO
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.339. SW-CPU-CALIBRATION-OFFSET
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element spezifiziert einen festen Adressoffset, der beim Zugriff auf Kalibrierparameter hinzuzurechnen ist. Dies ist von Bedeutung bei
  • Near Pointers in calibration objects. Some record layouts include near pointers inside a calibration object from which the calibration system has to compute the absolute values by adding the <SW-CPU-CALIBRATION-OFFSET>.
  • Variant Coding. Some ECU projects include multiple data sets for different engine or vehicle projects served by one common ECU. By using the <SW-CPU-CALIBRATION-OFFSET>, a selection for project base address can be made.
Example
<SW-CPU-CALIBRATION-OFFSET>0x1000</SW-CPU-CALIBRATION-OFFSET>
Formale Beschreibung
Hat als Kontext: | SW-CPU-SPEC
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.340. SW-CPU-EPK
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element spezifiziert den EPROM-Identifier des Steuergerätes, also den String, der unter der Adresse von <SW-CPU-ADDR-EPK> im Steuergerät gefunden werden sollte.
Example
<SW-CPU-EPK>EPROM identifier test</SW-CPU-EPK>
Formale Beschreibung
Hat als Kontext: | SW-CPU-SPEC
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.341. SW-CPU-MEM-SEG
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
A <SW-CPU-MEM-SEG> has a name which can be used for references from Interface-Data-Blobs and an accurate description of the memory by memory types <SW-MEM-TYPE> and attributes <SW-MEM-ATTR> (INTERN and EXTERN). The parameter <SW-MEM-OFFSET> is to be used to describe several mirrored segments. <SW-CPU-MEM-SEGS> with the same <SW-MEM-TYPE> and the same <SW-MEM-ATTR> may not overlap. Also all <SW-CPU-MEM-SEG> with the <SW-MEM-PROGRAM-TYPE> CODE, DATA, OFFLINE_DATA, RESERVED may not overlap mutually to get a linear address space for access on calibration data. All other <SW-CPU-MEM-SEG>s with different <SW-MEM-TYPE> or different <SW-MEM-ATTR> may however overlap, e.g. internal and external memory segments.
The following table gives a description for some useful combinations of <SW-MEM-PROGRAM-TYPE> and <SW-MEM-TYPE> and their meanings:
Useful Combinations for <SW-MEM-PROGRAM-TYPE> and <SW-MEM-TYPE>
Combination | Meaning
CODE/FLASH | Executable code, has to be preserved for download and HEX-file generation
DATA/FLASH or DATA/EEPROM | Calibration data, can be modified by the user via calibration systems.
RESERVED/FLASH | specific code or data, has to be preserved for HEX-file generation but not for download.
DATA/RAM | Calibration data, will be modified by ECU and calibration systems.
OFFLINE_DATA/FLASH | Calibration data, will be modified only without ECU access, online calibration is not allowed.
VARIABLES/RAM | RAM of the ECU for variables (measurement values and others).
REGISTER/RAM | RAM of the ECU for special purpose values.
SERAM/RAM | ECU-RAM section available for serial application. For usage see also: SW-CALIBRATION-METHOD.
Hinweis
FLASH has been used as synonym for EPROM and ROM.
Example
<SW-CPU-MEM-SEGS>
   <SW-CPU-MEM-SEG>
      <LONG-NAME>Data internal Flash</LONG-NAME>
      <SHORT-NAME>Data1</SHORT-NAME>
      <DESC>This describes Data for internal Flash.</DESC>
      <SW-MEM-PROGRAM-TYPE>DATA</SW-MEM-PROGRAM-TYPE>
      <SW-MEM-TYPE>FLASH</SW-MEM-TYPE>
      <SW-MEM-ATTR>INTERN</SW-MEM-ATTR>
      <SW-MEM-BASE-ADDR>0x4000</SW-MEM-BASE-ADDR>
      <SW-MEM-SIZE>0x200</SW-MEM-SIZE>
      <SW-MEM-OFFSETS>0x10000</SW-MEM-OFFSETS>
   </SW-CPU-MEM-SEG>
</SW-CPU-MEM-SEGS>
Formale Beschreibung
Hat als Kontext: | SW-CPU-MEM-SEGS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-MEM-PROGRAM-TYPE, SW-MEM-TYPE, SW-MEM-ATTR, SW-MEM-BASE-ADDR, SW-MEM-SIZE, SW-MEM-OFFSETS, SW-MC-INSTANCE-INTERFACES
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | Zeichenkette (CDATA) | SW-CPU-MEM-SEG | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.342. SW-CPU-MEM-SEG-REF

Beschreibung
Dieses Element referenziert <SW-CPU-MEM-SEG>.
Formale Beschreibung
Hat als Kontext: | SW-ADDR-INFO, SW-ADDR-METHOD
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-CPU-MEM-SEG | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.343. SW-CPU-MEM-SEGS

Beschreibung
Container Element für <SW-CPU-MEM-SEG>.
Formale Beschreibung
Hat als Kontext: | SW-CPU-SPEC
Ist Kontext für: | SW-CPU-MEM-SEG
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.344. SW-CPU-NUMBER-OF-INTERFACES
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element spezifiziert die Anzahl von Kalibrierschnittstellen, die von der CPU bereitgestellt werden.
Example
<SW-CPU-NUMBER-OF-INTERFACES>2</SW-CPU-NUMBER-OF-INTERFACES>
Formale Beschreibung
Hat als Kontext: | SW-CPU-SPEC
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.345. SW-CPU-SPEC

Beschreibung
This element is to specify the relevant details of the CPU within the control unit according to ASAM-MCD-2MC. If one ECU contains multiple CPUs then we have multiple <SW-SYSTEM>s.
Formale Beschreibung
Hat als Kontext: | SW-SYSTEM
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, BYTE-ORDER, SW-BASE-TYPE-SIZE, SW-MEM-ALIGNMENT, SW-CPU-STANDARD-RECORD-LAYOUT, SW-CPU-MEM-SEGS, SW-CPU-EPK, SW-CPU-ADDR-EPK, SW-CPU-TYPE, SW-CPU-CALIBRATION-OFFSET, SW-CPU-NUMBER-OF-INTERFACES, ADD-INFO
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.346. SW-CPU-STANDARD-RECORD-LAYOUT

Beschreibung
Dieses Element spezifiziert das Default-Record Layout, welches dann gültig ist, falls bei einem Kalibrierparameter keine Record Layout spezifiziert ist.
Formale Beschreibung
Hat als Kontext: | SW-CPU-SPEC
Ist Kontext für: | SW-RECORD-LAYOUT-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.347. SW-CPU-TYPE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt verbal den Typ der verwendeten CPU.
Example
<SW-CPU-TYPE>Intel 4711</SW-CPU-TYPE>
Formale Beschreibung
Hat als Kontext: | SW-CPU-SPEC
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.348. SW-CS-CONTEXT
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element spezifiziert das aktuelle Arbeitspaket für den aktuelle Applikations-Status für ein Applikations-Objekt. Ein Arbeitspaket ist eine Zusammenfassung kompletter Funktionen.
Example
Siehe SW-CS-HISTORY.
Formale Beschreibung
Hat als Kontext: | SW-CS-ENTRY
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.349. SW-CS-DATA-IDENTIFIER
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element spezifiziert die Version eines Datenstands eines bestimmten Applikationsstatus für eine zu applizierende Kenngröße.
Example
Siehe SW-CS-HISTORY.
Formale Beschreibung
Hat als Kontext: | SW-CS-ENTRY
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.350. SW-CS-ENTRY
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt einen Eintrag in der Historie aller Applikationsstati. Für folgende Elemente können Applikationsstati angegeben werden:
  • Kenngrößen
  • Funktionen
  • Arbeitspaktete (Zusammenfassung von Funktionen)
  • Datenstand
Example
Siehe SW-CS-HISTORY.
Formale Beschreibung
Hat als Kontext: | SW-CS-HISTORY
Ist Kontext für: | SW-CS-STATE, SW-CS-CONTEXT, SW-CS-PROJECT-INFO, SW-CS-TARGET-VARIANT, SW-CS-TEST-OBJECT, SW-CS-PROGRAM-IDENTIFIER, SW-CS-DATA-IDENTIFIER, SW-CS-PERFORMED-BY, REMARK, DATE, SW-CS-FIELD
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.351. SW-CS-FIELD
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
In diesem Element können beliebige Applikations-Statusinformationen gehalten werden. Dieser Ansatz wird verfolgt, um kompatibel an beliebige Bedatungen der MSRSW-Instanz zu sein. Die jeweilige Semantik der Bedatung von SW-CS-FIELD ist im Attribut [SI] anzugeben.
Example
<SW-CS-FIELD SI="Review-State">reviewed by Senior engineer<SW-CS-FIELD>
Formale Beschreibung
Hat als Kontext: | SW-CS-ENTRY
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.352. SW-CS-HISTORY
Siehe Auch Description Example Formale Beschreibung

Description
Container Element for <SW-CS-ENTRY> in order to store calibration states. <SW-CS-HISTORY> allows to track the history of the calibration process for one particular calibration item as well as for the entire calibration list. The history therefore allows to keep more than one history entry.
Example
 <SW-CS-HISTORY>
   <SW-CS-ENTRY>
      <SW-CS-STATE>calibrated</SW-CS-STATE>
      <SW-CS-CONTEXT>development of demo version</SW-CS-CONTEXT>
      <SW-CS-PROJECT-INFO>Demo-Project CDF / ASAM-MCD-2D</SW-CS-PROJECT-INFO>
      <SW-CS-TARGET-VARIANT>automatic gear</SW-CS-TARGET-VARIANT>
      <SW-CS-TEST-OBJECT>Vehicle: S-Nn-4455</SW-CS-TEST-OBJECT>
      <SW-CS-PROGRAM-IDENTIFIER>67985</SW-CS-PROGRAM-IDENTIFIER>
      <SW-CS-DATA-IDENTIFIER>67985:123.4</SW-CS-DATA-IDENTIFIER>
      <SW-CS-PERFORMED-BY>Weichel</SW-CS-PERFORMED-BY>
      <REMARK>
         <P>Note that we did not really calibrate this. The current structure is for demonstration purposes only. </P>
      </REMARK>
      <DATE>18.05.2001T13.23</DATE>
      <SW-CS-FIELD SI="feeling">We did feel good while doing this stuff.</SW-CS-FIELD>
   </SW-CS-ENTRY>
</SW-CS-HISTORY>
Formale Beschreibung
Hat als Kontext: | SW-INSTANCE-PROPS-VARIANT, SW-INSTANCE-TREE
Ist Kontext für: | SW-CS-ENTRY
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.353. SW-CS-PERFORMED-BY
Siehe Auch Description Example Formale Beschreibung

Description
<SW-CS-PERFORMED-BY> specifies the particular individual which assigned the current calibration state. Although this could be a reference to <TEAM-MEMBER>, it is simply a string. This is because data might be copied from project to project, which would make the formal reference invalid.
Example
For an example, see SW-CS-HISTORY.
Formale Beschreibung
Hat als Kontext: | SW-CS-ENTRY
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.354. SW-CS-PROGRAM-IDENTIFIER
Siehe Auch Description Example Formale Beschreibung

Description
<SW-CS-PROGRAM-IDENTIFIER> denotes the identifier of the ECU program which was used while calibrating the current calibration item up to the state of the current calibration history.
To some extent, this should give the basis to determine the matching SYMBOLIC-FILE according to CDF specification.
Example
For an example, see SW-CS-HISTORY.
Formale Beschreibung
Hat als Kontext: | SW-CS-ENTRY
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.355. SW-CS-PROJECT-INFO
Siehe Auch Description Example Formale Beschreibung

Description
<SW-CS-PROJECT-INFO> allows to denote a project identifier in order to specify the project in which the current calibration state was achieved. This makes sense, because, calibration items can be copied from one project to another. Therefore the information in <PROJECT-DATA> is not sufficient for this use case.
Example
For an example, see SW-CS-HISTORY.
Formale Beschreibung
Hat als Kontext: | SW-CS-ENTRY
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.356. SW-CS-STATE
Siehe Auch Description Example Formale Beschreibung

Description
<SW-CS-STATE> is used to denote the current state of the calibration item, depending on the context of the instantiated function. The legal values must be defined within the process.
Example
<SW-CS-STATE>fineTuned<SW-CS-STATE>
For a further example, see SW-CS-HISTORY.
Formale Beschreibung
Hat als Kontext: | SW-CS-ENTRY
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.357. SW-CS-TARGET-VARIANT
Siehe Auch Description Example Formale Beschreibung

Description
<SW-CS-TARGET-VARIANT> is used to specify the variant of the target system which was used to achieve the current calibration state.
Example
For an example, see SW-CS-HISTORY.
Formale Beschreibung
Hat als Kontext: | SW-CS-ENTRY
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.358. SW-CS-TEST-OBJECT
Siehe Auch Description Example Formale Beschreibung

Description
<SW-CS-TEST-OBJECT> denotes the object witin the the current calibration item was calibrated. This is mainly a vehicle or a particular test environment.
Example
For an example, see SW-CS-HISTORY.
Formale Beschreibung
Hat als Kontext: | SW-CS-ENTRY
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.359. SW-CSE-CODE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
This element is used for parametrizing the ASAP1b-interface.
Abbildung 2: ASAP1b-Prinzip
During parameterisation, specifications concerning the scaling units must be made at various points. The values of these specifications (Codes for scaling units, CSE) are uniformly laid down:
Scaling Units CSE
Value | Unit | Referred to | Comment
0 | 1 µsec | Time |
1 | 10 µsec | Time |
2 | 10 µsec | Time |
3 | 1 msec | Time |
4 | 10 msec | Time |
5 | 100 msec | Time |
6 | 1 sec | Time |
7 | 10 sec | Time |
8 | 1 min | Time |
9 | 1 h | Time |
10 | 1 d | Time |
100 | Angular degrees | Angle |
101 | Revolutions 360 degrees | Angle |
102 | Cycle 720 degrees | Angle | e.g. in case of IC engines
103 | Cylinder segment | Combustion | e.g. in case of IC engines
998 | When frame available | Time | Source defined in the ASAP 2 keyword, FRAME
999 | Always if there is new value |  | Calculation of a new upper range limit after receiving a new partial value, e.g. when calculating a complex trigger condition
1000 | Non deterministic |  | Without fixed scaling
Example
Siehe SW-REFRESH-TIMING
Formale Beschreibung
Hat als Kontext: | SW-REFRESH-TIMING
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.360. SW-CSE-CODE-FACTOR

Beschreibung
Dieses Element beschreibt den Koeffizienten des <SW-CSE-CODE>s, welcher parallel zu <SW-CSE-CODE-FACTOR> für ein <SW-REFRESH-TIMING> steht.
Falls z.B. der Wert in <SW-CSE-CODE-FACTOR> 360 und der Wert in <SW-CSE-CODE> 100 ist, ist dies äquivalent zum Wert 1 in <SW-CSE-CODE-FACTOR> und dem Wert 101 in <SW-CSE-CODE>.
Formale Beschreibung
Hat als Kontext: | SW-REFRESH-TIMING
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.361. SW-DATA-CONSTR

Beschreibung
A data constraint <SW-DATA-CONSTR> may be applied to data objects such as computation methods, variables and parameters. Therefore, a <SW-DATA-CONSTR-RULE> is supplied.
Formale Beschreibung
Hat als Kontext: | SW-DATA-CONSTRS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-CONSTR-OBJECTS, SW-DATA-CONSTR-RULE
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-DATA-CONSTR | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.362. SW-DATA-CONSTR-REF

Beschreibung
Dieses Element referenziert eine <SW-DATA-CONSTR>.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-INDIVIDUAL, SW-COMPU-METHOD, SW-DATA-CONSTR-REFS, SW-DATA-DEF-PROPS, SW-GENERIC-AXIS-PARAM-TYPE
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-DATA-CONSTR | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.363. SW-DATA-CONSTR-REFS

Beschreibung
Container Element für <SW-DATA-CONSTR-REF>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-CONT
Ist Kontext für: | SW-DATA-CONSTR-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.364. SW-DATA-CONSTR-RULE

Beschreibung
Beschreibt die internen oder physikalischen Grenzen für Variablen- bzw. Parameterwerte in den Elementen <SW-PHYS-CONSTRS> bzw. <SW-INTERNAL-CONSTRS>.
Formale Beschreibung
Hat als Kontext: | SW-DATA-CONSTR
Ist Kontext für: | SW-CONSTR-LEVEL, SW-MAX-GRADIENT, SW-PHYS-CONSTRS, SW-INTERNAL-CONSTRS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.365. SW-DATA-CONSTRS

Beschreibung
Container Element für <SW-DATA-CONSTR>.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DICTIONARY-SPEC
Ist Kontext für: | ADMIN-DATA, SW-DATA-CONSTR
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.366. SW-DATA-DEF-PROPS

Beschreibung
Dieses Element beschreibt alle Eigenschaften, die ein Datenobjekt (Variable oder Parameter) charakterisieren. <SW-DATA-DEF-PROPS> wird überall dort verwendet, wo Eigenschaften von Datenobjekten angegeben werden müssen.
Zwangsläufig sind nicht alle Angaben an allen Stellen sinnvoll. Es ist die Aufgabe der Prozeßdefinition bzw. der DCI, hier Einschränkungen vorzunehmen.
Die <SW-DATA-DEF-PROPS> beschreiben die Eigenschaften aller Achsen:
  • Die Eigenschaften der Argumentachsen (Abszissen) werden in <SW-CALPRM-AXIS-SET> beschrieben
  • Die Eigenschaften der Werteachse werden direkt in <SW-DATA-DEF-PROPS> beschrieben
Formale Beschreibung
Hat als Kontext: | SW-CALPRM, SW-CALPRM-IMPL, SW-CLASS, SW-CLASS-ATTR-IMPL, SW-CLASS-INSTANCE, SW-INSTANCE-PROPS-VARIANT, SW-SYSTEMCONST, SW-TEMPLATE, SW-VARIABLE, SW-VARIABLE-IMPL
Ist Kontext für: | ANNOTATIONS, SW-ADDR-METHOD-REF, SW-ALIAS-NAME, SW-BASE-TYPE-REF, SW-BIT-REPRESENTATION, SW-CALIBRATION-ACCESS, SW-CALPRM-AXIS-SET, SW-CALPRM-NO-EFFECT-VALUE, SW-CALPRM-POINTER, SW-CALPRM-TARGET, SW-CALPRM-TEXT, SW-CALPRM-VALUE-AXIS-LABELS, SW-CODE-SYNTAX-REF, SW-COMPARISON-VARIABLES, SW-COMPU-METHOD-REF, SW-DATA-CONSTR-REF, SW-DATA-DEPENDENCY, SW-DISPLAY-FORMAT, SW-HOST-VARIABLE, SW-IMPL-POLICY, SW-INTENDED-RESOLUTION, SW-INTERPOLATION-METHOD, SW-IS-VIRTUAL, SW-MC-BASE-TYPE-REF, SW-RECORD-LAYOUT-REF, SW-REFRESH-TIMING, SW-TASK-REF, SW-TEMPLATE-REF, SW-UNIT-REF, SW-VARIABLE-KIND, SW-VAR-INIT-VALUE, SW-VAR-NOT-AVL-VALUE, SW-VCD-CRITERION-REFS, ADD-INFO
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.367. SW-DATA-DEPENDENCY
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt die Abhängigkeiten von Variablen und Parametern untereinander. Damit kann man z.B. virtuelle Parameter behandeln.
Example
Das folgende Beispiel beschreibt ein Szenario, bei dem die Ankathete A eines rechtwinkligen Dreiecks mit der Hypothenuse der Länge 1 im Steuergerät abgelegt wird. Für das physikalische Verständnis des Applikateurs ist die Länge der Gegenkathete B (= SQRT(1-A*A)) bzw. die durch die Gegenkathete aufgespannte Fläche B_AREA relevant. Daher werden drei Kalilbrierparameter angelegt, von denen zwei (B und B_AREA) virtuell sind. Das Beispiel ist der ASAP1.3 entnommen.
Abbildung 3: SW-DATA-DEPENDENCY
<SW-CALPRMS>
   <SW-CALPRM>
      <LONG-NAME>Eingangsparamenter</LONG-NAME>
      <SHORT-NAME>A</SHORT-NAME>
      <DESC>A ist die im Speicher abgelegte Ankathete</DESC>
   </SW-CALPRM>

   <SW-CALPRM>
      <LONG-NAME>Abhängiger Parameter</LONG-NAME>
      <SHORT-NAME>B</SHORT-NAME>
      <DESC>Dies ist die Gegenkathete</DESC>
      <SW-DATA-DEF-PROPS>
         <SW-DATA-DEPENDENCY>
            <SW-DATA-DEPENDENCY-FORMULA>sqrt(1 - X1 * X1)</SW-DATA-DEPENDENCY-FORMULA>
            <SW-DATA-DEPENDENCY-ARGS>
               <SW-CALPRM-REF>A</SW-CALPRM-REF>
            </SW-DATA-DEPENDENCY-ARGS>
         </SW-DATA-DEPENDENCY>
         <SW-IS-VIRTUAL>yes</SW-IS-VIRTUAL>
      </SW-DATA-DEF-PROPS>
     </SW-CALPRM>

   <SW-CALPRM>
      <LONG-NAME>Fläche</LONG-NAME>
      <SHORT-NAME>B_Area</SHORT-NAME>
      <SW-DATA-DEF-PROPS>
         <SW-DATA-DEPENDENCY>
            <DESC>Dies ist die Fläche, die durch ein Quadrat aus B aufgespannt wird.</DESC>
            <SW-DATA-DEPENDENCY-FORMULA>X1 * X1</SW-DATA-DEPENDENCY-FORMULA>
            <SW-DATA-DEPENDENCY-ARGS>
               <SW-CALPRM-REF>B</SW-CALPRM-REF>
            </SW-DATA-DEPENDENCY-ARGS>
         </SW-DATA-DEPENDENCY>
         <SW-IS-VIRTUAL>yes</SW-IS-VIRTUAL>
      </SW-DATA-DEF-PROPS>
   </SW-CALPRM>
</SW-CALPRMS>
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS, SW-RELATED-CONSTRS
Ist Kontext für: | DESC, SW-DATA-DEPENDENCY-FORMULA, SW-DATA-DEPENDENCY-ARGS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.368. SW-DATA-DEPENDENCY-ARGS
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element spezifiziert die Elemente, die in einer <SW-DATA-DEPENDENCY> verwendet werden.
Example
Siehe SW-DATA-DEPENDENCY
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEPENDENCY
Ist Kontext für: | SW-SYSTEMCONST-CODED-REF, SW-CALPRM-REF, SW-VARIABLE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.369. SW-DATA-DEPENDENCY-FORMULA
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt die Formel, mit der die Abhängigkeiten zwischen den beteiligten Objekten definiert wird. Die Formeln sind Texte, die arithmetische Ausdrücke erster Ordnung formulieren.
Es gilt folgende Syntax:
numeric_expression ::= ( "-"expression ) | ( expression ( "+" | "-" | "*" | "/" | "^") expression )
expression ::= ( number | variable | numeric_expression | ( "(" expression ")" ) | sinus_statement | cosinus_statement | sqrt_statement ) | expression {whitespace}
sinus_statement ::= "sin" "(" expression ")"
cosinus_statement ::= "cos" "(" expression ")"
sqrt_statement ::= "sqrt" "(" expression ")"
number ::= integer_literal | float_literal
variable ::= Any valid Object in question
integer_literal ::= ( "1..9" { "0..9" } ) | ( "0" "x" "0..9a..f" { "0..9a..f" } )
float_literal ::= ( decimal_digits "." [ decimal_digits ] [ exponent_part ] ) | ( "." decimal_digits [ exponent_part ] ) | ( decimal_digits [ exponent_part ] )
decimal_digits ::= "0..9" { "0..9" }
exponent_part ::= "e" [ "+" | "-" ] decimal_digits
whitespace ::= tabulator | blank | newline | carriage_return | {tabulator | blank | newline | carriage_return }
tabulator ::= \t
blank ::= " "
newline ::= \n
carriage_return ::= \c
Example
Siehe SW-DATA-DEPENDENCY
Weitere Beispiele sind:
X1 + X2^2 (X1 - X2)^2
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEPENDENCY
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.370. SW-DATA-DICTIONARY-SPEC

Beschreibung
A Data Dictionary contains all information about the datastructures and related objects in a ECU. A Data Dictionary may occur in two locations in order to express different scopes within the ECU:
<SW-SYSTEM> | This represents a global Data Dictionary definition which means that all objects within these Data Dictionaries are globally known within the ECU.
<SW-FEATURE> | This represents a local Data Dictionary. This is local to the particular feature (sometimes called module or component) in the ECU software. The objects within this Data Dictionary are locally known within the feature. They may be addressed by prefixing by the <SHORT-NAME> of the feature.
Unless the ECU uses local data objects, all calibration parameters and variables should be placed in the global Data Dictionary.
The Data Dictionary mainly defines three kinds of objects which occur in the ECU:
<SW-VARIABLE> | These objects (often called measurements) represent all data which is variable during the runtime of the ECU.
<SW-CALPRM> | These objects (often called calibration parameters) represent data which is adjusted during the calibration process of the ECU.
<SW-CLASS-INSTANCE> | These objects (currently new to the domain of ECUs) represent instantiations of particular classes. These instantiantiations are specified as reference to the class and one of the implementations provided by the class (see SW-CLASS).
In addition to this, the Data Dictionary contains auxiliary definitions required to specify the three main items mentioned above. These auxiliary definitions are [image] :
<SW-UNIT> | Physical Unit
<SW-COMPU-METHOD> | Methods to convert physical data to normalized data.
<SW-BASE-TYPE> | Definitions of base-types within the ECU such as "Unsigned Integer", "Float". These base-types may be standardized by ASAM concerning their name and the technical properties.
<SW-CODE-SYNTAX> | Containers for generator-specific definitions how to describe the data objects (variables, calibration parameters) in the intended programming language.
<SW-RECORD-LAYOUT> | Defines how the data objects (variables, calibration parameters etc.) shall be stored in the ECU memory. As an example, this definition specifies the sequence of axis points in the ECU memory.
<SW-ADDR-METHOD> | Reserves names which serve as keywords how the data objects might be addressed within the ECU-memory.
<SW-AXIS-TYPE> | Reserves names for specific axis computing strategies. For the reason that arbitrary algorithms for computing axis-points are possible, no formal specification is given. Instead, the algorithm is described verbally; the parameters are specified formally with respect to their name and constraints.
<SW-TEMPLATE> | These templates are used to predefine some properties of variables or parameters. The templates can be used to simplify the typing task. They have no architectural meaning, so they have no influence on the data model in the ECU.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE, SW-SYSTEM
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, DESC, SW-UNITS, SW-TEMPLATES, SW-VARIABLES, SW-CALPRMS, SW-SYSTEMCONSTS, SW-CLASS-INSTANCES, SW-COMPU-METHODS, SW-ADDR-METHODS, SW-RECORD-LAYOUTS, SW-CODE-SYNTAXES, SW-BASE-TYPES, SW-DATA-CONSTRS, SW-AXIS-TYPES, ADD-INFO
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.

Each of the following elements is described in the singular form in spite of the fact that the Data Dictionary allows multiple instances of each of them


1.371. SW-DISPLAY-FORMAT

Beschreibung
Dieses Element beschreibt das Anzeigeformat in "printf"-Format der Syntax für die Programmiersprache C.
Dies wird u.a. bei Umrechnungsformeln <SW-COMPU-METHOD> verwendet.
Formale Beschreibung
Hat als Kontext: | SW-CALPRM-AXIS, SW-COMPU-METHOD, SW-DATA-DEF-PROPS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.372. SW-EFFECT

Beschreibung
The effect of the parent element <SW-EFFECTING-VARIABLE> is given as a keyword in <SW-EFFECT> . The values must be agreed upon the partners.
Formale Beschreibung
Hat als Kontext: | SW-EFFECTING-VARIABLE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[ORIGIN] optional | Zeichenkette (CDATA) | Gibt an, von wem die Information stammt. Ansatz ist der, dass die <SW-EFFECT>-Flow von z.B. Ascet erstellt, und manuell nachgearbeitet wird. In diesem Fall würden die von ASCET als Origin=Ascet sein, bei manueller Nacharbeit wird Origin=Username eingetragen.
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.373. SW-EFFECT-FLOW

Beschreibung
Insert <SW-EFFECT-FLOW> in <SW-FUNCTION-VARIANT> to describe how the referenced variable <SW-VARIABLE-REF> is influenced by <SW-EFFECTING-VARIABLE>. The effect is given as a keyword in the child node <SW-EFFECT> of <SW-EFFECTING-VARIABLE>. The values must be agreed upon the partners.
Formale Beschreibung
Hat als Kontext: | SW-EFFECT-FLOWS
Ist Kontext für: | SW-VARIABLE-REF, SW-EFFECTING-VARIABLE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.374. SW-EFFECT-FLOWS

Beschreibung
Container Element für <SW-EFFECT-FLOW>.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE
Ist Kontext für: | SW-EFFECT-FLOW
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.375. SW-EFFECTING-VARIABLE

Beschreibung
In the Element <SW-EFFECTING-VARIABLE>, the variable referenced by its sister element <SW-VARIABLE-REF> is influenced by the child element <SW-VARIABLE-REF> of <SW-EFFECTING-VARIABLE>.
Formale Beschreibung
Hat als Kontext: | SW-EFFECT-FLOW
Ist Kontext für: | SW-VARIABLE-REF, SW-EFFECT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.376. SW-FEATURE

Beschreibung
A SW-FEATURE describes a specific ECU-Feature concerning functionality, used data and processing. It may define its own SW-DATA-DICTIONARY-SPEC and SW-FEATURE-VARIABLES for feature-local purposes.
Formale Beschreibung
Hat als Kontext: | SW-COMPONENTS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-FULFILS, SW-FEATURE-DESIGN-DATA, SW-EFFECT-FLOWS, SW-FEATURE-VARIABLES, SW-FEATURE-PARAMS, SW-FEATURE-CLASS-INSTANCES, SW-SYSTEMCONST-REFS, SW-DATA-DICTIONARY-SPEC, SW-TEST-DESC, SW-APPLICATION-NOTES, SW-MAINTENANCE-NOTES, SW-CARB-DOC, SW-FEATURE-DECOMPOSITION, ANNOTATIONS, ADD-INFO
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-FEATURE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | SW-ADDR-METHOD SW-AXIS-TYPE SW-BASE-TYPE SW-CLASS-INSTANCE SW-CODE-SYNTAX SW-COMPU-METHOD SW-DATA-CONSTR SW-CALPRM SW-RECORD-LAYOUT SW-SYSTEMCONST SW-TEMPLATE SW-UNIT SW-VARIABLE | Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')


1.377. SW-FEATURE-CLASS-INSTANCES

Beschreibung
Container Element für <SW-FEATURE-EXPORT-CLASS-INSTANCES>, <SW-FEATURE-IMPORT-CLASS-INSTANCES>, <SW-FEATURE-LOCAL-CLASS-INSTANCES>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS, SW-FEATURE
Ist Kontext für: | SW-FEATURE-EXPORT-CLASS-INSTANCES, SW-FEATURE-IMPORT-CLASS-INSTANCES, SW-FEATURE-LOCAL-CLASS-INSTANCES
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.378. SW-FEATURE-DECOMPOSITION
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element erlaubt eine Hierarchisierung der funktionalen Beschreibung einer Software, in dem ein <SW-FEATURE> durch Referenz auf andere Komponenten zusammengesetzt wird. Bei dieser Zusammensetzung kann auch eine Prozeßreihenfolge spezifiziert werden (siehe <SW-SUBCOMPONENT>).
Example
 <SW-FEATURE>
   <SHORT-NAME>Zusammegesetztes Feature</SHORT-NAME>
   <SW-FEATURE-DECOMPOSITION>
      <SW-SUBCOMPONENT>
         <SW-FEATURE-REF>SF1</SW-FEATURE-REF>
         <SW-PROCESSES>
            <SW-PROCESS>
               <SHORT-LABEL>Initialisierung</SHORT-LABEL>
               <SW-TASK-REF>init</SW-TASK-REF>
            </SW-PROCESS>
            <SW-PROCESS>
               <SHORT-LABEL>Zeitscheibe 1</SHORT-LABEL>
               <SW-TASK-REF>10msec</SW-TASK-REF>
            </SW-PROCESS>
         </SW-PROCESSES>
      </SW-SUBCOMPONENT>
   </SW-FEATURE-DECOMPOSITION>
</SW-FEATURE>
Formale Beschreibung
Hat als Kontext: | SW-FEATURE
Ist Kontext für: | SW-SUBCOMPONENT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.379. SW-FEATURE-DEF

Beschreibung
Dieses Element beinhaltet die textuelle Definition einer Software-Funktion <SW-FEATURE>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS, SW-FEATURE
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.380. SW-FEATURE-DESC

Beschreibung
Dieses Element beinhaltet die textuelle Beschreibung einer Software-Funktion <SW-FEATURE>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS, SW-FEATURE
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.381. SW-FEATURE-DESIGN-DATA

Beschreibung
Zum Zeitpunkt des Entwurfs eines Software-Systems sind zwar die Variablen und Kalibrierparameter bekannt, nicht jedoch deren Implementierungsdetails sowie die Systemaufteilung (welche Kenngröße wird wo deklariert, exportiert oder importiert). Deshalb kann unter <SW-FEATURE-DESIGN-DATA> der logische Informationsfluß beschrieben werden, ohne Rücksicht auf die Aufteilung der Deklarationen zu nehmen. Dieses Element ist somit für die frühe Software-Designphase gedacht und wird später durch <SW-FEATURE-VARIABLES>, <SW-FEATURE-CALPRMS> und <SW-FEATURE-CLASS-INSTANCES> obsolet.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE
Ist Kontext für: | SW-VARIABLES-READ, SW-VARIABLES-WRITE, SW-VARIABLES-READ-WRITE, SW-FEATURE-LOCAL-PARAMS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.382. SW-FEATURE-EXPORT-CALPRMS

Beschreibung
Parameter, die von einer Funktion angelegt und bei Bedarf auch in anderen Funktionen zur Verfügung gestellt werden.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-PARAMS
Ist Kontext für: | SW-CALPRM-REF, SW-CALPRM-REF-SYSCOND
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.383. SW-FEATURE-EXPORT-CLASS-INSTANCES

Beschreibung
Klassen-Instanzen, die von einer Funktion angelegt und bei Bedarf auch in anderen Funktionen zur Verfügung gestellt werden.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-CLASS-INSTANCES
Ist Kontext für: | SW-CLASS-INSTANCE-REF, SW-INSTANCE-REF-SYSCOND
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.384. SW-FEATURE-EXPORT-VARIABLES

Beschreibung
Ausgangs-RAM-Größen, die in der aktuellen Funktion angelegt werden und in anderen Funktionen als Eingangsgrößen zur Verfügung stehen.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-VARIABLES
Ist Kontext für: | SW-VARIABLES-READ, SW-VARIABLES-WRITE, SW-VARIABLES-READ-WRITE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.385. SW-FEATURE-IMPORT-CALPRMS

Beschreibung
Parameter, die von einer anderen Funktion angelegt und von der aktuellen Funktion verwendet werden.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-PARAMS
Ist Kontext für: | SW-CALPRM-REF, SW-CALPRM-REF-SYSCOND
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.386. SW-FEATURE-IMPORT-CLASS-INSTANCES

Beschreibung
Klassen-Instanzen, die von einer anderen Funktion angelegt und von der aktuellen Funktion verwendet werden.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-CLASS-INSTANCES
Ist Kontext für: | SW-CLASS-INSTANCE-REF, SW-INSTANCE-REF-SYSCOND
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.387. SW-FEATURE-IMPORT-VARIABLES

Beschreibung
RAM-Größen, die von einer anderen Funktion angelegt und als Ausgang zur Verfügung gestellt werden.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-VARIABLES
Ist Kontext für: | SW-VARIABLES-READ, SW-VARIABLES-WRITE, SW-VARIABLES-READ-WRITE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.388. SW-FEATURE-LOCAL-CLASS-INSTANCES

Beschreibung
Klassen-Instanzen, die in der aktuellen Funktion angelegt werden, aber nicht in anderen Funktionen benutzt werden können.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-CLASS-INSTANCES
Ist Kontext für: | SW-CLASS-INSTANCE-REF, SW-INSTANCE-REF-SYSCOND
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.389. SW-FEATURE-LOCAL-PARAMS

Beschreibung
Parameter, die in der aktuellen Funktion angelegt werden, aber nicht in anderen Funktionen benutzt werden können.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-DESIGN-DATA, SW-FEATURE-PARAMS
Ist Kontext für: | SW-CALPRM-REF, SW-CALPRM-REF-SYSCOND
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.390. SW-FEATURE-LOCAL-VARIABLES

Beschreibung
Variablen, die in der aktuellen Funktion angelegt werden, aber nicht in anderen Funktionen benutzt werden können.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-VARIABLES
Ist Kontext für: | SW-VARIABLES-READ-WRITE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.391. SW-FEATURE-MODEL-ONLY-VARIABLES

Beschreibung
Dieses Element beschreibt Variablen, die nur in Simulationsmodellen existieren, nicht aber im realen Steuergerät existieren. In der Regel handelt es sich dabei um virtuelle Variablen (d.h. mit <SW-IS-VIRTUAL>).
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-VARIABLES
Ist Kontext für: | SW-VARIABLE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.392. SW-FEATURE-PARAMS

Beschreibung
Dieses Element deklariert Parameter, welche von einer anderen Funktion <SW-FEATURE> angelegt werden.
Formale Beschreibung
Hat als Kontext: | SW-CLASS, SW-FEATURE
Ist Kontext für: | SW-FEATURE-EXPORT-CALPRMS, SW-FEATURE-IMPORT-CALPRMS, SW-FEATURE-LOCAL-PARAMS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.393. SW-FEATURE-REF

Beschreibung
Dieses Element referenziert eine SW-Funktion <SW-FEATURE>.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-REFS, SW-INSTANCE, SW-INSTANCE-TREE, SW-ROOT-FEATURES, SW-SUBCOMPONENT
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-FEATURE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.394. SW-FEATURE-REFS

Beschreibung
Container Element für <SW-FEATURE-REF>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-CONT
Ist Kontext für: | SW-FEATURE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.395. SW-FEATURE-VARIABLES

Beschreibung
Dieses Element deklariert Variablen, welche von einer anderen Funktion <SW-FEATURE> angelegt werden.
Formale Beschreibung
Hat als Kontext: | SW-CLASS, SW-FEATURE
Ist Kontext für: | SW-FEATURE-EXPORT-VARIABLES, SW-FEATURE-IMPORT-VARIABLES, SW-FEATURE-LOCAL-VARIABLES, SW-FEATURE-MODEL-ONLY-VARIABLES
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.396. SW-FILL-CHARACTER

Beschreibung
Füllzeichen für Textparamter, um auf die maximale Länge <SW-CALPRM-MAX-TEXT-SIZE> im Eltern-Element <SW-CALPRM-TEXT> aufzufüllen.
Formale Beschreibung
Hat als Kontext: | SW-CALPRM-TEXT
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.397. SW-FULFILS
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Mit diesem Element werden Referenzen auf die mit dem vorliegenden Feature erfüllten Anforderungen spezifiziert. Hier gibt es zwei Möglichkeiten:
  • <FUNCTION-REF> zum Verhalten von Systemfunktionen in MSRSYS.DTD-Instanzen
  • Verweise zu Anforderungen über <REQUIREMENT-REF>, welche in derselben MSRSW-Instanz vorkommen, oder aber auch in einem externen Dokument beschrieben sein können.
Example
Siehe SW-FUNCTION-REF
Formale Beschreibung
Hat als Kontext: | SW-CLASS, SW-FEATURE
Ist Kontext für: | FUNCTION-REF, REQUIREMENT-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.398. SW-GENERIC-AXIS-DESC

Beschreibung
Dieses Element beinhaltet eine textuelle Achsenbeschreibung für eine Achse <SW-AXIS-TYPE>.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-TYPE
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.399. SW-GENERIC-AXIS-PARAM

Beschreibung
Dieses Element beschreibt einen spezifischen Parameter einer generischen Achse. Für diesen Parameter ist anzugeben:
  • der Name des Parameters; hier realisiert durch einen Verweis (<SW-GENERIC-AXIS-PARAM-TYPE-REF>) auf einen beim entsprechenden Achsentyp definierten Parameter. Dieser steht beim Geschwisterelement <SW-AXIS-TYPE-REF> des entsprechenden <SW-GENERIC-AXIS-PARAMS>-Elementes.
    Achtung
    Es darf nur ein Achsenparameter referenziert werden, welcher innerhalb des referenzierten Achsentyps definiert ist.
  • Der Wert des Parameters, angegeben im Element <VF>.
Formale Beschreibung
Hat als Kontext: | SW-GENERIC-AXIS-PARAMS
Ist Kontext für: | SW-GENERIC-AXIS-PARAM-TYPE-REF, VF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.400. SW-GENERIC-AXIS-PARAM-TYPE

Beschreibung
Dieses Element beschreibt einen generischen Achsentyp, welcher beinhaltet:
  • Es können Plausibilitätskontrollen spezifiziert werden (<SW-DATA-CONSTR-REF>).
  • Textuelle Beschreibung (<NCOI-3>), da eine formale Beschreibung aufgrund der Vielfalt an Möglichkeiten nicht sinnvoll erscheint.
  • Falls dieser Parameter Strukturen enthält, können diese durch den rekursiven Einsatz von <SW-GENERIC-AXIS-PARAM-TYPES> modelliert werden.
Formale Beschreibung
Hat als Kontext: | SW-GENERIC-AXIS-PARAM-TYPE, SW-GENERIC-AXIS-PARAM-TYPES
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-DATA-CONSTR-REF, SW-GENERIC-AXIS-PARAM-TYPE
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-GENERIC-AXIS-PARAM-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.401. SW-GENERIC-AXIS-PARAM-TYPE-REF

Beschreibung
Dieses Element referenziert <SW-GENERIC-AXIS-PARAM-TYPE>.
Formale Beschreibung
Hat als Kontext: | SW-GENERIC-AXIS-PARAM, SW-RECORD-LAYOUT-GROUP, SW-RECORD-LAYOUT-V
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-GENERIC-AXIS-PARAM-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.402. SW-GENERIC-AXIS-PARAM-TYPES

Beschreibung
Container Element für <SW-GENERIC-AXIS-PARAM-TYPE>.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-TYPE
Ist Kontext für: | SW-GENERIC-AXIS-PARAM-TYPE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.403. SW-GENERIC-AXIS-PARAMS

Beschreibung
Container Element für <SW-GENERIC-AXIS-PARAM>.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-GENERIC
Ist Kontext für: | SW-GENERIC-AXIS-PARAM
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.404. SW-GLOSSARY

Beschreibung
Dieses Element dient zum Aufbau eines Glossars. Hintergrund ist die Aufnahme eines festen Kapitels in der Steuergerätedokumentation, in der ein Glossar auftritt.
Formale Beschreibung
Hat als Kontext: | MSRSW
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, ADMIN-DATA, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.405. SW-HOST-VARIABLE

Beschreibung
Dieses Element beinhaltet die Referenz <SW-VARIABLE-REF> auf eine Variable, welche als Host-Variable für eine Bitgröße <SW-BIT-REPRESENTATION> steht.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | SW-VARIABLE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.406. SW-IMPL-POLICY

Beschreibung
<SW-IMPL-POLICY> erlaubt es, eine Implementierungsstrategie zu spezifizieren. Damit kann in einer frühen Phase schon die Richtung der späteren Implementierung vorgegeben werden. Der Inhalt des Elementes ist ein Schlüsselwort, welches im Prozess zu vereinbaren ist. Beispiele für mögliche Werte sind
  • MEMORY_OPTIMIZED
  • CPU-OPTIMIZED
  • INPLACE
  • SINGLE-INSTANCE
  • MULTI-INSTANCE
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes


1.407. SW-INSTANCE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
A <SW-INSTANCE> represents the instance specific information. If an variable or a scalar parameter is specified, the subelement <SHORT-NAME> has to be populated, if a parameter array is specified, the <SW-ARRAY-INDEX> has to be populated.
<SW-INSTANCE> represents one particular calibration item and therefore corresponds to CAL-ITEM in CDF.
Example
<SW-INSTANCE>
   <LONG-NAME>faule Bären aus München (Viktualienmarkt)</LONG-NAME>
   <SHORT-NAME>FBAM_V</SHORT-NAME>
   <CATEGORY>curve_individual</CATEGORY>
   <SW-INSTANCE-PROPS-VARIANTS>
      <SW-INSTANCE-PROPS-VARIANT>
         <SW-AXIS-CONTS>
            <SW-AXIS-CONT>
               <SW-UNIT-REF>grad_040C</SW-UNIT-REF>
               <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
               <SW-VALUES-PHYS>
                  <V>-35.6</V>
                  <V>-32.0</V>
                  <V>-24.9</V>
                  <V>-21.3</V>
                  <V>-18.4</V>
                  <V>-15.5</V>
                  <V>-14.1</V>
                  <V>3.9</V>
                  <V>21.8</V>
                  <V>39.8</V>
               </SW-VALUES-PHYS>
            </SW-AXIS-CONT>
            <SW-AXIS-CONT>
               <SW-UNIT-REF>km_pro_h</SW-UNIT-REF>
               <SW-AXIS-INDEX>0</SW-AXIS-INDEX>
               <SW-VALUES-PHYS>
                  <V>0.00</V>
                  <V>3.63</V>
                  <V>3.75</V>
                  <V>3.88</V>
                  <V>3.94</V>
                  <V>4.06</V>
                  <V>4.13</V>
                  <V>4.25</V>
                  <V>4.69</V>
                  <V>5.25</V>
               </SW-VALUES-PHYS>
            </SW-AXIS-CONT>
         </SW-AXIS-CONTS>
         <SW-CS-HISTORY>
            <SW-CS-ENTRY>
               <SW-CS-STATE>calibrated</SW-CS-STATE>
               <SW-CS-CONTEXT>development of demo version</SW-CS-CONTEXT>
               <SW-CS-PROJECT-INFO>Demo-Project CDF / ASAM-MCD-2D</SW-CS-PROJECT-INFO>
               <SW-CS-TARGET-VARIANT>automatic gear</SW-CS-TARGET-VARIANT>
               <SW-CS-TEST-OBJECT>Vehicle: S-Nn-4455</SW-CS-TEST-OBJECT>
               <SW-CS-PROGRAM-IDENTIFIER>67985</SW-CS-PROGRAM-IDENTIFIER>
               <SW-CS-DATA-IDENTIFIER>67985:123.4</SW-CS-DATA-IDENTIFIER>
               <SW-CS-PERFORMED-BY>Weichel</SW-CS-PERFORMED-BY>
               <REMARK>
                  <P>Note that we did not really calibrate this. The current structure is for demonstration purposes only. </P>
               </REMARK>
               <DATE>18.05.2001T13.23</DATE>
               <SW-CS-FIELD SI="feeling">We did feel good while doing this stuff.</SW-CS-FIELD>
            </SW-CS-ENTRY>
         </SW-CS-HISTORY>
      </SW-INSTANCE-PROPS-VARIANT>
   </SW-INSTANCE-PROPS-VARIANTS>
</SW-INSTANCE>
Formale Beschreibung
Hat als Kontext: | SW-INSTANCE, SW-INSTANCE-TREE
Ist Kontext für: | LONG-NAME, SHORT-NAME, SW-ARRAY-INDEX, DESC, CATEGORY, ADMIN-DATA, SW-FEATURE-REF, SW-INSTANCE-PROPS-VARIANTS, SW-INSTANCE
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | Zeichenkette (CDATA) | SW-INSTANCE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-INSTANCE | Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')


1.408. SW-INSTANCE-PROPS-VARIANT
Siehe Auch Description Example Formale Beschreibung

Description
<SW-INSTANCE-PRPS-VARIANT> describes one particular variant of the current calibration item. Since CDF did not request this, there is one and only one variant per calibration item which can be specified.
Example
For an example, see 1.352. SW-CS-HISTORY SW-CS-HISTORY SW-CS-HISTORY SW-CLASS.
Formale Beschreibung
Hat als Kontext: | SW-INSTANCE-PROPS-VARIANTS
Ist Kontext für: | ADMIN-DATA, DESC, SW-VCD-CRITERION-VALUES, SW-ADDR-INFOS, SW-AXIS-CONTS, SW-DATA-DEF-PROPS, SW-MC-INSTANCE-INTERFACES, SW-CS-HISTORY, ANNOTATIONS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.409. SW-INSTANCE-PROPS-VARIANTS
Siehe Auch Description Example Formale Beschreibung

Description
<SW-INSTANCE-PROPS-VARIANTS> is the container which takes all variants of one particular calibration item.
Example
For an example, see 1.407. SW-INSTANCE SW-INSTANCE SW-INSTANCE SW-CLASS.
Formale Beschreibung
Hat als Kontext: | SW-INSTANCE
Ist Kontext für: | SW-INSTANCE-PROPS-VARIANT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.410. SW-INSTANCE-REF

Beschreibung
Dieses Element referenziert <SW-INSTANCE>.
Formale Beschreibung
Hat als Kontext: | SW-INSTANCE-REFS, SW-MC-BLOB-ECU-DEPOSIT, SW-VALUES-CODED, SW-VALUES-CODED-HEX, SW-VALUES-GENERIC, SW-VALUES-PHYS, VG
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-INSTANCE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.411. SW-INSTANCE-REF-SYSCOND

Beschreibung
Dieses Element ist eine bedingte Referenz auf eine Klasseninstanz. Dieses wird verwendet, um die Zuordnung von Klasseninstanzen zu Funktionen abhängig zu machen von Systemkonstanten-Einstellungen. Deshalb existiert das Element parallel zu <SW-INSTANCE-REF>.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-EXPORT-CLASS-INSTANCES, SW-FEATURE-IMPORT-CLASS-INSTANCES, SW-FEATURE-LOCAL-CLASS-INSTANCES
Ist Kontext für: | SW-CLASS-INSTANCE-REF, SW-SYSCOND
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.412. SW-INSTANCE-REFS

Beschreibung
Container Element für <SW-INSTANCE-REF>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-CONT
Ist Kontext für: | SW-INSTANCE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.413. SW-INSTANCE-SPEC
Siehe Auch Description Formale Beschreibung

Description
<SW-INSTANCE-SPEC> is the section within a <SW-SYSTEM> which takes all information about the instances of data items within the ECU, in particular the calibration items.
As <SW-SYSTEM> does not allow to place a note or an introduction, <INTRODUCTION> of <SW-INSTANCE-SPEC> corresponds to NOTE in CAL-LIST specified by CDF.
Formale Beschreibung
Hat als Kontext: | SW-SYSTEM
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-INSTANCE-TREE, ADD-INFO
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.414. SW-INSTANCE-TREE
Siehe Auch Description Example Formale Beschreibung

Description
The instance tree contains all "real existing" instances, i.e. variables and parameters, that are part of the ECU software. The structure is in the form of a tree (in contrast to ASAM-MCD- 2MC V1.3 where only a flat list is possible) to reflect the natural (e.g. function resp. feature) structure.
<SW-INSTANCE-TREE> receives one particular set of calibration items. Therefore it corresponds to CAL-LIST within CDF specification.
Example
<SW-INSTANCE-SPEC>
   <INTRODUCTION>
      <P>This is the system to demonstrate, how CDF should work.</P>
   </INTRODUCTION>
   <SW-INSTANCE-TREE>
      <SHORT-NAME>Summertest</SHORT-NAME>
      <SW-INSTANCE>
         <LONG-NAME>faule Bären aus München (Viktualienmarkt)</LONG-NAME>
         <SHORT-NAME>FBAM_V</SHORT-NAME> ... </SW-INSTANCE>
   </SW-INSTANCE-TREE>

   <SW-INSTANCE-TREE>
      <SHORT-NAME>Wintertest</SHORT-NAME>
      <SW-INSTANCE>
         <LONG-NAME>faule Bären aus München (Viktualienmarkt)</LONG-NAME>
         <SHORT-NAME>FBAM_V</SHORT-NAME> ... </SW-INSTANCE>
   </SW-INSTANCE-TREE>
</SW-INSTANCE-SPEC>
Formale Beschreibung
Hat als Kontext: | SW-INSTANCE-SPEC
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-CS-HISTORY, SW-VCD-CRITERION-VALUES, SW-FEATURE-REF, SW-INSTANCE
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-INSTANCE-TREE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-INSTANCE | Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')


1.415. SW-INTENDED-RESOLUTION
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element dient dazu, in einer frühen Design-Phase die angeforderte Quantisierung von Datenobjekten zu beschreiben. Ultimativ ergibt sich die Auflösung über die zugrundeliegende Umrechnungsformel (<SW-COMPU-METHOD>), welche den Übergang von der physikalischen in die normierte Welt (und umgekehrt) spezifiziert (die "Steigung pro Bit" ist hierbie implizit in der Umrechnungsformel vorhanden). In einer Entwicklungsphase, bei der die Umrechnungsformel noch nicht festliegt, kann durch <SW-INTENDED-RESOLUTION> eine Vorspezifikation erfolgen. Wenn die Umrechnungsformel aber vorliegt, kann diese gegen <SW-INTENDED-RESOLUTION> plausibilisiert werden.
Example
<SW-VARIABLE>
   <LONG-NAME>Drehzahl</LONG-NAME>
   <SHORT-NAME>N</SHORT-NAME>
   <SW-DATA-DEF-PROPS>
      <SW-INTENDED-RESOLUTION>40</SW-INTENDED-RESOLUTION>
      <SW-UNIT-REF>upm</SW-UNIT-REF>
   </SW-DATA-DEF-PROPS>
</SW-VARIABLE>
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.416. SW-INTERNAL-CONSTRS

Beschreibung
Beschreibt die Einschränkungen, die für die normierten Werte von Variablen bzw. Kalibrierparametern gelten (im Gegensatz zu <SW-PHYS-CONSTRS>).
Formale Beschreibung
Hat als Kontext: | SW-DATA-CONSTR-RULE
Ist Kontext für: | LOWER-LIMIT, UPPER-LIMIT, SW-SCALE-CONSTRS, SW-MAX-DIFF, SW-MONOTONY, SW-RELATED-CONSTRS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.417. SW-INTERNAL-CONSTRS-1

Beschreibung
Dieses Element schränkt <SW-INTERNAL-CONSTRS> derart ein, daß nur Wertebereiche definiert werden können.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-METHOD
Ist Kontext für: | SW-SCALE-CONSTR
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.418. SW-INTERPOLATION-METHOD

Beschreibung
Dieses Element beschreibt textuell die anzuwendende mathematische Interpolationsmethode.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.419. SW-IS-VIRTUAL
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element kennzeichnet, ob das korrespondierende Objekt virtuell ist. Virtuelle Objekte treten nicht im Speicher auf, sie sind vielmehr von anderen Objekten abhängig abgeleitet und müssen daher ein <SW-DATA-DEPENDENCY> haben.
Hinweis
Der Inhalt des Elementes ist ausschließlich auf den Wert "yes" zu setzen. Spätere Versionen können auch andere Werte zulassen. Das Element hat Inhalt, um leere Elemente zu vermeiden, was bei SGML zu Problemen führt.
Example
Siehe SW-DATA-DEPENDENCY
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.420. SW-MAINTENANCE-NOTES

Beschreibung
Dieses Element beschreibt den Beitrag, den die jeweilige Funktion oder Klasse für die Erstellung der Kundendienstunterlagen liefert.
Formale Beschreibung
Hat als Kontext: | SW-CLASS, SW-FEATURE
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.421. SW-MAX-AXIS-POINTS

Beschreibung
Maximale Anzahl Stützstellen einer Achse für ein Kennfeld bzw. Kennlinie.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-INDIVIDUAL
Ist Kontext für: | Text, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.422. SW-MAX-DIFF

Beschreibung
Maximale Differenz, die zwischen zwei benachbarten Achswerten auftreten darf. .
Hinweis
Diese können sowohl bei Werte- als auch bei Eingangsachsen verwendet werden. Bei Eingangsachsen wird die Randbedingung jedoch nur bei <SW-AXIS-INDIVIDUAL> angegeben. Bei Gruppenachsen wird die Einschränkung bei der referenzierte Achse selber, und nicht bei der Referenz angegeben
Formale Beschreibung
Hat als Kontext: | SW-INTERNAL-CONSTRS, SW-PHYS-CONSTRS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.423. SW-MAX-GRADIENT

Beschreibung
Dieses Element spezifiziert die maximale Steigung, die für Kennlinien bzw. Kennfelder auftreten darf.
Formale Beschreibung
Hat als Kontext: | SW-DATA-CONSTR-RULE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.424. SW-MC-ADDR-MAPPED-SIZE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Size of a remapped address space of the ECU to an access address.
Example
Siehe SW-MC-ADDR-MAPPING.
Formale Beschreibung
Hat als Kontext: | SW-MC-ADDR-MAPPING
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.425. SW-MC-ADDR-MAPPING
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Remapping of the address space of the ECU to an access address. This is needed for special application methods (for example, special address calculation is needed in KWP2000, where only 24 bit addresses are available.)
Example
<SW-MC-ADDR-MAPPING>
   <SW-MC-ORIGINAL-ADDR>0x4000</SW-MC-ORIGINAL-ADDR>
   <SW-MC-MAPPED-ADDR>0x8000</SW-MC-MAPPED-ADDR>
   <SW-MC-ADDR-MAPPED-SIZE>0x0200</SW-MC-ADDR-MAPPED-SIZE>
</SW-MC-ADDR-MAPPING>
Formale Beschreibung
Hat als Kontext: | SW-MC-ADDR-MAPPINGS
Ist Kontext für: | SW-MC-ORIGINAL-ADDR, SW-MC-MAPPED-ADDR, SW-MC-ADDR-MAPPED-SIZE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.426. SW-MC-ADDR-MAPPINGS

Beschreibung
Container Element für <SW-MC-ADDR-MAPPING>.
Formale Beschreibung
Hat als Kontext: | SW-MC-INSTANCE-INTERFACE
Ist Kontext für: | SW-MC-ADDR-MAPPING
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.427. SW-MC-BASE-TYPE

Beschreibung
<SW-MC-BASE-TYPE> follows the approach of <SW-BASE-TYPE>.
Formale Beschreibung
Hat als Kontext: | SW-MC-BASE-TYPES
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-BASE-TYPE-SIZE, SW-CODED-TYPE, SW-MEM-ALIGNMENT, BYTE-ORDER, SW-BASE-TYPE-REF
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | Zeichenkette (CDATA) | SW-MC-BASE-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.428. SW-MC-BASE-TYPE-REF

Beschreibung
Dieses Element referenziert <SW-MC-BASE-TYPE>.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-MC-BASE-TYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.429. SW-MC-BASE-TYPES

Beschreibung
Container Element für <SW-MC-BASE-TYPE>.
Formale Beschreibung
Hat als Kontext: | SW-MC-COMMUNICATION-SPEC
Ist Kontext für: | SW-MC-BASE-TYPE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.430. SW-MC-BLOB-ECU-DEPOSIT

Beschreibung
<SW-MC-BLOB-ECU-DEPOSIT> is the alternative to <SW-MC-BLOB-VALUE> in the parent element, if the blob is given as the instance of a calibration parameter.
Formale Beschreibung
Hat als Kontext: | SW-MC-QP-BLOB-CONTS, SW-MC-TP-BLOB-CONTS
Ist Kontext für: | SW-INSTANCE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.431. SW-MC-BLOB-LAYOUTS

Beschreibung
Container Element für <SW-MC-TP-BLOB-LAYOUT>, <SW-MC-QP-BLOB-LAYOUT>, <SW-MC-KP-BLOB-LAYOUT>, <SW-MC-DP-BLOB-LAYOUT>, <SW-MC-PA-BLOB-LAYOUT>.
Formale Beschreibung
Hat als Kontext: | SW-MC-INTERFACE
Ist Kontext für: | SW-MC-TP-BLOB-LAYOUT, SW-MC-QP-BLOB-LAYOUT, SW-MC-KP-BLOB-LAYOUT, SW-MC-DP-BLOB-LAYOUT, SW-MC-PA-BLOB-LAYOUT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.432. SW-MC-BLOB-VALUE

Beschreibung
<SW-MC-BLOB-VALUE> is the value of the blob given in A2L microsyntax. <SW-MC-BLOB-ECU-DEPOSIT> is the alternative in the parent element, if the blob is given as the instance of a calibration parameter.
Formale Beschreibung
Hat als Kontext: | SW-MC-QP-BLOB-CONTS, SW-MC-TP-BLOB-CONTS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.433. SW-MC-COMMUNICATION-SPEC

Beschreibung
This corresponds to the BLOB defintion of the A2ML part. It comprises merely of a formal definition of datatypes <SW-MC-SYSTEM-BASE-TYPES> and <SW-MC-INTERFACE-SPEC> specifying BLOB layouts <SW-MC-BLOB-LAYOUTS>. This element is introduced to take all information about interfaces of a module. In the first step we put ASAP 1b compliant MC-Interfaces there. But in the future, other interfaces to the outside world could be modelled here.
Formale Beschreibung
Hat als Kontext: | MSRSW
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-MC-INTERFACE-SPEC, SW-MC-BASE-TYPES, SW-MC-INTERFACE-IMPLS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.434. SW-MC-DP-BLOB-CONTS

Beschreibung
Datenparameter Blob - (BLOB: binary large ob-ject): an interface specific description for accessing a calibration parameter. Any object for which a DP-BLOB exists, can be uploaded and downloaded. It exists for each resp. parameter instance. It is a runtime blob.
Formale Beschreibung
Hat als Kontext: | SW-MC-GENERIC-INTERFACE, SW-MC-INSTANCE-INTERFACE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.435. SW-MC-DP-BLOB-LAYOUT

Beschreibung
Dieses Element beschreibt in ASAP-Syntax die für ein Verstellsystem relevanten Informationen eines Datenparameter-BLOB-Layouts. Hierduch ist das Verstellsystem in der Lage, den <SW-MC-DP-BLOB-VALUE> zu interpretieren.
Formale Beschreibung
Hat als Kontext: | SW-MC-BLOB-LAYOUTS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.436. SW-MC-FRAME

Beschreibung
This element represent message frames and associate messages. This is located in the subtree of SW-MC-INTERFACE-IMPL because it is considered to be interface specific.
A frame establishes a group of variable references which can be accessed in one step in the MCD system. This group is called "frame" within ASAP.
Formale Beschreibung
Hat als Kontext: | SW-MC-FRAMES
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-REFRESH-TIMING, SW-VARIABLE-REFS
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | Zeichenkette (CDATA) | SW-MC-FRAME | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.437. SW-MC-FRAMES

Beschreibung
Container Element für <SW-MC-FRAME>.
Formale Beschreibung
Hat als Kontext: | SW-MC-INTERFACE-IMPL
Ist Kontext für: | SW-MC-FRAME
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.438. SW-MC-GENERIC-INTERFACE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
In ASAM-MCD 1.x wird für jede Variante einer Kenngröße bzw. Variablen (d.h. für jede <SW-INSTANCE>) eine spezifische Konfiguration für die Schnittstellen zum Verstellsystem angelegt (<SW-MC-INSTANCE-INTERFACE>). In den dabei auftretenden Blobs wird jedoch sehr oft Information codiert, welche im ASAM-MCD - File schon einmal vorhanden ist, und ggf. durch intelligentere MCD-Systeme direkt gewonnen werden könnte.
Um solche Ansätze zu unterstützen, kann man in <SW-MC-GENERIC-INTERFACE> Regeln spezifizieren, wie die instanzspezifischen BLOBS zu errechnen sind.
Hinweis
Die Verwendung dieses Elementes ist unter den Projektbeteiligten abzustimmen. Das Element ist vorhanden, um praktische Erfahrung sammeln zu können. Insbesondere ist offen:
Benötigt man mehr als eine generische Schnittstellenbeschreibung pro MCD-Schnittstelle? Wenn ja, worin unterscheiden sich diese?
Hängt die generische Schnittstellenbeschreibung vom der Struktur der Kennlinie/Variablen ab?
Welche Sprachumgebung wird für die Spezifikation der Ausdrücke genutzt (z.B. Xpath, JavaScript, Perl ...)?
Example
Ein generischer XML-Prozessor könnte die Informationen in <SW-MC-GENERIC-INTERFACES> auswerten und die <SW-MC-INSTANCE-INTERFACE> im Instanzenbaum ausfüllen. Im folgenden Beispiel werden Xpath-Ausdrücke verwendet, um ausgehend von einer <SW-INSTANCE-PROPS-VARIANT> die Blob-Einträge zu berechnen.
<SW-MC-GENERIC-INTERFACE>
   <SW-MC-KP-BLOB-CONTS>
      xpath(SW-ADDR-INFOS/SW-ADDR-INFO/SW-BASE-ADRESS/text()) + xpath(SW-ADDR-INFOS/SW-ADDR-INFO/SW-CPU-MEM-SEG-REF/getAdressType()) + xpath(SW-ADDR-INFOS/SW-SIZE-OF-INSTANCE/text())
   </SW-MC-KP-BLOB-CONTS>
   <SW-MC-DP-BLOB-CONTS>
      xpath(SW-ADDR-INFOS/SW-ADDR-INFO/SW-BASE-ADRESS/text()) + count(SW-AXIS-CONTS[1]/SW-VALUES-PHYS/*)
   </SW-MC-DP-BLOB-CONTS>
</SW-MC-GENERIC-INTERFACE>
Formale Beschreibung
Hat als Kontext: | SW-MC-GENERIC-INTERFACES
Ist Kontext für: | LABEL, SHORT-LABEL, DESC, SW-MC-INTERFACE-DEFAULT-SOURCE, SW-MC-INTERFACE-AVL-SOURCES, SW-MC-KP-BLOB-CONTS, SW-MC-DP-BLOB-CONTS, SW-MC-PA-BLOB-CONTS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.439. SW-MC-GENERIC-INTERFACES

Beschreibung
Container Element für <SW-MC-GENERIC-INTERFACE>.
Formale Beschreibung
Hat als Kontext: | SW-MC-INTERFACE-IMPL
Ist Kontext für: | SW-MC-GENERIC-INTERFACE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.440. SW-MC-INSTANCE-INTERFACE

Beschreibung
This element describes a date record to describe the interface specific description data used at ASAP1b device. The parameters associated with this keyword are described in the ASAP2 metalanguage (in short A2ML) by the control unit supplier or the interface module supplier.
Formale Beschreibung
Hat als Kontext: | SW-MC-INSTANCE-INTERFACES
Ist Kontext für: | SW-MC-INTERFACE-REF, SW-MC-INTERFACE-DEFAULT-SOURCE, SW-MC-INTERFACE-AVL-SOURCES, SW-MC-KP-BLOB-CONTS, SW-MC-DP-BLOB-CONTS, SW-MC-PA-BLOB-CONTS, SW-MC-ADDR-MAPPINGS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.441. SW-MC-INSTANCE-INTERFACES

Beschreibung
Container Element für <SW-MC-INSTANCE-INTERFACES>.
Formale Beschreibung
Hat als Kontext: | SW-CPU-MEM-SEG, SW-INSTANCE-PROPS-VARIANT
Ist Kontext für: | SW-MC-INSTANCE-INTERFACE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.442. SW-MC-INTERFACE

Beschreibung
<SW-MC-INTERFACE> beschreibt die Struktur einer spezifischen Schnittstelle vom Steuergerät zum MCD-System. Diese Struktur wird im wesentlichen durch die Layouts der verwendeten BLOBS beschrieben, d.h. durch das Layout der Information, die zur Konfiguration des MCD-Systems für die betroffene Schnittstelle benötigt wird.
Formale Beschreibung
Hat als Kontext: | SW-MC-INTERFACE-SPEC
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-MC-BLOB-LAYOUTS
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | Zeichenkette (CDATA) | SW-MC-INTERFACE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.443. SW-MC-INTERFACE-AVL-SOURCES

Beschreibung
This Element provides the available sources referenced by <SW-MC-INTERFACE-SOURCE-REF>.
Formale Beschreibung
Hat als Kontext: | SW-MC-GENERIC-INTERFACE, SW-MC-INSTANCE-INTERFACE
Ist Kontext für: | SW-MC-INTERFACE-SOURCE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.444. SW-MC-INTERFACE-DEFAULT-SOURCE

Beschreibung
Interfaces for variables and parameters may have a default source specified in <SW-MC-INTERFACE-DEFAULT-SOURCE>. This must be one of the available sources specified in <SW-MC-INTERFACE-AVL-SOURCES>. This supports the fact that the user of an MCD System may change the source during runtime if the variable or the parameter is submitted in multiple source's communication. If this is done to its full extend, it will generate a lot of data.
Formale Beschreibung
Hat als Kontext: | SW-MC-GENERIC-INTERFACE, SW-MC-INSTANCE-INTERFACE
Ist Kontext für: | SW-MC-INTERFACE-SOURCE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.445. SW-MC-INTERFACE-IMPL

Beschreibung
This element comprises the actual blob data which represent the actual implementation of a particular interface. It consists of the driver specific blob in <SW-MC-TP-BLOB-CONTS>. In addition to this, the sources provided by the interface are specified in <SW-SYSTEM-MC-INTERFACE-SOURCES>.
Formale Beschreibung
Hat als Kontext: | SW-MC-INTERFACE-IMPLS
Ist Kontext für: | ADMIN-DATA, SW-MC-INTERFACE-REF, SW-MC-TP-BLOB-CONTS, SW-MC-GENERIC-INTERFACES, SW-MC-INTERFACE-SOURCES, SW-MC-FRAMES
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.446. SW-MC-INTERFACE-IMPLS

Beschreibung
Container Element für <SW-MC-INTERFACE-IMPL>.
Formale Beschreibung
Hat als Kontext: | SW-MC-COMMUNICATION-SPEC
Ist Kontext für: | SW-MC-INTERFACE-IMPL
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.447. SW-MC-INTERFACE-REF

Beschreibung
Dieses Element referenziert <SW-MC-INTERFACE> und bezeichnet die MCD-Schnittstelle, für die die im Kontext-Element angegebenen Informationen gültig sind.
Formale Beschreibung
Hat als Kontext: | SW-MC-INSTANCE-INTERFACE, SW-MC-INTERFACE-IMPL
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-MC-INTERFACE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.448. SW-MC-INTERFACE-SOURCE

Beschreibung
This source can be understood as a channel which provides access to data in a certain time raster for that particular interface. There can be different sources within different interfaces. There is a default souce (<SW-SYSTEM-MC-INTERFACE-DEFAULT-SOURCE>) which was not there in ASAM-MCD-2MC. This makes it easier for the user to specify a source each time he wants to have access to a particular data. <REFRESH-TIMING> describes the maximum update rate for different sources of the interfaces.
Formale Beschreibung
Hat als Kontext: | SW-MC-INTERFACE-SOURCES
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-REFRESH-TIMING, SW-MC-QP-BLOB-CONTS
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | Zeichenkette (CDATA) | SW-MC-INTERFACE-SOURCE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.449. SW-MC-INTERFACE-SOURCE-REF

Beschreibung
Dieses Element referenziert <SW-MC-INTERFACE-SOURCE>.
Formale Beschreibung
Hat als Kontext: | SW-MC-INTERFACE-AVL-SOURCES, SW-MC-INTERFACE-DEFAULT-SOURCE
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-MC-INTERFACE-SOURCE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.450. SW-MC-INTERFACE-SOURCES

Beschreibung
Container Element für <SW-MC-INTERFACE-SOURCE>.
Formale Beschreibung
Hat als Kontext: | SW-MC-INTERFACE-IMPL
Ist Kontext für: | SW-MC-INTERFACE-SOURCE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.451. SW-MC-INTERFACE-SPEC

Beschreibung
This Element specifies the interfaces to an MCD-system (Measurement, Calibration and Diagnostic systems) mainly in terms of
  • basic data types for the MCD communication (<SW-MCD-BASE-TYPES>)
  • layout of the blobs (<SW-MC-BLOB-LAYOUTS>)
  • data sources (SW-MC-)
Formale Beschreibung
Hat als Kontext: | SW-MC-COMMUNICATION-SPEC
Ist Kontext für: | ADMIN-DATA, SW-MC-INTERFACE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.452. SW-MC-KP-BLOB-CONTS

Beschreibung
Kanal Parameter - an interface specific description for accessing a software variable. It exists for each variable instance. It is a runtime blob and is used to transfer individual channel parameters.
Formale Beschreibung
Hat als Kontext: | SW-MC-GENERIC-INTERFACE, SW-MC-INSTANCE-INTERFACE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.453. SW-MC-KP-BLOB-LAYOUT

Beschreibung
Dieses Element beschreibt in ASAP-Syntax die für ein Verstellsystem relevanten Informationen eines Kanalparameter-BLOB-Layouts. Hierduch ist das Verstellsystem in der Lage, den <SW-MC-KP-BLOB-VALUE> zu interpretieren.
Formale Beschreibung
Hat als Kontext: | SW-MC-BLOB-LAYOUTS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.454. SW-MC-MAPPED-ADDR
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
This specifies the remapped address of the ECU to an access address. This is needed for special application methods (for example, special address calculation is needed in KWP2000, where only 24 bit addresses are available.)
Example
Siehe SW-MC-ADDR-MAPPING
Formale Beschreibung
Hat als Kontext: | SW-MC-ADDR-MAPPING
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.455. SW-MC-ORIGINAL-ADDR
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Original Address of a remapped address of the address space of the ECU to an access address. This is needed for special application methods (for example, special address calculation is needed in KWP2000, where only 24 bit addresses are available.)
Example
Siehe SW-MC-ADDR-MAPPING.
Formale Beschreibung
Hat als Kontext: | SW-MC-ADDR-MAPPING
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.456. SW-MC-PA-BLOB-CONTS

Beschreibung
This Element describes information in ASAP-Syntax to any special parameters needed for this service; these are in ASAP-Syntax.
Formale Beschreibung
Hat als Kontext: | SW-MC-GENERIC-INTERFACE, SW-MC-INSTANCE-INTERFACE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.457. SW-MC-PA-BLOB-LAYOUT

Beschreibung
Dieses Element beschreibt in ASAP-Syntax die für ein Verstellsystem relevanten Informationen eines Parameter-Accessr-BLOB-Layouts. Hierduch ist das Verstellsystem in der Lage, den <SW-MC-PA-BLOB-VALUE> zu interpretieren.
Formale Beschreibung
Hat als Kontext: | SW-MC-BLOB-LAYOUTS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.458. SW-MC-QP-BLOB-CONTS

Beschreibung
Quell Parameter - describes the different channels for data acquisitions for the MCD System such as measurements. It exists exactly once per raster. It is used at initialization time.
<SW-MC-BLOB-VALUE> is the value of the blob given in A2L microsyntax. <SW-MC-BLOB-ECU-DEPOSIT> is the alternative, if the blob is given as the instance of a calibration parameter.
Formale Beschreibung
Hat als Kontext: | SW-MC-INTERFACE-SOURCE
Ist Kontext für: | SW-MC-BLOB-VALUE, SW-MC-BLOB-ECU-DEPOSIT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.459. SW-MC-QP-BLOB-LAYOUT

Beschreibung
Dieses Element beschreibt die für ein Verstellsystem relevanten Informationen eines Quellparameter-BLOB-Layouts. Hierduch ist das Verstellsystem in der Lage, den <SW-MC-QP-BLOB-VALUE> zu interpretieren.
Formale Beschreibung
Hat als Kontext: | SW-MC-BLOB-LAYOUTS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.460. SW-MC-TP-BLOB-CONTS

Beschreibung
Treiber Parameter - specifies in the interface driver specific information. Usually there is a TP-BLOB for each interface. It exists for each interface supported by the ECU. It is used at initialization time.
<SW-MC-BLOB-VALUE> is the value of the blob given in A2L microsyntax. <SW-MC-BLOB-ECU-DEPOSIT> is the alternative, if the blob is given as the instance of a calibration parameter.
As any other blob contents, this comprises as a sequence of blob values (<SW-MC-BLOB-VALUE>) . The blob contents must match to the <SW-MC-TP-BLOB-LAYOUT>.
This element is used to transfer specific parameterisation and preparation values, the content of which are not known to the higher-ranking coordinator and which can only be passed by the latter. BLOBs originate generally from ASAP2 and are generated by the application.
Formale Beschreibung
Hat als Kontext: | SW-MC-INTERFACE-IMPL
Ist Kontext für: | SW-MC-BLOB-VALUE, SW-MC-BLOB-ECU-DEPOSIT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.461. SW-MC-TP-BLOB-LAYOUT

Beschreibung
Dieses Element beschreibt in ASAP-Syntax die für ein Verstellsystem relevanten Informationen eines Treiberparameter-BLOB-Layouts. Hierduch ist das Verstellsystem in der Lage, den <SW-MC-TP-BLOB-VALUE> zu interpretieren.
Formale Beschreibung
Hat als Kontext: | SW-MC-BLOB-LAYOUTS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.462. SW-MEM-ALIGNMENT

Beschreibung
Dieses Element spezifiziert die Ausrichtung eines Speicherobjektes.
Formale Beschreibung
Hat als Kontext: | SW-BASE-TYPE, SW-CPU-SPEC, SW-MC-BASE-TYPE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.463. SW-MEM-ATTR

Beschreibung
This element describes attributes of the corresponding segment. Valid values are:
<SW-MEM-ATTR>
Type | Description
INTERN | Internal Segment
EXTERN | External Segment
Formale Beschreibung
Hat als Kontext: | SW-CPU-MEM-SEG
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.464. SW-MEM-BASE-ADDR

Beschreibung
This element describes the initial address of the corresponding segment.
Formale Beschreibung
Hat als Kontext: | SW-CPU-MEM-SEG
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.465. SW-MEM-OFFSET

Beschreibung
This element describes the offset address of mirrored segments.
Formale Beschreibung
Hat als Kontext: | SW-MEM-OFFSETS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.466. SW-MEM-OFFSETS

Beschreibung
Container Element für <SW-MEM-OFFSET>.
Formale Beschreibung
Hat als Kontext: | SW-CPU-MEM-SEG
Ist Kontext für: | SW-MEM-OFFSET
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.467. SW-MEM-PROGRAM-TYPE

Beschreibung
Dieses Element beschreibt den Typ der in dem Speichersegment abgelegten Daten.
<SW-MEM-PROGRAM-TYPE>
Typ | Beschreibung
CODE | Program Code
DATA | Programm-Daten, welche für online Kalbrierung verwendet werden können
OFFLINE-DATA | Program -Daten, welche nur für offline Kalibrierung verwendet werden dürfen.
VARIABLES | Programm-Variablen
SERAM | Programm-Daten für serielle Emulation
RESERVED | Reservierte Segmente
CALIBRATION_VARIABLES | Values which are available in the ECU but do not exist in the Hex-file. There is no upload required to get access to the ECU data. The ECU will never be touched by the instrumentation tool except by upload.
EXCLUDE_FROM_FLASH | Values existing in the ECU but not droped down in the binary file. There should no upload be needed to get access to the ECU data. The ECU will never be touched by the instrumentation tool ex-cept by upload.
Formale Beschreibung
Hat als Kontext: | SW-CPU-MEM-SEG
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.468. SW-MEM-SIZE

Beschreibung
Dieses Element spezifiziert die Läge des korrespondierenden Speichersegmentes.
Formale Beschreibung
Hat als Kontext: | SW-CPU-MEM-SEG
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.469. SW-MEM-TYPE

Beschreibung
Dieses Element beschreibt den verwendeten Speichertyp des aktuellen Speichersegments. Folgende Typen sind erlaubt:
<SW-MEM-TYPE>
Typ | Beschreibung
RAM | RAM-Segment
EEPROM | EEPROM-Segment
EPROM | EPROM-Segment
ROM | ROM-Segment
REGISTER | CPU-Register-Segment
FLASH | FLASH-Segment
Formale Beschreibung
Hat als Kontext: | SW-CPU-MEM-SEG
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.470. SW-MIN-AXIS-POINTS

Beschreibung
Dieses Element spezifiziert die minimale Anzahl Stützstellen auf der aktuellen Achse für ein Kennfeld bzw. Kennlinie.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-INDIVIDUAL
Ist Kontext für: | Text, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.471. SW-MONOTONY

Beschreibung
Dieses Element spezifiziert die Monotonie-Eigenschaften der aktuellen internen bzw. physikalischen Grenzen. Folgende Tabelle zeigt die Monotonieeigenschaften, welche durch die entsprechenden Werte zu befüllen sind. Falls kein Inhalt im Element vorhanden ist oder das Element weggelassen wird, ist keine Monotonie (no-monotony) der Default-Inhalt.
Monotonieeigenschaften
Name | Typ
increasing | Zeichenkette (CDATA)
optional | Zeichenkette (CDATA)
optional | Zeichenkette (CDATA)
optional | optional
optional | optional
Formale Beschreibung
Hat als Kontext: | SW-INTERNAL-CONSTRS, SW-PHYS-CONSTRS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.472. SW-NUMBER-OF-AXIS-POINTS

Beschreibung
Die Anzahl der zu berechnenden Stützstellen der aktuellen Achse wird in <SW-NUMER-OF-AXIS-POINTS> definiert.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-GENERIC
Ist Kontext für: | Text, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.473. SW-PHYS-CONSTRS

Beschreibung
Beschreibt die physikalischen Grenzen für Variablen- bzw. Parameterwerte.
Formale Beschreibung
Hat als Kontext: | SW-DATA-CONSTR-RULE
Ist Kontext für: | LOWER-LIMIT, UPPER-LIMIT, SW-SCALE-CONSTRS, SW-UNIT-REF, SW-MAX-DIFF, SW-MONOTONY, SW-RELATED-CONSTRS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.474. SW-PHYS-CONSTRS-1

Beschreibung
Dieses Element schränkt <SW-PHYS-CONSTRS> derart ein, daß nur Wertebereiche definiert werden können.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-METHOD
Ist Kontext für: | SW-SCALE-CONSTR
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.475. SW-PROCESS
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Prozesse werden innerhalb von <SW-FEATURE-DECOMPOSITION> definiert. Dabei werden auch die Zuordnungen der Prozesse auf die Tasks vorgenommen. Für weitere Informationen zu Tasks und Prozessen, siehe auch SW-TASK-SPEC
Example
Siehe SW-FEATURE-DECOMPOSITION
Formale Beschreibung
Hat als Kontext: | SW-PROCESSES
Ist Kontext für: | LABEL, SHORT-LABEL, SW-TASK-REF, DESC
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.476. SW-PROCESSES

Beschreibung
Container Element für <SW-PROCESS>.
Formale Beschreibung
Hat als Kontext: | SW-SUBCOMPONENT
Ist Kontext für: | SW-PROCESS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.477. SW-RECORD-LAYOUT
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Defines how the data objects (variables, calibration parameters etc.) shall be stored in the ECU memory. As an example, this definition specifies the sequence of axis points in the ECU memory. Iterations through axis values are stored within the subelements <SW-RECORD-LAYOUT-GROUP>. These subelements might be stored nested.
Example
<SW-RECORD-LAYOUTS>
   <SW-RECORD-LAYOUT ID="KWUB">
      <LONG-NAME>this is SW-RECORD-LAYOUT Kennwert Unsigned Byte KWUB</LONG-NAME>
      <SHORT-NAME>KwUb</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
         <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
         <SW-RECORD-LAYOUT-V>
            <SW-BASE-TYPE-REF ID-REF="UBYTE">UBYTE</SW-BASE-TYPE-REF>
            <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
         </SW-RECORD-LAYOUT-V>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="SIMPLE-CURVE">
      <LONG-NAME>This is the record layout for a simple curve.</LONG-NAME>
      <SHORT-NAME>rly-simple-curve</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-V>
            <SW-BASE-TYPE-REF ID-REF="UBYTE">UBYTE</SW-BASE-TYPE-REF>
            <SW-RECORD-LAYOUT-V-PROP>SOURCE-ADR</SW-RECORD-LAYOUT-V-PROP>
         </SW-RECORD-LAYOUT-V>
         <SW-RECORD-LAYOUT-V>
            <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
         </SW-RECORD-LAYOUT-V>
         <SW-RECORD-LAYOUT-GROUP>
            <DESC>Here are the values of the x axis.</DESC>
            <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
            <SW-RECORD-LAYOUT-GROUP-INDEX>x</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
               <SW-RECORD-LAYOUT-V-INDEX>x</SW-RECORD-LAYOUT-V-INDEX>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <DESC>Here are the values of the value axis.</DESC>
            <SW-RECORD-LAYOUT-GROUP-AXIS>0</SW-RECORD-LAYOUT-GROUP-AXIS>
            <SW-RECORD-LAYOUT-GROUP-INDEX>v</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
               <SW-RECORD-LAYOUT-V-INDEX>v</SW-RECORD-LAYOUT-V-INDEX>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="ALTERNATIVE-CURVE">
      <LONG-NAME>This is the record layout for an alternative curve.</LONG-NAME>
      <SHORT-NAME>alternative-curve</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-V>
            <SW-BASE-TYPE-REF ID-REF="UBYTE">UBYTE</SW-BASE-TYPE-REF>
            <SW-RECORD-LAYOUT-V-PROP>SOURCE-ADR</SW-RECORD-LAYOUT-V-PROP>
         </SW-RECORD-LAYOUT-V>
         <SW-RECORD-LAYOUT-V>
            <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
         </SW-RECORD-LAYOUT-V>
         <SW-RECORD-LAYOUT-GROUP>
            <DESC>Here are the values of the x axis.</DESC>
            <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
            <SW-RECORD-LAYOUT-GROUP-INDEX>x</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
               <SW-RECORD-LAYOUT-V-INDEX>x</SW-RECORD-LAYOUT-V-INDEX>
            </SW-RECORD-LAYOUT-V>
            <SW-RECORD-LAYOUT-V>
               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
               <SW-RECORD-LAYOUT-V-INDEX>x</SW-RECORD-LAYOUT-V-INDEX>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="SIMPLE-MAP">
      <LONG-NAME>This is the record layout for a simple map.</LONG-NAME>
      <SHORT-NAME>simple_map</SHORT-NAME>
      <DESC>Appendix B in ASAP2-specification (KEBUSS).</DESC>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF ID-REF="UBYTE">UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
            <SW-RECORD-LAYOUT-V>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <DESC>Here are the values of the x axis.</DESC>
            <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
            <SW-RECORD-LAYOUT-GROUP-INDEX>x</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>-1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF ID-REF="UBYTE">UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
               <SW-RECORD-LAYOUT-V-INDEX>x</SW-RECORD-LAYOUT-V-INDEX>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <DESC>Here are the values of the y axis.</DESC>
            <SW-RECORD-LAYOUT-GROUP-AXIS>2</SW-RECORD-LAYOUT-GROUP-AXIS>
            <SW-RECORD-LAYOUT-GROUP-INDEX>y</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>-1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF ID-REF="UWORD">UWORD</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>2</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
               <SW-RECORD-LAYOUT-V-INDEX>x</SW-RECORD-LAYOUT-V-INDEX>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-AXIS>2</SW-RECORD-LAYOUT-GROUP-AXIS>
            <SW-RECORD-LAYOUT-GROUP-INDEX>y</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>-1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-GROUP>
               <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
               <SW-RECORD-LAYOUT-GROUP-INDEX>x</SW-RECORD-LAYOUT-GROUP-INDEX>
               <SW-RECORD-LAYOUT-GROUP-FROM>-1</SW-RECORD-LAYOUT-GROUP-FROM>
               <SW-RECORD-LAYOUT-GROUP-TO>1</SW-RECORD-LAYOUT-GROUP-TO>
               <SW-RECORD-LAYOUT-V>
                  <SW-BASE-TYPE-REF ID-REF="UWORD">UWORD</SW-BASE-TYPE-REF>
                  <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                  <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                  <SW-RECORD-LAYOUT-V-INDEX>x y</SW-RECORD-LAYOUT-V-INDEX>
               </SW-RECORD-LAYOUT-V>
            </SW-RECORD-LAYOUT-GROUP>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="COMMON-X-AXIS">
      <LONG-NAME>This is the record layout for a common x Axis.</LONG-NAME>
      <SHORT-NAME>common-x-axis</SHORT-NAME>
      <DESC></DESC>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF ID-REF="UBYTE">UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <DESC>Here are the values of the x axis.</DESC>
            <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
            <SW-RECORD-LAYOUT-GROUP-INDEX>x</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF ID-REF="UBYTE">UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
               <SW-RECORD-LAYOUT-V-INDEX>x</SW-RECORD-LAYOUT-V-INDEX>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="IDB6433D9radCD2F5">
      <LONG-NAME>Ablageschema Festkennfeld FKF0</LONG-NAME>
      <SHORT-NAME>FKF0</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-AXIS>2</SW-RECORD-LAYOUT-GROUP-AXIS>
            <SW-RECORD-LAYOUT-GROUP-INDEX>Y</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-GROUP>
               <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
               <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
               <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
               <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
               <SW-RECORD-LAYOUT-V>
                  <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                  <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                  <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                  <SW-RECORD-LAYOUT-V-INDEX>Y X</SW-RECORD-LAYOUT-V-INDEX>
               </SW-RECORD-LAYOUT-V>
            </SW-RECORD-LAYOUT-GROUP>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="IDB6433D9rad19537">
      <LONG-NAME>Ablageschema Festkennlinie FKL0</LONG-NAME>
      <SHORT-NAME>FKL0</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="IDB6433D9rad4EA19">
      <LONG-NAME>Ablageschema Gruppenkennfeld GKF0</LONG-NAME>
      <SHORT-NAME>GKF0</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-AXIS>2</SW-RECORD-LAYOUT-GROUP-AXIS>
            <SW-RECORD-LAYOUT-GROUP-INDEX>Y</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-GROUP>
               <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
               <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
               <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
               <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
               <SW-RECORD-LAYOUT-V>
                  <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                  <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                  <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                  <SW-RECORD-LAYOUT-V-INDEX>Y X</SW-RECORD-LAYOUT-V-INDEX>
               </SW-RECORD-LAYOUT-V>
            </SW-RECORD-LAYOUT-GROUP>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="IDB6433D9rad921E6">
      <LONG-NAME>Ablageschema Gruppenkennlinie GKL0</LONG-NAME>
      <SHORT-NAME>GKL0</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="IDB6433D9radBE1E5">
      <LONG-NAME>Ablageschema Kennfeld KF0</LONG-NAME>
      <SHORT-NAME>KF0</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>SOURCE-ADR</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>2</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>SOURCE-ADR</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>2</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-INDEX>Y</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>2</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-AXIS>2</SW-RECORD-LAYOUT-GROUP-AXIS>
            <SW-RECORD-LAYOUT-GROUP-INDEX>Y</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-GROUP>
               <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
               <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
               <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
               <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
               <SW-RECORD-LAYOUT-V>
                  <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
                  <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                  <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                  <SW-RECORD-LAYOUT-V-INDEX>Y X</SW-RECORD-LAYOUT-V-INDEX>
               </SW-RECORD-LAYOUT-V>
            </SW-RECORD-LAYOUT-GROUP>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="IDB6433D9rad9E02A">
      <LONG-NAME>Ablageschema Kennlinie KL0</LONG-NAME>
      <SHORT-NAME>KL0</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>SOURCE-ADR</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="IDB6433D9rad1063C">
      <LONG-NAME>Ablageschema Kennlinie KL1</LONG-NAME>
      <SHORT-NAME>KL1</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>SOURCE-ADR</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="IDB6433D9rad9035C">
      <LONG-NAME>Ablageschema Kennwert KW0</LONG-NAME>
      <SHORT-NAME>KW0</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <DESC>IGNORE</DESC>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <DESC>IGNORE</DESC>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="IDB6433D9rad2AE47">
      <LONG-NAME>Ablageschema Kennwert KW1</LONG-NAME>
      <SHORT-NAME>KW1</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UWORD</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="IDB6433D9rad7A3B6">
      <LONG-NAME>Ablageschema Kennwert KW2</LONG-NAME>
      <SHORT-NAME>KW2</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>ULONG</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="IDB6433D9rad65958">
      <LONG-NAME>Ablageschema Kennwertblock KWB0</LONG-NAME>
      <SHORT-NAME>KWB0</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="IDB6433D9radDE73A">
      <LONG-NAME>Ablageschema Einzelstützstelle SST0</LONG-NAME>
      <SHORT-NAME>SST0</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>SOURCE-ADR</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="ID71EA062AradC6319">
      <LONG-NAME>Gruppenkennfeld SWORD</LONG-NAME>
      <SHORT-NAME>GkfWSw</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-AXIS>2</SW-RECORD-LAYOUT-GROUP-AXIS>
            <SW-RECORD-LAYOUT-GROUP-INDEX>Y</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-GROUP>
               <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
               <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
               <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
               <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
               <SW-RECORD-LAYOUT-V>
                  <SW-BASE-TYPE-REF>SWORD</SW-BASE-TYPE-REF>
                  <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                  <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                  <SW-RECORD-LAYOUT-V-INDEX>Y X</SW-RECORD-LAYOUT-V-INDEX>
               </SW-RECORD-LAYOUT-V>
            </SW-RECORD-LAYOUT-GROUP>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="ID71EA062AradC16F8">
      <LONG-NAME>Gruppenkennfeld UWORD</LONG-NAME>
      <SHORT-NAME>GkfWUw</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-AXIS>2</SW-RECORD-LAYOUT-GROUP-AXIS>
            <SW-RECORD-LAYOUT-GROUP-INDEX>Y</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-GROUP>
               <SW-RECORD-LAYOUT-GROUP-AXIS>1</SW-RECORD-LAYOUT-GROUP-AXIS>
               <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
               <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
               <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
               <SW-RECORD-LAYOUT-V>
                  <SW-BASE-TYPE-REF>UWORD</SW-BASE-TYPE-REF>
                  <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
                  <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
                  <SW-RECORD-LAYOUT-V-INDEX>Y X</SW-RECORD-LAYOUT-V-INDEX>
               </SW-RECORD-LAYOUT-V>
            </SW-RECORD-LAYOUT-GROUP>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="ID71EA062AradE849A">
      <LONG-NAME>Kenntexte mit Endekennung</LONG-NAME>
      <SHORT-NAME>KtxC</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP> </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="ID71EA062AradC0865">
      <LONG-NAME>Kenntexte aufgefuellt bis zur max. Laenge</LONG-NAME>
      <SHORT-NAME>KtxF</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="ID71EA062AradCF598">
      <LONG-NAME>Kenntexte mit Laenge am Anfang</LONG-NAME>
      <SHORT-NAME>KtxL</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="ID71EA062Arad021C9">
      <LONG-NAME>Kennwertblock UBYTE</LONG-NAME>
      <SHORT-NAME>KwbUb</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="ID71EA062AradCE36D">
      <LONG-NAME>Kennwertblock UWORD</LONG-NAME>
      <SHORT-NAME>KwbUw</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UWORD</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="ID71EA062Arad66295">
      <LONG-NAME>Kennwert UBYTE</LONG-NAME>
      <SHORT-NAME>KwUb</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UBYTE</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="ID71EA062AradB6CC6">
      <LONG-NAME>Kennwert UWORD</LONG-NAME>

      <SHORT-NAME>KwUw</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UWORD</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>0</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>

   <SW-RECORD-LAYOUT ID="ID71EA062Arad32B0C">
      <LONG-NAME>Einzelstützstelle UWORD Einzelstützstelle UWORD</LONG-NAME>
      <SHORT-NAME>SstAUwSstUw</SHORT-NAME>
      <SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UWORD</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>COUNT</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
         <SW-RECORD-LAYOUT-GROUP>
            <SW-RECORD-LAYOUT-GROUP-INDEX>X</SW-RECORD-LAYOUT-GROUP-INDEX>
            <SW-RECORD-LAYOUT-GROUP-FROM>1</SW-RECORD-LAYOUT-GROUP-FROM>
            <SW-RECORD-LAYOUT-GROUP-TO>-1</SW-RECORD-LAYOUT-GROUP-TO>
            <SW-RECORD-LAYOUT-V>
               <SW-BASE-TYPE-REF>UWORD</SW-BASE-TYPE-REF>
               <SW-RECORD-LAYOUT-V-AXIS>1</SW-RECORD-LAYOUT-V-AXIS>
               <SW-RECORD-LAYOUT-V-PROP>VALUE</SW-RECORD-LAYOUT-V-PROP>
            </SW-RECORD-LAYOUT-V>
         </SW-RECORD-LAYOUT-GROUP>
      </SW-RECORD-LAYOUT-GROUP>
   </SW-RECORD-LAYOUT>
</SW-RECORD-LAYOUTS>
Formale Beschreibung
Hat als Kontext: | SW-RECORD-LAYOUTS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-RECORD-LAYOUT-GROUP
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-RECORD-LAYOUT | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.478. SW-RECORD-LAYOUT-COMPONENT

Beschreibung
This Element It is used to denote the component the group in question applies to. Thus record layout supports structured objects. This provides independence of the sequence of components because the can be referred to via name.
Formale Beschreibung
Hat als Kontext: | SW-RECORD-LAYOUT-GROUP
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.479. SW-RECORD-LAYOUT-GROUP

Beschreibung
Specifies how a record layout is set up. Using <SW-RECORD-LAYOUT-GROUP> recursively models iterations through axis values. The subelement <SW-RECORD-LAYOUT-REF> may reference other <SW-RECORD-LAYOUT>s. The order of the subelements <SW-RECORD-LAYOUT-REF>, <SW-RECORD-LAYOUT-V> and <SW-RECORD-LAYOUT-GROUP> is relevant for the modeled record layout.
Formale Beschreibung
Hat als Kontext: | SW-RECORD-LAYOUT, SW-RECORD-LAYOUT-GROUP
Ist Kontext für: | DESC, SW-RECORD-LAYOUT-GROUP-AXIS, SW-RECORD-LAYOUT-GROUP-INDEX, SW-GENERIC-AXIS-PARAM-TYPE-REF, SW-RECORD-LAYOUT-GROUP-FROM, SW-RECORD-LAYOUT-GROUP-TO, SW-RECORD-LAYOUT-GROUP-STEP, SW-RECORD-LAYOUT-COMPONENT, SW-RECORD-LAYOUT-REF, SW-RECORD-LAYOUT-V, SW-RECORD-LAYOUT-GROUP
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.480. SW-RECORD-LAYOUT-GROUP-AXIS

Beschreibung
Der Inhalt dieses Elementes spezifiziert die Achsen-Nummer innerhalb einer Record Layout Gruppe <SW-RECORD-LAYOUT-GROUP>. Die Geschwisterelemente rechts im Baum neben <SW-RECORD-LAYOUT-GROUP-AXIS> beziehen sich auf die genau diese Achsen-Nummer.
Formale Beschreibung
Hat als Kontext: | SW-RECORD-LAYOUT-GROUP
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.481. SW-RECORD-LAYOUT-GROUP-FROM

Beschreibung
Dieses Element spezifiziert den Iterator-Index für einen Achsen-Punkt, ab welchem für eine Record Layout Gruppe <SW-RECORD-LAYOUT-GROUP> begonnen wird. Es sind auch negative Werte möglich, d.h. ein Wert -4 zählt ab dem viertletzten Wert.
Formale Beschreibung
Hat als Kontext: | SW-RECORD-LAYOUT-GROUP
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.482. SW-RECORD-LAYOUT-GROUP-INDEX

Beschreibung
Dieses Element vergibt einen symbolischen Namen für den Iterator der übergelagerten Record-Layout-Gruppe <SW-RECORD-LAYOUT-GROUP>. Dieser kann unterhalb untergeordneten oder nachfolgenden <SW-RECORD-LAYOUT-V>-Elementen als ein Schleifenindex referenziert werden.
Formale Beschreibung
Hat als Kontext: | SW-RECORD-LAYOUT-GROUP
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.483. SW-RECORD-LAYOUT-GROUP-STEP

Beschreibung
Dieses Element spezifiziert die Schrittweite für den Iterator-Index, welcher für eine Record Layout Gruppe <SW-RECORD-LAYOUT-GROUP> verwendet wird.
Formale Beschreibung
Hat als Kontext: | SW-RECORD-LAYOUT-GROUP
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.484. SW-RECORD-LAYOUT-GROUP-TO

Beschreibung
Dieses Element spezifiziert den Iterator-Index für einen Achsen-Punkt, bis zu welchem für eine Record Layout Gruppe iteriert wird. Es sind auch negative Werte möglich, d.h. ein Wert -4 zählt bis zu dem viertletzten Wert
Formale Beschreibung
Hat als Kontext: | SW-RECORD-LAYOUT-GROUP
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.485. SW-RECORD-LAYOUT-REF

Beschreibung
Dieses Element referenziert <SW-RECORD-LAYOUT>.
Formale Beschreibung
Hat als Kontext: | SW-CPU-STANDARD-RECORD-LAYOUT, SW-DATA-DEF-PROPS, SW-RECORD-LAYOUT-GROUP, SW-RECORD-LAYOUT-REFS, SW-RECORD-LAYOUT-V
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-RECORD-LAYOUT | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.486. SW-RECORD-LAYOUT-REFS

Beschreibung
Container Element für <SW-RECORD-LAYOUT-REF>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-CONT
Ist Kontext für: | SW-RECORD-LAYOUT-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.487. SW-RECORD-LAYOUT-V

Beschreibung
Dieses Element spezifiziert, welche Werte für die aktuelle <SW-RECORD-LAYOUT-GROUP> abgespeichert sind. Falls kein <SW-BASE-TYPE-REF> vorhanden ist, ist der zuerst im Vaterelement <SW-RECORD-LAYOUT-GROUP> referenzierte <SW-BASE-TYPE> gültig. Durch Angabe von <SW-RECORD-LAYOUT-V-AXIS> wird die Achse angegeben, von der Werte gemäß des aktuellen Record Layouts <SW-RECORD-LAYOUT-GROUP> abzuspeichern sind. In <SW-RECORD-LAYOUT-V-PROP> spezifiziert man, um welche Art von abzuspeichernden Werten, z.B. Anzahl oder Wert, es sich handelt. Unter <SW-RECORD-V-INDEX> gibt man die symbolischen Werte der Achsen an, für welche man den unter <SW-RECORD-LAYOUT-V-PROP> angegebenden Wert iteriert. Diese symbolischen Werte beziehen sich auf in <SW-RECORD-LAYOUT-GROUP-INDEX> vergebene Werte.
Formale Beschreibung
Hat als Kontext: | SW-RECORD-LAYOUT-GROUP
Ist Kontext für: | DESC, SW-BASE-TYPE-REF, SW-RECORD-LAYOUT-V-AXIS, SW-RECORD-LAYOUT-V-PROP, SW-RECORD-LAYOUT-V-INDEX, SW-GENERIC-AXIS-PARAM-TYPE-REF, SW-RECORD-LAYOUT-V-FIX-VALUE, SW-RECORD-LAYOUT-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.488. SW-RECORD-LAYOUT-V-AXIS

Beschreibung
Dieses Element spezifiziert die Nummer der Achse, von welcher Werte im Steuergerät abgespeichert sind. Nähres findet man unter <SW-RECORD-LAYOUT-V>.
Formale Beschreibung
Hat als Kontext: | SW-RECORD-LAYOUT-V
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.489. SW-RECORD-LAYOUT-V-FIX-VALUE

Beschreibung
Dieses Element spezifiziert als Hex-Ziffern anzugebende Füllzeichen für das aktuelle Record-Layout. Im parallel dazu vorhandenen Element <SW-RECORD-LAYOUT-V-PROP> muß hierzu der Inhalt FILL stehen.
Formale Beschreibung
Hat als Kontext: | SW-RECORD-LAYOUT-V
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.490. SW-RECORD-LAYOUT-V-INDEX
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieser symbolische Wert bzw. diese durch Leerzeichen getrennten symbolischen Werte für Iteratoren referenzieren auf die in <SW-RECORD-LAYOUT-GROUP-INDEX> vergebenen symbolischen Werte. Die Iteratoren werden von links nach rechts derart abgearbeitet, daß sie Schleifenindizes von außen nach innen symbolisieren.
Es ist ein Fehler, wenn ein Parameter einen Record Layout referenziert, welcher einen <SW-RECORD-LAYOUT-V-INDEX> mit mehr Komponenten enthält, als der Parameter Achsen hat.
Abbildung 4: Beispiel für eine solche Fehlerprüfung in MetaMorphosis
//*******************************************************

//Übung: dieses in XPath tun  :-)

((*prm:=this).null,
 \ref(child[?sw-record-layout-ref].data)
    [
       ?descendant[?sw-record-layout-v-index
                     [
                      count(data.split(" ")) ^=
                      count(*prm.descendant[?sw-calprm-axis])
                     ]
                  ]
    ]
)
Example
Siehe SW-RECORD-LAYOUT
Formale Beschreibung
Hat als Kontext: | SW-RECORD-LAYOUT-V
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.491. SW-RECORD-LAYOUT-V-PROP

Beschreibung
Der Inhalt dieses Elementes beschreibt die Art der abzuspeichernden Werte. Zulässig sind:
VALUE | The value of the axis
COUNT | The amount of values of the axis
LEFTDIFF | The difference to the previous value
RIGHTDIFF | The difference to the next value
DIST | The <distance> value of this axis (if introduced)
SOURCE-ADR | The adress of the source of this axis
RESULT-ADR | The adress of the result for this axis (if introduced)
ADDRESS | the adress
FILL | Fill with the hex value specified as contents of <SW-RECORD-LAYOUT-FIX-VALUE>
FIXLEFTDIFF | Differenz zu einem linken festen Wert (i.d.R. 0)
FIXRIGHTDIFF | Differenz zu einem rechten festen Wert (z.B. 255)
... | Further values must be worked out.
Formale Beschreibung
Hat als Kontext: | SW-RECORD-LAYOUT-V
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.492. SW-RECORD-LAYOUTS

Beschreibung
Container Element für <SW-RECORD-LAYOUT>.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DICTIONARY-SPEC
Ist Kontext für: | ADMIN-DATA, SW-RECORD-LAYOUT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.493. SW-REFRESH-TIMING
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element spezifiziert die Aufruf- bzw. Berechnungs-Häufigkeit des betroffenen Objektes.
Example
<SW-VARIABLE>
   <LONG-NAME>Drehzahl</LONG-NAME>
   <SHORT-NAME>N</SHORT-NAME>
   <SW-DATA-DEF-PROPS>
      <SW-INTENDED-RESOLUTION>40</SW-INTENDED-RESOLUTION>
      <SW-REFRESH-TIMING>
         <SW-CSE-CODE>101</SW-CSE-CODE>
         <SW-CSE-CODE-FACTOR>1</SW-CSE-CODE-FACTOR>
      </SW-REFRESH-TIMING>
      <SW-UNIT-REF>upm</SW-UNIT-REF>
   </SW-DATA-DEF-PROPS>
</SW-VARIABLE>
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS, SW-MC-FRAME, SW-MC-INTERFACE-SOURCE, SW-TASK
Ist Kontext für: | SW-CSE-CODE, SW-CSE-CODE-FACTOR
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.494. SW-RELATED-CONSTRS

Beschreibung
Dieses Element beschreibt Plausibilisierungsregeln, die über das eigene Datenobjekt hinausgreifen. Z.B. darf die Schubabschaltdrehzahl nicht über der Maximaldrehzahl liegen. Diese Plausibilisierungsregel wird genau so definiert wie die Zusammenhänge und Abhängigkeiten von virtuellen Kenngrößen und Variablen.
Formale Beschreibung
Hat als Kontext: | SW-INTERNAL-CONSTRS, SW-PHYS-CONSTRS
Ist Kontext für: | SW-DATA-DEPENDENCY
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.495. SW-ROOT-FEATURES

Beschreibung
Dieses Element ist das Wurzelelement der durch die Funktionszerlegung implizit gegebenen Hierarchie.
Formale Beschreibung
Hat als Kontext: | SW-COMPONENT-SPEC
Ist Kontext für: | SW-FEATURE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.496. SW-SCALE-CONSTR

Beschreibung
Beschreibt die abschnittsweise definierten Ober- und Untergrenzen für interne sowie physikalische Grenzen.
Formale Beschreibung
Hat als Kontext: | SW-INTERNAL-CONSTRS-1, SW-PHYS-CONSTRS-1, SW-SCALE-CONSTRS
Ist Kontext für: | LOWER-LIMIT, UPPER-LIMIT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.497. SW-SCALE-CONSTRS

Beschreibung
Container Element für <SW-SCALE-CONSTR>.
Formale Beschreibung
Hat als Kontext: | SW-INTERNAL-CONSTRS, SW-PHYS-CONSTRS
Ist Kontext für: | SW-SCALE-CONSTR
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.498. SW-SIZEOF-INSTANCE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element gibt die Größe eines Speicherobjektes in Byte, an. Diese wird benötigt, um bei Ablage von Strukturen die Einzeladdressen der Komponenten nachrechnen zu können.
Example
Siehe SW-ADDR-INFO
Formale Beschreibung
Hat als Kontext: | SW-ADDR-INFO
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.499. SW-SUBCOMPONENT
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt eine Unterkomponente innerhalb der funktionalen Zerlegung eines Features. Bei dieser Zusammensetzung kann auch eine Prozeßreihenfolge spezifiziert werden (siehe <SW-FEATURE-DECOMPOSITION>).
Example
Siehe SW-FEATURE-DECOMPOSITION
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-DECOMPOSITION
Ist Kontext für: | SW-FEATURE-REF, SW-PROCESSES
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.500. SW-SYSCOND

Beschreibung
Dieses Element spezifiziert einen zu errechnenden Ausdruck, in dem System-Konstanten, referenziert durch <SW-SYSTEMCONST-CODED-REF> und <SW-SYSTEMCONST-PHYS-REF>, substituiert werden.
Formale Beschreibung
Hat als Kontext: | SW-CALPRM-PROTOTYPE, SW-CALPRM-REF-SYSCOND, SW-CLASS-PROTOTYPE, SW-INSTANCE-REF-SYSCOND, SW-VARIABLE-PROTOTYPE, SW-VARIABLE-REF-SYSCOND
Ist Kontext für: | Text, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.501. SW-SYSTEM
Siehe Auch Description Example Formale Beschreibung

Description
<SW-SYSTEM> describes one particular system within the current file. This supports to transfer the calibration data of multi ecu systems within one file.
Example
<SW-SYSTEM>
   <SHORT-NAME>DEMO</SHORT-NAME>
   <SW-INSTANCE-SPEC>
      <INTRODUCTION>
         <P>This is the system to demonstrate, how CDF should work.</P>
      </INTRODUCTION>
      <SW-INSTANCE-TREE>
         <SHORT-NAME>Summertest</SHORT-NAME>
         <SW-INSTANCE>
            <LONG-NAME>faule Bären aus München (Viktualienmarkt)</LONG-NAME>
            <SHORT-NAME>FBAM_V</SHORT-NAME> ... </SW-INSTANCE>
      </SW-INSTANCE-TREE>
   </SW-INSTANCE-SPEC>
</SW-SYSTEM>
Formale Beschreibung
Hat als Kontext: | SW-SYSTEMS
Ist Kontext für: | NA, TBD, TBR, LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, INTRODUCTION, SW-ARCHITECTURE, SW-TEST-SPEC, SW-DATA-DICTIONARY-SPEC, SW-COMPONENT-SPEC, SW-INSTANCE-SPEC, SW-COLLECTION-SPEC, SW-USER-RIGHT-SPEC, SW-CPU-SPEC, SW-CALIBRATION-METHOD-SPEC, SW-VCD-SPEC, ADD-SPEC
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-SYSTEM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | SW-ADDR-METHOD SW-AXIS-TYPE SW-BASE-TYPE SW-CALPRM SW-CALPRM-PROTOTYPE SW-CLASS-PROTOTYPE SW-CLASS-ATTR-IMPL SW-CLASS-INSTANCE SW-CLASS SW-CODE-SYNTAX SW-COLLECTION SW-COMPU-METHOD SW-CPU-MEM-SEG SW-DATA-CONSTR SW-FEATURE SW-GENERIC-AXIS-PARAM-TYPE SW-INSTANCE-TREE SW-INSTANCE SW-RECORD-LAYOUT SW-SYSTEMCONST SW-TASK SW-TEMPLATE SW-UNIT SW-USER-ACCESS-CASE SW-USER-GROUP SW-VARIABLE-PROTOTYPE SW-VARIABLE SW-VCD-CRITERION | Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')


1.502. SW-SYSTEMCONST
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element spezifiziert eine Systemkonstante. Eine Systemkonstante ist typischerweise zur Compilezeit (nicht zur Laufzeit) verfügbar. Eine Systemkonstante kann einer bestimmten Kategorie <CATEGORY> angehören. Physikalische Werte <SW-VALUES-PHYS> bzw. interne Werte <SW-VALUES-CODED> sind spezifizierbar. Wenn die Systemkonstante codiert referenziert ist, aber nur physikalisch gesetzt wurde, wird statt der Referenz der umgerechnete Wert eingesetzt. Die Referenzen auf Systemkonstanten werden also literal durch den (ggf. errechneten) Wert der referenzierten Systemkonstante ersetzt.
Example
<MSRSW>
   <ADMIN-DATA>
      <LANGUAGE>EN</LANGUAGE>
   </ADMIN-DATA>
   <INTRODUCTION></INTRODUCTION>
   <SW-SYSTEMS>
      <SW-SYSTEM>
         <LONG-NAME><?xm-replace_text {LONG-NAME}></LONG-NAME>
         <SHORT-NAME><?xm-replace_text {SHORT-NAME}></SHORT-NAME>
         <SW-DATA-DICTIONARY-SPEC>
            <SW-SYSTEMCONSTS>
               <SW-SYSTEMCONST>
                  <LONG-NAME><?xm-replace_text{LONG-NAME}></LONG-NAME>
                  <SHORT-NAME>sy_medium_temperature</SHORT-NAME>
                  <CATEGORY>scaling</CATEGORY>
                  <SW-VALUES-PHYS>
                     <V>20</V>
                  </SW-VALUES-PHYS>
                  <DESC>This systemconstant describes the medium athmosphere temperature which is expected in the target market continent. It is used for clima control purposed only </DESC>
               </SW-SYSTEMCONST>
            </SW-SYSTEMCONSTS>
            <SW-COMPU-METHODS>
               <SW-COMPU-METHOD>
                  <SHORT-NAME>TEMP</SHORT-NAME>
                  <SW-UNIT-REF>degC</SW-UNIT-REF>
                  <SW-COMPU-PHYS-TO-INTERNAL>
                     <SW-COMPU-SCALES>
                        <SW-COMPU-SCALE>
                           <LOWER-LIMIT>-30</LOWER-LIMIT>
                           <UPPER-LIMIT>130</UPPER-LIMIT>
                           <SW-COMPU-RATIONAL-COEFFS>
                              <SW-COMPU-NUMERATOR>
                                 <V>60</V>
                                 <V>2</V>
                              </SW-COMPU-NUMERATOR>
                              <SW-COMPU-DENOMINATOR>
                                 <V>1</V>
                              </SW-COMPU-DENOMINATOR>
                           </SW-COMPU-RATIONAL-COEFFS>
                        </SW-COMPU-SCALE>
                     </SW-COMPU-SCALES>
                  </SW-COMPU-PHYS-TO-INTERNAL>
               </SW-COMPU-METHOD>
            </SW-COMPU-METHODS>
         </SW-DATA-DICTIONARY-SPEC>
         <SW-INSTANCE-SPEC>
            <SW-INSTANCE-TREE>
               <SHORT-NAME>sampledata</SHORT-NAME>
               <SW-INSTANCE>
                  <SHORT-NAME>ClimaLimit</SHORT-NAME>
                  <SW-INSTANCE-PROPS-VARIANTS>
                     <SW-INSTANCE-PROPS-VARIANT>
                        <SW-AXIS-CONTS>
                           <SW-AXIS-CONT>
                              <SW-VALUES-PHYS>
                                 <VF>
                                    <SW-SYSTEMCONST-PHYS-REF>sy_medium_temperature</SW-SYSTEMCONST-PHYS-REF> + 10</VF>
                              </SW-VALUES-PHYS>
                              <SW-VALUES-CODED>
                                 <VF>
                                    <SW-SYSTEMCONST-CODED-REF>sy_medium_temperature</SW-SYSTEMCONST-CODED-REF> + 80</VF>
                              </SW-VALUES-CODED>
                           </SW-AXIS-CONT>
                        </SW-AXIS-CONTS>
                     </SW-INSTANCE-PROPS-VARIANT>
                  </SW-INSTANCE-PROPS-VARIANTS>
               </SW-INSTANCE>
            </SW-INSTANCE-TREE>
         </SW-INSTANCE-SPEC>
      </SW-SYSTEM>
   </SW-SYSTEMS>
</MSRSW>
Formale Beschreibung
Hat als Kontext: | SW-SYSTEMCONSTS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-VALUES-PHYS, SW-VALUES-CODED, SW-DATA-DEF-PROPS
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-SYSTEMCONST | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.503. SW-SYSTEMCONST-CODED-REF

Beschreibung
Dieses Element referenziert <SW-SYSTEMCONST>, wobei es sich bei <SW-SYSTEMCONST> um eine interne Systemkonstante handelt.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-GENERIC-MATH, SW-DATA-DEPENDENCY-ARGS, SW-MAX-AXIS-POINTS, SW-MIN-AXIS-POINTS, SW-NUMBER-OF-AXIS-POINTS, SW-SYSCOND, VF
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-SYSTEMCONST | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.504. SW-SYSTEMCONST-PHYS-REF

Beschreibung
Dieses Element referenziert <SW-SYSTEMCONST>, wobei es sich bei <SW-SYSTEMCONST> um eine physikalische Systemkonstante handelt.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-GENERIC-MATH, SW-MAX-AXIS-POINTS, SW-MIN-AXIS-POINTS, SW-NUMBER-OF-AXIS-POINTS, SW-SYSCOND, VF
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-SYSTEMCONST | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.505. SW-SYSTEMCONST-REF

Beschreibung
Dieses Element referenziert <SW-SYSTEMCONST>.
Formale Beschreibung
Hat als Kontext: | SW-SYSTEMCONST-REFS
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-SYSTEMCONST | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.506. SW-SYSTEMCONST-REFS

Beschreibung
Container Element für <SW-SYSTEMCONST-REF>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-CONT, SW-FEATURE
Ist Kontext für: | SW-SYSTEMCONST-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.507. SW-SYSTEMCONSTS

Beschreibung
Container Element für <SW-SYSTEMCONST>.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DICTIONARY-SPEC
Ist Kontext für: | SW-SYSTEMCONST
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.508. SW-SYSTEMS
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Container Element für <SW-SYSTEM>. Der Hauptinhalt einer MSRSW-Instanz steht unterhalb von SW-SYSTEM. Dies ermöglicht es, mehrere ECU-Systeme zu unterstützen, als auch ein System mit mehreren CPUs.
Example
<SW-SYSTEMS>
   <SW-SYSTEM>
      <SHORT-NAME>DEMO</SHORT-NAME>
      <SW-INSTANCE-SPEC>
         <INTRODUCTION>
            <P>This is the system to demonstrate, how CDF should work.</P>
         </INTRODUCTION>
         <SW-INSTANCE-TREE>
            <SHORT-NAME>Summertest</SHORT-NAME>
            <SW-INSTANCE>
               <LONG-NAME>faule Bären aus München (Viktualienmarkt)</LONG-NAME>
               <SHORT-NAME>FBAM_V</SHORT-NAME> ... </SW-INSTANCE>
         </SW-INSTANCE-TREE>
      </SW-INSTANCE-SPEC>
   </SW-SYSTEM>
</SW-SYSTEMS>
Formale Beschreibung
Hat als Kontext: | MSRSW
Ist Kontext für: | SW-SYSTEM
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.509. SW-TASK

Beschreibung
Dieses Element beschreibt eine spezifische Task. Weitere Einzelheiten siehe SW-TASK-SPEC.
Formale Beschreibung
Hat als Kontext: | SW-TASKS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-REFRESH-TIMING
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-TASK | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.510. SW-TASK-REF

Beschreibung
Dieses Element referenziert <SW-TASK>.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS, SW-PROCESS
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-TASK | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.511. SW-TASK-SPEC

Beschreibung
Dieses Element beschreibt die Task-Aufteilung im Steuergerät, die durch das Betriebssystem im Steuergerät bereitgestellt wird. Dabei sind die Tasks hinsichtlich ihres Zeitverhaltens spezifiziert. Das generelle Modell ist:
  • Das Betriebssystem führt eine Menge von Tasks aus, z.B. eine winkelsynchrone Task (synchron zum aktuellen Kurbelwellenwinkel) und/oder mehrere zeitsynchrone Tasks.
  • Die einzelnen Features etablieren Prozesse, welche in einer bestimmten Reihenfolge innerhalb der jeweiligen Task ablaufen sollen.
Dieses Modell wird unterstützt durch:
  • Definition der Tasks innerhalb <SW-TASK-SPEC>, global einmal pro System in <SW-ARCHITECTURE>
  • Definition der Prozesse innerhalb von <SW-FEATURE-DECOMPOSITION>. Dabei werden auch die Zuordnungen der Prozesse auf die Tasks vorgenommen.
Formale Beschreibung
Hat als Kontext: | SW-ARCHITECTURE
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-TASKS, ADD-INFO
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.512. SW-TASKS

Beschreibung
Container Element für <SW-TASK>.
Formale Beschreibung
Hat als Kontext: | SW-TASK-SPEC
Ist Kontext für: | SW-TASK
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.513. SW-TEMPLATE

Beschreibung
Dieses Element erlaubt die Vorwegdefinition von <SW-DATA-DEF-PROPS>, um diese bei <SW-VARIABLE> bzw. <SW-CALPRM> wieder einsetzen zu können. Templates dienen konzeptionell nur zur Schreibvereinfachung. Es ist nicht beabsichtigt, daß Templates ihren Niederschlag im Steuergerät finden.
Falls z.B. eine Variable auf ein Template referenziert und selbst Eigenschaften in <SW-DATA-DEF-PROPS> definiert, überschreiben diese die "geerbten" Template-Eigenschaften.
Formale Beschreibung
Hat als Kontext: | SW-TEMPLATES
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-DATA-DEF-PROPS
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-TEMPLATE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.514. SW-TEMPLATE-REF

Beschreibung
Dieses Element referenziert <SW-TEMPLATE>.
Formale Beschreibung
Hat als Kontext: | SW-CALPRM-POINTER, SW-DATA-DEF-PROPS
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-TEMPLATE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.515. SW-TEMPLATES

Beschreibung
Container Element für <SW-TEMPLATE>.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DICTIONARY-SPEC
Ist Kontext für: | SW-TEMPLATE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.516. SW-TEST-DESC

Beschreibung
Dieses Element beschreibt auf textuelle Art die Testumfänge des aktuellen Kontextes.
Formale Beschreibung
Hat als Kontext: | SW-CLASS, SW-FEATURE
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.517. SW-TEST-SPEC

Beschreibung
Dieses Element definiert textuell die Testspezifikation eines SW-Systems <SW-SYSTEM>.
Formale Beschreibung
Hat als Kontext: | SW-SYSTEM
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.518. SW-UNIT

Beschreibung
Beschreibt eine Maßeinheit. Hierbei kann es sich sowohl um eine <SI-UNIT> handeln, als auch um eine Maßeinheit, die andere <SI-UNIT> über <SW-UNIT-REF> referenziert und mittels <SW-UNIT-CONVERSION-METHOD> in die referenzierte <SI-UNIT> umrechnet.
Formale Beschreibung
Hat als Kontext: | SW-UNITS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-UNIT-DISPLAY, SW-UNIT-CONVERSION-METHOD, SI-UNIT, SW-UNIT-REF, ADD-INFO
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-UNIT | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.519. SW-UNIT-CONVERSION-METHOD

Beschreibung
Beschreibt die lineare Umrechnungsformel von einer <SW-UNIT> in eine andere <SW-UNIT>, welche im Elternelement von <SW-UNIT-CONVERSION-METHOD> durch deren Subelement <SW-UNIT-REF> angegeben wird. Beispiel siehe SI-UNIT.
Formale Beschreibung
Hat als Kontext: | SW-UNIT
Ist Kontext für: | SW-UNIT-GRADIENT, SW-UNIT-OFFSET
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.520. SW-UNIT-DISPLAY

Beschreibung
Beschreibt die textuelle Darstellung für eine Maßeinheit, die im Elternelement <SW-UNIT> spezifizert wird.
Formale Beschreibung
Hat als Kontext: | SW-UNIT
Ist Kontext für: | Text, SUP, SUB
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.521. SW-UNIT-GRADIENT

Beschreibung
Beschreibt den Gradienten (die Steigung) in der linearen Umrechnungsformel einer <SW-UNIT-CONVERSION-METHOD>.
Formale Beschreibung
Hat als Kontext: | SW-UNIT-CONVERSION-METHOD
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.522. SW-UNIT-OFFSET

Beschreibung
Beschreibt den Y-Achsenabschnitt in der linearen Umrechnungsformel einer <SW-UNIT-CONVERSION-METHOD>.
Formale Beschreibung
Hat als Kontext: | SW-UNIT-CONVERSION-METHOD
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.523. SW-UNIT-REF
Siehe Auch Description Example Formale Beschreibung

Description
<SW-UNIT-REF> is a formal reference to a measurement unit. Since CDF did not request this, the reference is treated as a measurement unit designator.
Achtung
The content of <SW-UNIT-REF> must follow the restrictions of <SHORT-NAME>, in particular must not contain whitespace and special characters.
Example
For an example, see SW-ARRAY-INDEX 1.407. SW-INSTANCE SW-INSTANCE SW-INSTANCE.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-CONT, SW-AXIS-INDIVIDUAL, SW-COMPU-METHOD, SW-DATA-DEF-PROPS, SW-PHYS-CONSTRS, SW-UNIT, SW-UNIT-REFS, SW-VARIABLE-PROTOTYPE
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-UNIT | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.524. SW-UNIT-REFS

Beschreibung
Container Element für <SW-UNIT-REF>.
Formale Beschreibung
Hat als Kontext: | SW-COLLECTION-CONT
Ist Kontext für: | SW-UNIT-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.525. SW-UNITS

Beschreibung
Container Element für <SW-UNIT>.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DICTIONARY-SPEC
Ist Kontext für: | ADMIN-DATA, SW-UNIT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.526. SW-USER-ACCESS-CASE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt eine Zugriffsoperation (wie z.B. Lesezugriff) , welche in der Zugriffsrechtetabelle (in <SW-ACCESS-DEFINITIONS>) referenziert wird.
Example
Siehe SW-ACCESS-DEF.
Formale Beschreibung
Hat als Kontext: | SW-USER-ACCESS-CASES
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-USER-ACCESS-CASE-REFS
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | Zeichenkette (CDATA) | SW-USER-ACCESS-CASE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.527. SW-USER-ACCESS-CASE-REF

Beschreibung
Dieses Element referenziert <SW-USER-ACCESS-CASE>.
Formale Beschreibung
Hat als Kontext: | SW-ACCESS-DEF, SW-USER-ACCESS-CASE-REFS
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-USER-ACCESS-CASE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.528. SW-USER-ACCESS-CASE-REFS

Beschreibung
Container Element für <SW-USER-ACCESS-CASE-REF>.
Formale Beschreibung
Hat als Kontext: | SW-USER-ACCESS-CASE
Ist Kontext für: | SW-USER-ACCESS-CASE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.529. SW-USER-ACCESS-CASES

Beschreibung
Container Element für <SW-USER-ACCESS-CASE>.
Formale Beschreibung
Hat als Kontext: | SW-USER-RIGHT-SPEC
Ist Kontext für: | SW-USER-ACCESS-CASE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.530. SW-USER-ACCESS-DEFINTIONS

Beschreibung
Container Element für <SW-ACCESS-DEF>.
Formale Beschreibung
Hat als Kontext: | SW-USER-RIGHT-SPEC
Ist Kontext für: | SW-ACCESS-DEF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.531. SW-USER-GROUP
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element spezifiziert eine Benutzergruppe, welche in der Zugriffsrechtetabelle (<SW-ACCESS-DEFINITIONS>) referenziert werden kann. Eine <SW-USER-GROUP> besteht aus Systembenutzern <SYSTEM-USER>s. Eine <SW-USER-GROUP> kann wiederum andere Benutzergruppen (durch <SW-USER-GRUOP-REFS>), als auch <TEAM-MEMBER-REFS> referenzieren.
Example
Siehe SW-ACCESS-DEF.
Formale Beschreibung
Hat als Kontext: | SW-USER-GROUPS
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, TEAM-MEMBER-REFS, SYSTEM-USERS, SW-USER-GROUP-REFS
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | Zeichenkette (CDATA) | SW-USER-GROUP | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.532. SW-USER-GROUP-REF

Beschreibung
Dieses Element referenziert <SW-USER-GROUP>.
Formale Beschreibung
Hat als Kontext: | SW-ACCESS-DEF, SW-USER-GROUP-REFS
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-USER-GROUP | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.533. SW-USER-GROUP-REFS

Beschreibung
Container Element für <SW-USER-GROUP-REF>.
Formale Beschreibung
Hat als Kontext: | SW-USER-GROUP
Ist Kontext für: | SW-USER-GROUP-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.534. SW-USER-GROUPS

Beschreibung
Container Element für <SW-USER-GROUP>.
Formale Beschreibung
Hat als Kontext: | SW-USER-RIGHT-SPEC
Ist Kontext für: | SW-USER-GROUP
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.535. SW-USER-RIGHT-SPEC
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element spezifiziert die Benutzergruppen (<SW-USER-GROUPS>), die Zugriffsoperationen (<SW-USER-ACCESS-CASES>) sowie die eigentliche Zugriffstabelle (<SW-ACCESS-DEFINITIONS>). Somit wird in diesem Element angegeben,
  • Wer überhaupt für einen Zugriff in Frage kommt
  • Welche Zugriffsarten vorliegen
  • Wer welche Art von Zugriff hat
Example
siehe SW-ACCESS-DEF
Formale Beschreibung
Hat als Kontext: | SW-SYSTEM
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-USER-GROUPS, SW-USER-ACCESS-CASES, SW-USER-ACCESS-DEFINTIONS, ADD-INFO
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.536. SW-VALUES-CODED

Beschreibung
Beschreibt interne Werte.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-CONT, SW-AXIS-GENERIC, SW-SYSTEMCONST
Ist Kontext für: | VF, VT, V, VG, SW-INSTANCE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.537. SW-VALUES-CODED-HEX

Beschreibung
Beschreibt interne Werte.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-CONT
Ist Kontext für: | VF, VT, V, VG, SW-INSTANCE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.538. SW-VALUES-GENERIC
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element enthält Achsenwerte in einem beliebigen Format, welches über das Attribut [TYPE] spezifiziert wird. Der Wert des Attributes ist mit den Prozeßpartnern zu vereinbaren.
Example
<SW-VALUES-GENERIC TYPE="octal">
   <VF>001</VF>
   <VF>003</VF>
   <VF>007</VF>
   <VF>013</VF>
   <VF>015</VF>
</SW-VALUES-GENERIC>
Formale Beschreibung
Hat als Kontext: | SW-AXIS-CONT
Ist Kontext für: | VF, VT, V, VG, SW-INSTANCE-REF
Name | Typ | Anmerkung
[TYPE] obligatorisch | SGML Zeichenkette (NMTOKEN) | Format, in dem die Achsenwerte angegeben werden.
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.539. SW-VALUES-PHYS
Siehe Auch Description Example Formale Beschreibung

Description
<SW-VALUES-PHYS> receives the physical values of the calibration item. The values can either be numeric (<V>) or textual (<VT>) but not mixed.
Example
For an example, see SW-ARRAY-INDEX 1.407. SW-INSTANCE SW-INSTANCE SW-INSTANCE.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-CONT, SW-AXIS-GENERIC, SW-SYSTEMCONST
Ist Kontext für: | VF, VT, V, VG, SW-INSTANCE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.540. SW-VAR-INIT-VALUE

Beschreibung
Beschreibt Initialwert(e) der aktuellen Variable oder des aktuellen Parameters.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.541. SW-VAR-NOT-AVL-VALUE

Beschreibung
Der interne Wert für "Variable nicht verfügbar" wird in diesem Element <SW-VAR-NOT-AVL-VALUE> (Software Variable Not Available Value) eingetragen. Dies ist der Wert, den die Variable annimmt, wenn der zugehörige externe Wert nicht verfügbar ist (sei es daß er noch nicht erfaßt ist, oder aber ein Fehler vorliegt). Einen externen Wert für nicht verfügbar kann es nicht geben, da er ja nicht verfügbar ist.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.542. SW-VARIABLE

Beschreibung
Dieses Element spezifiziert die Eigenschaften von Variablen (Meßgrößen) im Steuergerät. Variablen sind Objekte die zur Laufzeit des Fahrzeugs verändert werden können. Im Gegensatz dazu sind Kalibrierparameter (<SW-CALPRM>s) Objekte, die zur Laufzeit von der Software nicht manipuliert werden.
Variablen bestehen im wesentlichen aus:
  • Lang- und Kurzbezeichner (<LONG-NAME>, <SHORT-NAME>)
  • Kurzbeschreibung (<DESC>)
  • Kategorie (<CATEGORY>), welche die Grundstruktur der Variablen beschreibt
  • Feldgrößen (<SW-ARRAYSIZE>), falls die Variable als Array ausgeführt ist
  • die technischen Eigenschaften (<SW-DATA-DEF-PROPS>)
  • Unterstrukturen, die durch Verschachtelung von <SW-VARIABLES> modelliert werden.
  • Anmerkungen (<ANNOTATIONS>), die es erlauben, Notizen im Entwicklungsprozeß von Schritt zu Schritt weiterzureichen
  • Zusatzinformationen (<ADD-INFO>) in verbaler Form. Dabei können unter Verwendung von [SI]-Attributen auch formale Anteile untergebracht werden.
Formale Beschreibung
Hat als Kontext: | SW-VARIABLES
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-ARRAYSIZE, SW-DATA-DEF-PROPS, SW-VARIABLES, ANNOTATIONS, ADD-INFO
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[ID]
obligatorisch
Identifikator (ID)
Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[CALIBRATION]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • CALIBRATION
  • NO-CALIBRATION
  • NOT-IN-MC-SYSTEM
CALIBRATION: die aktulle Variable ist applizierbarNO-CALIBRATION: die aktuelle Variable ist nicht applizierbarNOT-IN-MC-SYSTEM: die aktuelle Variable ist nicht im Verstellsystem verfügbar
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS]
festgelegter Wert
SGML Zeichenkette (NMTOKEN)
SW-VARIABLE
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE]
festgelegter Wert
SGML Zeichenketten (NMTOKENS)
SW-VARIABLE
Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')

Diese sind identisch mit den technischen Eigenschaften von Parametern


1.543. SW-VARIABLE-IMPL

Beschreibung
Dieses Element beschreibt die Implementierungsdetails eines Klassenattributes, welches sich als Variable manifestiert.
Formale Beschreibung
Hat als Kontext: | SW-VARIABLE-IMPLS
Ist Kontext für: | SW-VARIABLE-PROTOTYPE-REF, SW-DATA-DEF-PROPS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.544. SW-VARIABLE-IMPLS

Beschreibung
Container Element für <SW-VARIABLE-IMPL>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS-ATTR-IMPL
Ist Kontext für: | SW-VARIABLE-IMPL
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.545. SW-VARIABLE-KIND
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt die Verwendung einer Variablen im organisatorischen Sinne.
Example
<SW-VARIABLE-KIND>Control Flow</SW-VARIABLE-KIND>
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.546. SW-VARIABLE-PROTOTYPE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt die Prototyp-Deklaration eines Klassenattributes, welcher als Variable auftritt.
Example
Siehe SW-CLASS
Formale Beschreibung
Hat als Kontext: | SW-VARIABLE-PROTOTYPES
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-ARRAYSIZE, SW-UNIT-REF, SW-SYSCOND, ANNOTATIONS, ADD-INFO
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | Zeichenkette (CDATA) | SW-VARIABLE-PROTOTYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.547. SW-VARIABLE-PROTOTYPE-REF

Beschreibung
Dieses Element referenziert <SW-VARIABLE-PROTOTYPE>.
Formale Beschreibung
Hat als Kontext: | SW-VARIABLE-IMPL
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-VARIABLE-PROTOTYPE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.548. SW-VARIABLE-PROTOTYPES

Beschreibung
Container Element für <SW-VARIABLE-PROTOTYPE>.
Formale Beschreibung
Hat als Kontext: | SW-CLASS-ATTR
Ist Kontext für: | SW-VARIABLE-PROTOTYPE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.549. SW-VARIABLE-REF

Beschreibung
Dieses Element referenziert <SW-VARIABLE>.
Formale Beschreibung
Hat als Kontext: | SW-CALPRM-TARGET, SW-COMPARISON-VARIABLES, SW-CONSTR-OBJECTS, SW-DATA-DEPENDENCY-ARGS, SW-EFFECT-FLOW, SW-EFFECTING-VARIABLE, SW-FEATURE-MODEL-ONLY-VARIABLES, SW-HOST-VARIABLE, SW-VARIABLE-REF-SYSCOND, SW-VARIABLE-REFS, SW-VARIABLES-READ, SW-VARIABLES-READ-WRITE, SW-VARIABLES-WRITE, SW-VCD-CRITERION
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-VARIABLE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.550. SW-VARIABLE-REF-SYSCOND

Beschreibung
Dieses Element ist eine bedingte Referenz auf eine Variable. Dieses wird verwendet, um die Zuordnung von Variablen zu Funktionen abhängig zu machen von Systemkonstanten-Einstellungen. Deshalb existiert das Element parallel zu <SW-VARIABLE-REF>.
Formale Beschreibung
Hat als Kontext: | SW-VARIABLES-READ, SW-VARIABLES-READ-WRITE, SW-VARIABLES-WRITE
Ist Kontext für: | SW-VARIABLE-REF, SW-SYSCOND
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.551. SW-VARIABLE-REFS

Beschreibung
Container Element für <SW-VARIABLE-REF>.
Formale Beschreibung
Hat als Kontext: | SW-AXIS-INDIVIDUAL, SW-COLLECTION-CONT, SW-MC-FRAME
Ist Kontext für: | SW-VARIABLE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.552. SW-VARIABLES

Beschreibung
Container Element für <SW-VARIABLE>.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DICTIONARY-SPEC, SW-VARIABLE
Ist Kontext für: | ADMIN-DATA, SW-VARIABLE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.553. SW-VARIABLES-READ

Beschreibung
Dieses Element spezifiziert Variablen, welche im Nur-Lesezugriff sind.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-DESIGN-DATA, SW-FEATURE-EXPORT-VARIABLES, SW-FEATURE-IMPORT-VARIABLES
Ist Kontext für: | SW-VARIABLE-REF, SW-VARIABLE-REF-SYSCOND
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.554. SW-VARIABLES-READ-WRITE

Beschreibung
Dieses Element spezifiziert Variablen welche im Schreib-Lesezugriff sind.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-DESIGN-DATA, SW-FEATURE-EXPORT-VARIABLES, SW-FEATURE-IMPORT-VARIABLES, SW-FEATURE-LOCAL-VARIABLES
Ist Kontext für: | SW-VARIABLE-REF, SW-VARIABLE-REF-SYSCOND
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.555. SW-VARIABLES-WRITE

Beschreibung
Dieses Element spezifiziert Variablen, welche im Nur-Lesezugriff sind.
Formale Beschreibung
Hat als Kontext: | SW-FEATURE-DESIGN-DATA, SW-FEATURE-EXPORT-VARIABLES, SW-FEATURE-IMPORT-VARIABLES
Ist Kontext für: | SW-VARIABLE-REF, SW-VARIABLE-REF-SYSCOND
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.556. SW-VCD-CRITERIA

Beschreibung
Container Element für <SW-VCD-CRITERION>.
Formale Beschreibung
Hat als Kontext: | SW-VCD-SPEC
Ist Kontext für: | SW-VCD-CRITERION
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.557. SW-VCD-CRITERION

Beschreibung
Das Variantenkriterium beschreibt, wie die variantenkodierten Parameter umgeschaltet werden. Der Wert X über SW-VARIABLE-REF referenzierten Variable wählt den Kriterienwert aus; ist dieser Wert X gleich 0, wird der erste Kriterienwert verwendet, ist er 1, so wird der zweite verwendet.
Formale Beschreibung
Hat als Kontext: | SW-VCD-CRITERIA
Ist Kontext für: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, SW-CALPRM-REF, SW-VARIABLE-REF, SW-VCD-CRITERION-POSSIBLE-VALUES, SW-COMPU-METHOD-REF
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | Zeichenkette (CDATA) | SW-VCD-CRITERION | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.558. SW-VCD-CRITERION-POSSIBLE-VALUES
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Mögliche Werte für Varantenkodierung.
Example
<SW-VCD-CRITERION>
   <SHORT-NAME>GETRIEBE</SHORT-NAME>
   <SW-VCD-POSSIBLE-VALUES>
      <VT>HAND</VT>
      <VT>AUTOMATIK</VT>
   </SW-VCD-POSSIBLE-VALUES>
</SW-VCD-CRITERION>
<SW-VCD-CRITERION>
   <SHORT-NAME>KAROSSERIE</SHORT-NAME>
   <SW-VCD-POSSIBLE-VALUES>
      <VT>CABRIO</VT>
      <VT>KOMBI</VT>
      <VT>LIMOUSINE</VT>
   </SW-VCD-POSSIBLE-VALUES>
</SW-VCD-CRITERION>
Formale Beschreibung
Hat als Kontext: | SW-VCD-CRITERION
Ist Kontext für: | VT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.559. SW-VCD-CRITERION-REF

Beschreibung
Verweist auf Variantenkriterium <SW-VCD-CRITERION> des Parameters, welches in der <SW-VCD-SPEC> spezifiziert ist. Dies ist somit das aktuell für einen Parameter eingestellte Variantenkriterium.
Formale Beschreibung
Hat als Kontext: | SW-VCD-CRITERION-REFS, SW-VCD-CRITERION-VALUE
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | SW-VCD-CRITERION | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.560. SW-VCD-CRITERION-REFS

Beschreibung
Container Element für <SW-VCD-CRITERION-REF>.
Formale Beschreibung
Hat als Kontext: | SW-DATA-DEF-PROPS
Ist Kontext für: | SW-VCD-CRITERION-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.561. SW-VCD-CRITERION-VALUE

Beschreibung
Definiert die Werte für Variantenkriterien. Die insgesamt hierfür möglichen Werte (siehe SW-VCD-CRITERION-POSSIBLE-VALUES) stehen in <SW-VCD-CRITERION-POSSIBLE-VALUES>. Die instanziierten Kombinationen im Instance-Tree, für die die Variantenkriterien aktuell gelten, werden durch Kombination der unter <SW-VCD-CRITERION-REFS> und <SW-VCD-CRITERION-VALUES>, welche beide im Unterbaum von <SW-INSTANCE-PROPS-VARIANT> stehen, gebildet.
Formale Beschreibung
Hat als Kontext: | SW-VCD-CRITERION-VALUES
Ist Kontext für: | SW-VCD-CRITERION-REF, VT
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.562. SW-VCD-CRITERION-VALUES

Beschreibung
Container Element für <SW-VCD-CRITERION-VALUE>.
Formale Beschreibung
Hat als Kontext: | SW-INSTANCE-PROPS-VARIANT, SW-INSTANCE-TREE
Ist Kontext für: | SW-VCD-CRITERION-VALUE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.563. SW-VCD-SPEC

Beschreibung
Das Vorhandensein dieses Objektes legt fest, daß Varientenkodierung eingesetzt ist. Außerdem werden bei diesem Objekt alle Informationen abgelegt, die für die ganze Varientenkodierung relevant sind.
Formale Beschreibung
Hat als Kontext: | SW-SYSTEM
Ist Kontext für: | NA, TBD, TBR, ADMIN-DATA, INTRODUCTION, SW-VCD-CRITERIA, ADD-INFO
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.564. SYSTEM-OVERVIEW

Beschreibung
Verwenden Sie <SYSTEM-OVERVIEW>, um die Systemübersicht einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PROJECT-DATA
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.565. SYSTEM-USER
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element spezifiziert einen Systembenutzer, der im Betriebssystem des MCD-Systems angemeldet ist.
Example
Siehe SW-ACCESS-DEF
Formale Beschreibung
Hat als Kontext: | SYSTEM-USERS
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.566. SYSTEM-USERS

Beschreibung
Container Element für <SYSTEM-USER>.
Formale Beschreibung
Hat als Kontext: | SW-USER-GROUP
Ist Kontext für: | SYSTEM-USER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.567. TABLE

Beschreibung
Verwenden Sie <TABLE>, um eine Tabelle zu erstellen.
Formale Beschreibung
Hat als Kontext: | ADD-INFO, CHAPTER, CRITICAL-ASPECTS, FREE-INFO, INTRODUCTION, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Ist Kontext für: | TABLE-CAPTION, TGROUP
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[TOCENTRY]
mit Default-Wert
SGML Zeichenkette (NMTOKEN)
1
0 - kein Eintrag der Tabellenbeschriftung <LONG-NAME> ins Tabellenverzeichnis1 - Eintrag der Tabellenbeschriftung <LONG-NAME> ins Tabellenverzeichnis
[TABSTYLE]
optional
SGML Zeichenkette (NMTOKEN)
Identifikation eines externen Tabellen-Styles
[SHORTENTRY]
optional
SGML Zeichenkette (NMTOKEN)
0 - Kurzbezeichnung <SHORT-NAME> wird nicht in das Tabellenverzeichnis übernommen1 - Kurzbezeichnung <SHORT-NAME> wird in das Tabellenverzeichnis übernommen
[FRAME]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • TOP
  • BOTTOM
  • TOPBOT
  • ALL
  • SIDES
  • NONE
TOP - Begrenzungslinie am oberen Rand der TabelleBOTTOM - Begrenzungslinie am unteren Rand der TabelleTOPBOT - Begrenzungslinien am oberen und unteren Rand der TabelleALL - Begrenzungslinien am gesamten Rand der TabelleSIDES - Begrenzungslinien an den Seitenrändern der TabelleNONE - keine Begrenzungslinien der Tabelle
[COLSEP]
optional
SGML Zeichenkette (NMTOKEN)
Legen Sie an dieser Stelle fest, ob für die Zelle Spaltenlinien angezeigt werden sollen.Geben Sie 0 ein, wenn keine Spaltenlinien angezeigt werden sollen.Geben Sie 1 ein, wenn Spaltenlinien angezeigt werden sollen.
[ROWSEP]
optional
SGML Zeichenkette (NMTOKEN)
Legen Sie an dieser Stelle fest, ob für die Zelle Reihenlinien angezeigt werden sollen.Geben Sie 0 ein, wenn keine Reihenlinien angezeigt werden sollenGeben Sie 1 ein, wenn Reihenlinien angezeigt werden sollen.
[ORIENT]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • PORT
  • LAND
PORT - Tabelleninhalt ist parallel zu den AbsatzelementenLAND - Tabelleninhalt ist um 90o gedreht zu den Absatzelementen
[PGWIDE]
optional
SGML Zeichenkette (NMTOKEN)
0 - Tabellenbreite ergibt die Summe der festgelegten Spaltenbreiten1 - Tabellenbreite entspricht der Seitenbreite
[HELP-ENTRY]
optional
Zeichenkette (CDATA)
Erlaubt es, das Vaterelement als ein Hilfe-Einstiegspunkt zu markieren. Die Syntax ergibt sich aus dem verwendeten Hilfesystem. Oft wird das dazu verwendet, aus einem Fenstersystem eine Objekt-Id bzw. eine Widget-Namenshierarchie zu errechnen, die dann mit den Help-Entry-Einträgen korreliert wird.Beispiel:
[FLOAT]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • FLOAT
  • NO-FLOAT
Erlaubt es, bei einer nicht umbrechbaren <TABLE> zu steuern ob die <TABLE> woanders hin verschoben werden kann um eine bessere Seitenausnutzung zu bekommen (vergleiche flat bei TeX).
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.568. TABLE-CAPTION

Beschreibung
Dieses Element spezifiziert die Überschrift für eine Tabelle.
Formale Beschreibung
Hat als Kontext: | TABLE
Ist Kontext für: | LONG-NAME, SHORT-NAME
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | TABLE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.569. TBD

Beschreibung
Verwenden Sie <TBD>, um den Hinweis Noch zu bearbeiten! einzugeben.
Formale Beschreibung
Hat als Kontext:
ACCEPTANCE-COND, ADD-DESIGN-DOC, ADD-SPEC, BINARY-COMPATIBILITY, CALIBRATION, COMMUNICATION, COMMUNICATION-INTERFACE, COMPATIBILITY, CONTRACT-ASPECTS, DATA-DESC, DATA-REQUIREMENTS, DATA-STRUCTURES, DEMARCATION-OTHER-PROJECTS, DESIGN-REQUIREMENTS, DEVELOPMENT-PROCESS-SPEC, DIAGNOSIS, DIR-HAND-OVER-DOC-DATA, EXTENSIBILITY, FAIL-SAVE-CONCEPT, FAILURE-MANAGEMENT, FAILURE-MEM, FLASH-PROGRAMMING, FMEA, FUNCTION-OVERVIEW, FUNCTIONAL-REQUIREMENTS, GENERAL-COND, GENERAL-HARDWARE, GENERAL-INTERFACES, GENERAL-PRODUCT-DATA-1, GENERAL-PROJECT-DATA, GENERAL-REQUIREMENTS, GENERAL-SOFTWARE, GUARANTEE, HARDWARE-INTERFACE, INTEGRATION-CAPABILITY, INTERNAL-INTERFACES, INTERRUPT-SPEC, KEY-DATA, MAINTENANCE, MONITORING, NORMATIVE-REFERENCE, OBJECTIVES, OPERATING-ENV, OPERATIONAL-REQUIREMENTS, OVERVIEW, PARALLEL-DESIGNS, PRODUCT-DEMARCATION, PRODUCT-DESC, PROJECT-SCHEDULE, PROTOCOLS, PURCHASING-COND, QUALITY, REASON-ORDER, RELIABILITY, REPLACEMENT-VALUES, REQUIREMENT-SPEC, RESOURCE-ALLOCATION, RESTRICTIONS-BY-HARDWARE, RIGHTS, SAFETY, SAMPLE-SPEC, SELF-DIAGNOSIS, SIMILAR-PRODUCTS, STANDARD-SW-MODULES, SW-ARCHITECTURE, SW-CALIBRATION-METHOD-SPEC, SW-COLLECTION-SPEC, SW-COMPONENT-SPEC, SW-CPU-SPEC, SW-DATA-DICTIONARY-SPEC, SW-GLOSSARY, SW-INSTANCE-SPEC, SW-MC-COMMUNICATION-SPEC, SW-SYSTEM, SW-TASK-SPEC, SW-TEST-SPEC, SW-USER-RIGHT-SPEC, SW-VCD-SPEC, SYSTEM-OVERVIEW, TIME-DEPENDENCY, USEFUL-LIFE, USER-INTERFACE, VARIANT-SPEC
Ist Kontext für:
TEAM-MEMBER-REFS, SCHEDULE, DESC

Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.570. TBODY

Beschreibung
Verwenden Sie <TBODY>, um alle Reihen einer Tabelle zu erstellen.
Formale Beschreibung
Hat als Kontext: | TGROUP
Ist Kontext für: | ROW
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[VALIGN]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • TOP
  • MIDDLE
  • BOTTOM
TOP - Der Tabelleninhalt wird am oberen Zellenrand ausgerichtet.BOTTOM - Der Tabelleninhalt wird am unteren Zellenrand ausgerichtet.MIDDLE - Der Tabelleninhalt wird vertikal zentriert ausgerichtet.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.571. TBR

Beschreibung
Verwenden Sie <TBR>, um die Noch aus anderem Dokument umzusetzen! einzugeben.
Formale Beschreibung
Hat als Kontext:
ACCEPTANCE-COND, ADD-DESIGN-DOC, ADD-SPEC, BINARY-COMPATIBILITY, CALIBRATION, COMMUNICATION, COMMUNICATION-INTERFACE, COMPATIBILITY, CONTRACT-ASPECTS, DATA-DESC, DATA-REQUIREMENTS, DATA-STRUCTURES, DEMARCATION-OTHER-PROJECTS, DESIGN-REQUIREMENTS, DEVELOPMENT-PROCESS-SPEC, DIAGNOSIS, DIR-HAND-OVER-DOC-DATA, EXTENSIBILITY, FAIL-SAVE-CONCEPT, FAILURE-MANAGEMENT, FAILURE-MEM, FLASH-PROGRAMMING, FMEA, FUNCTION-OVERVIEW, FUNCTIONAL-REQUIREMENTS, GENERAL-COND, GENERAL-HARDWARE, GENERAL-INTERFACES, GENERAL-PRODUCT-DATA-1, GENERAL-PROJECT-DATA, GENERAL-REQUIREMENTS, GENERAL-SOFTWARE, GUARANTEE, HARDWARE-INTERFACE, INTEGRATION-CAPABILITY, INTERNAL-INTERFACES, INTERRUPT-SPEC, KEY-DATA, MAINTENANCE, MONITORING, NORMATIVE-REFERENCE, OBJECTIVES, OPERATING-ENV, OPERATIONAL-REQUIREMENTS, OVERVIEW, PARALLEL-DESIGNS, PRODUCT-DEMARCATION, PRODUCT-DESC, PROJECT-SCHEDULE, PROTOCOLS, PURCHASING-COND, QUALITY, REASON-ORDER, RELIABILITY, REPLACEMENT-VALUES, REQUIREMENT-SPEC, RESOURCE-ALLOCATION, RESTRICTIONS-BY-HARDWARE, RIGHTS, SAFETY, SAMPLE-SPEC, SELF-DIAGNOSIS, SIMILAR-PRODUCTS, STANDARD-SW-MODULES, SW-ARCHITECTURE, SW-CALIBRATION-METHOD-SPEC, SW-COLLECTION-SPEC, SW-COMPONENT-SPEC, SW-CPU-SPEC, SW-DATA-DICTIONARY-SPEC, SW-GLOSSARY, SW-INSTANCE-SPEC, SW-MC-COMMUNICATION-SPEC, SW-SYSTEM, SW-TASK-SPEC, SW-TEST-SPEC, SW-USER-RIGHT-SPEC, SW-VCD-SPEC, SYSTEM-OVERVIEW, TIME-DEPENDENCY, USEFUL-LIFE, USER-INTERFACE, VARIANT-SPEC
Ist Kontext für:
Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, STD, XDOC, XFILE, MSR-QUERY-TEXT

Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.572. TEAM-MEMBER

Beschreibung
Verwenden Sie <TEAM-MEMBER>, um Daten zu einer projektbeteiligten Person der entsprechenden Unternehmen einzugeben.
Formale Beschreibung
Hat als Kontext: | TEAM-MEMBERS
Ist Kontext für: | LONG-NAME, SHORT-NAME, ROLES, DEPARTMENT, ADDRESS, ZIP, CITY, PHONE, FAX, EMAIL, HOMEPAGE
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | TEAM-MEMBER | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.573. TEAM-MEMBER-REF
Siehe Auch Description Example Formale Beschreibung

Description
<TEAM-MEMBER-REF> is the pointer to one particular team member. The content is the <SHORT-NAME> of the corresponding <TEAM-MEMBER>.
Example
For an example, see 1.7. ADMIN-DATA ADMIN-DATA ADMIN-DATA ADMIN-DATA.
Formale Beschreibung
Hat als Kontext: | COMPANY-DOC-INFO, DOC-REVISION, TEAM-MEMBER-REFS
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | TEAM-MEMBER | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.574. TEAM-MEMBER-REFS

Beschreibung
Verwenden Sie <TEAM-MEMBER-REFS>, um die Referenzen einzugeben.
Formale Beschreibung
Hat als Kontext: | SW-USER-GROUP, TBD
Ist Kontext für: | TEAM-MEMBER-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.575. TEAM-MEMBERS

Beschreibung
Verwenden Sie <TEAM-MEMBERS>, um Daten zu allen projektbeteiligten Personen der entsprechenden Unternehmen einzugeben.
Formale Beschreibung
Hat als Kontext: | COMPANY
Ist Kontext für: | TEAM-MEMBER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.576. TECHNICAL-ASPECTS

Beschreibung
Dieses Element beschreibt textuell die technischen Aspekte einer Anforderung <REQUIREMENT>.
Formale Beschreibung
Hat als Kontext: | REQUIREMENT
Ist Kontext für: | P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1, TOPIC-1, MSR-QUERY-TOPIC-1, CHAPTER, MSR-QUERY-CHAPTER
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.577. TEX-MATH

Beschreibung
Verwenden Sie <TEX-MATH>, um ein TeX-Formel einzufügen. Eine TeX-Formel kann von einem TeX- oder LaTeX-Prozessor verarbeitet werden.
Formale Beschreibung
Hat als Kontext: | FORMULA
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.578. TEXT

Beschreibung
Verwenden Sie <TEXT>, um beschreibenden Text in ein Tabellenfeld einer Parametertabelle einzugeben.
Formale Beschreibung
Hat als Kontext: | PRM-CHAR
Ist Kontext für: | Text, SUP, SUB
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.579. TFOOT

Beschreibung
Verwenden Sie <TFOOT>, um eine Fußzeile einer Tabelle zu erstellen.
Formale Beschreibung
Hat als Kontext: | TGROUP
Ist Kontext für: | COLSPEC, ROW
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[VALIGN]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • TOP
  • MIDDLE
  • BOTTOM
TOP - Der Tabelleninhalt wird am oberen Zellenrand ausgerichtet.BOTTOM - Der Tabelleninhalt wird am unteren Zellenrand ausgerichtet.MIDDLE - Der Tabelleninhalt wird vertikal zentriert ausgerichtet.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.580. TGROUP

Beschreibung
Verwenden Sie <TGROUP>, um eine Tabellengruppe innerhalb einer Tabelle zu erstellen.
Formale Beschreibung
Hat als Kontext: | TABLE
Ist Kontext für: | COLSPEC, SPANSPEC, THEAD, TFOOT, TBODY
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[COLS]
obligatorisch
SGML Zeichenkette (NMTOKEN)
Geben Sie die Anzahl der Spalten der Tabellengruppe ein.
[ALIGN]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • LEFT
  • RIGHT
  • CENTER
  • JUSTIFY
  • CHAR
LEFT - Der Tabelleninhalt wird linksbündig ausgerichtet.RIGHT - Der Tabelleninhalt wird rechtsbündig ausgerichtet.CENTER - Der Tabelleninhalt wird horizontal zentriert.JUSTIFY - Der Tabelleninhalt wird als Blocksatz dargestellt. Der Abstand zum linken und rechten Rand der Zelle ist gleich.CHAR - Die Ausrichtung des Tabelleninhalts wird über das Attribut [CHAR] festgelegt.
[CHAROFF]
mit Default-Wert
SGML Zeichenkette (NMTOKEN)
50
Wenn [ALIGN]="CHAR" ist, gibt dieser Wert die Prozentanzahl der aktuellen Spaltenbreite zum linken Rand des Ausrichtungszeichens im [CHAR]-Attribut an. Falls kein Ausrichtungszeichen im Element <ENTRY> vorhanden ist, wird horizontal rechts ausgerichtet.
[CHAR]
mit Default-Wert
Zeichenkette (CDATA)
Falls [ALIGN]="CHAR" ist, gibt dieser aus einem Zeichen bestehende Wert von [CHAR] das Ausrichtungszeichen, z.B. "," bzlw "." als Dezimalpunkttrennzeichen, an. Das Zeichen darf kein SDATA-Entity sein.
[TGROUPSTYLE]
optional
SGML Zeichenkette (NMTOKEN)
Identifikation eines externen Tabellengruppen-Styles
[COLSEP]
optional
SGML Zeichenkette (NMTOKEN)
Legen Sie an dieser Stelle fest, ob für die Zelle Spaltenlinien angezeigt werden sollen.Geben Sie 0 ein, wenn keine Spaltenlinien angezeigt werden sollen.Geben Sie 1 ein, wenn Spaltenlinien angezeigt werden sollen.
[ROWSEP]
optional
SGML Zeichenkette (NMTOKEN)
Legen Sie an dieser Stelle fest, ob für die Zelle Reihenlinien angezeigt werden sollen.Geben Sie 0 ein, wenn keine Reihenlinien angezeigt werden sollenGeben Sie 1 ein, wenn Reihenlinien angezeigt werden sollen.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.581. THEAD

Beschreibung
Verwenden Sie <THEAD>, um eine Kopfzeile einer Tabelle zu erstellen.
Formale Beschreibung
Hat als Kontext: | TGROUP
Ist Kontext für: | COLSPEC, ROW
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[VALIGN]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • TOP
  • MIDDLE
  • BOTTOM
TOP - Der Tabelleninhalt wird am oberen Zellenrand ausgerichtet.BOTTOM - Der Tabelleninhalt wird am unteren Zellenrand ausgerichtet.MIDDLE - Der Tabelleninhalt wird vertikal zentriert ausgerichtet.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.582. TIME-DEPENDENCY

Beschreibung
Dieses Element beschreibt in verbaler Weise zeitliche Abhängigkeiten innerhalb des Software-Systems, die auf Architekturniveau definiert werden können.
Formale Beschreibung
Hat als Kontext: | SW-ARCHITECTURE
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.583. TOL

Beschreibung
Verwenden Sie <TOL>, um die Toleranzwerte eines Parameters einzugeben.
Formale Beschreibung
Hat als Kontext: | PRM-CHAR
Ist Kontext für: | Text, SUP, SUB
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.584. TOOL

Beschreibung
Dieses Element beschreibt, mit welchem Tool das korrespondierernde <XFILE> erstellt wurde.
Formale Beschreibung
Hat als Kontext: | XFILE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.585. TOOL-VERSION
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element beschreibt, mit welcher Tool-Version das korrespondierernde <XFILE> erstellt wurde.
Example
<XFILE ID="DC17723163279664">
   <LONG-NAME-1>Praesentation</LONG-NAME-1>
   <NOTATION>PowerPoint</NOTATION>
   <TOOL>Microsoft PowerPoint</TOOL>
   <TOOL-VERSION>2000</TOOL-VERSION>
</XFILE>
Formale Beschreibung
Hat als Kontext: | XFILE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.586. TOPIC-1

Beschreibung
Verwenden Sie <TOPIC-1>, um eine abgeschlossene Sinneinheit innerhalb einer Dokumentation zu erstellen.
Formale Beschreibung
Hat als Kontext: | ADD-INFO, CHAPTER, CRITICAL-ASPECTS, FREE-INFO, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-TOPIC-1, NCOI-1, REALTIME-REQUIREMENTS, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS
Ist Kontext für: | LONG-NAME, SHORT-NAME, P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, PRMS, MSR-QUERY-P-1
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[ID]
obligatorisch
Identifikator (ID)
Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[HELP-ENTRY]
optional
Zeichenkette (CDATA)
Erlaubt es, das Vaterelement als ein Hilfe-Einstiegspunkt zu markieren. Die Syntax ergibt sich aus dem verwendeten Hilfesystem. Oft wird das dazu verwendet, aus einem Fenstersystem eine Objekt-Id bzw. eine Widget-Namenshierarchie zu errechnen, die dann mit den Help-Entry-Einträgen korreliert wird.Beispiel:
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS]
festgelegter Wert
SGML Zeichenkette (NMTOKEN)
TOPIC
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.587. TOPIC-2

Beschreibung
Verwenden Sie <TOPIC-2>, um eine abgeschlossene Sinneinheit innerhalb einer Dokumentation zu erstellen.
Formale Beschreibung
Hat als Kontext: | INTRODUCTION, MSR-QUERY-RESULT-TOPIC-2, NCOI-3
Ist Kontext für: | LONG-NAME, SHORT-NAME, P, VERBATIM, FIGURE, FORMULA, LIST, DEF-LIST, LABELED-LIST, NOTE, TABLE, MSR-QUERY-P-2
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[ID]
obligatorisch
Identifikator (ID)
Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[HELP-ENTRY]
optional
Zeichenkette (CDATA)
Erlaubt es, das Vaterelement als ein Hilfe-Einstiegspunkt zu markieren. Die Syntax ergibt sich aus dem verwendeten Hilfesystem. Oft wird das dazu verwendet, aus einem Fenstersystem eine Objekt-Id bzw. eine Widget-Namenshierarchie zu errechnen, die dann mit den Help-Entry-Einträgen korreliert wird.Beispiel:
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS]
festgelegter Wert
SGML Zeichenkette (NMTOKEN)
TOPIC
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.588. TT

Beschreibung
Verwenden Sie <TT>, um technische Begriffe innerhalb der Absatzelemente zu formatieren.
Formale Beschreibung
Hat als Kontext: | CHANGE, DESC, INDENT-SAMPLE, ITEM-LABEL, LABEL, LONG-NAME, LONG-NAME-1, MSR-QUERY-RESULT-TEXT, P, REASON, TBR
Ist Kontext für: | Text
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[TYPE]
obligatorisch
Auswahlwert (NAMEDTOKENGROUP)
  • SGMLTAG
  • SGML-ATTRIBUTE
  • TOOL
  • PRODUCT
  • VARIABLE
  • STATE
  • PRM
  • MATERIAL
  • CONTROL-ELEMENT
  • CODE
  • ORGANISATION
  • OTHER
Gibt einen Typ des jeweiligen Elementes an.
[USER-DEFINED-TYPE]
optional
Zeichenkette (CDATA)
Erlaubt es, benutzerspezifische TTs einzuführen.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.589. TYP

Beschreibung
Verwenden Sie <TYP>, um die typischen Werte eines Parameters einzugeben.
Formale Beschreibung
Hat als Kontext: | PRM-CHAR
Ist Kontext für: | Text, SUP, SUB
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.590. UNIT

Beschreibung
Verwenden Sie <UNIT>, um die Einheit eines Parameters einzugeben.
Formale Beschreibung
Hat als Kontext: | PRM-CHAR
Ist Kontext für: | Text, SUP, SUB
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.591. UPPER-LIMIT

Beschreibung
Dieses Element spezifiziert die obere Schranke eines geschlossenen, halboffenen oder offenen Intervalles.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-SCALE, SW-INTERNAL-CONSTRS, SW-PHYS-CONSTRS, SW-SCALE-CONSTR
Ist Kontext für: | Text
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[INTERVAL-TYPE]
obligatorisch
Auswahlwert (NAMEDTOKENGROUP)
  • OPEN
  • CLOSED
OPEN: Offenes Intervall; CLOSED: geschlossenes Intervall
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.592. URL
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element spezifiziert den Uniform Resource Locator (URL) des das <URL>-Element beinhaltenden Kontextes.
Example
Siehe 1.115. MATCHING-DCIS MATCHING-DCIS MATCHING-DCIS MATCHING-DCI.
Formale Beschreibung
Hat als Kontext: | MATCHING-DCI, STD, XDOC, XFILE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.593. USED-LANGUAGES

Beschreibung
Verwenden Sie <USED-LANGUAGES>, um neben der Dokumentensprache alle weiteren Sprachen einzugeben, die in einem Dokument oder Dokumentteil verwendet werden.
Formale Beschreibung
Hat als Kontext: | ADMIN-DATA
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.594. USEFUL-LIFE

Beschreibung
Verwenden Sie <USEFUL-LIFE>, um die Nutzungsdauer einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-HARDWARE
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, USEFUL-LIFE-PRMS, NCOI-3
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.595. USEFUL-LIFE-PRMS

Beschreibung
Verwenden Sie <USEFUL-LIFE-PRMS>, um die Parameter einzugeben.
Formale Beschreibung
Hat als Kontext: | USEFUL-LIFE
Ist Kontext für: | AVAILABILITY, LIFE-TIME, OPERATING-TIME, PRM
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.596. USER-INTERFACE

Beschreibung
Verwenden Sie USER-INTERFACE, um die Benutzerschnittstelle einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-INTERFACES
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, NCOI-1
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.597. V
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Verwenden Sie <V>, um einen numerischen Wert einzugeben.
Example
Siehe SW-ARRAY-INDEX.
Formale Beschreibung
Hat als Kontext: | SW-COMPU-CONST, SW-COMPU-DENOMINATOR, SW-COMPU-INVERSE-VALUE, SW-COMPU-NUMERATOR, SW-VALUES-CODED, SW-VALUES-CODED-HEX, SW-VALUES-GENERIC, SW-VALUES-PHYS, VG
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.598. VALUE

Beschreibung
Verwenden Sie <VALUE>, um den Wert einzugeben.
Formale Beschreibung
Hat als Kontext: | VARIANT-CHAR-VALUE
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.599. VARIANT-CHAR

Beschreibung
Verwenden Sie <VARIANT-CHAR>, um die Variantencharakteristik einzugeben.
Formale Beschreibung
Hat als Kontext: | VARIANT-CHARS
Ist Kontext für: | LONG-NAME, SHORT-NAME, CODE
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[TYPE]
obligatorisch
Auswahlwert (NAMEDTOKENGROUP)
  • NEW-PART-NUMBER
  • NO-NEW-PART-NUMBER
NEW-PART-NUMBER: Neue Typnummer; NO-NEW-PART-NUMBER: keine neue Typnummer.
[ID]
obligatorisch
Identifikator (ID)
Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS]
festgelegter Wert
SGML Zeichenkette (NMTOKEN)
VARIANT-CHAR
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.600. VARIANT-CHAR-ASSIGN

Beschreibung
Verwenden Sie <VARIANT-CHAR-ASSIGN>, um die Zuordnung einzugeben.
Formale Beschreibung
Hat als Kontext: | VARIANT-CHAR-ASSIGNS
Ist Kontext für: | VARIANT-CHAR-REF, VARIANT-CHAR-VALUE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.601. VARIANT-CHAR-ASSIGNS

Beschreibung
Verwenden Sie <VARIANT-CHAR-ASSIGNS>, um die Zuordnungen einzugeben.
Formale Beschreibung
Hat als Kontext: | VARIANT-DEF
Ist Kontext für: | VARIANT-CHAR-ASSIGN
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.602. VARIANT-CHAR-REF

Beschreibung
Verwenden Sie <VARIANT-CHAR-REF>, um die Referenz einzugeben.
Formale Beschreibung
Hat als Kontext: | VARIANT-CHAR-ASSIGN
Ist Kontext für: | Text
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID-REF] obligatorisch | ID-Referenz (IDREF) |  | Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] festgelegter Wert | SGML Zeichenketten (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | VARIANT-CHAR | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.603. VARIANT-CHAR-VALUE

Beschreibung
Verwenden Sie <VARIANT-CHAR-VALUE>, um den Wert einzugeben.
Formale Beschreibung
Hat als Kontext: | VARIANT-CHAR-ASSIGN
Ist Kontext für: | VALUE, CODE
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.604. VARIANT-CHARS

Beschreibung
Verwenden Sie <VARIANT-CHARS>, um die Eigenschaften einzugeben.
Formale Beschreibung
Hat als Kontext: | VARIANT-SPEC
Ist Kontext für: | VARIANT-CHAR
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.605. VARIANT-DEF

Beschreibung
Verwenden Sie <VARIANT-DEF>, um die Variantenbezeichnung einzugeben.
Formale Beschreibung
Hat als Kontext: | VARIANT-DEFS
Ist Kontext für: | LONG-NAME, SHORT-NAME, CODE, VARIANT-CHAR-ASSIGNS
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | VARIANT-DEF | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.606. VARIANT-DEFS

Beschreibung
Verwenden Sie <VARIANT-DEFS>, um die Varianten Definitionen einzugeben.
Formale Beschreibung
Hat als Kontext: | VARIANT-SPEC
Ist Kontext für: | VARIANT-DEF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.607. VARIANT-SPEC

Beschreibung
Verwenden Sie <VARIANT-SPEC>, um die Variantenspezifikation einzugeben.
Formale Beschreibung
Hat als Kontext: | GENERAL-PROJECT-DATA
Ist Kontext für: | NA, TBD, TBR, INTRODUCTION, VARIANT-CHARS, VARIANT-DEFS
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.608. VERBATIM
Siehe Auch Description Example Formale Beschreibung

Description
<VERBATIM> is a paragraph in which whitespace (in particular blanks and line feeds) is obeyed. This allows to perform basic preformatting which can be displayed on even dumb devices. The behavior is the same as PRE in HTML.
Example
<VERBATIM>
  This is the system to demonstrate, how CDF should work.

  I make it in three lines to demonstrate, how VERBATIM works.
</VERBATIM>
Formale Beschreibung
Hat als Kontext: | ADD-INFO, ANNOTATION-TEXT, CHAPTER, CRITICAL-ASPECTS, ENTRY, FIGURE, FORMULA, FREE-INFO, INTRODUCTION, ITEM, LABELED-ITEM, MSR-PROCESSING-LOG, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-2, NCOI-1, NCOI-3, REALTIME-REQUIREMENTS, REMARK, REQUIREMENT-BODY, REQUIREMENTS-DEPENDENCY, RISKS, SW-ADDR-METHOD-DESC, SW-APPLICATION-NOTES, SW-CARB-DOC, SW-CLASS-METHOD-RETURN, SW-CODE-SYNTAX-DESC, SW-FEATURE-DEF, SW-FEATURE-DESC, SW-GENERIC-AXIS-DESC, SW-MAINTENANCE-NOTES, SW-TEST-DESC, TECHNICAL-ASPECTS, TOPIC-1, TOPIC-2
Ist Kontext für: | Text, E
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[ALLOW-BREAK]
mit Default-Wert
SGML Zeichenkette (NMTOKEN)
1
Steuert, ob Seitenumbrüche in ein <VERBATIM> hineinkommen dürfen. Bei NO-ALLOW-BREAK ist der benutzer dafür zuständig, dass es auf eine Seite passt.
[HELP-ENTRY]
optional
Zeichenkette (CDATA)
Erlaubt es, das Vaterelement als ein Hilfe-Einstiegspunkt zu markieren. Die Syntax ergibt sich aus dem verwendeten Hilfesystem. Oft wird das dazu verwendet, aus einem Fenstersystem eine Objekt-Id bzw. eine Widget-Namenshierarchie zu errechnen, die dann mit den Help-Entry-Einträgen korreliert wird.Beispiel:
[FLOAT]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • FLOAT
  • NO-FLOAT
Erlaubt es, bei einem nicht umbrechbaren <VERBATIM> zu steuern ob das <VERBATIM> woanders hin verschoben werden kann um eine bessere Seitenausnutzung zu bekommen (vergleiche flat bei TeX).
[PGWIDE]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • PGWIDE
  • NO-PGWIDE
PGWIDE: erlaubt es, den Inhald des aktuellen Elementes auf die gesamte Seitenbreite zu formatieren. Dies ist z.B. bei Code sinnvoll, bei dem über 80 Zeichen pro Zeile vorkommen.
[KEEP-WITH-PREVIOUS]
optional
Auswahlwert (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
Erlaubt es zu erzwingen, daß das aktuelle Element bei einer Seitenformatierung auf dieselbe Seite wie das vorausgehende formatiert wird (KEEP). Falls der Wert NO-KEEP ist, wird das Element auf die nächste Seite relativ zum Vorgängerelement positioniert.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.


1.609. VF
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Wert, der über eine Systemkonstante berechnet wird. Dieses Element wird überall dort eingesetzt, wo numerische Werte zur Compilezeit (nicht zur Laufzeit!) parametrierberbar sein sollen. Damit kann z.B. der Einfluß der Zylinderzahl auf Umrechnungsformeln reproduzierbar eingeführt werden.
Example
Folgendes Beispiel demonstriert den Einfluß der Zylinderzahl auf den Zündabstand:
<VF>360/ <SW-SYSTEMCONST-CODED-REF>ZYLZA<SW-SYSTEMCONST-CODED-REF> </VF>
Folgendes Beispiel zeigt den Einfluß der geforderten Maximaldrehzahl auf eine sich daraus ergebende 8-Bit Drehzahlquantisierung:
<VF><SW-SYSTEMCONST-PHYS-REF>MAXDRZ<SW-SYSTEMCONST-PHYS-REF>/256 </VF>
Formale Beschreibung
Hat als Kontext: | SW-ARRAYSIZE, SW-CALIBRATION-HANDLE, SW-COMPU-CONST, SW-COMPU-DENOMINATOR, SW-COMPU-INVERSE-VALUE, SW-COMPU-NUMERATOR, SW-GENERIC-AXIS-PARAM, SW-VALUES-CODED, SW-VALUES-CODED-HEX, SW-VALUES-GENERIC, SW-VALUES-PHYS, VG
Ist Kontext für: | Text, SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-PHYS-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.610. VG

Beschreibung
Dieses Element ermöglicht die Gruppierung von Werteparametern. Dies kann dazu verwendet werden, Zeilen- und spaltenorientierte Gruppierungen vorzunehmen, um diese z.B. am Bildschirm gruppiert ausgeben zu können.
Formale Beschreibung
Hat als Kontext: | SW-VALUES-CODED, SW-VALUES-CODED-HEX, SW-VALUES-GENERIC, SW-VALUES-PHYS, VG
Ist Kontext für: | LABEL, VF, VT, V, VG, SW-INSTANCE-REF
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes


1.611. VT
Siehe Auch Description Example Formale Beschreibung

Description
<VT> represents one particular textual value of the the calibration item.
Example
<SW-INSTANCE>
   <LONG-NAME>Stupid Messages</LONG-NAME>
   <SHORT-NAME>murph</SHORT-NAME>
   <SW-INSTANCE-PROPS-VARIANTS>
      <SW-INSTANCE-PROPS-VARIANT>
         <SW-AXIS-CONTS>
            <SW-AXIS-CONT>
               <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
               <SW-VALUES-PHYS>
                  <V>1</V>
                  <V>2</V>
                  <V>3</V>
                  <V>4</V>
               </SW-VALUES-PHYS>
            </SW-AXIS-CONT>
            <SW-AXIS-CONT>
               <SW-AXIS-INDEX>0</SW-AXIS-INDEX>
               <SW-VALUES-PHYS>
                  <VT>Things appear to be nearer than they are</VT>
                  <VT>Shit happens</VT>
                  <VT>Things will never be the same</VT>
                  <VT>Stay tuned to see unexpected results</VT>
               </SW-VALUES-PHYS>
            </SW-AXIS-CONT>
         </SW-AXIS-CONTS>
      </SW-INSTANCE-PROPS-VARIANT>
   </SW-INSTANCE-PROPS-VARIANTS>
</SW-INSTANCE>
Formale Beschreibung
Hat als Kontext: | SW-COMPU-CONST, SW-COMPU-INVERSE-VALUE, SW-VALUES-CODED, SW-VALUES-CODED-HEX, SW-VALUES-GENERIC, SW-VALUES-PHYS, SW-VCD-CRITERION-POSSIBLE-VALUES, SW-VCD-CRITERION-VALUE, VG
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


1.612. XDOC

Beschreibung
Verwenden Sie <XDOC>, um auf ein externes Dokument zu verweisen.
Formale Beschreibung
Hat als Kontext: | P, TBR
Ist Kontext für: | LONG-NAME-1, SHORT-NAME, NUMBER, STATE-1, DATE-1, PUBLISHER, URL, POSITION
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | XDOC | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.613. XFILE
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Verwenden Sie <XFILE>, um auf eine externe Datei zu verweisen.
Example
<P>Please refer to
   <XFILE>
      <LONG-NAME-1>Parameter Contents file</LONG-NAME-1>
      <SHORT-NAME>0711paco</SHORT-NAME>
      <URL>../pacos/0711paco.xml</URL>
      <NOTATION>PaCo</NOTATION>
      <TOOL>DDCL</TOOL>
      <TOOL-VERSION>1.3</TOOL-VERSION>
   </XFILE>
</P>
Formale Beschreibung
Hat als Kontext: | P, TBR
Ist Kontext für: | LONG-NAME-1, SHORT-NAME, URL, NOTATION, TOOL, TOOL-VERSION
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | XFILE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.614. XREF

Beschreibung
Verwenden Sie <XREF>, um Querverweise innerhalb des Dokumentes zu erstellen.
Formale Beschreibung
Hat als Kontext: | CHANGE, DESC, INDENT-SAMPLE, ITEM-LABEL, MSR-QUERY-ARG, MSR-QUERY-RESULT-TEXT, P, REASON, SDG, TBR
Ist Kontext für: | Text
Name
Typ
Wertebereich / Vorbelegung
Anmerkung
[ID-CLASS]
obligatorisch
Auswahlwert (NAMEDTOKENGROUP)
  • CHAPTER
  • COMPANY
  • DEF-ITEM
  • EXTERNAL
  • FIGURE
  • FORMULA
  • PRM
  • REQUIREMENT
  • SAMPLE
  • SDG
  • STD
  • SW-ADDR-METHOD
  • SW-AXIS-TYPE
  • SW-BASE-TYPE
  • SW-CALPRM
  • SW-CALPRM-PROTOTYPE
  • SW-CLASS-PROTOTYPE
  • SW-CLASS-ATTR-IMPL
  • SW-CLASS-INSTANCE
  • SW-CLASS
  • SW-CODE-SYNTAX
  • SW-COLLECTION
  • SW-COMPU-METHOD
  • SW-CPU-MEM-SEG
  • SW-DATA-CONSTR
  • SW-FEATURE
  • SW-GENERIC-AXIS-PARAM-TYPE
  • SW-INSTANCE-TREE
  • SW-INSTANCE
  • SW-MC-BASE-TYPE
  • SW-MC-INTERFACE-SOURCE
  • SW-MC-INTERFACE
  • SW-RECORD-LAYOUT
  • SW-SYSTEMCONST
  • SW-SYSTEM
  • SW-TASK
  • SW-TEMPLATE
  • SW-UNIT
  • SW-USER-ACCESS-CASE
  • SW-USER-GROUP
  • SW-VARIABLE-PROTOTYPE
  • SW-VARIABLE
  • SW-VCD-CRITERION
  • TABLE
  • TEAM-MEMBER
  • TOPIC
  • VARIANT-DEF
  • VARIANT-CHAR
  • XDOC
  • XFILE
  • XREF-TARGET
ID-CLASS. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <XREF IDREF="ID1" ID-CLASS="TEAM-MEMBER">...</XREF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[ID-REF]
obligatorisch
ID-Referenz (IDREF)
Referenz auf ein durch einen ID-Attributwert eindeutiges Elementes innerhalb des Dokumentes.
[SHOW-SEE]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • SHOW-SEE
  • NO-SHOW-SEE
Entscheidet, ob der Fixtext "siehe" ausgegeben werden soll.
[SHOW-CONTENT]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • SHOW-CONTENT
  • NO-SHOW-CONTENT
CONTENT entscheidet, ob der Inhalt des Elements ausgegeben werden soll
[SHOW-RESOURCE-TYPE]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • SHOW-TYPE
  • NO-SHOW-TYPE
Wählen Sie SHOW-TYPE, um den Absatztyp des Verweisziels anzuzeigen.
[SHOW-RESOURCE-NUMBER]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • SHOW-NUMBER
  • NO-SHOW-NUMBER
Wählen Sie SHOW-NUMBER, um die Absatznummer des Verweisziels anzuzeigen.
[SHOW-RESOURCE-LONG-NAME]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • SHOW-LONG-NAME
  • NO-SHOW-LONG-NAME
Wählen Sie SHOW-LONG-NAME, um die Absatzbeschriftung des Verweisziels anzuzeigen.
[SHOW-RESOURCE-SHORT-NAME]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • SHOW-SHORT-NAME
  • NO-SHOW-SHORT-NAME
Wählen Sie SHOW-LONG-NAME, um die Kurzbezeichnung des Verweisziels anzuzeigen.
[SHOW-RESOURCE-PAGE]
mit Default-Wert
Auswahlwert (NAMEDTOKENGROUP)
  • SHOW-PAGE
  • NO-SHOW-PAGE
Wählen Sie SHOW-LONG-NAME, um die Seitennummer des Verweisziels anzuzeigen.
[EXT-ID-CLASS]
optional
Zeichenkette (CDATA)
External ID Class. The value of this attribute classifies links and external link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an external object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[VIEW]
optional
Zeichenkette (CDATA)
Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S]
optional
Zeichenkette (CDATA)
Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T]
optional
Zeichenkette (CDATA)
Zeitstempelangabe
[SI]
optional
Zeichenkette (CDATA)
Beschreibung der semantischen Bedeutung eines Elementes.
[HYTIME]
festgelegter Wert
SGML Zeichenkette (NMTOKEN)
CLINK
HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES]
festgelegter Wert
SGML Zeichenketten (NMTOKENS)
LINKEND ID-REF
HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.


1.615. XREF-TARGET
Siehe Auch Beschreibung Example Formale Beschreibung

Beschreibung
Dieses Element spezifiziert ein Verweisziel, welches in den Text eingestreut werden kann.
Example
<P>Dieses Element spezifiziert ein <XREF-TARGET ID="DC92181212673206"><LONG-NAME-1>Verweisziel</LONG-NAME-1></XREF-TARGET> Verweisziel,
welches in den Text eingestreut werden kann. </P>
Formale Beschreibung
Hat als Kontext: | CHANGE, DESC, INDENT-SAMPLE, ITEM-LABEL, MSR-QUERY-RESULT-TEXT, P, REASON, TBR
Ist Kontext für: | LONG-NAME-1, SHORT-NAME
Name | Typ | Wertebereich / Vorbelegung | Anmerkung
[ID] obligatorisch | Identifikator (ID) |  | Eindeutiger Identifikator des Elementes innerhalb des Dokumentes.
[VIEW] optional | Zeichenkette (CDATA) |  | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) |  | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) |  | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) |  | Beschreibung der semantischen Bedeutung eines Elementes.
[F-ID-CLASS] festgelegter Wert | SGML Zeichenkette (NMTOKEN) | XREF-TARGET | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


1.616. ZIP

Beschreibung
Verwenden Sie <ZIP>, um die Postleitzahl der Firmenadresse eines Projektbeteiligten einzugeben.
Formale Beschreibung
Hat als Kontext: | TEAM-MEMBER
Ist Kontext für: | Text
Name | Typ | Anmerkung
[VIEW] optional | Zeichenkette (CDATA) | Beliebiger Begriff zur Verwirklichung eines Sichtenkonzepts. Textteile können dadurch im Editor oder beim Generieren eines Dokumentes ein- oder ausgeblendet werden.
[S] optional | Zeichenkette (CDATA) | Signatur, um die berechnete Signatur des Kontents eines Elements abzulegen, z.B. CRC.
[T] optional | Zeichenkette (CDATA) | Zeitstempelangabe
[SI] optional | Zeichenkette (CDATA) | Beschreibung der semantischen Bedeutung eines Elementes.


Technische Begriffe

Element Attribute Documentation
Technische Begriffe

A-Links
ABS
ACCEPTANCE-COND
ADD-DESIGN-DOC
ADD-INFO
ADD-SPEC
ADDRESS
ADMIN-DATA
ANNOTATION
ANNOTATION-ORIGIN
ANNOTATION-TEXT
ANNOTATIONS
AREA
AVAILABILITY
BINARY-COMPATIBILITY
BIT-POSITION
BYTE-ORDER
C-CODE
C-IDENTIFIER
CALIBRATION
CATEGORY
CHANGE
CHAPTER
CITY
CODE
COLSPEC
COMMENT
COMMUNICATION
COMMUNICATION-INTERFACE
COMPANIES
COMPANY
COMPANY-DOC-INFO
COMPANY-DOC-INFOS
COMPANY-REF
COMPANY-REVISION-INFO
COMPANY-REVISION-INFOS
COMPATIBILITY
COND
CONTRACT-ASPECTS
CRITICAL-ASPECTS
DATA-DESC
DATA-REQUIREMENTS
DATA-STRUCTURES
DATE
DATE-1
DEF
DEF-ITEM
DEF-LIST
DEMARCATION-OTHER-PROJECTS
DEPARTMENT
DESC
DESIGN-REQUIREMENTS
DEVELOPMENT-PROCESS-SPEC
DIAGNOSIS
DIR-HAND-OVER-DOC-DATA
DOC-LABEL
DOC-REVISION
DOC-REVISIONS
E
EMAIL
ENTITY-NAME
ENTRY
EXTENSIBILITY
FAIL-SAVE-CONCEPT
FAILURE-MANAGEMENT
FAILURE-MEM
FAX
FIGURE
FIGURE-CAPTION
FLASH-PROGRAMMING
FMEA
FORMATTER-CTRL
FORMATTER-CTRLS
FORMULA
FORMULA-CAPTION
FREE-INFO
FT
FUNCTION-OVERVIEW
FUNCTION-REF
FUNCTIONAL-REQUIREMENTS
GENERAL-COND
GENERAL-HARDWARE
GENERAL-INTERFACES
GENERAL-PRODUCT-DATA-1
GENERAL-PROJECT-DATA
GENERAL-REQUIREMENTS
GENERAL-SOFTWARE
GENERIC-MATH
GRAPHIC
GUARANTEE
HARDWARE-INTERFACE
HOMEPAGE
IE
INDENT-SAMPLE
INTEGRATION-CAPABILITY
INTERNAL-INTERFACES
INTERRUPT-SPEC
INTRODUCTION
ISSUED-BY
ITEM
ITEM-LABEL
KEY-DATA
LABEL
LABELED-ITEM
LABELED-LIST
LANGUAGE
LIFE-TIME
LIST
LOCS
LONG-NAME
LONG-NAME-1
LOWER-LIMIT
MAINTENANCE
MAP
MATCHING-DCI
MATCHING-DCIS
MAX
MIN
MODIFICATION
MODIFICATIONS
MONITORING
MSR-PROCESSING-LOG
MSR-QUERY-ARG
MSR-QUERY-CHAPTER
MSR-QUERY-NAME
MSR-QUERY-P-1
MSR-QUERY-P-2
MSR-QUERY-PROPS
MSR-QUERY-RESULT-CHAPTER
MSR-QUERY-RESULT-P-1
MSR-QUERY-RESULT-P-2
MSR-QUERY-RESULT-TEXT
MSR-QUERY-RESULT-TOPIC-1
MSR-QUERY-RESULT-TOPIC-2
MSR-QUERY-TEXT
MSR-QUERY-TOPIC-1
MSR-QUERY-TOPIC-2
MSRSW
MTBF
NA
NAMELOC
NCOI-1, NCOI-1
NCOI-3
NMLIST
NORMATIVE-REFERENCE
NOTATION
NOTE
NUMBER
NUMBER-OF-BITS
OBJECTIVES
OPERATING-ENV
OPERATING-TIME
OPERATIONAL-REQUIREMENTS
OVERALL-PROJECT
OVERVIEW
P
PARALLEL-DESIGNS
PHONE
POSITION
PPM
PRIVATE-CODE
PRIVATE-CODES
PRM
PRM-CHAR
PRM-REF
PRM-REFS
PRMS
PRODUCT-DEMARCATION
PRODUCT-DESC
PROJECT
PROJECT-DATA
PROJECT-SCHEDULE
PROTOCOLS
PUBLISHER
PURCHASING-COND
QUALITY
REALTIME-REQUIREMENTS
REASON
REASON-ORDER
RELIABILITY
RELIABILITY-PRMS
REMARK
REPLACEMENT-VALUES
REQUIREMENT
REQUIREMENT-BODY
REQUIREMENT-REF
REQUIREMENT-SPEC
REQUIREMENTS
REQUIREMENTS-DEPENDENCY
RESOURCE-ALLOCATION
RESTRICTIONS-BY-HARDWARE
REVISION-LABEL
RIGHTS
RISKS
ROLE
ROLES
ROW
SAFETY
SAMPLE
SAMPLE-REF
SAMPLE-SPEC
SAMPLES
SCHEDULE
SD
SDG
SDG-CAPTION
SELF-DIAGNOSIS
SHORT-LABEL
SHORT-NAME
SI-UNIT
SIMILAR-PRODUCTS
SPANSPEC
SPECIAL-DATA
STANDARD-SW-MODULES
STATE
STATE-1
STD
SUB
SUBTITLE
SUP
SW-ACCESS-DEF
SW-ADDR-INFO
SW-ADDR-INFOS
SW-ADDR-METHOD
SW-ADDR-METHOD-DESC
SW-ADDR-METHOD-REF
SW-ADDR-METHOD-REFS
SW-ADDR-METHODS
SW-ADDR-OFFSET
SW-ALIAS-NAME
SW-APPLICATION-NOTES
SW-ARCHITECTURE
SW-ARRAY-INDEX
SW-ARRAYSIZE
SW-AXIS-CONT
SW-AXIS-CONTS
SW-AXIS-GENERIC
SW-AXIS-GROUPED
SW-AXIS-INDEX
SW-AXIS-INDIVIDUAL
SW-AXIS-TYPE
SW-AXIS-TYPE-REF
SW-AXIS-TYPE-REFS
SW-AXIS-TYPES
SW-BASE-ADDR
SW-BASE-TYPE
SW-BASE-TYPE-REF
SW-BASE-TYPE-REFS
SW-BASE-TYPE-SIZE
SW-BASE-TYPES
SW-BIT-REPRESENTATION
SW-CALIBRATION-ACCESS
SW-CALIBRATION-HANDLE
SW-CALIBRATION-METHOD
SW-CALIBRATION-METHOD-SPEC
SW-CALIBRATION-METHOD-VERSION
SW-CALIBRATION-METHOD-VERSIONS
SW-CALIBRATION-METHODS
SW-CALPRM
SW-CALPRM-AXIS
SW-CALPRM-AXIS-SET
SW-CALPRM-IMPL
SW-CALPRM-IMPLS
SW-CALPRM-MAX-TEXT-SIZE
SW-CALPRM-NO-EFFECT-VALUE
SW-CALPRM-POINTER
SW-CALPRM-PROTOTYPE
SW-CALPRM-PROTOTYPE-REF
SW-CALPRM-PROTOTYPES
SW-CALPRM-REF
SW-CALPRM-REF-SYSCOND
SW-CALPRM-REFS
SW-CALPRM-TARGET
SW-CALPRM-TEXT
SW-CALPRM-VALUE-AXIS-LABELS
SW-CALPRMS
SW-CARB-DOC
SW-CLASS
SW-CLASS-ATTR
SW-CLASS-ATTR-IMPL
SW-CLASS-ATTR-IMPL-REF
SW-CLASS-ATTR-IMPLS
SW-CLASS-IMPL
SW-CLASS-IMPLS
SW-CLASS-INSTANCE
SW-CLASS-INSTANCE-REF
SW-CLASS-INSTANCE-REFS
SW-CLASS-INSTANCES
SW-CLASS-METHOD
SW-CLASS-METHOD-ARG
SW-CLASS-METHOD-RETURN
SW-CLASS-METHODS
SW-CLASS-PROTOTYPE
SW-CLASS-PROTOTYPE-REF
SW-CLASS-PROTOTYPES
SW-CLASS-REF
SW-CODE-SYNTAX
SW-CODE-SYNTAX-DESC
SW-CODE-SYNTAX-REF
SW-CODE-SYNTAX-REFS
SW-CODE-SYNTAXES
SW-CODED-TYPE
SW-COLLECTION
SW-COLLECTION-CONT
SW-COLLECTION-REF
SW-COLLECTION-REFS
SW-COLLECTION-REGEXP
SW-COLLECTION-REGEXPS
SW-COLLECTION-RULE
SW-COLLECTION-RULES
SW-COLLECTION-SCRIPT
SW-COLLECTION-SCRIPTS
SW-COLLECTION-SPEC
SW-COLLECTION-WILDCARD
SW-COLLECTION-WILDCARDS
SW-COLLECTIONS
SW-COMPARISON-VARIABLES
SW-COMPONENT-SPEC
SW-COMPONENTS
SW-COMPU-CONST
SW-COMPU-DEFAULT-VALUE
SW-COMPU-DENOMINATOR
SW-COMPU-GENERIC-MATH
SW-COMPU-IDENTITY
SW-COMPU-INTERNAL-TO-PHYS
SW-COMPU-INVERSE-VALUE
SW-COMPU-METHOD
SW-COMPU-METHOD-REF
SW-COMPU-METHOD-REFS
SW-COMPU-METHODS
SW-COMPU-NUMERATOR
SW-COMPU-PHYS-TO-INTERNAL
SW-COMPU-PROGRAM-CODE
SW-COMPU-RATIONAL-COEFFS
SW-COMPU-SCALE
SW-COMPU-SCALES
SW-CONSTR-LEVEL
SW-CONSTR-OBJECTS
SW-CPU-ADDR-EPK
SW-CPU-CALIBRATION-OFFSET
SW-CPU-EPK
SW-CPU-MEM-SEG
SW-CPU-MEM-SEG-REF
SW-CPU-MEM-SEGS
SW-CPU-NUMBER-OF-INTERFACES
SW-CPU-SPEC
SW-CPU-STANDARD-RECORD-LAYOUT
SW-CPU-TYPE
SW-CS-CONTEXT
SW-CS-DATA-IDENTIFIER
SW-CS-ENTRY
SW-CS-FIELD
SW-CS-HISTORY
SW-CS-PERFORMED-BY
SW-CS-PROGRAM-IDENTIFIER
SW-CS-PROJECT-INFO
SW-CS-STATE
SW-CS-TARGET-VARIANT
SW-CS-TEST-OBJECT
SW-CSE-CODE
SW-CSE-CODE-FACTOR
SW-DATA-CONSTR
SW-DATA-CONSTR-REF
SW-DATA-CONSTR-REFS
SW-DATA-CONSTR-RULE
SW-DATA-CONSTRS
SW-DATA-DEF-PROPS
SW-DATA-DEPENDENCY
SW-DATA-DEPENDENCY-ARGS
SW-DATA-DEPENDENCY-FORMULA
SW-DATA-DICTIONARY-SPEC
SW-DISPLAY-FORMAT
SW-EFFECT
SW-EFFECT-FLOW
SW-EFFECT-FLOWS
SW-EFFECTING-VARIABLE
SW-FEATURE
SW-FEATURE-CLASS-INSTANCES
SW-FEATURE-DECOMPOSITION
SW-FEATURE-DEF
SW-FEATURE-DESC
SW-FEATURE-DESIGN-DATA
SW-FEATURE-EXPORT-CALPRMS
SW-FEATURE-EXPORT-CLASS-INSTANCES
SW-FEATURE-EXPORT-VARIABLES
SW-FEATURE-IMPORT-CALPRMS
SW-FEATURE-IMPORT-CLASS-INSTANCES
SW-FEATURE-IMPORT-VARIABLES
SW-FEATURE-LOCAL-CLASS-INSTANCES
SW-FEATURE-LOCAL-PARAMS
SW-FEATURE-LOCAL-VARIABLES
SW-FEATURE-MODEL-ONLY-VARIABLES
SW-FEATURE-PARAMS
SW-FEATURE-REF
SW-FEATURE-REFS
SW-FEATURE-VARIABLES
SW-FILL-CHARACTER
SW-FULFILS
SW-GENERIC-AXIS-DESC
SW-GENERIC-AXIS-PARAM
SW-GENERIC-AXIS-PARAM-TYPE
SW-GENERIC-AXIS-PARAM-TYPE-REF
SW-GENERIC-AXIS-PARAM-TYPES
SW-GENERIC-AXIS-PARAMS
SW-GLOSSARY
SW-HOST-VARIABLE
SW-IMPL-POLICY
SW-INSTANCE
SW-INSTANCE-PROPS-VARIANT
SW-INSTANCE-PROPS-VARIANTS
SW-INSTANCE-REF
SW-INSTANCE-REF-SYSCOND
SW-INSTANCE-REFS
SW-INSTANCE-SPEC
SW-INSTANCE-TREE
SW-INTENDED-RESOLUTION
SW-INTERNAL-CONSTRS
SW-INTERNAL-CONSTRS-1
SW-INTERPOLATION-METHOD
SW-IS-VIRTUAL
SW-MAINTENANCE-NOTES
SW-MAX-AXIS-POINTS
SW-MAX-DIFF
SW-MAX-GRADIENT
SW-MC-ADDR-MAPPED-SIZE
SW-MC-ADDR-MAPPING
SW-MC-ADDR-MAPPINGS
SW-MC-BASE-TYPE
SW-MC-BASE-TYPE-REF
SW-MC-BASE-TYPES
SW-MC-BLOB-ECU-DEPOSIT
SW-MC-BLOB-LAYOUTS
SW-MC-BLOB-VALUE
SW-MC-COMMUNICATION-SPEC
SW-MC-DP-BLOB-CONTS
SW-MC-DP-BLOB-LAYOUT
SW-MC-FRAME
SW-MC-FRAMES
SW-MC-GENERIC-INTERFACE
SW-MC-GENERIC-INTERFACES
SW-MC-INSTANCE-INTERFACE
SW-MC-INSTANCE-INTERFACES
SW-MC-INTERFACE
SW-MC-INTERFACE-AVL-SOURCES
SW-MC-INTERFACE-DEFAULT-SOURCE
SW-MC-INTERFACE-IMPL
SW-MC-INTERFACE-IMPLS
SW-MC-INTERFACE-REF
SW-MC-INTERFACE-SOURCE
SW-MC-INTERFACE-SOURCE-REF
SW-MC-INTERFACE-SOURCES
SW-MC-INTERFACE-SPEC
SW-MC-KP-BLOB-CONTS
SW-MC-KP-BLOB-LAYOUT
SW-MC-MAPPED-ADDR
SW-MC-ORIGINAL-ADDR
SW-MC-PA-BLOB-CONTS
SW-MC-PA-BLOB-LAYOUT
SW-MC-QP-BLOB-CONTS
SW-MC-QP-BLOB-LAYOUT
SW-MC-TP-BLOB-CONTS
SW-MC-TP-BLOB-LAYOUT
SW-MEM-ALIGNMENT
SW-MEM-ATTR
SW-MEM-BASE-ADDR
SW-MEM-OFFSET
SW-MEM-OFFSETS
SW-MEM-PROGRAM-TYPE
SW-MEM-SIZE
SW-MEM-TYPE
SW-MIN-AXIS-POINTS
SW-MONOTONY
SW-NUMBER-OF-AXIS-POINTS
SW-PHYS-CONSTRS
SW-PHYS-CONSTRS-1
SW-PROCESS
SW-PROCESSES
SW-RECORD-LAYOUT
SW-RECORD-LAYOUT-COMPONENT
SW-RECORD-LAYOUT-GROUP
SW-RECORD-LAYOUT-GROUP-AXIS
SW-RECORD-LAYOUT-GROUP-FROM
SW-RECORD-LAYOUT-GROUP-INDEX
SW-RECORD-LAYOUT-GROUP-STEP
SW-RECORD-LAYOUT-GROUP-TO
SW-RECORD-LAYOUT-REF
SW-RECORD-LAYOUT-REFS
SW-RECORD-LAYOUT-V
SW-RECORD-LAYOUT-V-AXIS
SW-RECORD-LAYOUT-V-FIX-VALUE
SW-RECORD-LAYOUT-V-INDEX
SW-RECORD-LAYOUT-V-PROP
SW-RECORD-LAYOUTS
SW-REFRESH-TIMING
SW-RELATED-CONSTRS
SW-ROOT-FEATURES
SW-SCALE-CONSTR
SW-SCALE-CONSTRS
SW-SIZEOF-INSTANCE
SW-SUBCOMPONENT
SW-SYSCOND
SW-SYSTEM
SW-SYSTEMCONST
SW-SYSTEMCONST-CODED-REF
SW-SYSTEMCONST-PHYS-REF
SW-SYSTEMCONST-REF
SW-SYSTEMCONST-REFS
SW-SYSTEMCONSTS
SW-SYSTEMS
SW-TASK
SW-TASK-REF
SW-TASK-SPEC
SW-TASKS
SW-TEMPLATE
SW-TEMPLATE-REF
SW-TEMPLATES
SW-TEST-DESC
SW-TEST-SPEC
SW-UNIT
SW-UNIT-CONVERSION-METHOD
SW-UNIT-DISPLAY
SW-UNIT-GRADIENT
SW-UNIT-OFFSET
SW-UNIT-REF
SW-UNIT-REFS
SW-UNITS
SW-USER-ACCESS-CASE
SW-USER-ACCESS-CASE-REF
SW-USER-ACCESS-CASE-REFS
SW-USER-ACCESS-CASES
SW-USER-ACCESS-DEFINTIONS
SW-USER-GROUP
SW-USER-GROUP-REF
SW-USER-GROUP-REFS
SW-USER-GROUPS
SW-USER-RIGHT-SPEC
SW-VALUES-CODED
SW-VALUES-CODED-HEX
SW-VALUES-GENERIC
SW-VALUES-PHYS
SW-VAR-INIT-VALUE
SW-VAR-NOT-AVL-VALUE
SW-VARIABLE
SW-VARIABLE-IMPL
SW-VARIABLE-IMPLS
SW-VARIABLE-KIND
SW-VARIABLE-PROTOTYPE
SW-VARIABLE-PROTOTYPE-REF
SW-VARIABLE-PROTOTYPES
SW-VARIABLE-REF
SW-VARIABLE-REF-SYSCOND
SW-VARIABLE-REFS
SW-VARIABLES
SW-VARIABLES-READ
SW-VARIABLES-READ-WRITE
SW-VARIABLES-WRITE
SW-VCD-CRITERIA
SW-VCD-CRITERION
SW-VCD-CRITERION-POSSIBLE-VALUES
SW-VCD-CRITERION-REF
SW-VCD-CRITERION-REFS
SW-VCD-CRITERION-VALUE
SW-VCD-CRITERION-VALUES
SW-VCD-SPEC
SYSTEM-OVERVIEW
SYSTEM-USER
SYSTEM-USERS
TABLE
TABLE-CAPTION
TBD
TBODY
TBR
TEAM-MEMBER
TEAM-MEMBER-REF
TEAM-MEMBER-REFS
TEAM-MEMBERS
TECHNICAL-ASPECTS
TEX-MATH
TEXT
TFOOT
TGROUP
THEAD
TIME-DEPENDENCY
TOL
TOOL
TOOL-VERSION
TOPIC-1
TOPIC-2
TT
TYP
UNIT
UPPER-LIMIT
URL
USED-LANGUAGES
USEFUL-LIFE
USEFUL-LIFE-PRMS
USER-INTERFACE
V
VALUE
VARIANT-CHAR
VARIANT-CHAR-ASSIGN
VARIANT-CHAR-ASSIGNS
VARIANT-CHAR-REF
VARIANT-CHAR-VALUE
VARIANT-CHARS
VARIANT-DEF
VARIANT-DEFS
VARIANT-SPEC
VERBATIM
VF
VG
VT
XDOC
XFILE
XREF
XREF-TARGET
ZIP
Kontroll-Elemente
ADDR_EPK
MSR-QUERY, MSR-QUERY, MSR-QUERY, MSR-QUERY, MSR-QUERY, MSR-QUERY, MSR-QUERY, MSR-QUERY, MSR-QUERY, MSR-QUERY, MSR-QUERY, MSR-QUERY, MSR-QUERY, MSR-QUERY
Organisationen
ASAM
CARB
IEEE
Produkte
A2ML
ASAM-MCD 1.x
CDF, CDF, CDF, CDF, CDF, CDF, CDF, CDF, CDF, CDF
DCI
HTML
MSRSW.DTD, MSRSW.DTD, MSRSW.DTD
MSRSYS.DTD, MSRSYS.DTD
PACO
Programmcode
ADAPTIVE
ADDRESS
ANNOTATION
ASCII
AXIS_VALUES
CAL-ITEM
CAL-LIST, CAL-LIST
CALIBRATION
CODE
COUNT
CURVE_AXIS_REF
CURVE_FIXED
CURVE_GROUPED
CURVE_INDIVIDUAL
DATA
DIST
EEPROM
EPROM
EXTERN, EXTERN
FILL
FIXLEFTDIFF
FIXRIGHTDIFF
FLASH
INTERN, INTERN
LEFTDIFF
MAP_FIXED
MAP_GROUPED
MAP_INDIVIDUAL
NO-CALIBRATION
NOT-IN-MEMORY
NOTE
OFFLINE_DATA
RAM
REGISTER
RESERVED
RESULT-ADR
RIGHTDIFF
ROM
SOURCE-ADR
STRUCTURE
SYMBOLIC-FILE
VALUE, VALUE
VALUE_BLOCK
SGML Attribute
ACCESSKEY
ALIGN, ALIGN, ALIGN, ALIGN
ALLOW-BREAK
ALT
AMOUNT-OF-SUBSTANCE-EXPO
BREAK
calibration
CATEGORY
CHAR, CHAR, CHAR, CHAR
CHAROFF, CHAROFF, CHAROFF, CHAROFF
CLASS, CLASS
COLNAME, COLNAME
COLNUM
COLOR
COLS
COLSEP, COLSEP, COLSEP, COLSEP, COLSEP
COLWIDTH
COORDS
DOCORSUB
EDIT-HEIGHT
EDIT-WIDTH
ELECTRIC-CURRENT-EXPO
EXT-ID-CLASS, EXT-ID-CLASS
F-CHILD-TYPE, F-CHILD-TYPE, F-CHILD-TYPE
F-EXT-ID-CLASS
F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS
F-NAMESPACE, F-NAMESPACE, F-NAMESPACE, F-NAMESPACE, F-NAMESPACE, F-NAMESPACE, F-NAMESPACE, F-NAMESPACE, F-NAMESPACE
F-PUBID
FILENAME
FIT
FLOAT, FLOAT, FLOAT
FRAME
FUNCTION-REF
GID, GID
HEIGHT
HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY
HREF
HTML-FIT
HTML-HEIGHT
HTML-WIDTH
HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES
HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME
ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID
ID-CLASS
ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF, ID-REF
INTERVAL-TYPE, INTERVAL-TYPE
invert
ITEM-LABEL-POS
KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS, KEEP-WITH-PREVIOUS
LANG-SUBSET
LANGUAGE
LENGTH-EXPO
LEVEL
LUMINOUS-INTENSITY-EXPO
MASS-EXPO
MOREROWS
NAME
NAMEEND, NAMEEND
NAMEST, NAMEST
NAMETYPE
NOHREF
NOTATION
NOTE-TYPE
ONBLUR
ONCLICK, ONCLICK
ONDBLCLICK, ONDBLCLICK
ONFOCUS
ONKEYDOWN, ONKEYDOWN
ONKEYPRESS, ONKEYPRESS
ONKEYUP, ONKEYUP
ONMOUSEDOWN, ONMOUSEDOWN
ONMOUSEMOVE, ONMOUSEMOVE
ONMOUSEOUT, ONMOUSEOUT
ONMOUSEOVER, ONMOUSEOVER
ONMOUSEUP, ONMOUSEUP
ORIENT
ORIGIN
PGWIDE, PGWIDE, PGWIDE
PROGRAM-LANG
PUBID
RESOLVE-REFS
ROLE
ROOT
ROTATE
ROWSEP, ROWSEP, ROWSEP, ROWSEP, ROWSEP, ROWSEP
S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S
SCALE
SCOPE
SHAPE
SHORTENTRY
SHOW-CONTENT
SHOW-RESOURCE-LONG-NAME
SHOW-RESOURCE-NUMBER
SHOW-RESOURCE-PAGE
SHOW-RESOURCE-SHORT-NAME
SHOW-RESOURCE-TYPE
SHOW-SEE
SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI, SI
SPANNAME, SPANNAME
STYLE, STYLE
T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T
TABINDEX
TABSTYLE
TARGET-SYSTEM
TGROUPSTYLE
THERMODYNAMIC-TEMPERATURE-EXPO
TIME-EXPO
TITLE, TITLE
TOCENTRY
TYPE, TYPE, TYPE, TYPE, TYPE, TYPE, TYPE, TYPE, TYPE, TYPE
USED-LIBS
USER-DEFINED-TYPE, USER-DEFINED-TYPE
VALIGN, VALIGN, VALIGN, VALIGN, VALIGN
VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW, VIEW
WIDTH
SGML Elemente
ABS
ACCEPTANCE-COND
ADD-DESIGN-DOC
ADD-INFO, ADD-INFO, ADD-INFO, ADD-INFO, ADD-INFO
ADD-SPEC, ADD-SPEC, ADD-SPEC
ADDRESS
ADMIN-DATA, ADMIN-DATA, ADMIN-DATA, ADMIN-DATA, ADMIN-DATA, ADMIN-DATA
ANNOTATION
ANNOTATION-ORIGIN
ANNOTATION-TEXT
ANNOTATIONS, ANNOTATIONS
AREA
AVAILABILITY
BINARY-COMPATIBILITY
BIT-POSITION, BIT-POSITION
C-CODE
CALIBRATION
CATEGORY, CATEGORY, CATEGORY, CATEGORY, CATEGORY
CHANGE
CHAPTER, CHAPTER, CHAPTER
CITY
COLSPEC, COLSPEC, COLSPEC
COMMENT
COMPANIES
COMPANY
COMPANY-DOC-INFO
COMPANY-DOC-INFOS
COMPANY-REF
COMPANY-REVISION-INFO
COMPANY-REVISION-INFOS
COND
CRITICAL-ASPECTS
DATE, DATE
DATE-1
DEF
DEF-ITEM
DEF-LIST
DEPARTMENT
DESC, DESC, DESC, DESC, DESC
distance
DOC-LABEL
DOC-REVISION, DOC-REVISION
DOC-REVISIONS
E
EMAIL
ENTITY-NAME
ENTRY, ENTRY, ENTRY
EXTENSIBILITY
FAIL-SAVE-CONCEPT
FAILURE-MANAGEMENT
FAILURE-MEM
FAX
FIGURE
FLASH-PROGRAMMING
FMEA
FORMATTER-CTRL, FORMATTER-CTRL
FORMULA
FREE-INFO
FT
FUNCTION-OVERVIEW
FUNCTION-REF
GENERAL-COND
GENERAL-HARDWARE
GENERAL-INTERFACES
GENERAL-PRODUCT-DATA-1
GENERAL-PROJECT-DATA
GENERAL-REQUIREMENTS, GENERAL-REQUIREMENTS, GENERAL-REQUIREMENTS
GENERAL-SOFTWARE
GENERIC-MATH
GRAPHIC
GUARANTEE
HARDWARE-INTERFACE
HOMEPAGE
IE
INDENT-SAMPLE
INTEGRATION-CAPABILITY
INTERNAL-INTERFACES
INTERRUPT-SPEC
INTRODUCTION, INTRODUCTION, INTRODUCTION, INTRODUCTION, INTRODUCTION
ITEM
ITEM-LABEL
KEY-DATA
LABEL, LABEL, LABEL, LABEL
LABELED-ITEM
LABELED-LIST
LANGUAGE
LIFE-TIME
LIST
LOCS, LOCS
LONG-NAME, LONG-NAME, LONG-NAME, LONG-NAME, LONG-NAME, LONG-NAME
LONG-NAME-1
LOWER-LIMIT
MAINTENANCE
MAP
MATCHING-DCI, MATCHING-DCI
MATCHING-DCIS, MATCHING-DCIS
MAX
MIN
MODIFICATION, MODIFICATION
MSR-PROCESSING-LOG
MSR-QUERY-ARG
MSR-QUERY-NAME, MSR-QUERY-NAME
MSR-QUERY-PROPS, MSR-QUERY-PROPS, MSR-QUERY-PROPS, MSR-QUERY-PROPS, MSR-QUERY-PROPS, MSR-QUERY-PROPS
MSR-QUERY-RESULT-CHAPTER
MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-1, MSR-QUERY-RESULT-P-1
MSR-QUERY-RESULT-P-2, MSR-QUERY-RESULT-P-2, MSR-QUERY-RESULT-P-2
MSR-QUERY-RESULT-TOPIC-1
MSR-QUERY-RESULT-TOPIC-2
MSR-QUERY-TEXT, MSR-QUERY-TEXT
MSRSW
MTBF
NA
NAMELOC
NCOI-1, NCOI-1
NCOI-3, NCOI-3
NMLIST
NORMATIVE-REFERENCE
NOTATION
NOTE
NUMBER
NUMBER-OF-BITS
OBJECTIVES
OPERATING-ENV, OPERATING-ENV
OPERATIONAL-REQUIREMENTS, OPERATIONAL-REQUIREMENTS
OVERALL-PROJECT
OVERVIEW
P, P, P, P
PARALLEL-DESIGNS
PHONE
POSITION
PPM
PRIVATE-CODE, PRIVATE-CODE
PRM
PRM-CHAR
PRM-REF
PRM-REFS
PRMS, PRMS, PRMS
PRODUCT-DEMARCATION
PRODUCT-DESC
PROJECT
PROJECT-DATA, PROJECT-DATA, PROJECT-DATA
PROJECT-SCHEDULE
PROTOCOLS
PUBLISHER
PURCHASING-COND
QUALITY
REALTIME-REQUIREMENTS
REASON
REASON-ORDER
REFRESH-TIMING
RELIABILITY
RELIABILITY-PRMS
REMARK, REMARK
REPLACEMENT-VALUES
REQUIREMENT, REQUIREMENT, REQUIREMENT, REQUIREMENT
REQUIREMENT-BODY
REQUIREMENT-REF, REQUIREMENT-REF
REQUIREMENT-SPEC
REQUIREMENTS-DEPENDENCY
RESOURCE-ALLOCATION
RESTRICTIONS-BY-HARDWARE
REVISION-LABEL
RIGHTS
RISKS
ROLE
ROLES
ROW
SAFETY
SAMPLE
SAMPLE-REF
SAMPLE-SPEC
SAMPLES
SCHEDULE
SD
SDG, SDG
SELF-DIAGNOSIS
SHORT-LABEL, SHORT-LABEL
SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME, SHORT-NAME
SI-UNIT, SI-UNIT, SI-UNIT
SIMILAR-PRODUCTS
SPANSPEC, SPANSPEC
SPECIAL-DATA
STANDARD-SW-MODULES
STATE
STATE-1
STD
SUB
SUBTITLE
SUP
SW-ACCESS-DEF
SW-ACCESS-DEFINITIONS, SW-ACCESS-DEFINITIONS, SW-ACCESS-DEFINITIONS
SW-ADDR-INFOS
SW-ADDR-METHOD, SW-ADDR-METHOD, SW-ADDR-METHOD, SW-ADDR-METHOD
SW-ADDR-METHOD-DESC
SW-ADDR-METHOD-REF, SW-ADDR-METHOD-REF
SW-ADDR-OFFSET
SW-ARCHITECTURE
SW-ARRAY-INDEX, SW-ARRAY-INDEX
SW-ARRAYSIZE, SW-ARRAYSIZE, SW-ARRAYSIZE
SW-AXIS-CONT
SW-AXIS-CONTS
SW-AXIS-GENERIC, SW-AXIS-GENERIC
SW-AXIS-GROUP
SW-AXIS-GROUPED, SW-AXIS-GROUPED, SW-AXIS-GROUPED, SW-AXIS-GROUPED
SW-AXIS-INDEX, SW-AXIS-INDEX, SW-AXIS-INDEX, SW-AXIS-INDEX
SW-AXIS-INDIVIDUAL, SW-AXIS-INDIVIDUAL, SW-AXIS-INDIVIDUAL
SW-AXIS-TYPE, SW-AXIS-TYPE, SW-AXIS-TYPE, SW-AXIS-TYPE, SW-AXIS-TYPE
SW-AXIS-TYPE-REF, SW-AXIS-TYPE-REF, SW-AXIS-TYPE-REF
SW-BASE-ADDR
SW-BASE-TYPE, SW-BASE-TYPE, SW-BASE-TYPE, SW-BASE-TYPE, SW-BASE-TYPE, SW-BASE-TYPE, SW-BASE-TYPE
SW-BASE-TYPE-REF, SW-BASE-TYPE-REF, SW-BASE-TYPE-REF, SW-BASE-TYPE-REF, SW-BASE-TYPE-REF
SW-BIT-REPRESENTATION, SW-BIT-REPRESENTATION, SW-BIT-REPRESENTATION, SW-BIT-REPRESENTATION, SW-BIT-REPRESENTATION
SW-CALIBRATION-ACCESS
SW-CALIBRATION-HANDLE
SW-CALIBRATION-METHOD
SW-CALIBRATION-METHOD-VERSION, SW-CALIBRATION-METHOD-VERSION
SW-CALPRM, SW-CALPRM, SW-CALPRM, SW-CALPRM, SW-CALPRM, SW-CALPRM, SW-CALPRM, SW-CALPRM
SW-CALPRM-AXIS-SET
SW-CALPRM-IMPL
SW-CALPRM-MAX-TEXT-SIZE
SW-CALPRM-NO-EFFECT-VALUE
SW-CALPRM-POINTER
SW-CALPRM-PROTOTYPE, SW-CALPRM-PROTOTYPE, SW-CALPRM-PROTOTYPE
SW-CALPRM-REF, SW-CALPRM-REF, SW-CALPRM-REF, SW-CALPRM-REF, SW-CALPRM-REF
SW-CALPRM-TARGET
SW-CALPRM-TEXT
SW-CALPRMS
sw-carb-doc
SW-CLASS, SW-CLASS, SW-CLASS, SW-CLASS, SW-CLASS, SW-CLASS
SW-CLASS-ATTR
SW-CLASS-ATTR-IMPL, SW-CLASS-ATTR-IMPL
SW-CLASS-ATTR-IMPLS
SW-CLASS-IMPL
SW-CLASS-INSTANCE, SW-CLASS-INSTANCE, SW-CLASS-INSTANCE, SW-CLASS-INSTANCE
SW-CLASS-INSTANCE-REF
SW-CLASS-METHOD, SW-CLASS-METHOD, SW-CLASS-METHOD
SW-CLASS-METHOD-ARG
SW-CLASS-METHOD-RETURN
SW-CLASS-PROTOTYPE, SW-CLASS-PROTOTYPE, SW-CLASS-PROTOTYPE
SW-CODE-SYNTAX, SW-CODE-SYNTAX, SW-CODE-SYNTAX
SW-CODE-SYNTAX-DESC
SW-CODE-SYNTAX-REF, SW-CODE-SYNTAX-REF
SW-CODE-SYNTAXES
SW-COLLECTION, SW-COLLECTION, SW-COLLECTION, SW-COLLECTION, SW-COLLECTION
SW-COLLECTION-CONT, SW-COLLECTION-CONT
SW-COLLECTION-REF, SW-COLLECTION-REF
sw-collection-refs
SW-COLLECTION-REGEXP
SW-COLLECTION-REGEXPS
SW-COLLECTION-RULE
sw-collection-rules
SW-COLLECTION-SCRIPT
SW-COLLECTION-SCRIPTS
SW-COLLECTION-WILDCARD
SW-COLLECTION-WILDCARDS
SW-COMPONENT-SPEC, SW-COMPONENT-SPEC
SW-COMPONENTS
SW-COMPU-DENOMINATOR, SW-COMPU-DENOMINATOR
SW-COMPU-IDENTITY, SW-COMPU-IDENTITY
SW-COMPU-INTERNAL-TO-PHYS
SW-COMPU-METHOD, SW-COMPU-METHOD, SW-COMPU-METHOD, SW-COMPU-METHOD, SW-COMPU-METHOD, SW-COMPU-METHOD
SW-COMPU-METHOD-REF, SW-COMPU-METHOD-REF
SW-COMPU-NUMERATOR, SW-COMPU-NUMERATOR
SW-COMPU-PHYS-TO-INTERNAL
SW-COMPU-RATIONAL-COEFFS
SW-COMPU-SCALE, SW-COMPU-SCALE, SW-COMPU-SCALE
SW-COMPU-SCALES
SW-CONSTR-LEVEL
SW-CONSTR-OBJECTS
SW-CPU-ADDR-EPK
SW-CPU-CALIBRATION-OFFSET
SW-CPU-MEM-SEG, SW-CPU-MEM-SEG, SW-CPU-MEM-SEG
SW-CPU-MEM-SEG-REF, SW-CPU-MEM-SEG-REF
SW-CPU-MEM-SEGS
SW-CPU-SPEC
SW-CS-ENTRY
SW-CS-HISTORY
SW-CS-PERFORMED-BY
SW-CS-PROGRAM-IDENTIFIER
SW-CS-PROJECT-INFO
SW-CS-STATE
SW-CS-TARGET-VARIANT
SW-CS-TEST-OBJECT
SW-CSE-CODE
SW-CSE-CODE-FACTOR
SW-DATA-CONSTR, SW-DATA-CONSTR, SW-DATA-CONSTR
SW-DATA-CONSTR-REF, SW-DATA-CONSTR-REF, SW-DATA-CONSTR-REF
SW-DATA-CONSTR-RULE
SW-DATA-CONSTRS
SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS, SW-DATA-DEF-PROPS
SW-DATA-DEPENDENCY, SW-DATA-DEPENDENCY
SW-DISPLAY-FORMAT, SW-DISPLAY-FORMAT
SW-EFFECT, SW-EFFECT
SW-EFFECT-FLOW, SW-EFFECT-FLOW
SW-EFFECTING-VARIABLE, SW-EFFECTING-VARIABLE, SW-EFFECTING-VARIABLE
SW-FEATURE, SW-FEATURE, SW-FEATURE, SW-FEATURE, SW-FEATURE, SW-FEATURE, SW-FEATURE, SW-FEATURE, SW-FEATURE, SW-FEATURE
SW-FEATURE-CALPRMS
SW-FEATURE-CLASS-INSTANCES
SW-FEATURE-DECOMPOSITION, SW-FEATURE-DECOMPOSITION, SW-FEATURE-DECOMPOSITION
sw-feature-defintion
SW-FEATURE-DESIGN-DATA
SW-FEATURE-EXPORT-CLASS-INSTANCES
SW-FEATURE-IMPORT-CLASS-INSTANCES
SW-FEATURE-LOCAL-CLASS-INSTANCES
SW-FEATURE-REF
SW-FEATURE-VARIABLES, SW-FEATURE-VARIABLES
sw-function
SW-FUNCTION-VARIANT
SW-GENERIC-AXIS-PARAM, SW-GENERIC-AXIS-PARAM
SW-GENERIC-AXIS-PARAM-TYPE, SW-GENERIC-AXIS-PARAM-TYPE
SW-GENERIC-AXIS-PARAM-TYPE-REF
SW-GENERIC-AXIS-PARAM-TYPES, SW-GENERIC-AXIS-PARAM-TYPES
SW-GENERIC-AXIS-PARAMS
SW-GLOSSARY
SW-HOST-VARIABLE
SW-IMPL-POLICY
SW-INSTANCE, SW-INSTANCE, SW-INSTANCE, SW-INSTANCE, SW-INSTANCE
SW-INSTANCE-PROPS-VARIANT, SW-INSTANCE-PROPS-VARIANT
SW-INSTANCE-PROPS-VARIANTS
SW-INSTANCE-PRPS-VARIANT
SW-INSTANCE-REF, SW-INSTANCE-REF
SW-INSTANCE-SPEC
SW-INSTANCE-TREE, SW-INSTANCE-TREE
SW-INTENDED-RESOLUTION
SW-INTERNAL-CONSTRS, SW-INTERNAL-CONSTRS
SW-INTERNAL-CONSTRS-1
SW-IS-VIRTUAL
SW-MAX-AXIS-POINTS
SW-MC-ADDR-MAPPING
SW-MC-BASE-TYPE, SW-MC-BASE-TYPE, SW-MC-BASE-TYPE, SW-MC-BASE-TYPE
SW-MC-BLOB-ECU-DEPOSIT, SW-MC-BLOB-ECU-DEPOSIT, SW-MC-BLOB-ECU-DEPOSIT, SW-MC-BLOB-ECU-DEPOSIT
SW-MC-BLOB-LAYOUTS, SW-MC-BLOB-LAYOUTS
SW-MC-BLOB-VALUE, SW-MC-BLOB-VALUE, SW-MC-BLOB-VALUE, SW-MC-BLOB-VALUE
SW-MC-COMMUNICATION-SPEC
SW-MC-DP-BLOB-LAYOUT
SW-MC-DP-BLOB-VALUE
SW-MC-FRAME
SW-MC-GENERIC-INTERFACE, SW-MC-GENERIC-INTERFACE
SW-MC-GENERIC-INTERFACES
SW-MC-INSTANCE-INTERFACE
SW-MC-INSTANCE-INTERFACES
SW-MC-INTERFACE, SW-MC-INTERFACE
SW-MC-INTERFACE-AVL-SOURCES
SW-MC-INTERFACE-DEFAULT-SOURCE
SW-MC-INTERFACE-IMPL
SW-MC-INTERFACE-SOURCE, SW-MC-INTERFACE-SOURCE
SW-MC-INTERFACE-SOURCE-REF
SW-MC-INTERFACE-SPEC
SW-MC-KP-BLOB-LAYOUT
SW-MC-KP-BLOB-VALUE
SW-MC-PA-BLOB-LAYOUT
SW-MC-PA-BLOB-VALUE
SW-MC-QP-BLOB-LAYOUT
SW-MC-QP-BLOB-VALUE
SW-MC-SYSTEM-BASE-TYPES
SW-MC-TP-BLOB-CONTS
SW-MC-TP-BLOB-LAYOUT, SW-MC-TP-BLOB-LAYOUT
SW-MC-TP-BLOB-VALUE
SW-MCD-BASE-TYPES
SW-MEM-ATTR, SW-MEM-ATTR
SW-MEM-OFFSET, SW-MEM-OFFSET
SW-MEM-PROGRAM-TYPE, SW-MEM-PROGRAM-TYPE
SW-MEM-TYPE, SW-MEM-TYPE
SW-MIN-AXIS-POINTS
SW-NUMER-OF-AXIS-POINTS, SW-NUMER-OF-AXIS-POINTS
sw-param
SW-PHYS-CONSTRS, SW-PHYS-CONSTRS, SW-PHYS-CONSTRS
SW-PHYS-CONSTRS-1
SW-PROCESS
SW-RECORD-LAYOUT, SW-RECORD-LAYOUT, SW-RECORD-LAYOUT, SW-RECORD-LAYOUT, SW-RECORD-LAYOUT
SW-RECORD-LAYOUT-FIX-VALUE
SW-RECORD-LAYOUT-GROUP, SW-RECORD-LAYOUT-GROUP, SW-RECORD-LAYOUT-GROUP, SW-RECORD-LAYOUT-GROUP, SW-RECORD-LAYOUT-GROUP, SW-RECORD-LAYOUT-GROUP, SW-RECORD-LAYOUT-GROUP
SW-RECORD-LAYOUT-GROUP-AXIS
SW-RECORD-LAYOUT-GROUP-INDEX, SW-RECORD-LAYOUT-GROUP-INDEX
SW-RECORD-LAYOUT-REF, SW-RECORD-LAYOUT-REF
SW-RECORD-LAYOUT-V, SW-RECORD-LAYOUT-V, SW-RECORD-LAYOUT-V
SW-RECORD-LAYOUT-V-AXIS
SW-RECORD-LAYOUT-V-INDEX
SW-RECORD-LAYOUT-V-PROP, SW-RECORD-LAYOUT-V-PROP
SW-RECORD-V-INDEX
SW-REFRESH-TIMING
SW-SCALE-CONSTR
SW-SIZEOF-INSTANCE
SW-SUBCOMPONENT
SW-SYSTEM, SW-SYSTEM, SW-SYSTEM, SW-SYSTEM, SW-SYSTEM, SW-SYSTEM, SW-SYSTEM
SW-SYSTEM-MC-INTERFACE-DEFAULT-SOURCE
SW-SYSTEM-MC-INTERFACE-SOURCES
SW-SYSTEMCONST, SW-SYSTEMCONST, SW-SYSTEMCONST, SW-SYSTEMCONST
SW-SYSTEMCONST-CODED-REF, SW-SYSTEMCONST-CODED-REF
SW-SYSTEMCONST-PHYS-REF, SW-SYSTEMCONST-PHYS-REF
SW-SYSTEMCONST-REF
SW-SYSTEMS
SW-TASK, SW-TASK
SW-TASK-SPEC, SW-TASK-SPEC
SW-TEMPLATE, SW-TEMPLATE, SW-TEMPLATE
SW-UNIT, SW-UNIT, SW-UNIT, SW-UNIT, SW-UNIT
SW-UNIT-CONVERSION-METHOD, SW-UNIT-CONVERSION-METHOD, SW-UNIT-CONVERSION-METHOD, SW-UNIT-CONVERSION-METHOD, SW-UNIT-CONVERSION-METHOD
SW-UNIT-REF, SW-UNIT-REF, SW-UNIT-REF, SW-UNIT-REF, SW-UNIT-REF, SW-UNIT-REF, SW-UNIT-REF, SW-UNIT-REF
SW-USER-ACCESS-CASE, SW-USER-ACCESS-CASE, SW-USER-ACCESS-CASE
SW-USER-ACCESS-CASE-REF, SW-USER-ACCESS-CASE-REF
SW-USER-ACCESS-CASES, SW-USER-ACCESS-CASES
SW-USER-GROUP, SW-USER-GROUP, SW-USER-GROUP
SW-USER-GROUP-REF, SW-USER-GROUP-REF
SW-USER-GROUPS
SW-USER-GRUOP-REFS
SW-VALUES-CODED, SW-VALUES-CODED, SW-VALUES-CODED
SW-VALUES-CODED-HEX
SW-VALUES-GENERIC
SW-VALUES-PHYS, SW-VALUES-PHYS, SW-VALUES-PHYS, SW-VALUES-PHYS
SW-VAR-NOT-AVL-VALUE
SW-VARIABLE, SW-VARIABLE, SW-VARIABLE, SW-VARIABLE, SW-VARIABLE, SW-VARIABLE, SW-VARIABLE, SW-VARIABLE
SW-VARIABLE-IMPL
SW-VARIABLE-PROTOTYPE, SW-VARIABLE-PROTOTYPE, SW-VARIABLE-PROTOTYPE
SW-VARIABLE-REF, SW-VARIABLE-REF, SW-VARIABLE-REF, SW-VARIABLE-REF, SW-VARIABLE-REF
SW-VARIABLE-REFS
sw-variables
SW-VCD-CRITERION, SW-VCD-CRITERION
SW-VCD-CRITERION-POSSIBLE-VALUES
SW-VCD-CRITERION-REF
SW-VCD-CRITERION-REFS
SW-VCD-CRITERION-VALUE
SW-VCD-CRITERION-VALUES
SW-VCD-SPEC
SYSTEM-OVERVIEW
SYSTEM-USER, SYSTEM-USER
TABLE
TBD
TBODY
TBR
TEAM-MEMBER, TEAM-MEMBER, TEAM-MEMBER, TEAM-MEMBER
TEAM-MEMBER-REF, TEAM-MEMBER-REF
TEAM-MEMBER-REFS, TEAM-MEMBER-REFS
TEAM-MEMBERS
TECHNICAL-ASPECTS
TEX-MATH
TEXT
TFOOT
TGROUP, TGROUP
THEAD
TIME-DEPENDENCY
TOL
TOPIC-1, TOPIC-1
TOPIC-2, TOPIC-2
TT
TYP
UNIT
UPPER-LIMIT
URL, URL
USED-LANGUAGES
USEFUL-LIFE
USEFUL-LIFE-PRMS
V, V
VALUE
VARIANT-CHAR
VARIANT-CHAR-ASSIGN
VARIANT-CHAR-ASSIGNS
VARIANT-CHAR-REF
VARIANT-CHAR-VALUE
VARIANT-CHARS
VARIANT-DEF
VARIANT-DEFS
VARIANT-SPEC
VERBATIM, VERBATIM, VERBATIM, VERBATIM, VERBATIM
VF, VF
VT, VT
XDOC
XFILE, XFILE, XFILE
XREF, XREF, XREF
ZIP
Sonstige
Special Data Group
Werkzeuge
CDF processor
DCI checker
mcd system
MCD-System, MCD-System, MCD-System
MCD-Systemen
MCD-Systems


Untitled

In künftigen Versionen können bei Bedarf weitere formale Anteile hinzukommen.


Untitled

Diese sind identisch mit den technischen Eigenschaften von Variablen


Untitled

Each of the following elements is described in the singular form in spite of the fact that the Data Dictionary allows multiple instances of each of them


Untitled

Diese sind identisch mit den technischen Eigenschaften von Parametern