Implement PaCo V2.1 based on ASAM-MCD-2MC 2.2

ASAM-MCD-2MC

Implement PaCo V2.1 based on ASAM-MCD-2MC 2.2
Revision: 2.1.1
This document describes, the implementation of PaCo V2.0 based on ASAM-MCD-2MC 2.0(MSRSW V2.2.2) . The document refers to Examples for PaCo V2.0 and PaCo_dtd_V2.6.dtd . The document comprises of two parts:
  • Description structured according to the specification
  • Element an Attribute description of an appropriate subset of MSRSW.DTD 2.2.2 with is the result of the common ASAM/MSR workgorup.


I. Scope

Implement PaCo V2.1 based on ASAM-MCD-2MC 2.2
I. Scope

The scope of the PaCo File Format specification (PaCo) is to identify a common ASAM standard file format that can be used to interchange applicationdata and application history between vendor-independant calibration, simulation, documentation, spreadsheet and data acquisition tools. A secondary function is to allow calibration engineers to read the file into a text or XML editor and easily change values.


I.1. Identification

This document describes how these requirements can be satisfied by applying ASAM-MCD-2MC 2.0 as a particular subset. The document is the result of the task defined by Bernhard Weichel on November 2001.


I.2. General approach

In order to illustrate the desired mapping, a subset of MSRSW.DTD was created:
  • deleting all elements not required by the PaCo use case
  • Attributes were not removed


II. How to read this document

Implement PaCo V2.1 based on ASAM-MCD-2MC 2.2
II. How to read this document

This document is divided in two parts:
1. Mapping PaCo to ASAM-MCD-2MC A general comment how MSRSW.DTD matches to PaCo-Format.

2. PaCo relevant Elements in ASAM-MCD-2MC 2.0/MSRSW.DTD 2.2.2 A description of Elements and Attributes in alphabetical order

It is recommended to start reading at 1. Mapping PaCo to ASAM-MCD-2MC.


II.1. Terminology


II.2. Additional Documentation

For further information refer to additional documentation available:
  • An introduction to the ASAM-MCD-2MC.DTD/MSRSW.DTD in particular dedicated to an ASAP based audience ( ASAP2 V2.x, MSRSW V2.2.0 DTD final release ). One should probably start reading this.
  • The documentation to MSRDCI as finished so far. Structured Principles for the MSR - DCI . This may help to obtain an initial understanding of the MSRDCI approach.
  • The design rules for MSR DTDs, given in Concepts of the MSR application profile V2.x.x
  • The elements and attributes are described in MSRSW.DTD Elements and attributes

" " " "


III. The following conventions apply

Implement PaCo V2.1 based on ASAM-MCD-2MC 2.2
III. The following conventions apply

This document is written using MSRREP.DTD. The following conventions apply to this document:
<msrsw> SGML elements are noted as technical term [type]=SGMLTAG.

[type] SGML attributes are noted as technical term [type]=SGML-attribute.

sgml-attribute Values of SGML attributes or discrete values for elements are noted as technical term [type]=code

ASAM-MCD-2MC 2.0 The considered languages resp. DTDs are marked as technical term [type]=product.

ASAM The committees are noted as [type]=organization

CDF Keywords from CDF are marked as technical term [type]=code.

ECU Objects in general are marked as technical terms [type]=other. This might be automotive equipments general objects such as variables etc.

Note that an index of the technical terms is given at the end of the document.


III.1. Graphical conventions used in DTD diagrams

Since a DTD represents a grammar, it can be visualized graphically as a tree. The visualization in this document uses the notation given in Graphical notation of DTDs.
Figure 1: Graphical notation of DTDs
The meaning of the symbols is:
PCDATA | The element content is Processable Character Data (PCDATA). This is data that consists of zero or more characters of both text and markup. PCDATA is used to indicate that all markup delimiters defined in the SGML declaration will be recognized by the parser as markup in the given element rather than data characters.
RCDATA | The element content is Replaceable Character Data (RCDATA) . this is data that consists of zero or more characters, in which references to substitutions are not recognized (i.e. RCDATA may contain text and entity references (starting with "&") , but no sub-elements) [image] .
CDATA | Character Data (CDATA) consists of zero or more text characters, where no markup of any kind is recognized.
ANY | a terminal type indicating that the object may contain text or any element defined in the model [image] .
EMPTY | a terminal type keyword used to indicate that there is no data (i.e. no content, sub-elements or end-tags) for the object allowed in the document instance. This keyword is often used to describe elements that are placeholders or are pointers to external or system-generated data.
One | indicates that the element or the model group occurs exactly once.
ZERO-OR-ONE | indicates that the element or the model group is optional.
ONE-OR-MORE | indicates that the element or the model group occurs multiple times but at least once.
ZERO-OR-MORE | indicates that the element or the model group occurs multiple times but also can be missed (optional).
ORDERED | a connector used to specify that the sibling objects must appear in the document in the order shown in the model.
UNORDERED | a connector used to specify that the sibling objects can appear in any order in the document [image] .
SELECTION | a connector used to specify that only one of the sibling objects can appear in the document.
ELEMENT | indicates a single SGML structure element.
COLLAPSED | indicates, that the content of the element is not displayed here.
Hint
With respect to XML compliance, the following features are not used:
RCDATA, CDATA, ANY, EMPTY, UNORDERED connection,

UNODERED is not used in the DTDs described here, since it is not conforming with XML.
ANY is not used in the DTDs described here.
RCDATA is not used in the DTDs described here.


IV. Document management

Implement PaCo V2.1 based on ASAM-MCD-2MC 2.2
IV. Document management

Team members
Name | Company | {CONTACT}
Markus Müller | Robert Bosch GmbH | Phone: +(49) 711 81135582 Department: Robert Bosch GmbH, GS/EMW3 Markus.Mueller1@de.bosch.com
Version overview
Version | Date | Editor | State
2.1.1 | 26.07.2006 | Markus Müller | freigegeben
2.1.0 | 12.07.2004 | Markus Müller | Freigegeben
12 | 2003-12-12 | Markus Müller | Freigegeben
11 | 2003-11-26 | Markus Müller | Freigegeben
10 | 2003-05-26 | Markus Müller | Geprueft
9 | 2003-01-20 | Markus Müller | submitted
8 | 2003-01-10 | Markus Müller | submitted
7 | 2002-07-05 | Markus Müller | submitted
6 | 2002-03-25 | Markus Müller | locked
5 | 2002-03-12 | Markus Müller | initial draft
4 | 2002-01-30 | Markus Müller | initial draft
3 | 2002-01-30 | Markus Müller | initial draft
2 | 2002-01-30 | Markus Müller | initial draft
1 | 2002-01-10 | Markus Müller | initial draft
Modifications
Version
Change
Related to
2.1.1
Change the note in 2.52. SW-CS-HISTORY about the interpretation of the sequence of <SW-CS-ENTRY>s
Reason: All Tools supporting PaCo do it the other way round
Content
2.1.0
Integration of [SW_COMPONENT] as a legal value für <CATEGORY> in <SW-INSTANCE> .
Reason: This will replace the strategie of representing function oriented calibration documentation in several <SW-INSTANCE-TREE>s.
Content
Deleting the hint about the strategie of representing function oriented calibration documentation in several <SW-INSTANCE-TREE>s. in 2.66. SW-INSTANCE-TREE
Reason: Replacement of the strategie of representing function oriented calibration documentation in several <SW-INSTANCE-TREE>s.
Content
Inserting a note in 2.52. SW-CS-HISTORY about the interpretation of the sequence of <SW-CS-ENTRY>s
Reason: The <SW-CS-ENTRY> with ne nearest value in <DATE> must not be the one that had been inserted last.
Content
Inserting a note in 2.56. SW-CS-STATE how to interpret the state of <SW-INSTANCE>s without a <SW-CS-STATE>.
Content
12
Rework of the examples.
Reason: Several inconsistencies in the examples.
Content
11
Inserting 2.87. VT als legal content in 2.86. VG and 2.73. SW-VALUES-PHYS .
Reason: Bugfix, VT is necessary <SW-INSTANCE> with <CATEGORY> [ASCII]
Content
10
Extending 2.62. SW-INSTANCE with a new example for class support and a few notes.
Content
Update of date-field
Reason: wrong format
Content
rearranged admin-data
Reason: place the recent revision on top
Content
9
Changing wrong Character set definition ISO-8850-1 in 1.1.1. Character Set Definitionto the correct definition ISO-8859-1
Content
8
Extending 2.66. SW-INSTANCE-TREE whith a description of the mechanisem to mange calibration items function oriented in PaCo
Content
Extending 2.61. SW-FEATURE-REF whith a description of the mechanisem to mange calibration items function oriented in PaCo
Content
7
Postition of <CATEGORY> in <SW-INSTANCE> corrected
Reason: Position of <CATEGORY> must be before <SW-FEATURE-REF>
Content
Adding explicit legal Values for <CATEGORY> in <SW-INSTANCE> and <SW-CS-STATE>
Reason: Neccessary for a worldwide uniform standard and meaning
Content
6
Integrating changes from MSR-SW 2.2.2
Reason: Be up to date with MSR-SW.
Content
5
Removing several chapters
Reason: Modification of PaCo_DTD up to Version 2.3
Content
Editing several chapters
Reason: Notes from B. Weichel, 06.02.2002
Content
Editing Several Chapters
Reason: Notes from K. Pinnow, 11.03.2002
Content
4
Removing several chapters
Reason: Modification of PaCo_DTD up to Version 2.2
Content
3
Fixing document code
Reason: Errors while processing
Document
2
Fixing document code
Reason: Errors while processing
Document
1
Created the document
Reason: According to question from Bernhard Weichel GS/EMW4
Content
Modifications included
Date
Chapter
Change
Related to
26.07.2006
Gesamt
Change the note in 2.52. SW-CS-HISTORY about the interpretation of the sequence of <SW-CS-ENTRY>s
Reason: All Tools supporting PaCo do it the other way round
Content
12.07.2004
Gesamt
Integration of [SW_COMPONENT] as a legal value für <CATEGORY> in <SW-INSTANCE> .
Reason: This will replace the strategie of representing function oriented calibration documentation in several <SW-INSTANCE-TREE>s.
Content
Deleting the hint about the strategie of representing function oriented calibration documentation in several <SW-INSTANCE-TREE>s. in 2.66. SW-INSTANCE-TREE
Reason: Replacement of the strategie of representing function oriented calibration documentation in several <SW-INSTANCE-TREE>s.
Content
Inserting a note in 2.52. SW-CS-HISTORY about the interpretation of the sequence of <SW-CS-ENTRY>s
Reason: The <SW-CS-ENTRY> with ne nearest value in <DATE> must not be the one that had been inserted last.
Content
Inserting a note in 2.56. SW-CS-STATE how to interpret the state of <SW-INSTANCE>s without a <SW-CS-STATE>.
Content
2003-12-12
Gesamt
Rework of the examples.
Reason: Several inconsistencies in the examples.
Content
2003-11-26
Gesamt
Inserting 2.87. VT als legal content in 2.86. VG and 2.73. SW-VALUES-PHYS .
Reason: Bugfix, VT is necessary <SW-INSTANCE> with <CATEGORY> [ASCII]
Content
2003-05-26
Gesamt
Extending 2.62. SW-INSTANCE with a new example for class support and a few notes.
Content
Update of date-field
Reason: wrong format
Content
rearranged admin-data
Reason: place the recent revision on top
Content
2003-01-20
Gesamt
Changing wrong Character set definition ISO-8850-1 in 1.1.1. Character Set Definitionto the correct definition ISO-8859-1
Content
2003-01-10
Gesamt
Extending 2.66. SW-INSTANCE-TREE whith a description of the mechanisem to mange calibration items function oriented in PaCo
Content
Extending 2.61. SW-FEATURE-REF whith a description of the mechanisem to mange calibration items function oriented in PaCo
Content
2002-07-05
Gesamt
Postition of <CATEGORY> in <SW-INSTANCE> corrected
Reason: Position of <CATEGORY> must be before <SW-FEATURE-REF>
Content
Adding explicit legal Values for <CATEGORY> in <SW-INSTANCE> and <SW-CS-STATE>
Reason: Neccessary for a worldwide uniform standard and meaning
Content
2002-03-25
Gesamt
Integrating changes from MSR-SW 2.2.2
Reason: Be up to date with MSR-SW.
Content
2002-03-12
Gesamt
Removing several chapters
Reason: Modification of PaCo_DTD up to Version 2.3
Content
Editing several chapters
Reason: Notes from B. Weichel, 06.02.2002
Content
Editing Several Chapters
Reason: Notes from K. Pinnow, 11.03.2002
Content
2002-01-30
Gesamt
Removing several chapters
Reason: Modification of PaCo_DTD up to Version 2.2
Content
2002-01-30
Gesamt
Fixing document code
Reason: Errors while processing
Document
2002-01-30
Gesamt
Fixing document code
Reason: Errors while processing
Document
2002-01-10
Gesamt
Created the document
Reason: According to question from Bernhard Weichel GS/EMW4
Content


1. Mapping PaCo to ASAM-MCD-2MC

Implement PaCo V2.1 based on ASAM-MCD-2MC 2.2
1. Mapping PaCo to ASAM-MCD-2MC

Contents of this chapter:
  • 1.1. File format
  • 1.2. XML Schemas and Namespaces


1.1. File format

MSRSW.DTD can be used as SGML as well as XML. The difference is mainly in the tools which are used. The instances are are compatible between XML and SGML.


1.1.1. Character Set Definition

When used in XML style, the PaCo file may be encoded in any of the character sets permitted for XML. In western countries usage of ISO-8859-1 is a good choice. XML recommendation specifies UTF-8 as default, but this prevents non unicode edtitors from safely handling the files.


1.1.2. General

If no information is available, then the field shall be left out. For this reason, every element is kept optional. The omission of an element is much easier to detect than the fact that an element is empty (e.g. because of insignificant whit space).
The general structure of the file is given in the following illustration:
Figure 2: General structure
<MSRSW> is the root element of the file. Mainly it consists of the following sections:
<SHORT-NAME> | A short designator of the file. Usually this is something like filename body a project identifier.
<CATEGORY> | This is denotes the category of the file.
<ADMIN-DATA> | This denotes all administrative data related to the current file.
<PROJECT-DATA> | This denotes all project data related to the current file.
<SW-SYSTEMS> | This section receives the intended content of the PaCo file.


1.1.3. Filename Definition

The file shall be saved according to committed conventions.
it is recommended to kee the extension as XML because most XML tools refer to this extension. The file could be marked as PaCo file by adding .paco before the extension:
Example: mycalibrations.paco.xml


1.2. XML Schemas and Namespaces

The DTD and schemas of released file formats shall be stored on the ASAM web server. Each file instance is required to supply a reference to the governig schema or DTD by an appropriate DOCTYPE declaration. By this, PaCo instances are required to be valid XML documents.
XML schema as well as DTD is not strong enough to specifiy all details. Therefore it is recommended also to use Document Content Information.
Hint
There are not many XML tools around which really support namespaces. It is therefore recommended not to request a namespace-attribute. In conjunction with a general ASAM-XML strategy, this item should be worked out.


2. PaCo relevant Elements in ASAM-MCD-2MC 2.0/MSRSW.DTD 2.2.2

Implement PaCo V2.1 based on ASAM-MCD-2MC 2.2
2. PaCo relevant Elements in ASAM-MCD-2MC 2.0/MSRSW.DTD 2.2.2

This chapter describes all proposed elements in alphabetical order.


2.1. ADDRESS
Description Example Properties

Description
<ADDRESS> can be used to describe the street of the company of a team-member.
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.81. TEAM-MEMBER
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature aof an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.2. ADMIN-DATA

Description
<ADMIN-DATA> can be used to capture all information regarding document management such as used language and versioning.
Example

<ADMIN-DATA>
  <LANGUAGE>en</LANGUAGE>

  <COMPANY-DOC-INFOS>
         <COMPANY-DOC-INFO>
          <COMPANY-REF>RB</COMPANY-REF>
            <PRIVATE-CODES>
        <PRIVATE-CODE>Version 12.3</PRIVATE-CODE>
            </PRIVATE-CODES>
         </COMPANY-DOC-INFO>
     </COMPANY-DOC-INFOS>

  <DOC-REVISIONS>
    <DOC-REVISION>
      <REVISION-LABEL>2</REVISION-LABEL>
      <STATE>review-candiate</STATE>
      <TEAM-MEMBER-REF ID-REF="wl">Wl</TEAM-MEMBER-REF>
      <DATE>2001.08.15</DATE>
      <MODIFICATIONS>
        <MODIFICATION>
          <CHANGE>fixed typos</CHANGE>
          <REASON>typos were found in the  internal review</REASON>
        </MODIFICATION>
      </MODIFICATIONS>
    </DOC-REVISION>

    <DOC-REVISION>
      <REVISION-LABEL>1</REVISION-LABEL>
      <STATE>initial draft</STATE>
      <TEAM-MEMBER-REF ID-REF="wl">Wl</TEAM-MEMBER-REF>
      <DATE>2001.08.12</DATE>
      <MODIFICATIONS>
        <MODIFICATION>
          <CHANGE>Created the document</CHANGE>
          <REASON>According to video-conference held at Jul 2001</REASON>
        </MODIFICATION>
      </MODIFICATIONS>
    </DOC-REVISION>
  </DOC-REVISIONS>
  </ADMIN-DATA>
Properties
Within context of: | 2.28. MSRSW , 2.60. SW-FEATURE
Is context for: | 2.24. LANGUAGE , 2.9. COMPANY-DOC-INFOS , 2.17. DOC-REVISIONS
Attributes |
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.3. CATEGORY

Description
<CATEGORY> allows to denote specific, mainly process dependant modes of its parent element. This can be used by generic checkers (e.g. a DCI checker) to perform a more detailed evaluation of the substructure.The possible values are also described at the parent elements.
<CATEGORY> in <MSRSW> shall reflect the nature of the File according to asam 1.4 with extensions. It should be PaCo.
<CATEGORY> in <SW-INSTANCE> shall reflect the nature of the instance according to asam 1.4 with extensions. It could be such as map, curve, ... but also variable-map if more advanced application.
<CATEGORY> in <SW-INSTANCE-TREE> may reflect the nature of the intance tree such as test-data, adress-info, ...
Example
The following example woud mark an MSRSR-File as an PaCo file.

<MSRSW>
  <CATEGORY>PACO</CATEGORY>
  ...
<MSRSW>
Properties
Within context of: | 2.28. MSRSW , 2.62. SW-INSTANCE , 2.66. SW-INSTANCE-TREE
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.4. CHANGE
Description Properties

Description
<CHANGE> can be used to describe the change performed in one particular modification.
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.26. MODIFICATION
Is context for: | Text, 2.84. TT , 2.18. E , 2.42. SUP , 2.41. SUB , 2.22. IE
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.5. CITY
Description Properties

Description
<City> can be used to describe the city of the company of a team-member.
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.81. TEAM-MEMBER
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.6. COMPANIES
Description Properties

Description
<COMPANIES> can be used to describe the companies being involved in the project. This is used mainly to specify copyright information and the involved persons. Usually there is more than one company involved in the project. The company which generated the file is determined by following <TEAM-MEMBER-REF> within <ADMIN-DATA>. In simple cases there is only one company, so this lookup is not really necessary.
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.32. PROJECT
Is context for: | 2.7. COMPANY
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.7. COMPANY
Description Properties

Description
<COMPANY> can be used to describe general company info and projectinfo.
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.6. COMPANIES
Is context for: | 2.25. LONG-NAME , 2.38. SHORT-NAME , 2.83. TEAM-MEMBERS
Name
Type
Values / Default
Notes
[ROLE]
required
Value selection (NAMEDTOKENGROUP)
  • MANUFACTURER
  • SUPPLIER
Wählen Sie MANUFACTURER aus, wenn das projektbeiteiligte Unternehmen ein Hersteller/ Partner ist.
Wählen Sie SUPPLIER aus, wenn das projektbeiteiligte Unternehmen ein Lieferant ist.
[ID]
required
ID (ID)
Clear identification of an element inside a document.
[VIEW]
optional
String (CDATA)
Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S]
optional
String (CDATA)
Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T]
optional
String (CDATA)
dd-mm-yyyyThh:mm:ss
dd/mm/yyyyThh:mm:ss
dd mm yyyyThh:mm:ss
Timestamp
[F-ID-CLASS]
fixed value
SGML string (NMTOKEN)
COMPANY
Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID- CLASS="TEAM-MEMBER">...</ TEAM-MEMBER- REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS=" TEAM-MEMBER">...</ TEAM-MEMBER>.
[F-NAMESPACE]
fixed value
SGML strings (NMTOKENS)
TEAM-MEMBER
Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/ sw-var1')
[F-CHILD-TYPE]
fixed value
String (CDATA)
LONG-NAME:SELECTION
Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/ sw-var1')


2.8. COMPANY-DOC-INFO
Description Properties

Description
<COMPANY-DOC-INFO> can be used to describe documentinfos of the involved companies.
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.9. COMPANY-DOC-INFOS
Is context for: | 2.9. COMPANY-DOC-INFOS , 2.30. PRIVATE-CODE
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.9. COMPANY-DOC-INFOS
Description Properties

Description
<COMPANY-DOC-INFOS> can be used to sum up documentinfos of the involved companies.
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.2. ADMIN-DATA
Is context for: | 2.8. COMPANY-DOC-INFO
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.10. COMPANY-REF
Description Properties

Description
<COMPANY-REF> can be used to link to the company for which is the documentinfos are made of.
Caution
The content of <COMPANY-REF> must follow the restrictions of <SHORT-NAME>, in particular must not contain whitespace and special characters.
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.8. COMPANY-DOC-INFO , 2.11. COMPANY-REVISION-INFO
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] required | ID reference (IDREF) |  | Link on an element in the document which is marked with an ID-Attribute
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | COMPANY | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID- CLASS="TEAM-MEMBER">...</ TEAM-MEMBER- REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS=" TEAM-MEMBER">...</ TEAM-MEMBER>.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/ Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.


2.11. COMPANY-REVISION-INFO
Description Properties

Description
<COMPANY-REVISION-INFO> can be used to describe the level of the documentinfos in the involved company.
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.12. COMPANY-REVISION-INFOS
Is context for: | 2.10. COMPANY-REF , 2.35. REVISION-LABEL , 2.40. STATE
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.12. COMPANY-REVISION-INFOS
Description Properties

Description
<COMPANY-REVISION-INFOS> allows to maintain company specific revision information. This supports the use case where each party involved uses a version management system of its own as well as its own versioning scheme. This approach allows a simultaneous versioning where all revision information remains visible and referrable.
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.16. DOC-REVISION
Is context for: | 2.11. COMPANY-REVISION-INFO
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.13. DATE

Description
<DATE> ist used to capture a time stamp. It must match to one of the following syntaxes:
<YYYY>-<MM>-<DD>[T<hh>:<mm>:<ss>]

<YYYY>.<MM>.<DD>[T<hh>:<mm>:<ss>]

<YYYY>/<MM>/<DD>[T<hh>:<mm>:<ss>]
The last pattern is the most preferred one, since it reflects a common use in US.
Example
<DATE>2001-03-20T09:00:00</DATE>
Or for an example, see 2.52. SW-CS-HISTORY .
Properties
Within context of: | 2.16. DOC-REVISION , 2.50. SW-CS-ENTRY
Is context for: | Text
Name | Type | Type | Notes
[SI] optional | String (CDATA) |  | Beschreibung der Semantischen Bedeutung eines Elements.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.14. DEPARTMENT

Description
<DEPARTMENT> can be used to describe thedepartment of a team-member.
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.81. TEAM-MEMBER
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.15. DESC

Description
<DESC> represents a general but brief description of the object in question. With respect of PaCo it is only used within <PROJECT> thus allowing to specify a brief overview of the project.
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.32. PROJECT
Is context for: | Text, 2.84. TT , 2.18. E , 2.42. SUP , 2.41. SUB , 2.22. IE
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.16. DOC-REVISION

Description
<DOC-REVISION> gets all information about one particular revision of the file.
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.17. DOC-REVISIONS
Is context for: | 2.12. COMPANY-REVISION-INFOS , 2.82. TEAM-MEMBER-REF , 2.13. DATE , 2.27. MODIFICATIONS
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.17. DOC-REVISIONS

Description
<DOC-REVISIONS> is a container to get the entire change-history. Although the sequence of changes can be determined by sorting <DOC-REVISIONS> according to <DOC-REVISION>/<DATE>, it is recommended to put the most recent <DOC-REVISION> as the first child of <DOC-REVISIONS>.
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.2. ADMIN-DATA
Is context for: | 2.16. DOC-REVISION
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.18. E

Description
<E> can be used to emphasize a textual part of a paragraph.
Example
Properties
Within context of: | 2.4. CHANGE , 2.15. DESC , 2.25. LONG-NAME , 2.34. REASON
Is context for: | Text
Name
Type
Values / Default
Notes
[TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • BOLD
  • ITALIC
Verwenden Sie BOLD, um fett hervorzuheben Verwenden Sie ITALIC, um kursiv hervorzuheben
[SI]
optional
String (CDATA)
Beschreibung der Semantischen Bedeutung eines Elements.
[VIEW]
optional
String (CDATA)
Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S]
optional
String (CDATA)
Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T]
optional
String (CDATA)
dd-mm-yyyyThh:mm:ss
dd/mm/yyyyThh:mm:ss
dd mm yyyyThh:mm:ss
Timestamp


2.19. EMAIL

Description
<EMAIL> can be used to describe the e-mail address of a team-member.
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.81. TEAM-MEMBER
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.20. FAX

Description
<FAX> can be used to describe the fax-number of a team-member.
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.81. TEAM-MEMBER
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.21. HOMEPAGE

Description
<HOMEPAGE> can be used to describe the homepage of a team-member.
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.81. TEAM-MEMBER
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.22. IE

Description
<IE> can be used to declare the element as an entry in the Document-Index.
Example
Properties
Within context of: | 2.4. CHANGE , 2.15. DESC , 2.25. LONG-NAME , 2.34. REASON
Is context for: | Text, 2.42. SUP , 2.41. SUB
Name
Type
Values / Default
Notes
[TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • BOLD
  • ITALIC
Gibt einen Typ des jeweiligen Elementes an.
[SI]
optional
String (CDATA)
Beschreibung der Semantischen Bedeutung eines Elements.
[VIEW]
optional
String (CDATA)
Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S]
optional
String (CDATA)
Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T]
optional
String (CDATA)
dd-mm-yyyyThh:mm:ss
dd/mm/yyyyThh:mm:ss
dd mm yyyyThh:mm:ss
Timestamp


2.23. LABEL

Description
<LABEL> is used as a long designator (similar to <LONG-NAME>) for objects which cannot be referenced. In this case it is the name of the corresponding project.
<LABEL> in <PROJECT> shall reflect the identifier of the Project. It could be such as Volvo Turnkey.
<LABEL> in <VG> shall reflect the constant value of one axis. It is used to raise the readability of PaCo in an Editor
Example
Properties
Within context of: | 2.32. PROJECT , 2.86. VG
Is context for: | Text, 2.84. TT , 2.18. E , 2.42. SUP , 2.41. SUB , 2.22. IE
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.24. LANGUAGE

Description
<LANGUAGE> represents the human language used within the file. It is mainly used to cause the tools to switch to an appropriate language.
This element follows ISO 639-1 two letter language codes ( Codes for the Representation of Names of Languages ). Mostly used codes are given in Most common language codes (alphabetical):
Most common language codes (alphabetical)
Code | Language
de | German
en | English
es | Spanish
fr | French
it | Italian
jp | Japanese
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.2. ADMIN-DATA
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.25. LONG-NAME

Description
<LONG-NAME> is used as a long designate for object such as companies, calibration Items.
Example
For an example, see .
Properties
Within context of: | 2.7. COMPANY , 2.60. SW-FEATURE , 2.62. SW-INSTANCE , 2.67. SW-SYSTEM , 2.75. SW-VCD-CRITERION , 2.81. TEAM-MEMBER
Is context for: | Text, 2.84. TT , 2.18. E , 2.42. SUP , 2.41. SUB , 2.22. IE
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.26. MODIFICATION

Description
<MODIFICATION> describes the modification of the file related to the predescessor.
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.27. MODIFICATIONS
Is context for: | 2.4. CHANGE , 2.34. REASON
Name
Type
Legal Values
Notes
[TYPE]
required
Value selection (NAMEDTOKENGROUP)
  • CONTENT-RELATED
  • DOC-RELATED
This attribute describes the level of the modification. In particular, this allows to specify, if the modification is relevant to the described systems.
[VIEW]
optional
String (CDATA)
Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S]
optional
String (CDATA)
Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T]
optional
String (CDATA)
dd-mm-yyyyThh:mm:ss
dd/mm/yyyyThh:mm:ss
dd mm yyyyThh:mm:ss
Timestamp


2.27. MODIFICATIONS

Description
<MODIFICATIONS> represents the container which receives all <MODIFICATION>s.
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.16. DOC-REVISION
Is context for: | 2.26. MODIFICATION
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.28. MSRSW

Description
<MSRSW> is the root element of the file. Mainly it consists of the following sections:
<SHORT-NAME> | A short designator of the file. Usually this is something like filename body a project identifier.
<CATEGORY> | <CATEGORY> in <MSRSW> shall reflect the nature of the File according to asam 1.4 with extensions. It should be PaCo.
<PROJECT-DATA> | This denotes all organisational and project relevant data.
<ADMIN-DATA> | This denotes al administrative data related to the current file.
<SW-SYSTEMS> | This section receives the hole application dokumentation. As an extension it supports multiple ECUs within one file.
Example
<MSRSW>
  <SHORT-NAME>DEMO</SHORT-NAME>

  <ADMIN-DATA>
     <LANGUAGE>en</LANGUAGE>
  </ADMIN-DATA>
  <SW-SYSTEMS>
     <SW-SYSTEM>
       <SHORT-NAME>DEMO</SHORT-NAME>
       <SW-INSTANCE-SPEC>
       <SW-INSTANCE-TREE>
          <SHORT-NAME>DEMODATA</SHORT-NAME>
          <SW-INSTANCE><SHORT-NAME>FBAM</SHORT-NAME>
             <CATEGORY>MAP</CATEGORY>
             <SW-INSTANCE-PROPS-VARIANTS>
               <SW-INSTANCE-PROPS-VARIANT>
                 ...
               </SW-INSTANCE-PROPS-VARIANT></SW-INSTANCE-PROPS-VARIANTS>
          </SW-INSTANCE>
       </SW-INSTANCE-TREE>

       <SW-INSTANCE-TREE>
          <SHORT-NAME>Testdata</SHORT-NAME>
          <SW-INSTANCE><SHORT-NAME>FBAM</SHORT-NAME>
             <CATEGORY>MAP</CATEGORY>
             <SW-INSTANCE-PROPS-VARIANTS>
               <SW-INSTANCE-PROPS-VARIANT>
                 ...
               </SW-INSTANCE-PROPS-VARIANT></SW-INSTANCE-PROPS-VARIANTS>
          </SW-INSTANCE>
       </SW-INSTANCE-TREE>
     </SW-SYSTEM>
  </SW-SYSTEMS>
</MSRSW>
Properties
Within context of: | Root
Is context for: | 2.38. SHORT-NAME , 2.3. CATEGORY , 2.33. PROJECT-DATA , 2.2. ADMIN-DATA , 2.68. SW-SYSTEMS
Name | Type | Values / Default | Notes
[PUBID] has default value | String (CDATA) | -//MSR//DTD MSR SOFTWARE DTD:V2.2.0:MSRSW.DTD//EN | Public Identifier. Dieser ist im Gegensatz zu [F-PUBID] durch eine Applikation veränderbar.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp
[F-PUBID] fixed value | String (CDATA) | -//MSR//DTD MSR SOFTWARE DTD:V2.2.0:MSRSW.DTD//EN | Fixed Public ID. Dieser ist im Gegensatz zu [PUBID] nicht veränderbar und beinhaltet den Public Identifier der aktuellen MSRSW.DTD.
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | CHAPTER COMPANY DEF-ITEM EXTERNAL FIGURE FORMULA PRM REQUIREMENT SAMPLE SDG STD SW-ADDR-METHOD SW-AXIS-TYPE SW-BASE-TYPE SW-CALPRM SW-CALPRM-PROTOTYPE SW-CLASS-PROTOTYPE SW-CLASS-ATTR-IMPL SW-CLASS-INSTANCE SW-CLASS SW-CODE-SYNTAX SW-COLLECTION SW-COMPU-METHOD SW-CPU-MEM-SEG SW-DATA-CONSTR SW-FEATURE SW-GENERIC-AXIS-PARAM-TYPE SW-INSTANCE-TREE SW-INSTANCE SW-MC-BASE-TYPE SW-MC-INTERFACE-SOURCE SW-MC-INTERFACE SW-RECORD-LAYOUT SW-SYSTEM-CONST SW-SYSTEM SW-TASK SW-TEMPLATE SW-UNIT SW-USER-ACCESS-CASE SW-USER-GROUP SW-VARIABLE-PROTOTYPE SW-VARIABLE SW-VCD-CRITERION TABLE TEAM-MEMBER TOPIC VARIANT-DEF VARIANT-CHAR XDOC XFILE | Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/ sw-var1')
[HYTIME] fixed value | SGML string (NMTOKEN) | HYDOC | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/ Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.


2.29. PHONE

Description
<PHONE> can be used to describe the phone-number of a team-member.
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.81. TEAM-MEMBER
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.30. PRIVATE-CODE

Description
<PRIVATE-CODE> can be used to describe special adjusted systems or processes.
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.30. PRIVATE-CODE
Is context for: | Text
Name | Type | Type | Notes
[TYPE] optional | String (CDATA) |  | Gibt einen Typ des jeweiligen Elementes an.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.31. PRIVATE-CODES

Description
<PRIVATE-CODES> can be used to sum up the discriptions for special adjusted systems or processes.
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.8. COMPANY-DOC-INFO
Is context for: | 2.30. PRIVATE-CODE
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.32. PROJECT

Description
Use <PROJECT> to describe the project configuration.
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.33. PROJECT-DATA
Is context for: | 2.23. LABEL , 2.15. DESC , 2.6. COMPANIES
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.33. PROJECT-DATA

Description
Use <PROJECT-DATA> to capture information about the project the file belongs to.
Example
<PROJECT-DATA>
     <PROJECT><LABEL>Demo project for PaCo file format with MSRSW.DTD</LABEL>
        <DESC>Tthis project is used to illustrate how PaCo format can be defined
          by following the structures of ASAM-MCD-2MC 2.0 resp. MSRSW.DTD 2.2.0 </DESC>
        <COMPANIES>
          <COMPANY ROLE=""SUPPLIER"" ID=""rb"">
             <LONG-NAME>Robert Bosch GmbH</LONG-NAME>
             <SHORT-NAME>Bosch</SHORT-NAME>
             <TEAM-MEMBERS>
                <TEAM-MEMBER ID=""wl"">
                  <LONG-NAME>Markus Müller</LONG-NAME>
                  <SHORT-NAME>Ml</SHORT-NAME>
                  <ROLES>
                     <ROLE>Author</ROLE>
                  </ROLES>
                  <DEPARTMENT>GS/EMW3</DEPARTMENT>
                  <ADDRESS>Robert-Bosch-Strasse 2</ADDRESS>
                  <ZIP>71701</ZIP>
                  <CITY>Schwieberdingen</CITY>
                  <PHONE>(0711)811-35582</PHONE>
                  <FAX>(0711)811-8262</FAX>
                  <EMAIL>markus.mueller1@de.bosch.com</EMAIL>
                  <HOMEPAGE>www.mypage.net</HOMEPAGE>
                </TEAM-MEMBER>
             </TEAM-MEMBERS>
          </COMPANY>
        </COMPANIES>
     </PROJECT>
  </PROJECT-DATA>
Properties
Within context of: | 2.28. MSRSW
Is context for: | 2.32. PROJECT
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.34. REASON

Description
Use <REASON> to specify the reason of a particular modification.
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.26. MODIFICATION
Is context for: | Text, 2.84. TT , 2.18. E , 2.42. SUP , 2.41. SUB , 2.22. IE
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.35. REVISION-LABEL

Description
<REVISION-LABEL> is used to denote version number of the current file.
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.11. COMPANY-REVISION-INFO
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.36. ROLE

Description
<ROLE> denotes one particular role taken by the team member in question within the current project. Roles are such as "Author", "Calibration engineer", "Supporter", "Quality assurance".
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.37. ROLES
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.37. ROLES

Description
<ROLES> is the container for all roles one particular team member takes within the project.
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.81. TEAM-MEMBER
Is context for: | 2.36. ROLE
Name | Type | Values / Default | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp
[F-CHILD-TYPE] fixed value | String (CDATA) | ROLE:SELECTION | Fixed Child Type. Warning: This attribute is only in the DTD for compatibility with older versions of the DTD and should not be used for any new implementations. It might be removed in future versions of the DTD.This attribute contains the information which child elements of the element carring this attribute should be checked by an semantic checker.


2.38. SHORT-NAME

Description
<SHORT-NAME> represents a short designator for objects which can be referred to.
Example
For an example, see 2.62. SW-INSTANCE .
Properties
Within context of: | 2.7. COMPANY , 2.28. MSRSW , 2.60. SW-FEATURE , 2.62. SW-INSTANCE , 2.66. SW-INSTANCE-TREE , 2.67. SW-SYSTEM , 2.69. SW-UNIT , 2.75. SW-VCD-CRITERION , 2.81. TEAM-MEMBER
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.39. SI-UNIT

Description
<SI-UNIT> specifies a measurement founded on seven SI base units for seven base quantities assumed to be mutually independent, as given in Table 1.
base quantities for SI units
Base quantity | Name | Symbol
length | meter | m
mass | kilogram | kg
time | second | s
electric current | ampere | A
thermodynamic temperature | kelvin | K
amount of substance | mole | mol
luminous intensity | candela | cd
The quantitiy exponents are speicified in appropriate attributes.Die Maßeinheiten-Exponenten werden über die entsprechenden spezifischen Attribute bestimmt.
Eine <SW-UNIT> kann sowohl auf Basis einer <SI-UNIT> als auch auf einer anderen beliebigen Maßeinheit mittels der Referenz <SW-UNIT-REF> definiert werden. Dabei ist zu beachten:
  • Bei Verwendung von referenzierten Maßeinheiten muß die Kette der Verweise bei einer <SI-UNIT> enden.
  • Die Umrechnung der aktuellen Maßeinheit in die referenzierte Maßeinheit wird spezifizert durch <SW-UNIT-CONVERSION-METHOD>.
    Dabei gilt: Umrechnung von Maßeinheiten
    SW-UNIT = SW-UNIT-GRADIENT * SW-UNIT-REF + SW-UNIT-OFFSET
Example
For an example, see 2.59. SW-DATA-DICTIONARY-SPEC .
Properties
Within context of: | 2.69. SW-UNIT
Is context for: | Text
Name | Type | Type | Notes
[LENGTH-EXPO] optional | String (CDATA) |  | Exponent der Längeneinheit
[TIME-EXPO] optional | String (CDATA) |  | Exponent der Zeiteinheit
[MASS-EXPO] optional | String (CDATA) |  | Exponent der Masseneinheit
[ELECTRIC-CURRENT-EXPO] optional | String (CDATA) |  | Exponent der Stromeinheit
[THERMODYNAMIC-TEMPERATURE-EXPO] optional | String (CDATA) |  | Exponent der Temperatureinheit
[LUMINOUS-INTENSITY-EXPO] optional | String (CDATA) |  | Exponent der Lichtstärkeneinheit
[AMOUNT-OF-SUBSTANCE-EXPO] optional | String (CDATA) |  | Exponent der Stoffmengeneinheit
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.40. STATE

Description
<STATE> represents the current state of the current file according to the configuration management plan.
Example
<STATE>reviewed</STATE>
Properties
Within context of: | 2.11. COMPANY-REVISION-INFO
Is context for: | Text
Name | Type | Type | Notes
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element. This can be used to match to formal state definitions.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.41. SUB

Description
<SUB> can be used to display a part of a paragraph in smaller font beneath the groundline.
Example
For an example, see 2.59. SW-DATA-DICTIONARY-SPEC .
Properties
Within context of: | 2.4. CHANGE , 2.15. DESC , 2.22. IE , 2.25. LONG-NAME , 2.34. REASON , 2.70. SW-UNIT-DISPLAY
Is context for: | Text
Name | Type | Type | Notes
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.42. SUP

Description
<SUP> can be used to display a part of a paragraph in smaller font above the groundline.
Example
For an example, see 2.59. SW-DATA-DICTIONARY-SPEC .
Properties
Within context of: | 2.4. CHANGE , 2.15. DESC , 2.22. IE , 2.25. LONG-NAME , 2.34. REASON , 2.70. SW-UNIT-DISPLAY
Is context for: | Text
Name | Type | Type | Notes
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.43. SW-ARRAY-INDEX

Description
In general, a <SW-INSTANCE> corresponds to a particular data object (variable or calibration parameter), a compoent of a data structure or a particulare element of an array.
If the <SW-INSTANCE> in question corresponds to an array element, then the index number of the array element is specified in <SW-ARRAY-INDEX>.
Array index is zero based. The first array element is therefore indicated by SW-ARRAY-INDEX 0
Example
For an example, see 2.65. SW-INSTANCE-SPEC .
Properties
Within context of: | 2.62. SW-INSTANCE
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.44. SW-AXIS-CONT

Description
<SW-AXIS-CONT> takes the contents of one particular axis (denoted by <SW-AXIS-INDEX>) of the current calibration item.
If there are more than one axis, then the axis with the index 1 is incrementing first. This means that the values are given in the following order:
v(1,1) | ... | v(n,1)
v(1,2) | ... | v(n,2)
... |  |
v(1,m) | ... | v(n, m)
Example
For an example, see 2.65. SW-INSTANCE-SPEC .
Properties
Within context of: | 2.45. SW-AXIS-CONTS
Is context for: | 2.71. SW-UNIT-REF , 2.46. SW-AXIS-INDEX , 2.73. SW-VALUES-PHYS
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.45. SW-AXIS-CONTS

Description
<SW-AXIS-CONTS> represents the contents of all axes of one particular calibration item.
Example
For an example, see 2.65. SW-INSTANCE-SPEC .
Properties
Within context of: | 2.63. SW-INSTANCE-PROPS-VARIANT
Is context for: | 2.44. SW-AXIS-CONT
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.46. SW-AXIS-INDEX

Description
<SW-AXIS-INDEX> denotes the index of the current axis for which the contents is specified. The index uses the following convention:
0: | This is the value axis of a curve or a map
1: | This is the X-axis of a curve or a map.
2: | This is the Y-axis of a map
3: | This is the Z-axis of a cuboid ...
Example
For an example, see 2.65. SW-INSTANCE-SPEC .
Properties
Within context of: | 2.44. SW-AXIS-CONT
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.47. SW-COMPONENT-SPEC

Description
In the PaCo use case <SW-COMPONENT-SPEC> includes a list of <SW-FEATURE> which is equal with a list of all ECU-Functions that are documented in this PaCo-File
The link from the calibartion-items to a ECU-Function is built with a <SW-FEATURE-REF> in every <SW-INSTANCE>
Example
     <SW-COMPONENT-SPEC><SW-COMPONENTS>
             <SW-FEATURE><LONG-NAME>Abgasrueckfuehrung</LONG-NAME>
                <SHORT-NAME>AGR</SHORT-NAME>
             </SW-FEATURE>
             <SW-FEATURE><LONG-NAME>Assembler-Funktion</LONG-NAME>
                <SHORT-NAME>fkt_ASS</SHORT-NAME>
                <ADMIN-DATA>
                  <LANGUAGE></LANGUAGE>
                  <DOC-REVISIONS>
                     <DOC-REVISION>
                        <COMPANY-REVISION-INFOS>
                          <COMPANY-REVISION-INFO>
                             <COMPANY-REF>company-not-available</COMPANY-REF>
                             <REVISION-LABEL>17.3</REVISION-LABEL>
                             <STATE>erzeugt-aus-DAMOS</STATE>
                          </COMPANY-REVISION-INFO>
                        </COMPANY-REVISION-INFOS>
                        <TEAM-MEMBER-REF>company-not-available/team-member-not-available</TEAM-MEMBER-REF>

                        <DATE>2001.07.16</DATE>
                        <MODIFICATIONS>
                          <MODIFICATION TYPE="content-related">
                             <CHANGE></CHANGE>
                             <REASON></REASON>
                          </MODIFICATION>
                        </MODIFICATIONS>
                     </DOC-REVISION>
                  </DOC-REVISIONS>
                </ADMIN-DATA>
             </SW-FEATURE>
          </SW-COMPONENTS>
        </SW-COMPONENT-SPEC>
Properties
Within context of: | 2.67. SW-SYSTEM
Is context for: | 2.48. SW-COMPONENTS
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.48. SW-COMPONENTS

Description
In the PaCo use case the <SW-COMPONENTS> is a container for <SW-FEATURE>
Example
For an example, see 2.47. SW-COMPONENT-SPEC .
Properties
Within context of: | 2.47. SW-COMPONENT-SPEC
Is context for: | 2.60. SW-FEATURE
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.49. SW-CS-DATA-IDENTIFIER

Description
<SW-CS-DATA-IDENTIFIER> denotes an identification string for the data version in which the calibration item was set to its current contents.
Example
For an example, see 2.52. SW-CS-HISTORY .
Properties
Within context of: | 2.50. SW-CS-ENTRY
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.50. SW-CS-ENTRY

Description
<SW-CS-ENTRY> is one particular entry in the calibration history.
Instruction
If a calibration item contains no <SW-CS-STATE> the reading system has to interpret this as a calibration item with the lowest possible state.
Example
For an example, see 2.52. SW-CS-HISTORY .
Properties
Within context of: | 2.52. SW-CS-HISTORY
Is context for: | 2.56. SW-CS-STATE , 2.55. SW-CS-PROJECT-INFO , 2.57. SW-CS-TARGET-VARIANT , 2.58. SW-CS-TEST-OBJECT , 2.54. SW-CS-PROGRAM-IDENTIFIER , 2.49. SW-CS-DATA-IDENTIFIER , 2.53. SW-CS-PERFORMED-BY , 2.13. DATE , 2.51. SW-CS-FIELD
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.51. SW-CS-FIELD

Description
<SW-CS-FIELD> can be used to declare any kind of application-information. The semantic must be declared in [SI] .
Example
For an example, see 2.52. SW-CS-HISTORY .
Properties
Within context of: | 2.50. SW-CS-ENTRY
Is context for: | Text
Name | Type | Type | Notes
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.52. SW-CS-HISTORY

Description
<SW-CS-HISTORY> allows to track the history of the calibration process for one particular calibration item as well as for the entire calibration list. The history therefore allows to keep more than one history entry.
Instruction
In case of a missing index the last inserted history entry must be on the bottom. This is very important because after a copy operation the value in <DATE> must not be equal with the date when the entry was inserted. A reading calibration system has to interpret the last <SW-CS-ENTRY> as the youngest not the one with the nearest value in <DATE>.
Example
       <SW-CS-HISTORY>
          <SW-CS-ENTRY>
             <SW-CS-STATE>calibrated</SW-CS-STATE>
             <SW-CS-CONTEXT>development of demo version</SW-CS-CONTEXT>
             <SW-CS-PROJECT-INFO>Demo-Project CDF / ASAM-MCD-2D</SW-CS-PROJECT-INFO>
             <SW-CS-TARGET-VARIANT>automatic gear</SW-CS-TARGET-VARIANT>
             <SW-CS-TEST-OBJECT>Vehicle: S-Nn-4455</SW-CS-TEST-OBJECT>
             <SW-CS-PROGRAM-IDENTIFIER>67985</SW-CS-PROGRAM-IDENTIFIER>
             <SW-CS-DATA-IDENTIFIER>67985:123.4</SW-CS-DATA-IDENTIFIER>
             <SW-CS-PERFORMED-BY>Weichel</SW-CS-PERFORMED-BY>
             <REMARK>
               <P>Note that we did not really calibrate this. The current
                  structure is for demonstration purposes only.
               </P>
             </REMARK>
             <DATE>2001.05.18T13.23</DATE>
             <SW-CS-FIELD SI="feeling">We did feel good while doing this stuff.</SW-CS-FIELD>
          </SW-CS-ENTRY>
       </SW-CS-HISTORY>
Properties
Within context of: | 2.63. SW-INSTANCE-PROPS-VARIANT ; 2.66. SW-INSTANCE-TREE
Is context for: | 2.50. SW-CS-ENTRY
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.53. SW-CS-PERFORMED-BY

Description
<SW-CS-PERFORMED-BY> specifies the particular individual which assigned the current calibration state. Although this could be a reference to <TEAM-MEMBER>, it is simply a string. This is because data might be copied from project to project, which would make the formal reference invalid.
Example
For an example, see 2.52. SW-CS-HISTORY .
Properties
Within context of: | 2.50. SW-CS-ENTRY
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.54. SW-CS-PROGRAM-IDENTIFIER

Description
<SW-CS-PROGRAM-IDENTIFIER> denotes the identifier of the ECU program which was used while calibrating the current calibration item up to the state of the current calibration history.
To some extent, this should give the basis to determine the matching ASAM-2-MC file.
Example
For an example, see 2.52. SW-CS-HISTORY .
Properties
Within context of: | 2.50. SW-CS-ENTRY
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.55. SW-CS-PROJECT-INFO

Description
<SW-CS-PROJECT-INFO> allows to denote a project identifier in order to specify the project in which the current calibration state was achieved. This makes sense, because, calibration items can be copied from one project to another. Therefore the information in <PROJECT-DATA> is not sufficient for this use case.
Example
For an example, see 2.52. SW-CS-HISTORY .
Properties
Within context of: | 2.50. SW-CS-ENTRY
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.56. SW-CS-STATE

Description
<SW-CS-STATE> is used to denote the current state of the calibration item. For the sake of worldwide uniform standard calibration state labels the state labels and their meaning must be fixed. Legal values of SW-CS-STATE in PaCo-Usecase describes the legal values for calibration states.
Legal values of <SW-CS-STATE> in PaCo-Usecase
Value | Calibration progress | Meaning
--- | 0% | Label/function is untouched.
changed | 0% | Label/function was changed without evaluation.
prelimCalibrated | 25% | Label/function contains default data, no calibration performed.
calibrated | 50% | Label/function is partly calibrated or contains data from variant without any evaluation.
checked | 75% | Label/function is calibrated, final validation still has to come. Data is expected to be production intend.
completed | 100% | Label/function is completely calibrated, final validation is done.
Instruction
If a calibration item contains no <SW-CS-STATE> the reading system has to interpret this as a calibration item with the lowest possible state!
Example
<SW-CS-STATE>calibrated<SW-CS-STATE>
For a further example, see 2.52. SW-CS-HISTORY .
Properties
Within context of: | 2.50. SW-CS-ENTRY
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.57. SW-CS-TARGET-VARIANT

Description
<SW-CS-TARGET-VARIANT> is used to specify the variant of the target system which was used to achieve the current calibration state.
Example
For an example, see 2.52. SW-CS-HISTORY .
Properties
Within context of: | 2.50. SW-CS-ENTRY
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.58. SW-CS-TEST-OBJECT

Description
<SW-CS-TEST-OBJECT> denotes the object witin the the current calibration item was calibrated. This is mainly a vehicle or a particular test environment.
Example
For an example, see 2.52. SW-CS-HISTORY .
Properties
Within context of: | 2.50. SW-CS-ENTRY
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.59. SW-DATA-DICTIONARY-SPEC

Description
In the PaCo use case the <DATA-DICTIONARY-SPEC> is a container for <SW-UNITS>.
In the ASAM-2-MC use case much more information about particular data objects are kept here.
Example
     <SW-DATA-DICTIONARY-SPEC><SW-UNITS>
             <SW-UNIT><SHORT-NAME>1_057sec</SHORT-NAME>
                <SW-UNIT-DISPLAY>1/sec</SW-UNIT-DISPLAY>
                <SI-UNIT>tbd</SI-UNIT>
             </SW-UNIT>
             <SW-UNIT><SHORT-NAME>dez</SHORT-NAME>
                <SW-UNIT-DISPLAY>dez</SW-UNIT-DISPLAY>
                <SI-UNIT>tbd</SI-UNIT>
             </SW-UNIT>
             <SW-UNIT><SHORT-NAME>digital</SHORT-NAME>
                <SW-UNIT-DISPLAY>digital</SW-UNIT-DISPLAY>
                <SI-UNIT>tbd</SI-UNIT>
             </SW-UNIT>
             <SW-UNIT><SHORT-NAME>grad_040C</SHORT-NAME>
                <SW-UNIT-DISPLAY>grad C</SW-UNIT-DISPLAY>
                <SI-UNIT>tbd</SI-UNIT>
             </SW-UNIT>
             <SW-UNIT><SHORT-NAME>Grad_040KW</SHORT-NAME>
                <SW-UNIT-DISPLAY>Grad KW</SW-UNIT-DISPLAY>
                <SI-UNIT>tbd</SI-UNIT>
             </SW-UNIT>
             <SW-UNIT><SHORT-NAME>grad_040KW</SHORT-NAME>
                <SW-UNIT-DISPLAY>grad KW</SW-UNIT-DISPLAY>
                <SI-UNIT>tbd</SI-UNIT>
             </SW-UNIT>
             <SW-UNIT><SHORT-NAME>kg_057h</SHORT-NAME>
                <SW-UNIT-DISPLAY>kg/h</SW-UNIT-DISPLAY>
                <SI-UNIT>tbd</SI-UNIT>
             </SW-UNIT>
          </SW-UNITS>
        </SW-DATA-DICTIONARY-SPEC>
Properties
Within context of: | 2.67. SW-SYSTEM
Is context for: | 2.72. SW-UNITS
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.60. SW-FEATURE

Description
In the PaCo use cases <SW-FEATURE>describes a particular function of the software with respect of the calibration items being introduced.
Example
For an example, see 2.47. SW-COMPONENT-SPEC .
Properties
Within context of: | 2.48. SW-COMPONENTS
Is context for: | 2.25. LONG-NAME , 2.38. SHORT-NAME , 2.2. ADMIN-DATA
Name | Type | Values / Default | Notes
[ID] required | ID (ID) |  | Clear identification of an element inside a document.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-FEATURE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</ TEAM-MEMBER- REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS=" TEAM-MEMBER">...</ TEAM-MEMBER>.
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | SW-ADDR-METHOD SW-AXIS-TYPE SW-BASE-TYPE SW-CLASS-INSTANCE SW-CODE-SYNTAX SW-COMPU-METHOD SW-DATA-CONSTR SW-CALPRM SW-RECORD-LAYOUT SW-SYSTEM-CONST SW-TEMPLATE SW-UNIT SW-VARIABLE | Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/ sw-var1')


2.61. SW-FEATURE-REF

Description
<SW-FEATURE-REF> in <SW-INSTANCE > can be used to build a link to a <SW-FEATURE>. This feature can be used by an process linking from the calibration item to the related feature (particular function of the software).
Caution
The content of <SW-FEATURE-REF> must follow the restrictions of <SHORT-NAME>, in particular must not contain whitespace and special characters.
Example
For an example, see 2.65. SW-INSTANCE-SPEC .
Properties
Within context of: | 2.62. SW-INSTANCE , 2.66. SW-INSTANCE-TREE
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] required | ID reference (IDREF) |  | Link on an element in the document which is marked with an ID-Attribute
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/ Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-FEATURE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</ TEAM-MEMBER- REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS=" TEAM-MEMBER">...</ TEAM-MEMBER>.


2.62. SW-INSTANCE

Description
<SW-INSTANCE> represents one particular calibration item. With the possibility to include an <SW-INSTANCE> in an <SW-INSTANCE> hierarchical structures can be mapped. This mechanism is used to implement classes in PaCo.
<CATEGORY> in <SW-INSTANCE> shall reflect the nature of the instance according to asam 1.4 with extensions. In addition zu asam 1.4 the value SW_COMPONENT is used to store meta-data represented by a <SW-CS-HISTORY> tree.
Legal values of <CATEGORY> in <SW-INSTANCE>
Value
Meaning
Remark
SW_COMPONENT
Specific ECU function
This is used to store meta data for a specific ECU function in the according dataset described by the whole SW-INSTANCE-TREE.
VALUE
Characteristic value
This represents a single value.
CURVE_INDIVIDUAL
Characteristic
This represents a curve with an embedded axis.
MAP_INDIVIDUAL
Map
This represents a map with embedded axes.
CURVE_FIXED
Fixed characteristic
This represents a curve of which the axis are calculated by the ecu-program. The algorithm is fixed and therefore the axis-points can not be calibrated.
MAP_FIXED
Fixed map
This represents a map of which the axes are calculated by the ecu-program. The algorithm is fixed and therefore the axis-points can not be calibrated.
CURVE_GROUPED
Group characteristic
This represents a curve which uses the axis-points of another calibration parameter.
Because the PaCo-Format does not include the grouped axis there must be implemented some special algorithms in the Tools.
When a PaCo-File is read the axis values must be compared with the values of the group axis in the ASAP File and there should be no difference between those both.
When a PaCo-File is written the values of the group axis must be written for every calibration item that needs the axis.
MAP_GROUPED
Group map
This represents a map which uses the axis-points of another calibration parameter.
Because the PaCo-Format does not include the grouped axis there must be implemented some special algorithms in the Tools.
When a PaCo-File is read the axis values must be compared with the values of the group axis in the ASAP File and there should be no difference between those both.
When a PaCo-File is written the values of the group axis must be written for every calibration item that needs the axis.
ASCII
Characteristic text
This represents a parameter which is text (e.g. a message).
STRUCTURE
Parameter structure
This represents a structure of calibration parameters. In this case, a nested <SW-INSTANCE> should exist.
This <CATEGORY> is also used to represent an instance of a parameter class. In this case for each <SW-INSTANCE> representing a class structure and including other <SW-INSTANCE> this <CATEGORY> is mandatory. The <CATEGORY> of the "terminal" <SW-INSTANCE> reflects the data type represented by this terminal (see SW-INSTANCE with classes)
VALUE_BLOCK
Characteristic values block
This represents a homogeneous set of parameters which are handled as a block. In opposite to structures or arrays, the components of a value block appear whithin one particular <SW-INSTANCE> in the instance tree. This means, that every value of the first axis is interpreted as a block value.
AXIS_VALUES
Group datapoints
This represents the axis points of a calibration parameter. This means, that the values of of the first axis are interpreted as a group axis.
Hint
For <SW-INSTANCE> representing a ECU function(<CATEGORY >= SW_COMPONENT) the <SHORT-NAME>and the <SW-FEATURE-REF> must contain the name of the ECU function and will be equal.
Hint
For the calibration items of types CURVE_FIXED, MAP_FIXED, CURVE_GROUPED, MAP_GROUPED the axis values of the source dataset must be included in the PaCo file as redundant information, even if they are already defined in another calibration item or calculated by the ECU. This information can be used to detect incompatibilities when data is copied from one project to another. It can also be use te reinterpolate the values according to new axis points if appropriate.
Hint
If the <SW-INSTANCE> represents a class structure, then hierarchical levels must be implemented top down starting with the root.
The implementation of classes with the <CATEGORY> STRUCTURE might be replaced in the next PaCo release with the new <CATEGORY> value CLASS_INSTANCE.
Example
Figure 3: SW-INSTANCES without classes
<SW-INSTANCE>
  <LONG-NAME>lazy bears from somewhere (Viktualienmarkt)</LONG-NAME>
  <SHORT-NAME>FBAM_V</SHORT-NAME>
  <CATEGORY>MAP</CATEGORY>
  <SW-FEATURE-REF>FEATURE1</SW-FEATURE-REF>
    <SW-INSTANCE-PROPS-VARIANTS>
      <SW-INSTANCE-PROPS-VARIANT>
        <SW-AXIS-CONTS>
          <SW-AXIS-CONT>
            <SW-UNIT-REF>grad_040C</SW-UNIT-REF>
            <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
            <SW-VALUES-PHYS>
              <V>10</V>
              <V>13</V>
              <V>15</V>
              <V>30</V>
            </SW-VALUES-PHYS>
          </SW-AXIS-CONT>
          <SW-AXIS-CONT>
            <SW-UNIT-REF>grad_040C</SW-UNIT-REF>
            <SW-AXIS-INDEX>2</SW-AXIS-INDEX>
            <SW-VALUES-PHYS>
              <V>-35.6</V>
              <V>-32.0</V>
            </SW-VALUES-PHYS>
          </SW-AXIS-CONT>
          <SW-AXIS-CONT>
            <SW-UNIT-REF>km_pro_h</SW-UNIT-REF>
            <SW-AXIS-INDEX>0</SW-AXIS-INDEX>
            <SW-VALUES-PHYS>
              <VG>
               <LABEL>-35.6</LABEL>
               <V>0.00</V>
               <V>3.63</V>
               <V>3.75</V>
               <V>3.88</V>
              </VG>
              <VG>
               <LABEL>-32.0</LABEL>
               <V>0.00</V>
               <V>3.63</V>
               <V>3.75</V>
               <V>3.88</V>
              </VG>
            </SW-VALUES-PHYS>
          </SW-AXIS-CONT>
       </SW-AXIS-CONTS>
       <SW-CS-HISTORY>
          <SW-CS-ENTRY>
             <SW-CS-STATE>calibrated</SW-CS-STATE>
             <SW-CS-CONTEXT>development of demo version</SW-CS-CONTEXT>
             <SW-CS-PROJECT-INFO>Demo-Project CDF / ASAM-MCD-2D</SW-CS-PROJECT-INFO>
             <SW-CS-TARGET-VARIANT>automatic gear</SW-CS-TARGET-VARIANT>
             <SW-CS-TEST-OBJECT>Vehicle: S-Nn-4455</SW-CS-TEST-OBJECT>
             <SW-CS-PROGRAM-IDENTIFIER>67985</SW-CS-PROGRAM-IDENTIFIER>
             <SW-CS-DATA-IDENTIFIER>67985:123.4</SW-CS-DATA-IDENTIFIER>
             <SW-CS-PERFORMED-BY>Weichel</SW-CS-PERFORMED-BY>
             <REMARK>
               <P>Note that we did not really calibrate this. The current
                  structure is for demonstration purposes only.
               </P>
             </REMARK>
             <DATE>2001.05.18T13.23</DATE>
             <SW-CS-FIELD SI="feeling">We did feel good while doing this stuff.</SW-CS-FIELD>
          </SW-CS-ENTRY>
       </SW-CS-HISTORY>
     </SW-INSTANCE-PROPS-VARIANT>
   </SW-INSTANCE-PROPS-VARIANTS>
</SW-INSTANCE>
The next example shows an instance (SENSOR1) of a class with consists of another class instance (LEFTSIDE) with two components: (DHSJE, FBAM).
Figure 4: SW-INSTANCE with classes
<SW-INSTANCE>
 <SHORT-NAME>SENSOR1</SHORT-NAME>
 <CATEGORY>STRUCTURE</CATEGORY>
 <SW-FEATURE-REF>FEATURE1</SW-FEATURE-REF>
   <SW-INSTANCE>
   <SHORT-NAME>LEFTSIDE</SHORT-NAME>
   <CATEGORY>STRUCTURE</CATEGORY>
   <SW-FEATURE-REF>FEATURE1</SW-FEATURE-REF>
     <SW-INSTANCE>
     <SHORT-NAME>DHSJE</SHORT-NAME>
     <CATEGORY>VALUE</CATEGORY>
     <SW-FEATURE-REF>FEATURE1</SW-FEATURE-REF>
       <SW-INSTANCE-PROPS-VARIANTS>
         <SW-INSTANCE-PROPS-VARIANT>
          <SW-AXIS-CONTS>
            <SW-AXIS-CONT>
             <SW-AXIS-INDEX>0</SW-AXIS-INDEX>
             <SW-VALUES-PHYS>
               <V>4000.00000</V>
             </SW-VALUES-PHYS>
            </SW-AXIS-CONT>
          </SW-AXIS-CONTS>
          <SW-CS-HISTORY>
           <SW-CS-ENTRY>
            <SW-CS-STATE>calibrated</SW-CS-STATE>
            <SW-CS-DATA-IDENTIFIER>grimm</SW-CS-DATA-IDENTIFIER>
            <SW-CS-PERFORMED-BY>Baumann</SW-CS-PERFORMED-BY>
            <DATE>2002.05.03 T16:16:00</DATE>
           </SW-CS-ENTRY>
           <SW-CS-ENTRY>
            <SW-CS-STATE>completed</SW-CS-STATE>
            <SW-CS-DATA-IDENTIFIER>grimm</SW-CS-DATA-IDENTIFIER>
            <SW-CS-PERFORMED-BY>Baumann</SW-CS-PERFORMED-BY>
            <DATE>2002.05.03 T16:15:00</DATE>
           </SW-CS-ENTRY>
          </SW-CS-HISTORY>
         </SW-INSTANCE-PROPS-VARIANT>
       </SW-INSTANCE-PROPS-VARIANTS>
     </SW-INSTANCE>

     <SW-INSTANCE>
      <LONG-NAME>lazy bears from somewhere (Viktualienmarkt)</LONG-NAME>
      <SHORT-NAME>FBAM_V</SHORT-NAME>
      <CATEGORY>MAP</CATEGORY>
      <SW-FEATURE-REF>FEATURE1</SW-FEATURE-REF>
        <SW-INSTANCE-PROPS-VARIANTS>
          <SW-INSTANCE-PROPS-VARIANT>
            <SW-AXIS-CONTS>
              <SW-AXIS-CONT>
                <SW-UNIT-REF>grad_040C</SW-UNIT-REF>
                <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
                <SW-VALUES-PHYS>
                  <V>10</V>
                  <V>13</V>
                  <V>15</V>
                  <V>30</V>
                </SW-VALUES-PHYS>
              </SW-AXIS-CONT>
              <SW-AXIS-CONT>
                <SW-UNIT-REF>grad_040C</SW-UNIT-REF>
                <SW-AXIS-INDEX>2</SW-AXIS-INDEX>
                <SW-VALUES-PHYS>
                  <V>-35.6</V>
                  <V>-32.0</V>
                </SW-VALUES-PHYS>
              </SW-AXIS-CONT>
              <SW-AXIS-CONT>
                <SW-UNIT-REF>km_pro_h</SW-UNIT-REF>
                <SW-AXIS-INDEX>0</SW-AXIS-INDEX>
                <SW-VALUES-PHYS>
                  <VG>
                   <LABEL>-35.6</LABEL>
                   <V>0.00</V>
                   <V>3.63</V>
                   <V>3.75</V>
                   <V>3.88</V>
                  </VG>
                  <VG>
                   <LABEL>-32.0</LABEL>
                   <V>0.00</V>
                   <V>3.63</V>
                   <V>3.75</V>
                   <V>3.88</V>
                  </VG>
                </SW-VALUES-PHYS>
              </SW-AXIS-CONT>
           </SW-AXIS-CONTS>
           <SW-CS-HISTORY>
              <SW-CS-ENTRY>
                 <SW-CS-STATE>calibrated</SW-CS-STATE>
                 <SW-CS-CONTEXT>development of demo version</SW-CS-CONTEXT>
                 <SW-CS-PROJECT-INFO>Demo-Project CDF / ASAM-MCD-2D</SW-CS-PROJECT-INFO>
                 <SW-CS-TARGET-VARIANT>automatic gear</SW-CS-TARGET-VARIANT>
                 <SW-CS-TEST-OBJECT>Vehicle: S-Nn-4455</SW-CS-TEST-OBJECT>
                 <SW-CS-PROGRAM-IDENTIFIER>67985</SW-CS-PROGRAM-IDENTIFIER>
                 <SW-CS-DATA-IDENTIFIER>67985:123.4</SW-CS-DATA-IDENTIFIER>
                 <SW-CS-PERFORMED-BY>Weichel</SW-CS-PERFORMED-BY>
                 <REMARK>
                   <P>Note that we did not really calibrate this. The current
                      structure is for demonstration purposes only.
                   </P>
                </REMARK>
                 <DATE>2001.05.18T13.23</DATE>
                 <SW-CS-FIELD SI="feeling">We did feel good while doing this stuff.</SW-CS-FIELD>
              </SW-CS-ENTRY>
           </SW-CS-HISTORY>
         </SW-INSTANCE-PROPS-VARIANT>
       </SW-INSTANCE-PROPS-VARIANTS>
    </SW-INSTANCE>
  </SW-INSTANCE>
</SW-INSTANCE>
Figure 5: SW-INSTANCE representing ECU function metadata
<SW-INSTANCE>
  <SHORT-NAME>ACIFI</SHORT-NAME>
  <CATEGORY>SW_COMPONENT</CATEGORY>
  <SW-FEATURE-REF>ACIFI</SW-FEATURE-REF>
  <SW-INSTANCE-PROPS-VARIANTS>
    <SW-INSTANCE-PROPS-VARIANT>
       <SW-CS-HISTORY>
          <SW-CS-ENTRY>
            <SW-CS-STATE>calibrated</SW-CS-STATE>
            <SW-CS-DATA-IDENTIFIER>grimm</SW-CS-DATA-IDENTIFIER>
            <SW-CS-PERFORMED-BY>Baumann</SW-CS-PERFORMED-BY>
            <DATE>2002.05.03 T16:16:00</DATE>
           </SW-CS-ENTRY>
           <SW-CS-ENTRY>
            <SW-CS-STATE>completed</SW-CS-STATE>
            <SW-CS-DATA-IDENTIFIER>grimm</SW-CS-DATA-IDENTIFIER>
            <SW-CS-PERFORMED-BY>Baumann</SW-CS-PERFORMED-BY>
            <DATE>2002.05.03 T16:15:00</DATE>
           </SW-CS-ENTRY>
          </SW-CS-HISTORY>
         </SW-INSTANCE-PROPS-VARIANT>
       </SW-INSTANCE-PROPS-VARIANTS>
</SW-INSTANCE>
Properties
Within context of: | 2.66. SW-INSTANCE-TREE
Is context for: | 2.25. LONG-NAME , 2.38. SHORT-NAME , 2.43. SW-ARRAY-INDEX , 2.61. SW-FEATURE-REF , 2.3. CATEGORY , 2.64. SW-INSTANCE-PROPS-VARIANTS
Name | Type | Values / Default | Notes
[ID] required | ID (ID) |  | Clear identification of an element inside a document.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-INSTANCE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</ TEAM-MEMBER- REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS=" TEAM-MEMBER">...</ TEAM-MEMBER>.
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | SW-INSTANCE | Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/ sw-var1')


2.63. SW-INSTANCE-PROPS-VARIANT

Description
<SW-INSTANCE-PROPS-VARIANT> describes one particular variant of the current calibration item. The variants are intended to be runtime variants. This makes all variants being kept in one particular ecu software. As opposite to this, compile time variants are not kept in the ECU simultanously. Each compile time variant will end up in a PaCo file of its own.
Example
For an example, see 2.65. SW-INSTANCE-SPEC .
Properties
Within context of: | 2.64. SW-INSTANCE-PROPS-VARIANTS
Is context for: | 2.79. SW-VCD-CRITERION-VALUES , 2.45. SW-AXIS-CONTS , 2.52. SW-CS-HISTORY
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.64. SW-INSTANCE-PROPS-VARIANTS

Description
<SW-INSTANCE-PROPS-VARIANTS> is the container which takes all variants of one particular calibration item.
Example
For an example, see 2.65. SW-INSTANCE-SPEC .
Properties
Within context of: | 2.62. SW-INSTANCE
Is context for: | 2.63. SW-INSTANCE-PROPS-VARIANT
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.65. SW-INSTANCE-SPEC
Description Example: Properties

Description
<SW-INSTANCE-SPEC> is the section within a <SW-SYSTEM> which takes all information about the instances of data items within the ECU, in particular the calibration items.
Example:

         <SW-INSTANCE-SPEC>
           <SW-INSTANCE-TREE><SHORT-NAME>grimm</SHORT-NAME>
               <CATEGORY>grimm</CATEGORY>
               <SW-INSTANCE><LONG-NAME>LLR-Integratorsteigung positiv</LONG-NAME>
                   <SHORT-NAME>DLIP</SHORT-NAME>
                   <SW-FEATURE-REF>AGR</SW-FEATURE-REF>
                   <CATEGORY>CURVE_FIXED</CATEGORY>
                   <SW-INSTANCE-PROPS-VARIANTS>
                    <SW-INSTANCE-PROPS-VARIANT>
                    <SW-AXIS-CONTS>
                      <SW-AXIS-CONT>
                       <SW-UNIT-REF>Upm</SW-UNIT-REF>
                       <SW-AXIS-INDEX>1</SW-AXIS-INDEX>
                       <SW-VALUES-PHYS>
                        <V>0.0</V>
                        <V>20.0</V>
                        <V>40.0</V>
                        <V>60.0</V>
                        <V>80.0</V>
                        <V>100.0</V>
                       </SW-VALUES-PHYS>
                   </SW-AXIS-CONT>
                   <SW-AXIS-CONT>
                       <SW-UNIT-REF>kg_057h_040pro_040sec</SW-UNIT-REF>
                       <SW-AXIS-INDEX>0</SW-AXIS-INDEX>
                       <SW-VALUES-PHYS>
                        <V>1.95</V>
                        <V>3.90</V>
                        <V>5.85</V>
                        <V>7.80</V>
                        <V>9.75</V>
                        <V>11.70</V>
                    </SW-VALUES-PHYS>
                  </SW-AXIS-CONT>
                 </SW-AXIS-CONTS>
                 <SW-CS-HISTORY>
                  <SW-CS-ENTRY>
                   <SW-CS-STATE>Prelim Calibrated</SW-CS-STATE>
                   <SW-CS-PROJECT-INFO>Demo-Project PaCo-Format</SW-CS-PROJECT-INFO>
                   <SW-CS-TARGET-VARIANT>z-04</SW-CS-TARGET-VARIANT>
                   <SW-CS-TEST-OBJECT>t-188</SW-CS-TEST-OBJECT>
                   <SW-CS-PROGRAM-IDENTIFIER>08567</SW-CS-PROGRAM-IDENTIFIER>
                   <SW-CS-DATA-IDENTIFIER>grimm</SW-CS-DATA-IDENTIFIER>
                   <SW-CS-PERFORMED-BY>Baumann</SW-CS-PERFORMED-BY>
                   <DATE>2001.07.16 T07.33</DATE>
                   <SW-CS-FIELD SI="FreeComment">Free comment of the calibrationdata</SW-CS-FIELD>
                  </SW-CS-ENTRY>
                  <SW-CS-ENTRY>
                   <SW-CS-STATE>Checked</SW-CS-STATE>
                   <SW-CS-PROJECT-INFO>Demo-Project PaCo-Format</SW-CS-PROJECT-INFO>
                   <SW-CS-TARGET-VARIANT>z-06</SW-CS-TARGET-VARIANT>
                   <SW-CS-TEST-OBJECT>t-188</SW-CS-TEST-OBJECT>
                   <SW-CS-PROGRAM-IDENTIFIER>08567</SW-CS-PROGRAM-IDENTIFIER>
                   <SW-CS-DATA-IDENTIFIER>grimm</SW-CS-DATA-IDENTIFIER>
                   <SW-CS-PERFORMED-BY>Baumann</SW-CS-PERFORMED-BY>
                   <SW-CS-FIELD SI="FreeComment">Free comment of the calibrationdata</SW-CS-FIELD>
                   <DATE>2001.07.16 T07.34</DATE>
                  </SW-CS-ENTRY>
                 </SW-CS-HISTORY>
               </SW-INSTANCE-PROPS-VARIANT>
              </SW-INSTANCE-PROPS-VARIANTS>
             </SW-INSTANCE>

             ...

     </SW-INSTANCE-TREE>
    </SW-INSTANCE-SPEC>
Properties
Within context of: | 2.67. SW-SYSTEM
Is context for: | 2.66. SW-INSTANCE-TREE
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.66. SW-INSTANCE-TREE

Description
<SW-INSTANCE-TREE> receives one particular set of calibration items.
<CATEGORY> in <SW-INSTANCE-TREE> may reflect the nature of the intance tree such as test-data, adress-info, ...
As there may be multiple instance trees within one file, there may be multiple use cases to be supported:
  1. multiple compile time variants
  2. multiple data states
  3. multiple levels of information such as test-data average data, raw data
  4. ...
The instance trees may be differentiated by short-name and/or category.
Example
<SW-INSTANCE-SPEC>
  <INTRODUCTION>
    <P>This is the system to demonstrate, how PaCo should work.</P>
  </INTRODUCTION>
  <SW-INSTANCE-TREE><SHORT-NAME>Summertest</SHORT-NAME>
    <SW-INSTANCE ><LONG-NAME>lazy bears from somewhere (Viktualienmarkt)</LONG-NAME>
      <SHORT-NAME>FBAM_V</SHORT-NAME>

       ...

    </SW-INSTANCE>
  </SW-INSTANCE-TREE>

  <SW-INSTANCE-TREE><SHORT-NAME>Wintertest</SHORT-NAME>
    <SW-INSTANCE ><LONG-NAME>lazy bears from somewhere (Viktualienmarkt)</LONG-NAME>
      <SHORT-NAME>FBAM_V</SHORT-NAME>

       ...

    </SW-INSTANCE>
  </SW-INSTANCE-TREE>
</SW-INSTANCE-SPEC>
Properties
Within context of: | 2.65. SW-INSTANCE-SPEC
Is context for: | 2.38. SHORT-NAME , 2.3. CATEGORY , 2.62. SW-INSTANCE , 2.61. SW-FEATURE-REF , 2.52. SW-CS-HISTORY
Name | Type | Values / Default | Notes
[ID] required | ID (ID) |  | Clear identification of an element inside a document.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-INSTANCE-TREE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</ TEAM-MEMBER- REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS=" TEAM-MEMBER">...</ TEAM-MEMBER>.
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | SW-INSTANCE | Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/ sw-var1')


2.67. SW-SYSTEM

Description
<SW-SYSTEM> describes one particular system within the current file. This supports to transfer the calibration data of multi ecu systems within one file.
Example
<SW-SYSTEM>
  <SHORT-NAME>DEMO</SHORT-NAME>
  <SW-INSTANCE-SPEC>
    <INTRODUCTION>
           <P>This is the system to demonstrate, how CDF should work.</P>
    </INTRODUCTION>
    <SW-INSTANCE-TREE><SHORT-NAME>Summertest</SHORT-NAME>
      <SW-INSTANCE >
         <LONG-NAME>lazy bears from somewhere (Viktualienmarkt)</LONG-NAME>
         <SHORT-NAME>FBAM_V</SHORT-NAME>
         ...
      </SW-INSTANCE>
    </SW-INSTANCE-TREE>
  </SW-INSTANCE-SPEC>
</SW-SYSTEM>
Properties
Within context of: | 2.68. SW-SYSTEMS
Is context for: | 2.25. LONG-NAME , 2.38. SHORT-NAME , 2.59. SW-DATA-DICTIONARY-SPEC , 2.47. SW-COMPONENT-SPEC , 2.65. SW-INSTANCE-SPEC , 2.80. SW-VCD-SPEC
Name | Type | Values / Default | Notes
[ID] required | ID (ID) |  | Clear identification of an element inside a document.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-SYSTEM | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</ TEAM-MEMBER- REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS=" TEAM-MEMBER">...</ TEAM-MEMBER>.
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | SW-ADDR-METHOD SW-AXIS-TYPE SW-BASE-TYPE SW-CALPRM SW-CALPRM-PROTOTYPE SW-CLASS-PROTOTYPE SW-CLASS-ATTR-IMPL SW-CLASS-INSTANCE SW-CLASS SW-CODE-SYNTAX SW-COLLECTION SW-COMPU-METHOD SW-CPU-MEM-SEG SW-DATA-CONSTR SW-FEATURE SW-GENERIC-AXIS-PARAM-TYPE SW-INSTANCE-TREE SW-INSTANCE SW-RECORD-LAYOUT SW-SYSTEM-CONST SW-TASK SW-TEMPLATE SW-UNIT SW-USER-ACCESS-CASE SW-USER-GROUP SW-VARIABLE-PROTOTYPE SW-VARIABLE SW-VCD-CRITERION | Fixed Namespace. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carriing the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namesspaces and the object itself e.g. '/test.xml/sw-system1/ sw-var1')


2.68. SW-SYSTEMS

Description
<SW-SYSTEMS> is the container to recieve all <SW-SYSTEM> in the current file.
Example

<SW-SYSTEMS>
  <SW-SYSTEM>
   <SHORT-NAME>DEMO</SHORT-NAME>
   <SW-INSTANCE-SPEC>
     <INTRODUCTION>
            <P>This is the system to demonstrate, how PaCo should work.</P>
     </INTRODUCTION>
     <SW-INSTANCE-TREE><SHORT-NAME>Summertest</SHORT-NAME>
       <SW-INSTANCE >
          <LONG-NAME>lazy bears from somewhere (Viktualienmarkt)</LONG-NAME>
          <SHORT-NAME>FBAM_V</SHORT-NAME>
           ...
       </SW-INSTANCE>
     </SW-INSTANCE-TREE>
   </SW-INSTANCE-SPEC>
  </SW-SYSTEM>
</SW-SYSTEMS>
Properties
Within context of: | 2.28. MSRSW
Is context for: | 2.67. SW-SYSTEM
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.69. SW-UNIT

Description
<SW-UNIT> can be used to describe a unit of measurement for calibration items. It can be based on <SI-UNIT> as well as on other <SW-UNITS> (by applying <SW-UNIT-REF>.
The following restrictions apply:
  • When using referenced units, the chain of references must end at a <SW-UNIT> based on <SI-UNIT>. Otherwise the physical semantics of the unit would still be ambiguous.
  • The conversion of th unit in question to the referenced unit is specified in <SW-UNIT-CONVERSION-METHOD> based on the following formula:
    Conversion of measurement units
    SW-UNIT = SW-UNIT-GRADIENT * SW-UNIT-REF + SW-UNIT-OFFSET
Example
For an example, see 2.59. SW-DATA-DICTIONARY-SPEC .
Properties
Within context of: | 2.72. SW-UNITS
Is context for: | 2.38. SHORT-NAME , 2.70. SW-UNIT-DISPLAY , 2.39. SI-UNIT
Name | Type | Values / Default | Notes
[ID] required | ID (ID) |  | Clear identification of an element inside a document.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-UNIT | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</ TEAM-MEMBER- REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS=" TEAM-MEMBER">...</ TEAM-MEMBER>.


2.70. SW-UNIT-DISPLAY

Description
<SW-UNIT> contains the textual presentation of a unit of measurement.
Example
For an example, see 2.59. SW-DATA-DICTIONARY-SPEC .
Properties
Within context of: | 2.69. SW-UNIT
Is context for: | Text, 2.41. SUB , 2.42. SUP
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.71. SW-UNIT-REF

Description
<SW-UNIT-REF> is a formal reference to a measurement unit.
Caution
The content of <SW-UNIT-REF> must follow the restrictions of <SHORT-NAME>, in particular must not contain whitespace and special characters.
Example
For an example, see 2.65. SW-INSTANCE-SPEC .
Properties
Within context of: | 2.44. SW-AXIS-CONT
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] required | ID reference (IDREF) |  | Link on an element in the document which is marked with an ID-Attribute
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/ Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-UNIT | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</ TEAM-MEMBER- REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS=" TEAM-MEMBER">...</ TEAM-MEMBER>.


2.72. SW-UNITS

Description
<SW-UNIT> ist a container for <SW-UNIT>
Example
For an example, see 2.59. SW-DATA-DICTIONARY-SPEC .
Properties
Within context of: | 2.59. SW-DATA-DICTIONARY-SPEC
Is context for: | 2.69. SW-UNIT
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.73. SW-VALUES-PHYS

Description
<SW-VALUES-PHYS> receives the physical values of the calibration item.
Example
For an example, see 2.65. SW-INSTANCE-SPEC .
Properties
Within context of: | 2.44. SW-AXIS-CONT
Is context for: | 2.85. V , 2.87. VT , 2.86. VG
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.74. SW-VCD-CRITERIA

Description
<SW-VCD-CRITERIA> is a container for <SW-VCD-CRITERION>.
Example
For an example, see 2.80. SW-VCD-SPEC .
Properties
Within context of: | 2.80. SW-VCD-SPEC
Is context for: | 2.75. SW-VCD-CRITERION
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.75. SW-VCD-CRITERION

Description
In the PaCo use case <SW-VCD-CRITERION> describes the possible characteristics of the car variants and its possible values.
Example
For an example, see 2.80. SW-VCD-SPEC .
Properties
Within context of: | 2.74. SW-VCD-CRITERIA
Is context for: | 2.25. LONG-NAME , 2.38. SHORT-NAME , 2.76. SW-VCD-CRITERION-POSSIBLE-VALUES
Name | Type | Values / Default | Notes
[ID] required | ID (ID) |  | Clear identification of an element inside a document.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-VCD-CRITERION | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</ TEAM-MEMBER- REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS=" TEAM-MEMBER">...</ TEAM-MEMBER>.


2.76. SW-VCD-CRITERION-POSSIBLE-VALUES

Description
<SW-VCD-CRITERION-POSSIBLE-VALUES> contains the possible values for one characteristica of a car variant.
Example
For an example, see 2.80. SW-VCD-SPEC .
Properties
Within context of: | 2.75. SW-VCD-CRITERION
Is context for: | 2.87. VT
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.77. SW-VCD-CRITERION-REF

Description
<SW-VCD-CRITERION-REF> can be used to build a link to a <SW-VCD-CRITERION>.
Caution
The content of <SW-VCD-CRITERION-REF> must follow the restrictions of <SHORT-NAME>, in particular must not contain whitespace and special characters.
Example
For an example, see 2.80. SW-VCD-SPEC or 2.65. SW-INSTANCE-SPEC .
Properties
Within context of: | 2.78. SW-VCD-CRITERION-VALUE
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] required | ID reference (IDREF) |  | Link on an element in the document which is marked with an ID-Attribute
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/ Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SW-VCD-CRITERION | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</ TEAM-MEMBER- REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS=" TEAM-MEMBER">...</ TEAM-MEMBER>.


2.78. SW-VCD-CRITERION-VALUE

Description
<SW-VCD-CRITERION-VALUE> contains multiple <SW-VCD-CRITERION-REF> or <VT> elements. The combination of these elements are the discription of the car variant the actual application item is valid for. The legal content of the Elements are described in 2.76. SW-VCD-CRITERION-POSSIBLE-VALUES
Example
For an example, see 2.65. SW-INSTANCE-SPEC .
Properties
Within context of: | 2.79. SW-VCD-CRITERION-VALUES
Is context for: | 2.77. SW-VCD-CRITERION-REF , 2.87. VT
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.79. SW-VCD-CRITERION-VALUES

Description
<SW-VCD-CRITERION-VALUES> is a container for <SW-VCD-CRITERION-VALUE>.
Example
For an example, see 2.65. SW-INSTANCE-SPEC .
Properties
Within context of: | 2.63. SW-INSTANCE-PROPS-VARIANT
Is context for: | 2.78. SW-VCD-CRITERION-VALUE
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.80. SW-VCD-SPEC

Description
<SW-VCD-SPEC> is a container for <SW-VCD-CRITERIA>. In the PaCo use case it contains all the car variants valid for the calibration items. the Variants are intended to be runtime variants. This makes all variants being kept in one particular ecu software. As opposite to this, compile time variants are not kept in the ECU simultanously. Each compile time variant will end up in a PaCo file of its own.
Example
 <SW-VCD-SPEC>
  <SW-VCD-CRITERIA>
         <SW-VCD-CRITERION><LONG-NAME>Abgasnorm</LONG-NAME>
          <SHORT-NAME>Abgas</SHORT-NAME>
          <SW-VCD-CRITERION-POSSIBLE-VALUES>
           <VT>MVEGI</VT>
        <VT>MVEGII</VT>
    </SW-VCD-CRITERION-POSSIBLE-VALUES>
   </SW-VCD-CRITERION>
        <SW-VCD-CRITERION><LONG-NAME>Getriebeart</LONG-NAME>
         <SHORT-NAME>Getriebe</SHORT-NAME>
         <SW-VCD-CRITERION-POSSIBLE-VALUES>
          <VT>Hs</VT>
          <VT>AG</VT>
   </SW-VCD-CRITERION-POSSIBLE-VALUES>
  </SW-VCD-CRITERION>
        <SW-VCD-CRITERION><LONG-NAME>Antriebsart</LONG-NAME>
        <SHORT-NAME>Spezial</SHORT-NAME>
         <SW-VCD-CRITERION-POSSIBLE-VALUES>
          <VT>Heck</VT>
          <VT>Front</VT>
          <VT>Quattro</VT>
   </SW-VCD-CRITERION-POSSIBLE-VALUES>
  </SW-VCD-CRITERION>
    </SW-VCD-CRITERIA>
 </SW-VCD-SPEC>
Properties
Within context of: | 2.67. SW-SYSTEM
Is context for: | 2.74. SW-VCD-CRITERIA
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.81. TEAM-MEMBER

Description
<TEAM-MEMBER> contains all information of the persons involved in the project.
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.83. TEAM-MEMBERS
Is context for: | 2.25. LONG-NAME , 2.38. SHORT-NAME , 2.37. ROLES , 2.14. DEPARTMENT , 2.1. ADDRESS , 2.88. ZIP , 2.5. CITY , 2.29. PHONE , 2.20. FAX , 2.19. EMAIL , 2.21. HOMEPAGE
Name | Type | Values / Default | Notes
[ID] required | ID (ID) |  | Clear identification of an element inside a document.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | TEAM-MEMBER | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</ TEAM-MEMBER- REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS=" TEAM-MEMBER">...</ TEAM-MEMBER>.


2.82. TEAM-MEMBER-REF

Description
<TEAM-MEMBER-REF> is the pointer to one particular team member. The content is the <SHORT-NAME> of the corresponding <TEAM-MEMBER>.
Caution
The content of <TEAM-MEMBER-REF> must follow the restrictions of <SHORT-NAME>, in particular must not contain whitespace and special characters.
Example
For an example, see 2.2. ADMIN-DATA .
Properties
Within context of: | 2.16. DOC-REVISION
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] required | ID reference (IDREF) |  | Link on an element in the document which is marked with an ID-Attribute
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architecural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/ Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversion.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | TEAM-MEMBER | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER">...</ TEAM-MEMBER- REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS=" TEAM-MEMBER">...</ TEAM-MEMBER>.


2.83. TEAM-MEMBERS

Description
<TEAM-MEMBERS> is a container for all <TEAM-MEMBER>
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.7. COMPANY
Is context for: | 2.81. TEAM-MEMBER
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.84. TT

Description
<TT> can be used to format technical terms in a paragraph.
Example
Properties
Within context of: | 2.4. CHANGE , 2.15. DESC , 2.25. LONG-NAME , 2.34. REASON
Is context for: | Text
Name
Type
Values / Default
Notes
[TYPE]
required
Value selection (NAMEDTOKENGROUP)
  • SGMLTAG
  • SGML-ATTRIBUTE
  • TOOL
  • PRODUCT
  • VARIABLE
  • STATE
  • PRM
  • MATERIAL
  • CONTROL-ELEMENT
  • CODE
  • ORGANISATION
  • OTHER
Gibt einen Typ des jeweiligen Elementes an.
[USER-DEFINED-TYPE]
optional
String (CDATA)
Erlaubt es, benutzerspezifische TTs einzuführen.
[SI]
optional
String (CDATA)
Description of the semantic meaning of an element.
[VIEW]
optional
String (CDATA)
Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S]
optional
String (CDATA)
Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T]
optional
String (CDATA)
dd-mm-yyyyThh:mm:ss
dd/mm/yyyyThh:mm:ss
dd mm yyyyThh:mm:ss
Teitstempelangabe


2.85. V

Description
<V> represents one particular numerical value of the the calibration item. <V> must be a valid floating number or a hexadecimal number in C-notation.
Example
For an example, see 2.65. SW-INSTANCE-SPEC .
Properties
Within context of: | 2.73. SW-VALUES-PHYS
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.86. VG

Description
<VG> represents a group of Values which belong together. The meaning of the group is represented by the <label>. <VG> is only used for documentation purposes.
Example
For an example, see 2.62. SW-INSTANCE .
Properties
Within context of: | 2.73. SW-VALUES-PHYS , 2.86. VG
Is context for: | 2.23. LABEL , 2.85. V , 2.87. VT , 2.86. VG
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.87. VT

Description
<VT> represents one particular textual value of the the calibration item. <VT> is used to take the text values e.g. for enumerators. To some extent, <VT> values are physical values, since these values are displayed in the VCD-System's physical mode.
Example
<SW-INSTANCE>
  <LONG-NAME>Stupid Messages</LONG-NAME>
  <SHORT-NAME>murph</SHORT-NAME>
  <CATEGORY>VALUE_BLOCK</CATEGORY>
  <SW-INSTANCE-PROPS-VARIANTS>
    <SW-INSTANCE-PROPS-VARIANT>
      <SW-AXIS-CONTS>
        <SW-AXIS-CONT>
          <SW-AXIS-INDEX>0</SW-AXIS-INDEX>
          <SW-VALUES-PHYS>
            <VT>Things appear to be nearer than they are</VT>
            <VT>Shit happens</VT>
            <VT>Things will never be the same</VT>
            <VT>Stay tuned to see unexpected results</VT>
          </SW-VALUES-PHYS>
        </SW-AXIS-CONT>
      </SW-AXIS-CONTS>
    </SW-INSTANCE-PROPS-VARIANT>
  </SW-INSTANCE-PROPS-VARIANTS>
</SW-INSTANCE>
Properties
Within context of: | 2.76. SW-VCD-CRITERION-POSSIBLE-VALUES , 2.73. SW-VALUES-PHYS , 2.86. VG
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


2.88. ZIP

Description
<ZIP> can be used to describe the postcode ot the company of a team-member.
Example
For an example, see 2.33. PROJECT-DATA .
Properties
Within context of: | 2.81. TEAM-MEMBER
Is context for: | Text
Name | Type | Type | Notes
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-concept. With it textelements could be included or excluded in view of an editor or a processing engine.
[S] optional | String (CDATA) |  | Signatur. Used to store the calculated signature of an element (e.g. CRC)
[T] optional | String (CDATA) | dd-mm-yyyyThh:mm:ss dd/mm/yyyyThh:mm:ss dd mm yyyyThh:mm:ss | Timestamp


Technical Terms

Implement PaCo V2.1 based on ASAM-MCD-2MC 2.2
Technical Terms


A-Links


Code

--- | 2.56.
calibrated | 2.56.
CDF | III.
changed | 2.56.
checked | 2.56.
code | III.
completed | 2.56.
organization | III.
other | III.
prelimCalibrated | 2.56.
product | III.
SGML-attribute | III.
SGMLTAG | III.


Control elements

CURVE_FIXED | 2.62.
CURVE_GROUPED | 2.62.
MAP_FIXED | 2.62.
MAP_GROUPED | 2.62.
value CLASS_INSTANCE. | 2.62.


Organisations

ASAM
III.


OTHER

ECU
III.


Products

ASAM-2-MC | 2.54. 2.59.
ASAM-MCD-2MC 2.0 | I.1. III.
ASAM-MCD-2MC.DTD | II.2.
CDF | III.
DTD | III.1.
MSRDCI | II.2.
MSRREP.DTD | III.
MSRSW.DTD | I.2. II. II.2. 1.1.
MSRSW.DTD 2.2.2 |
PaCo |


SGML Attributes

AMOUNT-OF-SUBSTANCE-EXPO | 2.39.
ELECTRIC-CURRENT-EXPO | 2.39.
F-CHILD-TYPE | 2.7. 2.37.
F-ID-CLASS | 2.7. 2.10. 2.60. 2.61. 2.62. 2.66. 2.67. 2.69. 2.71. 2.75. 2.77. 2.81. 2.82.
F-NAMESPACE | 2.7. 2.28. 2.60. 2.62. 2.66. 2.67.
F-PUBID | 2.28.
HYNAMES | 2.10. 2.61. 2.71. 2.77. 2.82.
HYTIME | 2.10. 2.28. 2.61. 2.71. 2.77. 2.82.
ID | 2.7. 2.60. 2.62. 2.66. 2.67. 2.69. 2.75. 2.81.
ID-REF | 2.10. 2.61. 2.71. 2.77. 2.82.
LENGTH-EXPO | 2.39.
LUMINOUS-INTENSITY-EXPO | 2.39.
MASS-EXPO | 2.39.
PUBID | 2.28.
ROLE | 2.7.
S | 2.1. 2.2. 2.3. 2.4. 2.5. 2.6. 2.7. 2.8. 2.9. 2.10. 2.11. 2.12. 2.13. 2.14. 2.15. 2.16. 2.17. 2.18. 2.19. 2.20. 2.21. 2.22. 2.23. 2.24. 2.25. 2.26. 2.27. 2.28. 2.29. 2.30. 2.31. 2.32. 2.33. 2.34. 2.35. 2.36. 2.37. 2.38. 2.39. 2.40. 2.41. 2.42. 2.43. 2.44. 2.45. 2.46. 2.47. 2.48. 2.49. 2.50. 2.51. 2.52. 2.53. 2.54. 2.55. 2.56. 2.57. 2.58. 2.59. 2.60. 2.61. 2.62. 2.63. 2.64. 2.65. 2.66. 2.67. 2.68. 2.69. 2.70. 2.71. 2.72. 2.73. 2.74. 2.75. 2.76. 2.77. 2.78. 2.79. 2.80. 2.81. 2.82. 2.83. 2.84. 2.85. 2.86. 2.87. 2.88.
SI | 2.13. 2.18. 2.22. 2.40. 2.41. 2.42. 2.51. 2.84.
T | 2.1. 2.2. 2.3. 2.4. 2.5. 2.6. 2.7. 2.8. 2.9. 2.10. 2.11. 2.12. 2.13. 2.14. 2.15. 2.16. 2.17. 2.18. 2.19. 2.20. 2.21. 2.22. 2.23. 2.24. 2.25. 2.26. 2.27. 2.28. 2.29. 2.30. 2.31. 2.32. 2.33. 2.34. 2.35. 2.36. 2.37. 2.38. 2.39. 2.40. 2.41. 2.42. 2.43. 2.44. 2.45. 2.46. 2.47. 2.48. 2.49. 2.50. 2.51. 2.52. 2.53. 2.54. 2.55. 2.56. 2.57. 2.58. 2.59. 2.60. 2.61. 2.62. 2.63. 2.64. 2.65. 2.66. 2.67. 2.68. 2.69. 2.70. 2.71. 2.72. 2.73. 2.74. 2.75. 2.76. 2.77. 2.78. 2.79. 2.80. 2.81. 2.82. 2.83. 2.84. 2.85. 2.86. 2.87. 2.88.
THERMODYNAMIC-TEMPERATURE-EXPO | 2.39.
TIME-EXPO | 2.39.
type | III.
USER-DEFINED-TYPE | 2.84.
VIEW | 2.1. 2.2. 2.3. 2.4. 2.5. 2.6. 2.7. 2.8. 2.9. 2.10. 2.11. 2.12. 2.13. 2.14. 2.15. 2.16. 2.17. 2.18. 2.19. 2.20. 2.21. 2.22. 2.23. 2.24. 2.25. 2.26. 2.27. 2.28. 2.29. 2.30. 2.31. 2.32. 2.33. 2.34. 2.35. 2.36. 2.37. 2.38. 2.39. 2.40. 2.41. 2.42. 2.43. 2.44. 2.45. 2.46. 2.47. 2.48. 2.49. 2.50. 2.51. 2.52. 2.53. 2.54. 2.55. 2.56. 2.57. 2.58. 2.59. 2.60. 2.61. 2.62. 2.63. 2.64. 2.65. 2.66. 2.67. 2.68. 2.69. 2.70. 2.71. 2.72. 2.73. 2.74. 2.75. 2.76. 2.77. 2.78. 2.79. 2.80. 2.81. 2.82. 2.83. 2.84. 2.85. 2.86. 2.87. 2.88.


SGML Elements

/ TEAM-MEMBER | 2.7. 2.10. 2.60. 2.61. 2.62. 2.66. 2.67. 2.69. 2.71. 2.75. 2.77. 2.81. 2.82.
/ TEAM-MEMBER- REF | 2.7. 2.10. 2.60. 2.61. 2.62. 2.66. 2.67. 2.69. 2.71. 2.75. 2.77. 2.81. 2.82.
ADDRESS | 2.1.
ADMIN-DATA | 1.1.2. 2.2. 2.6. 2.28.
CATEGORY | 1.1.2. 2.3. 2.28. 2.62. 2.66.
CATEGORY | 2.62.
CHANGE | 2.4.
City | 2.5.
COMPANIES | 2.6.
COMPANY | 2.7.
COMPANY-DOC-INFO | 2.8.
COMPANY-DOC-INFOS | 2.9.
COMPANY-REF | 2.10.
COMPANY-REVISION-INFO | 2.11.
COMPANY-REVISION-INFOS | 2.12.
DATA-DICTIONARY-SPEC | 2.59.
DATE | 2.13. 2.17. 2.52.
DEPARTMENT | 2.14.
DESC | 2.15.
DOC-REVISION | 2.16. 2.17.
DOC-REVISIONS | 2.17.
E | 2.18.
EMAIL | 2.19.
FAX | 2.20.
HOMEPAGE | 2.21.
IE | 2.22.
LABEL | 2.23.
LANGUAGE | 2.24.
LONG-NAME | 2.23. 2.25.
MODIFICATION | 2.26. 2.27.
MODIFICATIONS | 2.27.
msrsw | III.
PHONE | 2.29.
PRIVATE-CODE | 2.30.
PRIVATE-CODES | 2.31.
PROJECT | 2.15. 2.23. 2.32.
PROJECT-DATA | 1.1.2. 2.28. 2.33. 2.55.
REASON | 2.34.
REVISION-LABEL | 2.35.
ROLE | 2.36.
ROLES | 2.37.
SHORT-NAME | 1.1.2. 2.10. 2.28. 2.38. 2.61. 2.62. 2.71. 2.77. 2.82.
SI-UNIT | 2.39. 2.69.
STATE | 2.40.
SUB | 2.41.
SUP | 2.42.
SW-ARRAY-INDEX | 2.43.
SW-AXIS-CONT | 2.44.
SW-AXIS-CONTS | 2.45.
SW-AXIS-INDEX | 2.44. 2.46.
SW-COMPONENT-SPEC | 2.47.
SW-COMPONENTS | 2.48.
SW-CS-DATA-IDENTIFIER | 2.49.
SW-CS-ENTRY | 2.50. 2.52.
SW-CS-FIELD | 2.51.
SW-CS-HISTORY | 2.52. 2.62.
SW-CS-PERFORMED-BY | 2.53.
SW-CS-PROGRAM-IDENTIFIER | 2.54.
SW-CS-PROJECT-INFO | 2.55.
SW-CS-STATE | 2.50. 2.56.
SW-CS-TARGET-VARIANT | 2.57.
SW-CS-TEST-OBJECT | 2.58.
SW-FEATURE | 2.47. 2.48. 2.60. 2.61.
SW-FEATURE-REF | 2.47. 2.61. 2.62.
SW-INSTANCE | 2.3. 2.43. 2.47. 2.62.
SW-INSTANCE | 2.61.
SW-INSTANCE-PROPS-VARIANT | 2.63.
SW-INSTANCE-PROPS-VARIANTS | 2.64.
SW-INSTANCE-SPEC | 2.65.
SW-INSTANCE-TREE | 2.3. 2.66.
SW-SYSTEM | 2.65. 2.67. 2.68.
SW-SYSTEMS | 1.1.2. 2.28. 2.68.
SW-UNIT | 2.39. 2.69. 2.70. 2.72.
SW-UNIT-CONVERSION-METHOD | 2.39. 2.69.
SW-UNIT-REF | 2.39. 2.69. 2.71.
SW-UNITS | 2.59. 2.69.
SW-VALUES-PHYS | 2.73.
SW-VCD-CRITERIA | 2.74. 2.80.
SW-VCD-CRITERION | 2.74. 2.75. 2.77.
SW-VCD-CRITERION-POSSIBLE-VALUES | 2.76.
SW-VCD-CRITERION-REF | 2.77. 2.78.
SW-VCD-CRITERION-VALUE | 2.78. 2.79.
SW-VCD-CRITERION-VALUES | 2.79.
SW-VCD-SPEC | 2.80.
TEAM-MEMBER | 2.53. 2.81. 2.82. 2.83.
TEAM-MEMBER ID="ID1" F-ID-CLASS=" TEAM-MEMBER" | 2.7. 2.10. 2.60. 2.61. 2.62. 2.66. 2.67. 2.69. 2.71. 2.75. 2.77. 2.81. 2.82.
TEAM-MEMBER-REF | 2.6. 2.82.
TEAM-MEMBER-REF IDREF="ID1" F-ID- CLASS="TEAM-MEMBER" | 2.7. 2.10.
TEAM-MEMBER-REF IDREF="ID1" F-ID-CLASS="TEAM-MEMBER" | 2.60. 2.61. 2.62. 2.66. 2.67. 2.69. 2.71. 2.75. 2.77. 2.81. 2.82.
TEAM-MEMBERS | 2.83.
TT | 2.84.
V | 2.85.
VG | 2.23. 2.86.
VT | 2.78. 2.87.
ZIP | 2.88.


Tools

DCI checker | 2.3.
Editor | 2.23.
PaCo | 2.47.
XML editor | I.


Variables

STRUCTURE | 2.62.
SW_COMPONENT | 2.62.
Volvo Turnkey | 2.23.


Untitled

UNODERED is not used in the DTDs described here, since it is not conforming with XML.