MSRSW.DTD Elements and attributes

MSR Engineering Documentation (MEDOC)

MSRSW.DTD Elements and attributes
Scope: Software for electronic control units
[ MSRSW-EADOC-EN]
Revision: 1
This is a reference document for MSRSW DTD describing all elements.
MSRSW DTD is part of the MSR development documentation MEDOC.


I. How to read this document

MSRSW.DTD Elements and attributes
I. How to read this document

Contents of this chapter:
  • I.1. The following conventions apply
  • I.2. Graphical conventions used in DTD diagrams


I.1. The following conventions apply

This document is written using MSRREP DTD. The following conventions apply to this document:
<msrsw> SGML elements are noted as technical term [type]=SGMLTAG.

[type] SGML attributes are noted as technical term [type]=SGML-attribute.

sgml-attribute Values of SGML attributes or discrete values for elements are noted as technical term [type]=code

ASAP2 The considered languages resp. DTDs are marked as technical term [type]=product.

ASAP The commitees are noted as [type]=organization

ECU Objects in general are marked as technical terms [type]=other. This might be automotive equipments general objects such as variables etc.


I.2. Graphical conventions used in DTD diagrams

The structure of DTDs is shown in the MSR document as DTD diagrams (see convention in DTD diagrams).
Figure 1: convention in DTD diagrams
The meaning of the symbols is:
PCDATA | Processable Character Data (PCDATA) Data that consists of zero or more characters of both text and markup. PCDATA is a declared content keyword. PCDATA is used to indicate that all markup delimiters defined in the SGML declaration will be recognized by the parser as markup in the given element rather than data characters.
RCDATA | Replaceable Character Data (RCDATA) is data that consists of zero or more characters, in which references to substitutions are not recognized (i.e. RCDATA may contain text and entity references, but no sub-elements). See also: CDATA PCDATA.
CDATA | Character Data (CDATA) consists of zero or more text characters, where no markup of any kind is recognized. CDATA is an SGML term. Note that character references are allowed in a CDATA entity (substitution) but not in CDATA content.
ANY | a terminal type indicating that the object may contain text or any element defined in the model.
EMPTY | a terminal type keyword used to indicate that there is no data (i.e. no content, sub-elements or end-tags) for the object allowed in the document instance. This keyword is often used to describe elements that are placeholders or are pointers to external or system-generated data.
One | indicates that the element or the element group occurs exactly once
ZERO-OR-ONE | indicates that the element or the element group is optional
ONE-OR-MORE | indicates that the element or the element group occurs multiple times but at least once
ZERO-OR-MORE | indicates that the element or the element group occurs multiple times but also can be missed (optional)
ORDERED | a connector used to specify that the sibling objects must appear in the document in the order shown in the model
UNORDERED | a connector used to specify that the sibling objects can appear in any order in the document.
SELECTION | a connector used to specify that only one of the sibling objects can appear in the document.
ELEMENT | indicates a single SGML structure element
COLLAPSED | indicates, that the content of the element is not displayed here


II. Allgemeine Projektdaten

MSRSW.DTD Elements and attributes
II. Allgemeine Projektdaten


III. Document management

MSRSW.DTD Elements and attributes
III. Document management

team members
Name | Company
Dipl.-Ing.(FH) Uwe Bless | MSR-MEDOC
Dipl.-Inform. Helmut Gengenbach | MSR-MEDOC
Dipl. Ing. Eckard Jakobi | MSR-MEDOC
Dipl.-Ing. Herbert Klein | MSR-MEDOC
Dipl. Ing. Oliver Marcks | MSR-MEDOC
Dipl.-Inform. Peter Rauleder | MSR-MEDOC
Dipl.-Ing. Martin Trinschek | MSR-MEDOC
Dipl.-Ing. Bernhard Weichel | MSR-MEDOC
version overview
Date | Publisher
19.2.1999 | Dipl.-Ing. Bernhard Weichel
modifications
Change | Related to
initial revision Reason: | Content
modifications included
Date | Chapter | Change | Related to
19.2.1999 | Gesamt | initial revision Reason: | Content


1. ABS ... ARRAYSIZE

MSRSW.DTD Elements and attributes
1. ABS ... ARRAYSIZE

Contents of this chapter:
  • 1.1. ABS
  • 1.2. ACCEPTANCE-COND
  • 1.3. ADD-INFO
  • 1.4. ADD-SPEC
  • 1.5. ADDRESS
  • 1.6. ADMIN-DATA
  • 1.7. ANNOTATION
  • 1.8. ANNOTATION-ORIGIN
  • 1.9. ANNOTATION-TEXT
  • 1.10. ANNOTATIONS
  • 1.11. ARRAYSIZE


1.1. ABS

Figure 2: DTD-diagram for ABS
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for ABS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Absolute value for parameter characteristics. See parameter model (<sw-prm>).

Example
<prm>
   <long-name>long designation</long-name>
   <short-name>short designation</short-name>
   <prm-char>
      <abs>10</abs>
      <tol>5<tol>
      <unit>°C</unit>
   </prm-char>
</prm>
<prm>
   <long-name>long designation</long-name>
   <short-name>short designation</short-name>
   <prm-char>
      <min>0</min>
      <typ>5<typ>
      <max>0</max>
      <unit>°C</unit>
   </prm-char>
</prm>


1.2. ACCEPTANCE-COND

Figure 3: DTD-diagram for ACCEPTANCE-COND
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for ACCEPTANCE-COND
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


1.3. ADD-INFO

Figure 4: DTD-diagram for ADD-INFO
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <sw-function-variant> <sw-param> <sw-variable-implementation>
Attributes for ADD-INFO
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Additional information (which is not covered by the existing structure) can be given in this element. In opposite to <add-spec>, <add-info> complements an existing structure, whild <add-spec> is used where no structure exists at all.

Example
<sw-function-variant>
     ...
   <add-info>
      <prms>
         <prm>
            <long-name>program-language</long-name>
            <short-name>program-language</short-name>
            <prm-char><text>ASS</text>
            </prm-char>
         </prm>
      </prms>
   </add-info>
</sw-function-variant>


1.4. ADD-SPEC

Figure 5: DTD-diagram for ADD-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data> <msrsw>
Attributes for ADD-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element allows to give additional specifications for which no explicit structure exists. This element usually enforces another chapter in printed material. In opposite to <add-info>, <add-spec> is used as a substitute if no structure exists for the topic, while <add-info> is used where an existing structure is not appropriate.

Example


1.5. ADDRESS

Figure 6: DTD-diagram for ADDRESS
Child elements | none
parent elements | <team-member>
Attributes for ADDRESS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


1.6. ADMIN-DATA

Figure 7: DTD-diagram for ADMIN-DATA
Child elements | <language> <used-languages> <company-doc-infos> <doc-revisions>
parent elements | <chapter> <general-project-data> <msrsw> <sw-addressing-method> <sw-addressing-methods> <sw-code-syntax> <sw-code-syntaxes> <sw-compu-method> <sw-compu-methods> <sw-data-dictionary> <sw-data-dictionary-spec> <sw-function> <sw-function-spec> <sw-function-variant> <sw-glossary> <sw-param> <sw-param-contents> <sw-param-contents-spec> <sw-param-record-layout> <sw-param-record-layouts> <sw-params> <sw-physic-type> <sw-physic-types> <sw-unit> <sw-units> <sw-variable> <sw-variables>
Attributes for ADMIN-DATA
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | language:selection |
[S] | cdata | implied |  |
Description This element allows to specifiy adminstrative information regarding the substructure defined by the parent. This information may be versioning, fragmentation etc. The information rather covers the administration of the SGML-instance than the administration of the described subjects.

Example
<admin-data>
   <language>de</language>
   <doc-revisions>
      <doc-revision>
         <company-revision-infos>
            <company-revision-info>
               <company-ref>msr</company-ref>
               <revision-label>10.4</revision-label>
               <state>wd</state>
            </company-revision-info>
         </company-revision-infos>
         <team-member-ref></team-member-ref>
         <date>1.1.99</date>
         <modifications>
            <modification type="part-related">
               <change>Introduced new Architecture</change>
               <reason>Customer request</reason>
            </modification>
         </modifications>
      </doc-revision>
   </doc-revisions>
</admin-data>


1.7. ANNOTATION

Figure 8: DTD-diagram for ANNOTATION
Child elements | <label> <annotation-origin> <annotation-text>
parent elements | <annotations>
Attributes for ANNOTATION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Information of different kinds can arise throughout the course of a process, (e.g. processing information, notes etc.) that shall be linked to the variables, parameters or function and be forwarded in the process. Such kinds of information are stored in <annotation>.

Example


1.8. ANNOTATION-ORIGIN

Figure 9: DTD-diagram for ANNOTATION-ORIGIN
Child elements | none
parent elements | <annotation>
Attributes for ANNOTATION-ORIGIN
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


1.9. ANNOTATION-TEXT

Figure 10: DTD-diagram for ANNOTATION-TEXT
Child elements | <p> <verbatim>
parent elements | <annotation>
Attributes for ANNOTATION-TEXT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


1.10. ANNOTATIONS

Figure 11: DTD-diagram for ANNOTATIONS
Child elements | <annotation>
parent elements | <sw-function> <sw-function-variant> <sw-param> <sw-param-content> <sw-param-contents> <sw-variable-implementation>
Attributes for ANNOTATIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


1.11. ARRAYSIZE

Figure 12: DTD-diagram for ARRAYSIZE
Child elements | none
parent elements | <sw-param> <sw-variable-implementation>
Attributes for ARRAYSIZE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Variables <sw-variable> as well as calibration parameters <sw-param> may exist as an array. In this case the dimension of the array is given in <arraysize>. Dimensions are integer numbers and can be separated by blanks in case of multi-dimensional arrays.

Example
<sw-param>
   <long-name></long-name>
   <short-name>kgr_a</short-name>
   <sw-param-class>curve_individual</sw-param-class>
   <desc></desc>
   <sw-param-array-x>
      <sw-param-axis-x>
         <sw-axis-individual>
            <sw-variable-ref>TMOT</sw-variable-ref>
            <max-count></max-count>
         </sw-axis-individual>
      </sw-param-axis-x>
      <sw-param-axis-values>
         <sw-compu-method-ref>DEZ</sw-compu-method-ref>
      </sw-param-axis-values>
   </sw-param-array-x>
   <arraysize>0x3</arraysize>
   <sw-addressing-method-ref>Vek</sw-addressing-method-ref>
   <sw-param-record-layout-ref>DAMOS_KL0</sw-param-record-layout-ref>
   <sw-code-syntax-ref>csyKLuw</sw-code-syntax-ref>
</sw-param>


2. BIT-BASE-NAME ... BIT-POS

MSRSW.DTD Elements and attributes
2. BIT-BASE-NAME ... BIT-POS

Contents of this chapter:
  • 2.1. BIT-BASE-NAME
  • 2.2. BIT-BASE-TYPE
  • 2.3. BIT-COUNT
  • 2.4. BIT-POS


2.1. BIT-BASE-NAME

Figure 13: DTD-diagram for BIT-BASE-NAME
Child elements | none
parent elements | <sw-bit-representation>
Attributes for BIT-BASE-NAME
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description If a variable is a set of bits, there is another variable hosting the single bits. <bit-base-name> gives the name of this "host" variable.

Example
<sw-bit-representation>
   <bit-base-name>bit-host</bit-base-name>
   <bit-base-type>ubyte<bit-base-type>
   <bit-count>1</>
   <bit-pos>5</>
</sw-bit-pos>


2.2. BIT-BASE-TYPE

Figure 14: DTD-diagram for BIT-BASE-TYPE
Child elements | none
parent elements | <sw-bit-representation>
Attributes for BIT-BASE-TYPE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description If a variable is a set of bits, there is another variable hosting the single bits. <bit-base-type> gives the base type of this "host" variable (e.g. ubyte). The value must be agreed between project partners.

Example
<sw-bit-representation>
   <bit-base-name>bit-host</bit-base-name>
   <bit-base-type>ubyte<bit-base-type>
   <bit-count>1</>
   <bit-pos>5</>
</sw-bit-pos>


2.3. BIT-COUNT

Figure 15: DTD-diagram for BIT-COUNT
Child elements | none
parent elements | <sw-bit-representation>
Attributes for BIT-COUNT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description If a variable is a set of bits, there is another variable hosting the single bits. <bit-count> gives the number of bits allocated in the "host" variable .

Example
<sw-bit-representation>
   <bit-base-name>variable-short-name</bit-base-name>
   <bit-base-type>w<bit-base-type>
   <bit-count>1</>
   <bit-pos>5</>
</sw-bit-pos>


2.4. BIT-POS

Figure 16: DTD-diagram for BIT-POS
Child elements | none
parent elements | <sw-bit-representation>
Attributes for BIT-POS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description If a variable is a set of bits, there is another variable hosting the single bits. <bit-pos> gives the the position of the first bit in the "host" variable.

Example
<sw-bit-representation>
   <bit-base-name>variable-short-name</bit-base-name>
   <bit-base-type>w<bit-base-type>
   <bit-count>1</>
   <bit-pos>5</>
</sw-bit-pos>


3. C-CODE ... COND

MSRSW.DTD Elements and attributes
3. C-CODE ... COND

Contents of this chapter:
  • 3.1. C-CODE
  • 3.2. CHANGE
  • 3.3. CHAPTER
  • 3.4. CITY
  • 3.5. CMT-INT
  • 3.6. CMT-PHYS
  • 3.7. CMT-TEXT
  • 3.8. CODE
  • 3.9. CODED
  • 3.10. CODED-MAX
  • 3.11. CODED-MIN
  • 3.12. COLSPEC
  • 3.13. COMPANIES
  • 3.14. COMPANY
  • 3.15. COMPANY-DOC-INFO
  • 3.16. COMPANY-DOC-INFOS
  • 3.17. COMPANY-REF
  • 3.18. COMPANY-REVISION-INFO
  • 3.19. COMPANY-REVISION-INFOS
  • 3.20. COND


3.1. C-CODE

Figure 17: DTD-diagram for C-CODE
Child elements | none
parent elements | <formula>
Attributes for C-CODE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


3.2. CHANGE

Figure 18: DTD-diagram for CHANGE
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <modification>
Attributes for CHANGE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description More or less detailled description of the performed changes can be given here.

Example
<modification>
   <change>element description inserted</change>
   <reason>for better understanding</reason>
</modification>


3.3. CHAPTER

Figure 19: DTD-diagram for CHAPTER
Child elements | <long-name> <short-name> <admin-data> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <add-info> <chapter> <ncoi-1> <sw-addressing-method-desc> <sw-application-notes> <sw-carb-doc> <sw-code-syntax-desc> <sw-function-desc> <sw-maintenance-notes> <sw-param-record-layout-desc> <sw-test-spec>
Attributes for CHAPTER
Name | Type | Class | Value | Remark
[BREAK] | nmtkgrp | implied | BREAK NO-BREAK |
[F-ID-CLASS] | name | fixed | CHAPTER |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description <chapter> is used to put a presentation structure on prose descriptions. Chapters can be structured hierachically.

Example
<chapter id="ch1" help-entry="chapter">
   <long-name>Chapter1</long-name>
   <short-name></short-name>
   <p>This is the text in the chapter.</p>
   <figure id="fig1" help-entry="synopic diagram"><
      long-name>principal circuit diagram</long-name>
          <short-name>psb</short-name>
          <graphic filename="bild.eps" notation="eps"></graphic>
   </figure>
   <chapter id="ch11">
      <long-name>Chapter 1.1</long-name>
          <short-name></short-name>
          <p></p>
          <p></p>
   </chapter>
</chapter>


3.4. CITY

Figure 20: DTD-diagram for CITY
Child elements | none
parent elements | <team-member>
Attributes for CITY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


3.5. CMT-INT

Figure 21: DTD-diagram for CMT-INT
Child elements | none
parent elements | <sw-compu-method-text-pair> <sw-compu-method-value-pair>
Attributes for CMT-INT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Internal value for a conversion formula

Example
<sw-compu-method-text>
   <sw-compu-method-text-pair>
      <cmt-int>0</cmt-int>
      <cmt-text>Heck</cmt-text>
   </cmt-compu-method-text-pair>
</sw-compu-method-text>


3.6. CMT-PHYS

Figure 22: DTD-diagram for CMT-PHYS
Child elements | none
parent elements | <sw-compu-method-value-pair>
Attributes for CMT-PHYS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Physical value for a conversion formula defined as conversion table.

Example
<sw-compu-method-table>
   <sw-compu-method-value-pair>
      <cmt-int>0</cmt-int>
      <cmt-phys>11</cmt-phys>
   </cmt-compu-method-value-pair>
</sw-compu-method-table


3.7. CMT-TEXT

Figure 23: DTD-diagram for CMT-TEXT
Child elements | none
parent elements | <sw-compu-method-text-pair>
Attributes for CMT-TEXT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Value in text form for a conversion formula.

Example
<sw-compu-method-text>
   <sw-compu-method-text-pair>
      <cmt-int>0</cmt-int>
      <cmt-text>Heck</cmt-text>
   </cmt-compu-method-text-pair>
</sw-compu-method-text>


3.8. CODE

Figure 24: DTD-diagram for CODE
Child elements | none
parent elements | <variant-char> <variant-char-value> <variant-def>
Attributes for CODE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description The definition of variants end up in code names for variants resp. for variant characteristics resp. for values of variant characteristics. <code> takes these names. This code may be a number as well as a name.

Example
<code>007</code>


3.9. CODED

Figure 25: DTD-diagram for CODED
Child elements | <coded-min> <coded-max>
parent elements | <sw-limits> <sw-limits>
Attributes for CODED
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Coded/internal values for limits.

Example
<sw-limits>
   <coded>
      <coded-min>0</coded-min>
      <coded-max>255</coded-max>
   </coded>
   <phys>
      <phys-min>0</phys-min>
      <phys-max>90</phys-max></phys>
</sw-limits>


3.10. CODED-MAX

Figure 26: DTD-diagram for CODED-MAX
Child elements | none
parent elements | <coded>
Attributes for CODED-MAX
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Maximum coded limiting value

Example
<coded-max>255</coded-max>


3.11. CODED-MIN

Figure 27: DTD-diagram for CODED-MIN
Child elements | none
parent elements | <coded>
Attributes for CODED-MIN
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Minimum coded limiting value

Example
<coded-min>0</coded-min>


3.12. COLSPEC

Figure 28: DTD-diagram for COLSPEC
Child elements | none
parent elements | <tfoot> <tgroup> <thead>
Attributes for COLSPEC
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | implied | LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | implied |  |
[CHAROFF] | nutoken | implied |  |
[COLNAME] | nmtoken | implied |  |
[COLNUM] | number | implied |  |
[COLSEP] | number | implied |  |
[COLWIDTH] | cdata | implied |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |


3.13. COMPANIES

Figure 29: DTD-diagram for COMPANIES
Child elements | <company>
parent elements | <project>
Attributes for COMPANIES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Gets information about all companies participating in the project in question.

Example
<companies>
   <company role="supplier" id="bosch"></company>
   <company role="manufacturer" id="vw"></company>
</companies>


3.14. COMPANY

Figure 30: DTD-diagram for COMPANY
Child elements | <long-name> <short-name> <team-members> <general-project-data>
parent elements | <companies>
Attributes for COMPANY
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | long-name:selection |
[F-ID-CLASS] | name | fixed | COMPANY |
[F-NAMESPACE] | names | fixed | SAMPLE TEAM-MEMBER VARIANT-DEF VARIANT-CHAR |
[ID] | id | required |  |
[ROLE] | nmtkgrp | required | MANUFACTURER SUPPLIER |
[S] | cdata | implied |  |
Description Company-spefic details for a company participating in the project

Example
<company role="supplier" id="rb">
   <long-name>Robert Bosch GmbH</long-name>
   <short-name>rb</short-name>
   <team-members>
      <team-member id="ge"></team-member>
   </team-members><
   general-project-data></general-project-data>
</company>


3.15. COMPANY-DOC-INFO

Figure 31: DTD-diagram for COMPANY-DOC-INFO
Child elements | <company-ref> <doc-label> <private-codes> <entity-name>
parent elements | <company-doc-infos>
Attributes for COMPANY-DOC-INFO
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element takes company specific information about a document resp. a subpart of a document.

Example
<company-doc-info>
   <company-ref company="id0815">msr</company-ref>
   <doc-label>Programmstand</doc-label>
   <private-codes>1.1</private-codes>
   <entity-name>P11.sgm</entity-name>
</company-doc-info>


3.16. COMPANY-DOC-INFOS

Figure 32: DTD-diagram for COMPANY-DOC-INFOS
Child elements | <company-doc-info>
parent elements | <admin-data>
Attributes for COMPANY-DOC-INFOS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Company-specific information for administrative data

Example


3.17. COMPANY-REF

Figure 33: DTD-diagram for COMPANY-REF
Child elements | none
parent elements | <company-doc-info> <company-revision-info>
Attributes for COMPANY-REF
Name | Type | Class | Value | Remark
[COMPANY] | idref | required |  |
[HYNAMES] | names | fixed | LINKEND COMPANY |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
Description Reference to a company. The semantic of the reference is given by the context.

Example
<company-revision-info>
   <company-ref company="id0815">msr</company-ref>
   ...
</company-revision-info>


3.18. COMPANY-REVISION-INFO

Figure 34: DTD-diagram for COMPANY-REVISION-INFO
Child elements | <company-ref> <revision-label> <state> <introduction>
parent elements | <company-revision-infos>
Attributes for COMPANY-REVISION-INFO
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | state:selection |
[S] | cdata | implied |  |
Description Company-specific information concerning a certain revision of the document.

Example
<company-revision-info>
   <company-ref company="rb">rb</company-ref>
   <revision-label>15.4</revision-label>
   <state>freigegeben</state>
</company-revision-info>


3.19. COMPANY-REVISION-INFOS

Figure 35: DTD-diagram for COMPANY-REVISION-INFOS
Child elements | <company-revision-info>
parent elements | <doc-revision>
Attributes for COMPANY-REVISION-INFOS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Collection of all company specific revision information on an entity or a fragment.

Example


3.20. COND

Figure 36: DTD-diagram for COND
Child elements | <p>
parent elements | <prm-char>
Attributes for COND
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Condition for parameters. This condition is given as informal description.

Example
<prm>
   <long-name>Temperatur</long-name>
   <short-name>temp/short-name>
   <prm-char>
      <cond><p>valid if  x <  20</p></cond>
      <abs>10</abs>
      <tol>5<tol>
      <unit>°C</unit>
   </prm-char>
</prm>


4. COUNT ... COUNT

MSRSW.DTD Elements and attributes
4. COUNT ... COUNT

Contents of this chapter:
  • 4.1. COUNT


4.1. COUNT

Figure 37: DTD-diagram for COUNT
Child elements | none
parent elements | <sw-param-value-block>
Attributes for COUNT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Number of elements for one parameter block.

Example
<sw-param-value-block>
   <sw-param-axis-values>
      <sw-compu-method-ref sw-compu-method="dez">
          </sw-compu-method-ref>
   </sw-param-axis-values>
   <count>4</count>
</sw-param-value-block>


5. DATE ... DOC-REVISIONS

MSRSW.DTD Elements and attributes
5. DATE ... DOC-REVISIONS

Contents of this chapter:
  • 5.1. DATE
  • 5.2. DATE-1
  • 5.3. DEF
  • 5.4. DEF-ITEM
  • 5.5. DEF-LIST
  • 5.6. DEMARCATION-OTHER-PROJECTS
  • 5.7. DEPARTMENT
  • 5.8. DESC
  • 5.9. DIR-HAND-OVER-DOC-DATA
  • 5.10. DOC-LABEL
  • 5.11. DOC-REVISION
  • 5.12. DOC-REVISIONS


5.1. DATE

Figure 38: DTD-diagram for DATE
Child elements | none
parent elements | <doc-revision> <schedule>
Attributes for DATE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Date information according to local rules resp. agreed standards. If the DTD is configured multilingual, the date can be specified in multiple languages.

Example
<date>23.11.1998</date>
or as an international date
<date>1998-11-23</date>


5.2. DATE-1

Figure 39: DTD-diagram for DATE-1
Child elements | none
parent elements | <std> <xdoc>
Attributes for DATE-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Date information according to local rules resp. agreed standards. Even if the DTD is configured multilingual, the date can not be specified in multiple languages.


5.3. DEF

Figure 40: DTD-diagram for DEF
Child elements | <p>
parent elements | <def-item>
Attributes for DEF
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


5.4. DEF-ITEM

Figure 41: DTD-diagram for DEF-ITEM
Child elements | <long-name> <short-name> <def>
parent elements | <def-list>
Attributes for DEF-ITEM
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | DEF-ITEM |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |


5.5. DEF-LIST

Figure 42: DTD-diagram for DEF-LIST
Child elements | <def-item>
parent elements | <add-info> <chapter> <entry> <introduction> <item> <labeled-item> <ncoi-1> <remark> <sw-addressing-method-desc> <sw-application-notes> <sw-carb-doc> <sw-code-syntax-desc> <sw-function-desc> <sw-maintenance-notes> <sw-param-record-layout-desc> <sw-test-spec> <topic-1> <topic-2>
Attributes for DEF-LIST
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


5.6. DEMARCATION-OTHER-PROJECTS

Figure 43: DTD-diagram for DEMARCATION-OTHER-PROJECTS
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for DEMARCATION-OTHER-PROJECTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Informal description of relationship to similar projects.


5.7. DEPARTMENT

Figure 44: DTD-diagram for DEPARTMENT
Child elements | none
parent elements | <team-member>
Attributes for DEPARTMENT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Department of the <team-member>


5.8. DESC

Figure 45: DTD-diagram for DESC
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <figure> <overall-project> <prm> <project> <sw-data-dictionary> <sw-param> <sw-param-content> <sw-param-contents> <sw-physic-type> <sw-physic-type-1> <sw-variable> <tbd>
Attributes for DESC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Informal, concise description of the subject in question. This is ususally one or two senctences.

Example
<sw-variable calibration="no-calibration" f-id-class="sw-variable" f-namespace="sw-variable">
   <long-name>engine temperature</long-name>
   <short-name>tmot</short-name>
   <desc>The engine temeprature is stored in this variable</desc>
   ...
</sw-variable>


5.9. DIR-HAND-OVER-DOC-DATA

Figure 46: DTD-diagram for DIR-HAND-OVER-DOC-DATA
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for DIR-HAND-OVER-DOC-DATA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


5.10. DOC-LABEL

Figure 47: DTD-diagram for DOC-LABEL
Child elements | none
parent elements | <company-doc-info>
Attributes for DOC-LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This is the label of the document, serving as a company specific title or name of the document.

Example


5.11. DOC-REVISION

Figure 48: DTD-diagram for DOC-REVISION
Child elements | <company-revision-infos> <team-member-ref> <date> <modifications>
parent elements | <doc-revisions>
Attributes for DOC-REVISION
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | date:date |
[S] | cdata | implied |  |
Description This element gets all information of the document revision in question.

Example


5.12. DOC-REVISIONS

Figure 49: DTD-diagram for DOC-REVISIONS
Child elements | <doc-revision>
parent elements | <admin-data>
Attributes for DOC-REVISIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This is the collection of all known revisions of the document thus establishing the revision history. It is highly recommended that the most actual revision is on top.


6. E ... ENTRY

MSRSW.DTD Elements and attributes
6. E ... ENTRY

Contents of this chapter:
  • 6.1. E
  • 6.2. EMAIL
  • 6.3. ENTITY-NAME
  • 6.4. ENTRY


6.1. E

Figure 50: DTD-diagram for E
Child elements | none
parent elements | <change> <desc> <indent-sample> <item-label> <p> <reason> <tbr>
Attributes for E
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | nmtkgrp | default | BOLD BOLD ITALIC |


6.2. EMAIL

Figure 51: DTD-diagram for EMAIL
Child elements | none
parent elements | <team-member>
Attributes for EMAIL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


6.3. ENTITY-NAME

Figure 52: DTD-diagram for ENTITY-NAME
Child elements | none
parent elements | <company-doc-info>
Attributes for ENTITY-NAME
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Filename of the document fragment (if there is one). This is used to divide a document in multiple entities. SGML tools do not reflect this (physical) fragmentation on a logical level. Therefore, it must be entered manually here.


6.4. ENTRY

Figure 53: DTD-diagram for ENTRY
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <row>
Attributes for ENTRY
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | implied | LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | implied |  |
[CHAROFF] | nutoken | implied |  |
[COLNAME] | nmtoken | implied |  |
[COLSEP] | number | implied |  |
[MOREROWS] | number | default | 0 |
[NAMEEND] | nmtoken | implied |  |
[NAMEST] | nmtoken | implied |  |
[ROTATE] | number | default | 0 |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[SPANNAME] | nmtoken | implied |  |
[VALIGN] | nmtkgrp | default | TOP TOP BOTTOM MIDDLE |


7. FAX ... FUNCTION-REF

MSRSW.DTD Elements and attributes
7. FAX ... FUNCTION-REF

Contents of this chapter:
  • 7.1. FAX
  • 7.2. FIGURE
  • 7.3. FILE
  • 7.4. FORMULA
  • 7.5. FT
  • 7.6. FUNCTION-REF


7.1. FAX

Figure 54: DTD-diagram for FAX
Child elements | none
parent elements | <team-member>
Attributes for FAX
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


7.2. FIGURE

Figure 55: DTD-diagram for FIGURE
Child elements | <long-name> <short-name> <graphic> <verbatim> <desc>
parent elements | <add-info> <chapter> <entry> <introduction> <item> <labeled-item> <ncoi-1> <remark> <sw-addressing-method-desc> <sw-application-notes> <sw-carb-doc> <sw-code-syntax-desc> <sw-function-def> <sw-function-desc> <sw-maintenance-notes> <sw-param-record-layout-desc> <sw-test-spec> <topic-1> <topic-2>
Attributes for FIGURE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FIGURE |
[FLOAT] | nmtkgrp | implied | FLOAT NO-FLOAT |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Graphics can be linked using this element.

Example


7.3. FILE

Figure 56: DTD-diagram for FILE
Child elements | none
parent elements | <std> <xdoc> <xfile>
Attributes for FILE
Name | Type | Class | Value | Remark
[FILENAME] | cdata | required |  |
[NOTATION] | cdata | required |  |
[S] | cdata | implied |  |
[TOOL] | cdata | required |  |
[TOOL-VERSION] | cdata | required |  |
Description Information on a file name for referencing an external file (e.g. a standard). With respect to the limited capabilites of SGML's entity and notation mechanism this is not used here.

Example
<file filename="agr.eps" notation="eps" tool="ascet" tool-version="sd"></file>


7.4. FORMULA

Figure 57: DTD-diagram for FORMULA
Child elements | <long-name> <short-name> <graphic> <verbatim> <tex-math> <c-code> <generic-math>
parent elements | <add-info> <chapter> <entry> <introduction> <item> <labeled-item> <ncoi-1> <remark> <sw-addressing-method-desc> <sw-application-notes> <sw-carb-doc> <sw-code-syntax-desc> <sw-function-desc> <sw-maintenance-notes> <sw-param-record-layout-desc> <sw-test-spec> <topic-1> <topic-2>
Attributes for FORMULA
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FORMULA |
[ID] | id | required |  |
[S] | cdata | implied |  |


7.5. FT

Figure 58: DTD-diagram for FT
Child elements | none
parent elements | <change> <desc> <indent-sample> <item-label> <p> <reason> <tbr>
Attributes for FT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


7.6. FUNCTION-REF

Figure 59: DTD-diagram for FUNCTION-REF
Child elements | none
parent elements | <sw-fulfils>
Attributes for FUNCTION-REF
Name | Type | Class | Value | Remark
[FUNCTION] | idref | required |  |
[HYNAMES] | names | fixed | LINKEND FUNCTION |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
Description This is an external reference to a <function> within <behaviour> in an instance of MSRSYS DTD.

Example


8. GENERAL-PROJECT-DATA ... GRAPHIC

MSRSW.DTD Elements and attributes
8. GENERAL-PROJECT-DATA ... GRAPHIC

Contents of this chapter:
  • 8.1. GENERAL-PROJECT-DATA
  • 8.2. GENERIC-MATH
  • 8.3. GRAPHIC


8.1. GENERAL-PROJECT-DATA

Figure 60: DTD-diagram for GENERAL-PROJECT-DATA
Child elements | <na> <tbd> <tbr> <admin-data> <introduction> <system-overview> <reason-order> <objectives> <sample-spec> <variant-spec> <demarcation-other-projects> <parallel-designs> <integration-capability> <acceptance-cond> <project-schedule> <purchasing-cond> <protocols> <dir-hand-over-doc-data> <add-spec>
parent elements | <company>
Attributes for GENERAL-PROJECT-DATA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description General project data.

Example


8.2. GENERIC-MATH

Figure 61: DTD-diagram for GENERIC-MATH
Child elements | none
parent elements | <formula>
Attributes for GENERIC-MATH
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element is inteded for the definition of semantic math description which can be processed by math processors. Acutally there is no recommendation for the language of the formula specification or usage of a special rendering system.

Example


8.3. GRAPHIC

Figure 62: DTD-diagram for GRAPHIC
Child elements | none
parent elements | <figure> <formula>
Attributes for GRAPHIC
Name | Type | Class | Value | Remark
[CATEGORY] | nmtkgrp | implied | BARCODE CONCEPTUAL ENGINEERING FLOWCHART GRAPH LOGO SCHEMATIC WAVEFORM |
[FILENAME] | cdata | required |  |
[FIT] | number | default | 0 |
[HEIGHT] | cdata | implied |  |
[NOTATION] | cdata | required |  |
[S] | cdata | implied |  |
[SCALE] | cdata | implied |  |
[WIDTH] | cdata | implied |  |
Description The treatment of the graphic is determined by the attributes of <graphic>:

Do not enter annotating text to <long-name>in<figure> or <table>(like Figure 1: ...). This embellishment is the task of the processing system, not of the author. If the author adds these things, they will be there twice since the rendition system will add it again.
[category]
Denotes the category of the graphic. This information can be used to generate more specific list of figures
[filename]
Denotes the system filename where the rendition system can find the graphic. This is not necessarily the final format. It is up to the rendition system to locate the graphic in the company specific environment, to change the file extension to get the appropriate graphic representation.
The type of this attribute can be turned from SDATA toENTITY in the DTD file in order to allow SGML tools access to the file using its entity manager. In this case, the entity name should be chosen in the style of a filename (e.g. crpctmt.wmf) [image] .
[fit]

0 | figure is placed in original size. If it does not fit on the page or the available space, it is scaled down.
1 | the figure is scaled up or down to fit the page as possible. This value will be ignored if [width] or [height] is specified in addition.
2 | the figure is rotated counterclockwise by 90° if it is landscape and is wider than the actual text area. It is scaled down to the page size if it does not fit otherwise. This value will be ignored if [width] or [height] is specified in addition.
3 | the figure is always rotated counterclockwise by 90°. If it does not fit on the page it will be scaled down. If [width] or [height] is specified in addition, the figure will be rotated and then scaled to the specified values.
4 | the figure is always rotated counterclockwise by 90° and scaled up or down for best fit on the page. This value will be ignored if [width] or [height] is specified in addition.
[height]
If this attribute has a value, the figure will be scaled to the defined height which is a real value with dimensions (e.g. "10cm", "150mm", "12.5in"). If also [width]is specified the figure will be distorted. This value always specifies the width of the "figure box" on the page after possible scaling/rotating.
[notation]
This attribute specifies the format of the graphic file if used by an SGML Application supporting notations.
[scale]
If this attribute receives a value, the figure will be scaled by the given factor which must be a signed real number. Numbers greater 1 increase the size of the figure, values less than 1 make the figure smaller. For example with scale="0.5" the a figure of the size 10x10 cm will appear as 5*5cm.
[width]
If this attribute has a value, the figure will be scaled to the defined width which is a real value with dimensions (e.g. "10cm", "150mm", "12.5in"). If also [height]is specified the figure will be distorted. This value always specifies the width of the "figure box" on the page after possible scaling/rotating.
The scaling attribute precedence is:
  • [scale] has precedence over all
  • [fit]has precedence over [width]and/or [height]
Example
<graphic filename="ggub.eps" notation="eps"></graphic>

This is the way how this document is prepared. It is visible in the sgml source.


9. HOMEPAGE ... HOMEPAGE

MSRSW.DTD Elements and attributes
9. HOMEPAGE ... HOMEPAGE

Contents of this chapter:
  • 9.1. HOMEPAGE


9.1. HOMEPAGE

Figure 63: DTD-diagram for HOMEPAGE
Child elements | none
parent elements | <team-member>
Attributes for HOMEPAGE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


10. IE ... ITEM-LABEL

MSRSW.DTD Elements and attributes
10. IE ... ITEM-LABEL

Contents of this chapter:
  • 10.1. IE
  • 10.2. INDENT-SAMPLE
  • 10.3. INTEGRATION-CAPABILITY
  • 10.4. INTRODUCTION
  • 10.5. ITEM
  • 10.6. ITEM-LABEL


10.1. IE

Figure 64: DTD-diagram for IE
Child elements | <sup> <sub>
parent elements | <change> <desc> <indent-sample> <item-label> <long-name> <long-name-1> <p> <reason> <tbr>
Attributes for IE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | cdata | implied |  |
Description This is an index entry. The contents only appears in the index, not at the location where it is defined. This allows to define slightly different wording for the index than in the text itself.

Example
<p>This is an example of an <ie>index element</ie>index entry


10.2. INDENT-SAMPLE

Figure 65: DTD-diagram for INDENT-SAMPLE
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <labeled-list>
Attributes for INDENT-SAMPLE
Name | Type | Class | Value | Remark
[ITEM-LABEL-POS] | nmtkgrp | default | NO-NEWLINE NO-NEWLINE NEWLINE NEWLINE-IF-NECESSARY |
[S] | cdata | implied |  |


10.3. INTEGRATION-CAPABILITY

Figure 66: DTD-diagram for INTEGRATION-CAPABILITY
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for INTEGRATION-CAPABILITY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


10.4. INTRODUCTION

Figure 67: DTD-diagram for INTRODUCTION
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <topic-2>
parent elements | <acceptance-cond> <add-spec> <company-revision-info> <demarcation-other-projects> <dir-hand-over-doc-data> <general-project-data> <integration-capability> <msrsw> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <sw-data-dictionary-spec> <sw-function-spec> <sw-glossary> <sw-param-contents-spec> <system-overview> <variant-spec>
Attributes for INTRODUCTION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This is used to give a short introduction about the subject in question. It exists at the beginning of its parent element. It is not intended to use <introduction> for a full fledged description.

Example
<introduction>
  <p>This system is used to control the engine.</p>
</introduction>


10.5. ITEM

Figure 68: DTD-diagram for ITEM
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <list>
Attributes for ITEM
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


10.6. ITEM-LABEL

Figure 69: DTD-diagram for ITEM-LABEL
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <labeled-item>
Attributes for ITEM-LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


11. LABEL ... LONG-NAME-1

MSRSW.DTD Elements and attributes
11. LABEL ... LONG-NAME-1

Contents of this chapter:
  • 11.1. LABEL
  • 11.2. LABELED-ITEM
  • 11.3. LABELED-LIST
  • 11.4. LABELS
  • 11.5. LANGUAGE
  • 11.6. LIST
  • 11.7. LOCS
  • 11.8. LONG-NAME
  • 11.9. LONG-NAME-1


11.1. LABEL

Figure 70: DTD-diagram for LABEL
Child elements | none
parent elements | <annotation> <labels> <note> <overall-project> <prms> <project>
Attributes for LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Serves as a title (similar to <long-name>) for an object that must not, and cannot, be referenced, i.e. possesses no< short-name> and no [id].

A <label> within <sw-param-value-block> is a long designation for the characteristic values of a characteristic values block.
Example
<sw-param-value-block>
   <sw-param-axis-values>
      <sw-compu-method-ref sw-compu-method="dez">
         </sw-compu-method-ref>
         <labels>
            <label>sensor rear left</label>
            <label>sensor rear right</label>
            <label>sensor front left</label>
            <label>sensor front right</label>
         <l/abels>
   </sw-param-axis-values>
   <count>4</count>
</sw-param-value-block>


11.2. LABELED-ITEM

Figure 71: DTD-diagram for LABELED-ITEM
Child elements | <item-label> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <labeled-list>
Attributes for LABELED-ITEM
Name | Type | Class | Value | Remark
[HELP-ENTRY] | cdata | implied |  |
[S] | cdata | implied |  |


11.3. LABELED-LIST

Figure 72: DTD-diagram for LABELED-LIST
Child elements | <indent-sample> <labeled-item>
parent elements | <add-info> <chapter> <entry> <introduction> <item> <labeled-item> <ncoi-1> <remark> <sw-addressing-method-desc> <sw-application-notes> <sw-carb-doc> <sw-code-syntax-desc> <sw-function-desc> <sw-maintenance-notes> <sw-param-record-layout-desc> <sw-test-spec> <topic-1> <topic-2>
Attributes for LABELED-LIST
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


11.4. LABELS

Figure 73: DTD-diagram for LABELS
Child elements | <label>
parent elements | <sw-param-axis-values>
Attributes for LABELS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Set of labels for axis values giving the meaning of each individual value in an <sw-param-value-block>.

Example
<sw-param-value-block>
   <sw-param-axis-values>
      <sw-compu-method-ref sw-compu-method="dez">
         </sw-compu-method-ref>
         <labels>
            <label>sensor rear left</label>
            <label>sensor rear right</label>
            <label>sensor front left</label>
            <label>sensor front right</label>
         <l/abels>
   </sw-param-axis-values>
   <count>4</count>
</sw-param-value-block>


11.5. LANGUAGE

Figure 74: DTD-diagram for LANGUAGE
Child elements | none
parent elements | <admin-data>
Attributes for LANGUAGE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Identifies the masterlanguage for <admin-data>

Example


11.6. LIST

Figure 75: DTD-diagram for LIST
Child elements | <item>
parent elements | <add-info> <chapter> <entry> <introduction> <item> <labeled-item> <ncoi-1> <remark> <sw-addressing-method-desc> <sw-application-notes> <sw-carb-doc> <sw-code-syntax-desc> <sw-function-desc> <sw-maintenance-notes> <sw-param-record-layout-desc> <sw-test-spec> <topic-1> <topic-2>
Attributes for LIST
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | nmtkgrp | required | UNNUMBER NUMBER |


11.7. LOCS

Figure 76: DTD-diagram for LOCS
Child elements | <nameloc>
parent elements | <msrsw>
Attributes for LOCS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element is used for cross document/entity referencing (HyTime referencing using namelocs)

Example


11.8. LONG-NAME

Figure 77: DTD-diagram for LONG-NAME
Child elements | <tt> <ie>
parent elements | <chapter> <company> <def-item> <figure> <formula> <nameloc> <prm> <sample> <sw-addressing-method> <sw-code-syntax> <sw-compu-method> <sw-function> <sw-param> <sw-param-record-layout> <sw-physic-type> <sw-unit> <sw-variable> <table> <team-member> <topic-1> <topic-2> <variant-char> <variant-def>
Attributes for LONG-NAME
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Long designation, e.g. "Engine temperature".

Example
<sw-variable id="tmot">
   <long-name>engine temperature</long-name>
   <short-name>tmot</short-name>
   <desc></desc>
    ...
</sw-variable>


11.9. LONG-NAME-1

Figure 78: DTD-diagram for LONG-NAME-1
Child elements | <tt> <ie>
parent elements | <std> <xdoc> <xfile>
Attributes for LONG-NAME-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


12. MAX ... MSRSW

MSRSW.DTD Elements and attributes
12. MAX ... MSRSW

Contents of this chapter:
  • 12.1. MAX
  • 12.2. MAX-COUNT
  • 12.3. MIN
  • 12.4. MODIFICATION
  • 12.5. MODIFICATIONS
  • 12.6. MSRSW


12.1. MAX

Figure 79: DTD-diagram for MAX
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for MAX
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Maximum value of a parameter


12.2. MAX-COUNT

Figure 80: DTD-diagram for MAX-COUNT
Child elements | none
parent elements | <sw-axis-individual> <sw-axis-shift-offset>
Attributes for MAX-COUNT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Maximum number of datapoints

Example


12.3. MIN

Figure 81: DTD-diagram for MIN
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for MIN
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Minimum value for prm-char

Example


12.4. MODIFICATION

Figure 82: DTD-diagram for MODIFICATION
Child elements | <change> <reason>
parent elements | <modifications>
Attributes for MODIFICATION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | nmtkgrp | required | CONTENT-RELATED DOC-RELATED |
Description

Example


12.5. MODIFICATIONS

Figure 83: DTD-diagram for MODIFICATIONS
Child elements | <modification>
parent elements | <doc-revision>
Attributes for MODIFICATIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description

Example


12.6. MSRSW

Figure 84: DTD-diagram for MSRSW
Child elements | <short-name> <project-data> <admin-data> <introduction> <sw-function-refs> <sw-data-dictionary-spec> <sw-function-spec> <sw-param-contents-spec> <add-spec> <sw-glossary> <locs>
parent elements | none
Attributes for MSRSW
Name | Type | Class | Value | Remark
[F-NAMESPACE] | names | fixed | COMPANY SAMPLE TEAM-MEMBER VARIANT-CHAR VARIANT-DEF XDOC XFILE STD DEF-ITEM FIGURE FORMULA TABLE PRM TOPIC CHAPTER SW-ADDRESSING-METHOD SW-CODE-SYNTAX SW-COMPU-METHOD SW-FUNCTION SW-PARAM SW-PARAM-RECORD-LAYOUT SW-PHYSIC-TYPE SW-UNIT SW-VARIABLE |
[F-PUBID] | cdata | fixed | -//MSR//DTD MSR SOFTWARE DTD:V1.1.0:MSRSW.DTD//EN |
[HYTIME] | name | fixed | HYDOC |
[PUBID] | cdata | default | -//MSR//DTD MSR SOFTWARE DTD:V1.1.0:MSRSW.DTD//EN |
[S] | cdata | implied |  |
Description Root elelement

Example


13. NA ... NUMBER

MSRSW.DTD Elements and attributes
13. NA ... NUMBER

Contents of this chapter:
  • 13.1. NA
  • 13.2. NAMELOC
  • 13.3. NCOI-1
  • 13.4. NMLIST
  • 13.5. NOTE
  • 13.6. NUMBER


13.1. NA

Figure 85: DTD-diagram for NA
Child elements | none
parent elements | <acceptance-cond> <add-spec> <demarcation-other-projects> <dir-hand-over-doc-data> <general-project-data> <integration-capability> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <sw-data-dictionary-spec> <sw-function-spec> <sw-glossary> <sw-param-contents-spec> <system-overview> <variant-spec>
Attributes for NA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element is used instead of sub-structures if certain statements are not relevant ("not applicable").

Example
<sw-param-contents-spec>
   <na></na>
</sw-param-contents-spec>


13.2. NAMELOC

Figure 86: DTD-diagram for NAMELOC
Child elements | <long-name> <short-name> <nmlist>
parent elements | <locs>
Attributes for NAMELOC
Name | Type | Class | Value | Remark
[HYTIME] | name | fixed | NAMELOC |
[ID] | id | required |  |
[S] | cdata | implied |  |


13.3. NCOI-1

Figure 87: DTD-diagram for NCOI-1
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <acceptance-cond> <add-spec> <demarcation-other-projects> <dir-hand-over-doc-data> <integration-capability> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample> <sw-function-def> <sw-glossary> <system-overview>
Attributes for NCOI-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This is a general element that contains informal and non-software-specific structures ("none coded information").

Example


13.4. NMLIST

Figure 88: DTD-diagram for NMLIST
Child elements | none
parent elements | <nameloc>
Attributes for NMLIST
Name | Type | Class | Value | Remark
[DOCORSUB] | entity | implied |  |
[HYTIME] | name | fixed | NMLIST |
[NAMETYPE] | nmtkgrp | default | ELEMENT ENTITY ELEMENT |
[S] | cdata | implied |  |


13.5. NOTE

Figure 89: DTD-diagram for NOTE
Child elements | <label> <p>
parent elements | <add-info> <chapter> <entry> <introduction> <item> <labeled-item> <ncoi-1> <remark> <sw-addressing-method-desc> <sw-application-notes> <sw-carb-doc> <sw-code-syntax-desc> <sw-function-desc> <sw-maintenance-notes> <sw-param-record-layout-desc> <sw-test-spec> <topic-1> <topic-2>
Attributes for NOTE
Name | Type | Class | Value | Remark
[NOTE-TYPE] | nmtkgrp | required | CAUTION HINT TIP INSTRUCTION EXERCISE OTHER |
[S] | cdata | implied |  |
[USER-DEFINED-TYPE] | cdata | implied |  |


13.6. NUMBER

Figure 90: DTD-diagram for NUMBER
Child elements | none
parent elements | <xdoc>
Attributes for NUMBER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


14. OBJECTIVES ... OVERALL-PROJECT

MSRSW.DTD Elements and attributes
14. OBJECTIVES ... OVERALL-PROJECT

Contents of this chapter:
  • 14.1. OBJECTIVES
  • 14.2. OFFSET
  • 14.3. OVERALL-PROJECT


14.1. OBJECTIVES

Figure 91: DTD-diagram for OBJECTIVES
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for OBJECTIVES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


14.2. OFFSET

Figure 92: DTD-diagram for OFFSET
Child elements | none
parent elements | <sw-axis-shift-offset>
Attributes for OFFSET
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description The datapoints are defined by an algorithm for fixed characteristics and maps. Example for an algorithm: Datapoint[i] = ( ... shift ) * x + offset

Example
<sw-axis-shift-offset>
   <sw-variable-ref>var1</sw-variable-ref>
   <max-count>4</max-count>
   <shift>2</shift>
   <offset>3</offset>
<sw-axis-shift-offset></sw-axis-shift-offset>


14.3. OVERALL-PROJECT

Figure 93: DTD-diagram for OVERALL-PROJECT
Child elements | <label> <desc>
parent elements | <project-data>
Attributes for OVERALL-PROJECT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15. P ... PURCHASING-COND

MSRSW.DTD Elements and attributes
15. P ... PURCHASING-COND

Contents of this chapter:
  • 15.1. P
  • 15.2. PARALLEL-DESIGNS
  • 15.3. PHONE
  • 15.4. PHYS
  • 15.5. PHYS-MAX
  • 15.6. PHYS-MIN
  • 15.7. POSITION
  • 15.8. PRIVATE-CODE
  • 15.9. PRIVATE-CODES
  • 15.10. PRM
  • 15.11. PRM-CHAR
  • 15.12. PRMS
  • 15.13. PROG-CODE
  • 15.14. PROJECT
  • 15.15. PROJECT-DATA
  • 15.16. PROJECT-SCHEDULE
  • 15.17. PROTOCOLS
  • 15.18. PUBLISHER
  • 15.19. PURCHASING-COND


15.1. P

Figure 94: DTD-diagram for P
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie> <std> <xdoc> <xfile>
parent elements | <add-info> <annotation-text> <chapter> <cond> <def> <entry> <introduction> <item> <labeled-item> <ncoi-1> <note> <remark> <sw-addressing-method-desc> <sw-application-notes> <sw-carb-doc> <sw-code-syntax-desc> <sw-function-desc> <sw-maintenance-notes> <sw-param-record-layout-desc> <sw-test-spec> <topic-1> <topic-2>
Attributes for P
Name | Type | Class | Value | Remark
[HELP-ENTRY] | cdata | implied |  |
[S] | cdata | implied |  |
Description Paragraph. A paragraph can comprise text and the elements tt (technical text), xref (cross reference), e (text attribute like bold), ft (footnote), sup (superscript), sub (subscript), ie (index entry), std (standard), xdoc (external document), xfile (external file) in any arbitrary, though not hierarchical, order.

Example
<sw-function-desc>
   <p>This function describes the <ie>exhaust-gas return</ie>. Refer to <std> ... </std></p>
</sw-function-desc>


15.2. PARALLEL-DESIGNS

Figure 95: DTD-diagram for PARALLEL-DESIGNS
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PARALLEL-DESIGNS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.3. PHONE

Figure 96: DTD-diagram for PHONE
Child elements | none
parent elements | <team-member>
Attributes for PHONE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.4. PHYS

Figure 97: DTD-diagram for PHYS
Child elements | <phys-min> <phys-max>
parent elements | <sw-limits> <sw-limits>
Attributes for PHYS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.5. PHYS-MAX

Figure 98: DTD-diagram for PHYS-MAX
Child elements | none
parent elements | <phys>
Attributes for PHYS-MAX
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.6. PHYS-MIN

Figure 99: DTD-diagram for PHYS-MIN
Child elements | none
parent elements | <phys>
Attributes for PHYS-MIN
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.7. POSITION

Figure 100: DTD-diagram for POSITION
Child elements | none
parent elements | <std> <xdoc>
Attributes for POSITION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.8. PRIVATE-CODE

Figure 101: DTD-diagram for PRIVATE-CODE
Child elements | none
parent elements | <private-codes>
Attributes for PRIVATE-CODE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | cdata | implied |  |
Description

Example
<private-codes>
   <private-code> TYPE="generated_by_ASCET-SD">$generated_by_ASCET-SD:2.2.0$ </private-code>
   <private-code> TYPE="Implementation xy">Implementation xy</private-code>
</private-codes>


15.9. PRIVATE-CODES

Figure 102: DTD-diagram for PRIVATE-CODES
Child elements | <private-code>
parent elements | <company-doc-info>
Attributes for PRIVATE-CODES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description

Example
<company-doc-infos>
   <private-codes>
   <private-codes>
      <private-code> TYPE="generated_by_ASCET-SD">$generated_by_ASCET-SD:2.2.0$ </private-code>

   </private-codes>
</company-doc-infos>


15.10. PRM

Figure 103: DTD-diagram for PRM
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <prms>
Attributes for PRM
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description A parameter model has been implemented in MSR. There are 2 possibilities given. A parameter can be specified either by defining <abs>,<tol> or by defining <min>, <typ> and <max>.

Example


15.11. PRM-CHAR

Figure 104: DTD-diagram for PRM-CHAR
Child elements | <cond> <abs> <tol> <min> <typ> <max> <unit> <text> <remark>
parent elements | <prm>
Attributes for PRM-CHAR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Description of the parameter characteristics of a parameter

Example
<sw-prm>
   <long-name>long designation</long-name>
   <short-name>short designation</short-name>
   <min>10</min>
   <typ>45</typ>
   <max>90</max>
   <unit>°C</unit>
</sw-prm>


15.12. PRMS

Figure 105: DTD-diagram for PRMS
Child elements | <label> <prm>
parent elements | <add-info> <chapter> <ncoi-1> <sw-addressing-method-desc> <sw-application-notes> <sw-carb-doc> <sw-code-syntax-desc> <sw-function-desc> <sw-maintenance-notes> <sw-param-record-layout-desc> <sw-test-spec> <topic-1>
Attributes for PRMS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description List of parameters

Example


15.13. PROG-CODE

Figure 106: DTD-diagram for PROG-CODE
Child elements | none
parent elements | <sw-compu-method>
Attributes for PROG-CODE
Name | Type | Class | Value | Remark
[LANG-SUBSET] | names | implied |  |
[PROG-LANG] | cdata | implied |  |
[S] | cdata | implied |  |
[USED-LIBS] | nmtokens | implied |  |
Description Description of conversion formulae in a programming language notation

Example


15.14. PROJECT

Figure 107: DTD-diagram for PROJECT
Child elements | <label> <desc> <companies>
parent elements | <project-data>
Attributes for PROJECT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Information regarding a project.

Example


15.15. PROJECT-DATA

Figure 108: DTD-diagram for PROJECT-DATA
Child elements | <overall-project> <project>
parent elements | <msrsw>
Attributes for PROJECT-DATA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Project data

Example


15.16. PROJECT-SCHEDULE

Figure 109: DTD-diagram for PROJECT-SCHEDULE
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PROJECT-SCHEDULE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.17. PROTOCOLS

Figure 110: DTD-diagram for PROTOCOLS
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PROTOCOLS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.18. PUBLISHER

Figure 111: DTD-diagram for PUBLISHER
Child elements | none
parent elements | <xdoc>
Attributes for PUBLISHER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.19. PURCHASING-COND

Figure 112: DTD-diagram for PURCHASING-COND
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PURCHASING-COND
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


16. REASON ... ROW

MSRSW.DTD Elements and attributes
16. REASON ... ROW

Contents of this chapter:
  • 16.1. REASON
  • 16.2. REASON-ORDER
  • 16.3. REMARK
  • 16.4. REVISION-LABEL
  • 16.5. ROLE
  • 16.6. ROLES
  • 16.7. ROW


16.1. REASON

Figure 113: DTD-diagram for REASON
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <modification>
Attributes for REASON
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description

Example


16.2. REASON-ORDER

Figure 114: DTD-diagram for REASON-ORDER
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for REASON-ORDER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


16.3. REMARK

Figure 115: DTD-diagram for REMARK
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <prm-char> <sw-physic-type> <sw-physic-type-1>
Attributes for REMARK
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


16.4. REVISION-LABEL

Figure 116: DTD-diagram for REVISION-LABEL
Child elements | none
parent elements | <company-revision-info>
Attributes for REVISION-LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Revision

Example
<company-revision-info>
    <company-ref></company-ref>
    <revision-label>10.4</revision-label>
    <state></state>
</company-revision-info>


16.5. ROLE

Figure 117: DTD-diagram for ROLE
Child elements | none
parent elements | <roles>
Attributes for ROLE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


16.6. ROLES

Figure 118: DTD-diagram for ROLES
Child elements | <role>
parent elements | <team-member>
Attributes for ROLES
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | role:selection |
[S] | cdata | implied |  |


16.7. ROW

Figure 119: DTD-diagram for ROW
Child elements | <entry>
parent elements | <tbody> <tfoot> <thead>
Attributes for ROW
Name | Type | Class | Value | Remark
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |


17. SAMPLE ... SW-ADDRESSING-METHODS

MSRSW.DTD Elements and attributes
17. SAMPLE ... SW-ADDRESSING-METHODS

Contents of this chapter:
  • 17.1. SAMPLE
  • 17.2. SAMPLE-REF
  • 17.3. SAMPLE-SPEC
  • 17.4. SAMPLES
  • 17.5. SCHEDULE
  • 17.6. SHIFT
  • 17.7. SHORT-NAME
  • 17.8. SI-UNIT
  • 17.9. SPANSPEC
  • 17.10. STATE
  • 17.11. STATE-1
  • 17.12. STD
  • 17.13. SUB
  • 17.14. SUBTITLE
  • 17.15. SUP
  • 17.16. SW-ADDRESSING-METHOD
  • 17.17. SW-ADDRESSING-METHOD-CLASS
  • 17.18. SW-ADDRESSING-METHOD-DESC
  • 17.19. SW-ADDRESSING-METHOD-REF
  • 17.20. SW-ADDRESSING-METHODS


17.1. SAMPLE

Figure 120: DTD-diagram for SAMPLE
Child elements | <long-name> <short-name> <ncoi-1>
parent elements | <samples>
Attributes for SAMPLE
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | long-name:selection |
[F-ID-CLASS] | name | fixed | SAMPLE |
[ID] | id | required |  |
[S] | cdata | implied |  |


17.2. SAMPLE-REF

Figure 121: DTD-diagram for SAMPLE-REF
Child elements | none
parent elements | <schedule>
Attributes for SAMPLE-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND SAMPLE |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[SAMPLE] | idref | required |  |


17.3. SAMPLE-SPEC

Figure 122: DTD-diagram for SAMPLE-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <samples>
parent elements | <general-project-data>
Attributes for SAMPLE-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


17.4. SAMPLES

Figure 123: DTD-diagram for SAMPLES
Child elements | <sample>
parent elements | <sample-spec>
Attributes for SAMPLES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


17.5. SCHEDULE

Figure 124: DTD-diagram for SCHEDULE
Child elements | <sample-ref> <date>
parent elements | <tbd>
Attributes for SCHEDULE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


17.6. SHIFT

Figure 125: DTD-diagram for SHIFT
Child elements | none
parent elements | <sw-axis-shift-offset>
Attributes for SHIFT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description The datapoints are defined by an algorithm for fixed characteristics and fixed maps. Example for an algorithm: Datapoint[i] = ( ... shift ) * x + offset

Example
<sw-axis-shift-offset>
   <sw-variable-ref>var1</sw-variable-ref>
   <max-count>4</max-count>
   <shift>2</shift>
   <offset>3</offset>
<sw-axis-shift-offset></sw-axis-shift-offset>


17.7. SHORT-NAME

Figure 126: DTD-diagram for SHORT-NAME
Child elements | none
parent elements | <chapter> <company> <def-item> <figure> <formula> <msrsw> <nameloc> <prm> <sample> <std> <sw-addressing-method> <sw-code-syntax> <sw-compu-method> <sw-function> <sw-param> <sw-param-record-layout> <sw-physic-type> <sw-unit> <sw-variable> <table> <team-member> <topic-1> <topic-2> <variant-char> <variant-def> <xdoc> <xfile>
Attributes for SHORT-NAME
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Short designation, e.g. "TMOT". The <short-name> has an identifying character, in particular for outside references (e.g. ASAP, ASCET).

Example


17.8. SI-UNIT

Figure 127: DTD-diagram for SI-UNIT
Child elements | none
parent elements | <sw-unit>
Attributes for SI-UNIT
Name | Type | Class | Value | Remark
[AMOUNT-OF-SUBSTANCE-EXPO] | cdata | implied |  |
[ELECTRIC-CURRENT-EXPO] | cdata | implied |  |
[LENGTH-EXPO] | cdata | implied |  |
[LUMINOUS-INTENSITY-EXPO] | cdata | implied |  |
[MASS-EXPO] | cdata | implied |  |
[S] | cdata | implied |  |
[THERMODYNAMIC-TEMPERATURE-EXPO] | cdata | implied |  |
[TIME-EXPO] | cdata | implied |  |
Description There are SI units of measure for the units of measure. STEP (ISO/DIS 10303-41. S96ff) is supported with regard to SI units by seven basic units (length, mass, time, electric_current, thermodynamic_temperature, amount_of_substance, luminous_intensity). These basic units are realized by means of attributes.

Example
<sw-unit>
      <long-name>Meter per second</long-name>
      <short-name>mps</short-name>
      <si-unit length-expo = "1" time-expo = "-1"></si-unit>
          <sw-unit-display></sw-unit-display>
   </sw-unit>


17.9. SPANSPEC

Figure 128: DTD-diagram for SPANSPEC
Child elements | none
parent elements | <tgroup>
Attributes for SPANSPEC
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | default | CENTER LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | implied |  |
[CHAROFF] | nutoken | implied |  |
[COLSEP] | number | implied |  |
[NAMEEND] | nmtoken | required |  |
[NAMEST] | nmtoken | required |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[SPANNAME] | nmtoken | required |  |


17.10. STATE

Figure 129: DTD-diagram for STATE
Child elements | none
parent elements | <company-revision-info>
Attributes for STATE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description

Example


17.11. STATE-1

Figure 130: DTD-diagram for STATE-1
Child elements | none
parent elements | <std> <xdoc>
Attributes for STATE-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


17.12. STD

Figure 131: DTD-diagram for STD
Child elements | <long-name-1> <short-name> <subtitle> <state-1> <date-1> <file> <position>
parent elements | <p> <tbr>
Attributes for STD
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | date-1:date |
[F-ID-CLASS] | name | fixed | STD |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description

Example
<std>
   <long-name-1>ISO/DIS 10303-41 units of measure</long-name-1>
   <short-name>ISO/DIS 10303-41</short-name>
   <subtitle>SI units of measure</subtitle>
   <state-1></state-1>
   <date-1></date-1>
   <file>ISO10303-41.std</file>
   <position>S96ff</position>
</std>


17.13. SUB

Figure 132: DTD-diagram for SUB
Child elements | none
parent elements | <abs> <change> <desc> <ie> <indent-sample> <item-label> <max> <min> <p> <reason> <sw-unit-display> <tbr> <text> <tol> <typ> <unit>
Attributes for SUB
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


17.14. SUBTITLE

Figure 133: DTD-diagram for SUBTITLE
Child elements | none
parent elements | <std>
Attributes for SUBTITLE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


17.15. SUP

Figure 134: DTD-diagram for SUP
Child elements | none
parent elements | <abs> <change> <desc> <ie> <indent-sample> <item-label> <max> <min> <p> <reason> <sw-unit-display> <tbr> <text> <tol> <typ> <unit>
Attributes for SUP
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


17.16. SW-ADDRESSING-METHOD

Figure 135: DTD-diagram for SW-ADDRESSING-METHOD
Child elements | <admin-data> <long-name> <short-name> <sw-addressing-method-class> <sw-addressing-method-desc>
parent elements | <sw-addressing-methods>
Attributes for SW-ADDRESSING-METHOD
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | SW-ADDRESSING-METHOD |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Describes the addressing scheme. A description of how a parameter or a RAM variable from the control unit is given. Examples for the differing types of addressing are the direct addressing and the indirect addressing by a vector. The addressing scheme can also be used to define the RAM range in which the a RAM variable lies (e.g. in the internal or external RAM). Addressing schemes can be used by parameters and RAM variables.

This element is a reference to an access method for a name that must be simulated in the following systems (e.g. adjustment systems). This name links the MSR entity and the following systems.
Addressing schemes are not standardized or pre-defined in the DTD. Neither are they fully modeled. They are only described in terms of text in <sw-addressing-method-desc>.
Example


17.17. SW-ADDRESSING-METHOD-CLASS

Figure 136: DTD-diagram for SW-ADDRESSING-METHOD-CLASS
Child elements | none
parent elements | <sw-addressing-method>
Attributes for SW-ADDRESSING-METHOD-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Gives the class for the addressing scheme. Parameters or variables can only use addressing schemes of a certain class. This however cannot be assured by SGML means; the application must do this.

Addressing-scheme classes are not standardized or pre-defined in the DTD.
Example


17.18. SW-ADDRESSING-METHOD-DESC

Figure 137: DTD-diagram for SW-ADDRESSING-METHOD-DESC
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <sw-addressing-method>
Attributes for SW-ADDRESSING-METHOD-DESC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Text-form description of the addressing schemes

Example


17.19. SW-ADDRESSING-METHOD-REF

Figure 138: DTD-diagram for SW-ADDRESSING-METHOD-REF
Child elements | none
parent elements | <sw-param> <sw-variable-implementation>
Attributes for SW-ADDRESSING-METHOD-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND SW-ADDRESSING-METHOD |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[SW-ADDRESSING-METHOD] | idref | required |  |
Description Reference to the addressing scheme, e.g. by giving the short name.

Example
<sw-addressing-method-ref>defaultAdrS</sw-addressing-method-ref>


17.20. SW-ADDRESSING-METHODS

Figure 139: DTD-diagram for SW-ADDRESSING-METHODS
Child elements | <admin-data> <sw-addressing-method>
parent elements | <sw-data-dictionary>
Attributes for SW-ADDRESSING-METHODS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description All addressing schemes are defined in <sw-data-dictionary>

Example


18. SW-APPLICATION-NOTES ... SW-COMPU-METHOD-TEXT-PAIR

MSRSW.DTD Elements and attributes
18. SW-APPLICATION-NOTES ... SW-COMPU-METHOD-TEXT-PAIR

Contents of this chapter:
  • 18.1. SW-APPLICATION-NOTES
  • 18.2. SW-ARRAY-INDEX
  • 18.3. SW-ASAP-6-PRM-METHOD
  • 18.4. SW-AXIS-GROUPED
  • 18.5. SW-AXIS-INDIVIDUAL
  • 18.6. SW-AXIS-SHIFT-OFFSET
  • 18.7. SW-BASE-TYPE
  • 18.8. SW-BIT-REPRESENTATION
  • 18.9. SW-CARB-DOC
  • 18.10. SW-CODE-SYNTAX
  • 18.11. SW-CODE-SYNTAX-CLASS
  • 18.12. SW-CODE-SYNTAX-DESC
  • 18.13. SW-CODE-SYNTAX-REF
  • 18.14. SW-CODE-SYNTAXES
  • 18.15. SW-COMPU-GENERIC-MATH
  • 18.16. SW-COMPU-METHOD
  • 18.17. SW-COMPU-METHOD-REF
  • 18.18. SW-COMPU-METHOD-TABLE
  • 18.19. SW-COMPU-METHOD-TEXT
  • 18.20. SW-COMPU-METHOD-TEXT-PAIR


18.1. SW-APPLICATION-NOTES

Figure 140: DTD-diagram for SW-APPLICATION-NOTES
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <sw-function-variant>
Attributes for SW-APPLICATION-NOTES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Application notes

Example


18.2. SW-ARRAY-INDEX

Figure 141: DTD-diagram for SW-ARRAY-INDEX
Child elements | none
parent elements | <sw-param-content>
Attributes for SW-ARRAY-INDEX
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Reference to the sub-structure for parameter structures.

Example


18.3. SW-ASAP-6-PRM-METHOD

Figure 142: DTD-diagram for SW-ASAP-6-PRM-METHOD
Child elements | none
parent elements | <sw-compu-method>
Attributes for SW-ASAP-6-PRM-METHOD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description 6-parameter formula corresponding to ASAP (polynomial presentation. Presentation of the elements of the formula separated by white spaces. formula: int = (a × x2 + b × x1 + c ) / ( d × x2 + e × x1 + f)

Example
<sw-asap-6-prm-method>0 1 0 0 0 0.698 </sw-asap-6-prm-method>


18.4. SW-AXIS-GROUPED

Figure 143: DTD-diagram for SW-AXIS-GROUPED
Child elements | <sw-param-ref>
parent elements | <sw-param-axis-x> <sw-param-axis-y>
Attributes for SW-AXIS-GROUPED
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Several characteristics have the same datapoints for running-time reasons that are referenced by the name.

Example


18.5. SW-AXIS-INDIVIDUAL

Figure 144: DTD-diagram for SW-AXIS-INDIVIDUAL
Child elements | <sw-variable-ref> <max-count> <sw-limits>
parent elements | <sw-param-axis-x> <sw-param-axis-y> <sw-param-group-axis>
Attributes for SW-AXIS-INDIVIDUAL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Description of an axis, the datapoints for which can be individually defined. Each characteristic or each map has its own private datapoint values (unlike a group characteristic).

Example
<sw-param>
   <long-name></long-name>
   <short-name>etalam</short-name>
   <sw-param-class>curve_individual</sw-param-class>
   <desc></desc>
   <sw-param-array-x>
      <sw-param-axis-x>
         <sw-axis-individual>
            <sw-variable-ref>lambas</sw-variable-ref>
            <max-count>10</max-count>
         </sw-axis-individual>
      </sw-param-axis-x>
       ...
</sw-param>


18.6. SW-AXIS-SHIFT-OFFSET

Figure 145: DTD-diagram for SW-AXIS-SHIFT-OFFSET
Child elements | <sw-variable-ref> <max-count> <shift> <offset>
parent elements | <sw-param-axis-x> <sw-param-axis-y>
Attributes for SW-AXIS-SHIFT-OFFSET
Name | Type | Class | Value | Remark
[APPLICABLE] | number | default | 0 |
[S] | cdata | implied |  |
Description Special form of datapoints used for reasons of optimizing the running time. The datapoints are computed according to the following algorithm: Datapoint[i] = ... + Offset.

Example


18.7. SW-BASE-TYPE

Figure 146: DTD-diagram for SW-BASE-TYPE
Child elements | none
parent elements | <sw-param> <sw-variable-implementation>
Attributes for SW-BASE-TYPE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Base type of SW variable (e.g. char, integer).

Example
<sw-variable-implementation>
   <sw-base-type>UBIT</sw-base-type>
</sw-variable-implementation>


18.8. SW-BIT-REPRESENTATION

Figure 147: DTD-diagram for SW-BIT-REPRESENTATION
Child elements | <bit-base-name> <bit-base-type> <bit-count> <bit-pos>
parent elements | <sw-variable-implementation>
Attributes for SW-BIT-REPRESENTATION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This optional element contains information or bit presentation in the form of elements (number of bits, bit position, bit base name, bit base type) for variables with the data type "bit".

Example
<sw-bit-representation>
   <bit-base-name>variable-short-name</bit-base-name>
   <bit-base-type>w<bit-base-type>
   <bit-coutn>1</>
   <bit-pos>5</>
</sw-bit-pos>


18.9. SW-CARB-DOC

Figure 148: DTD-diagram for SW-CARB-DOC
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <sw-function-variant>
Attributes for SW-CARB-DOC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description CARB documentation.

Example


18.10. SW-CODE-SYNTAX

Figure 149: DTD-diagram for SW-CODE-SYNTAX
Child elements | <admin-data> <long-name> <short-name> <sw-code-syntax-class> <sw-code-syntax-desc>
parent elements | <sw-code-syntaxes>
Attributes for SW-CODE-SYNTAX
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | SW-CODE-SYNTAX |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Name reference to a code syntax. The presentation of RAM variables and parameters in the data source file is defined by the code syntax. The code syntaxes are described in the <sw-data-dictionary>. The code syntaxes described here can be used by variables and parameters by referencing.

The content of a code syntax is not fully modeled, i.e. the code syntax is only decribed in text-form in <sw-code-syntax-desc>. There are no standardized values or values pre-defined in the DTD for the code syntax.
Example
<sw-code-syntax>
   <long-name>Code syntax object for system constants</long-name>
   <short-name>cSyKgsSys</short-name>
   <sw-code-syntax-desc>
      <verbatim>Code syntax:       cSyKgsSys       Code syntax object for system constants
          ... e.g. C code

      </verbatim>
   </sw-code-syntax-desc>
</sw-code-syntax>


18.11. SW-CODE-SYNTAX-CLASS

Figure 150: DTD-diagram for SW-CODE-SYNTAX-CLASS
Child elements | none
parent elements | <sw-code-syntax>
Attributes for SW-CODE-SYNTAX-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Gives the class for the code syntax. Parameters or variables can only use the code syntax of a certain class. This however cannot be assured by SGML means; the application must do this. A code syntax is for example, suitable for a parameter or for a variable, or only for a characteristic. The combination of a certain code syntax with a certain saving scheme can also be expressed by the class.

There are no standardized values or values pre-defined in the DTD for the code syntax classes.
Example


18.12. SW-CODE-SYNTAX-DESC

Figure 151: DTD-diagram for SW-CODE-SYNTAX-DESC
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <sw-code-syntax>
Attributes for SW-CODE-SYNTAX-DESC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Description of the code syntax

Example


18.13. SW-CODE-SYNTAX-REF

Figure 152: DTD-diagram for SW-CODE-SYNTAX-REF
Child elements | none
parent elements | <sw-param> <sw-variable-implementation>
Attributes for SW-CODE-SYNTAX-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND SW-CODE-SYNTAX |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[SW-CODE-SYNTAX] | idref | required |  |
Description A reference to a code syntax can be made optionally within a RAM variable or parameter.

Example
</sw-variable-implementation>
    ...
   <sw-code-syntax-ref>csyRAMub</sw-code-syntax-ref>
    ...
</sw-variable-implementation>


18.14. SW-CODE-SYNTAXES

Figure 153: DTD-diagram for SW-CODE-SYNTAXES
Child elements | <admin-data> <sw-code-syntax>
parent elements | <sw-data-dictionary>
Attributes for SW-CODE-SYNTAXES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description List of code syntaxes.

Example


18.15. SW-COMPU-GENERIC-MATH

Figure 154: DTD-diagram for SW-COMPU-GENERIC-MATH
Child elements | none
parent elements | <sw-compu-method>
Attributes for SW-COMPU-GENERIC-MATH
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description The conversion formula is described by a general mathematical expression.

Example


18.16. SW-COMPU-METHOD

Figure 155: DTD-diagram for SW-COMPU-METHOD
Child elements | <admin-data> <long-name> <short-name> <sw-unit-ref> <sw-asap-6-prm-method> <sw-compu-method-table> <sw-compu-method-text> <prog-code> <sw-compu-generic-math>
parent elements | <sw-compu-methods>
Attributes for SW-COMPU-METHOD
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | SW-COMPU-METHOD |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Conversion formula. Computing procedure according to which a control-unit-internal variable can be converted into its physical value. The conversion formula must be reversible.

Example


18.17. SW-COMPU-METHOD-REF

Figure 156: DTD-diagram for SW-COMPU-METHOD-REF
Child elements | none
parent elements | <sw-param-axis-values> <sw-variable-implementation>
Attributes for SW-COMPU-METHOD-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND SW-COMPU-METHOD |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[SW-COMPU-METHOD] | idref | required |  |
Description Reference to a conversion formula

Example


18.18. SW-COMPU-METHOD-TABLE

Figure 157: DTD-diagram for SW-COMPU-METHOD-TABLE
Child elements | <sw-compu-method-value-pair>
parent elements | <sw-compu-method>
Attributes for SW-COMPU-METHOD-TABLE
Name | Type | Class | Value | Remark
[INTERPOLATION-STYLE] | nmtkgrp | default | INTERPOLATION INTERPOLATION NO-INTERPOLATION DISCRETE |
[S] | cdata | implied |  |
Description With this form for the conversion formula, the relationship between internal and physical presentation is given using a table of for the internal-physical pairs of values. An attribute interpolation-style is given that can take the values interpolation (default) and discrete.

Example


18.19. SW-COMPU-METHOD-TEXT

Figure 158: DTD-diagram for SW-COMPU-METHOD-TEXT
Child elements | <sw-compu-method-text-pair>
parent elements | <sw-compu-method>
Attributes for SW-COMPU-METHOD-TEXT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description The conversion formula is described in text form. Unlike the other types of conversions, the physical side does not constitute a number but rather a text. Applications are conceivable for switches ("on"/"off") or for country identification ( "D", "F", "US").

Example
<sw-compu-method-text>
   <sw-compu-method-text-pair>
      <cmt-int>0</cmt-int>
      <cmt-text>Heck</cmt-text>
   </cmt-compu-method-text-pair>
   <sw-compu-method-text-pair>
      <cmt-int>16</cmt-int>
      <cmt-text>16</cmt-text>
   </cmt-compu-method-text-pair>
</sw-compu-method-text>


18.20. SW-COMPU-METHOD-TEXT-PAIR

Figure 159: DTD-diagram for SW-COMPU-METHOD-TEXT-PAIR
Child elements | <cmt-int> <cmt-text>
parent elements | <sw-compu-method-text>
Attributes for SW-COMPU-METHOD-TEXT-PAIR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Includes an internal and a text-form value for text-type conversion formulae.

Example
<sw-compu-method-text-pair>
   <cmt-int>0</cmt-int>
   <cmt-text>Heck</cmt-text>
</cmt-compu-method-text-pair>


19. SW-COMPU-METHOD-VALUE-PAIR ... SW-FUNCTION-SPEC

MSRSW.DTD Elements and attributes
19. SW-COMPU-METHOD-VALUE-PAIR ... SW-FUNCTION-SPEC

Contents of this chapter:
  • 19.1. SW-COMPU-METHOD-VALUE-PAIR
  • 19.2. SW-COMPU-METHODS
  • 19.3. SW-DATA-DICTIONARIES
  • 19.4. SW-DATA-DICTIONARY
  • 19.5. SW-DATA-DICTIONARY-SPEC
  • 19.6. SW-DATA-TYPE-SCALING
  • 19.7. SW-DATADICTIONARY-CLASS
  • 19.8. SW-DECOMPOSITION
  • 19.9. SW-FULFILS
  • 19.10. SW-FUNCTION
  • 19.11. SW-FUNCTION-CLASS
  • 19.12. SW-FUNCTION-DEF
  • 19.13. SW-FUNCTION-DESC
  • 19.14. SW-FUNCTION-EXPORT-VARIABLES
  • 19.15. SW-FUNCTION-IMPORT-VARIABLES
  • 19.16. SW-FUNCTION-LOCAL-VARIABLES
  • 19.17. SW-FUNCTION-MODELONLY-VARIABLES
  • 19.18. SW-FUNCTION-REF
  • 19.19. SW-FUNCTION-REFS
  • 19.20. SW-FUNCTION-SPEC


19.1. SW-COMPU-METHOD-VALUE-PAIR

Figure 160: DTD-diagram for SW-COMPU-METHOD-VALUE-PAIR
Child elements | <cmt-int> <cmt-phys>
parent elements | <sw-compu-method-table>
Attributes for SW-COMPU-METHOD-VALUE-PAIR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Includes an internal and a physical value for tabular types of conversion formulae.

Example


19.2. SW-COMPU-METHODS

Figure 161: DTD-diagram for SW-COMPU-METHODS
Child elements | <admin-data> <sw-compu-method>
parent elements | <sw-data-dictionary>
Attributes for SW-COMPU-METHODS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description List of conversion formulae.

Example


19.3. SW-DATA-DICTIONARIES

Figure 162: DTD-diagram for SW-DATA-DICTIONARIES
Child elements | <sw-data-dictionary>
parent elements | <sw-data-dictionary-spec>
Attributes for SW-DATA-DICTIONARIES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Size of the data dictionaries

Example
<msrsw>
   <short-name></short-name>
   <sw-data-dictionary-spec>
      <sw-data-dictionaries>
             <sw-data-dictionary>
                    ...
                  </sw-data-dictionary>
          </sw-data-dictionaries>
   </sw-data-dictionary-spec>
   </msrsw>


19.4. SW-DATA-DICTIONARY

Figure 163: DTD-diagram for SW-DATA-DICTIONARY
Child elements | <admin-data> <desc> <sw-datadictionary-class> <sw-function-ref> <sw-units> <sw-physic-types> <sw-variables> <sw-params> <sw-compu-methods> <sw-addressing-methods> <sw-param-record-layouts> <sw-code-syntaxes>
parent elements | <sw-data-dictionaries>
Attributes for SW-DATA-DICTIONARY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Data dictionary. Data types, variables, parameters, units of measure, addressing schemes, storage schemes, code syntaxes and conversion formulae can be described here.

Example
<msrsw>
   <short-name></short-name>
   <sw-data-dictionary-spec>
      <sw-data-dictionaries>
             <sw-data-dictionary>
                     <sw-datadictionary-class> ... </sw-datadictionary-class>
                     <sw-funtion-ref> ... </sw-funtion-ref>
                <sw-units> ... </sw-units>
                <sw-physic-types> ... </sw-physic-types>
                <sw-variables> ... </sw-variables>
                     <sw-params> ... </sw-params>
                     <sw-compu-methods> ... </sw-compu-methods>
                <sw-addressing-methods> ... </sw-addressing-methods>
                     <sw-param-record-layouts> ... </sw-param-record-layouts>
                <sw-code-syntaxes> ... </sw-code-syntaxes>
                  </sw-data-dictionary>
          </sw-data-dictionaries>
   </sw-data-dictionary-spec>
   </msrsw>


19.5. SW-DATA-DICTIONARY-SPEC

Figure 164: DTD-diagram for SW-DATA-DICTIONARY-SPEC
Child elements | <na> <tbd> <tbr> <admin-data> <introduction> <sw-data-dictionaries>
parent elements | <msrsw> <sw-function-variant>
Attributes for SW-DATA-DICTIONARY-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Data-dictionary specification.

Example
<msrsw>
   <short-name></short-name>
   <sw-data-dictionary-spec>
      <sw-data-dictionaries>
             <sw-data-dictionary>
                      ...
                  </sw-data-dictionary>
          </sw-data-dictionaries>
   </sw-data-dictionary-spec>
   </msrsw>


19.6. SW-DATA-TYPE-SCALING

Figure 165: DTD-diagram for SW-DATA-TYPE-SCALING
Child elements | none
parent elements | <sw-physic-type> <sw-physic-type-1>
Attributes for SW-DATA-TYPE-SCALING
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Quantization of a variable. Example: "16 bit".

Example


19.7. SW-DATADICTIONARY-CLASS

Figure 166: DTD-diagram for SW-DATADICTIONARY-CLASS
Child elements | none
parent elements | <sw-data-dictionary>
Attributes for SW-DATADICTIONARY-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


19.8. SW-DECOMPOSITION

Figure 167: DTD-diagram for SW-DECOMPOSITION
Child elements | <sw-function-ref>
parent elements | <sw-function-variant>
Attributes for SW-DECOMPOSITION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Formation of functional hierarchies by referencing included and used functions.

Example
<sw-function id="function">
   <long-name>exhaust-gas return</long-name>
   <short-name>egr</short-name>
   <sw-function-class></sw-function-class>
   <sw-function-variants>
      <sw-function-variant>
             <sw-function-desc></sw-function-desc>
                 <sw-decomposition>
                    <sw-function-ref sw-function="function used"></sw-function-ref>
                 </sw-decomposition>
           </sw-function-variant>
   </sw-function-variants>
</sw-function>


19.9. SW-FULFILS

Figure 168: DTD-diagram for SW-FULFILS
Child elements | <function-ref>
parent elements | <sw-function-variant>
Attributes for SW-FULFILS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


19.10. SW-FUNCTION

Figure 169: DTD-diagram for SW-FUNCTION
Child elements | <admin-data> <long-name> <short-name> <sw-function-class> <sw-function-variants> <annotations>
parent elements | <sw-functions>
Attributes for SW-FUNCTION
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | SW-FUNCTION |
[F-NAMESPACE] | names | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Software function

Example
<sw-function id="EGR">
   <long-name>exhaust-gas return</long-name>
   <short-name>EGR</short-name>
   <sw-function-class>documentation only</sw-function-class>
   <sw-function-variants>
      <sw-function-variant></sw-function-variant>
   </sw-function-variants>
</sw-function>


19.11. SW-FUNCTION-CLASS

Figure 170: DTD-diagram for SW-FUNCTION-CLASS
Child elements | none
parent elements | <sw-function>
Attributes for SW-FUNCTION-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Function class. The functions can be broken down into different classes. There can be functions for example occurring only in the documentation/analysis phase that can be grouped to a class.

Example
<sw-function id="test">
   <long-name></long-name>
   <short-name></short-name>
   <sw-function-class>documentation only</sw-function-class>
   <sw-function-variants>
      <sw-function-variant></sw-function-variant>
   </sw-function-variants>
</sw-function>


19.12. SW-FUNCTION-DEF

Figure 171: DTD-diagram for SW-FUNCTION-DEF
Child elements | <figure> <ncoi-1>
parent elements | <sw-function-variant>
Attributes for SW-FUNCTION-DEF
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description A short decription for each function is given by a suitable means of presentation. A graphical and a short text are used as a rule. Example: ASCET function model, status diagrams, SA/SD diagrams.

Example
<sw-function-variant>
   <sw-function-def>
      <figure id="ascet-bild">
             <long-name></long-name>
             <short-name></short-name>
             <graphic filename="ascet-modell" notation="cgmbin"></graphic>
      </figure>
        ...
      <ncoi-1><p> ... </p></ncoi-1>
           ...
   </sw-function-def>
</sw-function-variant>


19.13. SW-FUNCTION-DESC

Figure 172: DTD-diagram for SW-FUNCTION-DESC
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <sw-function-variant>
Attributes for SW-FUNCTION-DESC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Extensive description in text form for the function.

Example
<sw-function-variant>
   <sw-function-desc>
        ...
      <chapter>
         <p>The ABS is an add-on function for a conventional brakes system.
                     It consists of a ABS hydro unit integrated electronic
                     control unit and 4 spped sensors for sensing the velocity behavior of the wheels.
         </p>
      </chapter>
   </sw-function-desc>
    ...
</sw-function-variant>


19.14. SW-FUNCTION-EXPORT-VARIABLES

Figure 173: DTD-diagram for SW-FUNCTION-EXPORT-VARIABLES
Child elements | <sw-variables-read> <sw-variables-write> <sw-variables-readwrite>
parent elements | <sw-function-variables>
Attributes for SW-FUNCTION-EXPORT-VARIABLES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description List of exported variables. When a function defines a variable, i.e., provides a variable or the value, then it is to be listed here.

Example
  <sw-funtion-variables></>
      <sw-function-export-variables>
          <sw-variables-read>
             <sw-variable-ref sw-variable="tmot">tmot</sw-variable-ref>
             <sw-variable-ref sw-variable="b_max_flr">b_max_flr</sw-variable-ref>
          </sw-variables-read>
          <sw-variables-write>
             <sw-variable-ref sw-variable="..."> ... </sw-variable-ref>
          </sw-variables-write>
          <sw-variables-readwrite>
             <sw-variable-ref sw-variable="..."> ... </sw-variable-ref>
          </sw-variables-readwrite>
      </sw-function-export-variables>

   </sw-function-variables>


19.15. SW-FUNCTION-IMPORT-VARIABLES

Figure 174: DTD-diagram for SW-FUNCTION-IMPORT-VARIABLES
Child elements | <sw-variables-read> <sw-variables-write> <sw-variables-readwrite>
parent elements | <sw-function-variables>
Attributes for SW-FUNCTION-IMPORT-VARIABLES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description List of imported variables. Variables are listed here that are made available by other functions.

Example


19.16. SW-FUNCTION-LOCAL-VARIABLES

Figure 175: DTD-diagram for SW-FUNCTION-LOCAL-VARIABLES
Child elements | <sw-variables-readwrite>
parent elements | <sw-function-variables>
Attributes for SW-FUNCTION-LOCAL-VARIABLES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description List of local variables, i.e. no transfer variable.

Example


19.17. SW-FUNCTION-MODELONLY-VARIABLES

Figure 176: DTD-diagram for SW-FUNCTION-MODELONLY-VARIABLES
Child elements | <sw-variable-ref>
parent elements | <sw-function-variables>
Attributes for SW-FUNCTION-MODELONLY-VARIABLES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description List of variables that only exist in the model and no longer occur during implementation.

Example


19.18. SW-FUNCTION-REF

Figure 177: DTD-diagram for SW-FUNCTION-REF
Child elements | none
parent elements | <sw-data-dictionary> <sw-decomposition> <sw-function-refs> <sw-param-content> <sw-param-contents>
Attributes for SW-FUNCTION-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND SW-FUNCTION |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[SW-FUNCTION] | idref | required |  |
Description In <msrsw>, reference to functions used that are described outside of the SW. In <sw-decomposition>, reference to functions that are described within <msrsw>.

Example


19.19. SW-FUNCTION-REFS

Figure 178: DTD-diagram for SW-FUNCTION-REFS
Child elements | <sw-function-ref>
parent elements | <msrsw>
Attributes for SW-FUNCTION-REFS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description References to functions used that are described outside of the document, e.g. operating system functions, network services.

Example


19.20. SW-FUNCTION-SPEC

Figure 179: DTD-diagram for SW-FUNCTION-SPEC
Child elements | <na> <tbd> <tbr> <admin-data> <introduction> <sw-functions>
parent elements | <msrsw>
Attributes for SW-FUNCTION-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Functions specification. A functions specification can include several functions. The functions can be in hierarchical form by which reference to a function is made by <sw-decomposition>.

Example


20. SW-FUNCTION-VARIABLES ... SW-PARAM-CONTENT-Y

MSRSW.DTD Elements and attributes
20. SW-FUNCTION-VARIABLES ... SW-PARAM-CONTENT-Y

Contents of this chapter:
  • 20.1. SW-FUNCTION-VARIABLES
  • 20.2. SW-FUNCTION-VARIANT
  • 20.3. SW-FUNCTION-VARIANTS
  • 20.4. SW-FUNCTIONS
  • 20.5. SW-GLOSSARY
  • 20.6. SW-INTERPOLATION-METHOD
  • 20.7. SW-LIMITS
  • 20.8. SW-MAINTENANCE-NOTES
  • 20.9. SW-PARAM
  • 20.10. SW-PARAM-ARRAY-X
  • 20.11. SW-PARAM-ARRAY-XY
  • 20.12. SW-PARAM-AXIS-VALUES
  • 20.13. SW-PARAM-AXIS-X
  • 20.14. SW-PARAM-AXIS-Y
  • 20.15. SW-PARAM-CLASS
  • 20.16. SW-PARAM-CONTENT
  • 20.17. SW-PARAM-CONTENT-TEXT
  • 20.18. SW-PARAM-CONTENT-V
  • 20.19. SW-PARAM-CONTENT-X
  • 20.20. SW-PARAM-CONTENT-Y


20.1. SW-FUNCTION-VARIABLES

Figure 180: DTD-diagram for SW-FUNCTION-VARIABLES
Child elements | <sw-function-export-variables> <sw-function-import-variables> <sw-function-local-variables> <sw-function-modelonly-variables>
parent elements | <sw-function-variant>
Attributes for SW-FUNCTION-VARIABLES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description List of variables used by the function

Example
<sw-function-variant>
    ...
   <sw-funtion-variables></>
      <sw-function-export-variables>
          <sw-variables-read>
             <sw-variable-ref sw-variable="tmot">tmot</sw-variable-ref>
             <sw-variable-ref sw-variable="b_max_flr">b_max_flr</sw-variable-ref>
          </sw-variables-read>
          <sw-variables-write>
             <sw-variable-ref sw-variable="..."> ... </sw-variable-ref>
          </sw-variables-write>
          <sw-variables-readwrite>
             <sw-variable-ref sw-variable="..."> ... </sw-variable-ref>
          </sw-variables-readwrite>
      </sw-function-export-variables>
      <sw-function-import-variables> ... </sw-function-import-variables>
      <sw-function-local-variables> ... </sw-function-local-variables>
      <sw-function-modelonly-variables> ... </sw-function-modelonly-variables>
   </sw-function-variables>
    ...
</sw-function-variant>


20.2. SW-FUNCTION-VARIANT

Figure 181: DTD-diagram for SW-FUNCTION-VARIANT
Child elements | <admin-data> <variant-def-refs> <sw-function-def> <sw-function-desc> <sw-fulfils> <sw-function-variables> <sw-param-refs> <sw-data-dictionary-spec> <sw-param-contents-spec> <sw-test-spec> <sw-application-notes> <sw-maintenance-notes> <sw-carb-doc> <sw-decomposition> <annotations> <add-info>
parent elements | <sw-function-variants>
Attributes for SW-FUNCTION-VARIANT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Function variant. If no function variants are used, then a minimum of one still has to be given. Each function variant must be completely described in the implementation V1.1.0, i.e. there is no re-use.

A features bar in <project-data> ... <var-def> (function switch) can be referenced by means of < variant-def-ref>.
Example
<sw-function id="EGR">
   <long-name>exhaust-gas return</long-name>
   <short-name>EGR</short-name>
   <sw-function-class>documentation only</sw-function-class>
   <sw-function-variants>
      <sw-function-variant>

         <variant-def-refs>
            <variant-def-ref variant-def="v1.2"></variant-def-ref>
            <variant-def-ref variant-def="v1.3"></variant-def-ref>
         </variant-def-refs>
         <sw-function-def> ...</sw-function-def>
         <sw-function-desc> ... </sw-function-desc>
         <sw-function-variables> ... </sw-function-variables>
         <sw-param-refs> ... </sw-param-refs>
         <sw-test-spec> ... </sw-test-spec>
         <sw-application-notes> ... </sw-application-notes>
         <sw-maintenance-notes> ... </sw-maintenance-notes>
         <sw-carb-doc> ... </sw-carb-doc>
         <sw-decomposition> ... </sw-decomposition>
         <add-info></add-info>

      </sw-function-variant>
   </sw-function-variants>
</sw-function>


20.3. SW-FUNCTION-VARIANTS

Figure 182: DTD-diagram for SW-FUNCTION-VARIANTS
Child elements | <sw-function-variant>
parent elements | <sw-function>
Attributes for SW-FUNCTION-VARIANTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Number of function variants.

Example


20.4. SW-FUNCTIONS

Figure 183: DTD-diagram for SW-FUNCTIONS
Child elements | <sw-function>
parent elements | <sw-function-spec>
Attributes for SW-FUNCTIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Number of functions in the functional specification/in the document. Envelope element.

Example


20.5. SW-GLOSSARY

Figure 184: DTD-diagram for SW-GLOSSARY
Child elements | <na> <tbd> <tbr> <introduction> <admin-data> <ncoi-1>
parent elements | <msrsw>
Attributes for SW-GLOSSARY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Glossary

Example
<sw-glossary>
   <ncoi-1>
      <def-list>
             <def-item id="gid1">
                    <long-name>Interpolation methods</long-name>
                    <def><p>linear interpolation between datapoints for parameters</p></def>
             </def-item>
      </def-list>
   </ncoi-1>
</sw-glossary>


20.6. SW-INTERPOLATION-METHOD

Figure 185: DTD-diagram for SW-INTERPOLATION-METHOD
Child elements | none
parent elements | <sw-param>
Attributes for SW-INTERPOLATION-METHOD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Interpolation method for parameters. The methods are not standardized or defined in the DTD. The methods are described in text form.

Example
<sw-param>
    ...
   <sw-interpolation-method>linear</sw-interpolation-method>
    ...
</sw-param>


20.7. SW-LIMITS

Figure 186: DTD-diagram for SW-LIMITS
Child elements | <phys> <coded> <coded> <phys>
parent elements | <sw-axis-individual> <sw-param-axis-values> <sw-physic-type> <sw-physic-type-1> <sw-variable-implementation>
Attributes for SW-LIMITS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Minimum and maximum values for the physical and the control-unit-internal values are given here.

Example
<sw-variable-implementation>
   <sw-base-type>UBYTE</sw-base-type>
   <sw-limits>
      <phys>
         <phys-min>40.000000</phys-min>
         <phys-max>4000.000000</phys-max>
      </phys>
   </sw-limits>
      ...
</sw-variable-implementation>


20.8. SW-MAINTENANCE-NOTES

Figure 187: DTD-diagram for SW-MAINTENANCE-NOTES
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <sw-function-variant>
Attributes for SW-MAINTENANCE-NOTES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Customer servicing notes

Example


20.9. SW-PARAM

Figure 188: DTD-diagram for SW-PARAM
Child elements | <admin-data> <long-name> <short-name> <sw-param-class> <desc> <sw-param-single-value> <sw-param-array-x> <sw-param-array-xy> <sw-param-value-block> <sw-param-group-axis> <sw-param-text> <sw-base-type> <arraysize> <sw-interpolation-method> <sw-params> <sw-addressing-method-ref> <sw-param-record-layout-ref> <sw-code-syntax-ref> <annotations> <add-info>
parent elements | <sw-params>
Attributes for SW-PARAM
Name | Type | Class | Value | Remark
[CALIBRATION] | nmtkgrp | default | CALIBRATION NOT-IN-MEMORY CALIBRATION NO-CALIBRATION |
[F-ID-CLASS] | name | fixed | SW-PARAM |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Software parameters. Software parameters are parameters ( in ASAP characteristics): characteristics, maps and fixed values.

Parameters are as a rule, stored in the EPROM of the control unit. They are applicable, i.e. they can be read or modified using application tools within the scope of the plausibility and within the scope of set access protection attributes. Exceptions: e.g. cylinder number, not in the EPROM, not applicable. There is one attribute calibration for the possible attribute values calibration (default), no-calibration and not-in-memory.
Example
<sw-param>
   <long-name></long-name>
   <short-name>etalam</short-name>
   <sw-param-class>curve_individual</sw-param-class>
   <desc></desc>
   <sw-param-array-x>
      <sw-param-axis-x>
         ...
      </sw-param-axis-x>
      <sw-param-axis-values>
         <sw-compu-method-ref>rel_ub-b127b5</sw-compu-method-ref>
      </sw-param-axis-values>
   <sw-addressing-method-ref>NearRomByte</sw-addressing-method-ref>
   <sw-param-record-layout-ref>KlAUbSstUbWUb</sw-param-record-layout-ref>
   <sw-code-syntax-ref>KlNearAUbSstUbUb</sw-code-syntax-ref>
</sw-param>


20.10. SW-PARAM-ARRAY-X

Figure 189: DTD-diagram for SW-PARAM-ARRAY-X
Child elements | <sw-param-axis-x> <sw-param-axis-values>
parent elements | <sw-param>
Attributes for SW-PARAM-ARRAY-X
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Characteristic

Example
<sw-param-array-x>
   <sw-param-axis-x>
      <sw-axis-individual>
         <sw-variable-ref>N40</sw-variable-ref>
         <max-count></max-count>
      </sw-axis-individual>
   </sw-param-axis-x>
   <sw-param-axis-values>
      <sw-compu-method-ref>FKT256</sw-compu-method-ref>
      <sw-param-noeffect-value>0.04567</sw-param-noeffect-value>
   </sw-param-axis-values>
</sw-param-array-x>


20.11. SW-PARAM-ARRAY-XY

Figure 190: DTD-diagram for SW-PARAM-ARRAY-XY
Child elements | <sw-param-axis-x> <sw-param-axis-y> <sw-param-axis-values>
parent elements | <sw-param>
Attributes for SW-PARAM-ARRAY-XY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Map

Example
<sw-param>
   <long-name>map exhaust gas recirculation</long-name>
   <short-name>KFAGR</short-name>
   <sw-param-class>map_individual</sw-param-class>
   <desc></desc>
   <sw-param-array-xy>
      <sw-param-axis-x>
         <sw-axis-individual>
            ...
         </sw-axis-individual>
      </sw-param-axis-x>
      <sw-param-axis-y>
         <sw-axis-individual>
            ...
         </sw-axis-individual>
      </sw-param-axis-y>
         <sw-param-axis-values>
         <sw-compu-method-ref>PCENT</sw-compu-method-ref>
         <sw-param-noeffect-value>0.000000</sw-param-noeffect-value>
      </sw-param-axis-values>
   </sw-param-array-xy>
   <sw-addressing-method-ref>Vek</sw-addressing-method-ref>
   <sw-param-record-layout-ref>KF0</sw-param-record-layout-ref>
   <sw-code-syntax-ref>cSyKfVk</sw-code-syntax-ref>
</sw-param>


20.12. SW-PARAM-AXIS-VALUES

Figure 191: DTD-diagram for SW-PARAM-AXIS-VALUES
Child elements | <sw-compu-method-ref> <sw-param-noeffect-value> <sw-limits> <labels>
parent elements | <sw-param-array-x> <sw-param-array-xy> <sw-param-single-value> <sw-param-value-block>
Attributes for SW-PARAM-AXIS-VALUES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Value axis. Description of a characteristic value or the values of a characteristic or map

Example
<sw-param-axis-values>
   <sw-compu-method-ref>DEZ</sw-compu-method-ref>
   <sw-param-noeffect-value>0.000000</sw-param-noeffect-value>
</sw-param-axis-values>


20.13. SW-PARAM-AXIS-X

Figure 192: DTD-diagram for SW-PARAM-AXIS-X
Child elements | <sw-axis-individual> <sw-axis-grouped> <sw-axis-shift-offset>
parent elements | <sw-param-array-x> <sw-param-array-xy>
Attributes for SW-PARAM-AXIS-X
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Describes the x axis of a parameter (<sw-param>). This description consists of the input variable (as reference to a variable), min, max, max-count (max. number of datapoints).

Example
<sw-param-axis-x>
   <sw-axis-individual>
      <sw-variable-ref>N40</sw-variable-ref>
      <max-count></max-count>
   </sw-axis-individual>
</sw-param-axis-x>


20.14. SW-PARAM-AXIS-Y

Figure 193: DTD-diagram for SW-PARAM-AXIS-Y
Child elements | <sw-axis-individual> <sw-axis-grouped> <sw-axis-shift-offset>
parent elements | <sw-param-array-xy>
Attributes for SW-PARAM-AXIS-Y
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Describes the y axis of a parameter (<sw-param>). This description consists of the input variable (as reference to a variable), min, max, max-count (max. nzmver of datapoints).

Example
<sw-param-axis-y>
   <sw-axis-individual>
      <sw-variable-ref>TL</sw-variable-ref>
      <max-count>4</max-count>
   </sw-axis-individual>
</sw-param-axis-y>


20.15. SW-PARAM-CLASS

Figure 194: DTD-diagram for SW-PARAM-CLASS
Child elements | none
parent elements | <sw-param> <sw-param-content>
Attributes for SW-PARAM-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Gives the type of parameter (characteristic, map, characteristic value, fixed characteristic, group characteristic, fixed map).

Example
<sw-param>
   <long-name>map Abgasrückführung</long-name>
   <short-name>KFAGR</short-name>
   <sw-param-class>map_individual</sw-param-class>
    ...
</sw-param>


20.16. SW-PARAM-CONTENT

Figure 195: DTD-diagram for SW-PARAM-CONTENT
Child elements | <sw-param-ref> <desc> <sw-function-ref> <sw-param-class> <annotations> <sw-array-index> <sw-param-content-x> <sw-param-content-y> <sw-param-content-v> <sw-param-content-text>
parent elements | <sw-param-contents>
Attributes for SW-PARAM-CONTENT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Parameter values

Example
<sw-param-contents-spec>
   <sw-param-contents>
      <sw-param-contents-class>msr-test-values</sw-param-contents-class>

      <sw-param-content>
         <sw-param-ref>DLIP</sw-param-ref>
         <sw-param-class>curve_fixed</sw-param-class>
         <sw-param-content-x>
            <sw-unit-ref>Upm</sw-unit-ref>
            <sw-param-values-phys>
                <v>0.000000</v><v>10.000000</v>
            </sw-param-values-phys>
         </sw-param-content-x>
         <sw-param-content-v>
            <sw-unit-ref>kg/h pro sec</sw-unit-ref>
            <sw-param-values-phys>
               <v>3.780000</v><v>32.90000</v>
            </sw-param-values-phys>
         </sw-param-content-v>
      </sw-param-content>

   </sw-param-contents>
</sw-param-contents-spec>


20.17. SW-PARAM-CONTENT-TEXT

Figure 196: DTD-diagram for SW-PARAM-CONTENT-TEXT
Child elements | none
parent elements | <sw-param-content>
Attributes for SW-PARAM-CONTENT-TEXT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description The values of a test parameter are given here (sw-param-text).

Example
<sw-param-content-text>EIN</sw-param-content-text>


20.18. SW-PARAM-CONTENT-V

Figure 197: DTD-diagram for SW-PARAM-CONTENT-V
Child elements | <sw-unit-ref> <sw-param-values-phys> <sw-param-values-coded> <sw-param-values-coded-hex> <sw-param-values-adr> <sw-param-values-generic>
parent elements | <sw-param-content>
Attributes for SW-PARAM-CONTENT-V
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description An individual value is given here for a characteristic value. The values of the v axis are given here for a characteristic. The values of the v axis are given here for a map. The following convention thereby applies: Index of the x axis runs faster. Values are separated by blanks or line feeds.

Example
<sw-param-content-v>
   <sw-unit-ref>dez</sw-unit-ref>
      <sw-param-values-phys>
         <v>1.000000</v><v>2.000000</v><v>3.000000</v><v>4.000000</v><v>5.000000</v><v>6.000000</v>
   </sw-param-values-phys>
</sw-param-content-v>


20.19. SW-PARAM-CONTENT-X

Figure 198: DTD-diagram for SW-PARAM-CONTENT-X
Child elements | <sw-unit-ref> <sw-param-values-phys> <sw-param-values-coded> <sw-param-values-coded-hex> <sw-param-values-adr> <sw-param-values-generic>
parent elements | <sw-param-content>
Attributes for SW-PARAM-CONTENT-X
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description The physical, internal, ... values for the x axis are given here.

Example
<sw-param-content-x>
   <sw-param-values-phys>
      <v>-30.5</v><v>-20.0</v><v>30</v>
   </sw-param-values-phys>
<sw-param-content-x>


20.20. SW-PARAM-CONTENT-Y

Figure 199: DTD-diagram for SW-PARAM-CONTENT-Y
Child elements | <sw-unit-ref> <sw-param-values-phys> <sw-param-values-coded> <sw-param-values-coded-hex> <sw-param-values-adr> <sw-param-values-generic>
parent elements | <sw-param-content>
Attributes for SW-PARAM-CONTENT-Y
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description The physical, internal, ... values for the y axis are given here.

Example
<sw-param-content-y>
   <sw-param-values-phys>
      <v>-30.5</v><v>-20.0</v><v>30</v>
   </sw-param-values-phys>
<sw-param-content-y>


21. SW-PARAM-CONTENTS ... SW-PARAM-VALUES-GENERIC

MSRSW.DTD Elements and attributes
21. SW-PARAM-CONTENTS ... SW-PARAM-VALUES-GENERIC

Contents of this chapter:
  • 21.1. SW-PARAM-CONTENTS
  • 21.2. SW-PARAM-CONTENTS-CLASS
  • 21.3. SW-PARAM-CONTENTS-SPEC
  • 21.4. SW-PARAM-GROUP-AXIS
  • 21.5. SW-PARAM-NOEFFECT-VALUE
  • 21.6. SW-PARAM-RECORD-LAYOUT
  • 21.7. SW-PARAM-RECORD-LAYOUT-CLASS
  • 21.8. SW-PARAM-RECORD-LAYOUT-DESC
  • 21.9. SW-PARAM-RECORD-LAYOUT-REF
  • 21.10. SW-PARAM-RECORD-LAYOUTS
  • 21.11. SW-PARAM-REF
  • 21.12. SW-PARAM-REFS
  • 21.13. SW-PARAM-SINGLE-VALUE
  • 21.14. SW-PARAM-TARGET
  • 21.15. SW-PARAM-TEXT
  • 21.16. SW-PARAM-VALUE-BLOCK
  • 21.17. SW-PARAM-VALUES-ADR
  • 21.18. SW-PARAM-VALUES-CODED
  • 21.19. SW-PARAM-VALUES-CODED-HEX
  • 21.20. SW-PARAM-VALUES-GENERIC


21.1. SW-PARAM-CONTENTS

Figure 200: DTD-diagram for SW-PARAM-CONTENTS
Child elements | <admin-data> <desc> <sw-function-ref> <annotations> <sw-param-contents-class> <sw-param-content>
parent elements | <sw-param-contents-spec>
Attributes for SW-PARAM-CONTENTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.2. SW-PARAM-CONTENTS-CLASS

Figure 201: DTD-diagram for SW-PARAM-CONTENTS-CLASS
Child elements | none
parent elements | <sw-param-contents>
Attributes for SW-PARAM-CONTENTS-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.3. SW-PARAM-CONTENTS-SPEC

Figure 202: DTD-diagram for SW-PARAM-CONTENTS-SPEC
Child elements | <na> <tbd> <tbr> <admin-data> <introduction> <sw-param-contents>
parent elements | <msrsw> <sw-function-variant>
Attributes for SW-PARAM-CONTENTS-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.4. SW-PARAM-GROUP-AXIS

Figure 203: DTD-diagram for SW-PARAM-GROUP-AXIS
Child elements | <sw-axis-individual> <sw-param-target>
parent elements | <sw-param>
Attributes for SW-PARAM-GROUP-AXIS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.5. SW-PARAM-NOEFFECT-VALUE

Figure 204: DTD-diagram for SW-PARAM-NOEFFECT-VALUE
Child elements | none
parent elements | <sw-param-axis-values>
Attributes for SW-PARAM-NOEFFECT-VALUE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.6. SW-PARAM-RECORD-LAYOUT

Figure 205: DTD-diagram for SW-PARAM-RECORD-LAYOUT
Child elements | <admin-data> <long-name> <short-name> <sw-param-record-layout-class> <sw-param-record-layout-desc>
parent elements | <sw-param-record-layouts>
Attributes for SW-PARAM-RECORD-LAYOUT
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | SW-PARAM-RECORD-LAYOUT |
[ID] | id | required |  |
[S] | cdata | implied |  |


21.7. SW-PARAM-RECORD-LAYOUT-CLASS

Figure 206: DTD-diagram for SW-PARAM-RECORD-LAYOUT-CLASS
Child elements | none
parent elements | <sw-param-record-layout>
Attributes for SW-PARAM-RECORD-LAYOUT-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.8. SW-PARAM-RECORD-LAYOUT-DESC

Figure 207: DTD-diagram for SW-PARAM-RECORD-LAYOUT-DESC
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <sw-param-record-layout>
Attributes for SW-PARAM-RECORD-LAYOUT-DESC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.9. SW-PARAM-RECORD-LAYOUT-REF

Figure 208: DTD-diagram for SW-PARAM-RECORD-LAYOUT-REF
Child elements | none
parent elements | <sw-param>
Attributes for SW-PARAM-RECORD-LAYOUT-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND SW-PARAM-RECORD-LAYOUT |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[SW-PARAM-RECORD-LAYOUT] | idref | required |  |


21.10. SW-PARAM-RECORD-LAYOUTS

Figure 209: DTD-diagram for SW-PARAM-RECORD-LAYOUTS
Child elements | <admin-data> <sw-param-record-layout>
parent elements | <sw-data-dictionary>
Attributes for SW-PARAM-RECORD-LAYOUTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.11. SW-PARAM-REF

Figure 210: DTD-diagram for SW-PARAM-REF
Child elements | none
parent elements | <sw-axis-grouped> <sw-param-content> <sw-param-refs>
Attributes for SW-PARAM-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND SW-PARAM |
[HYTIME] | name | fixed | CLINK |
[OWNS] | nmtkgrp | implied | NOOWN |
[S] | cdata | implied |  |
[SW-PARAM] | idref | required |  |


21.12. SW-PARAM-REFS

Figure 211: DTD-diagram for SW-PARAM-REFS
Child elements | <sw-param-ref>
parent elements | <sw-function-variant>
Attributes for SW-PARAM-REFS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.13. SW-PARAM-SINGLE-VALUE

Figure 212: DTD-diagram for SW-PARAM-SINGLE-VALUE
Child elements | <sw-param-axis-values>
parent elements | <sw-param>
Attributes for SW-PARAM-SINGLE-VALUE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.14. SW-PARAM-TARGET

Figure 213: DTD-diagram for SW-PARAM-TARGET
Child elements | <sw-variable-ref>
parent elements | <sw-param-group-axis>
Attributes for SW-PARAM-TARGET
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.15. SW-PARAM-TEXT

Figure 214: DTD-diagram for SW-PARAM-TEXT
Child elements | none
parent elements | <sw-param>
Attributes for SW-PARAM-TEXT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.16. SW-PARAM-VALUE-BLOCK

Figure 215: DTD-diagram for SW-PARAM-VALUE-BLOCK
Child elements | <sw-param-axis-values> <count>
parent elements | <sw-param>
Attributes for SW-PARAM-VALUE-BLOCK
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.17. SW-PARAM-VALUES-ADR

Figure 216: DTD-diagram for SW-PARAM-VALUES-ADR
Child elements | <v>
parent elements | <sw-param-content-v> <sw-param-content-x> <sw-param-content-y>
Attributes for SW-PARAM-VALUES-ADR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.18. SW-PARAM-VALUES-CODED

Figure 217: DTD-diagram for SW-PARAM-VALUES-CODED
Child elements | <v>
parent elements | <sw-param-content-v> <sw-param-content-x> <sw-param-content-y>
Attributes for SW-PARAM-VALUES-CODED
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.19. SW-PARAM-VALUES-CODED-HEX

Figure 218: DTD-diagram for SW-PARAM-VALUES-CODED-HEX
Child elements | <v>
parent elements | <sw-param-content-v> <sw-param-content-x> <sw-param-content-y>
Attributes for SW-PARAM-VALUES-CODED-HEX
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


21.20. SW-PARAM-VALUES-GENERIC

Figure 219: DTD-diagram for SW-PARAM-VALUES-GENERIC
Child elements | <v>
parent elements | <sw-param-content-v> <sw-param-content-x> <sw-param-content-y>
Attributes for SW-PARAM-VALUES-GENERIC
Name | Type | Class | Value | Remark
[TYPE] | nmtoken | required |  |


22. SW-PARAM-VALUES-PHYS ... SW-VARIABLE-REF

MSRSW.DTD Elements and attributes
22. SW-PARAM-VALUES-PHYS ... SW-VARIABLE-REF

Contents of this chapter:
  • 22.1. SW-PARAM-VALUES-PHYS
  • 22.2. SW-PARAMS
  • 22.3. SW-PHYSIC-TYPE
  • 22.4. SW-PHYSIC-TYPE-1
  • 22.5. SW-PHYSIC-TYPE-REF
  • 22.6. SW-PHYSIC-TYPES
  • 22.7. SW-RESOLUTION
  • 22.8. SW-TEST-SPEC
  • 22.9. SW-UNIT
  • 22.10. SW-UNIT-DISPLAY
  • 22.11. SW-UNIT-FROM-REF-METHOD
  • 22.12. SW-UNIT-REF
  • 22.13. SW-UNIT-TO-REF-METHOD
  • 22.14. SW-UNITS
  • 22.15. SW-VAR-INIT-VALUE
  • 22.16. SW-VAR-NOT-AV-VALUE
  • 22.17. SW-VARIABLE
  • 22.18. SW-VARIABLE-IMPLEMENTATION
  • 22.19. SW-VARIABLE-KIND
  • 22.20. SW-VARIABLE-REF


22.1. SW-PARAM-VALUES-PHYS

Figure 220: DTD-diagram for SW-PARAM-VALUES-PHYS
Child elements | <v>
parent elements | <sw-param-content-v> <sw-param-content-x> <sw-param-content-y>
Attributes for SW-PARAM-VALUES-PHYS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.2. SW-PARAMS

Figure 221: DTD-diagram for SW-PARAMS
Child elements | <admin-data> <sw-param>
parent elements | <sw-data-dictionary> <sw-param>
Attributes for SW-PARAMS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.3. SW-PHYSIC-TYPE

Figure 222: DTD-diagram for SW-PHYSIC-TYPE
Child elements | <admin-data> <long-name> <short-name> <desc> <sw-unit-ref> <sw-limits> <sw-resolution> <sw-data-type-scaling> <sw-variable-sample-rate> <remark> <sw-var-init-value> <sw-var-not-av-value>
parent elements | <sw-physic-types>
Attributes for SW-PHYSIC-TYPE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | SW-PHYSIC-TYPE |
[ID] | id | required |  |
[S] | cdata | implied |  |


22.4. SW-PHYSIC-TYPE-1

Figure 223: DTD-diagram for SW-PHYSIC-TYPE-1
Child elements | <desc> <sw-unit-ref> <sw-limits> <sw-resolution> <sw-data-type-scaling> <sw-variable-sample-rate> <remark> <sw-var-init-value> <sw-var-not-av-value>
parent elements | <sw-variable>
Attributes for SW-PHYSIC-TYPE-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.5. SW-PHYSIC-TYPE-REF

Figure 224: DTD-diagram for SW-PHYSIC-TYPE-REF
Child elements | none
parent elements | <sw-variable>
Attributes for SW-PHYSIC-TYPE-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND SW-PHYSIC-TYPE |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[SW-PHYSIC-TYPE] | idref | required |  |


22.6. SW-PHYSIC-TYPES

Figure 225: DTD-diagram for SW-PHYSIC-TYPES
Child elements | <admin-data> <sw-physic-type>
parent elements | <sw-data-dictionary>
Attributes for SW-PHYSIC-TYPES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.7. SW-RESOLUTION

Figure 226: DTD-diagram for SW-RESOLUTION
Child elements | none
parent elements | <sw-physic-type> <sw-physic-type-1>
Attributes for SW-RESOLUTION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.8. SW-TEST-SPEC

Figure 227: DTD-diagram for SW-TEST-SPEC
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <sw-function-variant>
Attributes for SW-TEST-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.9. SW-UNIT

Figure 228: DTD-diagram for SW-UNIT
Child elements | <admin-data> <long-name> <short-name> <sw-unit-display> <si-unit> <sw-unit-ref> <sw-unit-to-ref-method> <sw-unit-from-ref-method>
parent elements | <sw-units>
Attributes for SW-UNIT
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | SW-UNIT |
[ID] | id | required |  |
[S] | cdata | implied |  |


22.10. SW-UNIT-DISPLAY

Figure 229: DTD-diagram for SW-UNIT-DISPLAY
Child elements | <sup> <sub>
parent elements | <sw-unit>
Attributes for SW-UNIT-DISPLAY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.11. SW-UNIT-FROM-REF-METHOD

Figure 230: DTD-diagram for SW-UNIT-FROM-REF-METHOD
Child elements | none
parent elements | <sw-unit>
Attributes for SW-UNIT-FROM-REF-METHOD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.12. SW-UNIT-REF

Figure 231: DTD-diagram for SW-UNIT-REF
Child elements | none
parent elements | <sw-compu-method> <sw-param-content-v> <sw-param-content-x> <sw-param-content-y> <sw-physic-type> <sw-physic-type-1> <sw-unit>
Attributes for SW-UNIT-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND SW-UNIT |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[SW-UNIT] | idref | required |  |


22.13. SW-UNIT-TO-REF-METHOD

Figure 232: DTD-diagram for SW-UNIT-TO-REF-METHOD
Child elements | none
parent elements | <sw-unit>
Attributes for SW-UNIT-TO-REF-METHOD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.14. SW-UNITS

Figure 233: DTD-diagram for SW-UNITS
Child elements | <admin-data> <sw-unit>
parent elements | <sw-data-dictionary>
Attributes for SW-UNITS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.15. SW-VAR-INIT-VALUE

Figure 234: DTD-diagram for SW-VAR-INIT-VALUE
Child elements | none
parent elements | <sw-physic-type> <sw-physic-type-1> <sw-variable-implementation>
Attributes for SW-VAR-INIT-VALUE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.16. SW-VAR-NOT-AV-VALUE

Figure 235: DTD-diagram for SW-VAR-NOT-AV-VALUE
Child elements | none
parent elements | <sw-physic-type> <sw-physic-type-1> <sw-variable-implementation>
Attributes for SW-VAR-NOT-AV-VALUE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.17. SW-VARIABLE

Figure 236: DTD-diagram for SW-VARIABLE
Child elements | <admin-data> <long-name> <short-name> <desc> <sw-physic-type-ref> <sw-physic-type-1> <sw-variable-implementation>
parent elements | <sw-variables>
Attributes for SW-VARIABLE
Name | Type | Class | Value | Remark
[CALIBRATION] | nmtkgrp | default | CALIBRATION NOT-IN-MEMORY CALIBRATION NO-CALIBRATION |
[F-ID-CLASS] | name | fixed | SW-VARIABLE |
[F-NAMESPACE] | names | fixed | SW-VARIABLE |
[ID] | id | required |  |
[S] | cdata | implied |  |


22.18. SW-VARIABLE-IMPLEMENTATION

Figure 237: DTD-diagram for SW-VARIABLE-IMPLEMENTATION
Child elements | <sw-base-type> <sw-bit-representation> <sw-variable-kind> <sw-limits> <sw-variable-sample-rate> <sw-var-init-value> <sw-var-not-av-value> <arraysize> <sw-addressing-method-ref> <sw-compu-method-ref> <sw-variables> <sw-code-syntax-ref> <annotations> <add-info>
parent elements | <sw-variable>
Attributes for SW-VARIABLE-IMPLEMENTATION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.19. SW-VARIABLE-KIND

Figure 238: DTD-diagram for SW-VARIABLE-KIND
Child elements | none
parent elements | <sw-variable-implementation>
Attributes for SW-VARIABLE-KIND
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.20. SW-VARIABLE-REF

Figure 239: DTD-diagram for SW-VARIABLE-REF
Child elements | none
parent elements | <sw-axis-individual> <sw-axis-shift-offset> <sw-function-modelonly-variables> <sw-param-target> <sw-variables-read> <sw-variables-readwrite> <sw-variables-write>
Attributes for SW-VARIABLE-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND SW-VARIABLE |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[SW-VARIABLE] | idref | required |  |


23. SW-VARIABLE-SAMPLE-RATE ... SYSTEM-OVERVIEW

MSRSW.DTD Elements and attributes
23. SW-VARIABLE-SAMPLE-RATE ... SYSTEM-OVERVIEW

Contents of this chapter:
  • 23.1. SW-VARIABLE-SAMPLE-RATE
  • 23.2. SW-VARIABLES
  • 23.3. SW-VARIABLES-READ
  • 23.4. SW-VARIABLES-READWRITE
  • 23.5. SW-VARIABLES-WRITE
  • 23.6. SYSTEM-OVERVIEW


23.1. SW-VARIABLE-SAMPLE-RATE

Figure 240: DTD-diagram for SW-VARIABLE-SAMPLE-RATE
Child elements | none
parent elements | <sw-physic-type> <sw-physic-type-1> <sw-variable-implementation>
Attributes for SW-VARIABLE-SAMPLE-RATE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


23.2. SW-VARIABLES

Figure 241: DTD-diagram for SW-VARIABLES
Child elements | <admin-data> <sw-variable>
parent elements | <sw-data-dictionary> <sw-variable-implementation>
Attributes for SW-VARIABLES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


23.3. SW-VARIABLES-READ

Figure 242: DTD-diagram for SW-VARIABLES-READ
Child elements | <sw-variable-ref>
parent elements | <sw-function-export-variables> <sw-function-import-variables>
Attributes for SW-VARIABLES-READ
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


23.4. SW-VARIABLES-READWRITE

Figure 243: DTD-diagram for SW-VARIABLES-READWRITE
Child elements | <sw-variable-ref>
parent elements | <sw-function-export-variables> <sw-function-import-variables> <sw-function-local-variables>
Attributes for SW-VARIABLES-READWRITE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


23.5. SW-VARIABLES-WRITE

Figure 244: DTD-diagram for SW-VARIABLES-WRITE
Child elements | <sw-variable-ref>
parent elements | <sw-function-export-variables> <sw-function-import-variables>
Attributes for SW-VARIABLES-WRITE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


23.6. SYSTEM-OVERVIEW

Figure 245: DTD-diagram for SYSTEM-OVERVIEW
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for SYSTEM-OVERVIEW
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


24. TABLE ... TYP

MSRSW.DTD Elements and attributes
24. TABLE ... TYP

Contents of this chapter:
  • 24.1. TABLE
  • 24.2. TBD
  • 24.3. TBODY
  • 24.4. TBR
  • 24.5. TEAM-MEMBER
  • 24.6. TEAM-MEMBER-REF
  • 24.7. TEAM-MEMBER-REFS
  • 24.8. TEAM-MEMBERS
  • 24.9. TEX-MATH
  • 24.10. TEXT
  • 24.11. TFOOT
  • 24.12. TGROUP
  • 24.13. THEAD
  • 24.14. TOL
  • 24.15. TOPIC-1
  • 24.16. TOPIC-2
  • 24.17. TT
  • 24.18. TYP


24.1. TABLE

Figure 246: DTD-diagram for TABLE
Child elements | <long-name> <short-name> <tgroup>
parent elements | <add-info> <chapter> <introduction> <ncoi-1> <sw-addressing-method-desc> <sw-application-notes> <sw-carb-doc> <sw-code-syntax-desc> <sw-function-desc> <sw-maintenance-notes> <sw-param-record-layout-desc> <sw-test-spec> <topic-1> <topic-2>
Attributes for TABLE
Name | Type | Class | Value | Remark
[COLSEP] | number | implied |  |
[F-ID-CLASS] | name | fixed | TABLE |
[FLOAT] | nmtkgrp | implied | FLOAT NO-FLOAT |
[FRAME] | nmtkgrp | implied | TOP BOTTOM TOPBOT ALL SIDES NONE |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[ORIENT] | nmtkgrp | implied | PORT LAND |
[PGWIDE] | number | implied |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[SHORTENTRY] | number | implied |  |
[TABSTYLE] | nmtoken | implied |  |
[TOCENTRY] | number | default | 1 |


24.2. TBD

Figure 247: DTD-diagram for TBD
Child elements | <team-member-refs> <schedule> <desc>
parent elements | <acceptance-cond> <add-spec> <demarcation-other-projects> <dir-hand-over-doc-data> <general-project-data> <integration-capability> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <sw-data-dictionary-spec> <sw-function-spec> <sw-glossary> <sw-param-contents-spec> <system-overview> <variant-spec>
Attributes for TBD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


24.3. TBODY

Figure 248: DTD-diagram for TBODY
Child elements | <row>
parent elements | <tgroup>
Attributes for TBODY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[VALIGN] | nmtkgrp | default | TOP TOP MIDDLE BOTTOM |


24.4. TBR

Figure 249: DTD-diagram for TBR
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie> <std> <xdoc> <xfile>
parent elements | <acceptance-cond> <add-spec> <demarcation-other-projects> <dir-hand-over-doc-data> <general-project-data> <integration-capability> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <sw-data-dictionary-spec> <sw-function-spec> <sw-glossary> <sw-param-contents-spec> <system-overview> <variant-spec>
Attributes for TBR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


24.5. TEAM-MEMBER

Figure 250: DTD-diagram for TEAM-MEMBER
Child elements | <roles> <long-name> <short-name> <department> <address> <zip> <city> <phone> <fax> <email> <homepage>
parent elements | <team-members>
Attributes for TEAM-MEMBER
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | TEAM-MEMBER |
[ID] | id | required |  |
[S] | cdata | implied |  |


24.6. TEAM-MEMBER-REF

Figure 251: DTD-diagram for TEAM-MEMBER-REF
Child elements | none
parent elements | <doc-revision> <team-member-refs>
Attributes for TEAM-MEMBER-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND TEAM-MEMBER |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[TEAM-MEMBER] | idref | required |  |


24.7. TEAM-MEMBER-REFS

Figure 252: DTD-diagram for TEAM-MEMBER-REFS
Child elements | <team-member-ref>
parent elements | <tbd>
Attributes for TEAM-MEMBER-REFS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


24.8. TEAM-MEMBERS

Figure 253: DTD-diagram for TEAM-MEMBERS
Child elements | <team-member>
parent elements | <company>
Attributes for TEAM-MEMBERS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


24.9. TEX-MATH

Figure 254: DTD-diagram for TEX-MATH
Child elements | none
parent elements | <formula>
Attributes for TEX-MATH
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


24.10. TEXT

Figure 255: DTD-diagram for TEXT
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for TEXT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


24.11. TFOOT

Figure 256: DTD-diagram for TFOOT
Child elements | <colspec> <row>
parent elements | <tgroup>
Attributes for TFOOT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[VALIGN] | nmtkgrp | default | TOP TOP MIDDLE BOTTOM |


24.12. TGROUP

Figure 257: DTD-diagram for TGROUP
Child elements | <colspec> <spanspec> <thead> <tfoot> <tbody>
parent elements | <table>
Attributes for TGROUP
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | default | LEFT LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | default |  |
[CHAROFF] | nutoken | default | 50 |
[COLS] | number | required |  |
[COLSEP] | number | implied |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[TGROUPSTYLE] | nmtoken | implied |  |


24.13. THEAD

Figure 258: DTD-diagram for THEAD
Child elements | <colspec> <row>
parent elements | <tgroup>
Attributes for THEAD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[VALIGN] | nmtkgrp | default | BOTTOM TOP MIDDLE BOTTOM |


24.14. TOL

Figure 259: DTD-diagram for TOL
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for TOL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


24.15. TOPIC-1

Figure 260: DTD-diagram for TOPIC-1
Child elements | <long-name> <short-name> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms>
parent elements | <add-info> <chapter> <ncoi-1> <sw-addressing-method-desc> <sw-application-notes> <sw-carb-doc> <sw-code-syntax-desc> <sw-function-desc> <sw-maintenance-notes> <sw-param-record-layout-desc> <sw-test-spec>
Attributes for TOPIC-1
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | TOPIC |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |


24.16. TOPIC-2

Figure 261: DTD-diagram for TOPIC-2
Child elements | <long-name> <short-name> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table>
parent elements | <introduction>
Attributes for TOPIC-2
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | TOPIC |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |


24.17. TT

Figure 262: DTD-diagram for TT
Child elements | none
parent elements | <change> <desc> <indent-sample> <item-label> <long-name> <long-name-1> <p> <reason> <tbr>
Attributes for TT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | nmtkgrp | required | SGMLTAG SGML-ATTRIBUTE TOOL PRODUCT VARIABLE STATE PRM MATERIAL CONTROL-ELEMENT CODE ORGANISATION OTHER |
[USER-DEFINED-TYPE] | cdata | implied |  |


24.18. TYP

Figure 263: DTD-diagram for TYP
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for TYP
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


25. UNIT ... USED-LANGUAGES

MSRSW.DTD Elements and attributes
25. UNIT ... USED-LANGUAGES

Contents of this chapter:
  • 25.1. UNIT
  • 25.2. USED-LANGUAGES


25.1. UNIT

Figure 264: DTD-diagram for UNIT
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for UNIT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


25.2. USED-LANGUAGES

Figure 265: DTD-diagram for USED-LANGUAGES
Child elements | none
parent elements | <admin-data>
Attributes for USED-LANGUAGES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


26. V ... VERBATIM

MSRSW.DTD Elements and attributes
26. V ... VERBATIM

Contents of this chapter:
  • 26.1. V
  • 26.2. VALUE
  • 26.3. VARIANT-CHAR
  • 26.4. VARIANT-CHAR-ASSIGN
  • 26.5. VARIANT-CHAR-ASSIGNS
  • 26.6. VARIANT-CHAR-REF
  • 26.7. VARIANT-CHAR-VALUE
  • 26.8. VARIANT-CHARS
  • 26.9. VARIANT-DEF
  • 26.10. VARIANT-DEF-REF
  • 26.11. VARIANT-DEF-REFS
  • 26.12. VARIANT-DEFS
  • 26.13. VARIANT-SPEC
  • 26.14. VERBATIM


26.1. V

Figure 266: DTD-diagram for V
Child elements | none
parent elements | <sw-param-values-adr> <sw-param-values-coded> <sw-param-values-coded-hex> <sw-param-values-generic> <sw-param-values-phys>
Attributes for V
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


26.2. VALUE

Figure 267: DTD-diagram for VALUE
Child elements | none
parent elements | <variant-char-value>
Attributes for VALUE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


26.3. VARIANT-CHAR

Figure 268: DTD-diagram for VARIANT-CHAR
Child elements | <long-name> <short-name> <code>
parent elements | <variant-chars>
Attributes for VARIANT-CHAR
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | VARIANT-CHAR |
[ID] | id | required |  |
[S] | cdata | implied |  |
[TYPE] | nmtkgrp | required | NEW-PART-NUMBER NO-NEW-PART-NUMBER |


26.4. VARIANT-CHAR-ASSIGN

Figure 269: DTD-diagram for VARIANT-CHAR-ASSIGN
Child elements | <variant-char-ref> <variant-char-value>
parent elements | <variant-char-assigns>
Attributes for VARIANT-CHAR-ASSIGN
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


26.5. VARIANT-CHAR-ASSIGNS

Figure 270: DTD-diagram for VARIANT-CHAR-ASSIGNS
Child elements | <variant-char-assign>
parent elements | <variant-def>
Attributes for VARIANT-CHAR-ASSIGNS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


26.6. VARIANT-CHAR-REF

Figure 271: DTD-diagram for VARIANT-CHAR-REF
Child elements | none
parent elements | <variant-char-assign>
Attributes for VARIANT-CHAR-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND VARIANT-CHAR |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[VARIANT-CHAR] | idref | required |  |


26.7. VARIANT-CHAR-VALUE

Figure 272: DTD-diagram for VARIANT-CHAR-VALUE
Child elements | <value> <code>
parent elements | <variant-char-assign>
Attributes for VARIANT-CHAR-VALUE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


26.8. VARIANT-CHARS

Figure 273: DTD-diagram for VARIANT-CHARS
Child elements | <variant-char>
parent elements | <variant-spec>
Attributes for VARIANT-CHARS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


26.9. VARIANT-DEF

Figure 274: DTD-diagram for VARIANT-DEF
Child elements | <long-name> <short-name> <code> <variant-char-assigns>
parent elements | <variant-defs>
Attributes for VARIANT-DEF
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | VARIANT-DEF |
[ID] | id | required |  |
[S] | cdata | implied |  |


26.10. VARIANT-DEF-REF

Figure 275: DTD-diagram for VARIANT-DEF-REF
Child elements | none
parent elements | <variant-def-refs>
Attributes for VARIANT-DEF-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND VARIANT-DEF |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[VARIANT-DEF] | idref | required |  |


26.11. VARIANT-DEF-REFS

Figure 276: DTD-diagram for VARIANT-DEF-REFS
Child elements | <variant-def-ref>
parent elements | <sw-function-variant>
Attributes for VARIANT-DEF-REFS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


26.12. VARIANT-DEFS

Figure 277: DTD-diagram for VARIANT-DEFS
Child elements | <variant-def>
parent elements | <variant-spec>
Attributes for VARIANT-DEFS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


26.13. VARIANT-SPEC

Figure 278: DTD-diagram for VARIANT-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <variant-chars> <variant-defs>
parent elements | <general-project-data>
Attributes for VARIANT-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


26.14. VERBATIM

Figure 279: DTD-diagram for VERBATIM
Child elements | none
parent elements | <add-info> <annotation-text> <chapter> <entry> <figure> <formula> <introduction> <item> <labeled-item> <ncoi-1> <remark> <sw-addressing-method-desc> <sw-application-notes> <sw-carb-doc> <sw-code-syntax-desc> <sw-function-desc> <sw-maintenance-notes> <sw-param-record-layout-desc> <sw-test-spec> <topic-1> <topic-2>
Attributes for VERBATIM
Name | Type | Class | Value | Remark
[ALLOW-BREAK] | number | default | 1 |
[FLOAT] | nmtkgrp | implied | FLOAT NO-FLOAT |
[HELP-ENTRY] | cdata | implied |  |
[S] | cdata | implied |  |


27. XDOC ... XREF

MSRSW.DTD Elements and attributes
27. XDOC ... XREF

Contents of this chapter:
  • 27.1. XDOC
  • 27.2. XFILE
  • 27.3. XREF


27.1. XDOC

Figure 280: DTD-diagram for XDOC
Child elements | <long-name-1> <short-name> <number> <state-1> <date-1> <publisher> <file> <position>
parent elements | <p> <tbr>
Attributes for XDOC
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | date-1:date |
[F-ID-CLASS] | name | fixed | XDOC |
[ID] | id | required |  |
[S] | cdata | implied |  |


27.2. XFILE

Figure 281: DTD-diagram for XFILE
Child elements | <long-name-1> <short-name> <file>
parent elements | <p> <tbr>
Attributes for XFILE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | XFILE |
[ID] | id | required |  |
[S] | cdata | implied |  |


27.3. XREF

Figure 282: DTD-diagram for XREF
Child elements | none
parent elements | <change> <desc> <indent-sample> <item-label> <p> <reason> <tbr>
Attributes for XREF
Name | Type | Class | Value | Remark
[EXT-ID-CLASS] | cdata | implied |  |
[HYNAMES] | names | fixed | LINKEND ID-REF |
[HYTIME] | name | fixed | CLINK |
[ID-CLASS] | nmtkgrp | required | CHAPTER COMPANY DEF-ITEM FIGURE FORMULA PRM SAMPLE STD SW-FUNCTION SW-UNIT SW-PHYSIC-TYPE SW-VARIABLE SW-PARAM SW-COMPU-METHOD SW-ADDRESSING-METHOD SW-PARAM-RECORD-LAYOUT SW-CODE-SYNTAX TABLE TEAM-MEMBER TOPIC VARIANT-CHAR VARIANT-DEF XDOC XFILE EXTERNAL |
[ID-REF] | idref | required |  |
[S] | cdata | implied |  |


28. ZIP ... ZIP

MSRSW.DTD Elements and attributes
28. ZIP ... ZIP

Contents of this chapter:
  • 28.1. ZIP


28.1. ZIP

Figure 283: DTD-diagram for ZIP
Child elements | none
parent elements | <team-member>
Attributes for ZIP
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


Technical Terms

MSRSW.DTD Elements and attributes
Technical Terms


Code

code | I.1.
crpctmt.wmf | 8.3.
ENTITY | 8.3.
organization | I.1.
other | I.1.
product | I.1.
scale="0.5" | 8.3.
SDATA | 8.3.
SGML-attribute | I.1.
SGMLTAG | I.1.
ubyte | 2.2.


Organisations

ASAP
I.1.


OTHER

calibration | 20.9.
not-in-memory | 20.9.
calibration | 20.9.
discrete | 18.18.
ECU | I.1.
interpolation | 18.18.
interpolation-style | 18.18.
no-calibration | 20.9.


Products

ASAP2 | I.1.
ASCET | 17.7.
MSRREP DTD | I.1.
MSRSW DTD |
MSRSYS DTD | 7.6.


SGML Attributes

ALIGN
3.12. 6.4. 17.9. 24.12.
ALLOW-BREAK
26.14.
AMOUNT-OF-SUBSTANCE-EXPO
17.8.
APPLICABLE
18.6.
BREAK
3.3.
CALIBRATION
20.9. 22.17.
CATEGORY
8.3.
CHAR
3.12. 6.4. 17.9. 24.12.
CHAROFF
3.12. 6.4. 17.9. 24.12.
COLNAME
3.12. 6.4.
COLNUM
3.12.
COLS
24.12.
COLSEP
3.12. 6.4. 17.9. 24.1. 24.12.
COLWIDTH
3.12.
COMPANY
3.17.
DOCORSUB
13.4.
ELECTRIC-CURRENT-EXPO
17.8.
EXT-ID-CLASS
27.3.
F-CHILD-TYPE
1.6. 3.14. 3.18. 5.11. 16.6. 17.1. 17.12. 27.1.
F-ID-CLASS
3.3. 3.14. 5.4. 7.2. 7.4. 15.10. 17.1. 17.12. 17.16. 18.10. 18.16. 19.10. 20.9. 21.6. 22.3. 22.9. 22.17. 24.1. 24.5. 24.15. 24.16. 26.3. 26.9. 27.1. 27.2.
F-NAMESPACE
3.14. 12.6. 19.10. 22.17.
F-PUBID
12.6.
FILENAME
7.3. 8.3.
FIT
8.3.
FLOAT
7.2. 24.1. 26.14.
FRAME
24.1.
FUNCTION
7.6.
HEIGHT
8.3.
HELP-ENTRY
3.3. 5.4. 7.2. 11.2. 15.1. 24.1. 24.15. 24.16. 26.14.
HYNAMES
3.17. 7.6. 17.2. 17.19. 18.13. 18.17. 19.18. 21.9. 21.11. 22.5. 22.12. 22.20. 24.6. 26.6. 26.10. 27.3.
HYTIME
3.17. 7.6. 12.6. 13.2. 13.4. 17.2. 17.19. 18.13. 18.17. 19.18. 21.9. 21.11. 22.5. 22.12. 22.20. 24.6. 26.6. 26.10. 27.3.
ID
3.3. 3.14. 5.4. 7.2. 7.4. 13.2. 15.10. 17.1. 17.12. 17.16. 18.10. 18.16. 19.10. 20.9. 21.6. 22.3. 22.9. 22.17. 24.1. 24.5. 24.15. 24.16. 26.3. 26.9. 27.1. 27.2.
ID-CLASS
27.3.
ID-REF
27.3.
INTERPOLATION-STYLE
18.18.
ITEM-LABEL-POS
10.2.
LANG-SUBSET
15.13.
LENGTH-EXPO
17.8.
LUMINOUS-INTENSITY-EXPO
17.8.
MASS-EXPO
17.8.
MOREROWS
6.4.
NAMEEND
6.4. 17.9.
NAMEST
6.4. 17.9.
NAMETYPE
13.4.
NOTATION
7.3. 8.3.
NOTE-TYPE
13.5.
ORIENT
24.1.
OWNS
21.11.
PGWIDE
24.1.
PROG-LANG
15.13.
PUBID
12.6.
ROLE
3.14.
ROTATE
6.4.
ROWSEP
3.12. 6.4. 16.7. 17.9. 24.1. 24.12.
S
1.1. 1.2. 1.3. 1.4. 1.5. 1.6. 1.7. 1.8. 1.9. 1.10. 1.11. 2.1. 2.2. 2.3. 2.4. 3.1. 3.2. 3.3. 3.4. 3.5. 3.6. 3.7. 3.8. 3.9. 3.10. 3.11. 3.12. 3.13. 3.14. 3.15. 3.16. 3.17. 3.18. 3.19. 3.20. 4.1. 5.1. 5.2. 5.3. 5.4. 5.5. 5.6. 5.7. 5.8. 5.9. 5.10. 5.11. 5.12. 6.1. 6.2. 6.3. 6.4. 7.1. 7.2. 7.3. 7.4. 7.5. 7.6. 8.1. 8.2. 8.3. 9.1. 10.1. 10.2. 10.3. 10.4. 10.5. 10.6. 11.1. 11.2. 11.3. 11.4. 11.5. 11.6. 11.7. 11.8. 11.9. 12.1. 12.2. 12.3. 12.4. 12.5. 12.6. 13.1. 13.2. 13.3. 13.4. 13.5. 13.6. 14.1. 14.2. 14.3. 15.1. 15.2. 15.3. 15.4. 15.5. 15.6. 15.7. 15.8. 15.9. 15.10. 15.11. 15.12. 15.13. 15.14. 15.15. 15.16. 15.17. 15.18. 15.19. 16.1. 16.2. 16.3. 16.4. 16.5. 16.6. 16.7. 17.1. 17.2. 17.3. 17.4. 17.5. 17.6. 17.7. 17.8. 17.9. 17.10. 17.11. 17.12. 17.13. 17.14. 17.15. 17.16. 17.17. 17.18. 17.19. 17.20. 18.1. 18.2. 18.3. 18.4. 18.5. 18.6. 18.7. 18.8. 18.9. 18.10. 18.11. 18.12. 18.13. 18.14. 18.15. 18.16. 18.17. 18.18. 18.19. 18.20. 19.1. 19.2. 19.3. 19.4. 19.5. 19.6. 19.7. 19.8. 19.9. 19.10. 19.11. 19.12. 19.13. 19.14. 19.15. 19.16. 19.17. 19.18. 19.19. 19.20. 20.1. 20.2. 20.3. 20.4. 20.5. 20.6. 20.7. 20.8. 20.9. 20.10. 20.11. 20.12. 20.13. 20.14. 20.15. 20.16. 20.17. 20.18. 20.19. 20.20. 21.1. 21.2. 21.3. 21.4. 21.5. 21.6. 21.7. 21.8. 21.9. 21.10. 21.11. 21.12. 21.13. 21.14. 21.15. 21.16. 21.17. 21.18. 21.19. 22.1. 22.2. 22.3. 22.4. 22.5. 22.6. 22.7. 22.8. 22.9. 22.10. 22.11. 22.12. 22.13. 22.14. 22.15. 22.16. 22.17. 22.18. 22.19. 22.20. 23.1. 23.2. 23.3. 23.4. 23.5. 23.6. 24.1. 24.2. 24.3. 24.4. 24.5. 24.6. 24.7. 24.8. 24.9. 24.10. 24.11. 24.12. 24.13. 24.14. 24.15. 24.16. 24.17. 24.18. 25.1. 25.2. 26.1. 26.2. 26.3. 26.4. 26.5. 26.6. 26.7. 26.8. 26.9. 26.10. 26.11. 26.12. 26.13. 26.14. 27.1. 27.2. 27.3. 28.1.
SAMPLE
17.2.
SCALE
8.3.
SHORTENTRY
24.1.
SPANNAME
6.4. 17.9.
SW-ADDRESSING-METHOD
17.19.
SW-CODE-SYNTAX
18.13.
SW-COMPU-METHOD
18.17.
SW-FUNCTION
19.18.
SW-PARAM
21.11.
SW-PARAM-RECORD-LAYOUT
21.9.
SW-PHYSIC-TYPE
22.5.
SW-UNIT
22.12.
SW-VARIABLE
22.20.
TABSTYLE
24.1.
TEAM-MEMBER
24.6.
TGROUPSTYLE
24.12.
THERMODYNAMIC-TEMPERATURE-EXPO
17.8.
TIME-EXPO
17.8.
TOCENTRY
24.1.
TOOL
7.3.
TOOL-VERSION
7.3.
type
I.1.
USED-LIBS
15.13.
USER-DEFINED-TYPE
13.5. 24.17.
VALIGN
6.4. 24.3. 24.11. 24.13.
VARIANT-CHAR
26.6.
VARIANT-DEF
26.10.
WIDTH
8.3.


SGML Elements

short-name | 11.1.
variant-def-ref | 20.2.
abs | 15.10. 15.11. 17.13. 17.15.
acceptance-cond | 8.1. 10.4. 13.1. 13.3. 24.2. 24.4.
add-info | 1.3. 1.4. 3.3. 5.5. 7.2. 7.4. 11.3. 11.6. 13.5. 15.1. 15.12. 20.2. 20.9. 22.18. 24.1. 24.15. 26.14.
add-spec | 1.3. 1.4. 8.1. 10.4. 12.6. 13.1. 13.3. 24.2. 24.4.
address | 24.5.
admin-data | 3.3. 3.16. 5.12. 8.1. 11.5. 12.6. 17.16. 17.20. 18.10. 18.14. 18.16. 19.2. 19.4. 19.5. 19.10. 19.20. 20.2. 20.5. 20.9. 21.1. 21.3. 21.6. 21.10. 22.2. 22.3. 22.6. 22.9. 22.14. 22.17. 23.2. 25.2.
annotation | 1.7. 1.8. 1.9. 1.10. 11.1.
annotation-origin | 1.7.
annotation-text | 1.7. 15.1. 26.14.
annotations | 1.7. 19.10. 20.2. 20.9. 20.16. 21.1. 22.18.
arraysize | 1.11. 20.9. 22.18.
behaviour | 7.6.
bit-base-name | 2.1. 18.8.
bit-base-type | 2.2. 18.8.
bit-count | 2.3. 18.8.
bit-pos | 2.4. 18.8.
c-code | 7.4.
change | 6.1. 7.5. 10.1. 12.4. 17.13. 17.15. 24.17. 27.3.
chapter | 1.3. 1.6. 3.3. 5.5. 7.2. 7.4. 11.3. 11.6. 11.8. 13.3. 13.5. 15.1. 15.12. 17.7. 17.18. 18.1. 18.9. 18.12. 19.13. 20.8. 21.8. 22.8. 24.1. 24.15. 26.14.
city | 24.5.
cmt-int | 18.20. 19.1.
cmt-phys | 19.1.
cmt-text | 18.20.
code | 3.8. 26.3. 26.7. 26.9.
coded | 3.10. 3.11. 20.7.
coded-max | 3.9.
coded-min | 3.9.
colspec | 24.11. 24.12. 24.13.
companies | 3.14. 15.14.
company | 3.13. 8.1. 11.8. 17.7. 24.8.
company-doc-info | 3.16. 3.17. 5.10. 6.3. 15.9.
company-doc-infos | 1.6. 3.15.
company-ref | 3.15. 3.18.
company-revision-info | 3.17. 3.19. 10.4. 16.4. 17.10.
company-revision-infos | 3.18. 5.11.
cond | 15.1. 15.11.
count | 21.16.
date | 5.11. 17.5.
date-1 | 17.12. 27.1.
def | 5.4. 15.1.
def-item | 5.3. 5.5. 11.8. 17.7.
def-list | 1.3. 3.3. 5.4. 6.4. 10.4. 10.5. 11.2. 13.3. 16.3. 17.18. 18.1. 18.9. 18.12. 19.13. 20.8. 21.8. 22.8. 24.15. 24.16.
demarcation-other-projects | 8.1. 10.4. 13.1. 13.3. 24.2. 24.4.
department | 24.5.
desc | 6.1. 7.2. 7.5. 10.1. 14.3. 15.10. 15.14. 17.13. 17.15. 19.4. 20.9. 20.16. 21.1. 22.3. 22.4. 22.17. 24.2. 24.17. 27.3.
dir-hand-over-doc-data | 8.1. 10.4. 13.1. 13.3. 24.2. 24.4.
doc-label | 3.15.
doc-revision | 3.19. 5.1. 5.12. 12.5. 24.6.
doc-revisions | 1.6. 5.11.
e | 3.2. 5.8. 10.2. 10.6. 15.1. 16.1. 24.4.
email | 24.5.
entity-name | 3.15.
entry | 5.5. 7.2. 7.4. 11.3. 11.6. 13.5. 15.1. 16.7. 26.14.
fax | 24.5.
figure | 1.3. 3.3. 5.8. 6.4. 8.3. 10.4. 10.5. 11.2. 11.8. 13.3. 16.3. 17.7. 17.18. 18.1. 18.9. 18.12. 19.12. 19.13. 20.8. 21.8. 22.8. 24.15. 24.16. 26.14.
file | 17.12. 27.1. 27.2.
formula | 1.3. 3.1. 3.3. 6.4. 8.2. 8.3. 10.4. 10.5. 11.2. 11.8. 13.3. 16.3. 17.7. 17.18. 18.1. 18.9. 18.12. 19.13. 20.8. 21.8. 22.8. 24.9. 24.15. 24.16. 26.14.
ft | 3.2. 5.8. 10.2. 10.6. 15.1. 16.1. 24.4.
function | 7.6.
function-ref | 19.9.
general-project-data | 1.2. 1.4. 1.6. 3.14. 5.6. 5.9. 10.3. 10.4. 13.1. 14.1. 15.2. 15.16. 15.17. 15.19. 16.2. 17.3. 23.6. 24.2. 24.4. 26.13.
generic-math | 7.4.
graphic | 7.2. 7.4. 8.3.
homepage | 24.5.
ie | 3.2. 5.8. 10.2. 10.6. 11.8. 11.9. 15.1. 16.1. 17.13. 17.15. 24.4.
indent-sample | 6.1. 7.5. 10.1. 11.3. 17.13. 17.15. 24.17. 27.3.
integration-capability | 8.1. 10.4. 13.1. 13.3. 24.2. 24.4.
introduction | 1.2. 1.4. 3.18. 5.5. 5.6. 5.9. 7.2. 7.4. 8.1. 10.3. 10.4. 11.3. 11.6. 12.6. 13.5. 14.1. 15.1. 15.2. 15.16. 15.17. 15.19. 16.2. 17.3. 19.5. 19.20. 20.5. 21.3. 23.6. 24.1. 24.16. 26.13. 26.14.
item | 5.5. 7.2. 7.4. 11.3. 11.6. 13.5. 15.1. 26.14.
item-label | 6.1. 7.5. 10.1. 11.2. 17.13. 17.15. 24.17. 27.3.
label | 1.7. 11.1. 11.4. 13.5. 14.3. 15.12. 15.14.
labeled-item | 5.5. 7.2. 7.4. 10.6. 11.3. 11.6. 13.5. 15.1. 26.14.
labeled-list | 1.3. 3.3. 6.4. 10.2. 10.4. 10.5. 11.2. 13.3. 16.3. 17.18. 18.1. 18.9. 18.12. 19.13. 20.8. 21.8. 22.8. 24.15. 24.16.
labels | 11.1. 20.12.
language | 1.6.
list | 1.3. 3.3. 6.4. 10.4. 10.5. 11.2. 13.3. 16.3. 17.18. 18.1. 18.9. 18.12. 19.13. 20.8. 21.8. 22.8. 24.15. 24.16.
locs | 12.6. 13.2.
long-name | 3.3. 3.14. 5.4. 7.2. 7.4. 8.3. 10.1. 11.1. 13.2. 15.10. 17.1. 17.16. 18.10. 18.16. 19.10. 20.9. 21.6. 22.3. 22.9. 22.17. 24.1. 24.5. 24.15. 24.16. 24.17. 26.3. 26.9.
long-name-1 | 10.1. 17.12. 24.17. 27.1. 27.2.
max | 15.10. 15.11. 17.13. 17.15.
max-count | 18.5. 18.6.
min | 15.10. 15.11. 17.13. 17.15.
modification | 3.2. 12.5. 16.1.
modifications | 5.11. 12.4.
msrsw | I.1. 1.4. 1.6. 10.4. 11.7. 15.15. 17.7. 19.5. 19.18. 19.19. 19.20. 20.5. 21.3.
na | 1.2. 1.4. 5.6. 5.9. 8.1. 10.3. 14.1. 15.2. 15.16. 15.17. 15.19. 16.2. 17.3. 19.5. 19.20. 20.5. 21.3. 23.6. 26.13.
nameloc | 11.7. 11.8. 13.4. 17.7.
ncoi-1 | 1.2. 1.4. 3.3. 5.5. 5.6. 5.9. 7.2. 7.4. 10.3. 11.3. 11.6. 13.5. 14.1. 15.1. 15.2. 15.12. 15.16. 15.17. 15.19. 16.2. 17.1. 19.12. 20.5. 23.6. 24.1. 24.15. 26.14.
nmlist | 13.2.
note | 1.3. 3.3. 6.4. 10.4. 10.5. 11.1. 11.2. 13.3. 15.1. 16.3. 17.18. 18.1. 18.9. 18.12. 19.13. 20.8. 21.8. 22.8. 24.15. 24.16.
number | 27.1.
objectives | 8.1. 10.4. 13.1. 13.3. 24.2. 24.4.
offset | 18.6.
overall-project | 5.8. 11.1. 15.15.
p | 1.3. 1.9. 3.3. 3.20. 5.3. 6.1. 6.4. 7.5. 10.1. 10.4. 10.5. 11.2. 13.3. 13.5. 16.3. 17.12. 17.13. 17.15. 17.18. 18.1. 18.9. 18.12. 19.13. 20.8. 21.8. 22.8. 24.15. 24.16. 24.17. 27.1. 27.2. 27.3.
parallel-designs | 8.1. 10.4. 13.1. 13.3. 24.2. 24.4.
phone | 24.5.
phys | 15.5. 15.6. 20.7.
phys-max | 15.4.
phys-min | 15.4.
position | 17.12. 27.1.
private-code | 15.9.
private-codes | 3.15. 15.8.
prm | 5.8. 11.8. 15.11. 15.12. 17.7.
prm-char | 1.1. 3.20. 12.1. 12.3. 15.10. 16.3. 24.10. 24.14. 24.18. 25.1.
prms | 1.3. 3.3. 11.1. 13.3. 15.10. 17.18. 18.1. 18.9. 18.12. 19.13. 20.8. 21.8. 22.8. 24.15.
prog-code | 18.16.
project | 3.13. 5.8. 11.1. 15.15.
project-data | 12.6. 14.3. 15.14. 20.2.
project-schedule | 8.1. 10.4. 13.1. 13.3. 24.2. 24.4.
protocols | 8.1. 10.4. 13.1. 13.3. 24.2. 24.4.
publisher | 27.1.
purchasing-cond | 8.1. 10.4. 13.1. 13.3. 24.2. 24.4.
reason | 6.1. 7.5. 10.1. 12.4. 17.13. 17.15. 24.17. 27.3.
reason-order | 8.1. 10.4. 13.1. 13.3. 24.2. 24.4.
remark | 5.5. 7.2. 7.4. 11.3. 11.6. 13.5. 15.1. 15.11. 22.3. 22.4. 26.14.
revision-label | 3.18.
role | 16.6.
roles | 16.5. 24.5.
row | 6.4. 24.3. 24.11. 24.13.
sample | 11.8. 13.3. 17.4. 17.7.
sample-ref | 17.5.
sample-spec | 8.1. 10.4. 13.1. 17.4. 24.2. 24.4.
samples | 17.1. 17.3.
schedule | 5.1. 17.2. 24.2.
shift | 18.6.
short-name | 3.3. 3.14. 5.4. 7.2. 7.4. 12.6. 13.2. 15.10. 17.1. 17.7. 17.12. 17.16. 18.10. 18.16. 19.10. 20.9. 21.6. 22.3. 22.9. 22.17. 24.1. 24.5. 24.15. 24.16. 26.3. 26.9. 27.1. 27.2.
si-unit | 22.9.
spanspec | 24.12.
state | 3.18.
state-1 | 17.12. 27.1.
std | 5.2. 7.3. 11.9. 15.1. 15.7. 17.7. 17.11. 17.14. 24.4.
sub | 1.1. 3.2. 5.8. 10.1. 10.2. 10.6. 12.1. 12.3. 15.1. 16.1. 22.10. 24.4. 24.10. 24.14. 24.18. 25.1.
subtitle | 17.12.
sup | 1.1. 3.2. 5.8. 10.1. 10.2. 10.6. 12.1. 12.3. 15.1. 16.1. 22.10. 24.4. 24.10. 24.14. 24.18. 25.1.
sw-addressing-method | 1.6. 11.8. 17.7. 17.17. 17.18. 17.20.
sw-addressing-method-class | 17.16.
sw-addressing-method-desc | 3.3. 5.5. 7.2. 7.4. 11.3. 11.6. 13.5. 15.1. 15.12. 17.16. 24.1. 24.15. 26.14.
sw-addressing-method-ref | 20.9. 22.18.
sw-addressing-methods | 1.6. 17.16. 19.4.
sw-application-notes | 3.3. 5.5. 7.2. 7.4. 11.3. 11.6. 13.5. 15.1. 15.12. 20.2. 24.1. 24.15. 26.14.
sw-array-index | 20.16.
sw-asap-6-prm-method | 18.16.
sw-axis-grouped | 20.13. 20.14. 21.11.
sw-axis-individual | 12.2. 20.7. 20.13. 20.14. 21.4. 22.20.
sw-axis-shift-offset | 12.2. 14.2. 17.6. 20.13. 20.14. 22.20.
sw-base-type | 20.9. 22.18.
sw-bit-representation | 2.1. 2.2. 2.3. 2.4. 22.18.
sw-carb-doc | 3.3. 5.5. 7.2. 7.4. 11.3. 11.6. 13.5. 15.1. 15.12. 20.2. 24.1. 24.15. 26.14.
sw-code-syntax | 1.6. 11.8. 17.7. 18.11. 18.12. 18.14.
sw-code-syntax-class | 18.10.
sw-code-syntax-desc | 3.3. 5.5. 7.2. 7.4. 11.3. 11.6. 13.5. 15.1. 15.12. 18.10. 24.1. 24.15. 26.14.
sw-code-syntax-ref | 20.9. 22.18.
sw-code-syntaxes | 1.6. 18.10. 19.4.
sw-compu-generic-math | 18.16.
sw-compu-method | 1.6. 11.8. 15.13. 17.7. 18.3. 18.15. 18.18. 18.19. 19.2. 22.12.
sw-compu-method-ref | 20.12. 22.18.
sw-compu-method-table | 18.16. 19.1.
sw-compu-method-text | 18.16. 18.20.
sw-compu-method-text-pair | 3.5. 3.7. 18.19.
sw-compu-method-value-pair | 3.5. 3.6. 18.18.
sw-compu-methods | 1.6. 18.16. 19.4.
sw-data-dictionaries | 19.4. 19.5.
sw-data-dictionary | 1.6. 5.8. 17.20. 18.10. 18.14. 19.2. 19.3. 19.7. 19.18. 21.10. 22.2. 22.6. 22.14. 23.2.
sw-data-dictionary-spec | 1.6. 10.4. 12.6. 13.1. 19.3. 20.2. 24.2. 24.4.
sw-data-type-scaling | 22.3. 22.4.
sw-datadictionary-class | 19.4.
sw-decomposition | 19.18. 19.20. 20.2.
sw-fulfils | 7.6. 20.2.
sw-function | 1.6. 1.10. 11.8. 17.7. 19.11. 20.3. 20.4.
sw-function-class | 19.10.
sw-function-def | 7.2. 13.3. 20.2.
sw-function-desc | 3.3. 5.5. 7.2. 7.4. 11.3. 11.6. 13.5. 15.1. 15.12. 20.2. 24.1. 24.15. 26.14.
sw-function-export-variables | 20.1. 23.3. 23.4. 23.5.
sw-function-import-variables | 20.1. 23.3. 23.4. 23.5.
sw-function-local-variables | 20.1. 23.4.
sw-function-modelonly-variables | 20.1. 22.20.
sw-function-ref | 19.4. 19.8. 19.19. 20.16. 21.1.
sw-function-refs | 12.6. 19.18.
sw-function-spec | 1.6. 10.4. 12.6. 13.1. 20.4. 24.2. 24.4.
sw-function-variables | 19.14. 19.15. 19.16. 19.17. 20.2.
sw-function-variant | 1.3. 1.6. 1.10. 18.1. 18.9. 19.5. 19.8. 19.9. 19.12. 19.13. 20.1. 20.3. 20.8. 21.3. 21.12. 22.8. 26.11.
sw-function-variants | 19.10. 20.2.
sw-functions | 19.10. 19.20.
sw-glossary | 1.6. 10.4. 12.6. 13.1. 13.3. 24.2. 24.4.
sw-interpolation-method | 20.9.
sw-limits | 3.9. 15.4. 18.5. 20.12. 22.3. 22.4. 22.18.
sw-maintenance-notes | 3.3. 5.5. 7.2. 7.4. 11.3. 11.6. 13.5. 15.1. 15.12. 20.2. 24.1. 24.15. 26.14.
sw-param | 1.3. 1.6. 1.10. 1.11. 5.8. 11.8. 17.7. 17.19. 18.7. 18.13. 20.6. 20.10. 20.11. 20.13. 20.14. 20.15. 21.4. 21.9. 21.13. 21.15. 21.16. 22.2.
sw-param-array-x | 20.9. 20.12. 20.13.
sw-param-array-xy | 20.9. 20.12. 20.13. 20.14.
sw-param-axis-values | 11.4. 18.17. 20.7. 20.10. 20.11. 21.5. 21.13. 21.16.
sw-param-axis-x | 18.4. 18.5. 18.6. 20.10. 20.11.
sw-param-axis-y | 18.4. 18.5. 18.6. 20.11.
sw-param-class | 20.9. 20.16.
sw-param-content | 1.10. 5.8. 18.2. 19.18. 20.15. 20.17. 20.18. 20.19. 20.20. 21.1. 21.11.
sw-param-content-text | 20.16.
sw-param-content-v | 20.16. 21.17. 21.18. 21.19. 21.20. 22.1. 22.12.
sw-param-content-x | 20.16. 21.17. 21.18. 21.19. 21.20. 22.1. 22.12.
sw-param-content-y | 20.16. 21.17. 21.18. 21.19. 21.20. 22.1. 22.12.
sw-param-contents | 1.6. 1.10. 5.8. 19.18. 20.16. 21.2. 21.3.
sw-param-contents-class | 21.1.
sw-param-contents-spec | 1.6. 10.4. 12.6. 13.1. 20.2. 21.1. 24.2. 24.4.
sw-param-group-axis | 18.5. 20.9. 21.14.
sw-param-noeffect-value | 20.12.
sw-param-record-layout | 1.6. 11.8. 17.7. 21.7. 21.8. 21.10.
sw-param-record-layout-class | 21.6.
sw-param-record-layout-desc | 3.3. 5.5. 7.2. 7.4. 11.3. 11.6. 13.5. 15.1. 15.12. 21.6. 24.1. 24.15. 26.14.
sw-param-record-layout-ref | 20.9.
sw-param-record-layouts | 1.6. 19.4. 21.6.
sw-param-ref | 18.4. 20.16. 21.12.
sw-param-refs | 20.2. 21.11.
sw-param-single-value | 20.9. 20.12.
sw-param-target | 21.4. 22.20.
sw-param-text | 20.9.
sw-param-value-block | 4.1. 11.1. 11.4. 20.9. 20.12.
sw-param-values-adr | 20.18. 20.19. 20.20. 26.1.
sw-param-values-coded | 20.18. 20.19. 20.20. 26.1.
sw-param-values-coded-hex | 20.18. 20.19. 20.20. 26.1.
sw-param-values-generic | 20.18. 20.19. 20.20. 26.1.
sw-param-values-phys | 20.18. 20.19. 20.20. 26.1.
sw-params | 1.6. 19.4. 20.9.
sw-physic-type | 1.6. 5.8. 11.8. 16.3. 17.7. 19.6. 20.7. 22.6. 22.7. 22.12. 22.15. 22.16. 23.1.
sw-physic-type-1 | 5.8. 16.3. 19.6. 20.7. 22.7. 22.12. 22.15. 22.16. 22.17. 23.1.
sw-physic-type-ref | 22.17.
sw-physic-types | 1.6. 19.4. 22.3.
sw-prm | 1.1.
sw-resolution | 22.3. 22.4.
sw-test-spec | 3.3. 5.5. 7.2. 7.4. 11.3. 11.6. 13.5. 15.1. 15.12. 20.2. 24.1. 24.15. 26.14.
sw-unit | 1.6. 11.8. 17.7. 17.8. 22.10. 22.11. 22.12. 22.13. 22.14.
sw-unit-display | 17.13. 17.15. 22.9.
sw-unit-from-ref-method | 22.9.
sw-unit-ref | 18.16. 20.18. 20.19. 20.20. 22.3. 22.4. 22.9.
sw-unit-to-ref-method | 22.9.
sw-units | 1.6. 19.4. 22.9.
sw-var-init-value | 22.3. 22.4. 22.18.
sw-var-not-av-value | 22.3. 22.4. 22.18.
sw-variable | 1.6. 1.11. 5.8. 11.8. 17.7. 22.4. 22.5. 22.18. 23.2.
sw-variable-implementation | 1.3. 1.10. 1.11. 17.19. 18.7. 18.8. 18.13. 18.17. 20.7. 22.15. 22.16. 22.17. 22.19. 23.1. 23.2.
sw-variable-kind | 22.18.
sw-variable-ref | 18.5. 18.6. 19.17. 21.14. 23.3. 23.4. 23.5.
sw-variable-sample-rate | 22.3. 22.4. 22.18.
sw-variables | 1.6. 19.4. 22.17. 22.18.
sw-variables-read | 19.14. 19.15. 22.20.
sw-variables-readwrite | 19.14. 19.15. 19.16. 22.20.
sw-variables-write | 19.14. 19.15. 22.20.
system-overview | 8.1. 10.4. 13.1. 13.3. 24.2. 24.4.
table | 1.3. 3.3. 8.3. 10.4. 11.8. 13.3. 17.7. 17.18. 18.1. 18.9. 18.12. 19.13. 20.8. 21.8. 22.8. 24.12. 24.15. 24.16.
tbd | 1.2. 1.4. 5.6. 5.8. 5.9. 8.1. 10.3. 14.1. 15.2. 15.16. 15.17. 15.19. 16.2. 17.3. 17.5. 19.5. 19.20. 20.5. 21.3. 23.6. 24.7. 26.13.
tbody | 16.7. 24.12.
tbr | 1.2. 1.4. 5.6. 5.9. 6.1. 7.5. 8.1. 10.1. 10.3. 14.1. 15.2. 15.16. 15.17. 15.19. 16.2. 17.3. 17.12. 17.13. 17.15. 19.5. 19.20. 20.5. 21.3. 23.6. 24.17. 26.13. 27.1. 27.2. 27.3.
team-member | 1.5. 3.4. 5.7. 6.2. 7.1. 9.1. 11.8. 15.3. 16.6. 17.7. 24.8. 28.1.
team-member-ref | 5.11. 24.7.
team-member-refs | 24.2. 24.6.
team-members | 3.14. 24.5.
tex-math | 7.4.
text | 15.11. 17.13. 17.15.
tfoot | 3.12. 16.7. 24.12.
tgroup | 3.12. 17.9. 24.1. 24.3. 24.11. 24.13.
thead | 3.12. 16.7. 24.12.
tol | 15.10. 15.11. 17.13. 17.15.
topic-1 | 1.3. 3.3. 5.5. 7.2. 7.4. 11.3. 11.6. 11.8. 13.3. 13.5. 15.1. 15.12. 17.7. 17.18. 18.1. 18.9. 18.12. 19.13. 20.8. 21.8. 22.8. 24.1. 26.14.
topic-2 | 5.5. 7.2. 7.4. 10.4. 11.3. 11.6. 11.8. 13.5. 15.1. 17.7. 24.1. 26.14.
tt | 3.2. 5.8. 10.2. 10.6. 11.8. 11.9. 15.1. 16.1. 24.4.
typ | 15.10. 15.11. 17.13. 17.15.
unit | 15.11. 17.13. 17.15.
used-languages | 1.6.
v | 21.17. 21.18. 21.19. 21.20. 22.1.
value | 26.7.
var-def | 20.2.
variant-char | 3.8. 11.8. 17.7. 26.8.
variant-char-assign | 26.5. 26.6. 26.7.
variant-char-assigns | 26.4. 26.9.
variant-char-ref | 26.4.
variant-char-value | 3.8. 26.2. 26.4.
variant-chars | 26.3. 26.13.
variant-def | 3.8. 11.8. 17.7. 26.5. 26.12.
variant-def-ref | 26.11.
variant-def-refs | 20.2. 26.10.
variant-defs | 26.9. 26.13.
variant-spec | 8.1. 10.4. 13.1. 24.2. 24.4. 26.8. 26.12.
verbatim | 1.3. 1.9. 3.3. 6.4. 7.2. 7.4. 10.4. 10.5. 11.2. 13.3. 16.3. 17.18. 18.1. 18.9. 18.12. 19.13. 20.8. 21.8. 22.8. 24.15. 24.16.
xdoc | 5.2. 7.3. 11.9. 13.6. 15.1. 15.7. 15.18. 17.7. 17.11. 24.4.
xfile | 7.3. 11.9. 15.1. 17.7. 24.4.
xref | 3.2. 5.8. 10.2. 10.6. 15.1. 16.1. 24.4.
zip | 24.5.


Tools

adjustment systems | 17.16.
ASAP | 17.7.
entity manager | 8.3.
rendition system | 8.3.
SGML Application | 8.3.
SGML tool | 8.3.
SGML tools | 6.3.


Untitled

This is the way how this document is prepared. It is visible in the sgml source.