Benutzerhandbuch MSRREP V2.1.0

MSR MEDOC

Benutzerhandbuch MSRREP V2.1.0
Authors Guide
Version: 11
Dieses Benutzerhandbuch beschreibt die Anwendung der MSRREP V2.1.0 DTD. Die Elementhilfe befindet sich in einem separaten Dokument .


I. Vorwort

Benutzerhandbuch MSRREP V2.1.0
I. Vorwort

Dieses Benutzerhandbuch richtet sich an einen PC-Anwender mit folgenden Kenntnissen:
  • Grundkenntnisse im Erstellen von XML/SGML-Dokumenten
  • Grundkenntnisse im Umgang mit einem XML/SGML-Editor
  • Grundkenntnisse im Umgang mit Textverarbeitungssystemen


II. Arbeiten mit dem Benutzerhandbuch

Benutzerhandbuch MSRREP V2.1.0
II. Arbeiten mit dem Benutzerhandbuch

Struktur des Benutzerhandbuchs
Das Benutzerhandbuch beschreibt die Anwendung der MSRREP V2.1.0 DTD. In einem separaten Dokument befindet sich die Element- und Attribut-Dokumentation.
Die Anwendung der MSRREP V2.1.0 DTD ist gegliedert in eine MSR-Report-spezifische Beschreibung und in die Beschreibung der allgemeinen MSR-Elemente, die Applikationsprofile (siehe Kapitel 3. Allgemeine MSR-Elemente (Applikationsprofil). Die MSR-Report-spezifische Beschreibung enthält folgende Kapitel:
  • Erstellen des Dokumentvorspanns (siehe Kapitel 2. Erstellen des Dokumentenvorspanns REPORT-HEAD)
  • Erstellen des Anhangs (siehe Kapitel 5. Erstellen eines Anhangs)
  • Änderungsmanagement (siehe Kapitel 4. Änderungsmanagement CHG-CHAPTER
Konventionen
<XML/SGML-Element> | Darstellung eines XML/SGML-Elementes. Die so dargestellten XML/SGML-Elemente werden bei der Online-Darstellung in MS HTML-Help in einem Auto-Lookup-Index aufgenommen. Klicken Sie auf das entsprechende XML/SGML-Element, um zu weiteren Erwähnungen des XML/SGML-Elements im Dokument zu navigieren.
[XML/SGML-Attribut] | Darstellung eines XML/SGML-Attributes.
Zitat | Darstellung eines Zitats
Konventionen | Darstellung eines Querverweises


III. Dokumentenverwaltung

Benutzerhandbuch MSRREP V2.1.0
III. Dokumentenverwaltung

Beteiligte Personen
Name | Firma |
Barabara Wiegel/TZKOM | MSR MEDOC |
Herbert Klein /XI-Works | MSR MEDOC | Telefon: 07117248398-10 Herbert.Klein@XI-Works.de
Roman Reimer /XI-Works | MSR MEDOC |
Versionsübersicht
Version | Datum | Herausgeber
 | 2002-08-15 | Herbert Klein /XI-Works
 | 2002-02-07 | Roman Reimer /XI-Works
9 | 22.03.2001 | Barabara Wiegel/TZKOM
Änderungen
Änderung | Bezug
Korrektur von Grafiken, Neuformatierung Grund: - | Inhalt
Erstellen von Indexen, Technischen Begriffen und Querverweisen. Konvertieren nach MSRREP V210 XML. Grund: Aufbereitung für Abschlußdokumentation | Inhalt
Enthaltene Änderungen
Datum | Kapitel | Änderung | Bezug
2002-08-15 | Gesamt | Korrektur von Grafiken, Neuformatierung Grund: - | Inhalt
2002-02-07 | Gesamt | Erstellen von Indexen, Technischen Begriffen und Querverweisen. Konvertieren nach MSRREP V210 XML. Grund: Aufbereitung für Abschlußdokumentation | Inhalt


1. Arbeiten mit MSR-Report

Benutzerhandbuch MSRREP V2.1.0
1. Arbeiten mit MSR-Report

Inhalt dieses Kapitels:
  • 1.1. Was ist MSR-Report?
  • 1.2. Generelle Werkzeugumgebung zum Arbeiten mit MSR-Report
  • 1.3. Neuerstellen eines MSR-Report-Dokumentes


1.1. Was ist MSR-Report?

MSR-Report ist eine Dokumentstruktur, die vom Arbeitskreis Manufacturer Supplier Relationship (MSR) im Rahmen des Projektes MEDOC entwickelt wurde. Mit MSR-Report werden Berichte oder Spezifikationen erstellt, für die keine spezielle Dokumentstruktur entworfen wurde. MSR-Report stellt ebenfalls Strukturen für die Dokumentation eines Änderungsmanagements zur Verfügung. Weitere Informationen zu MSR und MEDOC erhalten Sie unter [MSR-Hompage;http://www.msr-wg.de;].
MSR-Report ist gegliedert in folgende Strukturen:
  • Dokumentenvorspann (siehe Kapitel 2. Erstellen des Dokumentenvorspanns REPORT-HEAD)
  • Allgemeine Dokumentinhalte (siehe Kapitel 3. Allgemeine MSR-Elemente (Applikationsprofil))
  • Anhang (siehe Kapitel 5. Erstellen eines Anhangs)
  • Änderungsmanagement 4. Änderungsmanagement CHG-CHAPTER
Typische Dokumente sind:
  • Einfache Dokumente ohne Dokumentvorspann und Anhang, z.B. Projektnotizen
  • Berichte mit kurzem Dokumentvorspann, z.B. Projektberichte, Protokolle
  • Handbücher mit ausführlichem Dokumentvorspann und Anhang.


1.2. Generelle Werkzeugumgebung zum Arbeiten mit MSR-Report

Die Abbildung Werkzeugumgebung der MSR-Report stellt die generelle Werkzeugumgebung zum Arbeiten mit der MSR-Report dar.
Abbildung 1: Werkzeugumgebung der MSR-Report
Die Werkzeugumgebung für MSR-Report-Dokumente muss einen Editor und eine Druckaufbereitung/Formatierer enthalten. Layoutinformationen zum Erzeugen eines Drucklayouts werden getrennt in den Style Sheets behandelt. Jedes dieser Werkzeuge verwendet die DTD zur Strukturprüfung und Style Sheets für die Definition des Layouts. Zusätzlich kann in professionellen Umgebungen ein Ablagesystem, z.B. eine Dokumentendatenbank, zum Einsatz kommen. Zum Erstellen eines MSR-Report-Dokuments der Version 2.1.0 können beliebige XML/SGML Editoren eingesetzt werden.


1.3. Neuerstellen eines MSR-Report-Dokumentes

Ein MSR-Report-Dokument besteht im Wesentlichen aus Dokumentenvorspann (<REPORT-HEAD>), Dokumentinhalt (<REPORT-BODY>) und Anhang (<REPORT-REAR>).
Hinweis
Ein Dokument kann auch ohne Dokumentenvorspann und Anhang erstellt werden, so dass allgemeine Texte und Gliederungsstrukturen direkt erstellt werden können.
Aus redaktioneller Sicht sollte jedoch innerhalb des Elementes <REPORT-HEAD> zumindest das Element <REPORT-SUBJECT> erstellt werden, um den Dokumentennamen festzulegen (siehe Kapitel 2.1. Erstellen der Dokumententitel).
Führen Sie folgende Schritte durch, um ein neues MSR-Report-Dokument formal vollständig zu erstellen:
  1. Erstellen Sie das Element <MSRREP>. Innerhalb dieses Elementes befindet sich der komplette Inhalt.
  2. Erstellen Sie innerhalb von <MSRREP> das Element <SHORT-NAME>, um eine Kurzbezeichnung des Dokumentes zu erstellen. Die Kurzbezeichnung ist hier eine eindeutige Kennung über die auf das Dokument verwiesen verwiesen werden kann. Das kann z.B. ein Dateiname mit oder ohne Erweiterung sein. In Dokumenten Management Systemen kann dies auch eine Dokumentnummer sein.
  3. Erstellen Sie innerhalb von <MSRREP> das Element <CATEGORY>, um das Dokument einer Kategorie zuzuordnen, z.B. Bericht, Testbericht, Änderungsdokumentation, Spezifikation.
  4. Erstellen Sie innerhalb des Elementes <MSRREP> das Element <REPORT-HEAD>, um den Dokumentenvorspann zu erstellen (siehe Kapitel 2. Erstellen des Dokumentenvorspanns REPORT-HEAD).
  5. Erstellen Sie das Element <REPORT-BODY>, um allgemeine Dokumentinhalte zu erstellen (siehe Kapitel 3. Allgemeine MSR-Elemente (Applikationsprofil)). Innerhalb des Elementes <REPORT-BODY> haben Sie die Möglichkeit, eine Kapitel- oder Themenstruktur zu erstellen (siehe Kapitel 3.3.3. Arbeiten mit freien Kapitel- und Themenstrukturen).
  6. Erstellen Sie das Element <REPORT-REAR>, um einen Anhang an das Dokument zu erstellen (siehe Kapitel 5. Erstellen eines Anhangs). Das Erstellen eines Anhangs ist optional.

Es ist möglich, abhängig von der <CATEGORY> spezielle Weiterverarbeitungsprozesse zu steuern.


2. Erstellen des Dokumentenvorspanns <REPORT-HEAD>

Benutzerhandbuch MSRREP V2.1.0
2. Erstellen des Dokumentenvorspanns <REPORT-HEAD>

Inhalt dieses Kapitels:
  • 2.1. Erstellen der Dokumententitel
  • 2.2. Erstellen von Information zu den Projektbeteiligten
  • 2.3. Erstellen einer Dokumentzusammenfassung
  • 2.4. Erstellen Administrativer Daten


2.1. Erstellen der Dokumententitel

Verwenden Sie das Element <REPORT-SUBJECT>, um Dokumententitel zu erstellen, die auf der Titelseite und den Kopfzeilen eines Papierdokuments oder auf der Einstiegsseite einer Online-Hilfe erscheinen können. Innerhalb des Elementes <REPORT-SUBJECT> können folgende Elemente zur Darstellung der Dokumententitel erzeugt werden:
<OVERALL-TITLE>
Geben Sie an dieser Stelle den Titel der Gesamtdokumentation ein, deren Teil das aktuelle Dokument ist.
<MAIN-TITLE>
Geben Sie an dieser Stelle den Titel des aktuellen Dokumentes ein. Dieser Titel wird meist als Titel des Deckblatts oder der Online-Einstiegsseite verwendet.
<SUB-TITLE>
Geben Sie an dieser Stelle eine Kurzbezeichnung oder eine genauere Spezifikation des Haupttitels <MAIN-TITLE> ein.


2.2. Erstellen von Information zu den Projektbeteiligten

Für die Pflege eines MSRREP Dokumentes ist es wichtig, dass mindestens eine Firma (<COMPANY>) mit einem Mitarbeiter (<TEAM-MEMBER>) angelegt wird. Dies wird zum Aufbau einer Dokumentenhistorie benötigt.
Verwenden Sie das Element <COMPANY>, um Daten zur Firma des Projektbeteiligten zu erstellen.
Geben Sie im Element <LONG-NAME> innerhalb des Elementes <COMPANY> den vollständigen Firmennamen des Projektbeteiligten ein.
Geben Sie im Element <SHORT-NAME> innerhalb des Elementes <COMPANY> die Kurzbezeichnung des Firmennamens des Projektbeteiligten ein.
Verwenden Sie das Element <TEAM-MEMBERS> innerhalb des Elementes <COMPANY>, um Daten der Projektbeteiligten einzugeben. Eine detailliertere Beschreibung zum Erstellen der projektbeteiligten Personen finden Sie im Kapitel 3.1.2.2. Informationen zu den Projektbeteiligten.
Beispiel:
Abbildung 2: Projektbeteiligte Personen beim Erstellen des Benutzerhandbuchs zu MSR-Report


2.3. Erstellen einer Dokumentzusammenfassung

Verwenden Sie das Element <ABSTRACT>, um eine allgemeine Dokumentzusammenfassung im Dokumentenvorspann zu erstellen. Verwenden Sie innerhalb des Elementes <ABSTRACT> die Elemente, die im 3.3.4. Arbeiten mit Fließtext beschrieben sind, um die Inhalte der Dokumentzusammenfassung darzustellen.


2.4. Erstellen Administrativer Daten

Administrative Daten dienen der unternehmensspezifischen Identifikation eines Dokumentes oder eines Dokumentteils (Fragment). In Unternehmen werden häufig Dokumentteile (Fragmente) in weiteren Dokumenten verwendet. Um den Ursprung eines Dokumententeils nachvollziehen zu können, ist es möglich, administrative Daten auch für Dokumentteile zu erstellen. Administrative Daten beinhalten unternehmensspezifische Daten, Informationen zum Dokumentenstand und Informationen zu den Dokumentensprachen eines Dokumentes oder Fragments. Eine detailliertere Beschreibung der administrativen Daten finden Sie in Kapitel 3.2. Erstellen administrativer Daten


3. Allgemeine MSR-Elemente (Applikationsprofil)

Benutzerhandbuch MSRREP V2.1.0
3. Allgemeine MSR-Elemente (Applikationsprofil)

Inhalt dieses Kapitels:
  • 3.1. Erstellen von Projektdaten
  • 3.2. Erstellen administrativer Daten
  • 3.3. Erstellen allgemeiner Dokumentinhalte
  • 3.4. Einbinden semantischer Prüfvorschriften
  • 3.5. Umgebungsspezifische Erweiterung der DTD
  • 3.6. Protokollierung von Prozessierungsabläufen
  • 3.7. Formelsatz für einen TEX- basierten Formatierer


3.1. Erstellen von Projektdaten

Inhalt dieses Kapitels:
  • 3.1.1. Übergeordnetes Projekt
  • 3.1.2. Aktuell dokumentiertes Projekt


3.1.1. Übergeordnetes Projekt

Entwicklungsdokumente sind zumeist projektorientiert. Verwenden Sie das Element <OVERALL-PROJECT> innerhalb von <PROJECT-DATA>, um das übergeordnete Projekt kurz zu beschreiben. Erstellen Sie dazu folgende Elemente innerhalb von <OVERALL-PROJECT>:
<LABEL>
Geben Sie in diesem Element den Titel des übergeordneten Projektes ein, z.B. Baureihen- oder Baugruppenbezeichnung.
<DESC>
Geben Sie in diesem Element eine zusammenfassende Beschreibung des übergeordneten Projektes ein.


3.1.2. Aktuell dokumentiertes Projekt

Die Projektdaten des aktuell dokumentierten Projektes sind gegliedert in unternehmensspezifische Details. Verwenden Sie das Element <PROJECT> innerhalb von <PROJECT-DATA>, um das aktuell dokumentierte Projekt zusammenfassend zu beschreiben. Erstellen Sie dazu folgende Elemente innerhalb von <PROJECT>:
<LABEL>
Geben Sie in diesem Element den Titel des aktuell dokumentierten Projektes ein.
<DESC>
Geben Sie in diesem Element eine zusammenfassende Beschreibung des aktuell dokumentierten Projektes ein.
Das Erstellen unternehmensspezifischer Details ist in Kapitel 3.1.2.1. Erstellen von Informationen zu den Projektbeteiligten Unternehmen beschrieben.


3.1.2.1. Erstellen von Informationen zu den Projektbeteiligten Unternehmen

Die Projektdaten des aktuell dokumentierten Projektes, <PROJECT>, sind untergliedert in unternehmensspezifische Details. Verwenden Sie das Element <COMPANY> innerhalb von <COMPANIES>, um Unternehmensdaten und generelle Projektdaten zu beschreiben. Modifizieren Sie folgende Attribute von <COMPANY>:
[ID]
Geben Sie an dieser Stelle den Referenznamen des projektbeteiligten Unternehmens ein.
[ROLE]
Wählen Sie an dieser Stelle die Rolle des Unternehmens im beschriebenen Projekt aus.
Wählen Sie MANUFACTURER aus, wenn das projektbeiteiligte Unternehmen ein Hersteller/Partner ist.
Wählen Sie SUPPLIER aus, wenn das projektbeiteiligte Unternehmen ein Lieferant ist.
Erstellen Sie folgende Elemente innerhalb von <COMPANY>, um Unternehmensdaten und generelle Projektdaten zu erstellen:
<LONG-NAME>
Geben Sie in diesem Element den Namen eines projektbeteiligten Unternehmens ein.
<SHORT-NAME>
Geben Sie in diesem Element die Kurzbezeichnung eines projektbeteiligten Unternehmens ein.
<TEAM-MEMBERS>
Erstellen Sie dieses Element, um Daten zu den projektbeteiligten Personen der entsprechenden Unternehmen einzugeben. Eine detailliertere Beschreibung zum Erstellen der projektbeteiligten Personen finden Sie im Kapitel 3.1.2.2. Informationen zu den Projektbeteiligten.
Geben Sie im Attribut [ID] den Referenznamen des Projektbeteiligten ein.
<GENERAL-PROJECT-DATA>
Erstellen Sie dieses Element, um generelle Projektdaten zum aktuellen Projekt eines projektbeteiligten Unternehmens zu erstellen. Erstellen Sie dazu folgende Elemente:
  • <ADMIN-DATA> beschrieben in Kapitel 3.2. Erstellen administrativer Daten
  • <INTRODUCTION>, verwenden sie dieses Element, um ein Einleitungskapitel zu den generellen Projektdaten zu erstellen.
  • <SYSTEM-OVERVIEW> beschrieben in Kapitel 3.1.2.3. Systemübersicht
  • <REASON-ORDER> beschrieben in Kapitel 3.1.2.4. Auftragsbegründung
  • <OBJECTIVES> beschrieben in Kapitel 3.1.2.5. Ziele
  • <CONTRACT-ASPECTS> beschrieben in Kapitel 3.1.2.6. Vertragliche Aspekte
  • <SAMPLE-SPEC> beschrieben in Kapitel 3.1.2.7. Musterdefinitionen
  • <VARIANT-SPEC> beschrieben in Kapitel 3.1.2.8. Variantenspezifikation
  • <DEMARCATION-OTHER-PROJECTS> beschrieben in Kapitel 3.1.2.9. Abgrenzung gegenüber anderen Projekten
  • <PARALLEL-DESIGN> beschrieben in Kapitel 3.1.2.7. Musterdefinitionen
  • <INTEGRATION-CAPABILITY> beschrieben in Kapitel 3.1.2.11. Integrationsfähigkeit
  • <ACCEPTANCE-COND > beschrieben in Kapitel 3.1.2.12. Abnahmebedingungen
  • <PROJECT-SCHEDULE> beschrieben in Kapitel 3.1.2.13. Projektzeitplan
  • <PURCHASING-COND> beschrieben in Kapitel 3.1.2.14. Angebote
  • <PROTOCOLS> beschrieben in Kapitel 3.1.2.15. Protokolle
  • <DIR-HAND-OVER-DOC-DATA> beschrieben in Kapitel 3.1.2.16. Verzeichnis der übergebenen Unterlagen
  • <ADD-SPEC> beschrieben in Kapitel 3.1.2.17. Zusätzliche Spezifikationen
  • <NA>, <TBR> und <TBD> beschrieben in Kapitel 3.3.2. Arbeiten mit vordefinierten Gliederungsstrukturen


3.1.2.2. Informationen zu den Projektbeteiligten

Verwenden Sie das Element <TEAM-MEMBERS> innerhalb des Elementes <COMPANY>, um Daten der Projektbeteiligten einzugeben. Erstellen Sie dazu folgende Elemente innerhalb von <TEAM-MEMBERS>:
<LONG-NAME>
Geben Sie in diesem Element Vor- und Nachname des Projektbeteiligten ein, z.B. Herbert Klein.
<SHORT-NAME>
Geben Sie in diesem Element das Namenskürzel des Projektbeteiligten ein, z.B. MM.
<ROLES>
Verwenden Sie das Element <ROLES>, um die Zuständigkeiten des Projektbeteiligten einzugeben. Geben Sie im Element <ROLE> innerhalb von <ROLES> eine der Zuständigkeiten des Projektbeteiligen ein, z.B. Technische Redaktion.
<DEPARTMENT>
Geben Sie in diesem Element die Abteilung des Projektbeteiligten ein, z.B. IT/PD.
<ADDRESS>
Geben Sie in diesem Element die Straße der Firmenadresse des Projektbeteiligten ein, z.B. Olgastr.86.
<ZIP>
Geben Sie in diesem Element die Postleitzahl der Firmenadresse des Projektbeteiligten ein, z.B. D-70180.
<CITY>
Geben Sie in diesem Element den Ort der Firmenadresse des Projektbeteiligten ein, z.B. Stuttgart.
<PHONE>
Geben Sie in diesem Element die Telefonnummer des Projektbeteiligten ein, z.B. 0711/248398-0.
<FAX>
Geben Sie in diesem Element die Faxnummer des Projektbeteiligten ein, z.B. 0711/248398-29.
<EMAIL>
Geben Sie in diesem Element die Email-Adresse des Projektbeteiligten ein, z.B. herbert.klein@xi-works.de.
<HOMEPAGE>
Geben Sie in diesem Element die Web-Adresse der Firma des Projektbeteiligten ein, z.B. www.xi-works.de.


3.1.2.3. Systemübersicht

Verwenden Sie das Element <SYSTEM-OVERVIEW>, um Informationen für das gesamte System festzulegen, z.B. für ein spezielles Fahrzeugmodell. Verwenden Sie dazu innerhalb von <SYSTEM-OVERVIEW> die Elemente, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden.


3.1.2.4. Auftragsbegründung

Verwenden Sie das Element <REASON-ORDER>, um Informationen zum Grund des Auftrags zu erstellen, z.B. Ausstattung der neuen Fahrzeugklasse mit Tempomat als Sonderausstattung. Verwenden Sie dazu innerhalb von <REASON-ORDER> die Elemente, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden.


3.1.2.5. Ziele

Verwenden Sie das Element <OBJECTIVES>, um Informationen zu den Projektgegenständen zu beschreiben, z.B. "Entwicklung eines Motoren-Management-Systems für das Modell New-Beetle". Verwenden Sie dazu innerhalb von <OBJECTIVES> die Elemente, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden.


3.1.2.6. Vertragliche Aspekte

Verwenden Sie das Element <CONTRACT-ASPECTS>, um Informationen zu den Vertragsinhalten zu erstellen. Verwenden Sie dazu innerhalb von <CONTRACT-ASPECTS> neben den Elementen, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden, folgende Elemente:
<RIGHTS>
Erstellen Sie dieses Element, um lizenzrechtliche Aspekte zum Vertragsgegenstand eines Projekte zu erstellen.
<GUARANTEE>
Erstellen Sie dieses Element, um Gewährleistungsbedingungen zum Vertragsgegenstand eines Projektes zu erstellen.
<MAINTENANCE>
Erstellen Sie dieses Element, um Wartungsbedingungen zum Vertragsgegenstand eines Projektes zu erstellen.
<ADD-SPEC>
Erstellen Sie dieses Element, um zusätzliche Spezifikationsbedingungen zum Vertragsgegenstand eines Projektes zu erstellen.


3.1.2.7. Musterdefinitionen

Verwenden Sie das Element <SAMPLE-SPEC>, um Informationen zu Mustern, z.B. A-, B- und C-Muster zu erstellen. Jedes Muster stellt das Ergebnis verschiedener Entwicklungsphasen dar. Verwenden Sie dazu innerhalb von <SAMPLE-SPEC> neben den Elementen, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden, das Element <SAMPLES>.
Erstellen Sie für jedes Muster eines Entwicklungsprojektes das Element <SAMPLE> innerhalb von <SAMPLES>. Geben Sie im Attribut [ID] des Elementes <SAMPLE> den Referenznamen des entsprechenden Musters ein. Erstellen Sie innerhalb von <SAMPLE> folgende Elemente:
<LONG-NAME>
Erstellen Sie in diesem Element die Bezeichnung des jeweiligen Muster-Typen.
<SHORT-NAME>
Erstellen Sie in diesem Element eine Kurzbezeichnung des jeweiligen Muster-Typen.
<NCOI>
Verwenden Sie dieses Element, um mit Fließtextelementen, beschrieben in Kapitel 3.3. Erstellen allgemeiner Dokumentinhalte, eine detaillierte Beschreibung der Muster zu erstellen.


3.1.2.8. Variantenspezifikation

Besonders im Automobilbereich gibt es viele Varianten eines Typen. Verwenden Sie das Element <VARIANT-SPEC>, um Informationen zu den verschiedenen Varianten eines Typen zu erstellen. Verwenden Sie dazu innerhalb von <VARIANT-SPEC> neben den Elementen, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden, die Elemente <VARIANT-CHARS> und <VARIANT-DEFS>.
Daten zur Variantenspezifikation werden in einer Tabelle dargestellt. Vertikal sind Varianten (siehe Kapitel Definition von Variantenmerkmalen), horizontal Variantendefinitionen (siehe Kapitel Definition von Varianten dargestellt.
Definition von Variantenmerkmalen
Aufgrund verschiedener Variantenmerkmale, wie z.B. Motor, Auslieferungsland oder Produktlinie werden neue Varianten erstellt. Verwenden Sie das Element <VARIANT-CHAR> innerhalb von <VARIANT-CHARS>, um neue Variantenmerkmale zu erstellen. Variantenmerkmale können in folgende zwei Klassen unterteilt werden:
  • Variante mit neuer Sachnummer
    Wählen Sie dazu im Attribut [TYPE] des Elementes <VARIANT-CHAR> NEW-PART-NUMBER aus, wenn das Variantenmerkmal eine neue Sachnummer begründet. Geben Sie im Attribut [ID] einen Referenznamen auf die neue Variante ein.
  • Variante ohne neue Sachnummer
    Wählen Sie dazu im Attribut [TYPE] des Elementes <VARIANT-CHAR> NO-NEW-PART-NUMBER aus.
Erstellen Sie innerhalb von <VARIANT-CHAR> folgende Elemente, um eine neue Variante zu spezifizieren:
<LONG-NAME>
Erstellen Sie in diesem Element den Titel der neuen Variante.
<SHORT-NAME>
Erstellen Sie in diesem Element eine Kurzbezeichnung der neuen Variante.
<CODE>
Geben Sie in diesem Element den Code der neuen Variante ein.
Definition von Varianten
Verwenden Sie das Element <VARIANT-DEF> innerhalb von <VARIANT-DEFS>, um Varianten zu erstellen. Varianten sind die Definition verschiedener Variantenmerkmale, die zu einer Variante zusammengefasst werden, wie z.B. Getriebe, EPS, Tacho. Sie werden in der Tabelle horizontal dargestellt. Geben Sie im Attribut [ID] des Elementes <VARIANT-DEF> den Referenznamen der Variante ein.
Erstellen Sie innerhalb von <VARIANT-DEF> folgende Elemente, um eine Variantendefinition für eine neue Variante zu spezifizieren:
<LONG-NAME>
Erstellen Sie in diesem Element den Titel der neuen Variantendefinition.
<SHORT-NAME>
Erstellen Sie in diesem Element eine Kurzbezeichnung der neuen Variantendefinition.
<CODE>
Geben Sie in diesem Element den Code der neuen Variantendefinition ein.
<VARIANT-CHAR-ASSIGNS>
Erstellen Sie im Element <VARIANT-CHAR-ASSIGN> innerhalb von <VARIANT-CHAR-ASSIGN> die Daten der Variantenmerkmale Eine detaillierte Beschreibung dazu finden Sie in Kapitel Zuordnung der Variantenmerkmale zu den Varianten.
Zuordnung der Variantenmerkmale zu den Varianten
Verwenden Sie das Element <VARIANT-CHAR-ASSIGN> (siehe Kapitel Definition von Varianten), um Variantenmerkmale wie z.B. Automatik für die Variantendefinition Getriebe zu erstellen. Erstellen Sie innerhalb von <VARIANT-CHAR-ASSIGN> folgende Elemente:
<VARIANT-CHAR-REF>
Erstellen Sie dieses Element, um auf das Variantenmerkmal zu referenzieren, das der Variante zugeordnet werden soll. Geben Sie im Attribut [VARIANT-CHAR] den Referenznamen des Variantenmerkmals ein, auf das referenziert werden soll.
<VARIANT-CHAR-VALUE>
Verwenden Sie dieses Element, um den Wert und den Code des Variantenmerkmals zu erstellen.
Erstellen Sie das Element <VALUE>, um den Wert des Variantenmerkmals einzugeben, z.B. Automatik.
Erstellen Sie das Element <CODE>, um den Code für das Variantenmerkmal einzugeben.
Beispiel:
Abbildung 3: Beispiel einer Variantentabelle


3.1.2.9. Abgrenzung gegenüber anderen Projekten

Verwenden Sie das Element <DEMARCATION-OTHER-PROJECTS>, um Informationen zu Projekten zu beschreiben, die die Schnittstellen zu dem aktuellen Projekt bilden. Verwenden Sie dazu innerhalb von <DEMARCATION-OTHER-PROJECTS> die Elemente, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden.


3.1.2.10. Parallelentwicklungen

Verwenden Sie das Element <PARALLEL-DESIGN>, um Informationen zu parallelen Entwicklungsprojekten zu beschreiben. Verwenden Sie dazu innerhalb von <PARALLEL-DESIGN> die Elemente, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden.


3.1.2.11. Integrationsfähigkeit

Verwenden Sie das Element <INTEGRATION-CAPABILITY>, um Informationen zu Anforderungen und Kapazitäten in der Integration für andere Systeme zu beschreiben. Verwenden Sie dazu innerhalb von <INTEGRATION-CAPABILITY> die Elemente, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden.


3.1.2.12. Abnahmebedingungen

Verwenden Sie das Element <ACCEPTANCE-COND>, um generelle Bedingungen zur Abnahme der beschriebenen Komponenten zu definieren. Verwenden Sie dazu innerhalb von <ACCEPTANCE-COND> die Elemente, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden.


3.1.2.13. Projektzeitplan

Verwenden Sie das Element <PROJECT-SCHEDULE>, um einen Projektzeitplan mit z.B. Meilensteinen und Abgabeterminen zu erstellen. Verwenden Sie dazu innerhalb von <PROJECT-SCHEDULE> die Elemente, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden.


3.1.2.14. Angebote

Verwenden Sie das Element <PURCHASING-COND>, um Angebotsdaten, wie z.B. Verkaufte Teile pro Jahr, Lieferzeiten oder Lagerbestand, zu beschreiben. Verwenden Sie dazu innerhalb von <PURCHASING-COND> die Elemente, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden.


3.1.2.15. Protokolle

Verwenden Sie das Element <PROTOCOLS>, um Protokolle und Besprechungsnotizen für Besprechung zu erstellen. Verwenden Sie dazu innerhalb von <PROTOCOLS> die Elemente, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden.


3.1.2.16. Verzeichnis der übergebenen Unterlagen

Verwenden Sie das Element <DIR-HAND-OVER-DOC-DATA>, um bereits bestehende Dokumente oder Dateien zum Projekt aufzulisten. Verwenden Sie dazu innerhalb von <DIR-HAND-OVER-DOC-DATA> die Elemente, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden.


3.1.2.17. Zusätzliche Spezifikationen

Verwenden Sie das Element <ADD-SPEC>, um zusätzliche projektspezifische Spezifikationsdaten zu beschreiben. Verwenden Sie dazu innerhalb von <ADD-SPEC> die Elemente, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden.


3.1.2.18. Darstellen der Projektdaten

Folgende Elemente werden verwendet, um im Element <GENERAL-PROJECT-DATA> Projektdaten zu erstellen:
<NA>, <TBR>, <TBD>
Erstellen Sie diese Elemente, um eine vordefinierte Gliederungsstruktur zu bearbeiten (siehe Kapitel 3.3.2. Arbeiten mit vordefinierten Gliederungsstrukturen).
<INTRODUCTION>
Verwenden Sie dieses Element, um einen einleitenden Text zu einem Projektthema zu erstellen. Verwenden Sie dazu innerhalb von <INTRODUCTION> Fließtextelemente (siehe Kapitel 3.3.4. Arbeiten mit Fließtext).
<NCOI>
Verwenden Sie dieses Element, um einen beschreibenden Text zu einem Projektthema zu erstellen. Verwenden Sie dazu innerhalb von <NCOI> Fließtextelemente (siehe Kapitel 3.3. Erstellen allgemeiner Dokumentinhalte).


3.2. Erstellen administrativer Daten

Inhalt dieses Kapitels:
  • 3.2.1. Allgemeines zu administrativen Daten
  • 3.2.2. Dokumentensprache
  • 3.2.3. Unternehmensspezifische Dokumentinformationen
  • 3.2.4. Informationen zum Dokumentstand
  • 3.2.5. Formatierer-Optionen


3.2.1. Allgemeines zu administrativen Daten

Administrative Daten dienen der unternehmensspezifischen Identifikation eines Dokumentes oder eines Dokumentteils (Fragment). In Unternehmen werden häufig Dokumentteile in weiteren Dokumenten verwendet. Um den Ursprung eines Dokumententeils nachvollziehen zu können, ist es möglich, administrative Daten auch für Dokumentteile zu erstellen. Administrative Daten beinhalten unternehmensspezifische Daten, Informationen zum Dokumentenstand und Informationen zu den Dokumentensprachen.


3.2.2. Dokumentensprache

Verwenden Sie folgende Elemente, um die Dokumentensprache festzulegen:
<LANGUAGE>
Geben Sie in diesem Element die Dokumentensprache ein, in der das Dokument oder der Dokumentteil überwiegend verfaßt wurde. Dieses Element kann dazu eingesetzt werden, Präfixe, die im XML/SGML-System erzeugt werden, in der entsprechenden Sprache einzufügen, z.B. DE für Deutsch.
<USED-LANGUAGES>
Geben Sie in diesem Element neben der Dokumentensprache alle weiteren Sprachen ein, die im Dokument oder Dokumentteil verwendet werden, z.B. DE, EN für Deutsch und Englisch. Dieses Element ist speziell für die mehrsprachige Version der DTD wichtig.


3.2.3. Unternehmensspezifische Dokumentinformationen

Verwenden Sie das Element <COMPANY-DOC-INFOS>, um unternehmensspezifische Dokumentinformationen zu erstellen. Erstellen Sie für Dokumentinformationen jeder projektbeteiligten Firma innerhalb des Elementes <COMPANY-DOC-INFOS> jeweils das Element <COMPANY-DOC-INFO>. Verwenden Sie folgende Elemente innerhalb des Elementes <COMPANY-DOC-INFO>, um Dokumentinformationen zu den jeweiligen Unternehmen zu erstellen:
<COMPANY-REF>
Referenzieren Sie in diesem Element auf die entsprechende Firma, für die Sie unternehmensspezifische Dokumentinformationen erstellen wollen. Geben Sie dazu im Attribut [ID-REF] die Identifikationsnummer ein, die Sie im Element <COMPANY> erstellt haben (siehe Kapitel 3.1.2.2. Informationen zu den Projektbeteiligten).
<DOC-LABEL>
Geben Sie in diesem Element den Titel des Dokumentes oder Dokumententeiles ein, für das Sie administrative Daten erstellen möchten. Dieser Titel erscheint auf der Titelseite des Dokumentes. Er kann auch die Dokumentennummer eines PDM- oder DMS-Systems sein.
<PRIVATE-CODES>
Dieses Element sollte nicht vom Benutzer sondern von System editiert werden. Erstellen Sie die Informationen für ein Unternehmen jeweils im Element <PRIVATE-CODE> innerhalb des Elementes <PRIVATE-CODES>. Diese Daten sind für speziell angepaßte Systeme oder für Prozesse von Bedeutung, z.B. Freigabe, Zustand-Flags usw.
<ENTITY-NAME>
Verwenden Sie dieses Element, um einen unternehmensspezifischen Dateinamen des Dokumentes oder Dokumentteils zu erstellen.


3.2.4. Informationen zum Dokumentstand

Verwenden Sie das Element <DOC-REVISIONS>, um Informationen zum Dokumentstand zu erstellen. Erstellen Sie für jeden neuen Dokumentstand innerhalb des Elementes <DOC-REVISIONS> jeweils das Element <DOC-REVISION>. Folgende Informationen zum Dokumentenstand können erstellt werden:
<COMPANY-REVISION-INFOS>
Verwenden Sie das Element <COMPANY-REVISION-INFOS>, um ein eigenes Versionierungsschema der Projektbeteiligten zum Dokumentstand zu erstellen. Die aktuellste Version des Dokumentes sollte dabei immer zuerst angezeigt werden. Erstellen Sie für Dokumentinformationen jeder projektbeteiligten Firma innerhalb des Elementes <COMPANY-REVISION-INFOS> jeweils das Element <COMPANY-REVISION-INFO>. Verwenden Sie folgende Elemente innerhalb des Elementes <COMPANY-REVISION-INFO>, um Informationen zum Dokumentenstand innerhalb des jeweiligen Unternehmens zu erstellen:
<COMPANY-REF>
Referenzieren Sie in diesem Element auf die entsprechende Firma, für die Sie unternehmensspezifische Dokumentinformationen erstellen wollen. Geben Sie dazu im Attribut [ID-REF] die Identifikationsnummer ein, die Sie im Element <COMPANY> im Dokumentenvorspann erstellt haben (siehe Kapitel 3.1.2.2. Informationen zu den Projektbeteiligten).
<REVISION-LABEL>
Geben Sie in diesem Element die Versionsnummer des Dokumentes oder Dokumententeiles ein, für das Sie administrative Daten erstellen möchten, z.B. Version 2.1.
<STATE>
Geben Sie in diesem Element den Zustand ein, in dem sich das Dokument befindet, z.B. Draft.
<REMARK>
Geben Sie in diesem Element eine Bemerkung zum Dokumentenstand ein.
<TEAM-MEMBER-REF>
Verwenden Sie dieses Element, um die Namen der Bearbeiter des aktuellen Dokumentstandes einzugeben.
<DATE>
Verwenden Sie dieses Element, um das Erstelldatum eines neuen Dokumentenstandes einzugeben.
<MODIFICATIONS>
Verwenden Sie das Element <MODIFICATIONS>, um Änderungen im Dokument im Vergleich zum Vorgängerdokument zu dokumentieren. Erstellen Sie für jede Änderung innerhalb des Elementes <MODIFICATIONS> jeweils das Element <MODIFICATION>.
Wählen Sie DOC-RELATED beim Attribut [TYPE] des Elementes <MODIFICATION> aus, wenn dokumentspezifische Änderungen der Grund für eine neue Dokumentenversion sind.
Wählen Sie CONTENT-RELATED beim Attribut [TYPE] des Elementes <MODIFICATION> aus, wenn produktspezifische Änderungen der Grund für eine neue Dokumentenversion sind.
Verwenden Sie folgende Elemente innerhalb des Elementes <MODIFICATION>, um die Änderungen im entsprechenden Dokumentenstand zu erstellen:
<CHANGE>
Geben Sie in diesem Element die Änderungen der aktuellen Dokumentversion im Vergleich zur Vorgängerversion ein.
<REASON>
Geben Sie in diesem Element den Grund für die Änderungen der aktuellen Dokumentversion im Vergleich zur Vorgängerversion ein.
Beispiel
Abbildung 4: Beispiel zur Versionsübersicht


3.2.5. Formatierer-Optionen

Verwenden Sie das Element <FORMATTER-CTRLS>, um Default-Werte für die Formatiereroptionen anzugeben.
Beispiel:
Abbildung 5: Beispiel für <FORMATTER-CTRLS>
 <formatter-ctrls> <formatter-ctrl
             si="LOGO">Bosch-Logo.eps</formatter-ctrl> <formatter-ctrl
             si="NA">omit</formatter-ctrl> </formatter-ctrls>


3.3. Erstellen allgemeiner Dokumentinhalte

Inhalt dieses Kapitels:
  • 3.3.1. Allgemeines zu Dokumentinhalten
  • 3.3.2. Arbeiten mit vordefinierten Gliederungsstrukturen
  • 3.3.3. Arbeiten mit freien Kapitel- und Themenstrukturen
  • 3.3.4. Arbeiten mit Fließtext
  • 3.3.5. Arbeiten mit Grafiken
  • 3.3.6. Arbeiten mit Tabellen
  • 3.3.7. Arbeiten mit Querverweisen
  • 3.3.8. Erstellen von Verzeichnissen
  • 3.3.9. MSR-Abfrage


3.3.1. Allgemeines zu Dokumentinhalten

Zum Erstellen der Dokumenteninhalte werden allgemeine Datenstrukturen, die sogenannten Applikationsprofile verwendet. Alle MSRDTDs enthalten diese allgemeine Datenstrukturen. Sie sind die grundlegenden beschreibenden Elemente unabhängig vom Inhalt des Dokumentes.


3.3.2. Arbeiten mit vordefinierten Gliederungsstrukturen

Abbildung 6: Übersicht zur vordefinierten Gliederungsstruktur
Kapitel einer vordefinierten Gliederungsstruktur sind entweder nicht anwendungsrelevant oder anwendungsrelevant. Nicht anwendungsrelevante Kapitel werden vom Autor gekennzeichnet. Anwendungsrelevante Kapitel können entweder in einem anderen Format vorhanden sein, die noch erstellt werden müssen oder sie sind bereits vorhanden. Zum Kennzeichnen der Relevanz einer vordefinierten Gliederungsstruktur können folgende Elemente verwendet werden:
  • <NA>, Not Applicable, Nicht anwendungsrelevant
    Das Kapitel ist für das Projekt nicht relevant und muss daher nicht beschrieben werden.
  • <TBR>, To be Resoved, Anwendungsrelevant
    Das Kapitel ist anwendungsrelevant. Eine Spezifikation ist bereits in einem anderen Format vorhanden, muss aber noch in XML/SGML umgesetzt werden.
  • <TBD>, Te be Defined, Anwendungsrelevant
    Das Kapitel ist anwendungsrelevant. Einer der Projektbeteiligten muss bis zu einem vorgegebenen Zeitpunkt oder Musterstand eine beschriebene Aufgabe ausführen. Erstellen Sie die Elemente TEAM-MEMBER-REFS, SCHEDULE und DESC, um die Daten der Aufgabe zu erstellen.
<TEAM-MEMBER-REFS>
Verwenden Sie die Elemente <TEAM-MEMEBER-REF> innerhalb von <TEAM-MEMEBER-REFS>, um die Projektmitarbeiter zu benennen, denen eine Aufgabe übertragen wurde. Geben Sie im Attribut [TEAM-MEMBER] den Referenznamen eines Projektbeteiligten ein.
<SCHEDULE>
Verwenden Sie das Element <DATE> innerhalb von <SCHEDULE>, um den Zeitpunkt festzulegen, zu dem die Aufgabe eines Projektbeteiligten erledigt ist.
Verwenden Sie das Element <SAMPLE-REF> innerhalb von <SCHEDULE>, um den Musterstand festzulegen, bis zu dem die Aufgabe eine Projektbeteiligten erledigt ist. Geben Sie im Attribut [SAMPLE] den Referenznamen des Musterstandes ein.
Verwenden Sie im Element <SCHEDULE> entweder das Element <DATE> oder das Element <SAMPLE-REF>. Der festgelegte Fertigstellungszeitpunkt muss eingehalten werden.
<DESC>
Verwenden Sie dieses Element, um eine Beschreibung der zu erledigenden Aufgabe zu erstellen. Verwenden Sie dazu die Elemente, die im Kapitel 3.1.2.18. Darstellen der Projektdaten beschrieben werden.
TBD kann, abhängig vom Editor, als Entity-Referenz eingefügt werden, um noch zu bearbeitende Stellen im Fließtext zu markieren. An den entsprechenden Stellen wird der Text To be defined erzeugt.


3.3.3. Arbeiten mit freien Kapitel- und Themenstrukturen

Inhalt dieses Kapitels:
  • 3.3.3.1. Anlegen einer Kapitelstruktur
  • 3.3.3.2. Anlegen eines Themenabschitts


3.3.3.1. Anlegen einer Kapitelstruktur

Benutzerhandbuch MSRREP V2.1.0
3. Allgemeine MSR-Elemente (Applikationsprofil)
3.3. Erstellen allgemeiner Dokumentinhalte
3.3.3. Arbeiten mit freien Kapitel- und Themenstrukturen
3.3.3.1. Anlegen einer Kapitelstruktur

Mit den MSRDTDs haben Sie die Möglichkeit, Kapitel beliebiger Ordnung anzulegen. Aus redaktioneller Sicht wird jedoch empfohlen, Kapitel nur bis zur vierten Ordnung anzulegen. Führen Sie folgende Schritte aus, um eine Kapitelstruktur anzulegen:
  1. Fügen Sie das Element <CHAPTER> in Ihre Dokumentation ein.
  2. Erstellen Sie innerhalb von <CHAPTER> das Element <LONG-NAME>, um die Überschrift Ihres Kapitels einzugeben.
  3. Wenn Sie eine Kurzbezeichnung für Ihr Kapitel erstellen möchten, fügen Sie das Element <SHORT-NAME> ein. Geben Sie dort die Kurzbezeichnung Ihres Kapitels ein.
  4. Erstellen Sie bei <CHAPTER> die entsprechenden Fließtextelemente (siehe Kapitel 3.3.4. Arbeiten mit Fließtext), um den Inhalt zu beschreiben
  5. Wenn Sie ein Kapitel zweiter Ordnung erstellen möchten, fügen Sie das Element <CHAPTER> in das bereits bestehende Element <CHAPTER> ein. Führen Sie anschließend die zuvor beschriebenen Punkte durch, um den Fließtext innerhalb des Unterkapitels zu erstellen. Verfahren Sie ebenso, um Kapitel dritter und vierter Ordnung zu erstellen.
Modifizieren Sie folgende Attribute des Elementes <CHAPTER>, um auf ein Kapitel referenzieren zu können oder um einen Seitenumbruch vor dem Kapitel einfügen zu können:
[BREAK]
Wählen Sie an dieser Stellen den Attributwert BREAK aus, damit das Kapitel auf einer neuen Seite beginnt.
[ID]
Geben Sie an dieser Stellen einen Referenznamen zur Identifikation des Kapitels ein. Das erste Zeichen des Referenznamens muss ein Buchstabe sein.
Das Element <CHAPTER> enthält neben allen Elementen, die im Kapitel 3.3. Erstellen allgemeiner Dokumentinhalte enthalten sind, auch noch administrative Daten für das gesamte Kapitel (siehe Kapitel 3.2. Erstellen administrativer Daten und MSR-Abfrage-Daten (siehe Kapitel 3.3.9. MSR-Abfrage).


3.3.3.2. Anlegen eines Themenabschitts

Benutzerhandbuch MSRREP V2.1.0
3. Allgemeine MSR-Elemente (Applikationsprofil)
3.3. Erstellen allgemeiner Dokumentinhalte
3.3.3. Arbeiten mit freien Kapitel- und Themenstrukturen
3.3.3.2. Anlegen eines Themenabschitts

Ein Thema ist eine abgeschlossene Sinneinheit innerhalb eines Kapitels. Eine weitere Strukturierung der Sinneinheiten wie bei der Kapitelstruktur ist hier nicht möglich. Führen Sie folgende Schritte aus, um einen Themenabschnitt anzulegen:
  1. Fügen Sie das Element <TOPIC-1> in das entsprechende Kapitel ein.
  2. Erstellen Sie das Element <LONG-NAME>, um die Überschrift Ihres Themenabschnitts einzugeben.
  3. Wenn Sie eine Kurzbezeichnung für Ihren Themenabschnitt erstellen möchten, fügen Sie das Element <SHORT-NAME> ein. Geben Sie dort die Kurzbezeichnung Ihres Themenabschnitts ein.
  4. Erstellen Sie bei <TOPIC-1> die entsprechenden Fließtextelemente (siehe Kapitel3.3.4. Arbeiten mit Fließtext), um das Thema zu beschreiben
Das Element <TOPIC-1> enthält neben den Fließtextelementen (siehe Kapitel 3.3.4. Arbeiten mit Fließtext das Element <MSR-QUERY-P-1>.


3.3.4. Arbeiten mit Fließtext

Inhalt dieses Kapitels:
  • 3.3.4.1. Absatzelemente
  • 3.3.4.2. Textelemente


3.3.4.1. Absatzelemente

Benutzerhandbuch MSRREP V2.1.0
3. Allgemeine MSR-Elemente (Applikationsprofil)
3.3. Erstellen allgemeiner Dokumentinhalte
3.3.4. Arbeiten mit Fließtext
3.3.4.1. Absatzelemente

Absatz
Verwenden Sie das Element <P>, um einen Absatz eines Fließtextes zu erstellen. Für diesen Absatz wird meist eine proportionale Schriftart verwendet. Innerhalb dieses Absatzes können die in Kapitel 3.3.4.2. Textelemente beschriebenen Elemente verwendet werden.
Absatz mit frei definierbaren Umbrüchen
Verwenden Sie das Element <VERBATIM>, um einen Absatz mit frei definierbaren Umbrüchen innerhalb eines Fließtextes zu erstellen. Für diesen Absatz wird meist eine nichtproportionale Schriftart verwendet. Zeilenumbrüche, Leerzeichen und Tabulatoren sind frei definierbar.
Beispiel:
Dieses Element wird dazu verwendet, Programm-Code und ASCII-Zeichenketten zu erstellen.
Formeln
Verwenden Sie das Element <FORMULA>, um eine Formel in eine Dokumentation einzufügen. Innerhalb dieses Elementes, können Sie die Formel mit folgenden fünf verschiedenen Elementen darstellen:
<GRAPHIC>
Verwenden Sie dieses Element, um eine Formel als Grafik-Element einzubinden.
<VERBATIM>
Verwenden Sie dieses Element, um eine Formel bestehend aus ASCII-Zeichen einzufügen.
<TEX-MATH>
Verwenden Sie dieses Element, um ein TeX-Formel einzufügen. Eine TeX-Formel kann von einem TeX- oder LaTeX-Prozessor verarbeitet werden.
<C-CODE>
Verwenden Sie dieses Element, um eine Formel einzufügen, die als C-Code definiert ist.
<GENERIC-MATH>
Verwenden Sie dieses Element, um semantische, mathematische Beschreibungen einzufügen, die von einem Math-Prozessor verarbeitet werden.
Verwenden Sie das Element <FORMULA-CAPTION>, um innerhalb des Elementes <FORMULA> die Beschriftung einer Formel zu erstellen. Geben Sie im Attribut <ID> des Elementes <FORMULA-CAPTION> den Refernznamen für die entsprechende Formel ein.
Im Anhang (siehe Kapitel 3.7. Formelsatz für einen TEX- basierten Formatierer) finden Sie den Formelsatz für einen TeX-basierten Formatierer.
Beispiel:
Testformel
34b/17+18*3a
Aufzählungen
Verwenden Sie das Element <LIST>, um Inhalte als Aufzählung darzustellen. Geben Sie das Element <ITEM> innerhalb des Elementes <LIST> ein, um die Aufzählungspunkte zu erstellen. Mit dem Attribut [TYPE] des Elementes <LIST> haben Sie die Möglichkeit, numerierte und nicht numerierte Aufzählungen zu erstellen.
Nicht numerierte Aufzählung
Wählen Sie den Attributtyp UNNUMBERED aus, um eine nicht numerierte Aufzählung zu erstellen. Nicht numerierte Aufzählungen können in beliebiger Ordnung erstellt werden. Aus redaktioneller Sicht wird empfohlen, Aufzählungen nur bis zur dritten Ordnung zu verwenden.
Numerierte Aufzählung
Wählen Sie den Attributtyp NUMBERED aus, um eine numerierte Aufzählung zu erstellen. Numerierte Aufzählung werden dazu verwendet, definierte Reihenfolgen darzustellen. Sie können in beliebiger Ordnung erstellt werden. Aus redaktioneller Sicht wird empfohlen, numerierte Aufzählungen nur bis zur zweiten Ordnung zu verwenden.
Beispiel:
  • Dies ist eine nicht numerierte Aufzählung erster Ordnung
    • Dies ist eine nicht numerierte Aufzählung zweiter Ordnung
  1. Dies ist eine numerierte Aufzählung erster Ordnung
    1. Dies ist eine numerierte Aufzählung zweiter Ordnung
Definitionslisten
Verwenden Sie das Element <DEF-LIST>, um eine Definitionsliste anzulegen. Eine Definitionsliste ist eine Marginalie (siehe Kapitel Marginalien), deren Einträge referenzierbar sind. Die Definitionsliste kann dazu verwendet werden, ein Glossar oder ein allgemeines Definitionsverzeichnis zu erstellen. Eine Definitionsliste sollte ausschließlich für Begriffsdefinitionen verwendet werden.
Wenn Sie das Element <DEF-LIST> erstellen, werden innerhalb dieses Elementes folgende Elemente eingefügt:
<DEF-ITEM>
Innerhalb dieses Elementes können Sie im <LONG-NAME>-Element den Eintrag eines Aufzählungselementes der Definitionsliste eingeben.
<DEF>
Innerhalb dieses Elementes können Sie im <P>-Element die Beschreibung zum Titel eingeben. Zur Anwendung des Elementes <P> siehe Kapitel Absatz
Beispiel:
Titel
Dies ist eine Definitionsliste. Auf Titel können Sie referenzieren.
Marginalien
Verwenden Sie das Element <LABELED-LIST>, um kurze Themenabschnitte strukturiert mit Hilfe eines gestalterischen Mittels darzustellen. Diese Beschreibung wird in zwei Spalten dargestellt. Die erste Spalte enthält die Benennung des Themas, fett dargestellt. Die zweite Spalte enthält die Beschreibung des Themas, als Absatz dargestellt.
Wenn Sie das Element <LABELED-LIST> erstellen, können innerhalb dieses Elementes folgende Elemente eingefügt werden:
<INDENT-SAMPLE>
Mit dem Element <INDENT-SAMPLE> erstellen Sie einen Platzhalter für die Breite der ersten Spalte Ihrer Marginalien. Verwenden Sie zur Definition des Zeilenumbruchs einer Marginalienbenennung die Attribute [NO-NEWLINE], [NEWLINE] und [NEWLINE-IF-NECESSARY].
  • [NO-NEWLINE] bedeutet einen Zeilenumbruch innerhalb der ersten Spalte. Beispiel:
    XXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXX
  • [NEWLINE] bedeutet keinen Zeilenumbruch innerhalb der ersten Spalte. Die Beschreibung zur Benennung beginnt in der zweiten Zeile. Beispiel:
    XXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXX
  • [NEWLINE-IF-NECESSARY] bedeutet keinen Zeilenumbruch in der ersten Spalte. Ist die Marginalienbenennung länger als unter <INDENT-SAMPLE> festgelegt, so beginnt die Beschreibung in der zweiten Zeile, andernfalls in der Ersten. Beispiel:
    XXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXX
<LABELED-ITEM>
Verwenden Sie dieses Element, um eine Marginalie innerhalb der Liste zu erstellen. Das Element <LABELED-ITEM> wird automatisch beim Erstellen des Elementes <LABELED-LIST> erzeugt. Innerhalb dieses Elementes können das Element <ITEM-LABEL> und weitere Absatzelemente erzeugt werden.
<ITEM-LABEL>
Innerhalb dieses Elementes können Sie im <LONG-NAME>-Element die Benennung der Marginalie eingeben. Diese Benennung wird in der ersten Spalte der Marginalie dargestellt.
Absatzelemente
Nach dem Element <ITEM-LABEL> können Sie die Absatzelemente <DEF-LIST>, <FIGURE>, <FORMULA>, <LABELED-LIST>, <LIST>, <NOTE>, <P> und <VERBATIM> erzeugen, um eine Beschreibung zu erstellen.
Beispiel:
Zur Beschreibung der Marginalienbenennung Beispiel können Sie alle Absatzelemente verwenden. Die Spaltenbreite der ersten Spalte ist im Element <INDENT-SAMPLE> festgelegt.
Hinweise
Verwenden Sie das Element <NOTE>, um Sicherheits- oder Bedienhinweise besonders hervorzuheben. Das Element besteht aus einem Icon und einem beschreibenden Text. Das Icon wird durch die Attributbeschreibung festgelegt. Wahlweise kann auch eine Überschrift erstellt werden.
Wenn Sie das Element <NOTE> erstellen, können innerhalb dieses Elementes folgende Elemente eingefügt werden:
<LABEL>
Verwenden Sie dieses Element, um optional eine Überschrift des Hinweises zu erstellen.
<P>
Verwenden Sie dieses Element, um den Hinweis zu formulieren. Das Element wird automatisch innerhalb von <NOTE> erzeugt.
Wählen Sie in der Attributliste des Elementes <NOTE> den Hinweistyp aus. Folgende Attribute stehen Ihnen zur Verfügung:
[CAUTION]
Verwenden Sie dieses Attribut, um auf Gefahren für Geräte und Personen bei der Bedienung hinzuweisen. Der vorgegebene Text Warnung wird erzeugt.
[HINT]
Verwenden Sie dieses Attribut, um besondere Bedienmerkmale hervorzuheben. Der vorgegebene Text Hinweis wird erzeugt.
[TIP]
Verwenden Sie dieses Attribut, um auf arbeitserleichternde Maßnahmen hinzuweisen. Der vorgegebene Text Tip wird erzeugt.
[INSTRUCTION]
Verwenden Sie dieses Attribut, um auf notwendige Anweisungen hinzuweisen. Der vorgegebene Text Anweisung wird erzeugt.
[EXERCISE]
Verwenden Sie dieses Attribut, um auf Praxisbeispiele hinzuweisen. Der vorgegebene Text Übung wird erzeugt.
[OTHER]
Verwenden Sie dieses Attribut, um andere Hinweise zu erstellen. Es wird kein vorgegebener Text erzeugt.
Beispiel:
Achtung: Überschrift des Hinweises
Der Hinweistyp wird in der Attributbeschreibung festgelegt. Der Text Warnung ist somit vorgegeben.
Parametertabellen
Verwenden Sie das Element <PRMS>, um Parametertabellen für physikalische Größen zu erstellen.
Wenn Sie das Element <PRMS> erstellen, werden innerhalb dieses Elementes folgende Elemente eingefügt:
<LABEL>
Verwenden Sie dieses Element, um optional eine Überschrift für die darauffolgenden Parametertabellen zu erstellen.
<PRM>
Verwenden Sie dieses Element, um eine Parametertabelle zu erstellen. Folgende Elemente können innerhalb von <PRM> erstellt werden, um einen Parameter darzustellen:
<LONG-NAME>
Verwenden Sie dieses Element, um die vollständige Bezeichnung eines Parameters einzugeben.
<SHORT-NAME>
Verwenden Sie dieses Element, um die Kurzbezeichnung eines Parameters einzugeben.
<PRM-CHAR>
Verwenden Sie dieses Element, um nachfolgende Parameterwerte zu erstellen.
<DESC>
Verwenden Sie dieses Element, um eine zusätzliche Beschreibung zur Parametertabelle einzugeben.
<COND>
Verwenden Sie dieses Element, um Randbedingungen, für die die Parameterwerte gültig sind, einzugeben.
<MIN>
Verwenden Sie dieses Element, um die Minimalwerte eines Parameters einzugeben.
<MAX>
Verwenden Sie dieses Element, um die Maximalwerte eines Parameters einzugeben.
<ABS>
Verwenden Sie dieses Element, um die Absolutwerte eines Parameters einzugeben.
<TYP>
Verwenden Sie dieses Element, um die typischen Werte eines Parameters einzugeben.
<TOL>
Verwenden Sie dieses Element, um die Toleranzwerte eines Parameters einzugeben.
<UNIT>
Verwenden Sie dieses Element, um die Einheit eines Parameters einzugeben.
<TEXT>
Verwenden Sie dieses Element, um beschreibenden Text in ein Tabellenfeld einzugeben.
<REMARK>
Verwenden Sie dieses Element, um zusätzliche Beschreibungen zu einem Parameter einzugeben.
Beispiel:
Parametertabellen können dazu verwendet werden, Minimal- und Maximalwerte der Betriebsspannung darzustellen:
Ub
Betriebsspannung
Zusätzliche Beschreibung zum Parameter Betriebsspannung
Bezeichnung Kürzel Min Typ Max Abs Tol Einheit Hinweis
Betriebsspannung
  • Eine Randbedingung könnte die Betriebstemperatur sein.
 Ub Minimalwert Typischer Wert Maximalwert Art der Einheit, z.B. V 1.
Hinweise:
1.
Zusätzliche Beschreibung zur Parameterdarstellung.


3.3.4.2. Textelemente

Benutzerhandbuch MSRREP V2.1.0
3. Allgemeine MSR-Elemente (Applikationsprofil)
3.3. Erstellen allgemeiner Dokumentinhalte
3.3.4. Arbeiten mit Fließtext
3.3.4.2. Textelemente

Hervorheben eines Textes
Verwenden Sie das Element <E>, um innerhalb eines Absatzelementes Textteile hervorzuheben. Wählen Sie als Attributtyp [BOLD] , um die Hervorhebung fett darzustellen, wählen Sie [ITALIC], um die Hervorhebung kursiv darzustellen.
Beispiel:
Das Wort Verstärkung wird fett dargestellt.
Das Wort Verstärkung wird kursiv dargestellt.
Tiefstellen eines Textes
Verwenden sie das Element <SUB>, um Textteile innerhalb eines Absatzelementes in kleinerer Schriftart unterhalb der Grundlinie darzustellen.
Beispiel:
Die Zahl 10wird tiefer gestellt.
Hochstellen eines Textes
Verwenden sie das Element <SUP>, um Textteile innerhalb eines Absatzelementes in kleinerer Schriftart oberhalb der Grundlinie darzustellen.
Beispiel:
Die Zahl 10wird höher gestellt.
Technische Begriffe
Verwenden Sie das Element <TT>, um technische Begriffe innerhalb der Absatzelemente zu formatieren. Verwenden Sie folgende Attributtypen, um verschiedene technische Begriffstypen darzustellen:
[SGMLTAG]
Verwenden Sie diesen Attributtyp, um ein SGML-Element innerhalb eines Absatzelementes darzustellen (Darstellung: <SGML-ELEMENT>).
[SGML-ATTRIBUTE]
Verwenden Sie diesen Attributtyp, um ein SGML-Attribut innerhalb eines Absatzelementes darzustellen (Darstellung: [SGML-ATTRIBUT]).
[TOOL]
Verwenden Sie diesen Attributtyp, um Processing-Tools innerhalb eines Absatzelementes darzustellen (Darstellung: Processing-Tool). Es kann sich dabei sowohl um Software als auch um mechanische Hilfsmittel handeln. Es sollte jedoch immer der Zweck des Tools angezeigt werden und nicht ein spezieller Produktname.
[PRODUCT]
Verwenden Sie diesen Attributtyp, um einen Produktnamen innerhalb eines Absatzelementes darzustellen (Darstellung: MetaMorphosis).
[VARIABLE]
Verwenden Sie diesen Attributtyp, um eine nicht-formelle Variable innerhalb eines Absatzelementes darzustellen (Darstellung: VAR). Sie wird dazu eingesetzt, Variablen auf Ihre Übereinstimmung zu überprüfen und Variablenlisten für nicht-formelle Berichte zu erstellen. Sie können diese Variable ebenfalls in der ECU-Software verwenden, wenn kein <SW-DATA-DICTIONARY> für das Dokument vorhanden ist. Formell entspricht dieser Attributtyp dem Element <XREF>.
STATE
Verwenden Sie diesen Attributtyp, um einen Prozess-Status innerhalb eines Absatzelementes darzustellen (Darstellung: revised).
[PRM]
Verwenden Sie diesen Attributtyp, um einen Prozess-Status innerhalb eines Absatzelementes darzustellen (Darstellung: <KFZW>). Dieser Attributtyp wird in der ECU-Software zur Darstellung von Kalibrationsparametern verwendet, wenn kein <SW-DATA-DICTIONARY> für das Dokument vorhanden ist. Formell entspricht dieser Attributtyp dem Element <XREF>.
[MATERIAL]
Verwenden Sie diesen Attributtyp, um einen Materialtyp innerhalb eines Absatzelementes darzustellen (Darstellung: Plastik).
[CONTROL-ELEMENT]
Verwenden Sie diesen Attributtyp, um Kontrollelemente innerhalb eines Absatzelementes darzustellen (Darstellung: Schaltfläche X). Kontrollelemente können z.B. Schaltflächen, Menüpunkte, Kippschalter, Tasten usw. sein.
[CODE]
Verwenden Sie diesen Attributtyp, um Eingabebefehle eines Programmes innerhalb eines Absatzelementes darzustellen (Darstellung: mm crp.sgm).
[ORGANISATION]
Verwenden Sie diesen Attributtyp, um den Namen einer Organisation innerhalb eines Absatzelementes darzustellen (Darstellung: ISO).
[OTHER]
Verwenden Sie diesen Attributtyp, um zusätzliche technische Begriffe innerhalb eines Absatzelementes darzustellen (Darstellung: OtherTT). Dies ist eine Möglichkeit, benutzerspezifische Anpassungen zu erstellen. Sie müssen mit dem Attribut [USER-DEFINED-TYPE] gekennzeichnet sein und vom Formatierer bearbeitet werden können.
Beispiel:
<SGMLTAG> wird zur Darstellung eines SGML-Elementes verwendet.
Externe Standards
Verwenden Sie das Element <STD>, um auf externe Standards innerhalb eines Absatzelementes zu verweisen.
Wenn Sie das Element <STD> erstellen, werden innerhalb dieses Elementes folgende Elemente eingefügt:
<LONG-NAME>
Geben Sie innerhalb dieses Elementes die komplette Bezeichnung des Standards ein.
<SHORT-NAME>
Geben Sie innerhalb dieses Elementes die Kurzform oder die Kennziffer des Standards ein.
<SUBTITLE>
Geben Sie innerhalb dieses Elementes eine Teilüberschrift des Standards ein.
<DATE-1>
Geben Sie innerhalb dieses Elementes das Gültigkeitsdatum des Standards ein.
<STATE-1>
Geben Sie innerhalb dieses Elementes die Version und den Zustand des Standards ein.
<URL>
Geben Sie innerhalb dieses Elementes die Lokation ein, unter der der Standard zu finden ist.
<POSITION>
Geben Sie innerhalb dieses Elementes Verweise auf die relevanten Stellen des Standards ein.
Beispiel:
Darstellung des Standard [Qualitätsmanagementsysteme - Grundlagen und Begriffe;DIN EN ISO 9000 QM;2000-12;http:\\www.DIN.de;]
Querverweis zu einem externen Dokument
Verwenden Sie das Element <XDOC>, um auf ein externes Dokument zu verweisen. Dieses Dokument muss nicht elektronisch vorliegen. Innerhalb von <XDOC> können Sie folgende Elemente einfügen:
<LONG-NAME>
Geben Sie in diesem Element den Titel des externen Dokumentes ein.
<SHORT-NAME>
Geben Sie in diesem Element die Kurzbezeichnung des externen Dokumentes ein.
<NUMBER>
Geben Sie in diesem Element die Versionsnummer des externen Dokumentes ein.
<DATE-1>
Geben Sie in diesem Element das Erstelldatum des externen Dokumentes ein.
<PUBLISHER>
Geben Sie in diesem Element den Herausgeber des externen Dokumentes ein.
<URL>
Geben Sie in diesem Element die Lokation ein, unter der das Dokument zu finden ist.
<POSITION>
Geben Sie in diesem Element Abschnitte des externen Dokumentes ein, auf die verwiesen werden soll.
Beispiel:
Elementes and Attributes of MESRREP.DTD
Querverweis zu einer externen Datei
Verwenden Sie das Element <XFILE>, um auf eine externe Datei zu verweisen, die vom SGML-Processing-System nicht bearbeitet werden kann. Innerhalb von <XFILE> können Sie folgende Elemente einfügen:
<LONG-NAME>
Geben Sie in diesem Element die Bezeichnung der externen Datei ein.
<SHORT-NAME>
Geben Sie in diesem Element eine Kurzbezeichnung für die externe Datei ein.
<URL>
Geben Sie in diesem Element die Lokation ein, unter der die Datei zu finden ist.
<NOTATION>
Geben Sie in diesem Element die Notation/das Format der Datei ein.
<TOOL>
Geben Sie in diesem Element das Tool ein, mit dem die Datei erstellt wurde.
<TOOL-VERSION>
Geben Sie in diesem Element die Versionsnummer des Tools ein, mit dem die externe Datei erstellt wurde.
Beispiel:
[motronic.asc;MOTRONIC;http:\\www.motronic.de;concept-ascii-format;concept;2.7;]
Allgemeine Querverweise
Verwenden Sie die Elemente <XREF> und <XREF-TARGET>, um Querverweise innerhalb des Dokumentes zu erstellen. Eine detaillierte Beschreibung dazu finden Sie im Kapitel 3.3.7.2. Allgemeine Querverweise.
Text einer MSR-Abfrage
Erstellen Sie mit dem Element <MSR-QUERY-TEXT> in einen Text. Eine detaillierte Beschreibung dazu finden Sie im Kapitel 3.3.9. MSR-Abfrage.
Index
Verwenden Sie das Element <IE> innerhalb der Absatzelemente, um einen Index zu erstellen, der im Indexverzeichnis erscheinen soll. Geben Sie innerhalb des Elementes <IE> den Text ein, der im Indexverzeichnis erscheinen soll. Dieser Text erscheint nicht im Fließtext.
Beispiel:
Dies ist ein Beispiel-Index .
Fußnoten
Verwenden Sie das Element <FT>, um eine Fußnote zu erstellen. Das Element <FT> kann innerhalb eines der Absatzelemente verwendet werden. Fußnoten werden meist hochgestellt dargestellt. Der Inhalt der Fußnote befindet sich gewöhnlich am Ende einer Seite.
Beispiel:
In diesem Satz wird auf die Fußnote referenziert [image] .

Geben Sie an dieser Stelle den Text ein, der in der Fußnote stehen soll.


3.3.5. Arbeiten mit Grafiken

Inhalt dieses Kapitels:
  • 3.3.5.1. Erstellen von Grafiken
  • 3.3.5.2. Einbinden von Grafiken
  • 3.3.5.3. Ändern der Grafikdarstellung
  • 3.3.5.4. Erstellen der Bildbeschriftung


3.3.5.1. Erstellen von Grafiken

In einem XML/SGML-Dokument können nur ASCII-Grafiken erstellt werden. Beachten Sie folgende Punkte beim Erstellen von externen Grafiken:
  • Erstellen Sie Grafiken, die in ein XML/SGML-Dokument eingebunden werden sollen, mit einem Grafikprogramm wie z.B. Corel Draw, Designer oder Visio.
  • Konvertieren Sie Grafiken, die mit einem Grafikprogramm erstellt wurden in folgende Formate:
    • EPS mit TIFF-Header (für TeX-Formatierer)
    • GIF, BMP, TIF, JPEG
      Diese Formate werden vom Formatierer in EPS konvertiert.
  • Die Größe der erstellten Grafik sollte die Seitengröße, bei DIN A4, von 17 x 22 cm nicht überschreiten.


3.3.5.2. Einbinden von Grafiken

Hinweis
Beim Dokumentaustausch müssen alle Grafiken mit dem XML/SGML-Dokument zusammen ausgetauscht werden. Dazu wird empfohlen, die Grafiken in einem ZIP-Archiv zu komprimieren.
Verwenden Sie das Element <FIGURE>, um Grafiken in ein Dokument einzubinden. Sie haben dazu folgende drei Möglichkeiten:
  • Einbinden einer Grafik, die mit einem Grafikprogramm erstellt wurde
  • Einbinden einer ASCII-Grafik
  • Erstellen einer Grafikbeschreibung
Kann eine bereits vorgegebene Grafik in einem System nicht dargestellt werden, so verwendet der Formatierer statt dessen die ASCII-Grafik. Kann auch die ASCII-Grafik nicht dargestellt werden, wird die Beschreibung der Grafik innerhalb des Elementes <DESC> angezeigt.
Wählen Sie im Attribut [FLOAT] den Wert FLOAT aus, wenn die Grafik in den Textfluß eingefügt werden soll. Wählen Sie NO-FLOAT aus, wenn die Grafik den Fließtext überlagern soll.
Einbinden einer vorgegebenen Grafik
Hinweis
Die Grafikdatei sollte sich immer im selben Verzeichnis befinden wie die SGML-Datei, in die die Grafik eingefügt werden soll.
Erstellen Sie im Element <FIGURE> das Element <GRAPHIC>, um eine Grafik einzubinden, die mit einem Grafikprogramm erstellt wurde. Spezifizieren Sie folgende Attribute des Elementes <GRAPHIC>, um die Grafik einzubinden:
[FILENAME]
Geben Sie hier den Dateinamen ein, unter dem das Wiedergabesystem die Grafik aufrufen kann. Das Format ist bei diesem Attribut unbedeutend. Abhängig vom Wiedergabesystem könnte die Grafik in einer firmenspezifischen Umgebung eingebunden sein. Um die passende Grafikdarstellung zu erreichen, müßte nur die Extension geändert werden.
[CATEGORY]
Geben Sie hier die Kategorie der Grafik ein. Dies kann dazu verwendet werden, eine Liste von Grafiken bestimmter Kategorien zu erstellen. Ihnen stehen die Kategorien Barcode, Conceptual, Engineering, Flowchart, Graph, Logo, Schematic und Waveform zur Verfügung.
[NOTATION]
Geben Sie hier das Format der Grafikdatei an. Dies wird für unterstützte Zeichensysteme von SGML-Applikationen benötigt.
Beispiel:
Einbinden einer ASCII-Grafik
Erstellen Sie im Element <FIGURE> das Element <VERBATIM>, um eine ASCII-Grafik einzubinden oder direkt zu erstellen. Die ASCII-Grafik wird auch ersatzweise dann angezeigt, wenn das System eine externe Grafik, die ander entsprechenden Stelle vorgesehen wäre, nicht darstellen kann.
Beispiel:

 \ | / @ @ ------oOO---(_)---OOo------
Erstellen einer Grafikbeschreibung
Erstellen Sie im Element <FIGURE> das Element <DESC>, um eine Grafikbeschreibung zu erstellen. Dies empfiehlt sich als zusätzliche Beschreibung einer Grafik, da manche Systeme keine Grafiken anzeigen können.
Beispiel:

In der Grafik wird das Logo von MSR-MEDOC dargestellt.


3.3.5.3. Ändern der Grafikdarstellung

Hinweis
Wird nur Höhe oder Breite einer Grafik verändert, so führt dies zu einer verzerrten Darstellung der Grafik.
Um eine eingebundene Grafik, die mit einem Grafikprogramm erstellt wurde, zu ändern, müssen folgende Attributwerte des Elementes <GRAPHIC> geändert werden:
[FIT]
Modifizieren Sie das Attribut [FIT], um festzulegen, auf welche Art die Grafik eingefügt werden soll. Sie haben folgende Möglichkeiten:
Geben Sie den Attributwert 0 ein, um eine Grafik in ihrer Originalgröße einzufügen. Ist sie zu groß für den vorgesehenen Freiraum, so wird sie angepaßt.
Geben Sie den Attributwert 1 ein, um eine Grafik an den vorgesehenen Freiraum anzupassen. Dies ist nicht der Fall, wenn Höhe und Breite der Grafik durch die Attribute [HEIGHT] und [WIDTH] bereits festgelegt sind.
Geben Sie den Attributwert 2 ein, um eine Grafik im Uhrzeigersinn um 90° zu drehen, wenn Sie zu breit für den vorgesehenen Freiraum ist. Ist Sie anschließend zu hoch für den vorgesehenen Freiraum, wird sie angepaßt. Dies ist nicht der Fall, wenn Höhe und Breite der Grafik durch die Attribute [HEIGHT] und [WIDTH] bereits festgelegt sind.
Geben Sie den Attributwert 3 ein, um eine Grafik im Uhrzeigersinn um 90° zu drehen. Ist Sie anschließend zu groß für den vorgesehenen Freiraum, wird sie angepaßt. Dies ist nicht der Fall, wenn Höhe und Breite der Grafik durch die Attribute [HEIGHT] und [WIDTH] bereits festgelegt sind.
Geben Sie den Attributwert 4 ein, um eine Grafik im Uhrzeigersinn um 90° so zu drehen, dass es am günstigsten an den vorgesehenen Freiraum angepaßt werden kann. Ist Sie anschließend zu groß für den vorgesehenen Freiraum, wird sie angepaßt. Dies ist nicht der Fall, wenn Höhe und Breite der Grafik durch die Attribute [HEIGHT] und [WIDTH] bereits festgelegt sind.
[SCALE]
Modifizieren Sie das Attribut [SCALE], um die Gesamtgröße der Grafik proportional zu verändern. Geben Sie eine Zahl größer 1 ein, um die Grafik zu vergrößern. Geben Sie ein Zahl zwischen 0 und 1 ein, um die Grafik zu verkleinern.
[HEIGHT]
Modifizieren Sie das Attribut [HEIGHT], um die Höhe der Grafik zu verändern. Geben Sie für die Höhe der Grafik eine reale Größe mit Einheit ein, z.B. 12 cm. Wenn Sie die Höhe der Grafik mit dem Attribut [HEIGHT] festlegen, so verfallen die Höhenanpassungen der anderen Attribute.
[WIDTH]
Modifizieren Sie das Attribut [WIDTH], um die Breite der Grafik zu verändern. Geben Sie für die Breite der Grafik eine reale Größe mit Einheit ein, z.B. 6 cm. Wenn Sie die Breite der Grafik mit dem Attribut [WIDTH] festlegen, so verfallen die Höhenanpassungen der anderen Attribute.

Funktion wird von XMetaL nicht unterstützt.
Funktion wird von XMetaL nicht unterstützt.


3.3.5.4. Erstellen der Bildbeschriftung

Erstellen Sie im Element <FIGURE> das Element <FIGURE-CAPTION>, um eine Bildbeschriftung zu erstellen. Die Bildnumerierung mit Text, z.B. Abbildung 1, wird dabei automatisch erstellt. Geben Sie anschließend im Element <LONG-NAME> den Titel zum Inhalt der Grafik ein.
Beispiel:
Abbildung 7: Bildbeschriftung zur folgenden Grafik


3.3.6. Arbeiten mit Tabellen

Inhalt dieses Kapitels:
  • 3.3.6.1. Hinweis zum Arbeiten mit Tabellen
  • 3.3.6.2. Aufbau Strukturierter Tabellen
  • 3.3.6.3. Einfügen von Reihen und Spalten
  • 3.3.6.4. Einfügen und Ausrichten von Text und Grafiken in Tabellen
  • 3.3.6.5. Erstellen der Tabellenüberschrift
  • 3.3.6.6. Erstellen von Zeilen- und Spaltenverschmelzungen
  • 3.3.6.7. Arbeiten mit Begrenzungslinien


3.3.6.1. Hinweis zum Arbeiten mit Tabellen

Hinweis
In diesem Kapitel wird beschrieben, wie eine strukturierte Tabelle auf Editor-Basis erstellt werden kann. Die meisten Editoren besitzen jedoch ein Plug-in, um Tabellen mit Hilfe von Menüs und Schaltflächen zu erstellen. Eine detaillierte Spezifikation der Tabellenelemente und -attribute finden Sie unter OASIS Technical Memorandum TM 9502:1995


3.3.6.2. Aufbau Strukturierter Tabellen

Verwenden sie das Element <TABLE>, um eine Tabelle zu erstellen. Für dieses Element können folgende Attribute festgelegt werden:
[TABSTYLE]
Geben Sie an dieser Stelle die Identifikation eines externen Tabellen-Styles ein.
[TOCENTRY]
Geben Sie den Attributwert 0 ein, wenn die Tabellenüberschrift nicht im Tabellenverzeichnis erscheinen soll.
Geben Sie den Attributwert 1 ein, wenn die Tabellenüberschrift im Tabellenverzeichnis erscheinen soll.
[SHORTENTRY]
Geben Sie den Attributwert 0 ein, wenn Sie die Kurzbezeichnung <SHORT-NAME> nicht in das Tabellenverzeichnis übernehmen möchten.
Geben Sie den Attributwert 1 ein, wenn Sie die Kurzbezeichnung <SHORT-NAME> in das Tabellenverzeichnis übernehmen möchten.
[PGWIDE]
Geben Sie den Attributwert 0 ein, wenn die Tabellenbreite der Breite des Textflusses entsprechen soll.
Geben Sie den Attributwert 1 ein, wenn die Tabellenbreite der Seitenbreite entsprechen soll.
Dieses Attribut ist nicht wirksam, wenn das Attribut [ORIENT] auf LAND gesetzt ist.
[FLOAT]
Wählen Sie im diesem Attribut den Wert FLOAT aus, wenn die Tabelle in den Textfluß eingefügt werden soll. Wählen Sie NO-FLOAT aus, wenn die Tabelle den Fließtext überlagern soll.
Eine Tabelle kann aus mehreren Tabellengruppen bestehen. Verwenden Sie das Element <TGROUP>, um eine Tabellengruppe zu erstellen. Die Reihen- und Spalteninformationen werden jeweils für eine Tabellengruppe festgelegt. In Kapitel 3.3.6.3. Einfügen von Reihen und Spalten finden sie eine detaillierte Beschreibung zur Vorgehensweise beim Einfügen von Reihen und Spalten.
Eine strukturierte Tabelle kann eine Kopfzeile, Standardzeilen und eine Fußzeile enthalten, die jeweils aus Zellen bestehen. Sie können sowohl komplexe Anordnungen von Informationen sein, als auch nur aus einer einzigen Zelle bestehen.
Beispiel:
Beispieltabelle
Kopfzeile, Spalte1 | Kopfzeile, Spalte 3 | Kopfzeile, Spalte 2
Inhalt der Spalte 1 | Inhalt der Spalte 2 | Inhalt der Spalte 3 auch in der nächsten Zeile
Inhalt von Spalte 1 und 2


3.3.6.3. Einfügen von Reihen und Spalten

Definieren der Tabellengruppe
Verwenden Sie das Element <TGROUP>, um eine Tabellengruppe einzufügen und zu spezifizieren. Modifizieren Sie dazu folgende Attributwerte:
[COLS]
Geben Sie an dieser Stelle die Anzahl der Spalten der Tabellengruppe ein.
[TGROUPSTYLE]
Geben Sie an dieser Stelle die Identifikation eines externen Tabellengruppen-Styles ein.
Definieren der Spalten
Verwenden Sie das Element <COLSPEC> innerhalb einer Tabellengruppe, um eine Spalte einzufügen und zu spezifizieren. Modifizieren Sie dazu folgende Attributwerte:
[COLNUM]
Geben Sie an dieser Stelle die Plazierung der modifizierten Spalte innerhalb der Tabelle an, z.B. 1 für die erste Spalte.
[COLNAME]
Geben Sie an dieser Stelle einen Identifikationsnamen für die modifizierte Spalte ein, z.B. Spalte1 für die erste Spalte.
[COLWIDTH]
Geben Sie an dieser Stelle die Breite der modifizierten Spalte innerhalb der Tabelle an. Sie können Absolutwerte wie z.B. 4 cm eingeben, oder Relativwerte, die mit * markiert werden, z.B. 2* für doppelte Spaltenbreite im Vergleich zu den anderen Spalten.
Definieren der Kopfzeile
Verwenden Sie innerhalb des Elementes <THEAD> das Element <ROW>, um eine Kopfzeile zu erstellen.
Definieren der Reihen für Tabelleninhalte
Verwenden Sie innerhalb des Elementes <TBODY> das Element <ROW>, um eine Reihe zu erstellen. Die Anordnung der <ROW>-Elemente bei der Erstellung entspricht der Anordnung der Reihen in der Tabellendarstellung.
Definieren der Fußzeile
Verwenden Sie innerhalb des Elementes <TFOOT> das Element <ROW>, um eine Fußzeile zu erstellen.


3.3.6.4. Einfügen und Ausrichten von Text und Grafiken in Tabellen

Einfügen von Text in eine Tabelle
Erstellen Sie innerhalb des Elementes <ENTRY> das Absatzelement mit dem der Inhalt der Zelle dargestellt werden soll, z.B. <P>. Das Element <ENTRY> wird innerhalb des Elementes <ROW> automatisch erzeugt, wenn Sie das Element <TABLE> erstellen.
Einfügen einer Grafik in eine Tabelle
Erstellen Sie innerhalb des Elementes <ENTRY> das Element <FIGURE>. Das Element <ENTRY> wird innerhalb des Elementes <ROW> automatisch erzeugt, wenn Sie das Element <TABLE> erstellen. Fügen Sie die Grafik, wie in Kapitel 3.3.5.2. Einbinden von Grafiken beschrieben, ein.
Drehen der Tabelleninhalte
Modifizieren Sie das Attribut [ORIENT] im Element <TABLE>, um festzulegen, ob Tabelleninhalte horizontal oder vertikal dargestellt werden. Sie können zwischen folgenden Werten wählen:
PORT
Wählen Sie diesen Attributwert, um den Tabelleninhalt parallel zu den Absatzelementen darzustellen.
LAND
Wählen Sie diesen Attributwert, um den Tabelleninhalt 90° gedreht zu den Absatzelementen darzustellen.
Horizontales Ausrichten des Tabelleninhalts
Modifizieren Sie das Attribut [ALIGN], um den Tabelleninhalt horizontal auszurichten. Sie haben folgende Möglichkeiten:
LEFT
Der Tabelleninhalt wird linksbündig ausgerichtet.
RIGHT
Der Tabelleninhalt wird rechtsbündig ausgerichtet.
CENTER
Der Tabelleninhalt wird horizontal zentriert.
JUSTIFY
Der Tabelleninhalt wird als Blocksatz dargestellt. Der Abstand zum linken und rechten Rand der Zelle ist gleich.
CHAR
Die Ausrichtung des Tabelleninhalts wird über das Attribut [CHAR] festgelegt.
Das Attribut [ALIGN] kann in folgenden Elementen modifiziert werden:
  • <TGROUP>
  • <COLSPEC>
  • <SPANSPEC>
  • <ENTRY>
Höchste Priorität bei der Ausrichtung hat das Element <ENTRY>, anschießend in dieser Reihenfolge <SPANSPEC>, <COLSPEC> und <TGROUP>.
Vertikales Ausrichten des Tabelleninhaltes
Modifizieren Sie das Attribut [VALIGN], um den Tabelleninhalt vertikal auszurichten. Sie haben folgende Möglichkeiten:
TOP
Der Tabelleninhalt wird am oberen Zellenrand ausgerichtet.
BOTTOM
Der Tabelleninhalt wird am unteren Zellenrand ausgerichtet.
MIDDLE
Der Tabelleninhalt wird vertikal zentriert ausgerichtet.
Das Attribut [VALIGN] kann in folgenden Elementen modifiziert werden:
  • <THEAD>
  • <TBODY>
  • <TFOOT>
  • <ROW>
  • <ENTRY>
Höchste Priorität bei der Ausrichtung hat das Element <ENTRY> und anschießend <ROW>. Die Elemente <THEAD>; <TBODY> und <TFOOT> sind gleichberechtigt und haben niedrigste Priorität.

Werden Texte einer Zelle nicht korrekt umgebrochen, kann an dieser Stelle ein Leerzeichen eingefügt werden, um den Umbruch zu erzwingen.


3.3.6.5. Erstellen der Tabellenüberschrift

Erstellen Sie im Element <TABLE> das Element <TABLE-CAPTION>, um eine Tabellenüberschrift zu erstellen. Die Bildnumerierung mit Text, z.B. Tabelle 1, wird dabei automatisch erstellt. Geben Sie anschließend im Element <LONG-NAME> den Titel zum Inhalt der Tabelle ein.
Beispiel:
Inhaltsangabe der Tabelle
Inhalt der Tabelle


3.3.6.6. Erstellen von Zeilen- und Spaltenverschmelzungen

Spaltenverschmelzungen
Modifizieren Sie das Element <SPANSPEC> im Element <TGROUP>, um die Identifikationdaten für eine Spaltenverschmelzung festzulegen. Modifizieren Sie folgende Attribute:
[NAMEST]
Geben Sie an dieser Stelle die Identifikationsnummer der ersten Spalte der Spaltenverschmelzung ein. Die Identifikationsnummer wird im Attribut [COLNUM] des Elementes <COLSPEC> festgelegt.
[NAMEEND]
Geben Sie an dieser Stelle die Identifikationsnummer der letzten Spalte der Spaltenverschmelzung ein. Die Identifikationsnummer wird im Attribut [COLNUM] des Elementes <COLSPEC> festgelegt.
[SPANNAME]
Geben Sie an dieser Stelle einen Identifikationsnamen für die spezifizierte Spaltenverschmelzung ein.
Führen Sie folgenden Arbeitsschritte aus, um eine Spaltenverschmelzung zu erstellen:
  1. Modifizieren Sie das Element <SPANSPEC> im Element <TGROUP> wie oben beschrieben.
  2. Geben Sie im Attribut [NAMEST] des Elementes <ENTRY> die Identifikationsnummer der ersten Spalte der Spaltenverschmelzung ein, in der der Tabelleninhalt erscheinen soll.
  3. Geben Sie im Attribut [NAMEEND] des Elementes <ENTRY> die Identifikationsnummer der letzten Spalte der Spaltenverschmelzung ein, in der der Tabelleninhalt erscheinen soll.
  4. Geben Sie im Attribut [SPANNAME] des Elementes <ENTRY> den Identifikationsnamen der Spaltenverschmelzung ein, in der der Tabelleninhalt erscheinen soll.
  5. Erstellen Sie im Element <ENTRY> ein Absatzelement, um den Tabelleninhalt für die Spaltenverschmelzung einzugeben.
Zeilenverschmelzungen
Modifizieren Sie im Element <ENTRY> das Attribut [MOREROWS], um die entsprechende <ENTRY>-Zelle mit den Zellen der darauffolgenden Zeilen zu verschmelzen.
Geben Sie 0 ein, wenn Sie keine Zeilenverschmelzung wünschen.
Geben Sie 1 ein, wenn Sie die Zelle mit der Zelle der nächsten Zeile verschmelzen möchten.
Geben Sie eine Zahl n ein, wenn Sie die Zelle mit Zellen der n darauffolgenden Zeilen verschmelzen möchten.


3.3.6.7. Arbeiten mit Begrenzungslinien

Rahmen und Begrenzungslinien der gesamten Tabelle
Modifizieren Sie folgende Attribute im Element <TABLE>, um Rahmen und Begrenzungslinien der gesamten Tabelle zu erstellen. Die Definition für die Begrenzungslinien der Tabelle wird aufgehoben durch die Definition der Begrenzungslinien für Tabellengruppe, Spalte, Reihe und Zelle.
<FRAME>
Wählen Sie TOP aus, wenn die Begrenzungslinie am oberen Rand der Tabelle angezeigt werden soll.
Wählen Sie BOTTOM aus, wenn die Begrenzungslinie am untern Rand der Tabelle angezeigt werden soll.
Wählen Sie TOPBOT aus, wenn die Begrenzungslinie am oberen und am unteren Rand der Tabelle angezeigt werden soll.
Wählen Sie ALL aus, wenn die Begrenzungslinien am gesamten Rand der Tabelle angezeigt werden sollen.
Wählen Sie SIDES aus, wenn die Begrenzungslinien an den Seitenrändern der Tabelle angezeigt werden sollen.
Wählen Sie NONE aus, wenn keine Begrenzungslinie der Tabelle angezeigt werden soll.
[COLSEP]
Legen Sie an dieser Stelle fest, ob für die Spalten innerhalb der Tabelle Spaltenlinien angezeigt werden sollen.
Geben Sie 0 ein, wenn keine Spaltenlinien angezeigt werden sollen.
Geben Sie 1 ein, wenn Spaltenlinien angezeigt werden sollen.
[ROWSEP]
Legen Sie an dieser Stelle fest, ob für die Spalten innerhalb der Tabelle Reihenlinien angezeigt werden sollen.
Geben Sie 0 ein, wenn keine Reihenlinien angezeigt werden sollen
Geben Sie 1 ein, wenn Reihenlinien angezeigt werden sollen.
Begrenzungslinien innerhalb einer Tabellengruppe
Modifizieren Sie folgende Attribute im Element <TGROUP>, um Rahmen und Begrenzungslinien der Tabellengruppe zu erstellen. Die Definition für die Begrenzungslinien der Tabellengruppe wird aufgehoben durch die Definition der Begrenzungslinien für Spalte, Reihe und Zelle.
[COLSEP]
Legen Sie an dieser Stelle fest, ob für die Spalten innerhalb der Tabellengruppe Spaltenlinien angezeigt werden sollen.
Geben Sie 0 ein, wenn keine Spaltenlinien angezeigt werden sollen.
Geben Sie 1 ein, wenn Spaltenlinien angezeigt werden sollen.
[ROWSEP]
Legen Sie an dieser Stelle fest, ob für die Spalten innerhalb der Tabellengruppe Reihenlinien angezeigt werden sollen.
Geben Sie 0 ein, wenn keine Reihenlinien angezeigt werden sollen
Geben Sie 1 ein, wenn Reihenlinien angezeigt werden sollen.
Begrenzungslinien innerhalb einer Spalte
Modifizieren Sie folgende Attribute im Element <COLSPEC>, um Begrenzungslinien innerhalb einer Spalte zu erstellen:
[COLSEP]
Legen Sie an dieser Stelle fest, ob für die modifizierte Spalte innerhalb der Tabelle Spaltenlinien angezeigt werden sollen.
Geben Sie 0 ein, wenn keine Spaltenlinien angezeigt werden sollen.
Geben Sie 1 ein, wenn Spaltenlinien angezeigt werden sollen.
[ROWSEP]
Legen Sie an dieser Stelle fest, ob für die modifizierte Spalte innerhalb der Tabelle Reihenlinien angezeigt werden sollen.
Geben Sie 0 ein, wenn keine Reihenlinien angezeigt werden sollen
Geben Sie 1 ein, wenn Reihenlinien angezeigt werden sollen.
Begrenzungslinien innerhalb einer Reihe
Geben beim Attribut [ROWSEP] 0 ein, wenn keine Reihenlinien angezeigt werden sollen. Geben Sie 1 ein, wenn Reihenlinien angezeigt werden sollen.
Begrenzungslinien innerhalb einer Zelle
Modifizieren Sie folgende Attribute im Element <ENTRY>, um Rahmen und Begrenzungslinien einer Zelle zu erstellen. Durch die Definition für die Begrenzungslinien der Zelle werden alle anderen Definitionen für Begrenzungslinien aufgehoben.
[COLSEP]
Legen Sie an dieser Stelle fest, ob für die modifizierte Zelle innerhalb der Tabelle Spaltenlinien angezeigt werden sollen.
Geben Sie 0 ein, wenn keine Spaltenlinien angezeigt werden sollen.
Geben Sie 1 ein, wenn Spaltenlinien angezeigt werden sollen.
[ROWSEP]
Legen Sie an dieser Stelle fest, ob für die modifizierte Zelle innerhalb der Tabelle Reihenlinien angezeigt werden sollen.
Geben Sie 0 ein, wenn keine Reihenlinien angezeigt werden sollen
Geben Sie 1 ein, wenn Reihenlinien angezeigt werden sollen.


3.3.7. Arbeiten mit Querverweisen

Inhalt dieses Kapitels:
  • 3.3.7.1. Verweiskonzept
  • 3.3.7.2. Allgemeine Querverweise
  • 3.3.7.3. Spezielle Querverweise
  • 3.3.7.4. Dokumentübergreifende Querverweise


3.3.7.1. Verweiskonzept

Benutzerhandbuch MSRREP V2.1.0
3. Allgemeine MSR-Elemente (Applikationsprofil)
3.3. Erstellen allgemeiner Dokumentinhalte
3.3.7. Arbeiten mit Querverweisen
3.3.7.1. Verweiskonzept

Abbildung 8: Übersicht zu Speziellen und Dokumentübergreifenden Querverweisen
Das Verweiskonzept der MSR-Report besteht aus folgenden drei verschiedenen Verweistypen:
3.3.7.2. Allgemeine Querverweise | Allgemeine Querverweise sind Querverweise innerhalb eines Dokumentes, die eindeutig adressierbar sind. Sie können an beliebigen Stellen als Textelement erstellt werden. Der Verweisanker ist ein Element, dem das Attribut [ID] beigefügt ist, z.B. <CHAPTER>. Darauf wird mit dem Attribut [ID-REF] verwiesen.
3.3.7.3. Spezielle Querverweise | Spezielle Querverweise sind Querverweise innerhalb eines Dokumentes, die auf ein spezielles Element verweisen, z.B. <TEAM-MEMBER-REF> verweist auf <TEAM-MEMBER>.
3.3.7.4. Dokumentübergreifende Querverweise | Dokumentübergreifende Querverweise sind Querverweise auf ein entsprechendes Element eines externen Dokumentes. Der Locator zeigt auf eine Nameloc-Resource, die das externe Ziel repräsentiert. Locators werden im Anhang des MSR-Report-Dokuments aufgelistet. Locators werden auf Basis des Elementes <SHORT-NAME> gebildet.


3.3.7.2. Allgemeine Querverweise

Benutzerhandbuch MSRREP V2.1.0
3. Allgemeine MSR-Elemente (Applikationsprofil)
3.3. Erstellen allgemeiner Dokumentinhalte
3.3.7. Arbeiten mit Querverweisen
3.3.7.2. Allgemeine Querverweise

Verwenden Sie die Elemente <XREF> und <XREF-TARGET>, um Querverweise innerhalb des Dokumentes zu erstellen.
<XREF> wird innerhalb eines Absatzelementes an der Stelle plaziert, von der aus verwiesen wird. Geben Sie im Element <XREF> die Kurzbezeichnung (<SHORT-NAME>) des Verweisziels ein. Modifizieren Sie folgende Attribute von <XREF>, um eine Verknüpfung mit dem Verweisziel zu erstellen:
[ID-CLASS]
Wählen Sie hier die Identifikationsklasse des Elementes aus, auf das verwiesen werden soll, z.B. CHAPTER.
[ID-REF]
Geben Sie hier die Identifikationnummer des Elementes ein, auf das verwiesen werden soll. Die Identifikationsnummer des Elementes, auf das verwiesen werden soll, wird in dessen Attribut [ID] definiert.
Verwenden Sie folgenden Attribute von <XREF>, um einen Verweis darzustellen:
[SHOW-RESOURCE-TYPE]
Wählen Sie SHOW-TYPE, um den Absatztyp, z.B. Kapitel, des Verweisziels anzuzeigen.Wählen Sie NO-SHOW-TYPE, um den Absatztyp des Verweisziels nicht anzuzeigen.
[SHOW-RESOURCE-NUMBER]
Wählen Sie SHOW-NUMBER, um die Absatznummer des Verweisziels anzuzeigen. Wählen Sie NO-SHOW-NUMBER, um die Absatznummer des Verweisziels nicht anzuzeigen.
[SHOW-RESOURCE-LONG-NAME]
Wählen Sie SHOW-LONG-NAME, um die Absatzbeschriftung des Verweisziels anzuzeigen. Wählen Sie NO-SHOW-LONG-NAME, um die Absatzbeschriftung des Verweisziels nicht anzuzeigen.
[SHOW-RESOURCE-SHORT-NAME]
Wählen Sie SHOW-LONG-NAME, um die Kurzbezeichnung des Verweisziels anzuzeigen. Wählen Sie NO-SHOW-LONG-NAME, um die Kurzbezeichnung des Verweisziels nicht anzuzeigen.
[SHOW-RESOURCE-PAGE]
Wählen Sie SHOW-PAGE, um die Seitennummer des Verweisziels anzuzeigen. Wählen Sie NO-SHOW-PAGE, um die Seitennummer des Verweisziels nicht anzuzeigen.
Verwenden Sie das Element <XREF-TARGET>, wenn Sie auf ein Element oder eine Textstelle verweisen wollen, für die kein Attribut [ID] definiert werden kann. Geben Sie beim Attribut [ID] des Elementes <XREF-TARGET> die Identifikationsnummer ein, auf die verwiesen werden kann. Geben Sie im Element <LONG-NAME> eine Bezeichnung für den Verweisanker ein.


3.3.7.3. Spezielle Querverweise

Benutzerhandbuch MSRREP V2.1.0
3. Allgemeine MSR-Elemente (Applikationsprofil)
3.3. Erstellen allgemeiner Dokumentinhalte
3.3.7. Arbeiten mit Querverweisen
3.3.7.3. Spezielle Querverweise

Spezielle Querverweise sind Querverweise, die auf ein spezielles Element der MSR-Report verweisen. In der MSR-Report treten folgende spezielle Querverweise auf:
  • <CHG-OBJECT-REVISION-REF> verweist auf <CHG-OBJECT-REVISION>
  • <CHG-REQUEST-REF> verweist auf <CHG-RELATED-REQUESTS>
  • <TEAM-MEMBER-REF> verweist auf <TEAM-MEMBER>
  • <COMPANY-REF> verweist auf <COMPANY>
Das Attribut [ID-REF] des Verweis-Elements (s.o.) verweist auf das Attribut [ID] des entsprechenden Ziel-Elements.


3.3.7.4. Dokumentübergreifende Querverweise

Benutzerhandbuch MSRREP V2.1.0
3. Allgemeine MSR-Elemente (Applikationsprofil)
3.3. Erstellen allgemeiner Dokumentinhalte
3.3.7. Arbeiten mit Querverweisen
3.3.7.4. Dokumentübergreifende Querverweise

Wählen Sie im Element <MSRREP> das Element <LOCS> aus, um Referenzen in externe Dokumente zu erstellen. Mit der Auswahl von <LOCS> wird ein neues Kapitel erstellt mit dem Titel Verweise in externe Dokumente. Innerhalb dieses Kapitels können folgende Elemente erstellt werden:
<NAMELOC>
Dieses Element enthält nachfolgende Elemente, um das externe Dokument zu identifizieren, auf das verwiesen werden soll. Geben Sie dazu für das Attribut [ID] eine Identifikationsnummer ein. Erstellen Sie für jeden Verweis in ein externes Dokument das Element <NAMELOC> innerhalb von <LOCS>.
<LONG-NAME>
Geben Sie in diesem Element die Bezeichnung der externen Datei ein.
<SHORT-NAME>
Geben Sie in diesem Element eine Kurzbezeichnung für die externe Datei ein.
<NMLIST>
Geben Sie in diesem Element die Bezeichnung der Entity oder des Elementes ein, worauf im externen Dokument verwiesen werden soll.
Wählen Sie im Attribut [NAMETYPE] ENTITY aus, um auf eine Entity zu verweisen.
Wählen Sie im Attribut [NAMETYPE] ELEMENT aus, um auf ein Element zu verweisen.


3.3.8. Erstellen von Verzeichnissen

Verzeichnisse werden beim Prozessing benutzerspezifisch erstellt. Inhalte, die in Verzeichnissen erscheinen sollen, müssen jedoch im Editor erstellt werden. Folgende Verzeichnisse können aus der MSRREP.DTD erstellt werden:
Inhaltsverzeichnis
Im Inhaltsverzeichnis erscheinen Inhalte, die in den Elementen <CHAPTER> (siehe Kapitel 3.3.3.1. Anlegen einer Kapitelstruktur) und <TOPIC> (siehe Kapitel 3.3.3.2. Anlegen eines Themenabschitts) erstellt wurden.
Tabellenverzeichnis
Im Tabellenverzeichnis erscheinen Inhalte, die im Element <TABLE-CAPTION> (siehe Kapitel 3.3.6.5. Erstellen der Tabellenüberschrift) erstellt wurden.
Abbildungsverzeichnis
Im Abbildungsverzeichnis erscheinen Inhalte, die im Element <FIGURE-CAPTION> (siehe Kapitel 3.3.5.4. Erstellen der Bildbeschriftung) erstellt wurden.
Literaturverzeichnis
Das Literaturverzeichnis setzt sich aus folgenden Verzeichnissen zusammen:
  • Verzeichnisse von Standards
    Im Verzeichnis der Standards erscheinen Inhalte, die im Element <STD> (siehe Kapitel Externe Standards) erstellt wurden.
  • Verzeichnisse externer Dokumente
    Im Verzeichnis externer Dokumente erscheinen Inhalte, die im Element <XDOC> (siehe Kapitel Querverweis zu einem externen Dokument) erstellt wurden.
  • Verzeichnisse externer Dateien
    Im Verzeichnis externer Dokumente erscheinen Inhalte, die im Element <XFILE> (siehe Kapitel Querverweis zu einer externen Datei) erstellt wurden.
Verzeichnis technischer Begriffe
In den Verzeichnissen technischer Begriffe erscheinen Inhalte, die im Element <TT> (siehe Kapitel Technische Begriffe) erstellt wurden. Abhängig vom Attribut des Elementes <TT> können Verzeichnisse für folgende technische Begriffe erstellt werden:
  • SGML-Elemente
  • SGML-Attribute
  • Processing-Tools
  • Produktnamen
  • Variablen
  • Stati
  • Parameter
  • Materialtypen
  • Kontrollelemente
  • Programmcode
  • Organisationsnamen
  • Sonstige
Indexverzeichnis
Im Indexverzeichnis erscheinen Inhalte, die im Element <IE> (siehe Kapitel Index) erstellt wurden.


3.3.9. MSR-Abfrage

Inhalt dieses Kapitels:
  • 3.3.9.1. Allgemeines zur MSR-Abfrage
  • 3.3.9.2. Erstellen der MSR-Abfrage-Eigenschaften
  • 3.3.9.3. Anzeigen eines MSR-Abfrage-Ergebnisses


3.3.9.1. Allgemeines zur MSR-Abfrage

<MSR-QUERY> ist ein Mechanismus, der es erlaubt in separaten Prozeßschritten Daten oder Dateien aus anderen Systemen, z.B. Adressdatenbanken, abzufragen und in Form von allgemeinen Textbeschreibungselementen in MSR-Query-Result einzutragen.
Abbildung 9: Übersicht zur MSR-Abfrage
Mit Hilfe der MSR-Abfrage werden Textabschnitte, wie Kapitel, Themenabschnitte, Absätze oder Fließtext im MSR-Abfrage-Ergebnis dargestellt. Vorhandene MSR-Abfragequellen eines Unternehmens müssen in einem separaten Dokument beschrieben werden. Folgende MSR-Abfrage-Elemente unterscheiden sich nur im Umfang der Beschreibungsmöglichkeiten unter MSR-Query-Result:
<MSR-QUERY-CHAPTER>
Erstellen Sie mit diesem Element im Element <MSR-QUERY-RESULT-CHAPTER> ein Kapitel.
<MSR-QUERY-TOPIC-1>
Erstellen Sie mit diesem Element im Element <MSR-QUERY-RESULT-TOPIC-1> einen Themenabschnitt.
<MSR-QUERY-P-1>
Erstellen Sie mit diesem Element im Element <MSR-QUERY-RESULT-P-1> Absatzelemente.
<MSR-QUERY-TEXT>
Erstellen Sie mit diesem Element im Element <MSR-QUERY-RESULT-TEXT> einen Text.
Jedes der oben genannten MSR-Abfrage-Elemente beinhaltet das Element <MSR-QUERY-PROPS>, in dem die MSR-Abfrage-Eigenschaften eingegeben werden, und ein Element, um MSR-Abfrage-Ergebnisse darzustellen, z.B. <MSR-QUERY-RESULT-CHAPTER>.


3.3.9.2. Erstellen der MSR-Abfrage-Eigenschaften

Verwenden Sie das Element <MSR-QUERY-PROPS>, um die Eigenschaften der MSR-Abfrage zu erstellen. Die Inhalte des Elementes <MSR-QUERY-PROPS> werden nicht im Dokument dargestellt. Dargestellt werden nur die MSR-Abfrage-Ergebnisse. Verwenden Sie folgende Elemente, um MSR-Abfrage-Eigenschaften zu erstellen:
<MSR-QUERY-NAME>
Geben Sie an dieser Stelle den Prozedurnamen der MSR-Abfrage ein.
<MSR-QUERY-ARG>
Geben Sie an dieser Stelle das Argument der MSR-Abfrage ein, das an den Präprozessor übergeben werden soll zur Suche im externen Dokument. Sie können innerhalb des Argumentes mit dem Element <XREF> auf bereits bestehende Textstellen innerhalb des aktuellen Dokumentes verweisen.
<COMMENT>
Geben Sie an dieser Stelle einen zusätzlichen Kommentar zur MSR-Abfrage ein.


3.3.9.3. Anzeigen eines MSR-Abfrage-Ergebnisses

Verwenden Sie folgende Elemente, um MSR-Abfrage-Ergebnisse als Kapitel, Themenabschnitt, Absatz oder Fließtext darzustellen:
<MSR-QUERY-RESULT-CHAPTER>
Das MSR-Abfrage-Ergebnis wird als Kapitel dargestellt (siehe Kapitel 3.3.3.1. Anlegen einer Kapitelstruktur. Geben Sie im Element <LONG-NAME> den Titel des Kapitel ein, das eingefügt werden soll.
<MSR-QUERY-RESULT-TOPIC-1>
Das MSR-Abfrage-Ergebnis wird als Themenabschnitt dargestellt (siehe Kapitel 3.3.3.2. Anlegen eines Themenabschitts. Geben Sie im Element <LONG-NAME> den Titel des Themenabschnitts ein, der eingefügt werden soll.
<MSR-QUERY-RESULT-P-1>
Das MSR-Abfrage-Ergebnis werden alle Fließtextelemente dargestellt (siehe Kapitel 3.3.4. Arbeiten mit Fließtext
<MSR-QUERY-RESULT-TEXT>
Das MSR-Abfrage-Ergebnis wird als Absatz dargestellt (siehe Kapitel Absatz)
Beispiel:
Abbildung 10: MSR-Abfrage-Ergebnis einer Adressdatenbank


3.4. Einbinden semantischer Prüfvorschriften

Verwenden Sie das Element <MATCHING-DCI>, um semantische Prüfvorschriften für das aktuelle Dokument einzubinden. Diese Prüfvorschriften sind in einer Datei mit der Extension *.dci abgelegt. Erstellen Sie folgende Elemente im Element <MATCHING-DCI>, um Daten der DCI-Datei festzulegen:
<LABEL>
Geben Sie in diesem Element eine Bezeichnung zu den semantischen Prüfvorschriften ein, z.B. Parameter- und Variablenbeschreibungen.
<SHORT-LABEL>
Geben Sie in diesem Element eine Kurzbezeichnung zu den semantischen Prüfvorschriften ein, z.B. PaVaSt.
<URL>
Geben Sie in diesem Element die Lokation der DCI-Datei ein, z.B. FILE:\\pavast.dci.
<REMARK>
Geben Sie in diesem Element eine Beschreibung zu den semantischen Prüfvorschriften ein, z.B. DCI-Datei für die Überprüfung des kompletten PaVaSt Use-Cases. Verwenden Sie innerhalb von <REMARK> Absatzelemente (siehe Kapitel 3.3.4.1. Absatzelemente


3.5. Umgebungsspezifische Erweiterung der DTD

Verwenden Sie das Element <SPECIAL-DATA>, um in der DTD fehlende Datenstrukturen zu definieren.
Hinweis
<SPECIAL-DATA> sollte nur Ausnahmefällen verwendet werden. In der Regel sollte für kontinuerliche Erweiterungsstrukturen von MSR eine Änderungsanforderung der DTD formuliert werden.
Die Daten der umgebungsspezifischen DTD-Erweiterung werden im Kapitel SPECIAL_DATA im Anhang erstellt und für Abfragezwecke verwendet. Aus diesem Kapitel kann in ein dokumentinternes Kapitel verwiesen werden oder allgemeine Dokumentinhalte erstellt werden. Erstellen Sie folgende Elemente innerhalb von <SPECIAL-DATA>, um die DTD zu erweitern:
<SDG>
Erstellen Sie eine Special Data Group (SDG), um eine Gruppe der umgebungsspezifischen DTD-Erweiterung zu generieren. Geben Sie im Attribut [GID] den Namen der Element-Gruppe ein, um die die DTD erweitert werden soll. Innerhalb des Elementes <SDG> können folgende Elemente erstellt werden:
SDG-CAPTION
SDG
SD
NCOI
XREF
<SDG-CAPTION>
Erstellen Sie dieses Element, um einen Titel für eine Special Data Group (SDG) zu erstellen. Geben Sie im Attribut [ID] den Identifikationsnamen der SDG ein. Innerhalb des Elementes <SDG-CAPTION> können folgende Elemente erstellt werden:
LONG-NAME
SHORT-NAME
<LONG-NAME>
Dieses Elemente kann innerhalb von <SDG-CAPTION> erstellt werden. Geben Sie eine Bezeichnung der umgebungsspezifischen DTD-Erweiterung ein.
<SHORT-NAME>
Dieses Element kann innerhalb von <SDG-CAPTION> erstellt werden. Geben Sie eine Kurzbezeichnung der umgebungsspezifischen DTD-Erweiterung ein.
<SD>
Erstellen Sie dieses Element, um ein neues Element einer umgebungsspezifischen DTD-Erweiterung zu definieren. Geben Sie dazu im Attribut [GID] den Identifikationsnamen des neuen Elementes ein, um das die DTD erweitert werden soll.
<NCOI>
Erstellen Sie dieses Element, um innerhalb der einer Special Data Group (SDG) allgemeine Dokumentinhalte zu erstellen (siehe Kapitel 3.3. Erstellen allgemeiner Dokumentinhalte).
<XREF>
Verwenden Sie dieses Element, um dokumentinterne Querverweise innerhalb einer Special Data Group (SDG) zu erstellen (siehe Kapitel 3.3.7.2. Allgemeine Querverweise).
Beispiel:
Abbildung 11: Beispiel einer umgebungsspezifischen DTD-Erweiterung
Wird diese Struktur mit dem Element <SPECIAL-DATA> dargestellt, so ergibt sich daraus folgender Code:
<SPECIAL-DATA> <SDG GID="LIQUID-TEMP"> <SD GID="LONG-NAME">Inhalt zu LONG-NAME</SD> <SD GID="SHORT-NAME">Inhalt zu SHORT-NAME</SD> <SD GID="DESC">Inhalt zu DESC</SD> <SDG GID="PRM-CHAR"> <SD GID="PRM-CHAR-DESC1">Inhalt zur SDG PRM-CHAR</SD> <SD GID="PRM-CHAR-DESC2">Inhalt zur SDG PRM-CHAR</SD> </SDG> </SDG> </SPECIAL-DATA>


3.6. Protokollierung von Prozessierungsabläufen

Werkzeuge wie Konverter, Updatewerkzeuge (MSR-Query), Dokumentverschmelzer (Merger), Semantikprüfer (DCI-Checker) können in das Element <MSR-PROCESSING-LOG> den Verlauf und das Ergebnis ihres Prozesses textuell mitprotokolieren. Inhalte in diesem Dokumentteil werden von einem Formatierer nicht ausgegben.


3.7. Formelsatz für einen TEX- basierten Formatierer

TEX-MATH-Formeln müssen in XML/SGML-Dokumenten in die Tags <FORMULA><TEX-MATH> eingebettet werden. In den folgenden Tabellen wird eine Auswahl der möglichen Formeln aufgeführt.
tex-math - Formeln
Funktion
Syntax
Beispiel
Darstellung
Gruppierung
{expr}
Kommando
\Name
Leerzeichen
\,

y \, ax
Klammerung
expr1 (expr2)

3+x\,(4+2x)
Exponent
expr1^expr2

x^{2y}
Index
expr1_expr2

x_1 \,\,bzw.\,\, U_{Motor}
Bruch
expr1 / expr2

n/2
großer Bruch
\frac{expr1} {expr2}

\frac {ax+b} {cx+d}
Wurzel
\sqrt {expr}

\sqrt {2}
nte-Wurzel
\sqrt [n] {expr}

\sqrt [i+3] {x^2}
mathematische Funktion
\name expr

\sin(\frac {\pi x} {2})
Summe
\sum

\sum_{i=0}^{n-1} q^i = \frac {q^n-1} {q-1}
Integral
\int

\int_a^b x dx= \frac {1} {2} (b^2)
Mehrzeilig
\matrix
\cr

\matrix{ a^2 + b^2 & = & c^2\cr\cr c^2 & = & a^2 + b^2\cr _{Dirk Speidel hat getestet}}
Beispielhafte Befüllung von TEX-Math
<TEX-MATH>Honig + Brot = Honigbrot</TEX-MATH>
Mathematische Sonderzeichen
Mathematische Sonderzeichen | Syntax | Sonderzeichen | Syntax
 | \pm |  | \#
 | \times |  | \$
 | \div |  | \%
 | > |  | \&
 | < |  | \_
 | \leq |  | \{
 | \geq |  | \}
 | \approx |  |
 | \neq |  |
 | \propto |  |
 | \star |  |
Grichische Sonderzeichen | Syntax
 | \alpha
 | \beta
 | \gamma
 | \delta
 | \epsilon
 | \zeta
 | \eta
 | \theta
 | \iota
 | \kappa
 | \lambda
 | \mu
 | \nu
 | \xi
 | \pi
 | \rho
 | \sigma
 | \tau
 | \phi
 | \chi
 | \psi
 | \omega
 | \Gamma
 | \Delta
 | \Theta
 | \Lambda
 | \Xi
 | \Pi
 | \Sigma
 | \Phi
 | \Psi
 | \Omega


4. Änderungsmanagement <CHG-CHAPTER>

Benutzerhandbuch MSRREP V2.1.0
4. Änderungsmanagement <CHG-CHAPTER>

Inhalt dieses Kapitels:
  • 4.1. Allgemeines zum Änderungsmanagement
  • 4.2. Änderungsgegenstände
  • 4.3. Änderungsanforderungen


4.1. Allgemeines zum Änderungsmanagement

Abbildung 12: Übersicht zum Änderungsmanagement
Verwenden Sie das Element <CHG-CHAPTER> innerhalb des Elementes <REPORT-BODY>, um ein Kapitel im Hauptteil zu erstellen, das das Änderungsmanagement enthält. Es dient als Überblick über bereits vorhandene Versionen und als Ausblick auf zukünftige Versionen, die zum Teil bereits beauftragt sind. Ein Änderungsmanagement wird für Änderungsgegenstände wie Dokumente, Software und Geräte angewandt.
Das Element <CHG-CHAPTER> enthält folgende Elemente, um die Dokumentation des Änderungsmanagements zu erstellen:
<LONG-NAME>
Verwenden Sie dieses Element, um den Titel des Kapitels einzugeben, das Änderungsanforderungen enthält.
<SHORT-NAME>
Verwenden Sie dieses Element, um eine Kurzbezeichnung des Kapitels einzugeben, das Änderungsanforderungen enthält.
<ADMIN-DATA>
Verwenden Sie dieses Element, um administrative Daten für das Kapitel einzugeben, das Änderungsanforderungen enthält (siehe Kapitel 3.2. Erstellen administrativer Daten).
<CHANGES>
Verwenden Sie dieses Element, um Änderungsobjekte und Änderungsanforderungen zu dokumentieren (siehe Kapitel 4.2. Änderungsgegenstände und 4.3. Änderungsanforderungen).


4.2. Änderungsgegenstände

Änderungsgegenstände werden als separate Kapitel dargestellt, die jeweils eine Tabelle aller bisherigen Änderungen enthält. Änderungsgegenstände können DTDs, Dokumente, Hardware, Software usw. sein.
Verwenden Sie das Element <CHG-OBJECTS> innerhalb des Elementes <CHANGES>, um das Kapitel Änderungsgegenstände zu erstellen.
Erstellen eines Änderungsgegenstands
Verwenden Sie das Element <CHG-OBJECT>, um einen speziellen Änderungsgegenstand zu beschreiben. Geben Sie im Attribut [ID] des Elementes <CHG-OBJECT> einen Referenznamen für den Änderungsgegenstand ein. Erstellen Sie dazu innerhalb des Elementes <CHG-OBJECT> folgende Elemente:
<LONG-NAME>
Geben Sie in diesem Element die Bezeichnung des Änderungsgegenstandes ein, z.B. MSR-Software-DTD.
<SHORT-NAME>
Geben Sie in diesem Element die Kurzbezeichnung des Änderungsgegenstandes ein, z.B. MSRSW.
<DESC>
Geben Sie in diesem Element eine kurze Beschreibung des Änderungsgegenstandes ein.
<CHG-OBJECT-REVISIONS>
Erstellen Sie innerhalb dieses Elementes das Element <CHG-OBJECT-REVISION>, um eine Überarbeitung des Änderungsgegenstandes zu dokumentieren (siehe Abschnitt Erstellen der Version eines Änderungsgegenstands
Erstellen der Version eines Änderungsgegenstands
Erstellen Sie das Element <CHG-OBJECT-REVISION> innerhalb des Elementes <CHG-OBJECT-REVISIONS>, um eine Version zu erstellen. Eine Version wird definiert durch Versionsnummer, Bezeichnung und Erstelldatum der Änderungen eines Änderungsgegenstandes. Geben Sie im Attribut [ID] des Elementes <CHG-OBJECT-REVISION> einen Referenznamen für die Änderung ein. Verwenden Sie folgende Elemente innerhalb von <CHG-OBJECT-REVISION>, um eine Änderung zu erstellen:
<LONG-NAME>
Geben Sie in diesem Element die Bezeichnung der Änderung eines Änderungsgegenstandes ein, z.B. Prerelease 1.1.
<SHORT-NAME>
Geben Sie in diesem Element die Versionsnummer der Änderung des Änderungsgegenstandes ein, z.B. msrsw-v2.2.0-prell.
<DESC>
Geben Sie in diesem Element eine kurze Beschreibung der Änderung des Änderungsgegenstandes ein.
<DATE>
Geben Sie in diesem Element das Fertigstellungsdatum einer Änderung ein.
Beispiel
Abbildung 13: Änderungen der DTD MSRSW


4.3. Änderungsanforderungen

Inhalt dieses Kapitels:
  • 4.3.1. Allgemeine Daten zu Änderungsanforderungen
  • 4.3.2. Auszuführende Aktionen bei einer Änderungsanforderung
  • 4.3.3. Lösungsalternativen zu Änderungsanforderungen
  • 4.3.4. Realisierung einer Änderungsanforderung


4.3.1. Allgemeine Daten zu Änderungsanforderungen

Änderungsanforderungen werden als separate Kapitel auf oberster Ebene dargestellt, die jeweils eine Tabelle aller Änderungsanforderungen enthalten. Änderungsanforderungen betreffen Änderungsgegenstände wie z.B. DTDs, Dokumente, Hardware, Software.
Verwenden Sie das Element <CHG-REQUESTS> innerhalb des Elementes <CHANGES>, um das Kapitel Änderungsanforderungen zu erstellen.
Erstellen Sie das Element <CHG-REQUEST>, um ein Kapitel zu erstellen, das eine Änderungsanforderung enthält. Ebenso wird unter dem Kapitel Änderungsanforderungen eine Tabelle erstellt, in der alle Änderungsanforderungen aufgelistet sind. Erstellen Sie folgende Elemente, um eine Änderungsanforderung zu definieren:
<LONG-NAME>
Geben Sie in diesem Element den Titel der Änderungsanforderung ein. Der Titel erscheint in der Übersichtstabelle unter der Spalte Bezeichnung und in der Kapitelüberschrift für die Änderungsanforderung.
<SHORT-NAME>
Geben Sie in diesem Element die Kurzbezeichnung der Änderungsanforderung ein. Der Titel erscheint in der Übersichtstabelle unter der Spalte Kürzel und in der Kapitelüberschrift für die Änderungsanforderung.
<CATEGORY>
Geben Sie in diesem Element die Kategorie der Änderungsanforderung ein. Die Kategorie erscheint in den Tabellen zu Änderungsanforderung unter der Spalte Kategorie. Unter Kategorie könnte beispielsweise das Kürzel enh für Verbesserung oder bug für Fehlerbehebung eingetragen werden.
<DATE>
Geben Sie in diesem Element das Definitionsdatum der Änderungsanforderung ein.
<CHG-STATE>
Geben Sie in diesem Element das letzte Bearbeitungsdatum einer Änderungsanforderung ein. Der Status erscheint im Kapitel der Änderungsanforderung unter dem Begriff Status. Modifizieren Sie das Attribut [STATE], um folgende Stati zu definieren:
  • OPEN
    Eine Änderungsanforderung wurde neu erstellt.
  • PASSED
    Eine Änderungsanforderung wurde angenommen.
  • REJECTED
    Eine Änderungsanforderung wurde zurückgewiesen.
  • IN-PROCESS
    Eine Änderung wird momentan bearbeitet.
  • DONE
    Eine Änderung wurde umgesetzt und freigegeben.
  • POSTPONED
    Eine Änderungsanforderung wurde zurückgestellt.
<CHG-PRIORITY>
Geben Sie in diesem Element die Priorität der Änderungsanforderung ein. Das Prioritätenschema kann frei vergeben werden, sollte jedoch in der Dokumentation beschrieben sein. Die Priorität erscheint in den Tabellen zu Änderungsanforderung unter der Spalte Priorität. Unter Priorität könnte beispielsweise das Kürzel A1 für höchste Priorität eingetragen werden.
<CHG-KEYWORDS>
Erstellen Sie in diesem Element das Element <CHG-KEYWORD>, um ein Schlüsselwort der Änderungsanforderung einzugeben. Das Schlüsselwort dient als Schlagwort, mit dessen Hilfe die Änderungsanforderung über einen Suchmechanismus gefunden werden kann. Pro Änderungsanforderung können mehrere Schlüsselworte eingegeben werden. Die Schlüsselworte erscheinen in der Tabelle zur Änderungsanforderung unter der Spalte Schlüsselworte.
<CHG-PROPOSED-BY>
Geben Sie in diesem Element den Namen der Person/Organisation ein, die die Änderungsanforderung gestellt hat. Der Antragsteller erscheint in der Tabelle zur Änderungsanforderung unter der Spalte Vorschlag von.
<CHG-RELATED-OBJECTS>
Referenzieren Sie in diesem Element auf den Änderungsgegenstand, den die Änderungsanforderung betrifft. Erstellen Sie dazu innerhalb von <CHG-RELATED-OBJECTS> das Element <CHG-OBJECT-REVISION-REF>. Geben Sie im Attribut [ID-REF] des Elementes <CHG-OBJECT-REVISION-REF> den Referenznamen des Änderungsgegenstandes ein, auf den verwiesen werden soll. Der entsprechende Änderungsgegenstand erscheint in der Übersichtstabelle zur Änderungsanforderung unter der Spalte Objekt.
<CHG-RELATED-REQUESTS>
Referenzieren Sie in diesem Element auf bereits vorhandene, sachbezogene Änderungsanforderungen. Erstellen Sie dazu innerhalb von <CHG-RELATED-REQUESTS> das Element <CHG-REQUEST-REF>. Geben Sie im Attribut [ID-REF] des Elementes <CHG-REQUEST-REF> den Referenznamen der Änderungsanforderung ein, auf den verwiesen werden soll. Wählen Sie im Attribut [RELATION] des Elementes <CHG-REQUEST-REF> PREREQUSITE aus, wenn die referenzierte Änderungsanforderung Grundvoraussetzung für die aktuelle Änderungsanforderung ist. Die entsprechende Änderungsanforderung erscheint in der Tabelle zur Änderungsanforderung unter der Spalte Mit Bezug auf.
<CHG-SUBJECT>
Erstellen Sie innerhalb dieses Elementes Fließtextelemente (siehe Kapitel 3.3. Erstellen allgemeiner Dokumentinhalte), um zu beschreiben, was geändert werden soll. Der Inhalt der Änderung erscheint im Kapitel der Änderungsanforderung unter dem Begriff Gegenstand der Änderung.
<CHG-REASON>
Erstellen Sie innerhalb dieses Elementes Fließtextelemente (siehe Kapitel 3.3. Erstellen allgemeiner Dokumentinhalte), um den Grund der Änderung zu beschreiben. Der Grund der Änderung erscheint im Kapitel der Änderungsanforderung unter dem Begriff Grund.
<CHG-ACTIONS>
Verwenden Sie dieses Element, um auszuführende Aktionen einer Änderungsanforderung zu definieren. Im Kapitel 4.3.2. Auszuführende Aktionen bei einer Änderungsanforderung finden Sie dazu eine detaillierte Beschreibung. Aktionen zur Änderung erscheinen im Kapitel der Änderungsanforderung unter dem Begriff Aktion.
<CHG-SOLUTIONS>
Verwenden Sie dieses Element, um Lösungsalternativen einer Änderungsanforderung zu beschreiben. Im Kapitel 4.3.3. Lösungsalternativen zu Änderungsanforderungen finden Sie dazu eine detaillierte Beschreibung. Lösungsalternativen zur Änderung erscheinen im Kapitel der Änderungsanforderung unter dem Begriff Lösungsalternative.
<CHG-CONCLUSION>
Verwenden Sie dieses Element, um die Lösung einer Änderungsanforderung zu beschreiben. Im Kapitel 4.3.4. Realisierung einer Änderungsanforderung finden Sie dazu eine detaillierte Beschreibung. Lösungsbeschreibungen zur Änderung erscheinen im Kapitel der Änderungsanforderung unter dem Begriff Beschlossene Lösung.
Beispiel:
Abbildung 14: Übersicht der Änderungsanforderungen für MSRSW
Abbildung 15: Detaillierte Beschreibung einer Änderungsanforderung


4.3.2. Auszuführende Aktionen bei einer Änderungsanforderung

Verwenden Sie das Element <CHG-ACTION> innerhalb des Elementes <CHG-ACTIONS>, um eine Aktion im Zusammenhang mit einer Änderungsanforderung festzulegen. Erstellen Sie innerhalb von <CHG-ACTION> folgende Elemente, um Aufgabenbeschreibung, Verantwortliche und Endzeitpunkt festzulegen:
<DESC>
Erstellen Sie in diesem Element eine Beschreibung der auszuführenden Aktion.
<CHG-RESPONSIBLE>
Verwenden Sie dieses Element, um eine Liste der Verantwortlichen beim Ausführen der Aktion zu erstellen. Erstellen Sie für jeden Verantwortlichen das Element <TEAM-MEMBER-REF>. Referenzieren Sie im Attribut [ID-REF] des Elementes <TEAM-MEMBER-REF> auf einen Projektbeteiligten, der im Dokumentvorspann aufgeführt ist (siehe Kapitel 3.1.2.2. Informationen zu den Projektbeteiligten ). Alternativ können die Namen der Verantwortlichen textuell eingegeben werden.
<DATE>
Geben Sie in diesem Element das Datum ein, bis zu dem die beschriebene Aktion ausgeführt sein muss.


4.3.3. Lösungsalternativen zu Änderungsanforderungen

Verwenden Sie das Element <CHG-SOLUTION> innerhalb des Elementes <CHG-SOLUTIONS>, um eine Beschreibung der Lösungsansätze zu erstellen. Erstellen Sie folgende Elemente innerhalb von <CHG-SOLUTION>, um eine Spezifikation, Vorteile und Nachteile eines Lösungsansätze zu beschreiben:
<CHG-SOLUTION-SPEC>
Erstellen Sie innerhalb dieses Elementes Fließtextelemente (siehe Kapitel 3.3. Erstellen allgemeiner Dokumentinhalte), um einen Lösungsansatz einer Änderungsanforderung zu beschreiben. Erstellen Sie innerhalb dieses Elementes das Element <CHG-EFFORT>, um den geschätzten Aufwand an Ressourcen in Mann-Tagen für die Lösungsalternative einzutragen. Der entsprechende Ressourcenaufwand erscheint in der Tabelle zur Änderungsanforderung unter der Spalte MT.
<CHG-SOLUTION-PRO>
Erstellen Sie innerhalb dieses Elementes Fließtextelemente (siehe Kapitel 3.3. Erstellen allgemeiner Dokumentinhalte), um Vorteile eines Lösungsansatzes zu einer Änderungsanforderung zu beschreiben.
<CHG-SOLUTION-CON>
Erstellen Sie innerhalb dieses Elementes Fließtextelemente (siehe Kapitel 3.3. Erstellen allgemeiner Dokumentinhalte), um Nachteile eines Lösungsansatzes zu einer Änderungsanforderung zu beschreiben.


4.3.4. Realisierung einer Änderungsanforderung

Verwenden Sie das Element <CHG-CONCLUSION>, um die Realisierung einer Änderungsanforderung zu beschreiben. Erstellen Sie dazu folgende Elemente innerhalb von <CHG-CONCLUSION>:
<CHG-SOLUTION-SPEC>
Erstellen Sie innerhalb dieses Elementes Fließtextelemente (siehe Kapitel 3.3. Erstellen allgemeiner Dokumentinhalte), um den umgesetzten Lösungsansatz der Änderungsanforderung zu beschreiben. Erstellen Sie innerhalb dieses Elementes das Element <CHG-EFFORT>, um den geschätzten Aufwand an Ressourcen in Mann-Tagen für die Lösung einzutragen. Der entsprechende Ressourcenaufwand erscheint in der Tabelle zur Änderungsanforderung unter der Spalte MT.
<CHG-IMPLEMENTATIONS>
Erstellen Sie das Element <CHG-IMPLEMENTATION> innerhalb von <CHG-IMPLEMENTATIONS>, um Angaben zur geplanten Implementation der Änderungsanforderung zu machen.
Erstellen Sie innerhalb von <CHG-IMPLEMENTATION> das Element <CHG-OBJECT-REVISION-REF>, um auf die Version zu referenzieren, in der die Änderung implementiert wird. Geben Sie im Attribut [ID-REF] des Elementes <CHG-OBJECT-REVISION-REF> den Referenznamen des Änderungsgegenstandes ein, auf den verwiesen werden soll.
Erstellen Sie innerhalb von <CHG-IMPLEMENTATION> das Element <CHG-RELEASE-NOTES>, um eine Beschreibung der Änderung dieser Version zu erstellen. Die Inhalte von <CHG-RELEASE-NOTES> können mit einem Release-Notes-Generator über alle Änderungsanforderungen einer Version in einem separaten Dokument zusammengestellt werden.


5. Erstellen eines Anhangs

Benutzerhandbuch MSRREP V2.1.0
5. Erstellen eines Anhangs

Verwenden Sie das Element <REPORT-REAR> innerhalb des Elementes <MSRREP>, um einen Anhang zu erstellen. Im Anhang befinden sich Kapitel, die ergänzende Informationen zu gesamten Dokumentinhalt enthalten. Innerhalb von <REPORT-REAR> können folgende Elemente erstellt werden:
<CHAPTER>
Verwenden Sie dieses Element, um innerhalb des Anhangs eine Kapitelstruktur zu erstellen (siehe Kapitel 3.3.3. Arbeiten mit freien Kapitel- und Themenstrukturen).
<MSR-QUERY-CHAPTER>
Verwenden Sie dieses Element, um ein Kapitel für eine MSR-Abfrage zu erstellen (siehe Kapitel 3.3.9. MSR-Abfrage).


Technische Begriffe

Benutzerhandbuch MSRREP V2.1.0
Technische Begriffe


Kontroll-Elemente

Schaltfläche X
3.3.4.2.


Material

Plastik
3.3.4.2.


Organisationen

ISO
3.3.4.2.


Produkte

MetaMorphosis
3.3.4.2.


Programmcode

mm crp.sgm
3.3.4.2.


SGML Attribute

ALIGN | 3.3.6.4.
BOLD | 3.3.4.2.
BREAK | 3.3.3.1.
CATEGORY | 3.3.5.2.
CAUTION | 3.3.4.1.
CHAR | 3.3.6.4.
CODE | 3.3.4.2.
COLNAME | 3.3.6.3.
COLNUM | 3.3.6.3. 3.3.6.6.
COLS | 3.3.6.3.
COLSEP | 3.3.6.7.
COLWIDTH | 3.3.6.3.
CONTROL-ELEMENT | 3.3.4.2.
EXERCISE | 3.3.4.1.
FILENAME | 3.3.5.2.
FIT | 3.3.5.3.
FLOAT | 3.3.5.2. 3.3.6.2.
GID | 3.5.
HEIGHT | 3.3.5.3.
HINT | 3.3.4.1.
ID | 3.1.2.1. 3.1.2.7. 3.1.2.8. 3.3.3.1. 3.3.7.1. 3.3.7.2. 3.3.7.3. 3.3.7.4. 3.5. 4.2.
ID-CLASS | 3.3.7.2.
ID-REF | 3.2.3. 3.2.4. 3.3.7.1. 3.3.7.2. 3.3.7.3. 4.3.1. 4.3.2. 4.3.4.
INSTRUCTION | 3.3.4.1.
ITALIC | 3.3.4.2.
MATERIAL | 3.3.4.2.
MOREROWS | 3.3.6.6.
NAMEEND | 3.3.6.6.
NAMEST | 3.3.6.6.
NAMETYPE | 3.3.7.4.
NEWLINE | 3.3.4.1.
NEWLINE-IF-NECESSARY | 3.3.4.1.
NO-NEWLINE | 3.3.4.1.
NOTATION | 3.3.5.2.
ORGANISATION | 3.3.4.2.
ORIENT | 3.3.6.2. 3.3.6.4.
OTHER | 3.3.4.1. 3.3.4.2.
PGWIDE | 3.3.6.2.
PRM | 3.3.4.2.
PRODUCT | 3.3.4.2.
RELATION | 4.3.1.
ROLE | 3.1.2.1.
ROWSEP | 3.3.6.7.
SAMPLE | 3.3.2.
SCALE | 3.3.5.3.
SGML-ATTRIBUT | 3.3.4.2.
SGML-ATTRIBUTE | 3.3.4.2.
SGMLTAG | 3.3.4.2.
SHORTENTRY | 3.3.6.2.
SHOW-RESOURCE-LONG-NAME | 3.3.7.2.
SHOW-RESOURCE-NUMBER | 3.3.7.2.
SHOW-RESOURCE-PAGE | 3.3.7.2.
SHOW-RESOURCE-SHORT-NAME | 3.3.7.2.
SHOW-RESOURCE-TYPE | 3.3.7.2.
SPANNAME | 3.3.6.6.
STATE | 4.3.1.
TABSTYLE | 3.3.6.2.
TEAM-MEMBER | 3.3.2.
TGROUPSTYLE | 3.3.6.3.
TIP | 3.3.4.1.
TOCENTRY | 3.3.6.2.
TOOL | 3.3.4.2.
TYPE | 3.1.2.8. 3.2.4. 3.3.4.1.
USER-DEFINED-TYPE | 3.3.4.2.
VALIGN | 3.3.6.4.
VARIABLE | 3.3.4.2.
VARIANT-CHAR | 3.1.2.8.
WIDTH | 3.3.5.3.
XML/SGML-Attribut | II.


SGML Elemente

ABS | 3.3.4.1.
ABSTRACT | 2.3.
ACCEPTANCE-COND | 3.1.2.12.
ACCEPTANCE-COND | 3.1.2.1.
ADD-SPEC | 3.1.2.1. 3.1.2.6. 3.1.2.17.
ADDRESS | 3.1.2.2.
ADMIN-DATA | 3.1.2.1. 4.1.
C-CODE | 3.3.4.1.
CATEGORY | 1.3. 4.3.1.
CHANGE | 3.2.4.
CHANGES | 4.1. 4.2. 4.3.1.
CHAPTER | 3.3.3.1. 3.3.7.1. 3.3.8. 5.
CHG-ACTION | 4.3.2.
CHG-ACTIONS | 4.3.1. 4.3.2.
CHG-CHAPTER | 4. 4.1.
CHG-CONCLUSION | 4.3.1. 4.3.4.
CHG-EFFORT | 4.3.3. 4.3.4.
CHG-IMPLEMENTATION | 4.3.4.
CHG-IMPLEMENTATIONS | 4.3.4.
CHG-KEYWORD | 4.3.1.
CHG-KEYWORDS | 4.3.1.
CHG-OBJECT | 4.2.
CHG-OBJECT-REVISION | 3.3.7.3. 4.2.
CHG-OBJECT-REVISION-REF | 3.3.7.3. 4.3.1. 4.3.4.
CHG-OBJECT-REVISIONS | 4.2.
CHG-OBJECTS | 4.2.
CHG-PRIORITY | 4.3.1.
CHG-PROPOSED-BY | 4.3.1.
CHG-REASON | 4.3.1.
CHG-RELATED-OBJECTS | 4.3.1.
CHG-RELATED-REQUESTS | 3.3.7.3. 4.3.1.
CHG-RELEASE-NOTES | 4.3.4.
CHG-REQUEST | 4.3.1.
CHG-REQUEST-REF | 3.3.7.3. 4.3.1.
CHG-REQUESTS | 4.3.1.
CHG-RESPONSIBLE | 4.3.2.
CHG-SOLUTION | 4.3.3.
CHG-SOLUTION-CON | 4.3.3.
CHG-SOLUTION-PRO | 4.3.3.
CHG-SOLUTION-SPEC | 4.3.3. 4.3.4.
CHG-SOLUTIONS | 4.3.1. 4.3.3.
CHG-STATE | 4.3.1.
CHG-SUBJECT | 4.3.1.
CITY | 3.1.2.2.
CODE | 3.1.2.8.
COLSPEC | 3.3.6.3. 3.3.6.4. 3.3.6.6. 3.3.6.7.
COMMENT | 3.3.9.2.
COMPANIES | 3.1.2.1.
COMPANY | 2.2. 3.1.2.1. 3.1.2.2. 3.2.3. 3.2.4. 3.3.7.3.
COMPANY-DOC-INFO | 3.2.3.
COMPANY-DOC-INFOS | 3.2.3.
COMPANY-REF | 3.2.3. 3.2.4. 3.3.7.3.
COMPANY-REVISION-INFO | 3.2.4.
COMPANY-REVISION-INFOS | 3.2.4.
COND | 3.3.4.1.
CONTRACT-ASPECTS | 3.1.2.1. 3.1.2.6.
DATE | 3.2.4. 3.3.2. 4.2. 4.3.1. 4.3.2.
DATE-1 | 3.3.4.2.
DEF | 3.3.4.1.
DEF-ITEM | 3.3.4.1.
DEF-LIST | 3.3.4.1.
DEMARCATION-OTHER-PROJECTS | 3.1.2.1. 3.1.2.9.
DEPARTMENT | 3.1.2.2.
DESC | 3.1.1. 3.1.2. 3.3.2. 3.3.4.1. 3.3.5.2. 4.2. 4.3.2.
DIR-HAND-OVER-DOC-DATA | 3.1.2.1. 3.1.2.16.
DOC-LABEL | 3.2.3.
DOC-REVISION | 3.2.4.
DOC-REVISIONS | 3.2.4.
E | 3.3.4.2.
EMAIL | 3.1.2.2.
ENTITY-NAME | 3.2.3.
ENTRY | 3.3.6.4. 3.3.6.6. 3.3.6.7.
FAX | 3.1.2.2.
FIGURE | 3.3.4.1. 3.3.5.2. 3.3.5.4. 3.3.6.4.
FIGURE-CAPTION | 3.3.5.4. 3.3.8.
FORMATTER-CTRLS | 3.2.5.
FORMULA | 3.3.4.1. 3.7.
FORMULA-CAPTION | 3.3.4.1.
FRAME | 3.3.6.7.
FT | 3.3.4.2.
GENERAL-PROJECT-DATA | 3.1.2.1. 3.1.2.18.
GENERIC-MATH | 3.3.4.1.
GRAPHIC | 3.3.4.1. 3.3.5.2. 3.3.5.3.
GUARANTEE | 3.1.2.6.
HOMEPAGE | 3.1.2.2.
ID | 3.3.4.1.
IE | 3.3.4.2. 3.3.8.
INDENT-SAMPLE | 3.3.4.1.
INTEGRATION-CAPABILITY | 3.1.2.1. 3.1.2.11.
INTRODUCTION | 3.1.2.1. 3.1.2.18.
ITEM | 3.3.4.1.
ITEM-LABEL | 3.3.4.1.
KFZW | 3.3.4.2.
LABEL | 3.1.1. 3.1.2. 3.3.4.1. 3.4.
LABELED-ITEM | 3.3.4.1.
LABELED-LIST | 3.3.4.1.
LANGUAGE | 3.2.2.
LIST | 3.3.4.1.
LOCS | 3.3.7.4.
LONG-NAME | 2.2. 3.1.2.1. 3.1.2.2. 3.1.2.7. 3.1.2.8. 3.3.3.1. 3.3.3.2. 3.3.4.1. 3.3.4.2. 3.3.5.4. 3.3.6.5. 3.3.7.2. 3.3.7.4. 3.3.9.3. 3.5. 4.1. 4.2. 4.3.1.
MAIN-TITLE | 2.1.
MAINTENANCE | 3.1.2.6.
MATCHING-DCI | 3.4.
MAX | 3.3.4.1.
MIN | 3.3.4.1.
MODIFICATION | 3.2.4.
MODIFICATIONS | 3.2.4.
MSR-PROCESSING-LOG | 3.6.
MSR-QUERY | 3.3.9.1.
MSR-QUERY-ARG | 3.3.9.2.
MSR-QUERY-CHAPTER | 3.3.9.1. 5.
MSR-QUERY-NAME | 3.3.9.2.
MSR-QUERY-P-1 | 3.3.3.2. 3.3.9.1.
MSR-QUERY-PROPS | 3.3.9.1. 3.3.9.2.
MSR-QUERY-RESULT-CHAPTER | 3.3.9.1. 3.3.9.3.
MSR-QUERY-RESULT-P-1 | 3.3.9.1. 3.3.9.3.
MSR-QUERY-RESULT-TEXT | 3.3.9.1. 3.3.9.3.
MSR-QUERY-RESULT-TOPIC-1 | 3.3.9.1. 3.3.9.3.
MSR-QUERY-TEXT | 3.3.4.2. 3.3.9.1.
MSR-QUERY-TOPIC-1 | 3.3.9.1.
MSRREP | 1.3. 3.3.7.4. 5.
NA | 3.1.2.1. 3.1.2.18. 3.3.2.
NAMELOC | 3.3.7.4.
NCOI | 3.1.2.7. 3.1.2.18. 3.5.
NMLIST | 3.3.7.4.
NOTATION | 3.3.4.2.
NOTE | 3.3.4.1.
NUMBER | 3.3.4.2.
OBJECTIVES | 3.1.2.1. 3.1.2.5.
OVERALL-PROJECT | 3.1.1.
OVERALL-TITLE | 2.1.
P | 3.3.4.1. 3.3.6.4.
PARALLEL-DESIGN | 3.1.2.1. 3.1.2.10.
PHONE | 3.1.2.2.
POSITION | 3.3.4.2.
PRIVATE-CODE | 3.2.3.
PRIVATE-CODES | 3.2.3.
PRM | 3.3.4.1.
PRM-CHAR | 3.3.4.1.
PRMS | 3.3.4.1.
PROJECT | 3.1.2. 3.1.2.1.
PROJECT-DATA | 3.1.1. 3.1.2.
PROJECT-SCHEDULE | 3.1.2.1. 3.1.2.13.
PROTOCOLS | 3.1.2.1. 3.1.2.15.
PUBLISHER | 3.3.4.2.
PURCHASING-COND | 3.1.2.1. 3.1.2.14.
REASON | 3.2.4.
REASON-ORDER | 3.1.2.1. 3.1.2.4.
REMARK | 3.2.4. 3.3.4.1. 3.4.
REPORT-BODY | 1.3. 4.1.
REPORT-HEAD | 1.3. 2.
REPORT-REAR | 1.3. 5.
REPORT-SUBJECT | 1.3. 2.1.
REVISION-LABEL | 3.2.4.
RIGHTS | 3.1.2.6.
ROLE | 3.1.2.2.
ROLES | 3.1.2.2.
ROW | 3.3.6.3. 3.3.6.4.
SAMPLE | 3.1.2.7.
SAMPLE-REF | 3.3.2.
SAMPLE-SPEC | 3.1.2.1. 3.1.2.7.
SAMPLES | 3.1.2.7.
SCHEDULE | 3.3.2.
SD | 3.5.
SDG | 3.5.
SDG-CAPTION | 3.5.
SGML-ELEMENT | 3.3.4.2.
SGMLTAG | 3.3.4.2.
SHORT-LABEL | 3.4.
SHORT-NAME | 1.3. 2.2. 3.1.2.1. 3.1.2.2. 3.1.2.7. 3.1.2.8. 3.3.3.1. 3.3.3.2. 3.3.4.1. 3.3.4.2. 3.3.6.2. 3.3.7.1. 3.3.7.2. 3.3.7.4. 3.5. 4.1. 4.2. 4.3.1.
SPANSPEC | 3.3.6.4. 3.3.6.6.
SPECIAL-DATA | 3.5.
STATE | 3.2.4.
STATE-1 | 3.3.4.2.
STD | 3.3.4.2. 3.3.8.
SUB | 3.3.4.2.
SUB-TITLE | 2.1.
SUBTITLE | 3.3.4.2.
SUP | 3.3.4.2.
SW-DATA-DICTIONARY | 3.3.4.2.
SYSTEM-OVERVIEW | 3.1.2.1. 3.1.2.3.
TABLE | 3.3.6.2. 3.3.6.4. 3.3.6.5. 3.3.6.7.
TABLE-CAPTION | 3.3.6.5. 3.3.8.
TBD | 3.1.2.1. 3.1.2.18. 3.3.2.
TBODY | 3.3.6.3. 3.3.6.4.
TBR | 3.1.2.1. 3.1.2.18. 3.3.2.
TEAM-MEMBER | 2.2. 3.3.7.1. 3.3.7.3.
TEAM-MEMBER-REF | 3.2.4. 3.3.7.1. 3.3.7.3. 4.3.2.
TEAM-MEMBER-REFS | 3.3.2.
TEAM-MEMBERS | 2.2. 3.1.2.1. 3.1.2.2.
TEAM-MEMEBER-REF | 3.3.2.
TEAM-MEMEBER-REFS | 3.3.2.
TEX-MATH | 3.3.4.1. 3.7.
TEXT | 3.3.4.1.
TFOOT | 3.3.6.3. 3.3.6.4.
TGROUP | 3.3.6.2. 3.3.6.3. 3.3.6.4. 3.3.6.6. 3.3.6.7.
THEAD | 3.3.6.3. 3.3.6.4.
TOL | 3.3.4.1.
TOOL | 3.3.4.2.
TOOL-VERSION | 3.3.4.2.
TOPIC | 3.3.8.
TOPIC-1 | 3.3.3.2.
TT | 3.3.4.2. 3.3.8.
TYP | 3.3.4.1.
UNIT | 3.3.4.1.
URL | 3.3.4.2. 3.4.
USED-LANGUAGES | 3.2.2.
VALUE | 3.1.2.8.
VARIANT-CHAR | 3.1.2.8.
VARIANT-CHAR-ASSIGN | 3.1.2.8.
VARIANT-CHAR-ASSIGNS | 3.1.2.8.
VARIANT-CHAR-REF | 3.1.2.8.
VARIANT-CHAR-VALUE | 3.1.2.8.
VARIANT-CHARS | 3.1.2.8.
VARIANT-DEF | 3.1.2.8.
VARIANT-DEFS | 3.1.2.8.
VARIANT-SPEC | 3.1.2.1. 3.1.2.8.
VERBATIM | 3.3.4.1. 3.3.5.2.
XDOC | 3.3.4.2. 3.3.8.
XFILE | 3.3.4.2. 3.3.8.
XML/SGML-Element | II.
XREF | 3.3.4.2. 3.3.7.2. 3.3.9.2. 3.5.
XREF-TARGET | 3.3.4.2. 3.3.7.2.
ZIP | 3.1.2.2.


Sonstige

OtherTT
3.3.4.2.


Status

revised | 3.3.4.2.
STATE | 3.3.4.2.


Variablen

VAR
3.3.4.2.


Werkzeuge

Processing-Tool
3.3.4.2.


Untitled

Es ist möglich, abhängig von der <CATEGORY> spezielle Weiterverarbeitungsprozesse zu steuern.


Untitled

Geben Sie an dieser Stelle den Text ein, der in der Fußnote stehen soll.


Untitled

Werden Texte einer Zelle nicht korrekt umgebrochen, kann an dieser Stelle ein Leerzeichen eingefügt werden, um den Umbruch zu erzwingen.