Elements and adttributes of MSRREP.DTD

MSR Engineering Documentation (MEDOC)

Elements and adttributes of MSRREP.DTD
[MSRREP-EADOC]
Revision: 3
This is a reference document for MSRREP DTD describing all elements and attributes.
MSRREP DTD is part of the MSR development documentation MEDOC.


I. How to read this document

Elements and adttributes of MSRREP.DTD
I. How to read this document

The following conventions apply
This document is written using MSRREP DTD. The following conventions apply to this document:
<msrsw> SGML elements are noted as technical term [type]=SGMLTAG.

[type] SGML attributes are noted as technical term [type]=SGML-attribute.

sgml-attribute Values of SGML attributes or discrete values for elements are noted as technical term [type]=code

ASAP2 The considered languages resp. DTDs are marked as technical term [type]=product.

ASAP The commitees are noted as [type]=organization

ECU Objects in general are marked as technical terms [type]=other. This might be automotive equipments general objects such as variables etc.

Graphical conventions used in DTD diagrams
The structure of DTDs is shown in the MSR document as DTD diagrams (see convention in DTD diagrams).
Figure 1: convention in DTD diagrams
The meaning of the symbols is:
PCDATA | Processable Character Data (PCDATA) Data that consists of zero or more characters of both text and markup. PCDATA is a declared content keyword. PCDATA is used to indicate that all markup delimiters defined in the SGML declaration will be recognized by the parser as markup in the given element rather than data characters.
RCDATA | Replaceable Character Data (RCDATA) is data that consists of zero or more characters, in which references to substitutions are not recognized (i.e. RCDATA may contain text and entity references, but no sub-elements). See also: CDATA PCDATA.
CDATA | Character Data (CDATA) consists of zero or more text characters, where no markup of any kind is recognized. CDATA is an SGML term. Note that character references are allowed in a CDATA entity (substitution) but not in CDATA content.
ANY | a terminal type indicating that the object may contain text or any element defined in the model.
EMPTY | a terminal type keyword used to indicate that there is no data (i.e. no content, sub-elements or end-tags) for the object allowed in the document instance. This keyword is often used to describe elements that are placeholders or are pointers to external or system-generated data.
One | indicates that the element or the element group occurs exactly once
ZERO-OR-ONE | indicates that the element or the element group is optional
ONE-OR-MORE | indicates that the element or the element group occurs multiple times but at least once
ZERO-OR-MORE | indicates that the element or the element group occurs multiple times but also can be missed (optional)
ORDERED | a connector used to specify that the sibling objects must appear in the document in the order shown in the model
UNORDERED | a connector used to specify that the sibling objects can appear in any order in the document.
SELECTION | a connector used to specify that only one of the sibling objects can appear in the document.
ELEMENT | indicates a single SGML structure element
COLLAPSED | indicates, that the content of the element is not displayed here


II. Allgemeine Projektdaten

Elements and adttributes of MSRREP.DTD
II. Allgemeine Projektdaten


III. Document management

Elements and adttributes of MSRREP.DTD
III. Document management

team members
Name | Company |
Dipl.-Ing.(FH) Uwe Bless | MSR MEDOC |
Dipl.-Inform. Helmut Gengenbach | MSR MEDOC |
Dipl. Ing. Eckard Jakobi | MSR MEDOC |
Dipl.-Ing. Herbert Klein | MSR MEDOC |
Dipl. Ing. Oliver Marcks | MSR MEDOC |
Dipl.-Inform. Peter Rauleder | MSR MEDOC |
Dipl.-Ing. Martin Trinschek | MSR MEDOC |
Dipl.-Ing. Bernhard Weichel | MSR MEDOC |
Dipl.-Ing. Roman Reimer | MSR MEDOC | Department: STZ XI-Works
version overview
Date | Publisher
2002-02-07 | Dipl.-Ing. Roman Reimer
28.05.1999 | Dipl.-Ing. Bernhard Weichel
18.02.1999 | Dipl.-Ing. Bernhard Weichel
modifications
Change | Related to
Create index, technical terms and reference. Convert to MSRREP V210 XML. Reason: | Content
initial release Reason: | Content
initial release Reason: | Content
modifications included
Date | Chapter | Change | Related to
2002-02-07 | Gesamt | Create index, technical terms and reference. Convert to MSRREP V210 XML. Reason: | Content
28.05.1999 | Gesamt | initial release Reason: | Content
18.02.1999 | Gesamt | initial release Reason: | Content


1. ABS ... ADMIN-DATA

Elements and adttributes of MSRREP.DTD
1. ABS ... ADMIN-DATA

Contents of this chapter:
  • 1.1. ABS
  • 1.2. ABSTRACT
  • 1.3. ACCEPTANCE-COND
  • 1.4. ADD-SPEC
  • 1.5. ADDRESS
  • 1.6. ADMIN-DATA


1.1. ABS

Figure 2: DTD-diagram for ABS
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for ABS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element defines an absolute value which is adjusted or measured.


1.2. ABSTRACT

Figure 3: DTD-diagram for ABSTRACT
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <topic-2>
parent elements | <report-head>
Attributes for ABSTRACT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description An abstract of the document content can be given here.


1.3. ACCEPTANCE-COND

Figure 4: DTD-diagram for ACCEPTANCE-COND
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for ACCEPTANCE-COND
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains a description of the acceptance conditions of this project.


1.4. ADD-SPEC

Figure 5: DTD-diagram for ADD-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for ADD-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This chapter allows the author to define additional specifications.


1.5. ADDRESS

Figure 6: DTD-diagram for ADDRESS
Child elements | none
parent elements | <team-member>
Attributes for ADDRESS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of the address of a team member.


1.6. ADMIN-DATA

Figure 7: DTD-diagram for ADMIN-DATA
Child elements | <language> <used-languages> <company-doc-infos> <doc-revisions>
parent elements | <chapter> <chg-chapter> <general-project-data> <msrrep>
Attributes for ADMIN-DATA
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | language:selection |
[S] | cdata | implied |  |
Description Definition of the administrative data of this document fragment.


2. C-CODE ... CHG-RELATED-OBJECTS

Elements and adttributes of MSRREP.DTD
2. C-CODE ... CHG-RELATED-OBJECTS

Contents of this chapter:
  • 2.1. C-CODE
  • 2.2. CHANGE
  • 2.3. CHANGES
  • 2.4. CHAPTER
  • 2.5. CHG-CHAPTER
  • 2.6. CHG-CLASS
  • 2.7. CHG-CONCLUSION
  • 2.8. CHG-EFFORT
  • 2.9. CHG-IMPLEMENTATION
  • 2.10. CHG-IMPLEMENTATIONS
  • 2.11. CHG-KEYWORDS
  • 2.12. CHG-OBJECT
  • 2.13. CHG-OBJECT-REVISION
  • 2.14. CHG-OBJECT-REVISION-REF
  • 2.15. CHG-OBJECT-REVISIONS
  • 2.16. CHG-OBJECTS
  • 2.17. CHG-PRIORITY
  • 2.18. CHG-PROPOSED-BY
  • 2.19. CHG-REASON
  • 2.20. CHG-RELATED-OBJECTS


2.1. C-CODE

Figure 8: DTD-diagram for C-CODE
Child elements | none
parent elements | <formula>
Attributes for C-CODE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element is used to specify the code of the formula transferred to the programming language C.


2.2. CHANGE

Figure 9: DTD-diagram for CHANGE
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <modification>
Attributes for CHANGE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Describes the change of a document.


2.3. CHANGES

Figure 10: DTD-diagram for CHANGES
Child elements | <chg-objects> <chg-requests>
parent elements | <chg-chapter>
Attributes for CHANGES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Serves to support the document change management.


2.4. CHAPTER

Figure 11: DTD-diagram for CHAPTER
Child elements | <long-name> <short-name> <admin-data> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <chapter> <ncoi-1> <report-body> <report-head> <report-rear>
Attributes for CHAPTER
Name | Type | Class | Value | Remark
[BREAK] | nmtkgrp | implied | BREAK NO-BREAK |
[F-ID-CLASS] | name | fixed | CHAPTER |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description This element is used to write one or more not content oriented chapters. Sub chapters are possible.


2.5. CHG-CHAPTER

Figure 12: DTD-diagram for CHG-CHAPTER
Child elements | <long-name> <short-name> <admin-data> <changes>
parent elements | <report-body>
Attributes for CHG-CHAPTER
Name | Type | Class | Value | Remark
[F-ID-CLASS] | cdata | fixed | chapter |
[F-NAMESPACE] | names | fixed | CHG-OBJECT CHG-OBJECT-REVISION CHG-REQUEST |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description This element serves to group changes to a chapter.


2.6. CHG-CLASS

Figure 13: DTD-diagram for CHG-CLASS
Child elements | none
parent elements | <chg-request>
Attributes for CHG-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Serves the textual classification of changes. The definition of the change class is done by the user.


2.7. CHG-CONCLUSION

Figure 14: DTD-diagram for CHG-CONCLUSION
Child elements | <chg-solution-spec> <chg-implementations>
parent elements | <chg-treatment>
Attributes for CHG-CONCLUSION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element describes the solution that is to be realized.


2.8. CHG-EFFORT

Figure 15: DTD-diagram for CHG-EFFORT
Child elements | none
parent elements | <chg-solution-spec>
Attributes for CHG-EFFORT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Serves to estimate the effort.


2.9. CHG-IMPLEMENTATION

Figure 16: DTD-diagram for CHG-IMPLEMENTATION
Child elements | <chg-object-revision-ref> <chg-release-notes>
parent elements | <chg-implementations>
Attributes for CHG-IMPLEMENTATION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element specifies the implementation of the solution to be realized.


2.10. CHG-IMPLEMENTATIONS

Figure 17: DTD-diagram for CHG-IMPLEMENTATIONS
Child elements | <chg-implementation>
parent elements | <chg-conclusion>
Attributes for CHG-IMPLEMENTATIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains informations about the solution to be realized.


2.11. CHG-KEYWORDS

Figure 18: DTD-diagram for CHG-KEYWORDS
Child elements | none
parent elements | <chg-request>
Attributes for CHG-KEYWORDS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element is used for the registration of keywords.


2.12. CHG-OBJECT

Figure 19: DTD-diagram for CHG-OBJECT
Child elements | <long-name> <short-name> <chg-object-revisions>
parent elements | <chg-objects>
Attributes for CHG-OBJECT
Name | Type | Class | Value | Remark
[F-ID-CLASS] | cdata | fixed | chg-object |
[F-NAMESPACE] | names | fixed | CHG-OBJECT-REVISION |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description This element specifies the object that is to be changed.


2.13. CHG-OBJECT-REVISION

Figure 20: DTD-diagram for CHG-OBJECT-REVISION
Child elements | <long-name> <short-name> <date>
parent elements | <chg-object-revisions>
Attributes for CHG-OBJECT-REVISION
Name | Type | Class | Value | Remark
[F-ID-CLASS] | cdata | fixed | chg-object-revision |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description This element contains information about the revision of a change object.


2.14. CHG-OBJECT-REVISION-REF

Figure 21: DTD-diagram for CHG-OBJECT-REVISION-REF
Child elements | none
parent elements | <chg-implementation> <chg-related-objects>
Attributes for CHG-OBJECT-REVISION-REF
Name | Type | Class | Value | Remark
[CHG-OBJECT-REVISION] | idref | required |  |
[HYNAMES] | names | fixed | LINKEND CHG-OBJECT-REVISION |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
Description This element is a reference to a revision of a change object.


2.15. CHG-OBJECT-REVISIONS

Figure 22: DTD-diagram for CHG-OBJECT-REVISIONS
Child elements | <chg-object-revision>
parent elements | <chg-object>
Attributes for CHG-OBJECT-REVISIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains the individual revisions of a change object.


2.16. CHG-OBJECTS

Figure 23: DTD-diagram for CHG-OBJECTS
Child elements | <chg-object>
parent elements | <changes>
Attributes for CHG-OBJECTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains the individual change objects.


2.17. CHG-PRIORITY

Figure 24: DTD-diagram for CHG-PRIORITY
Child elements | none
parent elements | <chg-request>
Attributes for CHG-PRIORITY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains the priority of a change request.


2.18. CHG-PROPOSED-BY

Figure 25: DTD-diagram for CHG-PROPOSED-BY
Child elements | none
parent elements | <chg-request>
Attributes for CHG-PROPOSED-BY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element states who proposed the request.


2.19. CHG-REASON

Figure 26: DTD-diagram for CHG-REASON
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1>
parent elements | <chg-request>
Attributes for CHG-REASON
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains the reason of a change.


2.20. CHG-RELATED-OBJECTS

Figure 27: DTD-diagram for CHG-RELATED-OBJECTS
Child elements | <chg-object-revision-ref>
parent elements | <chg-request>
Attributes for CHG-RELATED-OBJECTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Contains references to change object revisions concerned by the changes.


3. CHG-RELATED-REQUESTS ... COMPANY

Elements and adttributes of MSRREP.DTD
3. CHG-RELATED-REQUESTS ... COMPANY

Contents of this chapter:
  • 3.1. CHG-RELATED-REQUESTS
  • 3.2. CHG-RELEASE-NOTES
  • 3.3. CHG-REQUEST
  • 3.4. CHG-REQUEST-REF
  • 3.5. CHG-REQUESTS
  • 3.6. CHG-RESPONSIBILITY
  • 3.7. CHG-RESPONSIBLE
  • 3.8. CHG-SOLUTION
  • 3.9. CHG-SOLUTION-CON
  • 3.10. CHG-SOLUTION-PRO
  • 3.11. CHG-SOLUTION-SPEC
  • 3.12. CHG-SOLUTIONS
  • 3.13. CHG-STATE
  • 3.14. CHG-SUBJECT
  • 3.15. CHG-TREATMENT
  • 3.16. CITY
  • 3.17. CODE
  • 3.18. COLSPEC
  • 3.19. COMPANIES
  • 3.20. COMPANY


3.1. CHG-RELATED-REQUESTS

Figure 28: DTD-diagram for CHG-RELATED-REQUESTS
Child elements | <chg-request-ref>
parent elements | <chg-treatment>
Attributes for CHG-RELATED-REQUESTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Contains references to related change requests.


3.2. CHG-RELEASE-NOTES

Figure 29: DTD-diagram for CHG-RELEASE-NOTES
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1>
parent elements | <chg-implementation>
Attributes for CHG-RELEASE-NOTES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Contains information for the publification.


3.3. CHG-REQUEST

Figure 30: DTD-diagram for CHG-REQUEST
Child elements | <long-name> <short-name> <chg-keywords> <chg-proposed-by> <chg-priority> <chg-class> <chg-related-objects> <chg-subject> <chg-reason> <chg-treatment>
parent elements | <chg-requests>
Attributes for CHG-REQUEST
Name | Type | Class | Value | Remark
[F-ID-CLASS] | cdata | fixed | chg-request |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description This element describes a individual change request.


3.4. CHG-REQUEST-REF

Figure 31: DTD-diagram for CHG-REQUEST-REF
Child elements | none
parent elements | <chg-related-requests>
Attributes for CHG-REQUEST-REF
Name | Type | Class | Value | Remark
[CHG-REQUEST] | idref | required |  |
[HYNAMES] | names | fixed | LINKEND CHG-REQUEST |
[HYTIME] | name | fixed | CLINK |
[RELATION] | nmtkgrp | required | PREREQUISITE OTHER |
[S] | cdata | implied |  |
Description This element is a reference to a change request.


3.5. CHG-REQUESTS

Figure 32: DTD-diagram for CHG-REQUESTS
Child elements | <chg-request>
parent elements | <changes>
Attributes for CHG-REQUESTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains the individual change requests.


3.6. CHG-RESPONSIBILITY

Figure 33: DTD-diagram for CHG-RESPONSIBILITY
Child elements | <desc> <chg-responsible>
parent elements | <chg-treatment>
Attributes for CHG-RESPONSIBILITY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element describes the responsibility of the change request.


3.7. CHG-RESPONSIBLE

Figure 34: DTD-diagram for CHG-RESPONSIBLE
Child elements | <team-member-ref>
parent elements | <chg-responsibility>
Attributes for CHG-RESPONSIBLE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains references to team members that are responsible for a change request.


3.8. CHG-SOLUTION

Figure 35: DTD-diagram for CHG-SOLUTION
Child elements | <chg-solution-spec> <chg-solution-pro> <chg-solution-con>
parent elements | <chg-solutions>
Attributes for CHG-SOLUTION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element describes a possible change solution.


3.9. CHG-SOLUTION-CON

Figure 36: DTD-diagram for CHG-SOLUTION-CON
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1>
parent elements | <chg-solution>
Attributes for CHG-SOLUTION-CON
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element discusses the disadvantages of a change solution.


3.10. CHG-SOLUTION-PRO

Figure 37: DTD-diagram for CHG-SOLUTION-PRO
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1>
parent elements | <chg-solution>
Attributes for CHG-SOLUTION-PRO
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element discusses the advantages of a change solution.


3.11. CHG-SOLUTION-SPEC

Figure 38: DTD-diagram for CHG-SOLUTION-SPEC
Child elements | <chg-effort> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1>
parent elements | <chg-conclusion> <chg-solution>
Attributes for CHG-SOLUTION-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element specifies a change solution.


3.12. CHG-SOLUTIONS

Figure 39: DTD-diagram for CHG-SOLUTIONS
Child elements | <chg-solution>
parent elements | <chg-treatment>
Attributes for CHG-SOLUTIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains the individual change solutions.


3.13. CHG-STATE

Figure 40: DTD-diagram for CHG-STATE
Child elements | none
parent elements | <chg-treatment>
Attributes for CHG-STATE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[STATE] | nmtkgrp | default | OPEN OPEN PASSED REJECTED IN-PROCESS DONE |
Description This element describes the progress of a change request.


3.14. CHG-SUBJECT

Figure 41: DTD-diagram for CHG-SUBJECT
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1>
parent elements | <chg-request>
Attributes for CHG-SUBJECT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element defines a change request.


3.15. CHG-TREATMENT

Figure 42: DTD-diagram for CHG-TREATMENT
Child elements | <chg-state> <chg-related-requests> <chg-responsibility> <chg-solutions> <chg-conclusion>
parent elements | <chg-request>
Attributes for CHG-TREATMENT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element describes how a change request is to be dealt with.


3.16. CITY

Figure 43: DTD-diagram for CITY
Child elements | none
parent elements | <team-member>
Attributes for CITY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of the city of the address.


3.17. CODE

Figure 44: DTD-diagram for CODE
Child elements | none
parent elements | <variant-char> <variant-char-value> <variant-def>
Attributes for CODE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains the definition of the code.


3.18. COLSPEC

Figure 45: DTD-diagram for COLSPEC
Child elements | none
parent elements | <tfoot> <tgroup> <thead>
Attributes for COLSPEC
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | implied | LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | implied |  |
[CHAROFF] | nutoken | implied |  |
[COLNAME] | nmtoken | implied |  |
[COLNUM] | number | implied |  |
[COLSEP] | number | implied |  |
[COLWIDTH] | cdata | implied |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
Description Specifies a column, a vertical portion of a <entry>. The default values come from the <tgroup>, <thead> or <tfoot> starting the current group. Each <colspec> is for a single column, so it properly has a column number, column, implicitly in order starting from 1, and an optional colname by which it is known when used in any <spanspec> or in <entry>. A <colspec> set on <thead or <tfoot> should be complete for all columns. It overrides those on the containing <tgroup> and applies to just the <thead> or <tfoot>. If there is no <colspec> used within <thead> or <tfoot>, then the <colspec> of the containing <tgroup> is used. <colspec>s from the containing <tgroup> apply to <tbody>.


3.19. COMPANIES

Figure 46: DTD-diagram for COMPANIES
Child elements | <company>
parent elements | <report-head>
Attributes for COMPANIES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definitions of one or more companies.


3.20. COMPANY

Figure 47: DTD-diagram for COMPANY
Child elements | <long-name> <short-name> <team-members> <general-project-data>
parent elements | <companies>
Attributes for COMPANY
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | long-name:selection |
[F-ID-CLASS] | name | fixed | COMPANY |
[F-NAMESPACE] | names | fixed | SAMPLE TEAM-MEMBER VARIANT-DEF VARIANT-CHAR |
[ID] | id | required |  |
[ROLE] | nmtkgrp | required | MANUFACTURER SUPPLIER |
[S] | cdata | implied |  |
Description Definition of a company with all team members for this project.


4. COMPANY-DOC-INFO ... COND

Elements and adttributes of MSRREP.DTD
4. COMPANY-DOC-INFO ... COND

Contents of this chapter:
  • 4.1. COMPANY-DOC-INFO
  • 4.2. COMPANY-DOC-INFOS
  • 4.3. COMPANY-REF
  • 4.4. COMPANY-REVISION-INFO
  • 4.5. COMPANY-REVISION-INFOS
  • 4.6. COND


4.1. COMPANY-DOC-INFO

Figure 48: DTD-diagram for COMPANY-DOC-INFO
Child elements | <company-ref> <doc-label> <private-codes> <entity-name>
parent elements | <company-doc-infos>
Attributes for COMPANY-DOC-INFO
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Company specific document information.


4.2. COMPANY-DOC-INFOS

Figure 49: DTD-diagram for COMPANY-DOC-INFOS
Child elements | <company-doc-info>
parent elements | <admin-data>
Attributes for COMPANY-DOC-INFOS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Company specific document informations.


4.3. COMPANY-REF

Figure 50: DTD-diagram for COMPANY-REF
Child elements | none
parent elements | <company-doc-info> <company-revision-info>
Attributes for COMPANY-REF
Name | Type | Class | Value | Remark
[COMPANY] | idref | required |  |
[HYNAMES] | names | fixed | LINKEND COMPANY |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
Description Reference to a company (supplier).


4.4. COMPANY-REVISION-INFO

Figure 51: DTD-diagram for COMPANY-REVISION-INFO
Child elements | <company-ref> <revision-label> <state> <introduction>
parent elements | <company-revision-infos>
Attributes for COMPANY-REVISION-INFO
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | state:selection |
[S] | cdata | implied |  |
Description Company specific document revision.


4.5. COMPANY-REVISION-INFOS

Figure 52: DTD-diagram for COMPANY-REVISION-INFOS
Child elements | <company-revision-info>
parent elements | <doc-revision>
Attributes for COMPANY-REVISION-INFOS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Company specific document revisions.


4.6. COND

Figure 53: DTD-diagram for COND
Child elements | <p>
parent elements | <prm-char>
Attributes for COND
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Defines specific conditions under which this parameter characteristic is allowed.


5. DATE ... DOC-REVISIONS

Elements and adttributes of MSRREP.DTD
5. DATE ... DOC-REVISIONS

Contents of this chapter:
  • 5.1. DATE
  • 5.2. DATE-1
  • 5.3. DEF
  • 5.4. DEF-ITEM
  • 5.5. DEF-LIST
  • 5.6. DEMARCATION-OTHER-PROJECTS
  • 5.7. DEPARTMENT
  • 5.8. DESC
  • 5.9. DIR-HAND-OVER-DOC-DATA
  • 5.10. DOC-LABEL
  • 5.11. DOC-REVISION
  • 5.12. DOC-REVISIONS


5.1. DATE

Figure 54: DTD-diagram for DATE
Child elements | none
parent elements | <chg-object-revision> <doc-revision> <schedule>
Attributes for DATE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Specifies a date. The specification of the date is possible in several languages. But this is only possible with the right DTD configuration.


5.2. DATE-1

Figure 55: DTD-diagram for DATE-1
Child elements | none
parent elements | <std> <xdoc>
Attributes for DATE-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description With this element it is possible to specify a date in only one language.


5.3. DEF

Figure 56: DTD-diagram for DEF
Child elements | <p>
parent elements | <def-item>
Attributes for DEF
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This is a element of a definition list


5.4. DEF-ITEM

Figure 57: DTD-diagram for DEF-ITEM
Child elements | <long-name> <short-name> <def>
parent elements | <def-list>
Attributes for DEF-ITEM
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | DEF-ITEM |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description This element is used to specify a definition within a definition list.


5.5. DEF-LIST

Figure 58: DTD-diagram for DEF-LIST
Child elements | <def-item>
parent elements | <abstract> <chapter> <chg-reason> <chg-release-notes> <chg-solution-con> <chg-solution-pro> <chg-solution-spec> <chg-subject> <entry> <introduction> <item> <labeled-item> <ncoi-1> <remark> <topic-1> <topic-2>
Attributes for DEF-LIST
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element allows the user to define a list, consisting of several definitions.


5.6. DEMARCATION-OTHER-PROJECTS

Figure 59: DTD-diagram for DEMARCATION-OTHER-PROJECTS
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for DEMARCATION-OTHER-PROJECTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Specifies the demarcation and differences to other projects.


5.7. DEPARTMENT

Figure 60: DTD-diagram for DEPARTMENT
Child elements | none
parent elements | <team-member>
Attributes for DEPARTMENT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains the name of the department.


5.8. DESC

Figure 61: DTD-diagram for DESC
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <chg-responsibility> <figure> <prm> <tbd>
Attributes for DESC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Short text description of the object.


5.9. DIR-HAND-OVER-DOC-DATA

Figure 62: DTD-diagram for DIR-HAND-OVER-DOC-DATA
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for DIR-HAND-OVER-DOC-DATA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Directory of all documents which are handed over to the project partners.


5.10. DOC-LABEL

Figure 63: DTD-diagram for DOC-LABEL
Child elements | none
parent elements | <company-doc-info>
Attributes for DOC-LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Name of the document


5.11. DOC-REVISION

Figure 64: DTD-diagram for DOC-REVISION
Child elements | <company-revision-infos> <team-member-ref> <date> <modifications>
parent elements | <doc-revisions>
Attributes for DOC-REVISION
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | date:date |
[S] | cdata | implied |  |
Description This element describes a document revision.


5.12. DOC-REVISIONS

Figure 65: DTD-diagram for DOC-REVISIONS
Child elements | <doc-revision>
parent elements | <admin-data>
Attributes for DOC-REVISIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element describes the document revisions.


6. E ... ENTRY

Elements and adttributes of MSRREP.DTD
6. E ... ENTRY

Contents of this chapter:
  • 6.1. E
  • 6.2. EMAIL
  • 6.3. ENTITY-NAME
  • 6.4. ENTRY


6.1. E

Figure 66: DTD-diagram for E
Child elements | none
parent elements | <change> <desc> <indent-sample> <item-label> <main-title> <overall-title> <p> <reason> <sub-title> <tbr>
Attributes for E
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | nmtkgrp | default | BOLD BOLD ITALIC |
Description Identifies the scope of emphasized information.


6.2. EMAIL

Figure 67: DTD-diagram for EMAIL
Child elements | none
parent elements | <team-member>
Attributes for EMAIL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of the email-address.


6.3. ENTITY-NAME

Figure 68: DTD-diagram for ENTITY-NAME
Child elements | none
parent elements | <company-doc-info>
Attributes for ENTITY-NAME
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Filename of the document fragment.


6.4. ENTRY

Figure 69: DTD-diagram for ENTRY
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <row>
Attributes for ENTRY
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | implied | LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | implied |  |
[CHAROFF] | nutoken | implied |  |
[COLNAME] | nmtoken | implied |  |
[COLSEP] | number | implied |  |
[MOREROWS] | number | default | 0 |
[NAMEEND] | nmtoken | implied |  |
[NAMEST] | nmtoken | implied |  |
[ROTATE] | number | default | 0 |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[SPANNAME] | nmtoken | implied |  |
[VALIGN] | nmtkgrp | default | TOP TOP BOTTOM MIDDLE |
Description Identifies an entry in a table. Default values come from the <table>, <tgroup>, <colspec>, <spanspec>, <thead>, <tbody> or <row>; attributes. An entry not specified by a <spanspec> get the defaults from its starting column.


7. FAX ... FT

Elements and adttributes of MSRREP.DTD
7. FAX ... FT

Contents of this chapter:
  • 7.1. FAX
  • 7.2. FIGURE
  • 7.3. FILE
  • 7.4. FORMULA
  • 7.5. FT


7.1. FAX

Figure 70: DTD-diagram for FAX
Child elements | none
parent elements | <team-member>
Attributes for FAX
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Contains the fax number of an address.


7.2. FIGURE

Figure 71: DTD-diagram for FIGURE
Child elements | <long-name> <short-name> <graphic> <verbatim> <desc>
parent elements | <abstract> <chapter> <chg-reason> <chg-release-notes> <chg-solution-con> <chg-solution-pro> <chg-solution-spec> <chg-subject> <entry> <introduction> <item> <labeled-item> <ncoi-1> <remark> <topic-1> <topic-2>
Attributes for FIGURE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FIGURE |
[FLOAT] | nmtkgrp | implied | FLOAT NO-FLOAT |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Identifies a figure in the document.


7.3. FILE

Figure 72: DTD-diagram for FILE
Child elements | none
parent elements | <std> <xdoc> <xfile>
Attributes for FILE
Name | Type | Class | Value | Remark
[FILENAME] | cdata | required |  |
[NOTATION] | cdata | required |  |
[S] | cdata | implied |  |
[TOOL] | cdata | required |  |
[TOOL-VERSION] | cdata | required |  |
Description Definition of a filename (complete path).


7.4. FORMULA

Figure 73: DTD-diagram for FORMULA
Child elements | <long-name> <short-name> <graphic> <verbatim> <tex-math> <c-code> <generic-math>
parent elements | <abstract> <chapter> <chg-reason> <chg-release-notes> <chg-solution-con> <chg-solution-pro> <chg-solution-spec> <chg-subject> <entry> <introduction> <item> <labeled-item> <ncoi-1> <remark> <topic-1> <topic-2>
Attributes for FORMULA
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FORMULA |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description This element is used to specify a formula. Different kinds of specification of the formula are possible.


7.5. FT

Figure 74: DTD-diagram for FT
Child elements | none
parent elements | <change> <desc> <indent-sample> <item-label> <main-title> <overall-title> <p> <reason> <sub-title> <tbr>
Attributes for FT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Identifies the body of a footnote in the document.


8. GENERAL-PROJECT-DATA ... GRAPHIC

Elements and adttributes of MSRREP.DTD
8. GENERAL-PROJECT-DATA ... GRAPHIC

Contents of this chapter:
  • 8.1. GENERAL-PROJECT-DATA
  • 8.2. GENERIC-MATH
  • 8.3. GRAPHIC


8.1. GENERAL-PROJECT-DATA

Figure 75: DTD-diagram for GENERAL-PROJECT-DATA
Child elements | <na> <tbd> <tbr> <admin-data> <introduction> <system-overview> <reason-order> <objectives> <sample-spec> <variant-spec> <demarcation-other-projects> <parallel-designs> <integration-capability> <acceptance-cond> <project-schedule> <purchasing-cond> <protocols> <dir-hand-over-doc-data> <add-spec>
parent elements | <company>
Attributes for GENERAL-PROJECT-DATA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Specification of all general project data.


8.2. GENERIC-MATH

Figure 76: DTD-diagram for GENERIC-MATH
Child elements | none
parent elements | <formula>
Attributes for GENERIC-MATH
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element is used to describe formula for which no format (e.g. c-Code, TeX) is specified.


8.3. GRAPHIC

Figure 77: DTD-diagram for GRAPHIC
Child elements | none
parent elements | <figure> <formula>
Attributes for GRAPHIC
Name | Type | Class | Value | Remark
[CATEGORY] | nmtkgrp | implied | BARCODE CONCEPTUAL ENGINEERING FLOWCHART GRAPH LOGO SCHEMATIC WAVEFORM |
[FILENAME] | cdata | required |  |
[FIT] | number | default | 0 |
[HEIGHT] | cdata | implied |  |
[NOTATION] | cdata | required |  |
[S] | cdata | implied |  |
[SCALE] | cdata | implied |  |
[WIDTH] | cdata | implied |  |
Description Identifies a graphic. A graphic is stored in difference formats (notation attribute) and is used as an illustration in the document.


9. HOMEPAGE ... HOMEPAGE

Elements and adttributes of MSRREP.DTD
9. HOMEPAGE ... HOMEPAGE

Contents of this chapter:
  • 9.1. HOMEPAGE


9.1. HOMEPAGE

Figure 78: DTD-diagram for HOMEPAGE
Child elements | none
parent elements | <team-member>
Attributes for HOMEPAGE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Homepage of a team member.


10. IE ... ITEM-LABEL

Elements and adttributes of MSRREP.DTD
10. IE ... ITEM-LABEL

Contents of this chapter:
  • 10.1. IE
  • 10.2. INDENT-SAMPLE
  • 10.3. INTEGRATION-CAPABILITY
  • 10.4. INTRODUCTION
  • 10.5. ITEM
  • 10.6. ITEM-LABEL


10.1. IE

Figure 79: DTD-diagram for IE
Child elements | <sup> <sub>
parent elements | <change> <desc> <indent-sample> <item-label> <long-name> <long-name-1> <main-title> <overall-title> <p> <reason> <sub-title> <tbr>
Attributes for IE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | cdata | implied |  |
Description Identifies text of an item to be extracted for the index.


10.2. INDENT-SAMPLE

Figure 80: DTD-diagram for INDENT-SAMPLE
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <labeled-list>
Attributes for INDENT-SAMPLE
Name | Type | Class | Value | Remark
[ITEM-LABEL-POS] | nmtkgrp | default | NO-NEWLINE NO-NEWLINE NEWLINE NEWLINE-IF-NECESSARY |
[S] | cdata | implied |  |
Description The width of the content of this element specifies the width of the indention.


10.3. INTEGRATION-CAPABILITY

Figure 81: DTD-diagram for INTEGRATION-CAPABILITY
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for INTEGRATION-CAPABILITY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains all information about the integration capability of this project.


10.4. INTRODUCTION

Figure 82: DTD-diagram for INTRODUCTION
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <topic-2>
parent elements | <acceptance-cond> <add-spec> <company-revision-info> <demarcation-other-projects> <dir-hand-over-doc-data> <general-project-data> <integration-capability> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <system-overview> <variant-spec>
Attributes for INTRODUCTION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element can be used to create an introduction.


10.5. ITEM

Figure 83: DTD-diagram for ITEM
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <list>
Attributes for ITEM
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Identifies an item typically occurring within a list.


10.6. ITEM-LABEL

Figure 84: DTD-diagram for ITEM-LABEL
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <labeled-item>
Attributes for ITEM-LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element is used to designate the corresponding entry of the labeled list.


11. LABEL ... LONG-NAME-1

Elements and adttributes of MSRREP.DTD
11. LABEL ... LONG-NAME-1

Contents of this chapter:
  • 11.1. LABEL
  • 11.2. LABELED-ITEM
  • 11.3. LABELED-LIST
  • 11.4. LANGUAGE
  • 11.5. LIST
  • 11.6. LOCS
  • 11.7. LONG-NAME
  • 11.8. LONG-NAME-1


11.1. LABEL

Figure 85: DTD-diagram for LABEL
Child elements | none
parent elements | <note> <prms>
Attributes for LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contents a short label.


11.2. LABELED-ITEM

Figure 86: DTD-diagram for LABELED-ITEM
Child elements | <item-label> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <labeled-list>
Attributes for LABELED-ITEM
Name | Type | Class | Value | Remark
[HELP-ENTRY] | cdata | implied |  |
[S] | cdata | implied |  |
Description This element is used to specify an entry within a labeled list.


11.3. LABELED-LIST

Figure 87: DTD-diagram for LABELED-LIST
Child elements | <indent-sample> <labeled-item>
parent elements | <abstract> <chapter> <chg-reason> <chg-release-notes> <chg-solution-con> <chg-solution-pro> <chg-solution-spec> <chg-subject> <entry> <introduction> <item> <labeled-item> <ncoi-1> <remark> <topic-1> <topic-2>
Attributes for LABELED-LIST
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element is used to describe a labeled list.


11.4. LANGUAGE

Figure 88: DTD-diagram for LANGUAGE
Child elements | none
parent elements | <admin-data>
Attributes for LANGUAGE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Defines the language of the document (fragment).


11.5. LIST

Figure 89: DTD-diagram for LIST
Child elements | <item>
parent elements | <abstract> <chapter> <chg-reason> <chg-release-notes> <chg-solution-con> <chg-solution-pro> <chg-solution-spec> <chg-subject> <entry> <introduction> <item> <labeled-item> <ncoi-1> <remark> <topic-1> <topic-2>
Attributes for LIST
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | nmtkgrp | required | UNNUMBER NUMBER |
Description Identifies a list which is composed of one or more list items. There are two types of lists, numbered and unnumbered lists. They are classified by the type attribute.


11.6. LOCS

Figure 90: DTD-diagram for LOCS
Child elements | <nameloc>
parent elements | <msrrep>
Attributes for LOCS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element is used for referencing between multiple documents/instances.


11.7. LONG-NAME

Figure 91: DTD-diagram for LONG-NAME
Child elements | <tt> <ie>
parent elements | <chapter> <chg-chapter> <chg-object> <chg-object-revision> <chg-request> <company> <def-item> <figure> <formula> <nameloc> <prm> <sample> <table> <team-member> <topic-1> <topic-2> <variant-char> <variant-def>
Attributes for LONG-NAME
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Defines a long name (label, title). This element exists only in elements with identifier.


11.8. LONG-NAME-1

Figure 92: DTD-diagram for LONG-NAME-1
Child elements | <tt> <ie>
parent elements | <std> <xdoc> <xfile>
Attributes for LONG-NAME-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Defines a long name..


12. MAIN-TITLE ... MSRREP

Elements and adttributes of MSRREP.DTD
12. MAIN-TITLE ... MSRREP

Contents of this chapter:
  • 12.1. MAIN-TITLE
  • 12.2. MAX
  • 12.3. MIN
  • 12.4. MODIFICATION
  • 12.5. MODIFICATIONS
  • 12.6. MSRREP


12.1. MAIN-TITLE

Figure 93: DTD-diagram for MAIN-TITLE
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <report-subject>
Attributes for MAIN-TITLE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Main title of the document.


12.2. MAX

Figure 94: DTD-diagram for MAX
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for MAX
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element defines the maximum value of a typical range. When you define <min> and <max> you have to leave <typ> empty.


12.3. MIN

Figure 95: DTD-diagram for MIN
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for MIN
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Defines the minimum value of a typical range. When you define <min> and <max> you have to leave <typ> empty.


12.4. MODIFICATION

Figure 96: DTD-diagram for MODIFICATION
Child elements | <change> <reason>
parent elements | <modifications>
Attributes for MODIFICATION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | nmtkgrp | required | CONTENT-RELATED DOC-RELATED |
Description Description of a modification (value before and after the changes, position of change).


12.5. MODIFICATIONS

Figure 97: DTD-diagram for MODIFICATIONS
Child elements | <modification>
parent elements | <doc-revision>
Attributes for MODIFICATIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains all changes that are made in the document.


12.6. MSRREP

Figure 98: DTD-diagram for MSRREP
Child elements | <short-name> <report-head> <admin-data> <report-body> <report-rear> <locs>
parent elements | none
Attributes for MSRREP
Name | Type | Class | Value | Remark
[F-NAMESPACE] | names | fixed | CHAPTER CHG-OBJECT CHG-OBJECT-REVISION CHG-REQUEST COMPANY DEF-ITEM FIGURE FORMULA PRM SAMPLE STD TABLE TEAM-MEMBER TOPIC VARIANT-CHAR VARIANT-DEF XDOC XFILE |
[F-PUBID] | cdata | fixed | -//MSR//DTD MSR REPORT DTD:V1.1.0:MSRREP.DTD//EN |
[HYTIME] | name | fixed | HYDOC |
[PUBID] | cdata | default | -//MSR//DTD MSR REPORT DTD:V1.1.0:MSRREP.DTD//EN |
[S] | cdata | implied |  |
Description Root element of the MSR Report DTD.


13. NA ... NUMBER

Elements and adttributes of MSRREP.DTD
13. NA ... NUMBER

Contents of this chapter:
  • 13.1. NA
  • 13.2. NAMELOC
  • 13.3. NCOI-1
  • 13.4. NMLIST
  • 13.5. NOTE
  • 13.6. NUMBER


13.1. NA

Figure 99: DTD-diagram for NA
Child elements | none
parent elements | <acceptance-cond> <add-spec> <demarcation-other-projects> <dir-hand-over-doc-data> <general-project-data> <integration-capability> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <system-overview> <variant-spec>
Attributes for NA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Specifies that this information (see parent element) is not applicable for this project . The context of this element describes the reason why the information is not applicable.


13.2. NAMELOC

Figure 100: DTD-diagram for NAMELOC
Child elements | <long-name> <short-name> <nmlist>
parent elements | <locs>
Attributes for NAMELOC
Name | Type | Class | Value | Remark
[HYTIME] | name | fixed | NAMELOC |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description This element defines links to external documents.


13.3. NCOI-1

Figure 101: DTD-diagram for NCOI-1
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <acceptance-cond> <add-spec> <demarcation-other-projects> <dir-hand-over-doc-data> <integration-capability> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample> <system-overview>
Attributes for NCOI-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains the following objects to define a 'non content orientend information': topics tables figures paragraphs lists Only use these objects when you can't define all your informations in other elements!


13.4. NMLIST

Figure 102: DTD-diagram for NMLIST
Child elements | none
parent elements | <nameloc>
Attributes for NMLIST
Name | Type | Class | Value | Remark
[DOCORSUB] | entity | implied |  |
[HYTIME] | name | fixed | NMLIST |
[NAMETYPE] | nmtkgrp | default | ELEMENT ENTITY ELEMENT |
[S] | cdata | implied |  |
Description Definition of a locator element which identifies a external object.


13.5. NOTE

Figure 103: DTD-diagram for NOTE
Child elements | <label> <p>
parent elements | <abstract> <chapter> <chg-reason> <chg-release-notes> <chg-solution-con> <chg-solution-pro> <chg-solution-spec> <chg-subject> <entry> <introduction> <item> <labeled-item> <ncoi-1> <remark> <topic-1> <topic-2>
Attributes for NOTE
Name | Type | Class | Value | Remark
[NOTE-TYPE] | nmtkgrp | required | CAUTION HINT TIP INSTRUCTION EXERCISE OTHER |
[S] | cdata | implied |  |
[USER-DEFINED-TYPE] | cdata | implied |  |
Description This element is used to specify an annotation.


13.6. NUMBER

Figure 104: DTD-diagram for NUMBER
Child elements | none
parent elements | <xdoc>
Attributes for NUMBER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of a number.


14. OBJECTIVES ... OVERALL-TITLE

Elements and adttributes of MSRREP.DTD
14. OBJECTIVES ... OVERALL-TITLE

Contents of this chapter:
  • 14.1. OBJECTIVES
  • 14.2. OVERALL-TITLE


14.1. OBJECTIVES

Figure 105: DTD-diagram for OBJECTIVES
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for OBJECTIVES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description In this element the objectives of the project can be specified.


14.2. OVERALL-TITLE

Figure 106: DTD-diagram for OVERALL-TITLE
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <report-subject>
Attributes for OVERALL-TITLE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains the overall title of the document.


15. P ... PURCHASING-COND

Elements and adttributes of MSRREP.DTD
15. P ... PURCHASING-COND

Contents of this chapter:
  • 15.1. P
  • 15.2. PARALLEL-DESIGNS
  • 15.3. PHONE
  • 15.4. POSITION
  • 15.5. PRIVATE-CODE
  • 15.6. PRIVATE-CODES
  • 15.7. PRM
  • 15.8. PRM-CHAR
  • 15.9. PRMS
  • 15.10. PROJECT-SCHEDULE
  • 15.11. PROTOCOLS
  • 15.12. PUBLISHER
  • 15.13. PURCHASING-COND


15.1. P

Figure 107: DTD-diagram for P
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie> <std> <xdoc> <xfile>
parent elements | <abstract> <chapter> <chg-reason> <chg-release-notes> <chg-solution-con> <chg-solution-pro> <chg-solution-spec> <chg-subject> <cond> <def> <entry> <introduction> <item> <labeled-item> <ncoi-1> <note> <remark> <topic-1> <topic-2>
Attributes for P
Name | Type | Class | Value | Remark
[HELP-ENTRY] | cdata | implied |  |
[S] | cdata | implied |  |
Description Identifies text within a paragraph.


15.2. PARALLEL-DESIGNS

Figure 108: DTD-diagram for PARALLEL-DESIGNS
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PARALLEL-DESIGNS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Description of projects with concurrent informations (part type specifications).


15.3. PHONE

Figure 109: DTD-diagram for PHONE
Child elements | none
parent elements | <team-member>
Attributes for PHONE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of a phone number.


15.4. POSITION

Figure 110: DTD-diagram for POSITION
Child elements | none
parent elements | <std> <xdoc>
Attributes for POSITION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Describes the important position in the standard or in a external document.


15.5. PRIVATE-CODE

Figure 111: DTD-diagram for PRIVATE-CODE
Child elements | none
parent elements | <private-codes>
Attributes for PRIVATE-CODE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | cdata | implied |  |
Description This element allows you to interchange one private (encoded) data.


15.6. PRIVATE-CODES

Figure 112: DTD-diagram for PRIVATE-CODES
Child elements | <private-code>
parent elements | <company-doc-info>
Attributes for PRIVATE-CODES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element allows you to interchange private (encoded) data.


15.7. PRM

Figure 113: DTD-diagram for PRM
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <prms>
Attributes for PRM
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Definition of a numeric or alphanumeric (without <operator>, <unit> and <tolerance>) parameter.


15.8. PRM-CHAR

Figure 114: DTD-diagram for PRM-CHAR
Child elements | <cond> <abs> <tol> <min> <typ> <max> <unit> <text> <remark>
parent elements | <prm>
Attributes for PRM-CHAR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description A parameter consists of one or more characteristics. Each characteristic groups an <operator>, <value>, <unit>, <tolerance> and <cond>. Since it is possible to define a range with two parameter characteristics.


15.9. PRMS

Figure 115: DTD-diagram for PRMS
Child elements | <label> <prm>
parent elements | <chapter> <chg-reason> <chg-release-notes> <chg-solution-con> <chg-solution-pro> <chg-solution-spec> <chg-subject> <ncoi-1> <topic-1>
Attributes for PRMS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Groups one or more parameters to a parameter table.


15.10. PROJECT-SCHEDULE

Figure 116: DTD-diagram for PROJECT-SCHEDULE
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PROJECT-SCHEDULE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains a project schedule.


15.11. PROTOCOLS

Figure 117: DTD-diagram for PROTOCOLS
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PROTOCOLS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains all protocols (from the current company) of this project.


15.12. PUBLISHER

Figure 118: DTD-diagram for PUBLISHER
Child elements | none
parent elements | <xdoc>
Attributes for PUBLISHER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of the publisher of the external document.


15.13. PURCHASING-COND

Figure 119: DTD-diagram for PURCHASING-COND
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PURCHASING-COND
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element groups existing purchasing conditions.


16. REASON ... ROW

Elements and adttributes of MSRREP.DTD
16. REASON ... ROW

Contents of this chapter:
  • 16.1. REASON
  • 16.2. REASON-ORDER
  • 16.3. REMARK
  • 16.4. REPORT-BODY
  • 16.5. REPORT-HEAD
  • 16.6. REPORT-REAR
  • 16.7. REPORT-SUBJECT
  • 16.8. REVISION-LABEL
  • 16.9. ROLE
  • 16.10. ROLES
  • 16.11. ROW


16.1. REASON

Figure 120: DTD-diagram for REASON
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <modification>
Attributes for REASON
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Reason of the change.


16.2. REASON-ORDER

Figure 121: DTD-diagram for REASON-ORDER
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for REASON-ORDER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Reason of the order.


16.3. REMARK

Figure 122: DTD-diagram for REMARK
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <prm-char>
Attributes for REMARK
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Defines a remark.


16.4. REPORT-BODY

Figure 123: DTD-diagram for REPORT-BODY
Child elements | <chapter> <chg-chapter>
parent elements | <msrrep>
Attributes for REPORT-BODY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains the main part of the document as well as the change management support.


16.5. REPORT-HEAD

Figure 124: DTD-diagram for REPORT-HEAD
Child elements | <report-subject> <companies> <abstract> <chapter>
parent elements | <msrrep>
Attributes for REPORT-HEAD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains all global project related informations.


16.6. REPORT-REAR

Figure 125: DTD-diagram for REPORT-REAR
Child elements | <chapter>
parent elements | <msrrep>
Attributes for REPORT-REAR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains all appendices.


16.7. REPORT-SUBJECT

Figure 126: DTD-diagram for REPORT-SUBJECT
Child elements | <overall-title> <main-title> <sub-title> <short-name>
parent elements | <report-head>
Attributes for REPORT-SUBJECT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element specifies the subject of the report.


16.8. REVISION-LABEL

Figure 127: DTD-diagram for REVISION-LABEL
Child elements | none
parent elements | <company-revision-info>
Attributes for REVISION-LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Label of a revision.


16.9. ROLE

Figure 128: DTD-diagram for ROLE
Child elements | none
parent elements | <roles>
Attributes for ROLE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of a team member role (e.g. project leader).


16.10. ROLES

Figure 129: DTD-diagram for ROLES
Child elements | <role>
parent elements | <team-member>
Attributes for ROLES
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | role:selection |
[S] | cdata | implied |  |
Description Each team member has one or more roles in the project.


16.11. ROW

Figure 130: DTD-diagram for ROW
Child elements | <entry>
parent elements | <tbody> <tfoot> <thead>
Attributes for ROW
Name | Type | Class | Value | Remark
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
Description Identifies the row information in a <tgroup> of a table. Default values come from the <table>, <tgroup>, <colspec> or <spanspec> attributes.


17. SAMPLE ... SYSTEM-OVERVIEW

Elements and adttributes of MSRREP.DTD
17. SAMPLE ... SYSTEM-OVERVIEW

Contents of this chapter:
  • 17.1. SAMPLE
  • 17.2. SAMPLE-REF
  • 17.3. SAMPLE-SPEC
  • 17.4. SAMPLES
  • 17.5. SCHEDULE
  • 17.6. SHORT-NAME
  • 17.7. SPANSPEC
  • 17.8. STATE
  • 17.9. STATE-1
  • 17.10. STD
  • 17.11. SUB
  • 17.12. SUB-TITLE
  • 17.13. SUBTITLE
  • 17.14. SUP
  • 17.15. SYSTEM-OVERVIEW


17.1. SAMPLE

Figure 131: DTD-diagram for SAMPLE
Child elements | <long-name> <short-name> <ncoi-1>
parent elements | <samples>
Attributes for SAMPLE
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | long-name:selection |
[F-ID-CLASS] | name | fixed | SAMPLE |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Definition of a sample.


17.2. SAMPLE-REF

Figure 132: DTD-diagram for SAMPLE-REF
Child elements | none
parent elements | <schedule>
Attributes for SAMPLE-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND SAMPLE |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[SAMPLE] | idref | required |  |
Description Reference to a sample.


17.3. SAMPLE-SPEC

Figure 133: DTD-diagram for SAMPLE-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <samples>
parent elements | <general-project-data>
Attributes for SAMPLE-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element is used for specification of a sample.


17.4. SAMPLES

Figure 134: DTD-diagram for SAMPLES
Child elements | <sample>
parent elements | <sample-spec>
Attributes for SAMPLES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of a samples.


17.5. SCHEDULE

Figure 135: DTD-diagram for SCHEDULE
Child elements | <sample-ref> <date>
parent elements | <tbd>
Attributes for SCHEDULE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Fixes the date up to that a document fragment has to be resolved.


17.6. SHORT-NAME

Figure 136: DTD-diagram for SHORT-NAME
Child elements | none
parent elements | <chapter> <chg-chapter> <chg-object> <chg-object-revision> <chg-request> <company> <def-item> <figure> <formula> <msrrep> <nameloc> <prm> <report-subject> <sample> <std> <table> <team-member> <topic-1> <topic-2> <variant-char> <variant-def> <xdoc> <xfile>
Attributes for SHORT-NAME
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Identifier or label of a parameter.


17.7. SPANSPEC

Figure 137: DTD-diagram for SPANSPEC
Child elements | none
parent elements | <tgroup>
Attributes for SPANSPEC
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | default | CENTER LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | implied |  |
[CHAROFF] | nutoken | implied |  |
[COLSEP] | number | implied |  |
[NAMEEND] | nmtoken | required |  |
[NAMEST] | nmtoken | required |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[SPANNAME] | nmtoken | required |  |
Description Identifies a horizontal span of columns and associated attributes that can subsequently be referenced by its spanname to provide attributes repeatedly used in the entries or entry tables in several rows of the table group controlled by the group <colsdef>, or within the specific <thead>, <tfoot>, or <tbody> context in which the <spanspec> occurs. <Namest> and <nameend> identify the first and last columns in increasing order that identify the span. The reason <colname> is used rather than <colnum> in identifying <spanspec> is that the names are independant of revisions that may change the number of inserted/deleted columns, as long as namest remains to the left of (has a smaller colnum than) <nameend>. <spanspec>s set on <thead> or <tfoot> override those on the containing <tgroup> and apply to just the <thead> or<tfoot>. <spanspec>s from the containing <tgroup> apply to <tbody>.


17.8. STATE

Figure 138: DTD-diagram for STATE
Child elements | none
parent elements | <company-revision-info>
Attributes for STATE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Processing state of a document, e.g. draft, released.


17.9. STATE-1

Figure 139: DTD-diagram for STATE-1
Child elements | none
parent elements | <std> <xdoc>
Attributes for STATE-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of a state (multilingual).


17.10. STD

Figure 140: DTD-diagram for STD
Child elements | <long-name-1> <short-name> <subtitle> <state-1> <date-1> <file> <position>
parent elements | <p> <tbr>
Attributes for STD
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | date-1:date |
[F-ID-CLASS] | name | fixed | STD |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Specification of a standard. A <xref> can refer to a standard within a paragraph.


17.11. SUB

Figure 141: DTD-diagram for SUB
Child elements | none
parent elements | <abs> <change> <desc> <ie> <indent-sample> <item-label> <main-title> <max> <min> <overall-title> <p> <reason> <sub-title> <tbr> <text> <tol> <typ> <unit>
Attributes for SUB
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Text which appears or is displayed below the normal base line of text.


17.12. SUB-TITLE

Figure 142: DTD-diagram for SUB-TITLE
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <report-subject>
Attributes for SUB-TITLE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element specifies the subtitle of the document.


17.13. SUBTITLE

Figure 143: DTD-diagram for SUBTITLE
Child elements | none
parent elements | <std>
Attributes for SUBTITLE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element defines a subtitle of the standard.


17.14. SUP

Figure 144: DTD-diagram for SUP
Child elements | none
parent elements | <abs> <change> <desc> <ie> <indent-sample> <item-label> <main-title> <max> <min> <overall-title> <p> <reason> <sub-title> <tbr> <text> <tol> <typ> <unit>
Attributes for SUP
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Text which appears or is displayed above the normal base line of text.


17.15. SYSTEM-OVERVIEW

Figure 145: DTD-diagram for SYSTEM-OVERVIEW
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for SYSTEM-OVERVIEW
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Information about the complete system.


18. TABLE ... TYP

Elements and adttributes of MSRREP.DTD
18. TABLE ... TYP

Contents of this chapter:
  • 18.1. TABLE
  • 18.2. TBD
  • 18.3. TBODY
  • 18.4. TBR
  • 18.5. TEAM-MEMBER
  • 18.6. TEAM-MEMBER-REF
  • 18.7. TEAM-MEMBER-REFS
  • 18.8. TEAM-MEMBERS
  • 18.9. TEX-MATH
  • 18.10. TEXT
  • 18.11. TFOOT
  • 18.12. TGROUP
  • 18.13. THEAD
  • 18.14. TOL
  • 18.15. TOPIC-1
  • 18.16. TOPIC-2
  • 18.17. TT
  • 18.18. TYP


18.1. TABLE

Figure 146: DTD-diagram for TABLE
Child elements | <long-name> <short-name> <tgroup>
parent elements | <abstract> <chapter> <chg-reason> <chg-release-notes> <chg-solution-con> <chg-solution-pro> <chg-solution-spec> <chg-subject> <introduction> <ncoi-1> <topic-1> <topic-2>
Attributes for TABLE
Name | Type | Class | Value | Remark
[COLSEP] | number | implied |  |
[F-ID-CLASS] | name | fixed | TABLE |
[FLOAT] | nmtkgrp | implied | FLOAT NO-FLOAT |
[FRAME] | nmtkgrp | implied | TOP BOTTOM TOPBOT ALL SIDES NONE |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[ORIENT] | nmtkgrp | implied | PORT LAND |
[PGWIDE] | number | implied |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[SHORTENTRY] | number | implied |  |
[TABSTYLE] | nmtoken | implied |  |
[TOCENTRY] | number | default | 1 |
Description Identifies a table.


18.2. TBD

Figure 147: DTD-diagram for TBD
Child elements | <team-member-refs> <schedule> <desc>
parent elements | <acceptance-cond> <add-spec> <demarcation-other-projects> <dir-hand-over-doc-data> <general-project-data> <integration-capability> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <system-overview> <variant-spec>
Attributes for TBD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Specifies that this information (see parent element) will be defined. The context of this element describes the reason why the information is not defined.


18.3. TBODY

Figure 148: DTD-diagram for TBODY
Child elements | <row>
parent elements | <tgroup>
Attributes for TBODY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[VALIGN] | nmtkgrp | default | TOP TOP MIDDLE BOTTOM |
Description Defines the table body.


18.4. TBR

Figure 149: DTD-diagram for TBR
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie> <std> <xdoc> <xfile>
parent elements | <acceptance-cond> <add-spec> <demarcation-other-projects> <dir-hand-over-doc-data> <general-project-data> <integration-capability> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <system-overview> <variant-spec>
Attributes for TBR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Describes substructures which have to be resolved with existing document fragments.


18.5. TEAM-MEMBER

Figure 150: DTD-diagram for TEAM-MEMBER
Child elements | <roles> <long-name> <short-name> <department> <address> <zip> <city> <phone> <fax> <email> <homepage>
parent elements | <team-members>
Attributes for TEAM-MEMBER
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | TEAM-MEMBER |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Definition of a team member.


18.6. TEAM-MEMBER-REF

Figure 151: DTD-diagram for TEAM-MEMBER-REF
Child elements | none
parent elements | <chg-responsible> <doc-revision> <team-member-refs>
Attributes for TEAM-MEMBER-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND TEAM-MEMBER |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[TEAM-MEMBER] | idref | required |  |
Description Reference to an team member.


18.7. TEAM-MEMBER-REFS

Figure 152: DTD-diagram for TEAM-MEMBER-REFS
Child elements | <team-member-ref>
parent elements | <tbd>
Attributes for TEAM-MEMBER-REFS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description List of references to team members.


18.8. TEAM-MEMBERS

Figure 153: DTD-diagram for TEAM-MEMBERS
Child elements | <team-member>
parent elements | <company>
Attributes for TEAM-MEMBERS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element groups team-members of a company for the current project.


18.9. TEX-MATH

Figure 154: DTD-diagram for TEX-MATH
Child elements | none
parent elements | <formula>
Attributes for TEX-MATH
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Describes a TeX (LaTeX) formula.


18.10. TEXT

Figure 155: DTD-diagram for TEXT
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for TEXT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of text.


18.11. TFOOT

Figure 156: DTD-diagram for TFOOT
Child elements | <colspec> <row>
parent elements | <tgroup>
Attributes for TFOOT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[VALIGN] | nmtkgrp | default | TOP TOP MIDDLE BOTTOM |
Description Identifies the footer information in a table displayed after the <tbody> and also at the bottom of any <tbody> rows before a physical break.


18.12. TGROUP

Figure 157: DTD-diagram for TGROUP
Child elements | <colspec> <spanspec> <thead> <tfoot> <tbody>
parent elements | <table>
Attributes for TGROUP
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | default | LEFT LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | default |  |
[CHAROFF] | nutoken | default | 50 |
[COLS] | number | required |  |
[COLSEP] | number | implied |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[TGROUPSTYLE] | nmtoken | implied |  |
Description Each <tgroup> effectively identifies a new partition of a table. If a new <colspec> is provided, it replaces a previous one. If both <colspec> and <spanspec> are new, <spanspec> should refer to columns in the most recent <colspec>.


18.13. THEAD

Figure 158: DTD-diagram for THEAD
Child elements | <colspec> <row>
parent elements | <tgroup>
Attributes for THEAD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[VALIGN] | nmtkgrp | default | BOTTOM TOP MIDDLE BOTTOM |
Description Identifies the heading information in a table, displayed at the top of the table and again at the top of any continuation after a physical break between <rows> in <tbody>.


18.14. TOL

Figure 159: DTD-diagram for TOL
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for TOL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of a tolerance of the defined <value>.


18.15. TOPIC-1

Figure 160: DTD-diagram for TOPIC-1
Child elements | <long-name> <short-name> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms>
parent elements | <chapter> <chg-reason> <chg-release-notes> <chg-solution-con> <chg-solution-pro> <chg-solution-spec> <chg-subject> <ncoi-1>
Attributes for TOPIC-1
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | TOPIC |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description This element groups tables, parameter groups, figures, lists and paragraphs. It has the same function as a sub-chapter or sub-section.


18.16. TOPIC-2

Figure 161: DTD-diagram for TOPIC-2
Child elements | <long-name> <short-name> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table>
parent elements | <abstract> <introduction>
Attributes for TOPIC-2
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | TOPIC |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description This element groups tables, figures, lists and paragraphs. It has the same function as a sub-chapter or sub-section.


18.17. TT

Figure 162: DTD-diagram for TT
Child elements | none
parent elements | <change> <desc> <indent-sample> <item-label> <long-name> <long-name-1> <main-title> <overall-title> <p> <reason> <sub-title> <tbr>
Attributes for TT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | nmtkgrp | required | SGMLTAG SGML-ATTRIBUTE TOOL PRODUCT VARIABLE STATE PRM MATERIAL CONTROL-ELEMENT CODE ORGANISATION OTHER |
[USER-DEFINED-TYPE] | cdata | implied |  |
Description technical term


18.18. TYP

Figure 163: DTD-diagram for TYP
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for TYP
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Defines a typical value.


19. UNIT ... USED-LANGUAGES

Elements and adttributes of MSRREP.DTD
19. UNIT ... USED-LANGUAGES

Contents of this chapter:
  • 19.1. UNIT
  • 19.2. USED-LANGUAGES


19.1. UNIT

Figure 164: DTD-diagram for UNIT
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for UNIT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of a unit. Please use the standardized SI symbols.


19.2. USED-LANGUAGES

Figure 165: DTD-diagram for USED-LANGUAGES
Child elements | none
parent elements | <admin-data>
Attributes for USED-LANGUAGES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Languages in which the document is produced.


20. VALUE ... VERBATIM

Elements and adttributes of MSRREP.DTD
20. VALUE ... VERBATIM

Contents of this chapter:
  • 20.1. VALUE
  • 20.2. VARIANT-CHAR
  • 20.3. VARIANT-CHAR-ASSIGN
  • 20.4. VARIANT-CHAR-ASSIGNS
  • 20.5. VARIANT-CHAR-REF
  • 20.6. VARIANT-CHAR-VALUE
  • 20.7. VARIANT-CHARS
  • 20.8. VARIANT-DEF
  • 20.9. VARIANT-DEFS
  • 20.10. VARIANT-SPEC
  • 20.11. VERBATIM


20.1. VALUE

Figure 166: DTD-diagram for VALUE
Child elements | none
parent elements | <variant-char-value>
Attributes for VALUE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Specifies the value of a variant characteristic.


20.2. VARIANT-CHAR

Figure 167: DTD-diagram for VARIANT-CHAR
Child elements | <long-name> <short-name> <code>
parent elements | <variant-chars>
Attributes for VARIANT-CHAR
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | VARIANT-CHAR |
[ID] | id | required |  |
[S] | cdata | implied |  |
[TYPE] | nmtkgrp | required | NEW-PART-NUMBER NO-NEW-PART-NUMBER |
Description Definition of a variant characteristic.


20.3. VARIANT-CHAR-ASSIGN

Figure 168: DTD-diagram for VARIANT-CHAR-ASSIGN
Child elements | <variant-char-ref> <variant-char-value>
parent elements | <variant-char-assigns>
Attributes for VARIANT-CHAR-ASSIGN
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Assigns a variant characteristic.


20.4. VARIANT-CHAR-ASSIGNS

Figure 169: DTD-diagram for VARIANT-CHAR-ASSIGNS
Child elements | <variant-char-assign>
parent elements | <variant-def>
Attributes for VARIANT-CHAR-ASSIGNS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Assigns variant characteristics.


20.5. VARIANT-CHAR-REF

Figure 170: DTD-diagram for VARIANT-CHAR-REF
Child elements | none
parent elements | <variant-char-assign>
Attributes for VARIANT-CHAR-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND VARIANT-CHAR |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[VARIANT-CHAR] | idref | required |  |
Description Reference to a variant characteristic.


20.6. VARIANT-CHAR-VALUE

Figure 171: DTD-diagram for VARIANT-CHAR-VALUE
Child elements | <value> <code>
parent elements | <variant-char-assign>
Attributes for VARIANT-CHAR-VALUE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains the value of a variant characteristic.


20.7. VARIANT-CHARS

Figure 172: DTD-diagram for VARIANT-CHARS
Child elements | <variant-char>
parent elements | <variant-spec>
Attributes for VARIANT-CHARS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of variant characteristics.


20.8. VARIANT-DEF

Figure 173: DTD-diagram for VARIANT-DEF
Child elements | <long-name> <short-name> <code> <variant-char-assigns>
parent elements | <variant-defs>
Attributes for VARIANT-DEF
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | VARIANT-DEF |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description General definition of a variant.


20.9. VARIANT-DEFS

Figure 174: DTD-diagram for VARIANT-DEFS
Child elements | <variant-def>
parent elements | <variant-spec>
Attributes for VARIANT-DEFS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description General definitions of a variant.


20.10. VARIANT-SPEC

Figure 175: DTD-diagram for VARIANT-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <variant-chars> <variant-defs>
parent elements | <general-project-data>
Attributes for VARIANT-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Specification of a variant.


20.11. VERBATIM

Figure 176: DTD-diagram for VERBATIM
Child elements | none
parent elements | <abstract> <chapter> <chg-reason> <chg-release-notes> <chg-solution-con> <chg-solution-pro> <chg-solution-spec> <chg-subject> <entry> <figure> <formula> <introduction> <item> <labeled-item> <ncoi-1> <remark> <topic-1> <topic-2>
Attributes for VERBATIM
Name | Type | Class | Value | Remark
[ALLOW-BREAK] | number | default | 1 |
[FLOAT] | nmtkgrp | implied | FLOAT NO-FLOAT |
[HELP-ENTRY] | cdata | implied |  |
[S] | cdata | implied |  |
Description Used to indicate if the text is to be picked up and laid down as it is. Typically, it implies the usage of a monospace font and the designated point size. All record ends are retained. The use of tabs in verbatim text may cause unexpected results and should therefore be avoided.


21. XDOC ... XREF

Elements and adttributes of MSRREP.DTD
21. XDOC ... XREF

Contents of this chapter:
  • 21.1. XDOC
  • 21.2. XFILE
  • 21.3. XREF


21.1. XDOC

Figure 177: DTD-diagram for XDOC
Child elements | <long-name-1> <short-name> <number> <state-1> <date-1> <publisher> <file> <position>
parent elements | <p> <tbr>
Attributes for XDOC
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | date-1:date |
[F-ID-CLASS] | name | fixed | XDOC |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Specifies an external document which is not accessed by the SGML-System. The content of this external document is 'not included' in the document instance or presented in a report.


21.2. XFILE

Figure 178: DTD-diagram for XFILE
Child elements | <long-name-1> <short-name> <file>
parent elements | <p> <tbr>
Attributes for XFILE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | XFILE |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Specifies an external file which is not accessed by the SGML-System. The content of this external file is 'not included' in the document instance or presented in a report.


21.3. XREF

Figure 179: DTD-diagram for XREF
Child elements | none
parent elements | <change> <desc> <indent-sample> <item-label> <main-title> <overall-title> <p> <reason> <sub-title> <tbr>
Attributes for XREF
Name | Type | Class | Value | Remark
[EXT-ID-CLASS] | cdata | implied |  |
[HYNAMES] | names | fixed | LINKEND ID-REF |
[HYTIME] | name | fixed | CLINK |
[ID-CLASS] | nmtkgrp | required | CHAPTER CHG-OBJECT CHG-OBJECT-REVISION CHG-REQUEST COMPANY DEF-ITEM FIGURE FORMULA PRM SAMPLE STD TABLE TEAM-MEMBER TOPIC VARIANT-CHAR VARIANT-DEF XDOC XFILE EXTERNAL |
[ID-REF] | idref | required |  |
[S] | cdata | implied |  |
Description Reference inside a paragraph to objects (elements with identifier) in the document. The type attribute classifies this reference into following classes: - figures - tables - external documents - parameters - standards - other For the output, the processing system will use this classes for difference presentation.


22. ZIP ... ZIP

Elements and adttributes of MSRREP.DTD
22. ZIP ... ZIP

Contents of this chapter:
  • 22.1. ZIP


22.1. ZIP

Figure 180: DTD-diagram for ZIP
Child elements | none
parent elements | <team-member>
Attributes for ZIP
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains the ZIP of the used address.


Technical Terms

Elements and adttributes of MSRREP.DTD
Technical Terms


Code

code | I.
organization | I.
other | I.
product | I.
SGML-attribute | I.
SGMLTAG | I.


Organisations

ASAP
I.


OTHER

ECU
I.


Products

ASAP2 | I.
MSRREP DTD |


SGML Attributes

ALIGN
3.18. 6.4. 17.7. 18.12.
ALLOW-BREAK
20.11.
BREAK
2.4.
CATEGORY
8.3.
CHAR
3.18. 6.4. 17.7. 18.12.
CHAROFF
3.18. 6.4. 17.7. 18.12.
CHG-OBJECT-REVISION
2.14.
CHG-REQUEST
3.4.
COLNAME
3.18. 6.4.
COLNUM
3.18.
COLS
18.12.
COLSEP
3.18. 6.4. 17.7. 18.1. 18.12.
COLWIDTH
3.18.
COMPANY
4.3.
DOCORSUB
13.4.
EXT-ID-CLASS
21.3.
F-CHILD-TYPE
1.6. 3.20. 4.4. 5.11. 16.10. 17.1. 17.10. 21.1.
F-ID-CLASS
2.4. 2.5. 2.12. 2.13. 3.3. 3.20. 5.4. 7.2. 7.4. 15.7. 17.1. 17.10. 18.1. 18.5. 18.15. 18.16. 20.2. 20.8. 21.1. 21.2.
F-NAMESPACE
2.5. 2.12. 3.20. 12.6.
F-PUBID
12.6.
FILENAME
7.3. 8.3.
FIT
8.3.
FLOAT
7.2. 18.1. 20.11.
FRAME
18.1.
HEIGHT
8.3.
HELP-ENTRY
2.4. 5.4. 7.2. 11.2. 15.1. 18.1. 18.15. 18.16. 20.11.
HYNAMES
2.14. 3.4. 4.3. 17.2. 18.6. 20.5. 21.3.
HYTIME
2.14. 3.4. 4.3. 12.6. 13.2. 13.4. 17.2. 18.6. 20.5. 21.3.
ID
2.4. 2.5. 2.12. 2.13. 3.3. 3.20. 5.4. 7.2. 7.4. 13.2. 15.7. 17.1. 17.10. 18.1. 18.5. 18.15. 18.16. 20.2. 20.8. 21.1. 21.2.
ID-CLASS
21.3.
ID-REF
21.3.
ITEM-LABEL-POS
10.2.
MOREROWS
6.4.
NAMEEND
6.4. 17.7.
NAMEST
6.4. 17.7.
NAMETYPE
13.4.
NOTATION
7.3. 8.3.
NOTE-TYPE
13.5.
ORIENT
18.1.
PGWIDE
18.1.
PUBID
12.6.
RELATION
3.4.
ROLE
3.20.
ROTATE
6.4.
ROWSEP
3.18. 6.4. 16.11. 17.7. 18.1. 18.12.
S
1.1. 1.2. 1.3. 1.4. 1.5. 1.6. 2.1. 2.2. 2.3. 2.4. 2.5. 2.6. 2.7. 2.8. 2.9. 2.10. 2.11. 2.12. 2.13. 2.14. 2.15. 2.16. 2.17. 2.18. 2.19. 2.20. 3.1. 3.2. 3.3. 3.4. 3.5. 3.6. 3.7. 3.8. 3.9. 3.10. 3.11. 3.12. 3.13. 3.14. 3.15. 3.16. 3.17. 3.18. 3.19. 3.20. 4.1. 4.2. 4.3. 4.4. 4.5. 4.6. 5.1. 5.2. 5.3. 5.4. 5.5. 5.6. 5.7. 5.8. 5.9. 5.10. 5.11. 5.12. 6.1. 6.2. 6.3. 6.4. 7.1. 7.2. 7.3. 7.4. 7.5. 8.1. 8.2. 8.3. 9.1. 10.1. 10.2. 10.3. 10.4. 10.5. 10.6. 11.1. 11.2. 11.3. 11.4. 11.5. 11.6. 11.7. 11.8. 12.1. 12.2. 12.3. 12.4. 12.5. 12.6. 13.1. 13.2. 13.3. 13.4. 13.5. 13.6. 14.1. 14.2. 15.1. 15.2. 15.3. 15.4. 15.5. 15.6. 15.7. 15.8. 15.9. 15.10. 15.11. 15.12. 15.13. 16.1. 16.2. 16.3. 16.4. 16.5. 16.6. 16.7. 16.8. 16.9. 16.10. 16.11. 17.1. 17.2. 17.3. 17.4. 17.5. 17.6. 17.7. 17.8. 17.9. 17.10. 17.11. 17.12. 17.13. 17.14. 17.15. 18.1. 18.2. 18.3. 18.4. 18.5. 18.6. 18.7. 18.8. 18.9. 18.10. 18.11. 18.12. 18.13. 18.14. 18.15. 18.16. 18.17. 18.18. 19.1. 19.2. 20.1. 20.2. 20.3. 20.4. 20.5. 20.6. 20.7. 20.8. 20.9. 20.10. 20.11. 21.1. 21.2. 21.3. 22.1.
SAMPLE
17.2.
SCALE
8.3.
SHORTENTRY
18.1.
SPANNAME
6.4. 17.7.
STATE
3.13.
TABSTYLE
18.1.
TEAM-MEMBER
18.6.
TGROUPSTYLE
18.12.
TOCENTRY
18.1.
TOOL
7.3.
TOOL-VERSION
7.3.
type
I.
USER-DEFINED-TYPE
13.5. 18.17.
VALIGN
6.4. 18.3. 18.11. 18.13.
VARIANT-CHAR
20.5.
WIDTH
8.3.


SGML Elements

abs | 15.8. 17.11. 17.14.
abstract | 5.5. 7.2. 7.4. 11.3. 11.5. 13.5. 15.1. 16.5. 18.1. 18.16. 20.11.
acceptance-cond | 8.1. 10.4. 13.1. 13.3. 18.2. 18.4.
add-spec | 8.1. 10.4. 13.1. 13.3. 18.2. 18.4.
address | 18.5.
admin-data | 2.4. 2.5. 4.2. 5.12. 8.1. 11.4. 12.6. 19.2.
c-code | 7.4.
change | 6.1. 7.5. 10.1. 12.4. 17.11. 17.14. 18.17. 21.3.
changes | 2.5. 2.16. 3.5.
chapter | 1.6. 2.4. 5.5. 7.2. 7.4. 11.3. 11.5. 11.7. 13.3. 13.5. 15.1. 15.9. 16.4. 16.5. 16.6. 17.6. 18.1. 18.15. 20.11.
chg-chapter | 1.6. 2.3. 11.7. 16.4. 17.6.
chg-class | 3.3.
chg-conclusion | 2.10. 3.11. 3.15.
chg-effort | 3.11.
chg-implementation | 2.10. 2.14. 3.2.
chg-implementations | 2.7. 2.9.
chg-keywords | 3.3.
chg-object | 2.15. 2.16. 11.7. 17.6.
chg-object-revision | 2.15. 5.1. 11.7. 17.6.
chg-object-revision-ref | 2.9. 2.20.
chg-object-revisions | 2.12. 2.13.
chg-objects | 2.3. 2.12.
chg-priority | 3.3.
chg-proposed-by | 3.3.
chg-reason | 3.3. 5.5. 7.2. 7.4. 11.3. 11.5. 13.5. 15.1. 15.9. 18.1. 18.15. 20.11.
chg-related-objects | 2.14. 3.3.
chg-related-requests | 3.4. 3.15.
chg-release-notes | 2.9. 5.5. 7.2. 7.4. 11.3. 11.5. 13.5. 15.1. 15.9. 18.1. 18.15. 20.11.
chg-request | 2.6. 2.11. 2.17. 2.18. 2.19. 2.20. 3.5. 3.14. 3.15. 11.7. 17.6.
chg-request-ref | 3.1.
chg-requests | 2.3. 3.3.
chg-responsibility | 3.7. 3.15. 5.8.
chg-responsible | 3.6. 18.6.
chg-solution | 3.9. 3.10. 3.11. 3.12.
chg-solution-con | 3.8. 5.5. 7.2. 7.4. 11.3. 11.5. 13.5. 15.1. 15.9. 18.1. 18.15. 20.11.
chg-solution-pro | 3.8. 5.5. 7.2. 7.4. 11.3. 11.5. 13.5. 15.1. 15.9. 18.1. 18.15. 20.11.
chg-solution-spec | 2.7. 2.8. 3.8. 5.5. 7.2. 7.4. 11.3. 11.5. 13.5. 15.1. 15.9. 18.1. 18.15. 20.11.
chg-solutions | 3.8. 3.15.
chg-state | 3.15.
chg-subject | 3.3. 5.5. 7.2. 7.4. 11.3. 11.5. 13.5. 15.1. 15.9. 18.1. 18.15. 20.11.
chg-treatment | 2.7. 3.1. 3.3. 3.6. 3.12. 3.13.
city | 18.5.
code | 20.2. 20.6. 20.8.
colspec | 18.11. 18.12. 18.13.
companies | 3.20. 16.5.
company | 3.19. 8.1. 11.7. 17.6. 18.8.
company-doc-info | 4.2. 4.3. 5.10. 6.3. 15.6.
company-doc-infos | 1.6. 4.1.
company-ref | 4.1. 4.4.
company-revision-info | 4.3. 4.5. 10.4. 16.8. 17.8.
company-revision-infos | 4.4. 5.11.
cond | 15.1. 15.8.
date | 2.13. 5.11. 17.5.
date-1 | 17.10. 21.1.
def | 5.4. 15.1.
def-item | 5.3. 5.5. 11.7. 17.6.
def-list | 1.2. 2.4. 2.19. 3.2. 3.9. 3.10. 3.11. 3.14. 5.4. 6.4. 10.4. 10.5. 11.2. 13.3. 16.3. 18.15. 18.16.
demarcation-other-projects | 8.1. 10.4. 13.1. 13.3. 18.2. 18.4.
department | 18.5.
desc | 3.6. 6.1. 7.2. 7.5. 10.1. 15.7. 17.11. 17.14. 18.2. 18.17. 21.3.
dir-hand-over-doc-data | 8.1. 10.4. 13.1. 13.3. 18.2. 18.4.
doc-label | 4.1.
doc-revision | 4.5. 5.1. 5.12. 12.5. 18.6.
doc-revisions | 1.6. 5.11.
e | 2.2. 5.8. 10.2. 10.6. 12.1. 14.2. 15.1. 16.1. 17.12. 18.4.
email | 18.5.
entity-name | 4.1.
entry | 5.5. 7.2. 7.4. 11.3. 11.5. 13.5. 15.1. 16.11. 20.11.
fax | 18.5.
figure | 1.2. 2.4. 2.19. 3.2. 3.9. 3.10. 3.11. 3.14. 5.8. 6.4. 8.3. 10.4. 10.5. 11.2. 11.7. 13.3. 16.3. 17.6. 18.15. 18.16. 20.11.
file | 17.10. 21.1. 21.2.
formula | 1.2. 2.1. 2.4. 2.19. 3.2. 3.9. 3.10. 3.11. 3.14. 6.4. 8.2. 8.3. 10.4. 10.5. 11.2. 11.7. 13.3. 16.3. 17.6. 18.9. 18.15. 18.16. 20.11.
ft | 2.2. 5.8. 10.2. 10.6. 12.1. 14.2. 15.1. 16.1. 17.12. 18.4.
general-project-data | 1.3. 1.4. 1.6. 3.20. 5.6. 5.9. 10.3. 10.4. 13.1. 14.1. 15.2. 15.10. 15.11. 15.13. 16.2. 17.3. 17.15. 18.2. 18.4. 20.10.
generic-math | 7.4.
graphic | 7.2. 7.4.
homepage | 18.5.
ie | 2.2. 5.8. 10.2. 10.6. 11.7. 11.8. 12.1. 14.2. 15.1. 16.1. 17.11. 17.12. 17.14. 18.4.
indent-sample | 6.1. 7.5. 10.1. 11.3. 17.11. 17.14. 18.17. 21.3.
integration-capability | 8.1. 10.4. 13.1. 13.3. 18.2. 18.4.
introduction | 1.3. 1.4. 4.4. 5.5. 5.6. 5.9. 7.2. 7.4. 8.1. 10.3. 11.3. 11.5. 13.5. 14.1. 15.1. 15.2. 15.10. 15.11. 15.13. 16.2. 17.3. 17.15. 18.1. 18.16. 20.10. 20.11.
item | 5.5. 7.2. 7.4. 11.3. 11.5. 13.5. 15.1. 20.11.
item-label | 6.1. 7.5. 10.1. 11.2. 17.11. 17.14. 18.17. 21.3.
label | 13.5. 15.9.
labeled-item | 5.5. 7.2. 7.4. 10.6. 11.3. 11.5. 13.5. 15.1. 20.11.
labeled-list | 1.2. 2.4. 2.19. 3.2. 3.9. 3.10. 3.11. 3.14. 6.4. 10.2. 10.4. 10.5. 11.2. 13.3. 16.3. 18.15. 18.16.
language | 1.6.
list | 1.2. 2.4. 2.19. 3.2. 3.9. 3.10. 3.11. 3.14. 6.4. 10.4. 10.5. 11.2. 13.3. 16.3. 18.15. 18.16.
locs | 12.6. 13.2.
long-name | 2.4. 2.5. 2.12. 2.13. 3.3. 3.20. 5.4. 7.2. 7.4. 10.1. 13.2. 15.7. 17.1. 18.1. 18.5. 18.15. 18.16. 18.17. 20.2. 20.8.
long-name-1 | 10.1. 17.10. 18.17. 21.1. 21.2.
main-title | 6.1. 7.5. 10.1. 16.7. 17.11. 17.14. 18.17. 21.3.
max | 15.8. 17.11. 17.14.
min | 15.8. 17.11. 17.14.
modification | 2.2. 12.5. 16.1.
modifications | 5.11. 12.4.
msrrep | 1.6. 11.6. 16.4. 16.5. 16.6. 17.6.
msrsw | I.
na | 1.3. 1.4. 5.6. 5.9. 8.1. 10.3. 14.1. 15.2. 15.10. 15.11. 15.13. 16.2. 17.3. 17.15. 20.10.
nameloc | 11.6. 11.7. 13.4. 17.6.
ncoi-1 | 1.3. 1.4. 2.4. 5.5. 5.6. 5.9. 7.2. 7.4. 10.3. 11.3. 11.5. 13.5. 14.1. 15.1. 15.2. 15.9. 15.10. 15.11. 15.13. 16.2. 17.1. 17.15. 18.1. 18.15. 20.11.
nmlist | 13.2.
note | 1.2. 2.4. 2.19. 3.2. 3.9. 3.10. 3.11. 3.14. 6.4. 10.4. 10.5. 11.1. 11.2. 13.3. 15.1. 16.3. 18.15. 18.16.
number | 21.1.
objectives | 8.1. 10.4. 13.1. 13.3. 18.2. 18.4.
overall-title | 6.1. 7.5. 10.1. 16.7. 17.11. 17.14. 18.17. 21.3.
p | 1.2. 2.4. 2.19. 3.2. 3.9. 3.10. 3.11. 3.14. 4.6. 5.3. 6.1. 6.4. 7.5. 10.1. 10.4. 10.5. 11.2. 13.3. 13.5. 16.3. 17.10. 17.11. 17.14. 18.15. 18.16. 18.17. 21.1. 21.2. 21.3.
parallel-designs | 8.1. 10.4. 13.1. 13.3. 18.2. 18.4.
phone | 18.5.
position | 17.10. 21.1.
private-code | 15.6.
private-codes | 4.1. 15.5.
prm | 5.8. 11.7. 15.8. 15.9. 17.6.
prm-char | 1.1. 4.6. 12.2. 12.3. 15.7. 16.3. 18.10. 18.14. 18.18. 19.1.
prms | 2.4. 2.19. 3.2. 3.9. 3.10. 3.11. 3.14. 11.1. 13.3. 15.7. 18.15.
project-schedule | 8.1. 10.4. 13.1. 13.3. 18.2. 18.4.
protocols | 8.1. 10.4. 13.1. 13.3. 18.2. 18.4.
publisher | 21.1.
purchasing-cond | 8.1. 10.4. 13.1. 13.3. 18.2. 18.4.
reason | 6.1. 7.5. 10.1. 12.4. 17.11. 17.14. 18.17. 21.3.
reason-order | 8.1. 10.4. 13.1. 13.3. 18.2. 18.4.
remark | 5.5. 7.2. 7.4. 11.3. 11.5. 13.5. 15.1. 15.8. 20.11.
report-body | 2.4. 2.5. 12.6.
report-head | 1.2. 2.4. 3.19. 12.6. 16.7.
report-rear | 2.4. 12.6.
report-subject | 12.1. 14.2. 16.5. 17.6. 17.12.
revision-label | 4.4.
role | 16.10.
roles | 16.9. 18.5.
row | 6.4. 18.3. 18.11. 18.13.
sample | 11.7. 13.3. 17.4. 17.6.
sample-ref | 17.5.
sample-spec | 8.1. 10.4. 13.1. 17.4. 18.2. 18.4.
samples | 17.1. 17.3.
schedule | 5.1. 17.2. 18.2.
short-name | 2.4. 2.5. 2.12. 2.13. 3.3. 3.20. 5.4. 7.2. 7.4. 12.6. 13.2. 15.7. 16.7. 17.1. 17.10. 18.1. 18.5. 18.15. 18.16. 20.2. 20.8. 21.1. 21.2.
spanspec | 18.12.
state | 4.4.
state-1 | 17.10. 21.1.
std | 5.2. 7.3. 11.8. 15.1. 15.4. 17.6. 17.9. 17.13. 18.4.
sub | 1.1. 2.2. 5.8. 10.1. 10.2. 10.6. 12.1. 12.2. 12.3. 14.2. 15.1. 16.1. 17.12. 18.4. 18.10. 18.14. 18.18. 19.1.
sub-title | 6.1. 7.5. 10.1. 16.7. 17.11. 17.14. 18.17. 21.3.
subtitle | 17.10.
sup | 1.1. 2.2. 5.8. 10.1. 10.2. 10.6. 12.1. 12.2. 12.3. 14.2. 15.1. 16.1. 17.12. 18.4. 18.10. 18.14. 18.18. 19.1.
system-overview | 8.1. 10.4. 13.1. 13.3. 18.2. 18.4.
table | 1.2. 2.4. 2.19. 3.2. 3.9. 3.10. 3.11. 3.14. 10.4. 11.7. 13.3. 17.6. 18.12. 18.15. 18.16.
tbd | 1.3. 1.4. 5.6. 5.8. 5.9. 8.1. 10.3. 14.1. 15.2. 15.10. 15.11. 15.13. 16.2. 17.3. 17.5. 17.15. 18.7. 20.10.
tbody | 16.11. 18.12.
tbr | 1.3. 1.4. 5.6. 5.9. 6.1. 7.5. 8.1. 10.1. 10.3. 14.1. 15.2. 15.10. 15.11. 15.13. 16.2. 17.3. 17.10. 17.11. 17.14. 17.15. 18.17. 20.10. 21.1. 21.2. 21.3.
team-member | 1.5. 3.16. 5.7. 6.2. 7.1. 9.1. 11.7. 15.3. 16.10. 17.6. 18.8. 22.1.
team-member-ref | 3.7. 5.11. 18.7.
team-member-refs | 18.2. 18.6.
team-members | 3.20. 18.5.
tex-math | 7.4.
text | 15.8. 17.11. 17.14.
tfoot | 3.18. 16.11. 18.12.
tgroup | 3.18. 17.7. 18.1. 18.3. 18.11. 18.13.
thead | 3.18. 16.11. 18.12.
tol | 15.8. 17.11. 17.14.
topic-1 | 2.4. 2.19. 3.2. 3.9. 3.10. 3.11. 3.14. 5.5. 7.2. 7.4. 11.3. 11.5. 11.7. 13.3. 13.5. 15.1. 15.9. 17.6. 18.1. 20.11.
topic-2 | 1.2. 5.5. 7.2. 7.4. 10.4. 11.3. 11.5. 11.7. 13.5. 15.1. 17.6. 18.1. 20.11.
tt | 2.2. 5.8. 10.2. 10.6. 11.7. 11.8. 12.1. 14.2. 15.1. 16.1. 17.12. 18.4.
typ | 15.8. 17.11. 17.14.
unit | 15.8. 17.11. 17.14.
used-languages | 1.6.
value | 20.6.
variant-char | 3.17. 11.7. 17.6. 20.7.
variant-char-assign | 20.4. 20.5. 20.6.
variant-char-assigns | 20.3. 20.8.
variant-char-ref | 20.3.
variant-char-value | 3.17. 20.1. 20.3.
variant-chars | 20.2. 20.10.
variant-def | 3.17. 11.7. 17.6. 20.4. 20.9.
variant-defs | 20.8. 20.10.
variant-spec | 8.1. 10.4. 13.1. 18.2. 18.4. 20.7. 20.9.
verbatim | 1.2. 2.4. 2.19. 3.2. 3.9. 3.10. 3.11. 3.14. 6.4. 7.2. 7.4. 10.4. 10.5. 11.2. 13.3. 16.3. 18.15. 18.16.
xdoc | 5.2. 7.3. 11.8. 13.6. 15.1. 15.4. 15.12. 17.6. 17.9. 18.4.
xfile | 7.3. 11.8. 15.1. 17.6. 18.4.
xref | 2.2. 5.8. 10.2. 10.6. 12.1. 14.2. 15.1. 16.1. 17.12. 18.4.
zip | 18.5.