Structure Principles of MSRNET.DTD

MSR Engineering Documentation (MEDOC)

Structure Principles of MSRNET.DTD
Scope: Automotive Networks
[ MSRNET-EADOC]
Revision: 3
This is a reference document for MSRSW DTD describing all elements.
MSRNET DTD is part of the MSR development documentation MEDOC.


I. How to read this document

Structure Principles of MSRNET.DTD
I. How to read this document

The following conventions apply
This document is written using MSRREP DTD. The following conventions apply to this document:
<msrsw> SGML elements are noted as technical term [type]=SGMLTAG.

[type] SGML attributes are noted as technical term [type]=SGML-attribute.

sgml-attribute Values of SGML attributes or discrete values for elements are noted as technical term [type]=code

ASAP2 The considered languages resp. DTDs are marked as technical term [type]=product.

ASAP The commitees are noted as [type]=organization

ECU Objects in general are marked as technical terms [type]=other. This might be automotive equipments general objects such as variables etc.

Graphical conventions used in DTD diagrams
The structure of DTDs is shown in the MSR document as DTD diagrams (see convention in DTD diagrams).
Figure 1: convention in DTD diagrams
The meaning of the symbols is:
PCDATA | Processable Character Data (PCDATA) Data that consists of zero or more characters of both text and markup. PCDATA is a declared content keyword. PCDATA is used to indicate that all markup delimiters defined in the SGML declaration will be recognized by the parser as markup in the given element rather than data characters.
RCDATA | Replaceable Character Data (RCDATA) is data that consists of zero or more characters, in which references to substitutions are not recognized (i.e. RCDATA may contain text and entity references, but no sub-elements). See also: CDATA PCDATA.
CDATA | Character Data (CDATA) consists of zero or more text characters, where no markup of any kind is recognized. CDATA is an SGML term. Note that character references are allowed in a CDATA entity (substitution) but not in CDATA content.
ANY | a terminal type indicating that the object may contain text or any element defined in the model.
EMPTY | a terminal type keyword used to indicate that there is no data (i.e. no content, sub-elements or end-tags) for the object allowed in the document instance. This keyword is often used to describe elements that are placeholders or are pointers to external or system-generated data.
One | indicates that the element or the element group occurs exactly once
ZERO-OR-ONE | indicates that the element or the element group is optional
ONE-OR-MORE | indicates that the element or the element group occurs multiple times but at least once
ZERO-OR-MORE | indicates that the element or the element group occurs multiple times but also can be missed (optional)
ORDERED | a connector used to specify that the sibling objects must appear in the document in the order shown in the model
UNORDERED | a connector used to specify that the sibling objects can appear in any order in the document.
SELECTION | a connector used to specify that only one of the sibling objects can appear in the document.
ELEMENT | indicates a single SGML structure element
COLLAPSED | indicates, that the content of the element is not displayed here


II. Allgemeine Projektdaten

Structure Principles of MSRNET.DTD
II. Allgemeine Projektdaten


1. ABS ... ADMIN-DATA

Structure Principles of MSRNET.DTD
1. ABS ... ADMIN-DATA

Contents of this chapter:
  • 1.1. ABS
  • 1.2. ACCEPTANCE-COND
  • 1.3. ADD-INFO
  • 1.4. ADD-SPEC
  • 1.5. ADDRESS
  • 1.6. ADMIN-DATA


1.1. ABS

Figure 2: DTD-diagram for ABS
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for ABS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Absolute value for parameter characteristics. See parameter model (<sw-prm>).

Example
<prm>
   <long-name>long designation</long-name>
   <short-name>short designation</short-name>
   <prm-char>
      <abs>10</abs>
      <tol>5<tol>
      <unit>oC</unit>
   </prm-char>
</prm>
<prm>
   <long-name>long designation</long-name>
   <short-name>short designation</short-name>
   <prm-char>
      <min>0</min>
      <typ>5<typ>
      <max>0</max>
      <unit>oC</unit>
   </prm-char>
</prm>
Description This element defines an absolute value which is adjusted or measured.


1.2. ACCEPTANCE-COND

Figure 3: DTD-diagram for ACCEPTANCE-COND
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for ACCEPTANCE-COND
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains a description of the acceptance conditions of this project.


1.3. ADD-INFO

Figure 4: DTD-diagram for ADD-INFO
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <interface-circuit> <net-interface-spec> <net-message> <net-signal-spec> <net-signal-spec-variant> <transmission-spec>
Attributes for ADD-INFO
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Additional information (which is not covered by the existing structure) can be given in this element. In opposite to <add-spec>, <add-info> complements an existing structure, whild <add-spec> is used where no structure exists at all.

Example
<sw-function-variant>
     ...
   <add-info>
      <prms>
         <prm>
            <long-name>program-language</long-name>
            <short-name>program-language</short-name>
            <prm-char><text>ASS</text>
            </prm-char>
         </prm>
      </prms>
   </add-info>
</sw-function-variant>
Description This element allows the author to make additional informations in form of parameter models for tests.


1.4. ADD-SPEC

Figure 5: DTD-diagram for ADD-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data> <msrnet> <net-architecture> <net-oper-spec> <net-topology-spec>
Attributes for ADD-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element allows to give additional specifications for which no explicit structure exists. This element usually enforces another chapter in printed material. In opposite to <add-info>, <add-spec> is used as a substitute if no structure exists for the topic, while <add-info> is used where an existing structure is not appropriate.

Example
Description This chapter allows the author to define additional specifications.


1.5. ADDRESS

Figure 6: DTD-diagram for ADDRESS
Child elements | none
parent elements | <team-member>
Attributes for ADDRESS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of the address of a team member.


1.6. ADMIN-DATA

Figure 7: DTD-diagram for ADMIN-DATA
Child elements | <language> <used-languages> <company-doc-infos> <doc-revisions>
parent elements | <chapter> <connection-comp-1> <connection-comp-spec-1> <general-net-spec> <general-project-data> <msrnet> <net-architecture> <net-interface-spec> <net-message-spec> <net-oper-spec> <net-signal-spec> <net-topology-spec> <sw-compu-method> <sw-compu-methods> <sw-unit> <sw-units>
Attributes for ADMIN-DATA
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | language:selection |
[S] | cdata | implied |  |
Description This element allows to specifiy adminstrative information regarding the substructure defined by the parent. This information may be versioning, fragmentation etc. The information rather covers the administration of the SGML-instance than the administration of the described subjects.

Example
<admin-data>
   <language>de</language>
   <doc-revisions>
      <doc-revision>
         <company-revision-infos>
            <company-revision-info>
               <company-ref>msr</company-ref>
               <revision-label>10.4</revision-label>
               <state>wd</state>
            </company-revision-info>
         </company-revision-infos>
         <team-member-ref></team-member-ref>
         <date>1.1.99</date>
         <modifications>
            <modification type="part-related">
               <change>Introduced new Architecture</change>
               <reason>Customer request</reason>
            </modification>
         </modifications>
      </doc-revision>
   </doc-revisions>
</admin-data>
Description Definition of the administrative data of this document fragment.


2. BAUDRATE ... BYTE-ORDER

Structure Principles of MSRNET.DTD
2. BAUDRATE ... BYTE-ORDER

Contents of this chapter:
  • 2.1. BAUDRATE
  • 2.2. BITSIZE
  • 2.3. BTL-CYCLES
  • 2.4. BYTE-ORDER


2.1. BAUDRATE

Figure 8: DTD-diagram for BAUDRATE
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <net-interface-prms>
Attributes for BAUDRATE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |


2.2. BITSIZE

Figure 9: DTD-diagram for BITSIZE
Child elements | none
parent elements | <multiplexor> <net-signal-spec-variant>
Attributes for BITSIZE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


2.3. BTL-CYCLES

Figure 10: DTD-diagram for BTL-CYCLES
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <net-interface-prms>
Attributes for BTL-CYCLES
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |


2.4. BYTE-ORDER

Figure 11: DTD-diagram for BYTE-ORDER
Child elements | none
parent elements | <net-message>
Attributes for BYTE-ORDER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


3. C-CODE ... COMPANY-REVISION-INFOS

Structure Principles of MSRNET.DTD
3. C-CODE ... COMPANY-REVISION-INFOS

Contents of this chapter:
  • 3.1. C-CODE
  • 3.2. CALC-NET-MESSAGE-IDENTIFIERS
  • 3.3. CHANGE
  • 3.4. CHAPTER
  • 3.5. CITY
  • 3.6. CMT-INT
  • 3.7. CMT-PHYS
  • 3.8. CMT-TEXT
  • 3.9. CODE
  • 3.10. CODED
  • 3.11. CODED-MAX
  • 3.12. CODED-MIN
  • 3.13. COLSPEC
  • 3.14. COMPANIES
  • 3.15. COMPANY
  • 3.16. COMPANY-DOC-INFO
  • 3.17. COMPANY-DOC-INFOS
  • 3.18. COMPANY-REF
  • 3.19. COMPANY-REVISION-INFO
  • 3.20. COMPANY-REVISION-INFOS


3.1. C-CODE

Figure 12: DTD-diagram for C-CODE
Child elements | none
parent elements | <formula>
Attributes for C-CODE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element is used to specify the code of the formula transferred to the programming language C.


3.2. CALC-NET-MESSAGE-IDENTIFIERS

Figure 13: DTD-diagram for CALC-NET-MESSAGE-IDENTIFIERS
Child elements | <identifier-base-address> <senders>
parent elements | <net-message>
Attributes for CALC-NET-MESSAGE-IDENTIFIERS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


3.3. CHANGE

Figure 14: DTD-diagram for CHANGE
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <modification>
Attributes for CHANGE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description More or less detailled description of the performed changes can be given here.

Example
<modification>
   <change>element description inserted</change>
   <reason>for better understanding</reason>
</modification>
Description Describes the change of a document


3.4. CHAPTER

Figure 15: DTD-diagram for CHAPTER
Child elements | <long-name> <short-name> <admin-data> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <add-info> <chapter> <driver-concept> <ncoi-1> <net-emc-design> <net-line-desc> <net-message-desc> <net-message-layout> <segmentation-desc>
Attributes for CHAPTER
Name | Type | Class | Value | Remark
[BREAK] | nmtkgrp | implied | BREAK NO-BREAK |
[F-ID-CLASS] | name | fixed | CHAPTER |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description <chapter> is used to put a presentation structure on prose descriptions. Chapters can be structured hierachically.

Example
<chapter id="ch1" help-entry="chapter">
   <long-name>Chapter1</long-name>
   <short-name></short-name>
   <p>This is the text in the chapter.</p>
   <figure id="fig1" help-entry="synopic diagram"><
      long-name>principal circuit diagram</long-name>
          <short-name>psb</short-name>
          <graphic filename="bild.bmp" notation="eps"></graphic>
   </figure>
   <chapter id="ch11">
      <long-name>Chapter 1.1</long-name>
          <short-name></short-name>
          <p></p>
          <p></p>
   </chapter>
</chapter>
Description This element is used to write one or more not content oriented chapters. There are also sub chapters possible.


3.5. CITY

Figure 16: DTD-diagram for CITY
Child elements | none
parent elements | <team-member>
Attributes for CITY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of the city of the address.


3.6. CMT-INT

Figure 17: DTD-diagram for CMT-INT
Child elements | none
parent elements | <sw-compu-method-text-pair> <sw-compu-method-value-pair>
Attributes for CMT-INT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Internal value for a conversion formula

Example
<sw-compu-method-text>
   <sw-compu-method-text-pair>
      <cmt-int>0</cmt-int>
      <cmt-text>Heck</cmt-text>
   </cmt-compu-method-text-pair>
</sw-compu-method-text>


3.7. CMT-PHYS

Figure 18: DTD-diagram for CMT-PHYS
Child elements | none
parent elements | <sw-compu-method-value-pair>
Attributes for CMT-PHYS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Physical value for a conversion formula defined as conversion table.

Example
<sw-compu-method-table>
   <sw-compu-method-value-pair>
      <cmt-int>0</cmt-int>
      <cmt-phys>11</cmt-phys>
   </cmt-compu-method-value-pair>
</sw-compu-method-table


3.8. CMT-TEXT

Figure 19: DTD-diagram for CMT-TEXT
Child elements | none
parent elements | <sw-compu-method-text-pair>
Attributes for CMT-TEXT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Value in text form for a conversion formula.

Example
<sw-compu-method-text>
   <sw-compu-method-text-pair>
      <cmt-int>0</cmt-int>
      <cmt-text>Heck</cmt-text>
   </cmt-compu-method-text-pair>
</sw-compu-method-text>


3.9. CODE

Figure 20: DTD-diagram for CODE
Child elements | none
parent elements | <variant-char> <variant-char-value> <variant-def>
Attributes for CODE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description The definition of variants end up in code names for variants resp. for variant characteristics resp. for values of variant characteristics. <code> takes these names. This code may be a number as well as a name.

Example
<code>007</code>
Description This element contains the definition of the code.


3.10. CODED

Figure 21: DTD-diagram for CODED
Child elements | <coded-min> <coded-max>
parent elements | <sw-limits> <sw-limits>
Attributes for CODED
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Coded/internal values for limits.

Example
<sw-limits>
   <coded>
      <coded-min>0</coded-min>
      <coded-max>255</coded-max>
   </coded>
   <phys>
      <phys-min>0</phys-min>
      <phys-max>90</phys-max></phys>
</sw-limits>


3.11. CODED-MAX

Figure 22: DTD-diagram for CODED-MAX
Child elements | none
parent elements | <coded>
Attributes for CODED-MAX
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Maximum coded limiting value

Example
<coded-max>255</coded-max>


3.12. CODED-MIN

Figure 23: DTD-diagram for CODED-MIN
Child elements | none
parent elements | <coded>
Attributes for CODED-MIN
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Minimum coded limiting value

Example
<coded-min>0</coded-min>


3.13. COLSPEC

Figure 24: DTD-diagram for COLSPEC
Child elements | none
parent elements | <tfoot> <tgroup> <thead>
Attributes for COLSPEC
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | implied | LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | implied |  |
[CHAROFF] | nutoken | implied |  |
[COLNAME] | nmtoken | implied |  |
[COLNUM] | number | implied |  |
[COLSEP] | number | implied |  |
[COLWIDTH] | cdata | implied |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
Description Specifies a column, a vertical portion of a <entry>. The default values come from the <tgroup>, <thead> or <tfoot> starting the current group. Each <colspec> is for a single column, so it properly has a column number, column, implicitly in order starting from 1, and an optional colname by which it is known when used in any <spanspec> or in <entry>. A <colspec> set on <thead or <tfoot> should be complete for all columns. It overrides those on the containing <tgroup> and applies to just the <thead> or <tfoot>. If there is no <colspec> used within <thead> or <tfoot>, then the <colspec> of the containing <tgroup> is used. <colspec>s from the containing <tgroup> apply to <tbody>.


3.14. COMPANIES

Figure 25: DTD-diagram for COMPANIES
Child elements | <company>
parent elements | <project>
Attributes for COMPANIES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Gets information about all companies participating in the project in question.

Example
<companies>
   <company role="supplier" id="bosch"></company>
   <company role="manufacturer" id="vw"></company>
</companies>
Description Definitions of some companies.


3.15. COMPANY

Figure 26: DTD-diagram for COMPANY
Child elements | <long-name> <short-name> <team-members> <general-project-data>
parent elements | <companies>
Attributes for COMPANY
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | long-name:selection |
[F-ID-CLASS] | name | fixed | COMPANY |
[F-NAMESPACE] | names | fixed | SAMPLE TEAM-MEMBER VARIANT-DEF VARIANT-CHAR |
[ID] | id | required |  |
[ROLE] | nmtkgrp | required | MANUFACTURER SUPPLIER |
[S] | cdata | implied |  |
Description Company-spefic details for a company participating in the project

Example
<company role="supplier" id="rb">
   <long-name>Robert Bosch GmbH</long-name>
   <short-name>rb</short-name>
   <team-members>
      <team-member id="ge"></team-member>
   </team-members><
   general-project-data></general-project-data>
</company>
Description Definition of a company with all team members for this project.


3.16. COMPANY-DOC-INFO

Figure 27: DTD-diagram for COMPANY-DOC-INFO
Child elements | <company-ref> <doc-label> <private-codes> <entity-name>
parent elements | <company-doc-infos>
Attributes for COMPANY-DOC-INFO
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element takes company specific information about a document resp. a subpart of a document.

Example
<company-doc-info>
   <company-ref company="id0815">msr</company-ref>
   <doc-label>Programmstand</doc-label>
   <private-codes>1.1</private-codes>
   <entity-name>P11.sgm</entity-name>
</company-doc-info>
Description Company specific document informations.


3.17. COMPANY-DOC-INFOS

Figure 28: DTD-diagram for COMPANY-DOC-INFOS
Child elements | <company-doc-info>
parent elements | <admin-data>
Attributes for COMPANY-DOC-INFOS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Company-specific information for administrative data

Example
Description Company specific document information.


3.18. COMPANY-REF

Figure 29: DTD-diagram for COMPANY-REF
Child elements | none
parent elements | <company-doc-info> <company-revision-info>
Attributes for COMPANY-REF
Name | Type | Class | Value | Remark
[COMPANY] | idref | required |  |
[HYNAMES] | names | fixed | LINKEND COMPANY |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
Description Reference to a company. The semantic of the reference is given by the context.

Example
<company-revision-info>
   <company-ref company="id0815">msr</company-ref>
   ...
</company-revision-info>
Description Reference to a company (supplier).


3.19. COMPANY-REVISION-INFO

Figure 30: DTD-diagram for COMPANY-REVISION-INFO
Child elements | <company-ref> <revision-label> <state> <introduction>
parent elements | <company-revision-infos>
Attributes for COMPANY-REVISION-INFO
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | state:selection |
[S] | cdata | implied |  |
Description Company-specific information concerning a certain revision of the document.

Example
<company-revision-info>
   <company-ref company="rb">rb</company-ref>
   <revision-label>15.4</revision-label>
   <state>freigegeben</state>
</company-revision-info>
Description Company specific document revision.


3.20. COMPANY-REVISION-INFOS

Figure 31: DTD-diagram for COMPANY-REVISION-INFOS
Child elements | <company-revision-info>
parent elements | <doc-revision>
Attributes for COMPANY-REVISION-INFOS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Collection of all company specific revision information on an entity or a fragment.

Example
Description Company specific document revisions.


4. COND ... CYCLE-TIME

Structure Principles of MSRNET.DTD
4. COND ... CYCLE-TIME

Contents of this chapter:
  • 4.1. COND
  • 4.2. CONNECTION-COMP-1
  • 4.3. CONNECTION-COMP-CLASS
  • 4.4. CONNECTION-COMP-PRMS
  • 4.5. CONNECTION-COMP-REF
  • 4.6. CONNECTION-COMP-SPEC-1
  • 4.7. CONNECTION-COMPS-1
  • 4.8. CYCLE-TIME


4.1. COND

Figure 32: DTD-diagram for COND
Child elements | <p>
parent elements | <prm-char>
Attributes for COND
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Condition for parameters. This condition is given as informal description.

Example
<prm>
   <long-name>Temperatur</long-name>
   <short-name>temp/short-name>
   <prm-char>
      <cond><p>valid if  x <  20</p></cond>
      <abs>10</abs>
      <tol>5<tol>
      <unit>oC</unit>
   </prm-char>
</prm>
Description Defines specific conditions under this parameter characteristic is allowed.


4.2. CONNECTION-COMP-1

Figure 33: DTD-diagram for CONNECTION-COMP-1
Child elements | <admin-data> <long-name> <short-name> <part-number> <drawing-number> <connection-comp-class> <desc> <connection-comp-prms> <ncoi-3>
parent elements | <connection-comps-1>
Attributes for CONNECTION-COMP-1
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | drawing-number:drawing-number#part-number:part-number#connection-comp-class:selection |
[F-ID-CLASS] | name | fixed | CONNECTION-COMP |
[ID] | id | required |  |
[S] | cdata | implied |  |


4.3. CONNECTION-COMP-CLASS

Figure 34: DTD-diagram for CONNECTION-COMP-CLASS
Child elements | none
parent elements | <connection-comp-1>
Attributes for CONNECTION-COMP-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Spcification of the class of a connection component.


4.4. CONNECTION-COMP-PRMS

Figure 35: DTD-diagram for CONNECTION-COMP-PRMS
Child elements | <prm>
parent elements | <connection-comp-1>
Attributes for CONNECTION-COMP-PRMS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element describes the parameter of a connection component.


4.5. CONNECTION-COMP-REF

Figure 36: DTD-diagram for CONNECTION-COMP-REF
Child elements | none
parent elements | <segment> <segmentation-spec>
Attributes for CONNECTION-COMP-REF
Name | Type | Class | Value | Remark
[CONNECTION-COMP] | idref | required |  |
[HYNAMES] | names | fixed | LINKEND CONNECTION-COMP |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
Description Reference to a connection component.


4.6. CONNECTION-COMP-SPEC-1

Figure 37: DTD-diagram for CONNECTION-COMP-SPEC-1
Child elements | <na> <tbd> <tbr> <admin-data> <introduction> <connection-comps-1>
parent elements | <net-architecture>
Attributes for CONNECTION-COMP-SPEC-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


4.7. CONNECTION-COMPS-1

Figure 38: DTD-diagram for CONNECTION-COMPS-1
Child elements | <connection-comp-1>
parent elements | <connection-comp-spec-1>
Attributes for CONNECTION-COMPS-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


4.8. CYCLE-TIME

Figure 39: DTD-diagram for CYCLE-TIME
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <transmission-prms>
Attributes for CYCLE-TIME
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |


5. DATE ... DRIVER-CONCEPT

Structure Principles of MSRNET.DTD
5. DATE ... DRIVER-CONCEPT

Contents of this chapter:
  • 5.1. DATE
  • 5.2. DATE-1
  • 5.3. DEF
  • 5.4. DEF-ITEM
  • 5.5. DEF-LIST
  • 5.6. DEMARCATION-OTHER-PROJECTS
  • 5.7. DEPARTMENT
  • 5.8. DESC
  • 5.9. DIR-HAND-OVER-DOC-DATA
  • 5.10. DLC
  • 5.11. DOC-LABEL
  • 5.12. DOC-REVISION
  • 5.13. DOC-REVISIONS
  • 5.14. DRAWING-NUMBER
  • 5.15. DRIVER-CONCEPT


5.1. DATE

Figure 40: DTD-diagram for DATE
Child elements | none
parent elements | <doc-revision> <schedule>
Attributes for DATE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Date information according to local rules resp. agreed standards. If the DTD is configured multilingual, the date can be specified in multiple languages.

Example
<date>23.11.1998</date>
or as an international date
<date>1998-11-23</date>
Description Specifies a date. The specification of the date is only possible in one language. - last handling - publishing - creation.


5.2. DATE-1

Figure 41: DTD-diagram for DATE-1
Child elements | none
parent elements | <std> <xdoc>
Attributes for DATE-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Date information according to local rules resp. agreed standards. Even if the DTD is configured multilingual, the date can not be specified in multiple languages.

Description With this element it is possible to specify a date in several languages.


5.3. DEF

Figure 42: DTD-diagram for DEF
Child elements | <p>
parent elements | <def-item>
Attributes for DEF
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This is a element of an definition list


5.4. DEF-ITEM

Figure 43: DTD-diagram for DEF-ITEM
Child elements | <long-name> <short-name> <def>
parent elements | <def-list>
Attributes for DEF-ITEM
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | DEF-ITEM |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Null


5.5. DEF-LIST

Figure 44: DTD-diagram for DEF-LIST
Child elements | <def-item>
parent elements | <add-info> <chapter> <driver-concept> <entry> <introduction> <item> <labeled-item> <ncoi-1> <ncoi-3> <net-emc-design> <net-line-desc> <net-message-desc> <net-message-layout> <remark> <segmentation-desc> <topic-1> <topic-2>
Attributes for DEF-LIST
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element allows the user to define a list.


5.6. DEMARCATION-OTHER-PROJECTS

Figure 45: DTD-diagram for DEMARCATION-OTHER-PROJECTS
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for DEMARCATION-OTHER-PROJECTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Informal description of relationship to similar projects.

Description Specifies the demarcation and differences to other projects.


5.7. DEPARTMENT

Figure 46: DTD-diagram for DEPARTMENT
Child elements | none
parent elements | <team-member>
Attributes for DEPARTMENT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Department of the <team-member>

Description This element contains the name of the department.


5.8. DESC

Figure 47: DTD-diagram for DESC
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <baudrate> <btl-cycles> <connection-comp-1> <cycle-time> <figure> <latency-time> <net-node-port> <overall-project> <phase-relations> <powerdown-receive-time> <powerup-receive-time> <powerup-transmit-time> <prm> <project> <sample-point> <sample-rate> <segment-length> <sjw> <sync-edge> <tbd>
Attributes for DESC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Informal, concise description of the subject in question. This is ususally one or two senctences.

Example
<sw-variable calibration="no-calibration" f-id-class="sw-variable" f-namespace="sw-variable">
   <long-name>engine temperature</long-name>
   <short-name>tmot</short-name>
   <desc>The engine temeprature is stored in this variable</desc>
   ...
</sw-variable>
Description Short text description of the object.


5.9. DIR-HAND-OVER-DOC-DATA

Figure 48: DTD-diagram for DIR-HAND-OVER-DOC-DATA
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for DIR-HAND-OVER-DOC-DATA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Directory of all documents which are hand-over the project-partner.


5.10. DLC

Figure 49: DTD-diagram for DLC
Child elements | none
parent elements | <net-message>
Attributes for DLC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


5.11. DOC-LABEL

Figure 50: DTD-diagram for DOC-LABEL
Child elements | none
parent elements | <company-doc-info>
Attributes for DOC-LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This is the label of the document, serving as a company specific title or name of the document.

Example
Description Name of the document


5.12. DOC-REVISION

Figure 51: DTD-diagram for DOC-REVISION
Child elements | <company-revision-infos> <team-member-ref> <date> <modifications>
parent elements | <doc-revisions>
Attributes for DOC-REVISION
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | date:date |
[S] | cdata | implied |  |
Description This element gets all information of the document revision in question.

Example
Description This element describes a document revision


5.13. DOC-REVISIONS

Figure 52: DTD-diagram for DOC-REVISIONS
Child elements | <doc-revision>
parent elements | <admin-data>
Attributes for DOC-REVISIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This is the collection of all known revisions of the document thus establishing the revision history. It is highly recommended that the most actual revision is on top.

Description This element describes the document revisions


5.14. DRAWING-NUMBER

Figure 53: DTD-diagram for DRAWING-NUMBER
Child elements | none
parent elements | <connection-comp-1>
Attributes for DRAWING-NUMBER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element defines the drawing number.


5.15. DRIVER-CONCEPT

Figure 54: DTD-diagram for DRIVER-CONCEPT
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <net-interface-spec>
Attributes for DRIVER-CONCEPT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


6. E ... ERROR-VALUES

Structure Principles of MSRNET.DTD
6. E ... ERROR-VALUES

Contents of this chapter:
  • 6.1. E
  • 6.2. EMAIL
  • 6.3. ENTITY-NAME
  • 6.4. ENTRY
  • 6.5. ERROR-VALUE
  • 6.6. ERROR-VALUES


6.1. E

Figure 55: DTD-diagram for E
Child elements | none
parent elements | <change> <desc> <indent-sample> <item-label> <p> <reason> <tbr>
Attributes for E
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | nmtkgrp | default | BOLD BOLD ITALIC |
Description Identifies the scope of emphasized information.


6.2. EMAIL

Figure 56: DTD-diagram for EMAIL
Child elements | none
parent elements | <team-member>
Attributes for EMAIL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of the email-address.


6.3. ENTITY-NAME

Figure 57: DTD-diagram for ENTITY-NAME
Child elements | none
parent elements | <company-doc-info>
Attributes for ENTITY-NAME
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Filename of the document fragment (if there is one). This is used to divide a document in multiple entities. SGML tools do not reflect this (physical) fragmentation on a logical level. Therefore, it must be entered manually here.

Description Filename of the document fragment.


6.4. ENTRY

Figure 58: DTD-diagram for ENTRY
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <row>
Attributes for ENTRY
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | implied | LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | implied |  |
[CHAROFF] | nutoken | implied |  |
[COLNAME] | nmtoken | implied |  |
[COLSEP] | number | implied |  |
[MOREROWS] | number | default | 0 |
[NAMEEND] | nmtoken | implied |  |
[NAMEST] | nmtoken | implied |  |
[ROTATE] | number | default | 0 |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[SPANNAME] | nmtoken | implied |  |
[VALIGN] | nmtkgrp | default | TOP TOP BOTTOM MIDDLE |
Description Identifies an entry in a table. Default values come from the <table>, <tgroup>, <colspec>, <spanspec>, <thead>, <tbody> or <row>; attributes. An entry not specified by a <spanspec> get the defaults from its starting column.


6.5. ERROR-VALUE

Figure 59: DTD-diagram for ERROR-VALUE
Child elements | none
parent elements | <error-values>
Attributes for ERROR-VALUE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


6.6. ERROR-VALUES

Figure 60: DTD-diagram for ERROR-VALUES
Child elements | <error-value>
parent elements | <net-signal-spec-variant>
Attributes for ERROR-VALUES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


7. FAX ... FT

Structure Principles of MSRNET.DTD
7. FAX ... FT

Contents of this chapter:
  • 7.1. FAX
  • 7.2. FIGURE
  • 7.3. FILE
  • 7.4. FORMULA
  • 7.5. FT


7.1. FAX

Figure 61: DTD-diagram for FAX
Child elements | none
parent elements | <team-member>
Attributes for FAX
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Contents the fax number of an address.


7.2. FIGURE

Figure 62: DTD-diagram for FIGURE
Child elements | <long-name> <short-name> <graphic> <verbatim> <desc>
parent elements | <add-info> <chapter> <driver-concept> <entry> <interface-circuit> <introduction> <item> <labeled-item> <ncoi-1> <ncoi-3> <net-emc-design> <net-line-desc> <net-message-desc> <net-message-layout> <net-topology-spec> <remark> <segmentation-desc> <topic-1> <topic-2>
Attributes for FIGURE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FIGURE |
[FLOAT] | nmtkgrp | implied | FLOAT NO-FLOAT |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Graphics can be linked using this element.

Example
Description Identifies a figure in the document.


7.3. FILE

Figure 63: DTD-diagram for FILE
Child elements | none
parent elements | <std> <xdoc> <xfile>
Attributes for FILE
Name | Type | Class | Value | Remark
[FILENAME] | cdata | required |  |
[NOTATION] | cdata | required |  |
[S] | cdata | implied |  |
[TOOL] | cdata | required |  |
[TOOL-VERSION] | cdata | required |  |
Description Information on a file name for referencing an external file (e.g. a standard). With respect to the limited capabilites of SGML's entity and notation mechanism this is not used here.

Example
<file filename="agr.bmp" notation="eps" tool="ascet" tool-version="sd"></file>
Description Definition of a filename (complete path).


7.4. FORMULA

Figure 64: DTD-diagram for FORMULA
Child elements | <long-name> <short-name> <graphic> <verbatim> <tex-math> <c-code> <generic-math>
parent elements | <add-info> <chapter> <driver-concept> <entry> <introduction> <item> <labeled-item> <ncoi-1> <ncoi-3> <net-emc-design> <net-line-desc> <net-message-desc> <net-message-layout> <remark> <segmentation-desc> <topic-1> <topic-2>
Attributes for FORMULA
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FORMULA |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Null


7.5. FT

Figure 65: DTD-diagram for FT
Child elements | none
parent elements | <change> <desc> <indent-sample> <item-label> <p> <reason> <tbr>
Attributes for FT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Identifies the body of a footnote in the document.


8. GENERAL-NET-SPEC ... GRAPHIC

Structure Principles of MSRNET.DTD
8. GENERAL-NET-SPEC ... GRAPHIC

Contents of this chapter:
  • 8.1. GENERAL-NET-SPEC
  • 8.2. GENERAL-PROJECT-DATA
  • 8.3. GENERIC-MATH
  • 8.4. GRAPHIC


8.1. GENERAL-NET-SPEC

Figure 66: DTD-diagram for GENERAL-NET-SPEC
Child elements | <admin-data> <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <msrnet>
Attributes for GENERAL-NET-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


8.2. GENERAL-PROJECT-DATA

Figure 67: DTD-diagram for GENERAL-PROJECT-DATA
Child elements | <na> <tbd> <tbr> <admin-data> <introduction> <system-overview> <reason-order> <objectives> <sample-spec> <variant-spec> <demarcation-other-projects> <parallel-designs> <integration-capability> <acceptance-cond> <project-schedule> <purchasing-cond> <protocols> <dir-hand-over-doc-data> <add-spec>
parent elements | <company>
Attributes for GENERAL-PROJECT-DATA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description General project data.

Example
Description Specification of all general project data.


8.3. GENERIC-MATH

Figure 68: DTD-diagram for GENERIC-MATH
Child elements | none
parent elements | <formula>
Attributes for GENERIC-MATH
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element is inteded for the definition of semantic math description which can be processed by math processors. Acutally there is no recommendation for the language of the formula specification or usage of a special rendering system.

Example
Description Null


8.4. GRAPHIC

Figure 69: DTD-diagram for GRAPHIC
Child elements | none
parent elements | <figure> <formula>
Attributes for GRAPHIC
Name | Type | Class | Value | Remark
[CATEGORY] | nmtkgrp | implied | BARCODE CONCEPTUAL ENGINEERING FLOWCHART GRAPH LOGO SCHEMATIC WAVEFORM |
[FILENAME] | cdata | required |  |
[FIT] | number | default | 0 |
[HEIGHT] | cdata | implied |  |
[NOTATION] | cdata | required |  |
[S] | cdata | implied |  |
[SCALE] | cdata | implied |  |
[WIDTH] | cdata | implied |  |
Description The treatment of the graphic is determined by the attributes of <graphic>:

Do not enter annotating text to <long-name>in<figure> or <table>(like Figure 1: ...). This embellishment is the task of the processing system, not of the author. If the author adds these things, they will be there twice since the rendition system will add it again.
[category]
Denotes the category of the graphic. This information can be used to generate more specific list of figures
[filename]
Denotes the system filename where the rendition system can find the graphic. This is not necessarily the final format. It is up to the rendition system to locate the graphic in the company specific environment, to change the file extension to get the appropriate graphic representation.
The type of this attribute can be turned from SDATA toENTITY in the DTD file in order to allow SGML tools access to the file using its entity manager. In this case, the entity name should be chosen in the style of a filename (e.g. crpctmt.wmf) [image] .
[fit]

0 | figure is placed in original size. If it does not fit on the page or the available space, it is scaled down.
1 | the figure is scaled up or down to fit the page as possible. This value will be ignored if [width] or [height] is specified in addition.
2 | the figure is rotated counterclockwise by 90o if it is landscape and is wider than the actual text area. It is scaled down to the page size if it does not fit otherwise. This value will be ignored if [width] or [height] is specified in addition.
3 | the figure is always rotated counterclockwise by 90o. If it does not fit on the page it will be scaled down. If [width] or [height] is specified in addition, the figure will be rotated and then scaled to the specified values.
4 | the figure is always rotated counterclockwise by 90o and scaled up or down for best fit on the page. This value will be ignored if [width] or [height] is specified in addition.
[height]
If this attribute has a value, the figure will be scaled to the defined height which is a real value with dimensions (e.g. "10cm", "150mm", "12.5in"). If also [width]is specified the figure will be distorted. This value always specifies the width of the "figure box" on the page after possible scaling/rotating.
[notation]
This attribute specifies the format of the graphic file if used by an SGML Application supporting notations.
[scale]
If this attribute receives a value, the figure will be scaled by the given factor which must be a signed real number. Numbers greater 1 increase the size of the figure, values less than 1 make the figure smaller. For example with scale="0.5" the a figure of the size 10x10 cm will appear as 5*5cm.
[width]
If this attribute has a value, the figure will be scaled to the defined width which is a real value with dimensions (e.g. "10cm", "150mm", "12.5in"). If also [height]is specified the figure will be distorted. This value always specifies the width of the "figure box" on the page after possible scaling/rotating.
The scaling attribute precedence is:
  • [scale] has precedence over all
  • [fit]has precedence over [width]and/or [height]
Example
<graphic filename="ggub.bmp" notation="eps"></graphic>
Description Identifies a graphic. A graphic is stored in difference formats (notation attribute) and is used as an illustration in the document.

This is the way how this document is prepared. It is visible in the sgml source.


9. HOMEPAGE ... HOMEPAGE

Structure Principles of MSRNET.DTD
9. HOMEPAGE ... HOMEPAGE

Contents of this chapter:
  • 9.1. HOMEPAGE


9.1. HOMEPAGE

Figure 70: DTD-diagram for HOMEPAGE
Child elements | none
parent elements | <team-member>
Attributes for HOMEPAGE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Homepage of a team member


10. IDENTIFIER ... ITEM-LABEL

Structure Principles of MSRNET.DTD
10. IDENTIFIER ... ITEM-LABEL

Contents of this chapter:
  • 10.1. IDENTIFIER
  • 10.2. IDENTIFIER-BASE-ADDRESS
  • 10.3. IDENTIFIER-MASK
  • 10.4. IDENTIFIER-TYPE
  • 10.5. IE
  • 10.6. INDENT-SAMPLE
  • 10.7. INIT-VALUE
  • 10.8. INTEGRATION-CAPABILITY
  • 10.9. INTERFACE-CIRCUIT
  • 10.10. INTRODUCTION
  • 10.11. ITEM
  • 10.12. ITEM-LABEL


10.1. IDENTIFIER

Figure 71: DTD-diagram for IDENTIFIER
Child elements | none
parent elements | <net-message-identifier>
Attributes for IDENTIFIER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


10.2. IDENTIFIER-BASE-ADDRESS

Figure 72: DTD-diagram for IDENTIFIER-BASE-ADDRESS
Child elements | none
parent elements | <calc-net-message-identifiers>
Attributes for IDENTIFIER-BASE-ADDRESS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


10.3. IDENTIFIER-MASK

Figure 73: DTD-diagram for IDENTIFIER-MASK
Child elements | none
parent elements | <net-message>
Attributes for IDENTIFIER-MASK
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


10.4. IDENTIFIER-TYPE

Figure 74: DTD-diagram for IDENTIFIER-TYPE
Child elements | none
parent elements | <net-message>
Attributes for IDENTIFIER-TYPE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


10.5. IE

Figure 75: DTD-diagram for IE
Child elements | <sup> <sub>
parent elements | <change> <desc> <indent-sample> <item-label> <long-name> <long-name-1> <p> <reason> <tbr>
Attributes for IE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | cdata | implied |  |
Description This is an index entry. The contents only appears in the index, not at the location where it is defined. This allows to define slightly different wording for the index than in the text itself.

Example
<p>This is an example of an <ie>index element</ie>index entry
Description Identifies text of an item to be extracted for the index.


10.6. INDENT-SAMPLE

Figure 76: DTD-diagram for INDENT-SAMPLE
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <labeled-list>
Attributes for INDENT-SAMPLE
Name | Type | Class | Value | Remark
[ITEM-LABEL-POS] | nmtkgrp | default | NO-NEWLINE NO-NEWLINE NEWLINE NEWLINE-IF-NECESSARY |
[S] | cdata | implied |  |
Description Null


10.7. INIT-VALUE

Figure 77: DTD-diagram for INIT-VALUE
Child elements | none
parent elements | <net-signal-spec-variant>
Attributes for INIT-VALUE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


10.8. INTEGRATION-CAPABILITY

Figure 78: DTD-diagram for INTEGRATION-CAPABILITY
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for INTEGRATION-CAPABILITY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains all information about the integration capability of this project.


10.9. INTERFACE-CIRCUIT

Figure 79: DTD-diagram for INTERFACE-CIRCUIT
Child elements | <figure> <schematic-elements> <add-info>
parent elements | <node-variant>
Attributes for INTERFACE-CIRCUIT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This alpha-numeric parameter describes the type of interface circuit.


10.10. INTRODUCTION

Figure 80: DTD-diagram for INTRODUCTION
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <topic-2>
parent elements | <acceptance-cond> <add-spec> <company-revision-info> <connection-comp-spec-1> <demarcation-other-projects> <dir-hand-over-doc-data> <general-net-spec> <general-project-data> <integration-capability> <net-architecture> <net-block-modes> <net-diag-spec> <net-error-handling> <net-init-spec> <net-interface-spec> <net-line-spec> <net-message-spec> <net-mgmt-spec> <net-node-spec> <net-oper-spec> <net-signal-spec> <net-topology-spec> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <segmentation-spec> <system-overview> <variant-spec>
Attributes for INTRODUCTION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This is used to give a short introduction about the subject in question. It exists at the beginning of its parent element. It is not intended to use <introduction> for a full fledged description.

Example
<introduction>
  <p>This system is used to control the engine.</p>
</introduction>
Description This element can be used to create an introduction.


10.11. ITEM

Figure 81: DTD-diagram for ITEM
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <list>
Attributes for ITEM
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Identifes an item typically occurring within a list.


10.12. ITEM-LABEL

Figure 82: DTD-diagram for ITEM-LABEL
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <labeled-item>
Attributes for ITEM-LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Null


11. LABEL ... LONG-NAME-1

Structure Principles of MSRNET.DTD
11. LABEL ... LONG-NAME-1

Contents of this chapter:
  • 11.1. LABEL
  • 11.2. LABELED-ITEM
  • 11.3. LABELED-LIST
  • 11.4. LANGUAGE
  • 11.5. LATENCY-TIME
  • 11.6. LIST
  • 11.7. LOCS
  • 11.8. LONG-NAME
  • 11.9. LONG-NAME-1


11.1. LABEL

Figure 83: DTD-diagram for LABEL
Child elements | none
parent elements | <multiplex-signal-set> <net-node-port> <note> <overall-project> <prms> <project> <schematic-element>
Attributes for LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Serves as a title (similar to <long-name>) for an object that must not, and cannot, be referenced, i.e. possesses no< short-name> and no [id].

A <label> within <sw-param-value-block> is a long designation for the characteristic values of a characteristic values block.
Example
<sw-param-value-block>
   <sw-param-axis-values>
      <sw-compu-method-ref sw-compu-method="dez">
         </sw-compu-method-ref>
         <labels>
            <label>sensor rear left</label>
            <label>sensor rear right</label>
            <label>sensor front left</label>
            <label>sensor front right</label>
         <l/abels>
   </sw-param-axis-values>
   <count>4</count>
</sw-param-value-block>
Description This element contents a short label.


11.2. LABELED-ITEM

Figure 84: DTD-diagram for LABELED-ITEM
Child elements | <item-label> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <labeled-list>
Attributes for LABELED-ITEM
Name | Type | Class | Value | Remark
[HELP-ENTRY] | cdata | implied |  |
[S] | cdata | implied |  |
Description Null


11.3. LABELED-LIST

Figure 85: DTD-diagram for LABELED-LIST
Child elements | <indent-sample> <labeled-item>
parent elements | <add-info> <chapter> <driver-concept> <entry> <introduction> <item> <labeled-item> <ncoi-1> <ncoi-3> <net-emc-design> <net-line-desc> <net-message-desc> <net-message-layout> <remark> <segmentation-desc> <topic-1> <topic-2>
Attributes for LABELED-LIST
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Null


11.4. LANGUAGE

Figure 86: DTD-diagram for LANGUAGE
Child elements | none
parent elements | <admin-data>
Attributes for LANGUAGE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Identifies the masterlanguage for <admin-data>

Example
Description Defines the laguage of the document (fragment).


11.5. LATENCY-TIME

Figure 87: DTD-diagram for LATENCY-TIME
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <transmission-prms>
Attributes for LATENCY-TIME
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |


11.6. LIST

Figure 88: DTD-diagram for LIST
Child elements | <item>
parent elements | <add-info> <chapter> <driver-concept> <entry> <introduction> <item> <labeled-item> <ncoi-1> <ncoi-3> <net-emc-design> <net-line-desc> <net-message-desc> <net-message-layout> <remark> <segmentation-desc> <topic-1> <topic-2>
Attributes for LIST
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | nmtkgrp | required | UNNUMBER NUMBER |
Description Identifies a list which is composed of one or more list items. There are two types of lists, numbered and unnumbered lists. They are classified by the type attribute.


11.7. LOCS

Figure 89: DTD-diagram for LOCS
Child elements | <nameloc>
parent elements | <msrnet>
Attributes for LOCS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element is used for cross document/entity referencing (HyTime referencing using namelocs)

Example
Description Null


11.8. LONG-NAME

Figure 90: DTD-diagram for LONG-NAME
Child elements | <tt> <ie>
parent elements | <baudrate> <btl-cycles> <chapter> <company> <connection-comp-1> <cycle-time> <def-item> <figure> <formula> <latency-time> <nameloc> <net-line> <net-message> <net-message-set> <net-node> <net-node-port> <net-signal> <net-signal-group> <phase-relations> <powerdown-receive-time> <powerup-receive-time> <powerup-transmit-time> <prm> <sample> <sample-point> <sample-rate> <segment-length> <sjw> <sw-compu-method> <sw-unit> <sync-edge> <table> <team-member> <topic-1> <topic-2> <variant-char> <variant-def>
Attributes for LONG-NAME
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Long designation, e.g. "Engine temperature".

Example
<sw-variable id="tmot">
   <long-name>engine temperature</long-name>
   <short-name>tmot</short-name>
   <desc></desc>
    ...
</sw-variable>
Description Defines a long name (label, title). This element exists only in elements with identifier.


11.9. LONG-NAME-1

Figure 91: DTD-diagram for LONG-NAME-1
Child elements | <tt> <ie>
parent elements | <std> <xdoc> <xfile>
Attributes for LONG-NAME-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Null


12. MAX ... MULTIPLEXOR-VALUE

Structure Principles of MSRNET.DTD
12. MAX ... MULTIPLEXOR-VALUE

Contents of this chapter:
  • 12.1. MAX
  • 12.2. MESSAGE-IDENTIFIER-OFFSET
  • 12.3. MIN
  • 12.4. MODIFICATION
  • 12.5. MODIFICATIONS
  • 12.6. MSRNET
  • 12.7. MULTIPLEX-ENTRY
  • 12.8. MULTIPLEX-SIGNAL-LIST
  • 12.9. MULTIPLEX-SIGNAL-SET
  • 12.10. MULTIPLEXOR
  • 12.11. MULTIPLEXOR-VALUE


12.1. MAX

Figure 92: DTD-diagram for MAX
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for MAX
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Maximum value of a parameter

Description This element defines the maximum value of a typical range. When you define <min> and <max> you have to leave <typ> empty.


12.2. MESSAGE-IDENTIFIER-OFFSET

Figure 93: DTD-diagram for MESSAGE-IDENTIFIER-OFFSET
Child elements | none
parent elements | <node-variant>
Attributes for MESSAGE-IDENTIFIER-OFFSET
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


12.3. MIN

Figure 94: DTD-diagram for MIN
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for MIN
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Minimum value for prm-char

Example
Description Defines the minimum value of a typical range. When you define <min> and <max> you have to leave <typ> empty.


12.4. MODIFICATION

Figure 95: DTD-diagram for MODIFICATION
Child elements | <change> <reason>
parent elements | <modifications>
Attributes for MODIFICATION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | nmtkgrp | required | CONTENT-RELATED DOC-RELATED |
Description

Example
Description Description of a modification (value before and after the changes, position of change).


12.5. MODIFICATIONS

Figure 96: DTD-diagram for MODIFICATIONS
Child elements | <modification>
parent elements | <doc-revision>
Attributes for MODIFICATIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description

Example
Description This element contains all changes that are made in the document.


12.6. MSRNET

Figure 97: DTD-diagram for MSRNET
Child elements | <short-name> <project-data> <admin-data> <general-net-spec> <net-architecture> <net-oper-spec> <add-spec> <locs>
parent elements | none
Attributes for MSRNET
Name | Type | Class | Value | Remark
[F-NAMESPACE] | names | fixed | CHAPTER COMPANY CONNECTION-COMP DEF-ITEM FIGURE FORMULA NET-LINE NET-MESSAGE NET-MESSAGE-SET NET-NODE NET-NODE-PORT NET-SIGNAL NET-SIGNAL-GROUP PRM SAMPLE STD SW-COMPU-METHOD SW-UNIT TABLE TEAM-MEMBER TOPIC VARIANT-CHAR VARIANT-DEF XDOC XFILE |
[F-PUBID] | cdata | fixed | -//MSR//DTD MSR NETWORK DTD:V1.1.1:MSRNET.DTD//EN |
[HYTIME] | name | fixed | HYDOC |
[PUBID] | cdata | default | -//MSR//DTD MSR NETWORK DTD:V1.1.1:MSRNET.DTD//EN |
[S] | cdata | implied |  |


12.7. MULTIPLEX-ENTRY

Figure 98: DTD-diagram for MULTIPLEX-ENTRY
Child elements | <multiplexor-value> <net-message-signals>
parent elements | <multiplex-signal-list>
Attributes for MULTIPLEX-ENTRY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


12.8. MULTIPLEX-SIGNAL-LIST

Figure 99: DTD-diagram for MULTIPLEX-SIGNAL-LIST
Child elements | <multiplex-entry>
parent elements | <multiplex-signal-set>
Attributes for MULTIPLEX-SIGNAL-LIST
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


12.9. MULTIPLEX-SIGNAL-SET

Figure 100: DTD-diagram for MULTIPLEX-SIGNAL-SET
Child elements | <label> <multiplexor> <multiplex-signal-list>
parent elements | <net-message-signal>
Attributes for MULTIPLEX-SIGNAL-SET
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


12.10. MULTIPLEXOR

Figure 101: DTD-diagram for MULTIPLEXOR
Child elements | <offset> <bitsize>
parent elements | <multiplex-signal-set>
Attributes for MULTIPLEXOR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


12.11. MULTIPLEXOR-VALUE

Figure 102: DTD-diagram for MULTIPLEXOR-VALUE
Child elements | none
parent elements | <multiplex-entry>
Attributes for MULTIPLEXOR-VALUE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


13. NA ... NET-MESSAGE-IDENTIFIERS

Structure Principles of MSRNET.DTD
13. NA ... NET-MESSAGE-IDENTIFIERS

Contents of this chapter:
  • 13.1. NA
  • 13.2. NAMELOC
  • 13.3. NCOI-1
  • 13.4. NCOI-3
  • 13.5. NET-ARCHITECTURE
  • 13.6. NET-BLOCK-MODES
  • 13.7. NET-DIAG-SPEC
  • 13.8. NET-EMC-DESIGN
  • 13.9. NET-ERROR-HANDLING
  • 13.10. NET-INIT-SPEC
  • 13.11. NET-INTERFACE-PRMS
  • 13.12. NET-INTERFACE-SPEC
  • 13.13. NET-LINE
  • 13.14. NET-LINE-DESC
  • 13.15. NET-LINE-SPEC
  • 13.16. NET-LINES
  • 13.17. NET-MESSAGE
  • 13.18. NET-MESSAGE-DESC
  • 13.19. NET-MESSAGE-IDENTIFIER
  • 13.20. NET-MESSAGE-IDENTIFIERS


13.1. NA

Figure 103: DTD-diagram for NA
Child elements | none
parent elements | <acceptance-cond> <add-spec> <connection-comp-spec-1> <demarcation-other-projects> <dir-hand-over-doc-data> <general-net-spec> <general-project-data> <integration-capability> <net-architecture> <net-block-modes> <net-diag-spec> <net-error-handling> <net-init-spec> <net-interface-spec> <net-line-spec> <net-message-spec> <net-mgmt-spec> <net-node-spec> <net-oper-spec> <net-signal-spec> <net-topology-spec> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <segmentation-spec> <system-overview> <variant-spec>
Attributes for NA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element is used instead of sub-structures if certain statements are not relevant ("not applicable").

Example
<sw-param-contents-spec>
   <na></na>
</sw-param-contents-spec>
Description Specifies that this information (see parent element) isn't applicable for this project . The context of this element describes the reason why the information isn't applicable.


13.2. NAMELOC

Figure 104: DTD-diagram for NAMELOC
Child elements | <long-name> <short-name> <nmlist>
parent elements | <locs>
Attributes for NAMELOC
Name | Type | Class | Value | Remark
[HYTIME] | name | fixed | NAMELOC |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Null


13.3. NCOI-1

Figure 105: DTD-diagram for NCOI-1
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <acceptance-cond> <add-spec> <demarcation-other-projects> <dir-hand-over-doc-data> <general-net-spec> <integration-capability> <net-block-modes> <net-diag-spec> <net-error-handling> <net-init-spec> <net-mgmt-spec> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample> <system-overview>
Attributes for NCOI-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This is a general element that contains informal and non-software-specific structures ("none coded information").

Example
Description This element contents the following objects to define a 'none content orientend information': topics tables figures paragraphs lists Only use these objects when you can't define all your informations in other elements!


13.4. NCOI-3

Figure 106: DTD-diagram for NCOI-3
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <topic-2>
parent elements | <connection-comp-1>
Attributes for NCOI-3
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Null


13.5. NET-ARCHITECTURE

Figure 107: DTD-diagram for NET-ARCHITECTURE
Child elements | <na> <tbd> <tbr> <admin-data> <introduction> <connection-comp-spec-1> <net-topology-spec> <net-interface-spec> <add-spec>
parent elements | <msrnet>
Attributes for NET-ARCHITECTURE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


13.6. NET-BLOCK-MODES

Figure 108: DTD-diagram for NET-BLOCK-MODES
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <net-oper-spec>
Attributes for NET-BLOCK-MODES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


13.7. NET-DIAG-SPEC

Figure 109: DTD-diagram for NET-DIAG-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <net-oper-spec>
Attributes for NET-DIAG-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


13.8. NET-EMC-DESIGN

Figure 110: DTD-diagram for NET-EMC-DESIGN
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <net-interface-spec>
Attributes for NET-EMC-DESIGN
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


13.9. NET-ERROR-HANDLING

Figure 111: DTD-diagram for NET-ERROR-HANDLING
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <net-oper-spec>
Attributes for NET-ERROR-HANDLING
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


13.10. NET-INIT-SPEC

Figure 112: DTD-diagram for NET-INIT-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <net-oper-spec>
Attributes for NET-INIT-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


13.11. NET-INTERFACE-PRMS

Figure 113: DTD-diagram for NET-INTERFACE-PRMS
Child elements | <baudrate> <sample-point> <sample-rate> <btl-cycles> <sjw> <sync-edge>
parent elements | <net-interface-spec>
Attributes for NET-INTERFACE-PRMS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


13.12. NET-INTERFACE-SPEC

Figure 114: DTD-diagram for NET-INTERFACE-SPEC
Child elements | <na> <tbd> <tbr> <admin-data> <introduction> <net-interface-prms> <driver-concept> <net-emc-design> <add-info>
parent elements | <net-architecture>
Attributes for NET-INTERFACE-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


13.13. NET-LINE

Figure 115: DTD-diagram for NET-LINE
Child elements | <long-name> <short-name> <net-line-desc>
parent elements | <net-lines>
Attributes for NET-LINE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | NET-LINE |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Null


13.14. NET-LINE-DESC

Figure 116: DTD-diagram for NET-LINE-DESC
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <net-line>
Attributes for NET-LINE-DESC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


13.15. NET-LINE-SPEC

Figure 117: DTD-diagram for NET-LINE-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <net-lines>
parent elements | <net-topology-spec>
Attributes for NET-LINE-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


13.16. NET-LINES

Figure 118: DTD-diagram for NET-LINES
Child elements | <net-line>
parent elements | <net-line-spec>
Attributes for NET-LINES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Null


13.17. NET-MESSAGE

Figure 119: DTD-diagram for NET-MESSAGE
Child elements | <variant-def-refs> <long-name> <short-name> <net-message-desc> <net-message-identifiers> <calc-net-message-identifiers> <identifier-mask> <identifier-type> <byte-order> <dlc> <net-message-signals> <net-message-layout> <transmission-spec> <add-info>
parent elements | <net-messages>
Attributes for NET-MESSAGE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | NET-MESSAGE |
[ID] | id | required |  |
[S] | cdata | implied |  |


13.18. NET-MESSAGE-DESC

Figure 120: DTD-diagram for NET-MESSAGE-DESC
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <net-message>
Attributes for NET-MESSAGE-DESC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


13.19. NET-MESSAGE-IDENTIFIER

Figure 121: DTD-diagram for NET-MESSAGE-IDENTIFIER
Child elements | <identifier> <senders>
parent elements | <net-message-identifiers>
Attributes for NET-MESSAGE-IDENTIFIER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


13.20. NET-MESSAGE-IDENTIFIERS

Figure 122: DTD-diagram for NET-MESSAGE-IDENTIFIERS
Child elements | <net-message-identifier>
parent elements | <net-message>
Attributes for NET-MESSAGE-IDENTIFIERS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


14. NET-MESSAGE-LAYOUT ... NET-SIGNAL-CLASS

Structure Principles of MSRNET.DTD
14. NET-MESSAGE-LAYOUT ... NET-SIGNAL-CLASS

Contents of this chapter:
  • 14.1. NET-MESSAGE-LAYOUT
  • 14.2. NET-MESSAGE-SET
  • 14.3. NET-MESSAGE-SETS
  • 14.4. NET-MESSAGE-SIGNAL
  • 14.5. NET-MESSAGE-SIGNALS
  • 14.6. NET-MESSAGE-SPEC
  • 14.7. NET-MESSAGES
  • 14.8. NET-MGMT-SPEC
  • 14.9. NET-NODE
  • 14.10. NET-NODE-PORT
  • 14.11. NET-NODE-PORT-REF
  • 14.12. NET-NODE-PORTS
  • 14.13. NET-NODE-REF
  • 14.14. NET-NODE-SPEC
  • 14.15. NET-NODE-VARIANTS
  • 14.16. NET-NODES
  • 14.17. NET-OPER-SPEC
  • 14.18. NET-PORT-REF
  • 14.19. NET-SIGNAL
  • 14.20. NET-SIGNAL-CLASS


14.1. NET-MESSAGE-LAYOUT

Figure 123: DTD-diagram for NET-MESSAGE-LAYOUT
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <net-message>
Attributes for NET-MESSAGE-LAYOUT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


14.2. NET-MESSAGE-SET

Figure 124: DTD-diagram for NET-MESSAGE-SET
Child elements | <long-name> <short-name> <net-messages>
parent elements | <net-message-sets>
Attributes for NET-MESSAGE-SET
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | NET-MESSAGE-SET |
[ID] | id | required |  |
[S] | cdata | implied |  |


14.3. NET-MESSAGE-SETS

Figure 125: DTD-diagram for NET-MESSAGE-SETS
Child elements | <net-message-set>
parent elements | <net-message-spec>
Attributes for NET-MESSAGE-SETS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


14.4. NET-MESSAGE-SIGNAL

Figure 126: DTD-diagram for NET-MESSAGE-SIGNAL
Child elements | <variant-def-refs> <net-signal-ref> <offset> <receivers> <multiplex-signal-set>
parent elements | <net-message-signals>
Attributes for NET-MESSAGE-SIGNAL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


14.5. NET-MESSAGE-SIGNALS

Figure 127: DTD-diagram for NET-MESSAGE-SIGNALS
Child elements | <net-message-signal>
parent elements | <multiplex-entry> <net-message>
Attributes for NET-MESSAGE-SIGNALS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


14.6. NET-MESSAGE-SPEC

Figure 128: DTD-diagram for NET-MESSAGE-SPEC
Child elements | <na> <tbd> <tbr> <admin-data> <introduction> <net-message-sets>
parent elements | <net-oper-spec>
Attributes for NET-MESSAGE-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


14.7. NET-MESSAGES

Figure 129: DTD-diagram for NET-MESSAGES
Child elements | <net-message>
parent elements | <net-message-set>
Attributes for NET-MESSAGES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


14.8. NET-MGMT-SPEC

Figure 130: DTD-diagram for NET-MGMT-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <net-oper-spec>
Attributes for NET-MGMT-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


14.9. NET-NODE

Figure 131: DTD-diagram for NET-NODE
Child elements | <long-name> <short-name> <net-node-variants>
parent elements | <net-nodes>
Attributes for NET-NODE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | NET-NODE |
[F-NAMESPACE] | names | fixed | NET-NODE-PORT |
[ID] | id | required |  |
[S] | cdata | implied |  |


14.10. NET-NODE-PORT

Figure 132: DTD-diagram for NET-NODE-PORT
Child elements | <long-name> <short-name> <label> <net-port-ref> <desc>
parent elements | <net-node-ports>
Attributes for NET-NODE-PORT
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | NET-NODE-PORT |
[ID] | id | required |  |
[S] | cdata | implied |  |


14.11. NET-NODE-PORT-REF

Figure 133: DTD-diagram for NET-NODE-PORT-REF
Child elements | none
parent elements | <segment-end-nodes> <segment-end-nodes>
Attributes for NET-NODE-PORT-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND NET-NODE-PORT |
[HYTIME] | name | fixed | CLINK |
[NET-NODE-PORT] | idref | required |  |
[S] | cdata | implied |  |


14.12. NET-NODE-PORTS

Figure 134: DTD-diagram for NET-NODE-PORTS
Child elements | <net-node-port>
parent elements | <node-variant>
Attributes for NET-NODE-PORTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


14.13. NET-NODE-REF

Figure 135: DTD-diagram for NET-NODE-REF
Child elements | none
parent elements | <receivers> <sender>
Attributes for NET-NODE-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND NET-NODE |
[HYTIME] | name | fixed | CLINK |
[NET-NODE] | idref | required |  |
[S] | cdata | implied |  |


14.14. NET-NODE-SPEC

Figure 136: DTD-diagram for NET-NODE-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <net-nodes>
parent elements | <net-topology-spec>
Attributes for NET-NODE-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


14.15. NET-NODE-VARIANTS

Figure 137: DTD-diagram for NET-NODE-VARIANTS
Child elements | <node-variant>
parent elements | <net-node>
Attributes for NET-NODE-VARIANTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


14.16. NET-NODES

Figure 138: DTD-diagram for NET-NODES
Child elements | <net-node>
parent elements | <net-node-spec>
Attributes for NET-NODES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


14.17. NET-OPER-SPEC

Figure 139: DTD-diagram for NET-OPER-SPEC
Child elements | <na> <tbd> <tbr> <admin-data> <introduction> <net-mgmt-spec> <net-init-spec> <net-error-handling> <net-diag-spec> <net-block-modes> <net-signal-spec> <net-message-spec> <add-spec>
parent elements | <msrnet>
Attributes for NET-OPER-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


14.18. NET-PORT-REF

Figure 140: DTD-diagram for NET-PORT-REF
Child elements | none
parent elements | <net-node-port>
Attributes for NET-PORT-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND NET-PORT |
[HYTIME] | name | fixed | CLINK |
[NET-PORT] | idref | required |  |
[S] | cdata | implied |  |


14.19. NET-SIGNAL

Figure 141: DTD-diagram for NET-SIGNAL
Child elements | <long-name> <short-name> <variant-def-refs>
parent elements | <net-signals>
Attributes for NET-SIGNAL
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | NET-SIGNAL |
[ID] | id | required |  |
[S] | cdata | implied |  |


14.20. NET-SIGNAL-CLASS

Figure 142: DTD-diagram for NET-SIGNAL-CLASS
Child elements | none
parent elements | <net-signal-spec-variant>
Attributes for NET-SIGNAL-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15. NET-SIGNAL-GROUP ... NUMBER

Structure Principles of MSRNET.DTD
15. NET-SIGNAL-GROUP ... NUMBER

Contents of this chapter:
  • 15.1. NET-SIGNAL-GROUP
  • 15.2. NET-SIGNAL-GROUPS
  • 15.3. NET-SIGNAL-REF
  • 15.4. NET-SIGNAL-SPEC
  • 15.5. NET-SIGNAL-SPEC-VARIANT
  • 15.6. NET-SIGNAL-SPEC-VARIANTS
  • 15.7. NET-SIGNALS
  • 15.8. NET-TOPOLOGY-SPEC
  • 15.9. NMLIST
  • 15.10. NODE-TYPE
  • 15.11. NODE-VARIANT
  • 15.12. NOTE
  • 15.13. NUMBER


15.1. NET-SIGNAL-GROUP

Figure 143: DTD-diagram for NET-SIGNAL-GROUP
Child elements | <long-name> <short-name> <net-signals> <net-signal-spec-variants>
parent elements | <net-signal-groups>
Attributes for NET-SIGNAL-GROUP
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | NET-SIGNAL-GROUP |
[ID] | id | required |  |
[S] | cdata | implied |  |


15.2. NET-SIGNAL-GROUPS

Figure 144: DTD-diagram for NET-SIGNAL-GROUPS
Child elements | <net-signal-group>
parent elements | <net-signal-spec>
Attributes for NET-SIGNAL-GROUPS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.3. NET-SIGNAL-REF

Figure 145: DTD-diagram for NET-SIGNAL-REF
Child elements | none
parent elements | <net-message-signal>
Attributes for NET-SIGNAL-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND NET-SIGNAL |
[HYTIME] | name | fixed | CLINK |
[NET-SIGNAL] | idref | required |  |
[S] | cdata | implied |  |


15.4. NET-SIGNAL-SPEC

Figure 146: DTD-diagram for NET-SIGNAL-SPEC
Child elements | <na> <tbd> <tbr> <admin-data> <introduction> <sw-units> <sw-compu-methods> <net-signal-groups> <add-info>
parent elements | <net-oper-spec>
Attributes for NET-SIGNAL-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.5. NET-SIGNAL-SPEC-VARIANT

Figure 147: DTD-diagram for NET-SIGNAL-SPEC-VARIANT
Child elements | <variant-def-refs> <bitsize> <init-value> <net-signal-class> <error-values> <sw-base-type> <sw-limits> <sw-compu-method-ref> <add-info>
parent elements | <net-signal-spec-variants>
Attributes for NET-SIGNAL-SPEC-VARIANT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.6. NET-SIGNAL-SPEC-VARIANTS

Figure 148: DTD-diagram for NET-SIGNAL-SPEC-VARIANTS
Child elements | <net-signal-spec-variant>
parent elements | <net-signal-group>
Attributes for NET-SIGNAL-SPEC-VARIANTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.7. NET-SIGNALS

Figure 149: DTD-diagram for NET-SIGNALS
Child elements | <net-signal>
parent elements | <net-signal-group>
Attributes for NET-SIGNALS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.8. NET-TOPOLOGY-SPEC

Figure 150: DTD-diagram for NET-TOPOLOGY-SPEC
Child elements | <na> <tbd> <tbr> <admin-data> <introduction> <topology-type> <figure> <net-line-spec> <net-node-spec> <segmentation-spec> <add-spec>
parent elements | <net-architecture>
Attributes for NET-TOPOLOGY-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.9. NMLIST

Figure 151: DTD-diagram for NMLIST
Child elements | none
parent elements | <nameloc>
Attributes for NMLIST
Name | Type | Class | Value | Remark
[DOCORSUB] | entity | implied |  |
[HYTIME] | name | fixed | NMLIST |
[NAMETYPE] | nmtkgrp | default | ELEMENT ENTITY ELEMENT |
[S] | cdata | implied |  |
Description Null


15.10. NODE-TYPE

Figure 152: DTD-diagram for NODE-TYPE
Child elements | none
parent elements | <node-variant>
Attributes for NODE-TYPE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.11. NODE-VARIANT

Figure 153: DTD-diagram for NODE-VARIANT
Child elements | <variant-def-refs> <net-node-ports> <node-type> <message-identifier-offset> <protocol-conformance> <interface-circuit>
parent elements | <net-node-variants>
Attributes for NODE-VARIANT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


15.12. NOTE

Figure 154: DTD-diagram for NOTE
Child elements | <label> <p>
parent elements | <add-info> <chapter> <driver-concept> <entry> <introduction> <item> <labeled-item> <ncoi-1> <ncoi-3> <net-emc-design> <net-line-desc> <net-message-desc> <net-message-layout> <remark> <segmentation-desc> <topic-1> <topic-2>
Attributes for NOTE
Name | Type | Class | Value | Remark
[NOTE-TYPE] | nmtkgrp | required | CAUTION HINT TIP INSTRUCTION EXERCISE OTHER |
[S] | cdata | implied |  |
[USER-DEFINED-TYPE] | cdata | implied |  |
Description Null


15.13. NUMBER

Figure 155: DTD-diagram for NUMBER
Child elements | none
parent elements | <xdoc>
Attributes for NUMBER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of a number.


16. OBJECTIVES ... OVERALL-PROJECT

Structure Principles of MSRNET.DTD
16. OBJECTIVES ... OVERALL-PROJECT

Contents of this chapter:
  • 16.1. OBJECTIVES
  • 16.2. OFFSET
  • 16.3. OVERALL-PROJECT


16.1. OBJECTIVES

Figure 156: DTD-diagram for OBJECTIVES
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for OBJECTIVES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description In ths element the objectives of the project can be specified.


16.2. OFFSET

Figure 157: DTD-diagram for OFFSET
Child elements | none
parent elements | <multiplexor> <net-message-signal>
Attributes for OFFSET
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description The datapoints are defined by an algorithm for fixed characteristics and maps. Example for an algorithm: Datapoint[i] = ( ... shift ) * x + offset

Example
<sw-axis-shift-offset>
   <sw-variable-ref>var1</sw-variable-ref>
   <max-count>4</max-count>
   <shift>2</shift>
   <offset>3</offset>
<sw-axis-shift-offset></sw-axis-shift-offset>


16.3. OVERALL-PROJECT

Figure 158: DTD-diagram for OVERALL-PROJECT
Child elements | <label> <desc>
parent elements | <project-data>
Attributes for OVERALL-PROJECT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of an overall-project which is assigned to the actual project.


17. P ... PROJECT-DATA

Structure Principles of MSRNET.DTD
17. P ... PROJECT-DATA

Contents of this chapter:
  • 17.1. P
  • 17.2. PARALLEL-DESIGNS
  • 17.3. PART-NUMBER
  • 17.4. PHASE-RELATIONS
  • 17.5. PHONE
  • 17.6. PHYS
  • 17.7. PHYS-MAX
  • 17.8. PHYS-MIN
  • 17.9. POSITION
  • 17.10. POWERDOWN-RECEIVE-TIME
  • 17.11. POWERUP-RECEIVE-TIME
  • 17.12. POWERUP-TRANSMIT-TIME
  • 17.13. PRIVATE-CODE
  • 17.14. PRIVATE-CODES
  • 17.15. PRM
  • 17.16. PRM-CHAR
  • 17.17. PRMS
  • 17.18. PROG-CODE
  • 17.19. PROJECT
  • 17.20. PROJECT-DATA


17.1. P

Figure 159: DTD-diagram for P
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie> <std> <xdoc> <xfile>
parent elements | <add-info> <chapter> <cond> <def> <driver-concept> <entry> <introduction> <item> <labeled-item> <ncoi-1> <ncoi-3> <net-emc-design> <net-line-desc> <net-message-desc> <net-message-layout> <note> <remark> <segmentation-desc> <topic-1> <topic-2>
Attributes for P
Name | Type | Class | Value | Remark
[HELP-ENTRY] | cdata | implied |  |
[S] | cdata | implied |  |
Description Paragraph. A paragraph can comprise text and the elements tt (technical text), xref (cross reference), e (text attribute like bold), ft (footnote), sup (superscript), sub (subscript), ie (index entry), std (standard), xdoc (external document), xfile (external file) in any arbitrary, though not hierarchical, order.

Example
<sw-function-desc>
   <p>This function describes the <ie>exhaust-gas return</ie>. Refer to <std> ... </std></p>
</sw-function-desc>
Description Identifies text within a paragraph.


17.2. PARALLEL-DESIGNS

Figure 160: DTD-diagram for PARALLEL-DESIGNS
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PARALLEL-DESIGNS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Description of projects with concurrent informations (part type specifications).


17.3. PART-NUMBER

Figure 161: DTD-diagram for PART-NUMBER
Child elements | none
parent elements | <connection-comp-1>
Attributes for PART-NUMBER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element defines the number of a part.


17.4. PHASE-RELATIONS

Figure 162: DTD-diagram for PHASE-RELATIONS
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <transmission-prms>
Attributes for PHASE-RELATIONS
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |


17.5. PHONE

Figure 163: DTD-diagram for PHONE
Child elements | none
parent elements | <team-member>
Attributes for PHONE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of a phone number.


17.6. PHYS

Figure 164: DTD-diagram for PHYS
Child elements | <phys-min> <phys-max>
parent elements | <sw-limits> <sw-limits>
Attributes for PHYS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


17.7. PHYS-MAX

Figure 165: DTD-diagram for PHYS-MAX
Child elements | none
parent elements | <phys>
Attributes for PHYS-MAX
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


17.8. PHYS-MIN

Figure 166: DTD-diagram for PHYS-MIN
Child elements | none
parent elements | <phys>
Attributes for PHYS-MIN
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


17.9. POSITION

Figure 167: DTD-diagram for POSITION
Child elements | none
parent elements | <std> <xdoc>
Attributes for POSITION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Describes the importent position in the standard or external document.


17.10. POWERDOWN-RECEIVE-TIME

Figure 168: DTD-diagram for POWERDOWN-RECEIVE-TIME
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <transmission-prms>
Attributes for POWERDOWN-RECEIVE-TIME
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |


17.11. POWERUP-RECEIVE-TIME

Figure 169: DTD-diagram for POWERUP-RECEIVE-TIME
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <transmission-prms>
Attributes for POWERUP-RECEIVE-TIME
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |


17.12. POWERUP-TRANSMIT-TIME

Figure 170: DTD-diagram for POWERUP-TRANSMIT-TIME
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <transmission-prms>
Attributes for POWERUP-TRANSMIT-TIME
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |


17.13. PRIVATE-CODE

Figure 171: DTD-diagram for PRIVATE-CODE
Child elements | none
parent elements | <private-codes>
Attributes for PRIVATE-CODE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | cdata | implied |  |
Description

Example
<private-codes>
   <private-code> TYPE="generated_by_ASCET-SD">$generated_by_ASCET-SD:2.2.0$ </private-code>
   <private-code> TYPE="Implementation xy">Implementation xy</private-code>
</private-codes>
Description This element allows you to interchange one private (encoded) data.


17.14. PRIVATE-CODES

Figure 172: DTD-diagram for PRIVATE-CODES
Child elements | <private-code>
parent elements | <company-doc-info>
Attributes for PRIVATE-CODES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description

Example
<company-doc-infos>
   <private-codes>
   <private-codes>
      <private-code> TYPE="generated_by_ASCET-SD">$generated_by_ASCET-SD:2.2.0$ </private-code>

   </private-codes>
</company-doc-infos>
Description This element allows you to interchange private (encoded) data.


17.15. PRM

Figure 173: DTD-diagram for PRM
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <connection-comp-prms> <prms> <transmission-prms>
Attributes for PRM
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description A parameter model has been implemented in MSR. There are 2 possibilities given. A parameter can be specified either by defining <abs>,<tol> or by defining <min>, <typ> and <max>.

Example
Description Definition of a numeric or alphanumeric (without <operator>, <unit> and <tolerance>) parameter.


17.16. PRM-CHAR

Figure 174: DTD-diagram for PRM-CHAR
Child elements | <cond> <abs> <tol> <min> <typ> <max> <unit> <text> <remark>
parent elements | <baudrate> <btl-cycles> <cycle-time> <latency-time> <phase-relations> <powerdown-receive-time> <powerup-receive-time> <powerup-transmit-time> <prm> <sample-point> <sample-rate> <segment-length> <sjw> <sync-edge>
Attributes for PRM-CHAR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Description of the parameter characteristics of a parameter

Example
<sw-prm>
   <long-name>long designation</long-name>
   <short-name>short designation</short-name>
   <min>10</min>
   <typ>45</typ>
   <max>90</max>
   <unit>oC</unit>
</sw-prm>
Description A parameter consits of one or more characteristics. Each characteristic groups an <operator>, <value>, <unit>, <tolerance> and <cond>. Sence it is possible to define a range with two parameter characterists.


17.17. PRMS

Figure 175: DTD-diagram for PRMS
Child elements | <label> <prm>
parent elements | <add-info> <chapter> <driver-concept> <ncoi-1> <net-emc-design> <net-line-desc> <net-message-desc> <net-message-layout> <segmentation-desc> <topic-1>
Attributes for PRMS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description List of parameters

Example
Description Groups one or more parameters to a parameter table.


17.18. PROG-CODE

Figure 176: DTD-diagram for PROG-CODE
Child elements | none
parent elements | <sw-compu-method>
Attributes for PROG-CODE
Name | Type | Class | Value | Remark
[LANG-SUBSET] | names | implied |  |
[PROG-LANG] | cdata | implied |  |
[S] | cdata | implied |  |
[USED-LIBS] | nmtokens | implied |  |
Description Description of conversion formulae in a programming language notation

Example


17.19. PROJECT

Figure 177: DTD-diagram for PROJECT
Child elements | <label> <desc> <companies>
parent elements | <project-data>
Attributes for PROJECT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Information regarding a project.

Example
Description This element defines the project with all companies.


17.20. PROJECT-DATA

Figure 178: DTD-diagram for PROJECT-DATA
Child elements | <overall-project> <project>
parent elements | <msrnet>
Attributes for PROJECT-DATA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Project data

Example
Description For project syncronisation between manufactorer and supplier it is necessary, to interchange some project data. Normally are this data filled from the PDM system of the company.


18. PROJECT-SCHEDULE ... PURCHASING-COND

Structure Principles of MSRNET.DTD
18. PROJECT-SCHEDULE ... PURCHASING-COND

Contents of this chapter:
  • 18.1. PROJECT-SCHEDULE
  • 18.2. PROTOCOL-CONFORMANCE
  • 18.3. PROTOCOLS
  • 18.4. PUBLISHER
  • 18.5. PURCHASING-COND


18.1. PROJECT-SCHEDULE

Figure 179: DTD-diagram for PROJECT-SCHEDULE
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PROJECT-SCHEDULE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains a project schedule.


18.2. PROTOCOL-CONFORMANCE

Figure 180: DTD-diagram for PROTOCOL-CONFORMANCE
Child elements | none
parent elements | <node-variant>
Attributes for PROTOCOL-CONFORMANCE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


18.3. PROTOCOLS

Figure 181: DTD-diagram for PROTOCOLS
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PROTOCOLS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains all protocols (from the actual company) of this project.


18.4. PUBLISHER

Figure 182: DTD-diagram for PUBLISHER
Child elements | none
parent elements | <xdoc>
Attributes for PUBLISHER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of the publisher of the external document.


18.5. PURCHASING-COND

Figure 183: DTD-diagram for PURCHASING-COND
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PURCHASING-COND
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element groups existing purchasing conditions.


19. REASON ... ROW

Structure Principles of MSRNET.DTD
19. REASON ... ROW

Contents of this chapter:
  • 19.1. REASON
  • 19.2. REASON-ORDER
  • 19.3. RECEIVERS
  • 19.4. REMARK
  • 19.5. REVISION-LABEL
  • 19.6. ROLE
  • 19.7. ROLES
  • 19.8. ROW


19.1. REASON

Figure 184: DTD-diagram for REASON
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <modification>
Attributes for REASON
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description

Example
Description Reason of the change.


19.2. REASON-ORDER

Figure 185: DTD-diagram for REASON-ORDER
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for REASON-ORDER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Reason of the order.


19.3. RECEIVERS

Figure 186: DTD-diagram for RECEIVERS
Child elements | <net-node-ref>
parent elements | <net-message-signal>
Attributes for RECEIVERS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


19.4. REMARK

Figure 187: DTD-diagram for REMARK
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <prm-char>
Attributes for REMARK
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Defines a remark.


19.5. REVISION-LABEL

Figure 188: DTD-diagram for REVISION-LABEL
Child elements | none
parent elements | <company-revision-info>
Attributes for REVISION-LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Revision

Example
<company-revision-info>
    <company-ref></company-ref>
    <revision-label>10.4</revision-label>
    <state></state>
</company-revision-info>
Description Label of a revision.


19.6. ROLE

Figure 189: DTD-diagram for ROLE
Child elements | none
parent elements | <roles>
Attributes for ROLE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of a team member role (e.g. project leader).


19.7. ROLES

Figure 190: DTD-diagram for ROLES
Child elements | <role>
parent elements | <team-member>
Attributes for ROLES
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | role:selection |
[S] | cdata | implied |  |
Description Each team member has one or more roles in the project.


19.8. ROW

Figure 191: DTD-diagram for ROW
Child elements | <entry>
parent elements | <tbody> <tfoot> <thead>
Attributes for ROW
Name | Type | Class | Value | Remark
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
Description Identifies the row information in a <tgroup> of a table. Default values come from the <table>, <tgroup>, <colspec> or <spanspec> attributes.


20. SAMPLE ... SJW

Structure Principles of MSRNET.DTD
20. SAMPLE ... SJW

Contents of this chapter:
  • 20.1. SAMPLE
  • 20.2. SAMPLE-POINT
  • 20.3. SAMPLE-RATE
  • 20.4. SAMPLE-REF
  • 20.5. SAMPLE-SPEC
  • 20.6. SAMPLES
  • 20.7. SCHEDULE
  • 20.8. SCHEMATIC-ELEMENT
  • 20.9. SCHEMATIC-ELEMENTS
  • 20.10. SEGMENT
  • 20.11. SEGMENT-END-NODES
  • 20.12. SEGMENT-LENGTH
  • 20.13. SEGMENTATION-DESC
  • 20.14. SEGMENTATION-SPEC
  • 20.15. SEGMENTS
  • 20.16. SENDER
  • 20.17. SENDERS
  • 20.18. SHORT-NAME
  • 20.19. SI-UNIT
  • 20.20. SJW


20.1. SAMPLE

Figure 192: DTD-diagram for SAMPLE
Child elements | <long-name> <short-name> <ncoi-1>
parent elements | <samples>
Attributes for SAMPLE
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | long-name:selection |
[F-ID-CLASS] | name | fixed | SAMPLE |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Definition of a sample.


20.2. SAMPLE-POINT

Figure 193: DTD-diagram for SAMPLE-POINT
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <net-interface-prms>
Attributes for SAMPLE-POINT
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |


20.3. SAMPLE-RATE

Figure 194: DTD-diagram for SAMPLE-RATE
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <net-interface-prms>
Attributes for SAMPLE-RATE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |


20.4. SAMPLE-REF

Figure 195: DTD-diagram for SAMPLE-REF
Child elements | none
parent elements | <schedule>
Attributes for SAMPLE-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND SAMPLE |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[SAMPLE] | idref | required |  |
Description Reference to a sample.


20.5. SAMPLE-SPEC

Figure 196: DTD-diagram for SAMPLE-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <samples>
parent elements | <general-project-data>
Attributes for SAMPLE-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Null


20.6. SAMPLES

Figure 197: DTD-diagram for SAMPLES
Child elements | <sample>
parent elements | <sample-spec>
Attributes for SAMPLES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of a samples.


20.7. SCHEDULE

Figure 198: DTD-diagram for SCHEDULE
Child elements | <sample-ref> <date>
parent elements | <tbd>
Attributes for SCHEDULE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Null


20.8. SCHEMATIC-ELEMENT

Figure 199: DTD-diagram for SCHEMATIC-ELEMENT
Child elements | <label> <v>
parent elements | <schematic-elements>
Attributes for SCHEMATIC-ELEMENT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Specifies a schematic element.


20.9. SCHEMATIC-ELEMENTS

Figure 200: DTD-diagram for SCHEMATIC-ELEMENTS
Child elements | <schematic-element>
parent elements | <interface-circuit>
Attributes for SCHEMATIC-ELEMENTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Contains one or more schematic elements.


20.10. SEGMENT

Figure 201: DTD-diagram for SEGMENT
Child elements | <variant-def-refs> <segment-end-nodes> <segment-length> <connection-comp-ref>
parent elements | <segments>
Attributes for SEGMENT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


20.11. SEGMENT-END-NODES

Figure 202: DTD-diagram for SEGMENT-END-NODES
Child elements | <net-node-port-ref> <net-node-port-ref>
parent elements | <segment>
Attributes for SEGMENT-END-NODES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


20.12. SEGMENT-LENGTH

Figure 203: DTD-diagram for SEGMENT-LENGTH
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <segment>
Attributes for SEGMENT-LENGTH
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |


20.13. SEGMENTATION-DESC

Figure 204: DTD-diagram for SEGMENTATION-DESC
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <segmentation-spec>
Attributes for SEGMENTATION-DESC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


20.14. SEGMENTATION-SPEC

Figure 205: DTD-diagram for SEGMENTATION-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <segmentation-desc> <connection-comp-ref> <segments>
parent elements | <net-topology-spec>
Attributes for SEGMENTATION-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


20.15. SEGMENTS

Figure 206: DTD-diagram for SEGMENTS
Child elements | <segment>
parent elements | <segmentation-spec>
Attributes for SEGMENTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


20.16. SENDER

Figure 207: DTD-diagram for SENDER
Child elements | <variant-def-refs> <net-node-ref>
parent elements | <senders>
Attributes for SENDER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


20.17. SENDERS

Figure 208: DTD-diagram for SENDERS
Child elements | <sender>
parent elements | <calc-net-message-identifiers> <net-message-identifier>
Attributes for SENDERS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


20.18. SHORT-NAME

Figure 209: DTD-diagram for SHORT-NAME
Child elements | none
parent elements | <baudrate> <btl-cycles> <chapter> <company> <connection-comp-1> <cycle-time> <def-item> <figure> <formula> <latency-time> <msrnet> <nameloc> <net-line> <net-message> <net-message-set> <net-node> <net-node-port> <net-signal> <net-signal-group> <phase-relations> <powerdown-receive-time> <powerup-receive-time> <powerup-transmit-time> <prm> <sample> <sample-point> <sample-rate> <segment-length> <sjw> <std> <sw-compu-method> <sw-unit> <sync-edge> <table> <team-member> <topic-1> <topic-2> <variant-char> <variant-def> <xdoc> <xfile>
Attributes for SHORT-NAME
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Short designation, e.g. "TMOT". The <short-name> has an identifying character, in particular for outside references (e.g. ASAP, ASCET).

Example
Description Identifier or label of a parameter.


20.19. SI-UNIT

Figure 210: DTD-diagram for SI-UNIT
Child elements | none
parent elements | <sw-unit>
Attributes for SI-UNIT
Name | Type | Class | Value | Remark
[AMOUNT-OF-SUBSTANCE-EXPO] | cdata | implied |  |
[ELECTRIC-CURRENT-EXPO] | cdata | implied |  |
[LENGTH-EXPO] | cdata | implied |  |
[LUMINOUS-INTENSITY-EXPO] | cdata | implied |  |
[MASS-EXPO] | cdata | implied |  |
[S] | cdata | implied |  |
[THERMODYNAMIC-TEMPERATURE-EXPO] | cdata | implied |  |
[TIME-EXPO] | cdata | implied |  |
Description There are SI units of measure for the units of measure. STEP (ISO/DIS 10303-41. S96ff) is supported with regard to SI units by seven basic units (length, mass, time, electric_current, thermodynamic_temperature, amount_of_substance, luminous_intensity). These basic units are realized by means of attributes.

Example
<sw-unit>
      <long-name>Meter per second</long-name>
      <short-name>mps</short-name>
      <si-unit length-expo = "1" time-expo = "-1"></si-unit>
          <sw-unit-display></sw-unit-display>
   </sw-unit>


20.20. SJW

Figure 211: DTD-diagram for SJW
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <net-interface-prms>
Attributes for SJW
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |


21. SPANSPEC ... SW-UNIT-DISPLAY

Structure Principles of MSRNET.DTD
21. SPANSPEC ... SW-UNIT-DISPLAY

Contents of this chapter:
  • 21.1. SPANSPEC
  • 21.2. STATE
  • 21.3. STATE-1
  • 21.4. STD
  • 21.5. SUB
  • 21.6. SUBTITLE
  • 21.7. SUP
  • 21.8. SW-ASAP-6-PRM-METHOD
  • 21.9. SW-BASE-TYPE
  • 21.10. SW-COMPU-GENERIC-MATH
  • 21.11. SW-COMPU-METHOD
  • 21.12. SW-COMPU-METHOD-REF
  • 21.13. SW-COMPU-METHOD-TABLE
  • 21.14. SW-COMPU-METHOD-TEXT
  • 21.15. SW-COMPU-METHOD-TEXT-PAIR
  • 21.16. SW-COMPU-METHOD-VALUE-PAIR
  • 21.17. SW-COMPU-METHODS
  • 21.18. SW-LIMITS
  • 21.19. SW-UNIT
  • 21.20. SW-UNIT-DISPLAY


21.1. SPANSPEC

Figure 212: DTD-diagram for SPANSPEC
Child elements | none
parent elements | <tgroup>
Attributes for SPANSPEC
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | default | CENTER LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | implied |  |
[CHAROFF] | nutoken | implied |  |
[COLSEP] | number | implied |  |
[NAMEEND] | nmtoken | required |  |
[NAMEST] | nmtoken | required |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[SPANNAME] | nmtoken | required |  |
Description Identifies a horizontal span of columns and associated attributes that can subsequently be referenced by its spanname to provide attributes repeatedly used in the entries or entry tables in several rows of the table group controlled by the group <colsdef>, or within the specific <thead>, <tfoot>, or <tbody> context in which the <spanspec> occurs. <Namest> and <nameend> identify the first and last columns in increasing order that identify the span. The reason <colname> is used rather than <colnum> in identifying <spanspec> is that the names are independent of revisions that may change the number of inserted/deleted columns, as long as namest remains to the left of (has a smaller colnum than) <nameend>. <spanspec>s set on <thead> or <tfoot> override those on the containing <tgroup> and apply to just the <thead> or<tfoot>. <spanspec>s from the containing <tgroup> apply to <tbody>.


21.2. STATE

Figure 213: DTD-diagram for STATE
Child elements | none
parent elements | <company-revision-info>
Attributes for STATE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description

Example
Description Processing state of a document, i.e draft, released.


21.3. STATE-1

Figure 214: DTD-diagram for STATE-1
Child elements | none
parent elements | <std> <xdoc>
Attributes for STATE-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of a state (multilingual).


21.4. STD

Figure 215: DTD-diagram for STD
Child elements | <long-name-1> <short-name> <subtitle> <state-1> <date-1> <file> <position>
parent elements | <p> <tbr>
Attributes for STD
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | date-1:date |
[F-ID-CLASS] | name | fixed | STD |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description

Example
<std>
   <long-name-1>ISO/DIS 10303-41 units of measure</long-name-1>
   <short-name>ISO/DIS 10303-41</short-name>
   <subtitle>SI units of measure</subtitle>
   <state-1></state-1>
   <date-1></date-1>
   <file>ISO10303-41.std</file>
   <position>S96ff</position>
</std>
Description Specification of a standard. A <xref> can refer to a standard within a paragraph.


21.5. SUB

Figure 216: DTD-diagram for SUB
Child elements | none
parent elements | <abs> <change> <desc> <ie> <indent-sample> <item-label> <max> <min> <p> <reason> <sw-unit-display> <tbr> <text> <tol> <typ> <unit>
Attributes for SUB
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Text which appears or is displayed below the normal base line of text.


21.6. SUBTITLE

Figure 217: DTD-diagram for SUBTITLE
Child elements | none
parent elements | <std>
Attributes for SUBTITLE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element defines a subtitle of the standard.


21.7. SUP

Figure 218: DTD-diagram for SUP
Child elements | none
parent elements | <abs> <change> <desc> <ie> <indent-sample> <item-label> <max> <min> <p> <reason> <sw-unit-display> <tbr> <text> <tol> <typ> <unit>
Attributes for SUP
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Text which appears or is displayed above the normal base line of text.


21.8. SW-ASAP-6-PRM-METHOD

Figure 219: DTD-diagram for SW-ASAP-6-PRM-METHOD
Child elements | none
parent elements | <sw-compu-method>
Attributes for SW-ASAP-6-PRM-METHOD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description 6-parameter formula corresponding to ASAP (polynomial presentation. Presentation of the elements of the formula separated by white spaces. formula: int = (a × x2 + b × x1 + c ) / ( d × x2 + e × x1 + f)

Example
<sw-asap-6-prm-method>0 1 0 0 0 0.698 </sw-asap-6-prm-method>


21.9. SW-BASE-TYPE

Figure 220: DTD-diagram for SW-BASE-TYPE
Child elements | none
parent elements | <net-signal-spec-variant>
Attributes for SW-BASE-TYPE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Base type of SW variable (e.g. char, integer).

Example
<sw-variable-implementation>
   <sw-base-type>UBIT</sw-base-type>
</sw-variable-implementation>


21.10. SW-COMPU-GENERIC-MATH

Figure 221: DTD-diagram for SW-COMPU-GENERIC-MATH
Child elements | none
parent elements | <sw-compu-method>
Attributes for SW-COMPU-GENERIC-MATH
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description The conversion formula is described by a general mathematical expression.

Example


21.11. SW-COMPU-METHOD

Figure 222: DTD-diagram for SW-COMPU-METHOD
Child elements | <admin-data> <long-name> <short-name> <sw-unit-ref> <sw-asap-6-prm-method> <sw-compu-method-table> <sw-compu-method-text> <prog-code> <sw-compu-generic-math>
parent elements | <sw-compu-methods>
Attributes for SW-COMPU-METHOD
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | SW-COMPU-METHOD |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Conversion formula. Computing procedure according to which a control-unit-internal variable can be converted into its physical value. The conversion formula must be reversible.

Example


21.12. SW-COMPU-METHOD-REF

Figure 223: DTD-diagram for SW-COMPU-METHOD-REF
Child elements | none
parent elements | <net-signal-spec-variant>
Attributes for SW-COMPU-METHOD-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND SW-COMPU-METHOD |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[SW-COMPU-METHOD] | idref | required |  |
Description Reference to a conversion formula

Example


21.13. SW-COMPU-METHOD-TABLE

Figure 224: DTD-diagram for SW-COMPU-METHOD-TABLE
Child elements | <sw-compu-method-value-pair>
parent elements | <sw-compu-method>
Attributes for SW-COMPU-METHOD-TABLE
Name | Type | Class | Value | Remark
[INTERPOLATION-STYLE] | nmtkgrp | default | INTERPOLATION INTERPOLATION NO-INTERPOLATION DISCRETE |
[S] | cdata | implied |  |
Description With this form for the conversion formula, the relationship between internal and physical presentation is given using a table of for the internal-physical pairs of values. An attribute interpolation-style is given that can take the values interpolation (default) and discrete.

Example


21.14. SW-COMPU-METHOD-TEXT

Figure 225: DTD-diagram for SW-COMPU-METHOD-TEXT
Child elements | <sw-compu-method-text-pair>
parent elements | <sw-compu-method>
Attributes for SW-COMPU-METHOD-TEXT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description The conversion formula is described in text form. Unlike the other types of conversions, the physical side does not constitute a number but rather a text. Applications are conceivable for switches ("on"/"off") or for country identification ( "D", "F", "US").

Example
<sw-compu-method-text>
   <sw-compu-method-text-pair>
      <cmt-int>0</cmt-int>
      <cmt-text>Heck</cmt-text>
   </cmt-compu-method-text-pair>
   <sw-compu-method-text-pair>
      <cmt-int>16</cmt-int>
      <cmt-text>16</cmt-text>
   </cmt-compu-method-text-pair>
</sw-compu-method-text>


21.15. SW-COMPU-METHOD-TEXT-PAIR

Figure 226: DTD-diagram for SW-COMPU-METHOD-TEXT-PAIR
Child elements | <cmt-int> <cmt-text>
parent elements | <sw-compu-method-text>
Attributes for SW-COMPU-METHOD-TEXT-PAIR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Includes an internal and a text-form value for text-type conversion formulae.

Example
<sw-compu-method-text-pair>
   <cmt-int>0</cmt-int>
   <cmt-text>Heck</cmt-text>
</cmt-compu-method-text-pair>


21.16. SW-COMPU-METHOD-VALUE-PAIR

Figure 227: DTD-diagram for SW-COMPU-METHOD-VALUE-PAIR
Child elements | <cmt-int> <cmt-phys>
parent elements | <sw-compu-method-table>
Attributes for SW-COMPU-METHOD-VALUE-PAIR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Includes an internal and a physical value for tabular types of conversion formulae.

Example


21.17. SW-COMPU-METHODS

Figure 228: DTD-diagram for SW-COMPU-METHODS
Child elements | <admin-data> <sw-compu-method>
parent elements | <net-signal-spec>
Attributes for SW-COMPU-METHODS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description List of conversion formulae.

Example


21.18. SW-LIMITS

Figure 229: DTD-diagram for SW-LIMITS
Child elements | <phys> <coded> <coded> <phys>
parent elements | <net-signal-spec-variant>
Attributes for SW-LIMITS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Minimum and maximum values for the physical and the control-unit-internal values are given here.

Example
<sw-variable-implementation>
   <sw-base-type>UBYTE</sw-base-type>
   <sw-limits>
      <phys>
         <phys-min>40.000000</phys-min>
         <phys-max>4000.000000</phys-max>
      </phys>
   </sw-limits>
      ...
</sw-variable-implementation>


21.19. SW-UNIT

Figure 230: DTD-diagram for SW-UNIT
Child elements | <admin-data> <long-name> <short-name> <sw-unit-display> <si-unit> <sw-unit-ref> <sw-unit-to-ref-method> <sw-unit-from-ref-method>
parent elements | <sw-units>
Attributes for SW-UNIT
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | SW-UNIT |
[ID] | id | required |  |
[S] | cdata | implied |  |


21.20. SW-UNIT-DISPLAY

Figure 231: DTD-diagram for SW-UNIT-DISPLAY
Child elements | <sup> <sub>
parent elements | <sw-unit>
Attributes for SW-UNIT-DISPLAY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22. SW-UNIT-FROM-REF-METHOD ... SYSTEM-OVERVIEW

Structure Principles of MSRNET.DTD
22. SW-UNIT-FROM-REF-METHOD ... SYSTEM-OVERVIEW

Contents of this chapter:
  • 22.1. SW-UNIT-FROM-REF-METHOD
  • 22.2. SW-UNIT-REF
  • 22.3. SW-UNIT-TO-REF-METHOD
  • 22.4. SW-UNITS
  • 22.5. SYNC-EDGE
  • 22.6. SYSTEM-OVERVIEW


22.1. SW-UNIT-FROM-REF-METHOD

Figure 232: DTD-diagram for SW-UNIT-FROM-REF-METHOD
Child elements | none
parent elements | <sw-unit>
Attributes for SW-UNIT-FROM-REF-METHOD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.2. SW-UNIT-REF

Figure 233: DTD-diagram for SW-UNIT-REF
Child elements | none
parent elements | <sw-compu-method> <sw-unit>
Attributes for SW-UNIT-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND SW-UNIT |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[SW-UNIT] | idref | required |  |


22.3. SW-UNIT-TO-REF-METHOD

Figure 234: DTD-diagram for SW-UNIT-TO-REF-METHOD
Child elements | none
parent elements | <sw-unit>
Attributes for SW-UNIT-TO-REF-METHOD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.4. SW-UNITS

Figure 235: DTD-diagram for SW-UNITS
Child elements | <admin-data> <sw-unit>
parent elements | <net-signal-spec>
Attributes for SW-UNITS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


22.5. SYNC-EDGE

Figure 236: DTD-diagram for SYNC-EDGE
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <net-interface-prms>
Attributes for SYNC-EDGE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |


22.6. SYSTEM-OVERVIEW

Figure 237: DTD-diagram for SYSTEM-OVERVIEW
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for SYSTEM-OVERVIEW
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Null


23. TABLE ... TT

Structure Principles of MSRNET.DTD
23. TABLE ... TT

Contents of this chapter:
  • 23.1. TABLE
  • 23.2. TBD
  • 23.3. TBODY
  • 23.4. TBR
  • 23.5. TEAM-MEMBER
  • 23.6. TEAM-MEMBER-REF
  • 23.7. TEAM-MEMBER-REFS
  • 23.8. TEAM-MEMBERS
  • 23.9. TEX-MATH
  • 23.10. TEXT
  • 23.11. TFOOT
  • 23.12. TGROUP
  • 23.13. THEAD
  • 23.14. TOL
  • 23.15. TOPIC-1
  • 23.16. TOPIC-2
  • 23.17. TOPOLOGY-TYPE
  • 23.18. TRANSMISSION-PRMS
  • 23.19. TRANSMISSION-SPEC
  • 23.20. TT


23.1. TABLE

Figure 238: DTD-diagram for TABLE
Child elements | <long-name> <short-name> <tgroup>
parent elements | <add-info> <chapter> <driver-concept> <introduction> <ncoi-1> <ncoi-3> <net-emc-design> <net-line-desc> <net-message-desc> <net-message-layout> <segmentation-desc> <topic-1> <topic-2>
Attributes for TABLE
Name | Type | Class | Value | Remark
[COLSEP] | number | implied |  |
[F-ID-CLASS] | name | fixed | TABLE |
[FLOAT] | nmtkgrp | implied | FLOAT NO-FLOAT |
[FRAME] | nmtkgrp | implied | TOP BOTTOM TOPBOT ALL SIDES NONE |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[ORIENT] | nmtkgrp | implied | PORT LAND |
[PGWIDE] | number | implied |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[SHORTENTRY] | number | implied |  |
[TABSTYLE] | nmtoken | implied |  |
[TOCENTRY] | number | default | 1 |
Description Identifies a table.


23.2. TBD

Figure 239: DTD-diagram for TBD
Child elements | <team-member-refs> <schedule> <desc>
parent elements | <acceptance-cond> <add-spec> <connection-comp-spec-1> <demarcation-other-projects> <dir-hand-over-doc-data> <general-net-spec> <general-project-data> <integration-capability> <net-architecture> <net-block-modes> <net-diag-spec> <net-error-handling> <net-init-spec> <net-interface-spec> <net-line-spec> <net-message-spec> <net-mgmt-spec> <net-node-spec> <net-oper-spec> <net-signal-spec> <net-topology-spec> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <segmentation-spec> <system-overview> <variant-spec>
Attributes for TBD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Specifies that this information (see parent element) will be defined. The context of this element describes the reason why the information isn't defined.


23.3. TBODY

Figure 240: DTD-diagram for TBODY
Child elements | <row>
parent elements | <tgroup>
Attributes for TBODY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[VALIGN] | nmtkgrp | default | TOP TOP MIDDLE BOTTOM |
Description Defines the table body.


23.4. TBR

Figure 241: DTD-diagram for TBR
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie> <std> <xdoc> <xfile>
parent elements | <acceptance-cond> <add-spec> <connection-comp-spec-1> <demarcation-other-projects> <dir-hand-over-doc-data> <general-net-spec> <general-project-data> <integration-capability> <net-architecture> <net-block-modes> <net-diag-spec> <net-error-handling> <net-init-spec> <net-interface-spec> <net-line-spec> <net-message-spec> <net-mgmt-spec> <net-node-spec> <net-oper-spec> <net-signal-spec> <net-topology-spec> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <segmentation-spec> <system-overview> <variant-spec>
Attributes for TBR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Null


23.5. TEAM-MEMBER

Figure 242: DTD-diagram for TEAM-MEMBER
Child elements | <roles> <long-name> <short-name> <department> <address> <zip> <city> <phone> <fax> <email> <homepage>
parent elements | <team-members>
Attributes for TEAM-MEMBER
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | TEAM-MEMBER |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Definition of a team member.


23.6. TEAM-MEMBER-REF

Figure 243: DTD-diagram for TEAM-MEMBER-REF
Child elements | none
parent elements | <doc-revision> <team-member-refs>
Attributes for TEAM-MEMBER-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND TEAM-MEMBER |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[TEAM-MEMBER] | idref | required |  |
Description Reference to an team member.


23.7. TEAM-MEMBER-REFS

Figure 244: DTD-diagram for TEAM-MEMBER-REFS
Child elements | <team-member-ref>
parent elements | <tbd>
Attributes for TEAM-MEMBER-REFS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description List of references to team member.


23.8. TEAM-MEMBERS

Figure 245: DTD-diagram for TEAM-MEMBERS
Child elements | <team-member>
parent elements | <company>
Attributes for TEAM-MEMBERS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element groups some team-member of a company for the actual project.


23.9. TEX-MATH

Figure 246: DTD-diagram for TEX-MATH
Child elements | none
parent elements | <formula>
Attributes for TEX-MATH
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Describes a TeX (LaTeX) formular


23.10. TEXT

Figure 247: DTD-diagram for TEXT
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for TEXT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of text.


23.11. TFOOT

Figure 248: DTD-diagram for TFOOT
Child elements | <colspec> <row>
parent elements | <tgroup>
Attributes for TFOOT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[VALIGN] | nmtkgrp | default | TOP TOP MIDDLE BOTTOM |
Description Identifies the footer information in a table displayed after the <tbody> and also at the bottom of any <tbody> rows before a physical break.


23.12. TGROUP

Figure 249: DTD-diagram for TGROUP
Child elements | <colspec> <spanspec> <thead> <tfoot> <tbody>
parent elements | <table>
Attributes for TGROUP
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | default | LEFT LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | default |  |
[CHAROFF] | nutoken | default | 50 |
[COLS] | number | required |  |
[COLSEP] | number | implied |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[TGROUPSTYLE] | nmtoken | implied |  |
Description Each <tgroup> effectively identifies a new partition of a table. If a new <colspec> is provided, it replaces a previous one. If both <colspec> and <spanspec> are new, <spanspec> should refer to columns in the most recent <colspec>.


23.13. THEAD

Figure 250: DTD-diagram for THEAD
Child elements | <colspec> <row>
parent elements | <tgroup>
Attributes for THEAD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[VALIGN] | nmtkgrp | default | BOTTOM TOP MIDDLE BOTTOM |
Description Identifies the heading information in a table, displayed at the top of the table and again at the top of any continuation after a physical break between <rows> in <tbody>.


23.14. TOL

Figure 251: DTD-diagram for TOL
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for TOL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of a tolerance of the defined <value>.


23.15. TOPIC-1

Figure 252: DTD-diagram for TOPIC-1
Child elements | <long-name> <short-name> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms>
parent elements | <add-info> <chapter> <driver-concept> <ncoi-1> <net-emc-design> <net-line-desc> <net-message-desc> <net-message-layout> <segmentation-desc>
Attributes for TOPIC-1
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | TOPIC |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description This element groups tables, parameter groups, figures, lists and paragraphs. It has the same function as a sub-chapter or sub-section.


23.16. TOPIC-2

Figure 253: DTD-diagram for TOPIC-2
Child elements | <long-name> <short-name> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table>
parent elements | <introduction> <ncoi-3>
Attributes for TOPIC-2
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | TOPIC |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description This element groups tables, figures, lists and paragraphs. It has the same function as a sub-chapter or sub-section.


23.17. TOPOLOGY-TYPE

Figure 254: DTD-diagram for TOPOLOGY-TYPE
Child elements | none
parent elements | <net-topology-spec>
Attributes for TOPOLOGY-TYPE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


23.18. TRANSMISSION-PRMS

Figure 255: DTD-diagram for TRANSMISSION-PRMS
Child elements | <powerup-receive-time> <powerup-transmit-time> <powerdown-receive-time> <latency-time> <cycle-time> <phase-relations> <prm>
parent elements | <transmission-spec>
Attributes for TRANSMISSION-PRMS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


23.19. TRANSMISSION-SPEC

Figure 256: DTD-diagram for TRANSMISSION-SPEC
Child elements | <transmission-prms> <add-info>
parent elements | <net-message>
Attributes for TRANSMISSION-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |


23.20. TT

Figure 257: DTD-diagram for TT
Child elements | none
parent elements | <change> <desc> <indent-sample> <item-label> <long-name> <long-name-1> <p> <reason> <tbr>
Attributes for TT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[TYPE] | nmtkgrp | required | SGMLTAG SGML-ATTRIBUTE TOOL PRODUCT VARIABLE STATE PRM MATERIAL CONTROL-ELEMENT CODE ORGANISATION OTHER |
[USER-DEFINED-TYPE] | cdata | implied |  |
Description technical term


24. TYP ... TYP

Structure Principles of MSRNET.DTD
24. TYP ... TYP

Contents of this chapter:
  • 24.1. TYP


24.1. TYP

Figure 258: DTD-diagram for TYP
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for TYP
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Defines a typical value.


25. UNIT ... USED-LANGUAGES

Structure Principles of MSRNET.DTD
25. UNIT ... USED-LANGUAGES

Contents of this chapter:
  • 25.1. UNIT
  • 25.2. USED-LANGUAGES


25.1. UNIT

Figure 259: DTD-diagram for UNIT
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for UNIT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of a unit. Please use the standardized SI symbols.


25.2. USED-LANGUAGES

Figure 260: DTD-diagram for USED-LANGUAGES
Child elements | none
parent elements | <admin-data>
Attributes for USED-LANGUAGES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Null


26. V ... VERBATIM

Structure Principles of MSRNET.DTD
26. V ... VERBATIM

Contents of this chapter:
  • 26.1. V
  • 26.2. VALUE
  • 26.3. VARIANT-CHAR
  • 26.4. VARIANT-CHAR-ASSIGN
  • 26.5. VARIANT-CHAR-ASSIGNS
  • 26.6. VARIANT-CHAR-REF
  • 26.7. VARIANT-CHAR-VALUE
  • 26.8. VARIANT-CHARS
  • 26.9. VARIANT-DEF
  • 26.10. VARIANT-DEF-REF
  • 26.11. VARIANT-DEF-REFS
  • 26.12. VARIANT-DEFS
  • 26.13. VARIANT-SPEC
  • 26.14. VERBATIM


26.1. V

Figure 261: DTD-diagram for V
Child elements | none
parent elements | <schematic-element>
Attributes for V
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Specifies a value.


26.2. VALUE

Figure 262: DTD-diagram for VALUE
Child elements | none
parent elements | <variant-char-value>
Attributes for VALUE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Specifies the value of a variant characteristic.


26.3. VARIANT-CHAR

Figure 263: DTD-diagram for VARIANT-CHAR
Child elements | <long-name> <short-name> <code>
parent elements | <variant-chars>
Attributes for VARIANT-CHAR
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | VARIANT-CHAR |
[ID] | id | required |  |
[S] | cdata | implied |  |
[TYPE] | nmtkgrp | required | NEW-PART-NUMBER NO-NEW-PART-NUMBER |
Description Definition of a variant characteristic.


26.4. VARIANT-CHAR-ASSIGN

Figure 264: DTD-diagram for VARIANT-CHAR-ASSIGN
Child elements | <variant-char-ref> <variant-char-value>
parent elements | <variant-char-assigns>
Attributes for VARIANT-CHAR-ASSIGN
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Assigns a variant characteristic.


26.5. VARIANT-CHAR-ASSIGNS

Figure 265: DTD-diagram for VARIANT-CHAR-ASSIGNS
Child elements | <variant-char-assign>
parent elements | <variant-def>
Attributes for VARIANT-CHAR-ASSIGNS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Assigns variant characteristics.


26.6. VARIANT-CHAR-REF

Figure 266: DTD-diagram for VARIANT-CHAR-REF
Child elements | none
parent elements | <variant-char-assign>
Attributes for VARIANT-CHAR-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND VARIANT-CHAR |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[VARIANT-CHAR] | idref | required |  |
Description Reference to a variant chararteristic.


26.7. VARIANT-CHAR-VALUE

Figure 267: DTD-diagram for VARIANT-CHAR-VALUE
Child elements | <value> <code>
parent elements | <variant-char-assign>
Attributes for VARIANT-CHAR-VALUE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains the value of a variant charateristic.


26.8. VARIANT-CHARS

Figure 268: DTD-diagram for VARIANT-CHARS
Child elements | <variant-char>
parent elements | <variant-spec>
Attributes for VARIANT-CHARS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Definition of variant characteristics.


26.9. VARIANT-DEF

Figure 269: DTD-diagram for VARIANT-DEF
Child elements | <long-name> <short-name> <code> <variant-char-assigns>
parent elements | <variant-defs>
Attributes for VARIANT-DEF
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | VARIANT-DEF |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description General definition of a variant.


26.10. VARIANT-DEF-REF

Figure 270: DTD-diagram for VARIANT-DEF-REF
Child elements | none
parent elements | <variant-def-refs>
Attributes for VARIANT-DEF-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND VARIANT-DEF |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[VARIANT-DEF] | idref | required |  |
Description Reference to a variant definition.


26.11. VARIANT-DEF-REFS

Figure 271: DTD-diagram for VARIANT-DEF-REFS
Child elements | <variant-def-ref>
parent elements | <net-message> <net-message-signal> <net-signal> <net-signal-spec-variant> <node-variant> <segment> <sender>
Attributes for VARIANT-DEF-REFS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description References to a variant definition.


26.12. VARIANT-DEFS

Figure 272: DTD-diagram for VARIANT-DEFS
Child elements | <variant-def>
parent elements | <variant-spec>
Attributes for VARIANT-DEFS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description General definitions of a variant.


26.13. VARIANT-SPEC

Figure 273: DTD-diagram for VARIANT-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <variant-chars> <variant-defs>
parent elements | <general-project-data>
Attributes for VARIANT-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description Specification of a variant.


26.14. VERBATIM

Figure 274: DTD-diagram for VERBATIM
Child elements | none
parent elements | <add-info> <chapter> <driver-concept> <entry> <figure> <formula> <introduction> <item> <labeled-item> <ncoi-1> <ncoi-3> <net-emc-design> <net-line-desc> <net-message-desc> <net-message-layout> <remark> <segmentation-desc> <topic-1> <topic-2>
Attributes for VERBATIM
Name | Type | Class | Value | Remark
[ALLOW-BREAK] | number | default | 1 |
[FLOAT] | nmtkgrp | implied | FLOAT NO-FLOAT |
[HELP-ENTRY] | cdata | implied |  |
[S] | cdata | implied |  |
Description Used to indicate if the text is to be picked up and laid down as it is. Typically, it implies the usage of a monospace font and the designated point size. All record ends are retained. The use of tabs in verbatim text may cause unexpected results and should therefore be avoided.


27. XDOC ... XREF

Structure Principles of MSRNET.DTD
27. XDOC ... XREF

Contents of this chapter:
  • 27.1. XDOC
  • 27.2. XFILE
  • 27.3. XREF


27.1. XDOC

Figure 275: DTD-diagram for XDOC
Child elements | <long-name-1> <short-name> <number> <state-1> <date-1> <publisher> <file> <position>
parent elements | <p> <tbr>
Attributes for XDOC
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | date-1:date |
[F-ID-CLASS] | name | fixed | XDOC |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Specifiy an external document which is not accessed by the SGML-System. The content of this external document is 'not included' in the document instance or presented in a report.


27.2. XFILE

Figure 276: DTD-diagram for XFILE
Child elements | <long-name-1> <short-name> <file>
parent elements | <p> <tbr>
Attributes for XFILE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | XFILE |
[ID] | id | required |  |
[S] | cdata | implied |  |
Description Specifiy an external file which is not accessed by the SGML-System. The content of this external file is 'not included' in the document instance or presented in a report.


27.3. XREF

Figure 277: DTD-diagram for XREF
Child elements | none
parent elements | <change> <desc> <indent-sample> <item-label> <p> <reason> <tbr>
Attributes for XREF
Name | Type | Class | Value | Remark
[EXT-ID-CLASS] | cdata | implied |  |
[HYNAMES] | names | fixed | LINKEND ID-REF |
[HYTIME] | name | fixed | CLINK |
[ID-CLASS] | nmtkgrp | required | CHAPTER COMPANY CONNECTION-COMP DEF-ITEM FIGURE FORMULA NET-LINE NET-MESSAGE NET-MESSAGE-SET NET-NODE NET-NODE-PORT NET-SIGNAL NET-SIGNAL-GROUP PRM SAMPLE STD SW-COMPU-METHOD SW-UNIT TABLE TEAM-MEMBER TOPIC VARIANT-CHAR VARIANT-DEF XDOC XFILE EXTERNAL |
[ID-REF] | idref | required |  |
[S] | cdata | implied |  |
Description Reference inside a paragraph to objects (elements with identifier) in the document. The type attribute classifies this reference into following classes: - figures - tables - external documents - parameters - standards - other For the output, the processing system will use this classes for difference presentation.


28. ZIP ... ZIP

Structure Principles of MSRNET.DTD
28. ZIP ... ZIP

Contents of this chapter:
  • 28.1. ZIP


28.1. ZIP

Figure 278: DTD-diagram for ZIP
Child elements | none
parent elements | <team-member>
Attributes for ZIP
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
Description This element contains the ZIP of the used address.


Technical Terms

Structure Principles of MSRNET.DTD
Technical Terms

Code
code
crpctmt.wmf
ENTITY
organization
other
product
scale="0.5"
SDATA
SGML-attribute
SGMLTAG
Organisations
ASAP
OTHER
discrete
ECU
interpolation
interpolation-style
Products
ASAP2
ASCET
MSRNET DTD
MSRREP DTD
MSRSW DTD
SGML Attributes
ALIGN, ALIGN, ALIGN, ALIGN
ALLOW-BREAK
AMOUNT-OF-SUBSTANCE-EXPO
BREAK
CATEGORY
CHAR, CHAR, CHAR, CHAR
CHAROFF, CHAROFF, CHAROFF, CHAROFF
COLNAME, COLNAME
COLNUM
COLS
COLSEP, COLSEP, COLSEP, COLSEP, COLSEP
COLWIDTH
COMPANY
CONNECTION-COMP
DOCORSUB
ELECTRIC-CURRENT-EXPO
EXT-ID-CLASS
F-CHILD-TYPE, F-CHILD-TYPE, F-CHILD-TYPE, F-CHILD-TYPE, F-CHILD-TYPE, F-CHILD-TYPE, F-CHILD-TYPE, F-CHILD-TYPE, F-CHILD-TYPE
F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS
F-NAMESPACE, F-NAMESPACE, F-NAMESPACE
F-PUBID
FILENAME, FILENAME
FIT
FLOAT, FLOAT, FLOAT
FRAME
HEIGHT
HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY
HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES
HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME
ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID
ID-CLASS
ID-REF
INTERPOLATION-STYLE
ITEM-LABEL-POS
LANG-SUBSET
LENGTH-EXPO
LUMINOUS-INTENSITY-EXPO
MASS-EXPO
MOREROWS
NAMEEND, NAMEEND
NAMEST, NAMEST
NAMETYPE
NET-NODE
NET-NODE-PORT
NET-PORT
NET-SIGNAL
NOTATION, NOTATION
NOTE-TYPE
ORIENT
PGWIDE
PROG-LANG
PUBID
ROLE
ROTATE
ROWSEP, ROWSEP, ROWSEP, ROWSEP, ROWSEP, ROWSEP
S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S
SAMPLE
SCALE
SHORTENTRY
SPANNAME, SPANNAME
SW-COMPU-METHOD
SW-UNIT
TABSTYLE
TEAM-MEMBER
TGROUPSTYLE
THERMODYNAMIC-TEMPERATURE-EXPO
TIME-EXPO
TOCENTRY
TOOL
TOOL-VERSION
type
USED-LIBS
USER-DEFINED-TYPE, USER-DEFINED-TYPE
VALIGN, VALIGN, VALIGN, VALIGN
VARIANT-CHAR
VARIANT-DEF
WIDTH
SGML Elements
short-name
abs, abs, abs, abs
acceptance-cond, acceptance-cond, acceptance-cond, acceptance-cond, acceptance-cond, acceptance-cond
add-info, add-info, add-info, add-info, add-info, add-info, add-info, add-info, add-info, add-info, add-info, add-info, add-info, add-info, add-info, add-info, add-info, add-info, add-info, add-info
add-spec, add-spec, add-spec, add-spec, add-spec, add-spec, add-spec, add-spec, add-spec, add-spec, add-spec, add-spec
address
admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data
baudrate, baudrate, baudrate, baudrate, baudrate
bitsize, bitsize
btl-cycles, btl-cycles, btl-cycles, btl-cycles, btl-cycles
byte-order
c-code
calc-net-message-identifiers, calc-net-message-identifiers, calc-net-message-identifiers
change, change, change, change, change, change, change, change
chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter
city
cmt-int, cmt-int
cmt-phys
cmt-text
code, code, code, code
coded, coded, coded
coded-max
coded-min
colspec, colspec, colspec
companies, companies
company, company, company, company, company
company-doc-info, company-doc-info, company-doc-info, company-doc-info, company-doc-info
company-doc-infos, company-doc-infos
company-ref, company-ref
company-revision-info, company-revision-info, company-revision-info, company-revision-info, company-revision-info
company-revision-infos, company-revision-infos
cond, cond
connection-comp-1, connection-comp-1, connection-comp-1, connection-comp-1, connection-comp-1, connection-comp-1, connection-comp-1, connection-comp-1, connection-comp-1, connection-comp-1
connection-comp-class
connection-comp-prms, connection-comp-prms
connection-comp-ref, connection-comp-ref
connection-comp-spec-1, connection-comp-spec-1, connection-comp-spec-1, connection-comp-spec-1, connection-comp-spec-1, connection-comp-spec-1, connection-comp-spec-1
connection-comps-1, connection-comps-1
cycle-time, cycle-time, cycle-time, cycle-time, cycle-time
date, date
date-1, date-1
def, def
def-item, def-item, def-item, def-item
def-list, def-list, def-list, def-list, def-list, def-list, def-list, def-list, def-list, def-list, def-list, def-list, def-list, def-list, def-list, def-list, def-list, def-list
demarcation-other-projects, demarcation-other-projects, demarcation-other-projects, demarcation-other-projects, demarcation-other-projects, demarcation-other-projects
department
desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc
dir-hand-over-doc-data, dir-hand-over-doc-data, dir-hand-over-doc-data, dir-hand-over-doc-data, dir-hand-over-doc-data, dir-hand-over-doc-data
dlc
doc-label
doc-revision, doc-revision, doc-revision, doc-revision, doc-revision
doc-revisions, doc-revisions
drawing-number
driver-concept, driver-concept, driver-concept, driver-concept, driver-concept, driver-concept, driver-concept, driver-concept, driver-concept, driver-concept, driver-concept, driver-concept, driver-concept
e, e, e, e, e, e, e
email
entity-name
entry, entry, entry, entry, entry, entry, entry, entry, entry
error-value
error-values, error-values
fax
figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure
file, file, file
formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula
ft, ft, ft, ft, ft, ft, ft
general-net-spec, general-net-spec, general-net-spec, general-net-spec, general-net-spec, general-net-spec, general-net-spec
general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data
generic-math
graphic, graphic, graphic
homepage
identifier
identifier-base-address
identifier-mask
identifier-type
ie, ie, ie, ie, ie, ie, ie, ie, ie, ie, ie
indent-sample, indent-sample, indent-sample, indent-sample, indent-sample, indent-sample, indent-sample, indent-sample
init-value
integration-capability, integration-capability, integration-capability, integration-capability, integration-capability, integration-capability
interface-circuit, interface-circuit, interface-circuit, interface-circuit
introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction
item, item, item, item, item, item, item, item
item-label, item-label, item-label, item-label, item-label, item-label, item-label, item-label
label, label, label, label, label, label, label, label
labeled-item, labeled-item, labeled-item, labeled-item, labeled-item, labeled-item, labeled-item, labeled-item, labeled-item
labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list
language
latency-time, latency-time, latency-time, latency-time, latency-time
list, list, list, list, list, list, list, list, list, list, list, list, list, list, list, list, list
locs, locs
long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name
long-name-1, long-name-1, long-name-1, long-name-1, long-name-1
max, max, max, max
message-identifier-offset
min, min, min, min
modification, modification, modification
modifications, modifications
msrnet, msrnet, msrnet, msrnet, msrnet, msrnet, msrnet, msrnet
msrsw
multiplex-entry, multiplex-entry, multiplex-entry
multiplex-signal-list, multiplex-signal-list
multiplex-signal-set, multiplex-signal-set, multiplex-signal-set, multiplex-signal-set
multiplexor, multiplexor, multiplexor
multiplexor-value
na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na
nameloc, nameloc, nameloc, nameloc
ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1
ncoi-3, ncoi-3, ncoi-3, ncoi-3, ncoi-3, ncoi-3, ncoi-3, ncoi-3, ncoi-3, ncoi-3, ncoi-3
net-architecture, net-architecture, net-architecture, net-architecture, net-architecture, net-architecture, net-architecture, net-architecture, net-architecture, net-architecture
net-block-modes, net-block-modes, net-block-modes, net-block-modes, net-block-modes, net-block-modes
net-diag-spec, net-diag-spec, net-diag-spec, net-diag-spec, net-diag-spec, net-diag-spec
net-emc-design, net-emc-design, net-emc-design, net-emc-design, net-emc-design, net-emc-design, net-emc-design, net-emc-design, net-emc-design, net-emc-design, net-emc-design, net-emc-design, net-emc-design
net-error-handling, net-error-handling, net-error-handling, net-error-handling, net-error-handling, net-error-handling
net-init-spec, net-init-spec, net-init-spec, net-init-spec, net-init-spec, net-init-spec
net-interface-prms, net-interface-prms, net-interface-prms, net-interface-prms, net-interface-prms, net-interface-prms, net-interface-prms
net-interface-spec, net-interface-spec, net-interface-spec, net-interface-spec, net-interface-spec, net-interface-spec, net-interface-spec, net-interface-spec, net-interface-spec, net-interface-spec
net-line, net-line, net-line, net-line
net-line-desc, net-line-desc, net-line-desc, net-line-desc, net-line-desc, net-line-desc, net-line-desc, net-line-desc, net-line-desc, net-line-desc, net-line-desc, net-line-desc, net-line-desc
net-line-spec, net-line-spec, net-line-spec, net-line-spec, net-line-spec, net-line-spec
net-lines, net-lines
net-message, net-message, net-message, net-message, net-message, net-message, net-message, net-message, net-message, net-message, net-message, net-message, net-message, net-message, net-message
net-message-desc, net-message-desc, net-message-desc, net-message-desc, net-message-desc, net-message-desc, net-message-desc, net-message-desc, net-message-desc, net-message-desc, net-message-desc, net-message-desc, net-message-desc
net-message-identifier, net-message-identifier, net-message-identifier
net-message-identifiers, net-message-identifiers
net-message-layout, net-message-layout, net-message-layout, net-message-layout, net-message-layout, net-message-layout, net-message-layout, net-message-layout, net-message-layout, net-message-layout, net-message-layout, net-message-layout, net-message-layout
net-message-set, net-message-set, net-message-set, net-message-set
net-message-sets, net-message-sets
net-message-signal, net-message-signal, net-message-signal, net-message-signal, net-message-signal, net-message-signal
net-message-signals, net-message-signals, net-message-signals
net-message-spec, net-message-spec, net-message-spec, net-message-spec, net-message-spec, net-message-spec, net-message-spec
net-messages, net-messages
net-mgmt-spec, net-mgmt-spec, net-mgmt-spec, net-mgmt-spec, net-mgmt-spec, net-mgmt-spec
net-node, net-node, net-node, net-node
net-node-port, net-node-port, net-node-port, net-node-port, net-node-port, net-node-port
net-node-port-ref
net-node-ports, net-node-ports
net-node-ref, net-node-ref
net-node-spec, net-node-spec, net-node-spec, net-node-spec, net-node-spec, net-node-spec
net-node-variants, net-node-variants
net-nodes, net-nodes
net-oper-spec, net-oper-spec, net-oper-spec, net-oper-spec, net-oper-spec, net-oper-spec, net-oper-spec, net-oper-spec, net-oper-spec, net-oper-spec, net-oper-spec, net-oper-spec, net-oper-spec, net-oper-spec
net-port-ref
net-signal, net-signal, net-signal, net-signal
net-signal-class
net-signal-group, net-signal-group, net-signal-group, net-signal-group, net-signal-group
net-signal-groups, net-signal-groups
net-signal-ref
net-signal-spec, net-signal-spec, net-signal-spec, net-signal-spec, net-signal-spec, net-signal-spec, net-signal-spec, net-signal-spec, net-signal-spec, net-signal-spec
net-signal-spec-variant, net-signal-spec-variant, net-signal-spec-variant, net-signal-spec-variant, net-signal-spec-variant, net-signal-spec-variant, net-signal-spec-variant, net-signal-spec-variant, net-signal-spec-variant, net-signal-spec-variant
net-signal-spec-variants, net-signal-spec-variants
net-signals, net-signals
net-topology-spec, net-topology-spec, net-topology-spec, net-topology-spec, net-topology-spec, net-topology-spec, net-topology-spec, net-topology-spec, net-topology-spec, net-topology-spec, net-topology-spec, net-topology-spec
nmlist
node-type
node-variant, node-variant, node-variant, node-variant, node-variant, node-variant, node-variant
note, note, note, note, note, note, note, note, note, note, note, note, note, note, note, note, note, note, note
number
objectives, objectives, objectives, objectives, objectives, objectives
offset, offset
overall-project, overall-project, overall-project
p, p, p, p, p, p, p, p, p, p, p, p, p, p, p, p, p, p, p, p, p, p, p, p, p, p, p, p, p, p
parallel-designs, parallel-designs, parallel-designs, parallel-designs, parallel-designs, parallel-designs
part-number
phase-relations, phase-relations, phase-relations, phase-relations, phase-relations
phone
phys, phys, phys
phys-max
phys-min
position, position
powerdown-receive-time, powerdown-receive-time, powerdown-receive-time, powerdown-receive-time, powerdown-receive-time
powerup-receive-time, powerup-receive-time, powerup-receive-time, powerup-receive-time, powerup-receive-time
powerup-transmit-time, powerup-transmit-time, powerup-transmit-time, powerup-transmit-time, powerup-transmit-time
private-code
private-codes, private-codes
prm, prm, prm, prm, prm, prm, prm
prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char
prms, prms, prms, prms, prms, prms, prms, prms, prms, prms, prms, prms
prog-code
project, project, project, project
project-data, project-data, project-data
project-schedule, project-schedule, project-schedule, project-schedule, project-schedule, project-schedule
protocol-conformance
protocols, protocols, protocols, protocols, protocols, protocols
publisher
purchasing-cond, purchasing-cond, purchasing-cond, purchasing-cond, purchasing-cond, purchasing-cond
reason, reason, reason, reason, reason, reason, reason, reason
reason-order, reason-order, reason-order, reason-order, reason-order, reason-order
receivers, receivers
remark, remark, remark, remark, remark, remark, remark, remark, remark
revision-label
role
roles, roles
row, row, row, row
sample, sample, sample, sample
sample-point, sample-point, sample-point, sample-point, sample-point
sample-rate, sample-rate, sample-rate, sample-rate, sample-rate
sample-ref
sample-spec, sample-spec, sample-spec, sample-spec, sample-spec, sample-spec
samples, samples
schedule, schedule, schedule
schematic-element, schematic-element, schematic-element
schematic-elements, schematic-elements
segment, segment, segment, segment, segment
segment-end-nodes, segment-end-nodes
segment-length, segment-length, segment-length, segment-length, segment-length
segmentation-desc, segmentation-desc, segmentation-desc, segmentation-desc, segmentation-desc, segmentation-desc, segmentation-desc, segmentation-desc, segmentation-desc, segmentation-desc, segmentation-desc, segmentation-desc, segmentation-desc
segmentation-spec, segmentation-spec, segmentation-spec, segmentation-spec, segmentation-spec, segmentation-spec, segmentation-spec, segmentation-spec
segments, segments
sender, sender, sender
senders, senders, senders
short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name
si-unit
sjw, sjw, sjw, sjw, sjw
spanspec
state
state-1, state-1
std, std, std, std, std, std, std, std, std
sub, sub, sub, sub, sub, sub, sub, sub, sub, sub, sub, sub, sub, sub, sub, sub
subtitle
sup, sup, sup, sup, sup, sup, sup, sup, sup, sup, sup, sup, sup, sup, sup, sup
sw-asap-6-prm-method
sw-base-type
sw-compu-generic-math
sw-compu-method, sw-compu-method, sw-compu-method, sw-compu-method, sw-compu-method, sw-compu-method, sw-compu-method, sw-compu-method, sw-compu-method, sw-compu-method
sw-compu-method-ref
sw-compu-method-table, sw-compu-method-table
sw-compu-method-text, sw-compu-method-text
sw-compu-method-text-pair, sw-compu-method-text-pair, sw-compu-method-text-pair
sw-compu-method-value-pair, sw-compu-method-value-pair, sw-compu-method-value-pair
sw-compu-methods, sw-compu-methods, sw-compu-methods
sw-limits, sw-limits, sw-limits
sw-param-value-block
sw-prm
sw-unit, sw-unit, sw-unit, sw-unit, sw-unit, sw-unit, sw-unit, sw-unit, sw-unit
sw-unit-display, sw-unit-display, sw-unit-display
sw-unit-from-ref-method
sw-unit-ref, sw-unit-ref
sw-unit-to-ref-method
sw-units, sw-units, sw-units
sync-edge, sync-edge, sync-edge, sync-edge, sync-edge
system-overview, system-overview, system-overview, system-overview, system-overview, system-overview
table, table, table, table, table, table, table, table, table, table, table, table, table, table, table, table, table
tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd
tbody, tbody
tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr
team-member, team-member, team-member, team-member, team-member, team-member, team-member, team-member, team-member, team-member, team-member, team-member
team-member-ref, team-member-ref
team-member-refs, team-member-refs
team-members, team-members
tex-math
text, text, text
tfoot, tfoot, tfoot
tgroup, tgroup, tgroup, tgroup, tgroup, tgroup
thead, thead, thead
tol, tol, tol, tol
topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1
topic-2, topic-2, topic-2, topic-2, topic-2, topic-2, topic-2, topic-2, topic-2, topic-2, topic-2, topic-2, topic-2
topology-type
transmission-prms, transmission-prms, transmission-prms, transmission-prms, transmission-prms, transmission-prms, transmission-prms, transmission-prms
transmission-spec, transmission-spec, transmission-spec
tt, tt, tt, tt, tt, tt, tt, tt, tt
typ, typ, typ, typ
unit, unit, unit
used-languages
v
value
variant-char, variant-char, variant-char, variant-char
variant-char-assign, variant-char-assign, variant-char-assign
variant-char-assigns, variant-char-assigns
variant-char-ref
variant-char-value, variant-char-value, variant-char-value
variant-chars, variant-chars
variant-def, variant-def, variant-def, variant-def, variant-def
variant-def-ref
variant-def-refs, variant-def-refs, variant-def-refs, variant-def-refs, variant-def-refs, variant-def-refs, variant-def-refs, variant-def-refs
variant-defs, variant-defs
variant-spec, variant-spec, variant-spec, variant-spec, variant-spec, variant-spec, variant-spec
verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim
xdoc, xdoc, xdoc, xdoc, xdoc, xdoc, xdoc, xdoc, xdoc, xdoc
xfile, xfile, xfile, xfile, xfile
xref, xref, xref, xref, xref, xref, xref
zip
Tools
ASAP
entity manager
rendition system
rendition system
SGML Application
SGML tool
SGML tools


Untitled

This is the way how this document is prepared. It is visible in the sgml source.