Elements and attributes of MSRFMEA.DTD

MSR Engineering Documentation (MEDOC)

Elements and attributes of MSRFMEA.DTD
Scope: Failure Mode and Effects Analysis
[ MSRFMEA-EADOC]
Revision: 5
This is a reference document for MSRFMEA DTD describing all elements.
MSRFMEA DTD is part of the MSR development documentation MEDOC.


I. How to read this document

Elements and attributes of MSRFMEA.DTD
I. How to read this document

The following conventions apply
This document is written using MSRREP DTD. The following conventions apply to this document:
<msrsw> SGML elements are noted as technical term [type]=SGMLTAG.

[type] SGML attributes are noted as technical term [type]=SGML-attribute.

sgml-attribute Values of SGML attributes or discrete values for elements are noted as technical term [type]=code

ASAP2 The considered languages resp. DTDs are marked as technical term [type]=product.

ASAP The commitees are noted as [type]=organization

ECU Objects in general are marked as technical terms [type]=other. This might be automotive equipments general objects such as variables etc.

Graphical conventions used in DTD diagrams
The structure of DTDs is shown in the MSR document as DTD diagrams (see convention in DTD diagrams).
Figure 1: convention in DTD diagrams
The meaning of the symbols is:
PCDATA | Processable Character Data (PCDATA) Data that consists of zero or more characters of both text and markup. PCDATA is a declared content keyword. PCDATA is used to indicate that all markup delimiters defined in the SGML declaration will be recognized by the parser as markup in the given element rather than data characters.
RCDATA | Replaceable Character Data (RCDATA) is data that consists of zero or more characters, in which references to substitutions are not recognized (i.e. RCDATA may contain text and entity references, but no sub-elements). See also: CDATA PCDATA.
CDATA | Character Data (CDATA) consists of zero or more text characters, where no markup of any kind is recognized. CDATA is an SGML term. Note that character references are allowed in a CDATA entity (substitution) but not in CDATA content.
ANY | a terminal type indicating that the object may contain text or any element defined in the model.
EMPTY | a terminal type keyword used to indicate that there is no data (i.e. no content, sub-elements or end-tags) for the object allowed in the document instance. This keyword is often used to describe elements that are placeholders or are pointers to external or system-generated data.
One | indicates that the element or the element group occurs exactly once
ZERO-OR-ONE | indicates that the element or the element group is optional
ONE-OR-MORE | indicates that the element or the element group occurs multiple times but at least once
ZERO-OR-MORE | indicates that the element or the element group occurs multiple times but also can be missed (optional)
ORDERED | a connector used to specify that the sibling objects must appear in the document in the order shown in the model
UNORDERED | a connector used to specify that the sibling objects can appear in any order in the document.
SELECTION | a connector used to specify that only one of the sibling objects can appear in the document.
ELEMENT | indicates a single SGML structure element
COLLAPSED | indicates, that the content of the element is not displayed here


II. Allgemeine Projektdaten

Elements and attributes of MSRFMEA.DTD
II. Allgemeine Projektdaten


1. ABS ... ADMIN-DATA

Elements and attributes of MSRFMEA.DTD
1. ABS ... ADMIN-DATA

Contents of this chapter:
  • 1.1. ABS
  • 1.2. ACCEPTANCE-COND
  • 1.3. ADD-SPEC
  • 1.4. ADDRESS
  • 1.5. ADMIN-DATA


1.1. ABS

Figure 2: DTD-diagram for ABS
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for ABS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Absolute value for parameter characteristics. See parameter model (<sw-prm>).

Example
prm
   long-namelong designation/long-name
   short-nameshort designation/short-name
   prm-char
      abs10/abs
      tol5tol
      unitC/unit
   /prm-char
/prm
prm
   long-namelong designation/long-name
   short-nameshort designation/short-name
   prm-char
      min0/min
      typ5typ
      max0/max
      unitC/unit
   /prm-char
/prm


1.2. ACCEPTANCE-COND

Figure 3: DTD-diagram for ACCEPTANCE-COND
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for ACCEPTANCE-COND
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element contains a description of the acceptance conditions of this project.


1.3. ADD-SPEC

Figure 4: DTD-diagram for ADD-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for ADD-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element allows to give additional specifications for which no explicit structure exists. This element usually enforces another chapter in printed material. In opposite to <add-info>, <add-spec> is used as a substitute if no structure exists for the topic, while <add-info> is used where an existing structure is not appropriate.

Example


1.4. ADDRESS

Figure 5: DTD-diagram for ADDRESS
Child elements | none
parent elements | <team-member>
Attributes for ADDRESS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of the address of a team member.


1.5. ADMIN-DATA

Figure 6: DTD-diagram for ADMIN-DATA
Child elements | <language> <used-languages> <company-doc-infos> <lite-revisions> <doc-revisions>
parent elements | <chapter> <fm-action-type> <fm-fault> <fm-fault-type> <fm-function> <fm-function-type> <fm-structure> <fm-structure-element> <general-project-data> <msrfmea>
Attributes for ADMIN-DATA
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | language:selection |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element allows to specifiy adminstrative information regarding the substructure defined by the parent. This information may be versioning, fragmentation etc. The information rather covers the administration of the SGML-instance than the administration of the described subjects.

IQ-Fmea uses this element to describe the languages used in the instance.
Example

admin-data
   languagede/language
   doc-revisions>
      doc-revision>
         company-revision-infos>
            company-revision-info>
               company-ref>msr/company-ref>
               revision-label>10.4/revision-label>
               state>wd/state>
            /company-revision-info>
         /company-revision-infos>
         team-member-ref>/team-member-ref>
         date>1.1.99/date>
         modifications>
            modification type="part-related">
               change>Introduced new Architecture/change>
               reason>Customer request/reason>
            /modification>
         /modifications>
      /doc-revision>
   /doc-revisions>
/admin-data>


2. C-CODE ... COVER-SHEET-STYLE

Elements and attributes of MSRFMEA.DTD
2. C-CODE ... COVER-SHEET-STYLE

Contents of this chapter:
  • 2.1. C-CODE
  • 2.2. CHANGE
  • 2.3. CHAPTER
  • 2.4. CITY
  • 2.5. CODE
  • 2.6. COLSPEC
  • 2.7. COMPANIES
  • 2.8. COMPANY
  • 2.9. COMPANY-DOC-INFO
  • 2.10. COMPANY-DOC-INFOS
  • 2.11. COMPANY-REF
  • 2.12. COMPANY-REVISION-INFO
  • 2.13. COMPANY-REVISION-INFOS
  • 2.14. COND
  • 2.15. COVER-SHEET-STYLE


2.1. C-CODE

Figure 7: DTD-diagram for C-CODE
Child elements | <l-10>
parent elements | <formula>
Attributes for C-CODE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element is used to specify the code of the formula transferred to the programming language C.


2.2. CHANGE

Figure 8: DTD-diagram for CHANGE
Child elements | <l-2>
parent elements | <modification>
Attributes for CHANGE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Describes the change of a document


2.3. CHAPTER

Figure 9: DTD-diagram for CHAPTER
Child elements | <long-name> <short-name> <admin-data> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <chapter> <ncoi-1>
Attributes for CHAPTER
Name | Type | Class | Value | Remark
[BREAK] | nmtkgrp | implied | BREAK NO-BREAK |
[F-ID-CLASS] | name | fixed | CHAPTER |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element is used to write one or more not content oriented chapters. There are also sub chapters possible.


2.4. CITY

Figure 10: DTD-diagram for CITY
Child elements | none
parent elements | <team-member>
Attributes for CITY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of the city of the address.


2.5. CODE

Figure 11: DTD-diagram for CODE
Child elements | none
parent elements | <variant-char> <variant-char-value> <variant-def>
Attributes for CODE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element contains the definition of the code.


2.6. COLSPEC

Figure 12: DTD-diagram for COLSPEC
Child elements | none
parent elements | <tfoot> <tgroup> <thead>
Attributes for COLSPEC
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | implied | LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | implied |  |
[CHAROFF] | nutoken | implied |  |
[COLNAME] | nmtoken | implied |  |
[COLNUM] | number | implied |  |
[COLSEP] | number | implied |  |
[COLWIDTH] | cdata | implied |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Specifies a column, a vertical portion of a <entry>. The default values come from the <tgroup>, <thead> or <tfoot> starting the current group. Each <colspec> is for a single column, so it properly has a column number, column, implicitly in order starting from 1, and an optional colname by which it is known when used in any <spanspec> or in <entry>. A <colspec> set on <thead or <tfoot> should be complete for all columns. It overrides those on the containing <tgroup> and applies to just the <thead> or <tfoot>. If there is no <colspec> used within <thead> or <tfoot>, then the <colspec> of the containing <tgroup> is used. <colspec>s from the containing <tgroup> apply to <tbody>.


2.7. COMPANIES

Figure 13: DTD-diagram for COMPANIES
Child elements | <company>
parent elements | <fm-head>
Attributes for COMPANIES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definitions of some companies.


2.8. COMPANY

Figure 14: DTD-diagram for COMPANY
Child elements | <long-name> <short-name> <desc> <team-members> <general-project-data>
parent elements | <companies>
Attributes for COMPANY
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | long-name:selection |
[F-ID-CLASS] | name | fixed | COMPANY |
[F-NAMESPACE] | names | fixed | SAMPLE TEAM-MEMBER VARIANT-DEF VARIANT-CHAR |
[ID] | id | required |  |
[ROLE] | nmtkgrp | required | MANUFACTURER SUPPLIER |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of a company with all team members for this project.


2.9. COMPANY-DOC-INFO

Figure 15: DTD-diagram for COMPANY-DOC-INFO
Child elements | <company-ref> <doc-label> <private-codes> <entity-name>
parent elements | <company-doc-infos>
Attributes for COMPANY-DOC-INFO
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Company specific document informations.


2.10. COMPANY-DOC-INFOS

Figure 16: DTD-diagram for COMPANY-DOC-INFOS
Child elements | <company-doc-info>
parent elements | <admin-data>
Attributes for COMPANY-DOC-INFOS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Company specific document information.


2.11. COMPANY-REF

Figure 17: DTD-diagram for COMPANY-REF
Child elements | none
parent elements | <company-doc-info> <company-revision-info>
Attributes for COMPANY-REF
Name | Type | Class | Value | Remark
[COMPANY] | idref | required |  |
[HYNAMES] | names | fixed | LINKEND COMPANY |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Reference to a company (supplier).


2.12. COMPANY-REVISION-INFO

Figure 18: DTD-diagram for COMPANY-REVISION-INFO
Child elements | <company-ref> <revision-label> <state> <introduction>
parent elements | <company-revision-infos>
Attributes for COMPANY-REVISION-INFO
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | state:selection |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Company specific document revision.


2.13. COMPANY-REVISION-INFOS

Figure 19: DTD-diagram for COMPANY-REVISION-INFOS
Child elements | <company-revision-info>
parent elements | <doc-revision>
Attributes for COMPANY-REVISION-INFOS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Company specific document revisions.


2.14. COND

Figure 20: DTD-diagram for COND
Child elements | <p>
parent elements | <prm-char>
Attributes for COND
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Defines specific conditions under this parameter characteristic is allowed.


2.15. COVER-SHEET-STYLE

Figure 21: DTD-diagram for COVER-SHEET-STYLE
Child elements | none
parent elements | <user-cover-sheet>
Attributes for COVER-SHEET-STYLE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


3. DATE ... DOC-REVISIONS

Elements and attributes of MSRFMEA.DTD
3. DATE ... DOC-REVISIONS

Contents of this chapter:
  • 3.1. DATE
  • 3.2. DATE-1
  • 3.3. DEF
  • 3.4. DEF-ITEM
  • 3.5. DEF-LIST
  • 3.6. DEMARCATION-OTHER-PROJECTS
  • 3.7. DEPARTMENT
  • 3.8. DESC
  • 3.9. DIR-HAND-OVER-DOC-DATA
  • 3.10. DOC-LABEL
  • 3.11. DOC-REVISION
  • 3.12. DOC-REVISIONS


3.1. DATE

Figure 22: DTD-diagram for DATE
Child elements | <l-10>
parent elements | <doc-revision> <lite-revision> <schedule>
Attributes for DATE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Specifies a date. The specification of the date is only possible in one language. - last handling - publishing - creation.


3.2. DATE-1

Figure 23: DTD-diagram for DATE-1
Child elements | none
parent elements | <fm-task-schedule> <fm-task-sets> <std> <xdoc>
Attributes for DATE-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description With this element it is possible to specify a date in several languages.


3.3. DEF

Figure 24: DTD-diagram for DEF
Child elements | <p>
parent elements | <def-item>
Attributes for DEF
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This is a element of an definition list


3.4. DEF-ITEM

Figure 25: DTD-diagram for DEF-ITEM
Child elements | <long-name> <short-name> <def>
parent elements | <def-list>
Attributes for DEF-ITEM
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | DEF-ITEM |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


3.5. DEF-LIST

Figure 26: DTD-diagram for DEF-LIST
Child elements | <def-item>
parent elements | <chapter> <entry> <fm-form-sheet-presentation> <introduction> <item> <labeled-item> <ncoi-1> <remark> <topic-1> <topic-2>
Attributes for DEF-LIST
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element allows the user to define a list.


3.6. DEMARCATION-OTHER-PROJECTS

Figure 27: DTD-diagram for DEMARCATION-OTHER-PROJECTS
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for DEMARCATION-OTHER-PROJECTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Specifies the demarcation and differences to other projects.


3.7. DEPARTMENT

Figure 28: DTD-diagram for DEPARTMENT
Child elements | none
parent elements | <team-member>
Attributes for DEPARTMENT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element contains the name of the department.


3.8. DESC

Figure 29: DTD-diagram for DESC
Child elements | <l-2>
parent elements | <company> <figure> <fm-action> <fm-action-type> <fm-fault> <fm-fault-type> <fm-form-sheet> <fm-function> <fm-function-type> <fm-significance> <fm-structure> <fm-structure-element> <fm-task-schedule> <fm-task-set> <fm-task-sets> <fm-task-sets> <fm-team> <fm-tool> <misc> <prm> <tbd> <team-member>
Attributes for DESC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Short text description of the object.


3.9. DIR-HAND-OVER-DOC-DATA

Figure 30: DTD-diagram for DIR-HAND-OVER-DOC-DATA
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for DIR-HAND-OVER-DOC-DATA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Directory of all documents which are hand-over the project-partner.


3.10. DOC-LABEL

Figure 31: DTD-diagram for DOC-LABEL
Child elements | <l-10>
parent elements | <company-doc-info>
Attributes for DOC-LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Name of the document


3.11. DOC-REVISION

Figure 32: DTD-diagram for DOC-REVISION
Child elements | <company-revision-infos> <team-member-ref> <date> <modifications>
parent elements | <doc-revisions>
Attributes for DOC-REVISION
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | date:date |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element describes a document revision


3.12. DOC-REVISIONS

Figure 33: DTD-diagram for DOC-REVISIONS
Child elements | <doc-revision>
parent elements | <admin-data>
Attributes for DOC-REVISIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element describes the document revisions


4. E ... ENTRY

Elements and attributes of MSRFMEA.DTD
4. E ... ENTRY

Contents of this chapter:
  • 4.1. E
  • 4.2. EMAIL
  • 4.3. ENTITY-NAME
  • 4.4. ENTRY


4.1. E

Figure 34: DTD-diagram for E
Child elements | none
parent elements | <l-1> <l-2>
Attributes for E
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
[TYPE] | nmtkgrp | default | BOLD BOLD ITALIC |
Description Identifies the scope of emphasized information.


4.2. EMAIL

Figure 35: DTD-diagram for EMAIL
Child elements | none
parent elements | <team-member>
Attributes for EMAIL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of the email-address.


4.3. ENTITY-NAME

Figure 36: DTD-diagram for ENTITY-NAME
Child elements | none
parent elements | <company-doc-info>
Attributes for ENTITY-NAME
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Filename of the document fragment.


4.4. ENTRY

Figure 37: DTD-diagram for ENTRY
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <row>
Attributes for ENTRY
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | implied | LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | implied |  |
[CHAROFF] | nutoken | implied |  |
[COLNAME] | nmtoken | implied |  |
[COLSEP] | number | implied |  |
[MOREROWS] | number | default | 0 |
[NAMEEND] | nmtoken | implied |  |
[NAMEST] | nmtoken | implied |  |
[ROTATE] | number | default | 0 |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[SPANNAME] | nmtoken | implied |  |
[T] | cdata | implied |  |
[VALIGN] | nmtkgrp | default | TOP TOP BOTTOM MIDDLE |
Description Identifies an entry in a table. Default values come from the <table>, <tgroup>, <colspec>, <spanspec>, <thead>, <tbody> or <row>; attributes. An entry not specified by a <spanspec> get the defaults from its starting column.


5. FAX ... FM-EXTERNAL-ACTIONS-DETECT

Elements and attributes of MSRFMEA.DTD
5. FAX ... FM-EXTERNAL-ACTIONS-DETECT

Contents of this chapter:
  • 5.1. FAX
  • 5.2. FIGURE
  • 5.3. FILE
  • 5.4. FM-ACTION
  • 5.5. FM-ACTION-CLASS
  • 5.6. FM-ACTION-COMMENT
  • 5.7. FM-ACTION-REF
  • 5.8. FM-ACTION-STATE
  • 5.9. FM-ACTION-TYPE
  • 5.10. FM-ACTION-TYPE-CLASS
  • 5.11. FM-ACTION-TYPE-DECOMPOSITION
  • 5.12. FM-ACTION-TYPE-REF
  • 5.13. FM-ACTION-TYPES
  • 5.14. FM-ACTIONS
  • 5.15. FM-CAUSES
  • 5.16. FM-COUNTER-TASKS
  • 5.17. FM-DETECTION-TASKS
  • 5.18. FM-EXTERNAL-ACTION
  • 5.19. FM-EXTERNAL-ACTIONS-CONTROL
  • 5.20. FM-EXTERNAL-ACTIONS-DETECT


5.1. FAX

Figure 38: DTD-diagram for FAX
Child elements | none
parent elements | <team-member>
Attributes for FAX
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Contents the fax number of an address.


5.2. FIGURE

Figure 39: DTD-diagram for FIGURE
Child elements | <long-name> <short-name> <l-graphic> <verbatim> <desc>
parent elements | <chapter> <entry> <fm-form-sheet-presentation> <introduction> <item> <labeled-item> <ncoi-1> <remark> <topic-1> <topic-2>
Attributes for FIGURE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FIGURE |
[FLOAT] | nmtkgrp | implied | FLOAT NO-FLOAT |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Identifies a figure in the document.


5.3. FILE

Figure 40: DTD-diagram for FILE
Child elements | none
parent elements | <std> <xdoc> <xfile>
Attributes for FILE
Name | Type | Class | Value | Remark
[FILENAME] | cdata | required |  |
[NOTATION] | cdata | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
[TOOL] | cdata | required |  |
[TOOL-VERSION] | cdata | required |  |
Description Definition of a filename (complete path).


5.4. FM-ACTION

Figure 41: DTD-diagram for FM-ACTION
Child elements | <long-name> <short-name> <desc> <fm-action-class> <fm-action-type-ref> <team-member-ref> <fm-task-schedule> <fm-action-state> <fm-action-comment>
parent elements | <fm-actions>
Attributes for FM-ACTION
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FM-ACTION |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This element specifies actions (measures) in IQ-Fmea. Two existing kinds of actions must be specified: the counter-action (Preventive- oder Vermeidungsmaßnahmen) and the detection-action (Control- oder Entdeckungsmaßnahmen). This kind of action is written in the element FM-ACTION-PURPOSE


5.5. FM-ACTION-CLASS

Figure 42: DTD-diagram for FM-ACTION-CLASS
Child elements | none
parent elements | <fm-action>
Attributes for FM-ACTION-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


5.6. FM-ACTION-COMMENT

Figure 43: DTD-diagram for FM-ACTION-COMMENT
Child elements | <l-2>
parent elements | <fm-action>
Attributes for FM-ACTION-COMMENT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


5.7. FM-ACTION-REF

Figure 44: DTD-diagram for FM-ACTION-REF
Child elements | none
parent elements | <fm-counter-tasks> <fm-detection-tasks> <fm-external-action>
Attributes for FM-ACTION-REF
Name | Type | Class | Value | Remark
[FM-ACTION] | idref | required |  |
[HYNAMES] | names | fixed | LINKEND FM-ACTION |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

FM-Action-Ref is a reference to an existing FM-Action. All references in IQ-Fmea are implemented by Uniq-Identifiers. These are Integers with the size 2^64. Each of this Integers identifies exactly one IQ-Object.


5.8. FM-ACTION-STATE

Figure 45: DTD-diagram for FM-ACTION-STATE
Child elements | none
parent elements | <fm-action>
Attributes for FM-ACTION-STATE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

FM-Action-State qualifies the work-off of an action. Four states are defined: inProgress, untouched, finished, irrelevant.


5.9. FM-ACTION-TYPE

Figure 46: DTD-diagram for FM-ACTION-TYPE
Child elements | <long-name> <short-name> <desc> <admin-data> <fm-action-type-class> <fm-action-type-decomposition>
parent elements | <fm-action-types>
Attributes for FM-ACTION-TYPE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FM-ACTION-TYPE |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

The FM-Action-Type element is equivalent to the FM-Function-Type element


5.10. FM-ACTION-TYPE-CLASS

Figure 47: DTD-diagram for FM-ACTION-TYPE-CLASS
Child elements | none
parent elements | <fm-action-type>
Attributes for FM-ACTION-TYPE-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


5.11. FM-ACTION-TYPE-DECOMPOSITION

Figure 48: DTD-diagram for FM-ACTION-TYPE-DECOMPOSITION
Child elements | <fm-action-type-ref>
parent elements | <fm-action-type>
Attributes for FM-ACTION-TYPE-DECOMPOSITION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

The FM-Action-Type-Decomposition is equivalent to the FM-Function-Type-Decomposition


5.12. FM-ACTION-TYPE-REF

Figure 49: DTD-diagram for FM-ACTION-TYPE-REF
Child elements | none
parent elements | <fm-action> <fm-action-type-decomposition>
Attributes for FM-ACTION-TYPE-REF
Name | Type | Class | Value | Remark
[FM-ACTION-TYPE] | idref | required |  |
[HYNAMES] | names | fixed | LINKEND FM-ACTION-TYPE |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

FM-Action-Type-Ref is a reference to an element FM-Action-Type.


5.13. FM-ACTION-TYPES

Figure 50: DTD-diagram for FM-ACTION-TYPES
Child elements | <fm-action-type>
parent elements | <msrfmea>
Attributes for FM-ACTION-TYPES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


5.14. FM-ACTIONS

Figure 51: DTD-diagram for FM-ACTIONS
Child elements | <fm-action>
parent elements | <msrfmea>
Attributes for FM-ACTIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This is a collection with all existing FM-Actions in the instance. Each FM-Action may be referenced with FM-Action-Ref.


5.15. FM-CAUSES

Figure 52: DTD-diagram for FM-CAUSES
Child elements | <fm-fault-ref>
parent elements | <fm-fault>
Attributes for FM-CAUSES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This collection of Fm-fault-refs includes references to FM-Faults. Each reference is a Cause (Ursache) of the Fm-Fault.


5.16. FM-COUNTER-TASKS

Figure 53: DTD-diagram for FM-COUNTER-TASKS
Child elements | <risk-priority-factor> <fm-action-ref>
parent elements | <fm-task-set>
Attributes for FM-COUNTER-TASKS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This is a set of references to FM-Actions, the so-called counter-actions (Vermeidungsmaßnahmen)


5.17. FM-DETECTION-TASKS

Figure 54: DTD-diagram for FM-DETECTION-TASKS
Child elements | <risk-priority-factor> <fm-action-ref>
parent elements | <fm-task-set>
Attributes for FM-DETECTION-TASKS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This is a set of references to FM-Actions, the so-called detection-actions (Entdeckungsmaßnahmen)


5.18. FM-EXTERNAL-ACTION

Figure 55: DTD-diagram for FM-EXTERNAL-ACTION
Child elements | <fm-action-ref> <fm-fault-ref>
parent elements | <fm-external-actions-control> <fm-external-actions-detect>
Attributes for FM-EXTERNAL-ACTION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


5.19. FM-EXTERNAL-ACTIONS-CONTROL

Figure 56: DTD-diagram for FM-EXTERNAL-ACTIONS-CONTROL
Child elements | <fm-external-action>
parent elements | <fm-task-set>
Attributes for FM-EXTERNAL-ACTIONS-CONTROL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


5.20. FM-EXTERNAL-ACTIONS-DETECT

Figure 57: DTD-diagram for FM-EXTERNAL-ACTIONS-DETECT
Child elements | <fm-external-action>
parent elements | <fm-task-set>
Attributes for FM-EXTERNAL-ACTIONS-DETECT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


6. FM-FAULT ... FM-FUNCTION-TYPE-REF

Elements and attributes of MSRFMEA.DTD
6. FM-FAULT ... FM-FUNCTION-TYPE-REF

Contents of this chapter:
  • 6.1. FM-FAULT
  • 6.2. FM-FAULT-CLASS
  • 6.3. FM-FAULT-REF
  • 6.4. FM-FAULT-REFS
  • 6.5. FM-FAULT-TYPE
  • 6.6. FM-FAULT-TYPE-CLASS
  • 6.7. FM-FAULT-TYPE-DECOMPOSITION
  • 6.8. FM-FAULT-TYPE-REF
  • 6.9. FM-FAULT-TYPES
  • 6.10. FM-FAULTS
  • 6.11. FM-FORM-SHEET
  • 6.12. FM-FORM-SHEET-PRESENTATION
  • 6.13. FM-FORM-SHEETS
  • 6.14. FM-FUNCTION
  • 6.15. FM-FUNCTION-CLASS
  • 6.16. FM-FUNCTION-REF
  • 6.17. FM-FUNCTION-TYPE
  • 6.18. FM-FUNCTION-TYPE-CLASS
  • 6.19. FM-FUNCTION-TYPE-DECOMPOSITION
  • 6.20. FM-FUNCTION-TYPE-REF


6.1. FM-FAULT

Figure 58: DTD-diagram for FM-FAULT
Child elements | <long-name> <short-name> <desc> <admin-data> <fm-fault-class> <fm-fault-type-ref> <fm-causes> <fm-significance> <fm-task-history>
parent elements | <fm-faults>
Attributes for FM-FAULT
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FM-FAULT |
[F-NAMESPACE] | names | fixed | FM-TASK-SET FM-TASK-SETS |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

FM-Faults are the (possible) failures of Fm-Functions. Each Fm-Fault may have a significance, which is used to compute the risk-priority-factor. The Fm-Fault holds the Fm-Chg element, which is the root to the Fm-Tasks and further to the Fm-Actions.


6.2. FM-FAULT-CLASS

Figure 59: DTD-diagram for FM-FAULT-CLASS
Child elements | none
parent elements | <fm-fault>
Attributes for FM-FAULT-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


6.3. FM-FAULT-REF

Figure 60: DTD-diagram for FM-FAULT-REF
Child elements | none
parent elements | <fm-causes> <fm-external-action> <fm-fault-refs> <input> <output> <visible>
Attributes for FM-FAULT-REF
Name | Type | Class | Value | Remark
[FM-FAULT] | idref | required |  |
[HYNAMES] | names | fixed | LINKEND FM-FAULT |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[T] | cdata | implied |  |


6.4. FM-FAULT-REFS

Figure 61: DTD-diagram for FM-FAULT-REFS
Child elements | <fm-fault-ref>
parent elements | <fm-function>
Attributes for FM-FAULT-REFS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This is a collection with references to FM-Faults in the instance.


6.5. FM-FAULT-TYPE

Figure 62: DTD-diagram for FM-FAULT-TYPE
Child elements | <long-name> <short-name> <desc> <fm-fault-type-class> <admin-data> <fm-fault-type-decomposition>
parent elements | <fm-fault-types>
Attributes for FM-FAULT-TYPE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FM-FAULT-TYPE |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

The FM-Fault-Type element is equivalent to the FM-Function-Type element


6.6. FM-FAULT-TYPE-CLASS

Figure 63: DTD-diagram for FM-FAULT-TYPE-CLASS
Child elements | none
parent elements | <fm-fault-type>
Attributes for FM-FAULT-TYPE-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


6.7. FM-FAULT-TYPE-DECOMPOSITION

Figure 64: DTD-diagram for FM-FAULT-TYPE-DECOMPOSITION
Child elements | <fm-fault-type-ref>
parent elements | <fm-fault-type>
Attributes for FM-FAULT-TYPE-DECOMPOSITION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


6.8. FM-FAULT-TYPE-REF

Figure 65: DTD-diagram for FM-FAULT-TYPE-REF
Child elements | none
parent elements | <fm-fault> <fm-fault-type-decomposition>
Attributes for FM-FAULT-TYPE-REF
Name | Type | Class | Value | Remark
[FM-FAULT-TYPE] | idref | required |  |
[HYNAMES] | names | fixed | LINKEND FM-FAULT-TYPE |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[T] | cdata | implied |  |


6.9. FM-FAULT-TYPES

Figure 66: DTD-diagram for FM-FAULT-TYPES
Child elements | <fm-fault-type>
parent elements | <msrfmea>
Attributes for FM-FAULT-TYPES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This is a collection with all existing FM-Fault-Types in the instance. Each FM-Fault-Type may be referenced by a FM-Fault-Type-Ref element.


6.10. FM-FAULTS

Figure 67: DTD-diagram for FM-FAULTS
Child elements | <fm-fault>
parent elements | <msrfmea>
Attributes for FM-FAULTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This is a collection with all existing FM-Faults in the instance. Each FM-Fault may be referenced by a FM-Fault-Ref element.


6.11. FM-FORM-SHEET

Figure 68: DTD-diagram for FM-FORM-SHEET
Child elements | <long-name> <short-name> <desc> <user-cover-sheets> <misc-data> <fm-form-sheet-presentation> <fm-structure-element-refs>
parent elements | <fm-form-sheets>
Attributes for FM-FORM-SHEET
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FM-FORM-SHEET |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |


6.12. FM-FORM-SHEET-PRESENTATION

Figure 69: DTD-diagram for FM-FORM-SHEET-PRESENTATION
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <topic-2>
parent elements | <fm-form-sheet>
Attributes for FM-FORM-SHEET-PRESENTATION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This is a cals-tab-description of the visual representation of a fmea-form. Some different layouts are available but just the last active layout is exported. This presentation-layer has no semantic information because all the semantic information of a fmea-form can be restored from the "real" fmea-elements, f. e. Fm-Structure-Element, Fm-Fault, Fm-Function,Fm-Causes etc.


6.13. FM-FORM-SHEETS

Figure 70: DTD-diagram for FM-FORM-SHEETS
Child elements | <fm-form-sheet>
parent elements | <fm-structure>
Attributes for FM-FORM-SHEETS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


6.14. FM-FUNCTION

Figure 71: DTD-diagram for FM-FUNCTION
Child elements | <long-name> <short-name> <desc> <fm-function-class> <admin-data> <fm-function-type-ref> <fm-prerequisites> <fm-fault-refs>
parent elements | <fm-functions>
Attributes for FM-FUNCTION
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FM-FUNCTION |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

Each FM-Function is anchored at one systemelement (FM-Structure-Element). All the functions should describe the aim of their systemelement. Each function is an instance of its type (FM-Function-Type) and may be referenced by FM-Function-Ref.


6.15. FM-FUNCTION-CLASS

Figure 72: DTD-diagram for FM-FUNCTION-CLASS
Child elements | none
parent elements | <fm-function>
Attributes for FM-FUNCTION-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


6.16. FM-FUNCTION-REF

Figure 73: DTD-diagram for FM-FUNCTION-REF
Child elements | none
parent elements | <fm-prerequisites> <fm-se-functions> <input> <output> <visible>
Attributes for FM-FUNCTION-REF
Name | Type | Class | Value | Remark
[FM-FUNCTION] | idref | required |  |
[HYNAMES] | names | fixed | LINKEND FM-FUNCTION |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[T] | cdata | implied |  |


6.17. FM-FUNCTION-TYPE

Figure 74: DTD-diagram for FM-FUNCTION-TYPE
Child elements | <long-name> <short-name> <desc> <fm-function-type-class> <admin-data> <fm-function-type-decomposition>
parent elements | <fm-function-types>
Attributes for FM-FUNCTION-TYPE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FM-FUNCTION-TYPE |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

The FM-Function-Type is the name-provider for each fm-function. This technique is used for fm-functions, fm-faults and fm-actions. Each of this instances has a reference to its type, f. e. fm-function has a reference to its type within FM-Function-Type-Ref.


6.18. FM-FUNCTION-TYPE-CLASS

Figure 75: DTD-diagram for FM-FUNCTION-TYPE-CLASS
Child elements | none
parent elements | <fm-function-type>
Attributes for FM-FUNCTION-TYPE-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


6.19. FM-FUNCTION-TYPE-DECOMPOSITION

Figure 76: DTD-diagram for FM-FUNCTION-TYPE-DECOMPOSITION
Child elements | <fm-function-type-ref>
parent elements | <fm-function-type>
Attributes for FM-FUNCTION-TYPE-DECOMPOSITION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

The FM-Function-Type-Decomposition has the structure of a tree. Each FM-Function-Type has children with other FM-Function-Types. Each FM-Function-Type inherits the name of his parent - the so-called classification-name.


6.20. FM-FUNCTION-TYPE-REF

Figure 77: DTD-diagram for FM-FUNCTION-TYPE-REF
Child elements | none
parent elements | <fm-function> <fm-function-type-decomposition>
Attributes for FM-FUNCTION-TYPE-REF
Name | Type | Class | Value | Remark
[FM-FUNCTION-TYPE] | idref | required |  |
[HYNAMES] | names | fixed | LINKEND FM-FUNCTION-TYPE |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

The FM-Function-Type-Ref is a reference to a FM-Function-Type within the sgml-instance.


7. FM-FUNCTION-TYPES ... FM-STRUCTURE-ROOT

Elements and attributes of MSRFMEA.DTD
7. FM-FUNCTION-TYPES ... FM-STRUCTURE-ROOT

Contents of this chapter:
  • 7.1. FM-FUNCTION-TYPES
  • 7.2. FM-FUNCTIONS
  • 7.3. FM-HEAD
  • 7.4. FM-ID-PREFIX
  • 7.5. FM-IDTABLE
  • 7.6. FM-INTERFACE
  • 7.7. FM-ORPHAN-HOME
  • 7.8. FM-PREREQUISITES
  • 7.9. FM-SE-DECOMPOSITION
  • 7.10. FM-SE-FUNCTIONS
  • 7.11. FM-SIGNIFICANCE
  • 7.12. FM-STRUCTURE
  • 7.13. FM-STRUCTURE-CLASS
  • 7.14. FM-STRUCTURE-ELEMENT
  • 7.15. FM-STRUCTURE-ELEMENT-CLASS
  • 7.16. FM-STRUCTURE-ELEMENT-REF
  • 7.17. FM-STRUCTURE-ELEMENT-REFS
  • 7.18. FM-STRUCTURE-ELEMENTS
  • 7.19. FM-STRUCTURE-OWNER
  • 7.20. FM-STRUCTURE-ROOT


7.1. FM-FUNCTION-TYPES

Figure 78: DTD-diagram for FM-FUNCTION-TYPES
Child elements | <fm-function-type>
parent elements | <msrfmea>
Attributes for FM-FUNCTION-TYPES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


7.2. FM-FUNCTIONS

Figure 79: DTD-diagram for FM-FUNCTIONS
Child elements | <fm-function>
parent elements | <msrfmea>
Attributes for FM-FUNCTIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This is a collection with all existing FM-Functions in the instance. Each FM-Function may be referenced by a FM-Function-Ref element.


7.3. FM-HEAD

Figure 80: DTD-diagram for FM-HEAD
Child elements | <companies> <fm-teams>
parent elements | <msrfmea>
Attributes for FM-HEAD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This is used to hold information about the shared companies within the sgml-instance, the user-profile, employed persons (team-members) and their teams.


7.4. FM-ID-PREFIX

Figure 81: DTD-diagram for FM-ID-PREFIX
Child elements | none
parent elements | <fm-tool>
Attributes for FM-ID-PREFIX
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


7.5. FM-IDTABLE

Figure 82: DTD-diagram for FM-IDTABLE
Child elements | <idc>
parent elements | <fm-tool>
Attributes for FM-IDTABLE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
[TOOL] | name | implied |  |
Description

The Fm-Idtable identifies identities, that are generated by other applications than the Id-Owner. This "mapping" enables the parser, to recognize strange elements, that were formerly changed by himself. Each application uses its own Fm-Idtable, found in Fm-Idtables.


7.6. FM-INTERFACE

Figure 83: DTD-diagram for FM-INTERFACE
Child elements | <input> <output> <visible>
parent elements | <fm-structure>
Attributes for FM-INTERFACE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This element is not used yet. In the future the modules will be implemented. The interface is used to describe incoming,outgoing and visible references to/from a module.


7.7. FM-ORPHAN-HOME

Figure 84: DTD-diagram for FM-ORPHAN-HOME
Child elements | <fm-structure-element-ref>
parent elements | <fm-structure>
Attributes for FM-ORPHAN-HOME
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

The orphan home is a FM-Structure-Element which holds an orphan FM-Function. All "unanchored" Objects are anchored at the orphans.


7.8. FM-PREREQUISITES

Figure 85: DTD-diagram for FM-PREREQUISITES
Child elements | <fm-function-ref>
parent elements | <fm-function>
Attributes for FM-PREREQUISITES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This collection includes references to FM-Functions. Each reference is a prerequisite (Ursache) of the Fm-Function. This is similar to the causes of Fm-Faults.


7.9. FM-SE-DECOMPOSITION

Figure 86: DTD-diagram for FM-SE-DECOMPOSITION
Child elements | <fm-structure-element-ref>
parent elements | <fm-structure-element>
Attributes for FM-SE-DECOMPOSITION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

The Fm-Se-Decomposition describes the tree-structure of the Systemelements within a structure. The root-element is referenced in Fm-Structure. The Fm-Se-Decomposition is the children-collection of each Systemelement.


7.10. FM-SE-FUNCTIONS

Figure 87: DTD-diagram for FM-SE-FUNCTIONS
Child elements | <fm-function-ref>
parent elements | <fm-structure-element>
Attributes for FM-SE-FUNCTIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


7.11. FM-SIGNIFICANCE

Figure 88: DTD-diagram for FM-SIGNIFICANCE
Child elements | <risk-priority-factor> <desc>
parent elements | <fm-fault>
Attributes for FM-SIGNIFICANCE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


7.12. FM-STRUCTURE

Figure 89: DTD-diagram for FM-STRUCTURE
Child elements | <long-name> <short-name> <desc> <admin-data> <fm-structure-class> <fm-structure-owner> <fm-interface> <fm-structure-root> <fm-orphan-home> <fm-form-sheets> <misc-data>
parent elements | <fm-structures>
Attributes for FM-STRUCTURE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FM-STRUCTURE |
[F-NAMESPACE] | names | fixed | FM-FORM-SHEET |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

The FM-Structure is visualized by a tree. The root is one Fm-Structure-element. Each FM-Structure is owned by a team-member and must be classified as system or process (FM-Structure-Class).


7.13. FM-STRUCTURE-CLASS

Figure 90: DTD-diagram for FM-STRUCTURE-CLASS
Child elements | none
parent elements | <fm-structure>
Attributes for FM-STRUCTURE-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


7.14. FM-STRUCTURE-ELEMENT

Figure 91: DTD-diagram for FM-STRUCTURE-ELEMENT
Child elements | <long-name> <short-name> <desc> <fm-structure-element-class> <admin-data> <part-number> <fm-se-decomposition> <fm-se-functions>
parent elements | <fm-structure-elements>
Attributes for FM-STRUCTURE-ELEMENT
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FM-STRUCTURE-ELEMENT |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

The FM-Structure-Elements (systemelements) are the parts, of which a Structure (physically) exists. Fm-Structure-Elements are organized hierachically as a tree (see Fm-Se-Decomposition). Each systemelement has a name and is described by Fm-Functions.


7.15. FM-STRUCTURE-ELEMENT-CLASS

Figure 92: DTD-diagram for FM-STRUCTURE-ELEMENT-CLASS
Child elements | none
parent elements | <fm-structure-element>
Attributes for FM-STRUCTURE-ELEMENT-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


7.16. FM-STRUCTURE-ELEMENT-REF

Figure 93: DTD-diagram for FM-STRUCTURE-ELEMENT-REF
Child elements | none
parent elements | <fm-orphan-home> <fm-se-decomposition> <fm-structure-element-refs> <fm-structure-root> <visible>
Attributes for FM-STRUCTURE-ELEMENT-REF
Name | Type | Class | Value | Remark
[FM-STRUCTURE-ELEMENT] | idref | required |  |
[HYNAMES] | names | fixed | LINKEND FM-STRUCTURE-ELEMENT |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

A reference to a FM-Structure-Element, f.e. in Fm-Se-Decomposition.


7.17. FM-STRUCTURE-ELEMENT-REFS

Figure 94: DTD-diagram for FM-STRUCTURE-ELEMENT-REFS
Child elements | <fm-structure-element-ref>
parent elements | <fm-form-sheet>
Attributes for FM-STRUCTURE-ELEMENT-REFS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


7.18. FM-STRUCTURE-ELEMENTS

Figure 95: DTD-diagram for FM-STRUCTURE-ELEMENTS
Child elements | <fm-structure-element>
parent elements | <msrfmea>
Attributes for FM-STRUCTURE-ELEMENTS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This is a collection with all existing FM-Structure-Elements in the instance. Each FM-Structure-Element may be referenced by a FM-Structure-Element-Ref element.


7.19. FM-STRUCTURE-OWNER

Figure 96: DTD-diagram for FM-STRUCTURE-OWNER
Child elements | <team-member-ref>
parent elements | <fm-structure>
Attributes for FM-STRUCTURE-OWNER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

The Structure-Owner is "responsible" for the Fm-Structure. He determines the User-Access and the visibility of "his" structures.


7.20. FM-STRUCTURE-ROOT

Figure 97: DTD-diagram for FM-STRUCTURE-ROOT
Child elements | <fm-structure-element-ref>
parent elements | <fm-structure>
Attributes for FM-STRUCTURE-ROOT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This is a reference to a FM-Structure-Element and describes the root of the structure-tree.


8. FM-STRUCTURES ... FT

Elements and attributes of MSRFMEA.DTD
8. FM-STRUCTURES ... FT

Contents of this chapter:
  • 8.1. FM-STRUCTURES
  • 8.2. FM-TASK-HISTORY
  • 8.3. FM-TASK-SCHEDULE
  • 8.4. FM-TASK-SET
  • 8.5. FM-TASK-SET-CLASS
  • 8.6. FM-TASK-SETS
  • 8.7. FM-TEAM
  • 8.8. FM-TEAMS
  • 8.9. FM-TOOL
  • 8.10. FM-TOOL-DATA
  • 8.11. FORMULA
  • 8.12. FT


8.1. FM-STRUCTURES

Figure 98: DTD-diagram for FM-STRUCTURES
Child elements | <fm-structure>
parent elements | <msrfmea>
Attributes for FM-STRUCTURES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This is a collection with all existing FM-Structures in the instance.


8.2. FM-TASK-HISTORY

Figure 99: DTD-diagram for FM-TASK-HISTORY
Child elements | <fm-task-sets>
parent elements | <fm-fault>
Attributes for FM-TASK-HISTORY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


8.3. FM-TASK-SCHEDULE

Figure 100: DTD-diagram for FM-TASK-SCHEDULE
Child elements | <date-1> <desc>
parent elements | <fm-action>
Attributes for FM-TASK-SCHEDULE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

Fm-Actions may have deadlines.


8.4. FM-TASK-SET

Figure 101: DTD-diagram for FM-TASK-SET
Child elements | <long-name> <short-name> <desc> <fm-task-set-class> <fm-detection-tasks> <fm-counter-tasks> <fm-external-actions-detect> <fm-external-actions-control>
parent elements | <fm-task-sets>
Attributes for FM-TASK-SET
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FM-TASK-SET |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

Fm-Task-Sets are used to group the Fm-Actions by incidence and discovery.


8.5. FM-TASK-SET-CLASS

Figure 102: DTD-diagram for FM-TASK-SET-CLASS
Child elements | none
parent elements | <fm-task-set>
Attributes for FM-TASK-SET-CLASS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


8.6. FM-TASK-SETS

Figure 103: DTD-diagram for FM-TASK-SETS
Child elements | <long-name> <short-name> <desc> <date-1> <desc> <fm-task-set>
parent elements | <fm-task-history>
Attributes for FM-TASK-SETS
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FM-TASK-SETS |
[F-NAMESPACE] | names | fixed | FM-TASK-SET |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |


8.7. FM-TEAM

Figure 104: DTD-diagram for FM-TEAM
Child elements | <long-name> <short-name> <desc> <team-member-refs>
parent elements | <fm-teams>
Attributes for FM-TEAM
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FM-TEAM |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

A Fm-Team has references to Fm-Team-Members. Each team is named within the Long/Short-Name-element.


8.8. FM-TEAMS

Figure 105: DTD-diagram for FM-TEAMS
Child elements | <fm-team>
parent elements | <fm-head>
Attributes for FM-TEAMS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description

This is a collection with all existing FM-Teams in the instance.


8.9. FM-TOOL

Figure 106: DTD-diagram for FM-TOOL
Child elements | <long-name> <short-name> <desc> <fm-id-prefix> <misc-data> <fm-idtable>
parent elements | <fm-tool-data>
Attributes for FM-TOOL
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FM-TOOL |
[ID] | id | required |  |
[ID-AWARE] | nmtkgrp | default | ID-AWARE ID-AWARE NO-ID-AWARE |
[S] | cdata | implied |  |
[T] | cdata | implied |  |


8.10. FM-TOOL-DATA

Figure 107: DTD-diagram for FM-TOOL-DATA
Child elements | <fm-tool>
parent elements | <msrfmea>
Attributes for FM-TOOL-DATA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


8.11. FORMULA

Figure 108: DTD-diagram for FORMULA
Child elements | <long-name> <short-name> <l-graphic> <verbatim> <tex-math> <c-code> <generic-math>
parent elements | <chapter> <entry> <fm-form-sheet-presentation> <introduction> <item> <labeled-item> <ncoi-1> <remark> <topic-1> <topic-2>
Attributes for FORMULA
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | FORMULA |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


8.12. FT

Figure 109: DTD-diagram for FT
Child elements | none
parent elements | <l-1> <l-2>
Attributes for FT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Identifies the body of a footnote in the document.


9. GENERAL-PROJECT-DATA ... GRAPHIC

Elements and attributes of MSRFMEA.DTD
9. GENERAL-PROJECT-DATA ... GRAPHIC

Contents of this chapter:
  • 9.1. GENERAL-PROJECT-DATA
  • 9.2. GENERIC-MATH
  • 9.3. GRAPHIC


9.1. GENERAL-PROJECT-DATA

Figure 110: DTD-diagram for GENERAL-PROJECT-DATA
Child elements | <na> <tbd> <tbr> <admin-data> <introduction> <system-overview> <reason-order> <objectives> <sample-spec> <variant-spec> <demarcation-other-projects> <parallel-designs> <integration-capability> <acceptance-cond> <project-schedule> <purchasing-cond> <protocols> <dir-hand-over-doc-data> <add-spec>
parent elements | <company>
Attributes for GENERAL-PROJECT-DATA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Specification of all general project data.


9.2. GENERIC-MATH

Figure 111: DTD-diagram for GENERIC-MATH
Child elements | <l-10>
parent elements | <formula>
Attributes for GENERIC-MATH
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


9.3. GRAPHIC

Figure 112: DTD-diagram for GRAPHIC
Child elements | none
parent elements | <l-graphic>
Attributes for GRAPHIC
Name | Type | Class | Value | Remark
[CATEGORY] | nmtkgrp | implied | BARCODE CONCEPTUAL ENGINEERING FLOWCHART GRAPH LOGO SCHEMATIC WAVEFORM |
[FILENAME] | cdata | required |  |
[FIT] | number | default | 0 |
[HEIGHT] | cdata | implied |  |
[NOTATION] | cdata | required |  |
[S] | cdata | implied |  |
[SCALE] | cdata | implied |  |
[T] | cdata | implied |  |
[WIDTH] | cdata | implied |  |
Description Identifies a graphic. A graphic is stored in difference formats (notation attribute) and is used as an illustration in the document.


10. HOMEPAGE ... HOMEPAGE

Elements and attributes of MSRFMEA.DTD
10. HOMEPAGE ... HOMEPAGE

Contents of this chapter:
  • 10.1. HOMEPAGE


10.1. HOMEPAGE

Figure 113: DTD-diagram for HOMEPAGE
Child elements | none
parent elements | <team-member>
Attributes for HOMEPAGE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Homepage of a team member


11. IDC ... ITEM-LABEL

Elements and attributes of MSRFMEA.DTD
11. IDC ... ITEM-LABEL

Contents of this chapter:
  • 11.1. IDC
  • 11.2. IE
  • 11.3. INDENT-SAMPLE
  • 11.4. INPUT
  • 11.5. INTEGRATION-CAPABILITY
  • 11.6. INTRODUCTION
  • 11.7. ITEM
  • 11.8. ITEM-LABEL


11.1. IDC

Figure 114: DTD-diagram for IDC
Child elements | none
parent elements | <fm-idtable>
Attributes for IDC
Name | Type | Class | Value | Remark
[MAPPED-ID] | cdata | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |


11.2. IE

Figure 115: DTD-diagram for IE
Child elements | <sup> <sub>
parent elements | <l-1> <l-2> <l-4> <long-name-1>
Attributes for IE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
[TYPE] | cdata | implied |  |
Description Identifies text of an item to be extracted for the index.


11.3. INDENT-SAMPLE

Figure 116: DTD-diagram for INDENT-SAMPLE
Child elements | <l-2>
parent elements | <labeled-list>
Attributes for INDENT-SAMPLE
Name | Type | Class | Value | Remark
[ITEM-LABEL-POS] | nmtkgrp | default | NO-NEWLINE NO-NEWLINE NEWLINE NEWLINE-IF-NECESSARY |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


11.4. INPUT

Figure 117: DTD-diagram for INPUT
Child elements | <fm-function-ref> <fm-fault-ref>
parent elements | <fm-interface>
Attributes for INPUT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element defines the input of the actual function.


11.5. INTEGRATION-CAPABILITY

Figure 118: DTD-diagram for INTEGRATION-CAPABILITY
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for INTEGRATION-CAPABILITY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element contains all information about the integration capability of this project.


11.6. INTRODUCTION

Figure 119: DTD-diagram for INTRODUCTION
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <topic-2>
parent elements | <acceptance-cond> <add-spec> <company-revision-info> <demarcation-other-projects> <dir-hand-over-doc-data> <general-project-data> <integration-capability> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <system-overview> <variant-spec>
Attributes for INTRODUCTION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element can be used to create an introduction.


11.7. ITEM

Figure 120: DTD-diagram for ITEM
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <list>
Attributes for ITEM
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Identifes an item typically occurring within a list.


11.8. ITEM-LABEL

Figure 121: DTD-diagram for ITEM-LABEL
Child elements | <l-2>
parent elements | <labeled-item>
Attributes for ITEM-LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


12. L-1 ... LONG-NAME-1

Elements and attributes of MSRFMEA.DTD
12. L-1 ... LONG-NAME-1

Contents of this chapter:
  • 12.1. L-1
  • 12.2. L-10
  • 12.3. L-2
  • 12.4. L-3
  • 12.5. L-4
  • 12.6. L-GRAPHIC
  • 12.7. LABEL
  • 12.8. LABELED-ITEM
  • 12.9. LABELED-LIST
  • 12.10. LANGUAGE
  • 12.11. LIST
  • 12.12. LITE-REVISION
  • 12.13. LITE-REVISIONS
  • 12.14. LOCS
  • 12.15. LONG-NAME
  • 12.16. LONG-NAME-1


12.1. L-1

Figure 122: DTD-diagram for L-1
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie> <std> <xdoc> <xfile>
parent elements | <p> <tbr>
Attributes for L-1
Name | Type | Class | Value | Remark
[L] | cdata | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |


12.2. L-10

Figure 123: DTD-diagram for L-10
Child elements | none
parent elements | <c-code> <date> <doc-label> <generic-math> <na> <revision-label> <role> <state> <tex-math> <used-languages> <verbatim>
Attributes for L-10
Name | Type | Class | Value | Remark
[L] | cdata | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |


12.3. L-2

Figure 124: DTD-diagram for L-2
Child elements | <tt> <xref> <e> <ft> <sup> <sub> <ie>
parent elements | <change> <desc> <fm-action-comment> <indent-sample> <item-label> <reason>
Attributes for L-2
Name | Type | Class | Value | Remark
[L] | cdata | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |


12.4. L-3

Figure 125: DTD-diagram for L-3
Child elements | <sup> <sub>
parent elements | <text> <unit>
Attributes for L-3
Name | Type | Class | Value | Remark
[L] | cdata | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |


12.5. L-4

Figure 126: DTD-diagram for L-4
Child elements | <tt> <ie>
parent elements | <label> <long-name>
Attributes for L-4
Name | Type | Class | Value | Remark
[L] | cdata | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |


12.6. L-GRAPHIC

Figure 127: DTD-diagram for L-GRAPHIC
Child elements | <graphic>
parent elements | <figure> <formula>
Attributes for L-GRAPHIC
Name | Type | Class | Value | Remark
[L] | cdata | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |


12.7. LABEL

Figure 128: DTD-diagram for LABEL
Child elements | <l-4>
parent elements | <misc> <note> <prms>
Attributes for LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element contents a short label.


12.8. LABELED-ITEM

Figure 129: DTD-diagram for LABELED-ITEM
Child elements | <item-label> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <labeled-list>
Attributes for LABELED-ITEM
Name | Type | Class | Value | Remark
[HELP-ENTRY] | cdata | implied |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


12.9. LABELED-LIST

Figure 130: DTD-diagram for LABELED-LIST
Child elements | <indent-sample> <labeled-item>
parent elements | <chapter> <entry> <fm-form-sheet-presentation> <introduction> <item> <labeled-item> <ncoi-1> <remark> <topic-1> <topic-2>
Attributes for LABELED-LIST
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


12.10. LANGUAGE

Figure 131: DTD-diagram for LANGUAGE
Child elements | none
parent elements | <admin-data>
Attributes for LANGUAGE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Defines the laguage of the document (fragment).


12.11. LIST

Figure 132: DTD-diagram for LIST
Child elements | <item>
parent elements | <chapter> <entry> <fm-form-sheet-presentation> <introduction> <item> <labeled-item> <ncoi-1> <remark> <topic-1> <topic-2>
Attributes for LIST
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
[TYPE] | nmtkgrp | required | UNNUMBER NUMBER |
Description Identifies a list which is composed of one or more list items. There are two types of lists, numbered and unnumbered lists. They are classified by the type attribute.


12.12. LITE-REVISION

Figure 133: DTD-diagram for LITE-REVISION
Child elements | <revision-label> <state> <team-member-ref> <date> <modifications>
parent elements | <lite-revisions>
Attributes for LITE-REVISION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


12.13. LITE-REVISIONS

Figure 134: DTD-diagram for LITE-REVISIONS
Child elements | <lite-revision>
parent elements | <admin-data>
Attributes for LITE-REVISIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


12.14. LOCS

Figure 135: DTD-diagram for LOCS
Child elements | <nameloc>
parent elements | <msrfmea>
Attributes for LOCS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


12.15. LONG-NAME

Figure 136: DTD-diagram for LONG-NAME
Child elements | <l-4>
parent elements | <chapter> <company> <def-item> <figure> <fm-action> <fm-action-type> <fm-fault> <fm-fault-type> <fm-form-sheet> <fm-function> <fm-function-type> <fm-structure> <fm-structure-element> <fm-task-set> <fm-task-sets> <fm-team> <fm-tool> <formula> <nameloc> <prm> <sample> <table> <team-member> <topic-1> <topic-2> <variant-char> <variant-def>
Attributes for LONG-NAME
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Defines a long name (label, title). This element exists only in elements with identifier.


12.16. LONG-NAME-1

Figure 137: DTD-diagram for LONG-NAME-1
Child elements | <tt> <ie>
parent elements | <std> <xdoc> <xfile>
Attributes for LONG-NAME-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


13. MAX ... MSRFMEA

Elements and attributes of MSRFMEA.DTD
13. MAX ... MSRFMEA

Contents of this chapter:
  • 13.1. MAX
  • 13.2. MIN
  • 13.3. MISC
  • 13.4. MISC-DATA
  • 13.5. MISC-VALUE
  • 13.6. MODIFICATION
  • 13.7. MODIFICATIONS
  • 13.8. MSRFMEA


13.1. MAX

Figure 138: DTD-diagram for MAX
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for MAX
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element defines the maximum value of a typical range. When you define <min> and <max> you have to leave <typ> empty.


13.2. MIN

Figure 139: DTD-diagram for MIN
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for MIN
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Defines the minimum value of a typical range. When you define <min> and <max> you have to leave <typ> empty.


13.3. MISC

Figure 140: DTD-diagram for MISC
Child elements | <label> <desc> <misc-value>
parent elements | <misc-data>
Attributes for MISC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


13.4. MISC-DATA

Figure 141: DTD-diagram for MISC-DATA
Child elements | <misc>
parent elements | <fm-form-sheet> <fm-structure> <fm-tool> <user-cover-sheet>
Attributes for MISC-DATA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


13.5. MISC-VALUE

Figure 142: DTD-diagram for MISC-VALUE
Child elements | none
parent elements | <misc>
Attributes for MISC-VALUE
Name | Type | Class | Value | Remark
[FIELD-NAME] | cdata | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |


13.6. MODIFICATION

Figure 143: DTD-diagram for MODIFICATION
Child elements | <change> <reason>
parent elements | <modifications>
Attributes for MODIFICATION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
[TYPE] | nmtkgrp | required | CONTENT-RELATED DOC-RELATED |
Description Description of a modification (value before and after the changes, position of change).


13.7. MODIFICATIONS

Figure 144: DTD-diagram for MODIFICATIONS
Child elements | <modification>
parent elements | <doc-revision> <lite-revision>
Attributes for MODIFICATIONS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element contains all changes that are made in the document.


13.8. MSRFMEA

Figure 145: DTD-diagram for MSRFMEA
Child elements | <short-name> <admin-data> <fm-head> <fm-tool-data> <fm-structures> <fm-structure-elements> <fm-function-types> <fm-functions> <fm-fault-types> <fm-faults> <fm-action-types> <fm-actions> <locs>
parent elements | none
Attributes for MSRFMEA
Name | Type | Class | Value | Remark
[F-NAMESPACE] | names | fixed | CHAPTER COMPANY DEF-ITEM FIGURE FM-ACTION FM-ACTION-TYPE FM-FAULT FM-FAULT-TYPE FM-FORM-SHEET FM-FUNCTION FM-FUNCTION-TYPE FM-STRUCTURE FM-STRUCTURE-ELEMENT FM-TASK-SET FM-TASK-SETS FM-TEAM FM-TOOL FORMULA PRM SAMPLE STD TABLE TEAM-MEMBER TOPIC VARIANT-CHAR VARIANT-DEF XDOC XFILE EXTERNAL |
[F-PUBID] | cdata | fixed | -//MSR//DTD MSR FMEA DTD:V1.5.0:ML:MSRFMEA.DTD//EN |
[HYTIME] | name | fixed | HYDOC |
[PUBID] | cdata | default | -//MSR//DTD MSR FMEA DTD:V1.5.0:ML:MSRFMEA.DTD//EN |
[S] | cdata | implied |  |
[T] | cdata | implied |  |


14. NA ... NUMBER

Elements and attributes of MSRFMEA.DTD
14. NA ... NUMBER

Contents of this chapter:
  • 14.1. NA
  • 14.2. NAMELOC
  • 14.3. NCOI-1
  • 14.4. NMLIST
  • 14.5. NOTE
  • 14.6. NUMBER


14.1. NA

Figure 146: DTD-diagram for NA
Child elements | <l-10>
parent elements | <acceptance-cond> <add-spec> <demarcation-other-projects> <dir-hand-over-doc-data> <general-project-data> <integration-capability> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <system-overview> <variant-spec>
Attributes for NA
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Specifies that this information (see parent element) isn't applicable for this project . The context of this element describes the reason why the information isn't applicable.


14.2. NAMELOC

Figure 147: DTD-diagram for NAMELOC
Child elements | <long-name> <short-name> <nmlist>
parent elements | <locs>
Attributes for NAMELOC
Name | Type | Class | Value | Remark
[HYTIME] | name | fixed | NAMELOC |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


14.3. NCOI-1

Figure 148: DTD-diagram for NCOI-1
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms> <topic-1> <chapter>
parent elements | <acceptance-cond> <add-spec> <demarcation-other-projects> <dir-hand-over-doc-data> <integration-capability> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample> <system-overview>
Attributes for NCOI-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element contents the following objects to define a 'none content orientend information': topics tables figures paragraphs lists Only use these objects when you can't define all your informations in other elements!


14.4. NMLIST

Figure 149: DTD-diagram for NMLIST
Child elements | none
parent elements | <nameloc>
Attributes for NMLIST
Name | Type | Class | Value | Remark
[DOCORSUB] | entity | implied |  |
[HYTIME] | name | fixed | NMLIST |
[NAMETYPE] | nmtkgrp | default | ELEMENT ENTITY ELEMENT |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


14.5. NOTE

Figure 150: DTD-diagram for NOTE
Child elements | <label> <p>
parent elements | <chapter> <entry> <fm-form-sheet-presentation> <introduction> <item> <labeled-item> <ncoi-1> <remark> <topic-1> <topic-2>
Attributes for NOTE
Name | Type | Class | Value | Remark
[NOTE-TYPE] | nmtkgrp | required | CAUTION HINT TIP INSTRUCTION EXERCISE OTHER |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
[USER-DEFINED-TYPE] | cdata | implied |  |
Description Null


14.6. NUMBER

Figure 151: DTD-diagram for NUMBER
Child elements | none
parent elements | <xdoc>
Attributes for NUMBER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of a number.


15. OBJECTIVES ... OUTPUT

Elements and attributes of MSRFMEA.DTD
15. OBJECTIVES ... OUTPUT

Contents of this chapter:
  • 15.1. OBJECTIVES
  • 15.2. OUTPUT


15.1. OBJECTIVES

Figure 152: DTD-diagram for OBJECTIVES
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for OBJECTIVES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description In ths element the objectives of the project can be specified.


15.2. OUTPUT

Figure 153: DTD-diagram for OUTPUT
Child elements | <fm-function-ref> <fm-fault-ref>
parent elements | <fm-interface>
Attributes for OUTPUT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of the output of a function.


16. P ... PURCHASING-COND

Elements and attributes of MSRFMEA.DTD
16. P ... PURCHASING-COND

Contents of this chapter:
  • 16.1. P
  • 16.2. PARALLEL-DESIGNS
  • 16.3. PART-NUMBER
  • 16.4. PHONE
  • 16.5. POSITION
  • 16.6. PRIVATE-CODE
  • 16.7. PRIVATE-CODES
  • 16.8. PRM
  • 16.9. PRM-CHAR
  • 16.10. PRMS
  • 16.11. PROJECT-SCHEDULE
  • 16.12. PROTOCOLS
  • 16.13. PUBLISHER
  • 16.14. PURCHASING-COND


16.1. P

Figure 154: DTD-diagram for P
Child elements | <l-1>
parent elements | <chapter> <cond> <def> <entry> <fm-form-sheet-presentation> <introduction> <item> <labeled-item> <ncoi-1> <note> <remark> <topic-1> <topic-2>
Attributes for P
Name | Type | Class | Value | Remark
[HELP-ENTRY] | cdata | implied |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Identifies text within a paragraph.


16.2. PARALLEL-DESIGNS

Figure 155: DTD-diagram for PARALLEL-DESIGNS
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PARALLEL-DESIGNS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Description of projects with concurrent informations (part type specifications).


16.3. PART-NUMBER

Figure 156: DTD-diagram for PART-NUMBER
Child elements | none
parent elements | <fm-structure-element>
Attributes for PART-NUMBER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element defines the number of a part.


16.4. PHONE

Figure 157: DTD-diagram for PHONE
Child elements | none
parent elements | <team-member>
Attributes for PHONE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of a phone number.


16.5. POSITION

Figure 158: DTD-diagram for POSITION
Child elements | none
parent elements | <std> <xdoc>
Attributes for POSITION
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Describes the importent position in the standard or external document.


16.6. PRIVATE-CODE

Figure 159: DTD-diagram for PRIVATE-CODE
Child elements | none
parent elements | <private-codes>
Attributes for PRIVATE-CODE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
[TYPE] | cdata | implied |  |
Description This element allows you to interchange one private (encoded) data.


16.7. PRIVATE-CODES

Figure 160: DTD-diagram for PRIVATE-CODES
Child elements | <private-code>
parent elements | <company-doc-info>
Attributes for PRIVATE-CODES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element allows you to interchange private (encoded) data.


16.8. PRM

Figure 161: DTD-diagram for PRM
Child elements | <long-name> <short-name> <desc> <prm-char>
parent elements | <prms>
Attributes for PRM
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | PRM |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of a numeric or alphanumeric (without <operator>, <unit> and <tolerance>) parameter.


16.9. PRM-CHAR

Figure 162: DTD-diagram for PRM-CHAR
Child elements | <cond> <abs> <tol> <min> <typ> <max> <unit> <text> <remark>
parent elements | <prm>
Attributes for PRM-CHAR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description A parameter consits of one or more characteristics. Each characteristic groups an <operator>, <value>, <unit>, <tolerance> and <cond>. Sence it is possible to define a range with two parameter characterists.


16.10. PRMS

Figure 163: DTD-diagram for PRMS
Child elements | <label> <prm>
parent elements | <chapter> <ncoi-1> <topic-1>
Attributes for PRMS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Groups one or more parameters to a parameter table.


16.11. PROJECT-SCHEDULE

Figure 164: DTD-diagram for PROJECT-SCHEDULE
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PROJECT-SCHEDULE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element contains a project schedule.


16.12. PROTOCOLS

Figure 165: DTD-diagram for PROTOCOLS
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PROTOCOLS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element contains all protocols (from the actual company) of this project.


16.13. PUBLISHER

Figure 166: DTD-diagram for PUBLISHER
Child elements | none
parent elements | <xdoc>
Attributes for PUBLISHER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of the publisher of the external document.


16.14. PURCHASING-COND

Figure 167: DTD-diagram for PURCHASING-COND
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for PURCHASING-COND
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element groups existing purchasing conditions.


17. REASON ... ROW

Elements and attributes of MSRFMEA.DTD
17. REASON ... ROW

Contents of this chapter:
  • 17.1. REASON
  • 17.2. REASON-ORDER
  • 17.3. REMARK
  • 17.4. REVISION-LABEL
  • 17.5. RISK-PRIORITY-FACTOR
  • 17.6. ROLE
  • 17.7. ROLES
  • 17.8. ROW


17.1. REASON

Figure 168: DTD-diagram for REASON
Child elements | <l-2>
parent elements | <modification>
Attributes for REASON
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Reason of the change.


17.2. REASON-ORDER

Figure 169: DTD-diagram for REASON-ORDER
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for REASON-ORDER
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Reason of the order.


17.3. REMARK

Figure 170: DTD-diagram for REMARK
Child elements | <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note>
parent elements | <prm-char>
Attributes for REMARK
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Defines a remark.


17.4. REVISION-LABEL

Figure 171: DTD-diagram for REVISION-LABEL
Child elements | <l-10>
parent elements | <company-revision-info> <lite-revision>
Attributes for REVISION-LABEL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Label of a revision.


17.5. RISK-PRIORITY-FACTOR

Figure 172: DTD-diagram for RISK-PRIORITY-FACTOR
Child elements | none
parent elements | <fm-counter-tasks> <fm-detection-tasks> <fm-significance>
Attributes for RISK-PRIORITY-FACTOR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


17.6. ROLE

Figure 173: DTD-diagram for ROLE
Child elements | <l-10>
parent elements | <roles>
Attributes for ROLE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of a team member role (e.g. project leader).


17.7. ROLES

Figure 174: DTD-diagram for ROLES
Child elements | <role>
parent elements | <team-member>
Attributes for ROLES
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | role:selection |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Each team member has one or more roles in the project.


17.8. ROW

Figure 175: DTD-diagram for ROW
Child elements | <entry>
parent elements | <tbody> <tfoot> <thead>
Attributes for ROW
Name | Type | Class | Value | Remark
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Identifies the row information in a <tgroup> of a table. Default values come from the <table>, <tgroup>, <colspec> or <spanspec> attributes.


18. SAMPLE ... SYSTEM-OVERVIEW

Elements and attributes of MSRFMEA.DTD
18. SAMPLE ... SYSTEM-OVERVIEW

Contents of this chapter:
  • 18.1. SAMPLE
  • 18.2. SAMPLE-REF
  • 18.3. SAMPLE-SPEC
  • 18.4. SAMPLES
  • 18.5. SCHEDULE
  • 18.6. SHORT-NAME
  • 18.7. SPANSPEC
  • 18.8. STATE
  • 18.9. STATE-1
  • 18.10. STD
  • 18.11. SUB
  • 18.12. SUBTITLE
  • 18.13. SUP
  • 18.14. SYSTEM-OVERVIEW


18.1. SAMPLE

Figure 176: DTD-diagram for SAMPLE
Child elements | <long-name> <short-name> <ncoi-1>
parent elements | <samples>
Attributes for SAMPLE
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | long-name:selection |
[F-ID-CLASS] | name | fixed | SAMPLE |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of a sample.


18.2. SAMPLE-REF

Figure 177: DTD-diagram for SAMPLE-REF
Child elements | none
parent elements | <schedule>
Attributes for SAMPLE-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND SAMPLE |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[SAMPLE] | idref | required |  |
[T] | cdata | implied |  |
Description Reference to a sample.


18.3. SAMPLE-SPEC

Figure 178: DTD-diagram for SAMPLE-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <samples>
parent elements | <general-project-data>
Attributes for SAMPLE-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


18.4. SAMPLES

Figure 179: DTD-diagram for SAMPLES
Child elements | <sample>
parent elements | <sample-spec>
Attributes for SAMPLES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of a samples.


18.5. SCHEDULE

Figure 180: DTD-diagram for SCHEDULE
Child elements | <sample-ref> <date>
parent elements | <tbd>
Attributes for SCHEDULE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


18.6. SHORT-NAME

Figure 181: DTD-diagram for SHORT-NAME
Child elements | none
parent elements | <chapter> <company> <def-item> <figure> <fm-action> <fm-action-type> <fm-fault> <fm-fault-type> <fm-form-sheet> <fm-function> <fm-function-type> <fm-structure> <fm-structure-element> <fm-task-set> <fm-task-sets> <fm-team> <fm-tool> <formula> <msrfmea> <nameloc> <prm> <sample> <std> <table> <team-member> <topic-1> <topic-2> <variant-char> <variant-def> <xdoc> <xfile>
Attributes for SHORT-NAME
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Identifier or label of a parameter.


18.7. SPANSPEC

Figure 182: DTD-diagram for SPANSPEC
Child elements | none
parent elements | <tgroup>
Attributes for SPANSPEC
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | default | CENTER LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | implied |  |
[CHAROFF] | nutoken | implied |  |
[COLSEP] | number | implied |  |
[NAMEEND] | nmtoken | required |  |
[NAMEST] | nmtoken | required |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[SPANNAME] | nmtoken | required |  |
[T] | cdata | implied |  |
Description Identifies a horizontal span of columns and associated attributes that can subsequently be referenced by its spanname to provide attributes repeatedly used in the entries or entry tables in several rows of the table group controlled by the group <colsdef>, or within the specific <thead>, <tfoot>, or <tbody> context in which the <spanspec> occurs. <Namest> and <nameend> identify the first and last columns in increasing order that identify the span. The reason <colname> is used rather than <colnum> in identifying <spanspec> is that the names are independent of revisions that may change the number of inserted/deleted columns, as long as namest remains to the left of (has a smaller colnum than) <nameend>. <spanspec>s set on <thead> or <tfoot> override those on the containing <tgroup> and apply to just the <thead> or<tfoot>. <spanspec>s from the containing <tgroup> apply to <tbody>.


18.8. STATE

Figure 183: DTD-diagram for STATE
Child elements | <l-10>
parent elements | <company-revision-info> <lite-revision>
Attributes for STATE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Processing state of a document, i.e draft, released.


18.9. STATE-1

Figure 184: DTD-diagram for STATE-1
Child elements | none
parent elements | <std> <xdoc>
Attributes for STATE-1
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of a state (multilingual).


18.10. STD

Figure 185: DTD-diagram for STD
Child elements | <long-name-1> <short-name> <subtitle> <state-1> <date-1> <file> <position>
parent elements | <l-1>
Attributes for STD
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | date-1:date |
[F-ID-CLASS] | name | fixed | STD |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Specification of a standard. A <xref> can refer to a standard within a paragraph.


18.11. SUB

Figure 186: DTD-diagram for SUB
Child elements | none
parent elements | <abs> <ie> <l-1> <l-2> <l-3> <max> <min> <tol> <typ>
Attributes for SUB
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Text which appears or is displayed below the normal base line of text.


18.12. SUBTITLE

Figure 187: DTD-diagram for SUBTITLE
Child elements | none
parent elements | <std>
Attributes for SUBTITLE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element defines a subtitle of the standard.


18.13. SUP

Figure 188: DTD-diagram for SUP
Child elements | none
parent elements | <abs> <ie> <l-1> <l-2> <l-3> <max> <min> <tol> <typ>
Attributes for SUP
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Text which appears or is displayed above the normal base line of text.


18.14. SYSTEM-OVERVIEW

Figure 189: DTD-diagram for SYSTEM-OVERVIEW
Child elements | <na> <tbd> <tbr> <introduction> <ncoi-1>
parent elements | <general-project-data>
Attributes for SYSTEM-OVERVIEW
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


19. TABLE ... TYP

Elements and attributes of MSRFMEA.DTD
19. TABLE ... TYP

Contents of this chapter:
  • 19.1. TABLE
  • 19.2. TBD
  • 19.3. TBODY
  • 19.4. TBR
  • 19.5. TEAM-MEMBER
  • 19.6. TEAM-MEMBER-REF
  • 19.7. TEAM-MEMBER-REFS
  • 19.8. TEAM-MEMBERS
  • 19.9. TEX-MATH
  • 19.10. TEXT
  • 19.11. TFOOT
  • 19.12. TGROUP
  • 19.13. THEAD
  • 19.14. TOL
  • 19.15. TOPIC-1
  • 19.16. TOPIC-2
  • 19.17. TT
  • 19.18. TYP


19.1. TABLE

Figure 190: DTD-diagram for TABLE
Child elements | <long-name> <short-name> <tgroup>
parent elements | <chapter> <fm-form-sheet-presentation> <introduction> <ncoi-1> <topic-1> <topic-2>
Attributes for TABLE
Name | Type | Class | Value | Remark
[COLSEP] | number | implied |  |
[F-ID-CLASS] | name | fixed | TABLE |
[FLOAT] | nmtkgrp | implied | FLOAT NO-FLOAT |
[FRAME] | nmtkgrp | implied | TOP BOTTOM TOPBOT ALL SIDES NONE |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[ORIENT] | nmtkgrp | implied | PORT LAND |
[PGWIDE] | number | implied |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[SHORTENTRY] | number | implied |  |
[T] | cdata | implied |  |
[TABSTYLE] | nmtoken | implied |  |
[TOCENTRY] | number | default | 1 |
Description Identifies a table.


19.2. TBD

Figure 191: DTD-diagram for TBD
Child elements | <team-member-refs> <schedule> <desc>
parent elements | <acceptance-cond> <add-spec> <demarcation-other-projects> <dir-hand-over-doc-data> <general-project-data> <integration-capability> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <system-overview> <variant-spec>
Attributes for TBD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Specifies that this information (see parent element) will be defined. The context of this element describes the reason why the information isn't defined.


19.3. TBODY

Figure 192: DTD-diagram for TBODY
Child elements | <row>
parent elements | <tgroup>
Attributes for TBODY
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
[VALIGN] | nmtkgrp | default | TOP TOP MIDDLE BOTTOM |
Description Defines the table body.


19.4. TBR

Figure 193: DTD-diagram for TBR
Child elements | <l-1>
parent elements | <acceptance-cond> <add-spec> <demarcation-other-projects> <dir-hand-over-doc-data> <general-project-data> <integration-capability> <objectives> <parallel-designs> <project-schedule> <protocols> <purchasing-cond> <reason-order> <sample-spec> <system-overview> <variant-spec>
Attributes for TBR
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


19.5. TEAM-MEMBER

Figure 194: DTD-diagram for TEAM-MEMBER
Child elements | <roles> <long-name> <short-name> <desc> <department> <address> <zip> <city> <phone> <fax> <email> <homepage>
parent elements | <team-members>
Attributes for TEAM-MEMBER
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | TEAM-MEMBER |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of a team member.


19.6. TEAM-MEMBER-REF

Figure 195: DTD-diagram for TEAM-MEMBER-REF
Child elements | none
parent elements | <doc-revision> <fm-action> <fm-structure-owner> <lite-revision> <team-member-refs>
Attributes for TEAM-MEMBER-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND TEAM-MEMBER |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
[TEAM-MEMBER] | idref | required |  |
Description Reference to an team member.


19.7. TEAM-MEMBER-REFS

Figure 196: DTD-diagram for TEAM-MEMBER-REFS
Child elements | <team-member-ref>
parent elements | <fm-team> <tbd>
Attributes for TEAM-MEMBER-REFS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description List of references to team member.


19.8. TEAM-MEMBERS

Figure 197: DTD-diagram for TEAM-MEMBERS
Child elements | <team-member>
parent elements | <company>
Attributes for TEAM-MEMBERS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element groups some team-member of a company for the actual project.


19.9. TEX-MATH

Figure 198: DTD-diagram for TEX-MATH
Child elements | <l-10>
parent elements | <formula>
Attributes for TEX-MATH
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Describes a TeX (LaTeX) formular


19.10. TEXT

Figure 199: DTD-diagram for TEXT
Child elements | <l-3>
parent elements | <prm-char>
Attributes for TEXT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of text.


19.11. TFOOT

Figure 200: DTD-diagram for TFOOT
Child elements | <colspec> <row>
parent elements | <tgroup>
Attributes for TFOOT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
[VALIGN] | nmtkgrp | default | TOP TOP MIDDLE BOTTOM |
Description Identifies the footer information in a table displayed after the <tbody> and also at the bottom of any <tbody> rows before a physical break.


19.12. TGROUP

Figure 201: DTD-diagram for TGROUP
Child elements | <colspec> <spanspec> <thead> <tfoot> <tbody>
parent elements | <table>
Attributes for TGROUP
Name | Type | Class | Value | Remark
[ALIGN] | nmtkgrp | default | LEFT LEFT RIGHT CENTER JUSTIFY CHAR |
[CHAR] | cdata | default |  |
[CHAROFF] | nutoken | default | 50 |
[COLS] | number | required |  |
[COLSEP] | number | implied |  |
[ROWSEP] | number | implied |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
[TGROUPSTYLE] | nmtoken | implied |  |
Description Each <tgroup> effectively identifies a new partition of a table. If a new <colspec> is provided, it replaces a previous one. If both <colspec> and <spanspec> are new, <spanspec> should refer to columns in the most recent <colspec>.


19.13. THEAD

Figure 202: DTD-diagram for THEAD
Child elements | <colspec> <row>
parent elements | <tgroup>
Attributes for THEAD
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[VALIGN] | nmtkgrp | default | BOTTOM TOP MIDDLE BOTTOM |
Description Identifies the heading information in a table, displayed at the top of the table and again at the top of any continuation after a physical break between <rows> in <tbody>.


19.14. TOL

Figure 203: DTD-diagram for TOL
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for TOL
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of a tolerance of the defined <value>.


19.15. TOPIC-1

Figure 204: DTD-diagram for TOPIC-1
Child elements | <long-name> <short-name> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table> <prms>
parent elements | <chapter> <ncoi-1>
Attributes for TOPIC-1
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | TOPIC |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element groups tables, parameter groups, figures, lists and paragraphs. It has the same function as a sub-chapter or sub-section.


19.16. TOPIC-2

Figure 205: DTD-diagram for TOPIC-2
Child elements | <long-name> <short-name> <p> <verbatim> <figure> <formula> <list> <def-list> <labeled-list> <note> <table>
parent elements | <fm-form-sheet-presentation> <introduction>
Attributes for TOPIC-2
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | TOPIC |
[HELP-ENTRY] | cdata | implied |  |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element groups tables, figures, lists and paragraphs. It has the same function as a sub-chapter or sub-section.


19.17. TT

Figure 206: DTD-diagram for TT
Child elements | none
parent elements | <l-1> <l-2> <l-4> <long-name-1>
Attributes for TT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
[TYPE] | nmtkgrp | required | SGMLTAG SGML-ATTRIBUTE TOOL PRODUCT VARIABLE STATE PRM MATERIAL CONTROL-ELEMENT CODE ORGANISATION OTHER |
[USER-DEFINED-TYPE] | cdata | implied |  |
Description technical term


19.18. TYP

Figure 207: DTD-diagram for TYP
Child elements | <sup> <sub>
parent elements | <prm-char>
Attributes for TYP
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Defines a typical value.


20. UNIT ... USER-COVER-SHEETS

Elements and attributes of MSRFMEA.DTD
20. UNIT ... USER-COVER-SHEETS

Contents of this chapter:
  • 20.1. UNIT
  • 20.2. USED-LANGUAGES
  • 20.3. USER-COVER-SHEET
  • 20.4. USER-COVER-SHEETS


20.1. UNIT

Figure 208: DTD-diagram for UNIT
Child elements | <l-3>
parent elements | <prm-char>
Attributes for UNIT
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of a unit. Please use the standardized SI symbols.


20.2. USED-LANGUAGES

Figure 209: DTD-diagram for USED-LANGUAGES
Child elements | <l-10>
parent elements | <admin-data>
Attributes for USED-LANGUAGES
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Null


20.3. USER-COVER-SHEET

Figure 210: DTD-diagram for USER-COVER-SHEET
Child elements | <cover-sheet-style> <misc-data>
parent elements | <user-cover-sheets>
Attributes for USER-COVER-SHEET
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


20.4. USER-COVER-SHEETS

Figure 211: DTD-diagram for USER-COVER-SHEETS
Child elements | <user-cover-sheet>
parent elements | <fm-form-sheet>
Attributes for USER-COVER-SHEETS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


21. VALUE ... VISIBLE

Elements and attributes of MSRFMEA.DTD
21. VALUE ... VISIBLE

Contents of this chapter:
  • 21.1. VALUE
  • 21.2. VARIANT-CHAR
  • 21.3. VARIANT-CHAR-ASSIGN
  • 21.4. VARIANT-CHAR-ASSIGNS
  • 21.5. VARIANT-CHAR-REF
  • 21.6. VARIANT-CHAR-VALUE
  • 21.7. VARIANT-CHARS
  • 21.8. VARIANT-DEF
  • 21.9. VARIANT-DEFS
  • 21.10. VARIANT-SPEC
  • 21.11. VERBATIM
  • 21.12. VISIBLE


21.1. VALUE

Figure 212: DTD-diagram for VALUE
Child elements | none
parent elements | <variant-char-value>
Attributes for VALUE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Specifies the value of a variant characteristic.


21.2. VARIANT-CHAR

Figure 213: DTD-diagram for VARIANT-CHAR
Child elements | <long-name> <short-name> <code>
parent elements | <variant-chars>
Attributes for VARIANT-CHAR
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | VARIANT-CHAR |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
[TYPE] | nmtkgrp | required | NEW-PART-NUMBER NO-NEW-PART-NUMBER |
Description Definition of a variant characteristic.


21.3. VARIANT-CHAR-ASSIGN

Figure 214: DTD-diagram for VARIANT-CHAR-ASSIGN
Child elements | <variant-char-ref> <variant-char-value>
parent elements | <variant-char-assigns>
Attributes for VARIANT-CHAR-ASSIGN
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Assigns a variant characteristic.


21.4. VARIANT-CHAR-ASSIGNS

Figure 215: DTD-diagram for VARIANT-CHAR-ASSIGNS
Child elements | <variant-char-assign>
parent elements | <variant-def>
Attributes for VARIANT-CHAR-ASSIGNS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Assigns variant characteristics.


21.5. VARIANT-CHAR-REF

Figure 216: DTD-diagram for VARIANT-CHAR-REF
Child elements | none
parent elements | <variant-char-assign>
Attributes for VARIANT-CHAR-REF
Name | Type | Class | Value | Remark
[HYNAMES] | names | fixed | LINKEND VARIANT-CHAR |
[HYTIME] | name | fixed | CLINK |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
[VARIANT-CHAR] | idref | required |  |
Description Reference to a variant chararteristic.


21.6. VARIANT-CHAR-VALUE

Figure 217: DTD-diagram for VARIANT-CHAR-VALUE
Child elements | <value> <code>
parent elements | <variant-char-assign>
Attributes for VARIANT-CHAR-VALUE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element contains the value of a variant charateristic.


21.7. VARIANT-CHARS

Figure 218: DTD-diagram for VARIANT-CHARS
Child elements | <variant-char>
parent elements | <variant-spec>
Attributes for VARIANT-CHARS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Definition of variant characteristics.


21.8. VARIANT-DEF

Figure 219: DTD-diagram for VARIANT-DEF
Child elements | <long-name> <short-name> <code> <variant-char-assigns>
parent elements | <variant-defs>
Attributes for VARIANT-DEF
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | VARIANT-DEF |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description General definition of a variant.


21.9. VARIANT-DEFS

Figure 220: DTD-diagram for VARIANT-DEFS
Child elements | <variant-def>
parent elements | <variant-spec>
Attributes for VARIANT-DEFS
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description General definitions of a variant.


21.10. VARIANT-SPEC

Figure 221: DTD-diagram for VARIANT-SPEC
Child elements | <na> <tbd> <tbr> <introduction> <variant-chars> <variant-defs>
parent elements | <general-project-data>
Attributes for VARIANT-SPEC
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Specification of a variant.


21.11. VERBATIM

Figure 222: DTD-diagram for VERBATIM
Child elements | <l-10>
parent elements | <chapter> <entry> <figure> <fm-form-sheet-presentation> <formula> <introduction> <item> <labeled-item> <ncoi-1> <remark> <topic-1> <topic-2>
Attributes for VERBATIM
Name | Type | Class | Value | Remark
[ALLOW-BREAK] | number | default | 1 |
[FLOAT] | nmtkgrp | implied | FLOAT NO-FLOAT |
[HELP-ENTRY] | cdata | implied |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Used to indicate if the text is to be picked up and laid down as it is. Typically, it implies the usage of a monospace font and the designated point size. All record ends are retained. The use of tabs in verbatim text may cause unexpected results and should therefore be avoided.


21.12. VISIBLE

Figure 223: DTD-diagram for VISIBLE
Child elements | <fm-function-ref> <fm-fault-ref> <fm-structure-element-ref>
parent elements | <fm-interface>
Attributes for VISIBLE
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |


22. XDOC ... XREF

Elements and attributes of MSRFMEA.DTD
22. XDOC ... XREF

Contents of this chapter:
  • 22.1. XDOC
  • 22.2. XFILE
  • 22.3. XREF


22.1. XDOC

Figure 224: DTD-diagram for XDOC
Child elements | <long-name-1> <short-name> <number> <state-1> <date-1> <publisher> <file> <position>
parent elements | <l-1>
Attributes for XDOC
Name | Type | Class | Value | Remark
[F-CHILD-TYPE] | cdata | fixed | date-1:date |
[F-ID-CLASS] | name | fixed | XDOC |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Specifiy an external document which is not accessed by the SGML-System. The content of this external document is 'not included' in the document instance or presented in a report.


22.2. XFILE

Figure 225: DTD-diagram for XFILE
Child elements | <long-name-1> <short-name> <file>
parent elements | <l-1>
Attributes for XFILE
Name | Type | Class | Value | Remark
[F-ID-CLASS] | name | fixed | XFILE |
[ID] | id | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Specifiy an external file which is not accessed by the SGML-System. The content of this external file is 'not included' in the document instance or presented in a report.


22.3. XREF

Figure 226: DTD-diagram for XREF
Child elements | none
parent elements | <l-1> <l-2>
Attributes for XREF
Name | Type | Class | Value | Remark
[EXT-ID-CLASS] | cdata | implied |  |
[HYNAMES] | names | fixed | LINKEND ID-REF |
[HYTIME] | name | fixed | CLINK |
[ID-CLASS] | nmtkgrp | required | CHAPTER COMPANY DEF-ITEM FIGURE FM-ACTION FM-ACTION-TYPE FM-FAULT FM-FAULT-TYPE FM-FORM-SHEET FM-FUNCTION FM-FUNCTION-TYPE FM-STRUCTURE FM-STRUCTURE-ELEMENT FM-TASK-SET FM-TASK-SETS FM-TEAM FM-TOOL FORMULA PRM SAMPLE STD TABLE TEAM-MEMBER TOPIC VARIANT-CHAR VARIANT-DEF XDOC XFILE EXTERNAL |
[ID-REF] | idref | required |  |
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description Reference inside a paragraph to objects (elements with identifier) in the document. The type attribute classifies this reference into following classes: - figures - tables - external documents - parameters - standards - other For the output, the processing system will use this classes for difference presentation.


23. ZIP ... ZIP

Elements and attributes of MSRFMEA.DTD
23. ZIP ... ZIP

Contents of this chapter:
  • 23.1. ZIP


23.1. ZIP

Figure 227: DTD-diagram for ZIP
Child elements | none
parent elements | <team-member>
Attributes for ZIP
Name | Type | Class | Value | Remark
[S] | cdata | implied |  |
[T] | cdata | implied |  |
Description This element contains the ZIP of the used address.


Technical Terms

Elements and attributes of MSRFMEA.DTD
Technical Terms

Code
code
organization
other
product
SGML-attribute
SGMLTAG
Organisations
ASAP
OTHER
ECU
Products
ASAP2
MSRFMEA DTD
MSRREP DTD
SGML Attributes
ALIGN, ALIGN, ALIGN, ALIGN
ALLOW-BREAK
BREAK
CATEGORY
CHAR, CHAR, CHAR, CHAR
CHAROFF, CHAROFF, CHAROFF, CHAROFF
COLNAME, COLNAME
COLNUM
COLS
COLSEP, COLSEP, COLSEP, COLSEP, COLSEP
COLWIDTH
COMPANY
DOCORSUB
EXT-ID-CLASS
F-CHILD-TYPE, F-CHILD-TYPE, F-CHILD-TYPE, F-CHILD-TYPE, F-CHILD-TYPE, F-CHILD-TYPE, F-CHILD-TYPE, F-CHILD-TYPE
F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS, F-ID-CLASS
F-NAMESPACE, F-NAMESPACE, F-NAMESPACE, F-NAMESPACE, F-NAMESPACE
F-PUBID
FIELD-NAME
FILENAME, FILENAME
FIT
FLOAT, FLOAT, FLOAT
FM-ACTION
FM-ACTION-TYPE
FM-FAULT
FM-FAULT-TYPE
FM-FUNCTION
FM-FUNCTION-TYPE
FM-STRUCTURE-ELEMENT
FRAME
HEIGHT
HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY, HELP-ENTRY
HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES, HYNAMES
HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME, HYTIME
ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID, ID
ID-AWARE
ID-CLASS
ID-REF
ITEM-LABEL-POS
L, L, L, L, L, L
MAPPED-ID
MOREROWS
NAMEEND, NAMEEND
NAMEST, NAMEST
NAMETYPE
NOTATION, NOTATION
NOTE-TYPE
ORIENT
PGWIDE
PUBID
ROLE
ROTATE
ROWSEP, ROWSEP, ROWSEP, ROWSEP, ROWSEP, ROWSEP
S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S, S
SAMPLE
SCALE
SHORTENTRY
SPANNAME, SPANNAME
T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T, T
TABSTYLE
TEAM-MEMBER
TGROUPSTYLE
TOCENTRY
TOOL, TOOL
TOOL-VERSION
type
USER-DEFINED-TYPE, USER-DEFINED-TYPE
VALIGN, VALIGN, VALIGN, VALIGN
VARIANT-CHAR
WIDTH
SGML Elements
abs, abs, abs
acceptance-cond, acceptance-cond, acceptance-cond, acceptance-cond, acceptance-cond, acceptance-cond
add-info
add-spec, add-spec, add-spec, add-spec, add-spec, add-spec, add-spec
address
admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data, admin-data
c-code, c-code
change, change
chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter, chapter
city
code, code, code
colspec, colspec, colspec
companies, companies
company, company, company, company, company, company
company-doc-info, company-doc-info, company-doc-info, company-doc-info, company-doc-info
company-doc-infos, company-doc-infos
company-ref, company-ref
company-revision-info, company-revision-info, company-revision-info, company-revision-info, company-revision-info
company-revision-infos, company-revision-infos
cond, cond
cover-sheet-style
date, date, date, date
date-1, date-1, date-1, date-1
def, def
def-item, def-item, def-item, def-item
def-list, def-list, def-list, def-list, def-list, def-list, def-list, def-list, def-list, def-list, def-list
demarcation-other-projects, demarcation-other-projects, demarcation-other-projects, demarcation-other-projects, demarcation-other-projects, demarcation-other-projects
department
desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc, desc
dir-hand-over-doc-data, dir-hand-over-doc-data, dir-hand-over-doc-data, dir-hand-over-doc-data, dir-hand-over-doc-data, dir-hand-over-doc-data
doc-label, doc-label
doc-revision, doc-revision, doc-revision, doc-revision, doc-revision
doc-revisions, doc-revisions
e, e
email
entity-name
entry, entry, entry, entry, entry, entry, entry, entry, entry
fax
figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure, figure
file, file, file
fm-action, fm-action, fm-action, fm-action, fm-action, fm-action, fm-action, fm-action, fm-action, fm-action
fm-action-class
fm-action-comment, fm-action-comment
fm-action-ref, fm-action-ref, fm-action-ref
fm-action-state
fm-action-type, fm-action-type, fm-action-type, fm-action-type, fm-action-type, fm-action-type, fm-action-type
fm-action-type-class
fm-action-type-decomposition, fm-action-type-decomposition
fm-action-type-ref, fm-action-type-ref
fm-action-types, fm-action-types
fm-actions, fm-actions
fm-causes, fm-causes
fm-counter-tasks, fm-counter-tasks, fm-counter-tasks
fm-detection-tasks, fm-detection-tasks, fm-detection-tasks
fm-external-action, fm-external-action, fm-external-action, fm-external-action
fm-external-actions-control, fm-external-actions-control
fm-external-actions-detect, fm-external-actions-detect
fm-fault, fm-fault, fm-fault, fm-fault, fm-fault, fm-fault, fm-fault, fm-fault, fm-fault, fm-fault
fm-fault-class
fm-fault-ref, fm-fault-ref, fm-fault-ref, fm-fault-ref, fm-fault-ref, fm-fault-ref
fm-fault-refs, fm-fault-refs
fm-fault-type, fm-fault-type, fm-fault-type, fm-fault-type, fm-fault-type, fm-fault-type, fm-fault-type
fm-fault-type-class
fm-fault-type-decomposition, fm-fault-type-decomposition
fm-fault-type-ref, fm-fault-type-ref
fm-fault-types, fm-fault-types
fm-faults, fm-faults
fm-form-sheet, fm-form-sheet, fm-form-sheet, fm-form-sheet, fm-form-sheet, fm-form-sheet, fm-form-sheet, fm-form-sheet
fm-form-sheet-presentation, fm-form-sheet-presentation, fm-form-sheet-presentation, fm-form-sheet-presentation, fm-form-sheet-presentation, fm-form-sheet-presentation, fm-form-sheet-presentation, fm-form-sheet-presentation, fm-form-sheet-presentation, fm-form-sheet-presentation, fm-form-sheet-presentation
fm-form-sheets, fm-form-sheets
fm-function, fm-function, fm-function, fm-function, fm-function, fm-function, fm-function, fm-function, fm-function
fm-function-class
fm-function-ref, fm-function-ref, fm-function-ref, fm-function-ref, fm-function-ref
fm-function-type, fm-function-type, fm-function-type, fm-function-type, fm-function-type, fm-function-type, fm-function-type
fm-function-type-class
fm-function-type-decomposition, fm-function-type-decomposition
fm-function-type-ref, fm-function-type-ref
fm-function-types, fm-function-types
fm-functions, fm-functions
fm-head, fm-head, fm-head
fm-id-prefix
fm-idtable, fm-idtable
fm-interface, fm-interface, fm-interface, fm-interface
fm-orphan-home, fm-orphan-home
fm-prerequisites, fm-prerequisites
fm-se-decomposition, fm-se-decomposition
fm-se-functions, fm-se-functions
fm-significance, fm-significance, fm-significance
fm-structure, fm-structure, fm-structure, fm-structure, fm-structure, fm-structure, fm-structure, fm-structure, fm-structure, fm-structure, fm-structure, fm-structure
fm-structure-class
fm-structure-element, fm-structure-element, fm-structure-element, fm-structure-element, fm-structure-element, fm-structure-element, fm-structure-element, fm-structure-element, fm-structure-element
fm-structure-element-class
fm-structure-element-ref, fm-structure-element-ref, fm-structure-element-ref, fm-structure-element-ref, fm-structure-element-ref
fm-structure-element-refs, fm-structure-element-refs
fm-structure-elements, fm-structure-elements
fm-structure-owner, fm-structure-owner
fm-structure-root, fm-structure-root
fm-structures, fm-structures
fm-task-history, fm-task-history
fm-task-schedule, fm-task-schedule, fm-task-schedule
fm-task-set, fm-task-set, fm-task-set, fm-task-set, fm-task-set, fm-task-set, fm-task-set, fm-task-set, fm-task-set
fm-task-set-class
fm-task-sets, fm-task-sets, fm-task-sets, fm-task-sets, fm-task-sets, fm-task-sets
fm-team, fm-team, fm-team, fm-team, fm-team
fm-teams, fm-teams
fm-tool, fm-tool, fm-tool, fm-tool, fm-tool, fm-tool, fm-tool
fm-tool-data, fm-tool-data
formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula, formula
ft, ft
general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data, general-project-data
generic-math, generic-math
graphic
homepage
idc
ie, ie, ie, ie, ie, ie
indent-sample, indent-sample
input, input, input
integration-capability, integration-capability, integration-capability, integration-capability, integration-capability, integration-capability
introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction, introduction
item, item, item, item, item, item, item, item
item-label, item-label
l-1, l-1, l-1, l-1, l-1, l-1, l-1, l-1, l-1, l-1, l-1, l-1
l-10, l-10, l-10, l-10, l-10, l-10, l-10, l-10, l-10, l-10, l-10
l-2, l-2, l-2, l-2, l-2, l-2, l-2, l-2, l-2, l-2, l-2, l-2, l-2
l-3, l-3, l-3, l-3
l-4, l-4, l-4, l-4
l-graphic, l-graphic, l-graphic
label, label, label, label
labeled-item, labeled-item, labeled-item, labeled-item, labeled-item, labeled-item, labeled-item, labeled-item, labeled-item
labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list, labeled-list
language
list, list, list, list, list, list, list, list, list, list
lite-revision, lite-revision, lite-revision, lite-revision, lite-revision, lite-revision
lite-revisions, lite-revisions
locs, locs
long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name, long-name
long-name-1, long-name-1, long-name-1, long-name-1, long-name-1
max, max, max
min, min, min
misc, misc, misc, misc
misc-data, misc-data, misc-data, misc-data, misc-data
misc-value
modification, modification, modification
modifications, modifications, modifications
msrfmea, msrfmea, msrfmea, msrfmea, msrfmea, msrfmea, msrfmea, msrfmea, msrfmea, msrfmea, msrfmea, msrfmea, msrfmea
msrsw
na, na, na, na, na, na, na, na, na, na, na, na, na, na, na, na
nameloc, nameloc, nameloc, nameloc
ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1, ncoi-1
nmlist
note, note, note, note, note, note, note, note, note, note, note, note
number
objectives, objectives, objectives, objectives, objectives, objectives
output, output, output
p, p, p, p, p, p, p, p, p, p, p, p, p, p
parallel-designs, parallel-designs, parallel-designs, parallel-designs, parallel-designs, parallel-designs
part-number
phone
position, position
private-code
private-codes, private-codes
prm, prm, prm, prm, prm
prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char, prm-char
prms, prms, prms, prms, prms
project-schedule, project-schedule, project-schedule, project-schedule, project-schedule, project-schedule
protocols, protocols, protocols, protocols, protocols, protocols
publisher
purchasing-cond, purchasing-cond, purchasing-cond, purchasing-cond, purchasing-cond, purchasing-cond
reason, reason
reason-order, reason-order, reason-order, reason-order, reason-order, reason-order
remark, remark, remark, remark, remark, remark, remark, remark, remark
revision-label, revision-label, revision-label
risk-priority-factor, risk-priority-factor, risk-priority-factor
role, role
roles, roles
row, row, row, row
sample, sample, sample, sample
sample-ref
sample-spec, sample-spec, sample-spec, sample-spec, sample-spec, sample-spec
samples, samples
schedule, schedule, schedule
short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name, short-name
spanspec
state, state, state
state-1, state-1
std, std, std, std, std, std, std, std
sub, sub, sub, sub, sub, sub, sub, sub, sub
subtitle
sup, sup, sup, sup, sup, sup, sup, sup, sup
sw-prm
system-overview, system-overview, system-overview, system-overview, system-overview, system-overview
table, table, table, table, table, table, table, table, table
tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd, tbd
tbody, tbody
tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr, tbr
team-member, team-member, team-member, team-member, team-member, team-member, team-member, team-member, team-member, team-member, team-member, team-member, team-member
team-member-ref, team-member-ref, team-member-ref, team-member-ref, team-member-ref
team-member-refs, team-member-refs, team-member-refs
team-members, team-members
tex-math, tex-math
text, text
tfoot, tfoot, tfoot
tgroup, tgroup, tgroup, tgroup, tgroup, tgroup
thead, thead, thead
tol, tol, tol
topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1, topic-1
topic-2, topic-2, topic-2, topic-2, topic-2, topic-2, topic-2, topic-2, topic-2, topic-2, topic-2, topic-2, topic-2
tt, tt, tt, tt
typ, typ, typ
unit, unit
used-languages, used-languages
user-cover-sheet, user-cover-sheet, user-cover-sheet
user-cover-sheets, user-cover-sheets
value
variant-char, variant-char, variant-char, variant-char
variant-char-assign, variant-char-assign, variant-char-assign
variant-char-assigns, variant-char-assigns
variant-char-ref
variant-char-value, variant-char-value, variant-char-value
variant-chars, variant-chars
variant-def, variant-def, variant-def, variant-def, variant-def
variant-defs, variant-defs
variant-spec, variant-spec, variant-spec, variant-spec, variant-spec, variant-spec, variant-spec
verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim, verbatim
visible, visible, visible, visible
xdoc, xdoc, xdoc, xdoc, xdoc, xdoc, xdoc, xdoc, xdoc
xfile, xfile, xfile, xfile
xref, xref
zip