CC V2.2.0

MSR-MEDOC

CC V2.2.0
Container Catalog XML Model Specification
[catalog_2_2_0.sl-eadoc]
Revision: 6
In case of joint engineering efforts it is necessary to synchronize the engineering data bases. This structure specifies a container and in particular the meta data used for such an exchange.


I. Document management

CC V2.2.0
I. Document management

Team members
Name | Company | {CONTACT}
MSR MEDOC | MSR MEDOC |
Herbert Klein (XI-Works) | MSR MEDOC | Phone: +49 711 248398-10 Herbert.Klein@xi-works.de
Gerald Manger (BMW AG) | MSR MEDOC | Gerald.Manger@bmw.de
Hans Göttfert (DaimlerChrysler AG) | MSR MEDOC | Hans.Goettfert@daimlerchrysler.com
Hans Schröter (DaimlerChrysler AG) | MSR MEDOC | Hans.Schroeter@daimlerchrysler.com
Bernhard Weichel (Robert Bosch GmbH) | MSR MEDOC | Bernhard.Weichel@de.bosch.de
Thomas Beck (Robert Bosch GmbH) | MSR MEDOC | Thomas.Beck2@de.bosch.com
Helmut Wellnhofer (Siemens VDO) | MSR MEDOC | Helmut.Wellnhofer@siemens.com
Hans-Jürgen Sonnleitner (Siemens VDO) | MSR MEDOC | Hans-juergen.Sonnleitner@siemens.com
Christian Martin (Siemens VDO) | MSR MEDOC | christianmartin@siemens.com
Version overview
Version | Date | Editor | State
6 | 2003-11-03 | Herbert Klein (XI-Works) | Release
5 | 2003-07-30 | Christian Martin (Siemens VDO) | Draft
4 | 2003-06-05 | Herbert Klein (XI-Works) | Draft
3 | 2003-05-06 | Herbert Klein (XI-Works) | Draft
2 | 2003-04-14 | Herbert Klein (XI-Works) | Draft
Modifications
Version | Change | Related to
6 | Inserted the descriptions for <VERBATIM> and serveral new attributes. Reason: New elements and attributes in catalog_2_2_0. | Content
 | Setting the document to CD (Comitee Draft). Reason: Final Inputs regarding the UPD attribute have been inserted. | Content
 | Checking and adopting the MSR document rules Reason: Setting the document to CD | Content
5 | Introduction of a Sample Scenario for The UPD attribute of the ABLOCK Reason: Review in MSR Meeting | Content
4 | Introduction of the Review Results Reason: Review in MSR Meeting | Content
3 | Updated according to the change requests mentioned here. Reason: Release of V2.2.0 RC4 | Content
2 | Inserted all missing descriptions Reason: Release of V2.2.0 RC3 | Content
Modifications included
Date | Chapter | Change | Related to
2003-11-03 | Gesamt | Inserted the descriptions for <VERBATIM> and serveral new attributes. Reason: New elements and attributes in catalog_2_2_0. | Content
 |  | Setting the document to CD (Comitee Draft). Reason: Final Inputs regarding the UPD attribute have been inserted. | Content
 |  | Checking and adopting the MSR document rules Reason: Setting the document to CD | Content
2003-07-30 | Gesamt | Introduction of a Sample Scenario for The UPD attribute of the ABLOCK Reason: Review in MSR Meeting | Content
2003-06-05 | Gesamt | Introduction of the Review Results Reason: Review in MSR Meeting | Content
2003-05-06 | Gesamt | Updated according to the change requests mentioned here. Reason: Release of V2.2.0 RC4 | Content
2003-04-14 | Gesamt | Inserted all missing descriptions Reason: Release of V2.2.0 RC3 | Content


1. Introduction

CC V2.2.0
1. Introduction

This document describes the container catalog which is part of a generic approach for exchange of engineering data and its configuration. The container comprises of
  • Engineering objects such as source codes, documentation, compiled objects etc.
  • Meta information about the exchanged object such as creator, name, version info and configuration.
The catalog as described in the following sections is inspired by the RDF (Resource Data Framework) as published by the World Wide Web Consortium. RDF describes thing by making statements about it. These statements, called "assertions" are the basic mechanisms of the catalog.
The statements are given in <ABLOCK> which itself comprises of meta data and the "things" itself resp. a pointer to a file containing the "things".
Like RDF, the catalog is an application of XML as described by the world wide web consortium (www.w3c.org).
This document describes in general the container catalog dtd. The dtd provides a meta data scheme. It is expected, that the reader is informed about XML.
The particular application of this scheme must be documented separately.


2. General approach to the Catalog

CC V2.2.0
2. General approach to the Catalog

In general, the catalog is setup by the following items:
Figure 1: Overall structure of the catalog
<CATALOG>
This is the root of the catalog. As of XML a valid resp. a well formed document must have one and only one root element.
<SHORT-NAME>
This is the name of the catalog. It can be used for reference purposes.
<CATEGORY>
This defines the particular usecase of the catalog.
<COMPANIES>
This is the definition of the companies and persons which are involved in the data exchange.
<ABLOCK>
This is the assertion block about one particular "work item" or exchange item. This item can either be a file, a set of special data fields(<SDG>s), or a specific configuration which comprises of <AREF>. <SDG> (special data group) is a generic structure allowing to transmit any kind of property field.
Caution: The primary identification of an <ABLOCK> is the <SHORT-NAME> in conjunction with <CATEGORY>, and the version attributes [VAR], [REV] and [LABEL] as well as <DOMAIN> which must be unique within <CATALOG>. This reflects to the fact that a work item in an engineering process may have a particular role in the process (denoted by <CATEGORY>) and a name.
For ease of processing in XML-tools catalog also supports the identification by [ID].
<AREF>
This is used to establish a relationship between configuration items and particular exchange items. As an example, a program kit is setup as a set of particular files. This fact is expressed within the <ABLOCK> describing the program by referencing (via <AREF>) the <ABLOCK> representing the particular files.
Caution: Note that this reference can be expressed using XML's ID/IDREF or by using [CATEGORY], and the version attributes [VAR], [REV] and [LABEL] as well as [DOMAIN] or both. If both mechanisms are used, then they must be in sync.
<ADMIN-DATA>
This structure receives the administrative data like revision information or language definition of the catalog.
For further details refer to the element and attributes documentation in 4. Elemente der CATALOG DTD.


3. Example Scenarios

CC V2.2.0
3. Example Scenarios

This chapter describes possible application of the catalog. As mentioned earlier the base principle is that catalog keeps meta data about a set of files which is exhanged between an OEM and its supplier as shown in Example Data Exchange.
Figure 2: Example Data Exchange
The figure below shows an example for the import export process.
Figure 3: IMPORT/EXPORT Process
For better understanding more details of two application scenarios are described below:
  • Using CATALOG for synchronizing two repositories by incremetal approach.
  • Using CATALOG for exchanging version histories.


3.1. Incremental data exchange

The catalog can be used for full fledged as well as for incremental data exchange. In both cases, all meta data have to be transmitted. In case of incremental exchange the unchanged physical files can be omitted.
In order to keep all references valid within the catalog the appropriate <ABLOCK>s must be provided. Therefore, the [UPD] attribute allows to give information about the contents (see also 4.1. ABLOCK ):
NEW | The object is newly introduced in the data mangement system of the process. Therefore the contents file must be in the catalog (in particular, an <FILE> element must occur within <ABLOCK>) [image] .
REUSED | The object (<ABLOCK>) was introduced in the data mangement system of the process at former time and had been removed in between. Like [NEW] it is not in the catalog of the previous exchange. Therefore the content files must be referenced in the catalog (in particular, a <FILE> element must occur within <ABLOCK>).
UNUSED | The object is no longer used. The <ABLOCK> is there in order to indicate, that the object can be removed in the configuration on the receiver's site. The <ABLOCK> does not reference anything within the actual catalog [image] . This is used to support the update procedure on the receiver's site [image] .
UNCHANGED | The object is unchanged. Therefore it must already be available on the receiver's site. Therefore it is possible to omit the file itself.
CHANGED | The object is changed. Therefore the content files must be referenced in the catalog (in particular, a <FILE> element must occur within <ABLOCK>).
MOVED | The object is unchanged but in different Groups (also represented by <ABLOCK>). Therefore it must already be available on the receiver's site. So it is possible to omit the file itself. If the object is moved and changed it shall be marked as changed.
DELETED | This attribute is intended for use cases where objects can be created but not deleted. If the data mangement system of the process wants to deliver a catalog it must be able to tell the target data mangement system that this object must be ignored. As opposite to UNUSED this should be used if the new object is not yet in the target system. UNUSED is used, if the object is already in the target system.
UNDEFINED | For states that are not defined in the current value list. In that circumstance the [SI] attribute can be used for some special processing.

The reference catalog must be identified by local means and is not defined in the actual catalog.
There is no value "deleted" because versioned data is not deleted in order to track the full history.
This cannot be determined by comparing catalogs since the full exchange history is necessary which must be kept in the process data management system


3.2. Using the catalog for transmitting a revision history

In order to document change history of subjects, the following approach is recommended:
  • Insert one <ABLOCK> for each particular revision of a file or a group.
  • Use different file names for each version. In particular, it is recommended to code the revision label into the file name such as myfile-01-07.txt.
  • Place the version information into <ADMIN-DATA>/<DOC-REVISION>/<REVISION-LABEL>.
  • Add a <CATEGORY> with the content "Revision-history" to each <ABLOCK>.
<CATALOG>
  <SHORT-NAME>ARMD</SHORT-NAME>
  <CATEGORY>History-overview</CATEGORY>
  <ADMIN-DATA>
     <DOC-REVISIONS>
        <DOC-REVISION>
          <REVISION-LABEL>1.0</REVISION-LABEL>
          <DATE>2000-03-03T19:39:38</DATE>
        </DOC-REVISION>
     </DOC-REVISIONS>
  </ADMIN-DATA>
  <ABLOCK ID="ID67160756756491">
     <SHORT-NAME>ARMD</SHORT-NAME>
     <CATEGORY>Revision-history</CATEGORY>
     <ADMIN-DATA>
        <DOC-REVISIONS>
          <DOC-REVISION>
             <REVISION-LABEL>10.30</REVISION-LABEL>
          </DOC-REVISION>
        </DOC-REVISIONS>
     </ADMIN-DATA>
     <FILE>fkt-armd-10.30-0.pdf</FILE>
  </ABLOCK>
  <ABLOCK ID="ID46044516198054">
     <SHORT-NAME>ARMD</SHORT-NAME>
     <CATEGORY>Revision-history</CATEGORY>
     <ADMIN-DATA>
        <DOC-REVISIONS>
          <DOC-REVISION>
             <REVISION-LABEL>10.40</REVISION-LABEL>
          </DOC-REVISION>
        </DOC-REVISIONS>
     </ADMIN-DATA>
     <FILE>fkt-armd-10.40-0.pdf</FILE>
  </ABLOCK>
</CATALOG>


3.3. Usage of the ABLOCK attribute UPD in a sample scenario

Contents of this chapter:
  • 3.3.1. The UPD attribute of the ABLOCK
  • 3.3.2. Step1: Initial Exchange
  • 3.3.3. Step2: Without air condition (performance reasons...)
  • 3.3.4. Step2: Without air condition - Incremental exchange
  • 3.3.5. Step3: air condition again, but remove the radio
  • 3.3.6. Step3: air condition again, incremental
  • 3.3.7. Step4a: Rearrange the components
  • 3.3.8. Step4b: same as 4a, but with an updated SteeringWheel ABLOCK


3.3.1. The UPD attribute of the ABLOCK

 | In the following slides the value of the ABLOCK attribute <UPD> will be defined in detail. Therefore, a scenario will be used to clarify the meaning of the attribute, which describes the exchange of parts of a simple car between supplier and manufacturer using the container catalog. The car consists of the following elements:
Remark:
 | For transparency reasons, the instances have been made as short as possible and don't use essential administration info. E.g. the version info of the steering wheel is expressed in the filename, which has no equivalence in real live scenarios.


3.3.2. Step1: Initial Exchange

In the initial exchange all parts of the car will be transferred with the status new, due to the fact that the car doesn't yet exist on the receiving side.


3.3.3. Step2: Without air condition (performance reasons...)

During the development the steering wheel has been changed (new version) and the air condition has been removed from the system. All other parts of the system haven't changed. What is the difference between unused and deleted? If an <ABLOCK> is "unused" it offers the possibility to "reuse" it again. When it is deleted (UPD="DELETED"), this possibility doesn't exist. If a structure changes (e.g. the dashboard by removing the air condition) then the element must be marked as changed (UPD="CHANGED"). The file name for the steering wheel has been changed to express, that another version is used. In this example, the file name should carry the version info instead of using <ADMIN-DATA> therefore to keep it simple.


3.3.4. Step2: Without air condition - Incremental exchange

In the incremental exchange, only elements, which are changed, unused, deleted, reused, new will be transferred. An Element will be marked as changed, if the value of the UPD-Attribute of one of its children is
  • REUSED
  • UNUSED
  • NEW
  • DELETED
  • MOVED
if the element has,
Remark:
It is not possible to remove unchanged <ABLOCK>s from the container catalog due to
  • If only changed <ABLOCK>s are in container, the corresponding <AREF>s pointing to nothing - invalid instance
  • If also the <AREF>s pointing to unchanged <ABLOCK>s are removed, then some <ABLOCK>s are changed, because they have e.g. instead of 5 <AREF>s only 3.
Conclusion
Incremental exchange that is reflected in the container catalog structure is not possible.
Therefore:
  • Don't transmit the unchanged files and
  • don't set the <FILE> in unchanged files.


3.3.5. Step3: air condition again, but remove the radio

Changes: As the driver complains about the cockpit temperature, the air condition must be integrated again. To optimize the weight of the car, the radio is permanently removed from the car. (UPD=DELETED)


3.3.6. Step3: air condition again, incremental

The same scenario as incremental update from step 2


3.3.7. Step4a: Rearrange the components

Changes: Due to a reorganization of the company the responsibilities for the car have changed. As a result, the steering wheel is removed from the dashboard and placed to the chassis structure. Another rule of the container catalog defines, that, in one <ABLOCK> it is not possible to point to a <file> and also to a <ABLOCK> with <AREF>. Therefore a new ABLOCK - ChassisBody must be invented. Now this new ABLOCK carries the file chassis.dwg.
To mark the reorganization,
  • the dashboard has got the element <AREF-MOVED> of the steering-wheel ABLOCK the chassis element gets
  • the ABLOCK SteeringWheel with the UPD attribute MOVED


3.3.8. Step4b: same as 4a, but with an updated SteeringWheel ABLOCK

Same situation as 4a, but now the SteeringWheel element has also a new version. -> Open question: Must all organizational changes be covered by the container catalog or only by incremental updates. If there is a lot of hierarchical changes, the container catalog will get unreadable due to aref-moveds, moved.... .
In this example the SteeringWheel changes location and version. Now, the UPD is aggregated from MOVED and CHANGED which results in CHANGED.
As alternative we can use <ABLOCK UPD="MOVED|CHANGED">?


4. Elemente der CATALOG DTD

CC V2.2.0
4. Elemente der CATALOG DTD

This chapter reflects all elements in alphabetical order. The root can be found in 4.7. CATALOG


4.1. ABLOCK
See Also Description Formal Description

Description
This represents assertions about a particular object. It comprises of meta data, fields. and the physical representation of the object itself.
The content of the object can be:
  • a set of references (<AREF>) to other objects thus establishing a configuration tree.
  • a set of physical files referenced by <FILE> representing the object. This set may comprise of different file types with the same contents or the fact that the object is distributed across multiple files. Another method to achieve this, would be to pack these files using compressed archives such as ZIP.
  • a set of database fields (<SDG>) within <COMPANY-DOC-INFO> containing the data for the object. Note that the database fields can be there in addition to the contents mentioned above.
Note that for compatibility reasons there is no wrapper around the elements representing the contents of the ablock.
The version information for an <ABLOCK> can be given on two different ways:
  • implicitly by using attributes such as [REV], [VAR] etc. This is bound for use cases where all participants are using the same version scheme.
  • explicitly by using <ADMIN-DATA> which among others allows to use separate version schemes for each participant in <COMPANY-REVISION-INFO>.
Although possible, it is not intended to use both methods at the same time.
The attribute [UPD] specifies the update status if incremental data exchange is performed using the catalog. The possible values might be as defined in3.1. Incremental data exchange.
Formal Description
Within context of: | CATALOG
Is context for: | LONG-NAME, SHORT-NAME, DESC, CATEGORY, ADMIN-DATA, DOMAIN, USABLE-FOR-VARIANTS, OWNER, SDGS, AREF, AREF-MOVED, FILE
Name | Type | Values / Default | Notes
[DATE] optional | String (CDATA) |  | This reflects the date the object was last modified. This is for reference purposes only. It is useful, if the catalog is the only database used for meta data. Usually this attribute is omitted.
[ID] optional | ID (ID) |  | This is a unique identifier of the object in the catalog. This must be used to refer to a particular version, if more than one version of the object is mentioned in the catalog.
[LABEL] optional | String (CDATA) |  | This is the revision label string. It should be used, if the two step revision scheme provided by [REV] and [VAR] is not applied. The syntax of this attribute must be agreed upon the involved parties.
[REV] optional | String (CDATA) |  | This specifies the revision of the object if the two layer revision scheme mentioned above is used.
[S] optional | String (CDATA) |  | Signature. Used to store the calculated signature of an element (e.g. CRC).
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[T] optional | String (CDATA) |  | Time Stamp Entry
[UPD] optional | SGML string (NMTOKEN) |  | The attribute [UPD] specifies the update status if incremental data exchange is performed using the catalog. The possible values can be found above (see 3.1. Incremental data exchange).
[VAR] optional | String (CDATA) |  | This specifies the variant of the object if the two layer revision scheme mentioned above is used.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | ABLOCK | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <AREF ID-REF="ID1" F-ID-CLASS="ABLOCK"> ... </AREF> can only link to an object which is classified as "ABLOCK" like: <ABLOCK ID="ID1" F-ID-CLASS="ABLOCK"> ... </ABLOCK>.


4.2. ADDRESS

Description
<ADDRESS> can be used to save the address of the company.
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.3. ADMIN-DATA

Description
<ADMIN-DATA> can be used to capture all information regarding document management such as used language and versioning.
Formal Description
Within context of: | ABLOCK, CATALOG
Is context for: | LANGUAGE, USED-LANGUAGES, COMPANY-DOC-INFOS, FORMATTER-CTRLS, DOC-REVISIONS
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.4. AREF

Description
This refers to another object (<ABLOCK>). The reference can be done on two different mechanisms:
  • [ID-REF] pointing to an <ABLOCK> identified by [ID].
  • Content of <AREF> in conjunction with the attribute [CATEGORY] when <AREF> contains content of the <SHORT-NAME> of the referenced <ABLOCK> and the attribute [CATEGORY] contains the content of <CATEGORY> of the referenced <ABLOCK>.
It is not intended to use both mechanisms simultaneously. If however both methods are used at the same time, they must both point to the same object. A reader must flag contradictions as an error, and may continue using ID/IDREF.
If the catalog contains multiple versions of a particular object there is a name clash of <SHORT-NAME> within <ABLOCK>. This can be resolved by utilizing [DOMAIN], [REV] and [VAR] attributes resp. [LABEL] of <AREF>(see also 2. General approach to the Catalog)
Formal Description
Within context of: | ABLOCK, CATALOG
Is context for: | Text
Name | Type | Values / Default | Notes
[CATEGORY] optional | String (CDATA) |  | This is attribute contains the value of the <CATEGORY> element of the referenced <ABLOCK>.
[DOMAIN] optional | String (CDATA) |  | A DOMAIN is an additional separator in order to make <ABLOCK>s unique. This is useful, if one catalog carries elements from different systems, where the name (<SHORT-NAME>+<CATEGORY>[VAR]+[REV] resp. [LABEL] of the <ABLOCK>) is not unique in the catalog.
[ID-REF] optional | ID reference (IDREF) |  | This attribute contains an existing ID which can be used to identify the related link target by its [ID] attribute.
[LABEL] optional | String (CDATA) |  | This is the revision label string. It should be used, if the two step revision scheme provided by [REV] and [VAR] is not applied. The syntax of this attribute must be agreed upon the involved parties.
[REV] optional | String (CDATA) |  | This specifies the revision of the object if the two layer revision scheme mentioned above is used.
[S] optional | String (CDATA) |  | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[T] optional | String (CDATA) |  | Time Stamp Entry
[VAR] optional | String (CDATA) |  | This specifies the variant of the object if the two layer revision scheme mentioned above is used.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | ABLOCK | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <AREF ID-REF="ID1" F-ID-CLASS="ABLOCK"> ... </AREF> can only link to an object which is classified as "ABLOCK" like: <ABLOCK ID="ID1" F-ID-CLASS="ABLOCK"> ... </ABLOCK>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversals.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architectural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversals.


4.5. AREF-MOVED

Description
This refers to another object which has been part of the actual ablock in a previous version (<ABLOCK>). This specific reference is there to provide means to indicate changes within a configuration in greater detail. Otherwise a group can be marked with [UPD] as CHANGED but all components of this group are UNCHANGED because one component is moved to somewhere else.
The reference can be done on two different mechanisms:
  • [ID-REF] pointing to an <ABLOCK> identified by [ID].
  • Content of <AREF-MOVED> in conjunction with the attribute [CATEGORY] when <AREF-MOVED> contains an <ABLOCK>s <SHORT-NAME> and the attribute [CATEGORY] contains an <ABLOCK>s <CATEGORY>
It is not intended to use both mechanisms simultaneously. If however both methods are used at the same time, they must both point to the same object. A reader must flag contradictions as an error, and may continue using ID/IDREF.
If the catalog contains multiple versions of a particular object there is a name clash of <SHORT-NAME> within <ABLOCK>. This can be resolved by utilizing [DOMAIN], [REV] and [VAR] attributes resp. [LABEL] of <AREF>(see also 2. General approach to the Catalog)
Formal Description
Within context of: | ABLOCK
Is context for: | Text
Name | Type | Values / Default | Notes
[CATEGORY] optional | String (CDATA) |  | This is attribute contains the value of the <CATEGORY> element of the referenced <ABLOCK>.
[DOMAIN] optional | String (CDATA) |  | A DOMAIN is an additional separator in order to make <ABLOCK>s unique. This is useful, if one catalog carries elements from different systems, where the name (<SHORT-NAME>+[VAR]+[REV]) is not unique in the catalog.
[ID-REF] optional | ID reference (IDREF) |  | This attribute contains an existing ID which can be used to identify the related link target by its [ID] attribute.
[LABEL] optional | String (CDATA) |  | This is the revision label string. It should be used, if the two step revision scheme provided by [REV] and [VAR] is not applied. The syntax of this attribute must be agreed upon the involved parties.
[REV] optional | String (CDATA) |  | This specifies the revision of the object if the two layer revision scheme mentioned above is used.
[S] optional | String (CDATA) |  | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[T] optional | String (CDATA) |  | Time Stamp Entry
[VAR] optional | String (CDATA) |  | This specifies the variant of the object if the two layer revision scheme mentioned above is used.
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | ABLOCK | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF ID-REF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversals.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architectural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversals.


4.6. BR

Description
This element forces a line break. It allows to introduce linebreaks in paragraphs, but even to make <VERBATIM> resistent against inadequate whitespace handling.
Formal Description
Within context of: | CHANGE, DESC, MSR-QUERY-RESULT-TEXT, P, VERBATIM
Has no contents. |
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.7. CATALOG

Description
This is the root of the catalog. It comprises of meta data and assertion blocks. The meta data are related to the catalog itself.
If an entire system is transferred, the root of the configuration can be denoted in the <AREF> of <CATALOG>.
The use case of the catalog is denoted in <CATEGORY> as:
program-kit | used to exchange entire program kits.
tool-kit | used to exchange tool kits
History-overview | used to exchange an history overview of one particular work item.
The public identifier in the DOCTYPE statement of an CATALOG instance can be defined like this:
<!DOCTYPE PUBLIC "-//MSR//DTD CONTAINER CATALOG V 2.2.0 MSRCC.DTD//EN" "msrcc-v220.xml.dtd">
Formal Description
Within context of: | Root
Is context for: | SHORT-NAME, CATEGORY, COMPANIES, ADMIN-DATA, AREF, ABLOCK, MATCHING-DCIS
Name | Type | Values / Default | Notes
[CREATOR] optional | String (CDATA) |  | This denotes the tool which created the actual catalog.
[CREATOR-VERSION] optional | String (CDATA) |  | This denotes version of the tool which created the actual catalog.
[S] optional | String (CDATA) |  | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[T] optional | String (CDATA) |  | Time Stamp Entry
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.
[F-CM-TOOL-ID] fixed value | String (CDATA) | $Id: CATALOG.element.dtd,v 1.7 2003/05/07 11:24:52 beweiche Exp $ | Fixed configuration management tool identifier of the DTD.
[F-DTD-BUILD] fixed value | String (CDATA) | 14 | Fixed build number of the DTD.
[F-DTD-VERSION] fixed value | String (CDATA) | 2.2.0 | Fixed Version String of the DTD.
[F-PUBID] fixed value | String (CDATA) | -//MSR//DTD CONTAINER CATALOG V2.2.0:MSRCC.DTD//EN | Fixed Public Identifier of the DTD.


4.8. CATEGORY

Description
This denotes the class of the object. This class must be agreed upon for various applications. The top level category (/<CATALOG>/<CATEGORY>) element denotes the use case of the catalog.
Formal Description
Within context of: | ABLOCK, CATALOG
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.9. CHANGE

Description
<CHANGE> can be used to list the changes between the current and the latest document version.
Formal Description
Within context of: | MODIFICATION
Is context for: | Text, TT, BR, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, STD, XDOC, XFILE, MSR-QUERY-TEXT
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.10. CITY

Description
<CITY> can be used to save the city of a company.
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.11. COMMENT

Description
Use <COMMENT> to write a comment about the function, the configuration or the expected result of an MSR-QUERY. This element shouldn't be printed by formatters.
Formal Description
Within context of: | MSR-QUERY-PROPS
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.12. COMPANIES

Description
<COMPANIES> is an wrapper element for various companies and can be used to describe the companies being involved in the project. Usually there is more than one company involved in the project. The company which generated the file is determined by following <TEAM-MEMBER-REF> within <ADMIN-DATA>. In simple cases there is only one company, so this lookup is not really necessary.
Formal Description
Within context of: | CATALOG
Is context for: | COMPANY
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.13. COMPANY

Description
<COMPANY> can be used to describe the company and the persons being involved in the project.
Formal Description
Within context of: | COMPANIES
Is context for: | LONG-NAME, SHORT-NAME, ROLES, TEAM-MEMBERS
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | This is a unique identifier of the object in the catalog. This must be used to refer to a particular version, if more than one version of the object is mentioned in the catalog.
[ROLE] optional | SGML string (NMTOKEN) |  | Choose MANUFACTURER, if the <COMPANY> is an manufacturer or partner. Choose Supplier, if the <COMPANY> is a supplier.
[S] optional | String (CDATA) |  | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[T] optional | String (CDATA) |  | Time Stamp Entry
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.
[F-CHILD-TYPE] fixed value | String (CDATA) | LONG-NAME:SELECTION | Fixed Child Type. Warning: This attribute is only in the DTD for compatibility with older versions of the DTD and should not be used for any new implementations. It might be removed in future versions of the DTD. This attribute contains the information which child elements of the actual element should be checked by an semantic checker.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | COMPANY | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF ID-REF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[F-NAMESPACE] fixed value | SGML strings (NMTOKENS) | TEAM-MEMBER | Fixed name space. This attribute is placed on elements which define a namespace for linkable objects. The attribute contains a list of elements for which the element carrying the attribute is a namespace. This is used by processors which use the MSR natural linking mechanism. (Natural links address their link target with a sequence of short-names of the namespaces and the object itself e.g. '/test.xml/sw-system1/sw-var1')


4.14. COMPANY-DOC-INFO
See Also Description Example Formal Description

Description
Use <COMPANY-DOC-INFO> to save document information about a company.
Example
see 4.15. COMPANY-DOC-INFOS
Formal Description
Within context of: | COMPANY-DOC-INFOS
Is context for: | COMPANY-REF, DOC-LABEL, TEAM-MEMBER-REF, SDGS
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.15. COMPANY-DOC-INFOS
See Also Description Example Formal Description

Description
<COMPANY-DOC-INFOS> is a wrapper containing all document information of companies.
Example
<COMPANY-DOC-INFOS>
  <COMPANY-DOC-INFO>
    <COMPANY-REF>thecompany</COMPANY-REF>
    <DOC-LABEL>1.5</DOC-LABEL>
    <TEAM-MEMBER-REF>Wl</TEAM-MEMBER-REF>
    <SDGS>
      <SDG GID="file-info">
        <SD GID="filename">foo-bar.xml</SD>
        <SD GID="tool">foo-tool.exe</SD>
      </SDG>
      <SDG GID="procurement">
        <SD GID="cost-center">012-1234</SD>
        <SD GID="total-charge">1.25,00 EUR</SD>
      </SDG>
    </SDGS>
  </COMPANY-DOC-INFO>
</COMPANY-DOC-INFOS>
Formal Description
Within context of: | ADMIN-DATA
Is context for: | COMPANY-DOC-INFO
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.16. COMPANY-REF

Description
<COMPANY-REF> is the pointer to one particular company.
Formal Description
Within context of: | COMPANY-DOC-INFO, COMPANY-REVISION-INFO
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | This attribute contains an existing ID which can be used to identify the related link target by its [ID] attribute.
[S] optional | String (CDATA) |  | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[T] optional | String (CDATA) |  | Time Stamp Entry
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | COMPANY | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF ID-REF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversals.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architectural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversals.


4.17. COMPANY-REVISION-INFO

Description
<COMPANY-REVISION-INFO> can be used to save information about the document version of the company.
Formal Description
Within context of: | COMPANY-REVISION-INFOS
Is context for: | COMPANY-REF, REVISION-LABEL, REVISION-LABEL-P1, REVISION-LABEL-P2, STATE
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.18. COMPANY-REVISION-INFOS

Description
<COMPANY-REVISION-INFOS> is a wrapper containing all document versions of companies.
Formal Description
Within context of: | DOC-REVISION
Is context for: | COMPANY-REVISION-INFO
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.19. DATE

Description
<DATE> is used to capture a time stamp. It must match to one of the following syntaxes:
<YYYY>-<MM>-<DD>[T<hh>:<mm>:<ss>]

<YYYY>.<MM>.<DD>[T<hh>:<mm>:<ss>]

<YYYY>/<MM>/<DD>[T<hh>:<mm>:<ss>]
The last pattern is the most preferred one, since it reflects a common use in US.
Formal Description
Within context of: | DOC-REVISION
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.20. DATE-1

Description
<DATE-1> is used to capture a time stamp. It must match to one of the following syntaxes:
<YYYY>-<MM>-<DD>[T<hh>:<mm>:<ss>]

<YYYY>.<MM>.<DD>[T<hh>:<mm>:<ss>]

<YYYY>/<MM>/<DD>[T<hh>:<mm>:<ss>]
The last pattern is the most preferred one, since it reflects a common use in US.
Formal Description
Within context of: | STD, XDOC
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.21. DEPARTMENT

Description
<DEPARTMENT> is used to save the department of the team-member.
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.22. DESC

Description
<DESC> represents a general but brief description(1 to 20 lines) of the object in question.
Formal Description
Within context of: | ABLOCK, SDG-CAPTION
Is context for: | Text, TT, BR, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, STD, XDOC, XFILE, MSR-QUERY-TEXT
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.23. DOC-LABEL

Description
Use <DOC-LABEL> to define an identification title or document number of the <CATALOG> instance.
Formal Description
Within context of: | COMPANY-DOC-INFO
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.24. DOC-REVISION

Description
<DOC-REVISION> can be used to save information according to the document version.
Formal Description
Within context of: | DOC-REVISIONS
Is context for: | COMPANY-REVISION-INFOS, REVISION-LABEL, REVISION-LABEL-P1, REVISION-LABEL-P2, STATE, ISSUED-BY, TEAM-MEMBER-REF, DATE, MODIFICATIONS
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.25. DOC-REVISIONS

Description
<DOC-REVISIONS> is a container to get the entire change-history. Although the sequence of changes can be determined by sorting <DOC-REVISIONS> according to <DOC-REVISION>/<DATE>, it is recommended to put the most recent <DOC-REVISION> as the first child of <DOC-REVISIONS>.
Formal Description
Within context of: | ADMIN-DATA
Is context for: | DOC-REVISION
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.26. DOMAIN

Description
A <DOMAIN> is an additional separator in order to make ablocks unique. This is useful, if one catalog carries elements from different systems, where the name (name+version+revision) is not unique in the catalog.
Formal Description
Within context of: | ABLOCK
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.27. E

Description
Emphasis can be used to mark text to be bold, italic, bolditalic, and plain. This is controlled with the attribute [TYPE]. The color can be changed with the attribute [COLOR].
Formal Description
Within context of: | CHANGE, DESC, FT, LABEL, LONG-NAME, LONG-NAME-1, MSR-QUERY-RESULT-TEXT, P, REASON, VERBATIM
Is context for: | Text
Name
Type
Values / Default
Notes
[TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • BOLD
  • ITALIC
  • BOLDITALIC
  • PLAIN
Type of emphasis
[COLOR]
optional
String (CDATA)
Color of emphasis
[FONT]
optional
Value selection (NAMEDTOKENGROUP)
  • MONO
  • DEFAULT
Attribute
[S]
optional
String (CDATA)
Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI]
optional
String (CDATA)
Description of the semantic meaning of an element.
[T]
optional
String (CDATA)
Time Stamp Entry
[VIEW]
optional
String (CDATA)
Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.28. EMAIL

Description
<EMAIL> is used to save the email address of the team member.
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.29. FAX

Description
<FAX> is used to save the fax number of the team member.
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.30. FILE

Description
This points to the contents of the object represented as a physical file. The file is identified by the contents of <file>. It can be interpreted as simple file relative to the position of the catalog itself. It can also be interpreted as a universal ressource identifier.
If more than one <file> is there, all mentioned files belong to the ablock.
Formal Description
Within context of: | ABLOCK
Is context for: | Text
Name | Type | Notes
[CREATION-DATE] optional | String (CDATA) | This denotes the date the described file was created.
[CREATOR] optional | String (CDATA) | This denotes the tool which created the described file.
[L] optional | String (CDATA) | This denotes the language of the data in the described file.
[MIME-TYPE] optional | String (CDATA) | This denotes the MIME Type of the described file.
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[TYPE] optional | String (CDATA) | This denotes the type of the file. The values must be agreed upon the involved participants.
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.31. FORMATTER-CTRL

Description
Use FORMATTER-CTRL to give in document specific formatter configuration parameters. The value of the parameters is located in the content of FORMATTER-CTRL. The name of the parameter is located in the
[SI] attribute. The processing system which has to interpret the parameter can be defined in the attribute [TARGET-SYSTEM].
Formal Description
Within context of: | FORMATTER-CTRLS
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element. In this context the name of the formatter parameter.
[T] optional | String (CDATA) | Time Stamp Entry
[TARGET-SYSTEM] optional | String (CDATA) | Name of the formatter system.
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.32. FORMATTER-CTRLS

Description
Wrapper element for one or more FORMATTER-CTRL elements.
Formal Description
Within context of: | ADMIN-DATA
Is context for: | FORMATTER-CTRL
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.33. FT

Description
Use <FT> to make footnotes. Footnotes might be displayed inline within the container paragraph in XML editors. However they are printed on the bottom of the page by paper formatters. In online formats like HTML they might be displayed as sub windows .
Formal Description
Within context of: | CHANGE, DESC, MSR-QUERY-RESULT-TEXT, P, REASON
Is context for: | Text, TT, E
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.34. HOMEPAGE

Description
<HOMEPAGE> is used to save the URL of a company.
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.35. IE

Description
USE IE to define an index entry. The content of IE is not printed inline because of conjugation problem. That's why these terms have to been written twice in the text.
Formal Description
Within context of: | CHANGE, DESC, LABEL, LONG-NAME, LONG-NAME-1, MSR-QUERY-RESULT-TEXT, P, REASON
Is context for: | Text, SUP, SUB
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[TYPE] optional | String (CDATA) | Use this attribute to define an index type. This attribute isn't supported by all formatters.
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.36. ISSUED-BY

Description
Use ISSUED-BY to describe the person who has published the doc-revision in question. As an alternative the person can be defined by <TEAM-MEMBER-REF> if the person is described as an <TEAM-MEMBER> in <COMPANIES>.
Formal Description
Within context of: | DOC-REVISION
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.37. LABEL

Description
Use this element to give in a describing label of an object.
Formal Description
Within context of: | MATCHING-DCI
Is context for: | Text, TT, E, SUP, SUB, IE
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.38. LANGUAGE

Description
<LANGUAGE> represents the human language used within the file. It is mainly used to cause the tools to switch to an appropriate language.
This element follows ISO 639-1 two letter language codes ( Codes for the Representation of Names of Languages ). Mostly used codes are given in Most common language codes (alphabetical):
Most common language codes (alphabetical)
Code | Language
de | German
en | English
es | Spanish
fr | French
it | Italian
jp | Japanese
Formal Description
Within context of: | ADMIN-DATA
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.39. LONG-NAME

Description
<LONG-NAME> is used to describe the elements.
Formal Description
Within context of: | ABLOCK, COMPANY, SDG-CAPTION, TEAM-MEMBER
Is context for: | Text, TT, E, SUP, SUB, IE
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.40. LONG-NAME-1

Description
<LONG-NAME-1> is used to describe the elements.
Formal Description
Within context of: | STD, XDOC, XFILE, XREF-TARGET
Is context for: | Text, TT, E, SUP, SUB, IE
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.41. MATCHING-DCI

Description
<MATCHING-DCI> represents a reference to a DCI instance (Document Control Instance) tho which the current file is supposed to match to. The official identification of the DCI is denoted by <URL> which points to the DCI file. The other elements are provided for informational purposes.
Formal Description
Within context of: | MATCHING-DCIS
Is context for: | LABEL, SHORT-LABEL, URL, REMARK
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.42. MATCHING-DCIS

Description
<MATCHING-DCIS> represents all Document Content Information specifications the current file is supposed to be compliant to. As there may be multiple DCI instances, the current file is supposed to match to all of them. Nevertheless the check is only requested according to the current use case.
Formal Description
Within context of: | CATALOG
Is context for: | MATCHING-DCI
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.43. MODIFICATION

Description
<MODIFICATION> can be used to save a change in a document.
Formal Description
Within context of: | MODIFICATIONS
Is context for: | CHANGE, REASON
Name
Type
Values / Default
Notes
[TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • CONTENT-RELATED
  • DOC-RELATED
Classification of the modification. The following values are allowed:
DOC-RELATED - document specific changes, like spelling mistakes. CONTENT-RELATED - product specific changes or changes of the semantic meaning.
[S]
optional
String (CDATA)
Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI]
optional
String (CDATA)
Description of the semantic meaning of an element.
[T]
optional
String (CDATA)
Time Stamp Entry
[VIEW]
optional
String (CDATA)
Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.44. MODIFICATIONS

Description
<MODIFICATIONS> is the wrapper element of <MODIFICATION>. <MODIFICATION>s can be used to make a summary of changes between the current and the latest document version.
Formal Description
Within context of: | DOC-REVISION
Is context for: | MODIFICATION
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.45. MSR-QUERY-ARG

Description
Use this element to define an argument for a msr query. The value of the argument is located in the content of the element. The name of the argument can be written in the [SI] attribute.
Formal Description
Within context of: | MSR-QUERY-PROPS
Is context for: | Text, XREF
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element. In this context [SI] contains the name of the <MSR-QUERY-ARG>.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.46. MSR-QUERY-NAME

Description
MSR-QUERY-NAME contains the name of an MSR-Query. MSR-Query processors have to interpret this name and map it to the corresponding procedure during the execution of the query.
Formal Description
Within context of: | MSR-QUERY-PROPS
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.47. MSR-QUERY-PROPS

Description
This element contains all properties which are necessary for the execution of an MSR-Query.
Formal Description
Within context of: | MSR-QUERY-TEXT
Is context for: | MSR-QUERY-NAME, MSR-QUERY-ARG, COMMENT
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.48. MSR-QUERY-RESULT-TEXT

Description
This element contains the generated result of an MSR-Query. If the query has been executed the query-processor writes the result in this element by replacing all existing contents.
Formal Description
Within context of: | MSR-QUERY-TEXT
Is context for: | Text, TT, BR, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, STD, XDOC, XFILE, MSR-QUERY-TEXT
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.49. MSR-QUERY-TEXT

Description
MSR-QUERY-TEXT defines an MSR-Query. That is the content of <MSR-QUERY-RESULT-TEXT> is generated by a query which is specified by the properties in <MSR-QUERY-PROPS>.
Formal Description
Within context of: | CHANGE, DESC, MSR-QUERY-RESULT-TEXT, P, REASON
Is context for: | MSR-QUERY-PROPS, MSR-QUERY-RESULT-TEXT
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.50. NOTATION

Description
Use <NOTATION> to describe the notation/format of an external file.
As an example the following notations can be used:
  • BMP
  • CGMBIN
  • EPS
  • GIF
  • HTNL
  • JPEG
  • PCX
  • PDF
  • PS
  • SGML
  • TEX
  • TIFF
  • WMF
Formal Description
Within context of: | XFILE
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.51. NUMBER

Description
This element can be used to describe a publishing number of an external document, e.g. an ISBN number.
Formal Description
Within context of: | XDOC
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.52. OWNER

Description
This specifies the legal owner of the object. This is used to prevent the information to be used in illegal contexts. As an example, if the function specification was provided by a particular company, it must not be used in the context of another company.
Formal Description
Within context of: | ABLOCK
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.53. P

Description
Use <P> to define a paragraph in a text.
Formal Description
Within context of: | REMARK
Is context for: | Text, TT, BR, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, STD, XDOC, XFILE, MSR-QUERY-TEXT
Name
Type
Values / Default
Notes
[HELP-ENTRY]
optional
String (CDATA)
This attribute can be used to define an label for a help system. Formatters who generate help formats can use this label as a name for a navigation target.
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
The value keep shall keep this paragraph together with the predecessor block element(<P>)
[S]
optional
String (CDATA)
Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI]
optional
String (CDATA)
Description of the semantic meaning of an element.
[T]
optional
String (CDATA)
Time Stamp Entry
[VIEW]
optional
String (CDATA)
Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.54. PHONE

Description
<PHONE> is used to save the phone number of the team member.
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.55. POSITION

Description
Use POSITION to define a position within an external document or an standard.
Formal Description
Within context of: | STD, XDOC
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.56. PUBLISHER

Description
Use PUBLISHER to describe the publisher of an external document.
Formal Description
Within context of: | XDOC
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.57. REASON

Description
<REASON> is used to give reasons for the changes in the current document.
Formal Description
Within context of: | MODIFICATION
Is context for: | Text, TT, XREF, XREF-TARGET, E, FT, SUP, SUB, IE, MSR-QUERY-TEXT
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.58. REMARK

Description
<REMARK> is used to give a comment e.g. for the particular calibration state. There are two options:
  • Use <P> to allow the processing systems to perform a word wrapping.
  • Use <VERBATIM> if whitespace is siginifcant.
Formal Description
Within context of: | MATCHING-DCI
Is context for: | P, VERBATIM
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.59. REVISION-LABEL

Description
Use <REVISION-LABEL> to give an revision number of a document or document fragment.
Formal Description
Within context of: | COMPANY-REVISION-INFO, DOC-REVISION
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.60. REVISION-LABEL-P1

Description
Use <REVISION-LABEL-P1> to give a first alternative revision number of a document or document fragment.
Formal Description
Within context of: | COMPANY-REVISION-INFO, DOC-REVISION
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.61. REVISION-LABEL-P2

Description
Use <REVISION-LABEL-P12> to give a second alternative revision number of a document or document fragment.
Formal Description
Within context of: | COMPANY-REVISION-INFO, DOC-REVISION
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.62. ROLE

Description
<ROLE> denotes one particular role taken by the team member in question within the current project. Roles are such as "Author", "Calibration engineer", "Supporter", "Quality assurance".
Formal Description
Within context of: | ROLES
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.63. ROLES

Description
<ROLES> is a wrapper containing all roles one particular team member takes within the project.
Formal Description
Within context of: | COMPANY, TEAM-MEMBER
Is context for: | ROLE
Name | Type | Values / Default | Notes
[S] optional | String (CDATA) |  | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[T] optional | String (CDATA) |  | Time Stamp Entry
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.
[F-CHILD-TYPE] fixed value | String (CDATA) | ROLE:SELECTION | Fixed Child Type. Warning: This attribute is only in the DTD for compatibility with older versions of the DTD and should not be used for any new implementations. It might be removed in future versions of the DTD. This attribute contains the information which child elements of the element carrying this attribute should be checked by an semantic checker.


4.64. SD

Description
The special data element <SD> can be used to define additional terminal elements which are not included in the schema. The element can be a normal text field or an link. The name of the additional element can be given in the attribute <GID>. If the element shall be an link the attributes [ID-CLASS] and [ID-REF] can be used.
Formal Description
Within context of: | SDG
Is context for: | Text
Name | Type | Notes
[GID] required | String (CDATA) | This attribute contains the generic identifier of the <SD> element.
[ID-CLASS] optional | SGML string (NMTOKEN) | This attribute contains the value of the [ID-CLASS] or [F-ID-CLASS] attribute of the link target referenced by the ID contained in [ID-REF].
[ID-REF] optional | ID reference (IDREF) | This attribute contains an existing ID which can be used to identify the related link target by its [ID] attribute.
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.65. SDG

Description
<SDG> (Special Data Group) is a backdoor to transmit not interpreted structured data, which is contained in the "terminal" element <SD>. It is also very dangerous, because it may compromise the objective of standardized data exchange. It could be the case that data must be transmitted which is originally not supported in one of the DTDs. In order to avoid other file formats, the MSR-DTDs should be able to take such data.
<SDG> defines an group element which contains other element groups or <SD> terminal elements.
Links to other elements in the instance are also possible via <SD>. If the <SDG> shall be a link target it must contain a <SDG-CAPTION> element which has an [ID] and <LONG-NAME> and/or <SHORT-NAME>.
Formal Description
Within context of: | SDG, SDGS
Is context for: | SDG-CAPTION, SD, SDG
Name | Type | Notes
[GID] required | String (CDATA) | This attribute contains the generic identifier of the <SDG> element.
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.66. SDG-CAPTION

Description
This allows to assign an [ID], a <SHORT-NAME>, a <LONG-NAME> as well as <DESC> to a special data group <SDG>.
Formal Description
Within context of: | SDG
Is context for: | LONG-NAME, SHORT-NAME, DESC
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | This is a unique identifier of the object in the catalog. This must be used to refer to a particular version, if more than one version of the object is mentioned in the catalog.
[S] optional | String (CDATA) |  | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[T] optional | String (CDATA) |  | Time Stamp Entry
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | SDG | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF ID-REF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


4.67. SDGS

Description
Special data groups. SDGS groups one or more SDGs. SDG can be used to define free hierarchical structures to exchange data which is not modeled in the schema.
Formal Description
Within context of: | ABLOCK, COMPANY-DOC-INFO
Is context for: | SDG
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.68. SHORT-LABEL

Description
Use SHORT-LABEL to give in an identification label of an object.
Formal Description
Within context of: | MATCHING-DCI
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.69. SHORT-NAME

Description
<SHORT-NAME> is a label or name of the context element in order to identify this object. Leading and trailing whitespace shall have no meaning and must be ignored during the interpretation of the <SHORT-NAME>.
Formal Description
Within context of: | ABLOCK, CATALOG, COMPANY, SDG-CAPTION, STD, TEAM-MEMBER, XDOC, XFILE, XREF-TARGET
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.70. STATE

Description
<STATE> represents the current state of the current file according to the workflow, process or configuration management plan.
Formal Description
Within context of: | COMPANY-REVISION-INFO, DOC-REVISION
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.71. STATE-1

Description
<STATE-1> represents the current state of the current file according to the workflow, process or configuration management plan. This element has the same meaning as <STATE> (see 4.70. STATE ) except that it is not multilingual in the in the multilingual configuration of the DTD.
Formal Description
Within context of: | STD, XDOC
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.72. STD
See Also Description Example Formal Description

Description
Use <STD> to describe a standard within a paragraph.
Example
You can describe a standard like the [Code for the representation of names of languages;ISO 639-1:2002;Alpha-2 code;60.60;2002-07-18;http://www.iso.ch/iso/en/CatalogueDetailPage.CatalogueDetail?CSNUMBER=22109;Part 1;] in the following way:
<STD ID="ID19643804826275">
   <LONG-NAME-1>Code for the representation of names of languages</LONG-NAME-1>
   <SHORT-NAME>ISO 639-1:2002</SHORT-NAME>
   <SUBTITLE>Alpha-2 code</SUBTITLE>
   <STATE-1>60.60</STATE-1>
   <DATE-1>2002-07-18</DATE-1>
   <URL>http://www.iso.ch/iso/en/CatalogueDetailPage.CatalogueDetail?CSNUMBER=22109</URL>
   <POSITION>Part 1</POSITION>
</STD>
Formal Description
Within context of: | CHANGE, DESC, MSR-QUERY-RESULT-TEXT, P
Is context for: | LONG-NAME-1, SHORT-NAME, SUBTITLE, STATE-1, DATE-1, URL, POSITION
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | This is a unique identifier of the object in the catalog. This must be used to refer to a particular version, if more than one version of the object is mentioned in the catalog.
[S] optional | String (CDATA) |  | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[T] optional | String (CDATA) |  | Time Stamp Entry
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | STD | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF ID-REF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


4.73. SUB

Description
Use <SUB> to subscript a text.
E.g. to describe the following texts: log10, Jv = 1000 cd
Formal Description
Within context of: | CHANGE, DESC, IE, LABEL, LONG-NAME, LONG-NAME-1, MSR-QUERY-RESULT-TEXT, P, REASON
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.74. SUBTITLE

Description
This element describes a subtitle of an standard. See also 4.72. STD
Formal Description
Within context of: | STD
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.75. SUP

Description
Use <SUP> to superscript a text.
E.g. to describe the following texts: ax2+ b, Sumcurrent= 23 A
Formal Description
Within context of: | CHANGE, DESC, IE, LABEL, LONG-NAME, LONG-NAME-1, MSR-QUERY-RESULT-TEXT, P, REASON
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.76. TEAM-MEMBER

Description
Use <TEAM-MEMBER> to denote the persons which are involved in the production of the document or document part.
Formal Description
Within context of: | TEAM-MEMBERS
Is context for: | LONG-NAME, SHORT-NAME, ROLES, DEPARTMENT, ADDRESS, ZIP, CITY, PHONE, FAX, EMAIL, HOMEPAGE
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | This is a unique identifier of the object in the catalog. This must be used to refer to a particular version, if more than one version of the object is mentioned in the catalog.
[S] optional | String (CDATA) |  | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[T] optional | String (CDATA) |  | Time Stamp Entry
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | TEAM-MEMBER | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF ID-REF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


4.77. TEAM-MEMBER-REF

Description
<TEAM-MEMBER-REF> is the pointer to one particular team member. The content is the <SHORT-NAME> of the corresponding <TEAM-MEMBER>.
Formal Description
Within context of: | COMPANY-DOC-INFO, DOC-REVISION
Is context for: | Text
Name | Type | Values / Default | Notes
[ID-REF] optional | ID reference (IDREF) |  | This attribute contains an existing ID which can be used to identify the related link target by its [ID] attribute.
[S] optional | String (CDATA) |  | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[T] optional | String (CDATA) |  | Time Stamp Entry
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | TEAM-MEMBER | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF ID-REF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[HYNAMES] fixed value | SGML strings (NMTOKENS) | LINKEND ID-REF | HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversion.
[HYTIME] fixed value | SGML string (NMTOKEN) | CLINK | HYTIME is the standard attribute to define a HYTIME architectural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversals.


4.78. TEAM-MEMBERS

Description
<TEAM-MEMBERS> is the grouping element of all <TEAM-MEMBER> elements. Insert this element if you want to describe a <TEAM-MEMBER>. See also 4.76. TEAM-MEMBER
Formal Description
Within context of: | COMPANY
Is context for: | TEAM-MEMBER
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.79. TOOL

Description
TOOL describes the processing tool for an external file defined by <XFILE>
Formal Description
Within context of: | XFILE
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.80. TOOL-VERSION

Description
TOOL-VERSION describes the version of a processing tool(defined by <TOOL>) for an external file(<XFILE>).
Formal Description
Within context of: | XFILE
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.81. TT

Description
Technical Term. This element can be used to mark a term as a technical term. The attributes [TYPE] or [USER-DEFINED-TYPE](only if [TYPE="OTHER"]) describe the type of technical term. Technical terms can be used to produce classified indexes of technical terms, e.g. index of all mentioned tools.
Formal Description
Within context of: | CHANGE, DESC, FT, LABEL, LONG-NAME, LONG-NAME-1, MSR-QUERY-RESULT-TEXT, P, REASON
Is context for: | Text
Name
Type
Values / Default
Notes
[TYPE]
required
Value selection (NAMEDTOKENGROUP)
  • SGMLTAG
  • SGML-ATTRIBUTE
  • TOOL
  • PRODUCT
  • VARIABLE
  • STATE
  • PRM
  • MATERIAL
  • CONTROL-ELEMENT
  • CODE
  • ORGANISATION
  • OTHER
The attribute associates an type to an technical term.
If the type is "OTHER" the attribute [USER-DEFINED-TYPE] associates the type to the technical term.
[S]
optional
String (CDATA)
Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI]
optional
String (CDATA)
Description of the semantic meaning of an element.
[T]
optional
String (CDATA)
Time Stamp Entry
[USER-DEFINED-TYPE]
optional
String (CDATA)
The attribute associates an type to an technical term if type attribute is set to [TYPE="OTHER"] .
[VIEW]
optional
String (CDATA)
Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.82. URL

Description
Use <URL> to define URL's, URI's and URN's web addresses.
Formal Description
Within context of: | MATCHING-DCI, STD, XDOC, XFILE
Is context for: | Text
Name | Type | Notes
[MIME-TYPE] optional | String (CDATA) | Attribute
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.83. USABLE-FOR-VARIANT

Description
This specifies the possible values of the variant criterion denoted by [NAME] the object in question can be applied to.
Formal Description
Within context of: | USABLE-FOR-VARIANTS
Is context for: | V
Name | Type | Notes
[NAME] optional | String (CDATA) | This is the name of the variant characteristic in question.
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.84. USABLE-FOR-VARIANTS

Description
This denotes all the variants, the object in question can be used for.
Formal Description
Within context of: | ABLOCK
Is context for: | USABLE-FOR-VARIANT
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.85. USED-LANGUAGES

Description
Use <USED-LANGUAGES> to define all additional languages which are used within a document or within a part of the document.
Formal Description
Within context of: | ADMIN-DATA
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.86. V

Description
Use <V> to denote a single value of the element which contains <V>.
Formal Description
Within context of: | USABLE-FOR-VARIANT
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.87. VERBATIM

Description
<VERBATIM> is a paragraph in which white-space (in particular blanks and line feeds) is obeyed. This enables basic preformatting to be carried out, which can even be displayed on simple devices. Behavior is the same as PRE in HTML.
Formal Description
Within context of: | REMARK
Is context for: | Text, E, XREF, BR
Name
Type
Values / Default
Notes
[ALLOW-BREAK]
has default value
SGML string (NMTOKEN)
1
Checks whether page breaks may be included in a <VERBATIM>. NO-ALLOW-BREAK or "0" means that the user is responsible for confining the layout to a page.
[FLOAT]
optional
Value selection (NAMEDTOKENGROUP)
  • FLOAT
  • NO-FLOAT
Permits a check, in the case of a <VERBATIM> that cannot be broken up, to determine whether the <VERBATIM> can be shifted elsewhere, so that the page can be used to a greater advantage (compare to flat at TeX).
[HELP-ENTRY]
optional
String (CDATA)
A label which can be used to navigate to the representation of the element defining the [HELP-ENTRY="help-entry-content"] in a help system. E.g. for Mircrosofts HTML-Help transformations should produce an anchor like <A NAME="help-entry-content">.
[KEEP-WITH-PREVIOUS]
optional
Value selection (NAMEDTOKENGROUP)
  • KEEP
  • NO-KEEP
This makes it compulsory for the current element to be formatted on the same page as the previous element, during page formatting (KEEP). If the value is NO-KEEP, the positioning of the element on the next page relates to the position of the previous element.
[PGWIDE]
optional
Value selection (NAMEDTOKENGROUP)
  • PGWIDE
  • NO-PGWIDE
PGWIDE: enables the contents of the current element to be formatted using the entire width of the page. This for example, is beneficial in the case of code containing more than 80 characters per line.
[S]
optional
String (CDATA)
Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI]
optional
String (CDATA)
Description of the semantic meaning of an element.
[T]
optional
String (CDATA)
Time Stamp Entry
[VIEW]
optional
String (CDATA)
Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


4.88. XDOC

Description
Use <XDOC> to mention a document which is no <STANDARD>. These documents might be books, magazine articles, newspapers or documents in document management systems.
Formal Description
Within context of: | CHANGE, DESC, MSR-QUERY-RESULT-TEXT, P
Is context for: | LONG-NAME-1, SHORT-NAME, NUMBER, STATE-1, DATE-1, PUBLISHER, URL, POSITION
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | This is a unique identifier of the object in the catalog. This must be used to refer to a particular version, if more than one version of the object is mentioned in the catalog.
[S] optional | String (CDATA) |  | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[T] optional | String (CDATA) |  | Time Stamp Entry
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | XDOC | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF ID-REF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


4.89. XFILE

Description
Use <XFILE> to mention a file which is no external file(<XDOC>) and no standard(<STD>). E.g. CAD-files, Matlab-files etc.
Formal Description
Within context of: | CHANGE, DESC, MSR-QUERY-RESULT-TEXT, P
Is context for: | LONG-NAME-1, SHORT-NAME, URL, NOTATION, TOOL, TOOL-VERSION
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | This is a unique identifier of the object in the catalog. This must be used to refer to a particular version, if more than one version of the object is mentioned in the catalog.
[S] optional | String (CDATA) |  | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[T] optional | String (CDATA) |  | Time Stamp Entry
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | XFILE | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF ID-REF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


4.90. XREF

Description
Use <XREF> to define a cross reference. The link is established by valid values in the [ID-REF] and [ID-CLASS] attributes. Usually <XREF> has no content. However <XREF> can contain an MSR natural link [image] in some usecases.
Formal Description
Within context of: | CHANGE, DESC, MSR-QUERY-ARG, MSR-QUERY-RESULT-TEXT, P, REASON, VERBATIM
Is context for: | Text
Name
Type
Values / Default
Notes
[ID-CLASS]
required
SGML string (NMTOKEN)
ID Class. XREF can link to all classes of elements. The value of this attribute classifies to which class of link targets the link points to. This expresses the semantic constraint that a link can only link to an object of the given class. E.g. a link: <XREF ID-REF="ID1" F-ID-CLASS="TEAM-MEMBER">...</XREF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.
[SHOW-CONTENT]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-CONTENT
  • NO-SHOW-CONTENT
If set a formatter should print the content of the <XREF> element.
[SHOW-RESOURCE-LONG-NAME]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-LONG-NAME
  • NO-SHOW-LONG-NAME
If set a formatter should print the content of the target objects <LONG-NAME>.
[SHOW-RESOURCE-NUMBER]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-NUMBER
  • NO-SHOW-NUMBER
If set a formatter should print the the target objects number, e.g. chapter or figure numbers
[SHOW-RESOURCE-PAGE]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-PAGE
  • NO-SHOW-PAGE
If set a formatter should print the the target objects page number. This can only be interpreted by an paper formatter.
[SHOW-RESOURCE-SHORT-NAME]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-SHORT-NAME
  • NO-SHOW-SHORT-NAME
If set a formatter should print the content of the target objects <SHORT-NAME>.
[SHOW-RESOURCE-TYPE]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-TYPE
  • NO-SHOW-TYPE
If set a formatter should print the objects [F-ID-CLASS] string before the link.
[SHOW-SEE]
has default value
Value selection (NAMEDTOKENGROUP)
  • SHOW-SEE
  • NO-SHOW-SEE
If set a formatter should print the word "see" before the link.
[EXT-ID-CLASS]
optional
String (CDATA)
This attribute contains the [ID-CLASS] of the external object if [ID-CLASS="EXTERNAL"]. That is the link points to a <NAMELOC F-ID-CLASS="EXTERNAL">. .
[ID-REF]
optional
ID reference (IDREF)
This attribute contains an existing ID which can be used to identify the related link target by its [ID] attribute.
[S]
optional
String (CDATA)
Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI]
optional
String (CDATA)
Description of the semantic meaning of an element.
[T]
optional
String (CDATA)
Time Stamp Entry
[VIEW]
optional
String (CDATA)
Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.
[HYNAMES]
fixed value
SGML strings (NMTOKENS)
LINKEND ID-REF
HYNAMES is a mapping functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language) The names of the locator attributes e.g. ID-REF used to address the target of a hyperlink can be mapped to names defined in the HYTIME standard, that is LINKEND. This enables to use a generic architectural form processor for link processing and traversals.
[HYTIME]
fixed value
SGML string (NMTOKEN)
CLINK
HYTIME is the standard attribute to define a HYTIME architectural form. This functionality defined in ISO 10744 HYTIME (Hypermedia/Time-based Structuring Language). This enables to use a generic architectural form processor for link processing and traversals.

Natural links are made of an sequence of hierarchical object short-names which are able to address the target object . E.g. the address "system1/variable1" points to an <SW-VARIABLE> with the <SHORT-NAME> "variable1" within an <SW-SYSTEM> with <SHORT-NAME> "system1" if this address occurs in an MSRSW instance


4.91. XREF-TARGET

Description
Use <XREF-TARGET> to define an free destination anchor. Link to such an anchor with <XREF>
Formal Description
Within context of: | CHANGE, DESC, MSR-QUERY-RESULT-TEXT, P, REASON
Is context for: | LONG-NAME-1, SHORT-NAME
Name | Type | Values / Default | Notes
[ID] optional | ID (ID) |  | This is a unique identifer of the object in the catalog. This must be used to refer to a particular version, if more than one version of the object is mentioned in the catalog.
[S] optional | String (CDATA) |  | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) |  | Description of the semantic meaning of an element.
[T] optional | String (CDATA) |  | Time Stamp Entry
[VIEW] optional | String (CDATA) |  | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.
[F-ID-CLASS] fixed value | SGML string (NMTOKEN) | XREF-TARGET | Fixed ID Class. The value of this attribute classifies links and link targets. This expresses the semantic constraint that a link can only link to an object of the same class. E.g. a link: <TEAM-MEMBER-REF ID-REF="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER-REF> can only link to an object which is classified as "TEAM-MEMBER" like: <TEAM-MEMBER ID="ID1" F-ID-CLASS="TEAM-MEMBER">...</TEAM-MEMBER>.


4.92. ZIP

Description
Use <ZIP> to define a zip code.
Formal Description
Within context of: | TEAM-MEMBER
Is context for: | Text
Name | Type | Notes
[S] optional | String (CDATA) | Signature. Used to store the calculated signature a of an element (e.g. CRC).
[SI] optional | String (CDATA) | Description of the semantic meaning of an element.
[T] optional | String (CDATA) | Time Stamp Entry
[VIEW] optional | String (CDATA) | Any term used for a realization of a view-mechanism. With it text elements could be included or excluded in view of an editor or a processing engine.


Technical Terms

CC V2.2.0
Technical Terms


A-Links

ABLOCK | 4.1.
ADDRESS | 4.2.
ADMIN-DATA | 4.3.
AREF | 4.4.
AREF-MOVED | 4.5.
BR | 4.6.
CATALOG | 4.7.
CATEGORY | 4.8.
CHANGE | 4.9.
CITY | 4.10.
COMMENT | 4.11.
COMPANIES | 4.12.
COMPANY | 4.13.
COMPANY-DOC-INFO | 4.14.
COMPANY-DOC-INFOS | 4.15.
COMPANY-REF | 4.16.
COMPANY-REVISION-INFO | 4.17.
COMPANY-REVISION-INFOS | 4.18.
DATE | 4.19.
DATE-1 | 4.20.
DEPARTMENT | 4.21.
DESC | 4.22.
DOC-LABEL | 4.23.
DOC-REVISION | 4.24.
DOC-REVISIONS | 4.25.
DOMAIN | 4.26.
E | 4.27.
EMAIL | 4.28.
FAX | 4.29.
FILE | 4.30.
FORMATTER-CTRL | 4.31. 4.32.
FORMATTER-CTRLS | 4.32.
FT | 4.33.
HOMEPAGE | 4.34.
IE | 4.35.
ISSUED-BY | 4.36.
LABEL | 4.37.
LANGUAGE | 4.38.
LONG-NAME | 4.39.
LONG-NAME-1 | 4.40.
MATCHING-DCI | 4.41.
MATCHING-DCIS | 4.42.
MODIFICATION | 4.43.
MODIFICATIONS | 4.44.
MSR-QUERY-ARG | 4.45.
MSR-QUERY-NAME | 4.46.
MSR-QUERY-PROPS | 4.47.
MSR-QUERY-RESULT-TEXT | 4.48.
MSR-QUERY-TEXT | 4.49.
NOTATION | 4.50.
NUMBER | 4.51.
OWNER | 4.52.
P | 4.53.
PHONE | 4.54.
POSITION | 4.55.
PUBLISHER | 4.56.
REASON | 4.57.
REMARK | 4.58.
REVISION-LABEL | 4.59.
REVISION-LABEL-P1 | 4.60.
REVISION-LABEL-P2 | 4.61.
ROLE | 4.62.
ROLES | 4.63.
SD | 4.64.
SDG | 4.65. 4.67.
SDG-CAPTION | 4.66.
SDGS | 4.67.
SHORT-LABEL | 4.68.
SHORT-NAME | 4.69.
STATE | 4.70.
STATE-1 | 4.71.
STD | 4.72.
SUB | 4.73.
SUBTITLE | 4.74.
SUP | 4.75.
TEAM-MEMBER | 4.76.
TEAM-MEMBER-REF | 4.77.
TEAM-MEMBERS | 4.78.
TOOL | 4.79.
TOOL-VERSION | 4.80.
TT | 4.81.
URL | 4.82.
USABLE-FOR-VARIANT | 4.83.
USABLE-FOR-VARIANTS | 4.84.
USED-LANGUAGES | 4.85.
V | 4.86.
VERBATIM | 4.87.
XDOC | 4.88.
XFILE | 4.89.
XREF | 4.90.
XREF-TARGET | 4.91.
ZIP | 4.92.


Code

CHANGED | 3.1. 4.5.
DELETED | 3.1.
History-overview | 4.7.
ID/IDREF | 2.
MOVED | 3.1.
myfile-01-07.txt | 3.2.
NEW | 3.1.
program-kit | 4.7.
REUSED | 3.1.
Revision-history | 3.2.
tool-kit | 4.7.
UNCHANGED | 3.1. 4.5.
UNDEFINED | 3.1.
UNUSED | 3.1.


Organisations

world wide web consortium | 1.
www.w3c.org | 1.


OTHER

Special Data Group
4.65.


Products

catalog dtd | 1.
DCI | 4.41.
HTML | 4.87.
RDF | 1.
XML |


SGML Attributes

ALLOW-BREAK | 4.87.
CATEGORY | 2. 4.4. 4.5.
COLOR | 4.27.
CREATION-DATE | 4.30.
CREATOR | 4.7. 4.30.
CREATOR-VERSION | 4.7.
DATE | 4.1.
DOMAIN | 2. 4.4. 4.5.
EXT-ID-CLASS | 4.90.
F-CHILD-TYPE | 4.13. 4.63.
F-CM-TOOL-ID | 4.7.
F-DTD-BUILD | 4.7.
F-DTD-VERSION | 4.7.
F-ID-CLASS | 4.1. 4.4. 4.5. 4.13. 4.16. 4.64. 4.66. 4.72. 4.76. 4.77. 4.88. 4.89. 4.90. 4.91.
F-NAMESPACE | 4.13.
F-PUBID | 4.7.
FLOAT | 4.87.
FONT | 4.27.
GID | 4.64. 4.65.
HELP-ENTRY | 4.53. 4.87.
HELP-ENTRY="help-entry-content" | 4.87.
HYNAMES | 4.4. 4.5. 4.16. 4.77. 4.90.
HYTIME | 4.4. 4.5. 4.16. 4.77. 4.90.
ID | 2. 4.1. 4.4. 4.5. 4.13. 4.16. 4.64. 4.65. 4.66. 4.72. 4.76. 4.77. 4.88. 4.89. 4.90. 4.91.
ID-CLASS | 4.64. 4.90.
ID-CLASS="EXTERNAL" | 4.90.
ID-REF | 4.4. 4.5. 4.16. 4.64. 4.77. 4.90.
KEEP-WITH-PREVIOUS | 4.53. 4.87.
L | 4.30.
LABEL | 2. 4.1. 4.4. 4.5.
MIME-TYPE | 4.30. 4.82.
NAME | 4.83.
NEW | 3.1.
PGWIDE | 4.87.
REV | 2. 4.1. 4.4. 4.5.
ROLE | 4.13.
S | 4.1. 4.2. 4.3. 4.4. 4.5. 4.6. 4.7. 4.8. 4.9. 4.10. 4.11. 4.12. 4.13. 4.14. 4.15. 4.16. 4.17. 4.18. 4.19. 4.20. 4.21. 4.22. 4.23. 4.24. 4.25. 4.26. 4.27. 4.28. 4.29. 4.30. 4.31. 4.32. 4.33. 4.34. 4.35. 4.36. 4.37. 4.38. 4.39. 4.40. 4.41. 4.42. 4.43. 4.44. 4.45. 4.46. 4.47. 4.48. 4.49. 4.50. 4.51. 4.52. 4.53. 4.54. 4.55. 4.56. 4.57. 4.58. 4.59. 4.60. 4.61. 4.62. 4.63. 4.64. 4.65. 4.66. 4.67. 4.68. 4.69. 4.70. 4.71. 4.72. 4.73. 4.74. 4.75. 4.76. 4.77. 4.78. 4.79. 4.80. 4.81. 4.82. 4.83. 4.84. 4.85. 4.86. 4.87. 4.88. 4.89. 4.90. 4.91. 4.92.
SHOW-CONTENT | 4.90.
SHOW-RESOURCE-LONG-NAME | 4.90.
SHOW-RESOURCE-NUMBER | 4.90.
SHOW-RESOURCE-PAGE | 4.90.
SHOW-RESOURCE-SHORT-NAME | 4.90.
SHOW-RESOURCE-TYPE | 4.90.
SHOW-SEE | 4.90.
SI | 3.1. 4.1. 4.2. 4.3. 4.4. 4.5. 4.6. 4.7. 4.8. 4.9. 4.10. 4.11. 4.12. 4.13. 4.14. 4.15. 4.16. 4.17. 4.18. 4.19. 4.20. 4.21. 4.22. 4.23. 4.24. 4.25. 4.26. 4.27. 4.28. 4.29. 4.30. 4.31. 4.32. 4.33. 4.34. 4.35. 4.36. 4.37. 4.38. 4.39. 4.40. 4.41. 4.42. 4.43. 4.44. 4.45. 4.46. 4.47. 4.48. 4.49. 4.50. 4.51. 4.52. 4.53. 4.54. 4.55. 4.56. 4.57. 4.58. 4.59. 4.60. 4.61. 4.62. 4.63. 4.64. 4.65. 4.66. 4.67. 4.68. 4.69. 4.70. 4.71. 4.72. 4.73. 4.74. 4.75. 4.76. 4.77. 4.78. 4.79. 4.80. 4.81. 4.82. 4.83. 4.84. 4.85. 4.86. 4.87. 4.88. 4.89. 4.90. 4.91. 4.92.
T | 4.1. 4.2. 4.3. 4.4. 4.5. 4.6. 4.7. 4.8. 4.9. 4.10. 4.11. 4.12. 4.13. 4.14. 4.15. 4.16. 4.17. 4.18. 4.19. 4.20. 4.21. 4.22. 4.23. 4.24. 4.25. 4.26. 4.27. 4.28. 4.29. 4.30. 4.31. 4.32. 4.33. 4.34. 4.35. 4.36. 4.37. 4.38. 4.39. 4.40. 4.41. 4.42. 4.43. 4.44. 4.45. 4.46. 4.47. 4.48. 4.49. 4.50. 4.51. 4.52. 4.53. 4.54. 4.55. 4.56. 4.57. 4.58. 4.59. 4.60. 4.61. 4.62. 4.63. 4.64. 4.65. 4.66. 4.67. 4.68. 4.69. 4.70. 4.71. 4.72. 4.73. 4.74. 4.75. 4.76. 4.77. 4.78. 4.79. 4.80. 4.81. 4.82. 4.83. 4.84. 4.85. 4.86. 4.87. 4.88. 4.89. 4.90. 4.91. 4.92.
TARGET-SYSTEM | 4.31.
TYPE | 4.27. 4.30. 4.35. 4.43. 4.81.
TYPE="OTHER" | 4.81.
UPD | 3.1. 4.1. 4.5.
USER-DEFINED-TYPE | 4.81.
VAR | 2. 4.1. 4.4. 4.5.
VIEW | 4.1. 4.2. 4.3. 4.4. 4.5. 4.6. 4.7. 4.8. 4.9. 4.10. 4.11. 4.12. 4.13. 4.14. 4.15. 4.16. 4.17. 4.18. 4.19. 4.20. 4.21. 4.22. 4.23. 4.24. 4.25. 4.26. 4.27. 4.28. 4.29. 4.30. 4.31. 4.32. 4.33. 4.34. 4.35. 4.36. 4.37. 4.38. 4.39. 4.40. 4.41. 4.42. 4.43. 4.44. 4.45. 4.46. 4.47. 4.48. 4.49. 4.50. 4.51. 4.52. 4.53. 4.54. 4.55. 4.56. 4.57. 4.58. 4.59. 4.60. 4.61. 4.62. 4.63. 4.64. 4.65. 4.66. 4.67. 4.68. 4.69. 4.70. 4.71. 4.72. 4.73. 4.74. 4.75. 4.76. 4.77. 4.78. 4.79. 4.80. 4.81. 4.82. 4.83. 4.84. 4.85. 4.86. 4.87. 4.88. 4.89. 4.90. 4.91. 4.92.


SGML Elements

ABLOCK | 1. 2. 3.1. 3.2. 3.3.4. 4.1. 4.4. 4.5.
ADDRESS | 4.2.
ADMIN-DATA | 2. 3.2. 3.3.3. 4.1. 4.3. 4.12.
AREF | 2. 3.3.4. 4.1. 4.4. 4.5. 4.7.
AREF-MOVED | 4.5.
CATALOG | 2. 4.7. 4.8. 4.23.
CATEGORY | 2. 3.2. 4.4. 4.5. 4.7. 4.8.
CHANGE | 4.9.
CITY | 4.10.
COMMENT | 4.11.
COMPANIES | 2. 4.12. 4.36.
COMPANY | 4.13.
COMPANY-DOC-INFO | 4.1. 4.14.
COMPANY-DOC-INFOS | 4.15.
COMPANY-REF | 4.16.
COMPANY-REVISION-INFO | 4.1. 4.17.
COMPANY-REVISION-INFOS | 4.18.
DATE | 4.19. 4.25.
DATE-1 | 4.20.
DEPARTMENT | 4.21.
DESC | 4.22. 4.66.
DOC-LABEL | 4.23.
DOC-REVISION | 3.2. 4.24. 4.25.
DOC-REVISIONS | 4.25.
DOMAIN | 2. 4.26.
EMAIL | 4.28.
FAX | 4.29.
FILE | 3.1. 3.3.4. 4.1.
FT | 4.33.
GID | 4.64.
HOMEPAGE | 4.34.
LANGUAGE | 4.38.
LONG-NAME | 4.39. 4.65. 4.66. 4.90.
LONG-NAME-1 | 4.40.
MATCHING-DCI | 4.41.
MATCHING-DCIS | 4.42.
MODIFICATION | 4.43. 4.44.
MODIFICATIONS | 4.44.
MSR-QUERY-ARG | 4.45.
MSR-QUERY-PROPS | 4.49.
MSR-QUERY-RESULT-TEXT | 4.49.
NAMELOC F-ID-CLASS="EXTERNAL" | 4.90.
NOTATION | 4.50.
P | 4.53. 4.58.
PHONE | 4.54.
REASON | 4.57.
REMARK | 4.58.
REVISION-LABEL | 3.2. 4.59.
REVISION-LABEL-P1 | 4.60.
REVISION-LABEL-P12 | 4.61.
ROLE | 4.62.
ROLES | 4.63.
SD | 4.64. 4.65.
SDG | 2. 4.1. 4.65. 4.66.
SDG-CAPTION | 4.65.
SHORT-NAME | 2. 4.4. 4.5. 4.65. 4.66. 4.69. 4.77. 4.90.
STANDARD | 4.88.
STATE | 4.70. 4.71.
STATE-1 | 4.71.
STD | 4.72. 4.89.
SUB | 4.73.
SUP | 4.75.
TEAM-MEMBER | 4.36. 4.76. 4.77. 4.78.
TEAM-MEMBER-REF | 4.12. 4.36. 4.77.
TEAM-MEMBERS | 4.78.
TOOL | 4.80.
URL | 4.41. 4.82.
USED-LANGUAGES | 4.85.
V | 4.86.
VERBATIM | 4.58. 4.87.
XDOC | 4.88. 4.89.
XFILE | 4.79. 4.80. 4.89.
XREF | 4.90. 4.91.
XREF-TARGET | 4.91.
ZIP | 4.92.


Untitled

This cannot be determined by comparing catalogs since the full exchange history is necessary which must be kept in the process data management system


Untitled

There is no value "deleted" because versioned data is not deleted in order to track the full history.


Untitled

The reference catalog must be identified by local means and is not defined in the actual catalog.


Untitled

Natural links are made of an sequence of hierarchical object short-names which are able to address the target object . E.g. the address "system1/variable1" points to an <SW-VARIABLE> with the <SHORT-NAME> "variable1" within an <SW-SYSTEM> with <SHORT-NAME> "system1" if this address occurs in an MSRSW instance